SCCM Client installation to only Online machines from All Systems Device collection through Client Push

Hi,
How can we create a device collection based on only online machines , than use that collection to install the sccm client through client push method.
Shailendra Dev

You can run a ping report and then create a collection from only the online machines:
Ping Report Script (Put the machine list in "pclist.txt" in the same folder):
Const ForReading = 1
Set objFSO = CreateObject("Scripting.FileSystemObject")
Set objShell = CreateObject("WScript.Shell")
If not objFSO.FileExists("Pclist.txt") THEN
wscript.echo "File not found,"&_
vbcrlf&"with a hard return at the end of each line."
wscript.quit
end if
tempobj="temp.txt"
Set objTextFile = objFSO.OpenTextFile("Pclist.txt", ForReading)
logfile="results.csv"
Set ofile=objFSO.CreateTextFile(logfile,True)
strText = objTextFile.ReadAll
objTextFile.Close
wscript.echo "Ping starting"
ofile.WriteLine ","&"Ping Report -- Date: " & Now() & vbCrLf
arrComputers = Split(strText, vbCrLF)
for each item in arrcomputers
objShell.Run "cmd /c ping -n 1 -w 1200 " & item & " >temp.txt", 0, True
Set tempfile = objFSO.OpenTextFile(tempobj,ForReading)
Do Until tempfile.AtEndOfStream
temp=tempfile.readall
  striploc = InStr(temp,"[")
        If striploc=0 Then
            strip=""
        Else
            strip=Mid(temp,striploc,16)
            strip=Replace(strip,"[","")
            strip=Replace(strip,"]","")
            strip=Replace(strip,"w"," ")
            strip=Replace(strip," ","")
        End If     
        If InStr(temp, "Reply from") Then
             ofile.writeline item & ","&strip&","&"Online."
        ElseIf InStr(temp, "Request timed out.") Then
             ofile.writeline item &","&strip&","&"No response (Offline)."
        ELSEIf InStr(temp, "try again") Then
             ofile.writeline item & ","&strip&","&"Unknown host (no DNS entry)."
End If
Loop
Next
tempfile.close
objfso.deletefile(tempobj)
ofile.writeline
ofile.writeline ","&"Ping complete "&now()
wscript.echo "completed."
objShell.Run("""C:\Program Files\Microsoft Office\OFFICE11\excel.exe """&logfile)
-RG

Similar Messages

  • 13017 Received TACACS+ packet from unknown Network Device or AAA Client

    I am adding new routers to our Corporate network for a new MPLS network.  I am getting 13017 Received TACACS+ packet from unknown Network Device or AAA Client  errors for these new routers.  They are added to ACS 5.4.0.30 correctly just like all of our other devices.  We have never had real routers on the network before, just switches and access points.  Is there something special I need to set in ACS for these to work and authenticate correctly?  I can only access the currently with built in login locally.
    One of the new router configs
    Current configuration : 2370 bytes
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname T666
    boot-start-marker
    boot-end-marker
    enable secret 5 $1$h7b3$.T2idTKb9H98BQ8Op0MAC/
    aaa new-model
    aaa authentication login default group tacacs+ local
    aaa authentication enable default group tacacs+ enable
    aaa authorization exec default group tacacs+ local if-authenticated
    aaa accounting exec default start-stop group tacacs+
    aaa session-id common
    clock timezone CST -6
    clock summer-time CDT recurring
    ip cef
    ip auth-proxy max-nodata-conns 3
    ip admission max-nodata-conns 3
    voice-card 0
    crypto pki trustpoint TP-self-signed-2699490457
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-2699490457
     revocation-check none
     rsakeypair TP-self-signed-2699490457
    username netadmin privilege 15 secret 5 $1$SIR2$A3MpShVNeAOlTPyLZESr..
    interface FastEthernet0/0
     ip address 10.114.2.1 255.255.255.0
     ip helper-address 10.30.101.4
     duplex auto
     speed auto
    interface FastEthernet0/1
     no ip address
     shutdown
     duplex auto
     speed auto
    interface Serial0/1/0
     ip address X.X.X.X 255.255.255.252
     no fair-queue
     service-module t1 timeslots 1-24
     service-module t1 remote-alarm-enable
     service-module t1 fdl ansi
     no cdp enable
    router bgp 65065
     no synchronization
     bgp log-neighbor-changes
     network 10.114.2.0 mask 255.255.255.0
     neighbor X.X.X.X remote-as 209
     neighbor X.X.X.X default-originate
     default-information originate
     no auto-summary
    ip forward-protocol nd
    ip bgp-community new-format
    ip http server
    ip http authentication aaa
    ip http secure-server
    ip tacacs source-interface FastEthernet0/0
    no logging trap
    tacacs-server host 10.30.101.221 key 7 1429005B5C502225
    tacacs-server host 10.30.101.222 key 7 1429005B5C502225
    tacacs-server directed-request
    control-plane
    banner exec ^CC
    C
    Login OK
    ^C
    banner motd ^CC
    C
    **  UNAUTHORIZED ACCESS TO THIS SYSTEM IS PROHIBITED.  USE OF
    **  THIS SYSTEM CONSTITUES CONSENT TO MONITORING AT ALL TIMES.
    **  RUAN Transport Corporation
    **  Network Services
    **  [email protected]
    **  515.245.2512
    ^C
    line con 0
    line aux 0
    line vty 0 4
     exec-timeout 30 0
     transport input all
    line vty 5 15
     exec-timeout 30 0
    scheduler allocate 20000 1000
    end
    T666#

    AAA Protocol > TACACS+ Authentication Details
    Date :
    September 19, 2014
    Generated on September 19, 2014 10:21:27 AM CDT
    Authentication Details
    Status:
    Failed
    Failure Reason:
    13017 Received TACACS+ packet from unknown Network Device or AAA Client
    Logged At:
    Sep 19, 2014 10:21 AM
    ACS Time:
    Sep 19, 2014 10:21 AM
    ACS Instance:
    acs01
    Authentication Method:
    Authentication Type:
    Privilege Level:
    User
    Username:
    Remote Address:
    Network Device
    Network Device:
    Network Device IP Address:
    10.114.2.1
    Network Device Groups:
    Access Policy
    Access Service:
    Identity Store:
    Selected Shell Profile:
    Active Directory Domain:
    Identity Group:
    Access Service Selection Matched Rule :
    Identity Policy Matched Rule:
    Selected Identity Stores:
    Query Identity Stores:
    Selected Query Identity Stores:
    Group Mapping Policy Matched Rule:
    Authorization Policy Matched Rule:
    Authorization Exception Policy Matched Rule:
    Other
    ACS Session ID:
    Service:
    AV Pairs:
    Response Time:
    Other Attributes:
    ACSVersion=acs-5.3.0.40-B.839 
    ConfigVersionId=359 
    Device Port=59840 
    Protocol=Tacacs
    Authentication Result
    Steps
    Received TACACS+ packet from unknown Network Device or AAA Client
    Additional Details
    DiagnosticsACS Configuration Changes

  • TACACS+ packet from unknown Network Device or AAA Client

    Hi all,
    I can't perform login using the credential set at ACS server, From the log it shown:
    "Failure Reason: 13017 Received TACACS+ packet from unknown Network Device or AAA Client"
    I know there's some changes on TACACS+ part for new catalyst IOS, so i refer the guide and this is my config snipet:
    aaa group server tacacs+ TAC_PLUS
    server name AUTH
    tacacs server AUTH
    address ipv4 10.10.21.251
    key xxxxxx
    aaa authentication login TAC_PLUS group tacacs+ local line
    aaa authorization exec TAC_PLUS group tacacs+ none
    aaa authorization commands 15 default if-authenticated
    aaa accounting update periodic 1
    aaa accounting exec TAC_PLUS start-stop group tacacs+
    aaa accounting network TAC_PLUS start-stop group tacacs+
    aaa accounting connection TAC_PLUS start-stop group tacacs+
    My platform is
    - C6500 running on IOS 12.2 (33) SXJ1
    - ACS 5.2.0.26
    Need guidance on this, thanks
    Noel

    Hello,
    Is the appropriate IOS IP address defined on the Network Devices and AAA Clients for the ACS? If yes, which IP address is reported on the ACS Failure that includes the error "TACACS+ packet from unknown Network Device or AAA Client"? Is the ACS reporting the IP address as unknown when it is already defined appropriately?
    Regards.

  • Logging out of skype from all the devices.

    Hello,
    I just want to know, how do we logg out from skype from all the devices. Recently, my PC failed to work, I gave my PC to a computer engineer. On that PC, I used to loged in on my skype. I've also got my skype logged in on my mobile. So, would be great if I known how do I logg off from my skype from my computer through my mobile?

    You can try the /showplaces and /remotelogout chat commands.
    http://community.skype.com/t5/Windows-desktop-client/Skype-shows-me-online-though-I-am-not-connected...

  • I lost all my playlists trying to download I tunes 8 and becuase It deleted them from all my devices becuase of music match.  I have an Ipod that still has all the playlists can I restore them from that device?

    I lost all my playlists trying to download I tunes 8 and It deleted them from all my devices becuase of music match.  I have an Ipod that still has all the playlists can I restore them from that device?

    Hello!
    Do you have a Mac computer with Time Machine backups?

  • I accidentally deleted a folder of music from iTunes.  I have Match, and now it seems deleted from all my devices.  How can I get it back?

    I accidentally deleted a folder of music from iTunes.  I have Match, and now it seems deleted from all my devices.  How can I get it back?

    Were you in iTunes or the Finder? If you were in iTunes what exactly did you click? You say "a folder" but the only "folders" in iTunes contain Playlists and deleting a playlist will not delete tracks from the iTunes library.
    When you deleted the music were you prompted to delete the tracks from the cloud? If so, did you do so?
    Were you prompted to move the files to the Trash. If so did you do so? If you did have you emptied the Trash?

  • Remove DRM activation from all my devices

    remove DRM activation from all my devices. My ID is ....

    Adobe Live Chat: http://www.adobe.com/support/chat/ivrchat.html,
    or as a slight short cut try http://helpx.adobe.com/contact.html?product=digital-editions&topic=using-my-product-or-ser vice
    Click on 'I still need help' and then you should see 'Chat with an Agent' at the bottom of the page.
    'Ask our experts' will indeed just lead you back to this forum.
    Sometimes you will get ‘Sorry! All agents are busy— please check back soon.’
    Don’t refresh the page, just hang on and it should eventually go to ‘Chat Now, and agent is available’.
    They can reset your authorizations, and then you must reauthorize any devices you still need.
    (Unfortunately, Adobe haven’t got round to an admin website for viewing and editing authorizations.)
    Some of the representatives haven't been properly trained and don't know what to do (and claim there is nothing they can do);
    in that case the only way seems to be to give up that chat and try another session hoping for a properly trained representative.
    If your problem is with another device using Overdrive, Bluefire, Aldiko or similar third party app, it is recommended not to mention that app when on the chat, just mention that you have run out of authorizations  (E_ACT_TOO_MANY_ACTIVATIONS) .  Thanks to AJP_Bear for that tip.

  • Why cannot I delete all messages from all my devices?

    I have 3 Apple devices (personal MBP, work MBP, and iPhone). I run messages on all of them. If I send/receive a message from someone, I receive it on all devices, but I have to delete the message from ALL my devices - deleting it one just doesn't work. It is like Messages works like email with POP instead of email with IMAP. Extremely  frustrating, and I believe that this is working as designed. Why???

    for the   Points
    Neither of us said we liked it.
    Like you I think it is flawed and certainly a misuse of the word Sync.
    8:01 pm      Saturday; January 3, 2015
    ​  iMac 2.5Ghz i5 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

  • I can't connect to the itunes store from my iMac...But can from all other devices?? Any ideas?

    When trying to connect to the itunes store from my imac it says unable to connect to the itunes store at this time...please try again later.  Has been for 2 days now.  I'm able to connect from all other devices, just not our imac.  Any suggestions??

    Hi there Kevdog,
    I would recommend taking a look at the troubleshooting steps found in the article below.
    Can't connect to the iTunes Store
    http://support.apple.com/kb/TS1368
    -Griff W.

  • SCCM Cleint Installation on Windows 10 Machine

    Hi All,
    I was trying to push SCCM Client on a Windows 10 machine & i got this error :-
    it's clear from the log file that the OS version is not supported, but is there any workaround for this ?
    Thanks,
    Pranay.

    Correct, Windows 10 is not officially supported yet. In this case it means that client push does not work, yet, as it checks for a Windows version. A manual client installation, or task sequence deployment does not provide that problem.
    My Blog: http://www.petervanderwoude.nl/
    Follow me on twitter: pvanderwoude

  • Client Settings for Device collections Vs Client Settings for User collections

    I noticed there are "Client Settings" set for each User and Group in SCCM. I want all my "Client Settings" configured by Device Collections not User Collections, what can I do? Can someone explain the difference between those?
    Thanks
    James A+, Network+, MCP

    One is for user settings on a client and the other is for device settings on a client. As you can imagine user settings can only be deployed to user collections and device settings can only be deployed to device collections.
    For more information about the user and device settings see:
    https://technet.microsoft.com/en-us/library/gg682067.aspx?f=255&MSPPError=-2147217396
    My Blog: http://www.petervanderwoude.nl/
    Follow me on twitter: pvanderwoude

  • How do I sync all my icloud accounts onto one, more specifically I'm trying to access all my music from all my devices

    I have multiple Apple devices, Desktops, laptops, iPad, iPhones, etc.  I somehow was able to sync the desktop at my vacation home with iColoud where I stored not only all the music I purchased through iTunes, but my entire CD collection.  I have since bought and paid for iColud service multiple times and have yet been able to successfully sync my iPhone, or other devices, to where I can access my music. I can only accesss it from the one desktop. To make matters worse, I'm pretty sure I have more than one Apple ID so I am trying to consolidate everything into one as well.
    I am not very computer literate. I have always had folks around me (assistants) that did all this for me. I am now basically retired and fending for myself. This stinks and I'm struggling. Can anyone give me "idiot proof" instructions?
    Thank You!!!!

    You cannot merge or consolidate different icloud or itunes accounts into one account.
    All purchases made in itunes are forever associated with the account (i.e. ID) used to purchase them.  If you change the ID tied to the itunes store, then you will not be able to access purchases made on a previous ID.
    You talk about storing your music on icloud - I assume you have purchased an iTunes match subscription.  You should be able to have all devices access that music for download if they each connect to the iTunes account using the same ID.

  • TS4050 I keep losing most of my contacts from all my devices. I enter new ones and the next morning they are gone again on all my devices, iPad Mac and iPhone 4s

    I had 874 contacts yesterday and they were all synchronized with all my other Mac products. This morning only 134 are left on all devices. I entered another 34 more entries into the iCloud contacts and they synchronized with all the devices and this morning they are all gone and back to 134 yet again.
    Anyone any ideas.

    Thank you - I have done this now but resetting and restoring from another device didn't really help. However, syncing via iTunes was a bit more successful as it occurred to me that many of my contacts are in MS Outlook on my PC and I was able to copy them over.  There are still some contacts missing and I am continuing to try and figure out where they originate from to try and get them to show up. 

  • Upload data from legacy system to SAP through ALE IDOC

    Hello All,
    I have a requirement where i need to upload the data from legacy system to SAP. So i am using ALE IDOC.
    In my requirement i need to extend the Standard IDOC. I have extended the IDOC and even found the exit for the updation of the extended fields to SAP. My data would be be placed in the application server.
    Can anybody tell me how to retrieve the data and update in the tables for the extended fields.
    Could you please provide a sample program for retrieving data for IDOC.
    Thanks

    Hi,
    You can find the sample code in the following link.
    Re: calling idoc_input_creditor
    Regards
    Sajid

  • Pulling list of machines under the Customized device Collection

    Hi Guys,
    I have created a customized Device collection - "All Laptops" there are some 300+ laptop machines listed, i can see those machines when i do Right Click --> Show Members
    I need to submit the list of machine to my manager, How can get the list of machines in a Report format or an excel format
    Please assist.
    Cheers,

    Also in the console open up the collection so you see all the computers..
    Hit CTRL+A to select all of them
    Hit CTRL+C to copy
    Open up excel, select cell A1, CTRL+V will put them in Excel.

Maybe you are looking for

  • Importing to itunes (iMac) from Macbook

    Relevant hardware: desktop-iMac G5, PowerPC processor, OS 10.4.2; MacBook, 2GHz Intel processor, OS 10.4.8 Relevant software: Desktop-iTunes 7.0.2, MacBook-iTunes 7.0.2 Issue: Problem transferring music files from MacBook to iMac Description: Trying

  • Import and export CRM catalogue

    Hi, I am neewbie in CRM. I would like to export CRM catalogue, and then import it into other computer. For example, I am in TEST environment... navigate into "COMM_PCAT_ADM" and select "SALES_CATALOGUE". I would like to EXPORT "SALES_CATALOGUE" to ot

  • TDS (TCS) adjstement for Customer

    Hello Experts I have problem in adjusting TDS(TCS) for customer adjustment. At the time of downpayment system is deducted TDS for customer and at the time of Invoice also its getting deducted. Problem is at the time of Clearing DownPayment System is

  • A problem about table?

    I can connect to the oracle server, but I cannot list the tables or views ... Sometimes, I can use 'Select'. thanks.

  • Issue in Report printing

    Xperts, I hv an ALV report program which displays some output. While i am printing it , it prints some fields as blank.. Actual report output mmmmm1 hhhhh1 kkkkk1 mmmmm2 hhhhh2 kkkkk2 mmmmm3 hhhhh3 kkkkk3 Prrinted output mmmmm1 hhhhh1 kkkkk1 mmmmm2 h