Security and shared hosting

I'm writing a servlet that requires Bouncy Castle, and things work great. At least they work great locally. When I upload the servlet to my shared hosting account I'm having some trouble.
On the shared hosting account, I get a SecurtyException when I try to
Provider bcProvider = (Provider)(new org.bouncycastle.jce.provider.BouncyCastleProvider());
Security.addProvider(bcProvider);
Is there any way to get around this problem? I've looked at which providers are available to me, and it seems that it is just the standard Sun ones. Do I need to convince my service provider to also load the Bouncy Castle provider? Is it as simple as just loading it when Tomcat starts? Are there any references that say this is a safe thing to do so that they don't simply tell me they can't do it because of "security issues"?
Sander

Change the permissions to execute only by anyone other than you.

Similar Messages

  • Difficulty syncing and sharing 3G/GPRS connection with NokiaN75 post 10.5.2

    Prior to 10.5.2 (Feb. '08) I was easily able to use isync and share my Nokia's 3G/GPRS connection with the MacBook Pro. Whenever I needed to access the Internet or check my email, I could easily and simply establish the connection with the phone via Bluetooth and use the phone's access to the Internet. While not blazing fast, it was quicker than dial up and worked well when traveling and when you didn't want to pay $12.95 for 24 hour access...
    Since 10.5.2 I believe, I have had difficulty syncing - I get error messages saying that the synchronization failed. I can no longer connect and share the 3G connection, - an error message about PPP...Can anyone suggest a work around or perhaps Apple's engineering can put in a fix in 10.5.3??? Downloading the isync plug in from Nokia had no benefit...Thank you in advance...

    Actually I was answering Paul who does have an iMac but it doesn't matter one way or the other - the same answer applies. Odd that you have the same settings in security and sharing but it doesn't work in one direction. Are you sure you are using the right password? Have you attempted sharing with a different account on that computer?

  • Planning and Shared Services security disconnect.

    Hi,
    We have an intermittent problem. We are running 9.3.1 of Planning, Essbase, and Shared Services, etc. We have 6 planning applications on the same server. We use oracle as the database. The problem is at some point in time Planning stops getting updates made in Shared Services. When it happens you can go into the planning application, view the security on any object, and click "Add Access". The "Users and Groups" select box get's populated with "<None Available>". If you bounce the planning service and come back in the "Users and Groups" is populated as expected. It also dosen't affect all of the application or the same applications.
    We have an admin group that makes security updates. Mainly just adding users to native groups. When things are working the changes/additions flow through to the planning tables. (HSP_USERSINGROUP,HSP_OBJECT). We gave this group a query to run that shows the access a specific user has in planning. If a user is added to a group in SS they then run the query to make sure the access is granted in planning. When the query doesn't bring back the information they think should be there we know we have the issue and start scheduling an outage to bounce planning.
    Anyone else seen this behavior and is there another way to fix this besides bouncing planning?
    Thanks for any responses.
    Keith

    This show multiple apps but you could knock it down.
    select
    user_name,
    group_name,
    mart,
    object_name,
    object_type,
    access_mode,
    flag
    from (
    select
    U.Object_Name as User_Name,
    G.Object_Name as Group_Name,
    'PLAN_APP1' as mart,
    O.Object_Name as Object_Name,
    OT.Type_Name as Object_Type,
    Case AC.Access_Mode
    when 3 then 'ReadWrite'
    when 2 then 'Write'
    when 1 then 'Read'
    when -1 then 'None'
    else 'Unknown'
    end as access_mode,
    Case AC.Flags
    when 0 then 'Member'
    when 5 then 'Children'
    when 6 then 'IChildren'
    when 8 then 'Descendants'
    when 9 then 'IDescendants'
    else 'Unknown'
    end as flag
    from
    HYP_PLAN_APP1.HSP_ACCESS_CONTROL AC,
    HYP_PLAN_APP1.HSP_OBJECT U,
    HYP_PLAN_APP1.HSP_OBJECT O,
    HYP_PLAN_APP1.HSP_OBJECT_TYPE OT,
    HYP_PLAN_APP1.HSP_OBJECT G,
    HYP_PLAN_APP1.HSP_USERSINGROUP UG
    where
    AC.user_id = UG.group_id
    and UG.USER_ID = U.object_id
    and AC.object_id = O.object_id
    and UG.group_id = G.object_id
    and O.object_type = OT.object_type
    and O.object_type <> 7
    union
    select
    U.Object_Name as User_Name,
    '' as Group_Name,
    'PLAN_APP1' as mart,
    O.Object_Name as Object_Name,
    OT.Type_Name as Object_Type,
    Case AC.Access_Mode
    when 3 then 'ReadWrite'
    when 2 then 'Write'
    when 1 then 'Read'
    when -1 then 'None'
    else 'Unknown'
    end as access_mode,
    Case AC.Flags
    when 0 then 'Member'
    when 5 then 'Children'
    when 6 then 'IChildren'
    when 8 then 'Descendants'
    when 9 then 'IDescendants'
    else 'Unknown'
    end as flag
    from
    HYP_PLAN_APP1.HSP_ACCESS_CONTROL AC,
    HYP_PLAN_APP1.HSP_OBJECT U,
    HYP_PLAN_APP1.HSP_OBJECT O,
    HYP_PLAN_APP1.HSP_OBJECT_TYPE OT,
    HYP_PLAN_APP1.HSP_USERS UG
    where
    AC.user_id = UG.user_id
    and UG.USER_ID = U.object_id
    and AC.object_id = O.object_id
    and O.object_type = OT.object_type
    and O.object_type <> 7
    Union
    select
    U.Object_Name as User_Name,
    G.Object_Name as Group_Name,
    'PLAN_APP2' as mart,
    O.Object_Name as Object_Name,
    OT.Type_Name as Object_Type,
    Case AC.Access_Mode
    when 3 then 'ReadWrite'
    when 2 then 'Write'
    when 1 then 'Read'
    when -1 then 'None'
    else 'Unknown'
    end as access_mode,
    Case AC.Flags
    when 0 then 'Member'
    when 5 then 'Children'
    when 6 then 'IChildren'
    when 8 then 'Descendants'
    when 9 then 'IDescendants'
    else 'Unknown'
    end as flag
    from
    HYP_PLAN_APP2.HSP_ACCESS_CONTROL AC,
    HYP_PLAN_APP2.HSP_OBJECT U,
    HYP_PLAN_APP2.HSP_OBJECT O,
    HYP_PLAN_APP2.HSP_OBJECT_TYPE OT,
    HYP_PLAN_APP2.HSP_OBJECT G,
    HYP_PLAN_APP2.HSP_USERSINGROUP UG
    where
    AC.user_id = UG.group_id
    and UG.USER_ID = U.object_id
    and AC.object_id = O.object_id
    and UG.group_id = G.object_id
    and O.object_type = OT.object_type
    and O.object_type <> 7
    union
    select
    U.Object_Name as User_Name,
    '' as Group_Name,
    'PLAN_APP2' as mart,
    O.Object_Name as Object_Name,
    OT.Type_Name as Object_Type,
    Case AC.Access_Mode
    when 3 then 'ReadWrite'
    when 2 then 'Write'
    when 1 then 'Read'
    when -1 then 'None'
    else 'Unknown'
    end as access_mode,
    Case AC.Flags
    when 0 then 'Member'
    when 5 then 'Children'
    when 6 then 'IChildren'
    when 8 then 'Descendants'
    when 9 then 'IDescendants'
    else 'Unknown'
    end as flag
    from
    HYP_PLAN_APP2.HSP_ACCESS_CONTROL AC,
    HYP_PLAN_APP2.HSP_OBJECT U,
    HYP_PLAN_APP2.HSP_OBJECT O,
    HYP_PLAN_APP2.HSP_OBJECT_TYPE OT,
    HYP_PLAN_APP2.HSP_USERS UG
    where
    AC.user_id = UG.user_id
    and UG.USER_ID = U.object_id
    and AC.object_id = O.object_id
    and O.object_type = OT.object_type
    and O.object_type <> 7
    Union
    select
    U.Object_Name as User_Name,
    G.Object_Name as Group_Name,
    'PLAN_APP3' as mart,
    O.Object_Name as Object_Name,
    OT.Type_Name as Object_Type,
    Case AC.Access_Mode
    when 3 then 'ReadWrite'
    when 2 then 'Write'
    when 1 then 'Read'
    when -1 then 'None'
    else 'Unknown'
    end as access_mode,
    Case AC.Flags
    when 0 then 'Member'
    when 5 then 'Children'
    when 6 then 'IChildren'
    when 8 then 'Descendants'
    when 9 then 'IDescendants'
    else 'Unknown'
    end as flag
    from
    HYP_PLAN_APP3.HSP_ACCESS_CONTROL AC,
    HYP_PLAN_APP3.HSP_OBJECT U,
    HYP_PLAN_APP3.HSP_OBJECT O,
    HYP_PLAN_APP3.HSP_OBJECT_TYPE OT,
    HYP_PLAN_APP3.HSP_OBJECT G,
    HYP_PLAN_APP3.HSP_USERSINGROUP UG
    where
    AC.user_id = UG.group_id
    and UG.USER_ID = U.object_id
    and AC.object_id = O.object_id
    and UG.group_id = G.object_id
    and O.object_type = OT.object_type
    and O.object_type <> 7
    union
    select
    U.Object_Name as User_Name,
    '' as Group_Name,
    'PLAN_APP3' as mart,
    O.Object_Name as Object_Name,
    OT.Type_Name as Object_Type,
    Case AC.Access_Mode
    when 3 then 'ReadWrite'
    when 2 then 'Write'
    when 1 then 'Read'
    when -1 then 'None'
    else 'Unknown'
    end as access_mode,
    Case AC.Flags
    when 0 then 'Member'
    when 5 then 'Children'
    when 6 then 'IChildren'
    when 8 then 'Descendants'
    when 9 then 'IDescendants'
    else 'Unknown'
    end as flag
    from
    HYP_PLAN_APP3.HSP_ACCESS_CONTROL AC,
    HYP_PLAN_APP3.HSP_OBJECT U,
    HYP_PLAN_APP3.HSP_OBJECT O,
    HYP_PLAN_APP3.HSP_OBJECT_TYPE OT,
    HYP_PLAN_APP3.HSP_USERS UG
    where
    AC.user_id = UG.user_id
    and UG.USER_ID = U.object_id
    and AC.object_id = O.object_id
    and O.object_type = OT.object_type
    and O.object_type <> 7
    union
    select
    U.Object_Name as User_Name,
    G.Object_Name as Group_Name,
    'PLAN_APP4' as mart,
    O.Object_Name as Object_Name,
    OT.Type_Name as Object_Type,
    Case AC.Access_Mode
    when 3 then 'ReadWrite'
    when 2 then 'Write'
    when 1 then 'Read'
    when -1 then 'None'
    else 'Unknown'
    end as access_mode,
    Case AC.Flags
    when 0 then 'Member'
    when 5 then 'Children'
    when 6 then 'IChildren'
    when 8 then 'Descendants'
    when 9 then 'IDescendants'
    else 'Unknown'
    end as flag
    from
    HYP_PLAN_APP4.HSP_ACCESS_CONTROL AC,
    HYP_PLAN_APP4.HSP_OBJECT U,
    HYP_PLAN_APP4.HSP_OBJECT O,
    HYP_PLAN_APP4.HSP_OBJECT_TYPE OT,
    HYP_PLAN_APP4.HSP_OBJECT G,
    HYP_PLAN_APP4.HSP_USERSINGROUP UG
    where
    AC.user_id = UG.group_id
    and UG.USER_ID = U.object_id
    and AC.object_id = O.object_id
    and UG.group_id = G.object_id
    and O.object_type = OT.object_type
    and O.object_type <> 7
    union
    select
    U.Object_Name as User_Name,
    '' as Group_Name,
    'PLAN_APP4' as mart,
    O.Object_Name as Object_Name,
    OT.Type_Name as Object_Type,
    Case AC.Access_Mode
    when 3 then 'ReadWrite'
    when 2 then 'Write'
    when 1 then 'Read'
    when -1 then 'None'
    else 'Unknown'
    end as access_mode,
    Case AC.Flags
    when 0 then 'Member'
    when 5 then 'Children'
    when 6 then 'IChildren'
    when 8 then 'Descendants'
    when 9 then 'IDescendants'
    else 'Unknown'
    end as flag
    from
    HYP_PLAN_APP4.HSP_ACCESS_CONTROL AC,
    HYP_PLAN_APP4.HSP_OBJECT U,
    HYP_PLAN_APP4.HSP_OBJECT O,
    HYP_PLAN_APP4.HSP_OBJECT_TYPE OT,
    HYP_PLAN_APP4.HSP_USERS UG
    where
    AC.user_id = UG.user_id
    and UG.USER_ID = U.object_id
    and AC.object_id = O.object_id
    and O.object_type = OT.object_type
    and O.object_type <> 7
    Union
    select
    U.Object_Name as User_Name,
    G.Object_Name as Group_Name,
    'PLAN_APP5' as mart,
    O.Object_Name as Object_Name,
    OT.Type_Name as Object_Type,
    Case AC.Access_Mode
    when 3 then 'ReadWrite'
    when 2 then 'Write'
    when 1 then 'Read'
    when -1 then 'None'
    else 'Unknown'
    end as access_mode,
    Case AC.Flags
    when 0 then 'Member'
    when 5 then 'Children'
    when 6 then 'IChildren'
    when 8 then 'Descendants'
    when 9 then 'IDescendants'
    else 'Unknown'
    end as flag
    from
    HYP_PLAN_APP5.HSP_ACCESS_CONTROL AC,
    HYP_PLAN_APP5.HSP_OBJECT U,
    HYP_PLAN_APP5.HSP_OBJECT O,
    HYP_PLAN_APP5.HSP_OBJECT_TYPE OT,
    HYP_PLAN_APP5.HSP_OBJECT G,
    HYP_PLAN_APP5.HSP_USERSINGROUP UG
    where
    AC.user_id = UG.group_id
    and UG.USER_ID = U.object_id
    and AC.object_id = O.object_id
    and UG.group_id = G.object_id
    and O.object_type = OT.object_type
    and O.object_type <> 7
    union
    select
    U.Object_Name as User_Name,
    '' as Group_Name,
    'PLAN_APP5' as mart,
    O.Object_Name as Object_Name,
    OT.Type_Name as Object_Type,
    Case AC.Access_Mode
    when 3 then 'ReadWrite'
    when 2 then 'Write'
    when 1 then 'Read'
    when -1 then 'None'
    else 'Unknown'
    end as access_mode,
    Case AC.Flags
    when 0 then 'Member'
    when 5 then 'Children'
    when 6 then 'IChildren'
    when 8 then 'Descendants'
    when 9 then 'IDescendants'
    else 'Unknown'
    end as flag
    from
    HYP_PLAN_APP5.HSP_ACCESS_CONTROL AC,
    HYP_PLAN_APP5.HSP_OBJECT U,
    HYP_PLAN_APP5.HSP_OBJECT O,
    HYP_PLAN_APP5.HSP_OBJECT_TYPE OT,
    HYP_PLAN_APP5.HSP_USERS UG
    where
    AC.user_id = UG.user_id
    and UG.USER_ID = U.object_id
    and AC.object_id = O.object_id
    and O.object_type = OT.object_type
    and O.object_type <> 7
    Union
    select
    U.Object_Name as User_Name,
    G.Object_Name as Group_Name,
    'PLAN_APP6' as mart,
    O.Object_Name as Object_Name,
    OT.Type_Name as Object_Type,
    Case AC.Access_Mode
    when 3 then 'ReadWrite'
    when 2 then 'Write'
    when 1 then 'Read'
    when -1 then 'None'
    else 'Unknown'
    end as access_mode,
    Case AC.Flags
    when 0 then 'Member'
    when 5 then 'Children'
    when 6 then 'IChildren'
    when 8 then 'Descendants'
    when 9 then 'IDescendants'
    else 'Unknown'
    end as flag
    from
    HYP_PLAN_APP6.HSP_ACCESS_CONTROL AC,
    HYP_PLAN_APP6.HSP_OBJECT U,
    HYP_PLAN_APP6.HSP_OBJECT O,
    HYP_PLAN_APP6.HSP_OBJECT_TYPE OT,
    HYP_PLAN_APP6.HSP_OBJECT G,
    HYP_PLAN_APP6.HSP_USERSINGROUP UG
    where
    AC.user_id = UG.group_id
    and UG.USER_ID = U.object_id
    and AC.object_id = O.object_id
    and UG.group_id = G.object_id
    and O.object_type = OT.object_type
    and O.object_type <> 7
    union
    select
    U.Object_Name as User_Name,
    '' as Group_Name,
    'PLAN_APP6' as mart,
    O.Object_Name as Object_Name,
    OT.Type_Name as Object_Type,
    Case AC.Access_Mode
    when 3 then 'ReadWrite'
    when 2 then 'Write'
    when 1 then 'Read'
    when -1 then 'None'
    else 'Unknown'
    end as access_mode,
    Case AC.Flags
    when 0 then 'Member'
    when 5 then 'Children'
    when 6 then 'IChildren'
    when 8 then 'Descendants'
    when 9 then 'IDescendants'
    else 'Unknown'
    end as flag
    from
    HYP_PLAN_APP6.HSP_ACCESS_CONTROL AC,
    HYP_PLAN_APP6.HSP_OBJECT U,
    HYP_PLAN_APP6.HSP_OBJECT O,
    HYP_PLAN_APP6.HSP_OBJECT_TYPE OT,
    HYP_PLAN_APP6.HSP_USERS UG
    where
    AC.user_id = UG.user_id
    and UG.USER_ID = U.object_id
    and AC.object_id = O.object_id
    and O.object_type = OT.object_type
    and O.object_type <> 7
    Where user_name in ('Obama','McCain')

  • Sharing calendar appears on another persons device - security and privacy risk

    I really wanted to raise this as a bug, but couldn't find anywhere to do that.
    On my wife's iPhone which is running iOS 7, I wanted to share her iCloud calendar to my Apple ID so that I could see her calendar from my iPhone (also iOS 7).  Although I received the email telling me to accept the shared calendar, when I clicked the link it told me I was not authorized.  I then discovered that my parents had received the sharing invite on their phone (iOS 4.2.1) which they accepted and could see her calendar.
    This is a security and privacy risk because they are not connected to my iCloud account and it is not the account we specified to share with.  Also we did not specify their account to share with.  How can this happen?  Their iPhone was never registered to my Apple ID.  The only connection I can think of is that I believe my email address (which is also my Apple ID) is listed as their secondary email address or something.

    Sorry just realised it was their iPad 3 that received the invite not their iPhone, and it would have been running iOS 6

  • The trial period for this product has expired or Secure Store Shared Service is not supported for this SKU - SharePoint Foundation 2013

    After sucessfulling installing the SharePoint Foundation 2013, when i try to access the Secure Stored Service Application i get the below error
    11/16/2012 18:13:02.84  w3wp.exe (0x1774)                        0x15E8 Secure Store Service         
     Secure Store                   g0n6 High     The trial period for this product has expired or this feature is not supported in this SKU. b3b6e19b-7de2-e016-ad32-0fc975829ef0
    11/16/2012 18:13:02.84  w3wp.exe (0x1774)                        0x15E8 SharePoint Foundation        
     General                        8nca Medium   Application error when access /_admin/sssvc/ManageSSSvcApplication.aspx, Error=The
    trial period for this product has expired or Secure Store Shared Service is not supported for this SKU.   at Microsoft.Office.SecureStoreService.Server.SecureStoreServiceApplicationProxy.Execute[T](String operationName, Boolean validateCanary, ExecuteDelegate`1
    operation)     at Microsoft.Office.SecureStoreService.Server.SecureStoreServiceApplicationProxy.IsMasterSecretKeyPopulated()     at Microsoft.Office.SharePoint.ClientExtensions.SecureStoreAdministration.SSSAdminHelper.EnsurePrerequisite(SecureStoreServiceApplicationProxy
    proxy, String& errorMessage)     at Microsoft.Office.SharePoint.ClientExtensions.SecureStoreAdministration.ManageSSSvcApplication.InitializeGridView()     at Microsoft.Office.SharePoi... b3b6e19b-7de2-e016-ad32-0fc975829ef0
    11/16/2012 18:13:02.84* w3wp.exe (0x1774)                        0x15E8 SharePoint Foundation        
     General                        8nca Medium   ...nt.ClientExtensions.SecureStoreAdministration.ManageSSSvcApplication.OnLoad(EventArgs
    e)     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) b3b6e19b-7de2-e016-ad32-0fc975829ef0
    11/16/2012 18:13:02.84  w3wp.exe (0x1774)                        0x15E8 SharePoint Foundation        
     Runtime                        tkau Unexpected Microsoft.Office.Server.ProductExpiredException: The trial period for this product
    has expired or Secure Store Shared Service is not supported for this SKU.    at Microsoft.Office.SecureStoreService.Server.SecureStoreServiceApplicationProxy.Execute[T](String operationName, Boolean validateCanary, ExecuteDelegate`1 operation)    
    at Microsoft.Office.SecureStoreService.Server.SecureStoreServiceApplicationProxy.IsMasterSecretKeyPopulated()     at Microsoft.Office.SharePoint.ClientExtensions.SecureStoreAdministration.SSSAdminHelper.EnsurePrerequisite(SecureStoreServiceApplicationProxy
    proxy, String& errorMessage)     at Microsoft.Office.SharePoint.ClientExtensions.SecureStoreAdministration.ManageSSSvcApplication.InitializeGridView()     at Microsoft.Office.SharePoint.ClientExtensions.SecureSto... b3b6e19b-7de2-e016-ad32-0fc975829ef0
    11/16/2012 18:13:02.84* w3wp.exe (0x1774)                        0x15E8 SharePoint Foundation        
     Runtime                        tkau Unexpected ...reAdministration.ManageSSSvcApplication.OnLoad(EventArgs e)    
    at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) b3b6e19b-7de2-e016-ad32-0fc975829ef0
    11/16/2012 18:13:02.84  w3wp.exe (0x1774)                        0x15E8 SharePoint Foundation        
     General                        ajlz0 High     Getting Error Message for Exception System.Web.HttpUnhandledException
    (0x80004005): Exception of type 'System.Web.HttpUnhandledException' was thrown. ---> Microsoft.Office.Server.ProductExpiredException: The trial period for this product has expired or Secure Store Shared Service is not supported for this SKU.    
    at Microsoft.Office.SecureStoreService.Server.SecureStoreServiceApplicationProxy.Execute[T](String operationName, Boolean validateCanary, ExecuteDelegate`1 operation)     at Microsoft.Office.SecureStoreService.Server.SecureStoreServiceApplicationProxy.IsMasterSecretKeyPopulated()    
    at Microsoft.Office.SharePoint.ClientExtensions.SecureStoreAdministration.SSSAdminHelper.EnsurePrerequisite(SecureStoreServiceApplicationProxy proxy, String& errorMessage)     at Microsoft.Office.Sha... b3b6e19b-7de2-e016-ad32-0fc975829ef0
    11/16/2012 18:13:02.84* w3wp.exe (0x1774)                        0x15E8 SharePoint Foundation        
     General                        ajlz0 High     ...rePoint.ClientExtensions.SecureStoreAdministration.ManageSSSvcApplication.InitializeGridView()    
    at Microsoft.Office.SharePoint.ClientExtensions.SecureStoreAdministration.ManageSSSvcApplication.OnLoad(EventArgs e)     at System.Web.UI.Control.LoadRecursive()     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint,
    Boolean includeStagesAfterAsyncPoint)     at System.Web.UI.Page.HandleError(Exception e)     at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)    
    at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)     at System.Web.UI.Page.ProcessRequest()     at System.Web.UI.Page.ProcessRequest(HttpContext context)    
    at System.Web.Htt... b3b6e19b-7de2-e016-ad32-0fc975829ef0
    11/16/2012 18:13:02.84* w3wp.exe (0x1774)                        0x15E8 SharePoint Foundation        
     General                        ajlz0 High     ...pApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()    
    at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) b3b6e19b-7de2-e016-ad32-0fc975829ef0
    11/16/2012 18:13:02.86  w3wp.exe (0x1774)                        0x15E8 SharePoint Foundation        
     General                        aat87 Monitorable   b3b6e19b-7de2-e016-ad32-0fc975829ef0
    Is it a bug or any issue in configuration?
    Raghavendra Shanbhag | Blog: http://moss-solutions.blogspot.com
    Please click "Propose As Answer " if a post solves your problem or "Vote As Helpful" if a post has been useful to you.
    Disclaimer: This posting is provided "AS IS" with no warranties.

    Hello
    something should be related wuith this service, take a llok at my visual studio output whne I try to deplay and autohosted sharepoint app: (anyone can help)
    1>------ Build started: Project: MySharePointAppWeb, Configuration: Debug Any CPU ------
    1>  MySharePointAppWeb -> C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\bin\MySharePointAppWeb.dll
    2>------ Build started: Project: MySharePointApp, Configuration: Debug Any CPU ------
    2>C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\Web.Debug.config(34,4): warning : No element in the source document matches '/configuration/connectionStrings'
    2>  Transformed Web.config using C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\Web.Debug.config into obj\Debug\TransformWebConfig\transformed\Web.config.
    2>  Auto ConnectionString Transformed obj\Debug\TransformWebConfig\transformed\Web.config into obj\Debug\CSAutoParameterize\transformed\Web.config.
    2>  Copying all files to temporary location below for package/publish:
    2>  obj\Debug\Package\PackageTmp.
    2>  Packaging into C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointApp\obj\WebDeploy\MySharePointApp.Web.zip.
    2>  Adding sitemanifest (sitemanifest).
    2>  Adding IIS Application (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp)
    2>  Creating application (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp)
    2>  Adding virtual path (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp)
    2>  Adding directory (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp).
    2>  Adding directory (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp\bin).
    2>  Adding directory (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp\bin\en).
    2>  Adding file (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp\bin\en\Microsoft.IdentityModel.resources.dll).
    2>  Adding file (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp\bin\Microsoft.IdentityModel.dll).
    2>  Adding file (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp\bin\Microsoft.IdentityModel.Extensions.dll).
    2>  Adding file (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp\bin\Microsoft.SharePoint.Client.dll).
    2>  Adding file (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp\bin\Microsoft.SharePoint.Client.Runtime.dll).
    2>  Adding file (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp\bin\MySharePointAppWeb.dll).
    2>  Adding file (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp\bin\MySharePointAppWeb.pdb).
    2>  Adding file (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp\packages.config).
    2>  Adding directory (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp\Pages).
    2>  Adding file (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp\Pages\Default.aspx).
    2>  Adding directory (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp\Scripts).
    2>  Adding file (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp\Scripts\jquery-1.7.1.js).
    2>  Adding file (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp\Scripts\jquery-1.7.1.min.js).
    2>  Adding file (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp\Scripts\_references.js).
    2>  Adding file (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp\Web.config).
    2>  Adding ACL's for path (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp)
    2>  Adding ACL's for path (C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointAppWeb\obj\Debug\Package\PackageTmp)
    2>  Adding declared parameter 'IIS Web Application Name'.
    2>  Package "MySharePointApp.Web.zip" is successfully created as single file at the following location:
    2>  file:///C:/_works/visual%20studio%202012/Projects/MySharePointApp/MySharePointApp/obj/WebDeploy
    2>  To get the instructions on how to deploy the web package please visit the following link:
    2>  http://go.microsoft.com/fwlink/?LinkId=124618
    2>  Sample script for deploying this package is generated at the following location:
    2>  C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointApp\obj\WebDeploy\MySharePointApp.Web.deploy.cmd
    2>  For this sample script, you can change the deploy parameters by changing the following file:
    2>  C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointApp\obj\WebDeploy\MySharePointApp.Web.SetParameters.xml
    2>  Successfully created package at: C:\_works\visual studio 2012\Projects\MySharePointApp\MySharePointApp\bin\Debug\app.publish\1.0.0.0\MySharePointApp.app
    3>------ Deploy started: Project: MySharePointApp, Configuration: Debug Any CPU ------
    3>Active Deployment Configuration: Deploy App for SharePoint
    3>Uninstall app for SharePoint:
    3>  Skipping the uninstall step because the app for SharePoint is not installed on the server.
    3>Install app for SharePoint:
    3>  Uploading the app for SharePoint...
    3>  Creating a trusted root authority in SharePoint for IIS Express.
    3>  Installation is in progress (00:00:00)
    3>  Installation is in progress (00:00:01)
    3>  Installation is in progress (00:00:02)
    3>  Installation is in progress (00:00:03)
    3>  Installation is in progress (00:00:05)
    3>  Installation is in progress (00:00:06)
    3>  App failed to install, cleaning up...
    3>  App installation cleanup failed due to errors.  Please see the app on the SharePoint site’s “Site Contents” page for details.
    3>  App installation encountered the following errors:
    3> 
    3>  @"Error 1
    3>        CorrelationId: ceeeafab-3834-40ea-b360-c29d103e2248
    3>        ErrorDetail: The remote hosting service is not configured.
    3>        ErrorType: Configuration
    3>        ErrorTypeName: Configuration
    3>        ExceptionMessage: The trial period for this product has expired or Secure Store Shared Service is not supported for this SKU.
    3>        Source: RemoteWebSite
    3>        SourceName: Remote Web Site Deployment
    3> 
    3>  @"Error 2
    3>        CorrelationId: ceeeafab-3834-40ea-b360-c29d103e2248
    3>        ErrorDetail: The remote hosting service is not configured.
    3>        ErrorType: Configuration
    3>        ErrorTypeName: Configuration
    3>        ExceptionMessage: The trial period for this product has expired or Secure Store Shared Service is not supported for this SKU.
    3>        Source: RemoteWebSite
    3>        SourceName: Remote Web Site Deployment
    3>Error occurred in deployment step 'Install app for SharePoint': Failed to install app for SharePoint. Please see the output window for details.
    ========== Build: 2 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========
    ========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

  • Cisco ASA 5505 Cannot ping local traffic and local hosts cannot get out

    I have, what I believe to be, a simple issue - I must be missing something.
    Site to Site VPN with Cisco ASA's. VPN is up, and remote hosts can ping the inside int of ASA (10.51.253.209).
    There is a PC (10.51.253.210) plugged into e0/1.
    I know the PC is configured correctly with Windows firewall tuned off.
    The PC cannot get to the ouside world, and the ASA cannot ping 10.51.253.210.
    I have seen this before, and I deleted VLAN 1, recreated it, and I could ping the local host without issue.
    Basically, the VPN is up and running but PC 10.51.253.210 cannot get out.
    Any ideas? Sanitized Config is below. Thanks !
    ASA Version 7.2(4)
    hostname *****
    domain-name *****
    enable password N7FecZuSHJlVZC2P encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Vlan1
    nameif Inside
    security-level 100
    ip address 10.51.253.209 255.255.255.248
    interface Vlan2
    nameif Outside
    security-level 0
    ip address ***** 255.255.255.248
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    shutdown
    interface Ethernet0/3
    shutdown
    interface Ethernet0/4
    shutdown
    interface Ethernet0/5
    shutdown
    interface Ethernet0/6
    shutdown
    interface Ethernet0/7
    shutdown
    ftp mode passive
    dns server-group DefaultDNS
    domain-name *****
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 10.1.7.0 255.255.255.0
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 host 10.1.10.250
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 host 10.1.3.200
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 host 10.1.3.9
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 host 10.10.10.14
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 host 10.10.10.15
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 host 10.10.10.16
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 10.1.9.0 255.255.255.0
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 10.10.9.0 255.255.255.0
    access-list No_NAT extended permit ip 10.51.253.208 255.255.255.248 ***** 255.255.255.240
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 10.1.7.0 255.255.255.0
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 host 10.1.10.250
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 host 10.1.3.200
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 host 10.1.3.9
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 host 10.10.10.14
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 host 10.10.10.15
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 host 10.10.10.16
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 10.1.9.0 255.255.255.0
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 10.10.9.0 255.255.255.0
    access-list Outside_VPN extended permit ip 10.51.253.208 255.255.255.248 ***** 255.255.255.240
    pager lines 24
    mtu Outside 1500
    mtu Inside
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit any Outside
    no asdm history enable
    arp timeout 14400
    global (Outside) 1 interface
    nat (Inside) 0 access-list No_NAT
    route Outside 0.0.0.0 0.0.0.0 ***** 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    aaa authentication enable console LOCAL
    aaa authentication serial console LOCAL
    aaa authentication ssh console LOCAL
    http server enable
    no snmp-server location
    no snmp-server contact
    snmp-server community *****
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set DPS_Set esp-3des esp-md5-hmac
    crypto map DPS_Map 10 match address Outside_VPN
    crypto map DPS_Map 10 set peer *****
    crypto map DPS_Map 10 set transform-set *****
    crypto map DPS_Map interface Outside
    crypto isakmp enable Outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash md5
    group 2
    lifetime 28800
    crypto isakmp policy 65535
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 Outside
    ssh timeout 60
    console timeout 0
    management-access Inside
    username test password P4ttSyrm33SV8TYp encrypted
    tunnel-group ***** type ipsec-l2l
    tunnel-group ***** ipsec-attributes
    pre-shared-key *
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect netbios
      inspect rsh
      inspect rtsp
      inspect skinny
      inspect esmtp
      inspect sqlnet
      inspect sunrpc
      inspect tftp
      inspect sip
      inspect xdmcp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:8d0adca63eab6c6c738cc4ab432f609d
    : end
    1500

    Hi Martin,
    Which way you are trying. Sending traffic via site to site is not working or traffic which you generate to outside world is not working?
    But you say ASA connected interface to PC itself is not pinging that is strange. But try setting up the specific rules for the outgoing connection and check. Instead of not having any ACL.
    If it is outside world the you may need to check on the NAT rules which is not correct.
    If it is site to site then you may need to check few other things.
    Please do rate for the helpful posts.
    By
    Karthik

  • Security And Cryptography

    I'm so much new in Java Card programming and know alittle about security and cryptions in Javacards..
    Would u please help me to start learning in these topics from basic, or introduce any refrences that learns basic security and encrypt & decrypt
    thanks all..
    Kind Regards
    Hana

    This feature is often implemented using a secure channel.
    basically you have to authenticate with the card before being able to acess any data.
    pros:
    avoid internal encryption, which is costly
    allows to authenticate and encrypt the real important thing : communication. The card internals are secure by design: there are light/frequency/temperature sensors to protect from tampering.
    cons:
    i don't know :)
    how does it work? with a shared key and 3 ways handshake.
    (card contains a key that was loaded previously)
    1 host generates a random string H and sends it to the card.
    2 card generates a random string C and sends enc(H) and enc(C)
    host verifies that dec(enc(C))==C This way, we are sure the card knows the same key as us.
    3 host sends enc(H)
    card verifies that dec(enc(H))==H This way the card is sure the host knows the same key as it.
    access to data is granted only if all these steps passes.
    the crypto alg is generally 3DES with 16 bytes keys and 8 byte datablocks, this algo is managed in the card HARDware, so it's fast.
    this sort of process is used in global platform. Read this doc for more information, this is a bible.
    If you use the global platform mechanism, you will get excellent security with few code to write.
    Note that there are many possibilities here, this one is only an example to help you get the idea.

  • Using AX as wireless router, how to set up w/ security and airtunes on XP

    I previously had a Linksys wireless router. I just purchased an Airport express to use as the wireless router (and remove the Linksys router) as well as use the Airtunes functionality.
    After some trial and error, I have been able to wireless connect my computer to the AX on it's own (the linksys router is now unplugged and out of the equation). I can connect to the internet fine on my PC (XP Pro SP2).
    Trouble is, when I use the Network Setup Assistant, it shows the apple network listed, but it can't connect to it, no matter how many times I try, reboot my machine or reboot the AX. I've tried both the "setting up a new network" and "editing an existing network" option, and in each selection, after a few minutes of trying to connect to the network, I just get a failure message.
    If I try and use the Admin utility, nothing shows up in the left-hand list window, and when I Press re-scan, still nothing shows (it doesn't even appear to scan).
    I'm not sure what I'm doing wrong. I can't find simple instructions on how to set up the AX as the only wireless router for a PC and set up security and Airtunes (I'm assuming enabling airtunes is done in these applications, as I haven't seen anything about that yet either).
    Any ideas on how this is done with a PC? Much thanks!
    Dell 4500 series

    I have found the 'DHCP Reservations' option on the AirPort Extreme to be buggy.  I seem to remember it causing IP conflicts for some reason.  I think what I remember is that if the computer with the reservation was off, and the DHCP server then handed out that IP to another DHCP client, then there would be a conflict when the reserved IP computer was turned back on.  Maybe it was an issue in ealier versions of the AE or OS X as the case may be, and maybe it's been corrected, but I've never bothered using it agian since the method I describe below has always worked without fail.  Also, I'm guessing DHCP Reservations would work fine if one manually enters IPs outside of the DHCP range but in the AE 'DHCP Reservation Setup Assistant' the IP options provided are within the DHCP range which to me makes no sense and increases the potential for IP conflicts.
    Here's what I do to setup a mixed environment of static and dynamic IPs on my network.  It works like a charm and does not require the DHCP server (beyond the distribution of dynamic IPs to hosts using DHCP).
    For machines on my network that are accepting services from the public network, I set them up with static IPs using the 'Manually' option (System Preferences/Network/Ethernet/Configure IPv4).  The settings for 'Router' IP address and 'DNS Server' IP address should both be set with your gateway/router LAN IP).  Use an IP address below or above the DHCP range of adresses (in AE/Internet/DHCP/DHCP Beginning & Ending Address).
    i.e. if my subnet is 10.0.1.1 and my DHCP range is 10.0.1.100 to 10.0.1.150, you could set the static IPs on your local hosts as 10.0.1.x where x = any number from 2 - 99 or from 151 - 200 as an example.
    All other machines and devices that do not require static routing are setup as DHCP clients and get a dynamic IP from the AE.  To me it's a simpler setup though it might take a little extra time to setup initially.
    John

  • Windows Firewall doesn't work as advertised: "File and Sharing (SMB-in)" fails to restrict by user, computer or IP.

    Hello,
    I'm trying to understand whether I'm the one who's crazy, doing something wrong, or whether Windows Firewall was designed to be broken (and stay that way through Windows Server 2008 R2!)
    When I go to Windows Firewall with Advanced Security from the Start Menu and edit the Inbound Rule for "File and Sharing (SMB-in)", the result I am seeking is that I can restrict access by both user and computer.
    Upon enabling the rule, and selecting the "Allow the connection if it is secure" option (and nothing else), the firewall obliges by denying any and all attempts by other computers to map or browse files.
    When I enter the name of one PC in the Computers tab under the "Allow connections from these computers", again the firewall obliges and the said PC can now browse and map to shares on that server.  HOWEVER, now other computers on the network are able
    to do the same, as long as they have any set of verifiable credentials (like a local user/admin or domain user/admin, etc).  Trying to restrict by user or by IP yield almost identical results.  Both those who I do and do not want are able to access
    files on the said server.
    My question is this: how is this firewall rule supposed to work?  What do we have to do to actually make it accept and reject connections based on the criteria we have provided?
    My goal is to only allow SMB access to a user IF they log in from a particular computer or group of computers.
    Any help would be GREATLY appreciated!
    Waqqas

    I too find the same problem.  I enable the firewall rule, put in Local Addresses that I want to be able to get through the firewall to access the File shares, but it opens the firewall so any ip address can access the shares.  Anyone have an answer?
    And No, Niko Bellic,  checking the MSDN forum is NOT the answer!

  • Network and Sharing Centre problems (again)

    I seem to be tearing my hair out once again with the Network List Service. Several months back the Network and Sharing centre stopped displaying or reporting the active networks, although I was connected with internet access. A consequence was most of the
    Metro apps would not work as they thought the computer was off-line.
    The problem seemed to be that the permissions were wrong in the Network List hierarchy and adding Full Control for my user account in 'HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows
    NT\CurrentVersion\NetworkList' seemed to solve the problem.
    Once again thought the Metro apps are not working reporting no internet connection and the Network and Sharing centre has the following message:
    Unknown
    The service to detect this status is disabled
    More Information
    When I select More Information I get a dialog asking if I want to turn on Network List Service,  when I click "Turn this on' nothing happens. 
    Having looked in the Event Viewer, there are a large number of this entry, maybe it is related?
        DCOM got error "1068" attempting to start the service netprofm with arguments "Unavailable" in order to run the server:
    Network List Service is reported as running in Services.msc. and task  manager.
    I tried to check the permissions in the registry key as I did before but key was missing (i think). I tried switching to a local account on the computer from my Microsoft Live account but no change, although when I checked the registry, the NetworkList
    key was there and the permissions were correct. Maybe I was just looking in the wrong place but I was pretty sure it was missing...
    Not sure where to go next with this.. 

    Hi,
    The Network and Sharing centre opens as normal but where you would normally see 
    'View your active networks' followed by the network or list of networks that you are connected to it just says:
    Unknown (when view your active networks would be)
    The service to detect this status is disabled
    More Information
    Clicking on 'More information' informs me that the Network List Service is not running and asks if I want to start it, clicking yes does nothing. The Network list Service is listed as running in Service.msc
    I have tried a full virus scan and also ran a whole host of anti malware tools and the computer seems clean. I also tried sfc /scannow with no problems detected.
    I restored and old clonezilla backup I had and it is fine now but made a system backup before I did. This is the second time this has happened and I would like to find a solution so I will revert back to the drive image with the issue and post a screen shot. 

  • Help: Unable to set root servlet in a shared hosting environment

    I'm using a shared hosting environment with GoDaddy and can't set the http://www.domain.com/ root servlet, i.e. the servlet that gets invoked when we go to the homepage.
    I have the following web.xml file configured that currently works on my testing server:
         <servlet>
              <display-name>MainPage</display-name>
              <servlet-name>MainPage</servlet-name>
              <servlet-class>com.somedomain.MainPage</servlet-class>
         </servlet>
         <servlet-mapping>
              <servlet-name>MainPage</servlet-name>
              <url-pattern>/mainpage</url-pattern>
         </servlet-mapping>
         <welcome-file-list>
              <welcome-file>mainpage</welcome-file>
         </welcome-file-list>The application is configured as the 'ROOT' application on my development server, but shared in the hosting environment. I wonder if some permissions are not given since it is shared hosting environment. The error message I get when visiting the page is:
    Forbidden
    You don't have permission to access / on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/1.3.33 Server at dev9.somedomain.com Port 80Unfortunately the server get's restarted once a day, so multiple suggestions would be much appreciated. I will upload them all at once.

    Change the value of the url-pattern value of your servlet mapping in the deployment descriptor. Instead of using "/mainpage" as the value use "/index.html" or "/index.jsp".
    Edited To Add - But this might not be right, because it will result in an endless loop. You would eventually want to display the home page and it would trigger the servlet which would forward to the home page, triggering the servlet and on and on...
    I don't think I know the answer here...
    Edited by: nantucket on Apr 5, 2009 12:20 PM

  • On-line Back-up and Sharing Portal

    I just got FIos and downloaded the free trial of Security Suite including the On-line Back up and Ffile sharing. 
    It was simple to set up the back up schedule etc., however I can't seem to find a simple way to sign in to the on-line portal to getto my on-line back up and sharing files. For some reason I can't bookmark the location and getting to it from Verizon sign onpage is almost impossible. If I click on "Manage Broad Band Essesntials" it simply brings me to a screen that shows me thebilling information for the program and has a download button for the Suite, Back up and Sharing.  If I click Back up and Sharing itbrings me to the "shopping screen" and just shows me the various bundles and options I can purchase.
    The only way I can get there is by clicking on "edit sub accounts" I have no idea why that works-I found that out after about an hourof trying to access my on line files-but that's the thing--it doesn't always work.
    Isn't there a way I can ,make a short cut for it on my desktop or bookmark it somehow. It's kind of useless if it takes me all day to get to it. Also--for some reason I can't set up my home page either. I'd like to be able to just click on it from there.
    Any help would be much appreciated.
    Thanks you.

    I'm not sure what you would be saving when you're talking about copy written work--but I'm only saving my own documents and pictures. I'll be saving my itunes library--but that belongs to me already--I bought it!
    I had a computer crash last month. I thought I had everything saved and backed up--I was wrong. I don't want to go through that nonsenes again.I also don't want to have to worry about all of my document scans etc being burned in a fire or lost in a flood--god forbid--I know you're supposed to keep all of that stuff elsewhere, but who has that kind of time?
    Anyway--the 986th time must have been the charm. I downloaded the back up and sharing software again..and...it's working!! A personal victory. I don't give up witout a fight, that's for sure

  • Shared hosting, Coldfusion 8 & Livecycle Data Services ES

    I want to develop a CF/Flex/Air online/offline application that uses Livecylcle Data Services (LCDS) to synchronize client (SQLlite) and server (MySQL) databases.  I'm a coldfusion developer (MX6) and have done some Flash work (AS2).  I'm going to learn Flex, Air and AS3.
    I can only use shared hosting.   I'm confused about the licensing of LCDS and if there is shared hosting that provides it.  I Googled for Coldfusion/Flex/LCDS web hosting and the only one I found was way too expensive, e.g.$250/month. 
    But I just read that LCDS is included with Coldfusion 8.  So does that mean web hosting with CF 8 (Enterprise) automatically includes LCDS?

    It really depends on the hosting provider.  The ColdFusion 8 install (Standard & Enterprise) have the ability to install a LCDS "trial" which after 30 days will revert to LCDS ES which is free, as long as the server that it's installed on has no more than 1 processor (up to 2 cores though I believe).
    To more specifically answer your question, it really depends on whether the individual hosting provider has installed and offers this option to their clients.  The use of LCDS with Flex required configuration of a data-management-config.xml file and certain ports may need to be opened up for rtmp vs. polling transfer methods.  I'm not sure exactly how this would work given a shared hosting environment and if you could sandbox the configurations per client.
    The sure way to get this setup (and the method I've used for the past few years) is to get yourself a dedicated box (which can be had for less than 100 dollars, especially given the processor limitation on the LCDS licensing) and get yourself a license for CF8 while they're still available.  CF9 will still support LCDS integration, but the install isn't seamless like it is with CF8.  During the install process for CF8 you can choose to install LCDS and after a bit of configuration you're all set.

  • Error from EAS - "refreshing security from Shared Services failed"

    Hi,
    I was using Native only security in HSS for Essbase 11.1.1.3 and EAS allowed me to Refresh security from Shared Services. (Essbase security was already externalized to HSS.)
    However, after I added "MS Active Directory", and provisioned a MSAD user to a native Planning group, EAS errors out with "refreshing security from Shared Services failed" .
    I checked Essbase security and that MSAD user is not added to Essbase.
    From Essbase Log I see:
    Essbase failed to get roles list for [ESB:Analytic Servers:servername:1] from Shared Services Server with Error [32:1062:Failed to connect to the user directory [ HSS'sMSADname].
    I then tried to remove MSAD from our H Shared Services and see if this problem goes away. However, MSAD still shows on the left panel menu in H Shared Services. How can I get rid of MSAD?
    Any suggestions?
    Edited by: user643332 on May 12, 2010 12:05 AM

    Hi,
    Are you sure you have removed it from shared services, you may have just disabled it.
    You must restart the shared services application server to apply any changes made.
    Cheers
    John
    http://john-goodwin.blogspot.com/

  • WPA security and iBook

    I have searched and searched and read and read and called Buffalo and cannot solve this problem. Hope someone can help.
    I have set up a Buffalo Airstation (MHR-G54S) with my Macbook and it works just great wirelessly with WPA-PSK (AES) security enabled. However, I cannot get an iBook 500 dual USB with regualr airport card to connect to the network - the iBook "sees " the network but when I try to connect I get the message
    "there was an error joining the Airport network etc"
    The iBook has OS 10.3.9 and all system updates including Airport 4.2.
    Am I trying to do something that is not possible with the iBook?
    I have also tried to set up WEP security and that doesn't work with the Macbook or iBook but I am not sure I really understand how to set up the passwords for that even after reading the apple KB documents and posts about it.

    I have set up a Buffalo Airstation (MHR-G54S) with
    my Macbook and it works just great wirelessly with
    WPA-PSK (AES) security enabled.
    "WPA Personal" on the Mac corresponds to plain WPA, with a pre-shared key (PSK) and TKIP encryption, on non-Apple wireless routers.
    When You Can Join a WPA Network
    http://docs.info.apple.com/article.html?artnum=107795

Maybe you are looking for

  • Java.beans.Expression and inner classes

    hello, test.java public class test public class in public in() System.out.println("inner"); t.java import java.beans.*; class t public static void main(String...args) try {       new Expression(test.in.class,"new",null).getValue ();                  

  • Doubt Regarding Collection Methods

    Hello, I am working on Oracle version 10g Release 2 I wanted to know that how can we find a particular name (person) exists in a Collection.. Below is my Code DECLARE TYPE nested_tab IS TABLE OF VARCHAR2(100); l_tab nested_tab := nested_tab(); BEGIN

  • Use of generics programmiing in J2ME

    Where can I find out when Netbeans will support generics programming for mobile J2ME applications?

  • How I protect edition in some pages of my PDF, but accept modify one page in my PDF file?

    How I protect edition in some pages of my PDF, but accept modify one page in my PDF file? For example... I am author of a e-book. But, I want people distribute that my e-book inserting in first page your website of who is distributing. Look at how I

  • Installing Elements 12 from Purchased CD

    Should I uninstall the trial version of Elements 12 before installing my purchased version from CD?