SES: relate attributes to each other

Hi,
I am implementing a SES based index. In this index I store Customer data.
Most of the customers have multiple addresses, and here my problem is situated.
When I perform a search, the different addresses get mixed up.
For example, when I have a customer with the following addresses
Address 1: street = Baker Street city = London
Address 2: street = Town Street city = Liverpool
and another customer with the following addresses
Address 1: street = Baker Street city = Liverpool
Address 2: street = Town Street city = London
I find back both customers when I search for street = Baker Street and city = London
In my indexing class, in the method GET_ATTRIBUTE_VALUES I have given each address line a different ROW_COUNTER as this parameter suggest it can relate the address data to each other.
Has anybody got an idea how I can relate my address data to each other, so my search returns accurate results?
Thanks
Mario
PS: I don't want to use joined indexes for the addresses, as I already have build joined indexes with Sales Transactions where I will need to search on Sales Transaction Data combined with address data and customer master data.

My experiments with SES showed that here is what is needed:
- you should inform TREX that your attributes (city and street) are related by putting them into a single attribute group
- attributes' internal(as seen in trexadmin) type should be String (and not Text). By default only quite a short abap string (25 or 40 CHARs) gets converted by SES as String. My values were longer so I had to force String type for them, which is, I'm afraid, unsupported.
Also there seem to be some bugs with this sort of search in TREX 7.00 standalone (which I have). Release notes for 7.10 promise corrections

Similar Messages

  • Can these two attributes conflict each other?

    A Data Guard question: Can MAX_FAILURE and NET_TIMEOUT attributes conflict each other if we configure them simultaneously on a same LOG_ARCHIVE_DEST destination?
    Is there any overlap to them?

    Is it easier to ask someone else to look up the
    answer for you than to look it up yourself?
    http://www.oracle.com/pls/db111/homepage
    I encourage you to read it for yourself. You might
    just learn something else of value.
    Read the Doc - A Poem
    I need a guru who can do
      In one statement - a line or two,
    To write for me the fix i need
      to make me a hero, o yes indeed.
    I hack and I paste, can't show my true code
      But using your powers I'm sure you will know
    What is my issue, time is flying -  Tick-Tock...
      What do you mean, just go read the doc? RTFM - right? ;}

  • Java Lottery - relating arrays to each other

    Hello all and thank you for taking the time to read my problem.
    I am trying to create a program that asks the user for their name, then how man tickets they would like, then they enter 6 numbers for each ticket.
    The maximum amount of 6 number tickets that can be bought is 20.
    So for example user1 could get three tickets, user2 could get 10 tickets and user3 could get 7 tickets (20 in total).
    My main headache is how to relate the ticket numbers entered with the persons username.
    I assume that if user1 gets three tickets these are stored in an array [6] [20] but then when user2 puts their lines on how do I print out at the end who has which tickets?
    Also the maximum array size for tickets is [6] [20]...but what if only one user buys 3 tickets and does not use up the remaining 17 tickets, does this affect how I define the array?
    Thanks again, all help welcome!

    This is sort of what they were talking about, this is an object oriented approach.
    There should be no 2D arrays, just arrays of Objects that contain data about themselves or perhaps more Objects.
    Try to make your code look more like this.
    import java.util.*;
    public class Lottery {
        private LinkedList<Person> line = new LinkedList<Person>();
        public Person nextInLine() {
            line.add( new Person() );
            return line.getLast();
        public void showTicketsPurchased() {
            System.out.println( "\nTickets Purchased:");
            for( Person p: line ) {
                p.showTicketsPurchased();
        class Person {
            private LinkedList<Ticket> tickets= new LinkedList<Ticket>();
            void buyTicket( int num1, int num2, int num3, int num4, int num5, int num6 ) {
                try {
                    tickets.add( Ticket.sellTicket( num1, num2, num3, num4, num5, num6 ) );
                    System.out.println( "Bought Ticket: " + tickets.getLast() );
                } catch (NoSuchElementException nsee) {
                    System.out.println( nsee.getMessage() );
                    System.out.println( "Could not buy ticket, it's sold out");
            public void showTicketsPurchased() {
                for ( Ticket t: tickets ) {
                    System.out.println( t );
        public static void main( String[] args ) {
            Lottery lottery = new Lottery();
            Person servingThisPerson;
            //First person in line
            servingThisPerson = lottery.nextInLine();
            servingThisPerson.buyTicket( 1,2,3,4,5,6 );
            servingThisPerson.buyTicket( 2,3,4,5,6,7 );
            //Second person in line
            servingThisPerson = lottery.nextInLine();
            servingThisPerson.buyTicket( 10, 20, 30, 40, 50, 60 );
            servingThisPerson.buyTicket( 20, 30, 40, 50, 60, 70 );
            lottery.showTicketsPurchased();
    import java.util.*;
    public class Ticket {
        public static final int MAX_NUM_TICKETS = 20;
        private static int numTicketsSold = 0;
        private int[] numbers;
        private Ticket( int num1, int num2, int num3, int num4, int num5, int num6 ) {
            numbers = new int[]{ num1, num2, num3, num4, num5, num6 };
            numTicketsSold++;
        public static Ticket sellTicket( int num1, int num2, int num3, int num4, int num5, int num6 ) {
            if( numTicketsSold < MAX_NUM_TICKETS ) {
                return new Ticket( num1, num2, num3, num4, num5, num6 );
            } else {
                throw new NoSuchElementException("Tickets sold out");
         * Don't want people to change the tickets numbers after it has been created.
         * @return copy of tickets numbers, not the original array
        public int[] getTicketNumbers() {
            return Arrays.copyOf( numbers, numbers.length );
        public String toString() {
            return Arrays.toString( numbers );
    }Brushfire,

  • I can't seem to access new mail on my I pad . I can only see strings of messages that are related to each other. I also have lost the ability to search for messages that are no longer on display on my I pad.

    I cannot seem to access properly any more the new e mail messages on my I pad. I can only see strings of messages that relate to each other.
    Also I cannot search for old messages that have now disappeared . The search bar has disappeared.
    Tom

    Try a reset: hold down the home button along with the power button until you see the Apple, then let go.

  • Is it okay to home share with my roommate who is not related to me if we do not import each other's music?

    Is it okay to home share with my roommate who is not related to me if we do not import each other's music?

    Thanks I will try that . . . . the issue became worse when we recently updated to IOS6 - now all three of us get everything . . . . I was trying to avoid separate Apple ID's and emails but that might be the solution based on what I have read on here . . . .

  • Related emails not folding into each other in one folder / but do in all others

    It really bizarre for me, as my other folders also have mail routed to them via various rules, and related messages fold neatly into each other, with a little triangle next to them, indicating that there is a whole chain in there.
    But in this one particular mail folder, each message shows up one by one, I am not sure why?
    The rules route messages into it by subject line (i.e. if it contains "zee" move it to that folder).
    Can anyone explain?
    Thank you!
    Zebbler

    Hello eporon,
    the only possibility to create a DVD with several movies and have the option to either play the parts separatly or "play all" as in commercial DVDs is to duplicate your movie(s).
    This means you have to import the individual movies (as you already did), then create a new movie where you join the parts into one. Now import that movie as well and name the menu button "play all".
    Important: this can only work if the combined parts are less than 60 min long (DVD-R is max 120 min).
    Alternatively you could create a single movie out of the four parts and place chapter markers for each individual title (ceremony, reception...) the let iDVD create a chapter submenu. Now the separate titles can be accessed from there.
    hope this helps
    mish

  • Are this OSPF LSA relate to each other ???

    OSPF neighbor relationships progress
    1) Down State
    2) Init State
    OSPF routers send Type 1 (hello)
    3) Two-Way State
    4) ExStart State (Type 2)
    5) Exchange State
    6) Loading State (type 3)
    7) Full Adjacency
    ALSO,
    OSPF Area Types also use LSA exchange between routers or area
    Type 1 – generate by each router for each area it belongs to, flood only within particular area, describe the states of the router’s link to the area.
    Type 2 – generate by DR in multi-access networks, flood only within the area that contain the network, describe the set of routes attched to a particular network.
    Type 3 – Orgin by ABR, flood throughout the backbone area to other ABRs, describe the links between ABR and the internal routes of a local area.
    Type 4 – Orgin by ABR, flood throughout the backbone area to other ABRs, describe routes to ASBRs.
    Type 5 – Orgin by ASBR, describe the routes to destinations external to the AS, flood throughout an OSPF AS.
    The questions are this LSA relate to each other or it just happen like this ???

    Hi Friend,
    There is no relation between the type of LSA (1,2,3,4,5,7) exchanged between the routers within an area and between the areas to exchange the link state information and the packets which are used to form an ospf neigh and adjancy relationship.
    Taking an example LSA 5 which is used to carry the external route information into an area is not at all related to type 5 LSA which you are talking for formaing a naighbor relationship.
    I think the neighbor relationship is formed using hello packet, dd packet and LSU and LSR packets which you may name as type of LSA's. but these are not at all related to LSA's which are used to carry route information between the areas and within areas.
    HTH
    Ankur

  • Delete masterdata from two infoobjects which have each other as attribut

    Hello,
    we have the infoobject 0BPARTNER und 0CUSTOMER which have each other within as an attribut.
    0BPARTNER
       Attribute 0CUSTOMER
    0CUSTOMER
       Attribute 0BPARTNER
    Now we want to delete the master data from both of them. But it's not possible the delete in RSA1because of the assignment to each other.
    Can you help me?
    Best regards
    Stefan

    Hi Stefan:
      Do you want to delete ALL the Master Data records from the 2 InfoObjects? In case you need to do this on your DEVELOPMENT environment, then you could use Tcode SE14 to delete the CONTENTS from the SID table, Master Data Table, etc., please be aware that you need to use Tcode SE14 very carefully, because you could also delete the physical tables and not only the contents.
    *Important: Also note that it is not recommended to use SE14 on your PRODUCTION environment, unless you perfectly understand the implications (you would need to reload your DSOs or Cubes).
    Regards,
    Francisco Milán.
    Edited by: Francisco Milan on Jun 15, 2010 10:48 AM

  • TS4006 I want to set up "find my ipad" on my sister's ipad, so we can find each other's iPads. However, this seems to require differing individual cloud email addresses, so one ipad wouldn't recognise the other one. How do I get round this?

    I want to set up "find my ipad" on my sister's ipad, so we can find each other's iPads. However, this seems to require differing individual cloud email addresses, so one ipad wouldn't recognise the other one. How do I get round this?

    Many thanks for the quick response.
    I'm fine with using the same ID for iCloud, so I'll give that a try.
    You mention that a lost ipad can be found from any computer. As a relative computer novice, I didn't know this. How would I go about carrying out such a search?
    I don't think I'd use the find friends app. My concern is to find a lost or stolen ipad.
    Thanks

  • Form Error Message: Invalid relation attribute on pageSet xfa

    Hi,
    I've developed a form that many folks are using without any issues. However, I do have a small number of users that get the following error message when opening the form.
    Error Message:  Invalid relation attribute on pageSet xfa[0].template[0].form1[0].#pageSet[0]
    This error only appears to come up if they are using Adobe Acrobat Pro Version 8. No issues on versions 9 or 10 (X). The form is suppose to be compatible back to version 7.
    My main form is called (form1). Then there are 4 major sub forms under (form1), The top drop down (on the masterpage) hides or displays one of the major sub forms based on user selection.
    I have a hunch that something with the generated code not jiving well with Acrobat 8.
    Here's a snippet of the code if you'd like to look through it.
    form1.#pageSet[0].MasterPage1.FormActionDropDown::change - (JavaScript, client)
    //+ GENERATED - DO NOT EDIT (ID:D2FF16C4-6D1F-45D4-ACB7-0DB7CE14229F CRC:3650232787)
    //+ Type: Action
    //+ Result4: SetPresence("$Node5","hidden")
    //+ Result3: SetPresence("$Node4","visible")
    //+ Result2: SetPresence("$Node3","hidden")
    //+ Result1: SetPresence("$Node2","hidden")
    //+ Node5: form1[0].ChangePAForm[0]
    //+ Node4: form1[0].Non-PAForm[0]
    //+ Node3: form1[0].DeletePAForm[0]
    //+ Node2: form1[0].PAForm[0]
    //+ Node1: form1[0].#pageSet[0].MasterPage1[0].FormActionDropDown[0]
    //+ Condition1: ListField("$Node1","textselected","ADD NON-PA User")
    //+ ActionName: DropDown.change.NonPA
    if ($.boundItem(xfa.event.newText) == "ADD NON-PA User") {
      this.resolveNode("PAForm").presence = "hidden";
      this.resolveNode("DeletePAForm").presence = "hidden";
      this.resolveNode("Non-PAForm").presence = "visible";
      this.resolveNode("ChangePAForm").presence = "hidden";
    //+ GENERATED - DO NOT EDIT (ID:662A28BD-A30A-4E6D-92CD-6FF22B0EFB5D CRC:2945493746)
    //+ Type: Action
    //+ Result4: SetPresence("$Node5","hidden")
    //+ Result3: SetPresence("$Node4","hidden")
    //+ Result2: SetPresence("$Node3","visible")
    //+ Result1: SetPresence("$Node2","hidden")
    //+ Node5: form1[0].ChangePAForm[0]
    //+ Node4: form1[0].Non-PAForm[0]
    //+ Node3: form1[0].DeletePAForm[0]
    //+ Node2: form1[0].PAForm[0]
    //+ Node1: form1[0].#pageSet[0].MasterPage1[0].FormActionDropDown[0]
    //+ Condition1: ListField("$Node1","textselected","DELETE EXISTING PA")
    //+ ActionName: DropDown.change.DeletePA
    if ($.boundItem(xfa.event.newText) == "DELETE EXISTING PA") {
      this.resolveNode("PAForm").presence = "hidden";
      this.resolveNode("DeletePAForm").presence = "visible";
      this.resolveNode("Non-PAForm").presence = "hidden";
      this.resolveNode("ChangePAForm").presence = "hidden";
    //+ GENERATED - DO NOT EDIT (ID:66B7091F-75C5-4A73-8ACA-885AE42D0308 CRC:2169512649)
    //+ Type: Action
    //+ Result4: SetPresence("$Node5","visible")
    //+ Result3: SetPresence("$Node4","hidden")
    //+ Result2: SetPresence("$Node3","hidden")
    //+ Result1: SetPresence("$Node2","hidden")
    //+ Node5: form1[0].ChangePAForm[0]
    //+ Node4: form1[0].Non-PAForm[0]
    //+ Node3: form1[0].DeletePAForm[0]
    //+ Node2: form1[0].PAForm[0]
    //+ Node1: form1[0].#pageSet[0].MasterPage1[0].FormActionDropDown[0]
    //+ Condition1: ListField("$Node1","textselected","CHANGE / MODIFY EXISTING PA")
    //+ ActionName: DropDown.change.ChangePa
    if ($.boundItem(xfa.event.newText) == "CHANGE / MODIFY EXISTING PA") {
      this.resolveNode("PAForm").presence = "hidden";
      this.resolveNode("DeletePAForm").presence = "hidden";
      this.resolveNode("Non-PAForm").presence = "hidden";
      this.resolveNode("ChangePAForm").presence = "visible";
    //+ GENERATED - DO NOT EDIT (ID:C87B58DB-765D-426C-81BB-5A7ECFF42B63 CRC:2949030955)
    //+ Type: Action
    //+ Result4: SetPresence("$Node5","hidden")
    //+ Result3: SetPresence("$Node4","hidden")
    //+ Result2: SetPresence("$Node3","hidden")
    //+ Result1: SetPresence("$Node2","visible")
    //+ Node5: form1[0].ChangePAForm[0]
    //+ Node4: form1[0].Non-PAForm[0]
    //+ Node3: form1[0].DeletePAForm[0]
    //+ Node2: form1[0].PAForm[0]
    //+ Node1: form1[0].#pageSet[0].MasterPage1[0].FormActionDropDown[0]
    //+ Condition1: ListField("$Node1","textselected","CREATE NEW PA")
    //+ ActionName: DropDown.change.NewPA
    if ($.boundItem(xfa.event.newText) == "CREATE NEW PA") {
      this.resolveNode("PAForm").presence = "visible";
      this.resolveNode("DeletePAForm").presence = "hidden";
      this.resolveNode("Non-PAForm").presence = "hidden";
      this.resolveNode("ChangePAForm").presence = "hidden";

    You should post this question in the LiveCycle Designer forum here. This forum is for forms created in Acrobat (Acroforms).

  • Error Message: Invalid relation attribute on pageSet xfa

    Hi,
    Searching through the forums and on the net, I cannot seem to locate an answer to this problem so I'm trying here...
    I've developed a form that many folks are using without any issues. However, I do have a small number of users that get the following error message when opening the form.
    Error Message:  Invalid relation attribute on pageSet xfa[0].template[0].form1[0].#pageSet[0]
    This error only appears to come up if they are using Adobe Acrobat Pro Version 8. No issues on versions 9 or 10 (X). The form is suppose to be compatible back to version 7.
    My main form is called (form1). Then there are 4 major sub forms under (form1), The top drop down (on the MasterPage1) hides or displays one of the major sub forms based on user selection.
    I have a hunch that something with the generated code not jiving well with Acrobat 8.
    Here's a snippet of the code if you'd like to look through it.
    form1.#pageSet[0].MasterPage1.FormActionDropDown::change - (JavaScript, client)
    //+ GENERATED - DO NOT EDIT (ID:D2FF16C4-6D1F-45D4-ACB7-0DB7CE14229F CRC:3650232787)
    //+ Type: Action
    //+ Result4: SetPresence("$Node5","hidden")
    //+ Result3: SetPresence("$Node4","visible")
    //+ Result2: SetPresence("$Node3","hidden")
    //+ Result1: SetPresence("$Node2","hidden")
    //+ Node5: form1[0].ChangePAForm[0]
    //+ Node4: form1[0].Non-PAForm[0]
    //+ Node3: form1[0].DeletePAForm[0]
    //+ Node2: form1[0].PAForm[0]
    //+ Node1: form1[0].#pageSet[0].MasterPage1[0].FormActionDropDown[0]
    //+ Condition1: ListField("$Node1","textselected","ADD NON-PA User")
    //+ ActionName: DropDown.change.NonPA
    if ($.boundItem(xfa.event.newText) == "ADD NON-PA User") {
      this.resolveNode("PAForm").presence = "hidden";
      this.resolveNode("DeletePAForm").presence = "hidden";
      this.resolveNode("Non-PAForm").presence = "visible";
      this.resolveNode("ChangePAForm").presence = "hidden";
    //+ GENERATED - DO NOT EDIT (ID:662A28BD-A30A-4E6D-92CD-6FF22B0EFB5D CRC:2945493746)
    //+ Type: Action
    //+ Result4: SetPresence("$Node5","hidden")
    //+ Result3: SetPresence("$Node4","hidden")
    //+ Result2: SetPresence("$Node3","visible")
    //+ Result1: SetPresence("$Node2","hidden")
    //+ Node5: form1[0].ChangePAForm[0]
    //+ Node4: form1[0].Non-PAForm[0]
    //+ Node3: form1[0].DeletePAForm[0]
    //+ Node2: form1[0].PAForm[0]
    //+ Node1: form1[0].#pageSet[0].MasterPage1[0].FormActionDropDown[0]
    //+ Condition1: ListField("$Node1","textselected","DELETE EXISTING PA")
    //+ ActionName: DropDown.change.DeletePA
    if ($.boundItem(xfa.event.newText) == "DELETE EXISTING PA") {
      this.resolveNode("PAForm").presence = "hidden";
      this.resolveNode("DeletePAForm").presence = "visible";
      this.resolveNode("Non-PAForm").presence = "hidden";
      this.resolveNode("ChangePAForm").presence = "hidden";
    //+ GENERATED - DO NOT EDIT (ID:66B7091F-75C5-4A73-8ACA-885AE42D0308 CRC:2169512649)
    //+ Type: Action
    //+ Result4: SetPresence("$Node5","visible")
    //+ Result3: SetPresence("$Node4","hidden")
    //+ Result2: SetPresence("$Node3","hidden")
    //+ Result1: SetPresence("$Node2","hidden")
    //+ Node5: form1[0].ChangePAForm[0]
    //+ Node4: form1[0].Non-PAForm[0]
    //+ Node3: form1[0].DeletePAForm[0]
    //+ Node2: form1[0].PAForm[0]
    //+ Node1: form1[0].#pageSet[0].MasterPage1[0].FormActionDropDown[0]
    //+ Condition1: ListField("$Node1","textselected","CHANGE / MODIFY EXISTING PA")
    //+ ActionName: DropDown.change.ChangePa
    if ($.boundItem(xfa.event.newText) == "CHANGE / MODIFY EXISTING PA") {
      this.resolveNode("PAForm").presence = "hidden";
      this.resolveNode("DeletePAForm").presence = "hidden";
      this.resolveNode("Non-PAForm").presence = "hidden";
      this.resolveNode("ChangePAForm").presence = "visible";
    //+ GENERATED - DO NOT EDIT (ID:C87B58DB-765D-426C-81BB-5A7ECFF42B63 CRC:2949030955)
    //+ Type: Action
    //+ Result4: SetPresence("$Node5","hidden")
    //+ Result3: SetPresence("$Node4","hidden")
    //+ Result2: SetPresence("$Node3","hidden")
    //+ Result1: SetPresence("$Node2","visible")
    //+ Node5: form1[0].ChangePAForm[0]
    //+ Node4: form1[0].Non-PAForm[0]
    //+ Node3: form1[0].DeletePAForm[0]
    //+ Node2: form1[0].PAForm[0]
    //+ Node1: form1[0].#pageSet[0].MasterPage1[0].FormActionDropDown[0]
    //+ Condition1: ListField("$Node1","textselected","CREATE NEW PA")
    //+ ActionName: DropDown.change.NewPA
    if ($.boundItem(xfa.event.newText) == "CREATE NEW PA") {
      this.resolveNode("PAForm").presence = "visible";
      this.resolveNode("DeletePAForm").presence = "hidden";
      this.resolveNode("Non-PAForm").presence = "hidden";
      this.resolveNode("ChangePAForm").presence = "hidden";

    You should post this question in the LiveCycle Designer forum here. This forum is for forms created in Acrobat (Acroforms).

  • Anyconnect VPN peers cannot ping, RDP each other

    I have an ASA5505 running ASA 8.3(1) and ASDM 7.1(1).  I have a remote access VPN set up and the remote access users are able to log in and access LAN resources.   I can ping the VPN peers from the remote LAN.    My problem that the VPN peers cannot ping (RDP, ectc..) each other.   Pinging one VPN peer from another reveals the following error in the ASA Log.
    Asymmetric NAT rules matched for forward and reverse flows; Connection for icmp src outside:10.10.10.8 dst outside:10.10.10.9 (type 8, code 0) denied due to NAT reverse path failure. 
    Below is my ASA running-config:
    ASA Version 8.3(1)
    hostname ciscoasa
    domain-name dental.local
    enable password 9ddwXcOYB3k84G8Q encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address dhcp setroute
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    clock timezone CST -6
    clock summer-time CDT recurring
    dns domain-lookup inside
    dns server-group DefaultDNS
    name-server 192.168.1.128
    domain-name dental.local
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network RAVPN
    subnet 10.10.10.0 255.255.255.0
    object network NETWORK_OBJ_10.10.10.0_28
    subnet 10.10.10.0 255.255.255.240
    object network NETWORK_OBJ_192.168.1.0_24
    subnet 192.168.1.0 255.255.255.0
    access-list Local_LAN_Access remark VPN client local LAN access
    access-list Local_LAN_Access standard permit host 0.0.0.0
    access-list DefaultRAGroup_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0
    access-list VpnPeers remark allow vpn peers to ping each other
    access-list VpnPeers extended permit ip object NETWORK_OBJ_10.10.10.0_28 object NETWORK_OBJ_10.10.10.0_28
    pager lines 24
    logging enable
    logging asdm informational
    logging mail informational
    logging from-address [email protected]
    logging recipient-address [email protected] level informational
    logging rate-limit 1 600 level 6
    mtu outside 1500
    mtu inside 1500
    ip local pool VPNPool 10.10.10.5-10.10.10.10 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-711.bin
    no asdm history enable
    arp timeout 14400
    nat (inside,any) source static any any destination static RAVPN RAVPN
    nat (inside,outside) source static NETWORK_OBJ_192.168.1.0_24 NETWORK_OBJ_192.168.1.0_24 destination static NETWORK_OBJ_10.10.10.0_28 NETWORK_OBJ_10.10.10.0_28
    nat (inside,outside) source static any any destination static NETWORK_OBJ_10.10.10.0_28 NETWORK_OBJ_10.10.10.0_28
    object network obj_any
    nat (inside,outside) dynamic interface
    object network RAVPN
    nat (any,outside) dynamic interface
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community *****
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec transform-set ESP-AES-128-SHA-TRANS esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA-TRANS mode transport
    crypto ipsec transform-set ESP-DES-SHA-TRANS esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-SHA-TRANS mode transport
    crypto ipsec transform-set ESP-AES-192-SHA-TRANS esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA-TRANS mode transport
    crypto ipsec transform-set ESP-AES-256-SHA-TRANS esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-256-SHA-TRANS mode transport
    crypto ipsec transform-set ESP-3DES-SHA-TRANS esp-3des esp-sha-hmac
    crypto ipsec transform-set ESP-3DES-SHA-TRANS mode transport
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-192-SHA ESP-AES-256-SHA ESP-3DES-SHA ESP-DES-SHA ESP-AES-128-SHA-TRANS ESP-AES-192-SHA-TRANS ESP-AES-256-SHA-TRANS ESP-3DES-SHA-TRANS ESP-DES-SHA-TRANS
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto ca trustpoint LOCAL-CA-SERVER
    keypair LOCAL-CA-SERVER
    crl configure
    crypto ca trustpoint ASDM_TrustPoint0
    enrollment self
    subject-name CN=ciscoasa
    keypair billvpnkey
    proxy-ldc-issuer
    crl configure
    crypto ca server
    cdp-url http://ciscoasa/+CSCOCA+/asa_ca.crl
    issuer-name CN=ciscoasa
    smtp from-address admin@ciscoasa
    crypto ca certificate chain LOCAL-CA-SERVER
    certificate ca 01
       **hidden**
      quit
    crypto ca certificate chain ASDM_TrustPoint0
    certificate 10bdec50
        **hidden**
      quit
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication crack
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 20
    authentication rsa-sig
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 30
    authentication pre-share
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 40
    authentication crack
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 50
    authentication rsa-sig
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 60
    authentication pre-share
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 70
    authentication crack
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 80
    authentication rsa-sig
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 90
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 100
    authentication crack
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 110
    authentication rsa-sig
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 120
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 130
    authentication crack
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 140
    authentication rsa-sig
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 150
    authentication pre-share
    encryption des
    hash sha
    group 2
    lifetime 86400
    client-update enable
    telnet 192.168.1.1 255.255.255.255 inside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    management-access inside
    dhcpd auto_config outside
    dhcpd address 192.168.1.50-192.168.1.99 inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics
    threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
    ssl trust-point ASDM_TrustPoint0 outside
    webvpn
    enable outside
    svc image disk0:/anyconnect-win-3.1.04072-k9.pkg 1
    svc profiles DellStudioClientProfile disk0:/dellstudioclientprofile.xml
    svc enable
    tunnel-group-list enable
    internal-password enable
    smart-tunnel list SmartTunnelList RDP mstsc.exe platform windows
    group-policy DefaultRAGroup internal
    group-policy DefaultRAGroup attributes
    dns-server value 192.168.1.128
    vpn-tunnel-protocol l2tp-ipsec
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value DefaultRAGroup_splitTunnelAcl
    default-domain value dental.local
    webvpn
      svc modules value vpngina
    group-policy DefaultRAGroup_1 internal
    group-policy DefaultRAGroup_1 attributes
    dns-server value 192.168.1.128
    vpn-tunnel-protocol l2tp-ipsec
    default-domain value dental.local
    group-policy DfltGrpPolicy attributes
    dns-server value 192.168.1.128
    vpn-simultaneous-logins 4
    vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
    group-lock value RAVPN
    split-tunnel-network-list value Local_LAN_Access
    default-domain value dental.local
    webvpn
      url-list value DentalMarks
      svc modules value vpngina
      svc profiles value dellstudio type user
      svc ask enable default webvpn
      smart-tunnel enable SmartTunnelList
    username wketchel1 password 5c5OoeNtCiX6lGih encrypted
    username wketchel1 attributes
    vpn-group-policy DfltGrpPolicy
    webvpn
      svc profiles value DellStudioClientProfile type user
    username wketchel password 5c5OoeNtCiX6lGih encrypted privilege 15
    username wketchel attributes
    vpn-group-policy DfltGrpPolicy
    webvpn
      svc modules none
      svc profiles value DellStudioClientProfile type user
    username jenniferk password 5.TcqIFN/4yw0Vq1 encrypted privilege 0
    username jenniferk attributes
    vpn-group-policy DfltGrpPolicy
    webvpn
      svc profiles value DellStudioClientProfile type user
    tunnel-group DefaultRAGroup general-attributes
    address-pool VPNPool
    authorization-server-group LOCAL
    tunnel-group DefaultRAGroup ipsec-attributes
    pre-shared-key *****
    tunnel-group DefaultRAGroup ppp-attributes
    authentication pap
    authentication ms-chap-v2
    authentication eap-proxy
    tunnel-group RAVPN type remote-access
    tunnel-group RAVPN general-attributes
    address-pool VPNPool
    authorization-server-group LOCAL
    tunnel-group RAVPN webvpn-attributes
    group-alias RAVPN enable
    tunnel-group RAVPN ipsec-attributes
    pre-shared-key *****
    tunnel-group RAVPN ppp-attributes
    authentication pap
    authentication ms-chap-v2
    authentication eap-proxy
    tunnel-group WebSSLVPN type remote-access
    tunnel-group WebSSLVPN webvpn-attributes
    group-alias WebSSLVPN enable
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    smtp-server 173.194.64.108
    prompt hostname context
    hpm topN enable
    Cryptochecksum:3304bf6dcf6af5804a21e9024da3a6f8
    : end

    Hi,
    Seems to me that you could clean up the current NAT configuration a bit and make it a bit clearer.
    I would suggest the following changes
    object network VPN-POOL
    subnet 10.10.10.0 255.255.255.0
    object network LAN
    subnet 192.168.1.0 255.255.255.0
    object-group network PAT-SOURCE
    network-object 192.168.1.0 255.255.255.0
    network-object 10.10.10.0 255.255.255.0
    nat (inside,outside) source static LAN LAN destination static VPN-POOL VPN-POOL
    nat (outside,outside) 1 source static VPN-POOL VPN-POOL destination static VPN-POOL VPN-POOL
    nat (any,outside) after-auto source dynamic PAT-SOURCE interface
    The above should enable
    Dynamic PAT for LAN and VPN users
    NAT0 for the traffic between LAN and VPN
    NAT0 for traffic between VPN users
    You could then remove the previous NAT configurations. Naturally please do backup the configuration before doing the change if you wish to move back to the original configuration.
    no nat (inside,any) source static any any destination static RAVPN RAVPN
    no nat  (inside,outside) source static NETWORK_OBJ_192.168.1.0_24  NETWORK_OBJ_192.168.1.0_24 destination static NETWORK_OBJ_10.10.10.0_28  NETWORK_OBJ_10.10.10.0_28
    no nat (inside,outside) source static any any destination static NETWORK_OBJ_10.10.10.0_28 NETWORK_OBJ_10.10.10.0_28
    no object network obj_any
    no object network RAVPN
    In the event that you dont want to change the configurations that much you might be fine just by adding this
    object network VPN-POOL
    subnet 10.10.10.0 255.255.255.0
    nat (outside,outside) 1 source static VPN-POOL VPN-POOL destination static VPN-POOL VPN-POOL
    But the other above configurations changes would make the current NAT configurations simpler and clearer to see each "nat" configurations purpose.
    - Jouni

  • How to show relation attribute on logical model

    Hi.
    How to show child entity relation attributes on logical model?
    Entity properties attribute list contains relation attributes, LM dont show they.
    I have model with several subviews. I need to show some entity without related entities but need to save "semantic" of relations on this subview. When relation attributes does not visible - no information about invisible relations on this subview.
    I can create my own visible attribute like "reference to customer" to make sense the relation with entity "Customer". This case problem is relation attribute presents in entity implicitly and relation model have 2 attribute - my own and generated FK column.
    In logical model i can`t replace child table relation attribute to my own "visible" attribute.
    In relational model i should redefine FK manually. Transformation script is posible but very odd way.
    Any advice appreciated.

    I am confused.
    I think the legacy Oracle Designer Barker notation could show reation attributes optional or by default, int`t it?
    Thanks a lot anyway.

  • How can we get help/advice amoungst each other? I have questions

    How can we get help/advice amoungst each other? I have questions which might not be bug related and thought it would be nice if we could bounce questions off each other.
    Example:
    Why is my Reflow sample behaving like this?
    Should I have some kind of settings set so things don't get all weird?
    I didn't set any breakpoints yet, but things are going weird.
    Image attached! Any insights?
    Thanks.

    You can post questions here too. If they are design questions if people know the answer they can respond too.
    For this particular issue, it does look like a design problem. From the screen shots, I'm guessing that the light gray box is using negative top margin to overlap the darker dray box. I think for this change the dark gray box to use height:auto and add a padding-bottom to it for the current space below the text. That way when the text starts to push down there will be a constant amout of space from the bottom of the text to the bottom of the dark gray box and that will push the light gray box down as well.

  • SAP XI - Webpshere - complementing each other?

    Hello everyone,
    we are in a planning process to roll out SAP throughout several locations in Europe. The project will involve upgrading the central location's 4.6C R/3 system to SAP Netweaver. The EDI business scenario in place is built upon SAL ALE/EDI technology and IBM Websphere as an EDI Subystem. Would you please be so kind to enlighten me by answering these 2 questions:
    1)     Is XI essential/optional to an Netweaver environment? Quoting a whitepaper,  it “provides a technical infrastructure for XML-based message exchange in order to connect SAP components with each other, as well as with non-SAP components.” what does this mean in a concrete business scenario? What does “SAP components” relate to specifically? R/3 components (MM, SD, FI) or Netweaver components?
    2)     What are the pros/cons of integrating XI with Websphere juxtaposed to replacing Websphere with XI entirely? Is XI fully EDI compliant, or if 3rd party tools are to be used to make XI EDI compliant, how do these compare to Websphere in terms of costs and complexity?
    Kind regards,
    Sven Buttler

    1) By SAP Component, they mean pretty much anything with the name SAP attached to it. Either components like BW or Modules like FI (really this is integrating with the underlying Net weaver platform anyway). There are different methods for integrating with SAP systems depending on which versions are been run but they are all supported out of the box. Non SAP systems may require an adapter.
    Basically XI is designed to centralize all the integration between SAP Systems, SAP and non SAP Systems (e.g Websphere in your case) and non sap to non sap systems (if necessary). Older methods of integrating will still be supported although XI would be the recommend method.
    2) XI requires an additional adapter (at an additional cost) in order to integrate EDI.  There are also specific Websphere adapters from IBM for integrating it with XI. I cant really comment too much on the pro's and con's of either approach, sorry. Maybe try asking on the Exchange Infrastructure forum.

Maybe you are looking for

  • HP laptop can't connect to AirPort Extreme

    My dad has an HP laptop with an 802.11G wifi card. When I enabled AirPort Disk and restarted the router, the laptop came up with a "Limited or no connectivity" error. I tried resetting the network, unplugging the router, and even extending it with an

  • Move file to new folder if it does not exist already

    I have tried what feels like a million ways to do this and none of them are working like I want. A file will be placed in folder 1 with a unique case number as the file name. IE 12345675.txt If the data in the file is changed a new file with the same

  • Utorrent shortcut keys stopped working

    All the key shortcuts under the 'File' Menu from uTorrent (run under wine) stopped working. ctrl+o , ctrl+d, ctrl+u and ctrl+n . All the other keyboard shortcuts from the other dropdown menus work; like ctrl+p, ctrl+r, ctrl+g . This problem started a

  • CST not calculating on Delivery Charges

    Dear Users, I have a issue in my PO cst is calculating on delivery charges but while posting MIRO document CST not calculating on delivery charges its showing tax code 'V0' for delivery charges. Please suggest me with a solution. Thanks & Regards, Sh

  • How  do i freeze a frame

    how do I freeze a frame on iPhoto?