SFSB timeout

Hello!
I have servlet in which I create business delegate and save it to HttpSession. BusinessDelegate is for calling SFSB. However, after some time of inactivity SFSB is timeout and if I call it I get exception. But HttpSession is still active. I wrote error handler on web which redirects me to error page and display that SFSB has expired. Even if I refresh (F5) page SFSB is still timeouted because I keep it in HttpSession.
I have found two solutions so far and would like you to share your opinion with me. Also if anyone have better solution please tell me.
1. Make SFSB session lasting equal or more than HttpSession and force user to re-login when HttpSession will expire and automatically create new instance of SFSB.
2. In SFSB make dummy method and call this method from BD before call real business method and catch exception if SFSB timeouted. If exception is caught then recreate SFSB and call business method.
Regards,
Matjaz

Rule #1: Do not attempt to store the Remote
interface of any EJB in the HTTPSession,
surrounded by a BusinessDelegate or not. Ditto the
Home interface. Those objects are vendor-specific
implementations that carry network-specific logic and
data in them. Those interface implemenations will
react differently from vendor to vendor, even from
version to version.It's remote local interface. Is it till better not to store it in HttpSession?
I still not understand why not to store it in HttpSession? What does it have to
do with different implementation if we'r using same server during execution.
Maybe it's bad for remote interface since it makes calls to different JVM which
could be potentialy on different server than first JVM, but we have local remote interface.
>
Rule #2: If you need to pass a "reference" to an EJB
through a session, use the Handle of that
interface as the variable-type to persist.I don't understand this, can you please write simple example.
>
Rule #3: The only time you should hang on to the
Handle of a Remote interface is when you're
using a SFSB. When you retrieve the Remote object from
the Handle, most vendor implementations will
re-configure and re-attach the networking stuff
underneath so that you are indeed talking to the
"same" SFSB.We have SFSB.
Thanks for your answers!

Similar Messages

  • EJB 3.0 Stateful - Setting session timeout in configuration

    Hello Everyone,
    I am working with EJB v3.0 and Glassfish as the app server. In case of Stateful EJB, when we explicitely annotate a method with '@Remove', the bean instance is removed from the container when this method is invoked from the client. However, I just wanted to know if there is any way so that I can override the session timeout value (in configuration or via annotations) such that if no client calls this instance for some configured time, the bean is removed by the container automatically.
    Regards,
    San

    Using a Stateful Session facade from a Servlet is not necessarily a bad design. In some cases, you may want to do some cleanup work on completion of a transaction. Stateful Session beans provide a convenient way (By implementing SessionSynchronization interface) to do this.
    In the servlet programming model, Servlets are not designed to be single threaded. So if you inject a StatefulSessionBean (SFSB) references then multiple threads could be possibly be invoking the SFSB concurrently. In this case, the EJBContainer (as required by the specification), will throw a well defined exception.
    What you may want to do is to place this SFSB reference into you Servlet session.

  • Stateful Session Bean, After remove is called how do I create a new SFSB?

    The application when is deployed creates a new SFSB, after the remove method is called the SFSB does not exist anymore, also the same happens in a timeout. How do I create a new SFSB without restarting the server?
    I am using EJB 3.0
    I don't understand really how in a shopping cart examples through different uses the correct SFSB is called for each user, with EJB 3.0
    Also how should I store the SFSB, I always called it through JNDI lookup.
    Thanks,
    Zoe

    The application when is deployed creates a new SFSB,
    after the remove method is called the SFSB does not
    exist anymore, also the same happens in a timeout.
    How do I create a new SFSB without restarting the
    server?
    I am using EJB 3.0
    Just as you created the firwst one. Assuming that you have a handle to the home object stored somehwere from your first call, you use home.create(var1, var2) or else look up the home using jndi and then call create on the home object.
    I don't understand really how in a shopping cart
    examples through different uses the correct SFSB is
    called for each user, with EJB 3.0
    Through your remote object. Each user has got his own remote object and for SFSB, one and only one bean is tied to a remote object. It's the container's responsibility to relate the remote object and the bean.
    Also how should I store the SFSB, I always called it
    through JNDI lookup.Store? Use a handle and if the handle is lost or an attempt to retrieve the remote object using the handle fails, look at #1 above (lookup home, create on home etc)
    >
    Thanks,
    Zoe

  • StatefulSessionBean timeout/NoSuchObjectException JDev 10.1.3

    hi all,
    i have a SFSB(v3.0) running in embedded oc4j ejb container.
    it runs fine with multi-user enviroment. but when it runs timeout or the @remove method gets called explicitly, it always throw NoSuchObjectException, even i try to create a new SFSB object by access the server on another client.
    my environment is JDev 10.1.3 with embedded oc4j
    from the debug window, i can see every client gets the same object (i did see them from its id property), would it be anything i need to set in the configuration?
    anyone familiar with this problem?
    Thanks,
    Edward
    P.S. the same code will run well in JBoss with default config
    Message was edited by: Edward
    Xuphey

    Hi,
    this sound like a OC4J issue, less than a JDeveloper problem. Please try and reproduce the error in stand alone OC4J and if you can, report the issue to
    OC4J
    Frank

  • Statistics: stateful ejbs and timeout

    Hi,
    I'm wondering if there is a possiblity to get the number of stateful ejbs that hit the timeout marker. Any hints on that? (I'm not looking for the number of transactions that hit the timeout, but rather of the ejbs - related to the idle-timeout-seconds configuration settings.)
    Regards,
    Andi

    Hi,
    In a clustered environment, we've been told that
    stateful EJBs are only balanced before create()
    method. So, if we have already "created" the Remote
    interface, we're using it, and the server fails and
    must be balanced to another instance, what will
    happen? Will we lost that Remote interface and data
    included in it?no, WEBLogic will failover to another node. You will not lose remote interface and data, because SFSB data are copied among several servers (replication group). Please read WL docs at BEA site. WL has excelent documentation about clusters.
    Maris

  • Sso session timeout per partner application

    Hello,
    I was just wondering if it is possible to configure SSO session timeouts per partner application? I'm looking to log out users of a particular application after 15 minutes, but don't want this change to affect any of my other SSO enabled applications. Is this possible?
    Thanks,

    Hi,
    I do not think so, you can not specify specail parameter for one application in SSO.
    Why because SSO is one component (within your Infra) through which you logon different apps.
    Another solution may be it will expensive is that you 'll need to use different infra for this specific application.
    Regards,
    Hamdy

  • I am using the mac QQ and when I login it said login timeout.

    I am using the mac QQ and when I login it said login timeout.

    If you are missing using google maps - try the Nokia map app called "here"

  • Timeout session

    Dear all,
    I inherit this configuration from my colleague,
    The PC / host inside the network internet connection will timeout / disconnected after several minutes when not using.
    How do i disable the config and I want the host to continously connect to internet.
    =~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2011.08.11 11:01:19 =~=~=~=~=~=~=~=~=~=~=~=
    kewpie-MLK-ASA# sh run
    : Saved
    ASA Version 8.0(3)
    hostname kewpie-MLK-ASA
    domain-name default.domain.invalid
    enable password ym1CwmrLnc/fndsu encrypted
    names
    interface Ethernet0/0
    nameif outside
    security-level 0
    ip address 60.a.a.54 255.255.255.252
    interface Ethernet0/1
    no nameif
    no security-level
    no ip address
    interface Ethernet0/1.1
    vlan 10
    nameif Inside
    security-level 80
    ip address 192.168.0.1 255.255.255.0
    interface Ethernet0/1.2
    vlan 20
    nameif visitor
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    interface Ethernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface Ethernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    shutdown
    no nameif
    no security-level
    no ip address
    passwd 2KFQnbNIdI.2KYOU encrypted
    ftp mode passive
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    access-list 100 extended permit icmp any any
    access-list 100 extended permit tcp any any
    access-list 100 extended permit ip any any
    access-list 101 extended permit icmp any any
    access-list 101 extended permit tcp any any eq 2828
    access-list 101 extended permit tcp any host 192.168.0.254 eq 2255
    pager lines 24
    mtu outside 1500
    mtu Inside 1500
    mtu visitor 1500
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit any outside
    icmp permit any Inside
    icmp permit any visitor
    asdm image disk0:/asdm-507.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (Inside) 1 192.168.0.0 255.255.255.0
    nat (visitor) 1 192.168.1.0 255.255.255.0
    static (Inside,outside) tcp interface 2828 192.168.0.254 telnet netmask 255.255.255.255
    access-group 101 in interface outside
    access-group 100 in interface Inside
    access-group 100 in interface visitor
    route outside 0.0.0.0 0.0.0.0 60.a.a.53 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout uauth 0:30:00 absolute uauth 0:30:00 inactivity
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication include tcp/0 Inside 0.0.0.0 0.0.0.0 0.0.0.0 0.0.0.0 LOCAL
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    telnet 0.0.0.0 0.0.0.0 Inside
    telnet 192.168.4.0 255.255.255.0 Inside
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 outside
    ssh 0.0.0.0 0.0.0.0 Inside
    ssh timeout 5
    console timeout 0
    dhcpd dns 202.188.0.133 202.188.5.1
    dhcpd address 192.168.0.2-192.168.0.253 Inside
    dhcpd enable Inside
    dhcpd address 192.168.1.2-192.168.1.253 visitor
    dhcpd enable visitor
    threat-detection basic-threat
    threat-detection statistics access-list
    username admin password bOnxO8/ZA7i5hOxq encrypted
    username kpmsb password /LTd0pEXjM6Ht1Sp encrypted
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect netbios
      inspect rsh
      inspect rtsp
      inspect skinny 
      inspect esmtp
      inspect sqlnet
      inspect sunrpc
      inspect tftp
      inspect sip 
      inspect xdmcp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:809895a4506cb7e47a57552c4a0e0a0f
    : end

    Hi Mohammad,
    You have the following timeoutr values set:
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout uauth 0:30:00 absolute uauth 0:30:00 inactivity
    If you do not want the connection to timeout, use the following:
    timeout conn 0:00:00
    This would never timeout the connection.
    Thanks,
    Varun

  • Jackd + guitar: "timeouts and broken pipes"

    Hi friends! I'm trying to pass my electric guitar via any rack/effects (like Guitarix or Creox) with no luck. I've got this sound card:
    01:06.0 Multimedia audio controller: Creative Labs [SB Live! Value] EMU10k1X
    01:06.1 Input device controller: Creative Labs [SB Live! Value] Input device controller
    I try with QJackCtl and invoking jackd from the terminal with any luck.
    jackd -d alsa -C -P
    jackd 0.121.3
    Copyright 2001-2009 Paul Davis, Stephane Letz, Jack O'Quinn, Torben Hohn and others.
    jackd comes with ABSOLUTELY NO WARRANTY
    This is free software, and you are welcome to redistribute it
    under certain conditions; see the file COPYING for details
    could not open driver .so '/usr/lib/jack/jack_net.so': libcelt0.so.2: cannot open shared object file: No such file or directory
    could not open driver .so '/usr/lib/jack/jack_firewire.so': libffado.so.2: cannot open shared object file: No such file or directory
    JACK compiled with System V SHM support.
    loading driver ..
    creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
    control device hw:0
    configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
    ALSA: final selected sample format for capture: 16bit little-endian
    ALSA: use 2 periods for capture
    ALSA: final selected sample format for playback: 16bit little-endian
    ALSA: use 2 periods for playback
    jackd watchdog: timeout - killing jackd
    [gabo@machina ~]$
    This is the output from QJackCtl:
    00:12:07.126 Client deactivated.
    00:12:07.130 JACK is being forced...
    cannot read server event (Success)
    cannot continue execution of the processing graph (Bad file descriptor)
    zombified - calling shutdown handler
    cannot send request type 7 to server
    cannot read result for request type 7 from server (Broken pipe)
    cannot send request type 7 to server
    cannot read result for request type 7 from server (Broken pipe)
    00:12:07.339 JACK was stopped with exit status=1.
    I can hear my guitar and record with Audacity, but when jackd enter into the escenario everything blows up. I read that nowadays almost any sound card will work with QJackCtl with the default options. I play with the parameters and sometimes jack refuse to start. With the default options on i can make it run, but i get no sound of the racks or guitar effects processors neither the guitar tuners that use jack takes the sound from the guitar. My line input is in capture via alsamixer, but still no luck. Any clue on this? I'm skipping steps?
    Thanks in advance.
    iamgabo

    Hi!
    groups && cat /proc/asound/cards && cat ~/.asoundrc && cat '/etc/security/limits.d/audio.conf' && jackd -v
    adm disk lp wheel http network video audio optical storage power users polkitd vboxusers wireshark kismet
    0 [Live ]: EMU10K1X - Dell Sound Blaster Live!
    Dell Sound Blaster Live! at 0xcc00 irq 17
    #pcm.upmix71 {
    #type upmix
    #slave.pcm "surround71"
    #delay 15
    #channels 8
    pcm.!default {
    type hw
    card 0
    ctl.!default {
    type hw
    card 0
    # convert alsa API over jack API
    # use it with
    # % aplay foo.wav
    # use this as default
    pcm.!default {
    type plug
    slave { pcm "jack" }
    ctl.mixer0 {
    type hw
    card 1
    # pcm type jack
    pcm.jack {
    type jack
    playback_ports {
    0 system:playback_1
    1 system:playback_2
    capture_ports {
    0 system:capture_1
    1 system:capture_2
    cat: /etc/security/limits.d/audio.conf: No such file or directory
    I have a file called 99-audio.conf
    cat /etc/security/limits.d/99-audio.conf
    @audio - rtprio 99
    @audio - memlock unlimited
    Also i've seen some guys changing this file too:
    cat /etc/security/limits.conf
    # /etc/security/limits.conf
    #Each line describes a limit for a user in the form:
    #<domain> <type> <item> <value>
    #Where:
    #<domain> can be:
    # - an user name
    # - a group name, with @group syntax
    # - the wildcard *, for default entry
    # - the wildcard %, can be also used with %group syntax,
    # for maxlogin limit
    #<type> can have the two values:
    # - "soft" for enforcing the soft limits
    # - "hard" for enforcing hard limits
    #<item> can be one of the following:
    # - core - limits the core file size (KB)
    # - data - max data size (KB)
    # - fsize - maximum filesize (KB)
    # - memlock - max locked-in-memory address space (KB)
    # - nofile - max number of open files
    # - rss - max resident set size (KB)
    # - stack - max stack size (KB)
    # - cpu - max CPU time (MIN)
    # - nproc - max number of processes
    # - as - address space limit (KB)
    # - maxlogins - max number of logins for this user
    # - maxsyslogins - max number of logins on the system
    # - priority - the priority to run user process with
    # - locks - max number of file locks the user can hold
    # - sigpending - max number of pending signals
    # - msgqueue - max memory used by POSIX message queues (bytes)
    # - nice - max nice priority allowed to raise to values: [-20, 19]
    # - rtprio - max realtime priority
    #<domain> <type> <item> <value>
    #* soft core 0
    #* hard rss 10000
    #@student hard nproc 20
    #@faculty soft nproc 20
    #@faculty hard nproc 50
    #ftp hard nproc 0
    #@student - maxlogins 4
    * - rtprio 0
    * - nice 0
    @audio - rtprio 65
    @audio - nice -10
    @audio - memlock unlimited
    jackd 0.121.3
    There are the snaps for QJackCtl
    Also, checkout this stuff that i've recorded with audacity, only from the line and nothing else
    http://ompldr.org/vZ3A2eg
    Thanks!
    Last edited by iamgabo (2012-12-15 02:21:08)

  • Database connection timeouts and datasource errors

    Connections in the pool randomly die overnight. Stack traces show that for some reason, the evermind driver is being used even though the MySql connection pool is specified.
    Also, the evermind connection pool is saying connections aren't being closed, and the stack trace shows they're being allocated by entity beans that are definitely not left hanging around.
    Sometimes we get non-serializable errors when trying to retrieve the datasource (this is only after the other errors start). Some connections returned from the pool are still good, so the application limps along.
    EJBs and DAOs both use jdbc/SQLServerDSCore.
    Has anyone seen this problem?
    <data-sources>
         <data-source
              class="com.mysql.jdbc.jdbc2.optional.MysqlConnectionPoolDataSource"
              name="SQLServerDSCore"
              location="jdbc/SQLServerDSCore"
              xa-location="jdbc/xa/SQLServerXACore"
              ejb-location="jdbc/SQLServerDSCore"
              connection-driver="com.mysql.jdbc.Driver"
              min-connections="5"
              username="xxx"
              password="xxx"
              staleness-timeout="3600"
              alive-poll-query="SELECT 1 FROM medispan"
              url="jdbc:mysql://1.2.3.4:3306/dbo?autoReconnect=true&autoReconnectForPools=true&cachePrepStmts=true&is-connection-validation-required=true"
              inactivity-timeout="30"
         >
              <property name="autoReconnect" value="true"/>
              <property name="autoReconnectForPools" value="true"/>
              <property name="is-connection-validation-required" value="true"/>
              <property name="cachePrepStmts" value="true"/>
         </data-source>
    </data-sources>

    Rick,
    OC4J 9.0.4.0.0 - BTW, do you know of any patches?As far as I know, there are no patches for the 9.0.4
    production version of OC4J stand-alone.
    I'm using container managed persistence,It was not clear to me, from your previous post, that you
    are using CMP entity beans.
    I found staleness-timeout and alive-poll-query
    somewhere on a website when trying to track this
    down. Here's four sources:Those sources refer to OrionServer -- and an older version, too, it seems.
    Like all other Oracle products that start out as somebody
    else's -- including, for example, JBuilder (that became "JDeveloper"), Apache Web Server (that became "Oracle HTTP Server") and TopLink -- their development paths diverge, until, eventually, there is absolutely no similarity between them at all. Hence, the latest versions of OC4J and "OrionServer" are so different, that you cannot be sure that something that works for "OrionServer" will work for OC4J.
    I recall reading something, somewhere, sometime about configuring OC4J to use different databases (other than Oracle), but I really don't remember any details (since it was not relevant to me, because we only use Oracle database). In any case, it is possible to use a non-Oracle database with OC4J.
    Good Luck,
    Avi.

  • MDB Timeouts and transaction behavior

    Hi, thanks in advance for any help with this.
    We have a MDB where we have set the timeout to five minutes. In a particular case this timeout is being reached but even though the MDB times out the transaction and sends the message for redelivery the original transaction that was processing the message continues until something happens from an application standpoint to cause that original transaction to complete. This means that we have the same message processed twice under these circumstances.
    I would have expected that if a transaction timed out that the transaction would have been terminated and therefore our processing would have stopped. Is there a way to force this behavior or do we have to put an alarm in our code and kill ourselves such that we never encounter the transaction time out?
    Thanks,
    Sue Shanabrook

    I should have mentioned that we are using container managed transactions.

  • Lock Timeouts and Heap Space Exhaustion

    I'm having some trouble figuring out the best way to handle resource constraints in my application. Generally speaking, the application works well after starting for about a day or so, but inevitably starts generating "Lock timeout" messages and eventually runs out of heap space.
    Here is the main entity class:
    http://github.com/justindthomas/flower_as/blob/master/src/java/name/justinthomas/flower/analysis/statistics/StatisticalInterval.java
    Here is a supporting, persistent class:
    http://github.com/justindthomas/flower_as/blob/master/src/java/name/justinthomas/flower/analysis/statistics/StatisticalFlow.java
    This is the data accessor:
    http://github.com/justindthomas/flower_as/blob/master/src/java/name/justinthomas/flower/analysis/statistics/StatisticsAccessor.java
    And here is the class that controls the insertion and retrieval of data:
    http://github.com/justindthomas/flower_as/blob/master/src/java/name/justinthomas/flower/analysis/statistics/StatisticsManager.java
    The general flow is that a netflow packet is received from a sensor and the StatisticsManager normalizes the flow as it is inserted into the database. The normalization converts the summarized flow into several "resolutions." For example, one resolution might be 5000 ms. So the StatisticsManager takes the flow's end time/5000 - start time/5000 and divides the volume by the result and inserts that data into the database. It sounds kind of confusing, but results in a dataset that allows me to query for netflow activity for any time frame.
    It also means that the database is queried as it is written to; existing data is updated more frequently than new data is written.
    Regardless, Sleepycat seems to be holding on to more data than it needs to. Once an interval has passed (maybe 5 minutes or so), it is unlikely to be accessed again until queried to create charts. However, the memory usage grows out of control despite the lack of necessity for keeping all but recently entered entries in cache.
    This is how the trouble generally starts (note that I've increased the timeout to 15000 ms to try to accommodate for longer wait times, but that just seems to delay the onset of the issue by a day or so):
    [#|2010-10-23T13:46:00.854-0700|SEVERE|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=64;_ThreadName=Thread-1;|addStatisticalSeconds Failed: (JE 4.0.104) Lock expired. Locker 30264205 -1_pool-6-thread-8_ThreadLocker: waited for lock on database=persist#Statistics#name.justinthomas.flower.analysis.statistics.StatisticalInterval LockAddr:32426808 node=17057517 type=READ grant=WAIT_NEW timeoutMillis=15000 startTime=1287866745448 endTime=1287866760795
    Owners: [<LockInfo locker="29616818 -1_pool-6-thread-5_ThreadLocker" type="WRITE"/>]
    Waiters: [<LockInfo locker="7246740 -1_pool-6-thread-6_ThreadLocker" type="READ"/>, <LockInfo locker="26940477 -1_pool-6-thread-2_ThreadLocker" type="WRITE"/>, <LockInfo locker="5099094 -1_pool-6-thread-4_ThreadLocker" type="READ"/>]
    |#]
    [#|2010-10-23T15:00:41.343-0700|SEVERE|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=65;_ThreadName=Thread-1;|addStatisticalSeconds Failed: (JE 4.0.104) Lock expired. Locker 14184769 -1_pool-6-thread-1_ThreadLocker: waited for lock on database=persist#Statistics#name.justinthomas.flower.analysis.statistics.StatisticalInterval LockAddr:32730917 node=17057517 type=READ grant=WAIT_NEW timeoutMillis=15000 startTime=1287871223679 endTime=1287871241341
    Owners: [<LockInfo locker="23975039 -1_pool-6-thread-8_ThreadLocker" type="WRITE"/>]
    Waiters: [<LockInfo locker="19650664 -1_pool-6-thread-6_ThreadLocker" type="READ"/>]
    |#]
    [#|2010-10-23T15:32:13.090-0700|SEVERE|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=66;_ThreadName=Thread-1;|addStatisticalSeconds Failed: (JE 4.0.104) Lock expired. Locker 17937364 -1_pool-6-thread-7_ThreadLocker: waited for lock on database=persist#Statistics#name.justinthomas.flower.analysis.statistics.StatisticalInterval LockAddr:20265315 node=17057517 type=WRITE grant=WAIT_NEW timeoutMillis=15000 startTime=1287873113904 endTime=1287873133089
    Owners: [<LockInfo locker="3251671 -1_pool-6-thread-1_ThreadLocker" type="WRITE"/>]
    Waiters: [<LockInfo locker="32174859 -1_pool-6-thread-8_ThreadLocker" type="READ"/>, <LockInfo locker="33186148 -1_pool-6-thread-4_ThreadLocker" type="WRITE"/>, <LockInfo locker="17825718 -1_pool-6-thread-2_ThreadLocker" type="READ"/>]
    |#]
    [#|2010-10-23T15:32:13.096-0700|SEVERE|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=64;_ThreadName=Thread-1;|addStatisticalSeconds Failed: (JE 4.0.104) Lock expired. Locker 32174859 -1_pool-6-thread-8_ThreadLocker: waited for lock on database=persist#Statistics#name.justinthomas.flower.analysis.statistics.StatisticalInterval LockAddr:20265315 node=17057517 type=READ grant=WAIT_NEW timeoutMillis=15000 startTime=1287873118064 endTime=1287873133092
    Owners: [<LockInfo locker="3251671 -1_pool-6-thread-1_ThreadLocker" type="WRITE"/>]
    Waiters: [<LockInfo locker="33186148 -1_pool-6-thread-4_ThreadLocker" type="WRITE"/>, <LockInfo locker="17825718 -1_pool-6-thread-2_ThreadLocker" type="READ"/>]
    |#]
    [#|2010-10-23T15:32:13.367-0700|SEVERE|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=67;_ThreadName=Thread-1;|addStatisticalSeconds Failed: (JE 4.0.104) Lock expired. Locker 33186148 -1_pool-6-thread-4_ThreadLocker: waited for lock on database=persist#Statistics#name.justinthomas.flower.analysis.statistics.StatisticalInterval LockAddr:20265315 node=17057517 type=WRITE grant=WAIT_NEW timeoutMillis=15000 startTime=1287873118366 endTime=1287873133366
    Owners: [<LockInfo locker="3251671 -1_pool-6-thread-1_ThreadLocker" type="WRITE"/>]
    Waiters: [<LockInfo locker="17825718 -1_pool-6-thread-2_ThreadLocker" type="READ"/>, <LockInfo locker="25145711 -1_pool-6-thread-6_ThreadLocker" type="READ"/>, <LockInfo locker="5544029 -1_pool-6-thread-5_ThreadLocker" type="READ"/>]
    |#]
    [#|2010-10-23T15:33:14.030-0700|SEVERE|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=68;_ThreadName=Thread-1;|addStatisticalSeconds Failed: (JE 4.0.104) Lock expired. Locker 31602565 -1_pool-6-thread-5_ThreadLocker: waited for lock on database=persist#Statistics#name.justinthomas.flower.analysis.statistics.StatisticalInterval LockAddr:11219992 node=17057517 type=WRITE grant=WAIT_NEW timeoutMillis=15000 startTime=1287873175916 endTime=1287873194019
    Owners: [<LockInfo locker="27649147 -1_pool-6-thread-2_ThreadLocker" type="WRITE"/>]
    Waiters: [<LockInfo locker="3895581 -1_pool-6-thread-7_ThreadLocker" type="WRITE"/>, <LockInfo locker="8345933 -1_pool-6-thread-8_ThreadLocker" type="WRITE"/>, <LockInfo locker="12576013 -1_pool-6-thread-6_ThreadLocker" type="WRITE"/>, <LockInfo locker="5695501 -1_pool-6-thread-1_ThreadLocker" type="WRITE"/>]
    |#]
    [#|2010-10-23T15:33:23.334-0700|SEVERE|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=64;_ThreadName=Thread-1;|addStatisticalSeconds Failed: (JE 4.0.104) Lock expired. Locker 8345933 -1_pool-6-thread-8_ThreadLocker: waited for lock on database=persist#Statistics#name.justinthomas.flower.analysis.statistics.StatisticalInterval LockAddr:11219992 node=17057517 type=WRITE grant=WAIT_NEW timeoutMillis=15000 startTime=1287873184851 endTime=1287873203333
    Owners: [<LockInfo locker="3895581 -1_pool-6-thread-7_ThreadLocker" type="WRITE"/>]
    Waiters: [<LockInfo locker="12576013 -1_pool-6-thread-6_ThreadLocker" type="WRITE"/>, <LockInfo locker="5695501 -1_pool-6-thread-1_ThreadLocker" type="WRITE"/>, <LockInfo locker="13327115 -1_pool-6-thread-4_ThreadLocker" type="READ"/>, <LockInfo locker="11939897 -1_pool-6-thread-5_ThreadLocker" type="READ"/>]
    |#]
    [#|2010-10-23T15:33:23.344-0700|SEVERE|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=69;_ThreadName=Thread-1;|addStatisticalSeconds Failed: (JE 4.0.104) Lock expired. Locker 12576013 -1_pool-6-thread-6_ThreadLocker: waited for lock on database=persist#Statistics#name.justinthomas.flower.analysis.statistics.StatisticalInterval LockAddr:11219992 node=17057517 type=WRITE grant=WAIT_NEW timeoutMillis=15000 startTime=1287873184893 endTime=1287873203343
    Owners: [<LockInfo locker="3895581 -1_pool-6-thread-7_ThreadLocker" type="WRITE"/>]
    Waiters: [<LockInfo locker="5695501 -1_pool-6-thread-1_ThreadLocker" type="WRITE"/>, <LockInfo locker="13327115 -1_pool-6-thread-4_ThreadLocker" type="READ"/>, <LockInfo locker="11939897 -1_pool-6-thread-5_ThreadLocker" type="READ"/>]
    |#]
    Those errors go on and on and on, until I eventually see this:
    [#|2010-10-23T17:37:29.876-0700|SEVERE|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=71;_ThreadName=Thread-1;|Exception in thread "ContainerBackgroundProcessor[StandardEngine[com.sun.appserv]]" |#]
    [#|2010-10-23T17:37:34.915-0700|INFO|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=23;_ThreadName=Thread-1;|In main loop, we have serious trouble: java.lang.OutOfMemoryError: Java heap space|#]
    [#|2010-10-23T17:37:56.516-0700|SEVERE|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=66;_ThreadName=Thread-1;|Exception in thread "pool-6-thread-7" |#]
    [#|2010-10-23T17:39:11.060-0700|SEVERE|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=23;_ThreadName=Thread-1;|Exception in thread "{felix.fileinstall.poll=5000, felix.fileinstall.bundles.new.start=true, service.pid=org.apache.felix.fileinstall.fd8877ce-71aa-41d2-8ddc-15ce996cde1b, felix.fileinstall.dir=/opt/glassfishv3/glassfish/domains/domain1/autodeploy/bundles/, felix.fileinstall.filename=org.apache.felix.fileinstall-autodeploy-bundles.cfg, service.factorypid=org.apache.felix.fileinstall, felix.fileinstall.debug=1}" |#]
    [#|2010-10-23T17:39:11.070-0700|SEVERE|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=66;_ThreadName=Thread-1;|java.lang.OutOfMemoryError: Java heap space
         at java.util.IdentityHashMap.init(IdentityHashMap.java:261)
         at java.util.IdentityHashMap.<init>(IdentityHashMap.java:207)
         at com.sleepycat.je.utilint.IdentityHashMap.<init>(IdentityHashMap.java:25)
         at com.sleepycat.je.cleaner.LocalUtilizationTracker.<init>(LocalUtilizationTracker.java:39)
         at com.sleepycat.je.recovery.Checkpointer.flushDirtyNodes(Checkpointer.java:665)
         at com.sleepycat.je.recovery.Checkpointer.syncDatabase(Checkpointer.java:604)
         at com.sleepycat.je.dbi.DatabaseImpl.sync(DatabaseImpl.java:977)
         at com.sleepycat.je.dbi.DatabaseImpl.handleClosed(DatabaseImpl.java:863)
         at com.sleepycat.je.Database.closeInternal(Database.java:458)
         at com.sleepycat.je.Database.close(Database.java:314)
         at com.sleepycat.je.SecondaryDatabase.close(SecondaryDatabase.java:331)
         at com.sleepycat.persist.impl.Store.closeDb(Store.java:1454)
         at com.sleepycat.persist.impl.Store.close(Store.java:1059)
         at com.sleepycat.persist.EntityStore.close(EntityStore.java:630)
         at name.justinthomas.flower.analysis.persistence.FlowReceiver.addFlow(FlowReceiver.java:94)
         at name.justinthomas.flower.analysis.persistence.FlowReceiver.addFlow(FlowReceiver.java:65)
         at name.justinthomas.flower.collector.FlowWorker.parseData(FlowWorker.java:382)
         at name.justinthomas.flower.collector.FlowWorker.v9(FlowWorker.java:111)
         at name.justinthomas.flower.collector.FlowWorker.run(FlowWorker.java:61)
         at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
         at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
         at java.lang.Thread.run(Thread.java:636)
    |#]
    [#|2010-10-23T17:39:11.124-0700|SEVERE|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=23;_ThreadName=Thread-1;|java.lang.OutOfMemoryError: Java heap space
    |#]
    [#|2010-10-23T17:39:11.141-0700|SEVERE|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=72;_ThreadName=Thread-1;|Exception in thread "pool-6-thread-3" |#]
    [#|2010-10-23T17:39:11.144-0700|SEVERE|glassfish3.0.1|javax.enterprise.system.std.com.sun.enterprise.v3.services.impl|_ThreadID=72;_ThreadName=Thread-1;|java.lang.OutOfMemoryError: Java heap space
    |#]
    It's very frustrating, because things run so well at first and then just deteriorate into a resource nightmare. Any suggestions would be welcome. The application is running with 3 CPU cores and 2GB RAM.
    Edited by: justindthomas on Oct 23, 2010 7:19 PM: I initially tried to use the forum's "URL" mechanism, but that doesn't seem to work worth anything, so I un-did it.

    I've disabled that thread for now. While debugging that, I ran into a SecondaryIntegrityException and I read that I shouldn't use secondary indexes without also using transactions. I enabled transactional processing, but the locking issues grew far worse. I opted to find ways to not use secondary indexes instead.You're right that with secondaries it is important to use txns. But I'm not sure why you're having such severe locking problems with txns. Were you using a txn with a cursor, to perform a scan? If so, I can probably suggest ways of doing that without the txn, if you can describe what you're doing and/or point me to your source code. Or, perhaps you've decided not to use secondaries, and this isn't an issue anymore?
    --mark                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       

  • Session Timeouts and SmbServer

    Hi,
    When having iFS mapped to a network drive (via SMB), the SMB server
    is unable to recover from a timeout of the LibrarySession. The network
    drive then seems to be empty and doing a refresh within explorer
    doesn't help either. The only thing that helps, is remapping the
    network drive.
    Within Node.log of iFS I see this stacktrace.
    7/10/02 9:02 AM SmbServer: oracle.ifs.common.IfsException
    oracle.ifs.common.IfsException: IFS-21000: Session is not connected or has timed-out
    at java.lang.Throwable.fillInStackTrace(Native Method)
    at java.lang.Throwable.fillInStackTrace(Compiled Code)
    at java.lang.Throwable.<init>(Compiled Code)
    at java.lang.Exception.<init>(Compiled Code)
    at oracle.ifs.common.IfsException.<init>(Compiled Code)
    at oracle.ifs.common.IfsException.<init>(Compiled Code)
    at oracle.ifs.common.IfsException.<init>(Compiled Code)
    at oracle.ifs.beans.LibraryObject.verifyConnected(Compiled Code)
    at oracle.ifs.beans.Folder.findPublicObjectByPath(Compiled Code)
    at oracle.ifs.beans.FolderPathResolver.findPublicObjectByPath(Compiled Code)
    at oracle.ifs.beans.FolderPathResolver.findPublicObjectByPath(Compiled Code)
    at oracle.ifs.protocols.smb.server.DbTree$DbQuery.<init>(Compiled Code)
    at oracle.ifs.protocols.smb.server.DbTree.getQuery(Compiled Code)
    at oracle.ifs.protocols.smb.server.ComTrans.trans2FindFirst(Compiled Code)
    at oracle.ifs.protocols.smb.server.ComTrans.replyTransaction2(Compiled Code)
    at oracle.ifs.protocols.smb.server.ComTrans.process(Compiled Code)
    at oracle.ifs.protocols.smb.server.ComSmb.handleSmbMessage(Compiled Code)
    at oracle.ifs.protocols.smb.server.SmbThread.handleNbMessage(Compiled Code)
    at oracle.ifs.protocols.smb.server.SmbThread.readPackets(Compiled Code)
    at oracle.ifs.protocols.smb.server.SmbThread.run(Compiled Code)
    This behavior actually causes us big problems when editing files via MS Office.
    Fortunately Office is able to still save it's data using some generated filename.
    (At least until now I could not create any data loss)
    But then you have to close it, remap then network drive, rename the file and then
    reopen the file. This is big trouble to users, which are not familiar with mapping
    network drives and renaming files with extensions.
    Is there a way to make the SmbServer keep the LibrarySession alive, as long as
    the network drive is mapped ?
    Regards,
    Jens Lorenz

    Workflow #2:
    Login to my account
    Click view all email
    Open Drafts Folder
    Open draft email response
    Select "Send" to send email (total in session time of 30 seconds)
    On screen reload, where I would expect to see some sort of indication that my email was successfully sent, instead the system throws session time out message and kicks me out.
    I have no idea if my email was successfully sent or not.
    Workflow #3:
    Login to my account
    Click view all email
    Attempted to open the first new email in my inbox (total time in session <15 seconds)
    System throws session timeout error and kicks me out to the main login.
    There is obviously something going on with your session holding code. The session variable is not being passed correctly or something but it's very, very frustrating to spend 30-45 minutes trying to type out a couple of lines, particularly when you have multiple important activities going on that you need to respond too via email.

  • Webmail timeouts and lost mail

    I have seen several topics here  with people complaining that Webmail times out when they are composing outgoing mail, and lose it when they hit send. However, none of these existing posts seem to have valid fixes or responses, and they all seem to be locked down to prevent new comments, so here is my two cents:
    1. I have absolutely experienced the same thing. I've finally gotten into the habit of composing e-mail in an external editor, because I am sick and tired of wasting time recomposing lost e-mail.
    2. The Verizon FAQ states two, contradictory policies, both of which are inaccurate:
    http://www22.verizon.com/ResidentialHelp/HighSpeed/Email/Setup+And+Use/QuestionsOne/121965.htm:
    Does Webmail time me out?
    Webmail does not timeout due to inactivity.
    http://www22.verizon.com/ResidentialHelp/HighSpeed/Email/Setup%20And%20Use/QuestionsOne/123344.htm
    Does Webmail time out?
    Due to security reasons, Webmail Basic does timeout after 20 minutes of inactivity. However, messages that were being composed before your session timed out will be saved in the DRAFTS folder.
    The first one is outright wrong. Webmail absolutely, positively DOES time out.
    The second one is wrong, at least in some circumstances. I have no doubt that this is their desired policy, but like many other customers, I'm here to tell you that under at least some circumstances, Webmai-l times out in as little as 5 minutes, and in these same circumstances, IT DOES NOT SAVE YOUR COMPOSED E-MAIL TO THE DRAFTS FOLDER. It simplay takes you to the log in screen, and when you log back in, your text is irretrievably gone. Verizon Webmail has not auto-saved anything for me in at least a year.
    3. I have a theory as to what is going on here, and I am testing it today. Maybe one or two other folks can try this, too. I will report back whatever I find:
    I access Webmail through an old bookmark which is defined as http://netmail.verizon.net/webmail/driver?nimlet=deggetfolder
    However, I notice that if I login fresh from www.verizon.net and navigate to Webmail, I GET DIFFERENT SESSION COOKIES THAN I DO FROM THE ABOVE BOOKMARK. For example, I get a cookie called -_WL_AUTHCOOKIE_VZCSESSIONID which is not present when I log in using the old bookmark.. There are a couple of other variations, but this seems the most suspicious.
    So, my theory is that those of us who often lose composed e-mail after ridiculously short time outs, are logging in from old bookmarks, and that things changed underneath us at some point during a Verizon Webmail update. I am going to try  usng Webmail today from a fresh login, after first clearing out all my existing Verizon cookies, and see if this results in longer sessions without timing out, and saved messages when it does time out.

    Oh, and don't even get me started on SEARCH for text within a message. This has never worked, from Day One.
    All I ever get is "We were unable to perform your request. Please try again." SEARCH on header text, like Sender and Subject works fine, but apparently Verizon QA has never tested the other options on large mail inboxes.
    I'm pretty forgiving and undersrtanding of minor glitches and shortcomings in software, but Verizon Webmail is one of the most unreliable utilities that I've ever encountered from a large company with a huge customer base.

  • NetworkManager timeouts and can't connect

    Hello,
    I have a fresh install of Arch and I'm not succeeding in connecting with Network Manager. I followed the Wiki article, but everytime I run NetworkManager (either through applet or command line), it fails.
    $ nmcli d wifi connect myNetwork
    Error: Timeout 90 sec expired
    (I get prompted for password a few times)
    I checked the general troubleshooting but nothing there seemed to relate to my problem. I'm able to connect with netctl (through wifi-menu), though, which is what I'm using to post here.

    If you're not using a DE or other packages that require it, you might consider chucking NetworkManager.
    I know this isn't really an answer to the question you're asking, but I offer it because I had several networks at my office that I could never connect to with NetworkManager. However, once I switched to connman I haven't had any problems since. Connman doesn't offer an official applet or integration on the level of NetworkManager, but it's much lighter and faster and isn't too hard to configure. The connman wiki article doesn't offer much; I suggest looking at the source's configuration doc for specifics on setting up networks. I'm using qconnman-ui and it seems to work well.

Maybe you are looking for

  • When cmd+shift+d does not work on a mac, here's what to do.

    I have been trying to authorize my new Macbook Pro 2011 for weeks. (I set up and authorized my iPhone with no problem.) Whenever I try to authorize my computer using the Digital Editions instructions given at the bottom of this post, I get the messag

  • Windows 8.1 Password Complexity issue

    Hi All, We are running an AD Domain based on Server 2008 R2 and all of our Clients are Windows 8.1 with all of the latest security patches installed (last WSUS updates at 10-09-14) I am having an issues getting the Password must meet complexity requ

  • Why can't I sign in to my Adobe Story?

    I haven't used it in a while, but I have a few scripts in it. I just clicked on a file on my Mac with the extension ".stdoc" and it asked me to download updates in AIR. I downloaded as asked and now I get "Sorry, an error has occurred. The applicatio

  • Lightroom automaticaly enlarges print size. How do you stop this?

    How do you keep Lightroom from changing the print size? For example, if I have a 4.5 x 7.5 image ( the image size displayed in PS), LR seems to want to make it larger than this size, such that it fits into an arbitrary cell size designated by the "Fi

  • Need information about Enhancement packages

    Hi all, We are planning to implement Enhancement Packages in our Solution Manager server. The primary purpose will be to generate reports for the BI and APO systems configured in the Solman 7.0 system-System status and health check reports. Can anyon