Sg300-28 port-channel options

i have an sg300-28 running the latest firmware, and would like some insight on port-channel options.  below are the port configs i have for a LAG to my router.  i am currently using 802.3ad with LACP.  my router is a linux machine pulling duty as a basic (no dynamic routing) router, firewall and internet gateway.  the bonding options on the routers side explained at
http://docs.fedoraproject.org/en-US/Fedora/16/html/System_Administrators_Guide/sec-Using_Channel_Bonding.html.  the mode is 4 or 802.3ad and the xmit_hash_policy is 2 or layer2+3.  i also have 2 servers setup in a similar fashion with 2 interfaces in a LAG.
when i run a bandwidth test, iperf, between the two servers, i only get 900+ mbps which indicates that the GB ports are running fine.  this also indicates to me that the traffic is not being "striped" across the port-channeled interfaces, thereby giving me the aggregated bandwidth of all interfaces in the LAG.  i have found no options to use the balance-xor mode to create port-channels, which as i understand it, would aggregate the total bandwidth of all interfaces in the LAG.  is the sg300 capable of creating a LAG that will combine the throughput of all the members of the LAG?  for example, create a 2 GB pipe when 2 interfaces are port-channeled?  is the balance-xor mode what would do this (regardless of the sg300's ability to do this)
interface gigabitethernet25
description "Port Channel to Router"                
channel-group 1 mode auto
lldp notifications enable
lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy 802.3-lag 802.3-max-frame-size
lldp management-address automatic
interface gigabitethernet26
description "Port Channel to Router"
channel-group 1 mode auto
lldp notifications enable
lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy 802.3-lag 802.3-max-frame-size
lldp management-address automatic
interface gigabitethernet27
description "Port Channel to Router"
channel-group 1 mode auto
lldp notifications enable
lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy 802.3-lag 802.3-max-frame-size
lldp management-address automatic
interface gigabitethernet28
description "Port Channel to Router"
channel-group 1 mode auto                           
lldp notifications enable
lldp optional-tlv port-desc sys-name sys-desc sys-cap 802.3-mac-phy 802.3-lag 802.3-max-frame-size
lldp management-address automatic
interface Port-channel1
description "Port Channel to Router"
switchport mode general
switchport general allowed vlan add 2-3,25,37,50,52,253-255 tagged
switchport general pvid 255

Hi Brendan,
You said "i only get 900+ mbps which indicates that the GB ports are running fine.  this also indicates to me that the traffic is not being "striped" across the port-channeled interfaces, thereby giving me the aggregated bandwidth of all interfaces in the LAG.  i have found no options to use the balance-xor mode to create port-channels, which as i understand it, would aggregate the total bandwidth of all interfaces in the LAG."
As the Admin guide says on page 130, http://www.cisco.com/en/US/docs/switches/lan/csbms/sf30x_sg30x/administration_guide/78-19308-01.pdf
Load Balancing
Traffic forwarded to a LAG is load-balanced across the active member ports, thus achieving an effective bandwidth close to the aggregate bandwidth of all the active member ports of the LAG.
Traffic load balancing over the active member ports of a LAG is managed by a hash-based distribution function that distributes Unicast and Multicast traffic based on Layer 2 or Layer 3 packet header information.
The switch supports two modes of load balancing:
By MAC Addresses—Based on the destination and source MAC addresses of all packets.
By IP and MAC Addresses—Based on the destination and source IP addresses for IP packets, and destination and source MAC addresses for
non-IP packets.
   So,  an IP host running running IPERF maybe checking unicast throughput between the two IP hosts.  There will be a Source and Desination IP address in that test.  The switch will direct the traffic over one of the LAG port members .  It wont Round robin the unicast traffic over multiple LAG ports, if the Source and Desination IP address of the traffic is the same.  .
If the  PC  running IPerf,  had  another concurrent IPerf session to another or different IP host, the hash algorithm on the switch may direct that stream , maybe, over a different physical LAG interface.
So your comment about  achieving  900+mbps  sounds normal   Yes LAG spreads the load, the benefit comes when lots of hosts on  both sides of the switches.
You hay find with just two hosts on either side of a LAG, that the switch may run the traffic between two hosts over just one member of the LAG group.
regards Dave

Similar Messages

  • VSS port channel options

    Hi,
    I am converting 2 6500 chassis to VSS, currently they are configured as primary & backup. Downstream switch have 4 uplinks,  2 to each chassis with port channels. After I convert to VSS I will have all 4 ports connecting to downstream switch in a port channel, can I keep 2 separate port channels on downstream switch or will it cause issues ?
    thanks
    hasrat

    Hi Hazrat,
    I agree with Reza. By the way what is at your mind in keeping 2 seperate port-channels to one device?(please note after VSS logically it is one switch). One of the Port-channel will not be used at all since spanning tree will block it. So as Reza said bundle them in all one.
    Thanks,
    Madhu

  • SG300 Port-Channel Configuration

    We have an SG300 52P and a SG300 28P that we need to LAG/Trunk together, but have had a hell of a time doing it.  Both switches are updated to 1.3.0.62.  The 52 port switch is configured in layer 3, the 28 port switch in layer 2.  All connectivity that is directly connected to the 52 port works as intended, but no traffic on the 28 port over the port channel to VLANs outside the native VLAN are working.  Strangely too, it is possible to ping the 28 port from a serial connection on the 52 port on the native vlan address, but cannot access the management interface over ethernet.  The last 4 ports of each switch are part of the port channel.
    Here are the two configurations:
    52 Port:
    vlan database
    vlan 2,4,6,8,10,100
    ip dhcp relay address 10.0.4.10
    ip dhcp relay address 10.0.4.14
    ip dhcp relay enable
    ip name-server  10.0.4.10 10.0.4.14
    hostname CORE-SW1
    ip ssh server
    ip ssh pubkey-auth
    snmp-server server
    snmp-server community public ro 10.0.4.5 view Default
    interface vlan 1
    Name ReserverdDefault
    ip address 192.168.0.1 255.255.255.0
    no ip address dhcp
    interface vlan 2
    ip address 10.0.2.1 255.255.255.0
    ip dhcp relay enable
    interface vlan 4
    ip address 10.0.4.1 255.255.255.0
    ip dhcp relay enable
    interface vlan 6
    ip address 10.0.6.1 255.255.255.0
    ip dhcp relay enable
    interface vlan 8
    ip address 10.0.8.1 255.255.255.0
    ip dhcp relay enable
    interface vlan 10
    ip address 10.0.10.1 255.255.255.0
    ip dhcp relay enable
    interface vlan 100
    name Network
    ip address 10.0.0.1 255.255.255.0
    ip dhcp relay enable
    interface gigabitethernet1
    switchport mode access
    switchport access vlan 100
    interface gigabitethernet2
    switchport mode access
    switchport access vlan 100
    (all ports between are configured like ports 1 & 2)
    interface gigabitethernet49
    channel-group 1 mode on
    interface gigabitethernet50
    channel-group 1 mode on
    interface gigabitethernet51
    channel-group 1 mode on
    interface gigabitethernet52
    channel-group 1 mode on
    interface Port-channel1
    description CORELINK
    speed 1000
    no negotiation
    switchport trunk allowed vlan add 2,4,6,8,10
    switchport trunk native vlan 100
    ip default-gateway 10.0.0.254
    28 Port:
    vlan database
    vlan 2,4,6,8,10,100
    ip dhcp relay address 10.0.4.10
    ip dhcp relay address 10.0.4.14
    ip dhcp relay enable
    ip name-server  10.0.4.10 10.0.4.14
    hostname ACC-SW1
    ip ssh server
    ip ssh pubkey-auth
    snmp-server server
    snmp-server community public ro 10.0.4.5 view Default
    interface vlan 1
    Name ReserverdDefault
    no ip address dhcp
    interface vlan 2
    ip dhcp relay enable
    interface vlan 4
    ip dhcp relay enable
    interface vlan 6
    ip dhcp relay enable
    interface vlan 8
    ip dhcp relay enable
    interface vlan 10
    ip dhcp relay enable
    interface vlan 100
    name Network
    ip address 10.0.0.2 255.255.255.0
    ip dhcp relay enable
    interface gigabitethernet1
    switchport mode access
    switchport access vlan 100
    interface gigabitethernet2
    switchport mode access
    switchport access vlan 100
    (all ports between are configured like ports 1 & 2)
    interface gigabitethernet25
    channel-group 1 mode on
    interface gigabitethernet26
    channel-group 1 mode on
    interface gigabitethernet27
    channel-group 1 mode on
    interface gigabitethernet28
    channel-group 1 mode on
    interface Port-channel1
    description CORELINK
    speed 1000
    no negotiation
    switchport trunk allowed vlan add 2,4,6,8,10
    switchport trunk native vlan 100
    Thank you in advance for any assistance that you can provide, I have been tearing my hair out on this
    -Drew       

    The LAG is back up and working on native VLAN 100, but I am still not able to pass other vlan traffic from the L2 to L3 switch.  The switch also took out my switchport trunk native vlan 100 configs on both switches when they were connected.  After I manually put the configuration back the switches were able to communicate.  Here is the current port channel and LAG configurations:
    52:
    interface gigabitethernet51
    description "LAG 3"
    channel-group 1 mode on
    no macro auto smartport
    interface gigabitethernet52
    description "LAG 4"
    channel-group 1 mode on
    no macro auto smartport
    interface Port-channel1
    negotiation 1000f
    description CORELINK
    spanning-tree link-type point-to-point
    switchport trunk allowed vlan add 2,4,10,14
    switchport trunk native vlan 100
    macro description switch
    !next command is internal.
    macro auto smartport dynamic_type switch
    28:
    interface gigabitethernet27
    description "LAG 3"
    channel-group 1 mode on
    interface gigabitethernet28
    description "LAG 4"
    channel-group 1 mode on
    interface Port-channel1
    negotiation 1000f
    description CORELINK
    spanning-tree link-type point-to-point
    switchport trunk allowed vlan add 2,4,10,14
    switchport trunk native vlan 100
    macro description switch
    !next command is internal.
    macro auto smartport dynamic_type switch
    When I try to ping 10.0.4.1 from the 28 port, here is the output:
    Pinging 10.0.4.1 with 18 bytes of data:
    PING: net-unreachable
    PING: net-unreachable
    PING: net-unreachable
    PING: net-unreachable
    ----10.0.4.1 PING Statistics----
    4 packets transmitted, 0 packets received, 100% packet loss
    Thank you again for any assistance you can provide.
    -Drew

  • Port-channel max-bundle option

    Hello,
    if i have a port-channel with 4 ports in it with LACP. And i want to make two ports as a backup with max bundle command. Do that 'backuped' ports will be just "unselected" from etherchannel, o ir will be physical down ? Thanks
    I don't have the LAB yet, so i cant try by myself..

    Hi,
    The additional 2 ports will be in LACP inactive mode.
    HTH

  • OSPF load balancing across multiple port channels

    I have googled/searched for this everywhere but haven't been able to find a solution. Forgive me if I leave something out but I will try to convey all relevant information. Hopefully someone can provide some insight and many thanks in advance.
    I have three switches (A, B, and C) that are all running OSPF and LACP port channelling among themselves on a production network. Each port channel interface contains two physical interfaces and trunks a single vlan (so a vlan connecting each switch over a port channel). OSPF is running on each vlan interface.
    Switch A - ME3600
    Switch B - 3550
    Switch C - 3560G
    This is just a small part of a much larger topology. This part forms a triangle, if you will, where A is the source and C is the destination. A and C connect directly via a port channel and are OSPF neighbors. A and B connect directly via a port channel and are OSPF neighbors. B and C connect directly via a port channel and are OSPF neighbors. Currently, all traffic from A to C traverses B. I would like to load balance traffic sourced from A with a destination of C on the direct link and on the links through B. If all traffic is passed through B, traffic is evenly split on the two interfaces on the port channel. If all traffic is pushed onto the direct A-C link, traffic is evenly balanced on the two interfaces on that port channel. If OSPF load balancing is configured on the two vlans from A (so A-C and A-B), the traffic is divided to each port channel but only one port on each port channel is utilized while the other one passes nothing. So half of each port channel remains unused. The port channel on B-C continues to load balance, evenly splitting the traffic received from half of the port channel from A.
    A and C port channel load balancing is configured for src-dst-ip. B is a 3550 and does not have this option, so it is set to src-mac.
    Relevant configuration:
    Switch A:
    interface Port-channel1
    description Link to B
     port-type nni
     switchport trunk allowed vlan 11
     switchport mode trunk
    interface Vlan11
     ip address x.x.x.134 255.255.255.254
    interface Port-channel3
    description Link to C
     port-type nni
     switchport trunk allowed vlan 10
     switchport mode trunk
    interface Vlan10
     ip address x.x.x.152 255.255.255.254
    Switch B:
    interface Port-channel1
     description Link to A
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 11
     switchport mode trunk
    interface Vlan11
     ip address x.x.x.135 255.255.255.254
    interface Port-channel2
     description Link to C
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 12
     switchport mode trunk
    interface Vlan12
     ip address x.x.x.186 255.255.255.254
    Switch C:
    interface Port-channel1
     description Link to B
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 12
     switchport mode trunk
    interface Vlan12
     ip address x.x.x.187 255.255.255.254
    interface Port-channel3
     description Link to A
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 10
     switchport mode trunk
    interface Vlan10
     ip address x.x.x.153 255.255.255.254

    This is more FYI. 10.82.4.0/24 is a subnet on switch C. The path to it is split across vlans 10 and 11 but once it hits the port channel interfaces only one side of each is chosen. I'd like to avoid creating more vlan interfaces but right now that appears to be the only way to load balance equally across the four interfaces out of switch A.
    ME3600#sh ip route 10.82.4.0
    Routing entry for 10.82.4.0/24
      Known via "ospf 1", distance 110, metric 154, type extern 1
      Last update from x.x.x.153 on Vlan10, 01:20:46 ago
      Routing Descriptor Blocks:
        x.x.x.153, from 10.82.15.1, 01:20:46 ago, via Vlan10
          Route metric is 154, traffic share count is 1
      * x.x.x.135, from 10.82.15.1, 01:20:46 ago, via Vlan11
          Route metric is 154, traffic share count is 1
    ME3600#sh ip cef 10.82.4.0
    10.82.4.0/24
      nexthop x.x.x.135 Vlan11
      nexthop x.x.x.153 Vlan10
    ME3600#sh ip cef 10.82.4.0 internal       
    10.82.4.0/24, epoch 0, RIB[I], refcount 5, per-destination sharing
    sources: RIB 
    ifnums:
    Vlan10(1157): x.x.x.153
    Vlan11(1192): x.x.x.135
    path 093DBC20, path list 0937412C, share 1/1, type attached nexthop, for IPv4
    nexthop x.x.x.135 Vlan11, adjacency IP adj out of Vlan11, addr x.x.x.135 08EE7560
    path 093DC204, path list 0937412C, share 1/1, type attached nexthop, for IPv4
    nexthop x.x.x.153 Vlan10, adjacency IP adj out of Vlan10, addr x.x.x.153 093A4E60
    output chain:
    loadinfo 088225C0, per-session, 2 choices, flags 0003, 88 locks
    flags: Per-session, for-rx-IPv4
    16 hash buckets             
    < 0 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    < 1 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    < 2 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    < 3 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    < 4 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    < 5 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    < 6 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    < 7 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    < 8 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    < 9 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    <10 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    <11 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    <12 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    <13 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    <14 > IP adj out of Vlan11, addr x.x.x.135 08EE7560
    <15 > IP adj out of Vlan10, addr x.x.x.153 093A4E60
    Subblocks:                                                                                  
    None

  • Port Channels - WLC 5508 and 4510

    LACP and PAgP are not supported on the controller and it appears that the 4500 series will not use LAG.
    interface Port-channel10
     description WLC Port-Channel
     switchport
     switchport mode trunk
     service-policy input AutoQos-4.0-Input-Policy
     service-policy output OUTPUT-PRIORITY-POLICING-ETHERCHANNEL
    interface GigabitEthernet3/1
     description Cisco 5508 Wireless Controller 
     switchport mode trunk
     channel-group 10 mode active
     spanning-tree link-type point-to-point
    interface GigabitEthernet3/2
     description Cisco 5508 Wireless Controller 
     switchport mode trunk
     channel-group 10 mode active
     spanning-tree link-type point-to-point
    I am getting the error, "lacp not enabled on remote port..". I removed the 2nd fiber cable and removed the channel-group so I could get the WLC back online. Any help would be greatly appreciated. 

    In order to get the ether channel to work with the WLC you need to change your configuration from:
    interface GigabitEthernet3/1
     channel-group 10 mode active
    interface GigabitEthernet3/2
     channel-group 10 mode active
    To mode ON
    interface GigabitEthernet3/1
     channel-group 10 mode on
    interface GigabitEthernet3/2
     channel-group 10 mode on
    Mode ON tells the switch to do Link Aggregation Protocol and does try and negotiate using one of the two control protocols LACP or PAgP.
    using mode ON is part of the configuration guide when enabling Cisco WLC LAG option.

  • WLC LAG Mode and Port Channel

    So I was reading the controller best practices and got this:
    When you use LAG, the controller relies on the switch for the load balancing decisions on traffic that come from the network. It expects that traffic that belongs to an AP always enters on the same port. Use only ip-src or ip-src ip-dst load balancing options in the switch EtherChannel configuration. Some switch models might use unsupported load balancing mechanisms by default, so it is important to verify.
    This is how to verify the EtherChannel load balancing mechanism:
    switch#show etherchannel load-balance
    EtherChannel Load-Balancing Configuration:
    src-dst-ip
    EtherChannel Load-Balancing Addresses Used Per-Protocol:
    Non-IP: Source XOR Destination MAC address
    IPv4: Source XOR Destination IP address
    IPv6: Source XOR Destination IP address
    This is how to change the switch configuration (IOS):
    switch(config)#port-channel load-balance src-dst-ip
    Now Cisco switches by default will do src-mac.  If I make this change obviously this would be a global change.  I don't believe it should cause any performance issues but wanted to get some expert opinions on this.  Switches my controller will be connected to will also have two routers connected as well via Port Channel.
    I'm trying to understand the reasoning behind this.

    I've never seen that command cause any issues in any deployment I've worked on.
    HTH,
    Steve

  • Port Channel Load-Balancing Algorithm (North Bound)

    I'm trying to figure out what the load balancing algorithm for the 6100 and 6200 FIs for the Northbound connections. I can't find any documentation on how to change it.
    The Nexus 7000s use an 8-bit hash, making it very easy to do something other than 2, 4, or 8 link port channel and get even (at least algorithmically) distribution.
    Catalyst switches (not sure about Sup2T though) would use a 1, 2, or 3-bit index, which would skew traffic algorthmically if you used a non-power of 2.
    Looking at the 5K documentation, it seems to use the Catalyst style (though haven't been able to confirm). My guess is that whatever is used for the 5Ks is used for the 6100/6200.
    Design wise, this would mean you would want to use powers of 2 for your NB uplinks.

    Hello Tony,
    On UCS FI, it uses " sr-cdest-ip " as the load balancing algorithm and uses 8 parameters for hashing
    6248-01-B(nxos)# sh port-channel load-balance
    Port Channel Load-Balancing Configuration:
    System: source-dest-ip
    Port Channel Load-Balancing Addresses Used Per-Protocol:
    Non-IP: source-dest-mac
    IP: source-dest-ip source-dest-mac
    6248-01-B(nxos)# show platform fwm info pc port-channel 1
    dump pc info: if_index 369098752 dump_all 0 verbose 1
    Po1: state 0x0  #pifs 1  fwimpd ctx 0x9666c1c
    Po1: hash params - l2_da 1 l2_sa 1 l3_da 1 l3_sa 1
    Po1: hash params - l4_da 1 l4_sa 1 xor_sa_da 1 hash_elect 1
    I could not find an option to change these values.
    Padma

  • Nexus 1010v interfaces, port-channel, Catalyst 6500E VSS

    I'm installing a pair of 1010v-X appliances using flexible network option 5 on version 4.2(1)SP1(5.1).
    I have all interfaces grouped into a single port channel 6.  All interfaces uplink to a pair of Catalyst 6506Es in a VSS (Sup2T).
    My question relates to the VSS configuration.
    For example, do I set up one port-channel on the VSS and put all 12 interfaces in it? Or, do I set up two port-channels on the VSS and put the active 1010v-X in one port-channel and the standby into another port-channel?
    Do I set dot1q trunking up on the port-channel(s) on the VSS?
    Thanks.

    Hi,
    What version of IOS are you running on the ASAs?
    see table-12-3 in this link:
    http://www.cisco.com/c/en/us/td/docs/security/asa/asa84/configuration/guide/asa_84_cli_config/interface_start.html
    Also, since the 4500x are in VSS mode, you need to bundle one link from each switch and use LACP.
    HTH

  • Applying QoS to a port channel

    Hi,
    I've just applied QoS across our network and everything works fine with one exception. We have a 6509 with PFC running Version NmpSW: 6.1(2). The blade in question is a WS-X6348-RJ-45. Two ports on this blade are running as a port channel and a simple acl has been assigned to the individual ports to trust CoS values, see config below.
    set qos acl ip trustcos trust-cos ip any any
    set port qos 6/11-12 vlan-based
    set qos acl map trustcos 6/48
    set port channel 6/48 mode on
    For some reason the DSCP values are being stripped from packets and left with a dscp/cos value of 0.
    My question is Do I need to apply this acl to the port channel group? If I do, how do I do this. I've seen options for placing port channels into an admin group but I haven't done this yet and can't see any commands that would then allow me to apply an acl to such an admin group.
    Any suggestions would be appriciated.
    regards

    You can implememnt VACLs as described below
    http://www.cisco.com/en/US/products/hw/switches/ps708/products_configuration_guide_chapter09186a0080160a7e.html#wp1054941

  • "The `Inline' mode also supports `Port-Channel'" ?

    Referring to this document:
    http://www.cisco.com/en/US/solutions/collateral/ns340/ns517/ns224/ns377/deployment_guide_c07-490578.html
    it states:
    "The `Inline' mode also supports `Port-Channel', which enables load-balancing and `high-availability' should one of the physical link fails"
    is this true? I have a WAVE-474 which comes with 1 onboard port and 2 inline ports. Can you configure those 2 inline ports in a port channel and then use it with WCCP? I don't believe you can. Not sure what the document is referring too.
    I also have WAVE-574's and that one can do port-channel using two onboard GIG interfaces + WCCP.

    Hi Roman,
    Your judgement was right. You can not configure inline interface in a port channel configuraiton.
    Here is the output from wae-612 running 4.1.5c . You will see that there is no option for port channel / channel-group with inline interface.
    WAE612-3(config)#int inlineGroup ?
      <1-4>/  Slot number
    WAE612-3(config)#int inlineGroup 1/0
    WAE612-3(config-if)#?
      autosense      Interface autosense
      bandwidth      Interface bandwidth
      encapsulation  Set encapsulation type for an interface
      exit           Exit from this submode
      failover       Modify failover parameters
      full-duplex    Interface fullduplex
      half-duplex    Interface halfduplex
      inline         VLAN's to intercept
      ip             Interface Internet Protocol Config commands
      no             Negate a command or set its defaults
      shutdown       Put the inline interface in passthrough mode
    WAE612-3(config-if)#exit
    WAE612-3(config)#int g 1/0
    WAE612-3(config-if)#?
      autosense      Interface autosense
      bandwidth      Interface bandwidth
      cdp            Cisco Discovery Protocol Interface Config commands
      channel-group  Configure EtherChannel group
      description    Interface specific description
      exit           Exit from this submode
      full-duplex    Interface fullduplex
      half-duplex    Interface halfduplex
      ip             Interface Internet Protocol Config commands
      mtu            Set the interface Maximum Transmission Unit (MTU)
      no             Negate a command or set its defaults
      shutdown       Shutdown the specific interface
      standby        Standby interface config commands
    WAE612-3(config-if)#
    Hope this helps.
    Regards.

  • Nexus port channel load balance

    Hi
    I just want to clarify one setting for the port channel load balance on Nexus 6k switch. If I use the load balance option source-dest-ip-only, will following four converstions be load balanced?
    10.10.10.1 -> 192.168.1.1
    10.10.10.2 -> 192.168.1.1
    10.10.10.1 -> 192.168.1.1
    10.10.10.1 -> 192.168.1.2
    Thanks. Leo

    Hi Leo,
    I think there may be typo in your question as I only see three conversations and not four. That aside I've not seen the Nexus port-channel load balancing sufficiently well documented to be able to give you the exact answer.
    In their configuration guides Cisco only include the following statement:
    Cisco NX-OS load balances traffic across all operational interfaces in a port channel by reducing part of the binary pattern formed from the addresses in the frame to a numerical value that selects one of the links in the channel.
    There is other documentation that states the load balancing algorithm uses a CRC-8 based polynomial, but as we don't know exactly which parts of the frame are used in the calculation, I don't see it's possible to calculate the answer and so derive the link that will be used for a given conversation.
    While I've not seen full documentation regarding the science used in the calculation, what Cisco have done is provide a command on the switch CLI that will allow you to determine which link of a port-channel will be used.
    If you run the command show port-channel load-balance forwarding-path interface port-channel vlan src-ip dst-ip then one of the parts of the output is the member link of the port-channel that will be used for that flow.
    You can find full details of the options for the show port-channel load-balance command in the command reference.
    One other point to remember is that the load balancing across a port-channel is unidirectional, and the hashing might be completely different for the return flow of a conversation. For example it is entirely possible that traffic from A to B could use one link of a port-channel, while the return traffic from B to A for the same conversation could use a different link.
    In general I would use the source-dest-port option for load balancing on the Nexus switches as this will obviously include the Layer-4 port numbers in the calculation, and so give you a better distribution of flows across all member links.
    Regards

  • Span port channel

    Hi All,
       Is there any option to span port channel of Cisco 6500 Switch.If possible What is the configuration for the same..
    Pls help..
    Regards,
    Ajith

    Hi,
    You can, but the Portchannel has to be in on mode.  You cannot use it wilt LACP or PAGP.
    Note:
    From Cisco IOS Software Release  12.2(33)SXH and later, PortChannel interface can be a destination port.  Destination EtherChannels do not support the Port Aggregation Control  Protocol (PAgP) or Link Aggregation Control Protocol (LACP) EtherChannel  protocols; only the on mode is supported, with all EtherChannel  protocol support disabled.
    http://www.cisco.com/en/US/products/hw/switches/ps708/products_tech_note09186a008015c612.shtml
    HTH
    Reza

  • Fabric Interconnect Uplink port channeling...

    Hi,
    We setup port channel of two 10G uplink interfaces on each Fabric Interconnect. Everything is running as expected.
    However we noticed that under 'Port-Channel # (Fabric #)' setting on LAN tap, 'Admin Speed' was set to '10Gbps'.
    Should we leave this configuration as is or match to the maximum bandwidth of port Channel we set up (20Gbps)?
    I only see four options on each port channel configuration, 1 Gbps, 10Gbps, 20Gbps and 40Gbps so I'm not sure if we should change this setting.
    Thank you                   

    Hello,
    You do not need to change the speed ( admin ). 20 Gbps configuration is applicable for certain server models.
    --------  NXOS output -----------------
    FI-A(nxos)# sh run int port-channel 1
    interface port-channel1
      description U: Uplink
      switchport mode trunk
      speed 10000
    FI-A(nxos)# show int port-channel 1
    port-channel1 is up
      Hardware: Port-Channel, address: 547f.ee67.e0fb (bia 547f.ee67.e0fb)
      Description: U: Uplink
      MTU 1500 bytes, BW 20000000 Kbit, DLY 10 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA
      Port mode is trunk
      full-duplex, 10 Gb/s
    FI-A(nxos)# sh int bri
    Port-channel VLAN  Type Mode   Status  Reason                    Speed  Protocol
    Interface                                                               
    Po1          1     eth  trunk  up      none                       a-10G(D)  lacp
    There is cosmetic defect where we list the operational speed as 10 Gbps instead of 20Gbps
    FI-A /eth-uplink/fabric # show port-channel detail
    Port Channel:
        Port Channel Id: 1
        Name: FIA
        Admin State: Enabled
        Oper State: Up
       Speed: 10 Gbps
        Oper Speed: 10 Gbps
        State Reason:
        flow control policy: default
    HTH
    Padma

  • PIN GROUP, Port Channel

    Hi, Cisco Gurus:
    Need your authoritative take on the following: Ethernet and FC is all End-Host Mode.
    1. If client is using FC Port Channel on all of the FC Uplinks for the 2 Fabric Interconnects with a SINGLE VSAN on each FI, MUST THEY USE SAN PIN GROUP? Currently, they are pinning the vHBA template to this SAN Pin Group. vHBA-Fabric A pins to FC-PIN-GROUP-A and vice-versa,
    2.
    If FC Port Channel is being used as in 1, from WHICH UCSM option should the VSAN be created?
    Should VSAN be STILL created under the Individual Fabric A and B as before?
    Or
    It have to be Global VSAN or Dual VSAN outside the Fabric A or Fabric B?
    3.If client is using Ethernet Port Channel for each Fabric Interconnet or each fabric, must they use LAN PIN GROUP?
    Currently, they are pinning the vNIC template to this Pin Group (Fabric A & B). vNICA-Fabric A pins to LAN-PIN-GROUP-A and vice-versa.
    Something which I have SELDOM SEE before.
    As usual, I know it is easy meat for Cisco gurus. Thanks, PAL.
    So Long.
    SiM

    All VSANs in the screenshot above are Global.  Notice they're not created under the Fabric A/ B section.
    Unlike "VLANs", which are almost always Global and normally accessible from each Fabric Interconnect, VSANs are different.  Best practice for storage has keeping each SAN Fabric separate.  Keeping this in mind, does it make more sense to create VSANs as global or under their respective Fabric interconnects? (Under the separate Fabric Inteconnects of course.  The only use case for using Global VSANs is as Craig pointed out - when there is a single Storage switch northbound that both Fabric Interconnects uplink to.
    Where this gets confusing is when you're assigning vHBA's to a VSAN. 
    Ex. 
    Let's say, as your customer has done, they've created their two VSAN 10 and 20 as "Global".  For comparison sake I've also created VSAN 100 just under Fabric-A and VSAN 200 just under Fabric-B. Their VSANs would looks like:
    Now, when creating an vHBA under your service profile, you need to assign it to a VSAN.  Take a look:
    So depending which Fabric (A/B) they want the vHBA connected to the options will change.  You can see that by creating the VSANs 10 and 20 as "Global" they appear when either Fabric is selected - Conversly you can see the two 100 and 200 I created under each Fabric, only appear when that fabric is selected.
    So what?  Well if your upstream SAN switches only use one of the respective VSANs configured and only connect to one Fabric Interconnect, then you can potentially "blackhole" your storage traffic by assigning it to the wrong Fabric Interconnect.  Creating the VSANs only under the appropriate Fabric Interconnect prevents this possibility.
    SAN Port-Channels have no bearing on this.  All a SAN Port Channel does is make mulitple FC Uplinks appear as one - which requires SAN Port Channels configured upstream also.  Leaving the FC Uplinks as individual just lets UCS dynamically pin virtual interfaces across the FC uplinks in a round-robin fashion.
    In your case you have no need for Pin-Groups either.  As Jeremy pointed out, unless you have a specific need for them, it's safer to not use them.
    Regards,
    Robert

Maybe you are looking for

  • Not Able to Run A java Program!!!!!!!!!!

    Hi Gurus I have Change my Previos Version of Jdk Now I am getting This Error. Exception in thread "main" java.lang.UnsupportedClassVersionError: test (Unsuppo rted major.minor version 49.0)         at java.lang.ClassLoader.defineClass0(Native Method)

  • Cannot publish new .htm file with Contribute

    A client of mine is having an issue with a webpage he maintains daily using the Contribute package, and one major problem has come up while trying to add new features to his presentation. Instead of linking directly to a file as has been done in the

  • Encore CS4 Mac OS crashes every time during transcoding fo build

    I have tried uninstalling and reinstalling Encore and still have this problem.  When I select to build the DVD it will begin transcoding and will do so for a while, however it eventually crashes before it can complete.  Below is the problem report. P

  • Camera Connect Kit not working with iOS 4.2 software update

    Since updating my iPad software to iOS 4.2 when I try to use my Camera Connect Kit I receive a message saying "Cannot Use Device: the connected USB deivce requires too much power" Can any body help me find a way to fix this problem, or even tell me h

  • Cannot call out or receive calls without getting a busy signal.

    I can't even connect to my own voicemail without this problem happening. I can send and receive text messages just fine, as well as use mobile data. I've removed and replaced the Sim card as well as trying to change the network mode from Global to LT