Single Dynamic Checkbox record

Hi,
I am displaying 1 record with dynamic checkbox with the below
statement
select empno, ename, job,wwv_flow_item.checkbox(1, rownum) pr from emp where rownum = 1
When i hit the Save button i am using onMouseDown event and calling
the javascript function to make sure the checkbox is checked, and then i am submitting the Page.
For SAVE button in the button attributes i have this code: onMouseDown="Members_Selected();".
The below code is used in HTML HEADER:
<script language="JavaScript">
function Members_Selected(){
var bflag;
bflag = false;
alert('total count of check boxes:'+document.forms[0].f01.length);
for (var i=0; i<document.forms[0].f01.length; i++)
if (document.forms[0].f01.checked == true )
bflag = true;
if (!bflag)
alert("Please select Atleast 1 Member.");
return false;
if (confirm("Are you sure you want to assign the selected members !!"))
doSubmit('SAVE');
else
return false;
return true;
}</script>
Below is the problem i see When i HIT the SAVE BUTTON, by Selecting* the checkbox :*_
I see the java script alert : total count is shown as "undefined"
and another javascript alert : 'Please select Atleast 1 Member',
and the page is not submitted.
Have anyone encountered this problem, i have tested in apex workspace too, i see the same problem.
Any help or suggestion is appreciated
Thanks

Hello:
Check if this modified JS works for you function Members_Selected(){
var bflag;
bflag = false;
var arr=new Array();
obj=document.forms[0].f01;
if (obj.length)
    arr=obj;
else
    arr[0]=obj.value;
alert('total count of check boxes:'+arr.length);
for (var i=0; i<arr.length; i++)
if (arr.checked == true )
bflag = true;
if (!bflag)
alert("Please select Atleast 1 Member.");
return false;
if (confirm("Are you sure you want to assign the selected members !!"))
doSubmit('SAVE');
else
return false;
return true;
varad                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           

Similar Messages

  • How to build dynamic databases(record set) for mobile?

    Hi All ,
    i have an applocation that needs to personalize the data for users .
    i have the data available , but dont know how to personalize it fot users to download special version of my application.
    how to build dynamic databases(record set) for mobile?

    In the load rule in the dimension build settings you would need to go to the tab dimension definition, choose the time dimension and right click on it. Select Edit properties. If you have not done so, set the dimension to be the time dimension. Then go to the generations/levels tab and set the generation names you need. For example if you want YTD, you would set the generation name to Year, if you want QTD set it to Quarter. You would set the number to the generation number that coorisponds to the generation. The DBAG has the list of names for all of the DTS members.

  • Dynamically group records by date

    I am attempting to create a report that will dynamically group records into a set number of date buckets.  This is similar to grouping records by a date field and setting the days, weeks, months, etc property but instead of grouping by a set time span I want to a specific number of date groups regardless of date span.  So say i have records where the first date is today at 1am and the last record is today at 9 pm.  I want the data grouped into 10 groups and the time calculated for that group based on total time span / 10.  The first group would be 1AM to 3AM, the second would group 3AM to 5AM, etc..  The reason I am doing this is for a chart that displays record counts over time but the overall timespan will never be known until runtime.  Setting the chart for hourly or weekly doesn't work because if the user runs the report over a year the dates will be illegible.
    Thanks in advance!

    Well this SHOULD be easy. But leave it to CR make not...
    You can start by finding the minimum & maximum dates within your range:
    Local DateTimeVar MinDate;
    MinDate := Minimum({Table.DateField})
    and
    Local DateTimeVar MaxDate;
    MaxDate := Maximum({Person.ModifiedDate})
    Then figure out what the the interval would be if the span is broken down into 10 equal parts"
    DateDiff("n", {@MinDate}, {@MaxDate}) / 10
    From there just use a formula to segregate each records into the appropriate groups:
    EvaluateAfter({@Interval});
    IF {Table.DateField} >= {@MinDate}
        AND {Table.DateField} <= DateAdd("n",{@Interval}, {@MinDate}) THEN 1 ELSE
    IF {Table.DateField} > DateAdd("n",{@Interval}, {@MinDate})
        AND {Table.DateField} <= DateAdd("n",{@Interval} * 2, {@MinDate}) THEN 2 ELSE
    IF {Table.DateField} > DateAdd("n",{@Interval} * 2, {@MinDate})
        AND {Table.DateField} <= DateAdd("n",{@Interval} * 3, {@MinDate}) THEN 3 ELSE
    IF{Table.DateField} > DateAdd("n",{@Interval} * 3, {@MinDate})
        AND{Table.DateField} <= DateAdd("n",{@Interval} * 4, {@MinDate}) THEN 4 ELSE
    IF {Table.DateField} > DateAdd("n",{@Interval} * 4, {@MinDate})
        AND {Table.DateField} <= DateAdd("n",{@Interval} * 5, {@MinDate}) THEN 5 ELSE
    IF {Table.DateField} > DateAdd("n",{@Interval} * 5, {@MinDate})
        AND {Table.DateField} <= DateAdd("n",{@Interval} * 6, {@MinDate}) THEN 6 ELSE
    IF {Table.DateField} > DateAdd("n",{@Interval} * 6, {@MinDate})
        AND {Table.DateField} <= DateAdd("n",{@Interval} * 7, {@MinDate}) THEN 7 ELSE
    IF {Table.DateField} > DateAdd("n",{@Interval} * 7, {@MinDate})
        AND{Table.DateField} <= DateAdd("n",{@Interval} * 8, {@MinDate}) THEN 8 ELSE
    IF {Table.DateField} > DateAdd("n",{@Interval} * 8, {@MinDate})
        AND {Table.DateField} <= DateAdd("n",{@Interval} * 9, {@MinDate}) THEN 9 ELSE
    IF {Table.DateField} > DateAdd("n",{@Interval} * 9, {@MinDate})
        AND {Table.DateField}  <= {@MaxDate} THEN 10
    This is where CR drops the ball... IMHO... it WON'T allow you to to group by a formula field that uses an aggregate in the formula (in this case Minimum & Maximum)... It will however allow to to graph on it, which I assume is what you are actually trying to do.  If anyone knows a way to work around the grouping issue, I'd love to know it myself.
    HTH,
    Jason

  • Dynamic checkboxes with jsp

    Hi,
    I need to create dynamic checkboxes in my jsp page from the values retrived from the database(oracle).help me with the code.My oracle queries are in my Java bean coding.pls its very very urgent.help me out.

    hi,
    This is my bean coding.can u pls tell me how to store the resultset values in a arraylist.help me out.
    package campaign;
    //Imports
    import java.io.*;
    import javax.sql.DataSource;
    import javax.naming.*;
    import com.ibm.ws.sdo.mediator.jdbc.Create;
    import java.sql.*;
    * @author n48edf
    * TODO To change the template for this generated type comment go to
    * Window - Preferences - Java - Code Style - Code Templates
    public class AgentDao extends java.lang.Object implements UnsubscribeConstants
    protected int indivID = 0;
    protected Connection _conn;
    protected DataSource ds = null;
    protected ResultSet rs = null;
    private String driver = null;
    //need to code
    public void agentLoad(IndvId) throws IOException
    String driver = ORACLE_DRIVER;
    String dataSource= ORACLE_DATA_SOURCE;
    try
    //Establish database connection
    if (_conn == null)
    try
    Context context = new InitialContext();
    // JDBC JNDI lookup
    ds = (DataSource)context.lookup(dataSource);
    context.close();
    // Get a connection
    _conn = ds.getConnection();
    catch (Exception exp)
    throw exp;
    // Create a connection statement
    Statement stmt = _conn.createStatement();
    rs = stmt.executeQuery("SELECT DISTINCT busn_org_nm "+
    "FROM BUSN_ORG bo,AGYLOCINDV_RESP_BUSORG ab "+
    "WHERE ab.busn_org_cd=bo.busn_org_cd AND ab.indvid=p_IndvId");
    String array[]=rs;
    stmt.close();
    cleanUp();
    catch ( SQLException sqe )
    System.out.println ("AgentDao.java - SQL Exception: " + sqe.toString());
    sqe.printStackTrace();
    catch ( Exception e )
    System.out.println ("AgentDao.java - Exception: " + e.toString());
    e.printStackTrace();
    finally
    if(_conn != null|| rs != null)
    cleanUp();
    public void cleanUp()
    try
    //close resultset
    if (rs != null)
    rs.close();
    rs = null;
    //close connection
    if(_conn != null)
    _conn.close();
    _conn = null;
    catch (SQLException sqe)
    System.out.println("SQL Exception occurred in cleanUp() of AgentDAO");
    sqe.printStackTrace();
    catch (Exception e)
    System.out.println("Error occurred in cleanUp() of AgentDAO");
    e.printStackTrace();
    }

  • Iphone4 to 6.3.1, not single delete personal records Even deleted

    Why update my iphone4 to 6.3.1, not single delete personal records
    Even deleted, not when the machine is flash back
    I delete the phone number will appear simply no way to single delete records of calls reopen

    Please post in your native language. This makes very little sense in English.

  • LAP dynamic DNS record

    Hi,
    I'm facing some issues to populate dynamically DNS record of APs. The IPs addressing of APs are configured via DHCP servers (MS). The DHCP server is not configured to register automatically record against DNS (MS on the same server); as said by system administrator. The problem is that some APs record are populated on the DNS and some not (even in the same subnet).
    So the question is : Does LAP supports DDNS or the record needs to be done by the DHCP ?
    Thanks a lot
    Vincent 

    Does it simply check AP reachability or will that collect information via SNMP from AP directly.
    If SNMP, this will simply duplicate monitoring (as you already doing it via PI) & could impact the AP performance.
    I would simply give "read-only" view to Prime & briefing them what/how to look something on Prime.
    Not sure how many AP you got, we have close to 2K & I do not want to administer anything like what you are going to do.
    HTH
    Rasika

  • Help with dynamic checkbox from database results

    Hi,
    I am creating some dynamic checkboxes from the results of a database read to sqlite.  I am able to get the data and the correct number of checkboxes is being created but I'm having a problem populating the labels for the checkboxes.  Here is the section of code that gets the results from the database and creates the checkboxes.
                    var result:Array = stmt.getResult().data;
                    for each( var obj:Object in result )
                        var cb:CheckBox = new CheckBox();
                        cb.label = obj.toString();
                        cb.setStyle("color", 0x00593B);
                        cb.setStyle("symbolColor", 0x000000);
                        container.contentGroup.addElement(cb);                   
    Neil

    This was answered on another forum for me.
    The line cb.label = obj.toString();
    needed to be changed to the data.
    cb.label=obj.myDatabaseFieldName;
    myDatabaseFieldName would be whatever column you are pulling the data in from and should be the actual name in the table.
    Neil

  • Why does hitting the Single Field checkbox in QT remove lines from my video?

    Hi, when reviewing my HD video's I see annoying lines. However I went into the video track and hit the Single Field checkbox and they went away. The deinterlace checkbox did absolutely nothing however. Does this simply mean the footage is progressive but quicktime was just reading it wrong initially?
    Very intereseted in knowing the answer.
    All the best
    Kevin

    Ok, maybe you can help me. I was sold some software that was meant to output progressive files in the AVI container with the MJPEG codec. I told him the software seems to be outputting interlaced files and this was his reasoning. Is he correct or is he taking me for a ride? This is a little beyond my knowledge of video systems so if anyone and help me please do.
    They are Progressive Segmented Frames (PsF). This means they are progressive frames but with their information spread across two fields of an interlaced frame. Remember, interlacing is something added to the output of video to facilitate display requirements; it doesn't exist inside your PC. Odd, yes, but this is handy because if you had a true native progressive feed and tried to watch it on a display monitor that only supported interlaced input, you would not get an image. Also, PsF streams allow you to effectively use an interlaced camera to create progressive frames because, again, in a PC or MAC, there is no such thing as interlacing and during capture of each film frame, nothing moves between fields. Everything ends up progressive though carried on interlaced fields.  
    Forget film for a moment: Even when you shoot live video with an interlaced camera, the two successive fields for each frame are ALWAYS handled as one progressive frame inside your NLE, which usually displays only one of the fields during editing while the other field just goes along for the ride unseen. When you output the file or watch it on an external video monitor, the frames are then again broken up into fields to facilitate ease of playback on a variety of displays. If you were to deinterlace that video footage on your NLE, it would drop one field and use the remaining field to artificially create the missing field information to create one progressive frame. However, the output file would then be a PsF file because, even though the frames are now progressive, they are still being carried by an interlaced medium.
    Likewise, when you use your progressive camera to create a live image, believe it or not, the video output is a PsF stream. That means the progressive frames are carried in two successive fields. The PC or Mac doesn't care that the information for each progressive frame arrives in two parts because, as mentioned earlier, the two parts are handled as one frame inside the NLE during editing.

  • How to Controll Dynamic Checkbox Groups

    i want to create checkbox groups dynamically. Each group will have at least one child checkbox. if i select parent check box all child checkboxes should be checked.if i uncheck parent checkbox all child checkboxes should be unchecked.
    that check box group name also coming dynamically. i am trying to pass group name dynamically but it's not recognizing that name in javascript.
    pls help me on this how to controll dynamic checkbox groups.

    recognizing that name in javascript.Are you dynamically creating checkboxes with JSP?

  • Create dynamic checkBox

    Is it possible to create dynamic checkBox inside the loop? I am planning to generate a set of checkBox and then adding them into panels. Is it possible to do it? I have to generate checkBox dynamically.
    Thx.

    I tried as below. Is it right?
    private void createCheckBoxes(List javaFiles) {
            int count = javaFiles.size();
            System.out.println("The number of .tna files are"+count);
            for(int i=0; i<=count-1; i++){
                 System.out.println("Creating checkBoxes");
                 //Create checkbox
                  JCheckBox  box = new JCheckBox("region"+i);
                  box.setName("region"+i);
                dynamicPanel.add(box);
                dynamicPanel.validate();
        }I have few doubts.
    Initially I tried as below:
    JCheckBox  box = new JCheckBox();
    box.setName("region"+i);It created the check boxes dynamically but the name was not printed. Why is that so?
    Now my first set of code works. But how do I refer to these dynamic components?
    Thx.

  • Printing Selected Records thru Dynamic Checkboxes

    Hi,
    How to print records, selected thru checkboxes on the button action ? Everything is dynamically handled. Kindly help.
    Regards
    Mandeep Kaur

    Hi,
    Please check following blog, which may be helpful for this functionality:
    Implementing Copy Down functionality in WebDynpro Java
    /people/abhilash.gampa/blog/2008/01/16/implementing-copy-down-functionality-in-webdynpro-java

  • Create mutiple records w/dynamic checkboxes?

    Greetings
    This is no doubt an easy one, but can't seem to get multiple
    checkboxes displayed dynamically to create corresponding multiple
    records?
    The form page has:
    <form action="add_action.cfm" method="post">
    <cfoutput query="get_all">
    <tr bgcolor="###iif(currentrow MOD
    2,DE('ffffff'),DE('d9ecff'))#">
    <td class="tddynamic">#num#</td>
    <td class="tddynamic">#descriptions#</td>
    <td class="tddynamic"><INPUT Type="Checkbox"
    Name="ID"
    Value="#thequery.ID#"</td>
    Action Page?
    Access, CF8
    Thanks for your time in teaching an old dog new
    tricks...

    Try this:
    <cfoutput query="GetBlogs">
    <tr valign="top">
    <td>
    <input name="BlogID" id="BlogID" type="checkbox"
    value="#BlogID#">  #BlogName#
    </td>
    </tr>
    </cfoutput>
    <cftransaction>
    <cfloop index="i" list="#FORM.BlogID#">
    <cfquery name="Subscription" datasource="#blog#">
    INSERT INTO _subscriptions
    (DateSubscribed, BlogID, SubscriptionStatus, Subscriber,
    SubscriberEmail)
    VALUES
    (getdate(), #i#, 'Active', '#cookie.username#',
    '#cookie.useremail#')
    </cfquery>
    </cfloop>
    </cftransaction>
    Ken Ford
    Adobe Community Expert Dreamweaver/ColdFusion
    Adobe Certified Expert - Dreamweaver CS3
    Fordwebs, LLC
    http://www.fordwebs.com
    "Fineus" <[email protected]> wrote in
    message
    news:gaov4l$809$[email protected]..
    > Hi Ken,
    >
    > I saw one of your postyes on the web heloing someone
    out, and was hoping
    > you
    > might be able to help me out. I am generatign a dynamic
    list of check
    > boxes.
    >
    > <cfoutput query="GetBlogs">
    > <tr valign="top">
    > <td><input name="Subscription_#BlogID#"
    type="checkbox"
    >
    value="#BlogID#">  #BlogName#</td>
    > </tr>
    > </cfoutput>
    >
    > Works great. What I cant seem to get is how to put the
    selections into a
    > database as individual records. I keep getting a BlogID
    undefined error
    > before
    > it even gets to teh insert.
    >
    > <cftransaction>
    >
    > <cfset SubscriptionID =
    Evaluate('Subscription_#(BlogID)#')>
    >
    > <CFQUERY NAME="Subscription" DATASOURCE="#blog#">
    > INSERT INTO _subscriptions(DateSubscribed, BlogID,
    SubscriptionStatus,
    > Subscriber, SubscriberEmail)
    > VALUES(getdate(), '#SubscriptionID#', 'Active',
    '#cookie.username#',
    > '#cookie.useremail#')
    > </CFQUERY>
    >
    > </cftransaction>
    >
    > Any help would be much apprciated
    >
    >

  • Dynamic Checkboxes on Interactive Report

    I have an interactive report that currently lists a row of values:
    Field1
    Val1
    Val2
    Val3
    I would like to place a text-field at the top of this interactive report with a submit button:
    [textbox] [submit button]
    Field 1
    Val1
    Val2
    Va3
    Then I would like to have checkboxes [] appear in each row:
    [textbox] [submit button]
    Field1 | Checkbox
    Val1 | []
    Val2 | []
    Val3 | []
    Then I would like to make it so that the user enters some text into the textbox and selects any number of the row checkboxes. Upon hitting submit, a procedure will run that accepts each Field1 value and inserts a record into a table containing 2 fields: the Field1 value and the textbox text.
    So the following user input:
    [Test text in the textbox.] [submit button]
    Field1 | Checkbox
    Val1 | []
    Val2 | [x]
    Va3 | [x]
    After hitting the submit button, a procedure would be called that would insert 2 records into a table:
    Field1 | Field2
    Val2 | Test text in the textbox.
    Val3 | Test text in the textbox.
    Note that there is no entry for Val1 because its checkbox was not checked when the user pressed submit.
    What can I do to make this happen? I appreciate any help you can offer.

    Thanks for sharing
    I am having exactly the same problem.
    I have an interactive report with the following SQL.
    select RSN_CD,
        DESC,
    APEX_ITEM.CHECKBOX(1,RSN_CD) "Select"
    from CAN_RSN
    I've set the 'Select' column's type to 'Standard Report Column'.  But the checkbox does not appear on the report. 
    Apex Version: 4.0.1.00.03
    Thanks.

  • ASA 5505 9.1 and NAT issues to single dynamic IP

    Good afternoon everybody, 
    a few days ago I tried setting up my ASA 5505 to allow access from the outside network to an Exchange server (ports HTTPS and SMTP) in my inside LAN.
    Everything seems to be working... until my outside IP address changes (for example due to a router reset or a disconnection caused by the ISP). 
    As soon as the outside address changes the NAT rules are deleted and these 2 lines pop up in the syslog :
    <166>%ASA-6-305012: Teardown static TCP translation from inside:192.168.1.150/25 to outside:79.6.105.13/25 duration 0:01:17.
    <166>%ASA-6-305012: Teardown static TCP translation from inside:192.168.1.150/443 to outside:79.6.105.13/443 duration 0:01:17.
    In the same time, the consolle connection shows these two messages :
    Asa5505# ERROR: NAT unable to reserve ports.
    ERROR: NAT unable to reserve ports.
    I have moved both Anyconnect VPN essentials and http ports to 10443 and 8080 respectively so port 443 should be free for nat.
    This is the configuration file, I  have marked the lines related to network objects and relative nat statements, I hope it helps to find out where's the problem.
    Obviously the lines in red are the ones disappearing... I'm quite desperate, actually.
    ASA Version 9.1(5) 
    hostname Asa5505
    domain-name home
    enable password XXXXXX encrypted
    names
    interface Ethernet0/0
     description ADSLPPoE
     switchport access vlan 2
    interface Ethernet0/1
     description Internal_LAN
    interface Ethernet0/2
     description Management_Net 
     switchport access vlan 3
    interface Ethernet0/3
     shutdown
    interface Ethernet0/4
     shutdown
    interface Ethernet0/5
     description Uplink
     switchport trunk allowed vlan 1,3
     switchport trunk native vlan 1
     switchport mode trunk
    interface Ethernet0/6
     description Wireless-POE
     switchport trunk allowed vlan 1,3
     switchport trunk native vlan 1
     switchport mode trunk
    interface Ethernet0/7
     description Webcam-POE 
    interface Vlan1
     nameif inside
     security-level 100
     ip address 192.168.1.250 255.255.255.0 
    interface Vlan2
     nameif outside
     security-level 0
     pppoe client vpdn group AliceADSL
     ip address pppoe setroute 
    interface Vlan3
     no forward interface Vlan1
     nameif management
     security-level 100
     ip address 10.5.1.250 255.255.255.0 
    ftp mode passive
    clock timezone CEST 1
    clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
    dns domain-lookup inside
    dns domain-lookup outside
    dns server-group DefaultDNS
     name-server 192.168.1.4
     domain-name home
    object network Exchange-HTTPS
     host 192.168.1.150
    object network Exchange-SMTP
     host 192.168.1.150
    object network Network_Inside
     subnet 192.168.1.0 255.255.255.0
    object network Network_Management
     subnet 10.5.1.0 255.255.255.0
    access-list Outside_ACL extended permit tcp any object Exchange-HTTPS eq https 
    access-list Outside_ACL extended permit tcp any object Exchange-SMTP eq smtp 
    pager lines 24
    logging enable
    logging asdm warnings
    mtu inside 1500
    mtu outside 1492
    mtu management 1500
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    object network Exchange-HTTPS
     nat (inside,outside) static interface service tcp https https 
    object network Exchange-SMTP
     nat (inside,outside) static interface service tcp smtp smtp 
    object network Network_Inside
     nat (inside,outside) dynamic interface
    object network Network_Management
     nat (management,outside) dynamic interface
    access-group Outside_ACL in interface outside
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    http server enable 8080
    http 10.5.1.0 255.255.255.0 management
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    crypto ipsec security-association pmtu-aging infinite
    crypto ca trustpool policy
    telnet timeout 5
    ssh stricthostkeycheck
    ssh timeout 5
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    management-access management
    vpdn group AliceADSL request dialout pppoe
    vpdn group AliceADSL localname aliceadsl
    vpdn group AliceADSL ppp authentication pap
    vpdn username aliceadsl password ***** store-local
    dhcpd address 192.168.1.100-192.168.1.130 inside
    dhcpd dns 192.168.1.4 192.168.1.150 interface inside
    dhcpd wins 192.168.1.4 interface inside
    dhcpd enable inside
    dhcpd address 10.5.1.30-10.5.1.40 management
    dhcpd dns 208.67.222.222 208.67.220.220 interface management
    dhcpd enable management
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
     port 10443
     anyconnect-essentials
    class-map inspection_default
     match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
     parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
     class inspection_default
      inspect dns preset_dns_map 
      inspect ftp 
      inspect h323 h225 
      inspect h323 ras 
      inspect ip-options 
      inspect netbios 
      inspect rsh 
      inspect rtsp 
      inspect skinny  
      inspect esmtp 
      inspect sqlnet 
      inspect sunrpc 
      inspect tftp 
      inspect sip  
      inspect xdmcp 
    service-policy global_policy global
    prompt hostname context 
    no call-home reporting anonymous
    call-home
     profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:XXXXXXXX
    : end
    no asdm history enable
    Thanks in advance for your precious help !
    C.

    Update 29th of June :
    Tried both suggestions: flashing to 9.22 didn't fix the problem. The only significant change between 9.1(5) and 9.2(2) is that as soon as I reload the configuration after a connection drop both nat rules are restored. In 9.1(5) the nat statements were removed from the runnning configuration when the PPPoE connection was lost, and the config was updated (or maybe saved?), so after a reload those statements were gone and I had to copy-paste them back in conf-t in order to restore them.
    I tried using show xlate both before, during, and after the connection drop. As expected before the disconnection of PPPoE the static PAT rules are there, and the dynamic ones as well. During disconnection, all the xlate table is clean empty and the aforementioned error "Asa5505# ERROR: NAT unable to reserve ports. ERROR: NAT unable to reserve ports." pops up in the terminal. After a few minutes (needed by the DSL modem to perform its reset and bring up the DSL line again) the connection is established once more, but the only rules appearing in xlate are the ones created by the dynamic statements for management and LAN. If i reload the ASA using reload noconfirm every rule is restored and everything works again.
    Two brief questions :
    1) in my NAT statements for PAT, does it change anything if I modify them (for example) from 
    nat (inside,outside) static interface service tcp https https
    to
    nat (inside,outside) dynamic interface service tcp https https 
    ? Since it seems like the dynamic PAT is restored after a connection drop I was asking myself what happens if I change the rules this way.
    2) if there's not any ohter way to fix this, is it possible to schedule a reload of the ASA as soon as the PPPoE connection drops in order to make this problem "self fixing" ? I can't predict how many times a day the line drops and I can't be there 24/7 with my consolle cable connected in order to restore the nat statements ^^
    Thank you for your precious help and patience !
    C.

  • Dynamic Parameter Record Limit

    I am using Crystal 2008 with universes as a data source with BOE XI 3.0 (Edge) Infoview and need to create parameter fields that return greater than 1,000 records.  I have seen suggestions about modifying the local workstation registry, and also found a reference to an earlier version of BOE (SAP Note 1199759) about modifying the LOV batch size for custom sorting.  The latter refers to a Web Intelligence setting, so I'm not sure if it affects parameters in Crystal Reports.
    Which is the correct method to resolve this issue my versions of Crystal and BOE?

    Hi
    we need to make changes for CR so that it fetches more than 1000 records.
    Please refer to 1218588 - How to increase the number of values in a dynamic parameter list and make the necessary registry changes.
    Hope this helps!!
    Regards
    Sourashree

Maybe you are looking for