[SOLVED] I can't get virtual hosts working. What's wrong?

What I've decided to do is try to set up each domain name in the user folder to whom it belongs (for example: /home/username/somedomain.com/htdocs). I can't get it to work though. I keep getting an error saying that there's no index file (although there is) or that the location isn't readable (although it is). I'm trying to make it so that if the domain name matches with a virtual host section in httpd-vhosts.conf that a specific DocumentRoot will be loaded for that domain, etc. But, if the domain name points to my server but doesn't match, then I want the default location to work. I can't seem to make this work.
This is my http.conf:
ServerRoot "/etc/httpd"
Listen 80
LoadModule authn_file_module modules/mod_authn_file.so
LoadModule authn_dbm_module modules/mod_authn_dbm.so
LoadModule authn_anon_module modules/mod_authn_anon.so
LoadModule authn_dbd_module modules/mod_authn_dbd.so
LoadModule authn_default_module modules/mod_authn_default.so
LoadModule authz_host_module modules/mod_authz_host.so
LoadModule authz_groupfile_module modules/mod_authz_groupfile.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule authz_dbm_module modules/mod_authz_dbm.so
LoadModule authz_owner_module modules/mod_authz_owner.so
LoadModule authnz_ldap_module modules/mod_authnz_ldap.so
LoadModule authz_default_module modules/mod_authz_default.so
LoadModule auth_basic_module modules/mod_auth_basic.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule file_cache_module modules/mod_file_cache.so
LoadModule cache_module modules/mod_cache.so
LoadModule disk_cache_module modules/mod_disk_cache.so
LoadModule mem_cache_module modules/mod_mem_cache.so
LoadModule dbd_module modules/mod_dbd.so
LoadModule dumpio_module modules/mod_dumpio.so
LoadModule reqtimeout_module modules/mod_reqtimeout.so
LoadModule ext_filter_module modules/mod_ext_filter.so
LoadModule include_module modules/mod_include.so
LoadModule filter_module modules/mod_filter.so
LoadModule substitute_module modules/mod_substitute.so
LoadModule deflate_module modules/mod_deflate.so
LoadModule ldap_module modules/mod_ldap.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule log_forensic_module modules/mod_log_forensic.so
LoadModule logio_module modules/mod_logio.so
LoadModule env_module modules/mod_env.so
LoadModule mime_magic_module modules/mod_mime_magic.so
LoadModule cern_meta_module modules/mod_cern_meta.so
LoadModule expires_module modules/mod_expires.so
LoadModule headers_module modules/mod_headers.so
LoadModule ident_module modules/mod_ident.so
LoadModule usertrack_module modules/mod_usertrack.so
LoadModule unique_id_module modules/mod_unique_id.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule version_module modules/mod_version.so
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_connect_module modules/mod_proxy_connect.so
LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
LoadModule proxy_http_module modules/mod_proxy_http.so
LoadModule proxy_scgi_module modules/mod_proxy_scgi.so
LoadModule proxy_ajp_module modules/mod_proxy_ajp.so
LoadModule proxy_balancer_module modules/mod_proxy_balancer.so
LoadModule ssl_module modules/mod_ssl.so
LoadModule mime_module modules/mod_mime.so
LoadModule dav_module modules/mod_dav.so
LoadModule status_module modules/mod_status.so
LoadModule autoindex_module modules/mod_autoindex.so
LoadModule asis_module modules/mod_asis.so
LoadModule info_module modules/mod_info.so
LoadModule suexec_module modules/mod_suexec.so
LoadModule cgi_module modules/mod_cgi.so
LoadModule cgid_module modules/mod_cgid.so
LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule vhost_alias_module modules/mod_vhost_alias.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule dir_module modules/mod_dir.so
LoadModule imagemap_module modules/mod_imagemap.so
LoadModule actions_module modules/mod_actions.so
LoadModule speling_module modules/mod_speling.so
LoadModule userdir_module modules/mod_userdir.so
LoadModule alias_module modules/mod_alias.so
LoadModule rewrite_module modules/mod_rewrite.so
#CUSTOM
LoadModule php5_module modules/libphp5.so
<IfModule !mpm_netware_module>
<IfModule !mpm_winnt_module>
User http
Group http
</IfModule>
</IfModule>
ServerAdmin [email protected]
DocumentRoot "/srv/http/default/htdocs"
<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
</Directory>
<Directory "/srv/http/default/htdocs">
Options Indexes FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>
<IfModule dir_module>
DirectoryIndex index.php,index.html
</IfModule>
<FilesMatch "^\.ht">
Order allow,deny
Deny from all
Satisfy All
</FilesMatch>
ErrorLog "/var/log/httpd/error_log"
LogLevel warn
<IfModule log_config_module>
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %b" common
<IfModule logio_module>
# You need to enable mod_logio.c to use %I and %O
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio
</IfModule>
CustomLog "/var/log/httpd/access_log" common
</IfModule>
<IfModule alias_module>
ScriptAlias /cgi-bin/ "/srv/http/cgi-bin/"
</IfModule>
<IfModule cgid_module>
#Scriptsock /var/run/httpd/cgisock
</IfModule>
<Directory "/srv/http/cgi-bin">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>
DefaultType text/plain
<IfModule mime_module>
TypesConfig conf/mime.types
AddType application/x-compress .Z
AddType application/x-gzip .gz .tgz
</IfModule>
# Multi-language error messages
Include conf/extra/httpd-multilang-errordoc.conf
# Fancy directory listings
Include conf/extra/httpd-autoindex.conf
# Language settings
Include conf/extra/httpd-languages.conf
# User home directories
#Include conf/extra/httpd-userdir.conf
# Real-time info on requests and configuration
#Include conf/extra/httpd-info.conf
# Virtual hosts
Include conf/extra/httpd-vhosts.conf
# Local access to the Apache HTTP Server Manual
#Include conf/extra/httpd-manual.conf
# Distributed authoring and versioning (WebDAV)
#Include conf/extra/httpd-dav.conf
# Various default settings
Include conf/extra/httpd-default.conf
#CUSTOM
Include conf/extra/php5_module.conf
<IfModule ssl_module>
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
</IfModule>
And here's my httpd-vhosts.conf:
NameVirtualHost *:80
<VirtualHost *:80>
ServerName 45.117.5.40
ServerAdmin [email protected]
DocumentRoot "/srv/http/default/htdocs"
ErrorLog "/srv/http/default/log/error_log"
CustomLog "/srv/http/default/log/access_log" common
</VirtualHost>
<VirtualHost *:80>
ServerName somedomain.com
ServerName www.somedomain.com
ServerAdmin [email protected]
DocumentRoot "/home/normaluser/somedomain.com/htdocs"
ErrorLog "/home/normaluser/somedomain.com/log/error_log"
CustomLog "/home/normaluser/somedomain.com/log/access_log" common
</VirtualHost>
So, for example, I want it to be so that if I visit http://45.117.5.40 that it'll show the stuff ftom /srv/http/default/htdocs but if the domain name matches somedomain.com then I want the server to show the content from /home/normaluser/somedomain.com/htdocs.
What currently happens is that if I visit http://45.117.5.40 or somedomain.com, they both show the same content from /srv/http/default/htdocs.
If I comment out the first VirtualHost section, then everything stops working and I see the default "Access forbidden!" message.
What am I doing wrong?
Last edited by trusktr (2012-04-13 06:15:41)

I fixed it. In case any newbs come across this, I had to add a new <Directory> section for the DocumentRoot of the virtual host. Simply adding the VirtualHost entry in the vhosts file isn't enough.
For example, for the "somedomain.com" vhost in the example above to work, I added this to http.conf:
#This must match with the same location as DocumentRoot in httpd-vhost.conf.
<Directory "/home/normaluser/somedomain.com/htdocs">
#Put whatever directives you want in here
Options Indexes FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>
Let me know if you need any clarification.
Last edited by trusktr (2012-04-13 06:16:02)

Similar Messages

  • Can't get TouchEvent to work, what is wrong with my code?

    Hello,
    I am trying to get a touch event to trigger.  Using my Motorola Droid 2 phone, I can get a MouseEvent to trigger, but I can't get a TouchEvent to trigger that would change text on screen.
    I am using an AIR For Android Template in Flash Pro CS5.
    Here is my code:
    package  {
         import flash.display.MovieClip;
         import flash.events.TouchEvent;
         public class Document extends MovieClip {
             public function Document() {
                  stage.addEventListener(TouchEvent.TOUCH_TAP, testing);
             public function testing(event:TouchEvent){
                  debugTestbox.text = "Hello"
    This results in nothing hapening.
    However, when I make it a MouseEvent instead, it works.
    Am I using TouchEvent wrong?  If so, what is the correct way?
    Thank you in advance.
    Edit: Nevermind, I figured something out.  I imported Multitouch and MultitouchInputMode, then set Multitouch.inputMode to MultitouchInputMode.TOUCH_POINT and then replaced TouchEvent.TOUCH_TAP with TouchEvent.TOUCH_BEGIN.  I'm gussing TOUCH_TAP is buggy because it didn't work even after making the previous changes.  Regardless, TOUCH_BEGIN works for what I need.

    Hello,
    Take a look now everything should be working you just caught us in the middle of and upgrade.
    Carl

  • HELP!  I deleted my ipad email and re entered it and now I can't get any email?  What's wrong with this picture?

    i was was having problems with email and thought let's start from beginning so I dumped my email account which is att using yahoo and this morning I can't get any of my emails or send email,  anyine have any ideaS? 
    <Email Edited By Host>

    What email app are you using: ios mail or yahoo mail app?  You could try switching your email app.
    My yahoo mail app wouldn't accept my password for my id a few days ago.  I have not sorted it out yet.  Happened after I download a new version of the yahoo app.  Waiting for a new version of the app.  Reading my mail on my laptop instead.
    Robert

  • [SOLVED] I can't get rar to work.

    Hi all,
    I've installed rar and followed the wiki and I still can't extract. I just get "bash: rar: command not found"
    Can anyone provide any assistance?
    Last edited by guriinii (2010-09-24 11:47:13)

    How exactly did you install rar?
    'unrar' package provides a means of extracting rar archives, but it's not the same as the 'rar' package (which enables you to both create and extract rar archives). The former is available in the official repos, the latter isn't.
    You can add
    [archstuff]
    # AUR's most voted packages
    Server = http://archstuff.vs169092.vserver.de/i686
    to your pacman.conf, run 'pacman -Syy' and 'pacman -S rar' to install 'rar' package.
    Alternatively, you can call unrar instead of rar in the extract script.
    If it still doesn't work, post again.
    Last edited by karol (2010-09-24 11:25:43)

  • My scrollbar on my mouse pad on my laptop won't work since I downloaded the 4.0 version. I tried what some other people tried but I still can't get it to work.What can I do to fix it?

    I just download the 4.0 version and my scroll pad on my laptop won't work. I have to use my arrow keys or the side bar on the side. The scroll pad works with Internet Explorer and anywhere else just not with Firefox's newest version.

    This one is easy. The shortcut is for the old iTunes, that is why it won't work.
    I assume you are using Windows.
    If so, go to the bottom left of your screen and click the start button. Go up to programs and hold your cursor over it. A list of all your programs should pop up to the right. Move the curso over to iTunes. There should be an "about iTunes" and an iTunes logo there. Right click on the iTunes logo and click create shortcut (you can also just drag it out to your desktop). That will give you a desktop shortcut for your new version.

  • Ff won't work on windows and can't get maintanence to work what do i do?

    ff says its compatible,but windows says otherwise.ff freezes in the middle of anything, manly while loading a page.maintanence won't work at all help me!

    How about trying a previous build of Firefox? Then, if that works, upgrade again to the next version until you find the culprit. Then, just stay with the previous build!

  • I have Elements 12. I can't get it to work. I bought it in April nand havent used it yet.

    The person on Chat told me to come here for a solution. Apparently I need some sort of an upgrade because it is a "technical issue." What do I do?

    calamity janie wrote:
    The person on Chat told me to come here for a solution. Apparently I need some sort of an upgrade because it is a "technical issue." What do I do?
    You need to tell us more.  When you say "I can't get it to work" what exactly do you mean.  Can you launch it and get to the welcome screen?  Alternatively, tell us how far can you go when you launch the product.

  • I've installed it and can't get it to work

    I did the uninstall, reinstalled, checked settings, and can't get it to work.

    What is your operating system & version?
    What is your web browser?
    And what exactly means "can't get it to work"?

  • Pogo says my flash player is out dated and i cant get it to work what do i do to get it to work. it says on the computer that i have it

    pogo says my flash player is outdated but I can't get it to work. what do I do to get it to work? my computer says that I have the flash player. Help

    Hi Christina,
    Can you visit this page, click the "Check Now" button and please copy/paste the information shown?  That'll help us determine if Flash is running and what browser and operating system is being reported.
    Flash Player Help
    Thanks,
    Chris

  • Tomcat7 fails can not load virtual host directory [solved]

    I have a new installation of timcat7 setup. The default apps work fine.
    I have a virtual host setup in my home directory but tomcat gies the following erro and it does nto work:
    "SEVERE: Application base [/home/doug/Sites/localcity] for host [localcity] does not exist or is not a directory. deployOnStartUp and autoDeploy have been set to false to prevent deployment errors. Other errors may still occur."
    This is an extract of ls -la of ~/Sites
    drwxrwxr-x  2 tomcat tomcat 4096 Apr 25 12:05 localcity
    I have the exact same setup on a different machine and can not see any differences. Any clue as to what I can do get get this host working?
    I am in the group 'tomcat'.
    Last edited by hypoglycemic (2012-06-05 12:41:54)

    I changed back to the dafault host location of webapps with the examples in it to test if it some larger problem than hosts. It looks liek it is becasue thsi is the log output on start up:
    May 26, 2012 3:07:33 PM org.apache.catalina.core.StandardContext postWorkDirectory
    WARNING: Failed to create work directory [/usr/share/tomcat7/work/Catalina/localcity/manager] for context [/manager]
    May 26, 2012 3:07:34 PM org.apache.catalina.util.SessionIdGenerator createSecureRandom
    INFO: Creation of SecureRandom instance for session ID generation using [SHA1PRNG] took [741] milliseconds.
    May 26, 2012 3:07:34 PM org.apache.jasper.EmbeddedServletOptions <init>
    SEVERE: The scratchDir you specified: /usr/share/tomcat7/work/Catalina/localcity/manager is unusable.
    May 26, 2012 3:07:34 PM org.apache.catalina.startup.HostConfig deployDirectory
    INFO: Deploying web application directory /var/lib/tomcat7/webapps/docs
    May 26, 2012 3:07:34 PM org.apache.catalina.core.StandardContext postWorkDirectory
    WARNING: Failed to create work directory [/usr/share/tomcat7/work/Catalina/localcity/docs] for context [/docs]
    May 26, 2012 3:07:34 PM org.apache.jasper.EmbeddedServletOptions <init>
    SEVERE: The scratchDir you specified: /usr/share/tomcat7/work/Catalina/localcity/docs is unusable.
    May 26, 2012 3:07:34 PM org.apache.catalina.startup.HostConfig deployDirectory
    INFO: Deploying web application directory /var/lib/tomcat7/webapps/host-manager
    May 26, 2012 3:07:34 PM org.apache.catalina.core.StandardContext postWorkDirectory
    WARNING: Failed to create work directory [/usr/share/tomcat7/work/Catalina/localcity/host-manager] for context [/host-manager]
    May 26, 2012 3:07:34 PM org.apache.jasper.EmbeddedServletOptions <init>
    SEVERE: The scratchDir you specified: /usr/share/tomcat7/work/Catalina/localcity/host-manager is unusable.
    May 26, 2012 3:07:34 PM org.apache.catalina.startup.HostConfig deployDirectory
    INFO: Deploying web application directory /var/lib/tomcat7/webapps/ROOT
    May 26, 2012 3:07:34 PM org.apache.jasper.EmbeddedServletOptions <init>
    SEVERE: The scratchDir you specified: /usr/share/tomcat7/work/Catalina/localcity/_ is unusable.
    May 26, 2012 3:07:34 PM org.apache.catalina.startup.HostConfig deployDirectory
    INFO: Deploying web application directory /var/lib/tomcat7/webapps/examples
    May 26, 2012 3:07:34 PM org.apache.catalina.core.StandardContext postWorkDirectory
    WARNING: Failed to create work directory [/usr/share/tomcat7/work/Catalina/localcity/examples] for context [/examples]
    May 26, 2012 3:07:35 PM org.apache.catalina.core.ApplicationContext log
    INFO: ContextListener: contextInitialized()
    May 26, 2012 3:07:35 PM org.apache.catalina.core.ApplicationContext log
    INFO: SessionListener: contextInitialized()
    May 26, 2012 3:07:35 PM org.apache.jasper.EmbeddedServletOptions <init>
    SEVERE: The scratchDir you specified: /usr/share/tomcat7/work/Catalina/localcity/examples is unusable.
    May 26, 2012 3:07:35 PM org.apache.catalina.core.ApplicationContext log
    INFO: ContextListener: attributeAdded('org.apache.jasper.compiler.TldLocationsCache', 'org.apache.jasper.compiler.TldLocationsCache@6098f192')
    May 26, 2012 3:07:35 PM org.apache.coyote.AbstractProtocol start
    INFO: Starting ProtocolHandler ["http-bio-8080"]
    May 26, 2012 3:07:35 PM org.apache.catalina.startup.Catalina start
    So there is something wrong with the installation itself. I have pacman -R it followed by a -S but the problem remains.
    Is there someway to really super duperly remove the everythign related to tomcat to really truely remove ever trace so that it should rever to normal behaviour?

  • [SOLVED] Can't get sound to work.

    Hello, I installed archlinux a few days ago, I love it!
    But I can't get sound to work.
    I followed the alsa archwiki, but I still couldn't get it work.
    I'm a real noob.
    Someone please help.
    Last edited by egb (2011-02-16 22:45:12)

    JokerBoy wrote:
    Inxsible wrote:
    Try this: as your user NOT root
    alsamixer
    why not? i use alsamixer as root to set all "globally". and "alsactl store" after that.
    egb - make also sure you added yourself to audio group.
    yeah, I did that some time ago
    edit: oh and I get this when I do the "alsactl store":
    alsactl: save_state:1504: No soundcards found...
    Last edited by egb (2011-02-16 10:30:34)

  • Can't get sound to work [SOLVED]

    Hi, I'm new to arch/linux in general. Built a computer, and can't get sound to work. I ran Ubuntu for a short period of time, and sound worked there, so I'm assuming there's no hardware issue here.
    I'm a little bit stuck as to what I should be doing. Help?
    Last edited by uma (2012-01-28 22:51:25)

    Start with the wiki: https://wiki.archlinux.org/index.php/Ad … chitecture
    If you still can't figure it out and you want help, at least post some info, instead of 'can't get it to work' (this implies that you tried something, but what?).

  • ACE - Can not get it to work

    All,
    I am trying to configure simple load balancing to 4 servers on a ACE (ver 3.0.0A13B), but I can't get it to work.
    See config below. I have L3 vlan interfaces on my Cat6513 for vlan 22, 29 and 121.
    Can anyone spot the issue?
    Thanks, Pieter-Jon
    probe tcp TCP
    description TCP PROBE
    interval 2
    faildetect 2
    passdetect interval 2
    connection term forced
    open 2
    parameter-map type connection IDLE
    set timeout inactivity 600
    rserver host INFO-Realserver-1
    ip address 38.22.175.1
    probe TCP
    inservice
    rserver host INFO-Realserver-2
    ip address 38.22.175.2
    probe TCP
    inservice
    rserver host INFO-Realserver-3
    ip address 38.22.175.3
    probe TCP
    inservice
    rserver host INFO-Realserver-4
    ip address 38.22.175.4
    probe TCP
    inservice
    serverfarm host INFO2008
    predictor leastconns slowstart 15
    probe TCP
    rserver INFO-Realserver-1
    inservice
    rserver INFO-Realserver-2
    inservice
    rserver INFO-Realserver-3
    inservice
    rserver INFO-Realserver-4
    inservice
    class-map match-all L4_VIP_ADDRESS_CLASS
    2 match virtual-address 38.29.250.250 tcp any
    class-map type management match-any MGMT-Class
    2 match protocol icmp any
    3 match protocol ssh any
    4 match protocol telnet any
    class-map type management match-all SNMP_ALLOW_CLASS
    2 match protocol snmp any
    class-map type management match-all TELNET_ALLOW_ALL
    2 match protocol telnet any
    policy-map type management first-match MGMT-Policy
    class MGMT-Class
    permit
    policy-map type management first-match REMOTE_MGMT_ALLOW_POLICY
    class TELNET_ALLOW_ALL
    permit
    policy-map type management first-match SNMP_ALLOW_POLICY
    class SNMP_ALLOW_CLASS
    permit
    policy-map type loadbalance first-match L7_VIP_LB_ORDER_POLICY
    class class-default
    serverfarm INFO2008
    policy-map multi-match L4_LB_VIP_POLICY
    class L4_VIP_ADDRESS_CLASS
    loadbalance vip inservice
    loadbalance policy L7_VIP_LB_ORDER_POLICY
    loadbalance vip icmp-reply
    loadbalance vip advertise
    interface vlan 22
    description Info Servers vlan
    ip address 38.22.1.250 255.255.0.0
    no shutdown
    interface vlan 29
    description Info Front End vlan
    ip address 38.29.1.250 255.255.0.0
    service-policy input L4_LB_VIP_POLICY
    service-policy input REMOTE_MGMT_ALLOW_POLICY
    no shutdown
    interface vlan 121
    ip address 38.121.6.1 255.255.0.0
    service-policy input REMOTE_MGMT_ALLOW_POLICY
    service-policy input SNMP_ALLOW_POLICY
    no shutdown
    ip route 0.0.0.0 0.0.0.0 38.121.1.1

    > I have L3 vlan interfaces on my Cat6513 for vlan 22, 29 and 121.
    That is your problem first of all.
    If i get it right from your config.
    VLAN 121 is your transfer network / or client side vlan
    VLAN 22 and VLAN 29 are Server VLANS?
    What you should keep in mind is that you define the server side vlans only on the ACE contexts with L3. You don't define them on the supervisor.
    If you use the ACE in routed mode you have to assign networks exclusive to the ace like routing networks to a layer 3 device in your network. If you use those vlans (22,29) on other parts of your net you should subnet them or take another network.
    Your setup should look like this.
    6513
    L3 ~ VLAN 121
    L2 ~ VLAN 22,29,121
    ACE Module
    L3 ~ VLAN 22,29,121
    You assign the 3 vlans or any other to a vlan group and assign this group to the ace module.
    Create a new context -> assign the vlan 22,29 and 121 to this context.
    6513(L3) <-- vlan 121 --> ACE (L3) /Admin Context
    6513(L3) <-- vlan 121 --> ACE(L3) / Server Context --> VLAN 22,29
    ACE Admin Context (VLAN121)
    ACE Server Context (VLAN 121,22,29)
    After you have a working L2/L3 setup start troubleshooting the ace config itself. :)
    Hope it helps
    Roble

  • I have a Mac Mini and I can't get it to work with my Ricoh Aficio MP 161.  Any ideas?

    I have a Mac Mini and I can't get it to work with my Ricoh Aficio MP 161.  Any ideas?

    The latest Apple driver support begins with the MP 171.
    Here is Ricoh's official driver download page specifically for the Afico MP 161. Note that new drivers for this device were released on Aug 2, and include Lion and Mountain Lion.
    Hopefully, this will solve your device issues.

  • Cisco 1812 wireles setup, can't get it to work

    Hello everyone,
    I've read trough the "871 wireless setup" topic, which I found very helpful, but I still can't get my wireless working. Basically I have a Cisco 1812W and I would like both wireless and wired to be on the same subnet. We aren't using DHCP, so the IP's are all static (even for the wireless clients). I can connect to my wireless SSID, but ping doesn't go trough either way. Wired connections are working fine. So the wireless client is connected, but has no IP address as far as the router goes (show Dot11 associations shows it's IP as 0.0.0.0) , but the wireless client does have an IP set up.
    I guess I'm overlooking something in my config, so here it is (i took out the firewall rules and aaa setup, they aren't relevant if i'm not mistaken and there's a limit to post size):
    ip cef
    ip tcp synwait-time 10
    no ip bootp server
    ip name-server <removed>
    ip name-server <removed>
    crypto pki trustpoint TP-self-signed-1358229530
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1358229530
    revocation-check none
    rsakeypair TP-self-signed-1358229530
    crypto pki certificate chain TP-self-signed-1358229530
    certificate self-signed <removed>
    quit
    username <removed>
    bridge irb
    interface Null0
    no ip unreachables
    interface FastEthernet0
    description $ETH-WAN$$FW_OUTSIDE$
    ip address extip extsubnet
    ip access-group 101 in
    ip verify unicast reverse-path
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nbar protocol-discovery
    ip flow ingress
    ip flow egress
    ip nat outside
    ip inspect sdm_ins_in_100 in
    ip inspect SDM_MEDIUM out
    ip virtual-reassembly
    ip route-cache flow
    duplex auto
    speed auto
    interface FastEthernet1
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    shutdown
    duplex auto
    speed auto
    interface BRI0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    encapsulation hdlc
    ip route-cache flow
    shutdown
    interface FastEthernet2
    interface FastEthernet3
    interface FastEthernet4
    interface FastEthernet5
    interface FastEthernet6
    interface FastEthernet7
    interface FastEthernet8
    interface FastEthernet9
    interface Dot11Radio0
    description 802.11g
    no ip address
    encryption mode ciphers tkip
    ssid <removed>
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii 7 <removed>
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    station-role root
    bridge-group 1
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    interface Dot11Radio1
    description 802.11a
    no ip address
    shutdown
    encryption key 1 size 40bit 7 1ED10A3EC0C5 transmit-key
    encryption mode wep mandatory
    speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
    station-role root
    interface Vlan1
    description $FW_INSIDE$
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip virtual-reassembly
    ip route-cache flow
    bridge-group 1
    interface BVI1
    ip address <internal router ip> <subnet>
    ip access-group 100 in
    ip nat inside
    ip virtual-reassembly
    ip route 0.0.0.0 0.0.0.0 <external router IP> permanent
    ip flow-top-talkers
    top 5
    sort-by bytes
    ip http server
    ip http access-class 1
    ip http authentication local
    ip http secure-server
    <bunch of static nats>
    <access rules>
    no cdp run
    radius-server attribute 32 include-in-access-req format %h
    radius-server vsa send accounting
    control-plane
    bridge 1 protocol ieee
    bridge 1 route ip
    line con 0
    line aux 0
    line vty 0 4
    access-class 102 in
    password 7 <removed>
    transport input ssh
    scheduler allocate 4000 1000
    webvpn context Default_context
    ssl authenticate verify all
    no inservice
    end

    Okay, I've somewhat figured it out. Apparently my WPA-PSK configuration doesn't work with the integrated Broadcom adapter found in the laptop I was testing it with.
    Either that or my WPA-PSK configuration is broken.
    I switched over to an open network with no encrpytion and everything works now.

Maybe you are looking for

  • Head Office field in Vendor Master

    Hi,    We have entered a Head Office Vendor in the Vendor master ( Branch). Now at the time of PO creation system has correctly fetched the Branc Vendor address. When we are trying to post the Vendor Invoice we are getting error "Different invoicing

  • Error message in PBO module

    Hi, I want to display an error message in status bar. my validation is in PBO and m writing there - message e010 with 'error msg...' but when the respective screen(300) is displayed, its showing an error msg pop up and only option to exit. I want to

  • TS1702 Why are my pics in iPhoto on my iPad different than the pics in the same album in iPhoto on my iMac?

    Why are my album pics in iPhoto on my iPad different than the pics in the same album on my iMac?

  • Sign in Issue on pc but not on Lync throughOWA.

    Hello, We have an issue with one of our users. He is able to use Lync through OWA but not with Lync 2010 client. Our infrastructure is Lync Server 2013 On-Premise + Exchange 2010 On-Premise. I tried to sign-in my own computer with his account without

  • Why it is heating

    I Have an Problem is the Phone Heating ..!! It get's too much of Heat when I use the 3g