[SOLVED]Route connection to specified ip via specified interface

Hello,
I have 2 interfaces eth0 and wlan0
eth0 is connected to network with limited access outside(high bandwidth).
wlan0 is connected to network with unlimited access outside(low bandwidth).
What I want to achieve is to route specified ip via wlan0
I tried to route by "add" but it didn't work.
Please help.
ip route add x.x.153.202 via 192.168.1.73
[root@lukasz-dell7720 lukasz]# ip route list
default via 192.168.10.1 dev enp3s0 metric 202
default via 192.168.1.1 dev wlp2s0 metric 303
x.x.153.202 via 192.168.1.73 dev wlp2s0
192.168.1.0/24 dev wlp2s0 proto kernel scope link src 192.168.1.73 metric 303
192.168.1.73 via 127.0.0.1 dev lo metric 303
192.168.10.0/24 dev enp3s0 proto kernel scope link src 192.168.10.149 metric 202
192.168.10.149 via 127.0.0.1 dev lo metric 202
Last edited by str0gg (2014-01-02 12:01:23)

Define "didn't work" -- the route you added is in the route table from what you've posted.
EDIT: Are you sure 192.168.1.73 is the correct gateway? Your other 2 gateways appear to be 192.168.10.1 and 192.168.1.1
Last edited by fukawi2 (2013-12-31 12:21:57)

Similar Messages

  • Connecting to exchange server via web interface?

    Employer's exchange server has IMAP disabled and IT will not consider adding activesync for iPhone 2.0. Using the web interface via Safari is way too hard on an iPhone to be practical except in emergencies.
    Question: The new version of Entourage allows for retrieval and sync through a connection to the exchange web interface. It behaves just like it's connected directly to the exchange server, but is hitting exchange's web server.
    Is there anything like this for iPhone? Any way to retrieve mail into the native mail application (rather than web app) by polling the exchange web server?

    A few things. Neither will give you the functionality you seem to be after.
    1) Use Exchange OMA service (text based view via web) very quick compared to the full image web based application. Has read/write functionality but you are not going to want to write an email via this.
    2) Outlook 2007 supports http: access. You could use that to pull the data from your work account to say a home PC and sync your iPhone (albeit once a day).
    3) Ask them to install iTunes 7.7 on your work PC so you can sync (I think I know how this would go down in a company )

  • Connecting Two ASAs together via local interface

    Hi
    I have two cisco ASA routers & wish to connect them together so that traffic between is permitted with out going outside interface.
    Two asa are located at in ONE office and two have separate internet connection (ISP) configured.
    So here is what I did so far.
    configure one of the interface on each ASA with some IP adddress.
    ASA 1  ------- interface 0/6   10.1.1.1  (ASA X 1512)
    ASA 2 --------- interface 0/5  10.2.2.2  (ASA 5055)
    now connected a Ethernet cable to these inferface.
    I was able to addd a route on asa 2.
    route add interface0/5 10.1.1.0/24  10.2.2.2
    but when I add route on ASA 1 I get the following error.
    route add interface0/6 10.2.2.2/24  10.1.1.1
    %invalid next hop address it belongs to one of our interface.

    Sorry if I was not clear
    I have two separate ISPs connecting two two separate ASAs.. Two asa are now connecting separate LANs.
    Now I want to communicate between LANs.
    So I connected an ethernet cable bw ASAs and trying to configure the route.
    But not able to establish
    Here is the configuration of ASA where I am faceing problem, while trying to add route
    route add voice-interface 10.1.1.1/24  255.255.255.0  10.2.2.2 1
    I get error says
    route already exsists
    interface GigabitEthernet0/0
    nameif outside0
    security-level 0
    ip address 0.2.5.2 255.255.255.252
    interface GigabitEthernet0/1
    shutdown
    no nameif
    no security-level
    no ip address
    interface GigabitEthernet0/2
    nameif inside2
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    interface GigabitEthernet0/5
    nameif voice-interface
    security-level 100
    ip address 10.1.1.1 255.255.255.0
    object network NETWORK_OBJ_12.1.3.0_2
    subnet 12.1.3.0 255.255.255.0
    object network NETWORK_OBJ_192.168.1.0_24
    subnet 192.168.1.0 255.255.255.0
    object network OBJ_ALL_NETWORK
    subnet 0.0.0.0 0.0.0.0
    description Any Network
    object network voice-asa-network
    subnet 10.2.2.0 255.255.255.0
    object network 10.1.1.1
    host 10.1.1.1
    access-list outside0_cryptomap extended permit ip 192.168.1.0 255.255.255.0 12.1.3.0 255.255.255.0
    access-list inside2_access_in extended permit ip 192.168.1.0 255.255.255.0 any
    nat (inside2,outside0) source static NETWORK_OBJ_192.168.1.0_24 NETWORK_OBJ_192.168.1.0_24 destination static NETWORK_OBJ_12.1.3.0_24 NETWORK_OBJ_12.1.3.0_24 no-proxy-arp route-lookup
    object network OBJ_ALL_NETWORK
    nat (any,outside0) dynamic interface
    route outside0 0.0.0.0 0.0.0.0 0.2.5.2 1
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS mode transport
    crypto ipsec security-association pmtu-aging infinite
    crypto map outside0_map 1 match address outside0_cryptomap
    crypto map outside0_map 1 set pfs
    crypto map outside0_map 1 set peer 9.2.5.1
    crypto map outside0_map 1 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside0_map 1 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
    crypto map outside0_map interface outside0
    crypto ca trustpool policy
    crypto ikev2 policy 1
    encryption aes-256
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 10
    encryption aes-192
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 20
    encryption aes
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 30
    encryption 3des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    threat-detection basic-threat
    threat-detection scanning-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ssl encryption aes128-sha1 3des-sha1
    group-policy GroupPolicy_6.2.5.1 internal
    group-policy GroupPolicy_6.2.5.1 attributes
    vpn-tunnel-protocol ikev1 ikev2
    class-map inspection_default
    match default-inspection-traffic

  • ORA-12154 could not resolve the connect indentifier specified

    [http://www.freeimagehosting.net/image.php?793d240bb3.jpg]
    when i try to install oracle 10g i find this problem i wish you help me

    user473080 wrote:
    [http://www.freeimagehosting.net/image.php?793d240bb3.jpg]
    when i try to install oracle 10g i find this problem i wish you help meIn the future please work from a command line and use copy and paste to put commands and results in your posts. Many people's corporate nets block access to blog sites.
    I have recently blogged extensively on this very subject. See edstevensdba.wordpress.com. I can't post a link to the exact article, because my corporate website blocks access to blog sites. I have also, many many times posted on this error in this forum, which a cursory search would have turned up. But once again, back by popular request:
    =================================
    ORA-12154: TNS:could not resolve the connect identifier specified
    This error means one thing, and one thing only. The client could not find the specified entry in the tnsnames.ora file being used.
    As a follow-on to that statement, remember that when you use a dblink, the database in which the link is defined is acting as a client to the database that is the target of the link. So in this case, the tnsnames.ora file on the host of your source should have an entry for your target db, as defined in the db_link.
    And for the umpteenth time ... this error has <b><i><u>NOTHING</u></i></b> to do with the status of a listener. The connection request never got far enough to reach a listener. If anyone tells you to check a listener in response to ora-12154, they are not paying attention, or do not understand how TNS works. This error is the equivalent of not being able to place a telephone call because you don't know the number of the party you want to reach. You wouldn't debug that situation by going to the other guy's house and testing his telephone, or by going to the phone company and testing the switchboard. And you don't debug a ORA-12154 by checking the listener. If I had a top ten list of "Incredibly Simple Concepts (tm)" that should be burned into the brain of everyone who claims to be an Oracle DBA, it would include "ORA-12154 Has Nothing To Do With The Listener".
    =================================
    A couple of important points.
    First, the listener is a server side only process. It's entire purpose in life is to receive requests for connections to databases and set up those connections. Once the connection is established, the listener is out of the picture. It creates the connection. It doesn't sustain the connection. One listener, with the default name of LISTENER, running from one oracle home, listening on a single port, will serve multiple database instances of multiple versions running from multiple homes. It is an unnecessary complexity to try to have multiple listeners or to name the listener as if it belongs to a particular database. That would be like the telephone company building a separate switchboard for each customer.
    Additional notes on the listener: One listener is capable of listening on multiple ports. But please notice that it is the listener using these ports, not the database instance. You can't bind a specific listener port to a specific db instance. Similarly, one listener is capable of listnening on multiple IP addresses (in the case of a server with multiple NICs) But just like the port, you can't bind a specific ip address to a specific db instance.
    Second, the tnsnames.ora file is a client side issue. It's purpose is for address resolution - the tns equivalent of the 'hosts' file further down the network stack. The only reason it exists on a host machine is because that machine can also run client processes.
    Assume you have the following in your tnsnames.ora:
    larry =
      (DESCRIPTION =
        (ADDRESS_LIST =
          (ADDRESS = (PROTOCOL = TCP)(HOST = myhost)(PORT = 1521))
        (CONNECT_DATA =
          (SERVICE_NAME = curley)
      )Now, when you issue a connect, say like this:
    $> sqlplus scott/tiger@larrytns will look in your tnsnames.ora for an entry called 'larry'. Finding it, tns sends a request through the normal network stack to (PORT = 1521) on (HOST = myhost) using (PROTOCOL = TCP), asking for a connection to (SERVICE_NAME = curley).
    Where is (HOST = myhost) on the network? When the request gets passed from tns to the next layer in the network stack, the name 'myhost' will get resolved to an IP address, either via a local 'hosts' file, via DNS, or possibly other less used mechanisms. You can also hard-code the ip address (HOST = 123.456.789.101) in the tnsnames.ora.
    Next, the standard networking process delivers the message to port 1521 on myhost. Hopefully, there is a listener on myhost configured to listen on port 1521, and that listener knows about SERVICE_NAME = curley. If so, the listener will spawn a server process to act as the intermediary between your client and the database instance. Communication to the server process will be on a randomly selected available port. At that point the listener is out of the process and continues to user port 1521 to await other connection requests.
    What can go wrong?
    First, there may not be an entry for 'larry' in your tnsnames. In that case you get "ORA-12154: TNS:could not resolve the connect identifier specified" No need to go looking for a problem on the host, with the listener, etc. If you can't place a telephone call because you don't know the number (can't find your telephone directory (tnsnames.ora) or can't find the party you are looking for listed in it (no entry for larry)) you don't look for problems at the telephone switchboard.
    Maybe the entry for larry was found, but myhost couldn't be resolved to an IP address (say there was no entry for myhost in the local hosts file). This will result in "ORA-12545: Connect failed because target host or object does not exist"
    Maybe there was an entry for myserver in the local hosts file, but it specified a bad IP address. This will result in "ORA-12545: Connect failed because target host or object does not exist"
    Maybe the IP was good, but there is no listener running: "ORA-12541: TNS:no listener"
    Maybe the IP was good, there is a listener at myhost, but it is listening on a different port. "ORA-12560: TNS:protocol adapter error"
    Maybe the IP was good, there is a listener at myhost, it is listening on the specified port, but doesn't know about SERVICE_NAME = curley. "ORA-12514: TNS:listener does not currently know of service requested in connect descriptor"
    Third: If the client is on the same machine as the db instance, it is possible to connect without referencing tnsnames and without going through the listener.
    Now, when you issue a connect, say like this:
    $> sqlplus scott/tigertns will attempt to establish an IPC connection to the db instance. How does it know the name of the instance? It uses the current value of the enviornment variable ORACLE_SID. So...
    $> export ORACLE_SID=fred
    $> sqlplus scott/tigerIt will attempt to connect to the instance known as "fred". If there is no such instance, it will, of course, fail. Also, if there is no value set for ORACLE_SID, the connect will fail.
    check executing instances to get the SID
    [oracle@vmlnx01 ~]$ ps -ef|grep pmon|grep -v grep
    oracle    4236     1  0 10:30 ?        00:00:00 ora_pmon_vlnxora1set ORACLE_SID appropriately, and connect
    [oracle@vmlnx01 ~]$ export ORACLE_SID='vlnxora1
    [oracle@vmlnx01 ~]$ sqlplus scott/tiger
    SQL*Plus: Release 10.2.0.4.0 - Production on Wed Sep 22 10:42:37 2010
    Copyright (c) 1982, 2007, Oracle.  All Rights Reserved.
    Connected to:
    Oracle Database 10g Enterprise Edition Release 10.2.0.4.0 - Production
    With the Partitioning, OLAP, Data Mining and Real Application Testing optionsNow set ORACLE_SID to a bogus value, and try to connect
    SQL> exit
    [oracle@vmlnx01 ~]$ export ORACLE_SID=FUBAR
    [oracle@vmlnx01 ~]$ sqlplus scott/tiger
    SQL*Plus: Release 10.2.0.4.0 - Production on Wed Sep 22 10:42:57 2010
    Copyright (c) 1982, 2007, Oracle.  All Rights Reserved.
    ERROR:
    ORA-01034: ORACLE not available
    ORA-27101: shared memory realm does not exist
    Linux Error: 2: No such file or directory
    Enter user-name: Now set ORACLE_SID to null, and try to connect
    [oracle@vmlnx01 ~]$ export ORACLE_SID=
    [oracle@vmlnx01 ~]$ sqlplus /scott/tiger
    SQL*Plus: Release 10.2.0.4.0 - Production on Wed Sep 22 10:43:24 2010
    Copyright (c) 1982, 2007, Oracle.  All Rights Reserved.
    ERROR:
    ORA-12162: TNS:net service name is incorrectly specifiedOk, that is how we get from the client connection request to the listener. What about the listener's part of all this?
    The listener is very simple. It's job is to listen for connection requests and make the connection (server process) between the client and the database instance. Once that connection is made, the listener is out of the picture. If you were to kill the listener, all existing connections would continue. The listener is configured with the listener.ora file, but if that file doesn't exist, the listener is quite capable of starting up with all default values. One common mistake with the listner configuration is to specify "HOST=localhost" or "HOST=127.0.01". This is a NONROUTABLE ip address. LOCALHOST and ip address 127.0.0.1 always mean "this machine on which I am sitting". So, all computers are known as "localhost" or "127.0.0.1". If you specify this address, the listener will only be capable of receiving requests from the machine on which it is running. If you specified that address in your tnsnames file - on a remote client machine - the request would be routed to the machine on which the requesting client resides. Probably not what you want.
    =====================================

  • Ora-12154:TNS:Could not resolve the connect identifier specified

    Helo
    I face this error when i tried to connect to the database.
    i have been installed 11g database on machine with database name 'hrall'
    But when i tried to connect to the database it's shows me error "ora-12154:TNS:Could not resolve the connect identifier specified"
    when i put the old database entry an that machine and try ti connect it's connect Successfully.
    Kindly Suggest
    Regards,
    Sachin

    Hi Error not solved yet
    i am giving you my system details as follow -
    OS Name :     Microsoft(R) Windows(R) Server 2003 Standard x64 Edition
    System Type: x64-based PC
    My tnsentry also right
    posted as follow -
    HRALL.voltasworld.com =
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = ps-win-hrall.voltasworld.com)(PORT = 1521))
    (CONNECT_DATA =
    (SERVER = DEDICATED)
    (SERVICE_NAME = hrall)
    listener.ora file
    # listener.ora Network Configuration File: F:\app\dbadmin\product\11.2.0\dbhome_1\network\admin\listener.ora
    # Generated by Oracle configuration tools.
    SID_LIST_LISTENER =
    (SID_LIST =
    (SID_DESC =
    (SID_NAME = CLRExtProc)
    (ORACLE_HOME = F:\app\dbadmin\product\11.2.0\dbhome_1)
    (PROGRAM = extproc)
    (ENVS = "EXTPROC_DLLS=ONLY:F:\app\dbadmin\product\11.2.0\dbhome_1\bin\oraclr11.dll")
    LISTENER =
    (DESCRIPTION_LIST =
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1521))
    (ADDRESS = (PROTOCOL = TCP)(HOST = ps-win-hrall.voltasworld.com)(PORT = 1521))
    ADR_BASE_LISTENER = F:\app\dbadmin
    Kindly Suggest
    Regards
    Sachin

  • ORA-12154: TNS:could not resolve the connect identifier specified (sqlplus)

    Hi All,
    I don't know if this has ever been posted, but since I've spent a week figuring it out (no joke, a week), I thought I would post it so that no one else has to waste this much time.
    "ORA-12154: TNS:could not resolve the connect identifier specified" from what I've seen on this site is a major problem for a lot of people, but I did not find a reference to my specfic problem.
    FYI--
    My Database is called "ordidm"
    userID: SYSMAN
    password: p@ssw0rd
    My specific issue was the following:
    I can....
    - Connect to the database via the client "admin assstant" GUI in Windows while supplying the userID and password using the "Database Authentication".
    - Connect via sqlplus as "/as sysdba"
    - "tnsping oraidm" passes works just fine.
    I CANNOT....
    - connect to oraidm at the dos prompt by using sqlplus, regardless of whether or not I supply all the user authentiocation information and db name on one line, or...if I just type "sqlplus" at the command prompt and then enter the userID and password when prompted. Every time I get the "ORA-12154: TNS:could not resolve the connect identifier specified" error message.
    Ready for this?? (some may have guessed this already) The problem is the "@" in my password. After looking closely at the trace logs, I noticed that one of the entries was...
    [09-MAR-2009 08:23:12:921] nnftrne: Original name: ssw0rd
    Remember that the format for connecting on one line at the dos prompt is
    C:/> sqlplus SYSMAN/p@ssw0rd oraidm
    or you can do the following...
    C:\Documents and Settings\Administrator.WIN2K3>sqlplus
    SQL*Plus: Release 10.2.0.1.0 - Production on Mon Mar 9 09:08:50 2009
    Copyright (c) 1982, 2005, Oracle. All rights reserved.
    Enter user-name: scott
    Enter password:
    Connected to:
    Oracle Database 10g Enterprise Edition Release 10.2.0.1.0 - Production
    With the Partitioning, OLAP and Data Mining options
    SQL>
    (BTW-I just started using the "scott" ID because from what I understand, changing the SYSMAN userID password is kind of a pain. Figured just using "scott" ID would be easier to test)
    So of course what it's doing is counting everything after the first "@" as the database name...which of course it can't find in the tnsnames.ora file. Also, contrary to some other posts I found here and there, enclosing the userID and/or passowrd in quotes does not do any good. Apparently, even when using the 2nd method...in the background, the end result is it must pass the whole thing as one long string much like in the 1st method (as you will get the same truncated "Original Name" of "ssw0rd" in the log)
    So...the question is, why does Oracle even allow "@" in the password if it will become an issue with sqlplus??? Also, if you can't (or shouldn't) use it, why isn't it documented somewhere? At the least I would expect the installer to at least warn you ahead of time that an "@" is not suggested. I don't remember it being there. Maybe it's just me and I'm just missing this info somewhere
    I sincerely hope this saves someone else a week of their life. ;-)
    -Eric

    user8100001 wrote:
    Hi All,
    I don't know if this has ever been posted, but since I've spent a week figuring it out (no joke, a week), I thought I would post it so that no one else has to waste this much time.
    "ORA-12154: TNS:could not resolve the connect identifier specified" from what I've seen on this site is a major problem for a lot of people, but I did not find a reference to my specfic problem.
    FYI--
    My Database is called "ordidm"
    userID: SYSMAN
    password: p@ssw0rdThere are restrictions from oracle side how should password look:
    Passwords can be from 1 to 30 characters.
    The first character in an Oracle password must be a letter.
    Only letters, numbers, and the symbols “#”, “_” and “$” are acceptable in a password.
    And password must not be a reserved word (look into v$reserved_words).
    And as You can see sysman password containt "@" - this is not allowed.
    >
    My specific issue was the following:
    I can....
    - Connect to the database via the client "admin assstant" GUI in Windows while supplying the userID and password using the "Database Authentication".
    - Connect via sqlplus as "/as sysdba"
    - "tnsping oraidm" passes works just fine.
    I CANNOT....
    - connect to oraidm at the dos prompt by using sqlplus, regardless of whether or not I supply all the user authentiocation information and db name on one line, or...if I just type "sqlplus" at the command prompt and then enter the userID and password when prompted. Every time I get the "ORA-12154: TNS:could not resolve the connect identifier specified" error message.
    Ready for this?? (some may have guessed this already) The problem is the "@" in my password. After looking closely at the trace logs, I noticed that one of the entries was...
    [09-MAR-2009 08:23:12:921] nnftrne: Original name: ssw0rd
    Remember that the format for connecting on one line at the dos prompt is
    C:/> sqlplus SYSMAN/p@ssw0rd oraidAnd here You can see why this symbol is restricted as full syntax for sqlplus in this case will be:
    sqlplus username/password@oraidm
    but in Your case @symbol already is in password.
    Here can be used a small trick
    sqlplus sysman/"p@ssw0rd"@oraid
    >
    or you can do the following...
    C:\Documents and Settings\Administrator.WIN2K3>sqlplus
    SQL*Plus: Release 10.2.0.1.0 - Production on Mon Mar 9 09:08:50 2009
    Copyright (c) 1982, 2005, Oracle. All rights reserved.
    Enter user-name: scott
    Enter password:
    Connected to:
    Oracle Database 10g Enterprise Edition Release 10.2.0.1.0 - Production
    With the Partitioning, OLAP and Data Mining options
    SQL>
    (BTW-I just started using the "scott" ID because from what I understand, changing the SYSMAN userID password is kind of a pain. Figured just using "scott" ID would be easier to test)
    So of course what it's doing is counting everything after the first "@" as the database name...which of course it can't find in the tnsnames.ora file. Also, contrary to some other posts I found here and there, enclosing the userID and/or passowrd in quotes does not do any good. Apparently, even when using the 2nd method...in the background, the end result is it must pass the whole thing as one long string much like in the 1st method (as you will get the same truncated "Original Name" of "ssw0rd" in the log)
    So...the question is, why does Oracle even allow "@" in the password if it will become an issue with sqlplus??? Also, if you can't (or shouldn't) use it, why isn't it documented somewhere? At the least I would expect the installer to at least warn you ahead of time that an "@" is not suggested. I don't remember it being there. Maybe it's just me and I'm just missing this info somewhereActually Oracle is not allowing this if You will just try to
    alter user scott identidified by p@ssword
    You will get error message (ORA-00922: missing or invalid option), but You can
    alter user scott identified by "p@ssword" - and that will work.
    These double quotes will allow to overide Oracle restrictions.

  • Issue with 2wire dsl router when connecting power pc g4 via ethernet

    Issue with 2wire dsl router when connecting power pc g4 via ethernet. The 2wire will keep resetting. When I connect my macbook pro via ethernet to the 2wire all is ok, but as soon as i connect the power pc. . . .reset. I have emailed 2wire support. They recommended using a different patch cable. Tried that.. .. anyone else having this issue???? Any help would be appreciated. . .

    Search the discussions for issues with 2wire dsl routers. This has come up before in a discussion I've been involved with, but probably not to do with the MDD. I do remember it being a design issue with the router, something that was done to it before dispatch.
    Let us know if you can't find it and we'll have a look.
    If you afford it, bin the 2wire and go buy something decent like a Netgear.

  • My MacBook Pro won't connect to the Internet via wifi but it worked fine on ethernet cord...I tried running diagnostic but it didn't work:((((  it happen every time if I restart the modem and/or router

    My MacBook Pro won't connect to the Internet via wifi but it worked fine on ethernet cord...I tried running diagnostic but it didn't work:((((  it happen every time if I restart the modem and/or router.. Any idea how to fix this?

    Hello Rattisate,
    Sorry to hear you are not able to connect to Wi-Fi on your MacBook Pro.  I would be concerned about this too.  You can find information on how to troubleshoot this in the following article:
    Troubleshooting Wi-Fi issues in OS X Lion and Mac OS X v10.6
    http://support.apple.com/kb/HT4628
    Follow the steps in the section labeled, "Symptom: My Mac does not connect to the Internet."
    Thank you for posting in the Apple Support Communities.
    Best,
    Sheila M.

  • Wireless connection - do i need a wireless router or can i go via  macmini?

    Hello all
    Bit of a newcomer to the whole networking side of things so excuse my ignorance.
    I have a mac mini set up to the internet through a cable modem. Can I use airport to connect my new macbook to the internet via my mac mini or would i have to set up some kind of wireless network to to this? reluctant to shell out for a wireless router or one of the more expensive airport bits of kit if i dont have to!
    any advice much appreciated!

    Just reading the wireless posts. Here's a stupid question, although I think I know the answer? I have an iMac G5 running Panther - without an Airport card - connecting to the internet via Ethernet and a cable modem. Can I share this internet connection with my new Leopard MacBook via Airport?

  • ORA-12154: TNS:could not resolve the connect identifier specified [10g XE]

    Greetings
    There are many topics on this issue over the internet but None of them addresses this issue properly, so I couldn't find a solution to the problem.
    I installed: Oracle Database 10g Express Edition
    After the installation was done, I opened SQL Command Line
    and I used the command "connect" to login
    I enter the username
    Then I entered the password
    After a couple of seconds I got the following ERROR message:
    ORA-12154: TNS:could not resolve the connect identifier specified
    Screenshot of the error:
    http://i35.tinypic.com/14o26g7.png
    I installed this version of Oracle on both Windows XP 32 bit and Windows 7 32 bit and I get the same error message when it tries to connect.
    Why doesn't Oracle work right after the installation?
    Are there any further steps that need to be done in order to make this work? If so I would really appreciate any step by step help, I've been stuck trying to find a solution for days.
    Edited by: user10192105 on Aug 22, 2010 7:34 PM

    >
    I wento to CMD, then I entered sqlplus / as sysdba and that just opened the SQL*Plus program in CMD (SQL>)
    But nevertheless I still need to login with a user name and password which and I tried and I got the same error message.
    >
    We're making progress, you'll be logging in soon....
    Get into SQL*Plus with the command I gave you, now type this:
    alter user <theusernameyouwant> identified by abc123;followed by (still in SQL*Plus):
    connectafter you type "connect", SQL*Plus will ask you for a user name and password. Use the same user name and password you used in the alter command.
    HTH,
    John.

  • Ora-12154 Could not resolve the connect Identifier specified

    I am facing problem for communicating to Microsoft SQL Server through Oracle GateWay.
    *1*. In installed Oracle Gateway 11.2 @D:\product\11.2.0\tg
    *2. D:\product\11.2.0\tg\dg4msql\admin\initdg4msql.ora* is as:
    HS_FDS_CONNECT_INFO=dba.Insignia
    HS_FDS_TRACE_LEVEL=OFF
    HS_FDS_RECOVERY_ACCOUNT=RECOVER
    HS_FDS_RECOVERY_PWD=RECOVER
    *3. listener.ora is as (D:\product\11.2.0\tg\NETWORK\ADMIN\tnsnames.ora)*
    LISTENER =
    (DESCRIPTION_LIST =
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = dba)(PORT = 1521))
    (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1521))
    ADR_BASE_LISTENER = D:\product\11.2.0\tg
    SID_LIST_LISTENER =
    (SID_LIST =
    (SID_DESC =
    (SID_NAME = dg4dmssqldb)
    (PROGRAM = D:\product\11.2.0\tg\bin\dg4msql)
    SUBSCRIBE_FOR_NODE_DOWN_EVENT_LISTENER=OFF
    *4. tnsnames.ora is as (D:\product\11.2.0\tg\NETWORK\ADMIN\listener.ora)*
    PROD=
    (DESCRIPTION=
    (ADDRESS=(PROTOCOL=tcp)(HOST=192.168.0.230)(PORT=1521))
    (CONNECT_DATA=(SID=PROD))
    msql1=
    (DESCRIPTION=
    (ADDRESS_LIST=
    (ADDRESS=(PROTOCOL=TCP)(HOST=dba)(PORT=1521))
    (CONNECT_DATA=
    (SID=dg4dmssqldb) )
    (HS=OK)
    *5. Oracle Database Link (its working well)*
    create database link apps connect to dba identified by dba using 'prod';
    *6. Microsoft Sql server Database Link*
    create database link msql1 connect to "sa" identified by "angal" using 'msql1' ;
    When i try to select data through microsoft sql server database link its show following error;
    Ora-12154 Could not resolve the connect Identifier specified
    Wher i wrong......

    Hello,
    I have not used Oracle Gateway for a long time, but did you try to rename the file D:\product\11.2.0\tg\dg4msql\admin\initdg4msql.ora into D:\product\11.2.0\tg\dg4msql\admin\initdg4dmssqldb.ora ?
    initdg4msql.ora is the default name, and should be changed if you do not use dg4msql as gateway SID:
    http://download.oracle.com/docs/cd/E11882_01/gateways.112/e12013/configsql.htm#autoId2
    Hope it will help.
    Regards,
    Sylvie

  • How to solve the error "The specified resource is reserved" when running with DAQmx And LabVIEW?

    How to solve the error "The specified resource is reserved" when running with DAQmx And LabVIEW?

    I hate "J term"
    OK I love the learning the students get.   And, I like helping them out!  But, as a former man who's got the varicose viens to prove he's spent time "behind the podium" (yeah, "behind the podium" puts 'em to sleep- songs and dances for the young'uns) come on! USE the tools you teach!
    Instructors invited to engage in the forums
    Jeff

  • BO 4.0 Repository diagnostic tool-ora 12154.TNS could not resolve the connect identifier specified

    Hi All,
    I'm trying to run RDT on BO 4.0 using the following command on <INSTALLDIR>\SAP BusinessObjects Enterprise XI 4.0\win64_x64:
    reposcan.exe -dbdriver oracledatabasesubsystem -connect "UID=ceprod;PWD=ceprod;DSN=dsnname;HOSTNAME=ip of db server;PORT=1521" -dbkey [[XXXXXXX]] -inputfrsdir "\\share\FileStore\FileStore\Input" -outputfrsdir "\\Share\FileStore\FileStore\Output"
    I cannot be able to run the RDT as I get the following error:Business Objects Enterprise CMS:Unable to connect to the CMS system database DSN:dbserver ip:1521.Reason ORA 12154.TNS could not resolve the connect identifier specified
    I have created DSN for oracle db using 32 bit and 64 bit ODBC drivers. I can connect from this system to the database using the client tools.
    Also this is a clustered cms and do I need to use any other parameters here?
    regards,
    Sridhar

    Hi,
    Check if you have two different oracle directories listed in system variable path.
    e.g.:
    D:\oracle\product\11.2.0\client_1\bin;C:\Program Files\oracle\product\11.2.0\client_1\bin
    If this is the case, you have two different tnsnames.ora files.
    Then sometimes the first one is used and sometimes the second.
    If they don't contain the same info, you get these issues.
    Delete one of the paths in the system variable or synchronize the tnsname.ora files to get rid of that.
    Regards
    Moritz

  • ORA-12154: TNS:could not resolve the connect identifier specified Oracle 11

    I'm having a slight issue with Oracle 11 R2
    Oracle 10g was removed from the machine - The registry was cleared and I couldn't see anything of 10g left.
    I then installed Oracle 11 with just the software only, and then created a listener.
    Using the Database Configuration Assistant, I tried to add a database but I get the error:
    'ORA-12154: TNS:could not resolve the connect identifier specified'
    The TNS_ADMIN is set to: \\ravel\tnsnames and I can connect to other instances around the company.
    My tnsnames entry is:
    GMAN_1120.WORLD =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = gman)(PORT = 1521))
    (CONNECT_DATA =
    (SERVICE_NAME = ora112)
    If i start the listener i get:
    TNSLSNR for 32-bit Windows: Version 11.2.0.1.0 - Production
    System parameter file is D:\oracle\product\11.2.0\dbhome_1\network\admin\listener.ora
    Log messages written to d:\oracle\diag\tnslsnr\gman\listener\alert\log.xml
    Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=gman)(PORT=1521)))
    Connecting to (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))
    STATUS of the LISTENER
    Alias LISTENER
    Version TNSLSNR for 32-bit Windows: Version 11.2.0.1.0 - Production
    Start Date 03-AUG-2011 10:34:28
    Uptime 0 days 0 hr. 0 min. 1 sec
    Trace Level off
    Security ON: Local OS Authentication
    SNMP OFF
    Listener Parameter File D:\oracle\product\11.2.0\dbhome_1\network\admin\listener.ora
    Listener Log File d:\oracle\diag\tnslsnr\gman\listener\alert\log.xml
    Listening Endpoints Summary...
    (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=gman)(PORT=1521)))
    Services Summary...
    Service "PLSExtProc" has 1 instance(s).
    Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...
    Service "ora112" has 1 instance(s).
    Instance "ora112", status UNKNOWN, has 1 handler(s) for this service...
    The command completed successfully
    LSNRCTL>
    Can anyone spot what may have gone wrong? I've setup 10g multiple times and never had a problem

    I can tnsping my machine using another machine:
    Used TNSNAMES adapter to resolve the alias
    Attempting to contact (DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)(HOST = gman)(PORT = 1521))) (CONNECT_DATA = (SERVIC
    E_NAME = ora112)))
    OK (30 msec)
    My listener.ora file is:
    # listener.ora Network Configuration File: D:\oracle\product\11.2.0\dbhome_1\network\admin\listener.ora
    # Generated by Oracle configuration tools.
    SID_LIST_LISTENER =
    (SID_LIST =
    (SID_DESC =
    (SID_NAME = PLSExtProc)
    (ORACLE_HOME = D:\oracle\product\11.2.0\dbhome_1)
    (PROGRAM = extproc)
    (SID_DESC=
    (GLOBAL_DBNAME=ora112)
    (ORACLE_HOME=D:\oracle\product\11.2.0\dbhome_1)
    (SID_NAME=ora112)
    )

  • URGENT:  ORA-12154: TNS:could not resolve the connect identifier specified

    State: HY000. Code: 10058. [NQODBC] [SQL_STATE: HY000] [nQSError: 10058] A general error has occurred. [nQSError: 43113] Message returned from OBIS. [nQSError: 17001] Oracle Error code: 12154, message: ORA-12154: TNS:could not resolve the connect identifier specified at OCI call OCIServerAttach. [nQSError: 17014] Could not connect to Oracle database. (HY000)
    1). I have TNS entries under MW_HOME/OracleBI/network/admin
    2). TNSPING works fine.
    3). JDBC source set up on WLS side..
    what else do I need to do?

    Show the full exception stack trace. This doesn't seem to relate to WebLogic. Does the WebLogic console
    show the DataSource as running? Are you in fact using the WebLogic DataSource?

Maybe you are looking for