Source does not have a runnable target.

I am just learning Stored Procedures. I have Oracle SQL Developer Version 1.5.1 loaded, going against 11G running on Ubuntu Linux.
I try to build a very basic Stored Procedure:
CREATE OR REPLACE
PROCEDURE HR.TEST AS
BEGIN
Select * from hr.jobs
NULL;
END HR.TEST;
I always receive the following error:
Source does not have a runnable target
I always post these question in the wrong area on this Forum, so go ahead and just direct me to the correct forum if applicable.
Any ideas?
Thanks Zach

Ah, so Tom O'Neill was not writing about Oracle. The clue was in the title, "SQL Server Stored Procedures for Beginners". Easy to miss perhaps ;)
This is a valid procedure:
CREATE OR REPLACE PROCEDURE test
    ( p_salary       IN  jobs.min_salary%TYPE
    , p_out_results  OUT SYS_REFCURSOR )
AS
BEGIN
    OPEN p_out_results FOR
        SELECT *
        FROM   jobs
        WHERE  p_salary BETWEEN min_salary AND max_salary
        ORDER BY min_salary, max_salary, job_title;
END test;Here's how you might call it from SQL*Plus:
SQL> var results refcursor
SQL> exec test(3000, :results)
PL/SQL procedure successfully completed.
SQL> print :results
JOB_ID     JOB_TITLE                           MIN_SALARY MAX_SALARY
ST_CLERK   Stock Clerk                               2000       5000
PU_CLERK   Purchasing Clerk                          2500       5500
SH_CLERK   Shipping Clerk                            2500       5500
AD_ASST    Administration Assistant                  3000       6000
4 rows selected.or if you prefer,
SQL> set autoprint on
SQL>
SQL> exec test(3000, :results)
PL/SQL procedure successfully completed.
JOB_ID     JOB_TITLE                           MIN_SALARY MAX_SALARY
ST_CLERK   Stock Clerk                               2000       5000
PU_CLERK   Purchasing Clerk                          2500       5500
SH_CLERK   Shipping Clerk                            2500       5500
AD_ASST    Administration Assistant                  3000       6000
4 rows selected.No idea how to call it from SQL Developer, sorry.

Similar Messages

  • Stored Procedure Help: Source does not have a runnable target

    I'm an MS-SQL guy, so I'm fairly familiar with T-SQL syntax, but am having one heck of a time trying to take code I've written for SQL and transform it to work with Oracle.
    Anyways, I'm using Oracle's SQL Developer, and I've got a stored procedure that calls the Alter Table statement and adds a column to it. I'm just trying to get this one to work before I move on to the other one's I have. I keep getting the message Source does not have a runnable target when I try running this command.
    create or replace PROCEDURE rta_conv_addcolumn(rtatablename1 in varchar(20),
    rtatablename2 in varchar(20),
    rtacolumnname in varchar(256),
    rtacolumninfo in varchar(256))
    AS
    DECLARE rtasql VARCHAR(4000);
    BEGIN
    IF EXISTS (SELECT * FROM user_tables WHERE table_name = rtatablename1)
    AND NOT EXISTS (SELECT * FROM user_tab_columns WHERE column_name = rtacolumnname
    AND table_name = rtatablename1)
    AND NOT EXISTS (SELECT * FROM user_tab_columns WHERE column_name = rtacolumnname
    AND table_name = rtatablename2)
    Then rtasql:= 'ALTER TABLE ['+rtatablename2+'] ADD ' + rtacolumnname + ' ' + rtacolumninfo;
    Execute (rtasql);
    END rta_conv_addcolumn;
    If I try compiling it I get the following messages, which don't make sense, since the syntax I'm using for declaring the input variables looks to be right.
    Error(1,54): PLS-00103: Encountered the symbol "(" when expecting one of the following: := . ) , @ % default character The symbol ":=" was substituted for "(" to continue.
    Error(2,29): PLS-00103: Encountered the symbol "(" when expecting one of the following: := . ) , @ % default character The symbol ":=" was substituted for "(" to continue.
    Error(3,29): PLS-00103: Encountered the symbol "(" when expecting one of the following: := . ) , @ % default character The symbol ":=" was substituted for "(" to continue.
    Error(4,29): PLS-00103: Encountered the symbol "(" when expecting one of the following: := . ) , @ % default character The symbol ":=" was substituted for "(" to continue.
    Error(6,1): PLS-00103: Encountered the symbol "DECLARE" when expecting one of the following: begin function package pragma procedure subtype type use <an identifier> <a double-quoted delimited-identifier> form current cursor external language The symbol "begin" was substituted for "DECLARE" to continue.
    Error(15,5): PLS-00103: Encountered the symbol "RTA_CONV_ADDCOLUMN" when expecting one of the following: if

    What table you want to add the column to? rtatablename1 or rtatablename2? I assumed 1 for now.
    I tried to preserve your code structure so you can familiarize with it.
    This piece should work, but you need to make sure you validate the parameters you concatenate to your strings when you use dynamic SQL.
    That's when SQL injection takes place: when you trust the parameters you are receiving and don't validate them.
    Also remember that DDL statements execute an implicit commit. Any previous DML operations you have pending will be commited by
    this EXECUTE IMMEDIATE call if it succeeds.
    I'd recommend some reading at the Oracle docs regarding those topics and the invoker's vs definer's rights for procedures.
    It basically means that as a default behaviour, the user running the procedure "borrows" the rights and privileges of the procedure owner,
    and that guy is usually super-privileged.
    http://download.oracle.com/docs/cd/E11882_01/appdev.112/e10472/subprograms.htm#LNPLS00809
    CREATE OR REPLACE PROCEDURE rta_conv_addcolumn
      rtatablename1 IN VARCHAR,
      rtatablename2 IN VARCHAR,
      rtacolumnname IN VARCHAR,
      rtacolumninfo IN VARCHAR
    ) AS
      rtasql VARCHAR(4000);
      v_count NUMBER;
    BEGIN
      SELECT COUNT(*)
        INTO v_count
        FROM user_tables
       WHERE table_name = upper(rtatablename1)
             AND NOT EXISTS (SELECT *
                               FROM user_tab_columns
                              WHERE column_name = upper(rtacolumnname)
                                    AND table_name = upper(rtatablename1))
             AND NOT EXISTS (SELECT *
                               FROM user_tab_columns
                              WHERE column_name = upper(rtacolumnname)
                                    AND table_name = upper(rtatablename2));
      IF v_count > 0
      THEN
        -- is it to the rtablename1 or 2 you want to add this column to?
        rtasql := 'ALTER TABLE ' || rtatablename1 ||' ADD ' || rtacolumnname || ' ' || rtacolumninfo;
        EXECUTE IMMEDIATE rtasql;
      END IF;
    END rta_conv_addcolumn;Edited by: fsitja on Dec 11, 2009 11:21 PM

  • Building SCD Type2 changes. Any record deletion in Source does not expire the Target Record

    Building SCD Type2 changes. Any record deletion in Source does not expire the Target Record. When I Delete any Record in Source Table, I expect the same record should be 'Expired' with 'End_Date' with Active = 'N'. 
    BTW: In 'Table Comp',  I have Checked the 'Detect Deleted rows(s) ...'. /  ' ... largest generated key'  is selected by default..
    This is not happening..! My Update and Insert works fine..!

    Hi
    Do you have detect deletes set on Table Comparison?
    I also add the Map operations to the output of History Preserving and manage each stream of the Insert/Update/deletes separately and control the record start/effective & record end/Expiry dates with more variables based on the stream req, ie updates to end previous record have record end date set to variable for business or run date set to date - 1.
    You only need key gen for inserts (including the deleted record final state)
    Use merge to bring back together.

  • How can I convert my Open Source document files into Word document files? I cannot download Pages since my Macbook Air does not have the most recent software.

    How can I convert my Open Source document files into Word document files? I cannot download Pages since my Macbook Air does not have the most recent software. I downloaded open office to my mac to try and save money. It worked well for a while. Now I get this pop-up message that asks me to "Reopen" and when I select the option, nothing happens. I cannot save my documents anymore and I cannot convert them to word. Help!

    dwb wrote:
    Does OpenOffice output Word documents by default or do you have to select it manually?
    You have 17 options to save as in Open Office, one of which is .doc  files,  yes it needs to be saved manually.
    You may be able to default to DOC, but have not tried same.
    Since Open Office is 99% same as Word, I use it, or Word, either one.  Open Office is a bit less buggy than Word 11'

  • Output Column does not have a matching source column in the schema

    Hi Everyone,
                           Can you please help me in this. Already an ETL is loading the data from AS400 TO SQL server. I need to add a new
    column. In the Source (OLEDB source) am pulling the data from AS400 using ADO.NET connection manager.
    New column is added in AS400. To bring the new column from AS400, I added column name in the query in OLEDB source. Test connection is good. In the Source editor, when I click on preview it gives me the values of the new column and if I click on build
    new query also it gives me values for the new column.
    After mapping the columns and refreshing the data in OLEDB destination, I don't see any errors or warnings.
    But when I start executing the package it throws me the below error.
     Error: The output column  (4659) does not have a matching source column in the schema.
    [SSIS.Pipeline] Error: "component  (2861)" failed validation and returned validation status "VS_NEEDSNEWMETADATA".
    I need suggestion on this.
    Thanks
    Veeresh

    Hi Veeresh,
    As per my understanding, this error happens when the OLE DB Source component cannot find the corresponding source column in the database table. Possible reason is the the column name in the external database table has changed or
    the column has been removed.
    To verify this issue, please go to the Advanced Editor for OLE DB Source Input and Output Properties tab to see the External columns and Output columns. To fix it, please refresh the data or recreate the Source.
    Thanks,
    Katherine Xiong
    Katherine Xiong
    TechNet Community Support

  • Run As Account does not exist on the target system or does not have enough permissions

    We are getting below alerts,
    Run As Account does not exist on the target system or does not have enough permissions.
    I know we can create a Run As account with low Privilege can fix this issue ,
    http://blogs.technet.com/b/kevinholman/archive/2010/09/08/configuring-run-as-accounts-and-profiles-in-r2-a-sql-management-pack-example.aspx
    My question here is there is any other way to fix it. I tried giving below permission for scom_act account (we used for agent installation and has local admin rights) but still same issue and
    also i tried with sysadmin access for scom_act as well but no luck still having same issue , any solution would be welcome
    The min. Privilege for monitor SQL server
    DB Server Level
    a.  VIEW ANY DEFINITION
    b. VIEW SERVER STATE
    c.     VIEW ANY DATABASE
    Each DB
    a.  SQLAgentReaderRole database role.
    b.  PolicyAdministratorRole database role

    Check below link
    http://blog.coretech.dk/msk/run-as-account-does-not-exist-on-the-target-system-or-does-not-have-enough-permissions/
    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question, please click "Mark As Answer"
    Mai Ali | My blog: Technical | Twitter:
    Mai Ali

  • After Effects error : layer does not have a source.

    Hi All,
              I add a Text layer and then add my custom fill  effect to it. Then I call AdvItemSuite1()->PF_ForceRerender(in_data, &(params[0]->u.ld)) from AEGP for all the layers. But only for Text layer, AE pops up a dialog displaying the following error :
    After Effects error : layer does not have a source.
    (26::335)
    Why is this happening? What other call can I use to rerender all the layers?
    Thanks & Regards,
    Dheeraj

    Am 13.04.2011 12:21, schrieb dheeraj_c:
    For now just added a dummy parameter in the effect and calling AEGP_SetStreamValue() to render all the layer with effect.
    I also have experienced problems with PF_ForceRerender(),
    AEGP_SetStreamValu() seems like an alternative solution...

  • Target data source does not support the AGO operation

    Hi,
    In BI Admin Tool, I join Essbase cube and relational source. Then I apply Ago function to Essbase measures. In BI Answer, I try to run query that includes Essbase Ago measures and relational columns(non measures), error message shows the following detail:
    Error Codes: OPR4ONWY:U9IM8TAC:OI2DL65P
    State: HY000. Code: 10058. [NQODBC] [SQL_STATE: HY000] [nQSError: 10058] A general error has occurred. [nQSError: 22001] Target data source does not support the AGO operation. (HY000)
    When I remove the relational columns or run Essbase current-date messures, the result is fine.
    So, what's exact meaning of this error message? and does the relational columns (non-measure) support Essbase measures' Ago function?

    to clarify:
    fail case:
    criteria
    YEAR | YTD,gen03 | MONTH_NAME | SALES(YEAR_AGO)
    cube dimension: year, ytd,gen03
    relational source: month_name
    cube measure using AGO(): sales(year_ago)
    result: error messageSuccess case:
    criteria
    YEAR | YTD,gen03 | SALES(YEAR_AGO)
    cube dimension: year, ytd,gen03
    cube measure using AGO(): sales(year_ago)
    result: success~! how can i solve it? thx

  • Time machine says restore target does not have enough space, but not true

    I have a PowerMac G5 Tower with Dual 1.8Ghz, 3GB Memory.
    The internal system disk is a WD 1TB(931.4GB) disk, but it has serious volume structure errors that are not recoverable with First Aid or Micromat TechTool. The 1TB disk was only about 1/3 full(~350GB used).
    Fortunately, I have been using time machine since July, using the exact same type of disk(WD 1TB), which is external..
    I installed another external 1TB that is exactly the same as the original system disk(WD 1TB - 931.3GB).
    I am able to select the backup source of the original disk from the time machine disk, but when I select the destination(new 1TB disk which is completely empty and reformatted), I get the following error:
    -"This volume does not have enough space to restore your system"
    I don't get it.....the original and new disks are exactly the same size. In fact the time machine disk is also the same WD 1TB disk. Realistically, only 350GB should only be needed anyhow...
    Please help....
    Thanks,
    Phil

    Apple phone support recommended that I install Leopard on the replacement disk, boot from it, then use the 'transfer data from time machine backup option'. This worked, but takes an hour longer because I have to install an OS. I am in the process of transferring 337GB of data to the new disk using this method(system is estimating this takes about 8 hours, so I am sending this note before it completes). This further verifies that there was plenty of space on the 1TB replacement, despite the error message.
    The new replacement disk I chose was an internal Seagate SATA disk. I was wrong in the previous note, the original internal system disk that had the volume corruption was also a Seagate SATA disk, not WD(though, the external 1TB was a WD). I did duplicate the bug mentioned in this bug with this disk before I installed the OS, so the problem had nothing to do with Seagate vs. WD, or internal vs. external. I booted from the replacement, then used the setup assistant to transfer data from a time machine backup.
    In summary, there definitely is a bug in the time machine restore option: Time machine reports that there is not enough space to recover, despite the fact that it had a full 1TB clean, and newly reformatted space. I duplicated the error at least 6-7 times, during the course of troubleshooting, with different replacement 1TB disks(WD and Seagate), Internal/External disks, Firewire, USB, and SATA connect.
    This is very nerve-wracking, as the restore is the major reason we do backups. How could apple have missed this one?
    For what it is worth, I spent ALOT of time on this, because I also ran into the bug that WD external disks(firewire and USB) are not bootable on Power PC systems(this is of course a WD issue....).
    Phil

  • Why does my LabVIEW Run-time server return the message "source does not exist Last UI message: Start Execution"?

    I am trying to build a stand-alone application on a target pc for which I have built a LabVIEW server that TestStand can use as an adapter.
    In order to do this, I searched this site and found the topic: "How do I build and Use the LabVIEW Operator Interface as a LabVIEW ActiveX Run-time server?" After following the procedure to the letter, I ran the testexec.exe file as instructed and loaded my sequence file. As soon as I try to "Single Pass" or "Test UUT" I get an error which says "source does not existLast UI message: Start Execution". This error appears when running the testexec.exe file on the target pc or the development pc.
    I have found though, th
    at if I open the Operator interface through the Start: Programs>National Instruments>TestStand>Operator Interfaces>LabVIEW then the sequence file runs without these errors.
    Any ideas why this is happening?

    Hello Robroy,
    The KB you mentioned explaines how to build the LV Operator Interface (OI). So, I assumed you built the LV OI and also configured the LV adapter to use the TestStandGUILVRTS server without problems.
    The error you are getting may be due to missing VIs. In other words, the LabVIEW OI may not be finding all the VIs your sequence is calling.
    In order to deploy sequences that call VIs, you need to first run Tools >> Assemble VIs for Runtime Distribution. This tool gets all the VIs your sequence needs and saves in a separate directory.
    For more information, you may check the TestStand User Manual chapter 17, it describes how to distribute TestStand and sequences.
    Regards,
    Roberto Piacentini
    Applications Engineer
    National Inst
    ruments
    www.ni.com/ask

  • UNC Path is not valid or does not have write permissions

    Hi,
    I've just downloaded the MVMC 3.0 SA as well as the admin guide. My environment is the following setup:
    - Windows Server 2012 R2 as Hyper-V (SRV-1-011-HypV1, not domainjoined!)
    - Windows Server 2012 R2 as VM SRV-1-011-HypV1 (SRV-1-030-DC01, Domaincontroller)
    - Windows Server 2012 R2 as VM for Conversion with MVMC 3.0 hosted on SRV-1-011-HypV1 (SRV-1-032-File1, not domainjoined!)
    - VMWare ESXi 4.1, where the source VM resides (stone001)
    I've completed the wizard for converting a VM to Hyper-V and I'm Stuck at the Summary Check:
    "Blocking Issue(s):
     1: UNC Path '\\srv-1-011-hypv1\Converted' is not valid or does not have write permissions."
    From the admin guide this is described as Issue number 2:
    The machine, on which you   are running the conversion, and the destination Hyper-V host are not members   of the same Active Directory
    domain.
    Ensure that the machine on   which you are running the conversion and the destination Hyper-V host are   members of the same Active Directory
    domain.
    SRV-1-011-HypV1 and SRV-1-032-File1 are both Member of the "Workgroup" and are not domain joined. Right now, it is impossible to join the
    Hyper-V host to its VM-hosted Domain due to the required system restart at the domain join, while domain is going to be shut down. How can this issue be resolved?
    Further: Is there any conflict known operating MVMC from the destination Hyper-V host itself? Will the issue occur in this scenario too, as long as
    the hyper-V has not joined the domain?
    Kind regards
    S.Kuemmel

    Hi,
    in my case it worked when the Server(-VM) on which we installed the MVMC AND the target-file server were joined to the domain.
    We also created a domain account, which has write-permissions to the target fileshare. We used this domain account for logon on the MVMC-machine and for running the MVMC Wizard.
    Hope that helps
    Regards
    Robert

  • VMWare - Hyper-V Conversion Failed: Does Not Have Write Permissions

    Hey Guys - 
    Today I've been trying to convert a VM from VMWare Workstation to Hyper-V.  I have it in VMWare Workstation and not ESX because I'm working from home currently.  My Hyper-V server is also local and hosted on a new Windows Server 2012 R2 build.
    When I try to convert it at the end of the process, I get the below error:
    Blocking Issue(s):
    1: UNC Path "\\192.168.0.10\VDisks\Nagios Log Server" is not valid or does not have write permissions
    Warnings(s):
    1: The number of USB devices configured on the VMWare guest machine is 1.  The USB device (window cuts off here)
    2: The video memory configured on the VMware guest machine is greater than 4 MB.  The vid (window cuts off here)
    Below is a screenshot:
    Environment
    - Hyper-V server is on a separate system running Windows Server 2012 R2
    - VMWare Workstation is on the PC I'm running the converter on.  The source VM is shared and I have Workstation configured to share on port 444 (443 is taken)
    - Hyper-V Server is on domain - VMWare Workstation Computer is NOT joined to that domain - however - when choosing VM I connected with the domain credentials and browsed to select target folder - not just typed it in.
    - I'm using Domain Admin credentials and the VDisks share is set to have full access to the account
    - I can connect to target share via Explorer and write files / create folders successfully
    - VMWare Workstation version 11 running on Windows 8.1 Update 1 x64
    Any ideas or suggestions?  Thanks!
    Ben K.

    Hi,
    in my case it worked when the Server(-VM) on which we installed the MVMC AND the target-file server were joined to the domain.
    We also created a domain account, which has write-permissions to the target fileshare. We used this domain account for logon on the MVMC-machine and for running the MVMC Wizard.
    Hope that helps
    Regards
    Robert

  • How can I connect my 3gen apple tv with HDMI to my bush LCD32TV022HD which does not have an HDMI port but does have 1)S-Video I/P, 2)Video I/P, 3) L

    How can I connect my 3gen apple tv with HDMI to my BUSH LCD32TV022HD
    This does not have an HDMI port but does have:-
    1) S-Video I/P,
    2) Video I/P,
    3) Audio Input (Left & Right)
    4) Audio In jack (for VGA and DVI source)
    5) DVI input
    6) VGA input

    Welcome to the Apple community.
    The Apple TV doesn't officially support a DVI connection, however you may be able to get it to work. You will first need to check that your TV supports either 720p or 1080p as well as HDCP. If you are able to get the video working over the DVI connection, you may also require a DAC in order to connect with Apple TV's optical audio output to the TVs audio imput.
    You may well wish to make sure that the DVI connection works before spending any money on a DAC..

  • SSL VPN message "This (client) machine does not have the web access privilege."

    Hello!
    I am trying to configure the SSL VPN (WebVPN) and I am almost done but when clicking on the URL's I configured in the bookmarks, I get the message "This (client) machine does not have the web access privilege. Please contact your SSLVPN provider for assistance." I looked through the many tutorials and guides in existence and none talks about such error and the fix for it. In fact, if I search the net for this error message I get only one match, in the Cisco website, where is say that "The client computer does not meet the security criteria of having web access functionality through the SSL VPN gateway." and as fix it gave this tip "Check the URL to the gateway or contact the administrator if it persists." So, nothing on the website about what this issue is and how to fix it. I will provide my IOS configuration and hopefully someone will spot the issue. Here it goes:
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname R1
    boot-start-marker
    boot-end-marker
    logging message-counter syslog
    no logging buffered
    enable secret 5 $1$1LLX$u7aTc8XfNqPZhPVGwEF/J0
    enable password xxxxxxxx
    aaa new-model
    aaa authentication login userAuthen local
    aaa authentication login sdm_vpn_xauth_ml_1 local
    aaa authorization network groupauthor local
    aaa session-id common
    crypto pki trustpoint TP-self-signed-1279712955
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1279712955
    revocation-check none
    rsakeypair TP-self-signed-1279712955
    crypto pki certificate chain TP-self-signed-1279712955
    certificate self-signed 01
      3082023A 308201A3 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 31323739 37313239 3535301E 170D3130 30333233 31313030
      33375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 32373937
      31323935 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100A8EF 34E3E792 36660498 9801F934 E8A41865 3599EA35 B073AC91 D7A53AF4
      A4390D2F CB3DB2DE 936B28F0 A25F3CE1 6F40FD9E E79096F2 F89620E0 B31A7B34
      649BBA22 AE44CB55 9F38BF0C 2F2770CF 8380C167 C17D760C 380E28E4 FF7D6874
      9EFC310A 2AA60835 F1AA384F CD1A0173 19C98192 EBFBD531 24CB9203 EA9E7D54
      B2C30203 010001A3 62306030 0F060355 1D130101 FF040530 030101FF 300D0603
      551D1104 06300482 02523130 1F060355 1D230418 30168014 0D9D62EC DA77EAF3
      11ABF64D 933633F9 2BA362DC 301D0603 551D0E04 1604140D 9D62ECDA 77EAF311
      ABF64D93 3633F92B A362DC30 0D06092A 864886F7 0D010104 05000381 81006853
      48ED4E3E 5721C653 D9A2547C 36E4F0CB A6764B29 9AFFD30A 1B382C8C C6FDAA55
      265BCF6C 51023F5D 4AF6E177 C76C4560 57DE5259 40DE4254 E79B3E13 ABD0A78D
      7E0B623A 0F2D9C01 E72EF37D 5BAB72FF 65A176A1 E3709758 0229A66B 510F9AA2
      495CBB4B 2CD721A7 D6F6EB43 65538BE6 B45550D7 A80A4504 E529D092 73CD
       quit
    dot11 syslog
    ip source-route
    ip dhcp excluded-address 192.168.0.1 192.168.0.10
    ip dhcp pool myPOOL
       network 192.168.0.0 255.255.255.0
       default-router 192.168.0.1
       dns-server 87.216.1.65 87.216.1.66
    ip cef
    ip name-server 87.216.1.65
    ip name-server 87.216.1.66
    ip ddns update method mydyndnsupdate
    HTTP
      add http://username:[email protected]/nic/update?system=dyndns&hostname=<h>&myip=<a>
    interval maximum 1 0 0 0
    no ipv6 cef
    multilink bundle-name authenticated
    vpdn enable
    vpdn-group pppoe
    request-dialin
      protocol pppoe
    username cisco privilege 15 password 0 xxxxxxxx
    crypto isakmp policy 3
    encr 3des
    authentication pre-share
    group 2
    crypto isakmp fragmentation
    crypto isakmp client configuration group vpnclient
    key cisco123
    domain selfip.net
    pool ippool
    acl 110
    crypto ipsec transform-set myset esp-3des esp-md5-hmac
    crypto dynamic-map dynmap 10
    set transform-set myset
    reverse-route
    crypto map clientmap client authentication list userAuthen
    crypto map clientmap isakmp authorization list groupauthor
    crypto map clientmap client configuration address respond
    crypto map clientmap 10 ipsec-isakmp dynamic dynmap
    archive
    log config
      hidekeys
    interface Loopback0
    ip address 10.11.0.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    interface Loopback2
    description SSL VPN Website IP address
    ip address 10.10.10.1 255.255.255.0
    interface Loopback1
    description SSL DHCP Pool Gateway Address
    ip address 192.168.250.1 255.255.255.0
    interface FastEthernet0
    description $ES_LAN$
    ip address 192.168.0.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    duplex auto
    speed auto
    interface BRI0
    no ip address
    encapsulation hdlc
    shutdown
    interface FastEthernet1
    interface FastEthernet2
    switchport access vlan 2
    interface FastEthernet3
    interface FastEthernet4
    interface FastEthernet5
    interface FastEthernet6
    interface FastEthernet7
    interface FastEthernet8
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    pvc 8/35
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
    bundle-enable
    dsl operating-mode auto
    interface Vlan1
    no ip address
    interface Dialer1
    ip ddns update hostname myserver.selfip.net
    ip ddns update mydyndnsupdate host members.dyndns.org
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    ip policy route-map VPN-Client
    dialer pool 1
    ppp chap hostname xxx
    ppp chap password 0 xxxx
    ppp pap sent-username xxx password 0 xxxx
    crypto map clientmap
    ip local pool ippool 192.168.50.100 192.168.50.200
    ip local pool sslvpnpool 192.168.250.2 192.168.250.100
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip http server
    ip http authentication local
    ip http secure-server
    ip nat inside source static tcp 192.168.0.2 21 interface Dialer1 790
    ip nat inside source static tcp 192.168.0.15 21 interface Dialer1 789
    ip nat inside source list 102 interface Dialer1 overload
    ip nat inside source static tcp 10.10.10.1 443 interface Dialer1 443
    ip nat inside source static tcp 10.10.10.1 80 interface Dialer1 80
    access-list 102 deny   ip 192.168.0.0 0.0.0.255 192.168.50.0 0.0.0.255
    access-list 102 permit ip 192.168.0.0 0.0.0.255 any
    access-list 110 permit ip 192.168.0.0 0.0.0.255 192.168.50.0 0.0.0.255
    access-list 144 permit ip 192.168.50.0 0.0.0.255 any
    route-map VPN-Client permit 10
    match ip address 144
    set ip next-hop 10.11.0.2
    control-plane
    banner motd ^C
    ================================================================
                    UNAUTHORISED ACCESS IS PROHIBITED!!!
    =================================================================
    ^C
    line con 0
    line aux 0
    line vty 0 4
    password mypassword
    transport input telnet ssh
    webvpn gateway MyGateway
    ip address 10.10.10.1 port 443 
    http-redirect port 80
    ssl trustpoint TP-self-signed-1279712955
    inservice
    webvpn install svc flash:/webvpn/svc_1.pkg sequence 1
    webvpn install csd flash:/webvpn/sdesktop.pkg
    webvpn context SecureMeContext
    title "My SSL VPN Service"
    secondary-color #C0C0C0
    title-color #808080
    ssl authenticate verify all
    url-list "MyServers"
       heading "My Intranet"
       url-text "Cisco" url-value "http://192.168.0.2"
       url-text "NetGear" url-value "http://192.168.0.3"
    login-message "Welcome to My VPN"
    policy group MyDefaultPolicy
       url-list "MyServers"
       functions svc-enabled
       svc address-pool "sslvpnpool"
       svc keep-client-installed
    default-group-policy MyDefaultPolicy
    aaa authentication list userAuthen
    gateway MyGateway domain testvpn
    max-users 100
    csd enable
    inservice
    end
    Thank you!

    Hi,
    Please check SAP note:
    2004579 - You cannot create a FR company from a Package
    Thanks & Regards,
    Nagarajan

  • While deploying to another server from RM client using build definition i got below error "Package location does not exist or deployer user does not have access"

    We have installed RM client in the POC  server .
    Installed Deployment Agent in Dev server .
    We created Configuration stages  for POC->Dev.
    We created a template with x copy deployer  and  selected source as build definition.
    While releasing we faced following issue ,
    The release was success in POC (Where RM client is installed), but in  DEV environment (Which is different server)it got rejected because of  the error
    "Package location(Path)  does not exist or deployer user does not have access"

    Hi Dhamayandhi
    There is quite a bit to do to get RM working successfully. I have a soup-to-nuts guide on implementing continuous delivery with TFS and RM
    here.
    Cheers - Graham
    Blog:
    http://pleasereleaseme.net   LinkedIn:

Maybe you are looking for