Sticky Insert Situation

I would be grateful if someone could shed light on this baffling 'issue' than I have:
In Forms 6i c/s the following code (forms program unit) does not insert properly:
n st.stan.tran1%TYPE; -- Varchar2(23)
BEGIN
n :=  '        ';
INSERT INTO NIK VALUES(n);
Forms_DDl('commit');
END;
It does not insert spaces i.e.
Nume@TEST()desc nik
Name                            Null?    Type
N                                        VARCHAR2(35)
Nume@TEST()select n||'*' from nik;
N||'*'
1 row selected.
The same code run as an anonymous plsql block in SQL*Plus works fine:
  1  declare
  2  n st.stan.tran1%TYPE; -- Varchar2(23)
  3  BEGIN
  4   n :=  '        ';
  5   INSERT INTO NIK VALUES(n);
  6  -- Forms_DDl('commit');
  7* END;
Nume@TEST()/
PL/SQL procedure successfully completed.
Nume@TEST()select n||'*' from nik;
N||'*'
* -- Insert via Forms6i Program Unit
        * -- Insert via anonymous block
2 rows selected.
Nume@TEST()
FORMS Version info is:
Forms [32 Bit] Version 6.0.8.23.2 (Production)
Oracle8i Enterprise Edition Release 8.1.7.4.0 - Production
     With the Partitioning option
     JServer Release 8.1.7.4.0 - Production
Oracle Toolkit Version 6.0.8.23.0 (Production)
PL/SQL Version 8.0.6.3.0 (Production)
Oracle Procedure Builder V6.0.8.20.0 Build #1377 - Production
PL/SQL Editor (c) WinMain Software (www.winmain.com), v1.0 (Production)
Oracle Query Builder 6.0.7.0.0 - Production
Oracle Virtual Graphics System Version 6.0.5.38.0 (Production)
Oracle Tools GUI Utilities Version 6.0.8.20.1 (Production)
Oracle Multimedia Version 6.0.8.20.0 (Production)
Oracle Tools Integration Version 6.0.8.18.0 (Production)
Oracle Tools Common Area Version 6.0.8.18.0
Oracle CORE Version 4.0.6.0.0 - Production
AND
SQL*Plus: Release 8.0.6.0.0 - Production on Mon Oct 18 14:42:33 2004
(c) Copyright 1999 Oracle Corporation.  All rights reserved.
Connected to:
Oracle8i Enterprise Edition Release 8.1.7.4.0 - Production
With the Partitioning option
JServer Release 8.1.7.4.0 - Production
SQL>
Am I missing something here ?
Thanks,
N.

I created a stored procedure and called that procedure by the form and it worked.
SQL> create or replace PROCEDURE insert_spaces (p_spaces IN varchar2) IS
2 BEGIN
3 insert into varchar2_test values (p_spaces);
4 commit;
5 end;
6 /
Procedure created.
Now I called that procedure in the form trigger, in the form I created a Push button and in when-button-pressed trigger I wrote:
insert_spaces(' ');
and it worked.
SQL> select rownum, substr(text||'*', 1, 25) text from varchar2_test;
ROWNUM TEXT
1 *
2 *
3 *
Row # 1 -- this result followed when I created program Unit
Row # 2 -- this result is from running anonymous Block in SQL*PLUS
Row # 3 -- this is what, when I called stored proc through when-button-pressed trigger
Thanks,
Biswa

Similar Messages

  • CSM Sticky Cookie Insert

    Hello,
    We have a Catalyst 6500 w/ CSM-S configuration that has 2 serverfarms with identical real servers using the same VIP. Each farm has 50 real servers (2 IPs with 25 consecutive ports each). One of the serverfarms is defined under a SLB policy with client NAT and the second one directly under the vserver. Both serverfarms are configured with the same sticky group for cookie insert. When I issue "show mod csm 13 sticky group 4" I only see 52 entries instead of 100. Also, some of the entries are duplicate. All the rest of the sticky groups are displaying the correct number of cookie entries, matching the number of real servers in the farms. Any ideas on why this is?

    You probably have encountered the following bug fixed only in version 4.2.2
    CSCsa74493
    CSM: sticky insert table not updated if adding new reals
    The workaround is to reboot the CSM or reconfigure reals, policy and vserver in the correct order.
    Gilles.

  • Shape traffic on multiple load balance interface

    Hi,
    Router A and Router B have 2 Gibic connectivity for load balance. For eg. outbound traffic from Router A to Router B are 700 Mbps and 750 Mbps.
    How can i shape Total Outbound Traffic from Router A to Router B at 1400 Mbps?   

    Sean,
    Maybe a little confused.
    I have built the new serverfarm, policy-map and class-map in bold, I am just not sure how it gets referenced. Do I add it to the multi-match class statement?  My complete config for this particular app is below.
    Thanks,
    Dave
    serverfarm host application-80
      rserver server1 80
        probe server-80-PROBE
        inservice
      rserver server2 80
        probe server-80-PROBE
        inservice
    serverfarm host application-L7
      rserve rserver1 80
        probe server-80-PROBE
        inservice
      rserver server2 80
        probe server-80-PROBE
        inservice
    class-map match-all application-80-CLASS
      2 match virtual-address 1.1.1.1 tcp eq www
    class-map type http loadbalance match-any application-L7-CLASS
      3 match http url /uri1/
      4 match http url /uri2/uri2
      5 match http url /uri2/uri3.htm
    policy-map type loadbalance first-match application-80-POLICY
      class class-default
        sticky-serverfarm application-80-STICKY
        insert-http X-Forwarded-For header-value "%is"
    policy-map type loadbalance first-match application-L7-POLICY
      class application-L7-CLASS
        serverfarm application-L7
    policy-map multi-match POLICY-424
    class application-80-CLASS
        loadbalance vip inservice
        loadbalance policy application-80-POLICY
        loadbalance vip icmp-reply
        nat dynamic 22 vlan 424
        appl-parameter http advanced-options CASE_PARAM

  • ACE 4710 - Parameters Lost in URL

    Hi Everyone,
    I have configured SSL offloading and redirection on a 4710 appliance. Everything works fine. The issue I am facing is that some parameters in url are getting lost.
    I have https://%h/%p configured as a redirect server which works fine as far as hostname and path is concerned. i.e. full hostname and path are preserved, but that there are some parameters after the full path in encrypted format which are getting lost. I think 307 redirect can resolve this issue but ACE does not support that.
    Has anyone faced something similar? Any suggestions would be helpful.
    Thanks.
    Rehan

    Hi,
    See the snip of the config
    parameter-map type ssl SSL-MAP
      session-cache timeout 600
    parameter-map type http HTTP-MAP
      persistence-rebalance
    rserver host E-SERVER01
      ip address X.X.X.Y
      inservice
    rserver host E-SERVER02
      ip address X.X.X.Z
      inservice
    rserver redirect E-SERVICE
      webhost-redirection https://%h/%p 302
      inservice
    serverfarm host E-SERVERS
      rserver E-SERVER01 80
        inservice
      rserver E-SERVER02 80
        inservice
    serverfarm redirect SF-RE-DIRECT
      rserver E-SERVICE
        inservice
    class-map match-any E-WEB-HTTP
      2 match virtual-address X.X.X.15 tcp eq www
    class-map match-any E-WEB-HTTPS
      3 match virtual-address X.X.X.15 tcp eq https
    sticky ip-netmask 255.255.255.255 address source WEB-STICKY
      replicate sticky
      serverfarm E-SERVERS
    policy-map type loadbalance first-match PM-E-WEB
      class class-default
        sticky-serverfarm WEB-STICKY
        insert-http ClientProtocol header-value "https"
    policy-map type loadbalance first-match PM-REDIRECT
      class class-default
        serverfarm SF-RE-DIRECT
    policy-map multi-match SLB-POLICY
      class E-WEB-HTTPS
        loadbalance vip inservice
        loadbalance policy PM-E-WEB
        loadbalance vip icmp-reply
        appl-parameter http advanced-options HTTP-MAP
        ssl-proxy server SSL-MAP
      class E-WEB-HTTP
        loadbalance vip inservice
        loadbalance policy PM-REDIRECT
        loadbalance vip icmp-reply
        appl-parameter http advanced-options HTTP-MAP
    @Jorge: The device has many policies and has been running for a few years, therefore the show stats http command will not be of much help as we may see other traffic statistics/errors. If your looking for max parse len errors then thats not happening. The url length is not that long. Let me know if anything specific you want me to check.
    @Cesar: I will check but as per the information I have there are some parameters after the complete path "/" which are hash value of an authentication request. Basically what is happening when the user goes to the page, user needs to enter credentials. Once the user clicks submit the page just reloads, instead of going to the requested url.
    Thanks for your support,
    Rehan

  • Multi-tech wireless hotspot deployment

    Hi, 
    I have a project to expand a wireless network in order to offer a Internet access service with public hotspot. This network consists on autonomous APs Cisco 1131G, and I should add more APs based on coverage and capacity. I am considering installing Cisco 1602I or 1131AG APs. 
    I doubt whether mixing equipment with different technologies (802.11n, 802.11g APs only, 802.11ag, beamforming, MIMO,...) can make multi-vendor clients experiencing problems with performance, roaming, or sticky-client situations
    Is really a problem? Have any experience or recommendation to avoid these situations? 
    Thank you,

    See if there is something here that helps....
    http://www.apple.com/education/it/mdm/

  • Cisco ACE VIP not responding to Pings

    I've searched.....  I cannot figure out why my VIPs do not ping.  I have two vlans that both replay to a ping on the interface IPs.  And I'm new at this, thanks in advace.
    GKEL2-ACE1/35568059-Axia# show run
    Generating configuration....
    no ft auto-sync startup-config
    logging enable
    logging timestamp
    logging trap 5
    logging host 10.85.242.100 udp/514
    login timeout 60
    crypto chaingroup walnut-wcrt100
      cert .dom.cer
      cert wcrt100.pem
    crypto chaingroup .dom-wcrt100
      cert .dom.cer
      cert wcrt100.pem
    crypto csr-params .dom
      country CA
      state AB
      organization-unit IT
      common-name .dom
      serial-number 1000
      email support
    crypto csr-params .dom
      country CA
      state AB
      organization-unit IT
      common-name .dom
      serial-number 1001
      email support
    access-list ANYONE line 10 extended permit ip any any
    access-list ANYONE line 20 extended permit icmp any any
    access-list All line 1 extended permit ip any any
    probe http HTTP1025
      port 1025
      interval 2
      faildetect 2
      passdetect interval 2
      request method get url /Login.css
      open 1
    probe icmp PING
      interval 2
      faildetect 2
      passdetect interval 60
    probe tcp PROBE-TCP
      interval 2
      faildetect 2
      passdetect interval 10
      passdetect count 2
      open 1
    rserver redirect REDIRECT-HTTPS
      webhost-redirection https://%h%p 302
      inservice
    rserver host WL1
      ip address 10.205.70.100
      inservice
    rserver host WL2
      ip address 10.205.70.101
      inservice
    rserver host WLDev1
      ip address 10.205.71.202
      inservice
    rserver host WLDev2
      ip address 10.205.71.203
      inservice
    rserver host WLTest1
      ip address 10.205.71.150
      inservice
    rserver host WLTest2
      ip address 10.205.71.151
      inservice
    serverfarm redirect REDIRECT-SERVERFARM
      rserver REDIRECT-HTTPS
        inservice
    serverfarm host WEBLOGIC-7433
      predictor leastconns
      probe PING
      rserver WL1 7433
        inservice
      rserver WL2 7433
        inservice
    serverfarm host WEBLOGIC-PROD
      predictor leastconns
      probe PING
      rserver WL1 1025
        inservice
      rserver WL2 1026
        inservice
    serverfarm host WEBLOGIC-TEST-SSH
      predictor leastconns
      rserver WLTest1 22
        inservice
      rserver WLTest2 22
        inservice
    sticky http-cookie acecookie STICKY-INSERT-COOKIE
      cookie insert
      serverfarm WEBLOGIC-PROD
    action-list type modify http REWRITE
      header insert response Via header-value "1.1 web:%ps (ace10-8/a2)value"
      header insert request Via header-value "1.1 web:%ps (ace10-8/a2)value"
      header insert request X-Forwarded-Proto header-value "%pd"
      ssl url rewrite location "*.*"
      ssl header-insert session Id
    ssl-proxy service ssl-client
    ssl-proxy service ssl-proxy
      key netcracker.cal.dom.key
      cert netcracker.cal.dom.cer
      chaingroup netcracker.cal.dom-wcrt100
    class-map match-any L4VIPCLASS
      2 match virtual-address 10.205.70.80 any
    class-map type http loadbalance match-any L7-URL
      2 match http url /*.*
    class-map type http loadbalance match-all L7SLBCLASS
      2 match http url /*
    class-map type management match-any REMOTE-MANAGEMENT
      2 match protocol telnet any
      3 match protocol icmp any
      4 match protocol ssh any
      5 match protocol snmp any
      6 match protocol http any
      7 match protocol https any
    class-map match-any SSH_Test
      2 match virtual-address 10.205.71.80 tcp eq 22
    class-map match-any weblogic-7433
      2 match virtual-address 10.205.70.80 tcp eq 7433
    class-map match-any weblogic-http
      2 match virtual-address 10.205.70.80 tcp eq www
    class-map match-any weblogic-https
      2 match virtual-address 10.205.70.80 tcp eq https
    policy-map type management first-match REMOTE-MANAGEMENT
      class REMOTE-MANAGEMENT
        permit
    policy-map type loadbalance first-match L7SLBPOLICY
      class L7SLBCLASS
        ssl-proxy client ssl-client
    policy-map type loadbalance first-match SSH_Test_Policy
      class class-default
        serverfarm WEBLOGIC-TEST-SSH
    policy-map type loadbalance first-match weblogic-7433-policy
      class class-default
        serverfarm WEBLOGIC-7433
        ssl-proxy client ssl-client
    policy-map type loadbalance first-match weblogic-http-policy
      class class-default
        serverfarm REDIRECT-SERVERFARM
    policy-map type loadbalance first-match weblogic-https-policy
      class L7-URL
        sticky-serverfarm STICKY-INSERT-COOKIE
      class class-default
        serverfarm WEBLOGIC-PROD
        action REWRITE
        ssl-proxy client ssl-proxy
    policy-map multi-match L4LSBPOLICY
      class L4VIPCLASS
        loadbalance policy L7SLBPOLICY
    policy-map multi-match LB-VIP
      class weblogic-http
        loadbalance vip inservice
        loadbalance policy weblogic-http-policy
        loadbalance vip icmp-reply
        nat dynamic 1 vlan 3440
      class weblogic-https
        loadbalance vip inservice
        loadbalance policy weblogic-https-policy
        loadbalance vip icmp-reply
        nat dynamic 1 vlan 3440
        ssl-proxy server ssl-proxy
      class weblogic-7433
        loadbalance vip inservice
        loadbalance policy weblogic-7433-policy
        loadbalance vip icmp-reply
        nat dynamic 1 vlan 3440
        ssl-proxy server ssl-proxy
    policy-map multi-match LB-VIP-Test
      class SSH_Test
        loadbalance vip inservice
        loadbalance policy SSH_Test_Policy
        loadbalance vip icmp-reply
    interface vlan 3440
      description Internal Production
      ip address 10.205.70.250 255.255.255.0
      access-group input All
      access-group output All
      nat-pool 1 10.205.70.249 10.205.70.249 netmask 255.255.255.0 pat
      service-policy input REMOTE-MANAGEMENT
      service-policy input LB-VIP
      service-policy input L4LSBPOLICY
      no shutdown
    interface vlan 3516
      description Internal Test/Dev
      ip address 10.205.71.250 255.255.255.0
      access-group input All
      access-group output All
      nat-pool 2 10.205.71.249 10.205.71.249 netmask 255.255.255.0 pat
      service-policy input REMOTE-MANAGEMENT
      service-policy input LB-VIP-Test
      no shutdown
    interface vlan 3520
      description LB
      ip address 10.205.72.1 255.255.255.0
      access-group input All
      access-group output All
      no shutdown
    ip route 0.0.0.0 0.0.0.0 10.205.70.253
    username admin password 5 $1$r2r0NmEH$z8S0RxYdhwOE4RGXQ41  role Admin domain default-domain
    username cust_admin password 5 $1$/tOIIfUK$yigE519cqLq1IFgX.  role Admin domain default-domain

    I have removed that service policy completely.  It was from some knowledgebase article when I was trying to get http redirection working. 
    There is no more L4LSBPOLICY nor L4VIPCLASS, Thanks a lot for looking at this...
    GKEL2-ACE1/35568059-Axia# show service-policy summary
    service-policy: LB-VIP
    Class                            VIP             Prot  Port        VLAN          State    Curr Conns   Hit Count  Conns Drop
    weblogic-http                    10.205.70.80    tcp   eq 80       1,3440        IN-SRVC           0       50773         53
    weblogic-https                   10.205.70.80    tcp   eq 443      1,3440        IN-SRVC           0        7406        112
    weblogic-7433                    10.205.70.80    tcp   eq 7433     1,3440        IN-SRVC           0      145321         30
    service-policy: LB-VIP-Dev
    Class                            VIP             Prot  Port        VLAN          State    Curr Conns   Hit Count  Conns Drop
    weblogic-http-dev                10.205.71.90    tcp   eq 80       1,3516        IN-SRVC           0           0          0
    weblogic-https-dev               10.205.71.90    tcp   eq 443      1,3516        IN-SRVC           0           0          0
    weblogic-7433-dev                10.205.71.90    tcp   eq 7433     1,3516        IN-SRVC           0           0          0
    service-policy: LB-VIP-Test
    Class                            VIP             Prot  Port        VLAN          State    Curr Conns   Hit Count  Conns Drop
    SSH_Test                         10.205.71.80    tcp   eq 22       1,3516        IN-SRVC           0          29         24
    weblogic-http-test               10.205.71.80    tcp   eq 80       1,3516        IN-SRVC           0         117         40
    weblogic-https-test              10.205.71.80    tcp   eq 443      1,3516        IN-SRVC           0         161         61
    weblogic-7433-test               10.205.71.80    tcp   eq 7433     1,3516        IN-SRVC           0          27         11
    class-map type http loadbalance match-any L7-URL
      2 match http url /*.*
    class-map type http loadbalance match-all L7SLBCLASS
      2 match http url /*
    class-map type management match-any REMOTE-MANAGEMENT
      2 match protocol telnet any
      3 match protocol icmp any
      4 match protocol ssh any
      5 match protocol snmp any
      6 match protocol http any
      7 match protocol https any
    class-map match-any SSH_Test
      2 match virtual-address 10.205.71.80 tcp eq 22
    class-map match-any weblogic-7433
      2 match virtual-address 10.205.70.80 tcp eq 7433
    class-map match-any weblogic-7433-dev
      2 match virtual-address 10.205.71.90 tcp eq 7433
    class-map match-any weblogic-7433-test
      2 match virtual-address 10.205.71.80 tcp eq 7433
    class-map match-any weblogic-http
      2 match virtual-address 10.205.70.80 tcp eq www
    class-map match-any weblogic-http-dev
      2 match virtual-address 10.205.71.90 tcp eq www
    class-map match-any weblogic-http-test
      2 match virtual-address 10.205.71.80 tcp eq www
    class-map match-any weblogic-https
      2 match virtual-address 10.205.70.80 tcp eq https
    class-map match-any weblogic-https-dev
      2 match virtual-address 10.205.71.90 tcp eq https
    class-map match-any weblogic-https-test
      2 match virtual-address 10.205.71.80 tcp eq https
    policy-map type management first-match REMOTE-MANAGEMENT
      class REMOTE-MANAGEMENT
        permit
    policy-map type loadbalance first-match L7SLBPOLICY
      class L7SLBCLASS
        ssl-proxy client ssl-client
    policy-map type loadbalance first-match SSH_Test_Policy
      class class-default
        serverfarm WEBLOGIC-TEST-SSH
    policy-map type loadbalance first-match weblogic-7433-dev-policy
      class class-default
        serverfarm WEBLOGIC-7433-Dev
    policy-map type loadbalance first-match weblogic-7433-policy
      class class-default
        serverfarm WEBLOGIC-7433
        ssl-proxy client ssl-client
    policy-map type loadbalance first-match weblogic-7433-test-policy
      class class-default
        serverfarm WEBLOGIC-7433-Test
        ssl-proxy client ssl-client
    policy-map type loadbalance first-match weblogic-http-dev-policy
      class class-default
        serverfarm REDIRECT-SERVERFARM
    policy-map type loadbalance first-match weblogic-http-policy
      class class-default
        serverfarm REDIRECT-SERVERFARM
    policy-map type loadbalance first-match weblogic-http-test-policy
      class class-default
        serverfarm REDIRECT-SERVERFARM
    policy-map type loadbalance first-match weblogic-https-dev-policy
      class L7-URL
        sticky-serverfarm STICKY-INSERT-COOKIE-DEV
      class class-default
        serverfarm WEBLOGIC-DEV
        action REWRITE
    policy-map type loadbalance first-match weblogic-https-policy
      class L7-URL
        sticky-serverfarm STICKY-INSERT-COOKIE
      class class-default
        serverfarm WEBLOGIC-PROD
        action REWRITE
        ssl-proxy client ssl-proxy
    policy-map type loadbalance first-match weblogic-https-test-policy
      class L7-URL
        sticky-serverfarm STICKY-INSERT-COOKIE-TEST
      class class-default
        serverfarm WEBLOGIC-TEST
        action REWRITE
        ssl-proxy client ssl-proxy-nctest
    policy-map multi-match LB-VIP
      class weblogic-http
        loadbalance vip inservice
        loadbalance policy weblogic-http-policy
        loadbalance vip icmp-reply active
        nat dynamic 1 vlan 3440
      class weblogic-https
        loadbalance vip inservice
        loadbalance policy weblogic-https-policy
        loadbalance vip icmp-reply
        nat dynamic 1 vlan 3440
        ssl-proxy server ssl-proxy
      class weblogic-7433
        loadbalance vip inservice
        loadbalance policy weblogic-7433-policy
        loadbalance vip icmp-reply
        nat dynamic 1 vlan 3440
        ssl-proxy server ssl-proxy
    policy-map multi-match LB-VIP-Dev
      class weblogic-http-dev
        loadbalance vip inservice
        loadbalance policy weblogic-http-dev-policy
        loadbalance vip icmp-reply
        nat dynamic 1 vlan 3516
      class weblogic-https-dev
        loadbalance vip inservice
        loadbalance policy weblogic-https-dev-policy
        loadbalance vip icmp-reply
        nat dynamic 1 vlan 3516
      class weblogic-7433-dev
        loadbalance vip inservice
        loadbalance policy weblogic-7433-dev-policy
        loadbalance vip icmp-reply
        nat dynamic 1 vlan 3516
    policy-map multi-match LB-VIP-Test
      class SSH_Test
        loadbalance vip inservice
        loadbalance policy SSH_Test_Policy
        loadbalance vip icmp-reply
        nat dynamic 1 vlan 3516
      class weblogic-http-test
        loadbalance vip inservice
        loadbalance policy weblogic-http-test-policy
        loadbalance vip icmp-reply
        nat dynamic 1 vlan 3516
      class weblogic-https-test
        loadbalance vip inservice
        loadbalance policy weblogic-https-test-policy
        loadbalance vip icmp-reply
        nat dynamic 1 vlan 3516
        ssl-proxy server ssl-proxy-nctest
      class weblogic-7433-test
        loadbalance vip inservice
        loadbalance policy weblogic-7433-test-policy
        loadbalance vip icmp-reply
        nat dynamic 1 vlan 3516
        ssl-proxy server ssl-proxy-nctest
    interface vlan 3440
      description Internal Production
      ip address 10.205.70.250 255.255.255.0
      mac-sticky enable
      access-group input All
      access-group output All
      nat-pool 1 10.205.70.249 10.205.70.249 netmask 255.255.255.0 pat
      service-policy input REMOTE-MANAGEMENT
      service-policy input LB-VIP
      no shutdown
    interface vlan 3516
      description Internal Test/Dev
      ip address 10.205.71.250 255.255.255.0
      mac-sticky enable
      access-group input All
      access-group output All
      nat-pool 1 10.205.71.240 10.205.71.249 netmask 255.255.255.0 pat
      service-policy input REMOTE-MANAGEMENT
      service-policy input LB-VIP-Test
      service-policy input LB-VIP-Dev
      no shutdown
    interface vlan 3520
      description LB
      ip address 10.205.72.1 255.255.255.0
      access-group input All
      access-group output All
      no shutdown
    ip route 0.0.0.0 0.0.0.0 10.205.70.253

  • ACE behind Reverse Proxy - performance issue

    Hi,
      I've got a config working to accommodate the required use of reverse proxy servers infront of my application servers.  Traffic comes into the Front ACE and I insert a header "SRCIP" with the original client IP address which is preserved through the Rev Proxy servers and is then inspected on the Back ACE to create a sticky to a given application server/SRCIP pairing.  The use of the RP's appears to require using the persistence-rebalance option otherwise the traffic get stuck to the wrong app server.  The app functions perfectly with this config; however, there is a severe performance impact.  Using load-runner, we see response times go from 1.5 seconds to 16 seconds for the same transactions comparing this config to a previous config which used static sticky to bind the RP to the app servers..
    Question:  Is there a better way to do this and remain dynamic, or some way to optimize this approach to reduce the performance impact.
    Relevant Config for both ACE's here:
    !!Front ACE
    parameter-map type http HTTP_REBAL
      persistence-rebalance
      length-exceed continue
    sticky ip-netmask 255.255.255.255 address source ALPHA-SRCIP-sticky
      timeout 60
      replicate sticky
      serverfarm ALPHA
    policy-map type loadbalance first-match vip-R1A-ALPHA
      class class-default
        sticky-serverfarm ALPHA-SRCIP-sticky
        insert-http SRCIP header-value "%is"
    policy-map multi-match PREP-VIP
      class VIP-ALPHA-R1A
        loadbalance vip inservice
        loadbalance policy vip-R1A-ALPHA
        appl-parameter http advanced-options HTTP_REBAL
        ssl-proxy server SSL_ALPHA_R1A
    !!Back ACE
    parameter-map type http HTTP_REBAL
      persistence-rebalance
      length-exceed continue
    sticky http-header SRCIP ALPHA-SRCIP-sticky
      timeout 60
      replicate sticky
      serverfarm coresoms-ALPHAfarm
    class-map type http loadbalance match-all SRCIP-MAP
      2 match http header SRCIP header-value ".*"
    policy-map type loadbalance first-match vip-lb-ALPHA
      class SRCIP-MAP
        sticky-serverfarm ALPHA-SRCIP-sticky
    policy-map multi-match lb-vip
      class VIP-ALPHA
        loadbalance vip inservice
        loadbalance policy vip-lb-ALPHA
        appl-parameter http advanced-options HTTP_REBAL

    Hi Joseph,
    To achieve this you need to do stickiness based on some L7 parameter (either the header you are currently using or some cookie), so, whatever you do you will have to use persistence rebalance.
    I have one possible theory for your issue.
    The ACE has two different ways of treating the L7 connections internally, that we call "proxied" and "unproxied". In essence, the proxied mode means that the traffic will be processed by one of the CPU (normally to inspect/modify the L7 data), while, on the unproxied mode, the ACE sets up a hardware shortcut that allows forwarding traffic without the need to do any processing on it.
    For a L7 connection, the ACE will proxy it at the beginning, and, once all the L7 processing has been done it will unproxy the connection to save resources. Before it goes ahead with the unproxying, it needs to see the ACK for the last L7 data sent. This wait, on a Internet environment can introduce around 100-200ms of delay for each HTTP request, which can end up adding into a very big delay. By default, if the ACE sees that the RTT to the client is more than 200ms, the connection will never be unproxied to avoid these delays, so I think we could fix your issue by tweaking this threshold.
    From what you described, I asssume you don't have many connections (because they all come through a proxy) and that the connections will have a lot of HTTP requests inside. With that in mind, I would suggest setting the threshold to 0 to ensure to keep connections always proxied. To do this, you would nee to configure a parameter map like the one below and add it to your VIP
        parameter-map type connection
          set tcp wan-optimization rtt 0
    Even though this setting may avoid your issue, it also has some drawbacks. The main one is that the ACE20 only supports up to 512K simultaneous L7 connections in proxied state (which includes also the connections towards the servers, so, it would be 250K for client connections), so, if the amount of simultaneous connections reaches that limit, new connections would be dropped. The second issue, although not so impacting, would be that the maximum number of connections per second supported would also go down slightly due to the increased processing needed.
    I hope this helps
    Daniel

  • Load balance multiple URLs on single VIP

    Hello,
    I have a fairly typical load balance configuration on a pair of ACE appliances running (A3)2.5 and now I need to load balance multiple URIs to these same servers on port 80 to the one VIP. Can someone direct me to a doc that shows a good example of this, or explain it below?
    Thanks,
    Dave
    serverfarm host application
    rserver webserver1 80
    probe server-80-PROBE
    inservice
    rserver webserver2 80
    probe server-80-PROBE
    inservice
    sticky ip-netmask 255.255.255.255 address source application-80-STICKY
    replicate sticky
    serverfarm application
    class-map match-all application-80-CLASS
    2 match virtual-address 1.1.1.1.1 tcp eq www
    policy-map type loadbalance first-match application-80-POLICY
    class class-default
    sticky-serverfarm application-80-STICKY
    insert-http X-Forwarded-For header-value "%is"
    class application-80-CLASS
    loadbalance vip inservice
    loadbalance policy application-80-POLICY
    loadbalance vip icmp-reply
    nat dynamic 22 vlan 424
    appl-parameter http advanced-options CASE_PARAM

    Sean,
    Maybe a little confused.
    I have built the new serverfarm, policy-map and class-map in bold, I am just not sure how it gets referenced. Do I add it to the multi-match class statement?  My complete config for this particular app is below.
    Thanks,
    Dave
    serverfarm host application-80
      rserver server1 80
        probe server-80-PROBE
        inservice
      rserver server2 80
        probe server-80-PROBE
        inservice
    serverfarm host application-L7
      rserve rserver1 80
        probe server-80-PROBE
        inservice
      rserver server2 80
        probe server-80-PROBE
        inservice
    class-map match-all application-80-CLASS
      2 match virtual-address 1.1.1.1 tcp eq www
    class-map type http loadbalance match-any application-L7-CLASS
      3 match http url /uri1/
      4 match http url /uri2/uri2
      5 match http url /uri2/uri3.htm
    policy-map type loadbalance first-match application-80-POLICY
      class class-default
        sticky-serverfarm application-80-STICKY
        insert-http X-Forwarded-For header-value "%is"
    policy-map type loadbalance first-match application-L7-POLICY
      class application-L7-CLASS
        serverfarm application-L7
    policy-map multi-match POLICY-424
    class application-80-CLASS
        loadbalance vip inservice
        loadbalance policy application-80-POLICY
        loadbalance vip icmp-reply
        nat dynamic 22 vlan 424
        appl-parameter http advanced-options CASE_PARAM

  • ACE SSL Proxy performance issue

    Hi I've got an ACE module in a 6500 that is being used as an SSL Proxy For a web service.
    So the configuration is fairly basic, matches a VIP which has been Nat'ed from the public IP address port 443 and load balances over a number of reservers with the server ports being set to 80.
    The problem is the main web site is hosted elsewhere and so when they switch to checkout on a secure port the browser page requests multiple https:// files .
    The users are seeing very slow page loads a considerable amount longer than equivalent on http and more than you'd expect. The ACE is no where near any throughout or transaction limits.
    My concern is on how the session is tracked, would the ACE attempt to renegotiate with every https:// get? I've seen example configs for stickiness inserting cookies for normal end-end load balancing but not with an SSL proxy configuration.
    Sent from Cisco Technical Support iPad App

    Hi Craig,
    The SSL negotiation/handshake will happen everytime a client opens a new TCP connection i.e comes with a different source port.
    To make sure that ACE doesn't renegotiate you can try and use this command:
    (config-parammap-ssl)# session-cache timeout . You can use 24 hours or anytime you think is suitable.
    This is basically to enable SSL session reuse. A little explanation below for your reference:
    When client connects to a server over SSL, the server creates a session for that connection. This session ID is sent as a part of the Server Hello message. This is to make things efficient, in case the client has any plans of closing the current connection and reconnect in the near future. Most of the servers have a time out for these sessions (I think 24 hours is a common value, unless pressed for space).
    When the client connects to the same server again, it can send the same session ID as a part of the Client Hello. The server will first look up if it can find any sessions with that ID. If found, the same session will be reused. Thus the time spent in verifying the certs and negotiating the keys is saved. If the server cannot find a matching session, then it responds with a new session ID and its certificate in Server Hello message. The client knows that it has to verity the cert and negotiate the key again.
    Considerable amount of time is spent in validating server certs. Reusing SSL session will save this time.
    Having said that you need to check if the client is coming with a session ID which it got in previous handshake or not. If it doesn't and it is a new TCP connection then SSL handshake will happen. Please enable that command before testing.
    Also, ensure that you have allocated proper SSL resources to your context. Lack of resources can also cause dropped connections and sluggish performance.
    Regards,
    Kanwal

  • Is there a manual eject?

    my cd drive tray still has problems, i've tried everything suggested but it just wont open if it doesnt have a cd in it. Is there a manual eject for the imac G4?

    Bella&Me,The Open Firmware option works in almost all cases. Follow these instructions:
    Switch on/reboot
    After the startup chime, press and hold <command/apple> <alt/option> <o> <f>
    At the command line prompt, type: eject cd
    Hit Return, the optical drive will then eject.
    Type: mac-boot
    Hit return.
    - I had a fried logic board and wanted to clear the Optical Drive before I took the iMac in to a local AASP for repair - hence my extreme 'crack the case' solution - I wouldn't recommend it in your case.
    It's something I've wondered about wireless keyboards - how good they are when you need to get yourself out of a sticky mac situation - do they let you down?
    mrtotes

  • In Adobe Reader (11.0) the typing is very slow when I insert sticky notes.

    I bought a new laptop and I just installed the latest version of Adobe Reader.
    When I insert sticky notes, typing is very slow. This doesn't happen with the
    other program. I've uninstalled and reinstalled. I still have the same problem.

    This phenomenon can happen with PDF files that have errors in them.  Adobe Reader or Acrobat may be able to fix these errors, but if you close the application, it will ask to save the corrected file.  If you save it once, that should no longer occur when you open it again.
    This is just one explanation, but it doesn't explain why that happens with every PDF you have.
    Test: does it also happen with a PDF that is not supposed to contain any errors: http://helpx.adobe.com/pdf/adobe_reader_reference.pdf ?

  • What can I do for the following situation: I think my insert slot for the headphones does not work; when I put in any cable that should and can go in all I hear is low frequent static sounds.

    What can I do for the following situation: I think my insert slot for the headphones does not work; when I put in any cable that should and can go in all I hear is low frequent static sounds.

    You might try talking to the Apple store manager and see if you don't get more help...you might also contact Apple.com/support and see if they can give you a contact with the Apple Italy offices.
    Sounds like you have two levels of failure, the first shop that did the repair and broke a wire, and the second that has disabled something else and isn't helping.
    Apple officially refurbished equipment is usually good quality.  Surprising this has happened but you need to press on with complaints and try for resolution.

  • How do I insert the logged in application username programmatically in sticky notes.

    We have a multiuser application where different users can access the same PDF document and can add sticky notes,
    The application uses Acrobat PDF Control for displaying the PDF content. Is there any option to add the logged in user's username through the program with the sticky notes?

    This is forum for Adobe Acrobat issues not some open source project. You might want to contact the developer of PDF Viewer Control with your issue.

  • An INSERT EXEC statement cannot be nested.Please tel me some good way of formulation in following situation.

    Hi,
        The following query is showing error An INSERT EXEC statement cannot be nested
    CREATE PROCEDURE [dbo].[Procedur3]
    @para1 int
    AS
    BEGIN
    CREATE TABLE #tem
    select * from detialpar where did=@para1
    --this code is quite big and is called from many place so we kept it inside this SP , so that we can call the sp to get result.
    END
    CREATE PROCEDURE [dbo].[Procedur2]
    @para1 int
    @para2 datetime
    AS
    BEGIN
    CREATE TABLE #tem
    insert into #tem (value) exec [dbo].[Procedure3] @para1
    exec ('select * from abc
    left join #tem on id=temid
    where id =' + cast(@para1 as varchar) -- i do not want to change this big dynamic query, because it has many optonal code concatinated by using "if then else".
    END
    CREATE PROCEDURE [dbo].[Procedure1]
    @para1 int,
    @para2 datetime
    AS
    BEGIN
    delete from table1 where id=@para1
    insert into table1 ( col1,col2) exec Procedure2 @para1,@para2
    ……. There are many blocks in this SP where we are deleting and inserting with different SP .
    select Name,Amount from #Temp1
    END
    CREATE PROC Procedure
    AS
    BEGIN
    SET TRANSACTION ISOLATION LEVEL SNAPSHOT
    SET NOCOUNT ON
    LOOP "A" starts here which gests id from a table xyz @para1
    begin try
    begin trans
    exec [Procedure1] @para1
    LOOP "A" ents here
    COMMIT TRANSACTION;
    END TRY
    BEGIN CATCH
    IF @@trancount > 0 ROLLBACK TRANSACTION;
    END CATCH;
    END
    GO
    Please tel me some good way of solving the error.
    yours sincerly

    You can not do like above:
    Try the below:(Not tested), Below, we do not change the code, however, we placed your dynamic execution to different procedure.
    CREATE PROCEDURE [dbo].[Procedur3]
    @para1 int
    AS
    BEGIN
    CREATE TABLE #tem
    insert into #tem (value)
    select * from detialpar where did=@para1
    --this code is quite big and is called from many place so we kept it inside this SP , so that we can call the sp to get result.
    END
    CREATE PROCEDURE [dbo].[Procedur2]
    @para1 int
    @para2 datetime
    AS
    BEGIN
    CREATE TABLE #tem
    exec [dbo].[Procedure3] @para1
    END
    CREATE PROCEDURE [dbo].[Procedure1]
    @para1 int,
    @para2 datetime
    AS
    BEGIN
    delete from table1 where id=@para1
    insert into table1 ( col1,col2)
    exec ('select * from abc
    left join #tem on id=temid
    where id =' + cast(@para1 as varchar) -- i do not want to change this big dynamic query, because it has many optonal code concatinated by using "if then else".
    ……. There are many blocks in this SP where we are deleting and inserting
    with different SP .
    select Name,Amount from #Temp1
    END
    CREATE PROC Procedure
    AS
    BEGIN
    SET TRANSACTION ISOLATION LEVEL SNAPSHOT
    SET NOCOUNT ON
    LOOP "A" starts here which gests id from a table xyz @para1
    begin try
    begin trans
    exec [Procedure1] @para1
    LOOP "A" ents here
    COMMIT TRANSACTION;
    END TRY
    BEGIN CATCH
    IF @@trancount > 0 ROLLBACK TRANSACTION;
    END CATCH;
    END
    GO

  • Sticky situation negotiating pay but also leaving job

    No offers from any new company yet, just looking actively, applying etc, talking to a few possibles. Possibly looking at moving out of our city too.No pay/benefit will make me stay because it's just a smaller company that has limited growth potential. I'll always be a one-man show and not see a larger network/environment to help grow my skills and experience. I've been there 5 years and every year has seen new learning challenges but not all in IT. I don't want to sound shallow and say just money will keep me. It's also about what's best for my family and career. There won't ever be typical benefits like health insurance because they are too small to be required to offer it.I sent the letter to them because even if it takes me 3 months to find work, if I get a $500 or $1000 increase per month, why not? I did not actually expect them to...

    I've been looking to move into a new position, I have a recruiter, fixing up the old resume, making some connections. Things are moving.But at the same time, I submitted a long letter to the boss as to my current role, responsibilities, duties, pay, and my history at the company.In a surprising move, the bosses agreed that I'm not where I should be and that my value is more than what I'm making now. They want to discuss options very soon as to pay increase and benefits etc. (within a week)Now I'm in a pickle. I'm pretty much still looking for a job and will leave when something fitting comes up, but now I'm about to negotiate for more pay at the current job.Part of me feels bad about trying to get more pay, when I'm just going to leave whenever. But the other part of me says, take what I can get because job hunting can take time.I...
    This topic first appeared in the Spiceworks Community

Maybe you are looking for

  • How do I identify the version of Photoshop I have?

    I have a copy of photoshop cs6 (pc) for windows. On the disc it has the  number 91055319. I have lost the outer packaging so can you tell me what version of cs6 this is? I mean is it 1 pc / 2pc / full retail / student etc... I do remember down the si

  • Setting default font size in Safari

    Hi. I like to set my font size in Safari to one level below the default. I usually do this everytime I open up a Safari window and hit Command+Minus or go to View > make text smaller. Anyway, I was wondering if there was a way I could set this to def

  • Attribute of  subtype  not showing in supertype after delegation

    Hi, i've created a subtype of BUS2089 called ZBUS2089 added some attributes and then delegated to the BUS2089 but the new attributes are not showing, Any ideas? Thanzs in advanced to all Regards Jaime

  • Apple Configurator and multiple users

    I am the Apple admin for a large school district.  I have setup 1200 iPads against some 20 machines (as we have a seperate "configurator station" per school) using a local admin account (the IT maintinence account.  The issue now is that when a contr

  • Investment Management - Configuration and User Document

    Hi Can anybody provide the Configuration and User Documentation for Investment Management. I am new to this area. My E-mail ID is [email protected] Cheers V.Krishnan