Load balance multiple URLs on single VIP

Hello,
I have a fairly typical load balance configuration on a pair of ACE appliances running (A3)2.5 and now I need to load balance multiple URIs to these same servers on port 80 to the one VIP. Can someone direct me to a doc that shows a good example of this, or explain it below?
Thanks,
Dave
serverfarm host application
rserver webserver1 80
probe server-80-PROBE
inservice
rserver webserver2 80
probe server-80-PROBE
inservice
sticky ip-netmask 255.255.255.255 address source application-80-STICKY
replicate sticky
serverfarm application
class-map match-all application-80-CLASS
2 match virtual-address 1.1.1.1.1 tcp eq www
policy-map type loadbalance first-match application-80-POLICY
class class-default
sticky-serverfarm application-80-STICKY
insert-http X-Forwarded-For header-value "%is"
class application-80-CLASS
loadbalance vip inservice
loadbalance policy application-80-POLICY
loadbalance vip icmp-reply
nat dynamic 22 vlan 424
appl-parameter http advanced-options CASE_PARAM

Sean,
Maybe a little confused.
I have built the new serverfarm, policy-map and class-map in bold, I am just not sure how it gets referenced. Do I add it to the multi-match class statement?  My complete config for this particular app is below.
Thanks,
Dave
serverfarm host application-80
  rserver server1 80
    probe server-80-PROBE
    inservice
  rserver server2 80
    probe server-80-PROBE
    inservice
serverfarm host application-L7
  rserve rserver1 80
    probe server-80-PROBE
    inservice
  rserver server2 80
    probe server-80-PROBE
    inservice
class-map match-all application-80-CLASS
  2 match virtual-address 1.1.1.1 tcp eq www
class-map type http loadbalance match-any application-L7-CLASS
  3 match http url /uri1/
  4 match http url /uri2/uri2
  5 match http url /uri2/uri3.htm
policy-map type loadbalance first-match application-80-POLICY
  class class-default
    sticky-serverfarm application-80-STICKY
    insert-http X-Forwarded-For header-value "%is"
policy-map type loadbalance first-match application-L7-POLICY
  class application-L7-CLASS
    serverfarm application-L7
policy-map multi-match POLICY-424
class application-80-CLASS
    loadbalance vip inservice
    loadbalance policy application-80-POLICY
    loadbalance vip icmp-reply
    nat dynamic 22 vlan 424
    appl-parameter http advanced-options CASE_PARAM

Similar Messages

  • Recommended configuration for load balanced Portal with load balancer, multiple gateways and multiple servers.

    Does anyone have a recommended network, hardware and software configuration guide for a Portal installation running with multiple gateways load balanced (ie one URL) that talk to multiple servers?

    David,
    We've used Resonate (software) to load balance the gateways. It allows
    you to group all the gateways under 1 virtual URL and load balance the
    incoming connections over each gateway depending on the rules that you
    define in Resonate. Look in the SUN portal whitepapers there is one that
    talks about it specifically.
    As far as load balancing the calls to the portals, the gateways will
    automatically load balance across all the portals that they know about
    using a simple round-robin rotation. You may be able to use Resonate in
    front of the portals but you may need to activate persistance within
    Resonate to ensure that the user always ends up on the portal that he
    established his initial connection on (if you want that), check with Sun
    on this one.
    David Broeren wrote:
    Recommended configuration for load balanced Portal with load balancer,
    multiple gateways and multiple servers.
    Does anyone have a recommended network, hardware and software
    configuration guide for a Portal installation running with multiple
    gateways load balanced (ie one URL) that talk to multiple servers?
    Try our New Web Based Forum at http://softwareforum.sun.com
    Includes Access to our Product Knowledge Base!

  • Load balancing multiple J2ee servers - each running it's own CI

    Is it possible to load balance multiple J2ee servers(running Portal), both running it's own Central Instance?
    We do not have the resources (SAN storage) to implement MSCS for Portal...so instead we want to use two complete Portal servers HW load balanced with the ability to keep running in case one fails.
    thanks for any info !
    Linwood

    Hi Linwood,
    in a nutshell, the difference between an ordinary J2EE server instance and the central instance are the central services. The central services (enqueue server, message server) are only needed once. Basically, they are required for the communication between the server instances (and to the load balancer). What you should go for is a cluster installation with one central instance and another ordinary server instance (both running the SAP NetWeaver Portal). But be aware that you have to use the same database for both server instances (otherwise you cannot guarantee consistent data).
    For load balancing the two server you can use the SAP Web Dispatcher  or any other load balancer tool you like. 
    You will find more and detailed information on load balancing in the SAP Library. Have a look into section <a href="http://help.sap.com/saphelp_nw2004s/helpdata/en/2e/611724f410254ca12a3f396ec5ae85/frameset.htm">Java Cluster Architecture</a>.
    Hope I could help!
    Best regards,
    Martin

  • Load Balancer virtual URL not working with analytics page

    We have configured Load Balancer virtual URL. But it is working for only iAS. We have Oracle Application Server 10.1.3
    Our OBIEE is 10.1.3.4.1
    Here is the virtual configuration
    Listen 7877
    +<VirtualHost default:7877>+
    +# General setup for the virtual host+
    DocumentRoot "/apps_base/obiee/ias/Apache/Apache/htdocs"
    ServerName uat.bi.company.com
    ServerAdmin [email protected]
    ErrorLog "|/apps_base/obiee/ias/Apache/Apache/bin/rotatelogs /apps_base/obiee/ias/Apache/Apache/logs/error_log 43200"
    TransferLog "|/apps_base/obiee/ias/Apache/Apache/bin/rotatelogs /apps_base/obiee/ias/Apache/Apache/logs/access_log 43200"
    Port 443
    +# SSL Engine Switch:+
    +# Enable/Disable SSL for this virtual host.+
    SSLEngine on
    https://uat.bi.company.com -> WORKS great
    https://uat.bi.company.com/em -> WORKS great
    https://uat.bi.company.com/analytics -> page cannot be displayed
    We have SSO configured. So i do get the SSO login page, but clicking on submit button, I get page cannot be displayed.
    Everything works if I disable the load balancer virtual.
    THe Load Balancer is configured to listen on 443 and then routes to 7877 on the physical server coorldas04.company.com
    Can you assist in this one ??

    Is this still a problem?

  • Using a single CSS to load balance multiple services

    Is it possible to use a single CSS to load balance 3 different services (server farm) ? That mean the CSS need to advertise 3 VIP
    I'm thinking of two scenarios:
    1 - configure the CSS to use 4 interfaces: 1 to public, 3 to private (each interface will plug-in to a different vlan/server farm)
    2 - configure the CSS to use 2 interfaces: 1 to public, 1 to private (all 3 server farms are in the same vlan)
    Will both scenarios work ?
    Thanks
    --Phillip.

    Hi Phillip,
    both scenarios will work. One CSS can certainly manage more than 3 services! You can even use just one VIP for all traffic, then just create the proper rules to send specific traffic to the corresponding service(s). No need for 3 VIPs.
    Regards
    -juerg

  • Load balancing multiple SSO mid-tier with single SSO database

    I want to load balance SSO middle tier servers and have them access a single SSO database. When you install infrastructure and select SSO only it creates a new infrastructure database. How can I install multiple SSO servers and point them to a single database. I am doing Load Balancing with F5 and read an Oracle WP where they mentioned an Oracle supported configuration where they load balanced SSO servers with F5.
    KB

    Two possible solutions:
    1.) Oracle 10gAS Enterprise Deployment Guide (B13998-03) follow the configuration for SSO configuration in Chapter 5.
    2.) I have not tried this but it should be logically possible with the SSO. 10gAS Administrators guide (B13995-05) Part III Advanced Administration. The success of this method assumes you have OID and SSO each installed in separate homes. You would be cloning the SSO home to another box as if it were a middle tier (it is still part of the infrastructure) then re-configuring it on the new box.
    Personally solution 1 is the best method. We are using F5 Big-IP with this configuration and it is working great.
    Hope this helps!

  • CSS load balancing issue: url isn't accessible even though services are up

    service Server1:80
      ip address 10.10.10.34
      protocol tcp
      port 80
      keepalive type http
      keepalive uri "/test.asp"
      active
    service Server2:80
      protocol tcp
      port 80
      keepalive type http
      keepalive uri "/test.asp"
      ip address 10.10.10.35
      active
    owner Ow1
    content LBR1:80
        vip address 192.168.1.159
        port 80
        protocol tcp
        url "/*"
        balance weightedrr
        add service Server1:80
        add service Server2:80
        advanced-balance sticky-srcip
        sticky-inact-timeout 21
        flow-timeout-multiplier 8
        active
    service Server1:80
      ip address 10.10.10.34
      protocol tcp
      port 80
      keepalive type http
      keepalive uri "/test.asp"
      active
    service Server2:80
      protocol tcp
      port 80
      keepalive type http
      keepalive uri "/test.asp"
      ip address 10.10.10.35
      active
    owner OW1
      content LBR2:80
        vip address 192.168.1.98
        protocol tcp
        port 80
        url "/*"
        balance weightedrr
        add service Server1:80
        add service Server2:80
        advanced-balance sticky-srcip
        sticky-inact-timeout 21
        flow-timeout-multiplier 8
        active
    All services are alive all the time and both contexts are alive all the time.
    when user tries to access LBR2:80's URL it works all the time. but when user tries to access LBR1:80's url then it works sometimes and some times it doesn't work.
    could you advise what the issue could be?

    When the SYN comes in the CSS will first check for the srcip in the sticky database and if it finds a match will forward to the stuck server. If the source ip is not in the sticky database the request will be load balanced using weightedrr and a server selected. That sticky server will then be added to the sticky database.
    If the sticky-srcip is used between 2 content rule, it will use separate sticky table.
    You may need to take packet capture to understand what is really failing along with
    a following outputs :
    sh flow
    sh rule Ow1 LBR1:80 ser
    regards
    Andrew

  • CSS10500 Load Balancing Multiple Hosts

    Hello,
    I have a CSS10500 switch and i would like to load balance the connections to a couple of hosts. My setup (roughly) is as follows
    int e1-RTR1-------->int e2-Host1
                     -------->int e3-Host2
    and
    int e5-RTR2------>int e6-Host1
                     ------>int e7-Host2
    How can i assing different interfaces to the two sets of hosts??? I want all ports (0-65535 and tcp/udp)  to go to both sets. I made a circuit vlan 1 and assigned it an ip address but i cannot make a circuit vlan 2 and when i assign multiple addresses to vlan1 i cannot somehow assign interfaces to each ip.
    Is there anything i can do??
    Sorry for all the fuss i am new to the CSS concept.

    Let's start with the basic
    http://www.cisco.com/en/US/products/hw/contnetw/ps792/products_configuration_example09186a008009438d.shtml
    If you can't make it work, get back to us with whatever you have configured.
    Verify that you can ping the CSS from the router and the server.
    Gilles.

  • What's the best way to load balance multiple protocols on one vserver?

    Hi,
    We have a CSM blade on a 6513, in bridge mode. I'm just wondering what is the best way to serve HTTP and HTTPS (or any two or more ports) from the same group of servers. As I see it, we have two options:
    1. Don't set a port on the vserver, so it is load balancing "any" or "tcp". This is easy but I want to be sure there isn't a downside to this, other than the obvious security issue.
    2. Create multiple vservers and point them at the same serverfarm. I tried this and I got some odd results with the health checks.
    Any ideas? Thanks a lot.

    you listed the only 2 options available.
    The advantage of solution #2 is that you can apply specific config for each protocol ie: for HTTP you can turn 'persistent rebalance' if needed.
    If you want to use specific probes [not icmp], it is also a good practice to create a different serverfarm for each protocol.
    Like this, if the HTTP service goes down but not the server, you can still have other protocols loadbalanced.
    Regards,
    Gilles.
    Thanks for rating this answer.

  • Load balancing FTP/HTTP on same VIP

    Hi,
    Please could someone confirm if it is possible to load balance FTP and HTTP on same VIP? Would something like this work in a one-armed design?
    class-map match-any WCVS
      2 match virtual-address 20.0.0.1 tcp eq www
      4 match virtual-address 20.0.0.1 tcp eq ftp
    policy-map multi-match int3
      class WCVS
        loadbalance vip inservice
        loadbalance policy VS-l7slb
        inspect ftp
        nat dynamic 5 vlan 20
    int vl20
    service-policy input int3

    Hello,
    I assume you want to ultimately use cookie sticky, since it is in your config, but not yet used.  The '80' next to the rservers within the serverfarm will keep FTP from working because that will force the ACE to always use a destination port of 80 to the rservers, which is good for HTTP, but not so good for FTP.  Below is your config with some modifications.  I've created a new serverfarm for FTP, created a new probe for that farm, included HTTP cookie-sticky, and created a new L7 policy-map.  There is one line that I would like you to remove and see if it works.  If it does not, then add this line and see if it works.
    Let me know how it goes...
    logging enable
    logging buffered 6
    access-list ALL line 8 extended permit ip any any
    access-list ALL line 16 extended permit icmp any any
    probe http Probe_HTTP
      interval 5
      passdetect interval 60
      expect status 200 200
      open 2
      receive 2
    probe tcp Probe_FTP
      port 21
      interval 5
      passdetect interval 60
      open 2
      receive 2
    rserver host Server1
      ip address 10.10.10.10
      conn-limit max 4000000 min 4000000
      inservice
    rserver host Server2
      ip address 10.10.10.11
      conn-limit max 4000000 min 4000000
      inservice
    serverfarm host FARM-HTTP
      probe Probe_HTTP
      rserver Server1 80
        conn-limit max 4000000 min 4000000
        inservice
      rserver Server2 80
        conn-limit max 4000000 min 4000000
        inservice
    serverfarm host FARM-FTP
      probe Probe_FTP
      rserver Server1
        conn-limit max 4000000 min 4000000
        inservice
      rserver Server2
        conn-limit max 4000000 min 4000000
        inservice
    sticky http-cookie XXX_tempCookie XXX_tempCookie
      cookie insert
      serverfarm FARM-HTTP
    class-map type management match-any Management
      201 match protocol http any
      202 match protocol https any
      203 match protocol icmp any
      204 match protocol kalap-udp any
      205 match protocol ssh any
      206 match protocol telnet any
      207 match protocol xml-https any
    class-map match-any XXX-WCVS-WWW
      2 match virtual-address 10.10.10.100 tcp eq www
    class-map match-any XXX-WCVS-FTP
      2 match virtual-address 10.10.10.100 tcp eq ftp
      3 match virtual-address 10.10.10.100 tcp range 1023 65535   <-- try first without this, then with this
    class-map match-any NAT-VIP
      2 match destination-address 10.10.10.100 255.255.255.255
    policy-map type management first-match Management
      class Management
        permit
    policy-map type loadbalance first-match XXX_VS-l7slb-WWW
      class class-default
        sticky-serverfarm XXX_tempCookie
    policy-map type loadbalance first-match XXX_VS-l7slb-FTP
      class class-default
        Serverfarm FARM-FTP
    policy-map multi-match int3
      class XXX-WCVS-WWW
        loadbalance vip inservice
        loadbalance policy XXX_VS-l7slb-WWW
      class XXX-WCVS-FTP   
        loadbalance vip inservice
        loadbalance policy XXX_VS-l7slb-FTP
        inspect ftp   
      class NAT-VIP
        nat dynamic 5 vlan 12
    interface vlan 12
      ip address 10.10.10.1 255.255.255.0
      alias 10.10.10.3 255.255.255.0
      peer ip address 10.10.10.2 255.255.255.0
      access-group input ALL
      nat-pool 5 10.10.10.100 10.10.10.100 netmask 255.255.255.0 pat
      service-policy input Management
      service-policy input int3
      no shutdown
    ip route 0.0.0.0 0.0.0.0 10.10.10.254

  • Flex Load Balancer Environment URL Redirect

    Hi,
    Our Flex application is running on a load balancer environment, where SSL is terminated.  From the browser to load balancer, the connection is using https and from the load balancer to the server, it is http. What we are noticing is, when the https url is invoked on the browser, it immediately redirects the url from https to http. This breaks the connection and an error message unable to connect is shown on the browser.  We traced the network traffic using the Live HTTP headers, it showed the same redirect in the url with the message HTTP/1.1 302 Moved Temporarily.
    Please let me know, how i can resolve this issue. Also let me know, if you need any other information from me.
    Thanks for your help.
    Murugan.

    I'm kind of a newbie on the netscaler. What od you mean by stick? We keep persistence by a cookie insert.
    I did find out what the issue was, our E1 installation sits on port 8086, so from the netscaler we would reroute the port 80 calls from jdesso.xxx.local to the E1 server, but for some reason when the handoff came back from OID to E1 the load balancer somehow realized the app server was running from port 8086 and it mixed the whole process up (instead of keeping all traffic to and from the client on port 80). To workaround this I created a new virtual server to listen on port 8086, then I redirected the port 80 calls to new 8086 VS, and then from the 8086VS to the app server and it worked correctly.

  • Load Balancing multiple web servers

    Hi All:
    I need to load balance 2 different web servers using sticky connections on a LocalDirector 416.
    I need to use cookie-passive mode, which of course relies on a cookie set by the web server.
    Problem: The name of the session cookie is different on each web server (IIS) and I'm not sure that I can change it.
    Question: What do I pass to the sticky command as the name of the cookie?
    Any ideas?
    craig

    fortunately the cookie are different on the 2 servers otherwise this feature would not work.
    The value you enter after the keyword cookie-passive is a 'name' and can be whatever you want (you can also leave it blank/empty).
    The LD will learn the cookie directly from the server.
    See the documentation at :
    http://www.cisco.com/univercd/cc/td/doc/product/iaabu/localdir/ldv42/421guide/42ch05.htm#xtocid8565101
    I hope this answer your question.
    Gilles.

  • Load balancing multiple AP1242

    Hi,
    I just deployed a few AP1242 in my office environment.
    I've set them to use the same SSID and encryption (WPA2).
    I would like to know can I set load balancing on the APs? E.g. there are 30 users at the office and I installed 2 APs in the area, is there anyway the AP will auto loan balance between themselves, taking 15 users each?
    Thanks.

    Hi Patrick
    There really is no load balancing feature with Autonomous AP's. But you can use this;
    To allow only so many users to associate to an AP at one time you can use the max-Associations command.
    This example shows how to:
    Name an SSID
    Configure the SSID for RADIUS accounting
    Set the maximum number of client devices that can associate using this SSID to 15
    Assign the SSID to a VLAN
    AP# configure terminal
    AP(config)# interface dot11radio 0
    AP(config-if)# ssid batman
    AP(config-ssid)# accounting accounting-method-list
    AP(config-ssid)# max-associations 15
    AP(config-ssid)# vlan 3762
    AP(config-ssid)# end
    From this doc;
    http://www.cisco.com/en/US/products/hw/wireless/ps4570/products_configuration_guide_chapter09186a00802085c4.html
    To find out how many users are associated to an AP, this example shows how to display all client devices associated with the access point:
    AP# show dot11 associations client
    http://www.cisco.com/en/US/docs/wireless/access_point/12.3_4_JA/command/reference/cr34main.html#wpxref81339
    Hope this helps!
    Rob

  • Load balancing multiple serverfarms

    access-list PERMIT_ACL line 1 extended permit ip any any
    probe http port-7777
    port 7777
    interval 5
    faildetect 15
    passdetect interval 15
    receive 2
    expect status 200 200
    open 2
    probe http port-8005
    Listener Port
    port 8005
    interval 5
    faildetect 15
    passdetect interval 15
    receive 2
    expect status 200 200
    open 2
    parameter-map type http http-par
    persistence-rebalance
    set header-maxparse-length 4096
    length-exceed continue
    rserver host zcgnoraapp04-Perf
    ip address 10.1.40.12
    inservice
    rserver host zcgnoraapp05
    ip address 10.1.40.13
    inservice
    rserver host zcgnoradb04-Perf
    ip address 10.1.40.112
    inservice
    rserver host zcgnoradb05-Perf
    ip address 10.1.40.113
    inservice
    serverfarm host SFarm1-Perf
    probe port-7777
    rserver zcgnoradb04-Perf 7777
    inservice
    rserver zcgnoradb05-Perf 7777
    inservice
    serverfarm host SFarm3-Perf
    description SFARM3-Perf
    probe port-7777
    probe port-8005
    rserver zcgnoraapp04-Perf 8005
    inservice
    rserver zcgnoraapp05-Perf 8005
    inservice
    serverfarm host SFarm6-Perf
    description SFARM6-Perf
    probe port-7777
    probe port-8005
    rserver zcgnoraapp04-Perf 7777
    inservice
    rserver zcgnoraapp05-Perf 7777
    inservice
    sticky http-cookie acecookiePerf sticky-cookie-insert-7777-Perf_SOA
    cookie insert
    replicate sticky
    serverfarm SFarm1-Perf
    sticky http-cookie acecookiePerf sticky-cookie-insert-8005-perf
    cookie insert
    replicate sticky
    serverfarm SFarm3
    sticky http-cookie acecookiePerf sticky-cookie-insert-7777-Perf
    cookie insert
    replicate sticky
    serverfarm SFarm6
    class-map match-all port_8005_perf
    description Match Apache port
    2 match virtual-address 10.1.90.140 tcp eq 8005
    class-map match-all port_7777_perf
    description Match ESB and SOA port
    2 match virtual-address 10.1.90.140 tcp eq 7777
    class-map match-all port_7777_perf_SOA
    2 match virtual-address 10.1.90.141 tcp eq 7777
    policy-map type loadbalance first-match port_7777_policy_perf_SOA
    class class-default
    sticky-serverfarm sticky-cookie-insert-7777-Perf_SOA
    insert-http x-forward header-value "%is"
    policy-map type loadbalance first-match port_7777_policy_perf_SSO
    class class-default
    sticky-serverfarm sticky-cookie-insert-7777-Perf
    insert-http x-forward header-value "%is"
    policy-map type loadbalance first-match port_8005_policy_perf
    class class-default
    sticky-serverfarm sticky-cookie-insert-8005-Perf
    insert-http x-forward header-value "%is"
    policy-map multi-match VIP
    class port_7777_perf
    loadbalance vip inservice
    loadbalance policy port_7777_policy_perf_SSO
    loadbalance vip icmp-reply active
    nat dynamic 1 vlan 5
    appl-parameter http advanced-options http-par
    class port_7777_perf_S0A
    loadbalance vip inservice
    loadbalance policy port_7777_policy_perf_SOA
    loadbalance vip icmp-reply active
    nat dynamic 1 vlan 5
    appl-parameter http advanced-options http-par
    class port_8005_perf
    loadbalance vip inservice
    loadbalance policy port_8005_policy_perf
    loadbalance vip icmp-reply active
    nat dynamic 1 vlan 5
    appl-parameter http advanced-options http-par
    interface vlan 5
    ip address 10.1.90.162 255.255.255.240
    access-group input PERMIT_ACL
    nat-pool 1 10.1.90.165 10.1.90.174 netmask 255.255.255.240 pat
    service-policy input VIP
    no shutdown
    ip route 0.0.0.0 0.0.0.0 10.1.90.161
    whn initiate a request for 10.1.90.140 on port 8005, the connection gets estab with the server from serverfarm1 and that too on port 7777
    the connection should go to serverfarm6
    whn initiate a request for 10.1.90.141 on port 8005, the connection gets estab with the server from serverfarm1 and that too on port 7777-although there is no match statment in class for this port on that vip. the connection shouldnt establish
    not sure whats wrong?

    You are using the same cookie-name for all sticky groups.
    When sticky is in place. Sticky DB is checked first and the decision is made.
    Something in the following lines should do
    sticky http-cookie acecookie1 sticky-cookie-insert-7777-Perf_SOA
    cookie insert
    replicate sticky
    serverfarm SFarm1-Perf
    sticky http-cookie acecookie2 sticky-cookie-insert-8005-perf
    cookie insert
    replicate sticky
    serverfarm SFarm3
    sticky http-cookie acecookie3 sticky-cookie-insert-7777-Perf
    cookie insert
    replicate sticky
    serverfarm SFarm6
    Syed Iftekhar Ahmed

  • ACE-Single VIP-Multiple URL-Multiple ServerFarm

    Hi Everyone,
    I am trying to put together a configuration that has multiple requirements that are all dependant so I wanted to post in a single discussion.  Please see the parameters below:
    1. ACE 4710 placed in DMZ in one-armed mode
    2. Use only 2 VIPS (1 for HTTP traffic and 1 HTTPS traffic)
    3. Multiple URLs for each VIP. Each URL makes use of sub-domains (ex. "subdomain1.domain.com" , "subdomain2.domain.com")
    4. Match on the hostheader and send to a corresponding serverfarm. (each URL has seperate serverfarm).
    5. SSL off-load. All Secure URL's share a single wild-card certificate.
    6. Any connections to Secure URL's that connect using HTTP need to be redirected to HTTPS and then load-balanced. I would like to have a single redirect serverfarm that will take the path and url that is sent,whichever that may be, and redirect it to HTTPS.
    So here are my questions:
    1. One of the URL's being matched is for Exchange 2010 (OWA and ActiveSync).  Since all services will be directed at the same serverfarm I believe that matching on the sub-domain (host header) will be sufficient for both services but I would like some confirmation.
    2. I would like to confirm that the composition of my class-maps and subsequent policy-maps will meet the requirements listed above.
    3. I would like any suggestions on how I may make this configuration more efficient.
    I have attached a scrubbed copy of my configuration, any suggestions would be greatly appreciated!!!

    Hi Michael,
    One of the URL's being matched is for Exchange 2010 (OWA and ActiveSync).  Since all services will be directed at the same serverfarm I believe that matching on the sub-domain (host header) will be sufficient for both services but I would like some confirmation
    The ACE performs regular expression matching against the received packet data and hence you can use a single expression like \.mvnu\.edu and that should match msmail\.mvnu\.edu", ihelp\.mvnu\.edu and ishare\.mvnu\.edu and since all of them need to go to same serverfarm there is no need to define three different server farms under policy map.
    2. I would like to confirm that the composition of my class-maps and subsequent policy-maps will meet the requirements listed above.
    The config looks fine but you can make it more stream line by using one regex which will match all host header information and since it needs to go one serverfarm only, it is not required to have three different server farms unless needed of course. Pardon if i haven't  understood your requirment correctly.
    3. I would like any suggestions on how I may make this configuration more efficient.
    It should be there in answer 1:)
    Please feel free to discuss if there is something which is not what you were looking for.
    Regards,
    Kanwal

Maybe you are looking for