TIMEZONE question on 10.2.0.1.0

Hi Experts,
Env: Sun Solaris 8
DB 10.2.0.1.0 -- Single instance
a) I did set env variable as TZ=UTC
b) When I check SQLPLUS from server, it is fine. i.e. It shows time in GMT
SQL> select to_char(sysdate,'DD-MON-YYYY HH24:MI:SS') from dual ;
TO_CHAR(SYSDATE,'DD-
14-MAR-2007 18:51:23
c) However, when I try from SQLPLUS client, it is NOT showing correctly.
What I mean, it is still showing LOCAl time.
SQL> select to_char(sysdate,'DD-MON-YYYY HH24:MI:SS') from dual ;
TO_CHAR(SYSDATE,'DD-
14-MAR-2007 12:59:08
d) We use LDAP for connectyions.
HOW TO FIX THIS?
Thanks for help
Regards
Natrajan

Get the current timezone
SQL> SELECT DBTIMEZONE FROM DUAL;
DBTIME
+00:00
Use the SET TIME_ZONE clause to set the time zone of the database. You can specify the time zone in two ways:
1.By specifying a displacement from UTC (Coordinated Universal Time--formerly Greenwich Mean Time). The valid range of hh:mm is -12:00 to +14:00.
ALTER DATABASE SET TIME_ZONE = '+02:00';
OR
2. By specifying a time zone region. To see a listing of valid region names, query the TZNAME column of the V$TIMEZONE_NAMES dynamic performance view.
SELECT TZNAME FROM V$TIMEZONE_NAMES
http://www.oracleabc.com/forums/viewthread.php?tid=30&extra=page%3D1

Similar Messages

  • Timezone question

    I'm trying to use the TZ_OFFSET command to manipulate data from multiple timezones. The problem is that it won't recognize any of the US daylight savings time timezones. I looked up on Metalink, and it keeps mentioning patches to this, that, and the other, but it's hard to make anything of it. I'm on 10.2.0.2. Can someone point me in the right direction?
    PS - I'd rather not have to patch the DB at this time.

    >
    PS - I'd rather not have to patch the DB at this time.
    >
    But should you have patched already! The patch is very straight forward and very low impact.
    Check the corefile version from your $ORACLE_HOME/oracore/zoneinfo/readme.txt. It should read like
    Current Structure version: 2
    Current Content Version :7 <-- This is the version
    I'm in eastern Australia so according to the DST notes, my version should be 7. Check your version from related DST notes.
    Edited by: AliD on Oct 21, 2009 4:43 PM

  • AIR SQLite timezone question (JavaScript)

    SQLite stores dates in UTC, which is great, but when I fetch the value, the resulting date object is incorrectly offset. Hopefully I'm missing something obvious and someone can point it out. Here's what I'm doing:
    CREATE TABLE myTable ("id" INTEGER PRIMARY KEY ,"created" DATE);
    INSERT INTO myTable (id,created) VALUES (1,DATETIME('NOW'));
    SELECT id,created FROM myTable WHERE id=1;
    My expectation is that the INSERT will store the current date/time adjusted to UTC. Because the AIR runtime casts date values to JavaScript date objects, my expectation is that the SELECT would give me back a valid date object, from which I could display either UTC or local time information. And it almost does.
    Suppose 'NOW' is 11:42:23 AM Pacific Time (GMT-8). I would expect the time information from toString() on the resulting date object to print something like "11:42:23 GMT-0800" but instead, I'm getting "19:42:23 GMT-0800". Clearly, it's a timezone issue because minutes and seconds look good. It's like AIR (or SQLite) is assuming that the value "11:42:23" is already UTC when inserting, and when AIR creates the resulting date object, it's applying the 8 hour timezone offset.
    I tried the solution posted here, which is to modify the INSERT as follows.
    INSERT INTO myTable (id,created) VALUES (1,DATETIME('NOW','localtime'));
    That works, but I don't want to store these values as local times, I want to store them as UTC and display them as local times. Meaning I should be able to store "11:42:23" in the Pacific timezone, and if I change to Eastern, I expect that value to be displayed as "14:42:43". When I use this solution, toString prints "11:42:23 GMT-0500".

    Update: Based on this topic on Stack Overflow, I tried changing the value in the insert from "DATETIME('NOW')" with a parameter:
    stmt.parameters[":created"] = new window.runtime.Date();
    (Aside: it's kind of annoying that AIR does not support JS dates, I'd like to see that change.)
    Anyway, this still doesn't solve the original problem. It works just like using DATETIME('NOW','localtime'). If the value goes in at 1:54pm PST, and I change the timezone to EST and read the value, it displays as "1:54pm EST", when I would expect it to be "4:54pm EST".
    Any advice is appreciated. Thanks!

  • Calendar / Timezone question for anyone in Arizona

    I was just looking at my calendar for next week and noticed that all items are 1 hour earlier than they should be.  My first thought was that the timezone was set incorrectly (Arizona doesn't observe DST).  In fact when I went to Settings -> General -> Date & Time with Set Automatically On it shows me in Cupertino.  If I turn Set Automatically Off and type in Phoenix for the Timezone next weeks calendar is correct.
    Not sure what else I should do to get the phone to automatically put me in the right timezone.  I've made sure Setting Time Zone is on under location services.  Went outside to make sure I had a good GPS signal while toggling Set Automatically On and Off.
    Anyone in AZ or any other place that doesn't observe DST seeing similar issues?

    Hey Dark,
    Follow Allan's advice. You might just find an "Easy Out" that will fit perfectly. Otherwise you'll have to drill it out a bit to get a grip. There is a liquid that had carborundum grit in it that I've used with success.
    One heads up, that power button lead is really tiny and can be easily ripped out. You have to detach it before the outer case is more than 5" or so off.
    Richard

  • Java DST timezone question

    I am trying to write a procedure that will return the start and end times of Daylight Saving Time, when passed a timezone and a year. I have read the timezone method and the simpletimezone constructs, and I do not see how these constructs provide this information. I have tried things like the following to try to get more info but haven't been successful:
    Calendar aCal = new GregorianCalendar();
    System.out.println("ZONE_OFFSET: " + aCal.get(Calendar.ZONE_OFFSET));
    System.out.println("DST_OFFSET: " + aCal.get(Calendar.DST_OFFSET));
    I would like something more like this:
    String DSTOn = TimeZone(GetDSTStart("EST",2007");
    String DSTOff = TimeZone(GetDSTStart("EST",2007");
    System.out.println(DSTOn);
    System.out.println(DSTOff);
    When run would return:
    03/14/07 02:00:00 (ideally in EPOCH time)
    11/04/07 02:00:00
    Has anyone done this/ no which methods to call to do this? Any help is appreciated.
    Thanks,
    Mike

    Daylight Savings Time is essentially a legal construct. It must be codified somehow in the Java source (so the date/time formatting stuff would work), but I have no idea how. However, it must be in the sources somewhere.
    I'd suggest looking at the source code for the TimeZone etc classes (it's included in the JDK) and see how they encoded it. Note that a legal change in a state can thus screw up source code. There must be a table of this data somewhere. Maybe it's exposed in the API but I doubt it.
    Another option is to see if this data is exposed somewhere else than the API, maybe someplace more dynamic. I can imagine that a government web site may have this information where you could just grab it easily. If you're lucky it may be available as a web service.

  • Using ADF calendar to show employee absences

    Hi,
    (Actually this question belongs to ADF as well as HRMS..so posting in both the forums)
    We are having JDeveloper 11.1.2.4
    We need to show employee absence calendar in ADF page.
    Question 1) We believe we can use ADF Calendar component for this. Kindly confirm.
    I gone through "How to Use the ADF Faces Calendar" section in ADF Guide and tried to implement Employee Absence Calendar accordingly (based on seeded oracle table - PER_ABSENCE_ATTENDANCES.)
    However step 2 mentions creating 3 named bind variables in VO:
    A string that represents the time zone
    A date that represents the start time for the current date range shown on the calendar.
    A date that represents the end time for the current date range shown on the calendar.
    I created these 3 named bind parameters accordingly. However when I run the page with ADF calendar, it shows following error:
    Attempt to set a parameter name that does not occur in the SQL: timeZone
    Question 2) How to resolve this error?
    Kindly advise.
    Thanks,
    Vivek

    Hi minh-hieu,
    According to your description, you want to calculate YTD value of Sales Amount. Right?
    As we tested in our environment, the expression you assign in This function is correct. It can return the YTD values properly:
    So please pay attention to the set expression in your SCOPE statement. Try the code below:
    SCOPE(MEASURES.[YTD Sales]); --Calendar YTD
    SCOPE([DimDates].[Year].[Year].MEMBERS,[DimDates].[Year-Qtr-Month-Day].MEMBERS);
    THIS = AGGREGATE( PERIODSTODATE([Date].[Year].[Year], [Date].[Year].CURRENTMEMBER), [Measures].[Sales Amount]);
    END SCOPE;
    END SCOPE;
    Best Regards,
    Simon Hou
    TechNet Community Support

  • Timezone design question

    I have an application that is located in New York but accessed by users around the world(London, Tokyo, HongKong etc.) The users wanted to see the date/time fields according to their local(desktop timezone), not in EST. So, we passed the offset from the client (using javascript new Date().getTimezoneOffset()) and converted date fields using this offset.
    But with DST rules, the offset changes twice every year. So, the date/time displayed vary based on what rules apply, which is not a desired behavior.
    1) Is depending on client offset an unreliable approach ?
    2) What is the best practise for this problem ?

    If you want to write code that's easier for you to write, you do whatever the hell you want.
    If you want to write good code, retain the ID.

  • TimeZone.getDefault() question

    Hi All
    I have a simple program as below
    import java.util.TimeZone;
    public class TimeTest
    public static void main(String args[])
    System.out.println("Current time zone: " + TimeZone.getDefault().getID());
    I have 2 linux machines and the same jvm installations are mounted on both machines.
    Running on machine 1 gives
    Current time zone: Europe/London
    running on machine 2 gives
    Current time zone: America/New_York.
    The TZ environment varaible is unset on both machines and running 'date' from the command line on either machine returns a timestamp in GMT.
    So clearly there's something about machine 2 that effects the timezone.
    There are various versions of java mounted across both machines including flavours of 1.4, 1.5 and 1.6 but the exact version of java used makes no difference to the behaviour per machine, machine 1 always says Europe/London and machine 2 always says America/New_York.
    Can anyone suggest any reasons for this behaviour?
    Appreciate any feedback

    As far as I recall JVM gets the system variables during its start up. That could be the couse of the problem. But I am not sure of this tho.

  • Question regarding timezone

    Is there a way in oracle to convert from "timestamp with timezone" to timestamp. The function should apply the timezone and return timestamp in yyyy-mm-dd hh:mm:ss format.
    For example if you have a timestamp like '2009-03-10 10:00:00 -5:0". Then it should return something like '2009-03-10 13:00:00'. Thanks.

    Use CAST + AT TIME ZONE:
    SQL> create table tbl1(ts timestamp with time zone)
      2  /
    Table created.
    SQL> insert into tbl1
      2  values(to_timestamp_tz('2009-03-10 10:00:00 -05:00','yyyy-mm-dd hh24:mi:ss tzh:tzm'))
      3  /
    1 row created.
    SQL> select * from tbl1
      2  /
    TS
    10-MAR-09 10.00.00.000000 AM -05:00
    SQL> select cast(ts at time zone 'UTC' as timestamp) from tbl1
      2  /
    CAST(TSATTIMEZONE'UTC'ASTIMESTAMP)
    10-MAR-09 03.00.00.000000 PM
    SQL> select cast(ts at time zone '-2:00' as timestamp) from tbl1
      2  /
    CAST(TSATTIMEZONE'-2:00'ASTIMESTAMP)
    10-MAR-09 01.00.00.000000 PM
    SQL> SY.

  • ASA VPN QUESTION

    Hi All
    The question is pretty simple. I can successfully connect  to my ASA 5505  firewall via cisco vpn client 64 bit , i can ping any ip  address on the LAN behind ASA but none of the LAN computers can see or  ping the IP Address which is assigned to my vpn client from the ASA VPN  Pool.
    The LAN behind ASA is 192.168.0.0 and the VPN Pool for the cisco vpn client is 192.168.30.0
    I would appreciate some help pls
    Here is the config:
    ASA Version 7.2(4)
    hostname ciscoasa
    domain-name default.domain.invalid
    enable password J7NxNd4NtVydfOsB encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    name 192.168.0.11 EXCHANGE
    name x.x.x.x WAN
    name 192.168.30.0 VPN_POOL2
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.0.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address WAN 255.255.255.252
    interface Ethernet0/0
    switchport access vlan 2
    <--- More --->
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    boot system disk0:/asa724-k8.bin
    ftp mode passive
    clock timezone EEST 2
    clock summer-time EEDT recurring last Sun Mar 3:00 last Sun Oct 4:00
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    access-list nk-acl extended permit tcp any interface outside eq smtp
    access-list nk-acl extended permit tcp any interface outside eq https
    access-list customerVPN_splitTunnelAcl standard permit 192.168.0.0 255.255.255.0
    access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.255.0 VPN_POOL2 255.255.255.0
    access-list inside_access_in extended permit ip any any
    access-list VPN_NAT extended permit ip VPN_POOL2 255.255.255.0 192.168.0.0 255.255.255.0
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    ip local pool VPN_POOL2 192.168.30.10-192.168.30.90 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-524.bin
    no asdm history enable
    arp timeout 14400
    global (inside) 10 interface
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    nat (outside) 10 access-list VPN_NAT outside
    static (inside,outside) tcp interface smtp EXCHANGE smtp netmask 255.255.255.255
    static (inside,outside) tcp interface https EXCHANGE https netmask 255.255.255.255
    access-group inside_access_in in interface inside
    access-group nk-acl in interface outside
    route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    aaa authentication enable console LOCAL
    aaa authentication http console LOCAL
    aaa authentication serial console LOCAL
    aaa authentication ssh console LOCAL
    aaa authentication telnet console LOCAL
    aaa authorization command LOCAL
    http server enable
    http 192.168.0.0 255.255.255.0 inside
    snmp-server host inside 192.168.0.16 community public
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto dynamic-map outside_dyn_map 20 set pfs group1
    crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto isakmp nat-traversal  20
    telnet 192.168.0.0 255.255.255.0 inside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcp-client client-id interface outside
    dhcpd dns 217.27.32.196
    dhcpd address 192.168.0.100-192.168.0.200 inside
    dhcpd dns 192.168.0.10 interface inside
    dhcpd enable inside
    group-policy DfltGrpPolicy attributes
    banner none
    wins-server none
    dns-server none
    dhcp-network-scope none
    vpn-access-hours none
    vpn-simultaneous-logins 3
    vpn-idle-timeout 30
    vpn-session-timeout none
    vpn-filter none
    vpn-tunnel-protocol IPSec l2tp-ipsec
    password-storage disable
    ip-comp disable
    re-xauth disable
    group-lock none
    pfs disable
    ipsec-udp disable
    ipsec-udp-port 10000
    split-tunnel-policy tunnelall
    split-tunnel-network-list none
    default-domain none
    split-dns none
    intercept-dhcp 255.255.255.255 disable
    secure-unit-authentication disable
    user-authentication disable
    user-authentication-idle-timeout 30
    ip-phone-bypass disable
    leap-bypass disable
    nem disable
    backup-servers keep-client-config
    msie-proxy server none
    msie-proxy method no-modify
    msie-proxy except-list none
    msie-proxy local-bypass disable
    nac disable
    nac-sq-period 300
    nac-reval-period 36000
    nac-default-acl none
    address-pools none
    smartcard-removal-disconnect enable
    client-firewall none
    client-access-rule none
    webvpn
      functions url-entry
      html-content-filter none
      homepage none
      keep-alive-ignore 4
      http-comp gzip
      filter none
      url-list none
      customization value DfltCustomization
      port-forward none
      port-forward-name value Application Access
      sso-server none
      svc none
      svc keep-installer installed
      svc keepalive none
      svc rekey time none
      svc rekey method none
      svc dpd-interval client none
      svc dpd-interval gateway none
      svc compression deflate
    group-policy customerVPN internal
    group-policy customerVPN attributes
    dns-server value 192.168.0.10
    vpn-tunnel-protocol IPSec
    password-storage enable
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value customerVPN_splitTunnelAcl
    default-domain value customer.local
    username xxx password 8SYsAcRU4s6DpQP1 encrypted privilege 0
    username xxx attributes
    vpn-group-policy TUNNEL1
    username xxx password C6M4Xy7t0VOLU3bS encrypted privilege 0
    username xxx attributes
    vpn-group-policy PAPAGROUP
    username xxx password RU2zcsRqQAwCkglQ encrypted privilege 0
    username xxx attributes
    vpn-group-policy customerVPN
    username xxx password zfP8z5lE6WK/sSjY encrypted privilege 15
    tunnel-group customerVPN type ipsec-ra
    tunnel-group customerVPN general-attributes
    address-pool VPN_POOL2
    default-group-policy customerVPN
    tunnel-group customerVPN ipsec-attributes
    pre-shared-key *
    tunnel-group-map default-group DefaultL2LGroup
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:a4dfbb82008f78756fe4c7d029871ec1
    : end
    ciscoasa#                           

    Well lots of new features have been hinted at for ASA 9.2 but I've not seen anything as far as an Engineering Commit or Customer Commit for that feature.
    Site-site VPN in multiple context mode was added in 9.0(1) and I have customers have been asking for the remote access features as well.
    I will remember to ask about that at Cisco Live next month.

  • Questions on SAP/SF PO Integration & SF BizX RBP

    Dear Experts,
    We are implementing SAP HCM and SF. SF goes live before SAP. We'll have a transition period from Flat File upload to SAP PO integration.
    Would anyone have any recommendation on how to ensure a smooth seamless transition? We have tested in the test instance, and noticed some issues when SAP PO is turned on, i.e. User Name upper and lower cases, certain derived fields generated duplicate records, default locale was not passed from SAP and therefore overrides SF provisioning config, and users are not always in sync (bizX vs LMS). We will be using SOAP (Axis) Adapter for integration between SF and SAP.
    A few questions:
    1. Below are some of our data mapping, would appreciate if anyone has any recommendations/better suggestions or tips on these fields?
    SAP Pers ID = SF User ID
    SAP SSO ID (0105) = SF User Name (did anyone have issues with User ID - unique identifier and User Name - unique name for each user id?)
    Manager field: we are using A002, if no value use B012, if no value use one up manager (by using one up manager, would this cause any issues?)
    Time zone will be defaulted based on the employee's SAP ID (has anyone experienced issues with Timezone? especially for companies in Australia?)
    Hire Date: is it true Hire Date must be in US format? When default locale is Eng_GB and timezone is Australia?
    Initially we do not use Job code as it's not configured in SAP. We mapped Tilte = SAP Position Title. Is it possible to map SF LMS Job Title to Position Title in BizX?
    Default Locale: we hard coded to "Eng_GB"
    2. We would like to set up a filter to select certain population of employees to be passed to SF. In our case we would like to pass only employees with an ESS user role. Does anyone know if there is a way of identifying and picking up only ESS users to be sent to SF?
    3. With Flat File integration, you recieve on screen error for pre import errors/warnings and an email notification after import. For SAP PO integration, we will have a nightly job to transfer employee data to SuccessFactors. Errors that occurred during the interface are stored in auto logs which are provided through the background job log. Is it true that the only way to check if there are failed/errored employees is by going into Webdypro and check the job log? Or would it be possible for SAP to send notifications of the pre PO errors and SF to send post PO errors? With Flat File load, the person whom imported the file will receive import status notification. With SAP PO since it is a batch job, how do we configure for a centralised email inbox to be the recipient?
    4. BizX security question: we do not want to show employee MI to users. RBP is set up not to display MI, BizX displays correctly except for under Company Info -> Directory, employees' MI is still showing. Is there a way to hide MI completely from users?
    5. We have experienced some User Connector issues, i.e. BizX and LMS are not always in sync, employees can be found in BizX but not always showing up in LMS. Does anyone have any tip or know the root cause for this issue?
    6. Lastly, is it true you are not able to delete records EVER in SF? Even if the record was created by error and no learning history attached?
    Thank you so much in advance. Any feedback is highly appreciated!!
    Vera

    Hi Vera,
    What version and Support Package of the add-on are using?
    1. These are some of my recommendations:
    Manager field: we are using A002, if no value use B012, if no value use one up manager (by using one up manager, would this cause any issues?) >For this you need to ensure if there is no manager that the value is NO_MANAGER
    Time zone will be defaulted based on the employee's SAP ID (has anyone experienced issues with Timezone? especially for companies in Australia?) >You need to ensure you have the exact correct Timezone text - ask your implementation partner for the text
    Hire Date: is it true Hire Date must be in US format? When default locale is Eng_GB and timezone is Australia? >All date formats must be in US format (MM/DD/YYYY)
    Default Locale: we hard coded to "Eng_GB" >It should be "EN_GB", not "Eng_GB"
    2. You can do this with a report variant, but you'll need to ensure that users can be identified by the available criteria.
    3. The WebDynpro is only for the Compensation process integration. I would post this specific question in the SAP NetWeaver Technical Integration with ERP
    6. This is not true. You can use the Purge Data option.
    Regarding questions 4 and 5, I need to put my SCN moderator hat on. Please can you create new posts as they are not related to integration and it is best practice to keep one topic to one post.
    Best regards,
    Luke

  • How can I set the timezone in my application?

    I inherited a website in which the DateFormat() function is littered throughout, and plays an integral role in ensuring the application runs correctly. For instance, we have a calendar system in which employees can book lessons on certain days and at certain times. The Date and Time functions are key to this application's success.
    But we moved the website from one server to a newer, shared, one a few months back running CF10 on Windows Server 2008. (I believe the old one was running CF8 on a Windows 2000 server or something.) But what appears to be happening is that other users on this new shared box are changing the date/time based on their needs and at different times, and it is affecting our applications. I called the support staff of the hosting company who told me I had to specify the date and time via Java in my application file and that should solve the problem.
    The issue is that I really have no idea how to do this. My programming with Java is virtually null, and even my familiarity with ColdFusion is waning, as I have not seriously used it in about 9 years. I see there are a number of tutorials and demonstrations on the web for accessing date and time via Java in ColdFusion, but I don't know how to set the application to a specified timezone, (which is what I think I have to do), so that when the DateFormat() object is called, it calls the correct date. Otherwise, when employees go to book lessons, the dates are off. Their calendar will show that April might begin on a Tuesday instead of a Monday. At other times we've noticed the hour is off by a considerable amount - 4 or 5 hours, when the server itself is in a timezone only 1 hour behind us.
    Any idea how to pull something like this off?
    I figure even if I can specify the timezone in the application files I may have to overwrite every instance of DateFormat() to something customized, but I'm hoping I don't have to go that far.
    Any help is greatly appreciated.

    Question: Do you think the response from the support staff is correct? I mean, surely, I can't be the only CF user on a shared box whose other users need to modify the date and time within their applications. Even if they do it at the application level for their domain, surely it wouldn't affect mine, would it? That was what was implied by the support people, but I have a feeling they are way off, or covering for some goof-up on their end. I struggled like hell yesterday trying to get this to work and I did not get very far at all.
    I found an interesting tutorial here which does a comparison of time zones and, theoretically, this might do the trick. But if what the guy told me was nonsense then I won't bother with it. For the record, our calendar has been working fine for about a week now.

  • Post upgrade issues from Timezone setting

    Everyone,
    We just upgraded from 4.5 -> version 6.0 SP1 (so we first upgraded the data to 4.5 WS then to version 6)
    After the upgrade, we saw the web service registration to have the send timezone setting to portlet as checked for all the portlets that were upgraded/migrated.
    Then after the DB upgrade, we saw some portlets not displaying because of a person's time zone setting. This went a step further and there are users who reported that they can't access the change locale settings page or even add portlets to their page.
    A PT spy of the users experience showed this particular error: com.plumtree.portalpages.browsing.portalsettings.localesettings.LocaleSettingsView     LocaleSettingsView::Display An error occured when trying to display the HTML.
    System.InvalidCastException: Specified cast is not valid.
    at com.plumtree.portalpages.browsing.portalsettings.localesettings.LocaleSettingsModel.GetTimeZoneSetting() in e:\buildroot\Release\portalui\6.0.x\ptwebui\portalpages\dotnet\prod\src\com\plumtree\portalpages\browsing\portalsettings\localesettings\LocaleSettingsModel.cs:line 192
    at com.plumtree.portalpages.browsing.portalsettings.localesettings.LocaleSettingsView.Display() in e:\buildroot\Release\portalui\6.0.x\ptwebui\portalpages\dotnet\prod\src\com\plumtree\portalpages\browsing\portalsettings\localesettings\LocaleSettingsView.cs:line 59
    I noticed that the cast error originates from the GetTimeZoneSetting() method. This led me to believe that some values in the DB were unexpected. True enough, I noticed that for the strTimeZone preference some users has a value of 1/-1 and the PrefValueType is set to 3 (instead of 8). After modifying this we resolve the issue and the users could proceed as normal.
    My question is that has anyone else experienced a similar issue(or is this just specific to our environment)? Also is there a list of settings/preference you need to check for data integrity after an upgrade? Thanks!

    I experienced an issue similar to this once. I don't know if it was exactly the same because it was a 4.5 to 5.x upgrade done a couple years ago, but it sounds like pretty much the same thing. I also tracked it down to a pref problem in the database. I had to manually fix the bad values, but that resolved the problem, and that was the only problem of that type I encountered. That doesn't mean you won't find anything else strange with your upgrade, but it seemed to be a strange isolated incident to me. I have done many upgrades since that time, and never encountered the problem again. I would suspect that if you have fixed all the database records that were affected by this, then you are probably OK.
    DJ Dewey | VHA Inc. | [email protected]

  • Wls10.3.2: Why do we need to explicitly set -Duser.timezone

    Hi All,
    We are installed FMW 11g PS1 Weblogic 10.3.2 &Oracle Fusion Applicaton Runtime 11g on Oracle Linux 5.7 VM (running on Oracle Virutal Box / Host-only Network adapter) and created new weblogic domain using EM & JRF product templates and choose default options. (except choosing 'Production Mode')
    While deploying our application we are getting "Caused By: java.sql.SQLDataException: ORA-01882: timezone region not found" while performing data base operations (retrieve date from Oracle Database 11g R2 using eclipse link)
    Note:- DB schema have column with timezone set.
    So, Issue got resolve after updating setDomainEnv.sh file with "-Duser.timezone='-05:00'" (CDT) for EXTRA_JAVA_PROPERTIES.
    In general, we didn't the update this properties for our systems.
    Please let me know what want wrong with my setup (Linux installation - date & time settings/ Weblogic /Domain creation/Database time zone settings)?
    Thanks,
    Suresh

    Unfortunately, there are many ways how various OSes setup a configuration to indicate what timezone it is using. The JRE assumes a certain way of how this is done and on many systems it is able to get the necessary info it needs to determine what the timezone is, but of course, it also gets it wrong sometimes, or in your case, it did not find what it was expecting.
    To preempt your next question, what needs to be set? Well, I wish I knew the exact answer. I have several Solaris, Linux, Windows, etc.. systems, on most of them java is able to get the right timezone, but on some it is getting the wrong timezone, but as far as I can tell the timezone configuration on the ones that are wrong look just like the ones that are correct.

  • Report Scheduling. How to syncronize the GMT and the local server timezones

    Hi everybody, I need to schedule reports using the Schedule tab on BIP, but I didn't still understand how the syncronization between my server's timezone and the GMT timezone works.....
    I noticed that when I open the Report Schedules initial page, this is refreshed using the GMT timezone as follows:
    Page Refreshed   Monday, July 26, 2010 7:53 AM GMT
    Actually I'm located in Athens (GMT+3)
    I noticed that if I want to Run once a report, ONLY the GMT is took in consideration.
    For example, I want to run a report at 11.30 (Athens timeone) where the time conditions are the following:
    BIP time (GMT timezone): 08.00 AM GMT
    server timezone: 11.00 AM (Athens time)
    So, if I want to run a report at 11.30 AM (Athens time), I have to write in BIP (Run once) 08.30 AM, instead of 11.30, otherwise if I put 11.30, the report runs 3 hours and 30 minutes later instead of only 30 minutes !!! This is very frustrating....because it means that everytime I need to remember that there is a difference of 3 hours and if I want effectively....
    I also set the Report Formatting Time Zone = GMT+03:00 to fill the gap between the GMT's timezone and Athens's timezone but it didn't work....
    I found that the variable <xsl:param name="_XDOTIMEZONE">GMT</xsl:param> is set into the tmpl.xsl; I tried to change it (GMT+3 or GMT+03:00), I stop and restart the BIP server....but nothing...the BIP timezone is always GMT (as showed by th Page Refreshed date and time).
    At the end my question is this: is there a way to modify the internal BIP timezone in order to fill the gap between this and the server timezone ?
    In other words, I'd like to see the page refreshed with the server timezone (Athens timezone) and not the GMT timezone, in order to schedule reports thinking directly my local server timezone (and not think always to calculate how many hours is the difference).
    This, I think is a common issue for everybody, but....I didn't find nothing in the forum....
    If somebody found a workaround, every help will be appreciated.
    Thanks
    Alex

    Good Morning Vetsrini,
    I know that the "Report Formatting Time Zone" is used to set the timezone properly INSIDE the report...but my attention now is concentrated on the Scheduling...
    As I mentioned before I'd like to find a way to syncronize the BIP timezone (based on GMT) and my local server timezone (Athens, GMT+2), and this I think it's possiblie only if I can modify the BIP timezone (GMT): instead to have GMT, I'd like to have GMT+2 in order to have the same time in both of systems.
    I already tried to change the variable <xsl:param name="_XDOTIMEZONE">GMT</xsl:param> into the tmpl.xsl, but it didn't work....
    I don't understand how all the others millions of BIP users who don't live in UK can use the scheduler keeping in mind always the gap between their local time and the GMT time set in BIP......
    Do you have another hint or workaround ?
    Thanks for your help
    Alex

Maybe you are looking for