Understanding output of sh crypto ipsec sa peer

Hi All,
I a bit puzzled by why the remote indent and remote crypto endpointpt ID is different.  I also noticed that the remote ident address matches the remote NBMA address, but just not the remote crypto endpt address.  I really expected the remote crypto endpt address to be the same as the remote indent address and remote NBMA address (remote tunnel source address).  Tunnel1 is an mGRE tunnel protected by IPSec.
Could anyone shed light on this?
Thanks,
David
Router#sh crypto ipsec sa peer 1.1.1.1
interface: Tunnel1
    Crypto map tag: Tunnel1-head-0, local addr 2.2.2.2
   protected vrf: (none)
   local  ident (addr/mask/prot/port): (2.2.2.2/255.255.255.255/47/0)
   remote ident (addr/mask/prot/port): (3.3.3.3/255.255.255.255/47/0)
   current_peer 1.1.1.1 port 4500
     PERMIT, flags={origin_is_acl,}
    #pkts encaps: 7978837, #pkts encrypt: 7978837, #pkts digest: 7978837
    #pkts decaps: 7286115, #pkts decrypt: 7286115, #pkts verify: 7286115
    #pkts compressed: 0, #pkts decompressed: 0
    #pkts not compressed: 0, #pkts compr. failed: 0
    #pkts not decompressed: 0, #pkts decompress failed: 0
    #send errors 0, #recv errors 14644
     local crypto endpt.: 2.2.2.2, remote crypto endpt.: 1.1.1.1
     path mtu 1514, ip mtu 1514, ip mtu idb Loopback2
     current outbound spi: 0xB96E4FB1(3111014321)
     inbound esp sas:
      spi: 0xB1D02649(2983208521)
        transform: esp-256-aes esp-sha-hmac ,
        in use settings ={Tunnel UDP-Encaps, }
        conn id: 3002, flow_id: Onboard VPN:2, crypto map: Tunnel1-head-0
        sa timing: remaining key lifetime (k/sec): (4501742/22874)
        IV size: 16 bytes
        replay detection support: Y
        Status: ACTIVE
     inbound ah sas:
     inbound pcp sas:
     outbound esp sas:
      spi: 0xB96E4FB1(3111014321)
        transform: esp-256-aes esp-sha-hmac ,
        in use settings ={Tunnel UDP-Encaps, }
        conn id: 3001, flow_id: Onboard VPN:1, crypto map: Tunnel1-head-0
        sa timing: remaining key lifetime (k/sec): (4445656/22873)
        IV size: 16 bytes
        replay detection support: Y
        Status: ACTIVE
     outbound ah sas:
     outbound pcp sas:

The output suggests you have NAT-T in the network and IPSEC tunnel mode turned on.  If the transform-set is set to transport mode, clear the crypto sessions then remote ident and crypto endpoint will be the same address.
HTH,
Dan

Similar Messages

  • EasyVPN :crypto ipsec client ezvpn xauth

    Hi
    Everytime when I reboot a easyVPN client it is prompting for username and password by prompting following command "crypto ipsec client ezvpn xauth".
    How do I make connection persistent, so that it won't ask for username and password during next reboot.
    I am using cisco 877 router as easyVPN server and Cisco 877 router as EasyVPN client.
    My Easy VPN server configuration is  as follows cisco 877
    sh run
    Building configuration...
    Current configuration : 2306 bytes
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    boot-start-marker
    boot-end-marker
    aaa new-model
    aaa authentication login userauthen local
    aaa authorization network groupauthor local
    aaa session-id common
    dot11 syslog
    ip cef
    ip name-server 139.130.4.4
    ip name-server 203.50.2.71
    ip inspect name firewall tcp
    ip inspect name firewall udp
    ip inspect name firewall rtsp
    multilink bundle-name authenticated
    username cisco password 5 121A0C0411045D5679
    crypto isakmp policy 3
    encr 3des
    authentication pre-share
    group 2
    crypto isakmp client configuration group vpngrp
    key cisco123
    save-password
    crypto ipsec transform-set myset esp-3des esp-sha-hmac
    crypto dynamic-map dynmap 10
    set transform-set myset
    crypto map clientmap client authentication list userauthen
    crypto map clientmap isakmp authorization list groupauthor
    crypto map clientmap 10 ipsec-isakmp dynamic dynmap
    archive
    log config
      hidekeys
    interface Loopback10
    ip address 192.168.0.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    pvc 8/35
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
    dsl operating-mode auto
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    interface FastEthernet3
    interface Vlan1
    no ip address
    ip nat inside
    ip virtual-reassembly
    shutdown
    interface Dialer0
    mtu 1460
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname [email protected]
    ppp chap password
    crypto map clientmap
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer0
    no ip http server
    no ip http secure-server
    ip dns server
    control-plane
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    scheduler max-task-time 5000
    ntp clock-period 17182092
    ntp server 202.83.64.3
    end
    My cisco877 router client configuration...
    sh run
    Building configuration...
    Current configuration : 1919 bytes
    ! No configuration change since last restart
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname Goldcoast
    boot-start-marker
    boot-end-marker
    no aaa new-model
    dot11 syslog
    ip cef
    ip name-server 139.130.4.4
    ip name-server 203.50.2.71
    ip inspect name firewall tcp
    ip inspect name firewall udp
    ip inspect name firewall rtsp
    multilink bundle-name authenticated
    crypto ipsec client ezvpn ez
    connect auto
    group vpngrp key cisco123
    mode network-extension
    peer 165.228.130.43
    xauth userid mode interactive
    archive
    log config
      hidekeys
    interface Loopback0
    ip address 192.168.1.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    crypto ipsec client ezvpn ez inside
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    pvc 8/35
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
    dsl operating-mode auto
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    interface FastEthernet3
    interface Vlan1
    no ip address
    ip nat inside
    ip virtual-reassembly
    shutdown
    interface Dialer0
    mtu 1460
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname [email protected]
    ppp chap password
    crypto ipsec client ezvpn ez
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer0
    no ip http server
    no ip http secure-server
    control-plane
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    login
    scheduler max-task-time 5000
    ntp clock-period 17182119
    ntp server 202.83.64.3
    end
    I am able to connect. But I want to make the connection dynamic rather than user interactive. Please help me.
    Siva.

    Sorry for the late reply.
    I am getting following error after removing xauth. Here is the error.
    ay 14 12:43:47.020: EZVPN(ez) Server does not allow save password option,
    enter your username and password manually
    May 14 12:43:47.020: EZVPN(ez): *** Logic Error ***
    May 14 12:43:47.020: EZVPN(ez): Current State: READY
    May 14 12:43:47.020: EZVPN(ez): Event: MODE_CONFIG_REPLY
    May 14 12:43:47.020: EZVPN(ez): Resetting the EZVPN state machine to recover
    May 14 12:43:47.020: %CRYPTO-6-EZVPN_CONNECTION_DOWN: (Client)  User=  Group=vpngrp  Client_public_addr=Server_public_addr=
    May 14 12:43:49.272: EZVPN(ez) Server does not allow save password option,
    enter your username and password manually
    May 14 12:43:49.272: EZVPN(ez): *** Logic Error ***
    May 14 12:43:49.272: EZVPN(ez): Current State: READY
    May 14 12:43:49.272: EZVPN(ez): Event: MODE_CONFIG_REPLY
    May 14 12:43:49.272: EZVPN(ez): Resetting the EZVPN state machine to recover
    May 14 12:43:49.272: %CRYPTO-6-EZVPN_CONNECTION_DOWN: (Client)  User=  Group=vpngrp  Client_public_addr=Server_public_addr=
    May 14 12:43:51.620: EZVPN(ez) Server does not allow save password option,
    enter your username and password manually
    May 14 12:43:51.620: EZVPN(ez): *** Logic Error ***
    May 14 12:43:51.620: EZVPN(ez): Current State: READY
    May 14 12:43:51.620: EZVPN(ez): Event: MODE_CONFIG_REPLY
    May 14 12:43:51.620: EZVPN(ez): Resetting the EZVPN state machine to recover
    May 14 12:43:51.624: %CRYPTO-6-EZVPN_CONNECTION_DOWN: (Client)  User=  Group=vpngrp  Client_public_addr=Server_public_addr=
    May 14 12:43:53.701: EZVPN(ez) Server does not allow save password option,
    enter your username and password manually
    May 14 12:43:53.701: EZVPN(ez): *** Logic Error ***
    May 14 12:43:53.701: EZVPN(ez): Current State: READY
    May 14 12:43:53.701: EZVPN(ez): Event: MODE_CONFIG_REPLY
    May 14 12:43:53.701: EZVPN(ez): Resetting the EZVPN state machine to recover
    May 14 12:43:53.701: %CRYPTO-6-EZVPN_CONNECTION_DOWN: (Client)  User=  Group=vpngrp  Client_public_addr= Server_public_addr=
    May 14 12:43:55.989: EZVPN(ez) Server does not allow save password option,
    enter your username and password manually
    May 14 12:43:55.989: EZVPN(ez): *** Logic Error ***
    May 14 12:43:55.989: EZVPN(ez): Current State: READY
    May 14 12:43:55.989: EZVPN(ez): Event: MODE_CONFIG_REPLY
    May 14 12:43:55.989: EZVPN(ez): Resetting the EZVPN state machine to recover
    May 14 12:43:55.989: %CRYPTO-6-EZVPN_CONNECTION_DOWN: (Client)  User=  Group=vpngrp  Client_public_addr=Server_public_addr=
    Goldcoast(config-crypto-ezvpn)#
    May 14 12:43:58.009: EZVPN(ez) Server does not allow save password option,
    enter your username and password manually
    May 14 12:43:58.009: EZVPN(ez): *** Logic Error ***
    May 14 12:43:58.009: EZVPN(ez): Current State: READY
    May 14 12:43:58.009: EZVPN(ez): Event: MODE_CONFIG_REPLY
    May 14 12:43:58.009: EZVPN(ez): Resetting the EZVPN state machine to recover
    May 14 12:43:58.009: %CRYPTO-6-EZVPN_CONNECTION_DOWN: (Client)  User=  Group=vpngrp  Client_public_addr=Server_public_addr=
    Thanks,
    siva.

  • PFS shown as disabled in 'show crypto ipsec sa' even tough configured

    Hi,
    I have PFS configured (at least I think) but when I do a 'show crypto ipsec sa', it says 'PFS: N' ...
    interface: Tunnel0
        Crypto map tag: Tunnel0-head-0, local addr 1.1.1.1
       protected vrf: (none)
       local  ident (addr/mask/prot/port): (1.1.1.1/255.255.255.255/47/0)
       remote ident (addr/mask/prot/port): (2.2.2.2/255.255.255.255/47/0)
       current_peer 2.2.2.2 port 500
         PERMIT, flags={origin_is_acl,}
        #pkts encaps: 163, #pkts encrypt: 163, #pkts digest: 163
        #pkts decaps: 340, #pkts decrypt: 340, #pkts verify: 340
        #pkts compressed: 5, #pkts decompressed: 8
        #pkts not compressed: 157, #pkts compr. failed: 1
        #pkts not decompressed: 0, #pkts decompress failed: 0
        #send errors 0, #recv errors 0
         local crypto endpt.: 1.1.1.1, remote crypto endpt.: 2.2.2.2
         path mtu 1500, ip mtu 1500, ip mtu idb Port-channel1.10
         current outbound spi: 0x2093BFD5(546553813)
         PFS (Y/N): N, DH group: none
    Here's the relevant config:
    crypto isakmp policy 10
    encr aes 256
    hash sha256
    authentication pre-share
    group 20
    lifetime 3600
    crypto ipsec transform-set vpn-s2s-ts esp-aes 256 esp-sha256-hmac comp-lzs
    mode transport require
    crypto ipsec profile vpn-s2s
    set transform-set vpn-s2s-ts
    set pfs group20
    interface Tunnel0
      tunnel protection ipsec profile vpn-s2s
    A 'show crypto map' shows it enabled AFAICT:
    Crypto Map IPv4 "Tunnel0-head-0" 65537 ipsec-isakmp
        Map is a PROFILE INSTANCE.
        Peer = 2.2.2.2
        Extended IP access list
            access-list  permit gre host 1.1.1.1 host 2.2.2.2
        Current peer: 2.2.2.2
        Security association lifetime: 4608000 kilobytes/3600 seconds
        Responder-Only (Y/N): N
        PFS (Y/N): Y
        DH group:  group20
        Transform sets={
            vpn-s2s-ts:  { esp-256-aes esp-sha256-hmac  } , { comp-lzs  } ,
        Interfaces using crypto map Tunnel0-head-0:
            Tunnel0
    Any idea ?
    Cheers,
         Sylvain

    Hi,
    I have the same problem with an ASR1001, running asr1001-universalk9.03.10.03.S.153-3.S3-ext.bin.
    Im am using IKEv2 and IPSec with PFS group20. Here's the relevant config (lab):
    crypto ikev2 proposal ikev2-prop_1
     encryption aes-cbc-256
     integrity sha512
     group 20
    crypto ikev2 policy ikev2-pol_1
     match address local 10.10.0.1
     proposal ikev2-prop_1
    crypto ikev2 profile ikev2-prof_1
     match address local interface GigabitEthernet0/0/1
     match identity remote address 10.10.0.2 255.255.255.255
     authentication remote pre-share
     authentication local pre-share
     keyring local keyring_1
     dpd 10 3 on-demand
    crypto ipsec profile ipsec-prof_1
     set transform-set tset_1
     set pfs group20
     set ikev2-profile ikev2-prof_1
    interface Tunnel1
     ip address 10.20.0.1 255.255.255.252
     tunnel source GigabitEthernet0/0/1
     tunnel destination 10.10.0.2
     tunnel protection ipsec profile ipsec-prof_1
    As soon as the IPSec SA is established, the "show crypto ipsec sa" command shows:
    PFS (Y/N): N, DH group: none
    But after the first rekeying (after default time of 3600 secs) it shows:
    PFS (Y/N): Y, DH group: group20
    I consider this a cosmetical problem only, since PFS is doing its job. This can be told from the debugs during the first rekeying:
    000492: Jul  2 11:20:41.790 CEST: IKEv2:(SESSION ID = 210,SA ID = 2):Checking for PFS configuration
    000493: Jul  2 11:20:41.790 CEST: IKEv2:(SESSION ID = 210,SA ID = 2):PFS configured, DH group 20
    000494: Jul  2 11:20:41.790 CEST: IKEv2:(SESSION ID = 210,SA ID = 2):[IKEv2 -> Crypto Engine] Computing DH secret key, DH Group 20
    000495: Jul  2 11:20:41.798 CEST: IKEv2:(SA ID = 2):[Crypto Engine -> IKEv2] DH key Computation PASSED
    000496: Jul  2 11:20:41.798 CEST: IKEv2:(SESSION ID = 210,SA ID = 2):Request queued for computation of DH secret
    000497: Jul  2 11:20:41.798 CEST: IKEv2:(SESSION ID = 210,SA ID = 2):Checking if IKE SA rekey
    000498: Jul  2 11:20:41.798 CEST: IKEv2:(SESSION ID = 210,SA ID = 2):Load IPSEC key material
    000499: Jul  2 11:20:41.798 CEST: IKEv2:(SA ID = 2):[IKEv2 -> IPsec] Create IPsec SA into IPsec database

  • Crypto ipsec gre tunels droped

    Hi,
    From time to time lots of tunnels drop down due to:
    Feb 1 15:10:05 EET: CRYPTO_ENGINE: crypto_pak_coalesce: could not get buffer for new pak. requested size 24
    Feb 1 15:10:05 EET: CRYPTO_ENGINE: crypto_pak_coalesce: could not get buffer for new pak. requested size 90
    Can somebody help me ?
    #sho crypto eli
    Hardware Encryption : ACTIVE
    Number of hardware crypto engines = 1
    CryptoEngine VAM2+:1 details: state = Active
    Capability : IPPCP, DES, 3DES, AES, RSA, IPv6
    IKE-Session : 423 active, 5120 max, 0 failed
    DH : 227 active, 5120 max, 0 failed
    IPSec-Session : 746 active, 10230 max, 0 failed
    Router:
    Cisco 7206VXR (NPE-G1) processor (revision B) with 491520K/32768K bytes of memory.

    To configure Generic Routing Encapsulation (GRE) over an IPSec tunnel between two routers, perform these steps:
    Create a tunnel interface (the IP address of tunnel interface on both routers must be in the same subnet), and configure a tunnel source and tunnel destination under tunnel interface configuration, as shown:
    interface Tunnel0
    ip address 192.168.16.1 255.255.255.0
    tunnel source
    tunnel destination
    Configure isakmp policies, as shown:
    crypto isakmp policy 1
    authentication pre-share
    Configure pre share keys, as shown:
    crypto isakmp key cisco123 address (Remote outside interface IP with 32 bit subnet mask)
    Configure transform set, as shown:
    crypto ipsec transform-set strong esp-3des esp-md5-hmac
    Creat crypto ACI that permits GRE traffic from the outside interface of the local router to the outside interface of the remote router, as shown:
    access-list 120 permit gre host (local outside interface ip) host (Remote outside interface IP)
    Configure crypto map and bind transform set and crypto Access Control List (ACL) to crypto map. Define peer IP address under crypto map, as shown:
    crypto map vpn 10 ipsec-isakmp
    set peer
    set transform-set strong
    match address 120
    Bind crypto map to the physical (outside) interface if you are running Cisco IOS? Software Release 12.2.15 or later. If not, then the crypto map must be applied to the tunnel interface as well as the physical interace, as shown:
    interface Ethernet0/0
    ip address
    half-duplex
    crypto map vpn
    Configure Network Address Traslation (NAT) bypass if needed, as shown:
    access-list 175 deny ip (local private network) (subnet mask) (remote private network) (subnet mask)
    access-list 175 permit ip (local private network) (subnet mask) any
    route-map nonat permit 10
    match ip address 175
    exit
    ip nat inside source route-map nonat interface (outside interface name) overload

  • Do I need 'crypto ipsec df-bit clear'?

    I have a VPN tunnel between an 871 and 877, the tunnel seems to be fine, but checking the tunnel using SDM shows an error.
    Checking the tunnel status... Up
    Encapsulation :330231
    Decapsulation :393226
    Send Error :7939
    Received Error :0
    A ping with data size of this VPN interface MTU size and 'Do not Fragment' bit set to the other end VPN device is failing. This may happen if there is a lesser MTU network which drops the 'Do not Fragmet' packets.
    1)Contact your ISP/Administrator to resolve this issue. 2)Issue the command 'crypto ipsec df-bit clear' under the VPN interface to avoid packets drop due to fragmentation.
    Are the send errors anything to worry about?
    Do I need to issue the 'crypto ipsec df-bit clear' on the routers?
    Any info would be much appreciated.
    Thanks
    Gareth

    Hi Rick
    I've got a list of icmp types from typing 'permit icmp any any ?' in IOS... theres quite a list, 57!!
    How should I decide which ones to allow and which ones to block, I don't even know what they mean :-) Do Cisco publish any recommendations?
    bim7dsl(config-ext-nacl)#permit icmp any any ?
    <0-255> ICMP message type
    administratively-prohibited Administratively prohibited
    alternate-address Alternate address
    conversion-error Datagram conversion
    dod-host-prohibited Host prohibited
    dod-net-prohibited Net prohibited
    echo Echo (ping)
    echo-reply Echo reply
    fragments Check non-initial fragments
    general-parameter-problem Parameter problem
    host-isolated Host isolated
    host-precedence-unreachable Host unreachable for precedence
    host-redirect Host redirect
    host-tos-redirect Host redirect for TOS
    host-tos-unreachable Host unreachable for TOS
    host-unknown Host unknown
    host-unreachable Host unreachable
    information-reply Information replies
    information-request Information requests
    log Log matches against this entry
    log-input Log matches against this entry, including input
    interface
    mask-reply Mask replies
    mask-request Mask requests
    mobile-redirect Mobile host redirect
    net-redirect Network redirect
    net-tos-redirect Net redirect for TOS
    net-tos-unreachable Network unreachable for TOS
    net-unreachable Net unreachable
    network-unknown Network unknown
    no-room-for-option Parameter required but no room
    option Match packets with given IP Options value
    option-missing Parameter required but not present
    packet-too-big Fragmentation needed and DF set
    parameter-problem All parameter problems
    port-unreachable Port unreachable
    precedence Match packets with given precedence value
    precedence-unreachable Precedence cutoff
    protocol-unreachable Protocol unreachable
    reassembly-timeout Reassembly timeout
    redirect All redirects
    reflect Create reflexive access list entry
    router-advertisement Router discovery advertisements
    router-solicitation Router discovery solicitations
    source-quench Source quenches
    source-route-failed Source route failed
    time-exceeded All time exceededs
    time-range Specify a time-range
    timestamp-reply Timestamp replies
    timestamp-request Timestamp requests
    tos Match packets with given TOS value
    traceroute Traceroute
    ttl-exceeded TTL exceeded
    unreachable All unreachables
    Would it be better to permit all icmp where the source is the other end of my VPN, a known fixed IP? And then deny icmp from elsewhere?
    Thanks for all your help on this.
    Gareth

  • Crypto IPSec SA output

    Hi,
    I have a lab setup in GNS3 using two ASAs for site to site VPN. Phase 1 and phase 2 establish fine, however the output shows a high number of packets that are not being compressed, which is identical on both ASAs. See below:
    site2-fw1# sho cry ipsec sa
    interface: outside
        Crypto map tag: VPNMAP, seq num: 1, local addr: x.x.x.x
          access-list CRYPTO-to-SITE1 extended permit ip 172.16.50.0 255.255.255.0 172.16.5.0 255.255.255.0
          local ident (addr/mask/prot/port): (172.16.50.0/255.255.255.0/0/0)
          remote ident (addr/mask/prot/port): (172.16.5.0/255.255.255.0/0/0)
          current_peer: x.x.x.x
          #pkts encaps: 97, #pkts encrypt: 97, #pkts digest: 97
          #pkts decaps: 97, #pkts decrypt: 97, #pkts verify: 97
          #pkts compressed: 0, #pkts decompressed: 0
          #pkts not compressed: 97, #pkts comp failed: 0, #pkts decomp failed: 0
          #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
          #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
          #send errors: 0, #recv errors: 0
          local crypto endpt.: x.x.x.x/0, remote crypto endpt.: x.x.x.x/0
          path mtu 1500, ipsec overhead 74, media mtu 1500
          current outbound spi: 86CE5CB6
          current inbound spi : CEE35649
        inbound esp sas:
          spi: 0xCEE35649 (3471005257)
             transform: esp-aes esp-sha-hmac no compression
             in use settings ={L2L, Tunnel, PFS Group 2, }
             slot: 0, conn_id: 8192, crypto-map: VPNMAP
             sa timing: remaining key lifetime (kB/sec): (4373990/28656)
             IV size: 16 bytes
             replay detection support: Y
             Anti replay bitmap:
              0xFFFFFFFF 0xFFFFFFFF
        outbound esp sas:
          spi: 0x86CE5CB6 (2261671094)
             transform: esp-aes esp-sha-hmac no compression
             in use settings ={L2L, Tunnel, PFS Group 2, }
             slot: 0, conn_id: 8192, crypto-map: VPNMAP
             sa timing: remaining key lifetime (kB/sec): (4373990/28656)
             IV size: 16 bytes
             replay detection support: Y
             Anti replay bitmap:
              0x00000000 0x00000001
    I have not seen this behavious before and not sure whether it is a bad thing.
    Can someone please explain what this means?
    Thanks,
    Ash

    Hi,
    EDIT: Gah, was looking at the wrong counters. There the third counter that mentions "pkts no compressed".
    To me the output seems that you might be testing with ICMP and every single packet has had a reply since the encapsulation/decapsulation counters match eachother.
         #pkts encaps: 97, #pkts encrypt: 97, #pkts digest: 97
          #pkts decaps: 97, #pkts decrypt: 97, #pkts verify: 97
    So since we can see packets on both directions then it would seem that the actual VPN connection is forwarding traffic in both directions between the specified networks.
    To my undertanding you wont see any statistics for compression unless you specifically configure it for the VPN. I have not seen this in use anywhere myself nor have I configured it ever.
    - Jouni

  • Understanding Output Error Messages

    I don't understand the "heirarchy" of Flash Output Error Messages.
    For example:
    TypeError: Error #1009: Cannot access a property or method of a null object reference.
        at bBrand_Gallery()
    ArgumentError: Error #2025: The supplied DisplayObject must be a child of the caller.
        at flash.display::DisplayObjectContainer/removeChild()
        at bBrand_Gallery/startShow()
        at bBrand_Gallery/onComplete()
    This error shows when I preview a SWF that calls en external swf. All the code listed in the Error Codes is contained in the external swf. In the TypeError -- where do I look for the problem code? bBrand_Gallery is a class description for the externally called swf. The externally called swf runs fine by itself. All functions in the package are declared as public functions. I know that the null object reference means that it's looking for the property of an object that is not yet instantiated. How do I find that object? Would it most likely be a variable that is not delacred publicly?
    I believe the ArgumentError has to do with the fact that the DisplayObject in question is not "created" by the function startShow which includes the removeChild statement. How do I resolve that issue??
    Is there a reference as to the best way to interpret these error messages?? I'm so confused!?!?!!?
    Thanks,
    Mike

    Ned Murphy wrote:
    The messages remain something in the way of being difficult to interpret, but sometimes you can get a little better information when you set the option to Permit Debugging in the Flash Publish Settings.  Your 1009 error would end up presenting you with a line number just after the frame number to help you narrow down the problem...
    TypeError: Error #1009: Cannot access a property or method of a null object reference.
        at bBrand_Gallery() frame1:19
    That's telling you line 19 holds the problemed code.  Error messages normally report in a manner of increasing distance from the problemed code.  So you can normally stop looking after the first localization...
    ArgumentError: Error #2025: The supplied DisplayObject must be a child of the caller.
        at flash.display::DisplayObjectContainer/removeChild()
    In the case of this error, you need to focus on what it tells you... there is a removeChild attempt being made for something that is not a child of the container object targeted... and if you follow on, it looks like it is being attempted in a function named startShow, which may have been executed via another function named onComplete
    Ned -- thanks for the feedback.
    I enabled Debugging and published again -- the error code remains the same, with no number or frame info.
    AFA the ArgumentError -- I suspect it's not showing as a child since the errors are preventing the entire swf from loading and running. The child is never created. I need to find the first error, and then the second should disappear.
    I guess the next step is to comment out sections of code and see what elinminates the error and then go from there. . .
    If you have any other suggestions I'm game. Thanks for explaining the sequence of the messages -- I suspected that was the case, but your confirmation helps.
    ETA: Found it.
    There was a reference to the stage width in positioning the preloader, which is a TextField. The external SWF couldn't reference the stage dimensions. I replaced the stage reference with hard dimensions, and the errors are gone.
    Thanks again for your help, Ned. . .
    Message was edited by: mjperry1951

  • Understanding output of sp_helpsegment "default".

    Hi Community.
    I need understand why in the output of sp_helpsegment "default" I can see some  system tables as syscomments,sysreferences and some indexes of syscomments,sysreferences,sysusermessages?.
    I question this  because I Know that All System tables without syslogs must be in the System Segment.
    What is the reason?
    1> sp_helpsegment "default"
    2> go
    segment name    status
           1 default      1
    device        size   free_pages
    prueba_mixed2 50.0MB      24600
    Objects on segment 'default':
    table_name      index_name        indid partition_name
    syscomments     syscomments           0 syscomments_6
    syscomments     csyscomments          2 csyscomments_6
    sysreferences   sysreferences         0 sysreferences_16
    sysreferences   ncsysreferences       2 ncsysreferences_16
    sysreferences   nc2sysreferences      3 nc2sysreferences_16
    sysreferences   csysreferences        4 csysreferences_16
    sysusermessages csysusermessages      1 csysusermessages_15
    sysusermessages ncsysusermessages     2 ncsysusermessages_15
    table_pru       table_pru             0 table_pru_608002166
    table_pru2      table_pru2            0 table_pru2_640002280
    table_pru3      table_pru3            0 table_pru3_672002394
    Objects currently bound to segment 'default':
    table_name      index_name        indid
    syscomments     syscomments           0
    syscomments     csyscomments          2
    sysreferences   sysreferences         0
    sysreferences   ncsysreferences       2
    sysreferences   nc2sysreferences      3
    sysreferences   csysreferences        4
    sysusermessages csysusermessages      1
    sysusermessages ncsysusermessages     2
    table_pru       table_pru             0
    table_pru2      table_pru2            0
    table_pru3      table_pru3            0
    total_size        total_pages     free_pages      used_pages      reserved_pages
    50.0MB            25600           24600           1000            0
    (return status = 0)
    Thanks.
    Cristian Lopez.

    Hi Cristian,
    I see the same thing on my own server, so it appears to be "normal".  I don't know why this would be so, though.  Logically, these should be on the system segment.  I suspect it is a minor bug of some kind in the bootstrap install/upgrade code.  I do not believe it will cause any actual problems, even if you were to take the unusual step of separating the default and system segments on different devices.
    I'll post a followup if I can find an actual explanation.
    -bret

  • Single crypto with two peer

    dear All,
    issue : cisco 2811 , IP sec tunnel establishement with single crypto defined but two set peer
    ip address.
    i want to know :
    In a single crypto map if i define two peer IP address (set Peer ) then did the VPN will come
    up from both the Peer IP OR it will try from the first one and then switch back on the second
    set peer. if later is the case then what are the reasons for causing switch back. .
    Rgds,mac.

    If the first one is no longer reachable, it will fall-back to the second peer.
    Regards
    Farrukh

  • Understanding output of : ucsm-B(nxos)# sh int br

    Hi All ,
    Could you please help me understand the output of the following command :
    ucsm-B(nxos)# sh int br
    I have a few queries on the interfaces number eth1/1/1 to eth 1/1/8 :
    What governs the naming convetion used for the ethernet ports starting eth1/1/1 to eth1/1/9 ?
    If I connect another chassis to the FI , will it start by eth2/1/1 ?
    I would like to understand how Eth1/x/x or Eth2/x/x is decided by the UCS for naming ..
    --------------- truncated -----------------------------------------------------------------------------------------------------
    Interface  Vsan   Admin  Admin   Status          SFP    Oper  Oper   Port
                      Mode   Trunk                          Mode  Speed  Channel
                             Mode                                 (Gbps)
    vfc684     102    F      on      trunking         --     TF      auto --
    vfc688     102    F      on      trunking         --     TF      auto --
    Ethernet      VLAN   Type Mode   Status  Reason                   Speed     Port
    Interface                                                                   Ch #
    Eth1/1/1      1      eth  vntag  up      none                        10G(D) --
    Eth1/1/2      1      eth  vntag  up      none                        10G(D) --
    Eth1/1/3      1      eth  vntag  up      none                        10G(D) --
    Eth1/1/4      1      eth  access down    Administratively down       10G(D) --
    Eth1/1/5      1      eth  access down    Administratively down       10G(D) --
    Eth1/1/6      1      eth  access down    Administratively down       10G(D) --
    Eth1/1/7      1      eth  access down    Administratively down       10G(D) --
    Eth1/1/8      1      eth  access down    Administratively down       10G(D) --
    Eth1/1/9      4044   eth  trunk  up      none                        10G(D) --

    Hello Vikas,
    These are host interfaces ( HIF ) / backplane ports on the FEX / IOM connecting to the blades.
    Eth//
    " show fex detail " would provide additional information about FEX ports.
    The ninth interface provides CIMC connectivity to the blades,
    HTH
    Padma

  • Does anyone understand output power?

    ADSL line status
    Connection Information
    Line state
    Connected
    Connection time
    0 days, 03:12:05
    Downstream
    287 Kbps
    Upstream
    846 Kbps
    ADSL Settings
    VPI/VCI
    0/38
    Type
    PPPoA
    Modulation
    G.992.5 Annex A
    Latency type
    Interleaved
    Noise margin (Down/Up)
    9.8 dB / 6.4 dB
    Line attenuation (Down/Up)
    58.9 dB / 35.0 dB
    Output power (Down/Up)
    1.4 dBm / 1.2 dBm
    Loss of Framing (Local/Remote)
    0 / 0
    Loss of Signal (Local/Remote)
    0 / 0
    Loss of Power (Local/Remote)
    0 / 0
    FEC Errors (Down/Up)
    10643 / 1
    CRC Errors (Down/Up)
    2 / 1
    HEC Errors (Down/Up)
    0 / 0
    Error Seconds (Local/Remote)
    2 / 1
    Does low output power indicate a high resistance fault in a wire ?

    No it does not.
    Your connection speed should be about 2944Kbs
    To enable forum members to help you, please could you look at Helping forum members to help you which asks you to do a few checks first, and has some helpful hints.
    When you have done that, please post the results here, so members can offer advice. Thank you.
    There are some useful help pages here, for BT Broadband customers only, on my personal website.
    BT Broadband customers - help with broadband, WiFi, networking, e-mail and phones.

  • IPSEC packets are not encrypted

    Hello (and Happy Thanksgiving to those in the USA),
    We recently swapped our ASA and re-applied the saved config to the new device. There is a site-to-site VPN that works and a remote client VPN that does not. We use some Cisco VPN clients and some Shrew Soft VPN clients.I've compared the config of the new ASA to that of the old ASA and I cannot find any differences (but the remote client VPN was working on the old ASA). The remote clients do connect and a tunnel is established but they are unable to pass traffic. Systems on the network where the ASA is located are able to access the internet.
    Output of sho crypto isakmp sa (ignore peer #1, that is the working site-to-site VPN)
       Active SA: 2
        Rekey SA: 0 (A tunnel will report 1 Active and 1 Rekey SA d
    Total IKE SA: 2
    1   IKE Peer: xx.168.155.98
        Type    : L2L             Role    : responder
        Rekey   : no              State   : MM_ACTIVE
    2   IKE Peer: xx.211.206.48
        Type    : user            Role    : responder
        Rekey   : no              State   : AM_ACTIVE
    Output of sho crypto ipsec sa (info regarding site-to-site VPN removed). Packets are decrypted but not encrypted.
        Crypto map tag: SYSTEM_DEFAULT_CRYPTO_MAP, seq num: 65535, local addr: publi
    c-ip
          local ident (addr/mask/prot/port): (0.0.0.0/0.0.0.0/0/0)
          remote ident (addr/mask/prot/port): (10.20.1.100/255.255.255.255/0/0)
          current_peer: xx.211.206.48, username: me
          dynamic allocated peer ip: 10.20.1.100
          #pkts encaps: 0, #pkts encrypt: 0, #pkts digest: 0
          #pkts decaps: 20, #pkts decrypt: 20, #pkts verify: 20
          #pkts compressed: 0, #pkts decompressed: 0
          #pkts not compressed: 0, #pkts comp failed: 0, #pkts decomp failed: 0
          #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
          #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
          #send errors: 0, #recv errors: 0
          local crypto endpt.: public-ip/4500, remote crypto endpt.: xx.211.206.48/4
    500
          path mtu 1500, ipsec overhead 82, media mtu 1500
          current outbound spi: 7E0BF9B9
          current inbound spi : 41B75CCD
        inbound esp sas:
          spi: 0x41B75CCD (1102535885)
             transform: esp-aes esp-sha-hmac no compression
             in use settings ={RA, Tunnel,  NAT-T-Encaps, }
             slot: 0, conn_id: 16384, crypto-map: SYSTEM_DEFAULT_CRYPTO_MAP
             sa timing: remaining key lifetime (sec): 28776
             IV size: 16 bytes
             replay detection support: Y
             Anti replay bitmap:
              0x00000000 0x00000001
          spi: 0xC06BF0DD (3228299485)
             transform: esp-aes esp-sha-hmac no compression
             in use settings ={RA, Tunnel,  NAT-T-Encaps, Rekeyed}
             slot: 0, conn_id: 16384, crypto-map: SYSTEM_DEFAULT_CRYPTO_MAP
             sa timing: remaining key lifetime (sec): 28774
             IV size: 16 bytes
             replay detection support: Y
             Anti replay bitmap:
              0x000003FF 0xFFF80001
        outbound esp sas:
          spi: 0x7E0BF9B9 (2114714041)
             transform: esp-aes esp-sha-hmac no compression
             in use settings ={RA, Tunnel,  NAT-T-Encaps, }
             slot: 0, conn_id: 16384, crypto-map: SYSTEM_DEFAULT_CRYPTO_MAP
             sa timing: remaining key lifetime (sec): 28774
             IV size: 16 bytes
             replay detection support: Y
             Anti replay bitmap:
              0x00000000 0x00000001
          spi: 0xCBF945AC (3422111148)
             transform: esp-aes esp-sha-hmac no compression
             in use settings ={RA, Tunnel,  NAT-T-Encaps, Rekeyed}
             slot: 0, conn_id: 16384, crypto-map: SYSTEM_DEFAULT_CRYPTO_MAP
             sa timing: remaining key lifetime (sec): 28772
             IV size: 16 bytes
             replay detection support: Y
             Anti replay bitmap:
              0x00000000 0x00000001
    Config from ASA
    : Saved
    : Written by me at 19:56:37.957 pst Tue Nov 26 2013
    ASA Version 8.2(4)
    hostname mfw01
    domain-name company.int
    enable password xxx encrypted
    passwd xxx encrypted
    names
    name xx.174.143.97 cox-gateway description cox-gateway
    name 172.16.10.0 iscsi-network description iscsi-network
    name 192.168.1.0 legacy-network description legacy-network
    name 10.20.50.0 management-network description management-network
    name 10.20.10.0 server-network description server-network
    name 10.20.20.0 user-network description user-network
    name 192.168.1.101 private-em-imap description private-em-imap
    name 10.20.10.2 private-exchange description private-exchange
    name 10.20.10.3 private-ftp description private-ftp
    name 192.168.1.202 private-ip-phones description private-ip-phones
    name 10.20.10.6 private-kaseya description private-kaseya
    name 192.168.1.2 private-mitel-3300 description private-mitel-3300
    name 10.20.10.1 private-pptp description private-pptp
    name 10.20.10.7 private-sharepoint description private-sharepoint
    name 10.20.10.4 private-tportal description private-tportal
    name 10.20.10.8 private-xarios description private-xarios
    name 192.168.1.215 private-xorcom description private-xorcom
    name xx.174.143.99 public-exchange description public-exchange
    name xx.174.143.100 public-ftp description public-ftp
    name xx.174.143.101 public-tportal description public-tportal
    name xx.174.143.102 public-sharepoint description public-sharepoint
    name xx.174.143.103 public-ip-phones description public-ip-phones
    name xx.174.143.104 public-mitel-3300 description public-mitel-3300
    name xx.174.143.105 public-xorcom description public-xorcom
    name xx.174.143.108 public-remote-support description public-remote-support
    name xx.174.143.109 public-xarios description public-xarios
    name xx.174.143.110 public-kaseya description public-kaseya
    name xx.174.143.111 public-pptp description public-pptp
    name 192.168.2.0 Irvine_LAN description Irvine_LAN
    name xx.174.143.98 public-ip
    name 10.20.10.14 private-RevProxy description private-RevProxy
    name xx.174.143.107 public-RevProxy description Public-RevProxy
    name 10.20.10.9 private-XenDesktop description private-XenDesktop
    name xx.174.143.115 public-XenDesktop description public-XenDesktop
    name 10.20.1.1 private-gateway description private-gateway
    name 192.168.1.96 private-remote-support description private-remote-support
    interface Ethernet0/0
    nameif public
    security-level 0
    ip address public-ip 255.255.255.224
    interface Ethernet0/1
    speed 100
    duplex full
    nameif private
    security-level 100
    ip address private-gateway 255.255.255.0
    interface Ethernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface Ethernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    ip address 192.168.0.1 255.255.255.0
    management-only
    ftp mode passive
    clock timezone pst -8
    clock summer-time PDT recurring
    dns server-group DefaultDNS
    domain-name mills.int
    object-group service ftp
    service-object tcp eq ftp
    service-object tcp eq ftp-data
    object-group service DM_INLINE_SERVICE_1
    group-object ftp
    service-object udp eq tftp
    object-group service DM_INLINE_TCP_1 tcp
    port-object eq 40
    port-object eq ssh
    object-group service web-server
    service-object tcp eq www
    service-object tcp eq https
    object-group service DM_INLINE_SERVICE_2
    service-object tcp eq smtp
    group-object web-server
    object-group service DM_INLINE_SERVICE_3
    service-object tcp eq ssh
    group-object web-server
    object-group service kaseya
    service-object tcp eq 4242
    service-object tcp eq 5721
    service-object tcp eq 8080
    service-object udp eq 5721
    object-group service DM_INLINE_SERVICE_4
    group-object kaseya
    group-object web-server
    object-group service DM_INLINE_SERVICE_5
    service-object gre
    service-object tcp eq pptp
    object-group service VPN
    service-object gre
    service-object esp
    service-object ah
    service-object tcp eq pptp
    service-object udp eq 4500
    service-object udp eq isakmp
    object-group network MILLS_VPN_VLANS
    network-object 10.20.1.0 255.255.255.0
    network-object server-network 255.255.255.0
    network-object user-network 255.255.255.0
    network-object management-network 255.255.255.0
    network-object legacy-network 255.255.255.0
    object-group service InterTel5000
    service-object tcp range 3998 3999
    service-object tcp range 6800 6802
    service-object udp eq 20001
    service-object udp range 5004 5007
    service-object udp range 50098 50508
    service-object udp range 6604 7039
    service-object udp eq bootpc
    service-object udp eq tftp
    service-object tcp eq 4000
    service-object tcp eq 44000
    service-object tcp eq www
    service-object tcp eq https
    service-object tcp eq 5566
    service-object udp eq 5567
    service-object udp range 6004 6603
    service-object tcp eq 6880
    object-group service DM_INLINE_SERVICE_6
    service-object icmp
    service-object tcp eq 2001
    service-object tcp eq 2004
    service-object tcp eq 2005
    object-group service DM_INLINE_SERVICE_7
    service-object icmp
    group-object InterTel5000
    object-group service DM_INLINE_SERVICE_8
    service-object icmp
    service-object tcp eq https
    service-object tcp eq ssh
    object-group service RevProxy tcp
    description RevProxy
    port-object eq 5500
    object-group service XenDesktop tcp
    description Xen
    port-object eq 8080
    port-object eq 2514
    port-object eq 2598
    port-object eq 27000
    port-object eq 7279
    port-object eq 8000
    port-object eq citrix-ica
    access-list public_access_in extended permit object-group DM_INLINE_SERVICE_8 any host public-ip
    access-list public_access_in extended permit object-group VPN any host public-ip
    access-list public_access_in extended permit object-group DM_INLINE_SERVICE_7 any host public-ip-phones
    access-list public_access_in extended permit object-group DM_INLINE_SERVICE_1 any host public-ftp
    access-list public_access_in extended permit tcp any host public-xorcom object-group DM_INLINE_TCP_1
    access-list public_access_in extended permit object-group DM_INLINE_SERVICE_2 any host public-exchange
    access-list public_access_in extended permit tcp any host public-RevProxy object-group RevProxy
    access-list public_access_in extended permit object-group DM_INLINE_SERVICE_3 any host public-remote-support
    access-list public_access_in extended permit object-group DM_INLINE_SERVICE_6 any host public-xarios
    access-list public_access_in extended permit object-group web-server any host public-sharepoint
    access-list public_access_in extended permit object-group web-server any host public-tportal
    access-list public_access_in extended permit object-group DM_INLINE_SERVICE_4 any host public-kaseya
    access-list public_access_in extended permit object-group DM_INLINE_SERVICE_5 any host public-pptp
    access-list public_access_in extended permit ip any host public-XenDesktop
    access-list private_access_in extended permit icmp any any
    access-list private_access_in extended permit ip any any
    access-list VPN_Users_SplitTunnelAcl standard permit server-network 255.255.255.0
    access-list VPN_Users_SplitTunnelAcl standard permit user-network 255.255.255.0
    access-list VPN_Users_SplitTunnelAcl standard permit management-network 255.255.255.0
    access-list VPN_Users_SplitTunnelAcl standard permit 10.20.1.0 255.255.255.0
    access-list VPN_Users_SplitTunnelAcl standard permit legacy-network 255.255.255.0
    access-list private_nat0_outbound extended permit ip object-group MILLS_VPN_VLANS Irvine_LAN 255.255.255.0
    access-list private_nat0_outbound extended permit ip object-group MILLS_VPN_VLANS 10.20.1.96 255.255.255.240
    access-list private_nat0_outbound extended permit ip object-group MILLS_VPN_VLANS 10.90.2.0 255.255.255.0
    access-list public_1_cryptomap extended permit ip object-group MILLS_VPN_VLANS Irvine_LAN 255.255.255.0
    access-list public_2_cryptomap extended permit ip object-group MILLS_VPN_VLANS 10.90.2.0 255.255.255.0
    pager lines 24
    logging enable
    logging list Error-Events level warnings
    logging monitor warnings
    logging buffered warnings
    logging trap warnings
    logging asdm warnings
    logging mail warnings
    logging host private private-kaseya
    logging permit-hostdown
    logging class auth trap alerts
    mtu public 1500
    mtu private 1500
    mtu management 1500
    ip local pool VPN_Users 10.20.1.100-10.20.1.110 mask 255.255.255.0
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (public) 101 interface
    nat (private) 0 access-list private_nat0_outbound
    nat (private) 101 0.0.0.0 0.0.0.0
    nat (management) 101 0.0.0.0 0.0.0.0
    static (private,public) public-ip-phones private-ip-phones netmask 255.255.255.255 dns
    static (private,public) public-ftp private-ftp netmask 255.255.255.255 dns
    static (private,public) public-xorcom private-xorcom netmask 255.255.255.255 dns
    static (private,public) public-exchange private-exchange netmask 255.255.255.255 dns
    static (private,public) public-RevProxy private-RevProxy netmask 255.255.255.255 dns
    static (private,public) public-remote-support private-remote-support netmask 255.255.255.255 dns
    static (private,public) public-xarios private-xarios netmask 255.255.255.255 dns
    static (private,public) public-sharepoint private-sharepoint netmask 255.255.255.255 dns
    static (private,public) public-tportal private-tportal netmask 255.255.255.255 dns
    static (private,public) public-kaseya private-kaseya netmask 255.255.255.255 dns
    static (private,public) public-pptp private-pptp netmask 255.255.255.255 dns
    static (private,public) public-XenDesktop private-XenDesktop netmask 255.255.255.255 dns
    access-group public_access_in in interface public
    access-group private_access_in in interface private
    route public 0.0.0.0 0.0.0.0 cox-gateway 1
    route private server-network 255.255.255.0 10.20.1.254 1
    route private user-network 255.255.255.0 10.20.1.254 1
    route private management-network 255.255.255.0 10.20.1.254 1
    route private iscsi-network 255.255.255.0 10.20.1.254 1
    route private legacy-network 255.255.255.0 10.20.1.254 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    ldap attribute-map admin-control
      map-name  comment Privilege-Level
    ldap attribute-map allow-dialin
      map-name  msNPAllowDialin IETF-Radius-Class
      map-value msNPAllowDialin FALSE NOACCESS
      map-value msNPAllowDialin TRUE IPSecUsers
    ldap attribute-map mills-vpn_users
      map-name  msNPAllowDialin IETF-Radius-Class
      map-value msNPAllowDialin FALSE NOACCESS
      map-value msNPAllowDialin True IPSecUsers
    ldap attribute-map network-admins
      map-name  memberOf IETF-Radius-Service-Type
      map-value memberOf FALSE NOACCESS
      map-value memberOf "Network Admins" 6
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server Mills protocol nt
    aaa-server Mills (private) host private-pptp
    nt-auth-domain-controller ms01.mills.int
    aaa-server Mills_NetAdmin protocol ldap
    aaa-server Mills_NetAdmin (private) host private-pptp
    server-port 389
    ldap-base-dn ou=San Diego,dc=mills,dc=int
    ldap-group-base-dn ou=San Diego,dc=mills,dc=int
    ldap-scope subtree
    ldap-naming-attribute cn
    ldap-login-password *
    ldap-login-dn cn=asa,ou=Service Accounts,ou=San Diego,dc=mills,dc=int
    server-type microsoft
    ldap-attribute-map mills-vpn_users
    aaa-server NetworkAdmins protocol ldap
    aaa-server NetworkAdmins (private) host private-pptp
    ldap-base-dn ou=San Diego,dc=mills,dc=int
    ldap-group-base-dn ou=San Diego,dc=mills,dc=int
    ldap-scope subtree
    ldap-naming-attribute cn
    ldap-login-password *
    ldap-login-dn cn=asa,ou=Service Accounts,ou=San Diego,dc=mills,dc=int
    server-type microsoft
    ldap-attribute-map network-admins
    aaa-server ADVPNUsers protocol ldap
    aaa-server ADVPNUsers (private) host private-pptp
    ldap-base-dn ou=San Diego,dc=mills,dc=int
    ldap-group-base-dn ou=San Diego,dc=mills,dc=int
    ldap-scope subtree
    ldap-naming-attribute cn
    ldap-login-password *
    ldap-login-dn cn=asa,ou=Service Accounts,ou=San Diego,dc=mills,dc=int
    server-type microsoft
    ldap-attribute-map mills-vpn_users
    aaa authentication enable console ADVPNUsers LOCAL
    aaa authentication http console ADVPNUsers LOCAL
    aaa authentication serial console ADVPNUsers LOCAL
    aaa authentication telnet console ADVPNUsers LOCAL
    aaa authentication ssh console ADVPNUsers LOCAL
    http server enable
    http 0.0.0.0 0.0.0.0 management
    http 0.0.0.0 0.0.0.0 public
    http 0.0.0.0 0.0.0.0 private
    snmp-server host private private-kaseya poll community ***** version 2c
    snmp-server location Mills - San Diego
    snmp-server contact Mills Assist
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    sysopt noproxyarp private
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map public_map 1 match address public_1_cryptomap
    crypto map public_map 1 set pfs
    crypto map public_map 1 set peer xx.168.155.98
    crypto map public_map 1 set transform-set ESP-3DES-MD5 ESP-AES-128-SHA
    crypto map public_map 1 set nat-t-disable
    crypto map public_map 1 set phase1-mode aggressive
    crypto map public_map 2 match address public_2_cryptomap
    crypto map public_map 2 set pfs group5
    crypto map public_map 2 set peer xx.181.134.141
    crypto map public_map 2 set transform-set ESP-AES-128-SHA
    crypto map public_map 2 set nat-t-disable
    crypto map public_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map public_map interface public
    crypto isakmp enable public
    crypto isakmp policy 1
    authentication pre-share
    encryption aes
    hash sha
    group 5
    lifetime 86400
    crypto isakmp policy 10
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 30
    authentication pre-share
    encryption 3des
    hash md5
    group 1
    lifetime 28800
    telnet 0.0.0.0 0.0.0.0 private
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 public
    ssh 0.0.0.0 0.0.0.0 private
    ssh 0.0.0.0 0.0.0.0 management
    ssh timeout 5
    console timeout 0
    dhcpd address 192.168.0.2-192.168.0.254 management
    threat-detection basic-threat
    threat-detection statistics access-list
    threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
    ntp authenticate
    ntp server 216.129.110.22 source public
    ntp server 173.244.211.10 source public
    ntp server 24.124.0.251 source public prefer
    webvpn
    enable public
    svc enable
    group-policy NOACCESS internal
    group-policy NOACCESS attributes
    vpn-simultaneous-logins 0
    vpn-tunnel-protocol svc
    group-policy IPSecUsers internal
    group-policy IPSecUsers attributes
    wins-server value 10.20.10.1
    dns-server value 10.20.10.1
    vpn-tunnel-protocol IPSec
    password-storage enable
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value VPN_Users_SplitTunnelAcl
    default-domain value mills.int
    address-pools value VPN_Users
    group-policy Irvine internal
    group-policy Irvine attributes
    vpn-tunnel-protocol IPSec
    username admin password Kra9/kXfLDwlSxis encrypted
    tunnel-group VPN_Users type remote-access
    tunnel-group VPN_Users general-attributes
    address-pool VPN_Users
    authentication-server-group Mills_NetAdmin
    default-group-policy IPSecUsers
    tunnel-group VPN_Users ipsec-attributes
    pre-shared-key *
    tunnel-group xx.189.99.114 type ipsec-l2l
    tunnel-group xx.189.99.114 general-attributes
    default-group-policy Irvine
    tunnel-group xx.189.99.114 ipsec-attributes
    pre-shared-key *
    tunnel-group xx.205.23.76 type ipsec-l2l
    tunnel-group xx.205.23.76 general-attributes
    default-group-policy Irvine
    tunnel-group xx.205.23.76 ipsec-attributes
    pre-shared-key *
    tunnel-group xx.168.155.98 type ipsec-l2l
    tunnel-group xx.168.155.98 general-attributes
    default-group-policy Irvine
    tunnel-group xx.168.155.98 ipsec-attributes
    pre-shared-key *
    class-map global-class
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global-policy
    class global-class
      inspect dns
      inspect esmtp
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect netbios
      inspect rsh
      inspect rtsp
      inspect sip 
      inspect skinny 
      inspect sqlnet
      inspect sunrpc
      inspect tftp
      inspect xdmcp
    service-policy global-policy global
    privilege cmd level 3 mode exec command perfmon
    privilege cmd level 3 mode exec command ping
    privilege cmd level 3 mode exec command who
    privilege cmd level 3 mode exec command logging
    privilege cmd level 3 mode exec command failover
    privilege cmd level 3 mode exec command packet-tracer
    privilege show level 5 mode exec command import
    privilege show level 5 mode exec command running-config
    privilege show level 3 mode exec command reload
    privilege show level 3 mode exec command mode
    privilege show level 3 mode exec command firewall
    privilege show level 3 mode exec command asp
    privilege show level 3 mode exec command cpu
    privilege show level 3 mode exec command interface
    privilege show level 3 mode exec command clock
    privilege show level 3 mode exec command dns-hosts
    privilege show level 3 mode exec command access-list
    privilege show level 3 mode exec command logging
    privilege show level 3 mode exec command vlan
    privilege show level 3 mode exec command ip
    privilege show level 3 mode exec command ipv6
    privilege show level 3 mode exec command failover
    privilege show level 3 mode exec command asdm
    privilege show level 3 mode exec command arp
    privilege show level 3 mode exec command route
    privilege show level 3 mode exec command ospf
    privilege show level 3 mode exec command aaa-server
    privilege show level 3 mode exec command aaa
    privilege show level 3 mode exec command eigrp
    privilege show level 3 mode exec command crypto
    privilege show level 3 mode exec command vpn-sessiondb
    privilege show level 3 mode exec command ssh
    privilege show level 3 mode exec command dhcpd
    privilege show level 3 mode exec command vpn
    privilege show level 3 mode exec command blocks
    privilege show level 3 mode exec command wccp
    privilege show level 3 mode exec command webvpn
    privilege show level 3 mode exec command module
    privilege show level 3 mode exec command uauth
    privilege show level 3 mode exec command compression
    privilege show level 3 mode configure command interface
    privilege show level 3 mode configure command clock
    privilege show level 3 mode configure command access-list
    privilege show level 3 mode configure command logging
    privilege show level 3 mode configure command ip
    privilege show level 3 mode configure command failover
    privilege show level 5 mode configure command asdm
    privilege show level 3 mode configure command arp
    privilege show level 3 mode configure command route
    privilege show level 3 mode configure command aaa-server
    privilege show level 3 mode configure command aaa
    privilege show level 3 mode configure command crypto
    privilege show level 3 mode configure command ssh
    privilege show level 3 mode configure command dhcpd
    privilege show level 5 mode configure command privilege
    privilege clear level 3 mode exec command dns-hosts
    privilege clear level 3 mode exec command logging
    privilege clear level 3 mode exec command arp
    privilege clear level 3 mode exec command aaa-server
    privilege clear level 3 mode exec command crypto
    privilege cmd level 3 mode configure command failover
    privilege clear level 3 mode configure command logging
    privilege clear level 3 mode configure command arp
    privilege clear level 3 mode configure command crypto
    privilege clear level 3 mode configure command aaa-server
    prompt hostname context
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:5d5c963680401d150bee94b3c7c85f7a
    Maybe my eyes are glazing over from looking at this for too long. Does anything look wrong? Maybe I missed a command that would not show up in the config?
    Thanks in advance to all who take a look.

    Marius,
    I connected via my VPN client at home and pinged a remote server, attempted to RDP by name and then attempted to RDP by IP address. All were unsuccessful. Here is the packet capture:
    72 packets captured
       1: 09:44:06.304671 10.20.1.100.137 > 10.20.10.1.137:  udp 68
       2: 09:44:06.304885 10.20.1.100.54543 > 10.20.10.1.53:  udp 34
       3: 09:44:07.198384 10.20.1.100.51650 > 10.20.10.1.53:  udp 32
       4: 09:44:07.300353 10.20.1.100.54543 > 10.20.10.1.53:  udp 34
       5: 09:44:07.786504 10.20.1.100.137 > 10.20.10.1.137:  udp 68
       6: 09:44:07.786671 10.20.1.100.137 > 10.20.10.1.137:  udp 68
       7: 09:44:07.786855 10.20.1.100.137 > 10.20.10.1.137:  udp 68
       8: 09:44:08.198399 10.20.1.100.51650 > 10.20.10.1.53:  udp 32
       9: 09:44:09.282608 10.20.1.100.61328 > 10.20.10.1.53:  udp 32
      10: 09:44:09.286667 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      11: 09:44:09.286926 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      12: 09:44:09.287201 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      13: 09:44:09.300491 10.20.1.100.54543 > 10.20.10.1.53:  udp 34
      14: 09:44:10.199193 10.20.1.100.51650 > 10.20.10.1.53:  udp 32
      15: 09:44:10.282150 10.20.1.100.61328 > 10.20.10.1.53:  udp 32
      16: 09:44:11.286865 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      17: 09:44:12.302993 10.20.1.100.61328 > 10.20.10.1.53:  udp 32
      18: 09:44:12.785054 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      19: 09:44:13.301101 10.20.1.100.54543 > 10.20.10.1.53:  udp 34
      20: 09:44:14.204029 10.20.1.100.51650 > 10.20.10.1.53:  udp 32
      21: 09:44:14.287323 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      22: 09:44:14.375331 10.20.1.100 > 10.20.10.1: icmp: echo request
      23: 09:44:16.581589 10.20.1.100.137 > 10.20.10.1.137:  udp 50
      24: 09:44:18.083842 10.20.1.100.137 > 10.20.10.1.137:  udp 50
      25: 09:44:18.199879 10.20.1.100.137 > 10.20.10.1.137:  udp 50
      26: 09:44:19.224063 10.20.1.100 > 10.20.10.1: icmp: echo request
      27: 09:44:19.582367 10.20.1.100.137 > 10.20.10.1.137:  udp 50
      28: 09:44:19.704019 10.20.1.100.137 > 10.20.10.1.137:  udp 50
      29: 09:44:20.288193 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      30: 09:44:21.200307 10.20.1.100.137 > 10.20.10.1.137:  udp 50
      31: 09:44:21.786321 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      32: 09:44:23.289535 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      33: 09:44:24.204777 10.20.1.100 > 10.20.10.1: icmp: echo request
      34: 09:44:29.219440 10.20.1.100 > 10.20.10.1: icmp: echo request
      35: 09:44:29.287460 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      36: 09:44:30.787617 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      37: 09:44:32.287887 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      38: 09:45:00.533816 10.20.1.100.137 > 10.20.10.1.137:  udp 50
      39: 09:45:02.018019 10.20.1.100.137 > 10.20.10.1.137:  udp 50
      40: 09:45:03.160239 10.20.1.100.52764 > 10.20.10.1.53:  udp 34
      41: 09:45:03.350354 10.20.1.100.53948 > 10.20.10.1.53:  udp 38
      42: 09:45:03.521960 10.20.1.100.137 > 10.20.10.1.137:  udp 50
      43: 09:45:04.158408 10.20.1.100.52764 > 10.20.10.1.53:  udp 34
      44: 09:45:04.344342 10.20.1.100.53948 > 10.20.10.1.53:  udp 38
      45: 09:45:06.160681 10.20.1.100.52764 > 10.20.10.1.53:  udp 34
      46: 09:45:06.358593 10.20.1.100.53948 > 10.20.10.1.53:  udp 38
      47: 09:45:10.159125 10.20.1.100.52764 > 10.20.10.1.53:  udp 34
      48: 09:45:10.345227 10.20.1.100.53948 > 10.20.10.1.53:  udp 38
      49: 09:45:14.550478 10.20.1.100.59402 > 10.20.10.1.53:  udp 32
      50: 09:45:15.536166 10.20.1.100.59402 > 10.20.10.1.53:  udp 32
      51: 09:45:17.546144 10.20.1.100.59402 > 10.20.10.1.53:  udp 32
      52: 09:45:21.882812 10.20.1.100.137 > 10.20.10.1.137:  udp 50
      53: 09:45:23.379222 10.20.1.100.137 > 10.20.10.1.137:  udp 50
      54: 09:45:24.893386 10.20.1.100.137 > 10.20.10.1.137:  udp 50
      55: 09:45:41.550035 10.20.1.100.137 > 10.20.10.1.137:  udp 50
      56: 09:45:43.029875 10.20.1.100.137 > 10.20.10.1.137:  udp 50
      57: 09:45:44.541979 10.20.1.100.137 > 10.20.10.1.137:  udp 50
      58: 09:46:10.767782 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      59: 09:46:12.261934 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      60: 09:46:13.776250 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      61: 09:46:19.848970 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      62: 09:46:20.113183 10.20.1.100.49751 > 10.20.10.7.3389: S 3288428077:3288428077(0) win 8192
      63: 09:46:21.331251 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      64: 09:46:22.831423 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      65: 09:46:23.101511 10.20.1.100.137 > 10.20.10.1.137:  udp 50
      66: 09:46:23.123254 10.20.1.100.49751 > 10.20.10.7.3389: S 3288428077:3288428077(0) win 8192
      67: 09:46:24.591705 10.20.1.100.137 > 10.20.10.1.137:  udp 50
      68: 09:46:26.115976 10.20.1.100.137 > 10.20.10.1.137:  udp 50
      69: 09:46:28.834276 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      70: 09:46:29.125817 10.20.1.100.49751 > 10.20.10.7.3389: S 3288428077:3288428077(0) win 8192
      71: 09:46:30.342816 10.20.1.100.137 > 10.20.10.1.137:  udp 68
      72: 09:46:31.840746 10.20.1.100.137 > 10.20.10.1.137:  udp 68
    72 packets shown

  • L2L IPSec VPN- At Wits End

    I've got 3 ASA 5505, each with AnyConnect access and IPSec tunnels to the other two.  For some reason I can't get the traffic between two of the subnets.
    Boxb LAN (137.x)                -->       Dal LAN (139.x)       =     BAD
    Boxb AnyConnect (237.x)     -->       Dal LAN (139.x)      =      Good
    Boxb LAN (137.x)                -->       Wal LAN (138.x)       =     Good
    Boxb AnyConnect (237.x)     -->       Wal LAN (138.x)      =      Good
    Dal LAN (139.x)                -->          Boxb LAN (137.x)       =     BAD
    Dal AnyConnect (230.x)     -->          Boxb LAN (137.x)      =      Good
    Dal LAN (139.x)                -->       Wal LAN (138.x)       =     Good
    Dal AnyConnect (239.x)     -->       Wal LAN (138.x)      =      Good
    Everything works fine to/from the Waltham ASA, and if you're connected via AnyConnect connections.  Just the 192.168.137.x to/from 192.168.139.x subnets can't talk. 
    I can see the ICMP connections being built and torndown when I ping across those subnets, but no other errors are logged. 
    I've attached the running configs and outputs of "sh crypto ipsec sa detail" from Dallas and Boxb. Can someone take a look?

    Here is the policy. The watchguard has phase 1 set to SHA1-3DES.
    bfccrtr#sh crypto isakmp policy
    Global IKE policy
    Protection suite of priority 1
            encryption algorithm:   Three key triple DES
            hash algorithm:         Secure Hash Standard
            authentication method:  Pre-Shared Key
            Diffie-Hellman group:   #2 (1024 bit)
            lifetime:               3600 seconds, no volume limit
    This is why I'm so confused with this. It appears to me that everything is matched up. The watchguard has multiple other VPN tunnels configured on it, but none with a Cisco device on the other end, so I'm not getting much help from that vendor. Unfortunately, I'm not familiar with the watchguard device.

  • Two ASA tunnels, only some remote peers are reachable

    Hi, very strange issue here ...
    Brief overview ..... I have one ASA with two tunnels. Each going to a different 3rd party Checkpoint firewall (site A, site B)
    Each site has two servers (A1, A2, B1, B2)
    I can only connect to A1 and B1. any connection to A2 and B2 fails.
    I have defined B2 and A2 in the crypto map to be protected.
    If I only have B2 or A2 in the crypto map ACL then the tunnel fails. Phase 1 does not come up. Its as if the ASA is ignoring the entries for B2 and A2.
    ASA running 8.4(2).
    I have also trashed the VPN and built via the wizard, same result.
    Any thoughts greatly appreciated.
    Regards
    Paul

    Hi,
    To my understanding the Phase1 should not be affected by the configurations you set in the Phase2 ACL defining interesting traffic.
    Though it would naturally mean that your VPN negotiation would still fail.
    It would seem to me that if the secondary A2 and B2 addresses dont work along with the A1 and B1 or even alone by themselves that the remote ends would have been configured incorrectly. Though it would seem wierd if this happens on 2 different connections. Unless ofcourse the same person handled the remote end configurations?
    If you want we could certainly check your ASAs configurations for any problems after which you could ask the remote site management to go through the configurations.
    You have also the ability to use the "packet-tracer" command to define what is happening.
    The format is this
    packet-tracer input tcp
    Just modify the above to suite your situation. The is the ASA interface behind which your connecting host is. (Dont use ASA interface IP addresses as the source)
    Can you take the above command output when you are trying to connect to A2 and B2 hosts. Please take the command output twice from each and then copy/paste the second commands output here on the forums. Why I ask you to take the output twice is because you would need the first command just to bring up the L2L VPN connection and it coudlnt go through completely. The second command output should on the other hand succeed if configurations are correct. If it doesnt go through then the problem is probably configurations between the local and remote site.
    You can also use the command "show crypto ipsec sa peer " to see if the both devices of the L2L VPN Connection have been able to form the connection.
    - Jouni

  • ASA 5505 rookie - can't ping remote site or vice versa

    Hi, I'm trying to setup an ipsec from an ASA 5505 (8.4) to a Sophos UTM (9.2)
    Internet etc is up and accessible. Ipsec tunnel is up also but I can't pass traffic through it.
    I get this message in the logs:
    3
    Aug 05 2014
    22:38:52
    81.111.111.156
    82.222.222.38
    Deny inbound protocol 50 src outside:81.111.111.156 dst outside:82.222.222.38
    SITE A (ASA 5505) = 82.222.222.38
    SITE B (UTM 9) = 81.111.111.156
    Any pointers would be good as this is the first time I've tried this. Thank you.
    Running config below:
    hostname ciscoasa
    enable password 8Ry2YjIyt7RRXU24 encrypted
    xlate per-session deny tcp any4 any4
    xlate per-session deny tcp any4 any6
    xlate per-session deny tcp any6 any4
    xlate per-session deny tcp any6 any6
    xlate per-session deny udp any4 any4 eq domain
    xlate per-session deny udp any4 any6 eq domain
    xlate per-session deny udp any6 any4 eq domain
    xlate per-session deny udp any6 any6 eq domain
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
     switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
     nameif inside
     security-level 100
     ip address 192.168.1.1 255.255.255.0
    interface Vlan2
     description Zen Internet
     nameif outside
     security-level 0
     pppoe client vpdn group Zen
     ip address 82.222.222.38 255.255.255.255 pppoe setroute
    boot system disk0:/asa922-k8.bin
    ftp mode passive
    dns domain-lookup inside
    dns domain-lookup outside
    dns server-group DefaultDNS
     name-server 8.8.8.8
    object network obj_any
     subnet 0.0.0.0 0.0.0.0
    object network MY-LAN
     subnet 192.168.1.0 255.255.255.0
    object network THIER-LAN
     subnet 192.168.30.0 255.255.255.0
    object network NETWORK_OBJ_192.168.1.0_24
     subnet 192.168.1.0 255.255.255.0
    object network NETWORK_OBJ_192.168.30.0_24
     subnet 192.168.30.0 255.255.255.0
    object network THIER_VPN
     host 81.111.111.156
     description THIER VPN 
    object service Sophos_Admin
     service tcp destination eq 4444
    object-group protocol DM_INLINE_PROTOCOL_1
     protocol-object ip
     protocol-object icmp
     protocol-object esp
    object-group protocol DM_INLINE_PROTOCOL_2
     protocol-object ip
     protocol-object icmp
     protocol-object esp
    object-group protocol DM_INLINE_PROTOCOL_3
     protocol-object ip
     protocol-object icmp
     protocol-object esp
    object-group service DM_INLINE_SERVICE_1
     service-object icmp
     service-object udp destination eq domain
     service-object object Sophos_Admin
     service-object tcp destination eq www
     service-object tcp destination eq https
     service-object esp
    object-group service DM_INLINE_SERVICE_2
     service-object icmp
     service-object object Sophos_Admin
     service-object esp
     service-object icmp echo-reply
    object-group service DM_INLINE_SERVICE_3
     service-object ip
     service-object esp
     service-object icmp echo-reply
    object-group service DM_INLINE_SERVICE_4
     service-object object Sophos_Admin
     service-object icmp echo
     service-object icmp echo-reply
    access-list outside_cryptomap extended permit object-group DM_INLINE_PROTOCOL_3 object MY-LAN object THIER-LAN
    access-list outside_cryptomap_1 extended permit object-group DM_INLINE_PROTOCOL_2 object MY-LAN object THIER-LAN
    access-list inside_cryptomap extended permit object-group DM_INLINE_PROTOCOL_1 object THIER-LAN object MY-LAN
    access-list outside_access_out extended permit object-group DM_INLINE_SERVICE_3 object THIER_VPN host 82.222.222.38
    access-list outside_access_out extended permit object-group DM_INLINE_SERVICE_1 any any
    access-list outside_access_in extended permit object-group DM_INLINE_SERVICE_2 object THIER_VPN host 82.222.222.38
    access-list inside_access_out extended permit object-group DM_INLINE_SERVICE_4 object MY-LAN object THIER-LAN
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-722.bin
    no asdm history enable
    arp timeout 14400
    no arp permit-nonconnected
    object network obj_any
     nat (inside,outside) dynamic interface
    access-group inside_access_out out interface inside
    access-group outside_access_in in interface outside
    access-group outside_access_out out interface outside
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    aaa authentication ssh console LOCAL
    aaa authentication http console LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS esp-aes esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA-TRANS mode transport
    crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-MD5-TRANS mode transport
    crypto ipsec ikev2 ipsec-proposal DES
     protocol esp encryption des
     protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal 3DES
     protocol esp encryption 3des
     protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES
     protocol esp encryption aes
     protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES192
     protocol esp encryption aes-192
     protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES256
     protocol esp encryption aes-256
     protocol esp integrity sha-1 md5
    crypto ipsec security-association pmtu-aging infinite
    crypto map outside_map 1 match address outside_cryptomap
    crypto map outside_map 1 set pfs
    crypto map outside_map 1 set peer 81.111.111.156
    crypto map outside_map 1 set ikev1 transform-set ESP-AES-128-SHA
    crypto map outside_map 1 set ikev2 ipsec-proposal AES
    crypto map outside_map 2 match address outside_cryptomap_1
    crypto map outside_map 2 set pfs
    crypto map outside_map 2 set peer 81.111.111.156
    crypto map outside_map 2 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map 2 set ikev2 ipsec-proposal DES 3DES AES AES192 AES256
    crypto map outside_map interface outside
    crypto ca trustpool policy
    crypto ikev2 policy 20
     encryption aes
     integrity sha
     group 2
     prf sha
     lifetime seconds 7800
    crypto ikev2 enable outside
    crypto ikev1 enable outside
    crypto ikev1 policy 90
     authentication pre-share
     encryption aes
     hash sha
     group 2
     lifetime 7800
    telnet timeout 5
    ssh scopy enable
    ssh stricthostkeycheck
    ssh 192.168.1.0 255.255.255.0 inside
    ssh timeout 30
    ssh version 2
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    vpdn group Zen request dialout pppoe
    vpdn group Zen localname MYISP@zen
    vpdn group Zen ppp authentication chap
    vpdn username MYISP@zen password ***** store-local
    dhcpd auto_config outside
    dhcpd address 192.168.1.5-192.168.1.36 inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    dynamic-filter updater-client enable
    dynamic-filter use-database
    dynamic-filter enable interface outside
    dynamic-filter drop blacklist interface outside
    webvpn
     anyconnect-essentials
    group-policy GroupPolicy_81.111.111.156 internal
    group-policy GroupPolicy_81.111.111.156 attributes
     vpn-tunnel-protocol ikev1
    username admin password JsE9Hv42G/zRUcG4 encrypted privilege 15
    username bob password lTKS32e90Yo5l2L/ encrypted
    tunnel-group 81.111.111.156 type ipsec-l2l
    tunnel-group 81.111.111.156 general-attributes
     default-group-policy GroupPolicy_81.111.111.156
    tunnel-group 81.111.111.156 ipsec-attributes
     ikev1 pre-shared-key *****
     ikev2 remote-authentication pre-shared-key *****
     ikev2 local-authentication pre-shared-key *****
    class-map inspection_default
     match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
     parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
     class inspection_default
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
      inspect icmp
      inspect dns preset_dns_map dynamic-filter-snoop
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    hpm topN enable
    Cryptochecksum:9430c8a44d330d2b55f981274599a67e
    : end
    ciscoasa#

    Hi,
    I started again and used various combinations of encryption etc but they all come back the same so I'm at a loss.
    output of debug crypto ipsec 128
    IPSEC: New embryonic SA created @ 0xcdbaeff8,
        SCB: 0xCDC33C70,
        Direction: inbound
        SPI      : 0x6699A5F8
        Session ID: 0x00006000
        VPIF num  : 0x00000003
        Tunnel type: l2l
        Protocol   : esp
        Lifetime   : 240 seconds
    IPSEC: New embryonic SA created @ 0xcdc76048,
        SCB: 0xCDB97B98,
        Direction: outbound
        SPI      : 0xB4E5EBD5
        Session ID: 0x00006000
        VPIF num  : 0x00000003
        Tunnel type: l2l
        Protocol   : esp
        Lifetime   : 240 seconds
    IPSEC: Completed host OBSA update, SPI 0xB4E5EBD5
    IPSEC: Creating outbound VPN context, SPI 0xB4E5EBD5
        Flags: 0x00000005
        SA   : 0xcdc76048
        SPI  : 0xB4E5EBD5
        MTU  : 1492 bytes
        VCID : 0x00000000
        Peer : 0x00000000
        SCB  : 0x3653C7F5
        Channel: 0xc8c234e0
    IPSEC: Completed outbound VPN context, SPI 0xB4E5EBD5
        VPN handle: 0x0003820c
    IPSEC: New outbound encrypt rule, SPI 0xB4E5EBD5
        Src addr: 192.168.1.0
        Src mask: 255.255.255.0
        Dst addr: 192.168.30.0
        Dst mask: 255.255.255.0
        Src ports
          Upper: 0
          Lower: 0
          Op   : ignore
        Dst ports
          Upper: 0
          Lower: 0
          Op   : ignore
        Protocol: 0
        Use protocol: false
        SPI: 0x00000000
        Use SPI: false
    IPSEC: Completed outbound encrypt rule, SPI 0xB4E5EBD5
        Rule ID: 0xca9505d8
    IPSEC: New outbound permit rule, SPI 0xB4E5EBD5
        Src addr: 88.222.222.38
        Src mask: 255.255.255.255
        Dst addr: 80.111.111.156
        Dst mask: 255.255.255.255
        Src ports
          Upper: 0
          Lower: 0
          Op   : ignore
        Dst ports
          Upper: 0
          Lower: 0
          Op   : ignore
        Protocol: 50
        Use protocol: true
        SPI: 0xB4E5EBD5
        Use SPI: true
    IPSEC: Completed outbound permit rule, SPI 0xB4E5EBD5
        Rule ID: 0xcdc482c8
    IPSEC: New embryonic SA created @ 0xcdbaeff8,
        SCB: 0xCDC33C70,
        Direction: inbound
        SPI      : 0x6699A5F8
        Session ID: 0x00006000
        VPIF num  : 0x00000003
        Tunnel type: l2l
        Protocol   : esp
        Lifetime   : 240 seconds
    IPSEC: Completed host IBSA update, SPI 0x6699A5F8
    IPSEC: Creating inbound VPN context, SPI 0x6699A5F8
        Flags: 0x00000006
        SA   : 0xcdbaeff8
        SPI  : 0x6699A5F8
        MTU  : 0 bytes
        VCID : 0x00000000
        Peer : 0x0003820C
        SCB  : 0x363F2BE7
        Channel: 0xc8c234e0
    IPSEC: Completed inbound VPN context, SPI 0x6699A5F8
        VPN handle: 0x00040e4c
    IPSEC: Updating outbound VPN context 0x0003820C, SPI 0xB4E5EBD5
        Flags: 0x00000005
        SA   : 0xcdc76048
        SPI  : 0xB4E5EBD5
        MTU  : 1492 bytes
        VCID : 0x00000000
        Peer : 0x00040E4C
        SCB  : 0x3653C7F5
        Channel: 0xc8c234e0
    IPSEC: Completed outbound VPN context, SPI 0xB4E5EBD5
        VPN handle: 0x0003820c
    IPSEC: Completed outbound inner rule, SPI 0xB4E5EBD5
        Rule ID: 0xca9505d8
    IPSEC: Completed outbound outer SPD rule, SPI 0xB4E5EBD5
        Rule ID: 0xcdc482c8
    IPSEC: New inbound tunnel flow rule, SPI 0x6699A5F8
        Src addr: 192.168.30.0
        Src mask: 255.255.255.0
        Dst addr: 192.168.1.0
        Dst mask: 255.255.255.0
        Src ports
          Upper: 0
          Lower: 0
          Op   : ignore
        Dst ports
          Upper: 0
          Lower: 0
          Op   : ignore
        Protocol: 0
        Use protocol: false
        SPI: 0x00000000
        Use SPI: false
    IPSEC: Completed inbound tunnel flow rule, SPI 0x6699A5F8
        Rule ID: 0xcdc35348
    IPSEC: New inbound decrypt rule, SPI 0x6699A5F8
        Src addr: 80.111.111.156
        Src mask: 255.255.255.255
        Dst addr: 88.222.222.38
        Dst mask: 255.255.255.255
        Src ports
          Upper: 0
          Lower: 0
          Op   : ignore
        Dst ports
          Upper: 0
          Lower: 0
          Op   : ignore
        Protocol: 50
        Use protocol: true
        SPI: 0x6699A5F8
        Use SPI: true
    IPSEC: Completed inbound decrypt rule, SPI 0x6699A5F8
        Rule ID: 0xc96f7cc8
    IPSEC: New inbound permit rule, SPI 0x6699A5F8
        Src addr: 80.111.111.156
        Src mask: 255.255.255.255
        Dst addr: 88.222.222.38
        Dst mask: 255.255.255.255
        Src ports
          Upper: 0
          Lower: 0
          Op   : ignore
        Dst ports
          Upper: 0
          Lower: 0
          Op   : ignore
        Protocol: 50
        Use protocol: true
        SPI: 0x6699A5F8
        Use SPI: true
    IPSEC: Completed inbound permit rule, SPI 0x6699A5F8
        Rule ID: 0xc96f6388

Maybe you are looking for

  • Formatting using JFormattedTextField

    Hi everyone , I'm trying to create a JFormattedTextField wich accepts only number and have a limited size and if the user didn't fill all field, I want this fields stillValid.. JFormattedTextField fmtNumer = new JFormattedTextField(new MaskFormatter(

  • How can I use the update operation in a VC Model

    Hello experts, i try to to use the update operation in my VC model.  I have developed an AS wich return a table. Now i want to update a table row. So I add the update operation to my model. But it doesn´t work. I mapped all attribute between the tabl

  • Last Transaction Date Report

    hi I'm trying to run a report in order to audit our database of suppliers (over 1000) (supplier records managed in symmetry) I need to see against every supplier the last date that we paid them so that I can identify the ones not used in the last 2yr

  • "unable to find driver for this platform" at random restart? please help!

    i cant get past this screen, right after the screen turns grey and i see the apple logo..... tried resetting NV ram, tried holding option and booting from my startup disk, tried starting from the installation cd, running disk utility and repairing pe

  • How can I install ADF runtime in Linux 6.3

    When I was installing the ADF runtime 11.1.1.6 in Oracle Linux 6.3. I got error at prerequisite check step due to the version of linux. I could still continue to install, but I am not sure if there will be any problem or not. How can I make the prere