Understanding static ip route command

Hi all,
this is not a technical problem, I am just trying to understand how the static ip routes in the form:
ip route vrf my_vrf 10.10.10.0 255.255.255.0 Te1/8/16
will work.
According to the CISCO documentation, the network 10.10.10.0/24 will be considered as a directly
connected network, right? This sounds to me thet the router || layer 3 switch would send ARP "who-has"
every time a packet should be delivered to some destination within 10.10.10.0/24 network.
But if the interface Te1/8/16 has just a point-to-point connection to his peer and both even belong to some
different network, say 192.168.1.0/30, who is going to answer the ARP request? Do we need to have
an ARP proxy or.. is it going to work at all? (I have seen such configurations only in books not in real world)
Unfortunately I do not have a test environment where i could just try this configuration,
so your explanations || pointing to the right documentation will be highly appreciated!
Thanks & regards,
Yury Pakhomenko

Hello Mahesh,
You can use IP address as long as Tunnel IP addresses on both sides are in the same subnet. So in your case you can use
ip route 101.101.101.101 255.255.255 13.13.13.3
Or you can use the tunnel interface
ip route 101.101.101.101 255.255.255 Tunnel0
Although I have seen issues in some cases when the interface name is used instead of tunnel IP.
Please rate this post if helpful.
THanks
Shaml

Similar Messages

  • UNABLE TO INJECT A STATIC DEFAULT ROUTE FROM PE????

    UNABLE TO INJECT A STATIC DEFAULT ROUTE FROM PE????
    Description:
    I am unable to get a static default route via MPBGP session for a vrf, any other route redistributed the same way is getting through.
    Just the static default route isn't ????
    1>
    SOURCE PE WHERE IS THE ROUTE REDISTRIBUTED:
    pe1#
    router bgp 4755
    bgp router-id 10.10.10.103
    no bgp default ipv4-unicast
    bgp log-neighbor-changes
    neighbor 10.10.10.100 remote-as 4755
    neighbor 10.10.10.100 update-source Loopback0
    address-family vpnv4
    neighbor 10.10.10.100 activate
    neighbor 10.10.10.100 send-community extended
    exit-address-family
    address-family ipv4 vrf B
    redistribute static <<<<<<<<<<<<<< STATIC REDIS
    no auto-summary
    no synchronization
    exit-address-family
    address-family ipv4 vrf A
    redistribute static <<<<<<<<<<<<<< STATIC REDIS
    no auto-summary
    no synchronization
    exit-address-family
    ip classless
    ip route vrf A 0.0.0.0 0.0.0.0 Serial1/0 192.168.1.2 global <<<< STATIC ROUTE POINTING THE GLOBAL CONTEXT INTERFACE
    ip route vrf B 0.0.0.0 0.0.0.0 Serial1/0 192.168.1.2 global <<<< STATIC ROUTE POINTING THE GLOBAL CONTEXT INTERFACE
    DESTINATION PE HERE I CANNOT SEE THE STATIC DEFAULT ROUTE:
    pe3(config-router-af)#do sh ip bgp vpnv4 all
    BGP table version is 11, local router ID is 10.10.10.103
    Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
    r RIB-failure, S Stale
    Origin codes: i - IGP, e - EGP, ? - incomplete
    Network Next Hop Metric LocPrf Weight Path
    Route Distinguisher: 4755:1 (default for vrf A)
    *>i172.16.1.0/30 10.10.10.101 0 100 0 ?
    *>i172.16.2.0/30 10.10.10.102 0 100 0 ?
    *>i172.16.10.0/24 10.10.10.101 2297856 100 0 ?
    *>i172.16.20.0/24 10.10.10.102 2297856 100 0 ?
    *>i172.16.200.0/24 10.10.10.102 2170112 100 0 ?
    Route Distinguisher: 4755:2 (default for vrf B)
    *>i172.16.1.0/30 10.10.10.101 0 100 0 ?
    *>i172.16.2.0/30 10.10.10.102 0 100 0 ?
    *>i172.16.10.0/24 10.10.10.101 2297856 100 0 ?
    *>i172.16.20.0/24 10.10.10.102 2297856 100 0 ?
    *>i172.16.200.0/24 10.10.10.102 2170112 100 0 ?
    THE STAITC ROUTE IS REDISTRIBUTED TO LOCAL VRF CONTXT ASWELL AS WE CAN SEE:
    pe3(config-router-af)#do sh ip route vrf A
    Routing Table: A
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
    ia - IS-IS inter area, * - candidate default, U - per-user static route
    o - ODR, P - periodic downloaded static route
    Gateway of last resort is 192.168.1.2 to network 0.0.0.0
    172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
    B 172.16.200.0/24 [200/2170112] via 10.10.10.102, 00:00:23
    B 172.16.20.0/24 [200/2297856] via 10.10.10.102, 00:00:23
    B 172.16.10.0/24 [200/2297856] via 10.10.10.101, 00:00:23
    B 172.16.1.0/30 [200/0] via 10.10.10.101, 00:00:23
    B 172.16.2.0/30 [200/0] via 10.10.10.102, 00:00:23
    S* 0.0.0.0/0 [1/0] via 192.168.1.2, Serial1/0
    Hope I am clear in explaining the issue...
    Thanks,
    Dara

    Hehehe :)
    "Unfortunately" that's true !!!!
    This could have been the last thing that I try.
    Getting he techs work, protocols work is fine.
    But if get to make myself understand the logic behind adding this command as well than ... :(
    Thanks a lot,

  • Metrics when redistributing a static default route into EIGRP?

    I saw a network working with EIGRP and resdistributing a static default route into it. I did not find the "default metrics" to redistribute into EIGRP but the static default route works and is redistributed. My understanding was that everytime you redistribute into EIGRP you needed to specify the metrics. How come this network is working? Can someone explain or point to a cisco document what explains it?
    Sample of the config:
    router eigrp 1
    redistribute static
    no autosummary
    network Y.Y.Y.Y
    ip route 0.0.0.0 0.0.0.0 X.X.X.X
    Thank you,

    It's just one of those specific things about EIGRP and IOS, maybe a design choice. If they do use the interface as the seed metric then that would help explain why it's that way.
    Weirdly if you are using EIGRP VRF address family configuration on IOS and you redistribute statics you do need a metric.
    And I believe NXOS running on Nexus switches also needs a metric defined.
    Just one of those things you have to remember but it would be good if it was consistent.
    Jon

  • Add static ip route in CUCM 6.X

    Hi,
    does anyone know the command to add a static ip route in CUCM 6.x...is it even supported?
    Thanks
    Mattias

    Hi Anjali,
    Unfortunately no. The OS for CallManager is pretty much locked down. There are only a couple of commands that can be run from the OS level. Here is the CLI guide for the latest version of CallManager outlining what commands are available.
    I am guessing if you have a specific need to route traffic, you probably will have to use route maps on the layer 3 switch.

  • The command line 'route' command is broken - what alternatives are there?

    The 'route' command appears to be broken in Mavericks ( now also in 10.9.4 ). It does update that tables, so netstat -r makes it seem that it has worked. However, browsers, pings and trace routes all give errors such as 'out of memory'.
    So, what can I do to set up working alternatives to the standard routing?
    There certainly is some routing capability, and the ability to change it - if you use the OS/X server and set up a VPN, you can set up routing there. So it should be possible to access it through the command line somehow.
    Any suggestions gratefully received.
    I really thought that this would be easy, but it's turned into quite a headache.

    This isn't a great fix but it's helped us out. We created an autoit script to edit the firefox.js file found in program files\mozilla firefox\default\pref. It searches for the line "pref("app.update.auto", true);" and changes it to "pref("app.update.auto", false);". It's a pain but it's the best we could come up with.
    Note: We updated to 3.6.14 and even with the setting above FF still did an auto update to 3.6.15.

  • How do I inject a static default route into vrf

    Could anybody give me any advise on injecting a static default route into vrf.
    The static route is to the internet, I can't enable vrf forwading on the fa interface as other users also use this internet connection.
    I am configuring a 7206 VXR 12.3(26) and have attached a copy of the config
    Any help gratefully received

    Hi
    I think you have to specify the route as this
    ip route vrf delegate_wireless fa0/0 0.0.0.0 0.0.0.0 194.154.168.1 global
    it tells the router to to use a next hop that is not part of the vrf.
    Also, don't forget that the return traffic has to be routed out to the vrf.
    Something like this.
    ip route a.b.c.d tu1 10.252.254.2
    /Mikael

  • "ip routing" command on SG300 switch

    What does "ip routing" do on the CLI on the SG300?
    When I do this, I see it enables ip forwarding, but there is no mention of this in the CLI manual.  I'm just trying to figure out what I would use this for, and if I should leave it enabled, or disable it.
    I have several different SG300 switches in L3 mode, and they are set up in a multi-vlan environment...
    Thanks,
    scott

    Ah, ok, thanks. I guess that was pretty obvious, now that I know the answer.
    The "ip routing" command isn't mentioned anywhere in the CLI documentation, but I guess if I'd thought about it a little longer, I may have come to the same conclusion.
    Thanks Tom. 

  • Trouble understanding static objects

    Hello,
    I have trouble understanding static objects.
    1)
    class TestA
    public static HashMap h = new HashMap();
    So if I add to TestA.h from within a Servlet, this is not a good idea, right?
    But if I just read from it, that is ok, right?
    2)
    class TestB
    public static SimpleDateFormat df = new SimpleDateFormat();
    What about TestB.df from within a Servlet? Is this ok?
    example: TestB.df.format(new Date(1980, 1, 20));

    There is exactly one instance of a static member for every instance of a class. It is okay to use static members in a servlet if they are final, or will not change. If they may change, it is a bad idea. Every call to a servlet launches a new thread. When there are multiple calls, there are multiple threads. If each of these threads are trying to make changes to the static memeber, or use the static memeber while changes are being made, the servelt could give incorrect results.
    I hope that helped..
    Thanks
    Cardwell

  • Distributed multicast routing command not working on Catalyst 3850 switch

    Hi Cisco community,
    I was wondering if there is a known problem as to why the ip multicast-routing [distributed] option is not available on the Cat 3850 platforms
    global command " ip multicast-routing " is accepted 
    the configuration guide named:
    IP Multicast Routing Configuration Guide, Cisco IOS XE Release 3SE (Catalyst 3850 Switches)
    First Published: January 29, 2013
    Last Modified: October 22, 2013
    explains that this option "key word" [distributed]  should be available>
    Enables IP multicast routing.
    ip multicast-routing [distributed] 
    Device(config)# ip multicast-routing distributed
    =============== Here is what i have and see =========
    Config attempt
    ============
    CAT-3850-1(config)#ip multicast-routing distributed
                                                ^
    Show command:
    ========
    CAT-3850-1#show ip multicast 
      Multicast Routing: enabled
      Multicast Multipath: disabled
      Multicast Route limit: No limit
      Multicast Fallback group mode: Sparse
      Number of multicast boundaries configured with filter-autorp option: 0
    Software:
    ========
    Cisco IOS Software, IOS-XE Software, Catalyst L3 Switch Software (CAT3K_CAA-UNIVERSALK9-M), 
    Version 03.03.03SE RELEASE SOFTWARE (fc2)
    License rights:
    ============
    CAT-3850-1#sh license right-to-use 
     Slot#  License name   Type     Count   Period left 
     1      ipservices   permanent     N/A   Lifetime
     1      apcount      adder         10     Lifetime
    License Level on Reboot: ipservices
     Slot#  License name   Type     Count   Period left 
     2      ipservices   permanent     N/A   Lifetime
     2      apcount      adder         10     Lifetime
    License Level on Reboot: ipservices
    Any hints and help would be greately appreciated.
    Many thanks in advance
    Markus 

    Hi Reza,
    Thank you for your quick reply, and for putting the record staright. As such, a helpful rating was provided
    PS: Feel free to help me one more time if you happend to know folllow on this query :)>
    I guess that the disributed function has been included in the standard mulitcast routing command because the key word is no longer needed. Or perhaps this platform does not support this at all.#
    Once again , thank you for your help above.
    Best regards

  • Obtaining DNS servers automatically on Cisco ADSL routers;" not static dns with command dns-server x.x.x.x" ?

    Obtaining DNS servers automatically on Cisco ADSL routers;" not static dns with command dns-server x.x.x.x" ?

    Ok Thank you Karsten

  • No 'ip routing' command on switch and yet intervlan routing.

    Hi,
    In my companies 4500 switch I see there is intervlan routing configured for the 4 Vlans it has but I do not see any 'ip routing' command on it
    to enable routing on the switch. Can a switch route even though the command isnt there?

    Ran the 'show run all' command and it was there. Thought '
    sh run | i ip' would display it but didn't.
    Thanks for the command.
    We just turned enterprise. I keep forgetting that.

  • Lync 2013 - EDGE (do you need static persistent routes - yes or no?)

    Hi there.
    Two edge servers in one edge pool.
    Every edge server has 1 LAN IP, and three DMZ ips. There's only a gateway on DMZ nic.
    Do you need to put static persistent routes or not?
    bostjanc

    No, nothing like that.  The routes would only be needed so the server knows how to get to additional subnets that it's not connected to.  Since your default route is the Internet, the entire Internet is already covered.  All you need is additional
    internal subnets now.
    For example, if you have another internal network that user's live on in a separate office with the IP
    192.168.128.0 and the way for your server to get to it is to send packets to the router at 192.168.2.1 you'd want to add:
    route add -p 192.168.128.0 mask 255.255.255.0 192.168.2.1
    But you'd only add subnets you're not directly connected to and should be reached via the Internal NIC (not the External NIC which is covered by the default gateway).
    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer".
    SWC Unified Communications
    This forum post is based upon my personal experience and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

  • Need help with understanding static vs dhcp on wrt54g router

    I currently have a NAS200 device attached to my WRT54G router. The WRT54G is in DHCP mode so as to allow my various laptops and cameras to be accessed over the internet. What happens is that when I have a power failure the NAS200 is given a new ip address even though its plugged into a service port. I am then forced to go into the router and change the port mapping to whatever port the router has given to the NAS. Is there any way to keep the NAS200 at a specific ip address regardless of router resets. Thanks Hexmate

    You have to set the static IP address on the NAS. The NAS is currently configured to use DHCP. Change it there to set a specific static IP address. The router itself does not have to option to set a fixed IP address to a specific device via DHCP.
    For static IP addresses make sure to choose an IP address which is not used by any other device nor is inside the DHCP server address pool of the router. With default configuration a Linksys router uses 192.168.1.1 and the DHCP server uses 192.168.1.100-149, thus you have addresses 192.168.1.2-99 and 150-254 available.
    Use an static IP address like 192.168.1.50, netmask 255.255.255.0, gateway 192.168.1.1 (if the NAS needs internet, e.g. for time synchronization) and DNS 192.168.1.1. That should do it. Again: this has to be done on the NAS device. The router has no option for that.

  • Static ARP entry command no worky with vlan

    Anyone know why this happens? I'm trying to enter a static arp entry and assign it to a specific vlan, for example:
    arp 192.168.200.1 aaaa.bbbb.cccc arpa vlan 15
                        % Invalid input detected at '^' marker
    When this is entered it errors out and marks the word vlan like it is invalid, though it is a valid option when inching forward using the ? help character. I tried multiple iterations and the only other response I get is if I enter vlan 1. To that the router responds with:
    Bad ARP command - Interface may only be specified when bridging IP
    Is one to assume that the vlan need not be specified? I opted to enter the vlan only for uniformity, but then when it behaved strangely I became curious. I wonder in what scenario adding the vlan to an arp entry would be valid and acceptable.
    Thanks, Mike

    Hello,
    What you experienced is the normal behavior. The L3 device does not allow
    you to specify the interface when you are operating in routed mode. Based on
    the address you have configured, it will automatically allocate the static
    ARP entry to appropriate interface. If you have entered an IP that does not
    belong to any subnet, then all interfaces will consider that ARP entry. Only
    if you configure two interfaces in bridge mode (like in the case of PPPoE
    scenarios), then you can specify the interface ID.
    Hope this helps.
    Regards,
    NT

  • Trying to understand Static methods

    Hi all,
    I am trying to learn a little bit about static methods and hope that someone here can help me understand it better. My understanding of static methods is that they exist only once (More like global methods). This tells me that usage of static methods should be used with care as they are likely to cause problems in cases where multiple users try to access a static object at the same time.
    I am looking at a piece of code that had me thinking for a bit. I cant post the code itself but here is an example of how the code is structured
    The first class declares a couple of non static arrays and makes them available via the getters and setters. It also has one method that calls a static method in another class.
    package com.tests.statictest;
    import java.util.ArrayList;
    public class ClassA{
         ArrayList arrayList1 = new ArrayList();
         ArrayList arrayList2 = new ArrayList();
         public ClassA(){
              arrayList1.add("TEST1");
              arrayList1.add("TEST2");
              arrayList2.add("Test3");
              arrayList2.add("Test4");
         ArrayList getArrayList1(){
              return arrayList1;
         ArrayList getArrayList2(){
              return arrayList2;
         ArrayList getJoinedArrayList(){
              return ClassB.joinArrays(arrayList1,arrayList2);
    }The second class contains the static method that is called by the above class to join the two arrays. This class is used by many other classes
    package com.tests.statictest;
    import java.util.ArrayList;
    public class ClassB{
         public static ArrayList joinArrays(ArrayList list1, ArrayList list2){
              ArrayList list3 = new ArrayList();
              list1.addAll(list2);
              return list1;
    }And here is my test class
    package com.tests.statictest;
    public class ClassC{
          public static void main(String args[]){
               ClassA classA = new ClassA();
              System.out.println(classA.getArrayList1());
              System.out.println(classA.getArrayList2());
              System.out.println(classA.getJoinedArrayList());
         }The output to the above program is shown below
    [TEST1, TEST2]
    [Test3, Test4]
    [TEST1, TEST2, Test3, Test4]My question for the above is that i am wondering if the above is safe. Can you think of situations where the above is not recommended. What exactly would happen if ten instances of ClassA threads are executed at the same time? Woulnt the static method in ClassB corrupt the data?

    ziggy wrote:
    Hi all,
    I am trying to learn a little bit about static methods and hope that someone here can help me understand it better. My understanding of static methods is that they exist only once (More like global methods). This tells me that usage of static methods should be used with care as they are likely to cause problems in cases where multiple users try to access a static object at the same time. There is no such thing as a "static object" in Java. The word "static" simply means "belonging to a class as a whole, rather than an individual instance."
    My question for the above is that i am wondering if the above is safe. Can you think of situations where the above is not recommended. What exactly would happen if ten instances of ClassA threads are executed at the same time?ClassA isn't a thread, so it can't be "executed", per se.
    Woulnt the static method in ClassB corrupt the data?"Staticness" doesn't have anything to do with it; the issue at hand is operations on a shared data structure, which is a concern whether you're dealing with static or non-static members. There is nothing inherent in ClassB that will "corrupt" anything, however.
    ~

Maybe you are looking for

  • Pop up text boxes on mouseovers

    I'm looking for an easy way (and the easiest tool to use between Dreamweaver, Fireworks, and Flash [and I'm guessing 'Fireworks']...or maybe Flash---I have Studio MX2004) to create not a 'pop-menu', but 'a Pop-Up TEXT box' on a mouseover event. For e

  • I see a copy--how do I locate the original?

    I see a copy in an album--how do I find the original?

  • To customize IE status bar?

    Hi, How can i add my text to IE status bar?

  • ABAP Queries - Recommended or not?

    Hello, Are ABAP queries still recommended by SAP on ECC 6.0 release? Some suggetions in our project is that ABAP queries should not be used anymore and must be deleted from the system, as they are not recommended by SAP anymore. Therefore the doubt.

  • Modify segment from Profit center

    Hi experts: I see that after assigning a segment to a profit center, the field become display only and it is not possible to change. How is usually the segment modified? Thanks in advance for your help. Best regards   Jose