Unexpected case IPv4 tunnel over IPv6 ?

hi,
I wonder if there is one use case one can think of that is not possible with Cisco IOS:
Establish a IPsec tunnel over an IPv6 network tranporting both IPv4 and Ipv6 traffic. Even IPsec tunnel over an IPv6 network transporting IPv4 only does not work.
I tried several things in my lab but couldn't get it running.
I tried to search the net for my use case but I only find the other way round.
Question: is it possible to achieve connectivity of the following IPv4 addresses over an IIPsec tunnel over Ipv6 network?
Ultimately, the same tunnel should be capable transporting both. A dedicated Tunnel for IPv4 and IPv6 tunnel on the same routers would also be OK.
     Svr A                (  )                Svr B
    +----+             , `,( .)              +----+
    |    |   +----+   ( .(  ...)    +----+   |    |
    |    |---| R1 |---`    .....)---| R2 |---|    |
    |    |   +----+    ( ......)    +----+   |    |
    +----+                                   +----+
10.0.23.1/24          IPv6 only          10.0.42.1/24
                        network

Same/similar question but the case is instead of Site to Site VPN, it would be using the Cisco VPN Client.  The host on the left side is connected to an IPv6-only network.  They need to communicate with IPv4 devices across the Internet (behind a Cisco ASA).
Is this possible?
Cisco VPN Client         (  )                Cisco ASA    +----+             , `,( .)              +----+    |    |   +----+   ( .(  ...)    +----+   |    |    |    |---| R1 |---`    .....)---| R2 |---|    |----IPv4 network    |    |   +----+    ( ......)    +----+   |    |    +----+                                   +----+IPv6-only HOST        IPv6 Network         has IPv6 Interface on public side
alexander.koeppe wrote:hi,I wonder if there is one use case one can think of that is not possible with Cisco IOS:Establish a IPsec tunnel over an IPv6 network tranporting both IPv4 and Ipv6 traffic. Even IPsec tunnel over an IPv6 network transporting IPv4 only does not work.I tried several things in my lab but couldn't get it running.I tried to search the net for my use case but I only find the other way round.Question: is it possible to achieve connectivity of the following IPv4 addresses over an IIPsec tunnel over Ipv6 network?Ultimately, the same tunnel should be capable transporting both. A dedicated Tunnel for IPv4 and IPv6 tunnel on the same routers would also be OK.                           ,_     Svr A                (  )                Svr B     +----+             , `,( .)              +----+    |    |   +----+   ( .(  ...)    +----+   |    |     |    |---| R1 |---`    .....)---| R2 |---|    |     |    |   +----+    ( ......)    +----+   |    |     +----+                                   +----+ 10.0.23.1/24          IPv6 only          10.0.42.1/24                        network

Similar Messages

  • IPv4 DMVPN over IPv6 WAN - Configuration

    Hello everyone,
    I'm struggeling to get a DMVPN to work over an IPv6 WAN Network.
    I have testet IPv6 connectivity from the Spoke (2001:2:2:2::1/64) to the Hub (2001:1:1:1::1/64) which is successful, there is also an IPv6 default route to my "ISP", I also have an crypto isakmp key for IPv6 addresses and my Tunnel Configuration looks like this:
    Did anyone configure a scenario like this and could point me in the right direction ? :-)
    Thanks in advance
    Greetings,
    Thomas
    ### HUB Configuration ###
    interface Tunnel1
    description ** DMVPN Intranet **
    bandwidth 1000
    ip vrf forwarding VPN
    ip address 10.0.10.1 255.255.255.0
    no ip redirects
    ip mtu 1416
    no ip next-hop-self eigrp 65351
    no ip split-horizon eigrp 65351
    ip pim sparse-mode
    ip nhrp map multicast dynamic
    ip nhrp network-id 1
    ip nhrp holdtime 360
    ip nhrp shortcut
    ip nhrp redirect
    ip tcp adjust-mss 1360
    load-interval 30
    ipv6 nhrp map multicast dynamic
    ipv6 nhrp network-id 1
    ipv6 nhrp holdtime 360
    ipv6 nhrp shortcut
    ipv6 nhrp redirect
    keepalive 10 3
    tunnel source GigabitEthernet0
    tunnel mode gre multipoint
    tunnel key 1
    tunnel protection ipsec profile My-Profile shared
    ### Spoke Configuration ###
    interface Tunnel1
    description ** DMVPN Intranet **
    ip vrf forwarding VPN
    ip address 10.0.10.2 255.255.255.0
    ip mtu 1416
    ip pim sparse-mode
    ip nhrp map 10.0.10.1 2001:1:1:1::1
    ip nhrp map multicast 2001:1:1:1::1
    ip nhrp network-id 1
    ip nhrp holdtime 360
    ip nhrp nhs 10.0.10.1
    ip nhrp shortcut
    ip tcp adjust-mss 1360
    delay 1000
    tunnel source GigabitEthernet0
    tunnel mode gre multipoint
    tunnel key 1
    tunnel protection ipsec profile My-Profile shared

    Hi,
    I got a solution for this.
    My configuration is as follows, I missed the keyword "tunnel mode gre multipoint ipv6"
    ### Hub ###
    interface Tunnel1
    description ** DMVPN Intranet **
    bandwidth 1000
    ip vrf forwarding VPN
    ip address 10.0.10.1 255.255.255.0
    ip mtu 1416
    no ip next-hop-self eigrp 65351
    no ip split-horizon eigrp 65351
    ip pim sparse-mode
    ip nhrp map multicast dynamic
    ip nhrp network-id 1
    ip nhrp holdtime 360
    ip nhrp shortcut
    ip nhrp redirect
    ip tcp adjust-mss 1360
    load-interval 30
    keepalive 10 3
    tunnel source GigabitEthernet0
    tunnel mode gre multipoint ipv6
    tunnel key 1
    tunnel protection ipsec profile My-Profile shared
    ### Spoke ###
    interface Tunnel1
    description ** DMVPN Intranet **
    ip vrf forwarding VPN
    ip address 10.0.10.2 255.255.255.0
    ip mtu 1416
    ip pim sparse-mode
    ip nhrp map 10.0.10.1 2001:1:1:1::1
    ip nhrp map multicast 2001:1:1:1::1
    ip nhrp network-id 1
    ip nhrp holdtime 360
    ip nhrp nhs 10.0.10.1
    ip nhrp shortcut
    ip tcp adjust-mss 1360
    delay 1000
    tunnel source GigabitEthernet0
    tunnel mode gre multipoint ipv6
    tunnel key 1
    tunnel protection ipsec profile My-Profile shared
    end
    Greetings
    Thomas

  • IPv4 LAN over IPv6 WAN

    With IPv6 I am most concerned today with receiving an IPv6 address from my ISP for my Spoke networks.  I don't have plans to convert my Spoke LANs  or Internal application servers to IPV6 anytime soon.  Reviewing all the books and technical documentation out there, I don't see discussion about how to get my IPv4 traffic tunneled through the Internet via an IPv6 carrier, a 4to6 tunnel.  Currently I'm running DMVPN which appears to support IPv6 tunnels, Native and 6to4.  Can anyone provide direction or expertise on how to get IPv4 traffic between Enterprise locations with ISPs move to IPv6 addressing?
    Thanks..

    Ryan,
    If this is a question of connecting LAN in different branches.
    The decently scalable option is GRE (with DMVPN being the neatest).
    On top ASA supports IPv4 in IPv6 IPsec (to other ASAs at this point).
    You might have a bit more challanges if you want to provide access to non-intrernal resources, Internet, partner sites without IPv4 on WANs.
    M.

  • Tcp mss adjust calculation for GRE tunnel over DSL line

    hi guys,
    need your advice on this one, as i search on cisco.com and netpro but unable to find the exact info that i required.
    First, can anyone confirm the following calculation to find out MSS size.
    Mss size = MTU size - encapsulation size - tcp header size
    So for normal case;
    MSS = 1500 - 48 (48 is the tcp/ip header)
    so MSS = 1452
    Thus in my case GRE tunnel over DSL connection;
    MSS = 1492 - 24 - 48 (24 is the GRE encap; 48 is the tcp/ip header)
    MSS = 1420
    is this correct?
    Secondly, where should the ip tcp mss-adjust to be implemented. Is it at the Dialer(DSL) interface or at Tunnel interface?

    I don't use the math (it doesn't work for me probably b/c I miss something). Here's how I do it-
    C:\>ping 10.125.0.250 -f -l 1600
    Pinging 10.125.0.250 with 1600 bytes of data:
    Packet needs to be fragmented but DF set.
    Packet needs to be fragmented but DF set.
    Packet needs to be fragmented but DF set.
    Packet needs to be fragmented but DF set.
    Ping statistics for 10.125.0.250:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
    C:\>ping 10.125.0.250 -f -l 1500
    Pinging 10.125.0.250 with 1500 bytes of data:
    Packet needs to be fragmented but DF set.
    Packet needs to be fragmented but DF set.
    Packet needs to be fragmented but DF set.
    Packet needs to be fragmented but DF set.
    Ping statistics for 10.125.0.250:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
    C:\>ping 10.125.0.250 -f -l 1400
    Pinging 10.125.0.250 with 1400 bytes of data:
    Reply from 10.125.0.250: bytes=1400 time=19ms TTL=251
    Reply from 10.125.0.250: bytes=1400 time=19ms TTL=251
    Reply from 10.125.0.250: bytes=1400 time=19ms TTL=251
    Reply from 10.125.0.250: bytes=1400 time=19ms TTL=251
    Ping statistics for 10.125.0.250:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 19ms, Maximum = 19ms, Average = 19ms
    C:\>ping 10.125.0.250 -f -l 1450
    Pinging 10.125.0.250 with 1450 bytes of data:
    Reply from 10.125.0.250: bytes=1450 time=19ms TTL=251
    Reply from 10.125.0.250: bytes=1450 time=20ms TTL=251
    Reply from 10.125.0.250: bytes=1450 time=19ms TTL=251
    Reply from 10.125.0.250: bytes=1450 time=19ms TTL=251
    Ping statistics for 10.125.0.250:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 19ms, Maximum = 20ms, Average = 19ms
    C:\>ping 10.125.0.250 -f -l 1475
    Pinging 10.125.0.250 with 1475 bytes of data:
    Packet needs to be fragmented but DF set.
    Packet needs to be fragmented but DF set.
    Packet needs to be fragmented but DF set.
    Packet needs to be fragmented but DF set.
    Ping statistics for 10.125.0.250:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
    C:\>ping 10.125.0.250 -f -l 1470
    Pinging 10.125.0.250 with 1470 bytes of data:
    Reply from 10.125.0.250: bytes=1470 time=19ms TTL=251
    Reply from 10.125.0.250: bytes=1470 time=22ms TTL=251
    Reply from 10.125.0.250: bytes=1470 time=20ms TTL=251
    Reply from 10.125.0.250: bytes=1470 time=19ms TTL=251
    Ping statistics for 10.125.0.250:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 19ms, Maximum = 22ms, Average = 20ms
    C:\>
    1470 works and has a little bit of extra room. The tcp mss-adjust should be done on the LAN interface.
    Hope it helps.

  • IPv6 in IPv4 Tunneling

    Any support for IPv6-in-IPv4 tunneling, e.g. HE, for us whose ISP do not do native IPv6 or 6RD?

    Gabby wrote:
    http://www6.nohold.net/Cisco2/ukp.aspx?pid=93&vw=1&articleid=23904
    All of the Linksys devices currently support only Internet Protocol version 4 (IPv4) addressing.  However, WRT610N and E4200 nominally support the latest Internet Protocol version 6 (IPv6) but these products are NOT yet IPv6 compliant.
    NOTE:  Future firmware releases of Linksys devices will be available to support IPv6.
    This information is OUTDATED.

  • Prefer IPv4 over IPv6

    Hi. I want use ipv4 before ipv6. For 2008 R2 i used fix "Microsoft Fix it 50410"
    But this not support server 2012.
    How i can correct change prefer on 2012?
    Thank you!

    Please, tell me, WHY man, who create IPv6 began use this fe80::6c02:573b:178c:dd8f naming.
    Blame that on the Internet Engineering Task Force (IETF) standards committee that came up with this naming convention back in 1998 (http://tools.ietf.org/html/rfc2460).  <grin> 
    Not sure what you mean by "reliable source with describe 'native IPv6 for 8\12'".  Microsoft has lots of documentation on IPv6 - I think the majority of it came out with Windows Server 2008 because that was the first release with the dual-stack as a
    default.  IpV6 was available for Windows Server 2003, but it was an add-on.  Go to Barnesandnoble.com or amazon.com to find a good reference book on IPv6 if you want to learn more - they are not small books.  It is the way the industry is moving
    because it offers many advantages over IPv4 (which, by the way, has officially run out of addresses which can be handed out).  Microsoft is simply helping customers move into future by providing a dual-stack that can automatically switch back and forth
    between IPv4 applications and IPv6 applications without the end-user even knowing it goes on.  Some things, like Direct Access, would be almost impossible to implement on IPv4, but becomes (relatively) easy when using IPv6.
    tim

  • JDBC connection over IPv6

    Hi
    I have an MS SQL Server 2005 Database Server and a Client computer on two different subnets.
    There is also a DNS Server, which contains both an IPv4 (A) and IPv6 (AAAA) DNS record for the Database Server.
    I've disabled IPv4 routing between the two subnets so that the Database Server is only accessible by IPv6 from the Client computer.
    I am then unable to connect to the Database Server from the Client using JDBC.
    I have tried increasing the loginTimeout in the JDBC connection string, but this doesn't appear to make any difference.
    I get a java.net.ConnectException in about 20 seconds.
    If I remove the IPv4 (A) record of the Database Server from the DNS Server, the JDBC connection then succeeds.
    Does JDBC iterate over all the possible addresses of the Database Server?
    Is the loginTimeout the correct parameter to try to increase, to allow it to iterate over the possible addresses?
    There is a similar problem with MS SQL Client - see http://msdn.microsoft.com/en-us/library/ms378428(SQL.90).aspx
    But increasing the connection timeout allows a successful connection.
    Thanks
    Alain

    jschell wrote:
    ahkal01 wrote:
    Alain: A machine may have multiple IPv6 addresses, as well as an IPv4 address.
    You may not be able to get to the machine via all the addresses, depending on the network route.
    If a driver gives up on the first DNS lookup (which probably will be the IPv4 address), it'll never try the IPv6 addresses. However that is NOT what you are testing.
    As described in your first post there is a route. Routing works if the final location is found. After that a refused connection is a refused connection.
    Alain: In my test, IPv4 routing is disabled between the two subnets. So there is no IPv4 routing between the two machines, only IPv6.
    >
    But even so, to me it is still two different IP addresses. Just as if you try to create your own replication by having two database servers on different IPv4 addresses. If the client is supposed to be using one address then the DNS should be set up that way.
    Or use the address. Because the point is not the IP address, the point is the DNS look up.
    Alain: With IPv6, it is common for computers to be assigned more than one address for routing under different hierarchies.
    If you're saying that the DNS lookup should be set up to return only one IP address to client computers trying to connect to the DB Server, DNS will need to be set up differently depending on where the client computer is.
    >
    Again looking at it from the point of someone developing a driver the only option I would allow is that one might be able to specify a configuration value that says to try a IPv6 address first. That would be in the driver, not JDBC. So you can look to your driver for that.
    There is a similar problem with MS SQL Client - see http://msdn.microsoft.com/en-us/library/ms378428(SQL.90).aspx
    But increasing the connection timeout allows a successful connection.
    I do not see anywhere in that link that it claims that the setup you are using would work Alain: apologies. It was the wrong url link.
    I meant, http://blogs.msdn.com/sql_protocols/archive/2005/10/12/480192.aspx.The scenario there is SQL Server is configured to listen only on IPv6 addresses and disable all IPv4 addresses so that only IPv6 connection can be accepted. The workaround is to specify the IPv6 address of the target machine explicitly to force SNI to use IPv6 connection directly or to use longer timeout value. I don't see that in that blog.
    It says that if you have addresses that some different behavior might result. It specifically refers to using an IPv4 address (not DNS) and failing on that and then attempting to use a IPv6 address (again not a DNS) and even in that case it might fail.
    Alain: The blog is talking about a hostname resolving into multiple addresses. I quote from the blog, with bold for emphasis,
    "In most cases, the connection string does not need to be modified if the <servername> is specified using server hostname or FQDN (Full Qualified Domain Name). If the server machine has dual-stack, *its hostname or FQDN will be resolved into multiple IP addresses*, including at lease one IPv4 address and multiple IPv6 addresses. *And SNI will attempt to establish connections using these IP addresses in order and use the first connection that succeeds*. IPv4 addresses are attempted first if both IPv4 and IPv6 addresses are present. This logic is transparent to the users of ODBC, OLEDB or ADO.NET.
    And it doesn't say anything about that some clients already do this but merely that they can.
    Alain: SNI does, from the quote above. A test also shows that it does try all the addresses that DNS returns, with the caveat that the connection timeout has to be increased.
    Unfortunately it looks like the MS JDBC driver doesn't do likewise.
    Myself I don't really consider that a valid option for most use cases for drivers. If I have a data center then I am not normally going to be using both types of addresses. And if I am both will work. And if there are variation in subnets then I would expect that if DNS is in use then it would be set up to correctly represent that.Thanks for your input on this thread. Much appreciated.

  • Problem about the jmf when working over IPV6

    I write a program about monitoring a RTP stream ,get the feedbacks about the stream by receving the RTCP reports and analysize the paramaters .Now the throny issues encountered is the code working perfect over the IPV4 network .but there are many exceptions when working over IPV6 the exceptions is as follows:
    Exception in thread "RTCP Reporter" java.lang.NullPointerException
    at com.sun.media.rtp.RTCPTransmitter.makereports(RTCPTransmitter.java:200)
    at com.sun.media.rtp.RTCPTransmitter.report(RTCPTransmitter.java:106)
    at com.sun.media.rtp.RTCPReporter.run(RTCPReporter.java:193)
    at java.lang.Thread.run(Thread.java:619)
    the session can be set up and can receive the stream .so I think it is ok of setting up the session with the IPV6 multicast address.strangely , the same particate in the session sends more than one feedbacks with different SSRC which is ought to be single.I cannot figure out.
    I wonder whether there is any special setting when JMF working on the IPV6 network.I did not find materials about the JMF working on IPV6 network in Microsoft xp pc.
    can any guys give me any tips?
    Edited by: judyw115 on Sep 4, 2010 6:08 AM

    judyw115 wrote:
    Is there anyone giving me any advices?You realize this is a free forum and not paid tech support, right?
    Drop the attitude and learn to be patient.

  • Cannot export nfs-share over ipv6 in OS X 10.8

    I've successfully exported my nfs share over ipv4 and can access this with a nfs-client from a linux machine. However, I'm not able to export the same share over ipv6.
    In my /etc/exports I have:
    /Volumes/Harddisk
    -network 10.0.0.0
    -mask 255.255.255.0
    /Volumes/Harddisk
    -network fd60:760d:98ec:8588::/64
    However, from the linux client I can only mount the ipv4 share, but not the ipv6 share.
    Is it possible to export nfs-shares over ipv6 in OS X 10.8?

    I would suggest testing a connection from a second Mac also running 10.8 via IPv6. At least then you know both will be using compatible versions. If that does not work then it would seem to be an IPv6 issue on the Mac server.

  • Do we support RADIUS over IPv6 in ACS 5.5?

    Hi,
    Could you please let me know if we support RADIUS over IPv6?

    It is hard to see the information in your screen shot but ACS 5.4 and later support IPv6 for network devices:
    http://www.cisco.com/c/en/us/td/docs/net_mgmt/cisco_secure_access_control_system/5-4/user/guide/acsuserguide/net_resources.html
    Also, if you type an invalid IP address in ACS you would get the following error:
    A valid IPv4 address consists of four numbers (0-255) separated by periods, e.g. 123.0.255.3
    A valid IPv6 address is n:n:n:n:n:n:n:n where the 'n's are either digits (0-9) or letters (A-F)
    I hope this is what you were looking for!
    Thank you for rating helpful posts!

  • OCR and voting disks on ASM, problems in case of fail-over instances

    Hi everybody
    in case at your site you :
    - have an 11.2 fail-over cluster using Grid Infrastructure (CRS, OCR, voting disks),
    where you have yourself created additional CRS resources to handle single-node db instances,
    their listener, their disks and so on (which are started only on one node at a time,
    can fail from that node and restart to another);
    - have put OCR and voting disks into an ASM diskgroup (as strongly suggested by Oracle);
    then you might have problems (as we had) because you might:
    - reach max number of diskgroups handled by an ASM instance (63 only, above which you get ORA-15068);
    - experiment delays (especially in case of multipath), find fake CRS resources, etc.
    whenever you dismount disks from one node and mount to another;
    So (if both conditions are true) you might be interested in this story,
    then please keep reading on for the boring details.
    One step backward (I'll try to keep it simple).
    Oracle Grid Infrastructure is mainly used by RAC db instances,
    which means that any db you create usually has one instance started on each node,
    and all instances access read / write the same disks from each node.
    So, ASM instance on each node will mount diskgroups in Shared Mode,
    because the same diskgroups are mounted also by other ASM instances on the other nodes.
    ASM instances have a spfile parameter CLUSTER_DATABASE=true (and this parameter implies
    that every diskgroup is mounted in Shared Mode, among other things).
    In this context, it is quite obvious that Oracle strongly recommends to put OCR and voting disks
    inside ASM: this (usually called CRS_DATA) will become diskgroup number 1
    and ASM instances will mount it before CRS starts.
    Then, additional diskgroup will be added by users, for DATA, REDO, FRA etc of each RAC db,
    and will be mounted later when a RAC db instance starts on the specific node.
    In case of fail-over cluster, where instances are not RAC type and there is
    only one instance running (on one of the nodes) at any time for each db, it is different.
    All diskgroups of db instances don't need to be mounted in Shared Mode,
    because they are used by one instance only at a time
    (on the contrary, they should be mounted in Exclusive Mode).
    Yet, if you follow Oracle advice and put OCR and voting inside ASM, then:
    - at installation OUI will start ASM instance on each node with CLUSTER_DATABASE=true;
    - the first diskgroup, which contains OCR and votings, will be mounted Shared Mode;
    - all other diskgroups, used by each db instance, will be mounted Shared Mode, too,
    even if you'll take care that they'll be mounted by one ASM instance at a time.
    At our site, for our three-nodes cluster, this fact has two consequences.
    One conseguence is that we hit ORA-15068 limit (max 63 diskgroups) earlier than expected:
    - none ot the instances on this cluster are Production (only Test, Dev, etc);
    - we planned to have usually 10 instances on each node, each of them with 3 diskgroups (DATA, REDO, FRA),
    so 30 diskgroups each node, for a total of 90 diskgroups (30 instances) on the cluster;
    - in case one node failed, surviving two should get resources of the failing node,
    in the worst case: one node with 60 diskgroups (20 instances), the other one with 30 diskgroups (10 instances)
    - in case two nodes failed, the only node survived should not be able to mount additional diskgroups
    (because of limit of max 63 diskgroup mounted by an ASM instance), so all other would remain unmounted
    and their db instances stopped (they are not Production instances);
    But it didn't worked, since ASM has parameter CLUSTER_DATABASE=true, so you cannot mount 90 diskgroups,
    you can mount 62 globally (once a diskgroup is mounted on one node, it is given a number between 2 and 63,
    and other diskgroups mounted on other nodes cannot reuse that number).
    So as a matter of fact we can mount only 21 diskgroups (about 7 instances) on each node.
    The second conseguence is that, every time our CRS handmade scripts dismount diskgroups
    from one node and mount it to another, there are delays in the range of seconds (especially with multipath).
    Also we found inside CRS log that, whenever we mounted diskgroups (on one node only), then
    behind the scenes were created on the fly additional fake resources
    of type ora*.dg, maybe to accomodate the fact that on other nodes those diskgroups were left unmounted
    (once again, instances are single-node here, and not RAC type).
    That's all.
    Did anyone go into similar problems?
    We opened a SR to Oracle asking about what options do we have here, and we are disappointed by their answer.
    Regards
    Oscar

    Hi Klaas-Jan
    - best practises require that also online redolog files are in a separate diskgroup, in case of ASM logical corruption (we are a little bit paranoid): in case DATA dg gets corrupted, you can restore Full backup plus Archived RedoLog plus Online Redolog (otherwise you will stop at the latest Archived).
    So we have 3 diskgroups for each db instance: DATA, REDO, FRA.
    - in case of fail-over cluster (active-passive), Oracle provide some templates of CRS scripts (in $CRS_HOME/crs/crs/public) that you edit and change at your will, also you might create additionale scripts in case of additional resources you might need (Oracle Agents, backups agent, file systems, monitoring tools, etc)
    About our problem, the only solution is to move OCR and voting disks from ASM and change pfile af all ASM instance (parameter CLUSTER_DATABASE from true to false ).
    Oracle aswers were a litlle bit odd:
    - first they told us to use Grid Standalone (without CRS, OCR, voting at all), but we told them that we needed a Fail-over solution
    - then they told us to use RAC Single Node, which actually has some better features, in csae of planned fail-over it might be able to migreate
    client sessions without causing a reconnect (for SELECTs only, not in case of a running transaction), but we already have a few fail-over cluster, we cannot change them all
    So we plan to move OCR and voting disks into block devices (we think that the other solution, which needs a Shared File System, will take longer).
    Thanks Marko for pointing us to OCFS2 pros / cons.
    We asked Oracle a confirmation that it supported, they said yes but it is discouraged (and also, doesn't work with OUI nor ASMCA).
    Anyway that's the simplest approach, this is a non-Prod cluster, we'll start here and if everthing is fine, after a while we'll do it also on Prod ones.
    - Note 605828.1, paragraph 5, Configuring non-raw multipath devices for Oracle Clusterware 11g (11.1.0, 11.2.0) on RHEL5/OL5
    - Note 428681.1: OCR / Vote disk Maintenance Operations: (ADD/REMOVE/REPLACE/MOVE)
    -"Grid Infrastructure Install on Linux", paragraph 3.1.6, Table 3-2
    Oscar

  • How get IPv4 instead of IPv6 (class NetworkInterface)

    Hello! I've written java code:
    nets = NetworkInterface.getNetworkInterfaces();
    NetworkInterface selInterface = Collections.list(nets).get(curIndex);
    ips = selInterface.getInetAddresses();
    InetAddress addr = Collections.list(ips).get(0);
    String str = addr.getHostAddress();
    And I obtain IPv6, for example: fe80::20c:29ff:fe2d:a225. How can I get IPv4 or transform IPv6?
    p.s. this problem is observed only in Linux, on windows machine program works good.

    Note : IPV4 address and IPV6 address are unrelated (i.e. no conversion from one to another)Note: this is not correct. Some IPv6 address formats are explicitly provided to act as representations of IPv4 addresses.

  • Gre tunnel over 2 mpls routers

    I have 2 sites and the voice server is in site A and Site B are the remote phones . Right now voice vlan go over the DMVPN we are facing some degraded performance and decided to move voice traffic to mpls . 
    We need to carry the multicast traffic as well which is not supported over our MPLS circuit. I have no idea why provider is not supporting multicast traffic over mpls circuit.
    So we decided to create GRE tunnels to carry multicast traffic over MPLS .We have L3 switches on both sites Site A cisco 4500 and Site B cisco 3850  . and MPLS connectivity is reachable upto L3 core switches. With 3850 we had issue to create tunnels and i have upgraded the IOS after upgrading i came to know no more tunnels are supported on 3850. So cannot have Gre tunnel between our L3 switches over the MPLS.
    My Question is can i ask the MPLS provider to setup tunnels on their routers which they are ready to help and point the static routes for voice vlan towards gre tunnels over mpls . 
    Can you advise any other solution or does this solution would work.?

    Aneesh,
    Lost of connectivity between the two PEs would indeed cause the GRE tunnel interface to go down, assuming that you configure tunnel keepalives as follow:
    int tu0
    keepalive
    Regards

  • HDMI over IPv6

    Can HDMI be routed over IP/IPv6, or dare I say it, transported over HTTP? Since HDMI is a digital protocol, this must be possible.
    Is there any known work in progress to get HDMI to be routed over IP/IPv6, or even to get it to be transported over HTTP?
    Do these CE hardware folks even know about the Internet? And why can't they fit PC video cards with real HDMI connectors that can carry HD audio as well? All PC video cards I've seen have S-Video out, or a DVI-HDMI connector, and neither can carry audio.
    With a high-bandwidth Layer 2 technology such as 10Gbps Ethernet or InfiniBand that offers even more bandwidth, the commodity potential of HDMI over IPv6 would be enormous. It can drive a substantial segment of any nation's economy.
    Thanks.

    Well, the reason Apple TV doesn't work well with HDMI switches is probably because Apple is not doing HDMI right. And the fact that Apple TV does not process HD Audio codecs such as DTS-HD Master Audio and Dolby TrueHD supports this theory.
    When Apple provides support for those HD audio codecs in Apple TV, you would get HDMI right.

  • SNA tunnel over GRE tunnel

    Is it possible?.
    Configure SNA tunnel over GRE tunnel

    To my knowledge, no, but it would sure work for me if it was possible. DLSW has always worked like a charm for me to route SNA over an IP network.

Maybe you are looking for

  • Lost inbox messages in mail

    I was revisting my Entourage mailbox after many months of not using it, saw old messages, saw messages from my "mail" mailbox, (but don't remember how I set that up.) When I closed out of Entourage and went back to my "mail" mailbox all the messages

  • LT06 HELP..........

    Sorry for not being clear.....my brain is confused and hurting trying to figure this WM stuff out. I will try again. Ok... I am trying to move 10,000 kg's of material from the UML-ZONE. Each item weighs 200 kg's. I need to get SU#'s for each item sep

  • Breakdown of CPU Time

    Hi, I have make a statspack about our database, and I upload about oraperf website. But I don't understand "Breakdown of CPU Time" Detail : Parse CPU Time 1190 58.42% Recursive CPU Time 1542 75.70% Other CPU Time 18446744073709550921 -34.12% Why The

  • Firefox 19 zeigt Schrift furchtbar an

    Seit dem ich Firefox 19 habe, sehe meine Schriften im Firefox grauenvoll aus. Scrollt man ein wenig hin und her, hat man schnell so ein Bild. http://tinypic.com/view.php?pic=33y4c2c&s=6 Was kann ich dagegen tun?

  • No tool presets defined for current tool ... how can i fix this ?

    no tool presets defined for current tool ... how can i fix this ?