Updating UI from outside SwingWorker-doInBackground() method

Good day!
I've a problem using SwingWorker class. I need to update user interface but not directly from doInBackground() method (a method is called from doInBackground() and this method should be able to update my UI). However, the only method offered by SwingWorker to update UI is publish() and it can't be used outside doInBackground(). Is there a way to solve my problem by using only SwingWorker methods or need I resort to invokeLater()/invokeAndWait() methods?
I'd appreciate any help.

nice day,
for example:
invoke void or class from SwingWorker done() {} method
     *  Change the LAF and recreate the UIManagerDefaults so that the properties
     *  of the new LAF are correctly displayed.
    class ChangeLookAndFeelAction extends AbstractAction {
        private String laf;
        protected ChangeLookAndFeelAction(String laf, String name) {
            this.laf = laf;
            putValue(Action.NAME, name);
            putValue(Action.SHORT_DESCRIPTION, getValue(Action.NAME));
        public void actionPerformed(ActionEvent e) {
            try {
                JMenuItem mi = (JMenuItem) e.getSource();
                JPopupMenu popup = (JPopupMenu) mi.getParent();
                JRootPane rootPane = SwingUtilities.getRootPane(popup.getInvoker());
                Component c = rootPane.getContentPane().getComponent(0);
                rootPane.getContentPane().remove(c);
                UIManager.setLookAndFeel(laf);
                KeyBindings bindings = new KeyBindings();
                rootPane.getContentPane().add(bindings.getContentPane());
                SwingUtilities.updateComponentTreeUI(rootPane);
                rootPane.requestFocusInWindow();
            } catch (Exception ex) {
                System.out.println("Failed loading L&F: " + laf);
                System.out.println(ex);
    }maybe just enough to ... SwingUtilities.updateComponentTreeUI(), packed to the SwingUtilities.invokeLater(Runable run);

Similar Messages

  • How to get the errors thrown during SwingWorkes-doInBackground-method

    Hi,
    I got an annoying problem.
    I use a SwingWorker to do some operations in background...
    Now it could be, that some of those operations throw an exception...
    but the SwingWorker do not throw those...
    The only exception i get is a final Exception cause of an object who
    wants to display the result of the background activity...
    In detail : a method done in background throws an index out of bounds exception
    but how i can get this error?
    I try to surround the swing worker object with a try and catch for general exceptions but
    this don't work.
    regards
    Olek

    There are two things you can do. First, you might wrap the code in doInBackground() in try/catch. I'd discourage this since it will make your code more complicated. Secondly, if an exception occurs, the SwingWorker will switch its state to 'done'. If you invoke the get() method (even if you're returning null in doInBackground()), an ExecutionException will be risen. Using Exception#getCause(), you will get the original exception that occured, in your case the ArrayIndexOutOfBoundsException.

  • Can not insert or update [TABLE] from internal table in method

    I've faced a problem with OO abap. I've tried to insert into [ TABLE ] from internal table, but i've got error msg after i compiled.
    "An explicit work area is necessary in the OO context. Use "INSERT wa INTO [TABLE] itab""
    After  i changed to loop in work area and INSERT INTO  [TABLE] VALUES gw_data., everything is fine, can compile and run.
    This is error code.
      METHOD set_data_to_table.
        REFRESH gi_data.
        CLEAR gi_data.
        IF gi_file[] IS NOT INITIAL.
    * Set data for modify table
          LOOP AT gi_file INTO gw_file.
            MOVE-CORRESPONDING gw_file TO gw_data.
            me->conversion_input( EXPORTING im_vendor = gw_data-vendor
                                  CHANGING  ch_vendor = gw_data-vendor ).
            APPEND gw_data TO gi_data.
          ENDLOOP.
          INSERT [TABLE] FROM TABLE gi_data.
    *      LOOP AT gi_data INTO gw_data.
    *        INSERT INTO  [TABLE] VALUES gw_data.
    *        IF sy-subrc = 0.
    *          COMMIT WORK.
    *        ELSE.
    *          ROLLBACK WORK.
    *        ENDIF.
    *      ENDLOOP.
        ELSE.
          MESSAGE 'No data found' TYPE 'I'.
        ENDIF.
      ENDMETHOD.                    "set_data_to_table

    Hi Matthew,
    I think there is no difference in database insert between OO and non-OO.
    The correct syntax according to ECC600 online documentation is
    [Inserting Several Lines|http://help.sap.com/saphelp_erp2005vp/helpdata/en/fc/eb3a6d358411d1829f0000e829fbfe/content.htm]
    To insert several lines into a database table, use the following:
    INSERT target FROM TABLE itab \[ACCEPTING DUPLICATE KEYS].
    This writes all lines of the internal table itabto the database table in one single operation. If one or more lines cannot be inserted because the database already contains a line with the same primary key, a runtime error occurs. You can prevent the runtime error occurring by using the addition ACCEPTING DUPLICATE KEYS.
    Whenever you want to insert more than one line into a database table, it is more efficient to work with an internal table than to insert the lines one by one.
    I think the syntax
    INSERT my_dbtable FROM TABLE gi_data.
    should work, your suggestion may lead to syntax error.
    Regards,
    Clemens

  • Call variable from outside method

    I have a method for a listSelectionListener with a variable in it called "results", I want to be able to get the information from this variable outside of this method. In my main class alled "gifts" I have a TextArea and I want "results" to be displayed in it but I can't get results into it because it's in a seperate method. Anyone know how I can do this?
    Heres some relevant code:
    public Gifts()
              super( "Spiritual Gift Database" );
              try
                   Class.forName(JDBC_DRIVER);
                   conn = DriverManager.getConnection(DATABASE_URL);
                   stat = conn.createStatement();
                   ResultSet rs = stat.executeQuery("SELECT heading1 FROM demo");
                   Vector vector1 = new Vector();
                   while(rs.next()) vector1.add(rs.getObject(1));
                   container = getContentPane();
               container.setLayout( new FlowLayout() );
                   nameListPanel = new JPanel();
                   statListPanel = new JPanel();
                   buttonPanel = new JPanel();
               nameList = new JList(vector1);
               nameList.setVisibleRowCount( 9 );
                   nameList.setPrototypeCellValue("XXXXXXXXXXXX");
                   nameList.addListSelectionListener(
                        new ListSelectionListener()
                             public void valueChanged(ListSelectionEvent event)
                                  try
                                       ResultSet resultSet = stat.executeQuery("SELECT * FROM demo");
                                       StringBuffer results = new StringBuffer();
                                       ResultSetMetaData metaData = resultSet.getMetaData();
                                       int numberOfColumns = metaData.getColumnCount();
                                       for(int i = 1; i<=numberOfColumns; i++)
                                       results.append(metaData.getColumnName(i) + "\t");
                                       results.append("\n");
                                       while (resultSet.next())
                                            for(int i = 1; i<= numberOfColumns; i++)
                                            results.append(resultSet.getObject(i) + "\t");
                                            results.append("\n");
                                  catch(SQLException sqlException)
                                       JOptionPane.showMessageDialog(null,sqlException.getMessage(),
                                       "Database Error", JOptionPane.ERROR_MESSAGE);
                                       System.exit(1);
                   statList = new JTextArea(results.toString());
                   add = new JButton("Add Entry");

    Declare you variable at the class level instead of the function level, then you can see if from any method in the class.
    Paul

  • Window Server communications from outside of session allowed for root

    Hi ,
    When I am running the following program, i got the exception as
    49:wasp.corp.apple.com_kevinli:/ngs/app/giat/src/java/chart> java MyFrame
    kCGErrorRangeCheck : Window Server communications from outside of session allowed for root and console user only
    Exception in thread "main" java.lang.InternalError: Can't connect to window server - not enough permissions.
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1586)
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1503)
    at java.lang.Runtime.loadLibrary0(Runtime.java:788)
    at java.lang.System.loadLibrary(System.java:834)
    at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:50)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.awt.NativeLibLoader.loadLibraries(NativeLibLoader.java:38)
    at sun.awt.DebugHelper.<clinit>(DebugHelper.java:29)
    at java.awt.Component.<clinit>(Component.java:506)
    at MyFrame.<clinit>(MyFrame.java:6)
    import java.awt.*;
    import javax.swing.*;
    public class MyFrame
    public static JFrame f = new JFrame();
    public static void main(String[] args)
    JFrame.setDefaultLookAndFeelDecorated(true);
    f.setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);
    //Add the ubiquitous "Hello World" label.
    JLabel label = new JLabel("Hello World");
    f.getContentPane().add(label);
    //Display the window.
    f.pack();
    f.setVisible(true);
    Please send a reply on this.
    with regards,
    Mohan

    Seth,
    you may also install the latest update (10.4.6) using the combo file from apple.com.
    Mihalis.
    Dual G5 @ 2GHz   Mac OS X (10.4.6)  

  • ALV Grid editable - How to raise the data_changed event from outside object

    Hi,
    i'd like to like to raise the data_changed event from outside the ALV-Grid object in order to display errors to the user.
    For example a new row was inserted within the program. The user has only to complete the missing informations. Before saving the transactions the program has to execute some semantic checks. The errors of this check process should be shown to the user by creating an instance of the cl_alv_changed_data_portocol object.
    Thanks.
    Regards

    You don't need to raise the data_changed event to perform the edits or to issue messages using cl_alv_changed_data_protocol.
    The following assumes you have an ALV grid object g_alv based on the CL_GUI_ALV_GRID class.
    You can mark the inserted records upon insertion as selected using the set_selected_rows method, and then retrieve these rows later using get_selected_rows and perform necessary edits.
    Save the row number of each inserted row into a table of the appropriate type (see the method definition for this):
    DATA: t_index_rows    TYPE  lvc_t_row.
    DATA: s_row_no        TYPE  lvc_s_roid.
    DATA: t_row_no        TYPE  lvc_t_roid.
    Load entries into t_row_no after each insert.  Capture the row number and save in the table t_row_no.
    e.g.
    PERFORM insert_row USING s_row_no-row_id.
    APPEND s_row_no TO t_row_no.
    FORM insert_row would have whatever code you are using to insert the row.  Save the row id into s_row_no-row_id (which is an INT4).
    When done with all inserts do the following
      IF t_row_no[] IS NOT INITIAL.
        CALL METHOD g_alv->set_selected_rows
          EXPORTING
            it_index_rows            = t_index_rows
            it_row_no                = t_row_no
            is_keep_other_selections = 'X'.
      ENDIF.
    Then, if SAVE is pressed without the data_changed event having been raised (such as if the user just pressed SAVE without changing anything), use method get_selected_rows to retrieve the rows that were inserted and perform the necessary edits.
      DATA: l_t_rows    TYPE lvc_t_row.              " ALV control: Table rows
      CALL METHOD g_alv->get_selected_rows
        IMPORTING
          et_index_rows = l_t_rows.
    Loop through l_t_rows and use the row as an index into the grid, perform the necessary edits, just as you would if the data_changed event had been raised.
    If any edits fail, then send messages to the user, abort the save, and re-display the grid.
    Remember to refresh the t_row_no and t_index_rows tables if you load a new data set.
    You can also use a similar technique with the data_changed event to mark each changed row as selected by saving the row ids, and then you only have to update the changed rows on SAVE, which can minimize database I/O.
    Good luck.
    Brian

  • Passing values from HTML to JSP method,

    Hello:
    I am starting to wonder if what I am doing will ever work...
    Ok, I am trying to avoid javascript. I have a drop-down list named "year" and I wish to call a JSP method that is defined/declared in the same JSP.
    First, I want to pass the chosen option to the method and then store the name/value in a global variable.
    Second, depending on what the user selects, I will get values from an array defined/initialized on page load AND display those values in another drop-down list.
    As a test, and until now, I have done this. I am not passing anything yet, I just wanted to test this "fuzzy logic" I am having:
    <%!
    String currentYear;
    private void showDaysInDDList()
    currentYear = request.getparameter("year");
    %>
    Then on the HTML part of the page I have a drop-down list:
    <html>
    <head>
    <title></title>
    <link rel="stylesheet" type="text/css" href="style.css">
    </head>
    <body bgcolor="ffffcc">
    <form method="POST" name="form1" action="left.jsp">
    <select name="year" onchange="<%=showDaysInDDList()%>">
         <option></option>
         </select>
    I am getting the following errors:
    An error occurred at line: 105 in the jsp file: /p1/left.jsp
    request cannot be resolved
    ....and regarding to the onchange="<%=showDaysInDDList()%>"> part I am getting the following:
    An error occurred at line: 204 in the jsp file: /p1/left.jsp
    The method print(boolean) in the type JspWriter is not applicable for the arguments (void)
    In the action="left.jsp", left.jsp is the same page where the drop-down list and the method is. I am not sure if that is another error.
    I will continue here with my coffee ... any help will be extremely appreciated !!..
    I'll have to shut down my "asp.net mind" for a while..
    I'll reply later,
    MMS

    Ok, this is a bit messy here. I don't know how much you've read up on JSP but you seem confused about some fundamentals to me. However, you mention that you've worked with ASP .net so I'm going to assume you do have some notion of how thing should work in general.
    1. JSP is on the server-side and events like onchange that you've used take place on the client-side after the JSP/ servlet code has run and produced the HTML page. So calling your showDaysInDDList() will not work.
    2. Are you sure you know how the declaration tags ( <%! %> ) work? When you normally write JSP code without these tags, all that code gets compiled into the service method of the corresponding servlet that the JSP gets turned into. But, you can declare your own methods and variables outside the service method by using these tags.
    So what you're effectively doing is declaring
    private String/ void showDaysInDDList()
    }and followed by your usual _jspService()
    public void _jspService(HttpServletRequest request,
       HttpServletResponse  response)
         throws IOException, ServletException
    }Now it may be clear, that the request object is not available in the showDaysInDDList() method by default; you'll either have to declare it ( not sure if it's good programming practice or not ) or pass the required parameters in the call.
    3. Like you seem to have realized, that error about the printing of booleans was related to the return type of your method because <%= %> translates to out.println(); and since the argument was the method call, the return value was to be printed which here was a void ( not sure why it says boolean though :D ).
    Read up on this introduction to JSPs http://java.sun.com/developer/onlineTraining/JSPIntro/contents.html, seems to be pretty good and covers everything in quick, short chunks.
    Hope this helps.

  • Why i cant access asa 8.4 thruogh asdm from outside interface ???

    hi all ,
    plz help e why i cant access asa asdm from outside interface
    my puclic ip on outisde is :
    x.x.55.34
    i changed  portf of asdm to 65000 because i have portforward  ,
    i tried to connect to my ip thriuogh asdm bu :
    x.x.55.34
    x.x.55.34:65000
    but no luck ,
    it succed if i try to connect locally
    here is my sh run command :
    ====================================================
    ASA5505#
    ASA5505# sh run
    : Saved
    ASA Version 8.4(2)
    hostname ASA5505
    enable password qsddsEGCCSH encrypted
    passwd 2KFsdsdbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    switchport access vlan 2
    interface Vlan1
    nameif ins
    security-level 100
    ip address 10.66.12.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 50
    ip address x.x.55.34 255.255.255.248
    boot system disk0:/asa842-k8.bin
    ftp mode passive
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network obj-0.0.0.0
    host 0.0.0.0
    object network localsubnet
    subnet 10.66.12.0 255.255.255.0
    description localsubnet
    object network HTTP-Host
    host 10.66.12.249
    description web server
    object network HTTPS-HOST
    host 10.66.12.249
    description Https
    object network RDP-Host
    host 10.66.12.122
    description RDP host
    object network citrix-host
    host 10.66.12.249
    description citrix
    object service rdp
    service tcp destination eq 3389
    object service https
    service tcp destination eq https
    object service citrix
    service tcp destination eq 2598
    object service http
    service tcp destination eq www
    object network RDP1
    host 10.66.12.249
    object network HTTPS-Host
    host 10.66.12.249
    object network CITRIX-Host
    host 10.66.12.249
    object-group network RDP-REDIRECT
    object-group network HTTP-REDIRECT
    object-group network HTTPS-REDIRECT
    object-group network CITRIX-ICA-HDX-REDIRECTION
    object-group network CITRIX-ICA-SESSION-RELIABILITY-REDIRECTION
    object-group service CITRIX-ICA-HDX
    object-group service CITRIX-SR
    object-group service RDP
    object-group network MY-insideNET
    network-object 10.66.12.0 255.255.255.0
    access-list outside_in extended permit tcp any host 10.66.12.249 eq www
    access-list outside_in extended permit tcp any host 10.66.12.249 eq https
    access-list outside_in extended permit tcp any host 10.66.12.249 eq 2598
    access-list outside_in extended permit tcp any host 10.66.12.122 eq 3389
    access-list outside_in extended permit tcp any host 10.66.12.249 eq citrix-ica
    access-list outside_in extended permit tcp any host x.x.55.34 eq 65000
    access-list outside_in extended permit tcp any host x.x.55.34 eq https
    access-list outside_in extended permit ip any any
    pager lines 24
    mtu ins 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-645.bin
    no asdm history enable
    arp timeout 14400
    object network localsubnet
    nat (ins,outside) dynamic interface
    object network HTTP-Host
    nat (ins,outside) static interface service tcp www www
    object network RDP-Host
    nat (ins,outside) static interface service tcp 3389 3389
    object network HTTPS-Host
    nat (ins,outside) static interface service tcp https https
    object network CITRIX-Host
    nat (ins,outside) static interface service tcp citrix-ica citrix-ica
    access-group outside_in in interface outside
    route outside 0.0.0.0 0.0.0.0 62.109.55.33 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    aaa authentication http console LOCAL
    aaa authentication ssh console LOCAL
    http server enable 65000
    http 10.66.12.0 255.255.255.0 ins
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ca trustpoint _SmartCallHome_ServerCA
    crl configure
    crypto ca certificate chain _SmartCallHome_ServerCA
    certificate ca 6ecc7aa5a7032009b8cebcf4e952d491
        308205ec 308204d4 a0030201 0202106e cc7aa5a7 032009b8 cebcf4e9 52d49130
        0d06092a 864886f7 0d010105 05003081 ca310b30 09060355 04061302 55533117
        30150603 55040a13 0e566572 69536967 6e2c2049 6e632e31 1f301d06 0355040b
        13165665 72695369 676e2054 72757374 204e6574 776f726b 313a3038 06035504
        0b133128 63292032 30303620 56657269 5369676e 2c20496e 632e202d 20466f72
        20617574 686f7269 7a656420 75736520 6f6e6c79 31453043 06035504 03133c56
        65726953 69676e20 436c6173 73203320 5075626c 69632050 72696d61 72792043
        65727469 66696361 74696f6e 20417574 686f7269 7479202d 20473530 1e170d31
        30303230 38303030 3030305a 170d3230 30323037 32333539 35395a30 81b5310b
        30090603 55040613 02555331 17301506 0355040a 130e5665 72695369 676e2c20
        496e632e 311f301d 06035504 0b131656 65726953 69676e20 54727573 74204e65
        74776f72 6b313b30 39060355 040b1332 5465726d 73206f66 20757365 20617420
        68747470 733a2f2f 7777772e 76657269 7369676e 2e636f6d 2f727061 20286329
        3130312f 302d0603 55040313 26566572 69536967 6e20436c 61737320 33205365
        63757265 20536572 76657220 4341202d 20473330 82012230 0d06092a 864886f7
        0d010101 05000382 010f0030 82010a02 82010100 b187841f c20c45f5 bcab2597
        a7ada23e 9cbaf6c1 39b88bca c2ac56c6 e5bb658e 444f4dce 6fed094a d4af4e10
        9c688b2e 957b899b 13cae234 34c1f35b f3497b62 83488174 d188786c 0253f9bc
        7f432657 5833833b 330a17b0 d04e9124 ad867d64 12dc744a 34a11d0a ea961d0b
        15fca34b 3bce6388 d0f82d0c 948610ca b69a3dca eb379c00 48358629 5078e845
        63cd1941 4ff595ec 7b98d4c4 71b350be 28b38fa0 b9539cf5 ca2c23a9 fd1406e8
        18b49ae8 3c6e81fd e4cd3536 b351d369 ec12ba56 6e6f9b57 c58b14e7 0ec79ced
        4a546ac9 4dc5bf11 b1ae1c67 81cb4455 33997f24 9b3f5345 7f861af3 3cfa6d7f
        81f5b84a d3f58537 1cb5a6d0 09e4187b 384efa0f 02030100 01a38201 df308201
        db303406 082b0601 05050701 01042830 26302406 082b0601 05050730 01861868
        7474703a 2f2f6f63 73702e76 65726973 69676e2e 636f6d30 12060355 1d130101
        ff040830 060101ff 02010030 70060355 1d200469 30673065 060b6086 480186f8
        45010717 03305630 2806082b 06010505 07020116 1c687474 70733a2f 2f777777
        2e766572 69736967 6e2e636f 6d2f6370 73302a06 082b0601 05050702 02301e1a
        1c687474 70733a2f 2f777777 2e766572 69736967 6e2e636f 6d2f7270 61303406
        03551d1f 042d302b 3029a027 a0258623 68747470 3a2f2f63 726c2e76 65726973
        69676e2e 636f6d2f 70636133 2d67352e 63726c30 0e060355 1d0f0101 ff040403
        02010630 6d06082b 06010505 07010c04 61305fa1 5da05b30 59305730 55160969
        6d616765 2f676966 3021301f 30070605 2b0e0302 1a04148f e5d31a86 ac8d8e6b
        c3cf806a d448182c 7b192e30 25162368 7474703a 2f2f6c6f 676f2e76 65726973
        69676e2e 636f6d2f 76736c6f 676f2e67 69663028 0603551d 11042130 1fa41d30
        1b311930 17060355 04031310 56657269 5369676e 4d504b49 2d322d36 301d0603
        551d0e04 1604140d 445c1653 44c1827e 1d20ab25 f40163d8 be79a530 1f060355
        1d230418 30168014 7fd365a7 c2ddecbb f03009f3 4339fa02 af333133 300d0609
        2a864886 f70d0101 05050003 82010100 0c8324ef ddc30cd9 589cfe36 b6eb8a80
        4bd1a3f7 9df3cc53 ef829ea3 a1e697c1 589d756c e01d1b4c fad1c12d 05c0ea6e
        b2227055 d9203340 3307c265 83fa8f43 379bea0e 9a6c70ee f69c803b d937f47a
        6decd018 7d494aca 99c71928 a2bed877 24f78526 866d8705 404167d1 273aeddc
        481d22cd 0b0b8bbc f4b17bfd b499a8e9 762ae11a 2d876e74 d388dd1e 22c6df16
        b62b8214 0a945cf2 50ecafce ff62370d ad65d306 4153ed02 14c8b558 28a1ace0
        5becb37f 954afb03 c8ad26db e6667812 4ad99f42 fbe198e6 42839b8f 8f6724e8
        6119b5dd cdb50b26 058ec36e c4c875b8 46cfe218 065ea9ae a8819a47 16de0c28
        6c2527b9 deb78458 c61f381e a4c4cb66
      quit
    telnet 0.0.0.0 0.0.0.0 outside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    management-access outside
    dhcpd address 10.66.12.160-10.66.12.180 ins
    dhcpd dns 212.112.166.22 212.112.166.18 interface ins
    dhcpd enable ins
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    username test password P4ttSdddd3SV8TYp encrypted privilege 15
    username ADMIN password 5dddd3ThngqY encrypted privilege 15
    username drvirus password p03BtCddddryePSDf encrypted privilege 15
    username cisco password edssdsdOAQcNEL encrypted privilege 15
    prompt hostname context
    call-home reporting anonymous
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DD
    CEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:d41d8cd98f00b204e9800998ecf8427e
    : end

    For access over VPN you need:
    management-access inside
    and don't forget:
    ssh inside
    http inside
    I'm guessing you forgot to grant ASDM (http/https) access to the IP addresses used by the VPN?  Can you SSH?  If not, that is your problem to solve first.

  • Updating data from PSA to Data Target

    Hi,
    I just want to update data from PSA to data target.
    There is a process chain running daily it will updating Master Data in to 0Vendor object. This process chain is updating only upto PSA not the data target. I just want to update from PSA to data target.
    There is a update rule for 0Vendor but itu2019s not active at the movement and also it is not properly mapped with the 0Vendor.
    Is there any other method which I can update data from PSA to Data target with in the same process chain.
    Thanks
    Ganesh

    If this is BW 3.5, change the infopackage setting to load to data target as well.
    This is a other w ay than using the update from infopackage.
    if this is 7.0, Use the DTP to load from PSA(datasource) to Target.
    Let me know if this helps.
    Thanks
    Sachin

  • Can not access CRM from outside the office network - Access denied You do not have sufficient access rights or privileges to perform this action.

    Hi,
    I can not access CRM from outside the office network - Access denied You do not have sufficient access rights or privileges to perform this action.  I can access CRM with same user id and password from our office inside the network.  I can get
    the page to give login details once I have login details I got below error. Please help me to solve this issue.  It was working before.
    Access denied You do not have sufficient access rights or privileges to perform this action. 
    Regards,
    Noushad
    [email protected]

    On Premise system Configured with AD FS server for claims-based authentication you need to update your host file with server url to access it from outside office network.
    Refer
    this on how to update host file.
    Regards, Saad

  • Copy Update Rule from Business Content

    Hi All,
    Currently I have activated some standard BI Content E.g. InfoCube 0FIAR_C03, DSO 0FIAR_O03, InfoSource 0FI_AR_4 and all the corresponding update rules.
    Now I have copied both InfoCube and DSO into another customized version E.g. ZAR_C03 and ZAR_O03. I managed to copy the same update rule from InfoSource 0FI_AR_4 to ZAR_O03 using the template but I don't have the option of copying the same update rule from ZAR_O03 to ZAR_C03 using the same update rule of 0FIAR_O03 to 0FIAR_C03.
    I know I have the choice to manually re-create all the details but is there any other workaround?
    Please read through carefully my question. I have seen some forum asking to load data from 0FIAR_O03 to then ZAR_O03 then so forth.
    Purpose of doing the above method is because I want to remain the business content as what it is and just to copy it to Z version for customization.
    Thanks
    David Yee

    Hi All,
    Is there any other second opinion related to this issue before I close the question?
    Thanks
    David Yee

  • Trying to access my 851w from outside my lan, but can access inside fine

    Hi,
    I purchased a 851w to use as my home router and to learn more about the cisco IOS. I have been spending some time studying for CCENT/CCNA and so far I have enjoyed learning as I go. However, I am having problems accessing this router from a remote location via ssh. I can access it just fine from my lan, but not outside it from another location. Currently, I am not using this router for internet access or anything else other than learning about the IOS, and it is connected to a basic dlink wireless router dir-615. I have port forwarding setup on the dlink that any traffic coming in on port 22 is directed to the 851w at 192.168.0.150. I also have the 851w connected with a crossover cable to a switch that is connected to the dlink router.
    Like I said, I can connect just fine from my lan, but can't connect from outside. I have tried a few different things but nothing works. I also use Teraterm to connect, but have tried Putty too. I also use ddns to access it, but I have also tried the wan ip address of the dlink with no luck.
    Could someone please take a look at my very basic running config and explain what I might need to do different?
    Thanks in advance.
    Sean

    Hi and thanks a bunch for your quick response.
    No, I can't ping anything other than my main router which I have setup as the gateway so why is that? For example,
    ip default-gateway 192.168.0.1
    Wouldn't it automatically send anything it doesn't know about to the 192.168.0.0/24 router?
    I have one of the switch ports, Fast Ethernet 0, connected to another switch connected to the dlink router. I have tried different ports but it didn't change anything. I don't have anything connected to the wan port of the 851w. I was trying to simulate remote access of a switch on an internal network. My next step would be to make the 851w my default router and then try to access it from the outside, but I wanted to succeed this way first.
    optimus#show ip int br
    Interface IP-Address OK? Method Status Protocol
    Dot11Radio0 unassigned YES unset administratively down down
    FastEthernet0 unassigned YES unset up up
    FastEthernet1 unassigned YES unset down down
    FastEthernet2 unassigned YES unset down down
    FastEthernet3 unassigned YES unset up down
    FastEthernet4 unassigned YES unset administratively down down
    Vlan1 192.168.0.150 YES manual up up
    Yes, my internal pc is on the 192.168.0.0/24 subnet.
    Best Regards,
    Sean

  • Remote Screen Sharing (VNC) from outside of my LAN

    I often have to connect to my parents' Macs to help them out with various things. I commute between two cities and stay with them when I'm there.
    (I set up a dynamic hostname with DynDNS to point to our router, which defaults to port 443, which on the home network is reserved for the QNAP NAS that's set up. I set the router up to be reachable at port 455 but I'm not sure if it is successfully sending IP address updates to DynDNS. I don't see a way to check if it is. DynDNS seems to require a paid account for that functionality and my routers log is also not very helpful. In short, I'm having trouble getting the whole dynamic DNS thing to work reliably with our router, which is otherwise a great little box: a Fritz!Box Fon WLAN 7390).
    I use Jolly's Fast VNC (http://goo.gl/UmllQ) to connect to a personal server and that works wonderfully, but then there the details are taken care of for me by my provider and I just have to type in the details.
    What I'd really love is something like Edovia's Screens (http://www.edovia.com/)... except for the Mac rather than the iPhone/iPad (though I do own an iPhone copy of it and it's wonderful).
    We do share a MobileMe subscription in the family, but that's not very helpful here either.
    So far, we've used iChat, Skype screen sharing and I often end up using TeamViewer because of its speed and near non-existant setup.
    My goal is to find a way to connect to my parents' Macbooks even when they are not around so I can help them out with problems while they may not even be around. The key here is that I want to be able to control their screens without needing any action on their part.
    Suggestions for the simplest possible way to do this are very welcome.

    I didn't know TeamViewer could be set up to be accessible without a second user having to be around to give me the session ID and password. I wonder if it's worth looking into that if LogMeIn Free with its server always running is a perfectly acceptable solution? Any advantages to using TeamViewer's solution?
    The free LogMeIn account does NOT allow file transfer. The free for personal use TeamViewer does.
    LogMeIn server hides in the background, so it is less likely your parents will Quit LogMeIn.com, were as TeamViewer looks like just another app, so they might Quit from it to get it out of the way.
    Of course if you need to transfer a file (or 2), you could use DropBox.com for that, and it is a very easy way to transfer files between systems. Or you could store the file on your MobileMe account in a public place, then via LogMeIn copy the file from your public space into your Parent's Mac(s). Or your could use LogMeIn to start TeamViewer, and then use TeamViewer to transfer the file.
    Basically once you can start applications on your Parent's Mac(s), you can use any number of utilities for transferring data.
    We do have MobileMe. I was under the impression that the way Back to my Mac works is that it will show you YOUR remote Macs in the Finder's sidebar. You know, ones that you're also logged in with YOUR MobileMe credentials. We all use our own, unique MobileMe accounts. Am I missing something?
    Yes, all the Macs would need to use the same MobileMe account. Do you all really need separate accounts? Maybe a Family account.
    I could deal with the port forwarding and DynDNS but I'll have to set that up to remotely administer my router and NAS, which is turning out to be quite the pain. So if I can simplify, I will. LogMeIn or TeamViewer will do the trick just fine.
    Port forwarding is a once and done thing for your parent's router. It allows you to get to their Macs from outside their home. It should have nothing to do with remote admin, or your router and NAS. Also once you can Screen Share your parent's Mac, you can then use that Mac to talk from the inside to their router. Although one must be very careful about making router config changes as one "Oops" and you could loose your remote access, and have to visit Mom and Dad to get physical access
    By the way, I've been using VNC/Screen Sharing and AFP file sharing over ssh tunnels in conjunction with port forwarding on the destination router for years. I do this, even though it is more work, because it was available long before most of the above services were available, and because it has a lot more flexibility once you know how to use it. Oh yea, I'm also a Unix software developer and spend a lot of time using ssh anyway

  • Do I need a domain name in order to connect to my Mini Server 10.8.2 from outside my network?

    I am working on setting up my mac mini server. Aside from in home file sharing I want ot be able to connect to some files remotely and even upload files, say pictures from my camera, to my server from outside my network. I am only looking to have maybe 2 users that have access. Should I get a domain name from a place like GoDaddy? in order to set up server to use domain in initial setup? I have 2 Drobos connected with my music, videos and pictures and I wat to access them from an Android, Windows and iPod device when away from home. Any how-tos out there or good step by step guides?
    Thanks for any information.
    -Peace
    -Dave

    A normal address like www.domain.com is intended to work with static IP addresses, DynDNS is a service specifically intended for dynamic addresses and it will therefore automatically update the address e.g. name.dyndns.org to match the dynamic IP address each time it changes.
    Some home broadband routers have built-in support to act as a DynDNS client but if yours does not then you can run the DynDNS software on your Mac server. This will then tell the DynDNS servers what your current dynamic IP address is so they can map it to your host name.
    The result will be that your users can use a name like yourname.dyndns.org to access your server and not have to worry about the fact your IP address may change.
    You would still need to run a VPN server to allow your remote users to connect to your network but OS X Server can do this. You could also run a website but depending on your needs that might be better done by using a web hosting service.

  • TS1967 i have a problem when i try to update or install apps in my ipad, and a message come up says "can not connect to Itunes Store", anyone know why? please advise. however i had update all my detail of payment method.

    i have a problem when i try to update or install apps in my ipad, and a message come up says "can not connect to Itunes Store", anyone know why? please advise. however i had update all my detail of payment method.

    Settings > General > Reset > Reset Network Settings.
    Power cycle the router.
    Basic troubleshooting from the User's Guide is reset, restart, restore (first from backup then as new).  Try each of these in order until the issue is resolved.

Maybe you are looking for

  • E-Mail Conflict - Unable to Send Away from Home

    I purchased a new Q10 (Model #SQN100-1) International Version phone in February 2015.  The software version I am working on is 10.3.2.440 which was downloaded when received from BB.  The e-mail service provider is Cogeco and the wireless service prov

  • Issue at Delivery

    Good day everyone, We have performed customization at SD Devliery, inserted few screen at VL01n/02n/03n tcodes. Customization done to convert the delivered quantity using a conversion formula and then overwrite the delivered quanitty. For example: de

  • How to get rid of movie pass stuck in passbook

    I've had a Fandango movie pass stuck in Passbook for a couple years now. When I click the info button there is no delete button at the top and no "remove card" at the bottom. I tried to get an answer here before and nobody had an answer for me. I'm r

  • Itunes keeps saying it is a locked disk or you do not have the write permission. What is happening?

    iTunes keep telling me that i havea locked disk or you do not have write permission. How can i fix this? I have deleted and reinstalled it.  It will let me open it on another user but will not let me sync. Says Ido not have enough authority..

  • T530: an error occurred while ejecting sd-card from internal sd-reader

    I can`t eject cards normaly. Error appears in 100% cases. Anyone experience such problems? Lenovo ThinkPad T530: i7-3520M/16GB RAM/128GB Vertex 4 SSD/1TB Seagate HDD + 8GB SSD Cache/NVS 5400M/FHD 1920x1080/9-cell BAT/ Backlit RU/Windows 7 Pro SP1 x64