Using both Dynamic and Static NAT with two Different Internet facing Subnets

We have two Class C Public Address subnets.  We started with Subnet (A) and have many of our Internet accessible devices on it. It is running on a Cisco PIX 515R. We bought a new ASA 5510 8.3(2) and started Migrating the Users and new servers to it so I started with our second Class C Subnet (B).   Later on down the road I found out that if the Firewalls Default Gateway is is set to a (B) Interface subnet, then the servers that are statically mapped to a (A) Address will have a (B) address when they communicate out to the internet.  So they are receiving packets on their (A) Address, though replying to them with a (B) address. 
It was mentioned that I should be able to combine static and dynamic NAT mapping to allow devices behind the firewall to have a fixed external Address when communicating outbound as well as inbound. 
So For instance I want the Following: when the Internal Replies I want the reply to come from the mapped IP, not a IP from the Dynamic Pool. 
Public IP: 192.168.1.100/24
Internal IP: 10.0.0.100/16
Public IP: 192.168.5.101/24
Internal IP: 10.0.0.101/16
interface Ethernet0/0
description 192.168.1.0/24 Network Outside IP
nameif outside-1
security-level 0
ip address 192.168.1.1 255.255.255.0
interface Ethernet0/1
description 192.168.5.0/24 Network Outside IP
nameif outside-5
security-level 0
ip address 192.168.5.1 255.255.255.0
interface Ethernet0/2
description inside 10.0.0.0/16
nameif inside
security-level 100
ip address 10.0.0.1 255.255.0.0
object network serverA_o
host 192.168.1.100
object network serverA_i
host 10.0.0.100
object network serverB_o
host 192.168.5.101
object network serverB_i
host 10.0.0.101
object network 192-168-1-NAT-POOL
range 192.168.1.50 192.168.1.239
nat (inside,outside-1) source static serverA_i serverA_o
nat (inside,outside-5) source static serverB_i serverB_o
nat (inside,outside-1) source dynamic any 192-168-1-NAT-POOL interface
object network serverA_i
nat (inside,outside-1) static serverA_o
object network serverB_i
nat (inside,outside-5) static serverB_o
route outside-1 0.0.0.0 0.0.0.0 192.168.1.1 1
route outside-5 0.0.0.0 0.0.0.0 192.168.5.1 2
When I set this up my serverB shows a Public IP of something in the 192-168-1-NAT-POOL Not 192.168.5.101
Any Suggestions?
Thanks!

Not sure why I have Multiple Entries. )-: I did think it was Odd. I think it might be because I looking at examples of the new and old styles of NAT.
We have a Single ISP, though have 2 separate non-Contiguous  Class C Addresses from them. We host some Servers on one subnet and some on the other. 
I'm looking for a way to use both Subnets on the same ASA. 
The Connection to the net looks like this:
Internet -> Edge Router Layer3 VLAN Switch
GE0/1.2 - 192.168.1.1 VLAN Tagged --> GE0 - VLAN Tagged
GE0/1.2 - 192.168.5.1 VLAN Tagged -^
Layer3 VLAN Switch Firewall
GE1 192.168.1.0/24 Untagged -> ASA Outside-1
GE2 192.168.5.0/24 Untagged -> ASA Outside-5
Firewall
ASA inside 10.0.0.0/16 -> Switch -> 10.0.0.100
Hope that helps clarify.
I could try to post some sanitized Configs of my PIX and ASA if needed.  But the end result I'm trying to do is have the ASA do NAT for multiple Public Subnets. 

Similar Messages

  • I have signed in iCloud and Apple Id with two different accounts and forgot the password of iCloud's account so what should I do?

    I have signed in iCloud and Apple Id with two different accounts on my Iphone 4S and forgot the password of iCloud's account and I am unable to reset the password of it,so what should I do?

    iCloud: Change your iCloud password
    If you forgot your Apple ID password - Apple Support
    Apple ID: Contacting Apple for help with Apple ID account security - Apple Support
    A forgotten iCloud password as above can go to http://iforgot.apple.com and sign in with the same ID they use for iCloud to enter the password reset process.
    https://getsupport.apple.com/https://getsupport.apple.com/GetproductgroupList.action

  • HT1476 i plug in my phone to the  charger and i tried with two different cables, and it seems like it is not making connection to the clable?

    i plug in my phone to the  charger and i tried with two different cables, and it seems like it is not making connection to the clable. but it is not charging. what are some possible ways o fix that?

    When you plug in your charger and attach it to the MBP, initially the light will turn green.  If the MBP needs charging, a few seconds later the light will turn amber.  That is normal.  If your symptoms are different, then they may or may not be a problem.
    Ciao.

  • How to use both wired and wireless connection with static addresses

    Now that I have setup my home network with static addresses (router, mini1, mini2 and PC) in the way I want, (big thanks to BDAqua http://discussions.apple.com/thread.jspa?threadID=1271635&tstart=0) I would like to understand some more advanced network concepts.
    I would like to change the network so that I use both the wireless connection and the built-in ethernet connection at the same time in my Mac mini1. I would like to connect my PC to my Mac mini by using the wired ethernet connection so that I reach the Internet from my PC as well. I would also like to be in control of all the addresses therefore I want to assign the addresses manually.
    The question: What addresses should I use between mini1 and PC? Should I use the same wireless address space as I already use between the wireless router and the other computers (router: 192.168.1.1, mini1: 192.168.1.101, mini2: 192.168.1.103) or should I use something totally different like 10.X.X.X? What should I put in ethernet connection "Router"-field, the same as in Airport (192.168.1.1)? What about DNS, same as in Airport?

    If I understand this correctly, you wish your Mini to perform Internet Sharing for your PC, correct!?
    If so you'll pretty much have to let the Mini handle DHCP & NAT on the Ethernet port. You also want to be sure Airport is dragged to the top of Network>Show:>Network Port Configurations, that's what position the Mini will use 1st for Internet itself.
    On the Mini turn on both Web Sharing & Internet Sharing. The PC once connected will have the Mini's Ethernet IP as it's Gateway addy.

  • Static NAT with two outside interfaces

    I have a router, which performs NAT on two outside interfaces with load balancing and had a task to allow inbound connection to be forwarded to the specific host inside on a well known port.
    here is example
    interface Fas0/0
    ip nat outside
    interface Fas0/1
    ip nat outside
    interface Vlan1
    ip nat inside
    ip nat inside source route-map rm_isp1 pool pool_isp1
    ip nat inside source route-map rm_isp2 pool pool_isp2
    all worked fine
    then i tried to add static nat
    ip nat inside source static tcp 10.0.0.1 25 interface Fas0/0 25
    ip nat inside source static tcp 10.0.0.1 25 interface Fas0/1 25
    and in result only last static NAT line appeared in config.
    the solution was to use interface's IPs instead of names. that helped but isn't that a bug?

    In this scenario, we are trying to access a mail server located at
    10.0.0.1 from outside and we have two outside IP, let's say, 71.1.1.1 and
    69.1.1.1.
    With CEF Enabled
    Packet comes in to Fa0/0 interface with Source IP 66.x.x.x and
    Destination IP 71.1.1.1. Our NAT rule translates this to 10.0.0.1.
    Packet goes to 10.0.0.1. The return packet goes to the LAN interface
    first and the routing rule is determined *before* the packet is
    translated.
    Packet source IP at this point is 10.0.0.1 and destination is
    66.x.x.x. Now, based on CEF, it will go out via Fa0/0 or Fa0/1,
    irrespective of the way it came in. Because of this, with CEF enabled
    this will not work. CEF is per-destination.
    So, let's say somebody on outside tried to access this server using 71.1.1.1, then he would
    expect a reply from 71.1.1.1 which may or may not be true as the traffic could be Nat'd to 69.1.1.1 or 71.1.1.1.
    If it gets reply packet from 71.1.1.1, it should work.
    If it gets it from 69.1.1.1, it will simply drop it as it never sent a
    packet to 69.1.1.1.
    With CEF and Fast Switching Disabled
    Same steps as above, only that the packet is sent to the process level
    to be routed. At this point, the packets will be sent out in a round
    robin fashion. One packet will go out via the Fa0/0 and the other via the
    Fa0/0. This will have a constant 50% packet loss and is also not a
    viable solution.
    So, what are you trying to achieve is not possible on Cisco router.
    HTH,
    Amit Aneja

  • How Can I use 2 Macs and a PC with two monitors

    This is for my office at work.
    I currently am using dual monitors and sharing those between a G4 and a PC. I'm using a Belkin switch box for the two computers. I'm adding a Mac Pro. I'm thinking I might use the Mac Pro by itself at another workstation but I would like to use it at my current workstation along with my other machines.
    I'm getting a new 23" monitor with the Mac Pro. I want to use it as my main monitor, then use one of my other monitors as a second screen. Is it possible to use two monitors with 3 computers? I would have to use the new keyboard and mouse (both will be standard, not wireless) on both of the macs and use the PC keyboard and mouse.
    Thank You
    Jim

    I would use the new Mac Pro as the main workstation and attach your mouse, keyboard and your new monitor to it.
    Then use the Belkin Switch Box to connect 1 monitor to the G4 and PC.
    Download and configure 'Synergy' (http://synergy2.sourceforge.net/) on the new Mac Pro (as the primary) and the G4 and PC (as secondary) - This will allow you to deal with only one keyboard and mouse.
    I'm with Malcolm, I would download and install VMware Fusion. VM the PC w/ Converter (http://www.vmware.com/products/converter/) and only deal with the new Mac Pro and G4. With the new Mac Pro, you can fire up the PC VM with 2 cores and have it set to a secondary space. You will not notice the difference.

  • Importing and editing footage with two different cameras

    I am editing a film that has footage caught and imported from two different cameras. Some of the footage is from a handheld HD camera that I have worked with before and use an "Easy Setup of Apple Intermediate Codec, 29.97 fps, HDV Apple Intermediate Codec 1080i60." I want to add some video footage that I shot with my Canon Rebel t2i. I searched a number of threads and concluded that when working with a project shot with the t2i, I should have the the Easy Setup be "HD, 29.97fps, DVCPRO HD 1080p30" (side question: is this correct?). My question is when starting a project where I will be using footage from both cameras, what Easy Setup should I use and is there anything else I should keep in mind?

    Shane-- Thanks for the willingness to help. I am in Helena, but travel all over the state for work--I am a fly fishing and bird hunting guide who likes to do some amateur filming and editing on the side. Love Missoula, Bozeman, Flathead area, etc! And since you are willing to be so helpful, I guess I should start with a go Cats!
    I am brand new to FCP, having previously worked a fair amount with FCE4. I actually do have FCP 7 and work with it on my Macbook Pro. My handheld camera is a JVC Everio that captures in AVCHD (1920x1080). I had my Easy Setup in FCE4 as Apple Intermediate Codec. If I use footage from this camera in FCP7, should I continue to do this?
    So not only am I new to FCP7, but I just bought the T2i and really am not totally sure what I am doing yet. I just got the Canon EOS Movie Plug-in and modified it according to some threads I read so that it works for the T2i. I also found directions on the Canon website on the proper way to Log and Transfer for T2i footage (side question: can I dump the files off my T2i onto an external HD and then Log and Transfer them into FCP7 from the external, and is there anything I need to know about when doing this?)
    So now that you know that I am very knew to FCP7 and the T2i, maybe I should start from scratch. When I log and transfer, what format should I use when I transcode? ProRes 442? And then, however you suggest I should transcode, what should my Easy Setup look like for footage from the T2i?
    Wow, if you are still reading at this point, and I haven't exhausted you with all of my questions and naivety, my final question is...once I have become comfortable with importing and editing footage from the T2i, what should I do if I want to log and transfer and then edit footage from both cameras? Do I need to change the Easy Setup? Do I need to make other changes?
    Thanks again in advance for all of your help and patience!!!

  • On my wireless printer can i use both usb and wireless at the same time

    i tried to print from coupons,com but it will not  i have used coupons.com before with my other printer and weorked fine i have coupons.com looking into it
    just wondering if anyone else out there have the same problem

    Hi,
    Same physical printer but when connecting to SAME computer using both USB and wireless it becomes two (logical) printers. Probably your default prnter is the wireless one, you have to select the right printer before print .
    Regards.
    BH
    **Click the KUDOS thumb up on the left to say 'Thanks'**
    Make it easier for other people to find solutions by marking a Reply 'Accept as Solution' if it solves your problem.

  • Dynamic PAT and Static NAT issue ASA 5515

    Hi All,
    Recently we migrated our network to ASA 5515, since we had configured nat pool overload on our existing router the users are able to translated their ip's outside. Right now my issue was when I use the existing NAT configured to our router into firewall, it seems that the translation was not successful actually I used Dynamic NAT. When I use the Dynamic PAT(Hide) all users are able to translated to the said public IP's. I know that PAT is Port address translation but when I use static nat for specific server. The Static NAT was not able to translated. Can anyone explain if there's any conflict whit PAT to Static NAT? I appriciate their response. Thanks!
    - Bhal

    Hi,
    I would have to guess that you Dynamic PAT was perhaps configured as a Section 1 rule and Static NAT configured as Section 2 rule which would mean that the Dynamic PAT rule would always override the Static NAT for the said host.
    The very basic configured for Static NAT and Default PAT I would do in the following way
    object network STATIC
    host
    nat (inside,outside) static dns
    object-group network DEFAULT-PAT-SOURCE
    network-object
    nat (inside,outside) after-auto source dynamic DEFAULT-PAT-SOURCE interface
    The Static NAT would be configured as Network Object NAT (Section 2) and the Default PAT would be configured with Twice NAT / Manual NAT (after-auto specifies it as Section 3 rule)
    This might sound confusing. Though it would be easier to say what the problem is if we saw the actual NAT configuration. Though I gave the reason that I think is probably one of the most likely reasons if there is some conflict with the 2 NAT rules
    You can also check out a NAT document I made regarding the new NAT configuration format and its operation.
    https://supportforums.cisco.com/docs/DOC-31116
    Hope this helps
    - Jouni

  • I have two different 5s's with two different phone numbers but they are both using the same iCloud/apple account. After upgrading to iOS8 when I get a phone call on one phone both phones ring.

    I have two different 5s's with two different phone numbers but they are both using the same iCloud/apple account. After upgrading to iOS8 when I get a phone call on one phone both phones ring. One phone is for work and one is for private and I don't need both phones to ring from one call. It's bizarre.......is this supposed to be like this? If so where can I turn it off?? And while we are at it iOS8 has installed iBooks on both of my phones and iTunes won't let me uninstall it. I don't need or want iBooks on my phones.

    Hi,
    There are two easy fixes to this.
    One, you can set up Family Sharing, in which you can have two different iCloud Accounts, yet still share the same apps, music, media etc.
    Two, go to Settings and turn-off "Handoff". This can be found under the General page.
    Hope this helps!

  • HT4818 Can you use both Bootcamp and Parallels with the same Windows 7 installed

    I have Parallels installed with Windows 7.  Can I use both Bootcamp and Parallels on the same machine depending on whether I just want to work in Windows all day (Bootcamp) or alternate during the same session (Parallels)?

    You can, yes. But there is a complication: once you activate windows it will only be activated for one of the two methods you use. So, let's say you install into boot camp and activate windows. You can then install Parallels and it will find your boot camp installation, but when running in Parallels, Windows will report that it is not activated. Or, you can activate it in Parallels and when running in Boot Camp Windows will report that it is not activated. The reason for this is because Windows thinks it is running on different computers depending on how you boot it. This may not be an issue for you if you run Windows a lot one way and just occasionally the other way, so be sure to activate Windows in whichever method you use more often. Hope this helps!

  • I am a language intructor, can I use Adobe Presenter to work properly on both, English, and Spanish presentations with the same software?

    I am a language intructor, can I use Adobe Presenter to work properly on both, English, and Spanish presentations with the same software?

    It shouldn't be an issue. Ultimately, Presenter doesn't care what language the content or audio is in, it will deliver it just the same. The only issue I could see causing problems would be the player skin. It has Spanish lables, but they only show on a computer with the OS set to Spanish. If you want the student to view both and English and a Spanish version on the same computer, you may need to have two versions of the language.xml file where you have one that has the desired English lables in the "en" section and one where it has the desired Spanish labels in the "en" section. You would then swap these files in and out of the folder located at,C:\Users\{UserName}\AppData\Local\Adobe\Adobe Presenter\Themes , as you need to publish an English or Spanish presentation.

  • My boyfriend and I have each an IPhone with two different Apple IDs. Since the recent software his contacts appears in my Iphone. How can I switch that off? I have be looking at both Iphones and Iclouds.

    My boyfriend and I have each an IPhone with two different Apple IDs. Since the recent software his contacts appears in my Iphone. How can I switch that off? I have be looking at both Iphones and Iclouds.

    All apps and purchases are linked to your apple ID, so you can't share them across 2 devices that are using different apple id's, it won't work. the purchases that are on your mac at the moment will only work with the apple id they were brought with.
    the only thing thats possible to share is purchased music. you have to first covert it to mp3 within itunes, then your bf can import it into his own itunes library and sync with his phone.

  • Iam using iphone 4s and Iphone 5s with same apple ID but my network is different and whenever Iam getting call in i5s and in my both handset same calls are coming. Please provide me solutions

    Iam using iphone 4s and Iphone 5s with same apple ID but my network is different and whenever Iam getting call in i5s and in my both handset same calls are coming. Please provide me solutions

    On both devices, go to Settings>Facetime and turn off cellular calls.
    ~Lyssa

  • Can I use an iPad and a ipad2 with the same iTunes in my computer? I want to use both

    Can I use an iPad and a ipad2 with the same iTunes in my computer? I want to use both. Want to give one to wife.do I need to open a new iTunes account for her?

    bashepard wrote:
    Can I use an iPad and a ipad2 with the same iTunes in my computer? I want to use both.
    Yes, No problem at all.
    Want to give one to wife.do I need to open a new iTunes account for her?
    No - you can share the same iTunes account (my wife and I share the same account). But when you sync the iPads, just remember to select the correct content for her iPad and the correct content for your iPad.

Maybe you are looking for

  • Chat Applet using RMI .... trouble running the Applet using the IE browser.

    Hi, I'm trying to run a chat application using RMI technology. Actually, this wasn't created from the scratch. I got this one from from the cd that comes with the book I bought and I did some refinements on it to suit what I wanted to: These are the

  • How to Connect to Unix OBIEE servers from Remote desk top

    Hi Experts, My obiee OBIEE Build/Dev is in Unix servers.I have to connect to Obiee OBIEE Build/Dev server through Remote desk top. Please guide me

  • JAXM ReqRespListener not found

    Hi all I developed a servlet that listens for incoming SOAP connections. It extends JAXMServlet and implements ReqRespListener. When I registered the libraries jaxm-api.jar and jaxm-runtime.jar in Eclipse, it had no problem in finding the classes in

  • IPhoto does not run under lion OS

    I have a 27" iMac purchased in 2010.  The hard drive recently went bad but Apple support was able to save my data and replaced the hard drive. I just upgraded the OS to Lion 10.7.  Now my iPhoto will not run.  Get the error message "Lion does not sup

  • I get multiple notifications of some posts (in digest mode)

    I recently asked a question in a forum. (My subscription settings automatically subscribe me to topics which I create or post to, and they send me a digest message once a day.) That night, I received a digest message informing me that a reply had bee