Using Switch With Double(Need Help)

Hello,
I want to write a program which says grades from numbers.For example;
When i write 87,it has to say that 87=BB
Grade system;
AA =94 - 100
BA =89 - 93
BB =84 - 88
CB =79 - 83
CC =74 - 78
FF =0-73
and i wrote this;
import javax.swing.JOptionPane;
          public class GradeCalculate {
             public static void main(String[] args) {
          double value = Double.parseDouble(JOptionPane.showInputDialog ("Enter value\n"));
                    switch (value/10.0) {
                    case 10.0:  System.out.println("AA"); break;
                 case 9.9:  System.out.println("AA"); break;
                 case 9.8:  System.out.println("AA"); break;
                 //it is going like that 9.7, 9.6, 9.5... etc               
}But i cant compile it.Where am i making mistake?How can i use double command with this program?I have to do this with using double and switch commands.
Thanks for helping.
Edited by: SuMMerMaN on Mar 10, 2010 12:14 PM
Edited by: SuMMerMaN on Mar 10, 2010 12:14 PM

SuMMerMaN wrote:
Well,it says;
possible loss of precision
found:double
required:int
switch (value/10.0)
^but i couldn't solve my problem,i have to use double command and it says "required:int"This is telling you that what goes inside the parentheses in switch(...) must be an int. So you need to either supply an int value, or cast the value that you do supply.

Similar Messages

  • Datasource connection with jboss, need help

    Hi friends,
    I am doing data source connection through Jboss (jboss-4.0.2) with mysql database. I am using java(j2sdk1.4.2_04). I have made all changes given in this link -- http://community.jboss.org/wiki/SetUpAMysqlDatasource
    After making changes I restart jboss properly, but when I am going to attempt to connection through class. it give following error.
    1.ERROR! Shared library ioser12 could not be found.
    Can't find SerialContextProvider
    When a create a diffrent new class, then give me this error.
    2. ERROR! Shared library ioser12 could not be found.
    Cannot get connection: javax.naming.CommunicationException: Can't find SerialContextProvider
    Kindly help me out for this problem.
    Thanks
    Abhishek Jain

    user13428037 wrote:
    ,,, JBoss ... give following error.
    1.ERROR! Shared library ioser12 could not be found.
    Can't find SerialContextProvider
    When a create a diffrent new class, then give me this error.
    2. ERROR! Shared library ioser12 could not be found.
    Cannot get connection: javax.naming.CommunicationException: Can't find SerialContextProviderPlease don't crosspost http://www.javaprogrammingforums.com/jdbc-databases/6353-datsource-connection-mysql-need-help.html#post22533
    The
    ERROR! Shared library ioser12 could not be found.error message has nothing to do with you adding a datasource.
    It would happen even before you made the datasource configuration changes.
    Looks like you added a j2ee.jar to the JBoss classpath.

  • HDMI switching with YV box - help?

    I am now in the unfortunate position of having a TV with only one HDMI input but currently have two boxes (YouView and NowTV) that output HDMI. The one scart input is used by the DVD player and I'm aware of scart-switch problems where YV boxes are concerned too.
    I bought a Duronics HDMI auto-switcher, it has three inputs and one output. I connected it up and the NowTV box displayed its bouncing logo fine. I switched on the YV box and got a pink screen. I tried unplugging the NowTV box from the mains, unplugging the HDMI lead etc. Cycling through the inputs using the manual switch - still the same pink screen, turned box on-off etc.
    Has anyone managed to use a HDMI switcher and if so how or which one and if it does work, does it always work without a problem? 
    For info: I have a BT supplied box (the first one they sent out, Humax ..), power set to the quicker starting one (eco-mode: Low??)

    I use a Thor combined HDMI/Optical switch with the YV box with no problem. Occasionally see a flash of pink when it switches then it settles down.
    Does this happen if you switch first before turning on the YV box (does your auto-switcher let you manually override to do this)?
    Have you re-tried plugging the HDMI lead direct into the TV as it maybe just a co-incidence this started happening when you introduced the switch?
    One other thing I suggest you try is swapping the HDMI leads between the YV box and the Now TV device.

  • How to use Crystal Report with Java - need help

    Dear everyone,
    i am completely new to Crystal report , please can anyone help me to creat a very simple Report using the Crystal report,
    the report will show some records from oracle DB.
    How can i make it by a simple example and with code please?
    do i need any JAR or Bean for Crystal report?
    thanks for your help and please don't hesitate to contact me in case of any inquiries.
    my email: [email protected]
    Thanks in advance

    I what to use Crystal report to generate report.My programe in java swing .Iam retrive table from database in Jtable .But when giving print
    command its print half screen .so that why I wantto usecrystal report
    package file2;
    import file2.choice;
    import java.awt.*;
    import java.awt.event.*;
    import javax.swing.*;
    import java.sql.*;
    import java.util.*;
    import java.awt.print.*;
    import javax.swing.table.*;
    import com.sun.java.swing.*;
    import javax.swing.JTable;
    public class cour extends JFrame implements Printable
         //Menu fileMenu;
         public static void main(String[] a)
    cour n = new cour();
    n.setVisible(true);
    public cour()
         super("Course Report");
         report();
         protected void report()
              JPanel panel = new JPanel();
         JButton printButton = new JButton("Print");
         panel.add(printButton);
         JButton exitButton = new JButton("Exit");
         panel.add(exitButton);     
         DefaultTableModel defaulttablemodel = new DefaultTableModel();
              JTable jtable = new JTable(defaulttablemodel);
              panel.add(new JScrollPane(jtable));
              String      tempname="";
              int tempcnt;
              String driver="sun.jdbc.odbc.JdbcOdbcDriver";
              String url="jdbc:odbc:regs";
              Object[] data = new Object[4];
              try
                             Class.forName(driver);                         
                             Connection connection=DriverManager.getConnection(url,"sa","");
                             Statement statement = connection.createStatement();     
                             String query = "SELECT courseid as CourseID,coursen as CourseName,cfee as Fee,coursed as Duration FROM course";
                             ResultSet rs = statement.executeQuery(query);     
                             ResultSetMetaData rmeta = rs.getMetaData();
                             int numColumns=rmeta.getColumnCount();                         
                             for(int i=1;i<=numColumns;i++)
                                  if(i<=numColumns)
                                       defaulttablemodel.addColumn(rmeta.getColumnName(i));
                             while(rs.next())
                                  for(int i=1;i<=numColumns;++i)
                                       if( i<=numColumns)
                                            tempname = rs.getString(i);
                                            tempcnt=i-1;
                                            data[tempcnt] = tempname;          
                                  defaulttablemodel.addRow(data);                              
                   catch(Exception ex)
              printButton.addActionListener(new ActionListener()
         public void actionPerformed(ActionEvent ae)
              /*if(ae.getActionCommand().equals("Print"))
              PrinterJob pj = PrinterJob.getPrinterJob();
              pj.setPrintable(cour.this);
              if (pj.printDialog())
              try
              pj.print();
              catch (PrinterException pe)
              System.out.println(pe);
    exitButton.addActionListener(new ActionListener()
         public void actionPerformed(ActionEvent ae)
              choice ch=new choice();
                   setVisible(false);
                   ch.setVisible(true);
    setContentPane(panel);
         setSize(1040,780);
    /*Dimension screenSize = Toolkit.getDefaultToolkit().getScreenSize();
    Dimension frameSize = getSize();
    int x = (screenSize.width - frameSize.width) / 2;
    int y = (screenSize.height - frameSize.height) / 2;
    setLocation(x, y);*/
    addWindowListener(new WindowAdapter() {
    public void windowClosing(WindowEvent e) {
    dispose();
    System.exit(0);
    public int print(Graphics g, PageFormat pf, int pageIndex)
    if (pageIndex != 0) return NO_SUCH_PAGE;
    Graphics2D g2 = (Graphics2D)g;
    g2.translate(pf.getImageableX(), pf.getImageableY());
    getContentPane().paint(g2);
    return PAGE_EXISTS;
    }

  • Help! I have a Used Mac Book Pro need help with apps update

    My ex bought me a mac book pro and purchased all of the apps and uploaded the apps under is apple id. I just recently update the new software now i can't get access to iPhoto, and other apps because its asking me for my password but his apple id coming up is there any way i re install these apps under my apple id. Please help I can used iPhoto.

    You cannot use or upgrade anything that is registered with his Apple ID. You must re-purchase it all using your Apple ID and your iTunes account. This includes the operating system as well. Essentially, you erase the drive and start from scratch. Here's how to get started:
    Install OS X Using Internet Recovery
    Be sure you backup your files to an external drive or second internal drive because the following procedure will remove everything from the hard drive.
    Boot to the Internet Recovery HD:
    Restart the computer and after the chime press and hold down the COMMAND-OPTION- R keys until a globe appears on the screen. Wait patiently - 15-20 minutes - until the Recovery main menu appears.
    Partition and Format the hard drive:
    Select Disk Utility from the main menu and click on the Continue button.
    After DU loads select your newly installed hard drive (this is the entry with the mfgr.'s ID and size) from the left side list. Click on the Partition tab in the DU main window.
    Under the Volume Scheme heading set the number of partitions from the drop down menu to one. Click on the Options button, set the partition scheme to GUID then click on the OK button. Set the format type to Mac OS Extended (Journaled.) Click on the Partition button and wait until the process has completed. Quit DU and return to the main menu.
    Reinstall OS X: Select Reinstall OS X and click on the Install button. Be sure to select the correct drive to use if you have more than one.
    Note: You will need an active Internet connection. I suggest using Ethernet if possible because it is three times faster than wireless.
    This should restore the version of OS X originally pre-installed on the computer. You can decide which apps you want to purchase (or download free) from the App Store where you will set up your own account and your own Apple ID if you don't have one.

  • MAC OS 10.6.8 Using Safari 5.1 Needing Help With Updating Adobe Flash

    Hello-
    Recently Adobe Flash installed an icon in my System Preferences and when I click the icon there are several tabs.  One allows updates to check automatically.  It says it will install the latest version of Flash without having to remove the previous version, but I have never been told that a newer version is available unless I clcik "check now."  although "Check for updates automatically" is checked, I do not know where it tells me a newer version is available.  Also, there has been 5 "newer versions" available since this icon was installed in System Prefeences, I have only found out about the newer versions when I clicked "Check Now."  If I read that with this new way to install the latest Mac version of Flash does not require me to uninstall the previous version of Flash how do I install the most recent version of Flash?  Does it come in an email?
    Since it is not telling me that there is a more recent version of Flash unless I click "Check Now" should I still do it the way I used to install the latest version of flash?  (The way before this icon was added to System Preferences)?
    I would appreciate help with updating Flash to the most recent version.  I used to uninstall the older version, restart the browser and download the most recent version and install it.  It always worked find but this was before there was an Adobe icon in my system Preferences.

    Hello,
    The way you used to do this (uninstall, restart the browser, etc.) is still definitely valid and probably the "safest" way to get a new version installed.  Uninstalling shouldn't be required, but it definitely doesn't hurt.  If you feel comfortable doing it the old way, please feel free to continue using that process.
    As for notifications, this is a bit trickier, but in general you should be notified within 30 days (or so) after a new player is released.  This usually occurs when the browser loads swf content.  Clicking the button will, like you mention, immediately check.  Another alternative to finding out when a new player is released is to subscribe to our Flash Player Releases feed.
    Is there a way to be automatically notified when a new Flash Runtime release is made?
    Thanks,
    Chris

  • Problem with routing - Need help

    Hello,
    I need a little direction with what I think is a routing problem. Any help will be appreciated. My setup is as follows:
    Cable Modem
    27.177.21.9
    WAN - Gi0/0
    27.177.21.10
    Cisco 2901
    LAN - Gi0/1
    192.168.1.250
    Client
    192.168.1.10
    The Problem
    Router can ping LAN interface
    Router cannot ping WAN interface -X
    Router can ping Cable Modem
    Client
    Client can ping LAN interface
    Client can ping WAN interface
    Client cannot ping Cable Modem -X
    Here is my routing table:
    Gateway of last resort is 27.177.21.9 to network 0.0.0.0 (this is my cable modem)
    S*    0.0.0.0/0 [1/0] via 27.177.21.9
                    is directly connected, GigabitEthernet0/0
          27.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C        27.177.21.8/30 is directly connected, GigabitEthernet0/0
    L        27.177.21.10/32 is directly connected, GigabitEthernet0/0
          192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
    C        192.168.1.0/24 is directly connected, GigabitEthernet0/1
    L        192.168.1.250/32 is directly connected, GigabitEthernet0/1
    Here is a portion of my configuration:
    interface GigabitEthernet0/0
     description Cable Internet$FW_OUTSIDE$$ETH-WAN$
     ip address 27.177.21.10 255.255.255.252
     zone-member security out-zone
     duplex auto
     speed auto
    interface GigabitEthernet0/1
     description hbc_staff$FW_INSIDE$$ETH-LAN$
     ip address 192.168.1.250 255.255.255.0
     zone-member security in-zone
     duplex auto
     speed auto
     no mop enabled
    ip default-gateway 27.177.21.9
    ip forward-protocol nd
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 600 life 86400 requests 10000
    ip route 0.0.0.0 0.0.0.0 27.177.21.9
    ip route 192.168.1.0 255.255.255.0 27.177.21.9
     Thanks in advance

    Hello Jon,
    I continue to try different configurations to get my router to connect without success. I am now trying NAT and this is where we stand now. Any help will be much appreciated.
    The problem
    Router now pings everything by ip address or name
    Client PC from inside the LAN cannot ping modem or Internet
    Relevant parts of configuration:
    ip domain name mydomain.org
    ip name-server 24.247.15.53
    ip name-server 66.189.0.100
    interface GigabitEthernet0/0
     description Internet$FW_OUTSIDE$ETH-WAN$
     ip address 27.177.21.10 255.255.255.252
     ip nat outside
     ip virtual-reassembly in
     duplex auto
     speed auto
    interface GigabitEthernet0/1
     description hbc_staff$FW_INSIDE$$ETH-LAN$
     ip address 192.168.1.250 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
     zone-member security in-zone
     duplex auto
     speed auto
     no mop enabled
    ip nat pool HBC-I 27.177.21.10 27.177.21.10 prefix-length 24
    ip nat inside source list 7 pool HBC-I overload
    ip route 0.0.0.0 0.0.0.0 27.177.21.9
    ip route 192.168.1.0 255.255.255.0 GigabitEthernet0/1
    access-list 7 permit 192.168.1.0 0.0.0.255
    #show ip route
    Gateway of last resort is 27.177.21.9 to network 0.0.0.0
    S*    0.0.0.0/0 [1/0] via 27.177.21.9
          27.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C        27.177.21.8/30 is directly connected, GigabitEthernet0/0
    L        27.177.21.10/32 is directly connected, GigabitEthernet0/0
          192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
    C        192.168.1.0/24 is directly connected, GigabitEthernet0/1
    L        192.168.1.250/32 is directly connected, GigabitEthernet0/1
    When pinging the modem from a client inside the LAN this is what I get from NAT translations and statistics:
    #sho ip nat translations ver
    Pro Inside global         Inside local          Outside local         Outside global
    icmp 27.177.21.10:40709   192.168.1.8:40709     27.177.21.9:40709     27.177.21.9:40709
        create 00:00:05, use 00:00:00 timeout:60000, left 00:00:59, Map-Id(In): 1, 
        flags: 
    extended, use_count: 0, entry-id: 4, lc_entries: 0
    #sho ip nat statistics
    Total active translations: 2 (0 static, 2 dynamic; 2 extended)
    Peak translations: 2, occurred 00:00:04 ago
    Outside interfaces:
      GigabitEthernet0/0
    Inside interfaces: 
      GigabitEthernet0/1
    Hits: 104  Misses: 0
    CEF Translated packets: 104, CEF Punted packets: 0
    Expired translations: 7
    Dynamic mappings:
    -- Inside Source
    [Id: 1] access-list 7 pool HBC-I refcount 2
     pool HBC-I: netmask 255.255.255.0
        start 27.177.21.10 end 27.177.21.10
        type generic, total addresses 1, allocated 1 (100%), misses 0
    Total doors: 0
    Appl doors: 0
    Normal doors: 0
    Queued Packets: 0

  • Problem with ichat, need help reinstalling.

    Hey guys, I'm new to mac so I need a little help.
    I did something last night to my comp and I'm not sure what it was. But when I click on the iChat icon it just comes up with a ? I search in spotlight and it's not there. I must have deleted it while getting rid of some other things. I don't have time machine and I need some help reinstalling. When I bought the mac it had Tiger and I still have those disc, but right now I have upgraded to Leopard. Where can I find iChat to reinstall? I looked on the iLife section of the Tiger discs but I couldn't find it. Any info will help.
    Thanks

    update
    I downloaded pacifist and got ichat to reinstall from my Tiger 10.4.9 disc, however, now when I try to open iChat it says, You cannot use the application “iChat” with this version of Mac OS X. I have leopard 10.5.2. Does anyone know how to update the version I have? I use the mac updater but it doesn't find anything.

  • Using own domain - newbie needs help!

    I've never created a webpage before, so bear with me! I've started one in iWeb and purchased my own domain from GoDaddy.com. I changed the CNAME per the directions of iWeb/me.com. However, my page is not being published under the personal domain name I purchased. The domain name is showing up on me.com under my webpages. I've "Published All to .Mac" and when it asks me to go to my site after it's published, I get the generic GoDaddy parked site for my personal domain. What else do I need to do to get this working? Sorry to be so ignorant, but any help would be appreciated!
    Thanks!!
    Message was edited by: hokie1998

    What you need to do to set-up CNAME is to firstly enter your domain name into the personal domain name option of MobileMe. If you look, you will see that www is already there, so you don't need to enter this, just yourdomainname.com or whatever and then confirm it in the second box and click on done and it will be set.
    You then need to go to your control panel settings at GoDaddy, where you got your domain name from. What you need is the DNS settings and your domain name should already show there. All are slightly different, but what you then need to do is enter www, then pick CNAME from a drop down menu or complete it and then either web.mac.com or web.me.com to redirect your domain name. This then means that you domain name will be forwarded to your iWeb site at web.mac.com.
    If you want a simpler way to do it, you can just use web forwarding instead, which means that you don't need to complete the personal domain in your MobileMe account. All you need do is go to the web forwarding section of your control panel at GoDaddy and enter your domain name and then forward it to web.mac.com/username/sitename or web.me.com/username/sitename.
    Remember that for CNAME forwarding you always forward to web.mac.com and for just forwarding you would enter web.mac.com/username/sitename.
    CNAME forwarding can take up to 24 hours to take effect, so you could have a wait, although most hosting companies are a lot quicker than this.

  • Frustrated with upgrade - NEED HELP

    I had a problem on my PowerBook PowerPC G4 when I updated to Safari 3.1.1
    Safari, Mail and the Software update would no longer run.
    Tried everything to no avail.
    Did an archive system install back to 10.4.6
    Now I am unable to update to 10.4.11
    I downloaded the Installer Package and when I run it I get the prompt:
    "You cannot install Mac OS X Update (PowerPC) on this volume.
    This volume does not meet the requirements for this update."
    What am I doing wrong?

    Here's another suggestion that will help in the future:
    Basic Backup
    Get an external Firewire drive at least equal in size to the internal hard drive and make (and maintain) a bootable clone/backup. You can make a bootable clone using the Restore option of Disk Utility. You can also make and maintain clones with good backup software. My personal recommendations are (order is not significant):
    1. Retrospect Desktop (Commercial - not yet universal binary)
    2. Synchronize! Pro X (Commercial)
    3. Synk (Backup, Standard, or Pro)
    4. Deja Vu (Shareware)
    5. PsynchX 2.1.1 and RsyncX 2.1 (Freeware)
    6. Carbon Copy Cloner (Freeware - 3.0 is a Universal Binary)
    7. SuperDuper! (Commercial)
    8. Intego Personal Backup (Commercial)
    9. Data Backup (Commercial)
    The following utilities can also be used for backup, but cannot create bootable clones:
    1. Backup (requires a .Mac account with Apple both to get the software and to use it.)
    2. Toast
    3. Impression
    4. arRSync
    Apple's Backup is a full backup tool capable of also backing up across multiple media such as CD/DVD. However, it cannot create bootable backups. It is primarily an "archiving" utility as are the other two.
    Impression and Toast are disk image based backups, only. Particularly useful if you need to backup to CD/DVD across multiple media.
    Visit The XLab FAQs and read the FAQs on maintenance, optimization, virus protection, and backup and restore. Also read How to Back Up and Restore Your Files.
    Although you can buy a complete FireWire drive system, you can also put one together if you are so inclined. It's relatively easy and only requires a Phillips head screwdriver (typically.) You can purchase hard drives separately. This gives you an opportunity to shop for the best prices on a hard drive of your choice. Reliable brands include Seagate, Hitachi, Western Digital, Toshiba, and Fujitsu. You can find reviews and benchmarks on many drives at Storage Review.
    Enclosures for FireWire and USB are readily available. You can find only FireWire enclosures, only USB enclosures, and enclosures that feature multiple ports. I would stress getting enclosures that use the Oxford chipsets (911, 921, 922, for example.) You can find enclosures at places such as;
    Cool Drives
    OWC
    WiebeTech
    Firewire Direct
    California Drives
    NewEgg
    All you need do is remove a case cover, mount the hard drive in the enclosure and connect the cables, then re-attach the case cover. Usually the only tool required is a small or medium Phillips screwdriver.

  • ITunes .dll error.  I can't use, uninstall, install iTunes - NEED HELP!

    I can't even start up iTunes anymore. I get "iTunes has encountered a problem and needs to close. We are sorry for the inconvenience." I can get details on the error but it's all Greek to me. Any insights/thoughts? Your help would be most appreciated!
    ibm t40   Windows XP Pro  

    If iTunes is crashing, why don't you send a crash log to those lazy Apple engineers.
    Typically, you'll need to configure Dr. Watson on your PC in order to generate crash logs. Windows start menu -> Run. Type in "cmd". Hit return. At the prompt in the command line window that comes up, type in
    drwtsn32 -i
    And hit return.
    This will create crash logs in Documents And Settings\All Users\Application Data\Microsoft\Dr Watson\. There'll usually be a file in here called "drwtsn32.log" If there's already a file there, it most likely has multiple crash logs in it (new crash logs are just appended to the end of the file). So, delete this file. This will make sure you're not sending extra information I don't need. These crash logs are text files, so you can open them in notepad or whatever to see what information you're sending.
    So, get the machine setup to collect crash logs, do the thing that makes iTunes crash. You need to send that file to our buddy Roy. Make sure that you include:
    (1) the drwtsn32.log file.
    (2) the link to this thread.
    (3) a one line description of your problem, i.e. "iTunes crashes on launch".
    (4) the username that you're using here in the discussion boards.
    Roy is getting a little swamped with messages and needs to make sure he gets all the information. And if he doesn't get that information, the message is just going to get dropped on the floor.

  • Need help with iPhoto, Need help with iPhoto

    Hey there!!!
    When I plug in my iPhone I go to iPhoto and can choose to import the pictures. I also tried Image Capture as it seemed easier to organise my pictures, making folders, sub-folders, etc. The problem with this is everytime I plug my iPhone into the computer click on Import the system automatically makes second, third, fourth, etc copies of each picture. This also means that there is a copy of my pictures on iPhoto and on Image Capture - which I do not really need.
    I have tried to make Albums and Folders on iPhoto. Sometimes when I delete a picture as it has been saved in two albums it gets deleted from both albums. Why is this? How can I make Albums or Folders to organise my pictures. If my pictures are transferred directly onto iPhoto, can I find them anywhere else in my computer? If I wanted to burn pictures from various albums on a disc how could I do that on iPhoto? Also I dont want events to create themselves. How can I avoid this?
    I would like help with either using iPhoto or know how the stop the duplicating of pictures on Image Capture.
    Maybe there is a better way I can transfer the pictures onto my MacBook??
    Thanks a mil!!!

    Are you running a "referenced" or "managed' library?
    Image Capture does not store phortos in it. It's an application for uploading photos to wherever you tell it to, either a folder on the hard drive or into iPhoto. If you want to use only Image Capture to upload your photos to iPhoto then set iPhoto's General preferences to the following:
    Deleting Photos from an iPhoto Library:
    1 - from an Event or the Photos mode: select the photo(s) and use the Delete key to move the photos to the trash bin. Then empty the iPhoto Trash bin as follows:
    2 - from an album, smart album, book, slideshow, card, etc.: select the photo(s) and use the key combination of Command+Option+Delete to move the photos to the trash bin.  Then empty the trash bin as above.
    NOTE: deleting a photo from an album, slideshow, book, etc., with only the Delete key only deletes that photo from that item. Deleting a photo from an Event deletes ALL occurances of that photo in the library.
    OT

  • Getting started with C# need help to know what I need to learn

    Good evening everybody, first time posting in this forum, so be gentle with my lack of knowledge about C#.
    A bit about me first, I'm a electronics student, with a strong C/C++ knowledge but geared toward micro-controllers(namely AVR's, PSoC and ARM Cortex-M3), now I want to make some nice GUI's for some electronic widgets and my main OS is Windows and
    C# seems to fit the bill for what I need to do, that is basic GUI's, serial com's and some graphing features do display simples x/y graphs.
    So, I'm in the process of designing a two stroke ignition system and I want to make a easy to use interface to re-program and visualize the ignition curve and some other parameters, so a simples program I think.
    My main idea/design is more or like the program made by the Ignitech company, I will post some example images so I can explain my self better. 
    The first picture shows the principal window for me, its a simple graph that is driven by the two tables that are over th graph, I would prefer to have a dynamic table(for example show only 8 positions or 10 ou 12, driven by another input box), and then
    the graph, and a couple tabs, in part so I can configure multi-curve ignitions, and to have a couple different "main" tabs, main configuration, the advance designer tab and a monitor tab(shown in the second picture).
    What I'm seeking is what functions/methods should I study and use to achieve this?
    I think I should say that I'm not copying anything from Ignitech, much less trying to make a "pirate" version of their software(its a free direct download from their site), its just a personal project.
    Best regards and thanks in advance.
    EDIT: For now I cannot post pictures(and links I assume), hope you guys and girls can get the mental image.

    Hi
    Keeepcool,
    I am sorry to tell you that this forum is only covering the C# programming language, IDE, libraries, samples, and tools. Since your issue is not clear to us. I will move your thread to "off-topic " forum. If you have any others issues about C#,
    Please feel free to post in this forum. Thanks for your understading.
    Best Wishes!
    Kristin
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click
    HERE to participate the survey.

  • Replacing 3COM 4500 switches with SG300-52 - help

    I'm replacing 2 3COM 4500 Swithes with the SG300-52 Cisco switch. We have 3 VLANs, 10, 20, 100. The switch is set for Layer 3 and I have setup DHCP relay. I was hoping someone might know what settings i should set on the Cisco for the following setups:
    3COM Setup
    interface GigabitEthernet1/0/1
    port link-type hybrid
    port hybrid vlan 10 tagged
    port hybrid vlan 1 20 100 untagged
    port hybrid pvid vlan 100
    My Cisco Translation
    interface gigabitethernet1
    switchport mode general
    switchport general allowed vlan add 10 tagged
    switchport general allowed vlan add 20,100 untagged
    switchport general pvid 100
    exit
    and one other example i'm curious if i set right..
    3COM Setup
    interface GigabitEthernet1/0/48
    port link-type trunk
    port trunk permit vlan all
    port trunk pvid vlan 100
    My Cisco Translation
    interface gigabitethernet51
    switchport trunk allowed vlan add 10,20
    switchport trunk native vlan 100
    exit
    Trying these settings I am not able to get any devices to work on the switch so i'm guessing i have something not setup correctly. Any help would be greatly appreciated..
    THanks,
    Chris

    Chris,
    Compared to your 3com switches yes the commands you currently ran are comparable. The reason it’s not working is a bigger question and we need a complete picture. First we need a topology(detailed as possible) of your network and details on how things need to work/setup? Then we can set up accordingly to the devices on your network. For quicker resolution call into the SBSC @ 1-866-606-18666 and open a support case .
    Thanks,
    Jasbryan

  • ISM with NAT44 - Need help with configuration

    Hello everyone,
    I'm trying to set up NAT44 in the following scenario below and I'm having a hard time figuring out how to redirect the traffic. As you can see the big problem is that I have one single interface that connects to the internal network (10.0.0.0/8) and also to the tunnel destinations all in the same VRF. Can you guys give me a hand? The trafiic comes from network network 10.0.0.0/8 enters interface bundle-ether 2 (Now it needs to be translated), once it is translated, now it needs to reach the destination known via GRE tunnel.
    Configurations
    vrf NAT_IN
    address-family ipv4 unicast
    vrf BLUE
    address-family ipv4 unicast
    hw-module service cgn location 0/3/CPU0
    interface Bundle-Ether2
    description UPLINK TO METRO ETHERNET
    interface Bundle-Ether2.2 l2transport
    encapsulation dot1q 2
    rewrite ingress tag pop 1 symmetric
    interface GigabitEthernet200/0/0/43
    description LINK TO METRO ETHERNET
    bundle id 2 mode active
    interface GigabitEthernet300/0/0/43
    description LINK TO METRO ETHERNET
    bundle id 2 mode active
    interface BVI2
    description METRO
    vrf BLUE
    ipv4 address 100.0.0.10/24
    interface tunnel-ip 101
    description GRE_TUNNEL
    vrf BLUE
    ipv4 address 1.1.1.1/32
    tunnel mode gre ipv4
    tunnel source interface bvi 2
    tunnel destination 200.0.0.1
    interface BVI 100
    vrf BLUE
    ipv4 address [GATEWAY_100] [MASK_100]
    interface BVI 200
    vrf BLUE
    ipv4 address [GATEWAY_200] [MASK_200]
    interface BVI 300
    vrf BLUE
    ipv4 address [GATEWAY_300] [MASK_300]
    interface ServiceApp1
    vrf NAT_IN
    ipv4 address 10.0.2.1 255.255.255.252
    service cgn CGN service-type nat44
    interface ServiceApp2
    vrf BLUE
    ipv4 address 10.0.2.2 255.255.255.252
    service cgn CGN service-type nat44
    interface ServiceInfra1
    ipv4 address 10.0.3.1 255.255.255.0
    service-location 0/3/CPU0
    router static
    address-family ipv4 unicast
    vrf NAT_IN
    address-family ipv4 unicast
    0.0.0.0/0 ServiceApp1
    10.0.0.0/8 vrf BLUE bvI 2 <NEXT HOP>
    vrf BLUE
    address-family ipv4 unicast
    172.16.0.0/24 ServiceApp2
    router ospf METRO
    vrf BLUE
    router-id [ROUTER_ID]
    redistribute bgp 65500 metric 100
    area 0
    interface bvi 2
    router ospf BLUE
    vrf BLUE
    router-id [ROUTER ID]
    redistribute bgp 65500 metric 100
    area 10
    interface BVI100
    interface BVI200
    interface BVI200
    router bgp 65500
    address-family ipv4 unicast
    address-family vpnv4 unicast
    vrf BLUE
    rd 65500:2
    address-family ipv4 unicast
    redistribute static
    redistribute ospf BLUE
    neighbor 1.1.1.2
    remote-as 64512
    ebgp-multihop 5
    address-family ipv4 unicast
    route-policy PASS in
    route-policy PASS out
    service cgn CGN
    service-location preferred-active 0/3/CPU0
    service-type nat44 nat44
    portlimit 20000
    inside-vrf NAT_IN
    map outside-vrf BLUE address-pool 172.16.0.0/24
    Thanks in advance,
    Renato

    Hi Somnath,
    Let's see if you can help with this new scenario. I want to extend this NAT configuration to a new site (BO1), but instead of using this entire setup with ASR9K, etc, I just want to use ASR9000v module and have this AS9K + ISM as the host. The first problem I see in this scenario is that I have the same 10.0.0.0/8 network in both sites, network which will access the same resources as the devices in the 10.0.0.0/8 in the main site.
    1) Do you think if I create a new inside VRF [NAT_IN1] would address this issue?
    2) Can I use the same outside VRF?
    Here is the configurations.
    !! IOS XR Configuration 4.3.1
    vrf NAT_IN
    address-family ipv4 unicast
      import route-target
       65500:2
       65500:3
      export route-target
       65500:3
    vrf RED
    address-family ipv4 unicast
      import route-target
       65500:1
      export route-target
       65500:1
    vrf NAT_OUT
    address-family ipv4 unicast
      import route-target
       65500:4
      export route-target
       65500:4
    vrf SATELLITE
    vrf BLUE
    address-family ipv4 unicast
      import route-target
       65500:2
      export route-target
       65500:2
    hw-module service cgn location 0/3/CPU0
    ipv4 access-list ABF
    5 permit ospf any any
    10 permit ipv4 any 10.200.0.0 0.0.255.255 nexthop1 vrf NAT_IN ipv4 10.0.2.2
    20 permit icmp any any
    interface Bundle-Ether3
    description Uplink (BE3 - VRF NAT_IN) - VLAN 20
    vrf NAT_IN
    ipv4 address 1.1.1.1 255.255.255.0
    ipv4 access-group ABF ingress
    interface Bundle-Ether22
    description LOOPBACK CABLE NAT_OUT
    vrf NAT_OUT
    ipv4 address 10.0.1.1 255.255.255.0
    interface Bundle-Ether23
    description LOOPBACK CABLE BLUE
    vrf BLUE
    ipv4 address 10.0.1.2 255.255.255.0
    interface 6
    description Uplink  (BE6 - Global) - VLAN 20,51,80-82
    interface 6.2
    ipv4 address 1.1.1.2 255.255.255.0
    encapsulation dot1q 2
    interface 6.51 l2transport
    description EFP - BE6 - VLAN 51
    encapsulation dot1q 51
    rewrite ingress tag pop 1 symmetric
    interface 6.80 l2transport
    description EFP - BE6 - VLAN 80
    encapsulation dot1q 80
    rewrite ingress tag pop 1 symmetric
    interface 6.81 l2transport
    description EFP - BE6 - VLAN 81
    encapsulation dot1q 81
    rewrite ingress tag pop 1 symmetric
    interface 6.82 l2transport
    description EFP - BE6 - VLAN 82
    encapsulation dot1q 82
    rewrite ingress tag pop 1 symmetric
    interface Bundle-Ether100
    description Bundle to Satellite 100
    vrf SATELLITE
    ipv4 point-to-point
    ipv4 unnumbered Loopback0
    nv
      satellite-fabric-link satellite 100
       remote-ports GigabitEthernet 0/0/0-43
    interface Bundle-Ether200
    description Bundle to Satellite 200
    vrf SATELLITE
    ipv4 point-to-point
    ipv4 unnumbered Loopback0
    nv
      satellite-fabric-link satellite 200
       remote-ports GigabitEthernet 0/0/0-43
    interface Bundle-Ether300
    description Bundle to Satellite 300
    vrf SATELLITE
    ipv4 point-to-point
    ipv4 unnumbered Loopback0
    nv
      satellite-fabric-link satellite 300
       remote-ports GigabitEthernet 0/0/0-35
    interface Loopback0
    description MGMT SATELLITE
    vrf SATELLITE
    ipv4 address 10.0.0.254 255.255.255.0
    interface tunnel-ip31101
    description BLUE-TUNNEL01
    vrf BLUE
    ipv4 address 10.200.253.90 255.255.255.252
    tunnel mode gre ipv4
    tunnel source 6.2
    tunnel destination 13.13.13.13
    interface tunnel-ip31102
    description BLUE-TUNNEL02
    vrf BLUE
    ipv4 address 10.200.253.94 255.255.255.252
    tunnel mode gre ipv4
    tunnel source 6.2
    tunnel destination 14.14.14.14
    interface tunnel-ip31103
    description RED-TUNNEL03
    vrf RED
    ipv4 address 10.200.253.90 255.255.255.252
    tunnel mode gre ipv4
    tunnel source 6.2
    tunnel destination 13.13.13.13
    interface tunnel-ip31104
    description RED-TUNNEL04
    vrf RED
    ipv4 address 10.200.253.94 255.255.255.252
    tunnel mode gre ipv4
    tunnel source 6.2
    tunnel destination 14.14.14.14
    interface TenGigE0/0/0/0
    description LINK TO SATELLITE 100
    bundle id 100 mode on
    interface TenGigE0/0/0/1
    description LINK TO SATELLITE 100
    bundle id 100 mode on
    interface TenGigE0/0/0/2
    description LINK TO SATELLITE 200
    bundle id 200 mode on
    interface TenGigE0/0/0/3
    description LINK TO SATELLITE 200
    bundle id 200 mode on
    interface TenGigE0/0/0/4
    description LINK TO SATELLITE 300
    vrf SATELLITE
    ipv4 point-to-point
    ipv4 unnumbered Loopback0
    nv
      satellite-fabric-link satellite 300
       remote-ports GigabitEthernet 0/0/36-43
    interface TenGigE0/0/0/5
    description LINK TO SATELLITE 300
    bundle id 300 mode on
    interface TenGigE0/0/0/16
    description UPLINK  (BE6 - GLOBAL) - VLAN 20,51,80-82
    bundle id 6 mode active
    interface TenGigE0/1/0/16
    description UPLINK  (BE6 - GLOBAL) - VLAN 20,51,80-82
    bundle id 6 mode active
    interface TenGigE0/0/0/17
    description UPLINK  (BE3 - VRF NAT_IN) - VLAN 20
    bundle id 3 mode active
    interface TenGigE0/1/0/17
    description UPLINK  (BE3 - VRF NAT_IN) - VLAN 20
    bundle id 3 mode active
    interface TenGigE0/0/0/22
    description LOOPBACK CABLE TE0/1/0/22
    bundle id 22 mode on
    interface TenGigE0/0/0/23
    description LOOPBACK CABLE TE0/1/0/23
    bundle id 22 mode on
    interface TenGigE0/1/0/0
    description LINK TO SATELLITE 100
    bundle id 100 mode on
    interface TenGigE0/1/0/1
    description LINK TO SATELLITE 100
    bundle id 100 mode on
    interface TenGigE0/1/0/2
    description LINK TO SATELLITE 200
    bundle id 200 mode on
    interface TenGigE0/1/0/3
    description LINK TO SATELLITE 200
    bundle id 200 mode on
    interface TenGigE0/1/0/4
    description LINK TO SATELLITE 300
    bundle id 300 mode on
    interface TenGigE0/1/0/5
    description LINK TO SATELLITE 300
    bundle id 300 mode on
    interface TenGigE0/1/0/22
    description LOOPBACK CABLE TE0/0/0/22
    bundle id 23 mode on
    interface TenGigE0/1/0/23
    description LOOPBACK CABLE TE0/0/0/23
    bundle id 23 mode on
    interface BVI30
    vrf RED
    ipv4 address 10.200.25.193 255.255.255.192
    interface BVI31
    vrf BLUE
    ipv4 address 10.200.1.1 255.255.255.248
    interface BVI32
    vrf BLUE
    ipv4 address 10.200.25.129 255.255.255.224
    interface BVI33
    vrf BLUE
    ipv4 address 10.200.25.1 255.255.255.128
    interface BVI36
    vrf BLUE
    ipv4 address 10.200.237.145 255.255.255.240
    interface BVI51
    vrf RED
    ipv4 address 192.168.7.12 255.255.255.0
    interface BVI80
    vrf RED
    ipv4 address 10.200.26.169 255.255.255.224
    interface BVI81
    vrf BLUE
    ipv4 address 10.200.25.164 255.255.255.240
    interface BVI82
    vrf BLUE
    ipv4 address 10.200.25.180 255.255.255.240
    interface ServiceApp1
    description NAT_IN
    vrf NAT_IN
    ipv4 address 10.0.2.1 255.255.255.252
    service cgn CGN service-type nat44
    interface ServiceApp2
    description NAT_OUT
    vrf NAT_OUT
    ipv4 address 10.0.2.5 255.255.255.252
    service cgn CGN service-type nat44
    interface ServiceInfra1
    description ISM
    ipv4 address 10.0.3.1 255.255.255.0
    service-location 0/3/CPU0
    prefix-set PS_ROUTES
      10.200.0.8,
      10.200.5.40/29,
      10.200.1.0/29,
      10.200.5.32/29,
      10.200.0.144/28,
      10.200.106.0/28,
      10.200.106.16/28
    end-set
    prefix-set PS_BGP_BLUE_OUT
      10.200.24.192/26,
      10.200.5.40/29,
      10.200.240.0/25,
      10.200.1.0/29,
      10.200.25.128/27,
      10.200.25.0/25,
      10.200.5.32/29,
      10.200.26.0/25,
      10.200.0.144/28,
      10.200.27.128/27,
      10.200.27.0/25,
      10.200.106.0/28,
      10.200.106.128/25,
      10.200.106.16/28,
      10.200.107.128/25
    end-set
    route-policy RP_DENY_ALL
      drop
    end-policy
    route-policy RP_PASS_ALL
      pass
    end-policy
    route-policy RP_BGP_BLUE_OUT
      if destination in PS_BGP_BLUE_OUT then
        pass
      endif
    end-policy
    route-policy RP_PASS_ROUTES
      if destination in PS_ROUTES then
        pass
      endif
    end-policy
    router static
    address-family ipv4 unicast
      0.0.0.0/0 1.1.1.20
    vrf NAT_IN
      address-family ipv4 unicast
       0.0.0.0/0 ServiceApp1
    vrf RED
    vrf NAT_OUT
      address-family ipv4 unicast
       0.0.0.0/0 10.0.1.2
       10.200.24.192/26 ServiceApp2
    vrf BLUE
      address-family ipv4 unicast
       10.200.24.192/26 10.0.1.1
    router ospf
    log adjacency changes
    vrf NAT_IN
      router-id 1.1.1.1
      disable-dn-bit-check
      redistribute bgp 65500 metric 5 metric-type 2 route-policy RP_PASS_ROUTES
      area 7
       interface Bundle-Ether3
    router ospf RED
    log adjacency changes
    vrf RED
      router-id 10.200.26.169
      disable-dn-bit-check
      redistribute bgp 65500 metric 10 metric-type 2
      area 11
       interface BVI30
       interface BVI80
    router ospf BLUE
    log adjacency changes
    vrf BLUE
      router-id 10.200.25.164
      disable-dn-bit-check
      redistribute static
      redistribute bgp 65500 metric 10 metric-type 2
      area 0
       interface BVI81
       interface BVI82
      area 2
       interface BVI31
       interface BVI32
       interface BVI33
       interface BVI36
    router bgp 65500
    address-family ipv4 unicast
    address-family vpnv4 unicast
    vrf NAT_IN
      rd 65500:3
      bgp router-id 1.1.1.1
      address-family ipv4 unicast
       route-target download
    vrf RED
      rd 65500:1
      bgp router-id 10.200.253.90
      address-family ipv4 unicast
       network 10.200.25.192/26
       network 10.200.26.128/27
       network 10.200.26.192/27
       network 10.200.27.192/26
       network 10.200.104.128/27
       network 10.200.104.160/27
      neighbor 10.200.253.89
       remote-as 64512
       ebgp-multihop 5
       update-source tunnel-ip31103
       address-family ipv4 unicast
        route-policy RP_PASS_ALL in
        route-policy RP_PASS_ALL out
        soft-reconfiguration inbound
      neighbor 10.200.253.93
       remote-as 64512
       ebgp-multihop 5
       update-source tunnel-ip31104
       address-family ipv4 unicast
        route-policy RP_PASS_ALL in
        route-policy RP_PASS_ALL out
        soft-reconfiguration inbound
    vrf BLUE
      rd 65500:2
      bgp router-id 10.200.253.90
      address-family ipv4 unicast
       network 10.200.0.144/28
       network 10.200.1.0/29
       network 10.200.5.32/29
       network 10.200.5.40/29
       network 10.200.24.192/26
       network 10.200.25.0/25
       network 10.200.25.128/27
       network 10.200.26.0/25
       network 10.200.27.0/25
       network 10.200.27.128/27
       network 10.200.106.0/28
       network 10.200.106.16/28
       network 10.200.106.128/25
       network 10.200.107.128/25
       network 10.200.240.0/25
      neighbor 10.200.253.89
       remote-as 64512
       ebgp-multihop 5
       update-source tunnel-ip31101
       address-family ipv4 unicast
        route-policy RP_PASS_ALL in
        route-policy RP_BGP_BLUE_OUT out
        soft-reconfiguration inbound
      neighbor 10.200.253.93
       remote-as 64512
       ebgp-multihop 5
       update-source tunnel-ip31102
       address-family ipv4 unicast
        route-policy RP_PASS_ALL in
        route-policy RP_BGP_BLUE_OUT out
        soft-reconfiguration inbound
    l2vpn
    load-balancing flow src-dst-ip
    bridge group VLAN30
      bridge-domain VLAN30
       routed interface BVI30
    bridge group VLAN31
      bridge-domain VLAN31
       routed interface BVI31
    bridge group VLAN32
      bridge-domain VLAN32
       routed interface BVI32
    bridge group VLAN33
      bridge-domain VLAN33
       routed interface BVI33
    bridge group VLAN36
      bridge-domain VLAN36
       routed interface BVI36
    bridge group VLAN51
      bridge-domain VLAN51
       routed interface BVI51
    bridge group VLAN80
      bridge-domain VLAN80
       interface 6.80
       routed interface BVI80
    bridge group VLAN81
      bridge-domain VLAN81
       interface 6.81
       routed interface BVI81
    bridge group VLAN82
      bridge-domain VLAN82
       interface 6.82
       routed interface BVI82
    nv
    satellite 100
      type asr9000v
      ipv4 address 10.0.0.1
    satellite 200
      type asr9000v
      ipv4 address 10.0.0.2
    satellite 300
      type asr9000v
      ipv4 address 10.0.0.3
    service cgn CGN
    service-location preferred-active 0/3/CPU0
    service-type nat44 nat44
      portlimit 20000
      inside-vrf NAT_IN
       map outside-vrf NAT_OUT address-pool 10.200.24.192/26
    Thanks in advance,
    Renato

Maybe you are looking for