Who can help me with a trigger?

Hi, I've got a little problem with my database that can be solved, or so I think, with a trigger. First of all, here it is.
create table utente
(id_utente number(5) Primary Key,
nome varchar2(40),
sexo varchar2(1) check (sexo='M' or sexo='F'),
morada varchar2(60),
     data_nascimento date,
     contacto number(10),
     numero_BI number(9)
create table servico
(id_servico number(5) Primary Key,
     descricao varchar2(40),
     valor number(5),
     data_inicio date,
data_fim date,
check (data_fim>=data_inicio)
create table modalidade
(id_modalidade number(5) Primary Key,
     descricao varchar2(40),
     valor number(5)
create table quarto
(id_quarto number(5) Primary Key,
     descricao varchar2(40)
create table inscricao_servico
(id_inscricao_servico number(5) Primary Key,
     id_servico number(5) references servico(id_servico),
     id_utente number(5) references utente(id_utente),
     data_pagamento date
create table inscricao_mod
(id_inscricao_mod number(5) Primary Key,
     id_modalidade number(5) references modalidade(id_modalidade),
     id_utente number(5) references utente(id_utente),
     data_inscricao date,
     data_cessacao date,
check (data_cessacao>data_inscricao)
create table estadia
(id_estadia number(5) Primary Key,
     id_utente number(5) references utente(id_utente),
     id_quarto number(5) references quarto(id_quarto),
     data_entrada date,
     data_saida date,
check (data_saida>data_entrada)
create table pag_mensalidade
     (id_pag_mensalidade number(5) Primary Key,
     id_inscricao_mod number(5) references inscricao_mod(id_inscricao_mod),
     mes_mensalidade number(6),
     data_pagamento date,
     unique (id_inscricao_mod,mes_mensalidade)
insert into utente values (1, 'Manel', 'M', 'Rua grande', to_date('80.02.02','yy.mm.dd'), 123456789, 687654321);
insert into utente values (2, 'Artur', 'M', 'Rua pequena', to_date('81.03.04', 'yy.mm.dd'), 223456789, 587654321);
insert into utente values (3, 'Cardoso', 'M', 'Rua estreita', to_date('82.04.05', 'yy.mm.dd'), 323456789, 487654321);
insert into utente values (4, 'Abílio', 'M', 'Rua larga', to_date('79.07.06', 'yy.mm.dd'), 423456789, 787654321);
insert into utente values (5, 'Antunes', 'M', 'Rua nova', to_date('79.06.01', 'yy.mm.dd'), 423557982, 387654822);
insert into modalidade values (1, 'Total', 800);
insert into modalidade values (2, 'Diurno ate 18', 600);
insert into modalidade values (3, 'Diurno ate 22', 700);
insert into quarto values (1, '412');
insert into quarto values (2, '413');
insert into quarto values (3, '414');
insert into quarto values (4, '415');
insert into quarto values (5, '416');
insert into servico values (1, 'Excursao a Fatima', 150, to_date('11.05.13', 'yy.mm.dd'), to_date('11.05.13', 'yy.mm.dd'));
insert into servico values (2, 'Ida ao cinema', 10, to_date('11.08.22', 'yy.mm.dd'), to_date('11.08.22', 'yy.mm.dd'));
insert into servico values (3, 'Apoio domiciliario', 100, to_date('11.07.01', 'yy.mm.dd'), to_date('11.07.31', 'yy.mm.dd'));
insert into estadia values (1, 1, 1, to_date('11.05.05', 'yy.mm.dd'), null);
insert into estadia values (2, 2, 2, to_date('10.01.02', 'yy.mm.dd'), null);
insert into estadia values (3, 3, 3, to_date('09.12.15', 'yy.mm.dd'), to_date('10.02.25', 'yy.mm.dd'));
insert into inscricao_mod values (1, 1, 1, to_date('09.12.15', 'yy.mm.dd'), null);
insert into inscricao_mod values (2, 2, 2, to_date('11.11.11', 'yy.mm.dd'), null);
insert into inscricao_mod values (3, 1, 3, to_date('10.04.10', 'yy.mm.dd'), to_date('11.09.21', 'yy.mm.dd'));
insert into inscricao_servico values (1, 1, 1, null);
insert into inscricao_servico values (2, 1, 2, to_date('11.10.01', 'yy.mm.dd'));
insert into inscricao_servico values (3, 2, 4, null);
insert into inscricao_servico values (4, 3, 5, to_date('10.12.12', 'yy.mm.dd'));
insert into pag_mensalidade values (1, 1, 201110, to_date('11.10.23', 'yy.mm.dd'));
insert into pag_mensalidade values (2, 2, 201111, to_date('11.11.27', 'yy.mm.dd'));
insert into pag_mensalidade values (3, 3, 201112, NULL);
insert into pag_mensalidade values (4, 1, 201111, NULL);
drop table estadia;
drop table inscricao_servico;
drop table quarto;
drop table pag_mensalidade;
drop table inscricao_mod;
drop table modalidade;
drop table servico;
drop table utente;
Ok, the problem is: the table 'estadia' means 'stay' and 'quarto' means 'room'. I need to, before inserting on 'estadia', to check if that room is available or not.
I may do this:
insert into estadia values (4, 3, *3*, to_date('09.12.15', 'yy.mm.dd'), to_date('10.02.25', 'yy.mm.dd'));
but if, after this command, i do this:
insert into estadia values (5, 4, *3*, to_date('09.12.15', 'yy.mm.dd'), to_date('10.02.25', 'yy.mm.dd'));
it accepts and it shouldn't, because I'm putting users 3 and 4 in the same room at the same time.
the 3rd field is the room id and the next two fields are the entry date (data_entrada) and the exit date (data_saida). If a room is related to a specific stay in which the exit date hasn't gone by, that room shouldn't be available. Also, the exit date may be null, meaning that the exit date is unknown.
I hope to have been clear about my question.
Thanks, Chiapa

This is a fairly easy business rule which can be implemented using triggers. Here goes.
Tables (my version):
drop table stay;
drop table room;
create table room
(room_id     number not null primary key
,other_col     varchar2(10) not null)
create table stay
(stay_id     number not null primary key
,room_id     number not null references room(room_id)
,arrive          date not null check(trunc(arrive)=arrive)
,depart          date          check(trunc(depart)=depart)
,unique (room_id,arrive)
,check(arrive <= depart))
/The rule you are trying to implement is this one:
create or replace assertion no_overlap as
check(not exists
        (select 'two overlapping stays for a room'
         from stay s1
             ,stay s2
         where s1.room_id = s2.room_id
           and s1.stay_id != s2.stay_id
           and (s1.arrive between s2.arrive and nvl(s2.depart,s1.arrive) or
                s1.depart between s2.arrive and nvl(s2.depart,s1.depart))
/Sometime in a far far away future, we may be done now. That future has still to arrive though.
So here's the trigger-code and supporting objects:
create or replace procedure p_get_Lock(p_lockname    in varchar2) as
pl_id number(38);
pl_return number;
pl_timeout number := 0;
begin
  -- Go get a unique lockhandle for this lockname.
  pl_id := dbms_utility.get_hash_value(name      => p_lockname
                                      ,base      => 1
                                      ,hash_size => power(2,30));
  -- Request the application lock in X-mode.
  pl_return :=
  dbms_lock.request(id                => pl_id
                   ,lockmode          => dbms_lock.ssx_mode
                   ,timeout           => pl_timeout
                   ,release_on_commit => true);
  if pl_return not in (0,4)
  then
    raise_application_error(-20000,'Could not serialize for business rule.');
  end if;
end;
create global temporary table stay_te
(room_id     number not null)
create or replace trigger stay_aiur
after insert or update on stay
for each row
begin
  if inserting or
     (updating and (:new.room_id != :old.room_id or
                    :new.arrive < :old.arrive or
                    :new.depart > :old.depart))
  then
    insert into stay_te(room_id) values(:new.room_id);
  end if;
end;
create or replace trigger stay_aius
after insert or update on stay
begin
  for r in (select distinct room_id
            from stay_te)
  loop
    p_get_lock(to_char(r.room_id));
    declare
      p_error varchar2(80);
    begin
      select 'Overlapping stays for room '||to_char(r.room_id)||'.'
      into p_error
      from dual
      where exists
        (select 'two overlapping stays for a room'
         from stay s1
             ,stay s2
         where s1.room_id = s2.room_id
           and s1.room_id = r.room_id
           and s1.stay_id != s2.stay_id
           and (s1.arrive between s2.arrive and nvl(s2.depart,s1.arrive) or
                s1.depart between s2.arrive and nvl(s2.depart,s1.depart))
      raise_application_error(-20000,p_error);
    exception when no_data_found then
      null;
    end;
  end loop;
  delete from stay_te;
end;
/Haven't tested it, but I think it's all okay.

Similar Messages

  • I will pay for who can help me with this applet

    Hi!, sorry for my english, im spanish.
    I have a big problem with an applet:
    I�ve make an applet that sends files to a FTP Server with a progress bar.
    Its works fine on my IDE (JBuilder 9), but when I load into Internet Explorer (signed applet) it crash. The applet seems like blocked: it show the screen of java loading and dont show the progress bar, but it send the archives to the FTP server while shows the java loading screen.
    I will pay with a domain or with paypal to anyone who can help me with this problematic applet. I will give my code and the goal is only repair the applet. Only that.
    My email: [email protected]
    thanks in advance.
    adios!

    thaks for yours anwswers..
    harmmeijer: the applet is signed ok, I dont think that is the problem...
    itchyscratchy: the server calls are made from start() method. The applet is crashed during its sending files to FTP server, when finish, the applet look ok.
    The class I use is FtpBean: http://www.geocities.com/SiliconValley/Code/9129/javabean/ftpbean/
    (I test too with apache commons-net, and the same effect...)
    The ftp is Filezilla in localhost.
    This is the code, I explain a little:
    The start() method calls iniciar() method where its is defined the array of files to upload, and connect to ftp server. The for loop on every element of array and uploads a file on subirFichero() method.
    Basicaly its this.
    The HTML code is:
    <applet
           codebase = "."
           code     = "revelado.Upload.class"
           archive  = "revelado.jar"
           name     = "Revelado"
           width    = "750"
           height   = "415"
           hspace   = "0"
           vspace   = "0"
           align    = "middle"
         >
         <PARAM NAME="usern" VALUE="username">
         </applet>
    package revelado;
    import java.awt.*;
    import java.awt.event.*;
    import java.applet.*;
    import javax.swing.*;
    import java.io.*;
    import javax.swing.border.*;
    import java.net.*;
    import ftp.*;
    public class Upload
        extends Applet {
      private boolean isStandalone = false;
      JPanel jPanel1 = new JPanel();
      JLabel jLabel1 = new JLabel();
      JLabel jlmensaje = new JLabel();
      JLabel jlarchivo = new JLabel();
      TitledBorder titledBorder1;
      TitledBorder titledBorder2;
      //mis variables
      String DIRECTORIOHOME = System.getProperty("user.home");
      String[] fotos_sel = new String[1000]; //array of selected images
      int[] indice_tamano = new int[1000]; //array of sizes
      int[] indice_cantidad = new int[1000]; //array of quantitys
      int num_fotos_sel = 0; //number of selected images
      double importe = 0; //total prize
      double[] precios_tam = {
          0.12, 0.39, 0.60, 1.50};
      //prizes
      String server = "localhost";
      String username = "pepe";
      String password = "pepe01";
      String nombreusuario = null;
      JProgressBar jProgreso = new JProgressBar();
      //Obtener el valor de un par�metro
      public String getParameter(String key, String def) {
        return isStandalone ? System.getProperty(key, def) :
            (getParameter(key) != null ? getParameter(key) : def);
      //Construir el applet
      public Upload() {
      //Inicializar el applet
      public void init() {
        try {
          jbInit();
        catch (Exception e) {
          e.printStackTrace();
      //Inicializaci�n de componentes
      private void jbInit() throws Exception {
        titledBorder1 = new TitledBorder("");
        titledBorder2 = new TitledBorder("");
        this.setLayout(null);
        jPanel1.setBackground(Color.lightGray);
        jPanel1.setBorder(BorderFactory.createEtchedBorder());
        jPanel1.setBounds(new Rectangle(113, 70, 541, 151));
        jPanel1.setLayout(null);
        jLabel1.setFont(new java.awt.Font("Dialog", 1, 16));
        jLabel1.setText("Subiendo archivos al servidor");
        jLabel1.setBounds(new Rectangle(150, 26, 242, 15));
        jlmensaje.setFont(new java.awt.Font("Dialog", 0, 10));
        jlmensaje.setForeground(Color.red);
        jlmensaje.setHorizontalAlignment(SwingConstants.CENTER);
        jlmensaje.setText(
            "Por favor, no cierre esta ventana hasta que termine de subir todas " +
            "las fotos");
        jlmensaje.setBounds(new Rectangle(59, 49, 422, 30));
        jlarchivo.setBackground(Color.white);
        jlarchivo.setBorder(titledBorder2);
        jlarchivo.setHorizontalAlignment(SwingConstants.CENTER);
        jlarchivo.setBounds(new Rectangle(16, 85, 508, 24));
        jProgreso.setForeground(new Color(49, 226, 197));
        jProgreso.setBounds(new Rectangle(130, 121, 281, 18));
        jPanel1.add(jlmensaje, null);
        jPanel1.add(jlarchivo, null);
        jPanel1.add(jProgreso, null);
        jPanel1.add(jLabel1, null);
        this.add(jPanel1, null);
        nombreusuario = getParameter("usern");
      //Iniciar el applet
      public void start() {
        jlarchivo.setText("Start() method...");
        iniciar();
      public void iniciar() {
        //init images selected array
        fotos_sel[0] = "C:/fotos/05160009.JPG";
        fotos_sel[1] = "C:/fotos/05160010.JPG";
        fotos_sel[2] = "C:/fotos/05160011.JPG";
         // etc...
         num_fotos_sel=3; //number of selected images
        //conectar al ftp (instanciar clase FtpExample)
        FtpExample miftp = new FtpExample();
        miftp.connect();
        //make the directory
         subirpedido(miftp); 
        jProgreso.setMinimum(0);
        jProgreso.setMaximum(num_fotos_sel);
        for (int i = 0; i < num_fotos_sel; i++) {
          jlarchivo.setText(fotos_sel);
    jProgreso.setValue(i);
    subirFichero(miftp, fotos_sel[i]);
    try {
    Thread.sleep(1000);
    catch (InterruptedException ex) {
    //salida(ex.toString());
    jlarchivo.setText("Proceso finalizado correctamente");
    jProgreso.setValue(num_fotos_sel);
    miftp.close();
    //Detener el applet
    public void stop() {
    //Destruir el applet
    public void destroy() {
    //Obtener informaci�n del applet
    public String getAppletInfo() {
    return "Subir ficheros al server";
    //Obtener informaci�n del par�metro
    public String[][] getParameterInfo() {
    return null;
    //sube al ftp (a la carpeta del usuario) el archivo
    //pedido.txt que tiene las lineas del pedido
    public void subirpedido(FtpExample miftp) {
    jlarchivo.setText("Iniciando la conexi�n...");
    //make folder of user
    miftp.directorio("www/usuarios/" + nombreusuario);
    //uploads a file
    public void subirFichero(FtpExample miftp, String nombre) {
    //remote name:
    String nremoto = "";
    int lr = nombre.lastIndexOf("\\");
    if (lr<0){
    lr = nombre.lastIndexOf("/");
    nremoto = nombre.substring(lr + 1);
    String archivoremoto = "www/usuarios/" + nombreusuario + "/" + nremoto;
    //upload file
    miftp.subir(nombre, archivoremoto);
    class FtpExample
    implements FtpObserver {
    FtpBean ftp;
    long num_of_bytes = 0;
    public FtpExample() {
    // Create a new FtpBean object.
    ftp = new FtpBean();
    // Connect to a ftp server.
    public void connect() {
    try {
    ftp.ftpConnect("localhost", "pepe", "pepe01");
    catch (Exception e) {
    System.out.println(e);
    // Close connection
    public void close() {
    try {
    ftp.close();
    catch (Exception e) {
    System.out.println(e);
    // Go to directory pub and list its content.
    public void listDirectory() {
    FtpListResult ftplrs = null;
    try {
    // Go to directory
    ftp.setDirectory("/");
    // Get its directory content.
    ftplrs = ftp.getDirectoryContent();
    catch (Exception e) {
    System.out.println(e);
    // Print out the type and file name of each row.
    while (ftplrs.next()) {
    int type = ftplrs.getType();
    if (type == FtpListResult.DIRECTORY) {
    System.out.print("DIR\t");
    else if (type == FtpListResult.FILE) {
    System.out.print("FILE\t");
    else if (type == FtpListResult.LINK) {
    System.out.print("LINK\t");
    else if (type == FtpListResult.OTHERS) {
    System.out.print("OTHER\t");
    System.out.println(ftplrs.getName());
    // Implemented for FtpObserver interface.
    // To monitor download progress.
    public void byteRead(int bytes) {
    num_of_bytes += bytes;
    System.out.println(num_of_bytes + " of bytes read already.");
    // Needed to implements by FtpObserver interface.
    public void byteWrite(int bytes) {
    //crea un directorio
    public void directorio(String nombre) {
    try {
    ftp.makeDirectory(nombre);
    catch (Exception e) {
    System.out.println(e);
    public void subir(String local, String remoto) {
    try {
    ftp.putBinaryFile(local, remoto);
    catch (Exception e) {
    System.out.println(e);
    // Main
    public static void main(String[] args) {
    FtpExample example = new FtpExample();
    example.connect();
    example.directorio("raul");
    example.listDirectory();
    example.subir("C:/fotos/05160009.JPG", "/raul/foto1.jpg");
    //example.getFile();
    example.close();

  • I need to download ferefox 9.0 but I cannot find it anywhere. Who can help me with this?

    I need to download ferefox 9.0 but I cannot find it anywhere. Who can help me with this?

    Please note that running out of date versions of Firefox is not recommended, as you will open yourself up to known security issues, alongside bugs and other issues. Is there a specific problem you are having with Firefox that I can help you with?
    You can download Firefox 9 at [http://ftp://ftp.mozilla.org/pub/firefox/releases/9.0.1/win32/en-US/ ftp://ftp.mozilla.org/pub/firefox/releases/9.0.1/win32/en-US/]

  • Who can help me with my ORDER?!

    I had made an online order for my iphone 5s on 11/15 online. It showed that will be delivery by 11/19. I  had recived the email with conformation # as quickly, but it always show "being processed, check it back tomorrow" in my order status. I have checked the local store, and they have the device in stock. So, I may want to cancel the order and get it in local store.
    However, I called to the customer serving for all day. They always told me to transfer me to another department. The only time, they said it would not cancelled during the status was being processed and also do a transfer to another deparmenrt. but There is always being No Agents Avilable for each time!!
    The chat live will not help you to do anything, except provide a phone number and let you call them.
    Now, my status still not changing, and I have no idea to who i can communited with this issue.
    Who can help me ?? How can I cancel it or to know anything about my order without only waste time for waiting and calling.

    >Post deleted to remove personal info<
    MODERATOR COMMENT: This is a public peer to peer (customer to customer) Community.
    Please call 800-922-0204 concerning your order
    Sent via the Samsung Galaxy Note® II, an AT&T 4G LTE smartphone
    Message was edited by: Verizon Moderator><

  • Is there really no one who can help me with my question postet 3 days ago!?

    I have a problem with blurry images after publishing -Am I really the only one who thinks this is a big problem -I tried to get some help 3 days ago? Is there other forums that can help me on this topic?
    It looks fine in iweb, but not in the browser after publishing... I'ts only with small logo images with hard graphichs in jpeg, its not my compression, it looks fine before publishing...

    dear wyodor, I thought that I explained my problem all right in my post? well,
    when I put a logo in the corner of my site -in my case a jpg file with some text, it looks good in iweb, but after publishing its not possible to read the small text because of the way iweb compress photos - my question is -can I do anything to keep the jpeg-compression i made i photoshop? Is there no way in iweb to control the compression? Its really frustrating -and the only really problem I have with iweb
    se how my logo looks im my site:
    http://web.mac.com/pierrienevoldsen/24x36.dk/om_24x36.dk.html
    I have the same logo twice now just to check different advises, but still its impossible to read the small lettes -but not in iweb

  • Who can HELP me with an seemingly impossible iTunes dilemma?

    Good day all and greetings from Malta (EU),
    I have what seems to be the need for an "impossible" solution. Let me explain my dilemma.
    I have never wanted to use the new versions of iTunes past 10.7 for ONLY ONE simple reason that the developers of iTunes have decided to eliminate.
    I am a digital dj - I use iTunes as my cataloging system for all the tracks I play. I am the kind of person that likes to prepare as much as possible before I play. Up till 10.7 there was an option to open MULTIPLE playlist windows. This was very important to me because that would mean practically that how ever the mood moved on the dance floor I was able to just choose from the open playlist windows without having to spend needless time searching for them while playing (which can be a big distraction)
    I have recently purchased my FIRST Mac (17" MacbookPro) and I have Yosemite running on it. I have followed tutorials to downgrade iTunes (using Pacifier & AppZapper) to 10.7 in order to get the only one feature I needed but was not available in future upgrades.
    I have a few problems. When I connect my iPhone it is not recognised and when I use the finder window I constantly get error messages popping up.
    So here's the thing. I DON'T mind re-installing the updated version of iTunes to make the OS run properly and to connect my iPhone but I can't do this without the old version as well.
    Is there a way to be able to rename the 10.7 version of iTunes so I can continue using that and it's own library AND also be able to install the latest iTunes so I can eliminate my problems and continue using the 10.7 version. I can point out that the updated version does not need to have the same library... I'd ONLY need that to eliminate the error messages & be able to connect my devices.
    can ANYONE PLEASE PLEASE help me with this dilemma? I searched "high and low" on Google and in the Apple Support Forum but I have failed to find an solution....
    Thanks and I am sooooo looking forward to someone helping me as soon as possible.
    And Happy Holidays EVERYONE!!!
    Chris Brown

    You could repartition your drive to have a different OS X with the older iTunes there, and the newer iTunes on the existing partition. Back up everything beforehand. See Kappy's advice in this thread. Partitioning my Hard Drive

  • Who can help me with this form?

    Having some problems with the form ive placed on my site.
    I cant find the problem. Is there someone who can tell me what i have done wrong.
    you can see the form on.
    http://www.salontouche.nl/explorers.htm
    and the error i get is..
    Oops! This page appears broken. DNS Error - Server cannot be found.
    hope to get some advice..
    this is the contactscript..
    <?php error_reporting(0);
        // VALUES FROM THE FORM
        $name        = $_POST['name'];
        $email        = $_POST['email'];
        $message    = $_POST['msg'];
        // ERROR & SECURITY CHECKS
        if ( ( !$email ) ||
             ( strlen($_POST['email']) > 200 ) ||
             ( !preg_match("#^[A-Za-z0-9](([_\.\-]?[a-zA-Z0-9]+)*)@([A-Za-z0-9]+)(([\.\-]?[a-zA-Z0-9]+)* )\.([A-Za-z]{2,})$#", $email) )
            print "Error: Invalid E-Mail Address";
            exit;
        if ( ( !$name ) ||
             ( strlen($name) > 100 ) ||
             ( preg_match("/[:=@\<\>]/", $name) )
            print "Error: Invalid Name";
            exit;
        if ( preg_match("#cc:#i", $message, $matches) )
            print "Error: Found Invalid Header Field";
            exit;
        if ( !$message )
            print "Error: No Message";
            exit;
    if ( strpos($email,"\r") !== false || strpos($email,"\n") !== false ){ 
            print "Error: Invalid E-Mail Address";
            exit;
        if (FALSE) {
            print "Error: You cannot send to an email address on the same domain.";
            exit;
        // CREATE THE EMAIL
        $headers    = "Content-Type: text/plain; charset=iso-8859-1\n";
        $headers    .= "From: $name <$email>\n";
        $recipient    = "[email protected]";
        $subject    = "Reactie van uw Website";
        $message    = wordwrap($message, 1024);
        // SEND THE EMAIL TO YOU
        mail($recipient, $subject, $message, $headers);
        // REDIRECT TO THE THANKS PAGE
        header("Location: http://www.salontouche.nl/thanks.php");
    ?>
    regards

    Having some problems with the form ive placed on my site.
    I cant find the problem. Is there someone who can tell me what i have done wrong.
    you can see the form on.
    http://www.salontouche.nl/explorers.htm
    and the error i get is..
    Oops! This page appears broken. DNS Error - Server cannot be found.
    hope to get some advice..
    this is the contactscript..
    <?php error_reporting(0);
        // VALUES FROM THE FORM
        $name        = $_POST['name'];
        $email        = $_POST['email'];
        $message    = $_POST['msg'];
        // ERROR & SECURITY CHECKS
        if ( ( !$email ) ||
             ( strlen($_POST['email']) > 200 ) ||
             ( !preg_match("#^[A-Za-z0-9](([_\.\-]?[a-zA-Z0-9]+)*)@([A-Za-z0-9]+)(([\.\-]?[a-zA-Z0-9]+)* )\.([A-Za-z]{2,})$#", $email) )
            print "Error: Invalid E-Mail Address";
            exit;
        if ( ( !$name ) ||
             ( strlen($name) > 100 ) ||
             ( preg_match("/[:=@\<\>]/", $name) )
            print "Error: Invalid Name";
            exit;
        if ( preg_match("#cc:#i", $message, $matches) )
            print "Error: Found Invalid Header Field";
            exit;
        if ( !$message )
            print "Error: No Message";
            exit;
    if ( strpos($email,"\r") !== false || strpos($email,"\n") !== false ){ 
            print "Error: Invalid E-Mail Address";
            exit;
        if (FALSE) {
            print "Error: You cannot send to an email address on the same domain.";
            exit;
        // CREATE THE EMAIL
        $headers    = "Content-Type: text/plain; charset=iso-8859-1\n";
        $headers    .= "From: $name <$email>\n";
        $recipient    = "[email protected]";
        $subject    = "Reactie van uw Website";
        $message    = wordwrap($message, 1024);
        // SEND THE EMAIL TO YOU
        mail($recipient, $subject, $message, $headers);
        // REDIRECT TO THE THANKS PAGE
        header("Location: http://www.salontouche.nl/thanks.php");
    ?>
    regards

  • Who can help me with my IPHONE4S unlock thank you.

    I was a few years ago in the United States work in Chinese, because the marriage, so coming back to China, I back to the iphone4s verzion customization, I do not have a verzion account, but returned to find the mobile phone is locked, and can not be used, please verzion untie me in the United States the United States, I also give my labor, although iphone4s on you nothing, but for me is a luxury, if has the opportunity I will continue for the United States to provide labor, verzion call upon you to help me with this help, very grateful for that my city, <MEID and email address deleted per the Terms of Service> thank you
    Message was edited by: Verizon Moderator

    Verizon may or may not be able to unlock your phone anymore. It is a service provided to their customers. People may think they can buy an iphone at a deep discount and leave the country forever without paying any cancelation fee. Try Apple stores to see if they can help you.

  • Who can help me with spice model thx

    i have download a power mosfet spice model, then creat a new component in multisim
    i copy the model directly into multisim but it does't work
    who can tell me causation, or tell me how can i trun it to multisim model
    thanks very much
    spice model:
    * PSpice Model Editor - Version 9.2.1
    *$
    *DEVICE=IXFN36N100,NMOS
    * IXFN36N100 NMOS model
    * updated using Model Editor release 9.2.1 on 03/06/04 at 13:01
    * The Model Editor is a PSpice product hem.
    .MODEL IXFN36N100 NMOS
    + LEVEL=3
    + L=2.0000E-6
    + W=52
    + KP=1.0353E-6
    + RS=10.000E-3
    + RD=.22254
    + VTO=4.7737
    + RDS=10.000E6
    + TOX=2.0000E-6
    + CGSO=208.54E-12
    + CGDO=7.5038E-12
    + CBD=23.424E-9
    + MJ=1.5000
    + PB=3
    + RG=10.000E-3
    + IS=8.8150E-6
    + N=2.2584
    + RB=1.0000E-9
    + GAMMA=0
    + KAPPA=0
    *$

    Like I told another user I am no expert on model files. I have tried this file and Multisim will not recongnize it. I would recommend the following procedure if you can do it. Go into the component wizard and create a default Mosfet Using the Model Makers.. This will give you the correct syntax for the model file that Multsim can understand. If you know what the parameters mean from Pspice file then you can edit the model after it is created for you in Multisim and plug the numbers into it from the Pspice file. This should create a model that would work in Multisim. This procedure is theoretical on my part and you would have to try it to see if it works for you. It is possible that you don't have the Model Makers depending on your version of Multisim. If that is the case then we will have to try another approach.
    I do not know the meaning of the Pspice parameters (i.e what does the L=XXXXX  and N=XXXXX actual stand for). If you are unable to do this then maybe the NI Team can decipher this for you and post a model file that would work for you.
    I am going to have to study the various parameter on these files to find out their meaning  so I can be of better assistance when it comes to these model files. Right now I just don't have the time since I recently acquired a job that takes up a fair chunk of my days. I will contin ue looking into this as times permits for me.
    Message Edited by lacy on 11-11-2007 07:40 AM
    Kittmaster's Component Database
    http://ni.kittmaster.com
    Have a Nice Day

  • I will PAYPAL 100 bucks to the person who can help me with 5510 issue

    Below is a on going chat i am having with a PIX expert... Can anyone see where the problem is when you read the message below???
    Cisco ASA 5510 configuration for host inside private network
    Question: We have a Citrix host behind a new 5510 that needs to be accessed by the public. I have tried to follow the examples on cisco.com but still continue to get errors. I KNOW I am missing something simple. I have taken out all my 'tries' and have basic config below with errors.
    I am new to PIX/ASA and would live some suggestions on the proper Access Group and corresponding ACL to get the 192.168.71.100/72.54.197.26 Citrix server to accept ssl from outside.
    ASA Version 7.0(8)
    interface Ethernet0/0
    description Outside interface to Cbeyond
    nameif OUTSIDE
    security-level 0
    ip address 72.54.197.28 255.255.255.248
    interface Ethernet0/1
    description Inside interface to internal network
    nameif INSIDE
    security-level 100
    ip address 192.168.72.2 255.255.255.0
    interface Ethernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    ip address 192.168.71.2 255.255.255.0
    management-only
    object-group service Citrix1494 tcp
    port-object eq citrix-ica
    port-object eq www
    port-object eq https
    port-object range 445 447
    nat-control
    global (OUTSIDE) 1 interface
    nat (INSIDE) 1 0.0.0.0 0.0.0.0
    static (OUTSIDE,INSIDE) 192.168.72.100 72.54.197.26 netmask 255.255.255.255
    static (INSIDE,OUTSIDE) 72.54.197.26 192.168.72.100 netmask 255.255.255.255
    route OUTSIDE 0.0.0.0 0.0.0.0 72.54.197.25 100
    http server enable
    http 192.168.71.0 255.255.255.0 management
    class-map inspection_default
    match default-inspection-traffic
    policy-map global_policy
    class inspection_default
      inspect dns maximum-length 512
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
    Error Log:
    3|Apr 15 2011 21:06:07|305005: No translation group found for tcp src INSIDE:192.168.72.75/57508 dst OUTSIDE:72.54.197.26/443
    3|Apr 15 2011 21:06:01|305005: No translation group found for tcp src INSIDE:192.168.72.75/57508 dst OUTSIDE:72.54.197.26/443
    3|Apr 15 2011 21:05:58|305005: No translation group found for tcp src INSIDE:192.168.72.75/57508 dst OUTSIDE:72.54.197.26/443
    5|Apr 15 2011 21:05:42|111008: User 'root' executed the 'no access-list OUTSIDE_access_in extended permit tcp host 72.54.197.26 host 72.54.197.26' command.
    4|Apr 15 2011 21:05:20|106023: Deny tcp src OUTSIDE:114.38.58.208/2817 dst INSIDE:72.54.197.26/445 by access-group "OUTSIDE_access_in"
    4|Apr 15 2011 21:05:17|106023: Deny tcp src OUTSIDE:114.38.58.208/2817 dst INSIDE:72.54.197.26/445 by access-group "OUTSIDE_access_in"
    4|Apr 15 2011 21:04:37|106023: Deny tcp src OUTSIDE:221.1.220.185/12200 dst INSIDE:72.54.197.26/1080 by access-group "OUTSIDE_access_in"
    4|Apr 15 2011 21:03:50|106023: Deny tcp src OUTSIDE:32.141.52.12/1787 dst INSIDE:72.54.197.26/443 by access-group "OUTSIDE_access_in"
    4|Apr 15 2011 21:03:44|106023: Deny tcp src OUTSIDE:32.141.52.12/1787 dst INSIDE:72.54.197.26/443 by access-group "OUTSIDE_access_in"
    4|Apr 15 2011 21:03:41|106023: Deny tcp src OUTSIDE:32.141.52.12/1787 dst INSIDE:72.54.197.26/443 by access-group "OUTSIDE_access_in"
    4|Apr 15 2011 21:02:23|106023: Deny tcp src OUTSIDE:32.141.52.12/1785 dst INSIDE:72.54.197.26/443 by access-group "OUTSIDE_access_in"
    4|Apr 15 2011 21:02:17|106023: Deny tcp src OUTSIDE:32.141.52.12/1785 dst INSIDE:72.54.197.26/443 by access-group "OUTSIDE_access_in"
    4|Apr 15 2011 21:02:14|106023: Deny tcp src OUTSIDE:32.141.52.12/1785 dst INSIDE:72.54.197.26/443 by access-group "OUTSIDE_access_in"
    5|Apr 15 2011 21:01:56|111008: User 'root' executed the 'access-list OUTSIDE_access_in line 1 extended permit tcp host 72.54.197.26 host 72.54.197.26' command.
    6|Apr 15 2011 21:00:13|302013: Built outbound TCP connection 7173 for OUTSIDE:150.70.85.65/443 (150.70.85.65/443) to INSIDE:192.168.72.100/2959 (72.54.197.26/2959)
    6|Apr 15 2011 20:56:57|302016: Teardown UDP connection 7082 for OUTSIDE:72.54.197.26/137 to INSIDE:192.168.72.17/137 duration 0:02:01 bytes 62
    6|Apr 15 2011 20:55:19|302013: Built outbound TCP connection 7088 for OUTSIDE:184.85.253.178/80 (184.85.253.178/80) to INSIDE:192.168.72.100/2879 (72.54.197.26/2879)
    6|Apr 15 2011 20:55:19|302013: Built outbound TCP connection 7086 for OUTSIDE:74.125.159.147/80 (74.125.159.147/80) to INSIDE:192.168.72.100/2878 (72.54.197.26/2878)
    6|Apr 15 2011 20:54:55|302015: Built outbound UDP connection 7082 for OUTSIDE:72.54.197.26/137 (192.168.72.100/137) to INSIDE:192.168.72.17/137 (72.54.197.28/24)
    6|Apr 15 2011 20:54:17|302021: Teardown ICMP connection for faddr 10.160.68.225/0 gaddr 72.54.197.26/1 laddr 192.168.72.100/1
    6|Apr 15 2011 20:54:15|302020: Built outbound ICMP connection for faddr 10.160.68.225/0 gaddr 72.54.197.26/1 laddr 192.168.72.100/1
    6|Apr 15 2011 20:54:13|302021: Teardown ICMP connection for faddr 172.28.16.2/0 gaddr 72.54.197.26/1 laddr 192.168.72.100/1
    6|Apr 15 2011 20:54:12|302013: Built outbound TCP connection 7074 for OUTSIDE:199.7.52.190/80 (199.7.52.190/80) to INSIDE:192.168.72.100/2815 (72.54.197.26/2815)
    6|Apr 15 2011 20:54:12|302013: Built outbound TCP connection 7073 for OUTSIDE:199.7.55.72/80 (199.7.55.72/80) to INSIDE:192.168.72.100/2813 (72.54.197.26/2813)
    6|Apr 15 2011 20:54:12|302013: Built outbound TCP connection 7072 for OUTSIDE:199.7.55.72/80 (199.7.55.72/80) to INSIDE:192.168.72.100/2812 (72.54.197.26/2812)
    6|Apr 15 2011 20:54:12|302013: Built outbound TCP connection 7071 for OUTSIDE:199.7.52.190/80 (199.7.52.190/80) to INSIDE:192.168.72.100/2811 (72.54.197.26/2811)
    6|Apr 15 2011 20:54:12|302013: Built outbound TCP connection 7070 for OUTSIDE:184.85.253.19/80 (184.85.253.19/80) to INSIDE:192.168.72.100/2810 (72.54.197.26/2810)
    3|Apr 15 2011 20:54:12|106014: Deny inbound icmp src OUTSIDE:172.28.16.2 dst INSIDE:72.54.197.26 (type 0, code 0)
    6|Apr 15 2011 20:54:11|302020: Built outbound ICMP connection for faddr 172.28.16.2/0 gaddr 72.54.197.26/1 laddr 192.168.72.100/1
    6|Apr 15 2011 20:54:10|302013: Built outbound TCP connection 7063 for OUTSIDE:64.4.18.90/80 (64.4.18.90/80) to INSIDE:192.168.72.100/2809 (72.54.197.26/2809)
    3|Apr 15 2011 20:52:17|305005: No translation group found for tcp src INSIDE:192.168.72.75/56624 dst OUTSIDE:72.54.197.26/443
    3|Apr 15 2011 20:52:11|305005: No translation group found for tcp src INSIDE:192.168.72.75/56624 dst OUTSIDE:72.54.197.26/443
    3|Apr 15 2011 20:52:08|305005: No translation group found for tcp src INSIDE:192.168.72.75/56624 dst OUTSIDE:72.54.197.26/443
    2|Apr 15 2011 20:50:02|106001: Inbound TCP connection denied from 187.28.118.35/1973 to 72.54.197.26/445 flags SYN  on interface OUTSIDE
    2|Apr 15 2011 20:49:59|106001: Inbound TCP connection denied from 187.28.118.35/1973 to 72.54.197.26/445 flags SYN  on interface OUTSIDE
    2|Apr 15 2011 20:49:58|106001: Inbound TCP connection denied from 184.27.73.83/443 to 72.54.197.26/60784 flags RST  on interface OUTSIDE
    2|Apr 15 2011 20:49:58|106001: Inbound TCP connection denied from 184.27.73.83/443 to 72.54.197.26/60783 flags RST  on interface OUTSIDE
    2|Apr 15 2011 20:49:58|106001: Inbound TCP connection denied from 184.27.73.83/443 to 72.54.197.26/60781 flags RST  on interface OUTSIDE
    2|Apr 15 2011 20:49:58|106001: Inbound TCP connection denied from 184.27.73.83/443 to 72.54.197.26/60782 flags RST  on interface OUTSIDE
    2|Apr 15 2011 20:49:58|106001: Inbound TCP connection denied from 184.27.73.83/443 to 72.54.197.26/60779 flags RST  on interface OUTSIDE
    2|Apr 15 2011 20:49:58|106001: Inbound TCP connection denied from 184.27.73.83/443 to 72.54.197.26/60785 flags RST  on interface OUTSIDE
    2|Apr 15 2011 20:49:35|106001: Inbound TCP connection denied from 217.10.43.52/1486 to 72.54.197.26/445 flags SYN  on interface OUTSIDE
    2|Apr 15 2011 20:49:32|106001: Inbound TCP connection denied from 217.10.43.52/1486 to 72.54.197.26/445 flags SYN  on interface OUTSIDE
    3|Apr 15 2011 20:48:17|305005: No translation group found for tcp src INSIDE:192.168.72.97/55593 dst OUTSIDE:72.54.197.26/443
    3|Apr 15 2011 20:48:11|305005: No translation group found for tcp src INSIDE:192.168.72.97/55593 dst OUTSIDE:72.54.197.26/443
    3|Apr 15 2011 20:48:08|305005: No translation group found for tcp src INSIDE:192.168.72.97/55593 dst OUTSIDE:72.54.197.26/443
    THANKS!!
    Reply.................................
    ok do this:
    no static (OUTSIDE,INSIDE) 192.168.72.100 72.54.197.26 netmask 255.255.255.255
    clear xlate
    access-list Outside-ACL extended permit tcp any host 72.54.197.26 object-group Citrix1494
    access-group Outside-ACL in interface OUTSIDE
    That should do it for you..
    /M_4911140.html
    Reply........................
    kenboonejr:
    Your reverse static needs to be taken out. then you need to do a "clear xlate" command.  do that and post your config again and let me see it.  I'll be standing by.
    /M_6253131.html
    Was this comment helpful?
    Yes No
    charlietaylor:
    ASA Version 7.0(8)
    hostname 5510
    domain-name xxxxx
    enable password xxxxx encrypted
    passwd xxxxx encrypted
    names
    dns-guard
    interface Ethernet0/0
    description Outside interface to Cbeyond
    nameif OUTSIDE
    security-level 0
    ip address 72.54.197.28 255.255.255.248
    interface Ethernet0/1
    description Inside interface to internal network
    nameif INSIDE
    security-level 100
    ip address 192.168.72.2 255.255.255.0
    interface Ethernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    ip address 192.168.71.2 255.255.255.0
    management-only
    banner exec xxxxx
    banner login VPN firewall/router
    ftp mode passive
    clock timezone CST -6
    clock summer-time CDT recurring 1 Sun Apr 2:00 last Sun Oct 2:00
    dns domain-lookup INSIDE
    dns name-server 66.180.96.12
    dns name-server 64.180.96.12
    object-group service Citrix1494 tcp
    port-object eq citrix-ica
    port-object eq www
    port-object eq https
    port-object range 445 447
    access-list Outside-ACL extended permit tcp any host 72.54.197.26 object-group C
    itrix1494
    pager lines 24
    logging enable
    logging asdm informational
    logging mail critical
    logging from-address xxxxx
    mtu OUTSIDE 1500
    mtu INSIDE 1500
    mtu management 1500
    asdm image disk0:/asdm-508.bin
    no asdm history enable
    arp timeout 14400
    nat-control
    global (OUTSIDE) 1 interface
    nat (INSIDE) 1 0.0.0.0 0.0.0.0
    static (INSIDE,OUTSIDE) 72.54.197.26 192.168.72.100 netmask 255.255.255.255
    access-group Outside-ACL in interface OUTSIDE
    route OUTSIDE 0.0.0.0 0.0.0.0 72.54.197.25 100
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00
    timeout mgcp-pat 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    username root password xxxxxx encrypted privilege 15
    http server enable
    http 192.168.71.0 255.255.255.0 management
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    telnet 192.168.72.0 255.255.255.0 management
    telnet 192.168.73.0 255.255.255.0 management
    telnet 192.168.71.0 255.255.255.0 management
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd address 192.168.71.3-192.168.71.254 management
    dhcpd dns 66.180.96.12 64.180.96.12
    dhcpd lease 3600
    dhcpd ping_timeout 50
    class-map inspection_default
    match default-inspection-traffic
    policy-map global_policy
    class inspection_default
      inspect dns maximum-length 512
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
    service-policy global_policy global
    smtp-server 66.180.96.57
    Cryptochecksum:472013675a200d36e6155c03238fa05c
    : end
    [OK]
    5510#
    Was this comment helpful?
    Yes No
    kenboonejr:
    Ok so at this point if you issues a clear xlate command that would have flushed the translation table and citrix should be able to get out with the current configuration.  If it can't post the logs for it..  This is the right config for what you want to do.
    Was this comment helpful?
    Yes No
    charlietaylor:
    Did that, no connections. Here is what the log says with the config above right after I cle xlate and try to connect from outside.....
    6|Apr 21 2011 12:40:44|302014: Teardown TCP connection 8954 for OUTSIDE:74.125.159.105/80 to INSIDE:192.168.72.100/57140 duration 0:00:30 bytes 0 SYN Timeout
    6|Apr 21 2011 12:40:43|302013: Built outbound TCP connection 9079 for OUTSIDE:74.125.159.105/80 (74.125.159.105/80) to INSIDE:192.168.72.100/57142 (72.54.197.26/57142)
    6|Apr 21 2011 12:40:14|302013: Built outbound TCP connection 8954 for OUTSIDE:74.125.159.105/80 (74.125.159.105/80) to INSIDE:192.168.72.100/57140 (72.54.197.26/57140)
    6|Apr 21 2011 12:40:13|302014: Teardown TCP connection 8618 for OUTSIDE:74.125.159.105/80 to INSIDE:192.168.72.100/57134 duration 0:00:30 bytes 0 SYN Timeout
    6|Apr 21 2011 12:39:43|302013: Built outbound TCP connection 8618 for OUTSIDE:74.125.159.105/80 (74.125.159.105/80) to INSIDE:192.168.72.100/57134 (72.54.197.26/57134)
    6|Apr 21 2011 12:39:35|302014: Teardown TCP connection 8369 for OUTSIDE:74.125.159.105/80 to INSIDE:192.168.72.100/57129 duration 0:00:30 bytes 0 SYN Timeout
    AND....
    Citrix server can not even get out to internet, here is the logs say when you try to open a browser.....
    6|Apr 21 2011 12:39:05|302013: Built outbound TCP connection 8369 for OUTSIDE:74.125.159.105/80 (74.125.159.105/80) to INSIDE:192.168.72.100/57129 (72.54.197.26/57129)
    6|Apr 21 2011 12:38:55|302014: Teardown TCP connection 8227 for OUTSIDE:74.125.159.99/80 to INSIDE:192.168.72.100/57121 duration 0:00:30 bytes 0 SYN Timeout
    6|Apr 21 2011 12:38:25|302013: Built outbound TCP connection 8227 for OUTSIDE:74.125.159.99/80 (74.125.159.99/80) to INSIDE:192.168.72.100/57121 (72.54.197.26/57121)
    6|Apr 21 2011 12:37:36|302014: Teardown TCP connection 7667 for OUTSIDE:216.52.233.134/443 to INSIDE:192.168.72.100/57108 duration 0:00:30 bytes 0 SYN Timeout
    6|Apr 21 2011 12:37:32|302014: Teardown TCP connection 7568 for OUTSIDE:74.125.159.99/80 to INSIDE:192.168.72.100/57107 duration 0:00:30 bytes 0 SYN Timeout
    Was this comment helpful?
    Yes No
    kenboonejr:
    ok so firewall is showing the rules for the inbound stuff working, but the citrix server is not responding that is why you are getting a SYN timeout.
    Does your citrix box have multiple IP addresses or multiple NICs?
    What is the default gateway on the citrix box.
    I can guarantee you that the config is good.
    The logs show sessions getting created - not blocked so its not the firewall causing the problem.  Something else is not quite right.
    Rank: Sage
    Was this comment helpful?
    Yes No
    kenboonejr:
    From the ASA can you ping the real ip address of the citix server?
    /M_6253131.html
    Was this comment helpful?
    Yes No
    charlietaylor:
    This network is in production. CurrentIy have a cheesy Lynksys router (the only thing it does is NAT for Citrix) and a "Transistion" throwdown firewall with two simple rules that allow all and allow outside to Citrix.
    The Citrix has one nic with default gatewway same as all other devices on network (72.2) and goes out just fine until I cut over to 5510. Then is can not get out. (and yes, all other equipment is turned off and the switches are power cycled afer I power up 5510 to make sure I am not having switch arp issues)
    The Citrix is in use 24/7 by remote users so I can't switch back and forth. (especialy during day when everybody goes out to Inet via this unit or the cheesy gear I am replacing)
    I see the connections too but it connects for half a second and sends 0 bytes..... hmmmm
    /M_4911140.htmlRank: Sage
    Was this comment helpful?
    Yes No
    kenboonejr:
    you are having arp issues with the citrix box i would think.
    so once you cutover to the ASA .. can you ping the citrix box from the ASA?
    The citrix arp table still shows the mac address of the linksys 72.2 interface is my guess and you would need to flush the arp table on the citrix server.
    Also, how does the internet connect.  Is it straight to the linksys router?  Is this cable, DSL or T1 to a provider router or what.  There is a router on the outside of the ASA of some sort.  It could be that that devices still has the mac address of public side MAC address of the citrix box in its ARP table.  Most likely that needs a reboot as well to flush its ARP table.  I would bet on it.
    I have been working on Cisco firewall since before Cisco bought the PIX.  I can assure the config is good without that reverse static.
    /M_6253131.html
    Was this comment helpful?
    Yes No
    charlietaylor:
    OK... but if it is an ARP issue would the 5510 still get the info that it is in the logs?
    I mean, if packets were headed to another port why am I seeing SCR/DES info in the logs?
    /M_6253131.html
    Was this comment helpful?
    Yes No
    charlietaylor:
    AND... I REALLY apperciate all your help!
    /M_4911140.htmlRank: Sage
    Was this comment helpful?
    Yes No
    kenboonejr:
    you got a point there.  Here is what I know.  When you try to access it from the outside... the citrix doesn't respond.  So could it be at that point the citrix box has the old arp entry for the linksys? so the packets aren't getting back.
    So if you cut over. start everything fresh.  turn off linksys.  reboot ISP router/device.  flush arp table on citrix.  Then ping the citrix box from the ASA.  If that works then try the connection from the outside.  How are you connecting to the outside?  Are you at a different location or are you on a mobile broadband card or what?
    Was this comment helpful?
    Yes No
    charlietaylor:
    I am physically sitting on the network. I am trying access from outside on my broadband card that is known to connect.
    Their office is closed tomorrow and I am getting access to come in and powercycle every single device. I will then first try to ping Citrix from ASA and move downstream like you suggest.
    Thanks again, I really do hope it is a ARP issue in a device I did not reload. (the ACTELIS ISP box and actual Citrix server)
    I will let you know.
    Was this comment helpful?
    Yes No
    charlietaylor:
    reboot of every device in the network did not change anything
    /M_6253131.html
    Was this comment helpful?
    Yes No
    charlietaylor:
    the ASA can ping the citrix server
    /M_777876.html
    Was this comment helpful?
    Yes No
    slamjam2000:
    From your config, I don't see a route to the inside... 
    The only route on the ASA is to the outside:
    route OUTSIDE 0.0.0.0 0.0.0.0 72.54.197.25 100
    Was this comment helpful?
    Yes No
    charlietaylor:
    so what are you suggesting?

    solved

  • Who can help me with replacing the standard HTML editor in WPC?

    Hi all,
    We have chosen to replace the standard HTML Editor in the Web Page Composer by the TinyMCE Editor. I have worked my way through the document written by Boris Magocsi (https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/f04b5c5d-3fd2-2a10-8ab0-8fa90e3ac162) and the TinyMCE Editor is diplayed when we add or edit a paragraph.
    However, we can not type any text in the input field anymore and we can not click any of the buttons in the TinyMCE editor. Can anybody help a total Javascript newby with fixing this? Full points will be awarded obviuosly. Thanks in advance!
    Best regards,
    Jan
    Note: We are on NW 7.0 SP 15 and the WPC component is not patched yet. We are trying to complete that today and patch it to patch level 1.

    Snippet from the default trace:
    #1.#005056A13EB000880001D90400005EBC000452C3D2595400#1216900908012#com.sap.engine.services.connector.resource.impl.MCEventHandl
    er#sap.com/irj#com.sap.engine.services.connector.resource.impl.MCEventHandler#JALAROS#631##192.168.17.45_POD_3367950#JALAROS#ef
    efb1f0597211ddc652005056a13eb0#SAPEngine_Application_Thread[impl:3]_25##0#0#Debug##Java###>>> com.sap.engine.services.connector
    .resource.impl.MCEventHandler15c015c --> 5(locTrSupp:false).cleanup({0}), shared: {1},  destroyed {2}, invoked from: {3}#4#tru
    e#false#false#java.lang.Exception
            at java.lang.Throwable.<init>(Throwable.java:58)
            at com.sap.engine.services.connector.Log.getStackTrace(Log.java:61)
            at com.sap.engine.services.connector.resource.impl.MCEventHandler.cleanup(MCEventHandler.java:267)
            at com.sap.engine.services.connector.resource.impl.MCEventHandler.connectionClosed(MCEventHandler.java:524)
            at com.sap.engine.services.dbpool.spi.LocalTXManagedConnectionImpl.removeConnectionHandle(LocalTXManagedConnectionImpl.
    java:322)
            at com.sap.engine.services.dbpool.cci.ConnectionHandle.close(ConnectionHandle.java:278)
            at com.sap.netweaver.config.store.CommonJDBCConfigPersistence.getProperty(CommonJDBCConfigPersistence.java:1120)
            at com.sap.netweaver.config.store.ConfigNode.getProperty(ConfigNode.java:61)
            at com.sap.netweaver.portal.prt.config.cmsource.CMStoreSource.getInternalTimestamp(CMStoreSource.java:1111)
            at com.sap.netweaver.portal.prt.config.cmsource.CMStoreSource.shouldRefresh(CMStoreSource.java:997)
            at com.sap.netweaver.portal.prt.config.cmsource.CMStoreSource.refreshObjects(CMStoreSource.java:1187)
            at com.sap.netweaver.portal.prt.config.cmsource.CMStoreSource.getTimeStamp(CMStoreSource.java:1331)
            at com.sapportals.config.fwk.meta.ConfigurableSourceSynchronizer.synchronizeListeners(ConfigurableSourceSynchronizer.ja
    va:124)
            at com.sapportals.config.fwk.data.ConfigPlugin.synchronizeConfigurablesCache(ConfigPlugin.java:1216)
            at com.sapportals.config.fwk.data.ConfigPlugin.getConfigurables(ConfigPlugin.java:362)
            at com.sap.nw.wpc.km.service.editor.EditorService.getStringConfig(EditorService.java:1119)
            at com.sap.nw.wpc.km.service.editor.EditorService.getImageLayoutSet(EditorService.java:1096)
            at com.sap.nw.wpc.km.service.editor.component.ImageSelectComponent.getCompoundComponent(ImageSelectComponent.java:213)
            at com.sap.nw.wpc.km.service.editor.component.ImageSelectComponent.initializeFromPageContext(ImageSelectComponent.java:
    135)
            at com.sap.nw.wpc.km.service.editor.component.EditorComponentFactory.getComponent(EditorComponentFactory.java:69)
            at com.sap.nw.wpc.km.service.editor.document.AbstractEditorObject.getComponent(AbstractEditorObject.java:162)
            at pagelet.editor._sapportalsjsp_editor.subDoContent(_sapportalsjsp_editor.java:1045)
            at pagelet.editor._sapportalsjsp_editor.doContent(_sapportalsjsp_editor.java:58)
            at pagelet.editor._sapportalsjsp_editor.service(_sapportalsjsp_editor.java:38)
            at com.sapportals.portal.prt.core.broker.PortalComponentItemFacade.service(PortalComponentItemFacade.java:360)
            at com.sapportals.portal.prt.core.broker.PortalComponentItem.service(PortalComponentItem.java:934)
            at com.sapportals.portal.prt.core.PortalRequestManager.dispatchRequest(PortalRequestManager.java:435)
            at com.sapportals.portal.prt.core.PortalRequestManager.dispatchRequest(PortalRequestManager.java:527)
            at com.sapportals.portal.prt.component.AbstractComponentResponse.include(AbstractComponentResponse.java:89)
            at com.sapportals.portal.prt.component.PortalComponentResponse.include(PortalComponentResponse.java:232)
            at com.sapportals.portal.htmlb.page.JSPDynPage.doOutput(JSPDynPage.java:76)
            at com.sapportals.htmlb.page.PageProcessor.handleRequest(PageProcessor.java:129)
            at com.sapportals.portal.htmlb.page.PageProcessorComponent.doContent(PageProcessorComponent.java:134)
            at com.sap.nw.wpc.editor.EditorTool.doContent(EditorTool.java:54)
            at com.sapportals.portal.prt.component.AbstractPortalComponent.serviceDeprecated(AbstractPortalComponent.java:209)
            at com.sapportals.portal.prt.component.AbstractPortalComponent.service(AbstractPortalComponent.java:114)
            at com.sapportals.portal.prt.core.PortalRequestManager.callPortalComponent(PortalRequestManager.java:328)
            at com.sapportals.portal.prt.core.PortalRequestManager.dispatchRequest(PortalRequestManager.java:136)
            at com.sapportals.portal.prt.core.PortalRequestManager.dispatchRequest(PortalRequestManager.java:189)
            at com.sapportals.portal.prt.component.PortalComponentResponse.include(PortalComponentResponse.java:215)
            at com.sapportals.portal.prt.pom.PortalNode.service(PortalNode.java:645)
            at com.sapportals.portal.prt.core.PortalRequestManager.callPortalComponent(PortalRequestManager.java:328)
            at com.sapportals.portal.prt.core.PortalRequestManager.dispatchRequest(PortalRequestManager.java:136)
            at com.sapportals.portal.prt.core.PortalRequestManager.dispatchRequest(PortalRequestManager.java:189)
            at com.sapportals.portal.prt.core.PortalRequestManager.runRequestCycle(PortalRequestManager.java:753)
            at com.sapportals.portal.prt.connection.ServletConnection.handleRequest(ServletConnection.java:240)
            at com.sapportals.portal.prt.dispatcher.Dispatcher$doService.run(Dispatcher.java:524)
            at java.security.AccessController.doPrivileged(AccessController.java:231)
            at com.sapportals.portal.prt.dispatcher.Dispatcher.service(Dispatcher.java:407)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
            at com.sap.engine.services.servlets_jsp.server.servlet.InvokerServlet.service(InvokerServlet.java:156)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
            at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.runServlet(HttpHandlerImpl.java:401)
            at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.handleRequest(HttpHandlerImpl.java:266)
            at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:387)
            at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:365)
            at com.sap.engine.services.httpserver.server.RequestAnalizer.invokeWebContainer(RequestAnalizer.java:944)
            at com.sap.engine.services.httpserver.server.RequestAnalizer.handle(RequestAnalizer.java:266)
            at com.sap.engine.services.httpserver.server.Client.handle(Client.java:95)
            at com.sap.engine.services.httpserver.server.Processor.request(Processor.java:175)
            at com.sap.engine.core.service630.context.cluster.session.ApplicationSessionMessageListener.process(ApplicationSessionM
    essageListener.java:33)
            at com.sap.engine.core.cluster.impl6.session.MessageRunner.run(MessageRunner.java:41)
            at com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37)
            at java.security.AccessController.doPrivileged(AccessController.java:207)
            at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:102)
            at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:172)
    #1.#005056A13EB000880001D90500005EBC000452C3D25AFC5C#1216900908121#com.sap.engine.services.connector.resource.impl.HandleWrappe
    r#sap.com/irj#com.sap.engine.services.connector.resource.impl.HandleWrapper#JALAROS#631##192.168.17.45_POD_3367950#JALAROS#efef
    b1f0597211ddc652005056a13eb0#SAPEngine_Application_Thread[impl:3]_25##0#0#Debug##Plain###>>> com.sap.engine.services.connector.
    jca.ConnectionManagerImpl3fa63fa6.allocateConnection(mcf: com.sap.engine.services.dbpool.spi.ManagedConnectionFactoryImpla986
    92e1, reqInfo: null)#

  • Using Iphoto 11 how do I change filename on photo so when it exports it does so in same sequence as Album created in.  Finder does not have option to keep as is... Thanks to anyone who can help me with this !

    The photos must be viewed in sequence as prepared with the filenames I have chosen to describe them.
    How can I just simply transfer this over to a dvd ?  Any help is appreciated !
    Thank You

    There are two ways to export photos so they remain in the same order as you put them in the iPhoto album:
    A:
    1 -  select the photos in the album and use the Photos ➙ Batch Rename  ➙ Title to Text menu with the option to add a sequential number to the file name.
    2 - Export out of iPhoto via File ➙ Export ➙ File Export with the option File Name = Title.
    B:
    1 - select all of the photos in the album and export via File ➙ Export ➙ File Export with the option File Name = Album name with number. 
    Both method will produce file with the following file name format:  xxxx-01.jpg, xxxx-02.jpg, etc., which will be in the order you had in iPhoto when view alphanumerically in the Finder.
    OT

  • Who can help me with connecting php and oracle ........

    and I've tried several ways and does not connect, I vote errors like this
    Warning: oci_connect(): ORA-12154: TNS:could not resolve the connect identifier specified in C:\xampp\htdocs\conexion oracle\consulta.php on line 4
    array(4) { ["code"]=> int(12154) ["message"]=> string(65) "ORA-12154: TNS:could not resolve the connect identifier specified" ["offset"]=> int(0) ["sqltext"]=> string(0) "" } Conexion es invalida
    almost always all errors have to do with the oci8 funsiones
    I appreciate the help you could provide

    ORA-12154 ALWAYS only occurs on SQL Client & no SQL*Net packets ever leave client system
    ORA-12154 NEVER involves the listener, the database itself or anything on the DB Server.
    ORA-12154 occurs when client requests a connection to some DB server system using some connection string.
    TNS-03505 is thrown by tnsping & is same error as ORA-12154 thrown by sqlplus or others.
    The lookup operation fails because the name provided can NOT be resolved to any remote DB.
    The analogous operation would be when you wanted to call somebody, but could not find their name in any phonebook.
    The most frequent cause for the ORA-12154 error is when the connection alias can not be found in tnsnames.ora.
    The lookup operation of the alias can be impacted by the contents of the sqlnet.ora file; specifically DOMAIN entry.
    So post the content of the sqlnet.ora file.
    TROUBLESHOOTING GUIDE: ORA-12154 & TNS-12154 TNS:could not resolve service name [ID 114085.1]
    http://edstevensdba.wordpress.com/2011/02/26/ora-12154tns-03505/

  • I'm trying to reach someone who can help me with the following message when I try to start my account: "Please contact iTunes support to complete this transaction" - but no one is answering the emails.  How do I find someone?

    Can someone who knows iTunes help me?
    I can't get anyone on the phone and their automated system isn't getting back to me.

    As I replied in your duplicate thread, these are user-to-user forums, you are not talking to Apple here.
    You can contact iTunes support via this page :http://www.apple.com/support/itunes/contact/ - click on Contact iTunes Store Support on the right-hand side of the page, then probably Purchases, Billing & Redemption

  • NOKIA 6288!! IS THERE ANYONE WHO CAN HELP ME WITH ...

    Hey, I have a Nokia 6288 phone and I just don't know why it won't let me use email and instant messaging. Is it because I am with Virgin Mobile? Or do I need some sort of settings? Please help me, I will be forever geatful if you do!
    Love,
    Vicki

    You must have a valid email as your apple user name.   Log on to iTunes on the computer and fix your information in the account info.
    Then you can fix the accounts on the device.
    http://support.apple.com/kb/HT2204
    http://support.apple.com/kb/HT5621

Maybe you are looking for

  • Apple TV (2nd gen) - Very Specific Buffering Issue

    I have been watching the threads regularly for a situation similar to mine but I can't see one so I am starting a new one. I have Four (4) Apple TVs in the house and a large library of movies, TV shows and personal movies loaded into iTunes on a Wind

  • Problems with safari screen grayed out unable to load pages from search

    Using IPAD last night and did a google search and google suggestions dialog box remains open along with keyboard, does not allow me to select any search results as the page is grayed out. When I try to select a new page, bookmarks of the back arrow I

  • Calculation of withholding tax on labour charges

    Dear Sir I want to calculate withholding tax on labour charges where tax to be calculated on clubbed amount of Labour charges plus 10.3% service tax on that amount . Can any body suggest the steps for the final configuration of withholding tax for la

  • Key data to multiple images

    I feel there must be a way to put the same data to multiple/batch images. e.g. code a batch of images yellow or put the same keywords. Help would be very much appreciated. Thanks, jp.

  • CONVERT_TO_LOCAL_CURRENCY issue

    Greeting Gurus, Anybody have and idea why a call to function module CONVERT_TO_LOCAL_CURRENCY, while loading transaction data from R/3, is failing with a message "NO FACTORS FOUND"?  I have successfully Transferred Exchange rates in RSA1 -> Source Sy