Xsql and external parameters

Is there a way to read in external parameters to an .xsql file from a static file?
In my .xsql file I have an href that has the hostname.domainname hardcoded. I would like to be able to get the hostname and domainname from a common config file that is used throughout my application.
example:
<xsql:include-xml href="http://webintegra.thirdspace.tv/tas/inbox.php?username{@username}&;password={@password}"/>
Any help is appreciated.
Thanks,
Brenda

You could write a simple custom action handler to do this job, which would be the most efficient because it could cache the configuration values in a static variable and not reread them on each page access, or you could use <xsql:include-xml> to pull in a static XML file into any XSQL page where it is needed, via a file:/// URL (or http:// URL).

Similar Messages

  • Using external XML to add and set parameters for AS cue points.

    Hi there. I am trying to use external xml to set cue point
    times (for video), titles, and other parameters. I have everything
    set up, except getting the proper data from the xml file to set the
    parameters for my cue points. I am researching hard and learning
    quickly - at this point, I need help. Thanks!

    Anyone?
    Still working on this if anyone has advice. Still haven't
    been able to figure out how to put xml data in the right place:
    addASCuePoint(//data from xml here to set name and time of
    cue point - HOW??//);
    Thanks!

  • How u will set the external parameters like packet size and number

    How u will set the external parameters like packet size and number of parallel process.

    Dear Karthik,
    <b>ALE:</b>    
    Use Transaction UPSC02         -      ALE Distribution Unit: Packet Types.
    Performance Optimization for <b>ODS</b> Objects:
    To ensure a good ODS object loading performance, take the following into account:
           1.      Creating SIDs
    The creation of SIDs takes a long time and can be avoided in the following cases by:
           Not setting the indicator for BEx Reporting if you are using the ODS object only as a data store. If you do set this indicator, SIDs are created for all new characteristic values.
           If you use line items (for example, document number or time stamp) as characteristics in the ODS object, in the characteristic maintenance, indicate these as Attribute Only.
    SIDs are created in parallel if <b>parallel activation</b> is switched on (see last point). They are then created with the same number of parallel processes as created for the activation.
    However, if you specify a server group or a special server in customizing, these specifications are not only valid for the activation, but also for the SID creation. The creation of SIDs runs on the application server on which the batch job also runs.
           2.      DB partitioning in active data tables (technical A table)
    By partitioning by database level, you can delete data from the ODS object much more quickly. As a partitioning criterion, choose the characteristic by which you want to delete.  For more information on partitioning database tables, see the database documentation (DBMS-CD). Partitioning is supported by the following databases: Oracle, DB2/390, Informix.
           3.      Indexing
    Use selection criteria for queries for ODS objects. If the key fields are specified, the existing primary index is used. The more frequently accessed characteristic should appear on the left-hand side.
    If you did not specify the key fields completely in the selection criteria (visible in the SQL trace), you improve the run time of the query by creating additional indexes. You can create these secondary indexes in the ODS object maintenance.
           4.      Activation of data in an ODS object
    To improve system performance when activating data in the ODS object, you can make the following entries in Customizing under SAP Customizing Implementation Guide -> SAP NetWeaver -> Business Information Warehouse -> General BW Settings ->  ODS Object Settings:
           the maximum number of parallel processes when activating data in the ODS object as when moving SIDs
           the minimum number of data records for each data package when activating data in the ODS object, meaning you define the size of the data packages that are activated
           the maximum wait time in seconds when activating data in the ODS object. This is the time when the main process (batch process) waits for the dialog process that is split before it classifies it as having failed.
           the server group that needs to be used when activating the data in ODS objects in parallel You have to create the server groups beforehand using the following path: Tools -> Administration -> Network -> RFC Destination, RFC -> RFC Groups. If you do not specify anything here, then the activation runs on the server on which the batch process was started for activation. If a server from the server group is not active, then the activation is cancelled.
           5.      Loading unique data records
    If you only load unique data records (meaning data records with nonrecurring key combinations) into the ODS object, then the loading performance is improved when you set the indicator Unique Data Records in the ODS object maintenance.
    The records are then updated more quickly because the system no longer needs to check whether the record already exists. You do have to be sure that there duplicate records are definitely not being loaded, because this will lead to termination.
    Regards,
    Naveen.

  • Conflict between Logic Pro and external device error in Logic Pro X./cpu problems

    hi Logic users,
    using a MacBookPro 15 inch Retina, 2,7 GHz intel Core i7, 16 GB Ram, OSX 10,8,5, Logic X 10.0.4.
    i am wondering if you can help me out with the following problem i cant solve:
    when starting logic x with a not too big arrangement, lets say using one third to half of cpu, i open u-he plugin Diva and the cpu is going up on full range and the following error appears: "sample-rate 39299 (number always changes) reconized. Check conflict between logic pro x and external device"
    as external device im running a VirusTi and as audio-device Apogge Duet. when dis-connecting both devices, i have the same problem.
    putting the sample buffer up to the highest rate, doesnt change anything.
    same arrangements on friends computers dont show that problem, so it has to be something wrong in my set up.
    anybody has an idea?
    would be much appreciated for your help,
    thanx-

    Have you used Diva's preset Accuracy system to reduce CPU load?
    accuracy
    Click on the Main button at the bottom of the window. To the right of the Master section are two selectors called Accuracy and OfflineAcc. In the current version of Diva these are global parameters i.e. they remain fixed across all presets, per loaded instance:
    draft........CPU-friendly, but FM will sound rough and resonance is primitive i.e. NOT zero delay! fast......... Fine for older computers and/or when you need more polyphony in acceptable quality great...... The best compromise between quality and polyphony on high-power computers divine..... Top-quality zero delay feedback filters... but can your computer can handle it?
    OfflineAcc only has two options – same or best (i.e. divine in the current version).
    Some host applications may have problems rendering to audio at the selected accuracy, but the
    better ones include an “inform plug-ins of offline rendering status” or similar.
    I typically work in draft mode and then switch to Devine or best when freezing the track or bouncing the entire project...

  • No sound internal and external

    I have a macbook right here running 10.4.11 and no sound comes out of it. not out of the internal not out of the external with headphones or speakers. The optical redlight jack isn't on, its all the way up on preferences. iTunes nothing, iMovie nothing, nothing out of the internet. The buttons work fine, it shows that its getting louder/quieter/muted but you don't hear the lil click/beep thing. I don't have warrenty anymore and don't want to get ripped off from apple. (its actually my friends laptop and don't want her to spend money if i can fix it). I'm thinking its a hardware thing, its all updated. I don't know if there is a sound driver for 10.4.11 (I mainly use PC's but Mac Pro at my friends recording studio) I highly doubt its on the software side, but it if is hardware there isn't much I can do to fix it if the mobo is fried somewhere, but if the mobo is fried the whole thing shouldn't work... unless its just the sound and sound only. correct me if my logic is off somewhere. The internal speakers don't work and external doesn't either so I think its the mobo chip that controls the sound... cuz if its software, it shouldn't visually look like its working. Anyone? Help?

    It is entirely possible that the OS would indicate normal sound operation but still be responsible for a silent computer. It is also possible that a preference setting held in non-volatile memory is the cause.
    For the first, you can try booting from the original disks that came with the MB & seeing if sound works. For the second, try resetting PRAM. Also try just launching Garage Band (if installed), which resets certain sound parameters that might prevent normal sound operation. (You don't have to do anything in Garage Band other than launch & then quit it.)
    It is also possible (& not entirely uncommon) to have a hardware problem that just affects a subsystem, especially one associated with a port that can be damaged by an external electrical signal. One way to check for this is to obtain an external sound converter like the Griffin Technology iMic & see if sounds output via a USB port work.
    It is normal not to see any light in the jack -- the MB senses the presence of a plug inserted into it, only turning on the optical output if the plug is of the optical type. If you have an optical cable with a mini-toslink plug available, you can try plugging it in & seeing if you see light at its other end.

  • Cisco 877W router and external ADSL modem

    Cisco 877W router and external ADSL modem
    In order to support ADSL2+ on a pre ADSL2+ router and in preparation for a later migration to BT infinity I am trying to configure the Router using an external adsl2+ modem appropriately.
    The original configuration had 3 ports configured as one (internal lan) vlan and bridge group together with one wireless sub-interface, the remaining port configured a second vlan and bridge group with a second wireless sub- interface. The Dialer was a member of the second bridge group. This way the second wireless interface and associated bridge group provided a kind of DMZ for outbound access.
    The configuration I am attempting is similar the lan ports remain the same, but port 0 as a member of the vlan and bridge group (now a pppoe client) associated with one of the wireless sub interfaces as per above. The ATM interface is downed. This nearly works except that if the wireless subinterface on this bridge group is configured the dialer no longer dials giving a 'no dialer string' error. If I do not configure that wireless sub interface all works well.
    If anyone is interested to look I would appreciate any comments. I enclose a sanitised config in which you will note the 'commented out' wireless subnet interface (in red).
    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    hostname xxxxxxxxxxxxxxxxxxxxx
    boot-start-marker
    boot-end-marker
    logging buffered 4096 warnings
    enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxx
    aaa new-model
    aaa group server radius sdm-vpn-server-group-2
    aaa group server radius rad_eap
     server 192.168.253.1 auth-port 1812 acct-port 1813
     server 192.168.253.1 auth-port 1645 acct-port 1646
    aaa group server radius rad_mac
    aaa group server radius rad_acct
    aaa group server radius rad_admin
    aaa group server tacacs+ tac_admin
    aaa group server radius rad_pmip
    aaa group server radius dummy
    aaa authentication login default local
    aaa authentication login sdm_vpn_xauth_ml_2 group sdm-vpn-server-group-2
    aaa authentication login eap_methods group rad_eap
    aaa authentication login mac_methods local
    aaa authorization exec default local
    aaa authorization ipmobile default group rad_pmip
    aaa authorization network sdm_vpn_group_ml_2 local
    aaa accounting network acct_methods start-stop group rad_acct
    aaa session-id common
    clock timezone PCTime 0
    clock summer-time PCTime date Mar 30 2003 1:00 Oct 26 2003 2:00
    crypto pki trustpoint TP-self-signed-2834265337
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-2834265337
     revocation-check none
     rsakeypair TP-self-signed-2834265337
    crypto pki certificate chain TP-self-signed-2834265337
     certificate self-signed 01 nvram:IOS-Self-Sig#2F.cer
    dot11 syslog
    dot11 ssid GuestAP
       vlan 101
       authentication open
       authentication key-management wpa
       mbssid guest-mode
       wpa-psk ascii 7 113B162712001F4A2D2B25
    dot11 ssid LanAP
       vlan 100
       authentication open eap eap_methods
       authentication network-eap eap_methods
       authentication key-management wpa
       mbssid guest-mode
    no ip source-route
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.10.10.1
    ip dhcp excluded-address 192.168.252.1 192.168.252.8
    ip dhcp excluded-address 192.168.252.15 192.168.252.254
    ip dhcp pool sdm-pool1
       import all
       network 192.168.252.0 255.255.255.0
       domain-name XXX.Local
       dns-server xxx.xxx.xxx.xxx
       default-router 192.168.252.254
    ip auth-proxy max-nodata-conns 3
    ip admission max-nodata-conns 3
    no ip bootp server
    no ip domain lookup
    ip domain name XXX.Local
    ip name-server xxx.xxx.xxx.xxx
    ip name-server xxx.xxx.xxx.xxx
    ip reflexive-list timeout 120
    vpdn enable
    vpdn-group 1
     request-dialin
      protocol pppoe
    username administrator privilege 15 secret 5 £££££££££££££££££££££
    class-map type inspect match-any IN_to_OUT_CLASS
     match protocol tcp
     match protocol udp
     match protocol icmp
    class-map type inspect match-any OUT_to_IN_CLASS
     match protocol https
     match protocol smtp extended
    class-map type inspect match-any DMZ_to_IN_CLASS
     match protocol http
     match protocol https
     match protocol smtp extended
    policy-map type inspect DMZ_to_IN_POL
     class type inspect DMZ_to_IN_CLASS
      inspect
     class class-default
      drop log
    policy-map type inspect IN_to_OUT_POL
     class type inspect IN_to_OUT_CLASS
      inspect
     class class-default
      drop log
    policy-map type inspect OUT_to_IN_POL
     class type inspect OUT_to_IN_CLASS
      inspect
     class class-default
      drop log
    zone security INSIDE
    zone security OUTSIDE
    zone security DMZ
    zone-pair security OUT_TO_IN source OUTSIDE destination INSIDE
     service-policy type inspect OUT_to_IN_POL
    zone-pair security IN_TO_OUT source INSIDE destination OUTSIDE
     service-policy type inspect IN_to_OUT_POL
    zone-pair security DMZ_TO_OUT source DMZ destination OUTSIDE
     service-policy type inspect IN_to_OUT_POL
    zone-pair security DMZ_TO_IN source DMZ destination INSIDE
     service-policy type inspect DMZ_to_IN_POL
    bridge irb
    interface Loopback0
     no ip address
    interface Null0
     no ip unreachables
    interface ATM0
     no ip address
     shutdown
     no atm ilmi-keepalive
     dsl operating-mode auto
    interface FastEthernet0
     description Outside Interface (PPPoE)
    interface FastEthernet1
     description Inside Interface
     switchport access vlan 10
    interface FastEthernet2
     description Inside Interface
     switchport access vlan 10
     spanning-tree portfast
    interface FastEthernet3
     description Inside Interface
     switchport access vlan 10
     spanning-tree portfast
    interface Dot11Radio0
     no ip address
     no ip route-cache cef
     no ip route-cache
     encryption vlan 100 mode ciphers aes-ccm tkip
     encryption vlan 101 mode ciphers aes-ccm tkip
     ssid GuestAP
     ssid LanAP
     mbssid
     speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
     channel 2437
     station-role root
    interface Dot11Radio0.100
     description LanAP
     encapsulation dot1Q 100
     no ip route-cache
     no cdp enable
     bridge-group 10
     bridge-group 10 subscriber-loop-control
     bridge-group 10 spanning-disabled
     bridge-group 10 block-unknown-source
     no bridge-group 10 source-learning
     no bridge-group 10 unicast-flooding
    !interface Dot11Radio0.101
    ! description GuestAP
    ! encapsulation dot1Q 101
    ! no ip route-cache
    ! no cdp enable
    ! bridge-group 1
    ! bridge-group 1 subscriber-loop-control
    ! bridge-group 1 spanning-disabled
    ! bridge-group 1 block-unknown-source
    ! no bridge-group 1 source-learning
    ! no bridge-group 1 unicast-flooding
    interface Vlan1
     description $ES_LAN$
     no ip address
     ip virtual-reassembly
     pppoe enable group global
     pppoe-client dial-pool-number 1
     bridge-group 1
    interface Vlan10
     no ip address
     ip virtual-reassembly
     bridge-group 10
    interface Dialer1
     description $FW_OUTSIDE$
     ip address negotiated
     no ip redirects
     no ip unreachables
     no ip proxy-arp
     ip mtu 1452
     ip nat outside
     ip virtual-reassembly
     zone-member security OUTSIDE
     encapsulation ppp
     ip route-cache flow
     dialer pool 1
     dialer-group 1
     ppp authentication chap pap callin
     ppp chap hostname XXXXXXX
     ppp chap password 7 xxxxxxxxxxxxxxxxxxx
     ppp pap sent-username xxxxxxxxxxxxxxxxxx password 7 xxxxxxxxxxxxxxxxxxxxx
     ppp ipcp dns request
     ppp ipcp wins request
     hold-queue 224 in
    interface Dialer0
     no ip address
    interface BVI10
     description Inside Interface
     ip address 192.168.253.254 255.255.255.0
     ip access-group 101 in
     ip helper-address 192.168.253.1
     ip nat inside
     ip virtual-reassembly
     zone-member security INSIDE
    interface BVI1
     description DMZ Interface
     ip address 192.168.252.254 255.255.255.0
     ip nat inside
     ip virtual-reassembly
     zone-member security DMZ
    ip local pool SDM_POOL_1 192.168.20.9 192.168.20.14
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip http server
    ip http access-class 1
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 600 life 86400 requests 10000
    ip nat inside source list Inside_Clients_NAT interface Dialer1 overload
    ip nat inside source static 192.168.253.10 xxx.xxx.xxx.xxx
    ip access-list extended DMZ_to_IN_POL
     remark SDM_ACL Category=128
     permit ip any any
    ip access-list extended Inside_Clients_NAT
     remark SDM_ACL Category=2
     permit ip 192.168.253.0 0.0.0.255 any
    logging 192.168.253.10
    access-list 1 remark Auto generated by SDM Management Access feature
    access-list 1 remark SDM_ACL Category=1
    access-list 1 permit 192.168.253.0 0.0.0.255
    access-list 100 remark VTY Access-class list
    access-list 100 remark SDM_ACL Category=1
    access-list 100 permit ip 192.168.253.0 0.0.0.255 any
    access-list 100 deny   ip any any
    access-list 101 remark Auto generated by SDM Management Access feature
    access-list 101 remark SDM_ACL Category=1
    access-list 101 remark Auto generated by SDM for NTP (123) xxx.xxx.xxx.xxx
    access-list 101 permit udp host xxx.xxx.xxx.xxx eq ntp host 192.168.253.254 eq ntp
    access-list 101 permit tcp 192.168.253.0 0.0.0.255 host 192.168.253.254 eq telnet
    access-list 101 permit tcp 192.168.253.0 0.0.0.255 host 192.168.253.254 eq 22
    access-list 101 permit tcp 192.168.253.0 0.0.0.255 host 192.168.253.254 eq www
    access-list 101 permit tcp 192.168.253.0 0.0.0.255 host 192.168.253.254 eq 443
    access-list 101 permit tcp 192.168.253.0 0.0.0.255 host 192.168.253.254 eq cmd
    access-list 101 deny   tcp any host 192.168.253.254 eq telnet
    access-list 101 deny   tcp any host 192.168.253.254 eq 22
    access-list 101 deny   tcp any host 192.168.253.254 eq www
    access-list 101 deny   tcp any host 192.168.253.254 eq 443
    access-list 101 deny   tcp any host 192.168.253.254 eq cmd
    access-list 101 deny   udp any host 192.168.253.254 eq snmp
    access-list 101 permit ip any any
    access-list 199 permit ip any host 10.1.1.1
    dialer-list 1 protocol ip permit
    no cdp run
    radius-server attribute 32 include-in-access-req format %h
    radius-server host 192.168.253.1 auth-port 1812 acct-port 1813 key 7 XXXXXXXXXXXXXXXXXX
    radius-server host 192.168.253.1 auth-port 1645 acct-port 1646 key 7 XXXXXXXXXXXXXXXXXX
    radius-server vsa send accounting
    control-plane
    bridge 1 protocol ieee
    bridge 1 route ip
    bridge 10 protocol ieee
    bridge 10 route ip
    banner login C Border Router
    line con 0
     no modem enable
     transport output telnet
    line aux 0
     transport output telnet
    line vty 0 4
     access-class 100 in
     privilege level 15
     length 0
     transport input telnet ssh
    scheduler max-task-time 5000
    scheduler interval 500
    ntp server xxx.xxx.xxx.xxx source Dialer0 prefer
    ntp server xxx.xxx.xxx.xxx source Dialer0 prefer
    sntp server xxx.xxx.xxx.xxx
    end

    Hi Jody,
    Apologies delay in replying. I have done the following:
    Made two of the FE ports vlan1,BVI1 (for LAN traffic)
    Left one port as VLAN10 as the pppoe client conected to the externalmodem
    Made the last port VLAN10 as well and gave it an IP addess as for a DMZ client.
    I have DHCP configured to serve the DMZ  addresses.
    This all works for LAN clients and also works for a client attachedto that physical DMZ port.
    When I added a dot11radio sub interface into VLAN 10 the wireless client did not get an IP lease. Everything else continued to work.
    I had never thought about this before, but if a dot11radio interface is on the same vlan (but not being part ofa bridge group) why are DHCP broadcasts not propogating to all the vlan members as I would have expected. I recognise that this isa limit in my understanding.
    If I then made VLAN10 a member of a new Bridge Group, I lost WAN connectivity as per original posting.
    I cannot add another VLAN due to the 2 vlan limit in this image.
    Finally regarding your comment about giving it what it wants, what exactly did you have in mind. The dialer already has a dial string parameters configured.
    Think I am about to give upon this.
    Regards,

  • XSQL and Packaged Procedure

    I've been reading thru the postings for XSQL and read a couple of references on how to get an out variable from a stored procedure. I read this thread from 3/31:
    http://technet.oracle.com:89/ubb/Forum11/HTML/001444.html
    Anyway, I followed the advice and I get the following error message:
    ORA-06571: Function CHECK_USER does not guarantee not to update database
    Did some research and found that I would need to create a PRAGMA in my function, which would need to be packaged. I did that, but the function would not compile because it would not fulfil the pragma. Below is the procedure I am trying to run, the wrapper function, and the XSQL source. Any ideas?
    Thanks
    Procedure
    Procedure check_user( inSiteID varchar2,
    v_userid number default null,
    inExtID varchar2 default null,
    v_return out varchar2)
    AS
    ParamIsNull EXCEPTION;
    invalid_data EXCEPTION;
    v_errmsg varchar2(200);
    v_count number := 0;
    BEGIN
    If v_userid Is Null AND inExtID Is Null Then Raise ParamIsNull; End If;
    If v_userid Is Not Null AND inExtID Is Not Null Then Raise ParamIsNull; End If;
    If v_userid Is Not Null Then
    SELECT COUNT(1) INTO v_count FROM USERS WHERE site_id=inSiteID and USERID = v_userid;
    If v_count = 0 then
    v_errmsg := '0, UserID Not Found';
    raise invalid_data;
    Else
    v_return:=('1');
    End if;
    End If;
    If inExtID Is Not Null Then
    SELECT COUNT(1) INTO v_count FROM USERS WHERE site_id=inSiteID and ext_uid = inExtID;
    If v_count = 0 then
    v_errmsg := '0, External ID Not Found';
    raise invalid_data;
    Else
    v_return:=('1');
    End if;
    End If;
    EXCEPTION
    WHEN ParamIsNull THEN
    v_return:=('0,1 Parameter Expected');
    WHEN invalid_data THEN
    v_return:=v_errmsg;
    END check_user;
    Function
    CREATE OR REPLACE PACKAGE DON AS
    FUNCTION CHECK_USER (siteid IN VARCHAR2, userid IN NUMBER, extid IN VARCHAR2)
    RETURN VARCHAR2;
    PRAGMA RESTRICT_REFERENCES (CHECK_USER, WNDS);
    END DON;
    CREATE OR REPLACE PACKAGE BODY DON AS
    FUNCTION CHECK_USER (siteid IN VARCHAR2, userid IN NUMBER, extid IN VARCHAR2)
    RETURN VARCHAR2 IS v_return VARCHAR2(200);
    BEGIN
    OTS_SCOPUS_PACK.CHECK_USER(siteid, userid, extid, v_return);
    RETURN v_return;
    END;
    END DON;
    XSQL Source
    <?xml version="1.0"?>
    <xsql:query xmlns:xsql="urn:oracle-xsql" connection="mvdv">
    select don.check_user('{@siteid}', {@userid}, '{@extid}') from dual
    </xsql:query>

    Your 'DON.CHECK_USER' function has a RESTRICT_REFERENCES pragma but it calls 'OTS_SCOPUS_PACK.CHECK_USER' which must also have a RESTRICT_REFERENCES pragma.
    All functions/procedures that are called directly or indirectly by 'DON.CHECK_USER' need to have a RESTRICT_REFERENCES pragma to guarantee that they do not write to the database or to a package.
    You cannot just write a wrapper function and apply the pragma to it.
    Good luck!
    null

  • Using external parameters within MS Query returning that data right into a pivot table Excel 2010

    In Excel 2010 i was able to use the external parameters within MS Query returning that data right into a pivot table.  But the parameter on the worksheet will not save in the paremeter setting of the data connection.  And if you save it and open
    it and try to refresh the pivot table Excel stops responding and you have to force the file closed.  I found out the reason to crash is that it did not keep the parameter saved.
    Can this be fixed?

    Hi,
    Just
    checking in to see if the information of Oskar was helpful. Please
    let us know if you would like further assistance.
    Jaynet Zhang
    TechNet Community Support

  • XSQL with optional parameters

    I am trying to create an XSQL page that has optional parameters.
    What I mean is, I would like the page to return all records for a query when the following url is used http://myserver.com/my_inventory.xsql
    And I would like the page to return limited records for a query when the following url is used http://myserver.com/my_inventory.xsql?item=123
    I have been trying the following with no success. Any suggestions?
    <?xml version="1.0"?>
    <?xml-stylesheet type="text/xsl" href="rowset2inventorylevel.xsl"?>
    <xsql:if-param name="item" exists="no">
    <xsql:query connection="myconn" tag-case="lower" xmlns:xsql="urn:oracle-xsql">
    select m.item_no
    , m.description
    , m.qty_on_hand
    , nvl(p.gross_wt,0) weight
    from item_master m
    , item_price p
    where m.item_no = p.item_no
    and m.status_flag='A'
    and m.discontinue_flag = 'N'
    order by m.item_no
    </xsql:query>
    </xsql:if-param>
    <xsql:if-param name="item" exists="yes">
    <xsql:query connection="myconn" tag-case="lower" xmlns:xsql="urn:oracle-xsql">
    select m.item_no
    , m.description
    , m.qty_on_hand
    , nvl(p.gross_wt,0) weight
    from item_master m
    , item_price p
    where m.item_no = p.item_no
    and m.status_flag='A'
    and m.discontinue_flag = 'N'
    and m.item_no = ?
    order by m.item_no
    </xsql:query>
    </xsql:if-param>

    The easy, but less optimal way, is to use OR in your where clause:
    rewrite "and m.item_no = ?" to "and m.item_no = ? or ? is null" - and remember to include the parameter twice in bind-params.
    The "right" way to do this, meaning a more optimal access path, is to use stored procedures that returns REF CURSORs. Then in the stored procedure you look for NULL and change the where clause accordingly.

  • XSQL command line parameters

    I have a situation where I am generating some XML from a query in an XSQL and I want to use some command line parameters. This ony seems to work inside queries, e.g. given the command line "xsql quote.xsql quotetype=carhire quotenum=123" this will substitute 123 for "{@quotenum}" given the command line and leave "{@quotetype}" untouched.
    <pre>
    <quote type="{@quotetype}">
    <xsql:query>
    select price from quotes where number={@quotenum}
    </xsql:query>
    </quote>
    </pre>
    Is there a way to substitute the {@quotetype} part in XSQL?

    I'm already using XSLT and I've put <xsl:param name="type"> in the stylesheet, but references to $type don't seem to get any result, e.g.
    <xsl:value-of select="$type"/> is blank
    and
    <xsl:if test="$type='carhire'">
    <xsl:text>car hire</xsl:text>
    </xsl:if>
    doesn't generate any output either, so either I've got my syntax for parameters wrong, or the parameters don't get passed from the XSQL front end to the XSLT back end.

  • XSQL Command-Line, parameters with blanks

    Is it possible to use XSQL Command-Line with parameters containing blanks (space characters).
    In an URL parameter spaces can be encoded with "+" or "%20", but this does'nt seem to work with XSQL Command-Line parameters.
    -- Peter

    I can't make this work on Unix (solaris), but I can see it is a shell script problem, not a XSQL problem.
    The normal syntax for Unix shell script would be
    $ script.sh foo="one two"
    but the standard Oracle-supplied xsql unix shell script sets environment and passes all command-line parameters to the java program with
    oracle.xml.xsql.XSQLCommandLine $*
    and thereby the quotes disappear.
    The problem is not really big, since I could just do
    oracle.xml.xsql.XSQLCommandLine test.xsql "foo=one two"
    after setting classpath. Anyway, if anybody knows how to make the xsql script work with quoted parameters, let me know.
    -- Peter

  • In-house production with on-line publication and external procurement C5

    Dear SAP Gurus,
    I need to configure PPDS to immediate transfer in-house production orders but to have periodical transfer for external procurement, do you know how to do this?
    Thanks and BR
    Andre

    Hi
    Goto Spro-APO-supply chain Planning-PPDSGlobal setting-maintain global parameters and defaults-
    Transfer to R/3 Inhouse Production- Always create transfer event
    Transfer To R/3 External Procurement- Do not create transfer event.
    To transfer external procurement periodicaly you can use /SAPAPO/RRP4 go to change mode and click on transfer order.
    Have a small test from all angles before going ahead with this approch. As you need check whether changes to already transfered purchase requisition get transfered to ECC if not how you will identify such orders and send it to ECC.
    May I know what is buisness reason for such requirement because I seen requirement to transfer inhouse production and external procurement only on conversion but heard of such requirement first time.
    Regards,
    Santosh

  • ENVS and GLOBAL_USERNAME parameters to SID_DESC

    DB:9i
    Hello All,
    Can we add ENVS and GLOBAL_USERNAME parameters to SID_DESC section of listener.ora
    Could anyone me the list of parameters,
    we can add to the SID_DESC section of listener.ora
    DN

    No, I mean GLOBAL_USERNAMEDid you read above link ? GLOBAL_USERNAME does not exist, while there is GLOBAL_DBNAME.
    what about ENVS?Please read the link : Use the parameter ENVS to specify environment variables for the listener to set prior to executing (as a child process) a dedicated server program or an executable specified with the PROGRAM parameter.
    I used it sometimes for external procedures.

  • Time Capsule and External HD as Network Attached Storage

    I was wondering if I can
    a. Attached and external hard drive to my Time Capsule and access is wirelessly?
    b. Back up to that external hard drive using Time Machine?
    c. Access that external hard drive and Time Capsule from a remote place off site?
    Thanks

    a. Yes
    b. I think so. But why not just use the TCs hard disk for TM backups?
    c. Apparently so based on these instructions I have found: (Haven't tried it myself)
    In the Finder preferences check the box "show server" to mount to desktop.
    Under Airport Utility:
    Disks - check over wan and check file sharing and write down the ip address
    Under the Finder, use the GO function to find your server ie the hard drive on the TC. In the window provided type afp://ip address then password if applicable. The hard drive should mount and be shown on the desktop.

  • What is main diff b/w imported Archives and External Defination in IR

    What is main diff b/w imported Archives and External Defination in IR

    Hi Vijay,
    ED-standard schema for describing the message structure.If you have the structure provided to you from some external application you can use it in PI directly without recreating in PI.you can import following formats which are used to describe message schema
    WSDL (Web Service Description Language),
    XSD (XML Schema Definition Language),
    DTDs (Document Type Definitions)
    Imported Archives: its used basically for java and xslt mapping where you create the required mapping externally using some tools
    (java-eclipse/NWDS .XSLT-stylus studio).You can also implement XSLT and Java mappingsf and save them as archives in the Integration Repository.
    read More details here
    [ED|http://help.sap.com/saphelp_nwesrce/helpdata/en/26/9e97b0f525d743882936c2d6f375c7/content.htm]
    [Imported Archives|http://help.sap.com/saphelp_nw04/helpdata/en/4c/b2ad3de2d76b3be10000000a114084/content.htm]
    Regards,
    Srinivas

Maybe you are looking for