Need some help in building a PowerShell Script

I am in the process of setting up continuous self-auditing on a set of computers that are on a Domain. My company has a restriction on use of USB devices as well as CDs/DVDs. The domain pushes patches but we have been seeing some users that are using (or
trying to) the network without becoming a part of the domain. My aim is to run a PowerShell script periodically (say, hourly) on each computer on the domain and dump certain parameters to XML / XHTML and then load these onto a web-server that can display the
results in a (sort of) dashboard to flag anomalies like unauthorised USB use etc.
I know there must be some commercial products for this but the boss says "No" to a purchase. 
Am I on the right track or do I need to change my approach? Also, is there a starting scirpt available somewhere so that I can study it for techniques? My major problem is the display part. I am able to dump it into XML and (sort of ) format it but how do
I collate the data and display it as a web-page is what is bothering me. Help would be deeply appreciated.

@JRV:
Users don't have to be domain administrators
to be able to install software. Local admin is more than enough. ie: I am no admin in the domain of my customer but am allowed to install software
Although I agree with you, in the sense it would be easier to restrict the users, it doesn't mean that a company has to do it that way; and it certainly doesn't represent the intelligence of an individual. 
@SarabRSingh:
What you are asking for is a lot of work, to get the script right (considering the special demands, ie. AV update checking is different depending on the SW) and it might require a lot of resources on the client.
From what you describe, you want to prevent any USB/Optical Media use. You should consider Group Policies to manage that. http://technet.microsoft.com/en-us/library/bb742376.aspx
The only part I would script (based on my work environment) is the checking of AV updates (gets tricky because our SW has a hard time forcing the user to update when connected by VPN).
user log in / out --> group policy: logon/off script writing appending timestamp to a file
has he/she used any USB device --> if you want to block it: GPO, if you only want to track it: powershell
Get-WmiObject Win32_USBControllerDevice
has any new application / software been installed: restrict installation completely with user permissions or: http://social.technet.microsoft.com/Forums/en-US/f4dc8ab9-370b-423e-b65d-1fa46fa9bcc4/powershell-script-to-remotely-audit-computers-on-lan?forum=ITCG
was the AV: no idea on what you are using (maybe: http://serverfault.com/questions/129611/how-to-detect-when-antivirus-is-out-of-date-with-powershell
OS updated: WSUS http://technet.microsoft.com/en-us/library/cc708519(v=ws.10).aspx
If you found this post helpful, please "Vote as Helpful". If it answered your question, remember to "Mark as Answer"
MCC & PowerShell enthusiast
http://oliver.lipkau.net/blog

Similar Messages

  • Need some help in debugging this exported script

    Below is DDL generated by visio forward engineering tool . The example below consists of 2 test tables with one foreign key.
    Forward engineering generated DDL script
    IF EXISTS (SELECT * FROM sys.objects WHERE object_id = OBJECT_ID(N'[dbo].[Table1]') AND type in (N'U'))
    DROP TABLE [dbo].[Table1]
    GO
    CREATE TABLE [dbo].[Table1] (
    [test] CHAR(10) NOT NULL
    , [test2] CHAR(10) NULL
    GO
    ALTER TABLE [dbo].[Table1] ADD CONSTRAINT [Table1_PK] PRIMARY KEY CLUSTERED (
    [test]
    GO
    GO
    IF EXISTS (SELECT * FROM sys.objects WHERE object_id = OBJECT_ID(N'[dbo].[Table2]') AND type in (N'U'))
    DROP TABLE [dbo].[Table2]
    GO
    CREATE TABLE [dbo].[Table2] (
    [test2] CHAR(10) NOT NULL
    GO
    ALTER TABLE [dbo].[Table2] ADD CONSTRAINT [Table2_PK] PRIMARY KEY CLUSTERED (
    [test2]
    GO
    GO
    ALTER TABLE [dbo].[Table1] WITH CHECK ADD CONSTRAINT [Table2_Table1_FK1] FOREIGN KEY (
    [test2]
    REFERENCES [dbo].[Table2] (
    [test2]
    GO
    GO
    When i converted this DDL script using scratch editor the migration tool gave some errors can anyone help me to resolve below
    DECLARE
    v_temp NUMBER(1, 0) := 0;
    BEGIN
    BEGIN
    SELECT 1 INTO v_temp
    FROM DUAL
    WHERE EXISTS ( SELECT *
    FROM objects
    WHERE OBJECT_ID_ = NULL/*TODO:OBJECT_ID(N'[OPS].[Table1]')*/
    AND TYPE IN ( N'U' )
    EXCEPTION
    WHEN OTHERS THEN
    NULL;
    END;
    IF v_temp = 1 THEN
    TRUNCATE TABLE Table1;
    END IF;
    END;
    CREATE TABLE Table1
    test CHAR(10) NOT NULL,
    test2 CHAR(10)
    ALTER TABLE Table1
    ADD
    CONSTRAINT Table1_PK PRIMARY KEY( test );
    --SQLDEV:Following Line Not Recognized
    DECLARE
    v_temp NUMBER(1, 0) := 0;
    BEGIN
    BEGIN
    SELECT 1 INTO v_temp
    FROM DUAL
    WHERE EXISTS ( SELECT *
    FROM objects
    WHERE OBJECT_ID_ = NULL/*TODO:OBJECT_ID(N'[OPS].[Table2]')*/
    AND TYPE IN ( N'U' )
    EXCEPTION
    WHEN OTHERS THEN
    NULL;
    END;
    IF v_temp = 1 THEN
    TRUNCATE TABLE Table2;
    END IF;
    END;
    CREATE TABLE Table2
    test2 CHAR(10) NOT NULL
    ALTER TABLE Table2
    ADD
    CONSTRAINT Table2_PK PRIMARY KEY( test2 );
    --SQLDEV:Following Line Not Recognized
    ALTER TABLE Table1
    ADD
    CONSTRAINT Table2_Table1_FK1 FOREIGN KEY( test2 ) REFERENCES Table2 (test2)
    --SQLDEV:Following Line Not Recognized
    ;

    Pl do not post duplicates - Need some help in debugging this script

  • Need some help on building my pc

    Hi i have seen some discussions about what pc to build,but i don't have any idea about hardware,i am very much confused about motherboards,cpu,ram,and overclocks,
    my requirement is that,I am a vfx compositor,i left my job and doing freelance for Feature Films,now i require a proffesional pc to build,-i work with fluids(realflow,houdini),maya,Premiere cs5.5(editing),Afx,3dsmax can any one plz give me perfect list to build my pc,thanks

    not a lot to add. The best would be that you get still access as a freelancer to your old company professional workstation. You could gain some time in checking out your business model first as we speak here from significant HW/SW investments.
    For vfx usage think about the largest and fastest  2x 6 core computer, at least 48 GB main storage), a professional OpenGL card from Gforce (e.g. specific support for 3d apps like Maya), 1-3 professional displays, some TB disks with/without raid, etc. To get some grip regarding performance you can run the cinebench at a vendor’s/business friend test workstation (CPU/GL)
    http://www.maxon.net/en/downloads/cinebench.html
    PS: Your above mentioned licenses represent a value of approx. 20k$+ (hopefully you got a golden shake hand from your former company or at least you have access to the education editions…) and I assume that you own already a set of in vfx production needed  add ons (e.g. video filters, music eq’s, compressors, mastering tools, etc),  sample libraries and a good HW monitoring/mixing equipment (Genelec, Yamaha, etc.).
    PPS: I run on an i920 (24 GB main storage, GTX 560Ti, 10 TB non raid disks) a full music production (Cubase 6.5, Wavelab 7 and tons of VSTi plugins),a  medium level CS5 Master Collection environment (mainly Premiere Pro, After Effects, Photoshop, Adobe Media Encoder and Dreamweaver) and an entry level 3D Cinema 4D app. Next upgrade will be a “real” workstation (either homebuild from a small company nearby or a HP Z600 like computer) as described above and most likely a RAID subsystem.

  • Need some help in building a Link Query

    Hi,
    I am having a scenario where the dataset looks like as below:
    Table Test containts the following values
    ================================
    100 200
    200 300
    200 300
    200 400
    400 100
    100 400
    i want to display the following string dynamically from the above record set .
    100 link 200 ,200 link 300 and 400,400 link 100,100 link 400
    Any help will be needful for me
    Thanks and Regards

    Duplicate thread.
    Did you see my COMPLETE solution in this thread?
    query error
    Cheers
    Sarma.

  • Need some help with Service Manager Powershell commands

    I am a real noob with SM and often I am asked to grant users access to the SM console. I am typically told to pattern the role membership like another user. Problem is I can't find and easy way to do that. If someone tells me, " I need the same access
    as John Doe", what power shell command can I use to find out all the roles John Doe belongs to. I am guessing its going to be PS because there is no option in the console for this.

    This is the wrong side up when you're thinking about permissions. Nobody gets hired to do "the same job as bob". It doesn't make any more sense to copy permissions for a user then it does to take bob's keychain and copy all of his keys. Just because bob
    needs access to his car, doesn't mean his successor needs the same access.
    The best way to deal with permissions (in Service Manager and in IT in general) is to create job role groups that reflect the rights required to do a given job. When someone is hired into a job, they get added into that group and get the right permissions.
    in service manager, you can put that job role group into all of the SCSM role groups that apply to that job role.

  • Need some help with social net site

    I need to create a site with editable user profiles, the site
    will feature sports stats that the user can update.
    I use Dreamweaver and MYSQL but I need some direction. Im
    starting from scratch here, are there any templates or free source
    code to go off of? I really need some help!!

    "Funks Da Burn" <[email protected]> wrote in
    message
    news:g1np74$eej$[email protected]..
    >I need to create a site with editable user profiles, the
    site will feature
    > sports stats that the user can update.
    > I use Dreamweaver and MYSQL but I need some direction.
    Im starting from
    > scratch here, are there any templates or free source
    code to go off of? I
    > really need some help!!
    That's not something you can do using templates or by
    dropping in a free
    script; it's pretty complicated. You need to know how to
    design a database
    and write server-side code. Dreamweaver will help you write
    the code, but
    you still need to plan and design the whole application. I'd
    recommend
    starting with a book. It sounds like PHP is going to be your
    best bet - does
    your host server support it? If so, do a search on Amazon.com
    for books on
    Dreamweaver and PHP, and/or ask for recommendations here.
    Patty Ayers | www.WebDevBiz.com
    Free Articles on the Business of Web Development
    Web Design Contract, Estimate Request Form, Estimate
    Worksheet

  • Need some help frist time useing dreamweaver

    Hey all,
    I am totaly new to Dreamweaver and am needing some help. I am
    needing to make a feedback form. Would need it to e-mail me the
    feedback to something like [email protected] I also need to know
    how to make a footer for the copyright and desiged by, on each page
    without having to manually entering them. Any help I could get
    would be awsome.

    There are only two ways to process form data -
    1. Use mailto:[email protected] as the action of the form
    2. Use a server-side scripting method to a) harvest the
    form's data, b)
    process it in some manner, e.g., enter it into a database, c)
    formulate and
    send an email to one or more email recipients, and d)
    redirect the visitor
    to some ending page
    Method 1 is quite simple, and is also the least reliable. It
    depends both
    on your visitor having an email client already installed on
    their computer -
    this eliminates public computers, or home users without email
    clients
    installed (more and more it seems) - and on the installed
    email client
    responding to
    the mailto call. It is not possible to use this method *and*
    send the
    visitor to a
    thank you page as well.
    Method 2a is the preferred method, since it eliminates the
    problems of
    method
    1, but it means that you have to grapple with
    server-scripting somehow (ASP,
    CF, PHP, perl, etc.).
    Method 2b would be to use some third-party form processing,
    like
    http://www.bebosoft.com/products/formstogo/.
    You would have to decide which of these methods is best for
    your needs,
    but if it's Method 2a, then start by asking your host what
    they provide for
    form
    processing. If it's 2b, then read their FAQ/instructions
    carefully.
    For your footer, investigate the use of DW's Templates (use
    F1 Help to read
    about them), or of server-side includes (again, F1 Help will
    give you some
    info here, as will Google).
    Murray --- ICQ 71997575
    Adobe Community Expert
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    http://www.projectseven.com/go
    - DW FAQs, Tutorials & Resources
    http://www.dwfaq.com - DW FAQs,
    Tutorials & Resources
    ==================
    "Xysos_Designs" <[email protected]> wrote in
    message
    news:[email protected]...
    > Hey all,
    > I am totaly new to Dreamweaver and am needing some help.
    I am needing to
    > make
    > a feedback form. Would need it to e-mail me the feedback
    to something like
    > [email protected] I also need to know how to make a
    footer for the
    > copyright
    > and desiged by, on each page without having to manually
    entering them. Any
    > help
    > I could get would be awsome.
    >

  • Need some help understanding the way materialized views are applied through

    Hi, I need some help understanding the way materialized views are applied through adpatch.
    In patch 1, we have a mv with build mode immediate. When applying it PTS hang due to pool performance of mv refresh.
    So we provide patch 2, with that mv build mode deferred, hoping it'll go through. But patch 2 hang too on the same mv.
    How does this work? Is that because mv already exists in the database with build immediate, patch 2 will force it to refresh first before changing build mode? How to get over this?
    Thanks,
    Wei

    Hi Hussein,
    Thank you for the response.
    Application release is 11.5.10.
    Patch 1 is MSC11510: 8639586 ASCP ENGINE RUP#38 PATCH FOR 11.5.10 BRANCH
    Patch 2 is MSC11510: 9001833 APCC MSC_PHUB_CUSTOMERS_MV WORKER IS STUCK ON "DB FILE SEQUENTIAL READ" 12 HOURS
    The MV is APPS.MSC_PHUB_CUSTOMERS_MV
    This happens at customer environment but not reproducable in our internal environment, as our testing data is much smaller.
    Taking closer look in the logs, I saw actually when applying both patch 1 and patch 2, MV doesn't exist in the database. So seems my previous assumption is wrong. Still, strange that patch 2 contains only one file which is the MV.xdf, it took 7 hours and finally got killed.
    -- patch 1 log
    Materialized View Name is MSC_PHUB_CUSTOMERS_MV
    Materialized View does not exist in the target database
    Executing create Statement
    Create Statement is
    CREATE MATERIALIZED VIEW "APPS"."MSC_PHUB_CUSTOMERS_MV"
    ORGANIZATION HEAP PCTFREE 10 PCTUSED 40 INITRANS 10 MAXTRANS 255 LOGGING
    STORAGE(INITIAL 4096 NEXT 131072 MINEXTENTS 1 MAXEXTENTS 2147483645
    PCTINCREASE 0 FREELISTS 4 FREELIST GROUPS 4 BUFFER_POOL DEFAULT)
    TABLESPACE "APPS_TS_SUMMARY"
    BUILD IMMEDIATE
    USING INDEX
    REFRESH FORCE ON DEMAND
    WITH ROWID USING DEFAULT LOCAL ROLLBACK SEGMENT
    DISABLE QUERY REWRITE
    AS select distinct
    from
    dual
    AD Worker error:
    The above program failed. See the error messages listed
    above, if any, or see the log and output files for the program.
    Time when worker failed: Tue Feb 02 2010 10:01:46
    Manager says to quit.
    -- patch 2 log
    Materialized View Name is MSC_PHUB_CUSTOMERS_MV
    Materialized View does not exist in the target database
    Executing create Statement
    Create Statement is
    CREATE MATERIALIZED VIEW "APPS"."MSC_PHUB_CUSTOMERS_MV"
    ORGANIZATION HEAP PCTFREE 10 PCTUSED 40 INITRANS 10 MAXTRANS 255 LOGGING
    STORAGE(INITIAL 4096 NEXT 131072 MINEXTENTS 1 MAXEXTENTS 2147483645
    PCTINCREASE 0 FREELISTS 4 FREELIST GROUPS 4 BUFFER_POOL DEFAULT)
    TABLESPACE "APPS_TS_SUMMARY"
    BUILD DEFERRED
    USING INDEX
    REFRESH COMPLETE ON DEMAND
    WITH ROWID USING DEFAULT LOCAL ROLLBACK SEGMENT
    DISABLE QUERY REWRITE
    AS select distinct
    from dual
    Start time for statement above is Tue Feb 02 10:05:06 GMT 2010
    Exception occured ORA-00028: your session has been killed
    ORA-00028: your session has been killed
    ORA-06512: at "APPS.AD_MV", line 116
    ORA-06512: at "APPS.AD_MV", line 258
    ORA-06512: at line 1
    java.sql.SQLException: ORA-00028: your session has been killed
    ORA-00028: your session has been killed
    ORA-06512: at "APPS.AD_MV", line 116
    ORA-06512: at "APPS.AD_MV", line 258
    ORA-06512: at line 1
    Exception occured :No more data to read from socket
    AD Run Java Command is complete.
    Copyright (c) 2002 Oracle Corporation
    Redwood Shores, California, USA
    AD Java
    Version 11.5.0
    NOTE: You may not use this utility for custom development
    unless you have written permission from Oracle Corporation.
    AD Worker error:
    The above program failed. See the error messages listed
    above, if any, or see the log and output files for the program.
    Time when worker failed: Tue Feb 02 2010 19:51:27
    Start time for statement above is Tue Feb 02 12:44:52 GMT 2010
    End time for statement above is Tue Feb 02 19:51:29 GMT 2010
    Thanks,
    Wei

  • Need some Help configuring sip

    Hi all ! ,
    Im kind off new to sip calling and cisco telephony , but here goes ,: i have a 2821 router with CME installed
    IOS : C2800NM-IPVOICEK9-M
    Sofware version : 15.1(4)M4 / CME 8.6
    Attached to GE0/0 is a CISCO 3750 switch
    GEO - consisfts of 3 VLANS  , the native
    172.22.1.X
    172.22.100.X VOICE
    172.22.101.X DATA
    my tftpserver = 172.22.1.150
    i need some help configuring a sip trunk , i have 10 testing phonenumbers from vodafone , but i do not know where to start to get this working
    i have tried
    http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_configuration_example09186a00808f9666.shtml
    but im getting stuck with what to fill in where .. is there anyone form NL whom has the same setup ? or similar ? or can give me some guidance on how to make the test calls

    ok.. here goes
    Building configuration...
    Current configuration : 9721 bytes
    ! Last configuration change at 15:26:14 CET Thu Jan 2 2014
    ! NVRAM config last updated at 15:26:14 CET Thu Jan 2 2014
    ! NVRAM config last updated at 15:26:14 CET Thu Jan 2 2014
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Router
    boot-start-marker
    boot-end-marker
    no aaa new-model
    clock timezone CET 1 0
    network-clock-participate wic 0
    network-clock-participate wic 1
    network-clock-select 1 E1 0/0/0
    network-clock-select 2 E1 0/0/1
    dot11 syslog
    ip source-route
    ip cef
    ip dhcp pool VOICE
    network 172.22.100.0 255.255.255.0
    option 150 ip 172.22.1.150
    default-router 172.22.100.1
    ip dhcp pool DATA
    network 172.22.101.0 255.255.255.0
    default-router 172.22.101.1
    no ip domain lookup
    no ipv6 cef
    multilink bundle-name authenticated
    isdn switch-type primary-net5
    voice service voip
    ip address trusted list
      ipv4 172.22.1.50
      ipv4 172.22.1.51
      ipv4 172.22.100.1
      ipv4 172.22.101.1
      ipv4 62.140.159.225
    callmonitor
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    no supplementary-service sip moved-temporarily
    no supplementary-service sip refer
    sip
      registrar server expires max 3600 min 3600
    voice class codec 1
    codec preference 1 g711ulaw
    codec preference 2 g711alaw
    codec preference 3 g729r8
    codec preference 4 g729br8
    voice register global
    voice translation-rule 1
    rule 1 /5123781291/ /601/
    rule 2 /5123781290/ /600/
    voice translation-rule 2
    rule 1 /^112$/ /112/
    voice translation-rule 3
    rule 1 /^.*/ /0262610290/
    voice translation-rule 4
    rule 2 /600/ /5123788000/
    rule 3 /601/ /5123788001/
    rule 4 /^2(..)$/ /51237812\1/
    voice translation-profile CUE_Voicemail/AutoAttendant
    translate called 1
    voice translation-profile PSTN_CallForwarding
    translate redirect-target 4
    translate redirect-called 4
    voice translation-profile PSTN_Outgoing
    translate calling 3
    translate called 2
    translate redirect-target 4
    translate redirect-called 4
    voice-card 0
    crypto pki token default removal timeout 0
    controller E1 0/0/0
    framing NO-CRC4
    pri-group timeslots 1-31
    controller E1 0/0/1
    framing NO-CRC4
    pri-group timeslots 1-31
    ip ftp username cisco
    ip ftp password cisco123
    ip tftp source-interface GigabitEthernet0/0.1
    interface GigabitEthernet0/0
    no ip address
    duplex auto
    speed auto
    no keepalive
    interface GigabitEthernet0/0.1
    encapsulation dot1Q 1 native
    ip address 172.22.1.51 255.255.255.0
    interface GigabitEthernet0/0.20
    encapsulation dot1Q 20
    ip address 172.22.101.1 255.255.255.0
    interface GigabitEthernet0/0.100
    encapsulation dot1Q 100
    ip address 172.22.100.1 255.255.255.0
    interface GigabitEthernet0/1
    no ip address
    shutdown
    duplex full
    speed 100
    interface Serial0/0/0:15
    no ip address
    encapsulation hdlc
    isdn switch-type primary-net5
    isdn incoming-voice voice
    no cdp enable
    interface Serial0/0/1:15
    no ip address
    encapsulation hdlc
    isdn switch-type primary-net5
    isdn incoming-voice voice
    no cdp enable
    interface BRI0/1/0
    no ip address
    isdn switch-type basic-net3
    isdn point-to-point-setup
    interface BRI0/1/1
    no ip address
    isdn switch-type basic-net3
    isdn point-to-point-setup
    ip forward-protocol nd
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http max-connections 16
    ip http path flash:gui
    ip route 0.0.0.0 0.0.0.0 172.22.1.50
    tftp-server flash:7941/apps41.8-4-1-23.sbn alias apps41.8-4-1-23.sbn
    tftp-server flash:7941/cnu41.8-4-1-23.sbn alias cnu41.8-4-1-23.sbn
    tftp-server flash:7941/dsp41.8-4-1-23.sbn alias dsp41.8-4-1-23.sbn
    tftp-server flash:7941/jar41sccp.8-4-1-23.sbn alias jar41sccp.8-4-1-23.sbn
    tftp-server flash:7941/cvm41sccp.8-4-1-23.sbn alias cvm41sccp.8-4-1-23.sbn
    tftp-server flash:7941/SCCP41.8-4-2S.loads alias SCCP41.8-4-2S.loads
    tftp-server flash:7941/term41.default.loads alias term41.default.loads
    tftp-server debug
    control-plane
    voice-port 0/0/0:15
    voice-port 0/1/0
    voice-port 0/1/1
    voice-port 0/0/1:15
    voice-port 2/0/0
    voice-port 2/0/1
    voice-port 2/0/2
    voice-port 2/0/3
    voice-port 2/0/4
    voice-port 2/0/5
    voice-port 2/0/6
    voice-port 2/0/7
    voice-port 2/0/8
    voice-port 2/0/9
    voice-port 2/0/10
    voice-port 2/0/11
    voice-port 2/0/12
    voice-port 2/0/13
    voice-port 2/0/14
    voice-port 2/0/15
    voice-port 2/0/16
    voice-port 2/0/17
    voice-port 2/0/18
    voice-port 2/0/19
    voice-port 2/0/20
    voice-port 2/0/21
    voice-port 2/0/22
    voice-port 2/0/23
    mgcp profile default
    dial-peer voice 1 voip
    description **Incomming Call from SIP Trunk**
    translation-profile incoming CUE_Voicemail/AutoAttendant
    session protocol sipv2
    session target ipv4:172.22.1.50
    incoming called-number .%
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 2 voip
    description **Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9........
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 3 voip
    description **Outgoing Call to SIP Trunk **
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9[2-9]..[2-9]......
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 4 voip
    description **Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9[0-1][2-9]..[2-9]......
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 5 voip
    description **911 Outgoing Call to SIP trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 911
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 6 voip
    description **Emergency Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9911
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 7 voip
    description **911/411 Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9[2-9]11
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 8 voip
    description **International Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9011T
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 9 voip
    description **Star Code to SIP Trunk**
    destination-pattern *..
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 10 voip
    description **CUE Voicemail**
    translation-profile outgoing PSTN_CallForwarding
    destination-pattern 600
    b2bua
    session protocol sipv2
    session target ipv4:172.22.1.155
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    dial-peer voice 11 voip
    description **CUE Auto Attendant**
    translation-profile outgoing PSTN_CallForwarding
    destination-pattern 601
    b2bua
    session protocol sipv2
    session target ipv4:172.22.1.155
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    sip-ua
    authentication username 0262610290 password 7 15020A1F173D24362C realm 62.140.1
    59.225
    authentication username 0262610290 password 7 021605481811003348
    no remote-party-id
    retry invite 2
    retry register 10
    timers connect 100
    registrar ipv4:62.140.159.225 expires 3600
    sip-server ipv4:62.140.159.224
    host-registrar
    telephony-service
    max-ephones 58
    max-dn 192
    ip source-address 172.22.100.1 port 2000
    calling-number initiator
    system message testing
    cnf-file location TFTP tftp://172.22.1.150/
    load 7960-7940 P00307020200.loads
    load 7941 SCCP41.8-4-2S.loads
    load 7941GE SCCP41.8-4-2S
    time-format 24
    dialplan-pattern 1 26261029.. extension-length 3 extension-pattern 9..
    voicemail 600
    max-conferences 12 gain -6
    call-forward pattern 9.T
    moh music-on-hold.au
    web admin system name admin password password
    dn-webedit
    time-webedit
    transfer-system full-consult
    secondary-dialtone 9
    directory entry 1 101 name 101
    create cnf-files version-stamp 7960 Jan 02 2014 08:40:49
    ephone-dn  1
    number 290 secondary 0262610290
    name Phone 1
    hold-alert 30 originator
    ephone-dn  2
    number 291 secondary 0262610291
    name phone 2
    hold-alert 30 originator
    ephone-dn  3
    number 292 secondary 0262610292
    name Phone 3
    hold-alert 30 originator
    ephone-dn  4
    number 293 secondary 0262610293
    name Phone 4
    hold-alert 30 originator
    ephone-dn  5
    number 294 secondary 0262610294
    label Phone 5
    hold-alert 30 originator
    ephone  1
    mac-address 0019.E88F.3BDD
    button  1:1
    ephone  2
    mac-address 001E.4A92.0A27
    type 7961
    button  1:2
    ephone  3
    mac-address 0012.43F5.03AF
    button  1:3
    ephone  4
    mac-address 000F.F7AC.502A
    button  1:4
    ephone  5
    mac-address 0019.E851.090A
    button  1:5
    line con 0
    line aux 0
    line vty 0 4
    login
    transport input all
    scheduler allocate 20000 1000
    ntp master
    end

  • Need some help learning cue points, etc

    I need some help with a Flash project I'm working on. If any
    Flash junkies out there are up for sitting down with me through
    email or IM and helping me get to the point where I have a template
    FLA doing what I want to do, I'd be willing to pay you. It wouldn't
    be much, but it would be something. Here's what I'm trying to do:
    I need to create an interactive talking-head style flash
    presentation with a number of progressive download externally
    linked FLV files, playing in succession, supported by movie-clip
    text animations and supporting graphics which are triggered by cue
    points in the video. I also need a simple navigation menu linking
    to the FLV files. I've got some of this down already, namely, I've
    laid the FLVs in and they are playing in succession. I'm stuck on
    the cue point part. At this point I really just need some hands-on
    help. I've bought books, I've scoured the web.
    I'm easy to communicate with, and I'm good with computers and
    comfortable in many multimedia design programs. Flash is very
    powerful, but tougher to learn than I expected, and I'm at the end
    of my rope =P

    My advice... start with a very simple "proof of concept" project before you attempt the entire package.
    It will be much easier to scale up if you first have a very good understanding of what's going on.
    So one simple video with just one cuepoint and only one button and additional display. You'll also have to work out the interaction of pausing the video when a cuepoint is reached or button pushed to display the graph, giving the viewer time to read the graph... then when the viewer closes the graph, the video should "resume".
    Start very simple and build on that only after you understand the fundamentals.
    Second, you mention "video reports"... plural. So that most likely means that you will need a video player with a "playlist".
    This may mean that you'll need to learn to use a little .xml to bring in the playlist data. You may also find xml an excellant way to bring other data into you project.
    At the link listed above there is an excellant tutorial on "Integrating Flash and XML"
    "Flash and XML"
    "XML Video Playlist"
    "ActionScript 3 XML Basics"
    "ActionScript 3 Advanced XML"
    Personally I would not even begin a project like this without considering how I could use xml to feed data into the project.
    Here's an example of a video player I created that has a playlist, thumbnails, categories, transcipts, "Now Playing" etc. All that data comes into the main .swf via various xml files. Super good way in input data into Flash.
    http://www.drheimer.com/video/
    Yours is a rather ambitious project and will take awhile to gain the skill and assemble the pieces. So when you come to a new part... first create a real simple "proof of concept" model so you can learn how that section works. Don't expect to be able to assemble the entire project all at once.
    Best wishes,
    Adninjastrator

  • Need some help, system won't boot now.

    Yesterday, I was having trouble getting WinXP installed on my SATA drive...after I tried some stuff to no avail, I decided to call it a night.  When I got up, I went to boot up the system and now all that happens is the 1 LED light flashes and the CD-ROM LED light flashes(and even these don't happen all the time).  Nothing else happens, fans don't start etc.  So I need some help on troubleshooting this prob.  When I do start it up, the D-bracket LEDs flash 4 red also, just flash like the other LED lights.  My first guess would be that the PSU is dead?  My PSU is a Antec Truepower 380W.  Any help is much appreciated.

    Believe Bas; As he is 100% Correct, as even 18 Amps is not anywhere enough on the +12V Rail nowadays, I mean I think the New "Minimum" Should be No Less than 25 Amps on the +12V Rail, With these new Powerful Vidio Cards, that Require thier own "Molex" Power Supply Connected to them (As most of these Top Nvidia FX, and ATI Pro's) Need and they can demand up to 6 Amps themselves, I mean, these Cards Have 400 and 550MHZ GPU's on them with over 100 Million Transistors, Not to mention the Extra 256MB of High Speed Graphics memory, Add this with a New 64BIT CPU, and a Sound Card, and a Couple of S-ATA's in RAID, And the 1GIG of High Speed System RAM, and you Are At or Over 18 Amps Already , And we are not even talking CD and DVD's or the At least 4 Fans that you should have ...Yep I for one say the Day's of the 18 Amp Min. Rating for the +12V Rail are Gone Forever...Why do you think that all the Really Good PSu's have At Least 30 Amp Ratings on thier +12V Rails......And in the Case of Enermax, They even went as Far to Start Building thier PSU's With 2 (Dual) +12V Rails ...Thats right, Now they have a +12V-1, and a +12V-2 , Now the CPU gets it's OWN Dedicated +12V Rail, and the System Gets the +12V-2 Rail.......I just got the new Enermax for my 3RD Rig that I'm Building (Dual Opteron 248) Rig , with Bas's Help of Coarse.....But For $99.00 US  It was the Best Money spent yet, so much, for a little Price, as the Antec Units are More expensive...And I hear that they are doing a little Cheating on thier Amp Ratings these Days ..Ask "Wonk" he will tell you...  ..............Sean REILLY875

  • Remote App on iPad connects but drops after about  20 mins. Need to turn  off wait about 1 minute then turn on wifi on iMac before it can reconnect. Need some help please.

    Remote App on iPad connects but drops after about  20 mins. Need to turn  off wait about 1 minute, then turn on wifi on iMac before it can reconnect. Need some help please.
    Already gone through troubleshooting guide a zillion times. Thanks.

    This worked for me... A little time consuming but once you get rolling it goes GREAT... Thanks....
    I got my artwork and saved it to my Desktop
    Opened up Microsoft Paint and clicked on "File" and "Open" and found it to get it on the screen to resize it
    Clicked "resize" and a box for changing it opened up
    Checked the box "Pixels" and "Unchecked maintain aspect ratio"
    Set Horizontal for 640 and Vertical for 480
    Clicked on "OK" and went back to "File" and did a "Save As" and chose JPEG Picture
    It came up "File Already Existed" and clicked "OK" (really did not care about the original artwork I found because wrong size)
    Went to iTunes and on the movie right clicked on "Get Info", clicked on "Details", then "Artwork"
    Go to the little box on the top left that shows your old artwork and click on it to get the little blue border to appear around it and hit "Delete" to make it gone
    Click on "Add Artwork" and find it where you put the one from above on your Desktop and hit "Open" and OK and your new artwork is now there and all good.
    Sounds like a lot of steps to follow but after around 5 or so you will fly through it. This worked perfect on my iPhone 6 Plus and I have artwork on my Home Videos now.

  • TS1702 I need some help the apps were downloading slowly

    The apps downloaded but it didn't cause it's stuck in downloading mode what should I do?
    The iOS 6 update didn't work.
    Please I need some help.
    The apps didn't download.
    Talking Angela and Ginger didn't download.
    Talking Santa didn't update.

    Try moving the existing backup file to a safe location so that iTunes has to create an entire new file.  The backup file is located here. You can delete that backup once you get a successfull backup.
    iTunes places the backup files in the following places:
    Mac: ~/Library/Application Support/MobileSync/Backup/
    Windows XP: \Documents and Settings\(username)\Application Data\Apple Computer\MobileSync\Backup\
    Windows Vista and Windows 7: \Users\(username)\AppData\Roaming\Apple Computer\MobileSync\Backup\
    Note: If you do not see the AppData or Application Data folders, you may need to show hidden files (Windows XP,  Windows Vista and Windows 7), or iTunes may not be installed in the default location. Show hidden files and then search the hard drive for the Backup directory.

  • Need some help: my itunes won't sync with my iphone anymore. Both softwares are up to date and I've reinstalled itunes. After I reinstall, it syncs. But then when I reboot my computer, it no longer syncs anymore and I have to keep reinstalling itunes. Tho

    Need some help: my itunes won't sync with my iphone anymore. Both softwares are up to date and I've reinstalled itunes. After I reinstall, it syncs. But then when I reboot my computer, it no longer syncs anymore and I have to keep reinstalling itunes. Thoughts???

    thought that it was possible to have the same iTunes library on any machine that was authorised, a kind of cloud-iTunes I guess. 
    That would convenient, but sadly it is not the case. Sorry!
    Either way your welcome and best of luck!
    B-rock

  • Need some help in creating Search Help for standard screen/field

    I need some help in adding a search-help to a standard screen-field.
    Transaction Code - PP01,
    Plan Version - Current Plan (PLVAR = '01'),
    Object Type - Position ( OTYPE = 'S'),
    Click on Infotype Name - Object ( Infotype 1000) and Create.
    I need to add search help to fields Object Abbr (P1000-SHORT) / Object Name (P1000-STEXT).
    I want to create one custom table with fields, Position Abb, Position Name, Job. Position Abb should be Primary Key. And when object type is Position (S), I should be able to press F4 for Object Abb/Object Name fields and should return Position Abbr and Position Name.
    I specify again, I have to add a new search help to standard screen/field and not to enhance it.
    This is HR specific transaction. If someone has done similar thing with some other transation, please let me know.
    There is no existing search help for these fields. If sm1 ever tried or has an idea how to add new search help to a standard screen/field.
    It's urgent.
    Thanks in advace. Suitable answers will be rewarded

    Hi Pradeep,
    Please have a look into the below site which might be useful
    Enhancing a Standard Search Help
    https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/daeda0d7-0701-0010-8caa-
    edc983384237
    http://help.sap.com/saphelp_nw04/helpdata/en/cf/21ee93446011d189700000e8322d00/frameset.htm
    A search help exit is a function module for making the input help process described by the search help more flexible than possible with the standard version.
    This function module must have the same interface as function module F4IF_SHLP_EXIT_EXAMPLE. The search help exit may also have further optional parameters (in particular any EXPORTING parameters).
    A search help exit is called at certain timepoints in the input help process.
    Note: The source text and long documentation of the above-specified function module (including the long documentation about the parameters) contain information about using search help exits.
    Function modules are provided in the function library for operations that are frequently executed in search help exits. The names of these function modules begin with the prefix F4UT_. These function modules can either be used directly as search help exits or used within other search help exits. You can find precise instructions for use in the long documentation for the corresponding function module.
    During the input help process, a number of timepoints are defined that each define the beginning of an important operation of the input help process.
    If the input help process is defined with a search help having a search help exit, this search help exit is called at each of these timepoints. If required, the search help exit can also influence the process and even determine that the process should be continued at a different timepoint.
    timepoints
    The following timepoints are defined:
    1. SELONE
    Call before selecting an elementary search help. The possible elementary search helps are already in SHLP_TAB. This timepoint can be used in a search help exit of a collective search help to restrict the selection possibilities for the elementary search helps.
    Entries that are deleted from SHLP_TAB in this step are not offered in the elementary search help selection. If there is only one entry remaining in SHLP_TAB, the dialog box for selecting elementary search helps is skipped. You may not change the next timepoint.
    The timepoint is not accessed again if another elementary search help is to be selected during the dialog.
    2. PRESEL1
    After selecting an elementary search help. Table INTERFACE has not yet been copied to table SELOPT at this timepoint in the definition of the search help (type SHLP_DESCR_T). This means that you can still influence the attachment of the search help to the screen here. (Table INTERFACE contains the information about how the search help parameters are related to the screen fields).
    3. PRESEL
    Before sending the dialog box for restricting values. This timepoint is suitable for predefining the value restriction or for completely suppressing or copying the dialog.
    4. SELECT
    Before selecting the values. If you do not want the default selection, you should copy this timepoint with a search help exit. DISP should be set as the next timepoint.
    5. DISP
    Before displaying the hit list. This timepoint is suitable for restricting the values to be displayed, e.g. depending on authorizations.
    6. RETURN (usually as return value for the next timepoint)
    The RETURN timepoint should be returned as the next step if a single hit was selected in a search help exit.
    It can make sense to change the F4 flow at this timepoint if control of the process sequence of the Transaction should depend on the selected value (typical example: setting SET/GET parameters). However, you should note that the process will then depend on whether a value was entered manually or with an input help.
    7. RETTOP
    You only go to this timepoint if the input help is controlled by a collective search help. It directly follows the timepoint RETURN. The search help exit of the collective search help, however, is called at timepoint RETTOP.
    8. EXIT (only for return as next timepoint)
    The EXIT timepoint should be returned as the next step if the user had the opportunity to terminate the dialog within the search help exit.
    9. CREATE
    The CREATE timepoint is only accessed if the user selects the function "Create new values". This function is only available if field CUSTTAB of the control string CALLCONTROL was given a value not equal to SPACE earlier on.
    The name of the (customizing) table to be maintained is normally entered there. The next step returned after CREATE should be SELECT so that the newly entered value can be selected and then displayed.
    10. APP1, APP2, APP3
    If further pushbuttons are introduced in the hit list with function module F4UT_LIST_EXIT, these timepoints are introduced. They are accessed when the user presses the corresponding pushbutton.
    Note: If the F4 help is controlled by a collective search help, the search help exit of the collective search help is called at timepoints SELONE and RETTOP. (RETTOP only if the user selects a value.) At all other timepoints the search help exit of the selected elementary search help is called.
    If the F4 help is controlled by an elementary search help, timepoint RETTOP is not executed. The search help exit of the elementary search help is called at timepoint SELONE (at the
    F4IF_SHLP_EXIT_EXAMPLE
    This module has been created as an example for the interface and design of Search help exits in Search help.
    All the interface parameters defined here are mandatory for a function module to be used as a search help exit, because the calling program does not know which parameters are actually used internally.
    A search help exit is called repeatedly in connection with several
    events during the F4 process. The relevant step of the process is passed on in the CALLCONTROL step. If the module is intended to perform only a few modifications before the step, CALLCONTROL-STEP should remain unchanged.
    However, if the step is performed completely by the module, the following step must be returned in CALLCONTROL-STEP.
    The module must react with an immediate EXIT to all steps that it does not know or does not want to handle.
    Hope this info will help you.
    ***Reward points if found useful
    Regards,
    Naresh

Maybe you are looking for