Access to biw from r3 via abap

hi folks,
we are using ecc 6.0 and biw 7.0 , and have a lot of abaps that have to directly show data from biw in e.g. an alv, in former days we had EIS and just selected the cf7xx tables to do this, but does anybody know how we can achive this easily using direct calls to biw or something like this.
best regards,
oliver

There are multiple ways of accessing BW data from ECC.
- Create a ABAP in ECC and make a RFC functional to BW
- Create a report in BW and dump the output to one of the tables in ECC using APD process
- From BW report, you can always link the ECC transaction
Regds,
Ravi

Similar Messages

  • Selecting Data from DSO via ABAP Routine

    Hello,
    i dont know how to solve my special requirements with sap bw. Maybe you have some idea.
    I have a row of data in my DSO, which is like:
    Date               ObjectA     ObjectB          Amount
    2014 08 18     testA          testB              1000
    2014 08 19     testA          testC              500
    2014 08 20     testA          testB              2000
    I want to have a key figure in my reports, which shows a special smoothed average per day of the past 3 months for each day-object combination.
    The formula how the average is calculated, should be neglected in that example.
    Date               ObjectA     ObjectB          Amount     smoothed average
    2014 08 18     testA          testB              1000          900
    2014 08 19     testA          testC              200            150  
    2014 08 20     testA          testB              2000          950
    2014 09 20     testA          testB              3000          1000
    My first idea was that I have to create that key figure in the transformation from DSO to my cube, because there is no option for that advanced calculations in queries.
    So I need access to all the data in my DSO while i am in an abap environment in the transformation routine. I need that because i have to do calculations from data in the past. How can I achieve this? Or are there other ways to solve my requirements?
    I hope you can help.
    Best regards
    Simon

    You should utilize the start routine or end routine functionality of a 7.x transformation.
    You can read from the DSO active table which has the naming convention: /BI0/A + dsoName + 00 (business content dso) or /BIC/A + dsoName + 00.
    For example in end routine:
    //local data declaration
    DATA: lt_dso TYPE standard table of /bic/azfi_o0100.
    FIELD-SYMBOLS: <fs_dso> type /bic/azfi_o0100.
    //get data
    SELECT *
    FROM /bic/azfi_o0100
    INTO table lt_dso
    FOR ALL ENTRIES IN RESULT_PACKAGE
    WHERE objectA = objectA AND
                   objectB = objectB.
    SORT lt_dso BY objectA objectB.
    //populate result package
    LOOP AT RESULT_PACKAGE ASSIGNING <result_fields>.
    READ TABLE lt_dso ASSIGNING <fs_dso>
    WITH KEY objectA = <result_fields>-objectA
                      objectB = <result_fields>-objectB
    binary search.
    //do calculation...
    <result_fields>-zsmoothavg = ...
    ENDLOOP.

  • How to call BW report from CRM via ABAP

    Hello,
    I want to call a BW report from CRM, this I want to invoke from a screen with some parameter.
    I have a BW user which I also wants to pass from CRM screen, while calling BW report as parameter.
    Can some one help me, how to invoke a BW report (in browser) from CRM ABAP code with passing username and password (which is a generic user to all) and with some parameters to BW report, so that can directly see the report output in the browser.
    Thanks a lot in advance.
    With Best Regards,
    -Praveen Soni

    Praveen,
    all you basically have to do is construct a URL in your ABAP program and call the browser with it. In the URL you can pass the right parameters. Execute your query in transaction RSRT with option HTML and you see parameters. Or execute it directly in the browser.
    When you have the URL, just do call function 'CALL_BROWSER'.
    Regards,
    Marc
    SAP NetWeaver RIG, US BI

  • Cant access Cs Live from application via proxy server

    Hi,
    I have a problem with CS Live. When I try and access it via a web browser I can login ok, but when I try using the application extension and sign in that way it gets rejected.
    Web access is via a Bluecoat proxy server. Checking the access logs I found the following message (ip's replaced with x's):
    xxx.xxx.xxx.xxx - - authentication_failed PROXIED "Computers/Internet" - 407 TCP_DENIED CONNECT - tcp services.acrobat.com 443 / - - "Adobe-ServiceManager" xxx.xxx.xxx.xxx 341 179 -
    I have rules setup inside the proxy for whitelist's that can allow access for problem websites, but including services.acrobat.com inside them doesnt have any effect.
    has anyone every come across this as it was working ok with no changes made a week ago and now it doesnt.
    Thanks

    Having the same problem - Having no luck either, sorry I'm of no help but would appreciate some help if you figure something out. Thanks
    Stephanie

  • Portal 7.3 & Web Dynpro iView, both accessed from Internet via Web Dispatch

    Hi guru,
    I'd like to know the best (or the correct) way to configure the FQDN and required DNS setting to allow user access ABAP Web Dynpro iview from internet.
    My setup here is very typical:
    One EP 7.3 in intranet, having "ep.internal.mycomp.com" as FQDN (given during installation)
    One SAP ECC in intranet, having "erp.internal.mycomp.com" as SAPLOCALHOSTFULL parameter
    One Web Dispatcher in DMZ, having "service.mycomp.com", and listen to 80 port (later added 8000 port for AS ABAP).
       User access my portal by using http://service.mycomp.com/irj, no problem.
    But problem raised during access WD4A iview, here are my problem and questions:
    [Problem]
    At the beginning, we found that the WD4A iView can only be accessed in intranet, not from internet. Eventhough we register "service.mycomp.com" in public DNS. After some http level analysis, I was shock that the WD4A iview is provided directly by AS ABAP which running this WD4A, EP does not play a "relay" role. (Don't believe the URL bar in your IE, use Tamper Data or HTTP live to check the HTTP requests, you will get it). Since we DO NOT have "erp.internal.mycomp.com" in public DNS, so the iview cannot be displayed. But I DON'T want direct access to my ERP box.
    I don't know a way to get rid of the "erp.mycomp.com" request generated by EP. So I tried to overcome the problem by leveraging the same Web Dispatcher used by EP. And I did make the WDisp -> ERP WD4A work using WDisp's FQDN (ie. service.mycomp.com:8000, also keep original service.mycomp.com:80 to EP), but the iview in EP does not use this FQDN. It use the SAPLOCALHOSTFULL parameter configured in backend ERP.  WDisp does not do any URL replacement for me.
    [Question 1]
    Is there any way to hide WD4A iview in EP (server to server communication only)?
    [Question 2]
    If I can only have "service.mycomp.com" entry in my public DNS, should I change the SAPLOCALHOSTFULL in ERP to "service.mycomp.com"?  I doubt  that it may cause a "loop" situation between WDisp and ERP ?
    [Question 3]
    Is it possible to access WD4A on ERP by two different FQDNs (one for public via WDisp, the other for internal access w/o WDisp) ? I know there is only one SAPLOCALHOSTFULL configuration.
    Anyone have done such integration ? please share your configuraiton. Thanks

    Hay Wei-Shang Ku,
    Many thanks to your prompt reply of this very old post I tried to ask!
    for the /sap/* redirect, think it required to use icm/HTTP/redirect_<xx> parametet in WDISP profile. And i did applied below too to make default WDISP URL go to /irj  (Portal login page).
    icm/HTTP/redirect_0 = PREFIX=/,TO=/irj
    so for "all request to /sap/* will go to ERP":
    icm/HTTP/redirect_0 = PREFIX=/sap/*,TO=/???  (how do you set the TO value here?)
    May i have your WDISP profile setting for reference? Did you make use of parameter wdisp/system_0?
    And here is my overall setting:
    we only have "service.mycomp.com" entry in public DNS.
    1. "service.mycomp.com" is WDISP URL mapped to 1 public IP (we used default http 80 port)
    2. we want user can access JPortal & also backend ERP via WebDynpro iView in JPortal via
       service.mycomp.com  (only port only)
    3. ERP system profile:
        SAPLOCALHOSTFULL = <ERPHOSTNAME>.mycomp.com (not in public DNS)
        icm/server_port_0 = PROT=HTTP,PORT=80$$,TIMEOUT=3600,PROCTIMEOUT=3600
    4. Portal:
        ABAP WebDynpro iView setting -
       System  = XXX (where XXX is alias of system iView)
      System iView setting -
        Logical System Name = ERPCLNTXXX
        ITS host = <ERPHOSTNAME>.mycomp.com:8000
    Thanks again your information, have headache of this issue for long times....
    Gary

  • Access Enterprise Search via ABAP Web Service

    Hello ES experts,
    I am looking for more information on how to access Enterprise Search via ABAP web service QSDispatcher, using processQuery operation. I created a client proxy and need information on structure of input and output parameters (query and query result)
    Thanks, Srdjan

    Hi Srdjan
    You can access the SAP ABAP system by configuring it in the NW ES admin console, any system with version > 4.6C can be integrated in the search engine.
    The UI for NW ES is a WebDynpro via Web Browser (In the future will be integrated in Widgets and Portal, etc) but i'm not sure if you want to use the WS to access the results of the ES searching or if you want to integrate a WS from ABAP as part of the searching area...
    Please clarify.
    Thanks,
    Best Regards,
    Luis

  • How to extract data from BPC InfoCube via ABAP program?

    Hi experts!!
    I tried to extract data from a BPC InfoCube via ABAP program, but I did'n have succeed.
    I used the function 'RSDRI_INFOPROV_READ' to extract data from standard InfoCubes such as '0COPC_C07' and it run OK! However, when I change the InfoCube name to '/CPMB/WAIX8NE' (BPC InfoCube), everything goes wrong...
    Is there any difference between extracting data from BPC and standard InfoCubes?
    Thank you all!

    Moderator message - Welcome to SCN.
    But please do not cross and duplicate post.
    Thread locked.
    Rob

  • Push data from BW 3.5 to XI 3.0 via ABAP proxy

    Hi,
      I have the following scenario: I´m in BW 3.5 trying to send data to XI 3.0 via ABAP proxy. I´ve already found a "How-to" to do build this scenario, but something does not work. I think that problem is when a try do the logon from BW to XI because I got the message "logon data not provided" on http service in XI. I´ve already configure an RFC Destination(SM59) as R/3 connection(type 3) and another as HTTP connection to R/3(type H) and both are correct. Someone knows where I configure the user/pass to logon from BW Intergration Server to XI Integration Server?
    Regards,
    Rafael Soares

    Hello fellows!
       I discovered that my problem was configuration on SXMB_ADM transaction.
       Thank you very much for your help!
    Best regards.
    Rafael

  • Accessing network from home via static IP

    Hello. I have a small network at the company that I own. We are a Mac network running Tiger on most machines. The server is 10.3. We just moved offices and have a new internet/DSL provider. At my old office, we had a static IP configured that allowed me to log in from home via the IP address. Now that we moved, I can't figure out how to get it set up to allow access through the new IP address. I have the modem set with a static IP for the WAN settings. Is there something I need to do on the server as well? I know just enough to be dangerous, but I'm not at all a network/IT expert. Any assistance would be appreciated.
    Thanks, Greg

    I think your best bet would be to configure the VPN server that way all your access would be sent over an encrypted network connection to your office network.
    Basically what that means is no one would be able to easily sniff out sensitive info from you. The VPN server is pretty easy to setup and works great for me. I access my office network from my home network to fix problems in the middle of the night so I don't have to drive into work.
    If you want more info or possibly some help setting it up, feel free to e-mail me at: japruim AT raoset DoT com (Make it a normal email and it will work just fine) Stupid spam bots

  • Gateway access from an Internal ABAP server

    Hi All,
    I am new to Gateway.
    We are having a ABAP backend system from where we are trying to access Gateway service through an UI5 application.
    Our backend server and Gateway server are 2 different servers in our intranet.
    Initially we got cross-origin errors. After resolving the error, we got an error "ERROR: ONLY FOR TESTING PURPOSE" from the SimpleServletProxy.
    Is it like the gateway service can be accessed only if both UI5 app and Gateway service are in same servers?
    Is there any way that an UI5 app can access gateway service from a different server?
    Please let me know if anyone has some answers.
    Thank you
    Rakesh

    Rakesh,
    What you are experiencing is due to a policy enforced by browsers called as "Same Origin Policy".
    Here is a nice blog on how to handle it in different ways.
    Solving "Same Origin Policy" Issue in different ways
    regards
    Krishna

  • Is it possible to access my TimeCapsule from outside my local network via internet? If so what is the best app  that  can help me?

    is it possible to access my TimeCapsule from outside my local network via internet? If so what is the best app  that  can help me?

    iCloud can do it..
    http://www.apple.com/au/support/icloud/back-to-my-mac/
    You need Lion and latest firmware on the TC..
    Were you hoping to use the ipad/iphone??  That maybe possible but I am not sure how.
    You cannot use windows without opening SMB to some strange port and this is going to mess with security.. you also need a static ip address from your ISP.. most private net users do not have this.
    You can do it via vpn.. you will need to buy a vpn router and bridge the TC to it.
    Just google remote access time capsule.. there are a zillion posts about it.

  • How do I access a network camera from internet via 501

    Please understand that I am nowhere near being a network guru and I'm even farther away from being a PIX guru.
    I have a 501 PIX between my home network and the outside internet. The PIX is connected to a cable modem and pretty much keeps the same DHCP IP address as assigned by the ISP. I have an AXIS 207 IP camera connected to my home network on IP 192.168.1.11. For the sake of illustration say the address assigned by my cable ISP is 123.123.123.1.
    What I need to do is to access the camera from the internet. To do that I suppose I need to add some instructions to the PIX configuration but I don't know where to start...I have never even thought about communicating with devices on my home network through the internet. Can someone please provide some pointers or better yet the commands I need to add. The next question is how do I access the camera assuming the PIX is all set up. I don't think I use the camera's address and I don't know how the ISP address would get to a specific device such as the camera - maybe appending a port number or whatever to the IP address I type when trying to access the camera from the internet?
    The way the camera works on the internal network is you type in it's IP address in a browser window and the camera opens up a web page just like any url and the video is streamed to a window in the web page.
    I hope I've provided enough info to understand what I'm trying to do and I would be most appreciative for any help.
    thanks

    I tried installing the commands as provided but am running into issues. Here are the error messages:
    pixfirewall(config)# nat (inside) 1 0.0.0.0
    ERROR: Duplicate NAT entry
    ERROR: fail to insert nat entry
    pixfirewall(config)# global (outside) 1 xxx.xxx.114.55
    ERROR: xxx.xxx.114.55-xxx.xxx.114.55 overlaps with outside interface address
    pixfirewall(config)#
    And here is a copy of my current configuration (including the code prior to entering the changes and the successful changes). Any Idea what needs to be done to fix things?
    thanks
    Building configuration...
    : Saved
    PIX Version 6.3(5)
    interface ethernet0 auto
    interface ethernet1 100full
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password xxx
    passwd xxx
    hostname pixfirewall
    domain-name ciscopix.com
    clock timezone CST -6
    clock summer-time CDT recurring
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    access-list 100 permit icmp any any echo-reply
    access-list 100 permit icmp any any time-exceeded
    access-list 100 permit icmp any any unreachable
    access-list inbound permit tcp any host xxx.xxx.114.55 eq www
    pager lines 24
    logging timestamp
    logging trap informational
    logging host inside 192.168.1.3
    icmp deny any echo outside
    mtu outside 1500
    mtu inside 1500
    ip address outside dhcp setroute
    ip address inside 192.168.1.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    pdm location 192.168.1.3 255.255.255.255 inside
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) tcp xxx.xxx.114.55 www 192.168.1.11 www netmask 255.255.255.255 0 0
    access-group inbound in interface outside
    timeout xlate 0:05:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout sip-disconnect 0:02:00 sip-invite 0:03:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server TACACS+ max-failed-attempts 3
    aaa-server TACACS+ deadtime 10
    aaa-server RADIUS protocol radius
    aaa-server RADIUS max-failed-attempts 3
    aaa-server RADIUS deadtime 10
    aaa-server LOCAL protocol local
    aaa authentication http console LOCAL
    aaa authentication telnet console LOCAL
    aaa authentication serial console LOCAL
    aaa authentication enable console LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    telnet 192.168.1.0 255.255.255.0 inside
    telnet timeout 15
    ssh timeout 5
    console timeout 0
    dhcpd address 192.168.1.6-192.168.1.10 inside
    dhcpd dns 207.69.188.171 207.69.188.172
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd auto_config outside
    dhcpd enable inside
    username administrator password xxx privilege 15
    terminal width 80
    Cryptochecksum:xxx
    : end
    [OK]

  • Can we access PI tables from WebDynpro Java via PI 7.1?

    Hi Experts
    Is it possible to fetch PI Tables (to display monitoring and alerts as dashboard on portal) from Java Stack. I got some javadocs API SAP Netweaver for PI 7.1 but i don't know how far it can help me in solving my purpose of fetching and displaying the PI monitoring data on Portal.
    https://www.sdn.sap.com/irj/sdn/javadocs
    Please advise if J2EE access to PI Tables is possible or RFC is the suggested solution to fetch PI Monitoring data.
    Thanks
    Neha

    Hi Neha,
    You can access PI tables from Webdynpro Java application using RFC or Webservices. Create RFC or Webservices which will fetch data from the PI tables.Create the required JCO's and the Webdynpro java application which uses the Adaptive RFC model or Adaptive Webservice Model to connect to the ECC system.
    I found a document that speaks about fetching data from SXMB_MONI Standard Table https://www.sdn.sap.com/irj/scn/go/portal/prtroot/docs/library/uuid/b050ff4f-84c3-2b10-3d99-8f9c44f57a17
    Hope this is useful.
    Regards,
    Seema Rane.

  • Link to Messaging tool data via ABAP stack

    Is there a way to get access to adapter data or the audit log linked to a message id via ABAP class or a FM.
    I'm using objects from CL_XMS_PERSIST and CL_XMS_PERSIST_ADM and either of them does not provide the adapter specific status.
    I really appreciate any leads in this area.
    Thank you.

    Hi Parimala
    I doubt there is any standard ABAP code available to access the adapter framework, since it runs in the J2EE stack. You might be able to access the information you want via http at http://host:port/mdt/monitorservlet, but this would likely require considerable reverse-engineering on your part.
    Regards,
    Thorsten

  • Access SAP data from xMII 12.1 without RFC or JCO

    Hi All,
    Is it possible to access/get data from SAP in xMII without RFC/ JCO call?
    Let me know if there is other option available..
    Regards,
    Sachin

    Sachin,
    As far my knowledge goes the primarily used forms of achieving MII to ERP connectivity,
    1) MII -- ERP (via RFC, IDOC's, BAPI's)
    2) MII -- PI(XI) -- ERP
    3) MII -- ESR -- ERP (Web-services)
    But, I completely concur with Mike on this, you do not need to create any function modules unless you have no other choice.
    Check this link for List of Bapi's available and their description
    [BAPI List|http://www.sapbapi.com/bapi-list/]
    If none of the BAPI's really meets your requirement then you can go for "RFC_READ_TABLE" this RFC accepts the SAP table name and desired column names. (in a way you will be accessing the SAP DB you are looking for...)
    Yet, if none of the above options suffices your requirement only then you go for writing a custom Function module.
    [Writing Function Module|http://abaplovers.blogspot.com/2008/02/creating-function-module-in-sap-abap.html]
    Good Luck!!
    Regards,
    Adarsh

Maybe you are looking for