Accessing the network from extproc

Hi! (dont know if this the correct forum category, but couldnt find any other suitable).
We have a 11.2 database running on Red Hat 5.5. The database have a scheduled job to fetch some files from another server using ftp, and herein lies the problem.
The job runs a pl/sql that runs the function in an (by us compiled) external library. The ftp-functionality itself is done by using libncftp and it's API's.
The process starts correctly, but then trying to login to the actual ftp host, ncftp only reports "Unknown username/password" (which is not the case).
I have the exact same code in an executable and when run from an interactive shell, it works fine.
So the only thing I can come up with, is there are differences when the process is started by Oracle, rather then being "an ordinary" process.
And I am stuck.
If there are any environment variables, paths etc missing when running the extproc-process, how do I find out which?
Regards
// Richard
Edited by: user6702107 on 2011-jun-09 06:33
Edited by: user6702107 on 2011-jun-09 06:33

You need to configure your listener to handle external procedures ie extproc
Such as
SID_LIST_LISTENER =
(SID_LIST =
(SID_DESC =
(SID_NAME = PLSExtProc)
(ORACLE_HOME = /ora/db)
(PROGRAM = extproc)
(ENVS = "EXTPROC_DLLS=ANY")
LISTENER =
(DESCRIPTION_LIST =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = Your host )(PORT = 1521))
(ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC0))
And you listener when restarted should have a entry something like
Listening Endpoints Summary...
(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=Your Host)(PORT=1521)))
(DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=EXTPROC0)))
Services Summary...
Service "PLSExtProc" has 1 instance(s).
Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...

Similar Messages

  • UNABLE TO ACCESS THE INTERNET FROM LOCAL PROVIDER ON A SITE-TO-SITE VPN CONNECTION

    Dear All,
    I have a site-to-site connection  from point A to point B. From point B i am unable to access the internet from local internet provider.
    I am trying to ping from 192.168.20.1 the dns 8.8.8.8   but i receive the  message "destination net unreachable".
    When i run "show ip nat translation" i receive nothing.
    The vpn connection is working properly, i can ping the other side 192.168.10/24
    Below is the configuration of the cisco router on point B.
    dot11 syslog
    ip source-route
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.21.254
    ip dhcp pool voice
     network 192.168.21.0 255.255.255.0
     default-router 192.168.21.254 
     option 150 ip 192.168.5.10 
    ip cef
    ip domain name neocleous.ru
    ip inspect name IOS_FIREWALL tcp
    ip inspect name IOS_FIREWALL udp
    ip inspect name IOS_FIREWALL icmp
    ip inspect name IOS_FIREWALL h323
    ip inspect name IOS_FIREWALL http
    ip inspect name IOS_FIREWALL https
    ip inspect name IOS_FIREWALL skinny
    ip inspect name IOS_FIREWALL sip
    no ipv6 cef
    multilink bundle-name authenticated
    vty-async
    isdn switch-type primary-net5
    redundancy
    crypto isakmp policy 5
     hash md5
     authentication pre-share
     group 2
    crypto isakmp policy 10
     encr aes
     authentication pre-share
     group 2
     lifetime 28800
    crypto isakmp policy 50
     encr 3des
     hash md5
     authentication pre-share
     group 2
    crypto isakmp key Pb85heuvMde9Wdac5Qohha7lziIf142u address [ip address]
    crypto isakmp invalid-spi-recovery
    crypto isakmp keepalive 10
    crypto ipsec transform-set TRANSET esp-aes esp-sha-hmac 
    crypto ipsec transform-set TRANSET2 esp-des esp-md5-hmac 
    crypto ipsec df-bit clear
    crypto map CryptoMAP1 ipsec-isakmp 
     set peer [ip address]
     set transform-set TRANSET 
     match address CryptoACL
    interface FastEthernet0/0
     description Primary Provider
     ip address [PUBLIC IP MAIN PROVIDER] 255.255.255.252
     ip access-group outside_acl in
     ip mtu 1390
     ip nat outside
     ip virtual-reassembly in
     load-interval 30
     duplex auto
     speed auto
     crypto map CryptoCY
     crypto ipsec df-bit clear
    interface FastEthernet0/1
     description TO LAN
     no ip address
     load-interval 30
     speed 100
     full-duplex
    interface FastEthernet0/1.1
     description DATA VLAN
     encapsulation dot1Q 20
     ip address 192.168.20.254 255.255.255.0
     ip access-group inside_acl in
     ip nat inside
     ip inspect IOS_FIREWALL in
     ip virtual-reassembly in
     ip tcp adjust-mss 1379
    interface FastEthernet0/1.2
     description VOICE VLAN
     encapsulation dot1Q 21
     ip address 192.168.21.254 255.255.255.0
    interface Serial0/2/0:15
     no ip address
     encapsulation hdlc
     isdn switch-type primary-net5
     isdn incoming-voice voice
     no cdp enable
    interface FastEthernet0/3/0
     no ip address
     ip access-group outside_acl in
     ip nat outside
     ip virtual-reassembly in
     shutdown
     duplex auto
     speed auto
     crypto map CryptoCY
    ip local pool VPNPool 192.168.23.2 192.168.23.10
    ip forward-protocol nd
    ip http server
    no ip http secure-server
    ip nat inside source list nat_list interface FastEthernet0/3/0 overload
    ip route 0.0.0.0 0.0.0.0 [default gateway ip]
    ip access-list standard VTY
      permit 192.168.20.0 0.0.0.255
    ip access-list extended CryptoACL
     permit ip 192.168.20.0 0.0.0.255 192.168.3.0 0.0.0.255
     permit ip 192.168.21.0 0.0.0.255 192.168.5.0 0.0.0.255
     permit ip 192.168.21.0 0.0.0.255 192.168.6.0 0.0.0.255
     permit ip 192.168.21.0 0.0.0.255 192.168.12.0 0.0.0.255
     permit ip 192.168.21.0 0.0.0.255 192.168.2.0 0.0.0.255
     permit ip 192.168.20.0 0.0.0.255 192.168.10.0 0.0.0.255
     permit ip host 192.168.22.1 192.168.5.0 0.0.0.255
     permit ip host 192.168.20.1 192.168.5.0 0.0.0.255
     permit ip host 192.168.22.1 192.168.6.0 0.0.0.255
    ip access-list extended DFBIT_acl
     permit tcp any any
    ip access-list extended inside_acl
     permit ip 192.168.20.0 0.0.0.255 host 192.168.3.35
     permit ip 192.168.20.0 0.0.0.255 host 192.168.3.39
     permit ip 192.168.20.0 0.0.0.255 host 192.168.3.23
     permit ip 192.168.20.0 0.0.0.255 host 192.168.3.18
     permit ip 192.168.20.0 0.0.0.255 host 192.168.3.55
     permit ip 192.168.20.0 0.0.0.255 host 192.168.10.144
     permit ip 192.168.20.0 0.0.0.255 host 192.168.10.146
     permit ip 192.168.20.0 0.0.0.255 host 192.168.10.141
     permit ip host 192.168.20.253 host 192.168.3.21
     permit ip host 192.168.20.254 host 192.168.3.21
     permit ip 192.168.20.0 0.0.0.255 host 192.168.3.10
     permit ip 192.168.20.0 0.0.0.255 host 192.168.20.254
    ip access-list extended nat_list
     deny   ip host 192.168.20.254 192.168.10.0 0.0.0.255
     deny   ip host 192.168.20.254 192.168.3.0 0.0.0.255
     deny   ip host 192.168.20.1 192.168.3.0 0.0.0.255
     deny   ip host 192.168.20.1 192.168.10.0 0.0.0.255
     deny   ip host 192.168.20.2 192.168.3.0 0.0.0.255
     deny   ip host 192.168.20.2 192.168.10.0 0.0.0.255
     permit ip host 192.168.20.1 any
     permit ip host 192.168.20.2 any
     permit ip host 192.168.20.254 any
    ip access-list extended outside_acl
     permit gre any host [ip address]
     permit esp any host [ip address]
     deny   ip any any
    ip sla 2
     icmp-echo 192.168.10.254 source-interface FastEthernet0/1.1
     frequency 180
     timeout 500
    ip sla schedule 2 life forever start-time now
    logging 192.168.3.21
    route-map DFBIT_routemap permit 10
     match ip address DFBIT_acl
     set ip df 0
    route-map ISP2 permit 10
     match ip address nat_list
     match interface FastEthernet0/3/0
    route-map nonat permit 10
     match ip address nonat_acl
    route-map ISP1 permit 10
     match ip address nat_list
     match interface FastEthernet0/0

    You cannot access internet, because all traffic is tunneled for VPN !!!!
    Please see cisco tech documentation and bypass traffic for internet.
    eg.  if lan traffic is going from site a to site b  then through vpn
          else
           lan traffic to internet (any) should be out thorugh the vpn .

  • Can DiskUtility access the network during installation of Mac OS X?

    Hi,
    I am currently backing up my system using SuperDuper .dmg images and store these on a network server. To restore a system from such an image, I am supposed to start Disk Utility during OS X setup. My question is: Can Disk Utility access the network to access the image on a server or would I have to copy the image to a mobile hard disk first and have DiskUtility access the image there?
    Thanks

    no ideas anyone?

  • Unable to access the data from Data Management Gateway: Query timeout expired

    Hi,
    Since 2-3 days the data refresh is failing on our PowerBI site. I checked below:
    1. The gateway is in running status.
    2. Data source is also in ready status and test connection worked fine too.
    3. Below is the error in System Health -
    Failed to refresh the data source. An internal service error has occurred. Retry the operation at a later time. If the problem persists, contact Microsoft support for further assistance.        
    Error code: 4025
    4. Below is the error in Event Viewer.
    Unable to access the data from Data Management Gateway: Query timeout expired. Please check 1) whether the data source is available 2) whether the gateway on-premises service is running using Windows Event Logs.
    5. This is the correlational id for latest refresh failure
    is
    f9030dd8-af4c-4225-8674-50ce85a770d0
    6.
    Refresh History error is –
    Errors in the high-level relational engine. The following exception occurred while the managed IDataReader interface was being used: The operation has timed out. Errors in the high-level relational engine. The following exception occurred while the
    managed IDataReader interface was being used: Query timeout expired. 
    Any idea what could have went wrong suddenly, everything was working fine from last 1 month.
    Thanks,
    Richa

    Never mind, figured out there was a lock on SQL table which caused all the problems. Once I released the lock it PowerPivot refresh started working fine.
    Thanks.

  • How can i access the EJB from a Webdynpro

    Dear all,
    How can i access the ejb , from a webdynpro?.
    Is there any way to do that?.
    I want to write the entire code (business functions) within the EJB and i wan to access the entire methods from a WebDynpro Application.This is the situation.
    Please help me to , resolve this problem.(Here im using JDBC Connection .. etc.).
    I want to do the basic connection setting's and data retrieval part within the EJB and use that within the WebDynpro..
    how can i seperate this two(i mean, i want to seperate the JDBC connections and WebDynpro,i dont want to hard code any connection parameters within the webdynpro code)
    So that i want use that saet of particular function's in many webdynpro applications..
    (i dont need any help regarding webservice way.)
    If anyone can , please help me..
    I tried that javabean class , manifest file , that way (importing javabean model).
    but im getting errors.
    I cant properly utilize that..
    So please help me with steps regarding that,,
    for javabean
    and if any , for EJB also..
    with regards
    Kishor.G

    HI,
    Since webdynpros follows Model View Controller Architecture You can access EJBs in webdynpro(views/frontend) infact to connec to database uding JDBC you have to utilise EJB ( opening connection to database closing, and other Business functionality).See this link
    https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/com.sap.km.cm.docs/library/unkown/web dynpro tutorial and sample applications.faq#q-7
    <b>How to access the Car Rental Web Service?</b>
    Regards,
    RK

  • I get an error message when downloading ITunes :could not access the network location %public%\desktop\

    I get an error message when downloading ITunes "could not access the network location" %public%\desktop\?
    windows vista 32 bit

    Try the following user tip:
    "Could not access network location %PUBLIC%\Desktop\" install errors

  • I just purchased the airport Express to use in hotels while traveling to create a wireless network from the hotels wired dsl.  A friend said to set up the network from home prior to traveling.  How do I set this up?  Thanks.

    I just purchased the airport Express to use in hotels while traveling to create a wireless network from the hotels wired dsl.  A friend said to set up the network from home prior to traveling.  How do I set this up?  Thanks.

    In addition to RyanJC's comments, the 802.11n AirPort Express Base Station (AXn) can store up to five different http://docs.info.apple.com/article.html?artnum=108081 configuration profiles. You will need to use the AirPort Utility to create & save these profiles.
    To create a new profile:
    Open AirPort Utility, select your AX from the list, and then, click "Manual Setup."
    From the AirPort Utility menu, select "Base Station," and then "Manage Profiles."
    Click "+" to create a new profile; give it a name, and then, click OK.
    Set options, such as network name, passwords, Internet connection method, etc.
    When done setting the options, click Update.
    To switch profiles:
    Open the AirPort Utility, select your AX from the list, and then, click "Manual Setup."
    From the AirPort Utility menu, select "Base Station," and then "Manage Profiles."
    Click on the desired profile, and then, click OK to apply the new profile and restart the AX.
    Just remember to switch to the desired configuration profile before removing power from the AX.

  • Accessing the ServletContext from a class that is not a Servlet?

    Is there any way of accessing the ServletContext from a class that is not a
              Servlet? The class is being used as part of a Web Application.
              Thanks.
              

    http://www.mozilla.org/mirrors.html
    Mozilla has download mirrors around the globe. If it is on the list, it is trustworthy.

  • Why can't I access the Store from my iTunes

    Why can't I access the Store from my iTunes on my PC?

    You must've blocked cookies. iTunes requires cookies I believe. If you did block it follow these steps:
    Go to settings > safari > block cookies > never.

  • How do I access the music from my Mac drive while booted into Windows?

    How do I access the music from my Mac drive while booted into Windows via Bootcamp? I tried using MacDrive but it's not supported for Vista 64-bit edition. Is there another program out there that I can use? I just want to be able to access my music that's on Leopard while in Vista. Any advice will be much appreciated. Thanks in advance.

    Your best bet is to move the music on the Windows side since Leopard will be able to read and play the music from the mounted Windows drive (Leopard will not be able write anything to the Windows NTFS partition).
    In your case it won't work the other way around.
    Axel F.

  • TS2972 I cannot seem to get all of my music shared across the network from my MacBook Pro to my iPad. This was not an issue a few days ago. Can anyone help?

    I cannot seem to get all of my music shared across the network from my MacBook Pro to my iPad. This was not an issue a few days ago. I can see all my songs if sorted that way, but if i sort by artist, only a few of them are present. Can anyone help or have any insight?

    Well I didn't think of it before, but I logged out of my apple ID othe iPad's home sharing. The I logged back in and it worked. It's a little weird, but I will take it. Thanks!

  • HT1695 IPhone 4 could not capture remote Wi-Fi but can capture the network from close range to Ataatjos meter

    IPhone 4 could not capture remote Wi-Fi but can capture the network from close range to Ataatjos meter

    I tried the process and was happy to note that there was some process that I managed to start because the process did start ...
    However to my disappointment,  landed back at the same status which says
    We're sorry, we are unable to continue with your activation at this time.
    Please try again later, or contact customer care
    I was using a GEVEY sim unlock with iOS 4.1 since (almost) last 2 yrs now in India on Vodafone. But as Apple designed it, there were several apps including Whatsapp, Facebook, Gmail and LinkedIn that stopped functioning due to the iOS updates and the subsequent (I guess 'mandatory' App updates). Finally yesterday I thought of updating to the iOS 6. As soon as I did that, I have been left with no choice but to see the above message.
    The process by jhidrowoh starts corectly but iTunes doesnt give you the option of restore only ... it is forcefully clubbed with update and the button that is displayed in the dialog box that appears on pressing 'Restore' in teh recovery mode, shows 'Restore and Update' and as soon as the iPhone is restored, it automatically updates the iOS as well to iOS 6 and hence leaves you hanging in the stale situation.
    Guys ... Need the data desperately ... Can anybody please help???

  • What is the easiest way to access the router from an iPad?  I have no problems accessing it from my laptop.  Even though I am entering the address in the left address box, not the Google search box, it wants to do either a search, or add www beginning of

    What is the easiest way to access the router from an iPad?  I have no problems accessing it from my laptop.  Even though I am entering the address in the left address box, not the Google search box, it wants to do either a search, or add www to the beginning of the IP address.
    I usually can eventually access the router, but it is way to much trouble.  However, I use my iPad hundreds of times more often than my laptop.

    Are you typing http:// in front of the IP address of the router? e.g. http://192.168.0.1
    Sometimes, and with some routers it doesn't seem to like it if you miss off the http://

  • Thow to tether iPad to MacBook to access the web from the MacBook?

    Am I missing something obvious here, or is this not possible?
    There are plenty of posts on the web about how to tether an iPad to a phone, but I want to access the web from a MacBook, using my iPad's 3G access.
    Is this possible? How?

    To use it on the iPhone you enable it via the phone's Settings menu - the iPad doesn't have the same option in Settings so there is no way to turn it on/off, and therefore no way to share the iPad's connectivity with other devices.

  • I cannot get my iMac with built-in airport to allow internet connections to Nook and PS3. The devices access the network, but internet connection fails. Internet sharing is enabled, network security (WEP, WPA) is completely off.  What to check next?

    I cannot get my iMac with built-in airport wi-fi to allow internet connections to Nook and PS3. The devices access the network, but internet connection fails. Internet sharing is enabled, network security (WEP, WPA) is disabled.  What to check next?

    On an additional note, I've purchased a wireless router and everything connected on the first attempt.  It just vexes me that the built-in wireless isn't working as a router.  Is this another example of "Mac only plays with Mac"?

Maybe you are looking for

  • How to set userName from security context to Criteria in portlet

    Hi, From the portal application I have to get the logged in user and use the same user to filter the records in Portlet. I have to execute a view Criteria in portlet as a default method activity which takes logged in user as a input param. Is this ac

  • Oracle user management

    I want to know the data dictionary queries to view roles, priviliges, role-priviliges mapping, users, user-role mapping, user-privileges mapping. Basically to view the following reports; [http://www.myorasql.com/img_pg_usrmag.html]

  • Loadjava fails on 10.1.0.3

    I have a testsystem running Oracle 10.1.0.3.0 on Solaris 9 on which I previously have successfully loaded some Java-stored procedures. But now all I get when I try to reload them is: oracle 11:13 ~ >loadjava -u test/test@testdb -resolve my_package/*.

  • IPhone 3G constantly plugged in

    Hey, Just wondering if its a bad thing for the battery or the phone having it in constantly? When I say constantly I mean overnight (12pm-8am) then majority of the day at work (9am-6pm). During the day at work it will be taken off charge a few times

  • I need to create an interactive timeline in muse for uni work, I can't find any tutorials and I am really stuck.

    So I have pictures and text and want to create a timeline which you can scroll with and when you hover over the images they expand. Can anyone help?