Accessing visibility (thru webdynpr) of components inside Interactive form

Hello All,
There are 3 text fields on the interactive form. Depending upon who has opened the form, i need to make the fields visible and editable. Hence this will be done at runtime. Please let me know how i can access the visiblity of text fields on IF via Java webdynpro.
Thanks.

Hi,
There you said based on who opend the form condion to applied .
This should be done in the JScript only.
let us suppose ur field is customer
In Java script editor add this code like this.
if(cust=="value") then
filed1.presence="hidden"
filed2.presence="hidden"
filed2.presence="hidden"
else
filed1.presence="Visible"
filed2.presence="Visible"
filed2.presence="Visible"
endif
This might helps you.
Thanks,
Lohi.

Similar Messages

  • Embedding BusinessGraphics inside Interactive Form in WebDynPro

    Hi,
    Does anyone know if it's possible to embed a BusinessGraphics UI element that has been rendered into an InteractiveForm? Or is there a way the URL to the BusinessGraphic or the binary data of the graphic itself accessible so that it can be bound to the context and passed on to an Adobe Interactive Form UI?
    THanks

    Hi,
    this is possible with a workaround. You have to programm against the IGS directly to generate the business grpahic and get the URL (This is what the UI element internally does). Then you have to put that URL into Web Dynpro context, bind the imageField-UIElement within the InteractiveForm to that context attribute(do not forget the script "this.value.image.href = xfa.resolveNode(this.value.image.href).value;" in form:ready. This will display the graphic.
    Regards
    Stefan

  • Components inside components (Flash 8)

    Hi,
    I have an Accordion component which needs to contain a number
    of small forms, each of which is built as a MovieClip containing
    TextInput, Button, ComboBox, etc.
    So, I build my little forms in Flash, make them into
    MovieClips, give them a linkage identifier and assign them the AS2
    class "mx.core.View", as the documentation says.
    Then I use ActionScript to attach these to my Accordion
    control, using my_accordion.createChild(). OK, fine. Works nicely.
    The problem is that in the next few lines of code I also want
    to be able to populate the TextInput and ComboBox components which
    reside inside my accordion. I can't do it. Trying to do so fails
    silently. Tracing out the path to the Components shows that they
    are "there", but if i put some content into, say, one of the
    TextInputs up-front (i.e. in the Properties panel inside Flash) and
    then try to trace... my_acc.my_form.my_textInput.text... i get
    undefined.
    So, it looks like the components inside the form inside the
    Accordion aren't yet "initialised" when I am trying to get/set
    their values. I've seen similar behaviour before, but it's not
    clear in the documentation how to get around it.
    Anyone help? What is the correct way to use components inside
    components like this? I don't want to have to call a second
    function or put any code on the timeline or anything like that!
    Many thanks,
    Andy

    Flash only supports a handful of html tags natively, so the
    short answer is, no, you can't do that. However, there are a few
    xhtml render classes floating around that will render many many
    more tags, including iframes. However, these implementations have
    VERY specific style and construction limitations, and of course
    don't support any scripting, so if you don't have control over the
    content, then it's pretty much hopeless.

  • Interactive Form Height in percentage

    Hi All,
      I have an Interactive for displaying a PDF on a WebDynpro view.  I can specify the Interactive Forms height property in pixels (e.g. 600px) however when I specify it in percentage (e.g. 100%) the form will not appear.  It fails silently.
      The funny thing is that the width property is set to 100% and works perfectly.
    Any thoughts?
    Larry
    P.S. Points will be awarded

    after more searching I've found the answer ... it cannot be done.
    See Note 885862
    Note 885862 - PDF document is not shown properly, only Toolbar appears
    Symptom
    A Web Dynpro application uses InteractiveForm UIElement. On the first attempt, only the Toolbar of Reader is displayed. The PDF document itself is not visible.
    Other terms
    Adobe Integration, Interactive Forms Solution
    Reason and Prerequisites
    The height property of the InteractiveForm UIElement is set to a per cent (%) value.
    Solution
    The height property of the InteractiveForm should be set to an absolute value as "%" is currently not supported of the Web Dynpro Runtime.
    Dissapointed again ....
    Larry

  • Accessing buttons on main stage from inside of a movie clip

    Greetings...
          here is the scenario:
                 - I have buttons on main stage, and a swf file which is loaded to scene using a LOADER in AS3
                 - this is a website, so the problem rises when user moves its cursor around the page and now  buttons in main stage,
                    are still active since they are behind the loaded swf file.
                 - i would like to learn, how can i CODE inside the loaded SWF file, to either remove the buttons in main page, or remove
                    the event listeners. not sure if my case has anything to do with .Parent or .roo, (I want to access those main stage
                    buttons from the SWF file which is loaded)
                 - The general case is, i have SWF files loading inside another SWF files, is it possible to access items on each stage from
                    inside of loaded SWF files on that specific stage. Similarly i would be interested to learn about accessing main stage from inside
                    of movieclips running on stage. how can i access something not in present FLA file yet, in FLA file that is loading the page as SWF.
                    Thanks.

    If you load an swf into another using the Loader class, then the Loader itself is the parent of the loaded swf., so MovieClip(parent.parent) might help you to target the timeline that the Loader was born from.  The more proper way to have a loaded file talk to a parent file is thru dispatching events that the parent assigns listeners for after the file has loaded.  Here's a link to a posting that might help explain how to implement this.
    http://forums.adobe.com/thread/470135?tstart=120
    As for the buttons that you want to disable, you could either use the removeEventListener() method to remove the listeners you have assigned, or you could set their mouseEnabled property to false, or you could set their visible property to false.

  • Change visibility of table in interactive form through scripting

    Hi all,
    I am designing an interactive form in wd java. I used a table to display records in the interactive form.I want to make the table invisible if there is no data in the node. The table is wrapped in a subform . What scripting I need to do to make the table invisible if there is no data in the table node.
    Thanks,
    Satish Kumar

    Dear Sathish,
    I dont think there is direct way to control the visibility property in the Interactive form. Instead, you can create a table inside a subform and change the Subform Content Property to "Flowed".
    You will be having a node assigned to the table. Instantiate the node twice, say first time for the heading row and the second time for the table content. and do this under the ciondition if the table is not enpty. This way you can control the visibility of the table and it is so simple.
    if(<tablevalues> == null)
    <Dont create any nodes>
    else
    //For Table Heading
    IPrivate<>.ITestNode tn = wdcontext.nodeTest();
    IPrivate<>.ITestElement tne = wdcontext.createTestElement());
    tn.add(tne);
    //For Table content
    IPrivate<>.ITestNode tn1 = wdcontext.nodeTest();
    IPrivate<>.ITestElement tne1 = wdcontext.createTestElement());
    tn1.add(tne1);
    Thanks,
    Vivek.

  • 'Element is currently not visible and so may not be interacted with' when using Firefox.

    .

    Hi MonsoonMally,
    Thank you for posting in MSDN forum.
    >>'Element is currently not visible and so may not be interacted with', when playing back a CodedUI capture for a particular button selection function (captured in IE) and played back in Firefox.
    Based on your issue, I suggest you can try to use the
    DrawHighlight Method /SetFocus() to check if the correct control is found before you perform actions on the target control.
    If the above suggestion could not help you, since this cross browser testing is involved to the Extensions tool
    Selenium components for Coded UI Cross Browser Testing, this extension tool is
    out of support range of this forum.
    In order to resolve your issue better, I suggest you post this issue
    here, click “Q AND A”, you will get better support there.
    Thanks for your understanding.
    Best Regards,
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click
    HERE to participate the survey.

  • Asa 5505, the outside cant access to a server in the inside

    hi, i have an Asa 5505, a pc in the outside with the ip 10.1.1.6 cant access to a server in the inside 192.168.1.4, pls help...
    this is my conf:
    ASA Version 8.0(4)
    hostname ciscoasa
    domain-name default.domain.invalid
    enable password 8Ry2YjIyt7RRXU24 encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Vlan1
    nameif inside
    security-level 0
    ip address 192.168.1.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 10.1.1.2 255.255.255.0
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    boot system disk0:/asa804-k8.bin
    ftp mode passive
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    access-list 100 extended permit tcp any host 10.1.1.3 eq www
    pager lines 24
    logging enable
    logging asdm debugging
    mtu inside 1500
    <--- More --->
    mtu outside 1500
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-613.bin
    no asdm history enable
    arp timeout 14400
    nat-control
    global (outside) 1 interface
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) 10.1.1.3 192.168.1.4 netmask 255.255.255.255
    access-group 100 in interface outside
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    <--- More --->
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside
    dhcpd address 192.168.1.2-192.168.1.254 inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
    message-length maximum 512
    policy-map global_policy
    class inspection_default
    inspect dns preset_dns_map
    inspect ftp
    <--- More --->
    inspect h323 h225
    inspect h323 ras
    inspect rsh
    inspect rtsp
    inspect esmtp
    inspect sqlnet
    inspect skinny
    inspect sunrpc
    inspect xdmcp
    inspect sip
    inspect netbios
    inspect tftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:14e7b74fabc386613ae646b915f60e9e
    : end
    ciscoasa#

    Andres
    The security level for your inside interface should be 100 ie.
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    After changing that can you
    1) ping the outside interface of the ASA from the pc or ping the PC from the ASA
    2) I'm assuming you are trying to connect to 10.1.1.3 when you attempt the connection ?
    Jon

  • Access Denied error while editing interactive forms in NWDS

    Hi,
    I am getting following error while editing the Adobe Interactive form in NWDS, I didnt understand why i am getting this error please help me in this issue
    the error i am getting is as follows
    java.io.FileNotFoundException: C:\Documents and Settings\my user\Application Data\Adobe\Designer\FormDesigner.ini (Access is denied)
         at java.io.RandomAccessFile.open(Native Method)
         at java.io.RandomAccessFile.<init>(RandomAccessFile.java:212)
         at com.sap.ide.webdynpro.adobetemplatedesigner.internalisation.AdobelanguageSettingService.setAdobeLanguage(AdobelanguageSettingService.java:43)
         at com.sap.ide.webdynpro.adobetemplatedesigner.AdobeDesignerEditorPart.createPartControl(AdobeDesignerEditorPart.java:123)
         at org.eclipse.ui.internal.EditorReference.createPartHelper(EditorReference.java:661)
         at org.eclipse.ui.internal.EditorReference.createPart(EditorReference.java:428)
         at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:594)
         at org.eclipse.ui.internal.EditorReference.getEditor(EditorReference.java:266)
         at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched(WorkbenchPage.java:2820)
         at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(WorkbenchPage.java:2729)
         at org.eclipse.ui.internal.WorkbenchPage.access$11(WorkbenchPage.java:2721)
         at org.eclipse.ui.internal.WorkbenchPage$10.run(WorkbenchPage.java:2673)
         at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
         at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2668)
         at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2652)
         at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2635)
         at com.sap.ide.webdynpro.adobetemplatedesigner.listener.ViewDesignerActionListener.launchAdobeDesigner(ViewDesignerActionListener.java:73)
         at com.sap.ide.webdynpro.adobetemplatedesigner.contentprovider.LaunchDesignerAction.run(LaunchDesignerAction.java:30)
         at org.eclipse.ui.internal.PluginAction.runWithEvent(PluginAction.java:251)
         at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:583)
         at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:500)
         at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:411)
         at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
         at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1003)
         at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3823)
         at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3422)
         at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2384)
         at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2348)
         at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2200)
         at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:495)
         at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:288)
         at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:490)
         at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
         at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:113)
         at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:193)
         at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
         at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
         at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:386)
         at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
         at java.lang.reflect.Method.invoke(Method.java:597)
         at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
         at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
         at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
    thanks
    Anu

    Hi Anu,
          Please check if you have permissions in C:\Documents and Settings\my user\Application Data\Adobe\Designer\FormDesigner.ini
          Change "my user" to the actual user.
    Best regards, Aldo.

  • Problem in accessing the Interactive forms in an ISR Senario(like MSS)

    Hi all,
    I am facing a problem whenever I try to access the interactive form.I am doing this from the standard Business Package, MSS.
    I have done all the configurations needed for these ISR Senarios.
    I suspect the the error is because of some missing IMG customizing.
    Pls provide some directions to solve this problem.
    Exception 1)
    initial exception that caused the request to fail, was:
    com.sap.tc.webdynpro.services.exceptions.PDFDocumentCreationException: ../../sap.com/pcui_gpisr/IsrForm/wd_key13_1171540676406/Error+PDF.pdf?sap-wd-download=1&sap-wd-dl_behaviour=1&sap-wd-cltwndid=DefaultExternal1171589446921&sap-ext-sid=dIiSA97eM6QRuNvwpwdigw%3D%3DzPkd%2BOwplNQFa31FtlR6vA%3D%3D%2Fpcd%3Aportal_content%2Fcom.sap.pct%2Fspecialist%2Fcom.sap.pct.erp.busunan.bp_folder%2Fcom.sap.pct.erp.busunan.roles%2Fcom.sap.pct.erp.busunan.business_unit_analyst_20%2Fcom.sap.pct.erp.busunan.business_unit_analyst_20%2Foverviewfolder%2Fcom.sap.pct.erp.busunan.overview_2%2Fcom.sap.pct.erp.busunan.masterdata_1%2Fcom.sap.pct.erp.common.isrform_page%2Fsap.com%2Fpcui_gp%7Eisr%2FIsrForm%2Fbase&sap-wd-norefresh=X&sap-ep-version=7.00.200611091758
    Exception 2: This Exception occurs when I try to run the application(sap.com/pcui_gp~isr/IsrForm) from the Webdynpro Content Administration Screen.
    com.sap.pcuigp.xssfpm.java.FPMRuntimeException: No scenario specified
    at com.sap.pcuigp.xssfpm.java.MessageManager.raiseException(MessageManager.java:111)
    at com.sap.pcui_gp.isr.isrprocessevent.init.VcISRInit.onBeforeOutput(VcISRInit.java:228)
    at com.sap.pcui_gp.isr.isrprocessevent.init.wdp.InternalVcISRInit.onBeforeOutput(InternalVcISRInit.java:181)
    at com.sap.pcui_gp.isr.isrprocessevent.init.VcISRInitInterface.onBeforeOutput(VcISRInitInterface.java:139)
    at com.sap.pcui_gp.isr.isrprocessevent.init.wdp.InternalVcISRInitInterface.onBeforeOutput(InternalVcISRInitInterface.java:136)
    at com.sap.pcui_gp.isr.isrprocessevent.init.wdp.InternalVcISRInitInterface$External.onBeforeOutput(InternalVcISRInitInterface.java:212)
    at com.sap.pcuigp.xssfpm.wd.FPMComponent.callOnBeforeOutput(FPMComponent.java:602)
    at com.sap.pcuigp.xssfpm.wd.FPMComponent.doProcessEvent(FPMComponent.java:568)
    at com.sap.pcuigp.xssfpm.wd.FPMComponent.doEventLoop(FPMComponent.java:437)
    at com.sap.pcuigp.xssfpm.wd.FPMComponent.wdDoInit(FPMComponent.java:195)
    at com.sap.pcuigp.xssfpm.wd.wdp.InternalFPMComponent.wdDoInit(InternalFPMComponent.java:110)
    at com.sap.tc.webdynpro.progmodel.generation.DelegatingComponent.doInit(DelegatingComponent.java:108)
    at com.sap.tc.webdynpro.progmodel.controller.Controller.initController(Controller.java:215)
    at com.sap.tc.webdynpro.progmodel.controller.Controller.init(Controller.java:200)
    at com.sap.tc.webdynpro.clientserver.cal.ClientComponent.init(ClientComponent.java:429)
    at com.sap.tc.webdynpro.clientserver.cal.ClientApplication.init(ClientApplication.java:362)
    Thanks in advance,
    Sethu

    Hey Sethu,
    Check the QISRSCENARIO settings.Also make sure that your ADS is configured.
    Also, please make sure that you have maintained all the settings which are mentioned in this link.
    http://help.sap.com/saphelp_erp2005vp/helpdata/en/3b/52dd3747934311abee4376f383fdf2/frameset.htm
    Regards
    <i><b>Raja Sekhar</b></i>

  • Problem with Input help inside an adobe interactive forms

    Hi Experts,
    I'm currently implementing a Webdynpro ABAP application containing a Interactive forms.
    I'm using Adobe Live Cycle Designer 8.0, Acrobat reader 9.2, Internet Explorer 7.0
    My problem is that when I click on the "input help" button inside the adobe form, he automatically refresh all the forms UI element with their initial values. Is-it a refresh event included when we pressed the "Input help" button or an other event? How Can I deactivate that action, event?
    Because since he automatically refresh my form data I loose the context current values.
    Thanks in advance,
    Louis

    P740741 wrote:>
    > Hi Norbert,
    >
    > Thanks for reply, yes I use ZCI and I inserted the Webdynpro script  through Utilities.
    >
    > Best Regards,
    > Louis
    strange, but you could compare the version of the zci scripting
    in your form in the hierarchy tab there are variables and the ContainerFoundation_JS script --> the first line
    // DO NOT MODIFY THE CODE BEYOND THIS POINT - xxxxxxxxxxxxxxxxxxxxxxxxxxx - ContainerFoundation_JS gives you the requested information about the scripting version...have a look at this version...
    norbert
    perhaps this note helps:
    Note 999998 - Analyzing errors with Adobe Integration of Web Dynpro ABAP
    --> for debugging!
    A client debug function is available as of SAP NetWeaver Release 7.00 Support Package 19 (or after you implement Note 1287114) and for all Enhancement Packages. Activate this client debug function using the URL parameter "sap-wd-clientDebug=X" (attach it to the URL using "&"). You can then activate the client trace using the key combination <CTRL><ALT><SHIFT>T (move the focus to a Web Dynpro UI element, for example, to an InputField, do NOT move the focus to Adobe Reader). The system opens a new browser window with the trace output. The trace may contain an error entry ("Network Error", and so on). The URL also activates the Adobe document services (ADS) trace. The trace outputs of the ADS are copied to the generated PDF document as an attachment. Open the file "Error.pdf" of the ADS trace: Form errors (for example, script errors) are listed there.
    Edited by: Norbert Prager on Oct 24, 2009 7:31 PM

  • Sending my callable object as interactive form thru workflow for approval

    hai
            I have created a sales order form as per the requirement given by sales head.Also i ve created a role in portal and have deployed my application implementing the rfc s required. i need to send my callable object(component1) to the saleshead with approve and reject button where when he approves notification mail should be sent to the required persons and if he rejects it should come back to me.(order initiator).i need to complete this soon and i dont have any idea about _+sending my callable object as interactive form thru workflow+_ .plz guide me with the steps(step bye step process) to be followed which ll help me to complete this project.

    Can we know the reason why do you need to extract the Interactive Form from Workflow.When you are calling the workflow try to save the form in a shared folder and save the url of the shared folder in a field and try to acces it by using SAP Activity.You can create a button for that create an SAP activity and when you click on the button the Interactive Form can be opened.
    Iam not sure weather i have answered your question or not?

  • HT1386 How do I sync two libraries from ITunes to my IPod Touch? I recently added a second library. How do I sync it and access it thru my IPod Touch?

    I have created a second library in ITunes containing only Christmas music. I want to sync it to my IPod Touch but maintain my regular ITunes library as well. How do I sync both libraries and how do I access them thru my IPod?

    You can only sync with one iTunes library but you can manage music and videos among different computers/libraries.. See:
    Using iPhone, iPad, or iPod with multiple computers

  • Programmatically refresh components inside a specific row of an af:table

    How to programmatically refresh components inside a specific row of an af:table without refreshing the whole table ?_
    I have an af:table displaying a read-only view object. There is an edit button inside the table calling an af:popup, where the user can update some informations and click a submit button to validate his changes.
    The action property of this button is a method in a backing been where
    -     1 : A stored procedure is called to update several tables (related to my read-only VO).
    -     2 : The VO is re-queried (VO. refreshQueryKeepingCurrentRow() )
    -     3 : The whole table is refreshed (AdfFacesContext.getCurrentInstance().addPartialTarget(myTable) )
    Is it possible to programmatically refresh some components of the current row of the table without refreshing the whole table (point 3)?
    I’ve tried to play with the “partialTrigger” property of af:outputText (table:column:outputText), without success.
    Thanks
    Nicolas

    "+do you happen to want to refresh following an action on the row? Like a link/button click?+" : NO
    There is a table on my page. The user select a row and click on an edit button. This edit button call a popup where the user can modify some information (not directly on the viewObject. All fields in the popup are dummy fields bind to attributes in my backing bean) and then he click on a submit button.
    The submit button action execute a method "submitInformation" in a backing been.
    public String submitInformation(){
            Map<String, Object> params = new HashMap<String, Object>();
            params.put("pManNo", xManNo.getValue()); //xManNo is an attribute of the backing bean
            params.put("pDate", xPeriod.getValue()); //xPeriod is an attribute of the backing bean
            // Execute Operation
            OperationBinding oper = ADFUtils.findOperation("serviceSubmitInfo");
            oper.getParamsMap().putAll(params);
            String results = (String)oper.execute();
            // Close Popup & Refresh Row if OK
            if(!StringUtils.isStringEmpty(results) && results.equals("TRUE")){
                 closePopup("pt1:popAbs");
                 refreshMyCol();
    }The serviceSubmitInfo method is defined in my serviceImpl
        public String serviceSubmitInfo (String pManNo, String pPeriod, ......){
             String results =
                callStoredFunction("? :=myDatabaseFunction(?, ?, ?, ?)",
                                   new Object[] { pManNo, pPeriod, ...... });
              // Commit
              getDBTransaction().commit();
              // Refresh VO (re-query & set currentRow)
              getMyVO().refreshQueryKeepingCurrentRow();         
              return results; // TRUE if ok
        }I want the " refreshMyCol()" method to refresh only the current row and not the whole table...
    Regards
    Nicolas

  • Accessing Portal thru a 2nd URL

    After setting up our Portal we can now access it using the qualified hostname which is as follows:
    http://gnwhepstg.company.com:50000/irj/portal
    We would now like to access the portal using the URL listed below:
    http://portalstg.psc.inside.tkr:50000/irj/portal
    How would we go about setting this up?
    Also, We need to access this site using https and not http.  Do we need to setup SSL on the Java stack for this?  If not , how is this setup?

    I can honestly tell you that I have no idea why it is as difficult as what it seems in that note.
    We operate one domain corp.company.com but all internal intranet web servers get the address inside.ZZZ.  The inside.ZZZ is on our IE exclusion list but company.com is not.  Adding company.com seems to be a miserable task so we are looking at adding an alias so our users can access the server at the new inside.ZZZ url.  We have DNS pointing the URL to the right server but we get an series of errors when logging in.  1. We get the "No Switch to HTTPS" error.  2. We get a second login for the ABAP stack (it is a dual stack EP7.0 portal) after successfully logging into the java stack.  Those are the errors we want to get rid of.  Any ideas how we make it work?  If the solution is the web Server Filter, I do not understand how that applies to this case.  It just isn't obvious to me.
    Thanks

Maybe you are looking for

  • Preview what a background 'Image Repeat' will look like?

    I want to preview some website background images that I have which are 1 pixel wide without having to upload to the website and refresh the page. Is there a way to preview images repeating in either Adobe Bridge or Adobe Photoshop or any product in t

  • Even the help files missing in Numbers & Pages

    I just went to check a detail in one of my Numbers app on my iPad 2 but when I got there the app was bare.  Yes not a single file or folder in Numbers I check Pages and that's the same. They are synced with iCloud and backed up & a jpg version is on

  • HTML DB Cursor Focus

    Hi everybody, I work with HTML DB 1.6. My question is about Cursor Focus. In my page Cursor Focus is SET TO: First item on page My first item is a Select list, my second item is an other Select list and my third item is a Text area. My cursor is focu

  • No Virtualiza​tion Enable Setting in BIOS for TS140?

    There is no Virtualization Setting in the BIOS (version 48A released date 8/26/13) of the new TS140. I have installed server 2012 but not able to install Hyper-V option. Called Lenovo Tech Support but he told me that if the Intel Chipset driver is in

  • Configuring an IP-in-IP Tunnel

    hi all, For configuring an IP-in-IP Tunnel according to Solaris man page for "ifconfig", I can use the command, $ifconfig ip.tun0 myaddr mydestaddr tsrc anothermyaddr tdst a_dest_addr up Can anybody help me what all addresses i need to provide in pla