AccountExpires attribute within Microsoft ActiveDirectory

Hi,
actually I have problem with the integration of the Active Directory to the IDM.
Our intention is to provisioin the validTo-Date to the Active Directory. Unfortunately it seems that sometimes the last day, and sometimes the last two days of the validity range are going lost.
Does any one has the same problem and, may be, a solution?
I found out, that AD doesn't store the attribute as an date like 28.July 2011. It saves the date as a large Integer (18 Digits), counting milli or nano seconds from January, 1st, 1601 and devided into a low part and a high part.
Kind regards,
Achim Heinekamp

I wrote a script to use to convert dates to the AD format:
// Main function: _vlo_convertToADValidToDate
function _vlo_convertToADValidToDate(Par){
     var dateLong = 1;
     if ( Par == null || Par == "" )
          uWarning("Set accountExpires to Never Expire (0)");
          dateLong = 0;
     else
          try {
               var validityDate = new String(Par);
               var df = java.text.SimpleDateFormat("yyyy-MM-dd");
               df.setTimeZone(java.util.TimeZone.getTimeZone("UTC"));
               var calcDate = df.parse(validityDate);
               dateLong = (calcDate.getTime() + 11644473600000) * 10000 + (48 * 60 * 60 * 10000000); //h * m * s
               //uWarning("Set accountExpires = " + dateLong + " (" + validityDate + ")");
          } catch (e) {
               uWarning("Parsing validityDate '" + validityDate + "'failed, expiring account.");
               uWarning(e);
               dateLong = 128970324000000000;
     return dateLong;
That is what we use. Hope that helps.

Similar Messages

  • How do I change text attributes within one text box in Motion 3?

    I am trying to change text attributes within one text box in Motion 3, but am only able to change the font/size for the entire box. Is there a way to change the attributes to individual lines of text within a text box without creating an entirely new one or using the "Lower Third" text effect?
    How do I create (two different) multiple colors, fonts, bold, italic, underline in one text box within Final Cut Studio Motion (FCP, FCS)

    Thank you! You saved me hours of tinkering around with multiple text boxes. It seemed like it should be something pretty elementary. It didn't help that I am not familiar with proper terminology, so thank you for defining glyph.
    Cheers,
    Owfownugi

  • Microsoft.ActiveDirectory.Management.ADPropertyValueCollection issue on get-aduser

    I am running the command
    get-aduser username -Properties * | select name, publicDelegates, publicDelegatesBL
    But the output only returns Microsoft.ActiveDirectory.Management.ADPropertyValueCollection,
    despite knowing there are delegates setup for the user queried.
    Is there anyway round this? I dont understand why it doesnt return the correct information. I did wonder if its perhaps because there are a number of entries
    in both fields?

    get-aduser username -Properties * | select -Expand publicDelegatesBL
    get-aduser username -Properties * | select name, @{N='publicDelegates';E={$_.publicDelegates -join '|'}}
    \_(ツ)_/

  • Report Dataset NOT displaying Fields within Microsoft Visual Studio

    I have developed my Stored Procedure using two driven parameters.
    @ReportTypeName
    @YearParameter
    The @ReportTypeName is handled within an IF at the End of the Stored Procedure to produce the correct type of report..."New" or "Renewal"
    The @YearParameter is an Integer Year that is provided by Code and then properly interpreted within the SQL Server Stored Procedures.
    My SQL Stored Procedure runs perfectly when I supply the Parameters in an EXEC Statement. Sooooo actually a two-part question...
    When I build my SSRS Report in Microsoft Visual Studio and Provide the Dataset accordingly, the SQL Server Stored Procedure name that I've previously created, the Report Dataset fields are not there. Why? So I have no way of dragging the Dataset report
    data fields onto my Report Tablix.
    I have as an <<Expr>> in my Report Header: ="Year Parameter Specified: " + Parameters!YearParameter.Value and when I try to Preview my Report I get the error message: The Value expression for the textrun 'textbox22.Paragraphs[0].TextRuns[0]'
    contains an error: Input string was not in a correct format. Does that mean I have to Convert my Integer Parameter Value to Character in order for it to be displayed as a Value ???
    Thanks for your review and am hopeful for a quick reply and Thanks in advance!

    Hi ITBobbyP,
    1.When I build my SSRS Report in Microsoft Visual Studio and Provide the Dataset accordingly, the SQL Server Stored Procedure name that I've previously created, the Report Dataset fields are not there. Why? So I have no way of dragging
    the Dataset report data fields onto my Report Tablix.
    In your scenario, please run the stored procedure in SSMS to check if the expected results can return. If the stored procedure can work fine in SSMS, then please check if you have specified a correct data source, also make sure
    the credential used to connect to the data source is the same as the credential you use in SSMS. For more information, please refer to this article:
    Create an Embedded or Shared Data Source (SSRS).
    2.I have as an <<Expr>> in my Report Header: ="Year Parameter Specified: " + Parameters!YearParameter.Value and when I try to Preview my Report I get the error message: The Value expression for the textrun
    'textbox22.Paragraphs[0].TextRuns[0]' contains an error: Input string was not in a correct format. Does that mean I have to Convert my Integer Parameter Value to Character in order for it to be displayed as a Value ???
    In this scenario, I would like to know if the YearParameter is a multivalued parameter. As we tested in our environment, if it’s a multivalued parameter, we should specify the expression like below:
    ="Year Parameter Specified: " & Join(Parameters!YearParameter.Value,",")
    Otherwise, you should change the expression like below:
    ="Year Parameter Specified: " & Parameters!
    YearParameter.Value
    If you have any question, please feel free to ask.
    Best regards,
    Qiuyun Yu
    Qiuyun Yu
    TechNet Community Support

  • Editable attribute within optional region?

    If I make an optional region in my template, and within it
    make some attributes editable, will this work ok?
    thanks

    Should, yes.
    Murray --- ICQ 71997575
    Adobe Community Expert
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    http://www.projectseven.com/go
    - DW FAQs, Tutorials & Resources
    http://www.dwfaq.com - DW FAQs,
    Tutorials & Resources
    ==================
    "jdldn" <[email protected]> wrote in message
    news:ge9j14$oj0$[email protected]..
    > If I make an optional region in my template, and within
    it make some
    > attributes editable, will this work ok?
    > thanks

  • How to modify user attributes in Microsoft IAS or Active Directory??

    Anyone have an idea?? What I'm trying to do is to authenticate management access to an ACE 4710 against a Microsoft IAS server.
    According to the document below:
    http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA1_7_/configuration/security/guide/aaa.html#wp1519045
    it sounds like I need to be able to modify user attributes similar to what I know is doable in ACS. I base my assumption on this because of the following statement in the link above:
    "Step 3 Go to the User Setup section of the Cisco Secure ACS HTML interface and double-click the name of an existing user that you want to define a user profile attribute for virtualization. The User Setup page appears.
    Step 4 Under the TACACS+ Settings section of the page, configure the following settings:
    •Click the Shell (exec) check box.
    •Click the Custom attributes check box.
    •In the text box under the Custom attributes, enter the user role and associated domain for a specific context in the following format:
    shell:<contextname>=<role> <domain1> <domain2>...<domainN>"
    Is something like this possible in IAS??
    I have the authentication piece working for the ACE however when I login, I'm assigned an ACE defined default role of 'network-monitor' which gives me only read-only access. The way I'm interpreting what needs to be done to resolve this is to have the authentication server send an attribute value that states that the user is in the role 'Admin' in which case I'll have unlimited access to my ACE.
    Make sense?? Any thoughts??
    Thanks in advance.
    -Lloyd

    Lloyd,
    It is possible via Radius and not TACACS. On the same link if you scroll down, you will see option of doing it via Radius.
    "Defining Private Attributes for Virtualization Support in a RADIUS Serve"
    Find attached the doc that explains about setting up user attributes on IAS.
    Regards,
    ~JG
    Do rate helpful posts

  • Using the binding attribute within Tomahawk's t:dataList tag

    I am trying to create a .jsp page with a dynamic list of tables. Each table on the page has a dynamic number of columns. I read an excellent blog ([The BalusC Code - Using datatables|http://balusc.blogspot.com/2006/06/using-datatables.html#PopulateDynamicDatatable]) that taught me how to create dynamic tables using the binding attribute. I can now get the tables with dynamic columns working.
    What I would like to do next is nest the dynamic tables within a Tomahawk t:dataList tag:
    <t:dataList value="#{utilitiesTableSegBean.attributeTables}" var="attributeTable">
        <h:outputText value="#{attributeTable.title}"/>
        <h:panelGroup binding="#{attributeTable.dynamicTableGroup}/>
    </t:dataList>
    {code}
    When I run my app I get this error:
    javax.servlet.ServletException: javax.servlet.jsp.JspException: org.apache.jasper.el.JspPropertyNotFoundException: /s/UtilitiesTableSeg.jsp(57,56) '#{attributeTable.dynamicTableGroup}' Target Unreachable, identifier 'attributeTable' resolved to null
    Why do I get this error?
    If I remove the h:panelGroup tag then the h:outputText tag works just fine.  Why does 'attributeTable' resolve to null for the binding attribute of h:panelGroup, yet works for the value attribute of h:outputText?
    So then I thought that I might be able to make it work with an index into a bean property that returned the list of table objects.  So I tried to modify my panel group tag to:
    {code}<h:panelGroup binding="#{utilitiesTableSegBean.attributeTables[0].dynamicTableGroup}"/>{code}
    I was just doing a quick initial test and expected to see the first table repeated over and over because I had hard coded the value of '0' as the index.  But I was wrong.  It listed through all of the tables correctly.  Why?  This makes no sense to me!
    So I changed my jsp again so that it looked like this:
    {code}
    <t:dataList rowIndexVar="tableIndex" value="#{utilitiesTableSegBean.attributeTables}" var="attributeTable">
        <h:outputText value="#{attributeTable.title}"/>
        <h:panelGroup binding="#{utilitiesTableSegBean.attributeTables[tableIndex].dynamicTableGroup}"/>
    </t:dataList>
    {code}
    This is how I expected to code it so that the tables would all be shown correctly.  And it gives this error:
    org.apache.jasper.JasperException: An exception occurred processing JSP page /s/UtilitiesTableSeg.jsp at line 57
    (Line 57 is the line with the h:panelGroup tag.)
    Root cause:  javax.servlet.ServletException: javax.servlet.jsp.JspException: java.lang.IllegalArgumentException: null
    I would really like to get the original version working, but any feedback and/or suggestions would be greatly appreciated.  I have spent a lot of time trying to figure this out and I just don't know where else to look.
    Thank you very much!
    Dave                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   

    Yes, sorry about that - I started off trying to prove a potential solution.
    Aim:
    A user logs onto a weblogic application and is authenticated against OID. The application is making SOAP service calls to a proxy endpoint monitored by another vendors software which authenticates the user against the ldap and checks their roles to see if the user can call the service.
    Solution so far:
    The initial application gets the username from the JAAS principal, but the password is not supplied. I can easily supply the SHA password digest to it (but putting a cleartext password in the header will probably not be given the go-ahead). This would enable the application to make the SOAP call with a username and digest.
    The software protecting the services can be configured in a variety of ways to authenticate the user to the ldap. One involves using the wsse username token in the header (cleartext password or digest).
    This authentication is failing and I don't yet have the diagnostic tools available to see which stage is in error. I was trying to prove that you could actually authenticate with an SHA password digest by doing a bind.
    Regards

  • How do I call a LabVIEW created DLL from within Microsoft Excel (VBA)?

    Hi,
    I'm trying to get Microsoft Excel 2003 to call a function stored in a dll that I created using LabVIEW 7.1.  The function is very simple and is called "binary_file_to_ascii".  Basically it just reads a LabVIEW created binary spreadsheet file and outputs the columns as float arrays.
    The function arguments are as follows:
    INPUT : String that contains the path to the binary spreadsheet file
    OUTPUT : Number of rows in the spreadsheet
    OUTPUT : Number of columns in the spreadsheet
    OUTPUT : Float array containing the elements in column 1
    OUTPUT : Float array containing the elements in column 2..
    OUTPUT : Float array containing the elements in column 11
    However, for some reason there is something wrong with my VBA code and/or the way I created the DLL in LabVIEW because Excel crashes when it loads my DLL.
    What do I need to change in my VBA code or my LabVIEW DLL build settings to fix this?
    I've attached to this post a ZIP file that contains all my code and a sample binary file.
    Your help with this will be much appreciated.  Thanks!
    Richard
    P.S.  Here is the VBA code I'm using:
    Private Declare Function binary_file_to_ascii Lib "C:\temp\binary_file_to_ascii\binary_to_ascii.dll" _
    (ByVal binaryFile As String, ByVal nrows As Long, ByVal ncols As Long, ByVal column1 As Variant, _
    ByVal column2 As Variant, ByVal column3 As Variant, _
    ByVal column4 As Variant, ByVal column5 As Variant, _
    ByVal column6 As Variant, ByVal column7 As Variant, _
    ByVal column8 As Variant, ByVal column9 As Variant, _
    ByVal column10 As Variant, ByVal column11 As Variant)
    Private Sub load_binary_spectra()
      Dim nrows, ncols As Long
      Dim col1(), col2(), col3(), col4(), col5(), col6(), _
          col7(), col8(), col9(), col10(), col11() As Variant
      Dim lRetVal As Long
      Dim spectra_path As String
        spectra_path = "C:\temp\binary_file_to_ascii\sample_binary_file\sample_binary_file.dat"
        lRetVal = binary_file_to_ascii(spectra_path, nrows, ncols, _
                  col1(), col2(), col3(), col4(), col5(), col6(), _
                  col7(), col8(), col9(), col10(), col11())
        MsgBox (spectra_path)
    End Sub
    Message Edited by Richard Ballantyne on 07-25-2007 02:39 PM
    Message Edited by Richard Ballantyne on 07-25-2007 02:39 PM
    Attachments:
    binary_file_to_ascii.zip ‏192 KB

    Hi,
    I don't know anything about Visual Basic, but here's my guess.
    When you load the DLL with this line of code
    Private Declare Function binary_file_to_ascii Lib "C:\temp\binary_file_to_ascii\binary_to_ascii.dll" _
    (ByVal binaryFile As String, ByVal nrows As Long, ByVal ncols As Long, ByVal column1 As Variant, _
    You are defining how the parameters are sent. It seems that all are sent by value (ByVal), but in the DLL header, some of the function's
    parameters are defined as pointers(see the function prototype below, look for asterisk(*))
    void __stdcall binary_file_to_ascii(PStr binaryFile,
                                                    long *numberOfRows,
                                                    long *numberOfColumns,
                                                    float column1[],
                                                    float column2[],
                                                    float column3[],
                                                    float column4[],
                                                    float column5[],
                                                    float column6[],
                                                    float column7[],
                                                    float column8[],
                                                    float column9[],
                                                    float column10[],
                                                    float column11[]);
    Can you define in VBA that you want to use pointer instead? Maybe by using ByRef (as by reference).
    Hope this helps.

  • Influencing BGP attributes within MPLS network

    pls take a look at my question and diagram is attached in the file. pls help me to fix this problem.
    I have following requirement about traffic paths within the 
    MPLS network.MPLS network is running MP-BGP4.
    1.Traffic from Europe branch to Asia branch go through London
      router.
    2.Traffic from America branch to Asia branch go through Los Angeles
      router.
    3.The two paths through London and Los Angeles should have redundancy.
      That is if path through London is not accessible all the traffic must
      go through Los Angeles. IF Los Angeles path go down all the traffic must
      go through London.
    4.Traffic from Asia to Europe and America is controlled by redistributing
      BGP4 learned routes with different metrics at the London and Los Angeles
      routers.So that trafic from Asia branch to Europe go through London and
      traffic from Asia to America go through Los Angeles.
    I have been using below configs on the PE routers. But it is not working.
    In the MPLS network only one path is selected for both traffic from Europe
    and America.Pls can anyone help me to fix this problem.
    #PE3
    ip vrf CUSTOMER
    rd 1:10
    route-target export 1:20
    route-target import 1:40
    export map EXPORT-ROUTE
    import map IMPORT-ROUTE
    interface FastEthernet0/0
    description LONDON-GW
    ip vrf forwarding CUSTOMER
    ip address 1.1.1.2 255.255.255.252
    router bgp 65400
    address-family ipv4 vrf CUSTOMER
    redistribute connected
    neighbor 1.1.1.1 remote-as 65401
    neighbor 1.1.1.1 activate
    neighbor 1.1.1.1 next-hop-self
    neighbor 1.1.1.1 soft-reconfiguration inbound
    no auto-summary
    no synchronization
    exit-address-family
    ip extcommunity-list 1 permit rt 1:10
    ip extcommunity-list 2 permit rt 1:40
    route-map EXPORT-ROUTE permit 10
    description LONDON-GW
    match extcommunity 1
    set extcomm-list 1 delete
    set extcommunity rt 1:20 additive
    route-map IMPORT-ROUTE permit 10
    description EU & US-BRANCH
    match extcommunity 2
    #PE4
    ip vrf CUSTOMER
    rd 1:10
    route-target export 1:30
    route-target import 1:40
    export map EXPORT-ROUTE
    import map IMPORT-ROUTE
    interface FastEthernet0/0
    description LA-GW
    ip vrf forwarding CUSTOMER
    ip address 2.2.2.2 255.255.255.252
    router bgp 65400
    address-family ipv4 vrf CUSTOMER
    redistribute connected
    neighbor 2.2.2.1 remote-as 65402
    neighbor 2.2.2.1 activate
    neighbor 2.2.2.1 next-hop-self
    neighbor 2.2.2.1 soft-reconfiguration inbound
    no auto-summary
    no synchronization
    exit-address-family
    ip extcommunity-list 1 permit rt 1:10
    ip extcommunity-list 2 permit rt 1:40
    route-map EXPORT-ROUTE permit 10
    description LA-GW
    match extcommunity 1
    set extcomm-list 1 delete
    set extcommunity rt 1:30 additive
    route-map IMPORT-ROUTE permit 10
    description EU & US-BRANCH
    match extcommunity 2
    #PE1
    ip vrf CUSTOMER
    rd 1:10
    route-target export 1:40
    route-target import 1:20
    route-target import 1:30
    export map EXPORT-ROUTE
    import map IMPORT-ROUTE
    interface FastEthernet0/0
    description EU-BRANCH
    ip vrf forwarding CUSTOMER
    ip address 3.3.3.2 255.255.255.252
    router bgp 65400
    address-family ipv4 vrf CUSTOMER
    redistribute connected
    redistribute static
    no auto-summary
    no synchronization
    exit-address-family
    ip route vrf CUSTOMER 172.16.1.0 255.255.255.0 FastEthernet0/0 3.3.3.1 name EU-BRANCH
    ip extcommunity-list 1 permit rt 1:10
    ip extcommunity-list 2 permit rt 1:20
    ip extcommunity-list 3 permit rt 1:30
    route-map EXPORT-ROUTE permit 10
    description EU-BRANCH
    match extcommunity 1
    set extcomm-list 1 delete
    set extcommunity rt 1:40 additive
    route-map IMPORT-ROUTE permit 10
    description LONDON-GW(MAIN)
    match extcommunity 2
    set metric 100
    route-map IMPORT-ROUTE permit 20
    description LA-GW(BACKUP)
    match extcommunity 3
    set metric 200
    route-map IMPORT-ROUTE permit 30
    description OTHER
    #PE2
    ip vrf CUSTOMER
    rd 1:10
    route-target export 1:40
    route-target import 1:20
    route-target import 1:30
    export map EXPORT-ROUTE
    import map IMPORT-ROUTE
    interface FastEthernet0/0
    description US-BRANCH
    ip vrf forwarding CUSTOMER
    ip address 4.4.4.2 255.255.255.252
    router bgp 65400
    address-family ipv4 vrf CUSTOMER
    redistribute connected
    redistribute static
    no auto-summary
    no synchronization
    exit-address-family
    ip route vrf CUSTOMER 192.168.1.0 255.255.255.0 FastEthernet0/0 4.4.4.1 name US-BRANCH
    ip extcommunity-list 1 permit rt 1:10
    ip extcommunity-list 2 permit rt 1:20
    ip extcommunity-list 3 permit rt 1:30
    route-map EXPORT-ROUTE permit 10
    description US-BRANCH
    match extcommunity 1
    set extcomm-list 1 delete
    set extcommunity rt 1:40 additive
    route-map IMPORT-ROUTE permit 10
    description LONDON-GW(BACKUP)
    match extcommunity 2
    set metric 200
    route-map IMPORT-ROUTE permit 20
    description LA-GW(MAIN)
    match extcommunity 3
    set metric 100
    route-map IMPORT-ROUTE permit 30
    description OTHER

    Hi Manoj
    "send-community both" will export both Standard and Extended Communities
    The Standard Community Values which we are setting up New on PE3 and PE4 and Matching on PE1 and PE2 can be anything in ASN:nn Format..I Just randomly chose them as 65400:1111 on PE3/PE1 and 65400:2222 on PE4/PE2.
    The extcommunity values to be used on PE3/PE4 will be the export RT values used in the VRF Customer Config as posted in your first post..
    #PE3
    ip vrf CUSTOMER
    rd 1:10
    route-target export 1:20
    route-target import 1:40
    export map EXPORT-ROUTE
    import map IMPORT-ROUTE
    #PE4
    ip vrf CUSTOMER
    rd 1:10
    route-target export 1:30
    route-target import 1:40
    export map EXPORT-ROUTE
    import map IMPORT-ROUTE
    I think I mixed up little with PE3 as PE1 and PE4 as PE2 instead ..Revised corrected config would be
    On PE3-- Under VPNv4 We enable sending out the normal community values out to the RR.Then we match the extcommunity rt for the VRF Customer and set the community value to 65400:1111 which will be matched at PE1
    router bgp 65400
    address-family vpnv4
    neighbor "RR-IP" send-community both
    neighbor "RR-IP" route-map community out
    exit-address-family
    route-map community permit 10
    match extcommunity CUSTOMER
    set community 65400:1111
    route-map community permit 20
    ip extcommunity-list standard CUSTOMER permit rt 1:20
    On PE4-- Under VPNv4 We enable sending out the normal community values out to the RR.Then we match the extcommunity rt for the VRF Customer and set the community value to 65400:2222 which will be matched at PE2
    router bgp 65400
    address-family vpnv4
    neighbor "RR-IP" send-community both
    neighbor "RR-IP" route-map community out
    exit-address-family
    route-map community permit 10
    match extcommunity CUSTOMER
    set community 65400:2222
    route-map community permit 20
    ip extcommunity-list standard CUSTOMER permit rt 1:30
    On PE1-- Under VPNv4 We match the community value 65400:1111 which was set at PE3 and set the LP to 110
    router bgp 65400
    address-family vpnv4
    neighbor "RR-IP" route-map community in
    exit-address-family
    route-map community permit 10
    match community CUSTOMER
    set local-preference 110
    route-map community permit 20
    ip community-list standard CUSTOMER permit 65400:1111
    On PE2-- Under VPNv4 We match the community value 65400:2222 which was set at PE4 and set the LP to 110
    router bgp 65400
    address-family vpnv4
    neighbor "RR-IP" route-map community in
    exit-address-family
    route-map community permit 10
    match community CUSTOMER
    set local-preference 110
    route-map community permit 20
    ip community-list standard CUSTOMER permit 65400:2222
    Make Sure that RR is enabled to propogate the normal BGP communities as well...
    Hope this helps to answer your question..Please let me know for any clarifications..
    Regards
    Varma

  • Display requestScope attributes within ADF UIX page

    In jsp I can do the following to display all attributes available in the current requestScope by
          < c:forEach var='parameter' items='${requestScope}'>
             < ul>
                < li>< b>< c:out value='${parameter.key} : ${parameter.value}'/></b>:</li>
             < /ul>
          < /c:forEach>How to do the same in ADF UIX (without using servletInclude)?

    Please provide an example
    This works
    <styledText text="parameterMap ${uix.bajaContext.servletRequest.parameterMap}"/>But this does not work.
    <stackLayout>
      <contents childData="${uix.bajaContext.servletRequest.parameterMap}">
             <styledText text="text: ${uix.current.key}"/>
       </contents>
    </stackLayout>How to use ${uix.bajaContext.servletRequest.attributeNames} for instance since this returns a java.util.Enumeration type?

  • Using TAG Attributes within JSF Tags

    I'm using some .tag files for templating purposes. I'm using two tag attributes via <@% attribute %> directive. How can i access this attribute to do something like follows.
    <%@ tag display-name="Area de Trabajo" language="java" %>
    <%@ taglib prefix="f" uri="http://java.sun.com/jsf/core"%>
    <%@ taglib prefix="h" uri="http://java.sun.com/jsf/html"%>
    <%@ taglib prefix="t" uri="http://myfaces.apache.org/tomahawk"%>
    <%@ attribute name="title" required="true"%>
    <%@ attribute name="location" %>
    <t:div styleClass="zonaArea#{(not empty location) ? location : 'Global'}">
      <h:panelGrid columns="1">
        <h:outputText value="#{title}" />
      </h:panelGrid>
      <jsp:doBody />
    </t:div>

    Hola Alberto.
    Any luck? Did you worked that around?
    I'm just trying to do the same thing...
    Tried to do something like:
    <%@attribute name="enabled" type="java.lang.String" %>
    <h:outputText value="test: #{requestScope['enabled']}" style="font-weight: bold;" /> to no avail...
    Let me know, please!
    Hi,
    Manrico

  • How do I change the number formatting within a Cell Table in Microsoft Word?

    Hi, I was wondering if someone could help me out on an issue I've been having... I work for an accounting firm and we do a lot of financial statements. 
    I was wondering if we would be able to treat a cell table in Microsoft Word 2007 like I would a cell table in Microsoft Excel. Meaning, I would like to change the formatting of the numbers in the table to the "Accounting" (number) format so it
    aligns by the decimal point and use the $ signs and () for negative numbers.  We do use the link tables feature, however, most of our balancing pages just can't be done in Excel because of the way the text is written. It would be much harder to format
    the text if it were to be typed in Excel. We have also tried  creating an Excel sheet within Microsoft Word but it is the same as linking the tables... Again, a text formatting issue.  The only option is to use tables within Word but how do we change
    the number formatting to a "accounting" (number) format where the numbers would align with the decimal point and use () for the negative numbers. Is there ANY option for us to do this other than manually entering this information in using tabs?  
    If there are no options other than entering it in manually, please consider this as an option for your next software update. I believe that a LOT of people out there will be interested in this feature... My manager and I just attended a webinar on Microsoft
    Advanced Word Tips Tricks and Techniques and 75% of the attending people had this question but no answer.
    Thank you very much for your help!!!!!

    Word does not really have number formatting for table cells. You can align cell contents on the decimal point, though, by setting a so-called decimal tab stop.
    Option 1:
    - Select the cells for which you want to do this.
    - Display the ruler.
    - Click the Tab box on the left hand side of the ruler until the box contains an inverted T with a dot.
    - Click in the ruler where you want the decimal tab.
    Option 2:
    - Select the cells for which you want to do this.
    - Click the arrow in the lower right corner of the Paragraph group on the Home tab of the ribbon.
    - Click the Tabs... button in the lower left corner of the dialog.
    - Specify a tab position in the box, e.g. 1.5".
    - Select the 'Decimal' radio button under 'Alignment'.
    - Click Set.
    - Click OK.
    You will have to type the numbers as they should appear, including the $ for currency and the ( ) for negative numbers.
    Regards, Hans Vogelaar

  • Error Extending 2012 R2 AD Schema for Exchange 2013 RTM/CU6/CU7 (for Office 365 attributes)

    Hello all,
    I am a sysadmin at a 3 campus school, and am trying to extend our AD schema to include Exchange 2013 attributes so that we can configure groups synced to Office 365 using DirSync. However it keeps failing at the same point each time.
    I have tried with RTM first, and then CU6, but I keep getting the same error and am unsure how to fix it.
    "repadmin /showrepl" says that our 3 DCs are replicating with no issues, and I'm trying to extend the schema using an "Enterprise Admin"/"Schema Admin" account on our schema master DC.
    Our domain/forest functional level is Server 2008R2, and we do not have an Exchange server set up already - if that helps.
    The PowerShell error is:
    PS C:\Users\rbbr\Desktop\Exchange> .\setup /PrepareSchema /IAcceptExchangeServerLicenseTerms
    Welcome to Microsoft Exchange Server 2013 Cumulative Update 6 Unattended Setup
    Copying Files...
    File copy complete. Setup will now collect additional information needed for installation.
    Performing Microsoft Exchange Server Prerequisite Check
    Prerequisite Analysis COMPLETED
    Configuring Microsoft Exchange Server
    Extending Active Directory schema FAILED
    The following error was generated when "$error.Clear();
    install-ExchangeSchema -LdapFileName ($roleInstallPath + "Setup\Data\"+$RoleSchemaPrefix + "schema89.ldf")
    " was run: "Microsoft.Exchange.Configuration.Tasks.TaskException: There was an error while running 'ldifde.exe' to impor
    t the schema file 'C:\Windows\Temp\ExchangeSetup\Setup\Data\schema89.ldf'. The error code is: 8245. More details can be
    found in the error file: 'C:\Users\rbbr\AppData\Local\Temp\ldif.err'
    at Microsoft.Exchange.Configuration.Tasks.Task.ThrowError(Exception exception, ErrorCategory errorCategory, Object ta
    rget, String helpUrl)
    at Microsoft.Exchange.Management.Deployment.InstallExchangeSchema.ImportSchemaFile(String schemaMasterServer, String
    schemaFilePath, String macroName, String macroValue, WriteVerboseDelegate writeVerbose)
    at Microsoft.Exchange.Management.Deployment.InstallExchangeSchema.InternalProcessRecord()
    at Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b()
    at Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePip
    elineIfFailed)".
    The Exchange Server setup operation didn't complete. More details can be found in ExchangeSetup.log located in the
    <SystemDrive>:\ExchangeSetupLogs folder.
    And ldif.err says:
    Entry DN: CN=ms-DS-GeoCoordinates-Altitude,CN=Schema,CN=Configuration,DC=kurnai,DC=lan
    Add error on entry starting on line 452: Unwilling To Perform
    The server side error is: 0x20bb Schema update failed: duplicate OID.
    The extended server error is:
    000020BB: SvcErr: DSID-032603C0, problem 5003 (WILL_NOT_PERFORM), data 8379
    An error has occurred in the program
    The schema attribute "CN=ms-DS-GeoCoordinates-Altitude,CN=Schema,CN=Configuration,DC=kurnai,DC=lan" does exist in the schema, but I don't know what to do or where to go from here.
    Any assistance would be greatly appreciated.

    I just tried .\setup /PrepareAD /OrganizationName:kurnaicollege /IAcceptExchangeServerLicenseTerms, and got the exact same error as above. 
    Is there a way to delete the offending schema attributes, or to force its overwrite or something?
    EDIT: I am also getting these eventvwr errors when running /PrepareAD, if it helps:
    The description for Event ID 106 from source MSExchange Common cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    If the event originated on another computer, the display information had to be saved with the event.
    The following information was included with the event:
    2
    Proxy Instance Count
    MSExchange ServiceProxyPool
    The exception thrown is : System.InvalidOperationException: The requested Performance Counter is not a custom counter, it has to be initialized as ReadOnly.
    at System.Diagnostics.PerformanceCounter.InitializeImpl()
    at System.Diagnostics.PerformanceCounter.get_RawValue()
    at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.get_RawValue()
    Last worker process info : Last worker process info not available!
    Processes running while Performance counter failed to update:
    2756 vds
    3540 NBBPassThruAuth_Helper
    4168 dwm
    1224 NBBPassThruAuth_Helper
    776 MsMpEng
    2940 dllhost
    3924 NBBPassThruAuth_Helper
    376 wininit
    1556 dns
    4900 taskhostex
    368 csrss
    2152 miiserver
    756 dwm
    1452 Microsoft.ActiveDirectory.WebServices
    1704 conhost
    1540 svchost
    4492 conhost
    740 LogonUI
    3716 notepad
    3888 WmiPrvSE
    140 NBBPassThruAuth_Helper
    1712 sqlservr
    3484 msseces
    916 svchost
    1116 sqlwriter
    1312 setup
    1508 dfsrs
    2492 explorer
    520 svchost
    712 WmiPrvSE
    4388 mmc
    2088 dfssvc
    1692 MSOIDSVCM
    704 conhost
    960 svchost
    304 csrss
    4440 NBBPassThruAuth_Helper
    3648 conhost
    884 svchost
    1080 vmtoolsd
    3440 conhost
    5012 NBBPassThruAuth_Helper
    3632 dllhost
    476 lsass
    1852 NBBPassThruAuth
    2836 svchost
    4016 winlogon
    468 services
    3028 vmtoolsd
    860 conhost
    1644 MSOIDSVC
    3416 conhost
    852 conhost
    2624 Microsoft.Online.DirSync.Scheduler
    2820 svchost
    4592 ServerManager
    1236 iashost
    636 svchost
    2800 svchost
    4768 ExSetup
    1812 msdtc
    1416 spoolsv
    4760 NBBPassThruAuth_Helper
    1016 svchost
    1992 ntfrs
    3368 powershell
    608 svchost
    1592 ismserv
    3756 csrss
    404 winlogon
    204 smss
    4 System
    988 rdpclip
    0 Idle
    Performance Counters Layout information: FileMappingNotFoundException for category MSExchange ServiceProxyPool : Microsoft.Exchange.Diagnostics.FileMappingNotFoundException: Cound not open File mapping for name Global\netfxcustomperfcounters.1.0msexchange serviceproxypool. Error Details: 2
    at Microsoft.Exchange.Diagnostics.FileMapping..ctor(String name, Boolean writable)
    at Microsoft.Exchange.Diagnostics.PerformanceCounterMemoryMappedFile.Initialize(String fileMappingName, Boolean writable)
    at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.GetAllInstancesLayout(String categoryName)
    the message resource is present but the message is not found in the string/message table
    The description for Event ID 106 from source MSExchange Common cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    If the event originated on another computer, the display information had to be saved with the event.
    The following information was included with the event:
    1
    Average Latency
    MSExchange ServiceProxyPool
    The exception thrown is : System.InvalidOperationException: The requested Performance Counter is not a custom counter, it has to be initialized as ReadOnly.
    at System.Diagnostics.PerformanceCounter.InitializeImpl()
    at System.Diagnostics.PerformanceCounter.IncrementBy(Int64 value)
    at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.IncrementBy(Int64 incrementValue)
    Last worker process info : Last worker process info not available!
    Processes running while Performance counter failed to update:
    4136 NBBPassThruAuth_Helper
    2756 vds
    4168 dwm
    1224 NBBPassThruAuth_Helper
    776 MsMpEng
    2940 dllhost
    3924 NBBPassThruAuth_Helper
    376 wininit
    1556 dns
    4900 taskhostex
    368 csrss
    2152 miiserver
    756 dwm
    4260 conhost
    1452 Microsoft.ActiveDirectory.WebServices
    1540 svchost
    4488 conhost
    740 LogonUI
    3716 notepad
    3888 WmiPrvSE
    140 NBBPassThruAuth_Helper
    1712 sqlservr
    3484 msseces
    916 svchost
    1116 sqlwriter
    1312 setup
    1508 dfsrs
    2492 explorer
    2688 NBBPassThruAuth_Helper
    520 svchost
    3472 conhost
    712 WmiPrvSE
    4388 mmc
    2088 dfssvc
    1692 MSOIDSVCM
    704 conhost
    960 svchost
    304 csrss
    3648 conhost
    884 svchost
    1080 vmtoolsd
    3836 WmiPrvSE
    5012 NBBPassThruAuth_Helper
    3632 dllhost
    476 lsass
    1852 NBBPassThruAuth
    2836 svchost
    4016 winlogon
    468 services
    3028 vmtoolsd
    860 conhost
    1644 MSOIDSVC
    3416 conhost
    852 conhost
    2624 Microsoft.Online.DirSync.Scheduler
    2820 svchost
    4592 ServerManager
    1236 iashost
    4580 NBBPassThruAuth_Helper
    636 svchost
    2800 svchost
    4768 ExSetup
    1812 msdtc
    1416 spoolsv
    3776 NBBPassThruAuth_Helper
    1016 svchost
    1992 ntfrs
    3368 powershell
    608 svchost
    1592 ismserv
    3756 csrss
    404 winlogon
    204 smss
    4 System
    988 rdpclip
    4436 conhost
    0 Idle
    Performance Counters Layout information: FileMappingNotFoundException for category MSExchange ServiceProxyPool : Microsoft.Exchange.Diagnostics.FileMappingNotFoundException: Cound not open File mapping for name Global\netfxcustomperfcounters.1.0msexchange serviceproxypool. Error Details: 2
    at Microsoft.Exchange.Diagnostics.FileMapping..ctor(String name, Boolean writable)
    at Microsoft.Exchange.Diagnostics.PerformanceCounterMemoryMappedFile.Initialize(String fileMappingName, Boolean writable)
    at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.GetAllInstancesLayout(String categoryName)
    the message resource is present but the message is not found in the string/message table
    The description for Event ID 106 from source MSExchange Common cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    If the event originated on another computer, the display information had to be saved with the event.
    The following information was included with the event:
    1
    Base for Average Latency
    MSExchange ServiceProxyPool
    The exception thrown is : System.InvalidOperationException: The requested Performance Counter is not a custom counter, it has to be initialized as ReadOnly.
    at System.Diagnostics.PerformanceCounter.InitializeImpl()
    at System.Diagnostics.PerformanceCounter.IncrementBy(Int64 value)
    at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.IncrementBy(Int64 incrementValue)
    Last worker process info : Last worker process info not available!
    Processes running while Performance counter failed to update:
    4136 NBBPassThruAuth_Helper
    2756 vds
    4168 dwm
    1224 NBBPassThruAuth_Helper
    776 MsMpEng
    2940 dllhost
    3924 NBBPassThruAuth_Helper
    376 wininit
    1556 dns
    4900 taskhostex
    368 csrss
    2152 miiserver
    756 dwm
    4260 conhost
    1452 Microsoft.ActiveDirectory.WebServices
    1540 svchost
    4488 conhost
    740 LogonUI
    3716 notepad
    3888 WmiPrvSE
    140 NBBPassThruAuth_Helper
    1712 sqlservr
    3484 msseces
    916 svchost
    1116 sqlwriter
    1312 setup
    1508 dfsrs
    2492 explorer
    2688 NBBPassThruAuth_Helper
    520 svchost
    3472 conhost
    712 WmiPrvSE
    4388 mmc
    2088 dfssvc
    1692 MSOIDSVCM
    704 conhost
    960 svchost
    304 csrss
    3648 conhost
    884 svchost
    1080 vmtoolsd
    3836 WmiPrvSE
    5012 NBBPassThruAuth_Helper
    3632 dllhost
    476 lsass
    1852 NBBPassThruAuth
    2836 svchost
    4016 winlogon
    468 services
    3028 vmtoolsd
    860 conhost
    1644 MSOIDSVC
    3416 conhost
    852 conhost
    2624 Microsoft.Online.DirSync.Scheduler
    2820 svchost
    4592 ServerManager
    1236 iashost
    4580 NBBPassThruAuth_Helper
    636 svchost
    2800 svchost
    4768 ExSetup
    1812 msdtc
    1416 spoolsv
    3776 NBBPassThruAuth_Helper
    1016 svchost
    1992 ntfrs
    3368 powershell
    608 svchost
    1592 ismserv
    3756 csrss
    404 winlogon
    204 smss
    4 System
    988 rdpclip
    4436 conhost
    0 Idle
    Performance Counters Layout information: FileMappingNotFoundException for category MSExchange ServiceProxyPool : Microsoft.Exchange.Diagnostics.FileMappingNotFoundException: Cound not open File mapping for name Global\netfxcustomperfcounters.1.0msexchange serviceproxypool. Error Details: 2
    at Microsoft.Exchange.Diagnostics.FileMapping..ctor(String name, Boolean writable)
    at Microsoft.Exchange.Diagnostics.PerformanceCounterMemoryMappedFile.Initialize(String fileMappingName, Boolean writable)
    at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.GetAllInstancesLayout(String categoryName)
    the message resource is present but the message is not found in the string/message table
    The description for Event ID 4027 from source MSExchange ADAccess cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    If the event originated on another computer, the display information had to be saved with the event.
    The following information was included with the event:
    ExSetup.exe
    4768
    Get Servers for kurnai.lan
    TopologyClientTcpEndpoint (localhost)
    3
    System.ServiceModel.EndpointNotFoundException: Could not connect to net.tcp://localhost:890/Microsoft.Exchange.Directory.TopologyService. The connection attempt lasted for a time span of 00:00:02.1106192. TCP error code 10061: No connection could be made because the target machine actively refused it 127.0.0.1:890. ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 127.0.0.1:890
    at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
    at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
    at System.ServiceModel.Channels.SocketConnectionInitiator.Connect(Uri uri, TimeSpan timeout)
    --- End of inner exception stack trace ---
    Server stack trace:
    at System.ServiceModel.Channels.SocketConnectionInitiator.Connect(Uri uri, TimeSpan timeout)
    at System.ServiceModel.Channels.BufferedConnectionInitiator.Connect(Uri uri, TimeSpan timeout)
    at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout)
    at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout)
    at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
    at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout)
    at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
    Exception rethrown at [0]:
    at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
    at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
    at System.ServiceModel.ICommunicationObject.Open()
    at Microsoft.Exchange.Net.ServiceProxyPool`1.GetClient(Boolean useCache)
    at Microsoft.Exchange.Net.ServiceProxyPool`1.TryCallServiceWithRetry(Action`1 action, String debugMessage, WCFConnectionStateTuple proxyToUse, Int32 numberOfRetries, Boolean doNotReturnProxyOnSuccess, Exception& exception)
    the message resource is present but the message is not found in the string/message table
    The description for Event ID 106 from source MSExchange Common cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    If the event originated on another computer, the display information had to be saved with the event.
    The following information was included with the event:
    2
    Time in Resource per second
    MSExchange Activity Context Resources
    The exception thrown is : System.InvalidOperationException: The requested Performance Counter is not a custom counter, it has to be initialized as ReadOnly.
    at System.Diagnostics.PerformanceCounter.InitializeImpl()
    at System.Diagnostics.PerformanceCounter.get_RawValue()
    at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.get_RawValue()
    Last worker process info : Last worker process info not available!
    Processes running while Performance counter failed to update:
    2756 vds
    4168 dwm
    776 MsMpEng
    2940 dllhost
    376 wininit
    1556 dns
    4900 taskhostex
    368 csrss
    2152 miiserver
    756 dwm
    1452 Microsoft.ActiveDirectory.WebServices
    1540 svchost
    4488 conhost
    740 LogonUI
    3716 notepad
    3888 WmiPrvSE
    1712 sqlservr
    3484 msseces
    916 svchost
    1116 sqlwriter
    1312 setup
    1508 dfsrs
    2492 explorer
    2688 NBBPassThruAuth_Helper
    520 svchost
    712 WmiPrvSE
    2088 dfssvc
    1692 MSOIDSVCM
    960 svchost
    304 csrss
    4436 conhost
    884 svchost
    1080 vmtoolsd
    3836 WmiPrvSE
    4388 mmc
    3632 dllhost
    476 lsass
    1852 NBBPassThruAuth
    2836 svchost
    4016 winlogon
    468 services
    3028 vmtoolsd
    1644 MSOIDSVC
    3416 conhost
    2624 Microsoft.Online.DirSync.Scheduler
    2820 svchost
    4592 ServerManager
    1236 iashost
    636 svchost
    2800 svchost
    4768 ExSetup
    1812 msdtc
    1416 spoolsv
    3776 NBBPassThruAuth_Helper
    1016 svchost
    1992 ntfrs
    3368 powershell
    608 svchost
    1592 ismserv
    3756 csrss
    404 winlogon
    204 smss
    4 System
    988 rdpclip
    0 Idle
    Performance Counters Layout information: FileMappingNotFoundException for category MSExchange Activity Context Resources : Microsoft.Exchange.Diagnostics.FileMappingNotFoundException: Cound not open File mapping for name Global\netfxcustomperfcounters.1.0msexchange activity context resources. Error Details: 2
    at Microsoft.Exchange.Diagnostics.FileMapping..ctor(String name, Boolean writable)
    at Microsoft.Exchange.Diagnostics.PerformanceCounterMemoryMappedFile.Initialize(String fileMappingName, Boolean writable)
    at Microsoft.Exchange.Diagnostics.ExPerformanceCounter.GetAllInstancesLayout(String categoryName)
    the message resource is present but the message is not found in the string/message table
    The description for Event ID 6 from source MSExchange CmdletLogs cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    If the event originated on another computer, the display information had to be saved with the event.
    The following information was included with the event:
    Get-OrganizationRelationship
    kurnai.lan/Kurnai/Morwell/Users/Techs/Robert Brandon
    Local-Exchange Management Console-Unknown
    4768 ExSetup.exe
    34
    00:00:00.0938055
    View Entire Forest: 'True', Configuration Domain Controller: 'C-Server1.kurnai.lan', Preferred Global Catalog: 'C-Server1.kurnai.lan', Preferred Domain Controllers: '{ C-Server1.kurnai.lan }'
    Microsoft.Exchange.Data.Directory.SystemConfiguration.OrgContainerNotFoundException: Couldn't find the Enterprise Organization container.
    at Microsoft.Exchange.Data.Directory.SystemConfiguration.ADSystemConfigurationSession.GetRootOrgContainer(String partitionFqdn, String domainController, NetworkCredential credential)
    at Microsoft.Exchange.Data.Directory.SystemConfiguration.ADSystemConfigurationSession.GetRootOrgContainerId(String partitionFqdn, String domainController, NetworkCredential credential)
    at Microsoft.Exchange.Configuration.Tasks.DataAccessTask`1.get_RootOrgContainerId()
    at Microsoft.Exchange.Configuration.Tasks.GetTenantADObjectWithIdentityTaskBase`2.InternalStateReset()
    at Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b()
    at Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)
    ServerOperation
    Ex31B4F7
    False
    0 objects execution has been proxied to remote server.
    0
    ActivityId: a2ea62f0-d687-4594-bb1a-bcd9642a6308
    en-US
    the message resource is present but the message is not found in the string/message table
    The description for Event ID 6 from source MSExchange CmdletLogs cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    If the event originated on another computer, the display information had to be saved with the event.
    The following information was included with the event:
    Get-OrganizationRelationship
    kurnai.lan/Kurnai/Morwell/Users/Techs/Robert Brandon
    Local-Exchange Management Console-Unknown
    4768 ExSetup.exe
    34
    00:00:00.0312685
    View Entire Forest: 'True', Configuration Domain Controller: 'C-Server1.kurnai.lan', Preferred Global Catalog: 'C-Server1.kurnai.lan', Preferred Domain Controllers: '{ C-Server1.kurnai.lan }'
    Microsoft.Exchange.Data.Directory.SystemConfiguration.OrgContainerNotFoundException: Couldn't find the Enterprise Organization container.
    at Microsoft.Exchange.Data.Directory.SystemConfiguration.ADSystemConfigurationSession.GetRootOrgContainer(String partitionFqdn, String domainController, NetworkCredential credential)
    at Microsoft.Exchange.Data.Directory.SystemConfiguration.ADSystemConfigurationSession.GetRootOrgContainerId(String partitionFqdn, String domainController, NetworkCredential credential)
    at Microsoft.Exchange.Configuration.Tasks.DataAccessTask`1.get_RootOrgContainerId()
    at Microsoft.Exchange.Configuration.Tasks.GetTenantADObjectWithIdentityTaskBase`2.InternalStateReset()
    at Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b()
    at Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)
    ServerOperation
    Ex31B4F7
    False
    0 objects execution has been proxied to remote server.
    0
    ActivityId: a2ea62f0-d687-4594-bb1a-bcd9642a6308
    en-US
    the message resource is present but the message is not found in the string/message table
    The description for Event ID 6 from source MSExchange CmdletLogs cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    If the event originated on another computer, the display information had to be saved with the event.
    The following information was included with the event:
    Get-AcceptedDomain
    kurnai.lan/Kurnai/Morwell/Users/Techs/Robert Brandon
    Local-Exchange Management Console-Unknown
    4768 ExSetup.exe
    20
    00:00:00
    View Entire Forest: 'True', Configuration Domain Controller: 'C-Server1.kurnai.lan', Preferred Global Catalog: 'C-Server1.kurnai.lan', Preferred Domain Controllers: '{ C-Server1.kurnai.lan }'
    Microsoft.Exchange.Data.Directory.SystemConfiguration.OrgContainerNotFoundException: Couldn't find the Enterprise Organization container.
    at Microsoft.Exchange.Data.Directory.SystemConfiguration.ADSystemConfigurationSession.GetRootOrgContainer(String partitionFqdn, String domainController, NetworkCredential credential)
    at Microsoft.Exchange.Data.Directory.SystemConfiguration.ADSystemConfigurationSession.GetRootOrgContainerId(String partitionFqdn, String domainController, NetworkCredential credential)
    at Microsoft.Exchange.Configuration.Tasks.DataAccessTask`1.get_RootOrgContainerId()
    at Microsoft.Exchange.Configuration.Tasks.GetTenantADObjectWithIdentityTaskBase`2.InternalStateReset()
    at Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b()
    at Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)
    ServerOperation
    Ex31B4F7
    False
    0 objects execution has been proxied to remote server.
    0
    ActivityId: a2ea62f0-d687-4594-bb1a-bcd9642a6308
    en-US
    the message resource is present but the message is not found in the string/message table
    The description for Event ID 6 from source MSExchange CmdletLogs cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    If the event originated on another computer, the display information had to be saved with the event.
    The following information was included with the event:
    Get-AcceptedDomain
    kurnai.lan/Kurnai/Morwell/Users/Techs/Robert Brandon
    Local-Exchange Management Console-Unknown
    4768 ExSetup.exe
    20
    00:00:00
    View Entire Forest: 'True', Configuration Domain Controller: 'C-Server1.kurnai.lan', Preferred Global Catalog: 'C-Server1.kurnai.lan', Preferred Domain Controllers: '{ C-Server1.kurnai.lan }'
    Microsoft.Exchange.Data.Directory.SystemConfiguration.OrgContainerNotFoundException: Couldn't find the Enterprise Organization container.
    at Microsoft.Exchange.Data.Directory.SystemConfiguration.ADSystemConfigurationSession.GetRootOrgContainer(String partitionFqdn, String domainController, NetworkCredential credential)
    at Microsoft.Exchange.Data.Directory.SystemConfiguration.ADSystemConfigurationSession.GetRootOrgContainerId(String partitionFqdn, String domainController, NetworkCredential credential)
    at Microsoft.Exchange.Configuration.Tasks.DataAccessTask`1.get_RootOrgContainerId()
    at Microsoft.Exchange.Configuration.Tasks.GetTenantADObjectWithIdentityTaskBase`2.InternalStateReset()
    at Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b()
    at Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)
    ServerOperation
    Ex31B4F7
    False
    0 objects execution has been proxied to remote server.
    0
    ActivityId: a2ea62f0-d687-4594-bb1a-bcd9642a6308
    en-US
    the message resource is present but the message is not found in the string/message table
    The description for Event ID 6 from source MSExchange CmdletLogs cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    If the event originated on another computer, the display information had to be saved with the event.
    The following information was included with the event:
    Install-ExchangeSchema
    -LdapFileName "Setup\Data\schema89.ldf"
    kurnai.lan/Kurnai/Morwell/Users/Techs/Robert Brandon
    Local-Exchange Management Console-Unknown
    4768 ExSetup.exe
    98
    00:00:02.1887925
    View Entire Forest: 'True', Configuration Domain Controller: 'C-Server1.kurnai.lan', Preferred Global Catalog: 'C-Server1.kurnai.lan', Preferred Domain Controllers: '{ C-Server1.kurnai.lan }'
    Microsoft.Exchange.Configuration.Tasks.TaskException: There was an error while running 'ldifde.exe' to import the schema file 'C:\Windows\Temp\ExchangeSetup\Setup\Data\schema89.ldf'. The error code is: 8245. More details can be found in the error file: 'C:\Users\rbbr\AppData\Local\Temp\ldif.err'
    at Microsoft.Exchange.Configuration.Tasks.Task.ThrowError(Exception exception, ErrorCategory errorCategory, Object target, String helpUrl)
    at Microsoft.Exchange.Management.Deployment.InstallExchangeSchema.ImportSchemaFile(String schemaMasterServer, String schemaFilePath, String macroName, String macroValue, WriteVerboseDelegate writeVerbose)
    at Microsoft.Exchange.Management.Deployment.InstallExchangeSchema.InternalProcessRecord()
    at Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b()
    at Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)
    7
    ExA2B06D
    False
    0 objects execution has been proxied to remote server.
    0
    ActivityId: f2ed251d-8d4a-480b-9b98-7b53d4adbcad
    en-US
    the message resource is present but the message is not found in the string/message table
    The description for Event ID 6 from source MSExchange CmdletLogs cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    If the event originated on another computer, the display information had to be saved with the event.
    The following information was included with the event:
    Install-ExchangeSchema
    -LdapFileName "Setup\Data\schema89.ldf"
    kurnai.lan/Kurnai/Morwell/Users/Techs/Robert Brandon
    Local-Exchange Management Console-Unknown
    4768 ExSetup.exe
    98
    00:00:00
    View Entire Forest: 'True', Configuration Domain Controller: 'C-Server1.kurnai.lan', Preferred Global Catalog: 'C-Server1.kurnai.lan', Preferred Domain Controllers: '{ C-Server1.kurnai.lan }'
    Microsoft.Exchange.Configuration.Tasks.TaskException: There was an error while running 'ldifde.exe' to import the schema file 'C:\Windows\Temp\ExchangeSetup\Setup\Data\schema89.ldf'. The error code is: 8245. More details can be found in the error file: 'C:\Users\rbbr\AppData\Local\Temp\ldif.err'
    at Microsoft.Exchange.Configuration.Tasks.Task.ThrowError(Exception exception, ErrorCategory errorCategory, Object target, String helpUrl)
    at Microsoft.Exchange.Management.Deployment.InstallExchangeSchema.ImportSchemaFile(String schemaMasterServer, String schemaFilePath, String macroName, String macroValue, WriteVerboseDelegate writeVerbose)
    at Microsoft.Exchange.Management.Deployment.InstallExchangeSchema.InternalProcessRecord()
    at Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b()
    at Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)
    7
    ExA2B06D
    False
    0 objects execution has been proxied to remote server.
    0
    ActivityId: f2ed251d-8d4a-480b-9b98-7b53d4adbcad
    en-US
    the message resource is present but the message is not found in the string/message table
    The description for Event ID 6 from source MSExchange CmdletLogs cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    If the event originated on another computer, the display information had to be saved with the event.
    The following information was included with the event:
    Install-ExchangeOrganization
    -Industry "NotSpecified" -PrepareDomain "True" -DomainController "C-Server1.kurnai.lan" -ActiveDirectorySplitPermissions $null -PrepareOrganization "True" -PrepareSchema "True" -OrganizationName "kurnaicollege"
    kurnai.lan/Kurnai/Morwell/Users/Techs/Robert Brandon
    Local-Exchange Management Console-Unknown
    4768 ExSetup.exe
    31
    00:03:01.8261106
    View Entire Forest: 'True', Configuration Domain Controller: 'C-Server1.kurnai.lan', Preferred Global Catalog: 'C-Server1.kurnai.lan', Preferred Domain Controllers: '{ C-Server1.kurnai.lan }'
    Microsoft.Exchange.Management.Deployment.ScriptExecutionException: The following error was generated when "$error.Clear();
    install-ExchangeSchema -LdapFileName ($roleInstallPath + "Setup\Data\"+$RoleSchemaPrefix + "schema89.ldf")
    " was run: "Microsoft.Exchange.Configuration.Tasks.TaskException: There was an error while running 'ldifde.exe' to import the schema file 'C:\Windows\Temp\ExchangeSetup\Setup\Data\schema89.ldf'. The error code is: 8245. More details can be found in the error file: 'C:\Users\rbbr\AppData\Local\Temp\ldif.err'
    at Microsoft.Exchange.Configuration.Tasks.Task.ThrowError(Exception exception, ErrorCategory errorCategory, Object target, String helpUrl)
    at Microsoft.Exchange.Management.Deployment.InstallExchangeSchema.ImportSchemaFile(String schemaMasterServer, String schemaFilePath, String macroName, String macroValue, WriteVerboseDelegate writeVerbose)
    at Microsoft.Exchange.Management.Deployment.InstallExchangeSchema.InternalProcessRecord()
    at Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b()
    at Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)". ---> Microsoft.Exchange.Configuration.Tasks.TaskException: There was an error while running 'ldifde.exe' to import the schema file 'C:\Windows\Temp\ExchangeSetup\Setup\Data\schema89.ldf'. The error code is: 8245. More details can be found in the error file: 'C:\Users\rbbr\AppData\Local\Temp\ldif.err'
    at Microsoft.Exchange.Configuration.Tasks.Task.ThrowError(Exception exception, ErrorCategory errorCategory, Object target, String helpUrl)
    at Microsoft.Exchange.Management.Deployment.InstallExchangeSchema.ImportSchemaFile(String schemaMasterServer, String schemaFilePath, String macroName, String macroValue, WriteVerboseDelegate writeVerbose)
    at Microsoft.Exchange.Management.Deployment.InstallExchangeSchema.InternalProcessRecord()
    at Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b()
    at Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)
    --- End of inner exception stack trace ---
    7
    Microsoft.Exchange.Configuration.Tasks.TaskException: There was an error while running 'ldifde.exe' to import the schema file 'C:\Windows\Temp\ExchangeSetup\Setup\Data\schema89.ldf'. The error code is: 8245. More details can be found in the error file: 'C:\Users\rbbr\AppData\Local\Temp\ldif.err'
    at Microsoft.Exchange.Configuration.Tasks.Task.ThrowError(Exception exception, ErrorCategory errorCategory, Object target, String helpUrl)
    at Microsoft.Exchange.Management.Deployment.InstallExchangeSchema.ImportSchemaFile(String schemaMasterServer, String schemaFilePath, String macroName, String macroValue, WriteVerboseDelegate writeVerbose)
    at Microsoft.Exchange.Management.Deployment.InstallExchangeSchema.InternalProcessRecord()
    at Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__b()
    at Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)
    Ex88D115
    False
    0 objects execution has been proxied to remote server.
    0
    ActivityId: f2ed251d-8d4a-480b-9b98-7b53d4adbcad
    en-US
    the message resource is present but the message is not found in the string/message table

  • Powershell script to Scan Active Directory Attributes for Country and Department ,Then add to Sales Group then add to Distribution list based on Region

    Hey Scripting Guys,
    I have been in and out of Powershell last few years, not that great at it tbh !!! I'm looking for advice on how I can as in Title, Create a Powershell script to Scan Active Directory Attributes for Country and Department ,Then add to Group then add to Distribution
    list based on Region/Country
    I was thinking along the lines of get-aduser -LDAPFilter "(department=SALES France) and adding a where clause for country.
    Any help would be great.
    Dec

    So I have tried a few variations but get errors on both 
    get-aduser -LDAPFilter "(&(department=SALES)(c=us))" | Add-ADPrincipalGroupMembership -MemberOf "testgroup"
    get-aduser -LDAPFilter "(&(department=SALES)(c=fr))" | Add-ADGroupMember -identity "testgroup"
    Add-ADPrincipalGroupMembership : Object reference not set to an instance of an
    object.
    At line:1 char:86
    + get-aduser -LDAPFilter "(&(department=SALES)(c=fr))" | Add-ADPrincipalGroupMe
    mbership <<<< -MemberOf "testgroup"
    + CategoryInfo : NotSpecified: (:) [Add-ADPrincipalGroupMembershi
    p], NullReferenceException
    + FullyQualifiedErrorId : Object reference not set to an instance of an ob
    ject.,Microsoft.ActiveDirectory.Management.Commands.AddADPrincipalGroupMem
    bership

  • Adjusting Internet Explorer settings when used within VFP9

    I have created a form and placed and OLEControl OleClass Shell.Explorer.2 into it.
    I can using statements like 
    Thisform.HTMLViewer.Navigate(m.tcUrl)
    m.loDocument = Thisform.HTMLViewer.Object.Document
    get to show web pages and get access to properties and attributes within the web Document.
    However, I am finding that numerous web pages (not under my control) contain Scripting errors.
    When using standalone IE under the Options settings I have "Display a notification about every script error" turned off.
    However, when using IE within the VFP9 form I get an IE dialog showing me all these Script errors on the sited visited.
    Does anyone know how to turn these off within the VFP9 OleControl environment?
    Any examination of the OleControl object does not show anything that is likely to have the desired effect.
    The English Bob

    Silent is all about script errors, as it seems.
    <!doctype html>
    <html>
    <body>
    <script lang="Javascript">
    w1 = window.open("http://www.microsoft.com", "Popup", "width=800,height=300,resizable=yes");
    w1.focus(); </script>
    </body>
    </html>
    Loading this into a web browser control the Microsoft site pops up, even when setting Silent = .T.
    Even simpler alert('test'); also shows up.
    Bye, Olaf.
    Olaf Doschke - TMN Systemberatung GmbH
    http://www.tmn-systemberatung.de

Maybe you are looking for