Influencing BGP attributes within MPLS network

pls take a look at my question and diagram is attached in the file. pls help me to fix this problem.
I have following requirement about traffic paths within the 
MPLS network.MPLS network is running MP-BGP4.
1.Traffic from Europe branch to Asia branch go through London
  router.
2.Traffic from America branch to Asia branch go through Los Angeles
  router.
3.The two paths through London and Los Angeles should have redundancy.
  That is if path through London is not accessible all the traffic must
  go through Los Angeles. IF Los Angeles path go down all the traffic must
  go through London.
4.Traffic from Asia to Europe and America is controlled by redistributing
  BGP4 learned routes with different metrics at the London and Los Angeles
  routers.So that trafic from Asia branch to Europe go through London and
  traffic from Asia to America go through Los Angeles.
I have been using below configs on the PE routers. But it is not working.
In the MPLS network only one path is selected for both traffic from Europe
and America.Pls can anyone help me to fix this problem.
#PE3
ip vrf CUSTOMER
rd 1:10
route-target export 1:20
route-target import 1:40
export map EXPORT-ROUTE
import map IMPORT-ROUTE
interface FastEthernet0/0
description LONDON-GW
ip vrf forwarding CUSTOMER
ip address 1.1.1.2 255.255.255.252
router bgp 65400
address-family ipv4 vrf CUSTOMER
redistribute connected
neighbor 1.1.1.1 remote-as 65401
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 next-hop-self
neighbor 1.1.1.1 soft-reconfiguration inbound
no auto-summary
no synchronization
exit-address-family
ip extcommunity-list 1 permit rt 1:10
ip extcommunity-list 2 permit rt 1:40
route-map EXPORT-ROUTE permit 10
description LONDON-GW
match extcommunity 1
set extcomm-list 1 delete
set extcommunity rt 1:20 additive
route-map IMPORT-ROUTE permit 10
description EU & US-BRANCH
match extcommunity 2
#PE4
ip vrf CUSTOMER
rd 1:10
route-target export 1:30
route-target import 1:40
export map EXPORT-ROUTE
import map IMPORT-ROUTE
interface FastEthernet0/0
description LA-GW
ip vrf forwarding CUSTOMER
ip address 2.2.2.2 255.255.255.252
router bgp 65400
address-family ipv4 vrf CUSTOMER
redistribute connected
neighbor 2.2.2.1 remote-as 65402
neighbor 2.2.2.1 activate
neighbor 2.2.2.1 next-hop-self
neighbor 2.2.2.1 soft-reconfiguration inbound
no auto-summary
no synchronization
exit-address-family
ip extcommunity-list 1 permit rt 1:10
ip extcommunity-list 2 permit rt 1:40
route-map EXPORT-ROUTE permit 10
description LA-GW
match extcommunity 1
set extcomm-list 1 delete
set extcommunity rt 1:30 additive
route-map IMPORT-ROUTE permit 10
description EU & US-BRANCH
match extcommunity 2
#PE1
ip vrf CUSTOMER
rd 1:10
route-target export 1:40
route-target import 1:20
route-target import 1:30
export map EXPORT-ROUTE
import map IMPORT-ROUTE
interface FastEthernet0/0
description EU-BRANCH
ip vrf forwarding CUSTOMER
ip address 3.3.3.2 255.255.255.252
router bgp 65400
address-family ipv4 vrf CUSTOMER
redistribute connected
redistribute static
no auto-summary
no synchronization
exit-address-family
ip route vrf CUSTOMER 172.16.1.0 255.255.255.0 FastEthernet0/0 3.3.3.1 name EU-BRANCH
ip extcommunity-list 1 permit rt 1:10
ip extcommunity-list 2 permit rt 1:20
ip extcommunity-list 3 permit rt 1:30
route-map EXPORT-ROUTE permit 10
description EU-BRANCH
match extcommunity 1
set extcomm-list 1 delete
set extcommunity rt 1:40 additive
route-map IMPORT-ROUTE permit 10
description LONDON-GW(MAIN)
match extcommunity 2
set metric 100
route-map IMPORT-ROUTE permit 20
description LA-GW(BACKUP)
match extcommunity 3
set metric 200
route-map IMPORT-ROUTE permit 30
description OTHER
#PE2
ip vrf CUSTOMER
rd 1:10
route-target export 1:40
route-target import 1:20
route-target import 1:30
export map EXPORT-ROUTE
import map IMPORT-ROUTE
interface FastEthernet0/0
description US-BRANCH
ip vrf forwarding CUSTOMER
ip address 4.4.4.2 255.255.255.252
router bgp 65400
address-family ipv4 vrf CUSTOMER
redistribute connected
redistribute static
no auto-summary
no synchronization
exit-address-family
ip route vrf CUSTOMER 192.168.1.0 255.255.255.0 FastEthernet0/0 4.4.4.1 name US-BRANCH
ip extcommunity-list 1 permit rt 1:10
ip extcommunity-list 2 permit rt 1:20
ip extcommunity-list 3 permit rt 1:30
route-map EXPORT-ROUTE permit 10
description US-BRANCH
match extcommunity 1
set extcomm-list 1 delete
set extcommunity rt 1:40 additive
route-map IMPORT-ROUTE permit 10
description LONDON-GW(BACKUP)
match extcommunity 2
set metric 200
route-map IMPORT-ROUTE permit 20
description LA-GW(MAIN)
match extcommunity 3
set metric 100
route-map IMPORT-ROUTE permit 30
description OTHER

Hi Manoj
"send-community both" will export both Standard and Extended Communities
The Standard Community Values which we are setting up New on PE3 and PE4 and Matching on PE1 and PE2 can be anything in ASN:nn Format..I Just randomly chose them as 65400:1111 on PE3/PE1 and 65400:2222 on PE4/PE2.
The extcommunity values to be used on PE3/PE4 will be the export RT values used in the VRF Customer Config as posted in your first post..
#PE3
ip vrf CUSTOMER
rd 1:10
route-target export 1:20
route-target import 1:40
export map EXPORT-ROUTE
import map IMPORT-ROUTE
#PE4
ip vrf CUSTOMER
rd 1:10
route-target export 1:30
route-target import 1:40
export map EXPORT-ROUTE
import map IMPORT-ROUTE
I think I mixed up little with PE3 as PE1 and PE4 as PE2 instead ..Revised corrected config would be
On PE3-- Under VPNv4 We enable sending out the normal community values out to the RR.Then we match the extcommunity rt for the VRF Customer and set the community value to 65400:1111 which will be matched at PE1
router bgp 65400
address-family vpnv4
neighbor "RR-IP" send-community both
neighbor "RR-IP" route-map community out
exit-address-family
route-map community permit 10
match extcommunity CUSTOMER
set community 65400:1111
route-map community permit 20
ip extcommunity-list standard CUSTOMER permit rt 1:20
On PE4-- Under VPNv4 We enable sending out the normal community values out to the RR.Then we match the extcommunity rt for the VRF Customer and set the community value to 65400:2222 which will be matched at PE2
router bgp 65400
address-family vpnv4
neighbor "RR-IP" send-community both
neighbor "RR-IP" route-map community out
exit-address-family
route-map community permit 10
match extcommunity CUSTOMER
set community 65400:2222
route-map community permit 20
ip extcommunity-list standard CUSTOMER permit rt 1:30
On PE1-- Under VPNv4 We match the community value 65400:1111 which was set at PE3 and set the LP to 110
router bgp 65400
address-family vpnv4
neighbor "RR-IP" route-map community in
exit-address-family
route-map community permit 10
match community CUSTOMER
set local-preference 110
route-map community permit 20
ip community-list standard CUSTOMER permit 65400:1111
On PE2-- Under VPNv4 We match the community value 65400:2222 which was set at PE4 and set the LP to 110
router bgp 65400
address-family vpnv4
neighbor "RR-IP" route-map community in
exit-address-family
route-map community permit 10
match community CUSTOMER
set local-preference 110
route-map community permit 20
ip community-list standard CUSTOMER permit 65400:2222
Make Sure that RR is enabled to propogate the normal BGP communities as well...
Hope this helps to answer your question..Please let me know for any clarifications..
Regards
Varma

Similar Messages

  • BGP Issue In MPLS Network

    we are having a gateway router which is running a public as and having a direct peering with service provider. We are also working as MPLS-SP and providing internet services to our esteemed clients. Now I am facing a one issue if the customer is coming at remote pop which is having a BGP with private as number and customer itself is having a global as number with his own ip pool. For that I created a peering with my gateway router by putting a route for loopback and created e-bgp peering. Now when the customer pool was advertised by my gateway it doesnot get the reverse path?
    Kindly give your suggestions or designs how the ebgp can be used with gateway router in case SP is runnig MPLS.
    regards
    shivlu jain

    Shivlu,
    Its not clear why u have Private-AS at one of ur POPs , while u could have the Same Public-AS configured and run IBGP session between Your PoPs. If you have Myltiple POPs than u can go for (Route-Reflector) design.
    The Second point, If you mean what type of Internet access, Then you can have one of the following:
    1- Classic Internet Access.
    2- a dedicated Vrf for Internet Access.
    HTH
    Mohamed

  • L3 mpls network with out P router, all PE to PE plus daisy chainging

    Guys, is it possible to run a core l3 MPLS network over 7600s and 3800s with out any P routers? The reason i aak is because of the particular situation where we will have to daisy chain PE routers due to lack of fiber.
    any thoughts?

    As martin says absolutley limited problems with this it will work a charm UNTIL yo urun into scaling issues. You are daisy chaining all the PEs which would also suggest to me that you are daisy chaining your RRs. In an mpls network the RR's have enough state to handle to keep them busy enough without also having to deal with passing labels about the network. Also you will have any cisco account team breaking down your door putting the fear of god into you for not having at least 2 P routers ;-). So yes you can indeed run it like you say but the lifetime of your network will be very limited indeed. If your not an SP then dont be concerned - unless you are an enterprise with 10000000s routes then id start to worry. Oh they (cisco) also state that PEs also have enough to do in their life without passing labelled packets about the place. sit and think about what your poor PE is having to do daily it could be 100 vrfs routing tables, which in turn means layer 3 lookups to find out where the packet has to go, qos, multicast, bgp, ospf, rip, eigrp, your own internal IGP, TE tunnels, RSVP - this poor router has enough to do without also adding transit traffic. ;-)

  • Why CEF needed in MPLS Network??

    I have read the MPLS Fundamentals book by Luc De Ghein, So I understand from the from book that cef needs to enabled in edge routers to tag or untag labels (for Ip packets). I am eager to know why Mpls (Not a cisco proprietary) depends on a cisco proprietary CEF?? If I use Non-Cisco routers in the mpls edge how come the labels get tagged for ip packets??
    <<<<<<<<<Taken from Book>>>>>>>>>>>>>
    MPLS Fundamentals - Luc De Ghein
    Why Is CEF Needed in MPLS Networks?
    Concerning MPLS, CEF is special for a certain reason; otherwise, this book would not explicitly
    cover it. Labeled packets that enter the router are switched according to the label forwarding
    information base (LFIB) on the router. IP packets that enter the router are switched according to
    the CEF table on the router. Regardless of whether the packet is switched according to the LFIB
    or the CEF table, the outgoing packet can be a labeled packet or an IP packet
    <<<<<<<<>>>>>>>>>>

    Hello Bava,
    the key point is that LDP or RSVP TE are able to generate distribute labels for FECs but they do not create the FECs from stratch.
    FEC = Forwarding Equivalent Class
    a destination IP subnet is a typical FEC.
    cisco MPLS code takes advantage of the work done by CEF and uses as input data the FIB (Forwarding Information Base) mantained by CEF, to build the LFIB that is the table where for each FEC there is an association with a label taken from the local node label space.
    The work done by CEF is not so different from what is needed by MPLS: the biggest difference is that the CEF table is kept local and not exported to any other device. MPLS FEC/label bindings are advertised.
    In MPLS frame mode the labels are distributed in unsolicited downstream mode.
    Unsolicited means that the label/FEC association is buiilt based on the topology FIB instead  of waiting for some device to ask a label for the FEC.
    downstream means the labels are sent in the opposite direction of that used by traffic.
    Other attributes are:
    indipendent : means each LSR is free to create its own FEC/label association before receiving the label from the edge LSR that owns the prefix or from a device that is nerarest to the IP subnet (upstream)
    liberal retention: the device will keep note of labels advertised by neighbors even if they are currently not on the best path. This can be seen in the output of show mpls ldp binding and allows for faster recover in case of failure of the best path.
    The unsolicited and liberal retention in standard frame mode comes from the relatively big label space (roughly one milllion labels)
    This was not possible in MPLS cell mode where the label space was small. So MPLS cell mode used on demand downstream label binding and no retention.
    Also MPLS allows for label stacking = use of multiple levels of MPLS Label for services like L3 VPNs
    to be noted other implementations are different in some aspects and each vendor has its internal tecnique to build a table of FECs to be used as starting point for MPLS code.
    For example indipendent label/FEC mapping has its own drawbacks it may be better to wait for a label to be received from a device upstream = nearest to the IP prefix in order to ensure the path is end to end.
    Hope to help
    Giuseppe

  • BGP attributes V/S BGP Comunity

    Have a small doubt : what is the difference between BGP attributes AND BGP Communities ?

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    It's really up to the two parties, sharing community values, to determine how they wish to use them and what a particular community value means.  Some what commonly, the top half of a community value represents the AS the community is for and the bottom half of the community is a weight to apply to route.  (I.e. communities are often used to manipulate how traffic will be routed.)
    I also want to mention, more than one community might be attached to a route prefix.

  • In our enterprise MPLS network we are using 192.168.20.0/24 subnet, in this subnet we have not assigned the IP 192.168.20.200/30 & 204/30, But still these subnets are reachable . Are these NNI IP ...Please explain.

    In our enterprise MPLS network we are using 192.168.20.0/24 subnet, in this subnet we have not assigned the IP 192.168.20.200/30 & 204/30, But still these subnets are reachable . Are these NNI IP ...Please explain.

    I have checked with ISP, there response is like below:
    Those are the NNI to GBNET IPs for Dominican Republic. They are Network IPs. You should be able to ping them-that means they are working.
    WANRT01#show  ip route | include 192.168.20.20
    B        192.168.20.200/30 [20/0] via 192.168.20.226, 02:18:29
    B        192.168.20.204/30 [20/0] via 192.168.20.226, 02:18:29
    Here its shows from any of our MPLS site we are able to trace the IP and it seems like, 192.168.20.204/30 is one more site but in actual its not.
    INMUMWANRT01#ping 192.168.20.205
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.20.205, timeout is 2 seconds:
    Success rate is 100 percent (5/5), round-trip min/avg/max = 224/232/260 ms
    INMUMWANRT01#trace              
    INMUMWANRT01#traceroute 192.168.20.205
    Type escape sequence to abort.
    Tracing the route to 192.168.20.205
    VRF info: (vrf in name/id, vrf out name/id)
      1 192.168.20.226 24 msec 24 msec 24 msec
      2 192.168.20.206 [AS 8035] 232 msec 232 msec 252 msec
      3 192.168.20.205 [AS 8035] 224 msec 224 msec *

  • Path Selection for Routes Across MPLS Network

    Customer hub site has two CE routers with two links connected to two seperate PE routers in the Carrier's MPLS network. At the customer's remote site one CE router on a single link is connected to PE router in MPLS network.
    How can I configure the CE routers at the hub site to advertised the same network across the MPLS network to the CE router at the remote site? Also, how can I configure the CE router at the remote site to select on of the router as the primary and the other as secondary? Can I use local-preference on the CE router at the remote site to selected on path over the other.
    I'm not sure if this makes any sense. Any help will be appreciated. Thanks

    Even with multiple RDs for VRFs belonging to the same VPN, you still need IBGP multipath, correct? Multiple RDs is just to get around the RR restriction.
    Also, you posted this message a while back:
    "If you have many VPN customers all using the same addresses (most likely rfc1918), the fact that they have different RDs and that the PE prepends the RD to the prefixes exchanged between PEs will make the same prefixes different in the MPLS VPN core
    cust1 advertises 192.168.1.0/24 with RD 1:1 therefore
    VPNv4 prefix is 1:1:192.168.1.0
    cust2 advertises 192.168.1.0/24 with RD 1:2 therefore
    VPNv4 prefix is 1:2:192.168.1.0"
    My test lab does not support the IBGP multipath command, and thus even with different RDs, it still only installs one best path.
    I understand that RD = make unique VPNv4 routes in SP space, and that RT = what to import into the VRF. However, I am having a hard time visualizing the scenario with mutiple RDs for the same VPN for load balancing purposes. I am trying to understand the logic behind it.
    Per your example, if both 1:1 and 1:2 are received by the remote PE, assuming IBGP multipath is enabled, why would the remote PE load balance between the two links? Why would it assume that the hub subnets are reachable via two different PEs, and that it's not two different, isolated VPNs altogether?
    Is it b/c you imported both 1:1 and 1:2 into a VRF at the remote PE?

  • Accessing files within the Network

    Hi
    I have problem with file sharing. Within the network I have a PC with windows Vista. It has file sharing on. But it is not showing any files in my MAC. Can anyone tell me how to change the settings in my MAC to access files from my PC within the network.

    Hi Avi,
    Thanks for your reply.
    Just to give to some background info. The java class is called from a package that is owned by the same schema. The schema owner is part of the dba_role and connect_role.
    The network drive on the windows 2000 serveris mapped by the domain administrator account.
    We have given permissions to the schema owner to access the mapped drive thru java.
    What the java script does is fill a string array with the name of each file in the directory. The script and error messages are below.
    I have a feeling that the schema account does not have windows 2000 permissions to access network resources, but it is just a hunch.
    Regards,
    Ned
    public static String[] getDirList(String dir, String FilterExt)
    System.out.println(dir + ' ' + FilterExt);
    FilenameFilter filter= new FilterExt(FilterExt);
    File DirList = new File(dir);
    String f[] = DirList.list(filter);
    System.out.println(f.length);
    for (int i = 0; i < f.length; i++)
    System.out.println(f.toString());
    return f;
    java.lang.NullPointerException
    at ImpExpUtil.getDirList(IMPEXPUTIL.java:2254)
    at AutoImpExp.getNewImportFile(AUTOIMPEXP.java:87)
    at AutoImpExp.Import(AUTOIMPEXP.java:253)
    at Tester.autoImportExport(TESTER.java:2135)

  • How do I change text attributes within one text box in Motion 3?

    I am trying to change text attributes within one text box in Motion 3, but am only able to change the font/size for the entire box. Is there a way to change the attributes to individual lines of text within a text box without creating an entirely new one or using the "Lower Third" text effect?
    How do I create (two different) multiple colors, fonts, bold, italic, underline in one text box within Final Cut Studio Motion (FCP, FCS)

    Thank you! You saved me hours of tinkering around with multiple text boxes. It seemed like it should be something pretty elementary. It didn't help that I am not familiar with proper terminology, so thank you for defining glyph.
    Cheers,
    Owfownugi

  • Equivalent for an "IP accounting" in MPLS Network

    Do we have an equivalent for an IP accounting in an interface in MPLS network. I would like to know this to identify traffic flowing across a WAN interface which is being tag/label switched

    Thanks gopal. However this command "show tag-switching forwarding table" did not help me find a host in a network choking up the WAN link. I heard from one of the cisco reps saying cisco is releasing an IOS to do this in Feb. I hope that helps.

  • VOIP MPLS network only 40-50% utilized

    We are in the process of upgrading our bandwidth at our branch locations into 3 Mbps MPLS networ and we only run Citrix traffic and IP Voice (Interoffice calls) from our Branch locations into our HQ.
    We expect Bandwith utilization to typically max out at 1.6 MBPS. Do you think we need to configure QoS for the voice traffic since the circuit will only be 40-50 percent utilized? My thinking was why should I configure QoS if the bandwidth is only at 40 - 50 percent. The voice traffic should have enough bandwidth to communicate over the wire.
    Is my thinking correct or should I configure QoS across this MPLS network? If I should confiure QoS what type do you recommend.
    Any responses are greatly appreciated

    Hi,
    I would configure QoS, because there are not only sunny days in life ...
    What if you catch Nimda version 7.2beta, i.e. the newest worm out there trying to blast any valid IP in your network? I would not want to explain to my CEO why we lost telephony as well ...
    So on a more technical level: QoS is needed to do resource management. As such you are right in that QoS is not needed if you have enough resources. Yet, who can guarantee this in an IP network at any point in time? I would put it QoS just as an insurance though it would not be needed during normal operation.
    Saying this I might add that this is the appropriate usage anyhow, as QoS will not solve issues arising from constant lack of bandwidth. Queueing is meant to handle exceptions. There is always the possibility of the unforseen.
    Hope this helps! Please rate all posts.
    Regards, Martin

  • Running Large Backups over an MPLS Network

    We are opening up a second data center at my organization. The location is about 60 miles from our primary data center.
    At our primary data center we use an MPLS network for our WAN. We have ll remote locations on our WAN and we have a DS-3 that connects to our primary data center.
    At our new second data center we will connect it to the MPLS network.
    Do you think we should run our backups between the 2 data centers across the MPLS or do you think we should order a seperate private line or ethernet type service between the 2 data centers? All back ups from our primary data center will continually move across the network to our new secondary data center.
    Do you think MPLS is a good technology to run large back ups across? Is it reliable enough

    "Do you think MPLS is a good technology to run large back ups across?"
    Sure.
    "Is it reliable enough"
    Depends more on your MPLS provider than the technology itself.
    Two issues that may be more important to you vs. how "reliable" MPLS is, might be cost of bandwidth vs. other technologies or sharing the MPLS bandwidth with non-backup applications. The latter would depend much on what QoS that might be available to you to insure your backup traffic doesn't adversely impact non-backup traffic.

  • MPLS network design challenge

    Hi,
    I have a design issue for which I really like your help.
    In a MPLS network there are twoPOP gateway routers (G1,G2) peering with various MPLS VPN Service providers via B2B vrf eBGP peering are in 4 different ASN's. They inturn all peer via VPNv4 eBGP with the Core ASN which comprises of  2 Nos VPNv4 RR's and every site in the ASN haveing 2 P/PE per site. Every P/PE is peering via VPNv4- iBGP with the VPNv4 RR's. The RR's are not in the forwarding path of the traffic.
    Every site has 2 Nos CE routers and each CE router does a vrf based ebgp peering with the P/PE's.
    The P/PE routers import 2Nos RT exported by the 2 Nos POP G/w routers and inturn selects the best path and pass it to the CE routers.
    Now it is seen that the P/PE of all sites is selecting the best path adverstised by G1 instead of  G2 based on the AS PATH length and the shortest path is being adverstised by G1. So till a situation arises that the G1 is down till that time the P/PE's are forwarding the outbound traffic from the CE to G1 even also when the IGP cost is adding up high and when there is a direct link failure from the P/PE site to G1 site.
    It therefore makes sense that if the direct physical link form a P/PE site to the site G1 is located goes down ,the P/PE's then should choose  G2 via another path even when G1 is available.
    Does these sort of requirements ever come in SP environments from customers ? if so what are the solutions ..
    Thanks in advance
    Kas

    Hi kas,
    This type of requirement come to providers and there are few options which provider can implement.
    1- Play with local preference along with import map in vrf if requirement is customer specific. I mean if one customer want that G1 should be primary exit point and other customer want G2 as primary exit than he can use import map (which is similar to route-map )
    ip vrf ABCD
    rd XX
    import map ABCD
    route-target export XX
    route-target import YY
    route-map ABCD permit 20
    set local-preference >100
    2- Or you can play with As-path prepending option if you want to skip selection based on local preference.
    it is in provider interest to provide you solution. as there are options of affecting traffic by using communities.
    Please provide diagram and some config for complete solution.
    Regards
    Mahesh

  • MPLS Network Backup

    We have a MPLS network between Head office & varios branch office located across the globe. Can you suggest me the best possible backup(automatic) for this MPLS? as we are facing lot of breaks/cuts in the MPLS Network.

    This is to give a fair idea.
    Pls modify the conifg to suit your setup.
    router ospf x
    router-id x.x.x.x
    network 192.168.1.0 0.0.0.255 area 1
    network 192.168.2.0 0.0.0.255 area 1
    network 192.168.3.0 0.0.0.255 area 1
    Assumption that you have Area 0 at your MPLS CE for upwards and other VPN router upwards.
    interface fa1/0
    Description Connection ot MPLS CE
    ip add 192.168.1.1 255.255.255.0
    ip ospf cost 10
    interface fa1/1
    Description Connection to Backup VPN CE
    ip add 192.168.2.1 255.255.255.0
    ip ospf cost 100
    interface vlan 10
    Description Connection to Servers Subnet
    ip add 192.168.3.1 255.255.255.0
    HTH-Cheers,
    Swaroop

  • Connectivity problems on ATM MPLS network

    We have implemented a country wide MPLS network based on 8500 platforms. We have encountered some strange connectivity problems between some PE's. Without apparent reason connectivity is lost between some PEs and restored after some time. The global routing table is perfectly stable among all the routers on the path between respective PE's. Also the LVC's & TAGs are stable and practically we were unable to find any change between the working and not working state. As a curious thing, during the outage (minutes) clearing routes into a PE VRF was restoring connectivity on the respective VRF and all other VRFs on the respective PE also!
    Has enyone seeing similar problems before?
    PE routers are 3660 series and we've tried all IOS available on CCO.

    Have you made any provisioning (upgrading connectivity) bet the PEs and Ps....I suffer such a similar problem with our network PEs and I notice that this happen after provisioning links between our PEs (RPMs in MGX 8850) and the ATM LSR (BPX 8600).
    when i issue "clear ip route vrf *" or reload the RPM.....all the VRFs operate normally again.....so I get used to such a problem after any network provisioning process but still i couldn't relate this to problems with VRFs.

Maybe you are looking for

  • SQL Query Works in MS SQL Server 2008 but not when using Database Toolkit

    I have this SQL query: DECLARE @DataTypeTable TABLE ( Name varchar(128), TypeID INT) --Add comma delimeted data type names to temp table INSERT INTO @DataTypeTable (Name) SELECT * FROM WhatWeShouldDoRead.func_Split(@DataTypeTrimmed,',') SELECT Name F

  • Problem with VPD policy function

    Hi All, I'm trying to secure database tables with VPD and getting "ORA-28112: failed to execute policy function" error when I query the table. --My schema is "sales" grant crete any context to sales; -- created context using this statement create OR

  • Why the viewport became laggy? (openGl issue?)

    Dear Community, I think I have a general system issue that prevent me to smoothly use some software (like Photoshop and After Effects, + some other non-Adobe software). The issue is a general lag and slowness in the updating of the viewport even when

  • Additional language for Nokia N73

    Hi, i am an italian actually in Saudi Arabia for work. The company gave to me a new Nokia N73 bought locally. The only languages available are arabic, french, english german and spanish. The major problem is when i have to write sms in italian. I hav

  • Running Flash 8 in Leopard - Please Help!

    I have the Leopard Developer Preview and everything works...except Flash 8. I open it and nothing happens. I even installed the Flash 9 AS3 Public Alpha and it still won't run. Please help!!!!!