Any hints on what may be wrong with this GROUP BY statement?

Hi,
I am testing the code below suggested on this site. When I tried it code and during my CHECK, and it gets to the GROUP BY line, and jumps back to the SELECT statement with the following message (even though DATE2 is in the GROUP BY statement):
E:The field "/BIC/AODSSSS00~DATE2" from the SELECT list is is
missing in the GROUP BY clause. is missing in the GROUP BY clause. Is
missing in the GROUP BY clause. is missing in the GROUP BY clause. is
I have played around, changing DATE2 in the GROUP By line with /BIC/AODSSSS00~DATE2 or /BIC/AODSSSS00-DATE2 or /BIC/DATE2, but still I get likewise.
loop at RESULT_PACKAGE into wa_RESULT_PACKAGE.
SELECT NUM ITEM /BIC/DATE1 DATE2 sum( QTY ) as QTY
INTO corresponding fields of table it_TABLE1
FROM /BIC/AODSSSS00
where /BIC/DATE1 <= wa_RESULT_PACKAGE-DATE2
AND NUM = wa_RESULT_PACKAGE-NUM
AND ITEM = wa_RESULT_PACKAGE-ITEM
GROUP BY NUM ITEM /BIC/DATE1 DATE2.
wa_RESULT_PACKAGE-/BIC/AONTIMQTY = sum.
MODIFY RESULT_PACKAGE from wa_RESULT_PACKAGE.
Endloop.
Thanks

I am not totally clear on what you want to achieve.  But please look this code over and see if it is closer to what you want to do.
I changed your workarea to a field-symbol, which are a little more convenient to use.  <result_fields> is already defined for you in your end routine.
I used tables and fields that exist in our system, but you should be able to translate those back to your system.
Please let me know if you need more help.
LOOP AT result_package ASSIGNING <result_fields>.
  SELECT me_order_n me_itemno serv_date SUM( /bic/znosubasp ) AS /bic/znosubasp
  INTO CORRESPONDING FIELDS OF it_table1
  FROM /bic/azmord2d00
  WHERE serv_date <= wa_result_package-serv_date
  AND me_order_n = wa_result_package-me_order_n
  AND me_itemno = wa_result_package-me_itemno
  GROUP BY me_order_n me_itemno serv_date.
    <result_fields>-me_quanti = it_table1-/bic/znosubasp.
  ENDSELECT.
ENDLOOP.

Similar Messages

  • What is going wrong with this config ??

    Hello guys,
    I am busting my head to find out what is going wrong with this config and cant figure it out since i am not an advanced cisco technician.
    Problem is that i cant access the 94.70.142.127 server that is supposed to be in a DMZ zone.
    I know it is a bit chaotic but would really appreciate any help since i am running on a deadline.
    I am building the config step by step and although it seems to be working access to the server all of the sudden is denied.
    No idea if its a NAT issue a firewall issue or a security audit issue.
    There are 3 vlans.
    Vlan 1 is the inside network.
    Vlan 2 is the DMZ server
    Vlan 3 is the Management Network.
    thanks in advance
    Building configuration...
    Current configuration : 11796 bytes
    ! Last configuration change at 11:28:33 PCTime Fri Jan 4 2013 by admin
    ! NVRAM config last updated at 11:27:51 PCTime Fri Jan 4 2013 by admin
    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime
    service password-encryption
    service sequence-numbers
    hostname R1
    boot-start-marker
    boot-end-marker
    security authentication failure rate 3 log
    security passwords min-length 8
    logging message-counter syslog
    logging buffered 4096 informational
    enable secret 5 $1$oT7y$BwhdEjMJfAaTQI3dzDVwP.
    no aaa new-model
    memory-size iomem 10
    clock timezone PCTime 2
    clock summer-time PCTime date Mar 30 2003 3:00 Oct 26 2003 4:00
    crypto pki trustpoint TP-self-signed-2567543707
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-2567543707
    revocation-check none
    rsakeypair TP-self-signed-2567543707
    crypto pki certificate chain TP-self-signed-2567543707
    certificate self-signed 01
      30820244 308201AD A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 32353637 35343337 3037301E 170D3133 30313032 30383431
      35335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 35363735
      34333730 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100ABA4 B7FFF4F1 9FBE79D8 2CEBCA68 A14BE3AB DBF770C2 EB35A954 B271AE3E
      F8485837 F2E8566B 66E5EF6B BCFCDFA3 8F6F91F3 FD8E3015 879A67F5 85DD95F5
      C26875C0 2202CA6C CE95888F 545AB4F6 6F708A0E C65E78D1 60967480 5589F5EE
      80505E46 8767CE2C 37C994FE AB555AF0 BA4C4679 63FF7641 34FFF6EF 3EC38006
      46B90203 010001A3 6C306A30 0F060355 1D130101 FF040530 030101FF 30170603
      551D1104 10300E82 0C52312E 646F636E 65742E67 72301F06 03551D23 04183016
      8014F0DE 85318FB3 70C36B4A FEB4B0CA 446025F0 329C301D 0603551D 0E041604
      14F0DE85 318FB370 C36B4AFE B4B0CA44 6025F032 9C300D06 092A8648 86F70D01
      01040500 03818100 5D76D5F4 5FB659C3 1E5B3777 420E1703 CD019889 AE79390D
      A2AA4D26 AD9913B4 B3292277 97ACACDD D7093465 78279B4D 5FAC0A21 EFBF3B74
      6A25BC5B ACFB648F 08F92678 00BB495C 037DEAF7 C5910944 3D2C0643 EA19E9BD
      0AFE5423 AADBB3C2 B2C94296 DABE0D3D 6438F7A8 32B0A92B 3E8E0D26 635070A3
      ACF87E49 65A9E468
          quit
    no ip source-route
    ip cef
    no ip bootp server
    ip domain name docnet.gr
    ip name-server 195.170.0.1
    no ipv6 cef
    username admin privilege 15 view root secret 5 $1$Lny5$et1FhWOpIKOOYRUtN89H10
    archive
    log config
      hidekeys
    ip tcp synwait-time 10
    ip ssh version 2
    class-map type inspect match-any WebService
    match protocol http
    match protocol https
    class-map type inspect match-all sdm-cls-sdm-pol-NATOutsideToInside-1-1
    match class-map WebService
    match access-group name WebServer
    class-map type inspect match-all ccp-cls-sdm-pol-NATOutsideToInside-1-1
    match access-group name Spoofing
    class-map type inspect match-any CCP-Voice-permit
    match protocol h323
    match protocol skinny
    match protocol sip
    class-map type inspect match-any tcp-udp
    match protocol http
    match protocol https
    match protocol dns
    match protocol icmp
    class-map type inspect match-all ccp-cls--3
    match access-group name mng-out
    match class-map tcp-udp
    class-map type inspect match-all ccp-cls--2
    match access-group name mng-self
    class-map type inspect match-all ccp-cls--4
    match access-group name mng-out-drop
    class-map type inspect match-any ccp-cls-insp-traffic
    match protocol cuseeme
    match protocol dns
    match protocol ftp
    match protocol h323
    match protocol https
    match protocol icmp
    match protocol imap
    match protocol pop3
    match protocol netshow
    match protocol shell
    match protocol realmedia
    match protocol rtsp
    match protocol smtp extended
    match protocol sql-net
    match protocol streamworks
    match protocol tftp
    match protocol vdolive
    match protocol tcp
    match protocol udp
    class-map type inspect match-all ccp-insp-traffic
    match class-map ccp-cls-insp-traffic
    class-map type inspect match-any http-https-DMZ
    match protocol http
    match protocol https
    class-map type inspect match-all sdm-cls--2
    match class-map http-https-DMZ
    match access-group name web_server
    class-map type inspect match-any MySQLService
    match protocol mysql
    class-map type inspect match-all sdm-cls--1
    match class-map MySQLService
    match access-group name DMZtoMySQL
    class-map type inspect match-any ccp-cls-icmp-access
    match protocol icmp
    match protocol tcp
    match protocol udp
    class-map type inspect match-all ccp-icmp-access
    match class-map ccp-cls-icmp-access
    class-map type inspect match-all ccp-invalid-src
    match access-group 100
    class-map type inspect match-all sdm-nat-https-1
    match access-group 102
    match protocol https
    class-map type inspect match-all ccp-protocol-http
    match protocol http
    policy-map type inspect ccp-permit-icmpreply
    class type inspect ccp-icmp-access
      inspect
    class class-default
      pass
    policy-map type inspect sdm-pol-NATOutsideToInside-1
    class type inspect ccp-cls-sdm-pol-NATOutsideToInside-1-1
      drop
    class type inspect sdm-cls-sdm-pol-NATOutsideToInside-1-1
      inspect
    class type inspect sdm-nat-https-1
      inspect
    class class-default
      drop
    policy-map type inspect ccp-inspect
    class type inspect ccp-invalid-src
      drop log
    class type inspect ccp-protocol-http
      inspect
    class type inspect ccp-insp-traffic
      inspect
    class type inspect CCP-Voice-permit
      inspect
    class class-default
      drop
    policy-map type inspect ccp-permit
    class class-default
      drop
    policy-map type inspect sdm-policy-sdm-cls--1
    class type inspect sdm-cls--1
      inspect
    class class-default
      drop
    policy-map type inspect ccp-policy-ccp-cls--1
    class class-default
      drop
    policy-map type inspect ccp-policy-ccp-cls--3
    class type inspect ccp-cls--3
      inspect
    class class-default
      drop
    policy-map type inspect sdm-policy-sdm-cls--2
    class type inspect sdm-cls--2
      inspect
    class class-default
      drop
    policy-map type inspect ccp-policy-ccp-cls--2
    class type inspect ccp-cls--2
      inspect
    class class-default
      drop
    policy-map type inspect ccp-policy-ccp-cls--5
    class class-default
      drop
    zone security out-zone
    zone security in-zone
    zone security dmz-zone
    zone security mng
    zone-pair security ccp-zp-self-out source self destination out-zone
    service-policy type inspect ccp-permit-icmpreply
    zone-pair security sdm-zp-NATOutsideToInside-1 source out-zone destination in-zone
    service-policy type inspect sdm-pol-NATOutsideToInside-1
    zone-pair security ccp-zp-in-out source in-zone destination out-zone
    service-policy type inspect ccp-inspect
    zone-pair security ccp-zp-out-self source out-zone destination self
    service-policy type inspect ccp-permit
    zone-pair security zp-dmz-to-outside source dmz-zone destination out-zone
    service-policy type inspect ccp-inspect
    zone-pair security zp-outside-to-dmz source out-zone destination dmz-zone
    service-policy type inspect sdm-pol-NATOutsideToInside-1
    zone-pair security sdm-zp-dmz-zone-in-zone source dmz-zone destination in-zone
    service-policy type inspect sdm-policy-sdm-cls--1
    zone-pair security sdm-zp-in-zone-dmz-zone source in-zone destination dmz-zone
    service-policy type inspect sdm-policy-sdm-cls--2
    zone-pair security sdm-zp-dmz-zone-self source dmz-zone destination self
    service-policy type inspect ccp-policy-ccp-cls--1
    zone-pair security sdm-zp-mng-self source mng destination self
    service-policy type inspect ccp-policy-ccp-cls--2
    zone-pair security sdm-zp-mng-out-zone source mng destination out-zone
    service-policy type inspect ccp-policy-ccp-cls--3
    zone-pair security sdm-zp-out-zone-mng source out-zone destination mng
    service-policy type inspect ccp-policy-ccp-cls--5
    interface Null0
    no ip unreachables
    interface BRI0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    encapsulation hdlc
    shutdown
    isdn termination multidrop
    interface ATM0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    no atm ilmi-keepalive
    interface ATM0.1 point-to-point
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    pvc 8/35
      pppoe-client dial-pool-number 1
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    switchport access vlan 3
    spanning-tree portfast
    interface FastEthernet3
    switchport access vlan 2
    interface Vlan1
    description $FW_INSIDE$
    ip address 192.168.0.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly
    zone-member security in-zone
    ip tcp adjust-mss 1412
    interface Vlan2
    description $FW_INSIDE$
    ip address 192.168.1.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly
    zone-member security dmz-zone
    interface Vlan3
    description $FW_INSIDE$
    ip address 10.0.10.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly
    zone-member security mng
    interface Dialer0
    description $FW_OUTSIDE$
    ip address negotiated
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1452
    ip flow ingress
    ip nat outside
    ip virtual-reassembly max-reassemblies 64
    zone-member security out-zone
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname [email protected]
    ppp chap password 7 0918425001505245
    ppp pap sent-username [email protected] password 7 13511B4B1359417D
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip route 10.0.10.0 255.255.255.0 Vlan3
    no ip http server
    ip http secure-server
    ip nat inside source list 1 interface Dialer0 overload
    ip nat inside source static 192.168.0.101 94.70.142.113
    ip nat inside source static 192.168.1.102 94.70.142.127
    ip access-list extended DMZtoMySQL
    remark CCP_ACL Category=128
    permit ip host 192.168.1.102 host 192.168.0.101
    ip access-list extended Spoofing
    remark CCP_ACL Category=128
    permit ip 10.0.0.0 0.255.255.255 any
    permit ip 192.168.0.0 0.0.255.255 any
    permit ip 172.16.0.0 0.15.255.255 any
    ip access-list extended VTY_incoming
    remark CCP_ACL Category=1
    permit ip host 10.0.10.2 any
    ip access-list extended WebServer
    remark CCP_ACL Category=128
    permit ip any host 192.168.1.102
    ip access-list extended mng-out
    remark CCP_ACL Category=128
    permit ip 10.0.10.0 0.0.0.255 any
    ip access-list extended mng-out-drop
    remark CCP_ACL Category=128
    permit ip any any
    ip access-list extended mng-self
    remark CCP_ACL Category=128
    permit ip any any
    ip access-list extended web_server
    remark CCP_ACL Category=128
    permit ip 192.168.0.0 0.0.0.255 host 192.168.1.102
    logging 10.0.10.2
    access-list 1 remark INSIDE_IF=Vlan1
    access-list 1 remark CCP_ACL Category=2
    access-list 1 remark VLan 1 Access
    access-list 1 permit 192.168.0.0 0.0.0.255
    access-list 1 remark VLan 3 Access
    access-list 1 permit 10.0.10.0 0.0.0.255
    access-list 1 remark Vlan 2 Access
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 100 remark CCP_ACL Category=128
    access-list 100 permit ip host 255.255.255.255 any
    access-list 100 permit ip 127.0.0.0 0.255.255.255 any
    access-list 102 remark CCP_ACL Category=0
    access-list 102 permit ip any host 192.168.0.101
    dialer-list 1 protocol ip permit
    no cdp run
    control-plane
    banner login ^CWARNING!!!This is a highly monitored private system. Access is prohibited!!^C
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    access-class VTY_incoming in
    password 7 12292504011C5C162E
    login local
    transport input ssh
    scheduler max-task-time 5000
    ntp authentication-key 1 md5 10603D29214711255F106B2677 7
    ntp authenticate
    ntp trusted-key 1
    ntp master 2
    end

    Hello karolos,
    Here is the thing.
    You said you are trying to access 94.70.142.113 and that is a server on the DMZ but based in your configuration that is not true
    ip nat inside source static 192.168.0.101 94.70.142.113
    So 192.168.0.101 is on Vlan 1 witch is the in-zone
    interface Vlan1
    description $FW_INSIDE$
    ip address 192.168.0.1 255.255.255.0
    security in-zone
    If you got confused with  the security zone that the host is assigned to then just add the following and it should work
    ip access-list extended WebServer
    permit ip any host 192.168.0.101
    Regards

  • What's wrong with this IF / ELSE statement? ASP/VBScript

    Hi,
    I'm trying to display a section, within an ASP page, where
    the customer
    logged in is the same as the customer who placed the order,
    identified by
    their "customerID".
    <%IF (rsUser.Fields.Item("customerID").Value) =
    "(rsOrderDetails.Fields.Item("& customerID
    &").Value)" Then%>
    Text etc...
    <%Else%>
    Other text etc...
    <%End IF%>
    The customerID in both database tables is a "bigint" type,
    but when I try
    the above, I get: "Type Mismatch"?
    I've tried this:
    <%IF (rsUser.Fields.Item("customerID").Value) =
    (rsOrderDetails.Fields.Item("& customerID &").Value)
    Then%>
    Text etc...
    <%Else%>
    Other text etc...
    <%End IF%>
    But this also produces a Type Mismatch error.
    Anything glaringly obviously wrong with this? Much
    appreciated.
    Nath.

    Thanks Dooza, that's sorted it.
    Why does ASP not recognise that they are the same format?
    Appreciate the help.
    Regards
    Nath.
    "Dooza" <[email protected]> wrote in message
    news:[email protected]...
    > Ok, it looks like you will need to convert them to the
    same format, even
    > if ASP doesn't think they are the same.
    >
    > <%IF cstr(rsUser.Fields.Item("customerID").Value) =
    > cstr(rsOrderDetails.Fields.Item("customerID").Value)
    Then%>
    > Text etc...
    > <%Else%>
    > Other text etc...
    > <%End IF%>
    >
    > That converts both to a string, which should evaluate
    against each other.
    >
    > See if that helps.
    >
    > Steve
    >
    > tradmusic.com wrote:
    >> Sorry Steve,
    >>
    >> I forgot to remove those from the last example. It
    should have read:
    >>
    >> <%IF (rsUser.Fields.Item("customerID").Value) =
    >> (rsOrderDetails.Fields.Item("customerID").Value)
    Then%>
    >> Text etc...
    >> <%Else%>
    >> Other text etc...
    >> <%End IF%>
    >>
    >> ....which still doesn't work. :o)
    >>
    >> Type Mismatch, yet both fields are bigint.
    >>
    >> Any idea's where the problem is? Much appreciated.
    >> Nath.
    >>
    >>
    >> "Dooza" <[email protected]> wrote in
    message
    >> news:[email protected]...
    >>> tradmusic.com wrote:
    >>>> Hi,
    >>>>
    >>>> I'm trying to display a section, within an
    ASP page, where the customer
    >>>> logged in is the same as the customer who
    placed the order, identified
    >>>> by their "customerID".
    >>>>
    >>>> <%IF
    (rsUser.Fields.Item("customerID").Value) =
    >>>> "(rsOrderDetails.Fields.Item("&
    customerID &").Value)" Then%>
    >>>> Text etc...
    >>>> <%Else%>
    >>>> Other text etc...
    >>>> <%End IF%>
    >>>>
    >>>> The customerID in both database tables is a
    "bigint" type, but when I
    >>>> try the above, I get: "Type Mismatch"?
    >>>>
    >>>> I've tried this:
    >>>>
    >>>> <%IF
    (rsUser.Fields.Item("customerID").Value) =
    >>>> (rsOrderDetails.Fields.Item("&
    customerID &").Value) Then%>
    >>>> Text etc...
    >>>> <%Else%>
    >>>> Other text etc...
    >>>> <%End IF%>
    >>>>
    >>>> But this also produces a Type Mismatch
    error.
    >>>>
    >>>> Anything glaringly obviously wrong with
    this? Much appreciated.
    >>> Whats with this?
    (rsOrderDetails.Fields.Item("& customerID &").Value)
    >>> Why are there ampersands in there?
    >>>
    >>> It should be just this:
    (rsOrderDetails.Fields.Item("customerID").Value)
    >>>
    >>> Steve
    >>

  • What could be wrong with this SuperCluster server?

    Kindly assist, what could be wrong with the super cluster server logs below, it comes up and down. Although as we speak, it is currently up and running now:
    root@ssc0101-mgmt-app1 # zpool status -x
      pool: emagine1
    state: UNAVAIL
    status: One or more devices could not be opened.  There are insufficient
    replicas for the pool to continue functioning.
    action: Attach the missing device and online it using 'zpool online'.
       see: http://www.sun.com/msg/ZFS-8000-3C
    scan: none requested
    config:
    NAME STATE     READ WRITE CKSUM
    emagine1 UNAVAIL      0     0 0  insufficient replicas
    /zonedev/emagine1/zonepool  UNAVAIL 0     0     0  cannot open
    root@ssc0101-mgmt-app1 # iostat -En
    c1t5000C5004382C93Fd0 Soft Errors: 0 Hard Errors: 0 Transport Errors: 0
    Vendor: SEAGATE  Product: ST960005SSUN600G Revision: 0606 Serial No: 1141P17W1H
    Size: 600.13GB <600127266816 bytes>
    Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 0
    Illegal Request: 0 Predictive Failure Analysis: 0
    c1t5000C500436A6673d0 Soft Errors: 0 Hard Errors: 0 Transport Errors: 0
    Vendor: SEAGATE  Product: ST960005SSUN600G Revision: 0606 Serial No: 1141P1DVT9
    Size: 600.13GB <600127266816 bytes>
    Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 0
    Illegal Request: 0 Predictive Failure Analysis: 0
    c1t50015179596974EDd0 Soft Errors: 0 Hard Errors: 0 Transport Errors: 0
    Vendor: ATA      Product: INTEL SSDSA2BZ30 Revision: 0362 Serial No:
    Size: 300.07GB <300069052416 bytes>
    Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 0
    Illegal Request: 1 Predictive Failure Analysis: 0
    c1t500151795966AFCBd0 Soft Errors: 0 Hard Errors: 0 Transport Errors: 0
    Vendor: ATA      Product: INTEL SSDSA2BZ30 Revision: 0362 Serial No:
    Size: 300.07GB <300069052416 bytes>
    Media Error: 0 Device Not Ready: 0 No Device: 0 Recoverable: 0
    Illegal Request: 1 Predictive Failure Analysis: 0
    root@ssc0101-mgmt-app1 # zpool clear emagine1
    root@ssc0101-mgmt-app1 #
    SUNW-MSG-ID: FMD-8000-4M, TYPE: Repair, VER: 1, SEVERITY: Minor
    EVENT-TIME: Tue Nov 13 18:22:27 WAT 2012
    PLATFORM: ORCL,SPARC-T4-4, CSN: -, HOSTNAME: ssc0101-mgmt-app1
    SOURCE: zfs-diagnosis, REV: 1.0
    EVENT-ID: 6e103a73-e131-4abd-eeab-cacd1b658dce
    DESC: All faults associated with an event id have been addressed.
      Refer to http://sun.com/msg/FMD-8000-4M for more information.
    AUTO-RESPONSE: Some system components offlined because of the original fault may have been brought back online.
    IMPACT: Performance degradation of the system due to the original fault may have been recovered.
    REC-ACTION: Use fmdump -v -u <EVENT-ID> to identify the repaired components.
    SUNW-MSG-ID: FMD-8000-6U, TYPE: Resolved, VER: 1, SEVERITY: Minor
    EVENT-TIME: Tue Nov 13 18:22:27 WAT 2012
    PLATFORM: ORCL,SPARC-T4-4, CSN: -, HOSTNAME: ssc0101-mgmt-app1
    SOURCE: zfs-diagnosis, REV: 1.0
    EVENT-ID: 6e103a73-e131-4abd-eeab-cacd1b658dce
    DESC: All faults associated with an event id have been addressed.
      Refer to http://sun.com/msg/FMD-8000-6U for more information.
    AUTO-RESPONSE: All system components offlined because of the original fault have been brought back online.
    IMPACT: Performance degradation of the system due to the original fault has been recovered.
    REC-ACTION: Use fmdump -v -u <EVENT-ID> to identify the repaired components.
    Thanks in advance for your support.

    Let's check the details of the fault. We can run the fmdump command to get the details. Run the following command and post the output.
    fmdump -v -u 6e103a73-e131-4abd-eeab-cacd1b658dce
    thanks
    Erik

  • Mac book pro is very very slow/it hangs for even the smallest tasks/even with the lid closed it is still running if it is not completely turned off. Dose any one know what may be wrong ? and how to fix it?

    More details about the problem : My computer is a Mid 2012 Mac Book pro 2.9GHz i7 processor with 8GB RAM updated to OS X v10.8.5
    - I ran a compleet scan of my computer for any threats ( I used virus barrier express ) and there was nothing identified
    - When I oppened the Activiti Monitor there are about 20-30 processes which I do not undersatand they are run under the user "root" 2 in perticular ( Kernel_task & fseventsd ) they both take up a lot of threads and kernel_task is constantly using 1.2 GB of "real memory" which is at least 20 times any other process that is running espesially the ones that run under the user "Apple" I do not know if this is causing the problems on my mac but i tryed to forces close it and it dose not even let me click the button, the others close but reopean immideatly. I will attach a screen shot of what i have mentioned here.
    - The problems I am facing are mainly performance :- To state a few examples, my mac dose not seam to be able to handile even the smallest tasks like switching tabs on safari, typing any thing, playing a movie withought stopping inbetween, etc.. ( let me elaborate on why I said its not able to handil these tasks, it is because when I am trying to do any one of the afformentioned tasks inbetween the cursor becomes a rainbow collered spinning disk and I am unable to do anything for about 10 seckonds after which it starts to work again for some time before it happens again. )
    - Another concern of mine is that my mac seems to be on even with the lid closed if I do not shut it down compleetly, if i just close the lid after some time the computer starts warming up, and the fan starts running. the battery is drained at the same rate or slightly less rate than it would have if i was using it normally with the lid opean. ( altough this is happning the screen dose not turn on untill the lid is opean again )
    - I have only 300+ GB full out of my 750GB so i believe these are not issues caused by my mac's memory being full ( BUT THE FIRST TIME I NOTICED THIS WAS HAPPNING WAS WHEN MY MEMORY WAS ABOUT 720GB FULL WHEN THESE ISSUES FIRST AROSE I IMMEADITLY DELEATED 400+GB OF MY USELESS FILES THAT I HAD BEEN HORDING ALL OF WHICH WERE MOVIES ) that about covers it all PLEASE LET ME KNOW IF ANY ONE KNOWS WHAT TO DO.
    Ps: I apoligize if I have given too many unrelevant details, not enough usefull information and or if i was just all over the place with my explanations but I am really frustrated and was hoping not to miss anyting. Please let me know if any information at all is required and ill do my best to provide it.
    Thank You

    Start with this comprehensive troubleshooting article:
    https://discussions.apple.com/docs/DOC-3521
    Look at this one for possible solutions:
    https://discussions.apple.com/docs/DOC-3353
    Ciao.

  • Does anyone have an idea what may be wrong with my iphone 4S?

    My iphone 4S has started turning itself off completely.  When I power it back up, it allows me to log in my code and when I push the enter button it turns itself completely off again.  I am trying to decide if it can be fixed or should I just buy a new iphone?  This AM it is working just fine??????
    If anyone knows or has a guess as to what is wrong with it, I would appreciate your input.

    Restore your phone, as described here:
    http://support.apple.com/kb/ht1414
    DO NOT restore from backup, rather sync your content back to your phone. If doing this doesn't fix things, you most likely have a hardware issue.

  • What the **** is wrong with this stupid machine???????

    **** my ipod just broke down for the 2nd time and it's really starting to be annoying..
    it won't reset, won't charge the battery, it just shows a sad face.
    i was looking for an email adress to contact somebody but it's all by phone and i refuse to pay more f**king money to these crappers. and i don't want to pay about 40 euro's of insurance costs which they charge me if i return my ipod to the shop. this is a serious problem for me..
    i want to know if there are any other people with this problem or one that looks like mine.
    i'm never using this crap from apple again.!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    make a good product for christ sake!!!!!!!!!!!!!!!!!!!!!!!1
    hp desktop   Windows XP  

    Just in case you would like to have a final try
    Hello,
    If a sad iPod icon or an exclamation point and folder icon appears on your iPod’s screen, or with sounds of clicking or HD whirring, it is usually the sign of a hard drive problem and you have the power to do something about it now. Your silver bullet of resolving your iPod issue – is to restore your iPod to factory settings.
    http://docs.info.apple.com/article.html?artnum=60983
    If you're having trouble, try these steps at different levels one at a time until the issue is resolved. These steps will often whip your iPod back into shape.
    Make sure you do all the following “TRYs”
    A. Try to wait 30 minutes while iPod is charging.
    B. Try another FireWire or USB through Dock Connector cable.
    C. Try another FireWire or USB port on your computer .
    D. Try to disconnect all devices from your computer's FireWire and USB ports.
    E. Try to download and install the latest version of iPod software and iTunes
    http://www.apple.com/itunes/download/
    For old and other versions of iPod updater for window you can get here
    http://www.ipodwizard.net/showthread.php?t=7369
    F. Try these five steps (known as the five Rs) and it would conquer most iPod issues.
    http://www.apple.com/support/ipod/five_rs/
    G. Try to put the iPod into Disk Mode if it fails to appear on the desktop
    http://docs.info.apple.com/article.html?artnum=93651
    If none of these steps address the issue, you may need to go to Intermediate level listed below in logical order. Check from the top of the lists to see if that is what keeping iPod from appearing on your computer in order for doing the Restore.
    Intermediate Level
    A. Try to connect your iPod with another computer with the iPod updater pre-installed.
    B. Still can’t see your iPod, put it in Disk Mode and connect with a computer, instead of doing a Restore on iPod Updater. Go and format the iPod instead.
    For Mac computer
    1. Open the disk utility, hope your iPod appears there (left hand side), highlight it
    2. Go to Tab “Partition”, click either “Delete” or “Partition”, if fails, skip this step and go to 3
    3. Go to Tab “Erase” , choose Volume Format as “MAC OS Extended (Journaled), and click Erase, again if fails, skip it and go to 4
    4. Same as step 3, but open the “Security Options....” and choose “Zero Out Data” before click Erase. It will take 1 to 2 hours to complete.
    5. Eject your iPod and do a Reset
    6. Open the iTunes 7 and click “Restore”
    For Window computer
    Go to folder “My Computer”
    Hope you can see your iPod there and right click on the iPod
    Choose “Format”. Ensure the settings are at “Default” and that “Quick Format” is not checked
    Now select “Format”
    Eject your iPod and do a Reset
    Open the iTunes 7 and click “Restore”
    In case you do not manage to do a “Format” on a window computer, try to use some 3rd party disk utility software, e.g.“HP USB Disk Storage Format Tool”.
    http://discussions.apple.com/thread.jspa?threadID=501330&tstart=0
    C. Windows users having trouble with their iPods should locate a Mac user. In many cases when an iPod won't show up on a PC that it will show up on the Mac. Then it can be restored. When the PC user returns to his computer the iPod will be recognized by the PC, reformatted for the PC, and usable again. By the way, it works in reverse too. A Mac user often can get his iPod back by connecting it to a PC and restoring it.
    Tips
    a. It does not matter whether the format is completed or not, the key is to erase (or partly) the corrupted firmware files on the Hard Drive of the iPod. After that, when the iPod re-connected with a computer, it will be recognized as an fresh external hard drive, it will show up on the iTunes 7.
    b. It is not a difficult issue for a Mac user to find a window base computer, for a PC user, if they can’t find any Mac user, they can go to a nearest Apple Shop for a favor.
    c. You may need to switch around the PC and Mac, try to do several attempts between “Format” and “Restore”
    http://discussions.apple.com/thread.jspa?messageID=2364921&#2364921
    Advance Level
    A. Diagnostic mode solution
    If you have tried trouble shooting your iPod to no avail after all the steps above, chances are your iPod has a hardware problem. The iPod's built-in Diagnostic Mode is a quick and easy way to determine if you have a "bad" iPod.
    You need to restart your iPod before putting it into Diagnostic Mode. Check that your hold switch is off by sliding the switch away from the headphone jack. Toggle it on and off to be safe.
    Press and hold the following combination of buttons simultaneously for approximately 10 seconds to reset the iPod.
    iPod 1G to 3G: "Menu" and "Play/Pause"
    iPod 4G+ (includes Photo, Nano, Video, and Mini): "Menu" and "Select"
    The Apple logo will appear and you should feel the hard drive spinning up. Press and hold the following sequence of buttons:
    iPod 1G to 3G: "REW", "FFW" and "Select"
    iPod 4G+ (includes Photo, Nano, Video, and Mini): "Back" and "Select"
    You will hear an audible chirp sound (3G models and higher) and the Apple logo should appear backwards. You are now in Diagnostic Mode. Navigate the list of tests using "REW" and "FFW". The scroll wheel will not function while in diagnostic mode. For further details on Diagnostic mode can be found at http://www.methodshop.com/mp3/ipodsupport/diagnosticmode/
    Try to do the 5in1, HDD R/W and HDD scan tests. Some successful cases have been reported after the running the few tests under the Diagnostic mode. In case it does not work in your case, and the scan tests reports show some errors then it proves your iPod has a hardware problem and it needs a repairing service.
    B. Format your iPod with a start disk
    I have not tried this solution myself, I heard that there were few successful cases that the users managed to get their iPod (you must put your iPod in disk mode before connecting with a computer) mounted by the computer, which was booted by a system startup disk. For Mac, you can use the Disk Utility (on the Tiger OS system disk), for PC user, you can use the window OS system disk. Try to find a way to reformat your iPod, again it does not matter which format (FAT32, NTFS or HFS+) you choose, the key is to erase the corrupted system files on the iPod. Then eject your iPod and do a Reset to switch out from Disk Mode. Reboot your computer at the normal way, connect your iPod back with it, open the iPod updater, and hopefully your iPod will appear there for the Restore.
    If none of these steps address the issue, your iPod may need to be repaired.
    Consider setting up a mail-in repair for your iPod http://depot.info.apple.com/ipod/
    Or visit your local Apple Retail Store http://www.apple.com/retail/
    In case your iPod is no longer covered by the warranty and you want to find a second repairing company, you can try iPodResQ at your own risk
    http://www.ipodresq.com/index.php
    Just in case that you are at the following situation
    Your iPod warranty is expired
    You don’t want to pay any service charges
    You are prepared to buy a new one
    You can’t accept the re-sell value of your broken iPod
    Rather than leave your iPod as paper-weight or throw it away.
    You can try the following, but again, only do it as your last resort and at your own risk.
    Warning !!!! – It may or may not manage to solve your problem, and with a risk that you may further damage your iPod, which end up as an expensive paper weight or you need to pay more higher repairing cost. Therefore, please re-consider again whether you want to try the next level
    Last Resort Level
    1. . Disconnecting the Hard Drive and battery inside the iPod – Warning !! Your iPod warranty will be waived once you open the iPod.
    In Hong Kong there are some electronic shops offering an iPod service for Sad iPod, the first thing they do is to open up the iPod’s case and disconnecting the battery and the Hard Drive from the main board of the iPod. Wait for 5-10 minutes and reconnecting them back. The reason behind which I can think of is to do a fully reset of a processor of the iPod. In case you want do it itself and you believe that you are good on fixing the electronics devices and have experience to deal with small bits of electronic parts, then you can read the following of how to open the iPod case for battery and HDD replacement (with Quicktimes)
    http://eshop.macsales.com/tech_center/index.cfm?page=Video/directory.html
    2.Press the reset button on the Hard Drive inside the iPod – Suggestion from Kill8joy
    http://discussions.apple.com/thread.jspa?messageID=2438774#2438774
    Have I tried these myself? No, I am afraid to do it myself as I am squeamish about tinkering inside electronic devices, I have few experiences that either I broke the parts (which are normally tiny or fragile) or failed to put the parts back to the main case. Therefore, I agree with suggestion to have it fixed by a Pro.
    2. Do a search on Google and some topics on this discussion forum about “Sad iPod”
    Exclamation point and folder and nothing else
    http://discussions.apple.com/thread.jspa?messageID=2831962#2831962
    What should I do with my iPod? Send it or keep it?
    http://discussions.apple.com/thread.jspa?threadID=469080&tstart=0
    Strange error on iPod (probably death)
    http://discussions.apple.com/thread.jspa?threadID=435160&start=0&tstart=0
    Sad Face on iPod for no apparent reason
    http://discussions.apple.com/thread.jspa?threadID=336342&start=0&tstart=0
    Meeting the Sad iPod icon
    http://askpang.typepad.com/relevanthistory/2004/11/meeting_thesad.html#comment-10519524
    Sad faced iPod, but my computer won’t recognize it?
    http://discussions.apple.com/thread.jspa?messageID=2236095#2236095
    iPod Photo: unhappy icon + warranty question
    http://discussions.apple.com/thread.jspa?messageID=2233746#2233746
    4th Gen iPod Users - are we all having the same problem?
    http://discussions.apple.com/message.jspa?messageID=2235623#2235623
    Low Battery, and clicking sounds
    http://discussions.apple.com/thread.jspa?messageID=2237714#2237714
    Sad faced iPod, but my computer won’t recognize it
    http://discussions.apple.com/thread.jspa?messageID=2242018#2242018
    Sad iPod solution
    http://discussions.apple.com/thread.jspa?threadID=412033&tstart=0
    Re: try to restore ipod and it says "can't mount ipod"
    http://discussions.apple.com/thread.jspa?threadID=443659&tstart=30
    iPod making clicking noise and is frozen
    http://discussions.apple.com/thread.jspa?messageID=2420150#2420150
    I am not suggesting that you should follow as well, but just read them as your reference. You are the person to make the call.
    Finally, I read a fair comments from dwb, regarding of slapping the back of the iPod multiple times
    Quote “This has been discussed numerous times as a 'fix'. It does work, at least for a while. In fact I remember using the same basic trick to revive Seagate and Quantam drives back in the mid to late 1980's. Why these tiny hard drives go bad I don't know - could be the actuator gets stuck in place or misaligned. Could be the platter gets stuck or the motor gets stuck. 'Stiction' was a problem for drives back in the 80's. Unfortunately the fix can cause damage to the platter so we temporarily fix one problem by creating another. But I know of two instances where a little slap onto the table revived the iPods and they are still worked a year or more later.”UnQuote

  • What could be wrong with this resolveNodes / for script?

    Hello, I am stumped and would greatly appreciate some help here.
    I have a table that has the ability to add additional rows.
    Each row includes a "delete" button to clear the row.
    I'd like to hide the "delete" button when another button is clicked.
    There are a variable amount of rows at any given time, so I can't target the button directly.
    I have used the "for" method before, but it doesn't seem to be able to find the nodes in this case.
    My hierarchy looks like this:
    form1
    - productSubform
    - - productJobTable
    - - - productJobRow
    - - - - deleteBtn
    my Javascript looks like this:
    var nodes = form1.productSubform.productJobTable.resolveNodes("productJobRow[*]");
    var len = nodes.length;
    for(var i = 0; i < len; i++) {
            nodes.item(i).deleteBtn.presence = "invisible";
    Can anyone see what could be wrong here?
    Thank you in advance.

    This code worked for me...
      var rows = form1.p1.Table1.resolveNodes("Row1[*]");
      var len = rows.length;
      for (var i=0; i<len; i++) rows.item(i).Button1.presence = "invisible";
    When I used nodes as the variable name, I got this error: "Invalid property set operation."

  • When I connect my iPad2 to my tv using the AV adapter I can hear sound for everything else except for my movies. I can hear tv shows, music, videos off YouTube, etc. I just can't hear the movies. Any ideas of what may be wrong?

    When I connect my iPad2 to my tv using the AV adapter I can hear sound for everything else except movies. I can hear tv episodes, music, YouTube videos, etc. anyone have an idea of how to fix this issue? Thank you for your help in advance.

    Just connect the new iPod to your computer and setup the iPod via iTunes (instead of via wifi).
    If you want to copy all the infor from an old iPod touch to the inew iPod see:
    iOS: Transferring information from your current iPhone, iPad, or iPod touch to a new device

  • Any ideas on what might be wrong with my HTML?

    I have created a HTML file the exact size of my frame.  It previews correctly, but when I view it in Adobe Viewer (both SD and HD iPads), it is reduced by about half.  Examples:

    Why do you have scale content to fit enabled? Turn it off.
    Bob

  • I have just upgraded my iOS and now I am unable to recive any emails. What's gone wrong with my iPad and the cloud?

    I upgraded iOS and since then I have no emails, no iCloud tabs, and it just dose not work, and this is also on my I phone 4s.

    Have you tried Deleting the Mail Account and then Re-adding it...
    Delete the affected email account from your device.
    Tap Settings > Mail, Contacts, Calendars.
    Choose the affected email account, then tap Delete Account.
    Add your account again.
    More Info here  >  http://www.apple.com/support/ipad/mail/

  • What's is wrong with this code

    import java.awt.*;
    public class FormulaOne extends Canvas {
    public FormulaOne() {
    super();
    setSize(300, 200);
    setBackground(Color.black);
    public static void main(String args[]) {
    FormulaOne it = new FormulaOne();
    GUIFrame frame = new GUIFrame("Formula One Manager");
    frame.add(it);
    frame.pack();
    frame.setVisible(true);
    public void paint(Graphics g) {
    Image img1 = Toolkit.getDefaultToolkit().getImage("F1.gif");
    g.DrawImage(img1, 0, 0, this);
    I get 3 errors
    1.GUIFrame frame = new GUIFrame("Formula One Manager");
    2.GUIFrame frame = new GUIFrame("Formula One Manager");
    3.g.DrawImage(img1, 0, 0, this);
    the line underneath the error code is what is given with the IDE iam using (Gel)
    The idea of this little code is to get a picture up for my game
    Can anybody help

    I get 3 errors
    1.GUIFrame frame = new GUIFrame("Formula One
    Manager");
    2.GUIFrame frame = new GUIFrame("Formula One
    Manager");
    The two are probably related. The code is looking to create
    an instance of the class GUIFrame. The compiler won't see
    GUIFrame unless you either import it into your source file with
    import <<whatever>>.GUIFrame, or have the GUIFrame class within
    the same package as your new class.
    In addition, you'll also need to make sure that the GUIFrame class
    contains a Constructor that takes a single String parameter, or you'll
    get an error with that line.
    3.g.DrawImage(img1, 0, 0, this);
    ------------------------------it's g.drawImage, not g.DrawImage

  • What the **** is wrong with this Photo app?

    This new Photo app is not working very well, i can't just simply press "delete" button to delete a photo anymore, really?  And I wish I had not deleted my iPhone app...  ****!

    Appreciate it!  I am more of a PS6 and Lightroom person, I only use iPhone to manage small Albums when I am on a time crunch...  now it seems a little more difficult to do with Photo app.  I guess I will have to get used to that.  I don't do edits in iPhoto, just albums, create and delete after upload them to my website.  Wish Apple would have a "trash" folder on the sidebar like they did with iPhoto, so we can just drag and drop to "Trash" on what we need to delete. 
    or even keep it iPhone looking but add all new features and keep the old ones as well lol

  • WHAT THE **** IS WRONG WITH THIS UPDATE TO 8.1

    At first i thought my problems were limited to CDs not importing.....NOW MY IPOD WILL NOT SYNC WITH IT. What's the point of and itunes upgrade if my BRAND NEW IPOD won't sync with it??????

    You might get better answers if you gave more specifics. What error messages are you getting? What exactly is happening?

  • What is wrong with this simple CFIF statement?

    Hi, I've included a simple cfif statment to check to see if a
    user is already in the database, for some reaons the <cfelse>
    part of the statement does not work. that is, if the user is there
    it returns the recordcount and ID etc. but if it is a new user (no
    records found) it is just blank (without the nothing doing !!!) any
    ideas?
    Thanks
    Yankee

    Based strictly on the code you have shown, you do not need
    the query="getuser" in your cfoutput tag.
    Also, I would check to see if the value is greater than zero
    rather than equal to one. What if the person has more than one
    record in the database?
    Try this...
    <CFIF getuser.recordcount GT 0>
    #GetUser.RecordCount# Records Found
    <CFELSE>
    Doing Nothing
    </CFIF>

Maybe you are looking for