ASR 1002-X HRSP Object Tracking

Hello
I have the following config in place. I want to make sure my HSRP is tracking to be affective.
Please review and advise.
track 1 ip route (ISP PER ip address) 255.255.255.252 reachability
interface GigabitEthernet0/0/5
 description Inside_DMZ_3750
 ip address 10.27.254.3 255.255.255.0
 standby 1 ip 10.27.254.1
 standby 1 priority 150
 standby 1 preempt
 standby 2 ip 10.27.254.2
 standby 2 priority 90
 standby 2 preempt
 speed 1000
 no negotiation auto
I have tried to add standby track 1 statements to HSRP config, however they do not show in display.
   standby 1 track 1 ?
   standby track 1 ?

1 more question
I am using this track command "track 1 ip route 1.1.1.9 255.255.255.252 reachability
is there anything else I should add to this:
ASR1002x(config-track)#?
Tracking instance configuration commands:
  default  Set a command to its defaults
  delay    Tracking delay
  exit     Exit from tracking configuration mode
  ip       Tracking IP configuration subcommands
  no       Negate a command or set its defaults

Similar Messages

  • ASR 1002 ACL object-group for ZBFW

    Hey guys,
    Quick question. I just want to know if anyone has experience configuring object-groups for ACLs on the ASR 1002. I am trying to so this on ours to consolidate a large ACL we have. It only works if I specifically use the protocols within the configuration. If I add a service object-group to match my protocols it doesn't match. The same configuration works on a 2811 router.
    I have a TAC case open and Cisco is telling me that object-groups are not supported on the ASRs but I have a hard time believing them if the commands clearly exist.
    If anyone has experience in this please let me know.
    Thanks,
    Elton
    Sent from Cisco Technical Support iPhone App

    Elton,
    "Hi Joe,
    Support will start in 3.9S (Q1CY2013).  Thanks. 
    Cheers,
    /Mani"
    From:
    Ask The Expert: Introduction to Cisco ASR 1000 Series Aggregation Services Routers

  • Running object track code on visual c++ with open CV

    Dear all,
    I am newbie to config the open CV in visual c++.
    i have visual studio 2013 desktop version & open CV beta v3.0; I have config the data as per link shared 
    Config opencv I have downloaded the example code from youtube ; link for the code as followyoutube
    link
    visual c++ code
    #include <sstream>
    #include <string>
    #include <iostream>
    #include <opencv\highgui.h>
    #include <opencv\cv.h>
    using namespace cv;
    //initial min and max HSV filter values.
    //these will be changed using trackbars
    int H_MIN = 0;
    int H_MAX = 256;
    int S_MIN = 0;
    int S_MAX = 256;
    int V_MIN = 0;
    int V_MAX = 256;
    //default capture width and height
    const int FRAME_WIDTH = 640;
    const int FRAME_HEIGHT = 480;
    //max number of objects to be detected in frame
    const int MAX_NUM_OBJECTS=50;
    //minimum and maximum object area
    const int MIN_OBJECT_AREA = 20*20;
    const int MAX_OBJECT_AREA = FRAME_HEIGHT*FRAME_WIDTH/1.5;
    //names that will appear at the top of each window
    const string windowName = "Original Image";
    const string windowName1 = "HSV Image";
    const string windowName2 = "Thresholded Image";
    const string windowName3 = "After Morphological Operations";
    const string trackbarWindowName = "Trackbars";
    void on_trackbar( int, void* )
    {//This function gets called whenever a
    // trackbar position is changed
    string intToString(int number){
    std::stringstream ss;
    ss << number;
    return ss.str();
    void createTrackbars(){
    //create window for trackbars
    namedWindow(trackbarWindowName,0);
    //create memory to store trackbar name on window
    char TrackbarName[50];
    sprintf( TrackbarName, "H_MIN", H_MIN);
    sprintf( TrackbarName, "H_MAX", H_MAX);
    sprintf( TrackbarName, "S_MIN", S_MIN);
    sprintf( TrackbarName, "S_MAX", S_MAX);
    sprintf( TrackbarName, "V_MIN", V_MIN);
    sprintf( TrackbarName, "V_MAX", V_MAX);
    //create trackbars and insert them into window
    //3 parameters are: the address of the variable that is changing when the trackbar is moved(eg.H_LOW),
    //the max value the trackbar can move (eg. H_HIGH),
    //and the function that is called whenever the trackbar is moved(eg. on_trackbar)
    // ----> ----> ---->
    createTrackbar( "H_MIN", trackbarWindowName, &H_MIN, H_MAX, on_trackbar );
    createTrackbar( "H_MAX", trackbarWindowName, &H_MAX, H_MAX, on_trackbar );
    createTrackbar( "S_MIN", trackbarWindowName, &S_MIN, S_MAX, on_trackbar );
    createTrackbar( "S_MAX", trackbarWindowName, &S_MAX, S_MAX, on_trackbar );
    createTrackbar( "V_MIN", trackbarWindowName, &V_MIN, V_MAX, on_trackbar );
    createTrackbar( "V_MAX", trackbarWindowName, &V_MAX, V_MAX, on_trackbar );
    void drawObject(int x, int y,Mat &frame){
    //use some of the openCV drawing functions to draw crosshairs
    //on your tracked image!
    //UPDATE:JUNE 18TH, 2013
    //added 'if' and 'else' statements to prevent
    //memory errors from writing off the screen (ie. (-25,-25) is not within the window!)
    circle(frame,Point(x,y),20,Scalar(0,255,0),2);
    if(y-25>0)
    line(frame,Point(x,y),Point(x,y-25),Scalar(0,255,0),2);
    else line(frame,Point(x,y),Point(x,0),Scalar(0,255,0),2);
    if(y+25<FRAME_HEIGHT)
    line(frame,Point(x,y),Point(x,y+25),Scalar(0,255,0),2);
    else line(frame,Point(x,y),Point(x,FRAME_HEIGHT),Scalar(0,255,0),2);
    if(x-25>0)
    line(frame,Point(x,y),Point(x-25,y),Scalar(0,255,0),2);
    else line(frame,Point(x,y),Point(0,y),Scalar(0,255,0),2);
    if(x+25<FRAME_WIDTH)
    line(frame,Point(x,y),Point(x+25,y),Scalar(0,255,0),2);
    else line(frame,Point(x,y),Point(FRAME_WIDTH,y),Scalar(0,255,0),2);
    putText(frame,intToString(x)+","+intToString(y),Point(x,y+30),1,1,Scalar(0,255,0),2);
    void morphOps(Mat &thresh){
    //create structuring element that will be used to "dilate" and "erode" image.
    //the element chosen here is a 3px by 3px rectangle
    Mat erodeElement = getStructuringElement( MORPH_RECT,Size(3,3));
    //dilate with larger element so make sure object is nicely visible
    Mat dilateElement = getStructuringElement( MORPH_RECT,Size(8,8));
    erode(thresh,thresh,erodeElement);
    erode(thresh,thresh,erodeElement);
    dilate(thresh,thresh,dilateElement);
    dilate(thresh,thresh,dilateElement);
    void trackFilteredObject(int &x, int &y, Mat threshold, Mat &cameraFeed){
    Mat temp;
    threshold.copyTo(temp);
    //these two vectors needed for output of findContours
    vector< vector<Point> > contours;
    vector<Vec4i> hierarchy;
    //find contours of filtered image using openCV findContours function
    findContours(temp,contours,hierarchy,CV_RETR_CCOMP,CV_CHAIN_APPROX_SIMPLE );
    //use moments method to find our filtered object
    double refArea = 0;
    bool objectFound = false;
    if (hierarchy.size() > 0) {
    int numObjects = hierarchy.size();
    //if number of objects greater than MAX_NUM_OBJECTS we have a noisy filter
    if(numObjects<MAX_NUM_OBJECTS){
    for (int index = 0; index >= 0; index = hierarchy[index][0]) {
    Moments moment = moments((cv::Mat)contours[index]);
    double area = moment.m00;
    //if the area is less than 20 px by 20px then it is probably just noise
    //if the area is the same as the 3/2 of the image size, probably just a bad filter
    //we only want the object with the largest area so we safe a reference area each
    //iteration and compare it to the area in the next iteration.
    if(area>MIN_OBJECT_AREA && area<MAX_OBJECT_AREA && area>refArea){
    x = moment.m10/area;
    y = moment.m01/area;
    objectFound = true;
    refArea = area;
    }else objectFound = false;
    //let user know you found an object
    if(objectFound ==true){
    putText(cameraFeed,"Tracking Object",Point(0,50),2,1,Scalar(0,255,0),2);
    //draw object location on screen
    drawObject(x,y,cameraFeed);}
    }else putText(cameraFeed,"TOO MUCH NOISE! ADJUST FILTER",Point(0,50),1,2,Scalar(0,0,255),2);
    int main(int argc, char* argv[])
    //some boolean variables for different functionality within this
    //program
    bool trackObjects = false;
    bool useMorphOps = false;
    //Matrix to store each frame of the webcam feed
    Mat cameraFeed;
    //matrix storage for HSV image
    Mat HSV;
    //matrix storage for binary threshold image
    Mat threshold;
    //x and y values for the location of the object
    int x=0, y=0;
    //create slider bars for HSV filtering
    createTrackbars();
    //video capture object to acquire webcam feed
    VideoCapture capture;
    //open capture object at location zero (default location for webcam)
    capture.open(0);
    //set height and width of capture frame
    capture.set(CV_CAP_PROP_FRAME_WIDTH,FRAME_WIDTH);
    capture.set(CV_CAP_PROP_FRAME_HEIGHT,FRAME_HEIGHT);
    //start an infinite loop where webcam feed is copied to cameraFeed matrix
    //all of our operations will be performed within this loop
    while(1){
    //store image to matrix
    capture.read(cameraFeed);
    //convert frame from BGR to HSV colorspace
    cvtColor(cameraFeed,HSV,COLOR_BGR2HSV);
    //filter HSV image between values and store filtered image to
    //threshold matrix
    inRange(HSV,Scalar(H_MIN,S_MIN,V_MIN),Scalar(H_MAX,S_MAX,V_MAX),threshold);
    //perform morphological operations on thresholded image to eliminate noise
    //and emphasize the filtered object(s)
    if(useMorphOps)
    morphOps(threshold);
    //pass in thresholded frame to our object tracking function
    //this function will return the x and y coordinates of the
    //filtered object
    if(trackObjects)
    trackFilteredObject(x,y,threshold,cameraFeed);
    //show frames
    imshow(windowName2,threshold);
    imshow(windowName,cameraFeed);
    imshow(windowName1,HSV);
    //delay 30ms so that screen can refresh.
    //image will not appear without this waitKey() command
    waitKey(30);
    return 0;
    For above code i config as per in video. But didnt get OPENCV_DEBUG243 file.
    error i am getting as below. Let me know how can solve the issue. What are additional info i need to include here.
    1>------ Build started: Project: ObjectTrackingTest, Configuration: Debug Win32 ------
    1> ObjectTrackingTest.cpp
    1>c:\program files (x86)\microsoft visual studio 12.0\vc\include\cwchar(29): error C2039: 'swprintf' : is not a member of '`global namespace''
    1>c:\program files (x86)\microsoft visual studio 12.0\vc\include\cwchar(29): error C2873: 'swprintf' : symbol cannot be used in a using-declaration
    1>c:\program files (x86)\microsoft visual studio 12.0\vc\include\cwchar(30): error C2039: 'vswprintf' : is not a member of '`global namespace''
    1>c:\program files (x86)\microsoft visual studio 12.0\vc\include\cwchar(30): error C2873: 'vswprintf' : symbol cannot be used in a using-declaration
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(38): warning C4244: 'initializing' : conversion from 'double' to 'const int', possible loss of data
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(40): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(40): error C2146: syntax error : missing ';' before identifier 'windowName'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(40): error C2440: 'initializing' : cannot convert from 'const char [15]' to 'int'
    1> There is no context in which this conversion is possible
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(41): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(41): error C2146: syntax error : missing ';' before identifier 'windowName1'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(41): error C2086: 'const int string' : redefinition
    1> c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(40) : see declaration of 'string'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(41): error C2440: 'initializing' : cannot convert from 'const char [10]' to 'int'
    1> There is no context in which this conversion is possible
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(42): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(42): error C2146: syntax error : missing ';' before identifier 'windowName2'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(42): error C2086: 'const int string' : redefinition
    1> c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(40) : see declaration of 'string'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(42): error C2440: 'initializing' : cannot convert from 'const char [18]' to 'int'
    1> There is no context in which this conversion is possible
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(43): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(43): error C2146: syntax error : missing ';' before identifier 'windowName3'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(43): error C2086: 'const int string' : redefinition
    1> c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(40) : see declaration of 'string'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(43): error C2440: 'initializing' : cannot convert from 'const char [31]' to 'int'
    1> There is no context in which this conversion is possible
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(44): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(44): error C2146: syntax error : missing ';' before identifier 'trackbarWindowName'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(44): error C2086: 'const int string' : redefinition
    1> c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(40) : see declaration of 'string'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(44): error C2440: 'initializing' : cannot convert from 'const char [10]' to 'int'
    1> There is no context in which this conversion is possible
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(54): error C2146: syntax error : missing ';' before identifier 'intToString'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(54): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(54): error C2373: 'string' : redefinition; different type modifiers
    1> c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(40) : see declaration of 'string'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(59): error C2440: 'return' : cannot convert from 'std::basic_string<char,std::char_traits<char>,std::allocator<char>>' to 'int'
    1> No user-defined-conversion operator available that can perform this conversion, or the operator cannot be called
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(60): error C2617: 'intToString' : inconsistent return statement
    1> c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(54) : see declaration of 'intToString'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(65): error C3861: 'namedWindow': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(79): error C3861: 'createTrackbar': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(80): error C3861: 'createTrackbar': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(81): error C3861: 'createTrackbar': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(82): error C3861: 'createTrackbar': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(83): error C3861: 'createTrackbar': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(84): error C3861: 'createTrackbar': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(97): error C3861: 'circle': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(99): error C3861: 'line': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(100): error C3861: 'line': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(102): error C3861: 'line': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(103): error C3861: 'line': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(105): error C3861: 'line': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(106): error C3861: 'line': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(108): error C3861: 'line': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(109): error C3861: 'line': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(111): error C3861: 'putText': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(119): error C2065: 'MORPH_RECT' : undeclared identifier
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(119): error C3861: 'getStructuringElement': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(121): error C2065: 'MORPH_RECT' : undeclared identifier
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(121): error C3861: 'getStructuringElement': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(123): error C3861: 'erode': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(124): error C3861: 'erode': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(127): error C3861: 'dilate': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(128): error C3861: 'dilate': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(138): error C2065: 'vector' : undeclared identifier
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(138): error C2059: syntax error : '>'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(139): error C2065: 'vector' : undeclared identifier
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(139): error C2275: 'cv::Vec4i' : illegal use of this type as an expression
    1> h:\softwares\opencv\build\include\opencv2\core\matx.hpp(357) : see declaration of 'cv::Vec4i'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(139): error C2065: 'hierarchy' : undeclared identifier
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(141): error C2065: 'contours' : undeclared identifier
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(141): error C2065: 'hierarchy' : undeclared identifier
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(141): error C3861: 'findContours': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(145): error C2065: 'hierarchy' : undeclared identifier
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(145): error C2228: left of '.size' must have class/struct/union
    1> type is 'unknown-type'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(146): error C2065: 'hierarchy' : undeclared identifier
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(146): error C2228: left of '.size' must have class/struct/union
    1> type is 'unknown-type'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(149): error C2065: 'hierarchy' : undeclared identifier
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(151): error C2065: 'contours' : undeclared identifier
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(151): error C3861: 'moments': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(159): warning C4244: '=' : conversion from 'double' to 'int', possible loss of data
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(160): warning C4244: '=' : conversion from 'double' to 'int', possible loss of data
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(170): error C3861: 'putText': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(176): error C3861: 'putText': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(196): error C2065: 'VideoCapture' : undeclared identifier
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(196): error C2146: syntax error : missing ';' before identifier 'capture'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(196): error C2065: 'capture' : undeclared identifier
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(198): error C2065: 'capture' : undeclared identifier
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(198): error C2228: left of '.open' must have class/struct/union
    1> type is 'unknown-type'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(200): error C2065: 'capture' : undeclared identifier
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(200): error C2228: left of '.set' must have class/struct/union
    1> type is 'unknown-type'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(201): error C2065: 'capture' : undeclared identifier
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(201): error C2228: left of '.set' must have class/struct/union
    1> type is 'unknown-type'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(206): error C2065: 'capture' : undeclared identifier
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(206): error C2228: left of '.read' must have class/struct/union
    1> type is 'unknown-type'
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(208): error C2065: 'COLOR_BGR2HSV' : undeclared identifier
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(208): error C3861: 'cvtColor': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(223): error C3861: 'imshow': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(224): error C3861: 'imshow': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(225): error C3861: 'imshow': identifier not found
    1>c:\users\user\documents\visual studio 2013\projects\objecttrackingtest\objecttrackingtest\objecttrackingtest.cpp(230): error C3861: 'waitKey': identifier not found
    ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========
    AMPS12

    // cwchar standard header
    #pragma once
    #ifndef _CWCHAR_
    #define _CWCHAR_
    #include <yvals.h>
    #ifdef _STD_USING
    #undef _STD_USING
    #include <wchar.h>
    #define _STD_USING
    #else /* _STD_USING */
    #include <wchar.h>
    #endif /* _STD_USING */
    typedef mbstate_t _Mbstatet;
    #if _GLOBAL_USING && !defined(RC_INVOKED)
    _STD_BEGIN
    using _CSTD _Mbstatet;
    using _CSTD mbstate_t; using _CSTD size_t; using _CSTD tm; using _CSTD wint_t;
    using _CSTD btowc; using _CSTD fgetwc; using _CSTD fgetws; using _CSTD fputwc;
    using _CSTD fputws; using _CSTD fwide; using _CSTD fwprintf;
    using _CSTD fwscanf; using _CSTD getwc; using _CSTD getwchar;
    using _CSTD mbrlen; using _CSTD mbrtowc; using _CSTD mbsrtowcs;
    using _CSTD mbsinit; using _CSTD putwc; using _CSTD putwchar;using _CSTD swprintf; using _CSTD swscanf; using _CSTD ungetwc;
    using _CSTD vfwprintf; using _CSTD vswprintf; using _CSTD vwprintf;
    using _CSTD wcrtomb; using _CSTD wprintf; using _CSTD wscanf;
    using _CSTD wcsrtombs; using _CSTD wcstol; using _CSTD wcscat;
    using _CSTD wcschr; using _CSTD wcscmp; using _CSTD wcscoll;
    using _CSTD wcscpy; using _CSTD wcscspn; using _CSTD wcslen;
    using _CSTD wcsncat; using _CSTD wcsncmp; using _CSTD wcsncpy;
    using _CSTD wcspbrk; using _CSTD wcsrchr; using _CSTD wcsspn;
    using _CSTD wcstod; using _CSTD wcstoul; using _CSTD wcsstr;
    using _CSTD wcstok; using _CSTD wcsxfrm; using _CSTD wctob;
    using _CSTD wmemchr; using _CSTD wmemcmp; using _CSTD wmemcpy;
    using _CSTD wmemmove; using _CSTD wmemset; using _CSTD wcsftime;
    using _CSTD vfwscanf; using _CSTD vswscanf; using _CSTD vwscanf;
    using _CSTD wcstof; using _CSTD wcstold;
    using _CSTD wcstoll; using _CSTD wcstoull;
    _STD_END
    #endif /* _GLOBAL_USING */
    #endif /* _CWCHAR_ */
    * Copyright (c) 1992-2013 by P.J. Plauger. ALL RIGHTS RESERVED.
    * Consult your license regarding permissions and restrictions.
    V6.40:0009 */
    this is line where it go when i clicked
    AMPS12

  • What is the Max Nat Session supported on ASR 1002 with ASR1002-5G/K9

    Hello,
    I am going for ASR 1002 With ASR1002-5G/K9 ESP, Can any 1 help me to know how many NAT translation is possible.
    As I got the Datasheet for ASR1000 it say’s 1M translation is Supported by ESP10 but it’s not giving any information regarding ESP5.
    Thanks in advance

    Firewall or NAT: 250,000 sessions and 50,000 sessions-per-sec setup rate
    This is from the datasheet. Pls check.
    Table 3. Cisco ASR 1000 Series 5-Gbps ESP Module Performance and Scaling
    Regards
    Durga Prasad - Datasoft Comnet
    Pls rate helpful posts
    Sent from Cisco Technical Support Android App

  • "Track 2 is controlled by stereo object track 1-2" - why?

    As i want to record in mono or stereo on track 1, 2 , 3 and so forth, i've got this problem that "trac 2 is controlled by stereo object track 1-2".
    Same message on track four, six and so on.
    Logic started acting strange in this way after an update.
    I'm using the Edirol FA66 Firewire converter, and i've also got very low input to logic from the unit. If i use the "line in" on my mac -through a mixer, the signal is ok.
    Any suggestions?
    Thanks
    Mac 2.33 Ghz Intel Core 2 Duo   Mac OS X (10.4.10)   Running Logic Pro 7.2.3, Edirol FA66

    You have Universal Track mode turned off in your audio preferences.
    I suggest enabling UTM, as this is the way most people use Logic, aside for those with specific reason to turn it off (mostly for old hardware support).

  • Migrate PPPoE/Virtual-Interface from 7206VXR to ASR 1002

    Good Day,
    I have been attempting to migrate services from an existing 7206VXR to a recently purchased ASR1002 and could use some help.
    My mistake in assuming that the config would be similar to 7206VXR, but there are changes - mainly VRF and cisco-avpair attributes that need added to radius.
    Our lab test, with the below ASR config will allow the user to authenticate successfully but does not assign IP address.
    User Status
    User is online
    Last Connection
    2012-09-21 10:27:47
    Online Time
    1 hours, 4 minutes, 15 seconds
    Server (NAS)
    206.251.40.52 (MAC: )
    User Workstation
    (MAC: )
    User Upload
    6.5 Kb
    User Download
    6.51 Kb
    ID
    HotSpot
    Username
    IP Address
    Start Time
    Stop Time
    Total Time
    Upload (Bytes)
    Download (Bytes)
    Termination
    NAS IP Address
    7837056
    [email protected]
    2012-09-21 10:27:47
    1 hours, 4 minutes, 15 seconds
    6.5 Kb
    6.51 Kb
    206.251.40.52
    I have also tried assigning a static IP to the CPE, however the CPE cannot see 199.200.107.1.
    No doubt the problem is something simple I appreciate any help or suggestions.
    Radius Reply Attributes
    Cisco-AVPair += ip:vrf-id=CV_VRF
    Cisco-AVPair += ip:ip-unnumbered=Loopback 111 (generates unsupported sub-interface errors when used)
    7206VXR Config-
    aaa new-model
    aaa authentication login default group radius
    aaa authentication login con none
    aaa authentication login vty line local
    aaa authentication login localauth local
    aaa authentication ppp default if-needed group radius
    aaa authorization network default group radius
    aaa authorization network noauth none
    aaa accounting update periodic 5
    aaa accounting network default
    action-type start-stop
    group radius
    aaa accounting system default
    action-type start-stop
    group radius
    bba-group pppoe 156
    virtual-template 156
    sessions per-vc limit 65000
    sessions per-mac limit 65000
    sessions per-vlan limit 65000
    interface Loopback0
    ip address 10.1.1.3 255.255.255.255
    ip ospf network point-to-point
    interface GigabitEthernet0/1
    no ip address
    no ip redirects
    duplex full
    speed 1000
    media-type rj45
    no negotiation auto
    no cdp enable
    interface GigabitEthernet0/1.20
    description ROUTER GATEWAY
    encapsulation dot1Q 20
    ip address 206.251.40.51 255.255.255.248
    no cdp enable
    interface GigabitEthernet0/2
    no ip address
    no ip redirects
    duplex full
    speed 1000
    media-type rj45
    no negotiation auto
    no cdp enable
    interface GigabitEthernet0/2.156
    encapsulation dot1Q 156
    ip address 199.30.185.1 255.255.255.0 secondary
    ip address 199.30.186.1 255.255.255.0 secondary
    ip address 199.30.187.1 255.255.255.0 secondary
    ip address 199.30.184.1 255.255.255.0
    pppoe enable group 156
    no cdp enable
    interface Virtual-Template156
    ip unnumbered GigabitEthernet0/2.156
    no ip redirects
    no ip route-cache cef
    peer default ip address pool IP_POOL156
    ppp mtu adaptive
    ppp authentication pap
    ip local pool IP_POOL156 199.30.184.2 199.30.184.254
    ip local pool IP_POOL156 199.30.185.2 199.30.185.254
    ip local pool IP_POOL156 199.30.186.2 199.30.186.254
    ip local pool IP_POOL156 199.30.187.2 199.30.187.254
    no ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip route 199.30.184.0 255.255.252.0 Null0 200
    ip prefix-list AS19045 seq 10 permit 199.30.184.0/22
    ip radius source-interface GigabitEthernet0/1.20
    radius-server host x.x.x.x auth-port 1812 acct-port 1813
    radius-server retransmit 1
    radius-server timeout 60
    radius-server key ********
    radius-server vsa send accounting
    radius-server vsa send authentication
    ASR 1002 Config (attempt)
    aaa new-model
    aaa group server radius AAA_CV_VRF
    server 208.98.188.6 auth-port 1812 acct-port 1813
    aaa authentication login default group AAA_CV_VRF
    aaa authentication login con none
    aaa authentication login vty line local
    aaa authentication login localauth local
    aaa authentication ppp default if-needed group AAA_CV_VRF
    aaa authorization network default group AAA_CV_VRF
    aaa authorization network noauth none
    aaa accounting update newinfo periodic 60
    aaa accounting network default start-stop group AAA_CV_VRF
    aaa accounting connection default start-stop group AAA_CV_VRF
    aaa accounting system default
    action-type start-stop
    group AAA_CV_VRF
    aaa accounting resource default start-stop group AAA_CV_VRF
    aaa session-id common
    aaa policy interface-config allow-subinterface
    clock timezone MST -7 0
    clock summer-time MST recurring
    no ip source-route
    ip vrf CV_VRF
    rd 1:1
    virtual-profile if-needed
    multilink bundle-name authenticated
    bba-group pppoe 111
    description TEST
    virtual-template 111
    sessions per-vc limit 65000
    sessions per-mac limit 65000
    sessions per-vlan limit 65000
    sessions auto cleanup
    interface Loopback0
    ip address 10.1.1.4 255.255.255.255
    ip ospf network point-to-point
    interface Loopback111
    description TEST
    ip vrf forwarding CV_VRF
    ip address 199.200.107.1 255.255.255.0
    interface GigabitEthernet0/0/2
    no ip address
    no ip redirects
    no negotiation auto
    interface GigabitEthernet0/0/2.20
    description ROUTER GATEWAY
    encapsulation dot1Q 20
    ip address 206.251.40.52 255.255.255.248
    interface GigabitEthernet0/0/3
    no ip address
    no ip redirects
    no negotiation auto
    interface GigabitEthernet0/0/3.111
    encapsulation dot1Q 111
    ip vrf forwarding CV_VRF
    no ip proxy-arp
    pppoe enable group 111
    interface Virtual-Template111
    ip unnumbered GigabitEthernet0/0/3.111
    no ip redirects
    no ip route-cache cef
    peer default ip address pool IP_POOL111
    ppp mtu adaptive
    ppp authentication pap
    router ospf 19045
    router-id 10.1.1.4
    network 10.1.1.4 0.0.0.0 area 0.0.0.0
    network 199.200.107.0 0.0.0.255 area 0.0.0.0
    network 206.251.40.48 0.0.0.7 area 0.0.0.0
    router bgp 19045
    bgp log-neighbor-changes
    network 199.200.104.0 mask 255.255.252.0
    network 206.251.40.0 mask 255.255.248.0
    neighbor 10.1.1.1 remote-as 19045
    neighbor 10.1.1.1 description IBGP_PEER_ASR
    neighbor 10.1.1.1 update-source Loopback0
    neighbor 10.1.1.1 next-hop-self
    ip local pool IP_POOL111 199.200.107.2 199.200.107.254
    no ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip route 0.0.0.0 0.0.0.0 206.251.40.49
    ip route 199.200.104.0 255.255.252.0 Null0 200
    ip prefix-list AS19045 seq 10 permit 199.200.104.0/22
    ip radius source-interface GigabitEthernet0/0/2.20
    radius-server host x.x.x.x auth-port 1812 acct-port 1813 key ********
    radius-server retransmit 1
    radius-server timeout 60
    radius-server vsa send accounting
    radius-server vsa send authentication
    Debug Info
    *Sep 20 22:03:26.677: [910]PPPoE 1911: AAA get dynamic attrs
    *Sep 20 22:03:26.678: [910]PPPoE 1911: O PADT  R:6468.0cf7.8546 L:f866.f287.7c83 Gi0/0/3.111
    *Sep 20 22:03:26.678: [910]PPPoE 1911: Destroying  R:6468.0cf7.8546 L:f866.f287.7c83 111 Gi0/0/3.111
    *Sep 20 22:03:26.678: PPPoE: Returning Vaccess Virtual-Access3
    *Sep 20 22:03:26.679: [910]PPPoE 1911: AAA get dynamic attrs
    *Sep 20 22:03:26.679: [910]PPPoE 1911: AAA account stopped
    *Sep 20 22:03:26.679: RADIUS/ENCODE(00000791):Orig. component type = PPPoE
    *Sep 20 22:03:26.679: RADIUS(00000791): Config NAS IP: 0.0.0.0
    *Sep 20 22:03:26.679: RADIUS(00000791): Config NAS IPv6: ::
    *Sep 20 22:03:26.679: RADIUS(00000791): sending
    *Sep 20 22:03:26.682: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to down
    *Sep 20 22:03:26.682: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to down
    *Sep 20 22:03:26.683: RADIUS/ENCODE: Best Local IP-Address 206.251.40.52 for Radius-Server 208.98.188.6
    *Sep 20 22:03:26.683: RADIUS(00000791): Sending a IPv4 Radius Packet
    *Sep 20 22:03:26.683: RADIUS(00000791): Send Accounting-Request to 208.98.188.6:1813 id 1646/71,len 379
    *Sep 20 22:03:26.683: RADIUS:  authenticator A6 50 A4 C3 2A 30 AB DA - 59 BF E8 75 8A 91 AA 9B
    *Sep 20 22:03:26.683: RADIUS:  Acct-Session-Id     [44]  10  "00000D51"
    *Sep 20 22:03:26.683: RADIUS:  Framed-Protocol     [7]   6   PPP                       [1]
    *Sep 20 22:03:26.683: RADIUS:  Vendor, Cisco       [26]  53 
    *Sep 20 22:03:26.683: RADIUS:   Cisco AVpair       [1]   47  "ppp-disconnect-cause=Lower Layer disconnected"
    *Sep 20 22:03:26.683: RADIUS:  User-Name           [1]   19  "[email protected]"
    *Sep 20 22:03:26.683: RADIUS:  Acct-Authentic      [45]  6   RADIUS                    [1]
    *Sep 20 22:03:26.683: RADIUS:  Vendor, Cisco       [26]  32 
    *Sep 20 22:03:26.683: RADIUS:   Cisco AVpair       [1]   26  "connect-progress=Call Up"
    *Sep 20 22:03:26.683: RADIUS:  Vendor, Cisco       [26]  31 
    *Sep 20 22:03:26.683: RADIUS:   Cisco AVpair       [1]   25  "nas-tx-speed=1000000000"
    *Sep 20 22:03:26.683: RADIUS:  Vendor, Cisco       [26]  31 
    *Sep 20 22:03:26.683: RADIUS:   Cisco AVpair       [1]   25  "nas-rx-speed=1000000000"
    *Sep 20 22:03:26.683: RADIUS:  Acct-Session-Time   [46]  6   615                      
    *Sep 20 22:03:26.683: RADIUS:  Acct-Input-Octets   [42]  6   1040                     
    *Sep 20 22:03:26.683: RADIUS:  Acct-Output-Octets  [43]  6   1066                     
    *Sep 20 22:03:26.683: RADIUS:  Acct-Input-Packets  [47]  6   78                       
    *Sep 20 22:03:26.684: RADIUS:  Acct-Output-Packets [48]  6   79                       
    *Sep 20 22:03:26.684: RADIUS:  Acct-Terminate-Cause[49]  6   admin-reset               [6]
    *Sep 20 22:03:26.684: RADIUS:  Vendor, Cisco       [26]  39 
    *Sep 20 22:03:26.684: RADIUS:   Cisco AVpair       [1]   33  "disc-cause-ext=Local Admin Disc"
    *Sep 20 22:03:26.684: RADIUS:  Acct-Status-Type    [40]  6   Stop                      [2]
    *Sep 20 22:03:26.684: RADIUS:  NAS-Port-Type       [61]  6   Virtual                   [5]
    *Sep 20 22:03:26.684: RADIUS:  NAS-Port            [5]   6   0                        
    *Sep 20 22:03:26.684: RADIUS:  NAS-Port-Id         [87]  11  "0/0/3/111"
    *Sep 20 22:03:26.684: RADIUS:  Vendor, Cisco       [26]  41 
    *Sep 20 22:03:26.684: RADIUS:   Cisco AVpair       [1]   35  "client-mac-address=6468.0cf7.8546"
    *Sep 20 22:03:26.684: RADIUS:  Connect-Info        [77]  8   "CV_VRF"
    *Sep 20 22:03:26.684: RADIUS:  Service-Type        [6]   6   Framed                    [2]
    *Sep 20 22:03:26.684: RADIUS:  NAS-IP-Address      [4]   6   206.251.40.52            
    *Sep 20 22:03:26.684: RADIUS:  Acct-Delay-Time     [41]  6   0                        
    *Sep 20 22:03:26.684: RADIUS(00000791): Started 60 sec timeout
    *Sep 20 22:03:26.686: [910]PPPoE 1911: Segment (SSS class): UNBOUND
    *Sep 20 22:03:26.686: [910]PPPoE 1911: Vi3 Block vaccess from being freed.
    *Sep 20 22:03:26.687: [910]PPPoE 1911: Segment (SSS class): UNPROVISION
    *Sep 20 22:03:26.687: [910]PPPoE 1911: failed to remove session from switching hash table.
    *Sep 20 22:03:26.694: PPPoE 1911: I PADT  R:6468.0cf7.8546 L:f866.f287.7c83 111 Gi0/0/3.111
    *Sep 20 22:03:26.758: RADIUS: Received from id 1646/71 208.98.188.6:1813, Accounting-response, len 20
    *Sep 20 22:03:26.758: RADIUS:  authenticator E3 A2 A1 EE B0 3F 43 1C - 03 B6 84 A8 20 0D B8 90
    *Sep 20 22:03:32.713: PPPoE 0: I PADI  R:6468.0cf7.8546 L:ffff.ffff.ffff 111 Gi0/0/3.111
    *Sep 20 22:03:32.713:  Service tag: NULL Tag
    *Sep 20 22:03:32.713: PPPoE 0: O PADO, R:f866.f287.7c83 L:6468.0cf7.8546 111 Gi0/0/3.111
    *Sep 20 22:03:32.713:  Service tag: NULL Tag
    *Sep 20 22:03:32.722: PPPoE 0: I PADR  R:6468.0cf7.8546 L:f866.f287.7c83 111 Gi0/0/3.111
    *Sep 20 22:03:32.722:  Service tag: NULL Tag
    *Sep 20 22:03:32.722: PPPoE : encap string prepared
    *Sep 20 22:03:32.722: [911]PPPoE 1912: Access IE handle allocated
    *Sep 20 22:03:32.722: [911]PPPoE 1912: AAA get retrieved attrs
    *Sep 20 22:03:32.722: [911]PPPoE 1912: AAA get nas port details
    *Sep 20 22:03:32.722: [911]PPPoE 1912: Error adjusting nas port format did
    *Sep 20 22:03:32.722: [911]PPPoE 1912: AAA get dynamic attrs
    *Sep 20 22:03:32.722: [911]PPPoE 1912: AAA unique ID 792 allocated
    *Sep 20 22:03:32.722: [911]PPPoE 1912: AAA method list  set
    *Sep 20 22:03:32.722: [911]PPPoE 1912: Service request sent to SSS
    *Sep 20 22:03:32.723: [911]PPPoE 1912: Created, Service: None R:f866.f287.7c83 L:6468.0cf7.8546 111 Gi0/0/3.111
    *Sep 20 22:03:32.723: [911]PPPoE 1912: State NAS_PORT_POLICY_INQUIRY    Event SSS MORE KEYS
    *Sep 20 22:03:32.724: [911]PPPoE 1912: data path set to PPP
    *Sep 20 22:03:32.724: [911]PPPoE 1912: Segment (SSS class): PROVISION
    *Sep 20 22:03:32.724: [911]PPPoE 1912: State PROVISION_PPP    Event SSM PROVISIONED
    *Sep 20 22:03:32.724: [911]PPPoE 1912: O PADS  R:6468.0cf7.8546 L:f866.f287.7c83 Gi0/0/3.111
    *Sep 20 22:03:32.724: [911]PPPoE 1912 <Gi0/0/3.111:111>: Unable to add line attributes from ANCP
    *Sep 20 22:03:32.724: [911]PPPoE 1912: Unable to Add ANCP Line attributes to the PPPoE Authen attributes
    *Sep 20 22:03:33.845: RADIUS/ENCODE(00000792):Orig. component type = PPPoE
    *Sep 20 22:03:33.845: RADIUS: DSL line rate attributes successfully added
    *Sep 20 22:03:33.845: RADIUS(00000792): Config NAS IP: 0.0.0.0
    *Sep 20 22:03:33.845: RADIUS(00000792): Config NAS IPv6: ::
    *Sep 20 22:03:33.845: RADIUS/ENCODE(00000792): acct_session_id: 3411
    *Sep 20 22:03:33.845: RADIUS(00000792): sending
    *Sep 20 22:03:33.845: RADIUS/ENCODE: Best Local IP-Address 206.251.40.52 for Radius-Server 208.98.188.6
    *Sep 20 22:03:33.845: RADIUS(00000792): Sending a IPv4 Radius Packet
    *Sep 20 22:03:33.845: RADIUS(00000792): Send Access-Request to 208.98.188.6:1812 id 1645/56,len 124
    *Sep 20 22:03:33.846: RADIUS:  authenticator 3E 87 16 F9 FF 1A F8 74 - D6 7F 38 C3 F0 98 6E 6F
    *Sep 20 22:03:33.846: RADIUS:  User-Name           [1]   10  "dcdi.net"
    *Sep 20 22:03:33.846: RADIUS:  User-Password       [2]   18  *
    *Sep 20 22:03:33.846: RADIUS:  NAS-Port-Type       [61]  6   Virtual                   [5]
    *Sep 20 22:03:33.846: RADIUS:  NAS-Port            [5]   6   0                        
    *Sep 20 22:03:33.846: RADIUS:  NAS-Port-Id         [87]  11  "0/0/3/111"
    *Sep 20 22:03:33.846: RADIUS:  Vendor, Cisco       [26]  41 
    *Sep 20 22:03:33.846: RADIUS:   Cisco AVpair       [1]   35  "client-mac-address=6468.0cf7.8546"
    *Sep 20 22:03:33.846: RADIUS:  Service-Type        [6]   6   Outbound                  [5]
    *Sep 20 22:03:33.846: RADIUS:  NAS-IP-Address      [4]   6   206.251.40.52            
    *Sep 20 22:03:33.846: RADIUS(00000792): Started 60 sec timeout
    *Sep 20 22:03:34.868: RADIUS: Received from id 1645/56 208.98.188.6:1812, Access-Reject, len 20
    *Sep 20 22:03:34.868: RADIUS:  authenticator 02 CF 53 0A 6A 62 E5 DB - 2E 96 99 E4 09 D8 2E B1
    *Sep 20 22:03:34.868: RADIUS(00000792): Received from id 1645/56
    *Sep 20 22:03:34.869: RADIUS/ENCODE(00000792):Orig. component type = PPPoE
    *Sep 20 22:03:34.869: RADIUS: DSL line rate attributes successfully added
    *Sep 20 22:03:34.869: RADIUS(00000792): Config NAS IP: 0.0.0.0
    *Sep 20 22:03:34.869: RADIUS(00000792): Config NAS IPv6: ::
    *Sep 20 22:03:34.869: RADIUS/ENCODE(00000792): acct_session_id: 3411
    *Sep 20 22:03:34.869: RADIUS(00000792): sending
    *Sep 20 22:03:34.870: RADIUS/ENCODE: Best Local IP-Address 206.251.40.52 for Radius-Server 208.98.188.6
    *Sep 20 22:03:34.870: RADIUS(00000792): Sending a IPv4 Radius Packet
    *Sep 20 22:03:34.870: RADIUS(00000792): Send Access-Request to 208.98.188.6:1812 id 1645/57,len 139
    *Sep 20 22:03:34.870: RADIUS:  authenticator 8D 12 A1 E3 30 52 B0 F5 - 1C CD 8F 60 49 E9 F4 26
    *Sep 20 22:03:34.870: RADIUS:  Framed-Protocol     [7]   6   PPP                       [1]
    *Sep 20 22:03:34.870: RADIUS:  User-Name           [1]   19  "[email protected]"
    *Sep 20 22:03:34.870: RADIUS:  User-Password       [2]   18  *
    *Sep 20 22:03:34.870: RADIUS:  NAS-Port-Type       [61]  6   Virtual                   [5]
    *Sep 20 22:03:34.870: RADIUS:  NAS-Port            [5]   6   0                        
    *Sep 20 22:03:34.870: RADIUS:  NAS-Port-Id         [87]  11  "0/0/3/111"
    *Sep 20 22:03:34.870: RADIUS:  Vendor, Cisco       [26]  41 
    *Sep 20 22:03:34.870: RADIUS:   Cisco AVpair       [1]   35  "client-mac-address=6468.0cf7.8546"
    *Sep 20 22:03:34.870: RADIUS:  Service-Type        [6]   6   Framed                    [2]
    *Sep 20 22:03:34.870: RADIUS:  NAS-IP-Address      [4]   6   206.251.40.52            
    *Sep 20 22:03:34.870: RADIUS(00000792): Started 60 sec timeout
    *Sep 20 22:03:34.894: RADIUS: Received from id 1645/57 208.98.188.6:1812, Access-Accept, len 44
    *Sep 20 22:03:34.894: RADIUS:  authenticator AC 92 A9 7C 1F CB 46 6B - F6 68 03 D8 AF 0B F0 F5
    *Sep 20 22:03:34.894: RADIUS:  Vendor, Cisco       [26]  24 
    *Sep 20 22:03:34.894: RADIUS:   Cisco AVpair       [1]   18  "ip:vrf-id=CV_VRF"
    *Sep 20 22:03:34.894: RADIUS(00000792): Received from id 1645/57
    *Sep 20 22:03:34.902: [911]PPPoE 1912: State LCP_NEGOTIATION    Event SSS CONNECT LOCAL
    *Sep 20 22:03:34.904: [911]PPPoE 1912: Segment (SSS class): UPDATED
    *Sep 20 22:03:34.904: [911]PPPoE 1912: Segment (SSS class): BOUND
    *Sep 20 22:03:34.904: [911]PPPoE 1912: data path set to Virtual Acess
    *Sep 20 22:03:34.905: [911]PPPoE 1912: State LCP_NEGOTIATION    Event SSM UPDATED
    *Sep 20 22:03:34.905: [911]PPPoE 1912: AAA get dynamic attrs
    *Sep 20 22:03:34.906: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to up
    *Sep 20 22:03:34.907: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to up
    *Sep 20 22:03:34.907: RADIUS/ENCODE(00000792):Orig. component type = PPPoE
    *Sep 20 22:03:34.907: RADIUS(00000792): Config NAS IP: 0.0.0.0
    *Sep 20 22:03:34.907: RADIUS(00000792): Config NAS IPv6: ::
    *Sep 20 22:03:34.907: RADIUS(00000792): sending
    *Sep 20 22:03:34.907: [911]PPPoE 1912: State PTA_BINDING    Event STATIC BIND RESPONSE
    *Sep 20 22:03:34.907: [911]PPPoE 1912: Connected PTA
    *Sep 20 22:03:34.908: RADIUS/ENCODE: Best Local IP-Address 206.251.40.52 for Radius-Server 208.98.188.6
    *Sep 20 22:03:34.913: RADIUS(00000792): Sending a IPv4 Radius Packet
    *Sep 20 22:03:34.913: RADIUS(00000792): Send Accounting-Request to 208.98.188.6:1813 id 1646/72,len 189
    *Sep 20 22:03:34.913: RADIUS:  authenticator 5B 19 2B 31 5B 6C E7 46 - 5D 69 8D 66 99 13 2E F0
    *Sep 20 22:03:34.913: RADIUS:  Acct-Session-Id     [44]  10  "00000D53"
    *Sep 20 22:03:34.913: RADIUS:  Framed-Protocol     [7]   6   PPP                       [1]
    *Sep 20 22:03:34.913: RADIUS:  User-Name           [1]   19  "[email protected]"
    *Sep 20 22:03:34.913: RADIUS:  Vendor, Cisco       [26]  32 
    *Sep 20 22:03:34.913: RADIUS:   Cisco AVpair       [1]   26  "connect-progress=Call Up"
    *Sep 20 22:03:34.913: RADIUS:  Acct-Authentic      [45]  6   RADIUS                    [1]
    *Sep 20 22:03:34.913: RADIUS:  Acct-Status-Type    [40]  6   Start                     [1]
    *Sep 20 22:03:34.913: RADIUS:  NAS-Port-Type       [61]  6   Virtual                   [5]
    *Sep 20 22:03:34.913: RADIUS:  NAS-Port            [5]   6   0                        
    *Sep 20 22:03:34.913: RADIUS:  NAS-Port-Id         [87]  11  "0/0/3/111"
    *Sep 20 22:03:34.913: RADIUS:  Vendor, Cisco       [26]  41 
    *Sep 20 22:03:34.913: RADIUS:   Cisco AVpair       [1]   35  "client-mac-address=6468.0cf7.8546"
    *Sep 20 22:03:34.913: RADIUS:  Connect-Info        [77]  8   "CV_VRF"
    *Sep 20 22:03:34.913: RADIUS:  Service-Type        [6]   6   Framed                    [2]
    *Sep 20 22:03:34.913: RADIUS:  NAS-IP-Address      [4]   6   206.251.40.52            
    *Sep 20 22:03:34.914: RADIUS:  Acct-Delay-Time     [41]  6   0                        
    *Sep 20 22:03:34.914: RADIUS(00000792): Started 60 sec timeout
    *Sep 20 22:03:34.994: RADIUS: Received from id 1646/72 208.98.188.6:1813, Accounting-response, len 20
    *Sep 20 22:03:34.994: RADIUS:  authenticator 8E E3 AD 24 76 EA C2 53 - AD 0F DD 57 AC 0D F3 BAsho debug
    coreASR1002#sho debugging
    General OS:
      AAA subscriber profile cli debugging is on
    PPPoE:
      PPPoE protocol events debugging is on
      PPPoE protocol errors debugging is on
    Radius protocol debugging is on
    Radius packet protocol debugging is on

    Good Day Manuel,
    "...client is not getting IP address even though the sessions seems to be up. Is this correct?" Correct.
    What I am seeing and suspecting is the problem has to do with 'ip:ip-unnumbered=interface'.
    Trying with the ip:ip-unnumbered=Loopback111 or GigabitEthernet0/0/3.111 (for testing) debugging reports "Session creation failed due to full virtual-access interfaces not being supported...", as soon as the attribute is removed in radius the client authenticates but does not get an IP address. I would rather not use Loopback if possible.
    GE0/0/3.111 is basically the client egress and GE0/0/2.20 is the ingress/router gateway
    Also seeing this debug message, "...Unable to add line attributes from ANCP ... Unable to Add ANCP Line attributes to the PPPoE Authen attributes" which may or may not relate to ip-unnumbered attribute.
    I hope the information isn't too much or confusing, sure appreciate the help.
    debugging with ip:vrf-id=CV_VRF w/o ip:ip-unnumbered
    *Sep 26 17:04:57.395: Vi3 PPP DISC: Lower Layer disconnected
    *Sep 26 17:04:57.396: Vi3 PPP: Sending Acct Event[Down] id[5FB]
    *Sep 26 17:04:57.396: PPP: NET STOP send to AAA.
    *Sep 26 17:04:57.396: Vi3 LCP: O TERMREQ [Open] id 4 len 4
    *Sep 26 17:04:57.396: Vi3 LCP: Event[CLOSE] State[Open to Closing]
    *Sep 26 17:04:57.396: Vi3 PPP: Phase is TERMINATING
    *Sep 26 17:04:57.397: Vi3 PPP: Block vaccess from being freed [0x10]
    *Sep 26 17:04:57.398: Vi3 LCP: Event[DOWN] State[Closing to Initial]
    *Sep 26 17:04:57.399: Vi3 PPP: Unlocked by [0x10] Still Locked by [0x0]
    *Sep 26 17:04:57.399: Vi3 PPP: Free previously blocked vaccess
    *Sep 26 17:04:57.399: Vi3 PPP: Phase is DOWN
    *Sep 26 17:04:57.400: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to down
    *Sep 26 17:04:57.401: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to down
    *Sep 26 17:05:03.440: PPP: Alloc Context [38E95CFC]
    *Sep 26 17:05:03.440: ppp514 PPP: Phase is ESTABLISHING
    *Sep 26 17:05:03.440: ppp514 PPP: Using vpn set call direction
    *Sep 26 17:05:03.440: ppp514 PPP: Treating connection as a callin
    *Sep 26 17:05:03.440: ppp514 PPP: Session handle[1D0005EB] Session id[514]
    *Sep 26 17:05:03.440: ppp514 LCP: Event[OPEN] State[Initial to Starting]
    *Sep 26 17:05:03.441: ppp514 PPP LCP: Enter passive mode, state[Stopped]
    *Sep 26 17:05:04.522: ppp514 LCP: I CONFREQ [Stopped] id 180 len 10
    *Sep 26 17:05:04.522: ppp514 LCP:    MagicNumber 0x0669ECAE (0x05060669ECAE)
    *Sep 26 17:05:04.522: ppp514 LCP: O CONFREQ [Stopped] id 1 len 18
    *Sep 26 17:05:04.522: ppp514 LCP:    MRU 1492 (0x010405D4)
    *Sep 26 17:05:04.522: ppp514 LCP:    AuthProto PAP (0x0304C023)
    *Sep 26 17:05:04.522: ppp514 LCP:    MagicNumber 0x6ABFFB9F (0x05066ABFFB9F)
    *Sep 26 17:05:04.522: ppp514 LCP: O CONFACK [Stopped] id 180 len 10
    *Sep 26 17:05:04.522: ppp514 LCP:    MagicNumber 0x0669ECAE (0x05060669ECAE)
    *Sep 26 17:05:04.522: ppp514 LCP: Event[Receive ConfReq+] State[Stopped to ACKsent]
    *Sep 26 17:05:04.525: ppp514 LCP: I CONFACK [ACKsent] id 1 len 18
    *Sep 26 17:05:04.526: ppp514 LCP:    MRU 1492 (0x010405D4)
    *Sep 26 17:05:04.526: ppp514 LCP:    AuthProto PAP (0x0304C023)
    *Sep 26 17:05:04.526: ppp514 LCP:    MagicNumber 0x6ABFFB9F (0x05066ABFFB9F)
    *Sep 26 17:05:04.526: ppp514 LCP: Event[Receive ConfAck] State[ACKsent to Open]
    *Sep 26 17:05:04.528: ppp514 PPP: Queue PAP code[1] id[15]
    *Sep 26 17:05:04.529: ppp514 PPP: Phase is AUTHENTICATING, by this end
    *Sep 26 17:05:04.529: ppp514 PAP: Redirect packet to ppp514
    *Sep 26 17:05:04.529: ppp514 PAP: I AUTH-REQ id 15 len 31 from "[email protected]"
    *Sep 26 17:05:04.529: ppp514 PAP: Authenticating peer [email protected]
    *Sep 26 17:05:04.529: ppp514 PPP: Phase is FORWARDING, Attempting Forward
    *Sep 26 17:05:04.529: ppp514 LCP: State is Open
    *Sep 26 17:05:05.553: ppp514 PPP: Phase is AUTHENTICATING, Unauthenticated User
    *Sep 26 17:05:05.553: ppp514 PPP: Sent PAP LOGIN Request
    *Sep 26 17:05:05.584: ppp514 PPP: Received LOGIN Response PASS
    *Sep 26 17:05:05.584: ppp514 PPP: Phase is FORWARDING, Attempting Forward
    *Sep 26 17:05:05.594: Vi3 PPP: Phase is AUTHENTICATING, Authenticated User
    *Sep 26 17:05:05.594: Vi3 PAP: O AUTH-ACK id 15 len 5
    *Sep 26 17:05:05.595: Vi3 PPP: Phase is UP
    *Sep 26 17:05:05.595: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to up
    *Sep 26 17:05:05.596: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to up
    *Sep 26 17:05:05.606: Vi3 IPCP: I CONFREQ [UNKNOWN] id 44 len 22
    *Sep 26 17:05:05.606: Vi3 IPCP:    Address 0.0.0.0 (0x030600000000)
    *Sep 26 17:05:05.606: Vi3 IPCP:    PrimaryDNS 0.0.0.0 (0x810600000000)
    *Sep 26 17:05:05.606: Vi3 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)
    *Sep 26 17:05:05.606: Vi3 LCP: O PROTREJ [Open] id 2 len 28 protocol IPCP
    *Sep 26 17:05:05.606: Vi3 LCP: (0x012C0018030600000000810600000000)
    *Sep 26 17:05:05.606: Vi3 LCP: (0x830600000000)
    *Sep 26 17:05:05.607: Vi3 IPV6CP: I CONFREQ [UNKNOWN] id 26 len 14
    *Sep 26 17:05:05.607: Vi3 IPV6CP:    Interface-Id 5421:6C1B:5DCE:401A (0x010A54216C1B5DCE401A)
    *Sep 26 17:05:05.607: Vi3 LCP: O PROTREJ [Open] id 3 len 20 protocol IPV6CP (0x011A0010010A54216C1B5DCE401A) debugging w/o ip:vrf-id=CV_VRF w/o ip:ip-unnumbered
    *Sep 26 17:13:12.424: Vi3 PPP DISC: Lower Layer disconnected
    *Sep 26 17:13:12.424: Vi3 PPP: Sending Acct Event[Down] id[5FE]
    *Sep 26 17:13:12.425: PPP: NET STOP send to AAA.
    *Sep 26 17:13:12.425: Vi3 LCP: O TERMREQ [Open] id 4 len 4
    *Sep 26 17:13:12.425: Vi3 LCP: Event[CLOSE] State[Open to Closing]
    *Sep 26 17:13:12.425: Vi3 PPP: Phase is TERMINATING
    *Sep 26 17:13:12.426: Vi3 PPP: Block vaccess from being freed [0x10]
    *Sep 26 17:13:12.426: Vi3 LCP: Event[DOWN] State[Closing to Initial]
    *Sep 26 17:13:12.428: Vi3 PPP: Unlocked by [0x10] Still Locked by [0x0]
    *Sep 26 17:13:12.428: Vi3 PPP: Free previously blocked vaccess
    *Sep 26 17:13:12.428: Vi3 PPP: Phase is DOWN
    *Sep 26 17:13:12.429: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to down
    *Sep 26 17:13:12.430: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to down
    *Sep 26 17:13:18.485: PPP: Alloc Context [38E95CFC]
    *Sep 26 17:13:18.485: ppp515 PPP: Phase is ESTABLISHING
    *Sep 26 17:13:18.486: ppp515 PPP: Using vpn set call direction
    *Sep 26 17:13:18.486: ppp515 PPP: Treating connection as a callin
    *Sep 26 17:13:18.486: ppp515 PPP: Session handle[AC0005EC] Session id[515]
    *Sep 26 17:13:18.486: ppp515 LCP: Event[OPEN] State[Initial to Starting]
    *Sep 26 17:13:18.486: ppp515 PPP LCP: Enter passive mode, state[Stopped]
    *Sep 26 17:13:19.572: ppp515 LCP: I CONFREQ [Stopped] id 181 len 10
    *Sep 26 17:13:19.572: ppp515 LCP:    MagicNumber 0x171E542B (0x0506171E542B)
    *Sep 26 17:13:19.572: ppp515 LCP: O CONFREQ [Stopped] id 1 len 18
    *Sep 26 17:13:19.572: ppp515 LCP:    MRU 1492 (0x010405D4)
    *Sep 26 17:13:19.572: ppp515 LCP:    AuthProto PAP (0x0304C023)
    *Sep 26 17:13:19.572: ppp515 LCP:    MagicNumber 0x6AC78AB2 (0x05066AC78AB2)
    *Sep 26 17:13:19.572: ppp515 LCP: O CONFACK [Stopped] id 181 len 10
    *Sep 26 17:13:19.572: ppp515 LCP:    MagicNumber 0x171E542B (0x0506171E542B)
    *Sep 26 17:13:19.572: ppp515 LCP: Event[Receive ConfReq+] State[Stopped to ACKsent]
    *Sep 26 17:13:19.576: ppp515 LCP: I CONFACK [ACKsent] id 1 len 18
    *Sep 26 17:13:19.576: ppp515 LCP:    MRU 1492 (0x010405D4)
    *Sep 26 17:13:19.576: ppp515 LCP:    AuthProto PAP (0x0304C023)
    *Sep 26 17:13:19.576: ppp515 LCP:    MagicNumber 0x6AC78AB2 (0x05066AC78AB2)
    *Sep 26 17:13:19.576: ppp515 LCP: Event[Receive ConfAck] State[ACKsent to Open]
    *Sep 26 17:13:19.579: ppp515 PPP: Queue PAP code[1] id[16]
    *Sep 26 17:13:19.601: ppp515 PPP: Phase is AUTHENTICATING, by this end
    *Sep 26 17:13:19.601: ppp515 PAP: Redirect packet to ppp515
    *Sep 26 17:13:19.601: ppp515 PAP: I AUTH-REQ id 16 len 31 from "[email protected]"
    *Sep 26 17:13:19.601: ppp515 PAP: Authenticating peer [email protected]
    *Sep 26 17:13:19.601: ppp515 PPP: Phase is FORWARDING, Attempting Forward
    *Sep 26 17:13:19.601: ppp515 LCP: State is Open
    *Sep 26 17:13:20.625: ppp515 PPP: Phase is AUTHENTICATING, Unauthenticated User
    *Sep 26 17:13:20.625: ppp515 PPP: Sent PAP LOGIN Request
    *Sep 26 17:13:20.650: ppp515 PPP: Received LOGIN Response PASS
    *Sep 26 17:13:20.650: ppp515 PPP: Phase is FORWARDING, Attempting Forward
    *Sep 26 17:13:20.657: Vi3 PPP: Phase is AUTHENTICATING, Authenticated User
    *Sep 26 17:13:20.657: Vi3 PAP: O AUTH-ACK id 16 len 5
    *Sep 26 17:13:20.658: Vi3 PPP: Phase is UP
    *Sep 26 17:13:20.658: Vi3 IPCP: Protocol configured, start CP. state[Initial]
    *Sep 26 17:13:20.658: Vi3 IPCP: Event[OPEN] State[Initial to Starting]
    *Sep 26 17:13:20.658: Vi3 IPCP: O CONFREQ [Starting] id 1 len 10
    *Sep 26 17:13:20.658: Vi3 IPCP:    Address 199.200.107.1 (0x0306C7C86B01)
    *Sep 26 17:13:20.658: Vi3 IPCP: Event[UP] State[Starting to REQsent]
    *Sep 26 17:13:20.658: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to up
    *Sep 26 17:13:20.660: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to up
    *Sep 26 17:13:20.666: Vi3 IPCP: I CONFREQ [REQsent] id 45 len 22
    *Sep 26 17:13:20.666: Vi3 IPCP:    Address 0.0.0.0 (0x030600000000)
    *Sep 26 17:13:20.666: Vi3 IPCP:    PrimaryDNS 0.0.0.0 (0x810600000000)
    *Sep 26 17:13:20.666: Vi3 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)
    *Sep 26 17:13:20.666: Vi3 IPCP AUTHOR: Start.  Her address 0.0.0.0, we want 0.0.0.0
    *Sep 26 17:13:20.666: Vi3 IPCP AUTHOR: Done.  Her address 0.0.0.0, we want 0.0.0.0
    *Sep 26 17:13:20.666: Vi3 IPCP: Pool returned 199.200.107.20
    *Sep 26 17:13:20.667: Vi3 IPCP: O CONFNAK [REQsent] id 45 len 22
    *Sep 26 17:13:20.667: Vi3 IPCP:    Address 199.200.107.20 (0x0306C7C86B14)
    *Sep 26 17:13:20.667: Vi3 IPCP:    PrimaryDNS 208.98.188.81 (0x8106D062BC51)
    *Sep 26 17:13:20.667: Vi3 IPCP:    SecondaryDNS 8.8.8.8 (0x830608080808)
    *Sep 26 17:13:20.667: Vi3 IPCP: Event[Receive ConfReq-] State[REQsent to REQsent]
    *Sep 26 17:13:20.667: Vi3 IPV6CP: I CONFREQ [UNKNOWN] id 27 len 14
    *Sep 26 17:13:20.667: Vi3 IPV6CP:    Interface-Id 096D:2933:E6FE:523D (0x010A096D2933E6FE523D)
    *Sep 26 17:13:20.667: Vi3 LCP: O PROTREJ [Open] id 2 len 20 protocol IPV6CP (0x011B0010010A096D2933E6FE523D)
    *Sep 26 17:13:20.668: Vi3 IPCP: I CONFACK [REQsent] id 1 len 10
    *Sep 26 17:13:20.668: Vi3 IPCP:    Address 199.200.107.1 (0x0306C7C86B01)
    *Sep 26 17:13:20.668: Vi3 IPCP: Event[Receive ConfAck] State[REQsent to ACKrcvd]
    *Sep 26 17:13:20.672: Vi3 IPCP: I CONFREQ [ACKrcvd] id 46 len 22
    *Sep 26 17:13:20.672: Vi3 IPCP:    Address 199.200.107.20 (0x0306C7C86B14)
    *Sep 26 17:13:20.672: Vi3 IPCP:    PrimaryDNS 208.98.188.81 (0x8106D062BC51)
    *Sep 26 17:13:20.672: Vi3 IPCP:    SecondaryDNS 8.8.8.8 (0x830608080808)
    *Sep 26 17:13:20.672: Vi3 IPCP: O CONFACK [ACKrcvd] id 46 len 22
    *Sep 26 17:13:20.672: Vi3 IPCP:    Address 199.200.107.20 (0x0306C7C86B14)
    *Sep 26 17:13:20.672: Vi3 IPCP:    PrimaryDNS 208.98.188.81 (0x8106D062BC51)
    *Sep 26 17:13:20.672: Vi3 IPCP:    SecondaryDNS 8.8.8.8 (0x830608080808)
    *Sep 26 17:13:20.672: Vi3 IPCP: Event[Receive ConfReq+] State[ACKrcvd to Open]
    *Sep 26 17:13:20.689: Vi3 IPCP: State is Open
    *Sep 26 17:13:20.691: %FMANRP_ESS-4-FULLVAI: Session creation failed due to Full Virtual-Access Interfaces not being supported. Check that all applied Virtual-Template and RADIUS features support Virtual-Access sub-interfaces. swidb= 0x41F07370, ifnum= 22
    *Sep 26 17:13:20.691: Vi3 Added to neighbor route AVL tree: topoid 0, address 199.200.107.20
    *Sep 26 17:13:20.691: Vi3 IPCP: Install route to 199.200.107.20
    *Sep 26 17:13:20.693: Vi3 PPP DISC: Lower Layer disconnected
    *Sep 26 17:13:20.693: Vi3 PPP: Sending Acct Event[Down] id[5FF]
    *Sep 26 17:13:20.693: PPP: NET STOP send to AAA.
    *Sep 26 17:13:20.694: Vi3 IPCP: Event[DOWN] State[Open to Starting]
    *Sep 26 17:13:20.694: Vi3 IPCP: Event[CLOSE] State[Starting to Initial]
    *Sep 26 17:13:20.694: Vi3 LCP: O TERMREQ [Open] id 3 len 4
    *Sep 26 17:13:20.694: Vi3 LCP: Event[CLOSE] State[Open to Closing]
    *Sep 26 17:13:20.694: Vi3 PPP: Phase is TERMINATING
    *Sep 26 17:13:20.695: Vi3 PPP: Block vaccess from being freed [0x10]
    *Sep 26 17:13:20.695: Vi3 Deleted neighbor route from AVL tree: topoid 0, address 199.200.107.20
    *Sep 26 17:13:20.695: Vi3 IPCP: Remove route to 199.200.107.20
    *Sep 26 17:13:20.696: Vi3 LCP: Event[DOWN] State[Closing to Initial]
    *Sep 26 17:13:20.696: Vi3 PPP: Unlocked by [0x10] Still Locked by [0x0]
    *Sep 26 17:13:20.696: Vi3 PPP: Free previously blocked vaccess
    *Sep 26 17:13:20.696: Vi3 PPP: Phase is DOWN
    *Sep 26 17:13:20.696: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to down
    *Sep 26 17:13:20.698: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to down

  • Problem with Embedded Event Manager and Object Tracking

    Hi,
    I have a 2801 running c2801-advipservicesk9-mz.124-24.T2.bin. It has the following configuration:
    track 300 list boolean or
    object 10
    object 11
    object 12
    object 13
    event manager applet clear_ipsec_tunnel
    event track 300 state down
    action 1.0 cli command "enable"
    action 2.0 cli command "clear crypto session"
    action 3.0 syslog msg "IPSec tunnel has been cleared by clear_ipsec_tunnel applet"
    My problem is that after the tracked object number 300 transitions from an up state to a down state, nothing happens. It seems like the applet doesn't work with object tracking. Here's what I see in logs:
    Dec  7 21:52:32.236 MCK: %TRACKING-5-STATE: 12 ip sla 12 reachability Up->Down
    Dec  7 21:52:37.236 MCK: %TRACKING-5-STATE: 13 ip sla 13 reachability Up->Down
    Dec  7 21:52:57.236 MCK: %TRACKING-5-STATE: 10 ip sla 10 reachability Up->Down
    Dec  7 21:53:07.236 MCK: %TRACKING-5-STATE: 11 ip sla 11 reachability Up->Down
    Dec  7 21:53:07.996 MCK: %TRACKING-5-STATE: 300 list boolean or Up->Down
    That's it. For some reason, the applet won't execute the CLI commands when the EEM applet is triggered. Am I doing something wrong or I have encountered some bug? Thanks.

    jclarke,
    Today I added the router into the tacacs server database and the applet started working just fine by using my login name. So the working configuration looks like this:
    event manager session cli username "my login name"
    event manager applet clear_ipsec_tunnel
    event track 300 state down maxrun 30
    action 1.0 cli command "enable"
    action 2.0 cli command "clear crypto session"
    action 3.0 syslog msg "IPSec tunnel has been cleared by clear_ipsec_tunnel applet"
    Then I tried to use a login name from the local database that has "privelege 15" access and of course the debug output showed me this:
    Dec  8 18:12:58.203 MCK: %TRACKING-5-STATE: 300 list boolean or Up->Down
    Dec  8 18:12:58.203 MCK: fh_track_object_changed: Track notification 300 state down
    Dec  8 18:12:58.203 MCK: fh_fd_track_event_match: track ED pubinfo enqueue rc = 0
    Dec  8 18:12:58.215 MCK: fh_send_track_fd_msg: msg_type=64
    Dec  8 18:12:58.215 MCK: fh_send_track_fd_msg: sval=0
    Dec  8 18:12:58.219 MCK: %HA_EM-6-LOG: clear_ipsec_tunnel : DEBUG(cli_lib) : : CTL : cli_open called.
    Dec  8 18:12:58.227 MCK: %HA_EM-6-LOG: clear_ipsec_tunnel : DEBUG(cli_lib) : : OUT : Router>
    Dec  8 18:12:58.227 MCK: %HA_EM-6-LOG: clear_ipsec_tunnel : DEBUG(cli_lib) : : IN  : Router>enable
    Dec  8 18:12:58.747 MCK: %HA_EM-6-LOG: clear_ipsec_tunnel : DEBUG(cli_lib) : : OUT : Command authorization failed.
    Dec  8 18:12:58.747 MCK: %HA_EM-6-LOG: clear_ipsec_tunnel : DEBUG(cli_lib) : : OUT :
    Dec  8 18:12:58.747 MCK: %HA_EM-6-LOG: clear_ipsec_tunnel : DEBUG(cli_lib) : : OUT : Router>
    Dec  8 18:12:58.747 MCK: %HA_EM-6-LOG: clear_ipsec_tunnel : DEBUG(cli_lib) : : IN  : Router>clear crypto session
    Dec  8 18:12:58.771 MCK: %HA_EM-6-LOG: clear_ipsec_tunnel : DEBUG(cli_lib) : : OUT :                                  ^
    Dec  8 18:12:58.771 MCK: %HA_EM-6-LOG: clear_ipsec_tunnel : DEBUG(cli_lib) : : OUT : % Invalid input detected at '^' marker.
    Dec  8 18:12:58.771 MCK: %HA_EM-6-LOG: clear_ipsec_tunnel : DEBUG(cli_lib) : : OUT :
    Dec  8 18:12:58.771 MCK: %HA_EM-6-LOG: clear_ipsec_tunnel : DEBUG(cli_lib) : : OUT : Router>
    Dec  8 18:12:58.775 MCK: %HA_EM-6-LOG: clear_ipsec_tunnel: IPSec tunnel has been cleared by clear_ipsec_tunnel  applet
    Dec  8 18:12:58.775 MCK: %HA_EM-6-LOG: clear_ipsec_tunnel : DEBUG(cli_lib) : : CTL : cli_close called.
    So I guess this problem arises when you have command authorization enabled and the tacacs server is not reachable or something like that. I have tried to find a way to use the local database instead of using the aaa server but didn't succeed. Although I have found an interesting workaround. Here it is:
    Link: http://blog.ioshints.info/2007/05/command-authorization-fails-with-eem.html
    Workaround found after reading the "Executing IOS commands from Tcl shell" from the "Tclsh on Cisco IOS tutorial".
    On the above article it is mentionned that the ios_config command is executed inside the context of another VTY line (also found with the AAA debug). The workaround is to define the FIRST VTY line with "transport input none" to prevent ssh or telnet to grab it and to configure the aaa authorization without any command authorization for this line.
    Kind regards
    Christian Chautems
    Looks great, but I am not quite sure how to "configure the aaa authorization without any command authorization for this line".
    Anyway, jclarke thank you so much for taking your time to look into my problem and for your help.

  • ASR 1002 inter-chassis redundancy

    Can anyone tell me which licence is required to create inter-chassis redundancy between 2 ASR 1002 routers?
    I don't need NAT/ Firewall features. I want redundancy only for ip data. As i have read on Cisco sites it is mentioned that we require licence for NAT/Firewall features. If i don't require these features is there any need for any particular licence or not?
    Regards,
    Mukesh Kumar
    Network Engineer
    Spooster IT Services

    Hello Leo Laohoo
    I know Rahul Chhabra. But my answer is not there where you told me to go.
    As you told him to use HSRP, we don't want to use this protocol. Because this is configured on the interface level. If we will use this protocol we need the same number of ip addresses as the interfaces we are having on the routers. Thats why we prefer Inter-chassis Hardware Redundancy between 2 ASR 1002 routers, in this case we require only two IP addresses for the both the routers.
    Now i want to know that we want to enable only routing on the ASR routers, for this do we need any license or not. If yes then which one license we have to purchase?
    If not then please tell me the link from where have you seen that we don't require any link.
    Regards,
    Mukesh Kumar
    Network Engineer
    Spooster IT Services

  • Entity object track changes "Modified by"

    Hi Experts,
    I have a question about entity object track changes. I change enabled one entity object attribute to track change "Modified by".
    However whenever the DB changes occurs then the Modified column is updated, however the name is the database connection user name. How can i override that value during the record update. Do i need to set any DbTransaction.session environment variable to save that in the db/
    - t

    Sorry for the late reply,
    I tried this but no luck. Can anyone let me know how to change the entity history columns values like modified by user name. etc....
    - t

  • NAT on ASR-1002

    Hello,
    Does anyone who uses NAT/PAT (nat overload) limit the max number of NAT translations that any one internal IP address can have?  We have had issues where people do port scans and utilise a large majority of our NAT pool.  We are doing NAT on a ASR 1002 with an ESP5.  It can do up to 250,000 NAT translations total and 50,000 new a second.  
    Now I found out that the ASR in a pool will only use the last available IP to do PAT.. The rest of the IP addresses are used for 1-1 NAT.
    Here is our NAT config
    > ip nat translation tcp-timeout 1800
    > ip nat translation udp-timeout 1800
    > ip nat translation max-entries 250000
    > ip nat pool Level3Pool some-ip-address some-ip-address netmask 255.255.255.248
    > ip nat inside source list NAT pool Level3Pool overload
    Any idea about: 
    ip nat settings mode cgn
    ip nat settings mode cgn
    Thanks

    Firewall or NAT: 250,000 sessions and 50,000 sessions-per-sec setup rate
    This is from the datasheet. Pls check.
    Table 3. Cisco ASR 1000 Series 5-Gbps ESP Module Performance and Scaling
    Regards
    Durga Prasad - Datasoft Comnet
    Pls rate helpful posts
    Sent from Cisco Technical Support Android App

  • ASR 1002-X, IOS XE and ISG

    Hello All.
    I started using asr 1002-x with IOS XE instead of 7201 as ISG + AAA + RADIUS.
    I had a question on IOS XE 3.11, 3.10, 3.9.
    Command "radius-server vsa send ..."  is in a configuration, however it isn't applied and doesn't appear in running-config.
    cod-r8(config)#radius-server vsa send?
      accounting Send in accounting requests
      authentication Send in access requests
      cisco-nas-port Send cisco-nas-port VSA (2)
      <cr>
    cod-r8(config)#radius-server vsa send accounting 
    cod-r8(config)#radius-server vsa send authentication           
    cod-r8(config)#radius-server vsa send cisco-nas-port
    cod-r8(config)#do sh run | include vsa
    radius-server vsa send cisco-nas-port</cr>
    It turns out that vsa is included by default or doesn't work at all?
    Thanks.
    Konstantin

    Hi Konstantin,
    Regarding "It is strange that these commands cleaned from sh run view.": this is normal for many default configuration commands.
    Mine is a lab device so I cannot really comment on stability or provide you a recommendation based on that. However, I see that the download section from Cisco.com mentiones the following release as the recommended based on quality, stability and longevity:
    asr1002x-universal.03.07.04a.S.152-4.S4a.SPA.bin
    The best would be for you to check this with yor cisco Account Team or Advanced Services Team as normally they are the proper point of contacts for SW advisory.
    Regards.

  • ASR 1002 current license for LNS router ???

    hi i want to ask about ASR 1002 license for LNS router .
    i want to know how many pppoe session can handle without any license
    i mean wts the current  sessions allowed on the current router
    and wt other options i have to upgrade this router so that it support more sessions and its prices.
    regards

    here is my current router :
    Gateway-ASR1002#sh inventory 
    NAME: "Chassis", DESCR: "Cisco ASR1002 Chassis"
    PID: ASR1002           , VID: V06, SN: FOX1807GBZW
    NAME: "module F0", DESCR: "Cisco ASR1000 Embedded Services Processor, 5Gbps"
    PID: ASR1000-ESP5      , VID: V04, SN: JAE18110AU1
    NAME: "Power Supply Module 0", DESCR: "Cisco ASR1002 AC Power Supply"
    PID: ASR1002-PWR-AC    , VID: V03, SN: ART1804U03P
    NAME: "Power Supply Module 1", DESCR: "Cisco ASR1002 AC Power Supply"
    PID: ASR1002-PWR-AC    , VID: V03, SN: ART1804U05H
    NAME: "module 0", DESCR: "Cisco ASR1002 SPA Interface Processor 10"
    PID: ASR1002-SIP10     , VID:    , SN:            
    NAME: "SPA subslot 0/0", DESCR: "4-port Gigabit Ethernet Shared Port Adapter"
    PID: 4XGE-BUILT-IN     , VID:    , SN:            
    NAME: "subslot 0/0 transceiver 0", DESCR: "GE T"
    PID: SFP-GE-T          , VID:     , SN: MTC1229019N     
    NAME: "subslot 0/0 transceiver 1", DESCR: "GE T"
    PID: SFP-GE-T          , VID:     , SN: MTC1231005A     
    NAME: "subslot 0/0 transceiver 2", DESCR: "GE T"
    PID: SFP-GE-T          , VID:     , SN: MTC1229019M     
    NAME: "module R0", DESCR: "Cisco ASR1002 Route Processor 1"
    PID: ASR1002-RP1       , VID: V06, SN: JAE18110F7G
    Gateway-ASR1002#

  • Reliable Static Routing Backup Using Object Tracking

    Can someone confirm if Reliable Static Routing Using Object Tracking is supported on the Cisco 3850 switch running IOS-XE?  If so, does it require IP Services licensing or will IP Base suffice?
    If it is not supported on the 3850, what about the 3750X running IOS?  Again, would it require IP Services licensing?                  

    Hello
    CCO seems to suggest it does
    http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipapp/configuration/xe-3se/3850/iap-xe-3se-3850-book.pdf#page21
    Res
    Paul
    Sent from Cisco Technical Support iPad App

  • ASR 1002 license

    Hello,
    we got  a new cisco ASR 1002 ,does it require a license to work as BRAS?? 
    Thnx

    Yes, it does.
    The feature licenses for ASR1K can be viewed at Table 2 on the URL http://www.cisco.com/en/US/prod/collateral/routers/ps9343/product_bulletin_c25-448292.html
    You would need a license to enable broadband (FLASR1-BB-RTU) and another license with the appropriate number of sessions.
    Cheers

  • CoPP on ASR 1002-X

    Hello,
    I'm trying to create CoPP on ASR 1002-X. I've created several base classess for different kinds of traffic I'm expecting to see.
    This works fine, OSPF, HSRP, ARP, BFD packets are going to their respective classes. But there are still some packets that fall to class-default.
    I've used "debug platform software infrastructure punt packet" to find out what packets are punted to the CPU.
    There is one that I'm not sure how to deal with. It's called "RP <-> QFP keepalive". Should I include it in CoPP? If so, how can I match it?
    Thanks.

    Hi Blaz,
    In the debugs, I still see Framed-Compression attribute in the access-accept sent from radius:
    Mar 19 11:22:37.737: RADIUS:  Framed-Compression  [13]  6   None                      [0]
    Changing the compression from "Van-Jacobsen-TCP-IP" to 'None' is not enough. You need to remove the Framed-Compression attribute completely from the radius profile for the subscriber.
    Could you try that?
    Regards

Maybe you are looking for

  • How to perform a clean install of Mountain Lion on MBA without usb?

    I purchased a new MBA last November and I want to perform a clean install of Mountain Lion (for various reasons), however, the MBA didn't come with an install usb drive from Apple.  When I go to the app store it says I need to buy the OS even though

  • Itunes will open on vista, but then is completely locked.

    My daughter's vista laptop will open itunes, but then it is completely frozen. mouse clicking, keyboarding, and scrolling do not work. It also does not recognize her iPod. I have to close it with the task manager. It has worked previously and she has

  • How to create new agent types  in transaction CBIH92.

    Hi guru's, Can anybody tell me how i can create new agent types . thanks and regards, Pronoy.

  • Rewriting a select statement containing a correlated subquery

    Hi, I would like to rewrite the statement below to improve it's performance. Is it possible? *SELECT DISTINCT A.FIELD1           ,A.FIELD2           ,A.FIELD3           ,A.FIELD4           ,A.DATE_FIELD1           ,(SELECT SUM(B.NUMBER_FIELD1)       

  • MalformedRequest - Enterprise Portal

    When provisioning UME Groups from GRC 5.3 AC CUP SP11 to the same java instance where GRC is installed, I periodically notice that the Group does not get provisioned. The CUP request is processed without any header errors but when I review the detail