Assigning a URI to a jsp client

Hi
I am trying to proxy a message from my OC client to a jsp client. My proxy servlet registers the URI I am supposed to fwd my message to.
I am not sure if I can assign a URI to my jsp client, and if yes, how?
If not, is there any other way for me to proxy it? I have been able to proxy stuff to an OC client, based on the sip addess, eg. sip:[email protected]:5064; by configuring the sip.xml and using "proxy.proxyTo(xxxxx)"
Some of my code is as follows...
***************ProxyServlet code***********************
package oracle.sdp.proxy;
import java.io.IOException;
import javax.servlet.ServletConfig;
import javax.servlet.ServletException;
import javax.servlet.sip.Proxy;
import javax.servlet.sip.SipFactory;
import javax.servlet.sip.SipServlet;
import javax.servlet.sip.SipServletRequest;
import javax.servlet.sip.SipServletResponse;
import javax.servlet.sip.URI;
@SuppressWarnings("serial")
public class ProxyServlet extends SipServlet
     private URI mForwardUri;
     private URI mForwardUri1;
     private URI mForwardUri2;
     private SipFactory getSipFactory() {
     return (SipFactory) getServletContext()
     .getAttribute(SipServlet.SIP_FACTORY);
     protected void doMessage(SipServletRequest request) throws ServletException,IOException
     log("Received: " + request.getMethod() + " Content: "+ request.getContent());
     try
          ServletConfig config = getServletConfig();
          String forwardUri = config.getInitParameter("forwardAddress");
          mForwardUri = getSipFactory().createURI(forwardUri);
          String forwardUri1 = config.getInitParameter("forwardAddress1");
          mForwardUri1 = getSipFactory().createURI(forwardUri1);
          String forwardUri2 = config.getInitParameter("forwardAddress2");
          mForwardUri2 = getSipFactory().createURI(forwardUri2);
     catch (NumberFormatException e)
     try
     Proxy proxy = request.getProxy();
     proxy.cancel();
     SipServletResponse resp = proxy.getOriginalRequest().createResponse(SipServletResponse.SC_CALL_BEING_FORWARDED, "Forward message to " + mForwardUri);
     resp.send();
     proxy.proxyTo(mForwardUri);//this forwards to OC1 client
     proxy.proxyTo(mForwardUri1);//this forwards to OC2 client
     proxy.proxyTo(mForwardUri2);//this forwards to FinalMessage.java, which is a Recepient servlet
          request.getSession().getApplicationSession().invalidate();
     catch (java.io.IOException ioe)
     log("Failed to send response", ioe);
********sip.xml for proxyservlet*********************
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE sip-app
PUBLIC "-//Java Community Process//DTD SIP Application 1.0//EN"
"http://www.jcp.org/dtd/sip-app_1_0.dtd">
<sip-app>
     <display-name>SIP Servlet Application</display-name>
<servlet>
<servlet-name>ProxyServlet</servlet-name>
<servlet-class>
oracle.sdp.proxy.ProxyServlet
</servlet-class>
<init-param>
<param-name>forwardAddress</param-name>
<param-value>sip:[email protected]:5064</param-value>
</init-param>
<init-param>
<param-name>forwardAddress1</param-name>
<param-value>sip:[email protected]:5062</param-value>
</init-param>
<init-param>
<param-name>forwardAddress2</param-name>
<param-value>sip:@127.0.0.1:5060;transport=tcp;appId=FinalMessage</param-value>
</init-param>
<load-on-startup/>
</servlet>
<servlet-mapping>
<servlet-name>ProxyServlet</servlet-name>
<pattern>
<equal>
<var>request.method</var>
<value>MESSAGE</value>
</equal>
</pattern>
</servlet-mapping>
</sip-app>
Please guide me.
Thanks,
A

The URI has to be of the form
sip:127.0.0.1;transport=xxxx;appId=xxx;
This solved the issue.

Similar Messages

  • How can i assign a Javascript variable to JSP variable

    Hi guys
    how i can assign a javascript variable to jsp expression.,
    e.g.,
    <input type = "button" value = "Add more" onclick = "return submitform1('<%=s%>')">
    function submitform1(String s)
          var s1 = s
    document.form1.action = "../intimation.do";    /* Here i want to pass the value s1 to jsp or servlets without using hidden fields and Query string*/
           document.form1.submit();
          return false;
    /*  i want to pass the values thru session whether it is possible */
    pls give sample code
    Reply
    Marimuthu

    You don't have the session.
    All you have is HTTP.
    The only way to communicate from the client to the server is via an HTTP request. The only way to send a value like that is with a parameter.
    Using a form with method="submit" as mentioned will pass the parameters without displaying them in the url bar (is that what you wanted?)

  • URI:/OA_HTML/AppsLocalLogin.jsp Exception java.lang.NoclassDefFound error

    Hi,
    Users are getting Request URI:/OA_HTML/AppsLocalLogin.jsp Exception java.lang.NoclassDefFoundError error, when they are trying to login to EBS,
    They cleared Cache at browser level and Cleared Cache Jinitiator, Do i need to check anything else
    EBS version is : 11i.
    OS : Linux

    Sawwan,
    We have not made changes .
    client denied by server configuration: /u09/dev/comn/java/oracle/jdbc
    [Mon Jan 18 14:38:45 2010] [error] client denied by server configuration: /u09/dev/comn/java/oracle/jdbc
    [Mon Jan 18 14:41:39 2010] [error] client denied by server configuration: /u09/dev/comn/java/java
    [Mon Jan 18 14:41:39 2010] [error] client denied by server configuration: /u09/dev/comn/java/java
    [[Mon Jan 18 14:41:42 2010] [error] File does not exist: /u09/dev/comn/java/log4j.xml
    [Mon Jan 18 14:41:42 2010] [error] File does not exist: /u09/dev/comn/java/log4j.xml
    [Mon Jan 18 14:41:42 2010] [error] File does not exist: /u09/dev/comn/java/log4j.properties
    [Mon Jan 18 14:41:42 2010] [error] File does not exist: /u09/dev/comn/java/log4j.properties
    Edited by: HumanDBA on Jan 18, 2010 11:48 AM

  • JSP client in RMI system - java.rmi.UnmarshalException: error unmarshalling

    Hi,
    Im developing a login part for a distributed airline reservation system using JSP as the client but while executing the jsp, the error that is being catched is :
    java.rmi.UnmarshalException: error unmarshalling return; nested exception is: java.lang.ClassNotFoundException: AirlineImpl_Stub (no security manager: RMI class loader disabled)
    Here are my codes:
    //Interface - Airline.java
    package Air;
    import java.rmi.*;
    public interface Airline extends Remote
         public int CheckUname(String username) throws RemoteException;
    }//implementation - AirlineImpl.java
    import java.net.*;
    import java.io.*;
    import java.sql.*;
    import java.rmi.*;
    import java.rmi.server.UnicastRemoteObject;
    public class AirlineImpl extends UnicastRemoteObject implements Airline
         public AirlineImpl() throws RemoteException
              super();
         public int CheckUname(String username) throws RemoteException
              try
                   int UnameCount = 0;
                   String xxx = "eaglebeta";
                   if(username.equals(xxx)
                        UnameCount++;
                   return UnameCount;
              catch (Exception e3)
                   System.out.println("Error: " + e3);
                   return 0;
    }//Server - AirlineServer.java
    import java.rmi.*;
    import java.rmi.server.UnicastRemoteObject;
    public class AirlineServer
         public static void main(String arg[])
              try
                   Airline myAirline = new AirlineImpl();
                   Naming.rebind("Airline", myAirline);
                   System.out.println();
                   System.out.println("************************************");
                   System.out.println(" >>> Airline Reservation System <<< ");
                   System.out.println("    >>> Server is Listening! <<<    ");
                   System.out.println("************************************");
                   System.out.println();
              catch (RemoteException e)
                   //System.out.println("Error: " + e);
                   System.out.println("RMI Registry is not active!");
                   System.out.println("Activate RMI Registry and retry!");
                   System.out.println("Bye bye, exiting...");
              catch (java.net.MalformedURLException e)
                   //System.out.println("URL Error: "+ e);
                   System.out.println("URL Malformed!");
                   System.out.println("Bye bye, exiting...");
    }//JSP client - newuser.jsp
    <%@ page contentType="text/html; charset=iso-8859-1" language="java" import="java.sql.*" errorPage="" %>
    <%@ page import="java.rmi.*, javax.servlet.*" %>
    <%@ page import="java.util.*, java.lang.*, java.io.*, Air.Airline" %>
    <html>
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    </head>
    <body bgcolor="#99CCFF">
    <%
    Object Airline = null;
    try
    Airline Air = (Airline)Naming.lookup("rmi://localhost/Airline");
    String Name = "eaglebeta";
    if(Air.CheckUname(Name)>0)
         %>
              Username already exists, choose another name
         <%
    else
         %>
         <%=Name%>
         <%
    catch (Exception e1)
    %>
    <%=e1%>
    <%
    %>
    </body>
    </html>The server, implementation, interface and stub are in a folder named "Airline Server" located on my desktop.
    The interface and stub again are in another folder named "Air" located in the "classes\Air" directory which is located in the tomcat 5.5 installation directory!
    The JSP client is located in the "Root" folder in the tomcat 5.5 installation derectory!
    1. I start the registry in the "Airline Server" folder by typing rmiregistry
    2. Load the Airline Server - java AirlineServer
    3. Call the jsp - http://localhost/newuser.jsp
    And i get the following error:
    java.rmi.UnmarshalException: error unmarshalling return; nested exception is: java.lang.ClassNotFoundException: AirlineImpl_Stub (no security manager: RMI class loader disabled)
    Please help me to solve this problem!

    When I am including security manager in my JSP code, the browser just get blank without any display
    if(System.getSecurityManager() == null)
         System.setProperty("java.security.policy", "java.policy");
        System.setSecurityManager(new RMISecurityManager());
    }Please, someone solve my problem! Im realy stuck and I don't know how to proceed! Provide me with a solution or any tutorial that would help me...

  • Create a JSP client to access Web Services

    Hi,
    I am working on a JSP client in WL 8.1 to access a non-WebLogic web service, with it's WSDL URL. I am trying to run the sample code from the WebLogic web services web site in my JSP but am running into errors with the Service class from JAX-RPC. Here's my JSP code:
    <%@page contentType="text/html"
    import="java.net.URL, java.util.*, javax.xml.rpc.ServiceFactory, javax.xml.rpc.Service, javax.xml.rpc.*, javax.xml.rpc.Call, javax.xml.rpc.ParameterMode, javax.xml.namespace.QName, javax.xml.*"
    %>
    <%
    ServiceFactory factory = ServiceFactory.newInstance();
    // define qnames
    String targetNamespace = "http://www.themindelectric.com/" + "wsdl/net.xmethods.services.stockquote.StockQuote/";
    QName serviceName = new QName(targetNamespace, "net.xmethods.services.stockquote.StockQuoteService");
    QName portName = new QName(targetNamespace, "net.xmethods.services.stockquote.StockQuotePort");
    QName operationName = new QName("urn:xmethods-delayed-quotes", "getQuote");
    URL wsdlLocation = new URL("http://services.xmethods.net/soap/urn:xmethods-delayed-quotes.wsdl");
    // create service
    Service service = factory.createService(wsdlLocation, serviceName);
    // create call
    Call call = service.createCall(portName, operationName);
    // invoke the remote web service
    Float result = (Float) call.invoke(new Object[] { "BEAS" });
    //The result is <%= result %>
    %>
    <html>
    <body>
    testing the web service... <br>
    The result is <%= result %>
    </body>
    </html>
    And here's the error. I am not able to create the service using the "Service" class. Any idea what's wrong in my code and how to fix it? I am running it from my domain. Am I missing any JAR files or any CLASSPATH entries?
    Thanks in advance for your help.
    Error Message below:
    <Aug 26, 2005 2:53:25 PM CDT> <Error> <HTTP> <BEA-101020> <[ServletContext(id=33
    443136,name=repairApp,context-path=/repairApp)] Servlet failed with Exception
    javax.xml.rpc.JAXRPCException: failed to create service
    at weblogic.webservice.core.rpc.ServiceImpl.getWebService(ServiceImpl.ja
    va:118)
    at weblogic.webservice.core.rpc.ServiceFactoryImpl.createService(Service
    FactoryImpl.java:42)
    at jsp_servlet.__main._jspService(__main.java:150)
    at weblogic.servlet.jsp.JspBase.service(JspBase.java:33)
    at weblogic.servlet.internal.ServletStubImpl$ServletInvocationAction.run
    (ServletStubImpl.java:996)
    at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
    pl.java:419)
    at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
    pl.java:463)
    at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
    pl.java:315)
    at weblogic.servlet.internal.WebAppServletContext$ServletInvocationActio
    n.run(WebAppServletContext.java:6452)
    at weblogic.security.acl.internal.AuthenticatedSubject.doAs(Authenticate
    dSubject.java:321)
    at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:
    118)
    at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppSe
    rvletContext.java:3661)
    at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestIm
    pl.java:2630)
    at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219)
    at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178)
    Message was edited by:
    sri_bali
    Message was edited by:
    sri_bali
    Message was edited by:
    sri_bali

    Hi
    Were you able to resolve this issue. Can you email me on [email protected] for the same
    Thanks
    Shilpi

  • JSP client+EJB server

    I want to pass the data value from a jsp client (post method)and accept these values from a java server program.Java server program will accept these using getParameter .How this is achieved i am usingh weblogic as my server
    Thanks in advance

    Hi
    Even i have the same problem...
    i have deployed the ejb in jboss..
    but i cannot even run the core-java client program
    can u pls mail me the code...
    and the directory path
    thanks a lot
    cheers
    simreen

  • JSP Error:   Request URI:/OA_HTML/OA.jsp after RUP 7

    Good day,
    After successfully applying   6241631 (RUP7)
    I am getting this error after supplying username and password to enter the EBS homepage.
    JSP Error:
    Request URI:/OA_HTML/OA.jsp
    Exception:
    java.lang.NoSuchMethodError: oracle.apps.fnd.framework.webui.OAWebBeanMetaData.getStyle(Loracle/apps/fnd/framework/webui/OAPageContext;)Ljava/lang/String;
    I don't see anything in my log files to further explain this error nor on the web.
    OS: ORHEL 4
    DB:10Gr2
    Regards,
    Shridath.

    Good day Hussein,
    I am on 11.5.10.2.
    Patch and pre-reqs were applied successfully to the best of my knowledge. (I am not not ruling out the possibility of missing a pre-req patch)
    No errors in the database log file.
    select count(*)
    from dba_objects
    where status='INVALID';
    *356
    The file header
    $Header OAWebBeanMetaData.java 115.10 2001/09/21 14:36:56 pkm ship   $
    I have also reviewed the bugs stated in the documents, but none speaks specifically to my error.
    I am currently reviewing the compilation errors of the in the adworker logs.
    Regards,
    Shridath.

  • Exceptin while aceesing jsp client

    Hi All,
    I have deployed BI Beans JSP client on 9ias. When i try to access this application through internet explorer i got this exception:
    500 Internal Server Error
    java.lang.NoSuchMethodError
         at oracle.dss.addins.thin.common.BaseThinSession.setupBiCustomization(BaseThinSession.java:84)
         at oracle.dss.addins.jspTags.BIThinSessionTag.populateBIRenderingContext(BIThinSessionTag.java:246)
         at oracle.dss.addins.jspTags.BIThinSessionTag.doStartTag(BIThinSessionTag.java:128)
         at milk_proc._jspService(_milk__proc.java:70)
         [SRC:/milk_proc.jsp:8]
         at com.orionserver[Oracle9iAS (9.0.2.0.0) Containers for J2EE].http.OrionHttpJspPage.service(OrionHttpJspPage.java:56)
         at oracle.jsp.runtimev2.JspPageTable.service(JspPageTable.java:302)
         at oracle.jsp.runtimev2.JspServlet.internalService(JspServlet.java:407)
         at oracle.jsp.runtimev2.JspServlet.service(JspServlet.java:330)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:336)
         at com.evermind[Oracle9iAS (9.0.2.0.0) Containers for J2EE].server.http.ResourceFilterChain.doFilter(ResourceFilterChain.java:59)
         at oracle.security.jazn.oc4j.JAZNFilter.doFilter(JAZNFilter.java:283)
         at com.evermind[Oracle9iAS (9.0.2.0.0) Containers for J2EE].server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:523)
         at com.evermind[Oracle9iAS (9.0.2.0.0) Containers for J2EE].server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:269)
         at com.evermind[Oracle9iAS (9.0.2.0.0) Containers for J2EE].server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:735)
         at com.evermind[Oracle9iAS (9.0.2.0.0) Containers for J2EE].server.http.AJPRequestHandler.run(AJPRequestHandler.java:151)
         at com.evermind[Oracle9iAS (9.0.2.0.0) Containers for J2EE].util.ThreadPoolThread.run(ThreadPoolThread.java:64)
    I got this exception only for the first time i tried to run jsp client. when i refreshed the page, It is working perfectly fine.
    Can anyone please tell me why this is happening and what to do.
    thanks and regardS
    Mukesh Harjai

    problem solved. Actually i miss to comment library path tag in application.xml while creating a separate oc4j instance.
    Now i am facing another problem. When i click on the graph or table button in tools menu, I got this exception:
    java.lang.ClassCastException: oracle.dss.thin.beans.graph.ThinGraph
         at milk_proc._jspService(_milk__proc.java:179)
         [SRC:/milk_proc.jsp:36]
         at com.orionserver[Oracle9iAS (9.0.2.0.0) Containers for J2EE].http.OrionHttpJspPage.service(OrionHttpJspPage.java:56)
         at oracle.jsp.runtimev2.JspPageTable.service(JspPageTable.java:302)
         at oracle.jsp.runtimev2.JspServlet.internalService(JspServlet.java:407)
         at oracle.jsp.runtimev2.JspServlet.service(JspServlet.java:330)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:336)
         at com.evermind[Oracle9iAS (9.0.2.0.0) Containers for J2EE].server.http.ResourceFilterChain.doFilter(ResourceFilterChain.java:59)
         at oracle.security.jazn.oc4j.JAZNFilter.doFilter(JAZNFilter.java:283)
         at com.evermind[Oracle9iAS (9.0.2.0.0) Containers for J2EE].server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:523)
         at com.evermind[Oracle9iAS (9.0.2.0.0) Containers for J2EE].server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:269)
         at com.evermind[Oracle9iAS (9.0.2.0.0) Containers for J2EE].server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:735)
         at com.evermind[Oracle9iAS (9.0.2.0.0) Containers for J2EE].server.http.AJPRequestHandler.run(AJPRequestHandler.java:151)
         at com.evermind[Oracle9iAS (9.0.2.0.0) Containers for J2EE].util.ThreadPoolThread.run(ThreadPoolThread.java:64)
    What can be the reason for this.
    Any help is appreciated.
    Thanks and regards
    Mukesh Harjai

  • Assigning 2 DNS servers to VPN clients

    It seems like I can only assign 2 DNS servers to VPN clients using the "dns-server" command in config-group-policy? How do I go about assigning more than 2?
    what exactly does dns server-group do? Can I use that command to assign dns servers to vpn clients since I can add more than 2 dns servers?

    ciscoasa# sh run
    : Saved
    ASA Version 8.0(4)
    hostname ciscoasa
    enable password c.LHJMlCqC0Qvrsf encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    speed 100
    duplex full
    nameif outside
    security-level 0
    ip address extip 255.255.255.240
    interface Ethernet0/1
    speed 100
    duplex full
    nameif inside
    security-level 100
    ip address 172.17.193.100 255.255.255.0
    interface Ethernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface Ethernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    management-only
    boot config disk0:/exit
    ftp mode passive
    clock timezone mst -7
    clock summer-time mdt recurring
    dns domain-lookup inside
    dns server-group TA-UAT
    name-server 44.44.44.102
    domain-name ta.corp.adds
    access-list split_tunnel_list standard permit 172.17.193.0 255.255.255.0
    access-list split_tunnel_list standard permit 44.44.44.0 255.255.255.0
    access-list inside_nat0_outbound extended permit ip 172.17.193.0 255.255.255.0 192.168.20.0 255.255.255.0
    access-list inside_nat0_outbound extended permit ip 44.44.44.0 255.255.255.0 192.168.20.0 255.255.255.0
    access-list inbound_on_outside extended permit icmp any any
    access-list inbound_on_outside extended permit tcp any host extip eq 5555
    access-list inbound_on_outside extended permit tcp any host extip eq www
    pager lines 24
    logging enable
    logging asdm informational
    mtu outside 1500
    mtu inside 1500
    mtu management 1500
    ip local pool vpnuserspool 192.168.20.101-192.168.20.254 mask 255.255.255.0
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    icmp deny any outside
    asdm image disk0:/asdm-613.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 44.44.44.0 255.255.255.0
    nat (inside) 1 172.17.193.0 255.255.255.0
    static (inside,outside) tcp extip 5555 172.17.193.96 5555 netmask 255.255.255.255
    static (inside,outside) tcp extip www 172.17.193.1 www netmask 255.255.255.255
    access-group inbound_on_outside in interface outside
    route outside 0.0.0.0 0.0.0.0 extip 1
    route inside 44.44.44.0 255.255.255.0 172.17.193.1 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication ssh console LOCAL
    http server enable
    http 192.168.20.0 255.255.255.0 inside
    http 172.17.193.0 255.255.255.0 inside
    http 192.168.1.0 255.255.255.0 management
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set firstset esp-3des esp-md5-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map dyn1 1 set transform-set firstset
    crypto dynamic-map dyn1 1 set security-association lifetime seconds 28800
    crypto dynamic-map dyn1 1 set security-association lifetime kilobytes 4608000
    crypto dynamic-map dyn1 1 set reverse-route
    crypto map mymap 1 ipsec-isakmp dynamic dyn1
    crypto map mymap interface outside
    crypto isakmp enable outside
    crypto isakmp policy 1
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 43200
    crypto isakmp nat-traversal 3600

  • Problems running JSP Client for ApplicationModule

    Hi All,
    I'm still having trouble getting a simple JSP client up and running for an AppModule. The AppModule tests okay using the java client, but when I try to run the main.jsp for my Module, it starts up with the following error. I've tried building several projects and have had no success with JSP.
    Does this really work? Has anyone here successfully gotten a JSP Client running?
    Thanks,
    Rich
    AppAccelerator(tm) 1.1.8 for Java (JDK 1.1), x86 version.
    Copyright (c) 1997-1998 Borland International. All Rights Reserved.
    Copyright (c) 1997-1999 Oracle Corporation. All Rights Reserved.
    log3: oracle.jsp.runner.JspRunner: init
    log3: Loading from CLASSPATH backend_AppModule.properties
    log3: Diagnostics: Routing diagnostics to standard output (use -Djbo.debugoutput
    =silent to remove)
    [0] Diagnostic Properties: (from /oracle/jbo/common/Diagnostic.properties)log3:
    [1] Timing:false Functions:false Linecount:true Threshold:6log3:
    [2] CSMessageBundle (language base) being initializedlog3:
    log3: oracle.jbo.ApplicationModuleCreateException: JBO-25222: Unable to create a
    pplication module.
    log3: at oracle.jbo.server.ApplicationModuleHomeImpl.create(Compiled Code)
    log3: at oracle.jbo.common.appmgr.AppModuleInfo.getReservedAppModuleInstance(C
    ompiled Code)
    log3: at oracle.jbo.common.appmgr.AppRegistry.getAppModuleInstance(Compiled Co
    de)
    log3: at oracle.jbo.html.jsp.JSPApplicationRegistry.registerApplicationFromPro
    pertyFile(Compiled Code)
    log3: at oracle.jbo.html.jsp.JSPApplicationRegistry.registerApplicationFromPro
    pertyFile(Compiled Code)
    log3: at webapp1.main._jspService(main.jsp:7)
    log3: at oracle.jsp.runtime.HttpJsp.service(Compiled Code)
    log3: at oracle.jsp.runner.JspRunner.dispatch(Compiled Code)
    log3: at oracle.jsp.runner.JspRunner.service(Compiled Code)
    log3: at javax.servlet.http.HttpServlet.service(Compiled Code)
    log3: at oracle.lite.web.JupServlet.service(Compiled Code)
    log3: at oracle.lite.web.MimeServletHandler.handle(Compiled Code)
    log3: at oracle.lite.web.JupApplication.service(Compiled Code)
    log3: at oracle.lite.web.JupAppHandler.handle(Compiled Code)
    log3: at oracle.lite.web.HTTPServer.include(Compiled Code)
    log3: at oracle.lite.web.HTTPServer.forward(Compiled Code)
    log3: at oracle.lite.web.HTTPServer.handleRequest(Compiled Code)
    log3: at oracle.lite.web.JupServer.handle(Compiled Code)
    log3: at oracle.lite.web.JupHTTPListener$JupHTTP.run(Compiled Code)
    log3: oracle.lite.web.workspace.WorkSpaceDevel: init

    Is the Appmodule running locally or as EJB in Oracle8i.
    Unable to create appmodule genrally is result of not all the required libraries in classpath.
    If you have deployed as EJB then in the project properties make sure that JBOEJBCLIENT and EJBSTUBS(Generated during deployment) are on top of the list.
    If this is not the scenario, give more details on your env.
    raghu
    null

  • JSP client not Working

    Hi all
    I have made a simple webservice which retrives some fileds of a remote pointbase
    database.i have published this webservice in the uddiexplorer and generated the
    wsdl file for this webservice.
    now i made the proxies need by the client from the test browser's overview page
    to invoke this webservice,and also wrote the following JSP code to invoke the
    service.
    <!--Generated by WebLogic Workshop-->
    <%@ page language="java" contentType="text/html;charset=UTF-8"%>
    <%@ taglib uri="netui-tags-databinding.tld" prefix="netui-data"%>
    <%@ taglib uri="netui-tags-html.tld" prefix="netui"%>
    <%@ taglib uri="netui-tags-template.tld" prefix="netui-template"%>
    <%@ page import="weblogic.jws.proxies.*"%>
    <%@ page import="WebServices.Users"%>
    <netui:html>
    <head>
    <title>
    Hello World Client Accessing HelloWorld Service
    </title>
    </head>
    <body>
    <p>
    <h2 align="center">Username's and associated Passwords stored in the Remote
    Database, at 10.3.8.254</h2>
    <br>
    <table align="center" border=1>
    <tr>
    <td>USERNAME</td>
    <td>PASSWORD</td>
    </tr>
    <%
    HelloWorld_Impl proxy = new
    HelloWorld_Impl("http://10.3.8.227:7001/SOAPappWeb/WebServices
    /HelloWorldContract.wsdl");
    HelloWorldSoap soapProxy = proxy.getHelloWorldSoap();
    org.openuri.www.Users[] result;
    result=soapProxy.uselect();
    for (int i=0; i< soapProxy.uselect().length; i++)
    %>
    <tr>
    <td align="center"><B><%out.print(
    result.getUSERNAME());%></B></td>
    <td align="center"><I><%out.println(
    result[i].getPASSWORD());%></I></td>
    </tr>
    <%}%>
    </p>
    </body>
    </netui:html>
    now when i run this code on the machine where server is running i get the correct
    result.but when i put the associated proxies and this JSP code on different machine
    and try t orun this JSP i m not able to run it.it sometimes keeps on loading the
    page or sometimes it shows me an error saying wsdl
    weblogic.webservice.tools.wsdlp.WSDLParseException: Failed to retrieve WSDL from
    D:/bea/user_projects/Webservice4/Webservice4Web/WebServices/HelloworldContract.
    wsdl. Please check the URL and make sure that it is a valid XML file [java.io.IOE
    xception: unable to find resource:D:/bea/user_projects/Webservice4/Webservice4We
    b/WebServices/HelloworldContract.xml]
    the path D:/bea/user_projects/Webservice4/Webservice4Web/WebServices/HelloworldContract.wsdl
    is the path where i have downloaded the wsdl in to my local machine i.e the machine
    where the client is.
    hope u get wat i m trying to say
    waiting for response..thanks for sparing time on my doubt
    kirtan

    Hello,
    Just a shot in the dark, but the _Impl needs a URL to the WSDL.  In the
    JSP, did you try something like (note the ?WSDL at the end):
         http://10.3.8.227:7001/SOAPappWeb/WebServices/HelloWorldContract?WSDL
    Can you point your browser at this location and get the WSDL? If you
    are doing a local WSDL file, you might try something like:
    blabla_Impl(new File("whatever.wsdl").toURL().toString());
    Some thoughts,
    Bruce
    kirtan patel wrote:
    >
    Hi all
    I have made a simple webservice which retrives some fileds of a remote pointbase
    database.i have published this webservice in the uddiexplorer and generated the
    wsdl file for this webservice.
    now i made the proxies need by the client from the test browser's overview page
    to invoke this webservice,and also wrote the following JSP code to invoke the
    service.
    <!--Generated by WebLogic Workshop-->
    <%@ page language="java" contentType="text/html;charset=UTF-8"%>
    <%@ taglib uri="netui-tags-databinding.tld" prefix="netui-data"%>
    <%@ taglib uri="netui-tags-html.tld" prefix="netui"%>
    <%@ taglib uri="netui-tags-template.tld" prefix="netui-template"%>
    <%@ page import="weblogic.jws.proxies.*"%>
    <%@ page import="WebServices.Users"%>
    <netui:html>
    <head>
    <title>
    Hello World Client Accessing HelloWorld Service
    </title>
    </head>
    <body>
    <p>
    <h2 align="center">Username's and associated Passwords stored in the Remote
    Database, at 10.3.8.254</h2>
    <br>
    <table align="center" border=1>
    <tr>
    <td>USERNAME</td>
    <td>PASSWORD</td>
    </tr>
    <%
    HelloWorld_Impl proxy = new
    HelloWorld_Impl("http://10.3.8.227:7001/SOAPappWeb/WebServices
    /HelloWorldContract.wsdl");
    HelloWorldSoap soapProxy = proxy.getHelloWorldSoap();
    org.openuri.www.Users[] result;
    result=soapProxy.uselect();
    for (int i=0; i< soapProxy.uselect().length; i++)
    %>
    <tr>
    <td align="center"><B><%out.print(
    result.getUSERNAME());%></B></td>
    <td align="center"><I><%out.println(
    result[i].getPASSWORD());%></I></td>
    </tr>
    <%}%>
    </p>
    </body>
    </netui:html>
    now when i run this code on the machine where server is running i get the correct
    result.but when i put the associated proxies and this JSP code on different machine
    and try t orun this JSP i m not able to run it.it sometimes keeps on loading the
    page or sometimes it shows me an error saying wsdl
    weblogic.webservice.tools.wsdlp.WSDLParseException: Failed to retrieve WSDL from
    D:/bea/user_projects/Webservice4/Webservice4Web/WebServices/HelloworldContract.
    wsdl. Please check the URL and make sure that it is a valid XML file [java.io.IOE
    xception: unable to find resource:D:/bea/user_projects/Webservice4/Webservice4We
    b/WebServices/HelloworldContract.xml]
    the path D:/bea/user_projects/Webservice4/Webservice4Web/WebServices/HelloworldContract.wsdl
    is the path where i have downloaded the wsdl in to my local machine i.e the machine
    where the client is.
    hope u get wat i m trying to say
    waiting for response..thanks for sparing time on my doubt
    kirtan

  • How do I change the assigned site code on a REMOTE client via WMI (C#)?

    Hi
    I was wondering if it is possible to change the site code on a client remotely via WMI. I have found one or two links to this, eg
    http://msdn.microsoft.com/en-us/library/jj874135.aspx
    and
    http://social.technet.microsoft.com/Forums/systemcenter/en-US/67b671bb-4819-4e7a-a4f6-6cb7ded17722/sccm-2007-change-assigned-site-code-on-clients?forum=configmgrgeneral
    However none of these will allow me to change it remotely directly from my machine. I have written a tool which fixes many issues but having difficulty with this one. In the past I have even resorted to copying a script remotely to an affected machine then
    setting a remote scheduled task which executes the script. This was effective but very dirty! I find it difficult to believe there is no way to do this directly but can't seem to find anything suggesting it is possible.
    Before anyone replies with a 'what are you trying to achieve...' type answer, I have a similar situation to that of the guy in the second link but I would like something more instant.
    Many thanks

    psexec or winrm will allow you to do this.
    Jason | http://blog.configmgrftw.com

  • Assigning value to proc_name in MT client

    Hello everyone,
    I'm wondering how one is supposed to assign a value to proc_name (for later use
    by userlog()) in a multi-threaded client?
    Would each thread (context) have to set it up? Or just the first one?
    Are there any other "gotchas" with userlog() in a threaded client?
    Many thanks in advance,
    /Per

    I think proc_name is a process defined variable, so you only need to set it
    up once in a process and
    it should best be done before userlog() is called the first time.
    /Lars
    "Per Lindström" <[email protected]> wrote in message
    news:3da321c5$[email protected]..
    >
    Hello everyone,
    I'm wondering how one is supposed to assign a value to proc_name (forlater use
    by userlog()) in a multi-threaded client?
    Would each thread (context) have to set it up? Or just the first one?
    Are there any other "gotchas" with userlog() in a threaded client?
    Many thanks in advance,
    /Per

  • OSB WSDL invocation from java /jsp client!

    Hi ,
    I did a sample work on invoking osb wsdl(based on DB adapter) from a java/jsp application.It worked fine!
    Its a simple select query wth parameter that was configured in my DB adapter.
    Below are the steps I follow -
    a.Created a DB adapter for collective response
    b.created BS out of jca
    c.Generated PS based on above BS.
    d.Performed some xquery tranformation in PS message flow response piepeline.
    e.Exported WSDL and tested it in SOAP UI ,getting the transformed response as required.
    When we generate Java client out of above WSDL in Eclipse ,it generates client for DB data,transformed data fields are not seen -How to obtain transformed data too through Java client?will this work ?
    Is it gud practice to generate java client directly n Eclipse (OEPE) or do we have any other alternative ways to generate Java client out of OSB WSDL?
    Please assist.
    Thanks,
    Ani

    Hi Anuj-
    My proxy was generated out of business ,i get 2 wsdl like master-child .Master wsdl holds referecnce to child wsdl.I hope wsdl generation is fine.
    When i invoke the proxy wsdl url from Java client ,i get below error -
    Exception in thread "main" AxisFault
    faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
    faultSubcode:
    faultString: org.xml.sax.SAXException: Invalid element in com.oracle.xmlns.pcbpel.adapter.db.PhysicalTampered_Meter.PhysicalTampered_MeterOutput - PhysicalTampered
    faultActor:
    faultNode:
    faultDetail:
         {http://xml.apache.org/axis/}stackTrace:org.xml.sax.SAXException: Invalid element in com.oracle.xmlns.pcbpel.adapter.db.PhysicalTampered_Meter.PhysicalTampered_MeterOutput - PhysicalTampered
         at org.apache.axis.encoding.ser.BeanDeserializer.onStartChild(BeanDeserializer.java:258)
         at org.apache.axis.encoding.DeserializationContext.startElement(DeserializationContext.java:1035)
         at org.apache.axis.message.SAX2EventRecorder.replay(SAX2EventRecorder.java:165)
         at org.apache.axis.message.MessageElement.publishToHandler(MessageElement.java:1141)
         at org.apache.axis.message.RPCElement.deserialize(RPCElement.java:236)
         at org.apache.axis.message.RPCElement.getParams(RPCElement.java:384)
         at org.apache.axis.client.Call.invoke(Call.java:2467)
         at org.apache.axis.client.Call.invoke(Call.java:2366)
         at org.apache.axis.client.Call.invoke(Call.java:1812)
         at com.oracle.xmlns.pcbpel.adapter.db.CoreAnalytics.PhysicalTampered_Meter.PhysicalTampered_Meter.PhysicalTampered_Meter_pttBindingStub.physicalTampered_Meter(PhysicalTampered_Meter_pttBindingStub.java:175)
         at Client.JavaClient.main(JavaClient.java:25)
         {http://xml.apache.org/axis/}hostname:B7B-3F-149-4HJV

  • Assigned a QoS profile based on client identity

    A client can be assigned a QoS profile based on its identity, through AAA, but how?

    You need a RADIUS server.
    Make sure the AAA override is enabled on the WLAN then try to use the folloiwng RADIUS attribute on the RADIUS server:
    RADIUS-Cisco Airespace -> Airespace-QOS-Level
    return the value of the QOS level in this attribute to the usres based on their identity.
    HTH
    Amjad
    p.s: never tried the above. so tell us if it worked correctly with you.
    Rating useful replies is more useful than saying "Thank you"

Maybe you are looking for

  • Milestone based billing in OM-AR or PA - Help needed

    Hello, need your valuable suggestion to identify the best approach, including modules, for the following business scenario with Minimum Customization. Business A directly receives orders/ contracts from customers. Business A does not manufacture any

  • Display repository content in Database Studio

    Hello We just started using Database Studio, upgrading from Database Manager.  We are trying to review the contents of the repositories like we were able to do with SQL Studio.  Have been looking thorugh all the data on line and have not found anythi

  • BEA webservice client has problem in talking to secured microsoft webservic

    Hi, I am developing a BEA client (standalone java client using BEA 10 MP1 install) to invoke a microsoft secured webservice which requires a X509 token in the request. I am able to invoke the service successfully but can not validate the response whi

  • Photoshop on creative cloud

    i cannot download photoshop. all items say install, photoshop says up to date? purchased subscription to creative cloud, when in adope manager photoshop is only item on list I cannot install, its states up to date?

  • How to automate backup in Max DB

    Hi All, I am using Maxdb.I would like to know is there any way to automate backup in maxdb(Like scheduling the backup at a perticular time) can any one of you help in this regard.I am using windows o/s and maxdb. Thanks in advance. Thanks Venu