Assignment % String sx = % search goes wrong

Hello,
I have the following JavaScript function in my JSP:
On Button click
( <INPUT type="button" name="Search" value="Search for Service" onclick="searchService(document.myform.Keyword.value);"></TD> )
the function searchService is called:
<SCRIPT language="JavaScript">
function searchService(s) {
     var search = s;
     <% String sx = %> search;
     var output = "<%= agent.searchForService(sx).elementAt(0)%>";
</SCRIPT>
How can I assign <% String sx = %> search; ?
The error message I get is: incompatible type for declaration. Can't convert void to java.lang.String.
String sx = ^ 1 error
Can anybody help me out please?
Thanks
Simone

Think of the transaction of processing a JSP page as server-side, client-side and a long pipe in between (the http connection).
First the server-side stuff is executed on the server, then the result is sent down the pipe and then the client-side stuff is executed on the client.
If you want client-side stuff to change the server-side execution, you will need to do a round trip back to the server - i.e. post the data to another (or the same) JSP in order to continue processing.
Sometimes it helps to think of this process as above in order to clarify the timing of when things happen.
Hope that helped.

Similar Messages

  • Upgrading to iPhoto '08 - what's going wrong with my iphoto Library

    Hi,
    I would appreciate your advice/knowledge on this problem.
    ==> Short Description of my problem:
    I can't recover the keywords associated with my pictures. I am asked to import my pictures although I choose to open my previous iPhoto Library after converting to iPhoto 08.
    ==> What I did:
    1. I recently upgraded my mac to Leopard, and then to iPhoto'08. When opening for the 1st time iPhoto '08, I selected my iPhoto Library (as I held the option key while opening iPhoto).
    2. I then get the message: “The photo library needs to be upgraded to work with this version of iPhoto. Your photo library will not be readable by previous versions of iPhoto after the upgrade. The upgrade process may take several minutes depending on the number of photos in the library.” I clicked on the "Upgrade" button
    3. My Mac then loaded/created ALL my previous albums and smart albums (including the most recent ones). It loaded pictures up to April 2005. BUT then, it prompted me with the following message : "5584 photos have been found in the iPhoto Library that are not a part of this photo library. Would you like to import them?". I was surprised to get this message, as I read that the upgrade should run smoothly.
    4. I made two tests, following this prompt. First, I answered "YES". I ended with a 24.5 GB iPhoto Library (instead of my previous 12.64 GB library). Then, while repeating steps 2&3, I answered No. I then decided to import manually my missing pictures, and ended up with a 14,4 GB (surprisingly, I got events called originals that contained same pictures than other created events). I have repeated the steps 2 to 4 from a new user account, but got the same results.
    5. None of these solutions are satisfactory as I had assigned keywords to my 5000+ photo. What is going wrong? Here is the content of my iPhoto Library (before conversion), if this is of any help:
    In my iPhoto Library Oct 23, 2007:
    folder 2000 Oct 18, 2007
    folder 2004 Feb 13, 2005
    folder 2005 Jan 29, 2006
    folder 2006 Jan 7, 2007
    folder 2007 Oct 23, 2007
    AlbumData.xml Apr 17, 2005
    folder Album Nov 11, 2007
    Dir.data Apr 9, 2005
    iPod Photo cache Nov 11, 2006
    iPhoto.db Apr 17, 2005
    Library.iPhoto Apr 9, 2005
    Thumb32.data Apr 9, 2005
    Thumb64.data Apr 9, 2005
    ThumbJPG Apr 9, 2005
    This library is an external-drive backup copy of my HD photo library (that no longer exists).
    ==> What to do next?
    1. How to check if my keywords information is still present in my original iPhoto library? Is there any solution to get back my photo with their keywords?
    2. Manage my iPhoto library with a smaller quantity of pictures, to ease backup and conversion. I have understood that iPhoto Libray Manager is a convenient free software to merge/de-merge libraries. Is that correct?
    Thanks for your help,
    Nicolas

    NicoSou
    This sounds to me like your v5 library is corrupted.
    Try using the rebuild command from iPhoto Library Manager to recreate the library - it won't get everything, but should get albums and keywords. Read the iPhoto Library Manager Help for more details.
    Regards
    TD

  • Does anybody know if Windows 8 is causing a problem with iTunes?   Many songs on my old iPod are now missing in my iTunes library and I can't find them anywhere.  Also, I have a new iPod and am afraid of using it for fear of something else going wrong.

    Does anybody know if Windows 8 is causing a problem with iTunes?  Many songs on my old iPod are now missing in my iTunes library and I can't find them anywhere.  .  Also, I have a new iPod and am afraid of using it for fear of something else going wrong.

    Try assigning Queen as the Album Artist on the compilations in iTunes on your computer.

  • Can some body tell me where my code is going wrong

    I have been trying to print a jTextArea and have been having trouble. Can some body look at my code and tell me where I am going wrong please, Thank You.
    I have pasted the code below. P.S. I have only attempted to print the jTextArea I have not done anything else. The program was written in the hope that I could learn how to print a jTextArea and no other function in an aim to transfer the successful code to other applications that I enter information into the jTextArea.
    * print.java
    * Created on 05 August 2007, 23:34
    package my.print;
    * @author morgan
    import java.awt.print.*;
    public class print extends javax.swing.JFrame {
    /** Creates new form print */
    public print() {
    initComponents();
    /** This method is called from within the constructor to
    * initialize the form.
    * WARNING: Do NOT modify this code. The content of this method is
    * always regenerated by the Form Editor.
    // <editor-fold defaultstate="collapsed" desc=" Generated Code ">
    private void initComponents() {
    jScrollPane1 = new javax.swing.JScrollPane();
    jTextArea1 = new javax.swing.JTextArea();
    jButton1 = new javax.swing.JButton();
    setDefaultCloseOperation(javax.swing.WindowConstants.EXIT_ON_CLOSE);
    jTextArea1.setColumns(20);
    jTextArea1.setRows(5);
    jScrollPane1.setViewportView(jTextArea1);
    jButton1.setText("jButton1");
    jButton1.addActionListener(new java.awt.event.ActionListener() {
    public void actionPerformed(java.awt.event.ActionEvent evt) {
    jButton1ActionPerformed(evt);
    javax.swing.GroupLayout layout = new javax.swing.GroupLayout(getContentPane());
    getContentPane().setLayout(layout);
    layout.setHorizontalGroup(
    layout.createParallelGroup(javax.swing.GroupLayout.Alignment.LEADING)
    .addGroup(layout.createSequentialGroup()
    .addGap(88, 88, 88)
    .addComponent(jScrollPane1, javax.swing.GroupLayout.PREFERRED_SIZE, javax.swing.GroupLayout.DEFAULT_SIZE, javax.swing.GroupLayout.PREFERRED_SIZE)
    .addPreferredGap(javax.swing.LayoutStyle.ComponentPlacement.RELATED)
    .addComponent(jButton1)
    .addContainerGap(67, Short.MAX_VALUE))
    layout.setVerticalGroup(
    layout.createParallelGroup(javax.swing.GroupLayout.Alignment.LEADING)
    .addGroup(layout.createSequentialGroup()
    .addGap(95, 95, 95)
    .addGroup(layout.createParallelGroup(javax.swing.GroupLayout.Alignment.LEADING)
    .addComponent(jButton1)
    .addComponent(jScrollPane1, javax.swing.GroupLayout.PREFERRED_SIZE, javax.swing.GroupLayout.DEFAULT_SIZE, javax.swing.GroupLayout.PREFERRED_SIZE))
    .addContainerGap(109, Short.MAX_VALUE))
    pack();
    }// </editor-fold>
    private void jButton1ActionPerformed(java.awt.event.ActionEvent evt) {
    try {
    jTextArea1.print();
    } catch (java.awt.print.PrinterException exc) { // ... }
    * @param args the command line arguments
    public static void main(String args[]){
    java.awt.EventQueue.invokeLater(new Runnable() {
    public void run() {
    new print().setVisible(true);
    // Variables declaration - do not modify
    private javax.swing.JButton jButton1;
    private javax.swing.JScrollPane jScrollPane1;
    private javax.swing.JTextArea jTextArea1;
    // End of variables declaration
    }

    sorry i hope that this preserves the code.
    * print.java
    * Created on 05 August 2007, 23:34
    package my.print;
    * @author  morgan
    import java.awt.print.*;
    public class print extends javax.swing.JFrame {
        /** Creates new form print */
        public print() {
                initComponents();
        /** This method is called from within the constructor to
         * initialize the form.
         * WARNING: Do NOT modify this code. The content of this method is
         * always regenerated by the Form Editor.
        // <editor-fold defaultstate="collapsed" desc=" Generated Code ">
        private void initComponents() {
            jScrollPane1 = new javax.swing.JScrollPane();
            jTextArea1 = new javax.swing.JTextArea();
            jButton1 = new javax.swing.JButton();
            setDefaultCloseOperation(javax.swing.WindowConstants.EXIT_ON_CLOSE);
            jTextArea1.setColumns(20);
            jTextArea1.setRows(5);
            jScrollPane1.setViewportView(jTextArea1);
            jButton1.setText("jButton1");
            jButton1.addActionListener(new java.awt.event.ActionListener() {
                public void actionPerformed(java.awt.event.ActionEvent evt) {
                    jButton1ActionPerformed(evt);
            javax.swing.GroupLayout layout = new javax.swing.GroupLayout(getContentPane());
            getContentPane().setLayout(layout);
            layout.setHorizontalGroup(
                layout.createParallelGroup(javax.swing.GroupLayout.Alignment.LEADING)
                .addGroup(layout.createSequentialGroup()
                    .addGap(88, 88, 88)
                    .addComponent(jScrollPane1, javax.swing.GroupLayout.PREFERRED_SIZE, javax.swing.GroupLayout.DEFAULT_SIZE, javax.swing.GroupLayout.PREFERRED_SIZE)
                    .addPreferredGap(javax.swing.LayoutStyle.ComponentPlacement.RELATED)
                    .addComponent(jButton1)
                    .addContainerGap(67, Short.MAX_VALUE))
            layout.setVerticalGroup(
                layout.createParallelGroup(javax.swing.GroupLayout.Alignment.LEADING)
                .addGroup(layout.createSequentialGroup()
                    .addGap(95, 95, 95)
                    .addGroup(layout.createParallelGroup(javax.swing.GroupLayout.Alignment.LEADING)
                        .addComponent(jButton1)
                        .addComponent(jScrollPane1, javax.swing.GroupLayout.PREFERRED_SIZE, javax.swing.GroupLayout.DEFAULT_SIZE, javax.swing.GroupLayout.PREFERRED_SIZE))
                    .addContainerGap(109, Short.MAX_VALUE))
            pack();
        }// </editor-fold>
        private void jButton1ActionPerformed(java.awt.event.ActionEvent evt) {
    try {
        jTextArea1.print();
    } catch (java.awt.print.PrinterException exc) { // ... }
         * @param args the command line arguments
        public static void main(String args[]){
            java.awt.EventQueue.invokeLater(new Runnable() {
                 public void run() {
                    new print().setVisible(true);
        // Variables declaration - do not modify
        private javax.swing.JButton jButton1;
        private javax.swing.JScrollPane jScrollPane1;
        private javax.swing.JTextArea jTextArea1;
        // End of variables declaration
        }The preview looked correct. Thank you for the URL. I have been writting my program in netbeans 5.5.1. unfortunately it simplifies the code that you have to put in but at the same time it makes it difficult to follow code examples that are intended to develope the whole of the code from scratch. I have tried looking at the netbeans guidance documentation but find that it doesn't always work even when I follow the direct code for the demonstrations. Anyway thanks for the guidance and for getting back to me so soon.

  • What is going wrong with this config ??

    Hello guys,
    I am busting my head to find out what is going wrong with this config and cant figure it out since i am not an advanced cisco technician.
    Problem is that i cant access the 94.70.142.127 server that is supposed to be in a DMZ zone.
    I know it is a bit chaotic but would really appreciate any help since i am running on a deadline.
    I am building the config step by step and although it seems to be working access to the server all of the sudden is denied.
    No idea if its a NAT issue a firewall issue or a security audit issue.
    There are 3 vlans.
    Vlan 1 is the inside network.
    Vlan 2 is the DMZ server
    Vlan 3 is the Management Network.
    thanks in advance
    Building configuration...
    Current configuration : 11796 bytes
    ! Last configuration change at 11:28:33 PCTime Fri Jan 4 2013 by admin
    ! NVRAM config last updated at 11:27:51 PCTime Fri Jan 4 2013 by admin
    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime
    service password-encryption
    service sequence-numbers
    hostname R1
    boot-start-marker
    boot-end-marker
    security authentication failure rate 3 log
    security passwords min-length 8
    logging message-counter syslog
    logging buffered 4096 informational
    enable secret 5 $1$oT7y$BwhdEjMJfAaTQI3dzDVwP.
    no aaa new-model
    memory-size iomem 10
    clock timezone PCTime 2
    clock summer-time PCTime date Mar 30 2003 3:00 Oct 26 2003 4:00
    crypto pki trustpoint TP-self-signed-2567543707
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-2567543707
    revocation-check none
    rsakeypair TP-self-signed-2567543707
    crypto pki certificate chain TP-self-signed-2567543707
    certificate self-signed 01
      30820244 308201AD A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 32353637 35343337 3037301E 170D3133 30313032 30383431
      35335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 35363735
      34333730 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100ABA4 B7FFF4F1 9FBE79D8 2CEBCA68 A14BE3AB DBF770C2 EB35A954 B271AE3E
      F8485837 F2E8566B 66E5EF6B BCFCDFA3 8F6F91F3 FD8E3015 879A67F5 85DD95F5
      C26875C0 2202CA6C CE95888F 545AB4F6 6F708A0E C65E78D1 60967480 5589F5EE
      80505E46 8767CE2C 37C994FE AB555AF0 BA4C4679 63FF7641 34FFF6EF 3EC38006
      46B90203 010001A3 6C306A30 0F060355 1D130101 FF040530 030101FF 30170603
      551D1104 10300E82 0C52312E 646F636E 65742E67 72301F06 03551D23 04183016
      8014F0DE 85318FB3 70C36B4A FEB4B0CA 446025F0 329C301D 0603551D 0E041604
      14F0DE85 318FB370 C36B4AFE B4B0CA44 6025F032 9C300D06 092A8648 86F70D01
      01040500 03818100 5D76D5F4 5FB659C3 1E5B3777 420E1703 CD019889 AE79390D
      A2AA4D26 AD9913B4 B3292277 97ACACDD D7093465 78279B4D 5FAC0A21 EFBF3B74
      6A25BC5B ACFB648F 08F92678 00BB495C 037DEAF7 C5910944 3D2C0643 EA19E9BD
      0AFE5423 AADBB3C2 B2C94296 DABE0D3D 6438F7A8 32B0A92B 3E8E0D26 635070A3
      ACF87E49 65A9E468
          quit
    no ip source-route
    ip cef
    no ip bootp server
    ip domain name docnet.gr
    ip name-server 195.170.0.1
    no ipv6 cef
    username admin privilege 15 view root secret 5 $1$Lny5$et1FhWOpIKOOYRUtN89H10
    archive
    log config
      hidekeys
    ip tcp synwait-time 10
    ip ssh version 2
    class-map type inspect match-any WebService
    match protocol http
    match protocol https
    class-map type inspect match-all sdm-cls-sdm-pol-NATOutsideToInside-1-1
    match class-map WebService
    match access-group name WebServer
    class-map type inspect match-all ccp-cls-sdm-pol-NATOutsideToInside-1-1
    match access-group name Spoofing
    class-map type inspect match-any CCP-Voice-permit
    match protocol h323
    match protocol skinny
    match protocol sip
    class-map type inspect match-any tcp-udp
    match protocol http
    match protocol https
    match protocol dns
    match protocol icmp
    class-map type inspect match-all ccp-cls--3
    match access-group name mng-out
    match class-map tcp-udp
    class-map type inspect match-all ccp-cls--2
    match access-group name mng-self
    class-map type inspect match-all ccp-cls--4
    match access-group name mng-out-drop
    class-map type inspect match-any ccp-cls-insp-traffic
    match protocol cuseeme
    match protocol dns
    match protocol ftp
    match protocol h323
    match protocol https
    match protocol icmp
    match protocol imap
    match protocol pop3
    match protocol netshow
    match protocol shell
    match protocol realmedia
    match protocol rtsp
    match protocol smtp extended
    match protocol sql-net
    match protocol streamworks
    match protocol tftp
    match protocol vdolive
    match protocol tcp
    match protocol udp
    class-map type inspect match-all ccp-insp-traffic
    match class-map ccp-cls-insp-traffic
    class-map type inspect match-any http-https-DMZ
    match protocol http
    match protocol https
    class-map type inspect match-all sdm-cls--2
    match class-map http-https-DMZ
    match access-group name web_server
    class-map type inspect match-any MySQLService
    match protocol mysql
    class-map type inspect match-all sdm-cls--1
    match class-map MySQLService
    match access-group name DMZtoMySQL
    class-map type inspect match-any ccp-cls-icmp-access
    match protocol icmp
    match protocol tcp
    match protocol udp
    class-map type inspect match-all ccp-icmp-access
    match class-map ccp-cls-icmp-access
    class-map type inspect match-all ccp-invalid-src
    match access-group 100
    class-map type inspect match-all sdm-nat-https-1
    match access-group 102
    match protocol https
    class-map type inspect match-all ccp-protocol-http
    match protocol http
    policy-map type inspect ccp-permit-icmpreply
    class type inspect ccp-icmp-access
      inspect
    class class-default
      pass
    policy-map type inspect sdm-pol-NATOutsideToInside-1
    class type inspect ccp-cls-sdm-pol-NATOutsideToInside-1-1
      drop
    class type inspect sdm-cls-sdm-pol-NATOutsideToInside-1-1
      inspect
    class type inspect sdm-nat-https-1
      inspect
    class class-default
      drop
    policy-map type inspect ccp-inspect
    class type inspect ccp-invalid-src
      drop log
    class type inspect ccp-protocol-http
      inspect
    class type inspect ccp-insp-traffic
      inspect
    class type inspect CCP-Voice-permit
      inspect
    class class-default
      drop
    policy-map type inspect ccp-permit
    class class-default
      drop
    policy-map type inspect sdm-policy-sdm-cls--1
    class type inspect sdm-cls--1
      inspect
    class class-default
      drop
    policy-map type inspect ccp-policy-ccp-cls--1
    class class-default
      drop
    policy-map type inspect ccp-policy-ccp-cls--3
    class type inspect ccp-cls--3
      inspect
    class class-default
      drop
    policy-map type inspect sdm-policy-sdm-cls--2
    class type inspect sdm-cls--2
      inspect
    class class-default
      drop
    policy-map type inspect ccp-policy-ccp-cls--2
    class type inspect ccp-cls--2
      inspect
    class class-default
      drop
    policy-map type inspect ccp-policy-ccp-cls--5
    class class-default
      drop
    zone security out-zone
    zone security in-zone
    zone security dmz-zone
    zone security mng
    zone-pair security ccp-zp-self-out source self destination out-zone
    service-policy type inspect ccp-permit-icmpreply
    zone-pair security sdm-zp-NATOutsideToInside-1 source out-zone destination in-zone
    service-policy type inspect sdm-pol-NATOutsideToInside-1
    zone-pair security ccp-zp-in-out source in-zone destination out-zone
    service-policy type inspect ccp-inspect
    zone-pair security ccp-zp-out-self source out-zone destination self
    service-policy type inspect ccp-permit
    zone-pair security zp-dmz-to-outside source dmz-zone destination out-zone
    service-policy type inspect ccp-inspect
    zone-pair security zp-outside-to-dmz source out-zone destination dmz-zone
    service-policy type inspect sdm-pol-NATOutsideToInside-1
    zone-pair security sdm-zp-dmz-zone-in-zone source dmz-zone destination in-zone
    service-policy type inspect sdm-policy-sdm-cls--1
    zone-pair security sdm-zp-in-zone-dmz-zone source in-zone destination dmz-zone
    service-policy type inspect sdm-policy-sdm-cls--2
    zone-pair security sdm-zp-dmz-zone-self source dmz-zone destination self
    service-policy type inspect ccp-policy-ccp-cls--1
    zone-pair security sdm-zp-mng-self source mng destination self
    service-policy type inspect ccp-policy-ccp-cls--2
    zone-pair security sdm-zp-mng-out-zone source mng destination out-zone
    service-policy type inspect ccp-policy-ccp-cls--3
    zone-pair security sdm-zp-out-zone-mng source out-zone destination mng
    service-policy type inspect ccp-policy-ccp-cls--5
    interface Null0
    no ip unreachables
    interface BRI0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    encapsulation hdlc
    shutdown
    isdn termination multidrop
    interface ATM0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    no atm ilmi-keepalive
    interface ATM0.1 point-to-point
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    pvc 8/35
      pppoe-client dial-pool-number 1
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    switchport access vlan 3
    spanning-tree portfast
    interface FastEthernet3
    switchport access vlan 2
    interface Vlan1
    description $FW_INSIDE$
    ip address 192.168.0.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly
    zone-member security in-zone
    ip tcp adjust-mss 1412
    interface Vlan2
    description $FW_INSIDE$
    ip address 192.168.1.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly
    zone-member security dmz-zone
    interface Vlan3
    description $FW_INSIDE$
    ip address 10.0.10.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly
    zone-member security mng
    interface Dialer0
    description $FW_OUTSIDE$
    ip address negotiated
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1452
    ip flow ingress
    ip nat outside
    ip virtual-reassembly max-reassemblies 64
    zone-member security out-zone
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname [email protected]
    ppp chap password 7 0918425001505245
    ppp pap sent-username [email protected] password 7 13511B4B1359417D
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip route 10.0.10.0 255.255.255.0 Vlan3
    no ip http server
    ip http secure-server
    ip nat inside source list 1 interface Dialer0 overload
    ip nat inside source static 192.168.0.101 94.70.142.113
    ip nat inside source static 192.168.1.102 94.70.142.127
    ip access-list extended DMZtoMySQL
    remark CCP_ACL Category=128
    permit ip host 192.168.1.102 host 192.168.0.101
    ip access-list extended Spoofing
    remark CCP_ACL Category=128
    permit ip 10.0.0.0 0.255.255.255 any
    permit ip 192.168.0.0 0.0.255.255 any
    permit ip 172.16.0.0 0.15.255.255 any
    ip access-list extended VTY_incoming
    remark CCP_ACL Category=1
    permit ip host 10.0.10.2 any
    ip access-list extended WebServer
    remark CCP_ACL Category=128
    permit ip any host 192.168.1.102
    ip access-list extended mng-out
    remark CCP_ACL Category=128
    permit ip 10.0.10.0 0.0.0.255 any
    ip access-list extended mng-out-drop
    remark CCP_ACL Category=128
    permit ip any any
    ip access-list extended mng-self
    remark CCP_ACL Category=128
    permit ip any any
    ip access-list extended web_server
    remark CCP_ACL Category=128
    permit ip 192.168.0.0 0.0.0.255 host 192.168.1.102
    logging 10.0.10.2
    access-list 1 remark INSIDE_IF=Vlan1
    access-list 1 remark CCP_ACL Category=2
    access-list 1 remark VLan 1 Access
    access-list 1 permit 192.168.0.0 0.0.0.255
    access-list 1 remark VLan 3 Access
    access-list 1 permit 10.0.10.0 0.0.0.255
    access-list 1 remark Vlan 2 Access
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 100 remark CCP_ACL Category=128
    access-list 100 permit ip host 255.255.255.255 any
    access-list 100 permit ip 127.0.0.0 0.255.255.255 any
    access-list 102 remark CCP_ACL Category=0
    access-list 102 permit ip any host 192.168.0.101
    dialer-list 1 protocol ip permit
    no cdp run
    control-plane
    banner login ^CWARNING!!!This is a highly monitored private system. Access is prohibited!!^C
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    access-class VTY_incoming in
    password 7 12292504011C5C162E
    login local
    transport input ssh
    scheduler max-task-time 5000
    ntp authentication-key 1 md5 10603D29214711255F106B2677 7
    ntp authenticate
    ntp trusted-key 1
    ntp master 2
    end

    Hello karolos,
    Here is the thing.
    You said you are trying to access 94.70.142.113 and that is a server on the DMZ but based in your configuration that is not true
    ip nat inside source static 192.168.0.101 94.70.142.113
    So 192.168.0.101 is on Vlan 1 witch is the in-zone
    interface Vlan1
    description $FW_INSIDE$
    ip address 192.168.0.1 255.255.255.0
    security in-zone
    If you got confused with  the security zone that the host is assigned to then just add the following and it should work
    ip access-list extended WebServer
    permit ip any host 192.168.0.101
    Regards

  • I have iphone 5c.  Having email problem.  Does not delete emails showing in inbox from date 8/27 thru 9/23.   When deleted, these same emails repopulate in inbox.  What is going wrong?  How do I fix the problem?

    Ihave iphone5c.  Does not permanently delete emails showing in inbox.  When they are move to Trash then inbox at first shows empty.  However if you leave Mailbox and return then all the emails that were previously deleted and now repopulated in Inbox.  I have tried various things like marking them "read" before deleting, then moving them to Trash, and they still return.  What is going wrong and how do I fix the problem?

    What your describing sounds lot like Nortons anti virus, but other do it to.
    Multiple copies of the same email over and over are almost always anti virus incoming mail scanning. Turn off scanning and the problem goes away turn it back on and it resumes.
    My guess is that your filter issues, and search problems are also related to this uniquitous and most ignored security tool that messes up far more than it should..
    Deleting the index
    I assume you mean the global-messages-db.sqlite. if you don't close Thunderbird and delete it now. Searches will be incomplete until it rebuilds and the time to do that will have a lot to do with how much mail there is and how busy the computer is.
    Now create an exclusion in your anti virus program for the Thunderbird profile folders. My guess is it is trying to scan the files in your profile every time Thunderbird tries to open them and generally turning things into a tug of war, which Thunderbird looses as it just does not wait around if files are locked. It expects exclusive access to it's files immediately, not in 10 minutes when the anti virus has done it's thing. So things get added to the index but not removed. Mails don't move as the destination or source file is "in use" etc.

  • Trouble with ADS configuration: What is going wrong?

    Hi Experts,
    I need some help in configuring the ADS Call on Solution Manager 7.0 (First question: is ADS runable on Solution Manager - maybe that's the error...?). I only need printforms, no interactive forms.
    Java and Abap is running on one machine.
    This are the notes I've checked:
    944221
    894009
    1016404
    915399
    That's what I configured:
    1. There were no adsuser and ads_agent, so I created them, adsuser as system user, ads_agent as service user, both with the same pw. For ads_agent I assigned the roles SAP_BC_FP_ICF and SAP_BC_FPADS_ICF, for ads_agent the role ADSCALLERS. I had to create the role ADSCALLERS before.
    2. Assigning JAVA Security Roles: Visual Administrator - Cluster - Server - Services - Security Provider - User Management. There I have checked whether the user adsuser is assigned to the group ADSCALLERS and is unlocked. In Policy Configuration (still in Visual Admin) I checked component "com.adobe/AdobeDocumentServices*AdobeDocumentServicesAssembly.jar" and mapped user adsuser and ads_agent to the Security Role ADSCallers.
    3. RFC Connection: HTTP Connection to external Server (was available), Connection Type G, Target: our server, Servicenr 50400 (System Nr is 04), präfix is "/AdobeDocumentServices/Config?style=rpc", user is "ADSUSER", pw the same like in user master data.
    Testing the RFC Connection was successfull.
    4. Checking the services (SICF): fp and fpads are active.
    5. Visual Administrator: Creation of the connection from JAVA to ABAP: Visual Administrator - Cluster - Server - Destinations - HTTP. I created a new destination with name FP_ICF_DATA_/sap/bc/fp/form/layout/fp_test_00.xdp with username ADSUser and pw is working fine.
    I hope you guys can help. I'm working on this issue now for some days, without any improvement.
    What is going wrong and what did I forget to configure?
    Thanks in advance,
    Tan
    EDIT: In Visual Administrator the users ADSUSER, ADS_AGENT and SAP* are locked automatically after some time...
    Edited by: Tan Yildiz on May 10, 2011 10:51 AM

    Hi again,
    maybe you guys can help now.
    Point 6 is fixed partially:
    6. Execution of FP_TEST_00, FP_PDF_TEST_00, FP_CHECK_DESTINATION_SERVICE there comes a popup to enter the username and pw, without any ettect. After I entered the data 3 times the popup is closed and there comes the error
    After executing the reports the popup is not prompting any more. There comes the error immediately:
    ERROR CODE : 100.101
    ERROR MESSAGE : SOAP Runtime Exception: CSoapExceptionTransport : HTTP send returned with status code
    Fehler SOAP Framework: SOAP Runtime Exception: CSoapExceptionTransport : HTTP send returned with status code(100.101).
    I figured out the the error lies within the RFC Destination, but I have no idea where.....
    The target device is our server name (no http:...stuff, just the name "hanna") the service nr is 50400 (04 is the system nr) and path prefix is "/AdobeDocumentServices/Config?style=rpc"
    So long everythings seems to be ok for me.
    But by testing the destination there is nothing happening.....no reaction, no error, no warning, no success message.....other RFC connections are working.
    If I change the service nr to 50000 (there is another system where ads is working) the test result is a success message......
    Any idea whats going wrong? Thanks in advance

  • Flash graphics glitch with alpha transparencies: any ideas what could be going wrong?

    Hey folks, this forum has found me loads of answers in the
    past through various searches but now it's time for me to enquire
    about something myself...
    Here's a bit of graphics I'm going to be using as part of a
    larger project:
    http://www.stucox.co.uk/file_dump/LogoGlitch.html
    You'll see that as the mask for the logo at the top seems to
    bite a chunk out of the mask on the arrows below (they've got an
    alpha mask on them to make them fade towards the top)... this is
    just a graphics glitch as if you get it to redraw that frame, it
    redraws fine.
    What could cause this? it's almost as if the two masks (the
    one on the logo and the one on the arrows) are adding/subtracting
    together, even though they're in totally different layers of
    heirarchy, have different instance names, etc
    I know that the issue is the masks as if i disable either one
    or the other, it renders fine. I've also noticed similar things in
    other areas of my graphics with two coinciding masks causing
    glitches.
    The one solution I've found (short of removing my
    transparency, but I want to keep that as part of the design!) is to
    make the movieclip containing all of the arrows to move very slowly
    (at least one pixel per frame seems to do it), which seems to stop
    the glitching - no idea why, other than that it might be forcing it
    to redraw properly?
    I've tried playing around with the bitmap caching on just
    about every movie clip in the movie and all sorts...
    Any thoughts?

    Thanks for the reply, sorry it's taken me a while to get back
    on.
    This is all going to be over the top of a bitmap background.
    No, you're right - this doesn't come anywhere near 10 alpha layers.
    The arrows are just bezier shapes I've drawn myself.
    And yeah, I can't really afford to make it low quality (I
    think the only reason that works is it then ignores alpha
    transparency), this is all going to be an "impressive" minsite for
    a big clubbing event in London!
    Obviously I can just tone down some of the animation a bit -
    make the arrows part of the bitmap background rather than tweening
    them on screen etc, but I'd really like to understand what's going
    wrong here to try and avoid it in the future!

  • Making a simple calc applet.  Where am I going wrong?

    Hi everyone. I'm taking a introductory java class over the summer and so far I've been doing pretty good in it. I've been able to knock out and figure out how to do most of the assignments on my own. But this latest problem is driving me up a wall. I think I might be making it more difficult then it is. I'm supposed to a take a simple calculation program, and then convert it into an applet with new button functionality and text fields. In the applet, there will be two text fields(input and result) and two buttons(Update and Reset). In the first field you put in an operator and a number. Then from there you hit the Update button and the new value is put in the second field.
    For example. The program is defaulted to "0". So you put "+ 9" in the first field, then Hit Update. "9" will now appear in the second field. Go back to the first field and put in "- 3", hit update again and now the second field will go to "6." You can keep doing this all you want. Then when you want to start all over again you hit reset. Its sort of a weird program.
    Here's the original calc program:
    import java.util.Scanner;
    Simple line-oriented calculator program. The class
    can also be used to create other calculator programs.
    public class Calculator
        private double result;
        private double precision = 0.0001; // Numbers this close to zero are
                                           // treated as if equal to zero.
        public static void main(String[] args)
            Calculator clerk = new Calculator( );
            try
                System.out.println("Calculator is on.");
                System.out.print("Format of each line: ");
                System.out.println("operator space number");
                System.out.println("For example: + 3");
                System.out.println("To end, enter the letter e.");
                clerk.doCalculation();
            catch(UnknownOpException e)
                clerk.handleUnknownOpException(e);
            catch(DivideByZeroException e)
                clerk.handleDivideByZeroException(e);
            System.out.println("The final result is " +
                                      clerk.getResult( ));
            System.out.println("Calculator program ending.");
        public Calculator( )
            result = 0;
        public void reset( )
            result = 0;
        public void setResult(double newResult)
            result = newResult;
        public double getResult( )
            return result;
         The heart of a calculator. This does not give
         instructions. Input errors throw exceptions.
        public void doCalculation( ) throws DivideByZeroException,
                                            UnknownOpException
            Scanner keyboard = new Scanner(System.in);
            boolean done = false;
            result = 0;
            System.out.println("result = " + result);
            while (!done)
               char nextOp = (keyboard.next( )).charAt(0);
                if ((nextOp == 'e') || (nextOp == 'E'))
                    done = true;
                else
                    double nextNumber = keyboard.nextDouble( );
                    result = evaluate(nextOp, result, nextNumber);
                    System.out.println("result " + nextOp + " " +
                                       nextNumber + " = " + result);
                    System.out.println("updated result = " + result);
         Returns n1 op n2, provided op is one of '+', '-', '*',or '/'.
         Any other value of op throws UnknownOpException.
        public double evaluate(char op, double n1, double n2)
                      throws DivideByZeroException, UnknownOpException
            double answer;
            switch (op)
                case '+':
                    answer = n1 + n2;
                    break;
                case '-':
                    answer = n1 - n2;
                    break;
                case '*':
                    answer = n1 * n2;
                    break;
                case '/':
                    if ((-precision < n2) && (n2 < precision))
                        throw new DivideByZeroException( );
                    answer = n1 / n2;
                    break;
                default:
                    throw new UnknownOpException(op);
            return answer;
        public void handleDivideByZeroException(DivideByZeroException e)
            System.out.println("Dividing by zero.");
            System.out.println("Program aborted");
            System.exit(0);
        public void handleUnknownOpException(UnknownOpException e)
            System.out.println(e.getMessage( ));
            System.out.println("Try again from the beginning:");
            try
                System.out.print("Format of each line: ");
                System.out.println("operator number");
                System.out.println("For example: + 3");
                System.out.println("To end, enter the letter e.");
                doCalculation( );
            catch(UnknownOpException e2)
                System.out.println(e2.getMessage( ));
                System.out.println("Try again at some other time.");
                System.out.println("Program ending.");
                System.exit(0);
            catch(DivideByZeroException e3)
                handleDivideByZeroException(e3);
    }Here's me trying to make it into an applet with the added button functionality.
    import java.awt.*;
    import java.awt.event.*;
    import javax.swing.*;
    import java.math.*;
    import java.util.*;
    import java.io.*;
    import java.lang.*;
    public class Calculator extends JApplet implements ActionListener
              // Variables declaration. 
               private javax.swing.JPanel jPanel2;
             private javax.swing.JLabel jLabel2;
             private javax.swing.JTextField jTextField1;
             private javax.swing.JLabel jLabel3;
             private javax.swing.JTextField jTextField2;
             private javax.swing.JButton jButton1;
             private javax.swing.JButton jButton2;
             private javax.swing.JTextArea resultArea;
             private Container container;
             // End of variables declaration
         public void init () {
            initComponents();    
            setSize(400, 200);       
        private void initComponents() {
            container = getContentPane();
            container.setLayout( new BorderLayout() );
                // Creating instances of each item 
                jPanel2 = new javax.swing.JPanel();
            jLabel2 = new javax.swing.JLabel();
            jTextField1 = new javax.swing.JTextField();
            jLabel3 = new javax.swing.JLabel();
            jTextField2 = new javax.swing.JTextField();
            jButton1 = new javax.swing.JButton();
            jButton2 = new javax.swing.JButton();
            resultArea = new javax.swing.JTextArea();
                // End Creation
            // Set text on labels, preferred size can be optional on labels,
                // size should/must be used on text fields.
              // Then each individual item is added to a panel.
            jLabel2.setText("Input =");
            jPanel2.add(jLabel2);
            jTextField1.setText("");
            jTextField1.setPreferredSize(new java.awt.Dimension(65, 20));
            jPanel2.add(jTextField1);
            container.add( jPanel2, BorderLayout.SOUTH);
            jButton1.setText("Update");
                jButton1.addActionListener(this);
                jButton2.setText("Reset");
                jButton2.addActionListener(this);
                container.add(resultArea, BorderLayout.CENTER);
            container.add(jButton1, BorderLayout.WEST);
            container.add(jButton2, BorderLayout.EAST);
                     resultArea.setText("Calculator is on.\n" +
                             "Format of each line: " +
                                             "\noperator space number" +
                             "\nFor example: + 3" +
                                             "\nThen hit Update to compute"+
                             "\nHit Reset to set the result back to zero.");
       private double result;
       private double precision = 0.0001;
       public void actionPerformed(ActionEvent e)
                Calculator clerk = new Calculator( );
            try
                clerk.doCalculation();
                catch(UnknownOpException e2)
                clerk.handleUnknownOpException(e2);
            catch(DivideByZeroException e2)
                clerk.handleDivideByZeroException(e2);
            resultArea.setText("The final result is " + clerk.getResult( )+
                                        "\nCalculator program ending.");
         public Calculator( )
            result = 0;
        public void reset( )
            result = 0;
        public void setResult(double newResult)
            result = newResult;
        public double getResult( )
            return result;
         The heart of a calculator. This does not give
         instructions. Input errors throw exceptions.
        public void doCalculation( ) throws DivideByZeroException,
                                            UnknownOpException
            Scanner keyboard = new Scanner(System.in);
            boolean done = false;
            result = 0;
            resultArea.setText("result = " + result);
            while (!done)
               char nextOp = (keyboard.next( )).charAt(0);
                if ((nextOp == 'e') || (nextOp == 'E'))
                    done = true;
                else
                    double nextNumber = keyboard.nextDouble( );
                    result = evaluate(nextOp, result, nextNumber);
                    resultArea.setText("result " + nextOp + " " + nextNumber + " = " + result+
                                                    "\nupdated result = " + result);
         Returns n1 op n2, provided op is one of '+', '-', '*',or '/'.
         Any other value of op throws UnknownOpException.
        public double evaluate(char op, double n1, double n2)
                      throws DivideByZeroException, UnknownOpException
            double answer;
            switch (op)
                case '+':
                    answer = n1 + n2;
                    break;
                case '-':
                    answer = n1 - n2;
                    break;
                case '*':
                    answer = n1 * n2;
                    break;
                case '/':
                    if ((-precision < n2) && (n2 < precision))
                        throw new DivideByZeroException( );
                    answer = n1 / n2;
                    break;
                default:
                    throw new UnknownOpException(op);
            return answer;
        public void handleDivideByZeroException(DivideByZeroException e)
            resultArea.setText("Dividing by zero."+
                               "\nProgram aborted");
            System.exit(0);
        public void handleUnknownOpException(UnknownOpException e)
            resultArea.setText(e.getMessage( )+
                              "\nTry again from the beginning:");
            try
                resultArea.setText("Calculator is on.\n" +
                             "Format of each line: " +
                                             "\noperator space number" +
                             "\nFor example: + 3" +
                             "\nHit Reset to set the result back to zero.");
                        doCalculation( );
            catch(UnknownOpException e2)
                System.out.println(e2.getMessage( ));
                System.out.println("Try again at some other time.");
                System.out.println("Program ending.");
                System.exit(0);
            catch(DivideByZeroException e3)
                handleDivideByZeroException(e3);
    }I'm not getting any compiling errors or anything and it launches, but it doesn't work at all. I'm sure it has something to do with the calc program and the applet actionevent. I just don't know where to go from there. Can anyone tell me where I'm going wrong? Or even make sense of what I've posted. I know its a lot. I've been looking at this thing for a day now and its killing me. Any help would be greatly appreciated. Thanks.

    This is a mistake
    public void actionPerformed(ActionEvent e)
                Calculator clerk = new Calculator( );
            try
                clerk.doCalculation();You don't want to create a whole new applet every time anyone pushes a button.
    Make whatever changes are neccessary so that you don't have to create a new applet in your actionPerformed

  • Can't see where I am going wrong!

    Can anyone see where I am going wrong.....I can't see the problem:
    import java.io.*;
    public class EmployeeRecord {
        private String employeeName;
        private int employeeIDNumber;
        private String jobCat;
        private double hourlyPayRate;
        private double annualSalary;
       /* public constructor.
       public Student(String employeeName, int employeeIDNumber, String jobCat, double hourlyPayRate)
             this.employeeName = employeeName;
             this.employeeIDNumber = employeeIDNumber;
             this.jobCat = jobCat;
             this.hourlyPayRate = hourlyPayRate;
       } // end method
           * return  employee name
          public String getEmployeeName() {
             return employeeName;
          } // end method
           * return employee ID number
          public int getEmployeeIDNumber() {
             return employeeIDNumber;
       } // end method
           * return job Cat
          public String getJobCat() {
             return jobCat;
          } // end method
           * return hourly pay rate
          public double getHourlyPayRate() {
             return hourlyPayRate;
       } // end method
           * return annual salary
          public double getAnnualSalary() {
             return annualSalary;
       } // end method
              public void calculateAnnualSalary(){
                      int tempCount = numberOfScores;
                      int tempScore = totalScore;
                      if (employeeArray[2] == "Full") {
                         annualSalary = 40 * employeeArray[3];
                      else {
                         annualSalary = 20 * employeeArray[3];
                      } // end else
                   } // end method
       public static void main(String[] args) {
          Employee[] employeeArray = { new Employee("JohnSmith", 654789345, "Full", 25.60);
                                        new Employee("BobJones", 456983209, "Full", 28.20);
                                        new Employee("LarryAnders", 989876123, "Full", 35.30);
                                        new Employee("TomEstes", 237847360, "Full", 41.35);
                                           new Employee("MariaCosta", 115387243, "Part", 15.40);
                                           new Employee("JoeShowen", 223456732, "Full", 45.75);
                                           new Employee("JillRoberts", 574839280, "Part", 38.45);
                                           new Employee("MaryAble", 427836410, "Part", 25.90);
                                           new Employee("NancyAtkins", 349856232, "Full", 35.60);
                                           new Employee("MarkSeimens", 328978455, "Full", 48.50);
       } // end method
    } // end classDesign the Java class to represent an employee record. Pseudo code for this object is given below:
    Employee class definition
    Instance Variables
    Employee name
    Employee ID number
    Job category
    Hourly pay rate
    Annual salary
    Instance Methods
    getName
    getEmployeeId
    calculateAnnualSalary
    getAnnualSalary
    Use the String class for the employee name.
    Use an array of objects for the employee records.
    Calculate each employee's annual salary from the job category and hourly rate, using the following constant information:
    Job category: Full - 40 hours a week
    Part - 20 hours a week
    Assume 52 weeks in a year.
    Display each employee's name, id and annual salary.
    Calculate and display the company's total amount for employees salaries.
    Use the following information to populate the employee objects: Employee
    Name Employee Id Job Category Hourly Pay Rate
    John Smith 654789345 Full 25.60
    Bob Jones 456983209 Full 28.20
    Larry Anders 989876123 Full 35.30
    Tom Estes 237847360 Full 41.35
    Maria Costa 115387243 Part 15.40
    Joe Showen 223456732 Full 45.75
    Jill Roberts 574839280 Part 38.45
    Mary Able 427836410 Part 25.90
    Nancy Atkins 349856232 Full 35.60
    Mark Seimens 328978455 Full 48.50

    I think this is what people mean, but It still wont work. Can someone else figure it out?
    import java.io.*;
    public class EmployeeRecord {
    private String employeeName;
    private int employeeIDNumber;
    private String jobCat;
    private double hourlyPayRate;
    private double annualSalary;
    /* public constructor.
    public void EmployeeRecord (String employeeName, int employeeIDNumber, String jobCat, double hourlyPayRate)
    this.employeeName = employeeName;
    this.employeeIDNumber = employeeIDNumber;
    this.jobCat = jobCat;
    this.hourlyPayRate = hourlyPayRate;
    } // end method
    * return employee name
    public String getEmployeeName() {
    return employeeName;
    } // end method
    * return employee ID number
    public int getEmployeeIDNumber() {
    return employeeIDNumber;
    } // end method
    * return job Cat
    public String getJobCat() {
    return jobCat;
    } // end method
    * return hourly pay rate
    public double getHourlyPayRate() {
    return hourlyPayRate;
    } // end method
    * return annual salary
    public double getAnnualSalary() {
    return annualSalary;
    } // end method
         public void calculateAnnualSalary(){
              int tempCount = numberOfScores;
              int tempScore = totalScore;
              if (employeeArray[2] == "Full") {
              annualSalary = 40 * employeeArray[3];
              else {
              annualSalary = 20 * employeeArray[3];
              } // end else
              } // end method
    public static void main(String[] args) {
    EmployeeRecord[] employeeArray = { new EmployeeRecord("JohnSmith", 654789345, "Full", 25.60),
         new EmployeeRecord("BobJones", 456983209, "Full", 28.20),
         new EmployeeRecord("LarryAnders", 989876123, "Full", 35.30),
         new EmployeeRecord("TomEstes", 237847360, "Full", 41.35),
         new EmployeeRecord("MariaCosta", 115387243, "Part", 15.40),
         new EmployeeRecord("JoeShowen", 223456732, "Full", 45.75),
         new EmployeeRecord("JillRoberts", 574839280, "Part", 38.45),
         new EEmployeeRecord("MaryAble", 427836410, "Part", 25.90),
         new EmployeeRecord("NancyAtkins", 349856232, "Full", 35.60),
         new EmployeeRecord("MarkSeimens", 328978455, "Full", 48.50),
    } // end method
    } // end class

  • I have an iPhone 4 and an iPod 4th gen linked to the same email address and apple ID. I am trying to set up a new email address for the iPod so a family member can use it but it doesn't want to recognize the new email account. Where am I going wrong?

    I have an iPhone 4 and a 4th gen iPod linked to the same email address and apple ID. I am trying to change the email address on the iPod so a family member can use it but when I do it says it doesn't recognize the email address. Where am I going wrong ? I just want them to be able to iMessage and email without having to use my email address.

    The procedure is Settings>Messages>Send & Receive at>You can be reached by iMessages at>Add another email address. The email address has to be a valid working email address, obviously. Apple should verify the email address and you have to go to the inbox of that email account, read the verification email from Apple and follow the inductions in the email in order to complete the verification. Then you go back to the settings, uncheck your email address and check the new email address to be used as the contact email address.

  • Recently wiped out my mac do to mavericks update going wrong. If i add this computer with my itunes match will it put all the music i had back in my itunes library or just upload the little bit of music i purchased on itunes in the past?

    Recently erased my entire mac HD do to mavericks update going wrong. I do not have a back up for my music. But my itunes match account  has all my music. If i add this computer with my itunes match will it put all the music i had back in my itunes library or just upload the little bit of music i purchased on itunes in the past that im only seeing now in my itunes? I do not want itunes match to  sync  or upload the little bit of purchased music i have on my itunes now..Please Help Thanks..

    Hello gogreenj14,
    If you had iTunes Match updated with all of your non iTunes purchased content already, then yes, when you enable iTunes Match with the following article it will have all the content that has been uploaded to iTunes Match will be available for download.
    iTunes: How to add a computer or iOS device to iTunes Match
    http://support.apple.com/kb/ht4913
    Open the latest version of iTunes on the computer you intend to add. You can download the latest version of iTunes here.
    Sign in with the Apple ID you use with iTunes Match.
    Choose Store > Turn On iTunes Match.
    Click the Add This Computer button.
    When prompted, enter your Apple ID password.
    iTunes will automatically begin scanning your computer's library for matches.
    A status indicator will allow you to track progress. You may also manually pause and resume the process at any time by clicking the Stop or Start button.
    Once iTunes has completed matching and uploading your iTunes library, your music in iCloud will be integrated into your local music library. A download button will appear to the right of any content that you have in iCloud that doesn't already exist on your computer.
    Thank you for using Apple Support Communities.
    Cheers,
    Sterling

  • Trying to update Mac OS X 10.8.5 on a Mac Pro 2010 platform.  The App Store starts the downloading, than stops.  Error (102).  Any idea what goes wrong?  Thx

    Just installed Mac OS X 10.8.5  on a Mac Pro 2010 platform. 
    The App Store shows there is an upgrade, so I click the download button. 
    After about 2 hrs the process stops and an  Error (102) appears on the screen. 
    Any idea what goes wrong? 
    THX

    You just now installed 10.8.5? Did you purchase that at the app store?
    What is the upgrade being offered?
    FWIW, you are not running iOS on a Mac Pro (we are talking about the desktop tower Mac Pro, right?)

  • I have Photoshop CS5 and a Nikon D 810 camera.  I have downloaded Camera Raw 8.8 & DNG converter.  I can neither open the raw files (.nef), nor process them with the DNG converter. What is going wrong?

    I have Photoshop CS5 and a Nikon D 810 camera.  I have downloaded Camera Raw 8.8 & DNG converter.  I can neither open the raw files (.nef), nor process them with the DNG converter. What is going wrong?  Thanks!

    This is the last paragraph from my very first response to you, post #1 in this thread:
    …Additionally, you need to install the DNG Converter, not just "download" it, and you need to launch it and run it on each folder of NEFs you wish to convert to raw DNGs.  [emphasis added]

  • Installing FMS,goes wrong,Please Help Me.Thank You!

    Hi,while im installing FMS,it goes wrong,i pasted the sceen below.pls help me.
    I dont know why.
    My Os:FC14_X86.
    Proceed with the installation? (y/n/q): y
    /opt/adobe/fms ~/FMS_4_0_0_r1121
    Server:fms command:stop
    sed: -e expression #1, char 6: unknown option to `s'
    ./server: line 41: /etc/SUSE-release: No such file or directory
    ./server: command substitution: line 46: syntax error near unexpected token `elif'
    ./server: command substitution: line 46: ` elif [ -f /etc/mandrake-release ] ; then'
    sed: -e expression #1, char 14: unknown option to `s'
    sed: -e expression #1, char 9: unknown option to `s'
    WARNING: Your Linux distribution, RedHat i686  is not supported by this
              installer.
    1024
    WARNING: FMS requires the maximum number of processes > 32K.
             Adjust ulimit to match system requirements.
    NPTL 2.13
    Stopping Adobe Flash Media Server (please check /var/log/messages)
    Server has shutdown...
    Admin server:fmsadmin command:stop
    sed: -e expression #1, char 14: unknown option to `s'
    ./adminserver: command substitution: line 45: syntax error near unexpected token `elif'
    ./adminserver: command substitution: line 45: ` elif [ -f /etc/mandrake-release ] ; then'
    sed: -e expression #1, char 9: unknown option to `s'
    sed: -e expression #1, char 6: unknown option to `s'
    ./adminserver: line 40: /etc/SUSE-release: No such file or directory
    WARNING: Your Linux distribution, RedHat i686  is not supported by this
              installer.
    Stopping Adobe Flash Media Admin Server (please check /var/log/messages)
    Admin Server has shutdown...
    ~/FMS_4_0_0_r1121
    Installing Adobe Flash Media Server files...
    Configuring Adobe Flash Media Server...
    Adding "fms" service.
    Setting default admin to "fms".
    sed: -e expression #1, char 14: unknown option to `s'
    ./installFMS: command substitution: line 204: syntax error near unexpected token `elif'
    ./installFMS: command substitution: line 204: ` elif [ -f /etc/mandrake-release ] ; then'
    sed: -e expression #1, char 9: unknown option to `s'
    sed: -e expression #1, char 6: unknown option to `s'
    ./installFMS: line 199: /etc/SUSE-release: No such file or directory
    Setting autostart for "fms".
    Server:fms command:start
    ./server: command substitution: line 46: syntax error near unexpected token `elif'
    ./server: command substitution: line 46: ` elif [ -f /etc/mandrake-release ] ; then'
    sed: -e expression #1, char 14: unknown option to `s'
    sed: -e expression #1, char 9: unknown option to `s'
    sed: -e expression #1, char 6: unknown option to `s'
    ./server: line 41: /etc/SUSE-release: No such file or directory
    WARNING: Your Linux distribution, RedHat i686  is not supported by this
              installer.
    1024
    WARNING: FMS requires the maximum number of processes > 32K.
             Adjust ulimit to match system requirements.
    NPTL 2.13
    Starting Adobe Flash Media Server (please check /var/log/messages)
    Admin server:fmsadmin command:start
    sed: -e expression #1, char 14: unknown option to `s'
    sed: -e expression #1, char 6: unknown option to `s'
    ./adminserver: command substitution: line 45: syntax error near unexpected token `elif'
    ./adminserver: command substitution: line 45: ` elif [ -f /etc/mandrake-release ] ; then'
    sed: -e expression #1, char 9: unknown option to `s'
    ./adminserver: line 40: /etc/SUSE-release: No such file or directory
    WARNING: Your Linux distribution, RedHat i686  is not supported by this
              installer.
    Starting Adobe Flash Media Admin Server (please check /var/log/messages)
    The Adobe Flash Media Server installation is complete.

    Hi ,
    Thanks for trying out FMS 4, but as you can see in the warnings, your linux distribution is not officially supported for FMS and hence there might be unknown issues blocking the proper installation. There are dependencies that might be missing on your distro.
    Anyways, as mentioned in the logs, did you try changing the ulimit settings  ?

Maybe you are looking for

  • Presenter Does Not Update to 8.1

    I have a subscription to eLearning Suite, but my Adobe Presenter has not updated to version 8.1. It is currently 8.0.1 Build 260. I am using Windows 7 Professional. How do I get the update please?

  • Cost of Service Sale

    Hi everybody! In my company want to determine the cost of a sale of services,,, but the material that we use doesn´t manage stock, so i don´t have manner to generate it. Please, can you help me??

  • What files can go on IPod when used as External Disk?

    I have done appropriate research, and I know how to use IPod 60GB Video to store and download data files, but I am unable to find out what file types it will accept. Are there any exceptions? I ask this because I just learned that "Notes" will only a

  • Price difference invoice allocation to items

    If a customer sends a price difference invoice and when we  are entering it in the system we want to allocate this value to the reference invoice items based on their values how should we do it? For example: There was a preeceding invoice material A 

  • Best way to print from application

    Hi! I have an application handling employee information. I'm trying to figure out the best way to print all information liked to an employee. What is best? I want to generate the page with a good layout, not just plain text(pictures, different fonts)