Asymmetric NAT rules matched for forward and reverse flows - NAT Issue

Having a problem with a VPN site trying to communicate to a subnet off my ASA 5505.   The network is simple, VPN IPSEC remote site is 192.168.6.0/24 and I can ping and access hosts on 192.168.10.0/24 (called InfraNet).   I am now trying to allow communications between 192.168.6.0/24 (called FD_net) to 192.168.9.0/24 (called Inside)
The Error:
5          Nov 12 2012          13:52:50                    192.168.9.19                                        Asymmetric NAT rules matched for forward and reverse flows; Connection for icmp src outside:192.168.6.11 dst inside:192.168.9.19 (type 8, code 0) denied due to NAT reverse path failure
I understand this is a NAT issue; but I not seeing the error and could use a second set of eyes.   Here's my current running configuration.
: Saved
ASA Version 8.3(2)
hostname fw1
domain-name xxxxxxxx.xxx
enable password <removed>
passwd <removed>
names
interface Vlan1
description Town Internal Network
nameif inside
security-level 100
ip address 192.168.9.1 255.255.255.0
interface Vlan2
description Public Internet
nameif outside
security-level 0
ip address 173.xxx.xxx.xxx 255.255.255.248
interface Vlan3
description DMZ (CaTV)
nameif dmz
security-level 50
ip address 192.168.2.1 255.255.255.0
interface Vlan10
description Infrastructure Network
nameif InfraNet
security-level 100
ip address 192.168.10.1 255.255.255.0
interface Vlan13
description Guest Wireless
nameif Wireless-Guest
security-level 25
ip address 192.168.1.1 255.255.255.0
interface Vlan23
nameif StateNet
security-level 75
ip address 10.63.198.2 255.255.255.0
interface Vlan33
description Police Subnet
shutdown
nameif PDNet
security-level 90
ip address 192.168.0.1 255.255.255.0
interface Ethernet0/0
switchport access vlan 2
interface Ethernet0/1
switchport trunk allowed vlan 1,5,10,13
switchport trunk native vlan 1
switchport mode trunk
speed 100
duplex full
interface Ethernet0/2
switchport access vlan 3
interface Ethernet0/3
interface Ethernet0/4
switchport trunk allowed vlan 1,10,13
switchport trunk native vlan 1
switchport mode trunk
interface Ethernet0/5
switchport access vlan 23
interface Ethernet0/6
shutdown
interface Ethernet0/7
switchport trunk allowed vlan 1
switchport trunk native vlan 1
switchport mode trunk
shutdown
banner exec                     Access Restricted to Personnel Only
banner login                     Access Restricted to Personnel Only
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns server-group DefaultDNS
domain-name xxxxxxx.xxx
same-security-traffic permit inter-interface
object network obj_any
subnet 0.0.0.0 0.0.0.0
object service IMAPoverSSL
service tcp destination eq 993
description IMAP over SSL     
object service POPoverSSL
service tcp destination eq 995
description POP3 over SSL     
object service SMTPwTLS
service tcp destination eq 465
description SMTP with TLS     
object network obj-192.168.9.20
host 192.168.9.20
object network obj-claggett-https
host 192.168.9.20
object network obj-claggett-imap4
host 192.168.9.20
object network obj-claggett-pop3
host 192.168.9.20
object network obj-claggett-smtp
host 192.168.9.20
object network obj-claggett-imapoverssl
host 192.168.9.20
object network obj-claggett-popoverssl
host 192.168.9.20
object network obj-claggett-smtpwTLS
host 192.168.9.20
object network obj-192.168.9.120
host 192.168.9.120
object network obj-192.168.9.119
host 192.168.9.119
object network obj-192.168.9.121
host 192.168.9.121
object network obj-wirelessnet
subnet 192.168.1.0 255.255.255.0
object network WirelessClients
subnet 192.168.1.0 255.255.255.0
object network obj-dmznetwork
subnet 192.168.2.0 255.255.255.0
object network FD_Firewall
host 74.94.142.229
object network FD_Net
subnet 192.168.6.0 255.255.255.0
object network NETWORK_OBJ_192.168.10.0_24
subnet 192.168.10.0 255.255.255.0
object network obj-TownHallNet
subnet 192.168.9.0 255.255.255.0
object network obj_InfraNet
subnet 192.168.10.0 255.255.255.0
object-group service EmailServices
description Normal Email/Exchange Services
service-object object IMAPoverSSL
service-object object POPoverSSL
service-object object SMTPwTLS
service-object tcp destination eq https
service-object tcp destination eq imap4
service-object tcp destination eq pop3
service-object tcp destination eq smtp
object-group service DM_INLINE_SERVICE_1
service-object object IMAPoverSSL
service-object object POPoverSSL
service-object object SMTPwTLS
service-object tcp destination eq pop3
service-object tcp destination eq https
service-object tcp destination eq smtp
object-group service DM_INLINE_SERVICE_2
service-object object IMAPoverSSL
service-object object POPoverSSL
service-object object SMTPwTLS
service-object tcp destination eq https
service-object tcp destination eq pop3
service-object tcp destination eq smtp
object-group network obj_clerkpc
description Clerk's PCs
network-object object obj-192.168.9.119
network-object object obj-192.168.9.120
network-object object obj-192.168.9.121
object-group network TownHall_Nets
network-object 192.168.10.0 255.255.255.0
network-object object obj-TownHallNet
object-group network DM_INLINE_NETWORK_1
network-object 192.168.10.0 255.255.255.0
network-object 192.168.9.0 255.255.255.0
access-list outside_access_in extended permit object-group DM_INLINE_SERVICE_2 any interface outside
access-list outside_access_in extended permit object-group DM_INLINE_SERVICE_1 any host 192.168.9.20
access-list StateNet_access_in extended permit ip object-group obj_clerkpc any
access-list outside_2_cryptomap extended permit ip object-group DM_INLINE_NETWORK_1 object FD_Net
pager lines 24
logging enable
logging asdm debugging
logging mail errors
logging from-address hostmaster@xxxxxxxxx
logging recipient-address john@xxxxxxxxx level errors
mtu inside 1500
mtu outside 1500
mtu dmz 1500
mtu Wireless-Guest 1500
mtu StateNet 1500
mtu InfraNet 1500
mtu PDNet 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-635.bin
no asdm history enable
arp timeout 14400
nat (InfraNet,outside) source static TownHall_Nets TownHall_Nets destination static FD_Net FD_Net
nat (inside,outside) source static TownHall_Nets TownHall_Nets destination static FD_Net FD_Net
object network obj_any
nat (inside,outside) static interface
object network obj-claggett-https
nat (inside,outside) static interface service tcp https https
object network obj-claggett-imap4
nat (inside,outside) static interface service tcp imap4 imap4
object network obj-claggett-pop3
nat (inside,outside) static interface service tcp pop3 pop3
object network obj-claggett-smtp
nat (inside,outside) static interface service tcp smtp smtp
object network obj-claggett-imapoverssl
nat (inside,outside) static interface service tcp 993 993
object network obj-claggett-popoverssl
nat (inside,outside) static interface service tcp 995 995
object network obj-claggett-smtpwTLS
nat (inside,outside) static interface service tcp 465 465
object network obj-192.168.9.120
nat (inside,StateNet) static 10.63.198.12
object network obj-192.168.9.119
nat (any,StateNet) static 10.63.198.10
object network obj-192.168.9.121
nat (any,StateNet) static 10.63.198.11
object network obj-wirelessnet
nat (Wireless-Guest,outside) static interface
object network obj-dmznetwork
nat (any,outside) static interface
object network obj_InfraNet
nat (InfraNet,outside) static interface
access-group outside_access_in in interface outside
access-group StateNet_access_in in interface StateNet
route outside 0.0.0.0 0.0.0.0 173.166.117.190 1
route StateNet 10.0.0.0 255.0.0.0 10.63.198.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable 5443
http 192.168.9.0 255.255.255.0 inside
http 74.xxx.xxx.xxx 255.255.255.255 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 2 match address outside_2_cryptomap
crypto map outside_map 2 set pfs
crypto map outside_map 2 set peer 173.xxx.xxx.xxx
crypto map outside_map 2 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet 192.168.9.0 255.255.255.0 inside
telnet timeout 5
ssh 192.168.9.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
dhcpd dns 208.67.222.222 208.67.220.220
dhcpd lease 10800
dhcpd auto_config outside
dhcpd address 192.168.2.100-192.168.2.254 dmz
dhcpd dns 8.8.8.8 8.8.4.4 interface dmz
dhcpd enable dmz
dhcpd address 192.168.1.100-192.168.1.254 Wireless-Guest
dhcpd enable Wireless-Guest
threat-detection basic-threat
threat-detection statistics host number-of-rate 2
threat-detection statistics port
threat-detection statistics protocol
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 63.240.161.99 source outside prefer
ntp server 207.171.30.106 source outside prefer
ntp server 70.86.250.6 source outside prefer
webvpn
group-policy FDIPSECTunnel internal
group-policy FDIPSECTunnel attributes
vpn-idle-timeout none
vpn-tunnel-protocol IPSec l2tp-ipsec
username support password <removed> privilege 15
tunnel-group 173.xxx.xxx.xxx type ipsec-l2l
tunnel-group 173.xxx.xxx.xxx general-attributes
default-group-policy FDIPSECTunnel
tunnel-group 173.xxx.xxx.xxx ipsec-attributes
pre-shared-key *****
smtp-server 192.168.9.20
prompt hostname context
call-home
profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email [email protected]
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:e4dc3cef0de15123f11439822880a2c7
: end
Any ideas would be appreciated.
John

I don't see any inspection-commands in your config. Is there a reason for not using any of them?
If your problem is only with ICMP, then you should enable at least icmp-inspection. You can do that easiely with the legacy command " fixup protocol icmp"
Sent from Cisco Technical Support iPad App

Similar Messages

  • %ASA-5-305013: Asymmetric NAT rules matched for forward and reverse flows; Connection for tcp src outside:10.159.159.3/49204 dst tru777:10.1.34.19/3389 denied due to NAT reverse path failure

    Hi,
    I have an ASA5510 running version 8.2(5). I have set up a new network on interface Ethernet0/1.777 of the fwl. The firewall works perfectly with remote access VPNs but has now given me the error with the new network that has been set up:
    %ASA-5-305013: Asymmetric NAT rules matched for forward and reverse flows; Connection for tcp src outside:10.159.159.3/49204 dst tru777:10.1.34.19/3389 denied due to NAT reverse path failure
    The difference between the other networks and the new one that I have set up is that this is the first one using a private addressing scheme. I understand that NAT is not allowing something along the way but I cant figure out what needs to change in order to get it to work. My config is as follows:
    interface Ethernet0/1.777
    description TRU 777
    vlan 777
    nameif tru777
    security-level 50
    ip address 10.1.34.17 255.255.255.240 standby 10.1.34.18
    access-list acl_tru777 remark * ALLOW ALL OUTBOUND *
    access-list acl_tru777 extended permit ip any any
    access-list RA-VPN extended permit ip 10.1.34.16 255.255.255.240 10.159.159.0 255.255.255.0
    access-list acl_no-nat extended permit ip 10.1.34.0 255.255.255.0 10.0.0.0 255.0.0.0
    access-list acl_no-nat extended permit ip 10.1.34.0 255.255.255.0 172.16.0.0 255.240.0.0
    access-list acl_no-nat extended permit ip 10.1.34.0 255.255.255.0 192.168.0.0 255.255.0.0
    access-list acl_ra-lock-tru777 extended permit ip 10.1.34.16 255.255.255.240 10.159.159.0 255.255.255.0
    access-list acl_ra-lock-tru777 extended permit ip 10.159.159.0 255.255.255.0 10.1.34.16 255.255.255.240
    ip local pool ra-pool 10.159.159.0-10.159.159.254 mask 255.255.255.0
    nat (tru777) 4 access-list acl_no-nat
    nat (tru777) 2 10.1.34.16 255.255.255.240
    global (outside) 2 x.x.x.x
    crypto isakmp nat-traversal 20
    I think that is everything you should need, if not please just ask.
    Thank you very much in advance,
    Chris

    Hi Julio,
    Here you go:
    FWL01# sh nameif
    Interface                Name                     Security
    Ethernet0/0              outside                    0
    Ethernet0/1              CLIENTS                 50
    Ethernet0/1.314        tru01                      50
    Ethernet0/1.313        dmz01                    50
    Ethernet0/1.316        tru02                      50
    Ethernet0/1.776        dmz776                  50
    Ethernet0/1.777        tru777                     50
    Management0/0       management           100
    FWL01#  sh run nat
    nat (tru02) 1 192.168.3.0 255.255.255.240
    nat (tru777) 4 access-list acl_no-nat
    nat (tru777) 2 10.1.34.16 255.255.255.240
    FWL01#    sh run glob
    global (outside) 1 interface
    global (outside) 2 x.x.x.x
    Thanks,
    Chris

  • Asymmetric NAT rules matched for forward and reverse flows

    Hi! I don't know why this comes up in the logs when I have configured my vpn like so:
    crypto dynamic-map L2L_MAP 50 set reverse-route
    crypto dynamic-map OUTSIDE_dyn_map 20 set transform-set ESP-3DES-SHA
    crypto dynamic-map OUTSIDE_dyn_map 40 set pfs
    crypto dynamic-map OUTSIDE_dyn_map 40 set transform-set ESP-3DES-SHA
    crypto dynamic-map OUTSIDE_dyn_map 60 set pfs
    crypto dynamic-map OUTSIDE_dyn_map 60 set transform-set ESP-3DES-SHA
    crypto dynamic-map OUTSIDE_dyn_map 65535 set transform-set ESP-3DES-SHA
    crypto dynamic-map OUTSIDE_dyn_map 65535 set security-association lifetime seconds 288000
    crypto dynamic-map OUTSIDE_dyn_map 65535 set security-association lifetime kilobytes 4608000
    crypto dynamic-map INSIDE_dyn_map 20 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 20 match address IDP_VPN
    crypto map L2L_MAP 20 set peer x.x.x.x
    crypto map L2L_MAP 20 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 40 match address cp_l2l_map_40
    crypto map L2L_MAP 40 set peer x.x.x.x
    crypto map L2L_MAP 40 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 60 match address bwi_l2l
    crypto map L2L_MAP 60 set peer x.x.x.x
    crypto map L2L_MAP 60 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 80 match address outside_80_cryptomap
    crypto map L2L_MAP 80 set peer x.x.x.x
    crypto map L2L_MAP 80 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 65535 ipsec-isakmp dynamic OUTSIDE_dyn_map
    crypto map L2L_MAP interface outside
    crypto map INSIDE_map 65535 ipsec-isakmp dynamic INSIDE_dyn_map
    crypto map INSIDE_map interface inside
    I am able to connect successfully via vpn client.  Its just that i cant reach the internal servers...  Any ideas?
    i get this error:
    Oct 18 2012 00:52:37: %ASA-5-305013: Asymmetric NAT rules matched for forward and reverse flows; Connection for udp src outside:10.10.13.221/137 dst inside:10.10.13.255/137 denied

    I put in the important configs:
    interface GigabitEthernet0/0
    nameif outside
    security-level 0
    ip address x.x.x.x 255.255.255.0 standby x.x.x.x
    ospf cost 10
    interface GigabitEthernet0/1
    nameif inside
    security-level 100
    ip address 10.10.13.5 255.255.255.0 standby 10.10.13.6
    ospf cost 10
    interface GigabitEthernet0/2
    nameif dmz
    security-level 50
    no ip address
    ospf cost 10
    interface GigabitEthernet0/2.720
    vlan 720
    nameif dmz-vsp
    security-level 50
    ip address 172.24.0.1 255.255.255.0 standby 172.24.0.2
    ospf cost 10
    interface GigabitEthernet0/2.724
    vlan 724
    nameif dmz-dbz
    security-level 75
    ip address 172.24.4.1 255.255.255.0 standby 172.24.4.2
    ospf cost 10
    interface GigabitEthernet0/2.725
    vlan 725
    nameif dmz-smtp
    security-level 50
    ip address 172.24.5.1 255.255.255.0 standby 172.24.5.2
    ospf cost 10
    dns domain-lookup outside
    dns domain-lookup inside
    dns server-group DefaultDNS
    name-server 10.10.10.50
    domain-name xxxx.local
    access-list nonatacl extended permit ip 10.10.0.0 255.255.0.0 10.40.4.0 255.255.255.0
    access-list nonatacl extended permit ip 172.16.0.0 255.255.0.0 10.40.4.0 255.255.255.0
    access-list nonatacl extended permit ip 192.168.2.0 255.255.255.0 10.40.4.0 255.255.255.0
    access-list nonatacl extended permit ip 192.168.3.0 255.255.255.0 10.40.4.0 255.255.255.0
    access-list nonatacl extended permit ip 10.10.0.0 255.255.0.0 10.40.14.0 255.255.255.0
    access-list nonatacl extended permit ip 10.10.13.0 255.255.255.0 10.10.10.0 255.255.255.0
    access-list nonatacl extended permit ip 10.10.10.0 255.255.255.0 10.10.13.0 255.255.255.0
    access-list nonatacl extended permit ip 10.10.13.0 255.255.255.0 192.168.6.0 255.255.255.0
    access-list nonatacl extended permit ip 192.168.6.0 255.255.255.0 10.10.13.0 255.255.255.0
    ip local pool inshse-vpn-pool2 192.168.6.220-192.168.6.230 mask 255.255.255.0
    global (outside) 201 192.168.16.1-192.168.16.250
    global (outside) 202 10.201.5.145-10.201.5.158
    global (outside) 4 10.10.13.180-10.10.13.189 netmask 255.0.0.0
    global (outside) 101 interface
    global (outside) 1 x.x.x.x netmask 255.0.0.0
    global (inside) 204 10.10.13.70-10.10.13.79 netmask 255.0.0.0
    nat (inside) 0 access-list nonatacl
    nat (inside) 201 access-list NAT_TO_IDP
    nat (inside) 202 access-list inside2-vsp_nat_outbound
    nat (inside) 101 0.0.0.0 0.0.0.0
    nat (dmz-vsp) 202 access-list dmz-vsp_nat_outbound
    nat (dmz-vsp) 101 0.0.0.0 0.0.0.0
    route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
    route inside 10.0.0.0 255.240.0.0 10.10.13.1 1
    route inside 10.40.1.0 255.255.255.0 10.10.13.1 1
    route inside 10.40.2.0 255.255.255.0 10.10.13.1 1
    route inside 10.40.3.0 255.255.255.0 10.10.13.1 1
    route inside 10.40.4.0 255.255.255.0 10.10.13.1 1
    route inside 10.40.13.0 255.255.255.0 10.10.13.1 1
    route inside 10.40.254.0 255.255.255.0 10.10.13.1 1
    route inside 172.16.0.0 255.255.0.0 10.10.13.1 1
    route inside 192.168.2.0 255.255.255.0 10.10.13.1 1
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server VPN_Auth protocol radius
    aaa-server VPN_Auth (inside) host 10.10.2.20
    timeout 5
    key *****
    no mschapv2-capable
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map L2L_MAP 50 set reverse-route
    crypto dynamic-map OUTSIDE_dyn_map 20 set transform-set ESP-3DES-SHA
    crypto dynamic-map OUTSIDE_dyn_map 40 set pfs
    crypto dynamic-map OUTSIDE_dyn_map 40 set transform-set ESP-3DES-SHA
    crypto dynamic-map OUTSIDE_dyn_map 60 set pfs
    crypto dynamic-map OUTSIDE_dyn_map 60 set transform-set ESP-3DES-SHA
    crypto dynamic-map OUTSIDE_dyn_map 65535 set transform-set ESP-3DES-SHA
    crypto dynamic-map OUTSIDE_dyn_map 65535 set security-association lifetime seconds 288000
    crypto dynamic-map OUTSIDE_dyn_map 65535 set security-association lifetime kilobytes 4608000
    crypto dynamic-map INSIDE_dyn_map 20 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 20 match address IDP_VPN
    crypto map L2L_MAP 20 set peer x.x.x.x
    crypto map L2L_MAP 20 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 40 match address cp_l2l_map_40
    crypto map L2L_MAP 40 set peer x.x.x.x
    crypto map L2L_MAP 40 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 60 match address nonatacl
    crypto map L2L_MAP 60 set peer x.x.x.x
    crypto map L2L_MAP 60 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 80 match address outside_80_cryptomap
    crypto map L2L_MAP 80 set peer x.x.x.x
    crypto map L2L_MAP 80 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 65535 ipsec-isakmp dynamic OUTSIDE_dyn_map
    crypto map L2L_MAP interface outside
    crypto map INSIDE_map 65535 ipsec-isakmp dynamic INSIDE_dyn_map
    crypto map INSIDE_map interface inside
    crypto isakmp enable outside
    crypto isakmp enable inside
    crypto isakmp enable dmz
    crypto isakmp enable dmz-vsp
    crypto isakmp policy 20
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 65535
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    no vpn-addr-assign aaa
    no vpn-addr-assign dhcp
    group-policy ihasavpn2_gp internal
    group-policy ihasavpn2_gp attributes
    dns-server value 10.10.10.52
    vpn-tunnel-protocol IPSec
    default-domain value xxxx.local
    tunnel-group ihasavpn2 type remote-access
    tunnel-group ihasavpn2 general-attributes
    address-pool inshse-vpn-pool2
    authentication-server-group VPN_Auth
    authentication-server-group (inside) VPN_Auth
    default-group-policy ihasavpn2_gp
    tunnel-group ihasavpn2 ipsec-attributes
    pre-shared-key *****
    tunnel-group ihasavpn2 ppp-attributes
    authentication ms-chap-v2

  • Workflow for Dual Control Principle for Posting and Reversing manual postin

    Hi Experts,
                     As per this link http://help.sap.com/saphelp_pserv463/helpdata/EN/ae/01e73a86e99c77e10000000a114084/content.htm
                    we configured the reaon  for posting and reversing and created a custom functiom modules and assigned to events 5500,5502 in instaliation specific function modules but those function modules are not triggered and system is not publishing events APPROVALREQUIRED,REVERSEAPPROVALREQUIRED documents are directedly getting posted.
                   how to make the system publish these events and send the documents for approval with out directly getting posted
    Regards,
    vCentric.

    Hi Suhas,
    The rule used in workflow template WS50100021 is a standard one. So try to find out that on what basis it is fetching the agents. It could be the case that the logic specified in the rule does not fulfill your requirement.
    The other reason could be that you have not specified the task as general. Please check if the agents tab is activated(green) in the task or not. If it is not you need to set the task as general.
    SOLUTION : if you want to get the workitem in your own SAP Inbox for testing purpose, you can set the WFINITIATOR as agent instead of that standard rule. This setting will send the workitem in your own SAP Inbox.
    Regards,
    Guddan

  • How do i do a forward and reverse sweep two independent variables

    Hi,
      So I was looking through the post on how to do a forward and reverse sweep with a real-time x-y plot. I have a similar situation except that instead of sweeping (forward and reverse) of one variable, but instead two variables (in my case, I call it gate voltage G-S Volt and source-drain voltage S-D Volt). I understand how to do it with one variable as provided in previous posts, but I am caught when I add another variable to reverse sweep. I have attached my vi to this post. Any suggesstions is greatly appreciated. Thank you. Also, a little more details on my plot, I am plotting current vs gate voltage which forward and reverse sweepeing (gate and source-drain voltage)..
    Attachments:
    FET_Isd - Vg measurement_Vg_201.vi ‏45 KB

    jasonct,
    It is very difficult to follow what your code is doing. It violates all of the style guide and good practice recommendation for LabVIEW code.
    The diagram should fit on one screen. SubVIs can help.  Generally dataflow eliminates the need for sequence structures.  Stacked sequence structures in particular obscure the code. Local variables are prone to race conditions, violate dataflow, and are not needed for the uses you are making of them.  Wiring should go right to left, with minimal numbers of bends.   Comments documenting what you are doing are helpful to others looking at your code and to you next month when you wonder why you did it that way.
    Lynn 

  • Document or report for assessment and reversed assessment?

    Hi guyz,
    Is there any document or report for assessment and reversed assessment?
    I need to find documentation as a proof for any execution and reversal of assessment, such as journal entry or report line items that is showing debit or credit for the expenses..
    Currently, I can only see actual cost document which shows execution of assessment and an assessment cost element debit and credit in the Cost Center Actual/Plan/Variance report.
    However, when I do reversal at KSU5, in the Cost Center A/P/V report is showing that assessment cost element is still exist (no more debit and credit showing as the result of the reversal), only that the value is now zero.
    Need your answer asap...Thanking you..

    Dear Meila,
    Use tcode KSB1 Cost Center Actual Line Itens, execute then report and change the Layout, insert the field Business Transaction in the report.
    Regards

  • Is there a workflow for approval and Reversal of Regular Journal

    Hi All,
    Is there a workflow for approval and Reversal of Regular Journal .
    can we use  the standard park document workflow for the same .. ???
    Thanks ,
    Naval

    For such activities you would probably better make use of ISR.
    See [SAP Help - Internal Service Request|http://help.sap.com/saphelp_erp60_sp/helpdata/en/53/3120386827c23ce10000009b38f842/frameset.htm]

  • F.05 Document numbers for valauation and reversal

    Hi All,
    We recently applied Support stack 18.  (Earlier we had Suppport Stack 13)
    After applying this stack, we observed that, When we run F.05, Forex valuation,
    The documents posted for valuation are reversed . and document number continued for valuation and reversal.
    Suppose i run this for GL account 11801  and GL 11832,
    Valuation for GL11801  and reversal for GL11801  are posted with document numbers in sequence and then Valuation for GL11832 and reversal for GL 11832 are posted.
    Earlier, all the valuations are posted for 11801 and 11832 in one sequence and reversals are posted in one sequence.
    Now the situation changed.
    Please advise, how to resolve this issue.

    Hi,
    In that case, you need to reverse the documents manually via FB08 or F.80
    SAP will not do the reversal automatically if you have not selected in F.05
    Regards,
    Gaurav

  • Quicktime Player fast-forward and reverse buttons not working for audio

    I have Quicktime Player 7.7.3 for Windows and the fast forward/reverse buttons will not work while playing audio files. I've tried it with mp3 and m4a, neither will work.
    The go to end/go to begining buttons are working fine.
    The ff/reverse button don't work very well for video files, they only will move a few frames at a time, but they will not work at all on strictly audio files.
    I've looked at the preferences, and the software is up to date.
    the only way to ff/reverse is to go to Window > Show A/V Controls and use the Jog Shuttle, but that is a clumsy workaround. I'd rather have the playback buttons work properly in the first place.
    Is there something else I should be doing (aside from purchasing QT Pro, that is)?

    ...stupid decision to replace the iTunes feedback...
    Not replaced, just moved. Now grouped with all other Mac OS X feedback:
    http://www.apple.com/macosx/feedback/
    It's not a bug. If it was we would all have this problem. My Macs don't.
    Shut iTunes down.
    Go to ~/your user name/Library/Preferences and place the file "com.apple.iTunes.plist" in the trash.
    Try iTunes again. If your problem is solved, empty the trash.

  • HT1399 How can I find an album as there is no screen in this version of the ipod,in the eraler model there is a viewing screen, this shuffle is solid just start arrows, arrows for forwarding or reversing and a plus or minus sign for changing the volume.

    I have a new ipod shuffle but can't see where I can see what album I am playing as it doesn't have a viewing screen, it has a solid front and back with a circle with the various forward and back and volume controls.I am missing something!

    What you see is what you get. The shuffle is a compact unit designed to play tracks at random from the selection you put on it. It isn't possible to search out and play specific tracks, nor get visual feedback of what is currently playing. You can have the device give feedback by VoiceOver if that is of any use to you.
    tt2

  • Forward and Reverse Engineering

    Hello,
    Iu2019m very new to ABAP Objects and I want to know, if there any solution for Forward Engineering, which means you modeled some classes in an UML tool like ARIS and import the XMI-File in the SAP-System and its generating the classes automatically?
    Well, I´m also interested in Reverse Engineering. Do you know a solution for an export of classes to an external UML tool (maybe via XMI)?
    Thanks for your answers.
    Edited by: Neil Gardiner on Sep 24, 2010 9:47 AM

    Hi,
    ABAP -> UML reverse engineering functionality is available starting with release 7.02 and 7.20.
    You will find them in transaction SE80 in the context menu of classes, interfaces, programs and function-groups (Display -> UML Class Diagram). The UML class diagram cannot be manually modified but there are many options to configure it. There is no plan for supporting two-way-editing functionality in the future. Nevertheless you will be able to print the UML class diagram, export the UML class diagram in XMI format (without graphic) or as an bitmap and you will be able to generate an ABAPDoc like HTML document including UML class diagram bitmaps.
    The XMI file can be imported in third party UML tools (e.g. StarUML and Altova UModel), to generate UML diagrams and to modify the classes and interfaces. Therefore, XMI download can be very useful in ABAP refactoring projects. Because of the ABAP Objects UML Class Diagram is designed for reverse engineering, there is currently no plan for an XMI upload functionality.
    Regards,
    Mathiyalagan

  • Forward and Reverse Pricing Calculations in the Same Pricing procedure

    Hello,
    I have a requirement where the Pricing has to set up to do the forward as reverse calculations in the same pricing procedure,For example:
    There is :
    PR00-Base Price
    Less
    K004:Discount(%)
    will give
    ZN00:Net Price
    Less Cost
    EK02
    will give the Profit Margin-ZMAR
    Forward calculation is possible as per SAP standard but the requirement is also to do reverse calculation such as
    By entering Profit Margin-,The system should do a backward(Reverse calculation) and arrive on the Net price from the Net Price(ZN00) it should calculate the Duscount automatically.
    Your inputs on this would be most helpful.
    Regards
    Mohammed Roshan

    hi,
    In Sale Order / Billing, in normal circumstances, tax will be calculated on the base price.   On the other hand, if you want the system to reverse calculate, you can achieve the same.
    In normal circumstances, system will calculate as follows:-,
    you maintained the PR00 of a material as                                                           Rs 200.00
    and  Discount                                                                                Rs.  25.00                                                                               
                            Net Value                                                                                Rs.175.00
    If you want to reverse calculate which means your invoice value itself should be Rs.200.00 which is inclusive of Discount. Then your Discount condition type (or in case there is tax, any tax condition type - MWST / UTXJ) have the Calculation Type as u201CHu201D
    With the above settings, your actual PR00 value would be 225.00 only, though you maintained Rs.200.00 for PR00.

  • Clarification of Servlet Spec for forwarding and filters

    Hi everybody,
    I'm having a problem trying to use SiteMesh in WebLogic 9.1 vs Tomcat 5.5.17. The issue seems to come up because the two containers have different behavior when it comes to forwarding and filters.
    The scenario is this: A request comes in to a servlet, that servlet forwards to a JSP page using RequestDispatcher.forward(). The SiteMesh filter looks at request.getServletPath() after the chain has executed and determines whether or not to apply the decoration based on the path of the page. The filter's doFilter() method looks something like :
    chain.doFilter(request, response)
    if(request.getServletPath() = matchingPath)
        applyDecoration();
    }Now, in Tomcat, a call to request.getServletPath() before and after the call to chain.doFilter() returns the exact same thing, regardless of whether the target servlet executes a forward. But in WebLogic, the call to getServletPath() after chain.doFilter() returns the forwarded path, not the original path.
    Who is right? Or is this one of those gray areas?
    Thanks,
    Scott

    Thanks for the info. You are correct, I was using 'forward'. I changed it to use 'sendRedirect' and this time the request goes via the filter. However, the request parameters that were in the original request have disappeared after the 'sendRedirect'. I could just add all the request parameters to the string I pass to sendredirect but was wondering if there was a better/simpler way.
    Thanks,
    Paul

  • Identifying the orginal Doc for reset and reverse documents

    hi,
    When there is a cheque return from the customer, what is the practice is to reset and reverse the original receipt posted in the system. but the issue is once the original document is reset and reverse there is no way of identifying the invoice details of the receipt created (f-28). Please some one help to find out those details.
    Thanks and Regards
    Gayani

    HI,
    Up to that point ok, say If i reverse the receipt and from the reversal document number I can see the "reversed with number" but the issue is I want to know the payment usage (original documents) of the "revered with number".
    Say There is receipt document number 1800000000
    and the bank return this cheque, so I want to reverse the receipt number 18000000, so I use the transaction FBRA to reset and reverse the document. but the customer want to know the original documents (invoice) of the receipt number 180000000?
    I can not get those information from the system
    Gayani

  • Good Issue after delivery and packing is done and reversal of goods Issue

    Hi All,
    I have a below requirment.
    1) How we will do the goods Issue using the code. as manuvally we can do it in VL09. I have a delivery number I need to Issue goods Issue for that delivery?
    2)If I have a delivery I need to reverse the goods Issue using the abap code. How we will do that is there any function module or BAPI available to reversal of goods Issue.
    Basically I need function module or BAPI to do the Goods Issues as well as reversal of goods Issue.
    Thanks for your help on this. 
    Thanks,
    Antony.

    Hello,
    I guess you made some typo error as VL09 is for reverse of goods issue and not for doing goods issue.
    Anyways, I suppose you are dealing with Outbound delivery.
    Goods issue, VL02n OR  WS_DELIVERY_UPDATE.
    Reverse Goods issue VL09 OR 'WS_REVERSE_GOODS_ISSUE'
    BR,
    Diwakar

Maybe you are looking for

  • Flip no longer working in iMovie '08

    My Flip camera was working just fine with iMovie '08. But, I recently had a hard drive crash, and, on my new hard drive (with Leopard OS), iMovie will no longer import the .avi files from my Flip. I have installed both the "Leopard Compatibility.dmg"

  • Extending the UML class diagrams with JDeveloper Extensions SDK?

    Hello, I studied the JDeveloper Extension SDK docs, but couldn't figure out how to write extensions that support UML Diagrams. What I would like to do, is to pin a different data model under the class diagram view. Well if you can't do that. In the w

  • Mapping enter and esc to ok and cancel buttons

    Hi, Does java's fine API offer any method of mapping Enter and ESC to OK and Cancel buttons in a customized JDialog? The current way I'm doing it is through a brute force of adding a KeyListener to every component in the dialog box (in an automated w

  • Restoring my 4s after a bad sync

    My son synced my phone with his and deleted my contacts and calendar.  No back up on icloud .  can we reset the 4s to where it was 1 hour before the screw up???

  • 802.11n only MBP connects new MP not

    When I set the Airport Extreme Base Station to 802.11n only (5GHz) then my MacBookPro (2009) does connect wirelessly, as do the other Airports in the chain. But my brandnew MacPro (mid 2010) does not. Is it possible this one works on 2.4 GHz only and