Forward and Reverse Engineering

Hello,
Iu2019m very new to ABAP Objects and I want to know, if there any solution for Forward Engineering, which means you modeled some classes in an UML tool like ARIS and import the XMI-File in the SAP-System and its generating the classes automatically?
Well, I´m also interested in Reverse Engineering. Do you know a solution for an export of classes to an external UML tool (maybe via XMI)?
Thanks for your answers.
Edited by: Neil Gardiner on Sep 24, 2010 9:47 AM

Hi,
ABAP -> UML reverse engineering functionality is available starting with release 7.02 and 7.20.
You will find them in transaction SE80 in the context menu of classes, interfaces, programs and function-groups (Display -> UML Class Diagram). The UML class diagram cannot be manually modified but there are many options to configure it. There is no plan for supporting two-way-editing functionality in the future. Nevertheless you will be able to print the UML class diagram, export the UML class diagram in XMI format (without graphic) or as an bitmap and you will be able to generate an ABAPDoc like HTML document including UML class diagram bitmaps.
The XMI file can be imported in third party UML tools (e.g. StarUML and Altova UModel), to generate UML diagrams and to modify the classes and interfaces. Therefore, XMI download can be very useful in ABAP refactoring projects. Because of the ABAP Objects UML Class Diagram is designed for reverse engineering, there is currently no plan for an XMI upload functionality.
Regards,
Mathiyalagan

Similar Messages

  • How do i do a forward and reverse sweep two independent variables

    Hi,
      So I was looking through the post on how to do a forward and reverse sweep with a real-time x-y plot. I have a similar situation except that instead of sweeping (forward and reverse) of one variable, but instead two variables (in my case, I call it gate voltage G-S Volt and source-drain voltage S-D Volt). I understand how to do it with one variable as provided in previous posts, but I am caught when I add another variable to reverse sweep. I have attached my vi to this post. Any suggesstions is greatly appreciated. Thank you. Also, a little more details on my plot, I am plotting current vs gate voltage which forward and reverse sweepeing (gate and source-drain voltage)..
    Attachments:
    FET_Isd - Vg measurement_Vg_201.vi ‏45 KB

    jasonct,
    It is very difficult to follow what your code is doing. It violates all of the style guide and good practice recommendation for LabVIEW code.
    The diagram should fit on one screen. SubVIs can help.  Generally dataflow eliminates the need for sequence structures.  Stacked sequence structures in particular obscure the code. Local variables are prone to race conditions, violate dataflow, and are not needed for the uses you are making of them.  Wiring should go right to left, with minimal numbers of bends.   Comments documenting what you are doing are helpful to others looking at your code and to you next month when you wonder why you did it that way.
    Lynn 

  • Asymmetric NAT rules matched for forward and reverse flows - NAT Issue

    Having a problem with a VPN site trying to communicate to a subnet off my ASA 5505.   The network is simple, VPN IPSEC remote site is 192.168.6.0/24 and I can ping and access hosts on 192.168.10.0/24 (called InfraNet).   I am now trying to allow communications between 192.168.6.0/24 (called FD_net) to 192.168.9.0/24 (called Inside)
    The Error:
    5          Nov 12 2012          13:52:50                    192.168.9.19                                        Asymmetric NAT rules matched for forward and reverse flows; Connection for icmp src outside:192.168.6.11 dst inside:192.168.9.19 (type 8, code 0) denied due to NAT reverse path failure
    I understand this is a NAT issue; but I not seeing the error and could use a second set of eyes.   Here's my current running configuration.
    : Saved
    ASA Version 8.3(2)
    hostname fw1
    domain-name xxxxxxxx.xxx
    enable password <removed>
    passwd <removed>
    names
    interface Vlan1
    description Town Internal Network
    nameif inside
    security-level 100
    ip address 192.168.9.1 255.255.255.0
    interface Vlan2
    description Public Internet
    nameif outside
    security-level 0
    ip address 173.xxx.xxx.xxx 255.255.255.248
    interface Vlan3
    description DMZ (CaTV)
    nameif dmz
    security-level 50
    ip address 192.168.2.1 255.255.255.0
    interface Vlan10
    description Infrastructure Network
    nameif InfraNet
    security-level 100
    ip address 192.168.10.1 255.255.255.0
    interface Vlan13
    description Guest Wireless
    nameif Wireless-Guest
    security-level 25
    ip address 192.168.1.1 255.255.255.0
    interface Vlan23
    nameif StateNet
    security-level 75
    ip address 10.63.198.2 255.255.255.0
    interface Vlan33
    description Police Subnet
    shutdown
    nameif PDNet
    security-level 90
    ip address 192.168.0.1 255.255.255.0
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    switchport trunk allowed vlan 1,5,10,13
    switchport trunk native vlan 1
    switchport mode trunk
    speed 100
    duplex full
    interface Ethernet0/2
    switchport access vlan 3
    interface Ethernet0/3
    interface Ethernet0/4
    switchport trunk allowed vlan 1,10,13
    switchport trunk native vlan 1
    switchport mode trunk
    interface Ethernet0/5
    switchport access vlan 23
    interface Ethernet0/6
    shutdown
    interface Ethernet0/7
    switchport trunk allowed vlan 1
    switchport trunk native vlan 1
    switchport mode trunk
    shutdown
    banner exec                     Access Restricted to Personnel Only
    banner login                     Access Restricted to Personnel Only
    ftp mode passive
    clock timezone EST -5
    clock summer-time EDT recurring
    dns server-group DefaultDNS
    domain-name xxxxxxx.xxx
    same-security-traffic permit inter-interface
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object service IMAPoverSSL
    service tcp destination eq 993
    description IMAP over SSL     
    object service POPoverSSL
    service tcp destination eq 995
    description POP3 over SSL     
    object service SMTPwTLS
    service tcp destination eq 465
    description SMTP with TLS     
    object network obj-192.168.9.20
    host 192.168.9.20
    object network obj-claggett-https
    host 192.168.9.20
    object network obj-claggett-imap4
    host 192.168.9.20
    object network obj-claggett-pop3
    host 192.168.9.20
    object network obj-claggett-smtp
    host 192.168.9.20
    object network obj-claggett-imapoverssl
    host 192.168.9.20
    object network obj-claggett-popoverssl
    host 192.168.9.20
    object network obj-claggett-smtpwTLS
    host 192.168.9.20
    object network obj-192.168.9.120
    host 192.168.9.120
    object network obj-192.168.9.119
    host 192.168.9.119
    object network obj-192.168.9.121
    host 192.168.9.121
    object network obj-wirelessnet
    subnet 192.168.1.0 255.255.255.0
    object network WirelessClients
    subnet 192.168.1.0 255.255.255.0
    object network obj-dmznetwork
    subnet 192.168.2.0 255.255.255.0
    object network FD_Firewall
    host 74.94.142.229
    object network FD_Net
    subnet 192.168.6.0 255.255.255.0
    object network NETWORK_OBJ_192.168.10.0_24
    subnet 192.168.10.0 255.255.255.0
    object network obj-TownHallNet
    subnet 192.168.9.0 255.255.255.0
    object network obj_InfraNet
    subnet 192.168.10.0 255.255.255.0
    object-group service EmailServices
    description Normal Email/Exchange Services
    service-object object IMAPoverSSL
    service-object object POPoverSSL
    service-object object SMTPwTLS
    service-object tcp destination eq https
    service-object tcp destination eq imap4
    service-object tcp destination eq pop3
    service-object tcp destination eq smtp
    object-group service DM_INLINE_SERVICE_1
    service-object object IMAPoverSSL
    service-object object POPoverSSL
    service-object object SMTPwTLS
    service-object tcp destination eq pop3
    service-object tcp destination eq https
    service-object tcp destination eq smtp
    object-group service DM_INLINE_SERVICE_2
    service-object object IMAPoverSSL
    service-object object POPoverSSL
    service-object object SMTPwTLS
    service-object tcp destination eq https
    service-object tcp destination eq pop3
    service-object tcp destination eq smtp
    object-group network obj_clerkpc
    description Clerk's PCs
    network-object object obj-192.168.9.119
    network-object object obj-192.168.9.120
    network-object object obj-192.168.9.121
    object-group network TownHall_Nets
    network-object 192.168.10.0 255.255.255.0
    network-object object obj-TownHallNet
    object-group network DM_INLINE_NETWORK_1
    network-object 192.168.10.0 255.255.255.0
    network-object 192.168.9.0 255.255.255.0
    access-list outside_access_in extended permit object-group DM_INLINE_SERVICE_2 any interface outside
    access-list outside_access_in extended permit object-group DM_INLINE_SERVICE_1 any host 192.168.9.20
    access-list StateNet_access_in extended permit ip object-group obj_clerkpc any
    access-list outside_2_cryptomap extended permit ip object-group DM_INLINE_NETWORK_1 object FD_Net
    pager lines 24
    logging enable
    logging asdm debugging
    logging mail errors
    logging from-address hostmaster@xxxxxxxxx
    logging recipient-address john@xxxxxxxxx level errors
    mtu inside 1500
    mtu outside 1500
    mtu dmz 1500
    mtu Wireless-Guest 1500
    mtu StateNet 1500
    mtu InfraNet 1500
    mtu PDNet 1500
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-635.bin
    no asdm history enable
    arp timeout 14400
    nat (InfraNet,outside) source static TownHall_Nets TownHall_Nets destination static FD_Net FD_Net
    nat (inside,outside) source static TownHall_Nets TownHall_Nets destination static FD_Net FD_Net
    object network obj_any
    nat (inside,outside) static interface
    object network obj-claggett-https
    nat (inside,outside) static interface service tcp https https
    object network obj-claggett-imap4
    nat (inside,outside) static interface service tcp imap4 imap4
    object network obj-claggett-pop3
    nat (inside,outside) static interface service tcp pop3 pop3
    object network obj-claggett-smtp
    nat (inside,outside) static interface service tcp smtp smtp
    object network obj-claggett-imapoverssl
    nat (inside,outside) static interface service tcp 993 993
    object network obj-claggett-popoverssl
    nat (inside,outside) static interface service tcp 995 995
    object network obj-claggett-smtpwTLS
    nat (inside,outside) static interface service tcp 465 465
    object network obj-192.168.9.120
    nat (inside,StateNet) static 10.63.198.12
    object network obj-192.168.9.119
    nat (any,StateNet) static 10.63.198.10
    object network obj-192.168.9.121
    nat (any,StateNet) static 10.63.198.11
    object network obj-wirelessnet
    nat (Wireless-Guest,outside) static interface
    object network obj-dmznetwork
    nat (any,outside) static interface
    object network obj_InfraNet
    nat (InfraNet,outside) static interface
    access-group outside_access_in in interface outside
    access-group StateNet_access_in in interface StateNet
    route outside 0.0.0.0 0.0.0.0 173.166.117.190 1
    route StateNet 10.0.0.0 255.0.0.0 10.63.198.1 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable 5443
    http 192.168.9.0 255.255.255.0 inside
    http 74.xxx.xxx.xxx 255.255.255.255 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto map outside_map 2 match address outside_2_cryptomap
    crypto map outside_map 2 set pfs
    crypto map outside_map 2 set peer 173.xxx.xxx.xxx
    crypto map outside_map 2 set transform-set ESP-3DES-SHA
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet 192.168.9.0 255.255.255.0 inside
    telnet timeout 5
    ssh 192.168.9.0 255.255.255.0 inside
    ssh timeout 5
    console timeout 0
    dhcpd dns 208.67.222.222 208.67.220.220
    dhcpd lease 10800
    dhcpd auto_config outside
    dhcpd address 192.168.2.100-192.168.2.254 dmz
    dhcpd dns 8.8.8.8 8.8.4.4 interface dmz
    dhcpd enable dmz
    dhcpd address 192.168.1.100-192.168.1.254 Wireless-Guest
    dhcpd enable Wireless-Guest
    threat-detection basic-threat
    threat-detection statistics host number-of-rate 2
    threat-detection statistics port
    threat-detection statistics protocol
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ntp server 63.240.161.99 source outside prefer
    ntp server 207.171.30.106 source outside prefer
    ntp server 70.86.250.6 source outside prefer
    webvpn
    group-policy FDIPSECTunnel internal
    group-policy FDIPSECTunnel attributes
    vpn-idle-timeout none
    vpn-tunnel-protocol IPSec l2tp-ipsec
    username support password <removed> privilege 15
    tunnel-group 173.xxx.xxx.xxx type ipsec-l2l
    tunnel-group 173.xxx.xxx.xxx general-attributes
    default-group-policy FDIPSECTunnel
    tunnel-group 173.xxx.xxx.xxx ipsec-attributes
    pre-shared-key *****
    smtp-server 192.168.9.20
    prompt hostname context
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:e4dc3cef0de15123f11439822880a2c7
    : end
    Any ideas would be appreciated.
    John

    I don't see any inspection-commands in your config. Is there a reason for not using any of them?
    If your problem is only with ICMP, then you should enable at least icmp-inspection. You can do that easiely with the legacy command " fixup protocol icmp"
    Sent from Cisco Technical Support iPad App

  • %ASA-5-305013: Asymmetric NAT rules matched for forward and reverse flows; Connection for tcp src outside:10.159.159.3/49204 dst tru777:10.1.34.19/3389 denied due to NAT reverse path failure

    Hi,
    I have an ASA5510 running version 8.2(5). I have set up a new network on interface Ethernet0/1.777 of the fwl. The firewall works perfectly with remote access VPNs but has now given me the error with the new network that has been set up:
    %ASA-5-305013: Asymmetric NAT rules matched for forward and reverse flows; Connection for tcp src outside:10.159.159.3/49204 dst tru777:10.1.34.19/3389 denied due to NAT reverse path failure
    The difference between the other networks and the new one that I have set up is that this is the first one using a private addressing scheme. I understand that NAT is not allowing something along the way but I cant figure out what needs to change in order to get it to work. My config is as follows:
    interface Ethernet0/1.777
    description TRU 777
    vlan 777
    nameif tru777
    security-level 50
    ip address 10.1.34.17 255.255.255.240 standby 10.1.34.18
    access-list acl_tru777 remark * ALLOW ALL OUTBOUND *
    access-list acl_tru777 extended permit ip any any
    access-list RA-VPN extended permit ip 10.1.34.16 255.255.255.240 10.159.159.0 255.255.255.0
    access-list acl_no-nat extended permit ip 10.1.34.0 255.255.255.0 10.0.0.0 255.0.0.0
    access-list acl_no-nat extended permit ip 10.1.34.0 255.255.255.0 172.16.0.0 255.240.0.0
    access-list acl_no-nat extended permit ip 10.1.34.0 255.255.255.0 192.168.0.0 255.255.0.0
    access-list acl_ra-lock-tru777 extended permit ip 10.1.34.16 255.255.255.240 10.159.159.0 255.255.255.0
    access-list acl_ra-lock-tru777 extended permit ip 10.159.159.0 255.255.255.0 10.1.34.16 255.255.255.240
    ip local pool ra-pool 10.159.159.0-10.159.159.254 mask 255.255.255.0
    nat (tru777) 4 access-list acl_no-nat
    nat (tru777) 2 10.1.34.16 255.255.255.240
    global (outside) 2 x.x.x.x
    crypto isakmp nat-traversal 20
    I think that is everything you should need, if not please just ask.
    Thank you very much in advance,
    Chris

    Hi Julio,
    Here you go:
    FWL01# sh nameif
    Interface                Name                     Security
    Ethernet0/0              outside                    0
    Ethernet0/1              CLIENTS                 50
    Ethernet0/1.314        tru01                      50
    Ethernet0/1.313        dmz01                    50
    Ethernet0/1.316        tru02                      50
    Ethernet0/1.776        dmz776                  50
    Ethernet0/1.777        tru777                     50
    Management0/0       management           100
    FWL01#  sh run nat
    nat (tru02) 1 192.168.3.0 255.255.255.240
    nat (tru777) 4 access-list acl_no-nat
    nat (tru777) 2 10.1.34.16 255.255.255.240
    FWL01#    sh run glob
    global (outside) 1 interface
    global (outside) 2 x.x.x.x
    Thanks,
    Chris

  • Asymmetric NAT rules matched for forward and reverse flows

    Hi! I don't know why this comes up in the logs when I have configured my vpn like so:
    crypto dynamic-map L2L_MAP 50 set reverse-route
    crypto dynamic-map OUTSIDE_dyn_map 20 set transform-set ESP-3DES-SHA
    crypto dynamic-map OUTSIDE_dyn_map 40 set pfs
    crypto dynamic-map OUTSIDE_dyn_map 40 set transform-set ESP-3DES-SHA
    crypto dynamic-map OUTSIDE_dyn_map 60 set pfs
    crypto dynamic-map OUTSIDE_dyn_map 60 set transform-set ESP-3DES-SHA
    crypto dynamic-map OUTSIDE_dyn_map 65535 set transform-set ESP-3DES-SHA
    crypto dynamic-map OUTSIDE_dyn_map 65535 set security-association lifetime seconds 288000
    crypto dynamic-map OUTSIDE_dyn_map 65535 set security-association lifetime kilobytes 4608000
    crypto dynamic-map INSIDE_dyn_map 20 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 20 match address IDP_VPN
    crypto map L2L_MAP 20 set peer x.x.x.x
    crypto map L2L_MAP 20 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 40 match address cp_l2l_map_40
    crypto map L2L_MAP 40 set peer x.x.x.x
    crypto map L2L_MAP 40 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 60 match address bwi_l2l
    crypto map L2L_MAP 60 set peer x.x.x.x
    crypto map L2L_MAP 60 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 80 match address outside_80_cryptomap
    crypto map L2L_MAP 80 set peer x.x.x.x
    crypto map L2L_MAP 80 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 65535 ipsec-isakmp dynamic OUTSIDE_dyn_map
    crypto map L2L_MAP interface outside
    crypto map INSIDE_map 65535 ipsec-isakmp dynamic INSIDE_dyn_map
    crypto map INSIDE_map interface inside
    I am able to connect successfully via vpn client.  Its just that i cant reach the internal servers...  Any ideas?
    i get this error:
    Oct 18 2012 00:52:37: %ASA-5-305013: Asymmetric NAT rules matched for forward and reverse flows; Connection for udp src outside:10.10.13.221/137 dst inside:10.10.13.255/137 denied

    I put in the important configs:
    interface GigabitEthernet0/0
    nameif outside
    security-level 0
    ip address x.x.x.x 255.255.255.0 standby x.x.x.x
    ospf cost 10
    interface GigabitEthernet0/1
    nameif inside
    security-level 100
    ip address 10.10.13.5 255.255.255.0 standby 10.10.13.6
    ospf cost 10
    interface GigabitEthernet0/2
    nameif dmz
    security-level 50
    no ip address
    ospf cost 10
    interface GigabitEthernet0/2.720
    vlan 720
    nameif dmz-vsp
    security-level 50
    ip address 172.24.0.1 255.255.255.0 standby 172.24.0.2
    ospf cost 10
    interface GigabitEthernet0/2.724
    vlan 724
    nameif dmz-dbz
    security-level 75
    ip address 172.24.4.1 255.255.255.0 standby 172.24.4.2
    ospf cost 10
    interface GigabitEthernet0/2.725
    vlan 725
    nameif dmz-smtp
    security-level 50
    ip address 172.24.5.1 255.255.255.0 standby 172.24.5.2
    ospf cost 10
    dns domain-lookup outside
    dns domain-lookup inside
    dns server-group DefaultDNS
    name-server 10.10.10.50
    domain-name xxxx.local
    access-list nonatacl extended permit ip 10.10.0.0 255.255.0.0 10.40.4.0 255.255.255.0
    access-list nonatacl extended permit ip 172.16.0.0 255.255.0.0 10.40.4.0 255.255.255.0
    access-list nonatacl extended permit ip 192.168.2.0 255.255.255.0 10.40.4.0 255.255.255.0
    access-list nonatacl extended permit ip 192.168.3.0 255.255.255.0 10.40.4.0 255.255.255.0
    access-list nonatacl extended permit ip 10.10.0.0 255.255.0.0 10.40.14.0 255.255.255.0
    access-list nonatacl extended permit ip 10.10.13.0 255.255.255.0 10.10.10.0 255.255.255.0
    access-list nonatacl extended permit ip 10.10.10.0 255.255.255.0 10.10.13.0 255.255.255.0
    access-list nonatacl extended permit ip 10.10.13.0 255.255.255.0 192.168.6.0 255.255.255.0
    access-list nonatacl extended permit ip 192.168.6.0 255.255.255.0 10.10.13.0 255.255.255.0
    ip local pool inshse-vpn-pool2 192.168.6.220-192.168.6.230 mask 255.255.255.0
    global (outside) 201 192.168.16.1-192.168.16.250
    global (outside) 202 10.201.5.145-10.201.5.158
    global (outside) 4 10.10.13.180-10.10.13.189 netmask 255.0.0.0
    global (outside) 101 interface
    global (outside) 1 x.x.x.x netmask 255.0.0.0
    global (inside) 204 10.10.13.70-10.10.13.79 netmask 255.0.0.0
    nat (inside) 0 access-list nonatacl
    nat (inside) 201 access-list NAT_TO_IDP
    nat (inside) 202 access-list inside2-vsp_nat_outbound
    nat (inside) 101 0.0.0.0 0.0.0.0
    nat (dmz-vsp) 202 access-list dmz-vsp_nat_outbound
    nat (dmz-vsp) 101 0.0.0.0 0.0.0.0
    route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
    route inside 10.0.0.0 255.240.0.0 10.10.13.1 1
    route inside 10.40.1.0 255.255.255.0 10.10.13.1 1
    route inside 10.40.2.0 255.255.255.0 10.10.13.1 1
    route inside 10.40.3.0 255.255.255.0 10.10.13.1 1
    route inside 10.40.4.0 255.255.255.0 10.10.13.1 1
    route inside 10.40.13.0 255.255.255.0 10.10.13.1 1
    route inside 10.40.254.0 255.255.255.0 10.10.13.1 1
    route inside 172.16.0.0 255.255.0.0 10.10.13.1 1
    route inside 192.168.2.0 255.255.255.0 10.10.13.1 1
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server VPN_Auth protocol radius
    aaa-server VPN_Auth (inside) host 10.10.2.20
    timeout 5
    key *****
    no mschapv2-capable
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map L2L_MAP 50 set reverse-route
    crypto dynamic-map OUTSIDE_dyn_map 20 set transform-set ESP-3DES-SHA
    crypto dynamic-map OUTSIDE_dyn_map 40 set pfs
    crypto dynamic-map OUTSIDE_dyn_map 40 set transform-set ESP-3DES-SHA
    crypto dynamic-map OUTSIDE_dyn_map 60 set pfs
    crypto dynamic-map OUTSIDE_dyn_map 60 set transform-set ESP-3DES-SHA
    crypto dynamic-map OUTSIDE_dyn_map 65535 set transform-set ESP-3DES-SHA
    crypto dynamic-map OUTSIDE_dyn_map 65535 set security-association lifetime seconds 288000
    crypto dynamic-map OUTSIDE_dyn_map 65535 set security-association lifetime kilobytes 4608000
    crypto dynamic-map INSIDE_dyn_map 20 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 20 match address IDP_VPN
    crypto map L2L_MAP 20 set peer x.x.x.x
    crypto map L2L_MAP 20 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 40 match address cp_l2l_map_40
    crypto map L2L_MAP 40 set peer x.x.x.x
    crypto map L2L_MAP 40 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 60 match address nonatacl
    crypto map L2L_MAP 60 set peer x.x.x.x
    crypto map L2L_MAP 60 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 80 match address outside_80_cryptomap
    crypto map L2L_MAP 80 set peer x.x.x.x
    crypto map L2L_MAP 80 set transform-set ESP-3DES-SHA
    crypto map L2L_MAP 65535 ipsec-isakmp dynamic OUTSIDE_dyn_map
    crypto map L2L_MAP interface outside
    crypto map INSIDE_map 65535 ipsec-isakmp dynamic INSIDE_dyn_map
    crypto map INSIDE_map interface inside
    crypto isakmp enable outside
    crypto isakmp enable inside
    crypto isakmp enable dmz
    crypto isakmp enable dmz-vsp
    crypto isakmp policy 20
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 65535
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    no vpn-addr-assign aaa
    no vpn-addr-assign dhcp
    group-policy ihasavpn2_gp internal
    group-policy ihasavpn2_gp attributes
    dns-server value 10.10.10.52
    vpn-tunnel-protocol IPSec
    default-domain value xxxx.local
    tunnel-group ihasavpn2 type remote-access
    tunnel-group ihasavpn2 general-attributes
    address-pool inshse-vpn-pool2
    authentication-server-group VPN_Auth
    authentication-server-group (inside) VPN_Auth
    default-group-policy ihasavpn2_gp
    tunnel-group ihasavpn2 ipsec-attributes
    pre-shared-key *****
    tunnel-group ihasavpn2 ppp-attributes
    authentication ms-chap-v2

  • Forward and Reverse Pricing Calculations in the Same Pricing procedure

    Hello,
    I have a requirement where the Pricing has to set up to do the forward as reverse calculations in the same pricing procedure,For example:
    There is :
    PR00-Base Price
    Less
    K004:Discount(%)
    will give
    ZN00:Net Price
    Less Cost
    EK02
    will give the Profit Margin-ZMAR
    Forward calculation is possible as per SAP standard but the requirement is also to do reverse calculation such as
    By entering Profit Margin-,The system should do a backward(Reverse calculation) and arrive on the Net price from the Net Price(ZN00) it should calculate the Duscount automatically.
    Your inputs on this would be most helpful.
    Regards
    Mohammed Roshan

    hi,
    In Sale Order / Billing, in normal circumstances, tax will be calculated on the base price.   On the other hand, if you want the system to reverse calculate, you can achieve the same.
    In normal circumstances, system will calculate as follows:-,
    you maintained the PR00 of a material as                                                           Rs 200.00
    and  Discount                                                                                Rs.  25.00                                                                               
                            Net Value                                                                                Rs.175.00
    If you want to reverse calculate which means your invoice value itself should be Rs.200.00 which is inclusive of Discount. Then your Discount condition type (or in case there is tax, any tax condition type - MWST / UTXJ) have the Calculation Type as u201CHu201D
    With the above settings, your actual PR00 value would be 225.00 only, though you maintained Rs.200.00 for PR00.

  • Forward and reverse coefficients

    Hi all, I am a newbie here.
    I am currently working on a filter project. I am required to design a filter in LabView based on the filter circuit and a list of coefficients given. (i have 512 coefficients here, so i dun think it is the 1 that i need)
    I was thinking of using IIR filter to achieve this. The problem that i am facing now is i do not know how to determine the reverse coefficients and the forward coefficients input to IIR filter.
    I would like to know if there is any formula or way to find these two coefficients? Is there any better way to create this filter in Labview?
    I would really appreciate if anyone can help me in this. thanks thanks =)
    Regads,
    Hauo Wah

    Hai,
    FIR or IIR filters are generic models that can be used to create other filters.
    Dive into dspguru.com website to get detailed info on digital filters.  I am attaching the smothing filter co-efficients vi along with this mail.  This vi ships along with the professional development system of LabVIEW not sure about 6.1 having this VI.
    The VI i have attached is converted to 8.0 version (i was able to convert up to that only!!) try converting to the version required.
    Feel free to post for any queries. 
    With regards,
    JK
    (Certified LabVIEW Developer)
    Give Kudos for Good Answers, and Mark it a solution if your problem is solved.
    Attachments:
    Smoothing Filter Coefficients.vi ‏21 KB

  • Quicktime Player fast-forward and reverse buttons not working for audio

    I have Quicktime Player 7.7.3 for Windows and the fast forward/reverse buttons will not work while playing audio files. I've tried it with mp3 and m4a, neither will work.
    The go to end/go to begining buttons are working fine.
    The ff/reverse button don't work very well for video files, they only will move a few frames at a time, but they will not work at all on strictly audio files.
    I've looked at the preferences, and the software is up to date.
    the only way to ff/reverse is to go to Window > Show A/V Controls and use the Jog Shuttle, but that is a clumsy workaround. I'd rather have the playback buttons work properly in the first place.
    Is there something else I should be doing (aside from purchasing QT Pro, that is)?

    ...stupid decision to replace the iTunes feedback...
    Not replaced, just moved. Now grouped with all other Mac OS X feedback:
    http://www.apple.com/macosx/feedback/
    It's not a bug. If it was we would all have this problem. My Macs don't.
    Shut iTunes down.
    Go to ~/your user name/Library/Preferences and place the file "com.apple.iTunes.plist" in the trash.
    Try iTunes again. If your problem is solved, empty the trash.

  • Designer 10G reconciliation and Reverse Engineering

    Hi All Oracle Designer 10G users,
    Years ago, I used to be an avid Oracle Designer 2000 user and have not used Oracle Designer in any of it forms since, until the last few months. I now have two issues which I need to solve, which are;
    - I need to reconcile the contents of the Oracle Designer 10G repository with physical (on-line) database and also if possible generate SQL DML to resolve any differences if found.
    - Also, I need to reverse engineer Foreign Keys that have been built in the physical (on-line) database schema into the Oracle Designer 10G repository.
    I hope any Oracle Designer 10G professionals out there can help me with the above issues.
    Many Thanks in advance,
    Austin

    Hello Austin,
    If you have access to Metalink then there are 2 notes that you may want to look at
    Note 260617.1 on how to Capture Design tables from a Database.
    Note.299067.1     Ext/Pub How to reverse engineer an ERD in Designer:
    These both have a video associated with them to help with thest items.
    To see the differances between your reposiotry objets and your DB objects you will need to generate to your DB but not execute.
    1 In the DE - Server Model tab
    2. Select the objects
    3. generate - generate Database from Server model
    4. Select database - enter the user name/ password and connect string
    5. Select the objects tab and make sure that the objects are on the right side that you want to see. - Start
    6. Select List Actions on the Message Window
    7. DDL Generation Complete comes up and select View Report
    If you select Execute DDL that is what will happen and you will change the DB. So be careful.
    the report will give you the difference between the objects in the repository and the database.

  • Forward and reverse timeline?

    Hey im using flash CS3 with actionscript 2.0. what i want to
    create is a column for an online magazine, the column will display
    a list of content, this list will be longer than it appears and
    have a "next" and "prev" buttons located at the bottom. i can set
    it up so than when next is clicked the content shifts and displays
    more, the problem is, what do i do about the "prev" button? i cant
    make the timeline play in reverse can i? i have a test FLA at
    www.waffleconezone.com/test.html ..
    thanks!

    that code works.  if it's not working for you it's because you're not using it correctly.
    to play movieclip abc in reverse use:
    playReverse(abc);
    // and it would be better to use:
    function playReverse(mc:MovieClip){
    if(!mc.reverseTempMC){
    mc.createEmptyMovieClip("reverseTempMC",1);
    mc.reverseTempMC.onEnterFrame=function(){
    this._parent.prevFrame();
    if(this._parent._currentframe==1){
    delete this.onEnterFrame()
    this.removeMovieClip();

  • Designer and Reverse Engineering Entire Database

    Does anyone know of any good papers, books, articles, etc to help out with Designer. I really am having trouble finding anything.
    What I am trying to do is capture an entire database into a new repository and I am plagued with errors. I'm a developer and really weak with Designer knowledge. I also want to find information on how I should organize my repository. Should each schema have its own application system folder if the schemas share/link information between one another?

    Hi,
    One book that I have always found good is the Oracle Designer Handbook by Paul Dorsey and Peter Koletzke. Although it's a bit long in the tooth now (only goes upto v6 I think), it's still very useful.
    The Oracle Designer Product Info link is at http://www.oracle.com/technology/products/designer/index.html
    What sort of errors are you getting? I presume you either have a live connection to the database or the DDL?
    Without knowing the contents of your schema, it usually makes sense to group each one into its own application system, subject to the number of tables, etc. If you have tables which are referenced by other schemas, they can be put into one application system and shared to the other application systems as applicable.
    Try and let us know a bit more about what you're trying to do.
    rgds, Antony

  • F5-asm and ace forward and reverse traffic

    Hi all,
    In our datacentre setup , we have f5 asm & ace- cisco for loadbalancing
    in which f5 is configured with  self ip& below the selfip,the  nodeip is there which is inturn the
    virtual ip for Ace t2 context
    the incoming traffic on f5 is like
    Publicip:xx--> f5.selfip:80-->Ace virtualip:yy
    for the ace request handling is of below
    Ace.virtualip:yy-->Rserver:xx
    but here the issue is that reverse http response flow is some what not analogous
    rserver:xx-->f5.selfip:80 & back to the Public ip
    myquery is that why the reply back from the rserver is not given back to ace virtual ip, but to the
    selfip of f5

    Good morning,
    You need to configure your routing in a way that the return traffic goes through the ACE. If you don't,  you may end up in the situation you are seeing
    Daniel

  • JDeveloper capabilities for Reverse Engineering existing instances and data

    We are experiencing difficulty obtaining the indexes, synonyms, and triggers via reverse-engineering capture of existing 10g DB's. Does JDeveloper have the capabilities for Reverse Engineering all objects from existing DB's ?
    Will 10g JDeveloper handle reverse-engineering large 300 table schemas rich with large quantity of indexes, synonyms, & triggers?
    And last, how can a listing of the Data Dictionary be extracted /exported in CSV or excel format for review distribution? Via JDeveloper? We have a large distributed development, test, quality, and integration team which prefers to review various elements of schema updates and changes in excel.
    Thanx.

    Vicki-
    Thanks for the additional info. I was thinking you were most concerned with reverse-engineering existing schemas. I did not realize you were designing new schemas.
    When you mention ERDs, are you interested in logical ERDs (as compared to physical tables and foreign keys)? If you are interested in doing pure logical ERD modelling, then Designer is the way to go. It has been years since I worked with Designer, but it has ooodles of capabilities to forward and reverse engineer between databases, physical models, and logical models of schemas. It sounds like you might be using Designer today and are hitting some snags. Is this the case? If so, I suggest you see if Oracle Support or the Designer forum can help you get past the specific Designer issues. The forum for Oracle Designer is here: Designer
    Sue mention that JDeveloper does support database modelling. Here is a how-to for JDeveloper 11g that shows how it works:
    http://www.oracle.com/technology/obe/obe11jdev/11/db_dev/obe_%20databasedevmt.htm
    The how-to is pretty complete showing you forward and reverse engineering capabilities.
    A few more minor notes:
    1.The JDeveloper schema modelling features work on a physical (not logical) level. In other words, they work on tables not entities.
    2.The SQL Developer report features certainly work on "DATA". But, the "DATA" they work on can certainly be the data dictionary data. In other words, I can write a report in SQL Developer that queries all of the column names, column data types for a subset of tables. Then I can export that "DATA" into excel and use it for whatever your downstream needs are. The potential capabilities are practically unlimited.
    Cheers,
    -dave

  • In iOS 7 I am no longer able to use the forward and revese keys when listening to music or spoken word

    I use my iPhone in the car. It has been a really useful feature to be able to fast forward and reverse buttons on the steering wheel when listening to an iBook. This no longer works with iO7 and I am really disappointed that I now have to revert to using the keys on the iPhone rather than the cars steering wheel. I also now get regular warnings that the cables I am using were not made for the iPhone. I bought them from Apple direct so what

    Hi,
    Try the following.
    Download the IDT Audio installer on the link below and save it to your Downloads folder.
    http://ftp.hp.com/pub/softpaq/sp50501-51000/sp50856.exe
    When done, open windows Control Panel, open Device Manager and open up Sound, Video and Game Controllers.  Right click the IDT device and select Uninstall - you should also get a prompt to remove the current driver, tick the box to allow this and then proceed with the uninstall.
    When complete, restart the notebook and let Windows fully load.  Open your Downloads folder, right click on the IDT installer and select 'Run as Administrator' to start the installation.  When this has completed, restart the notebook again.
    Regards,
    DP-K
    ****Click the White thumb to say thanks****
    ****Please mark Accept As Solution if it solves your problem****
    ****I don't work for HP****
    Microsoft MVP - Windows Experience

  • Profiling and UML reverse engineering

    Hi,
    I just downloaded the latest jdev905preview and so far the compiling and running works fine for my Java application. Unfortunately the (event/execution/memory)profiling options are disabled, is there any way to turn it on or it's a "feature" in the preview?
    Also I am wondering is there reverse engineering like in Togethersoft's ControlCenter where you can reconstruct back the class and sequence diagrams from existing source code?
    Thanks
    Aaron

    Aaron,
    Not sure on the first point. Are you using the JDK inside JDeveloper? If not I think you need to Install OJVM in the JDK you are using, see the release notes for more information.
    As for the second point, any Java code that you have in JDeveloper can be dragged and dropped onto a Class Diagram and it will then model your code. Sequence diagramming is still not yet available in JDeveloper.
    Thanks,
    Lisa Sherriff
    JDev QA

Maybe you are looking for