Bpelx:exec does not work?

Hi,
I an trying to set the Instance title via Java but what ever I do I get this error:
[2007/03/25 16:59:08] "XMLDOMException" has been thrown.less
ugyldigt navneområde for præfikset xmlns
My Java code looks like this:
        <bpelx:exec name="Java_Embedding_1" language="java" version="1.4">
          <![CDATA[String title = "qwerty"; 
setTitle(getTitle() + title);]]>
        </bpelx:exec>Anybody got an idea what is going wrong?
Regards Pete

Peter,
Did you apply all the the patches :-) (80+), I had this issue months ago and I can remember that it had to do with the DOM level 1 vs. level2 issue. It was solved by applying this patch. Look at my blog, http://orasoa.blogspot.com, fo a list of patches that I normally use, including this patch.
Marc

Similar Messages

  • Runtime.getRuntime().exec() does not work after JRE upgradation

    I have upgraded JRE from 1.3.0_02 to 1.3.1_15. After this upgrade, Runtime.getRuntime().exec() has suddenly stopped working. If I downgrade to 1.3.0_02, it starts working again.
    Please help.

    It has definitely forked, and this is the child process. It says so. If it was the parent process it would just show Java code related to launching processes. That does not involve PKCS11. After the fork there are two identical processes with the same stack: the child process of the fork goes on to replace itself with the target command via Unix exec(), which it doesn't look like it is succeeding at. The parent process doesn't do much at all, probably just housekeeping and then a Unix wait() for Process.waitFor() to hook into.

  • Runtime.exec does not work for commands with lengthy outputs

    I need to use Runtime.exec to run some custom commands on a Unix box. I have been doing this for quite some time now and had begun to feel comfortable when recently I started facing a problem. The thing is, whenever there is a command which prints a lot of data on to the console, the program is not able to exit from the waitFor method. Is there some thing that can be done about this?
    Following is a part of the code I use:
    Runtime rt = Runtime.getRuntime();
    Process p = rt.exec (command);
    System.out.println ("Got the process");
    int exitValue = p.waitFor();
    System.out.println ("Exit value: " + exitValue);When the output of the "command" is lengthy, it hangs after printing "Got the process".
    PS: By lengthy output, I mean that the command results in printing lines to the console which might be more than 100 in number. Say, something like what "ls -R /" would do in Unix / Linux.

    From java.lang.Process API doc:
    The Runtime.exec methods may not work well for special processes on certain native platforms, such as native windowing processes, daemon processes, Win16/DOS processes on Microsoft Windows, or shell scripts. The created subprocess does not have its own terminal or console. All its standard io (i.e. stdin, stdout, stderr) operations will be redirected to the parent process through three streams (Process.getOutputStream(), Process.getInputStream(), Process.getErrorStream()). The parent process uses these streams to feed input to and get output from the subprocess. Because some native platforms only provide limited buffer size for standard input and output streams, failure to promptly write the input stream or read the output stream of the subprocess may cause the subprocess to block, and even deadlock.
    So you need to consume the process' output. Check the StreamGobbler example from this article.
    Hope it helps.

  • Runtime.exec() does not work normally

    I try to wrapper the oracle connect command on unix using this function:
    runtime.exec("sqlplus username/password@dbinstance")
    it is ok on windows, but on unix, after runing the class, I get nothing. what is the problem?
    Please help me. thanks

    There are several traps with runtime.exec(). The most important one is that you should read
    the output stream of the launched program. Otherwise it will stop running when the console buffer overflows. The size of the buffer differs for various OSes.
    Look at this article:
    http://www.javaworld.com/javaworld/jw-12-2000/jw-1229-traps.html
    It it does not answer your problem, try to search the forums:
    http://search.java.sun.com/Search/java?qt=%2B%22exec%22+-%22Replies%3A+0%22&col=javafrm&rf=0&qp=%2Bforum%3A31
    This problem has been asked hundreds of times.
    Hope, this helps.

  • Runtime.exec() does not work under Linux

    Hi,
    I have a generic application runner class that runs an external
    program and redirects stdout/stderr to a buffer/file.
    While everythings works just fine under Windows, I get the
    following exception under Linux trying to run the Java interpreter
    'java':
    java.io.IOException: "/usr/lib/SunJava2-1.3.1/jre/bin/java": not found
    at java.lang.UNIXProcess.forkAndExec(Native Method)
    at java.lang.UNIXProcess.<init>(UNIXProcess.java:139)
    at java.lang.Runtime.execInternal(Native Method)
    at java.lang.Runtime.exec(Runtime.java:546)
    at java.lang.Runtime.exec(Runtime.java:413)
    I have checked that the file /usr/lib/SunJava2-1.3.1/jre/bin/java
    exists.
    Any help appreciated!
    Marc

    can I ask how you solved it? I am having a problem
    with quotes just now to and it might help me!I simply tested what the current platform is and
    only used quotes under Windows.
    Marc

  • Runtime.exec() does not work?

    I'm trying to invoke a C++ executable from java using the Runtime.exec() method. The C++ application accepts a filename as a command line argument & opens the file. This C++ app is unicode enabled i.e. it can accept UTF-16 (wide char) parameters. Howevere, when i invoke this application using Java's Runtime.exec() and specify a japanese file name as an argument, the japanese characters get converted to '?' characters by the time they are received in the C++ application. I'm running this application on Windows 2K, default i.e. English version.
    Looking at the source code of Runtime class, it seems that the exec()
    function makes use of a native helper function - execInternal(). Does
    this function support the entire unicode range?
    Is there any way we can avoid the conversion of japanese characters to '?' characters? Also, is there any other alternative for invoking an external application with Unicode (Say, japanese) arguments?
    Please reply ASAP.
    Thanks!

    >
    I'm trying to invoke a C++ executable from java using
    the Runtime.exec() method. The C++ application accepts
    a filename as a command line argument & opens the
    file. This C++ app is unicode enabled i.e. it can
    accept UTF-16 (wide char) parameters. Howevere, when i
    invoke this application using Java's Runtime.exec()
    and specify a japanese file name as an argument, the
    japanese characters get converted to '?' characters by
    the time they are received in the C++ application. I'm
    running this application on Windows 2K, default i.e.
    English version.
    Looking at the source code of Runtime class, it seems
    that the exec()
    function makes use of a native helper function -
    execInternal(). Does
    this function support the entire unicode range?I don't know because I've never tested this case specifically.
    You didn't show your code though. How are you reading in the String? You mentioned that you passed a Japanese character String as a filename argument. I also read that you are running on an English Win2K platform. How did you read that argument in? It may just be that you read the argument in your default encoding(English) and you needed to specify an alternate one.

  • Discoverer Reports does not work in Multi-org Environment after R12 Upgrade

    Discoverer Reports does not work in Multi-org Environment after R12 Upgrade. Created a simple report using the below query:
    SELECT po_header_id, segment1, type_lookup_code
    FROM po_headers
    WHERE segment1 = '5000002'
    Query works perfectly fine; when i set the ORG_CONTEXT in the database using the command:
    EXEC mo_global.set_policy_context('S',129)
    But the report doesn't fetch any data when ran from an Org based responsibility. We've ensured that the MO: Operting Unit is set accurately and general Oracle reports (PLSQL Program OR XML Publisher) are working perfectly fine.
    ===========
    I followed the steps provided in Metalink Note: 732826.1 - It works for some responsibilities where the MO: Security Profile is not set; but fails for those responsibilities where the MO: Security Profile is set.
    I am looking for specific solution that works irrespective of either the MO: Operating Unit profile is set of not.
    Please suggest. Appreciate your response.
    Thanks,
    Kesava Chunduri

    Hi Hussein,
    Thanks for the quick response.
    Yes, I've gone thru both the notes specified below:
    Discoverer Workbooks Based On Organization Enabled Views Are Not Populated [ID 1293438.1]
    - Tried this option; but this option is messing up a couple of Oracle Standard Functionalities.
    - For ex: If i set this profile option; we are not able to create any receipts using Custom Responsibilities.
    I am able to create the receipt, when i remove this profile option.
    No Data Shows for Reports in Discoverer 10g with Applications Release 12 [ID 1054380.1]
    - I see that the products i am running these reports from AR/GL - already exists in these tables.
    Anything other options??
    Thanks,
    Kesava

  • LD_ASSUME_KERNEL does not work in recent distros. How to avoid?

    LD_ASSUME_KERNEL=2.4.XX does not work in all recent distros.
    $ export LD_ASSUME_KERNEL=2.4.20
    $ ls
    ls: error while loading shared libraries: librt.so.1: cannot open shared object
    EBS contains very old cmponents like MWA wich not compiled without this setting. How to avoid errors?

    You can unset LD_ASSUME_KERNEL and EBS 11i (11.5.9 and 11.5.10) will work fine on 2.6.16 kernels (SLES-10 and RH 5.0).
    The following instructions should get you going:
    1) Setup the environment as you would for running Applications on RH 4 or SLES9
    I.E. follow Oracle Applications Installation Update Notes, Release 11i (11.5.10.2)
    http://metalink.oracle.com/metalink/plsql/ml2_documents.showDocument?p_database_id=NOT&p_id=316806.1
    2) Remove any LD_ASSUME_KERNEL references in O/S /etc/profile.d files
    3) Comment out LD_ASSUME_KERNEL entries in $ORACLE_HOME/appsutil/bin/adgetlnxver.sh and $AD_TOP/bin/adgetlnxver.sh
    if [ ${setflag}x = "x" -a $os = "Suse" ]; then
    # LD_ASSUME_KERNEL="2.4.21"
    # export LD_ASSUME_KERNEL
         os="Suse"
    fi
    if [ ${setflag}x = "x" -a $os = "RH" ]; then
    # LD_ASSUME_KERNEL="2.4.19"
    # export LD_ASSUME_KERNEL
         os = "RH"
    fi
    If doing a rapid install, the database startup will fail and rapidwiz will prompt to ignore or retry. At this point, edit $ORACLE_HOME/appsutil/bin/adgetlnxver.sh as shown above and click on retry. It will then run to the autoconfig step at the end and error out. Just hit cancel, edit $AD_TOP/bin/adgetlnxver.sh and run autoconfig.
    On Suse, one needs compat-gdbm for libgdbm.so.2
    rpm -Uhv compat-gdbm-1.8.0-7.i586.rpm
    Preparing... ########################################### [100%]
    1:compat-gdbm ########################################### [100%]
    Also in /usr/lib run ln -s libdb.so.2 libdb.so.3
    Ref:
    Note:300807.1 for Suse
    create symbolic link called libdb.so.2 pointing to libdb.so.3, as follows:
    $ cd /usr/lib
    $ ln -s libdb.so.3 libdb.so.2 (or install db1-1.85-85.1 which does the same)
    Note:294043.1 for Red Hat
    As per an internal Bug 4045349, this is an issue with O/S side installation of compat-db rpm.
    libdb.so.3 gets installed when compat-db rpm is installed.
    - The O/S installation CD would contain compat-db
    e.g compat-db-4.1.25-6.i386.rpm ( may change as per your version ).
    - Manually install the compat-db rpm
    e..g "rpm -ivh compat-db-4.1.25-6.i386.rpm"
    OR
    Note:345172.1
    A library is missing: libdb.so.2 is from gnome-libs-1.4.1.2.90-34.1.i386.
    This error also occurs in SLES9, same cause, slightly different resolution. SLES9 comes with libdb.so.3 and libdb.so.4 but not libdb.so.2 - need to install db1-1.85-85.1 to get libdb.so.2.
    4) In order to relink cplex library executables (MSC, MSO, MSR, MST, WIP, etc), edit $AD_TOP/bin/adrelinknew.sh and add the following LD option (-Wl,--noinhibit-exec) in the LINUX section:
    LINUX)
    LDFLAGS='-s -L$(ORACLE_HOME)/lib -L$(ORACLE_HOME)/lib/stubs -ldl'
    DEBUG_LDFLAGS='-g -L$(ORACLE_HOME)/lib -L$(ORACLE_HOME)/lib/stubs -ldl'
    exe_line='ELF .*executable'
    SHRLIB_LD='gcc'
    LD='gcc'
    SHRLIB_LDFLAGS='-L$(ORACLE_HOME)/lib -L$(ORACLE_HOME)/lib/stubs -shared'
    if test -f "/etc/redhat-release"; then
         CPP_LIBS='/usr/lib/libstdc++-2-libc6.1-1-2.9.0.so'
    elif test -f "/etc/SuSE-release"; then
         CPP_LIBS='/usr/lib/libstdc++.so.2.9'
    else
    CPP_LIBS=''
    fi
    CPP='g++'
    CPP_LDFLAGS='-s -L$(ORACLE_HOME)/lib -L$(ORACLE_HOME)/lib/stubs
    set CPP_LDFLAGS='-s -L$(ORACLE_HOME)/lib -L$(ORACLE_HOME)/lib/stubs
    to CPP_LDFLAGS='-s -L$(ORACLE_HOME)/lib -L$(ORACLE_HOME)/lib/stubs -Wl,--noinhibit-exec'
    After this chance, you can apply any MRP, ASCP patch and all executables will relink correctly. You can also use adadmin to relink all executables and it completes without error.
    5) Discoverer 4.1.38.08 Follow Metalink Note 280598.1 Discoverer 4i On Linux: Required Patch and Configuration for Discoverer Server Stability to use JDK 1.3.1 and oadj. I updated the autoconfig template files with this change after applying 3895177. Discoverer viewer and plus standard BIS reports all open correctly on SLES-10

  • MAC Authentication does not work

    My MAC Authentication does not work.
    I have a ACS 3.0 server set. the MAC address is set in the user name field and in the password field.
    I can ping the ACS, I can ping my AP, I can ping my client.
    I don't want WEP and I don't want LEAP just MAC. So I set my authentication to "Open with MAC" My client has WEP set to NO WEP and authentication to OPEN
    I have the latest drivers for both AP and my 350 Client.
    I see that the client is associating and disassociating back and forth non stop. My AP log is full with the following message:
    Station 0009.7c9f.xxxx Authentication failed
    this is my config:
    version 12.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname GOM_1200IOS
    aaa new-model
    aaa group server radius rad_eap
    aaa group server radius rad_mac
    server 10.1.2.197 auth-port 1812 acct-port 1812
    aaa group server radius rad_acct
    aaa group server radius rad_admin
    aaa group server tacacs+ tac_admin
    aaa group server radius rad_pmip
    aaa group server radius dummy
    aaa group server radius wlccp_rad_infra
    aaa group server radius wlccp_rad_eap
    aaa group server radius wlccp_rad_leap
    aaa group server radius wlccp_rad_mac
    aaa group server radius wlccp_rad_any
    aaa group server radius wlccp_rad_acct
    aaa authentication login eap_methods group rad_eap
    aaa authentication login mac_methods local
    aaa authentication login wlccp_infra group wlccp_rad_infra
    aaa authentication login wlccp_eap_client group wlccp_rad_eap
    aaa authentication login wlccp_leap_client group wlccp_rad_leap
    aaa authentication login wlccp_mac_client group wlccp_rad_mac
    aaa authentication login wlccp_any_client group wlccp_rad_any
    aaa authorization exec default local
    aaa authorization ipmobile default group rad_pmip
    aaa accounting network acct_methods start-stop group rad_acct
    aaa accounting network wlccp_acct_client start-stop group wlccp_rad_acct
    aaa session-id common
    enable secret xxxxxx
    username Cisco password xxxx
    ip subnet-zero
    iapp standby timeout 5
    bridge irb
    interface Dot11Radio0
    no ip address
    no ip route-cache
    encryption key 1 size 40bit 7 9DF1C10BF11A transmit-key
    ssid GOM_1230
    authentication open mac-address mac_methods
    speed basic-1.0 basic-2.0 basic-5.5 basic-11.0
    rts threshold 2312
    channel 2462
    station-role root
    no cdp enable
    dot1x reauth-period server
    dot1x client-timeout 600
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    bridge-group 1 spanning-disabled
    interface FastEthernet0
    no ip address
    no ip route-cache
    duplex auto
    speed auto
    no cdp enable
    bridge-group 1
    no bridge-group 1 source-learning
    bridge-group 1 spanning-disabled
    interface BVI1
    ip address 172.16.43.45 255.255.240.0
    no ip route-cache
    ip default-gateway 172.16.47.254
    ip http server
    ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag/ivory/1100
    ip radius source-interface BVI1
    access-list 700 permit 000a.b74c.e8c9 0000.0000.0000
    access-list 700 permit 0009.7c9f.d6e0 0000.0000.0000
    access-list 700 permit 0006.25b1.2f79 0000.0000.0000
    access-list 700 permit 000a.b78b.2d19 0000.0000.0000
    access-list 700 permit 000b.5f6e.77c8 0000.0000.0000
    access-list 700 deny 0000.0000.0000 ffff.ffff.ffff
    access-list 701 deny 000b.5f6e.77c8 0000.0000.0000
    access-list 701 permit 0000.0000.0000 ffff.ffff.ffff
    no cdp run
    snmp-server community GOM_AP1230 RO
    snmp-server enable traps tty
    radius-server local
    group AP1230
    user brazil nthash 7 1249523544595F517972017912677A3055325A25770B08770D5C5B4E4478087605 group AP1230
    radius-server host 10.1.2.197 auth-port 1812 acct-port 1812 key 7 00233C2B
    radius-server retransmit 3
    radius-server attribute 32 include-in-access-req format %h
    radius-server authorization permit missing Service-Type
    radius-server vsa send accounting
    bridge 1 route ip
    line con 0
    line vty 5 15
    end
    What is wrong?
    Thanks very much for your help.

    I figured out what was wrong so thank you for stopping by.
    I will publish the config for other people to see.
    Regards,

  • Bind variable peeking does not work

    Oracle 9.2.0.8
    create table my_table (c number);
    create index i on my_table(c);
    declare
    par varchar2(10);
    begin
    par:='qqq';
    for rec in (select * from my_table t where c = par or par is null )loop null; end loop;
    --USES FULL TABLE SCAN, works SLOW!!!
    --but the same query with constat insted of bind variable :
    for rec in (select * from my_table t where c = par or 'qqq' is null )loop null; end loop;
    --USES INDEX i ON column c ,  works FAST!!!
    --WHY bind variable peeking does not work ???
    end;
    Thank you for reply

    sqlplus:
    drop table my_table;
    create table my_table as select object_name as c from all_objects where rownum<=1000;
    insert into my_table select * from my_table;
    insert into my_table select * from my_table;
    insert into my_table select * from my_table;
    insert into my_table select * from my_table;
    insert into my_table select * from my_table;
    insert into my_table select * from my_table;
    commit;
    select count(1) from my_table;
    COUNT(1)
    64000
    create index my_table_idx on my_table(c);
    exec dbms_stats.gather_table_stats('bogdanov','my_table',cascade=>true)
    variable par varchar2(10)
    exec :par := 'www'
    --FIRST CASE                                             
    explain plan for select * from my_table where c=:par or 'www'='qqq';
    @?\rdbms\admin\utlxpls
    PLAN_TABLE_OUTPUT
    | Id | Operation | Name | Rows | Bytes | Cost |
    | 0 | SELECT STATEMENT | | 64 | 1792 | 3 |
    |* 1 | INDEX RANGE SCAN | MY_TABLE_IDX | 64 | 1792 | 3 |
    Predicate Information (identified by operation id):
    1 access("MY_TABLE"."C"=:Z)
    --SECOND CASE                                             
    explain plan for select * from my_table where c=:par or :par='qqq';
    PLAN_TABLE_OUTPUT
    | Id | Operation | Name | Rows | Bytes | Cost |
    | 0 | SELECT STATEMENT | | 703 | 19684 | 95 |
    |* 1 | TABLE ACCESS FULL | MY_TABLE | 703 | 19684 | 95 |
    Predicate Information (identified by operation id):
    1 filter("MY_TABLE"."C"=:Z OR :Z='qqq')
    --THIRD CASE very strange....  COMPARE IT WITH FIRST CASE: 123456789 vs. 'qqq'    
    explain plan for select * from my_table where c=:par or 'www'=123456789;
    @?\rdbms\admin\utlxpls
    PLAN_TABLE_OUTPUT
    | Id | Operation | Name | Rows | Bytes | Cost |
    | 0 | SELECT STATEMENT | | 703 | 19684 | 95 |
    |* 1 | TABLE ACCESS FULL | MY_TABLE | 703 | 19684 | 95 |
    Predicate Information (identified by operation id):
    1 filter("MY_TABLE"."C"=:Z OR TO_NUMBER(:Z)=123456789)
    Edited by: user450084 on Dec 9, 2008 5:17 AM
    Edited by: user450084 on Dec 9, 2008 5:27 AM

  • Unscheduling propagation does not work.

    When I try to unschedule the propagation, it does not work. I tried as following command:
    exec DBMS_AQADM.UNSCHEDULE_PROPAGATION(queue_name => 'TEST_Q1',
    destination => 'dbpm.phonon');
    So I tried to shutdown the job_queue_process, but it did not performed correctly. I used the command of
    alter system set job_queue_processes = 0;
    But the snp process did not killed even if the parameter was changed '0' value.
    RDBMS version is Oracle8i (8.1.6.3.0) and Platform is SunOS.
    Could you give me advice?
    Thanks in advance,
    Phyllis

    Thanks for your reply in advance.
    As a result, there's no any error messages.
    I tried to unschedule the AQ queueing propagation schedule via
    exec dbms_aqadm.unschedule_propagation. It appeared to hang
    (nothing response so long time). So hit the key <CTRL-C>.
    And I reattempted the previous process. But I haven't got any
    message. There's no response even if I attemped it for several
    times.

  • Sp_send_dbmail does not work with attachment

    Using sql server 2012. 
    I am using the following code to send query results as attachment to an email. It works in one of my sproc and does not work in the other. The only difference is the query, the attachment file name, subject and body message. bothe are executed under the same
    user.
    Please help me understand why this problem, or suggest alternate solution. This user does not have permission to use xp_cmdshell, and is not sysadmin.
    Thank You.
    [code]
    DECLARE @query NVARCHAR(MAX)
    DECLARE @DatePostFix varchar(8) =  CONVERT(VARCHAR(8), GETDATE(), 112)
    Declare @AttachmentFileName varchar(300) = 'Eligible_Customers_'+@DatePostFix+'.csv'
    DECLARE @query_result_separator CHAR(1) = char(9); --comma
    SET @query = 'set nocount on;select * from EligibleCustomers order by survey_designator desc; set nocount off;';
    EXEC msdb.dbo.sp_send_dbmail
     @profile_name     = 'MyDBAutomatedMailer',
          @recipients       = '[email protected]',                                               
          @subject          = 'Monthly Eligible Patients for Press Ganey Rpt.',
          @body             = 'Attached is your Monthly Eligible Customers Rpt.',
          @body_format      = 'HTML',
          @importance       = 'High',
          @query_attachment_filename = @AttachmentFileName,
          @attach_query_result_as_file = 1, 
          @query_result_header = 1, -- include column headers
          @exclude_query_output = 1, -- still seems to include query output (number of rows) & so using set nocount on
          @query_result_width = 1000,  
          @append_query_error = 1,
          @query_result_no_padding = 1, -- do not pad columns
          @query_result_separator = @query_result_separator,
          @query = @query;
    [/code]

    I have tried similar way and it worked fine for me. So I think nothing wrong with the code. Please see below post to fix this issue.
    http://technet.microsoft.com/en-us/library/ms188719(v=sql.105).aspx
    When u try your code is it giving any error???
    ESHANI. Please click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if a post has been useful to you

  • Cisco 1841 as PPTP client Does not work

    Dear All,
    I have Cisco 1841 router running the below roles       
    1) SSL VPN Server
    2) PPTP Server
    3) Site to Site Connection with Sonicwall router
    I want the router to be configured a pptp client to internet vpn server (so that i will get a fixed public ip )
    Once i get this ip address i want to use this connection to accept in coming connection and forward ports to internal host,
    I went through below
    http://www.mreji.eu/content/cisco-router-pptp-client
    https://supportforums.cisco.com/thread/2167562
    But it does not work as i do not have the option for the below 2 commands in vpdn-group 2 section.(Please see section in blue)
    protocol pptp
      rotary-group 4
    Please Advise and Help
    Regards
    Hasan Reza
    My Current Config is as below
    =~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2013.06.09 17:55:23 =~=~=~=~=~=~=~=~=~=~=~=
    exit
    Gateway#show run |      
    Building configuration...
    Current configuration : 25109 bytes
    ! Last configuration change at 13:33:57 UTC Sun Jun 9 2013 by admin
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname Gateway
    boot-start-marker
    boot system flash c1841-advsecurityk9-mz.151-2.T1.bin
    boot-end-marker
    logging buffered 4096
    no logging console
    enable secret 5 $1$SciF$TlX1tR5qaG9ZE7pdZHcRJ/
    no aaa new-model
    dot11 syslog
    ip source-route
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.236.5.1 10.236.5.20
    ip dhcp excluded-address 10.236.5.21 10.236.5.50
    ip dhcp excluded-address 172.21.51.2 172.21.51.50
    ip dhcp pool ContosoPool
       network 10.236.5.0 255.255.255.0
       default-router 10.236.5.254
       dns-server 213.42.20.20 195.229.241.222
    ip dhcp pool DMZ
       network 172.21.51.0 255.255.255.0
       dns-server 172.21.51.10
       default-router 172.21.51.1
       domain-name contoso.local
    ip cef
    ip domain name contoso.local
    ip name-server 213.42.20.20
    ip name-server 195.229.241.22
    ip name-server 195.229.241.222
    ip ddns update method dyndns
    HTTP
      add http://xxxxxx:[email protected]/nic/update?system=dyndns&hostname=<h>&myip=<a>
      remove http://xxxxxx:yyyyy@@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
    interval maximum 0 1 0 0
    multilink bundle-name authenticated
    vpdn enable
    vpdn-group 2
    request-dialin
      protocol l2tp
    initiate-to ip 173.195.0.42
    vpdn-group RAS-VPN
    ! Default PPTP VPDN group
    accept-dialin
      protocol pptp
      virtual-template 1
    l2tp tunnel timeout no-session 15
    crypto pki token default removal timeout 0
    crypto pki trustpoint TP.StartSSL.CA
    enrollment terminal pem
    revocation-check none
    crypto pki trustpoint TP.StartSSL-vpn
    enrollment terminal pem
    usage ssl-server
    serial-number none
    fqdn ssl.spktelecom.com
    ip-address none
    revocation-check crl
    rsakeypair RSA.StartSSL-vpn
    crypto pki trustpoint TP-self-signed-1981248591
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1981248591
    revocation-check none
    rsakeypair TP-self-signed-1981248591
    crypto pki trustpoint VMWare
    enrollment terminal
    revocation-check crl
    crypto pki trustpoint OWA
    enrollment terminal pem
    revocation-check crl
    crypto pki certificate chain TP.StartSSL.CA
    certificate ca 01
      (removed the certificate info for clarity)
       quit
    crypto pki certificate chain TP.StartSSL-vpn
    certificate 0936E1
        (removed the certificate info for clarity)9
       quit
    certificate ca 18
      (removed the certificate info for clarity)
       quit
    crypto pki certificate chain TP-self-signed-1981248591
    certificate self-signed 01
        (removed the certificate info for clarity)
       quit
    crypto pki certificate chain VMWare
    certificate ca 008EDCE6DBCE6B
        (removed the certificate info for clarity)
       quit
    crypto pki certificate chain OWA
       (removed the certificate info for clarity)
    license udi pid CISCO1841 sn FCZ122191TW
    archive
    log config
      hidekeys
    username admin privilege 15 password 7 1304131F02023B7B7977
    username ali password 7 06070328
    redundancy
    crypto isakmp policy 10
    encr 3des
    authentication pre-share
    group 2
    lifetime 84000
    crypto isakmp key admin_123 address 0.0.0.0 0.0.0.0
    crypto isakmp keepalive 10
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec transform-set vpnset esp-3des esp-sha-hmac
    crypto ipsec transform-set strongsha esp-3des esp-sha-hmac
    crypto dynamic-map mydyn 10
    set transform-set strongsha
    crypto map Dxb-Auh 1000 ipsec-isakmp dynamic XXXXXXXXXX
    interface FastEthernet0/0
    description Internal Network (Protected Interface)
    ip address 10.236.5.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    pppoe enable group global
    pppoe-client dial-pool-number 1
    interface ATM0/0/0
    no ip address
    shutdown
    no atm ilmi-keepalive
    interface BRI0/1/0
    no ip address
    encapsulation hdlc
    shutdown
    interface Virtual-Template1
    ip unnumbered Dialer1
    peer default ip address dhcp-pool ContosoPool
    ppp encrypt mppe auto required
    ppp authentication ms-chap ms-chap-v2 eap
    interface Dialer1
    ip ddns update hostname XXXXXXX.dyndns.org
    ip ddns update dyndns
    ip address negotiated
    ip nat outside
    ip virtual-reassembly in
    encapsulation ppp
    ip tcp adjust-mss 1450
    dialer pool 1
    ppp pap sent-username vermam password 7 13044E155E0913323B
    crypto map Dxb-Auh
    interface Dialer2
    mtu 1460
    ip address negotiated
    ip nat outside
    ip virtual-reassembly in
    encapsulation ppp
    dialer in-band
    dialer idle-timeout 0
    dialer string 123
    dialer vpdn
    dialer-group 2
    ppp pfc local request
    ppp pfc remote apply
    ppp encrypt mppe auto
    ppp authentication ms-chap ms-chap-v2 callin
    ppp eap refuse
    ppp chap hostname hasanreza
    ppp chap password 7 070E2541470726544541
    interface Dialer995
    no ip address
    ip local pool webssl 10.236.6.10 10.236.6.30
    ip forward-protocol nd
    ip http server
    ip http secure-server
    ip nat inside source list nat interface Dialer1 overload
    ip nat inside source static tcp 10.236.5.12 25 interface Dialer1 25
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 172.21.51.0 255.255.255.0 10.236.5.253
    ip access-list extended internal
    permit ip any 10.236.5.0 0.0.0.255
    ip access-list extended nat
    deny   ip 10.236.5.0 0.0.0.255 172.31.1.0 0.0.0.255
    deny   ip 10.236.5.0 0.0.0.255 172.19.19.0 0.0.0.255
    permit ip 10.236.5.0 0.0.0.255 any
    ip access-list extended nonat
    permit ip 10.236.5.0 0.0.0.255 172.19.19.0 0.0.0.255
    permit ip 10.236.5.0 0.0.0.255 172.31.1.0 0.0.0.255
    ip access-list extended sslacl
    ip access-list extended webvpn
    permit tcp any any eq 443
    logging esm config
    access-list 101 permit ip 10.236.5.0 0.0.0.255 172.31.1.0 0.0.0.255
    control-plane
    line con 0
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    login local
    transport preferred ssh
    transport input telnet ssh
    line vty 5 15
    exec-timeout 0 0
    login local
    transport preferred ssh
    transport input telnet ssh
    scheduler allocate 20000 1000
    webvpn gateway gateway1
    ip interface Dialer1 port 443
    ssl encryption rc4-md5
    ssl trustpoint TP.StartSSL-vpn
    inservice
    webvpn install svc flash:/webvpn/anyconnect-win-3.1.00495-k9.pkg sequence 1
    webvpn install csd flash:/webvpn/sdesktop.pkg
    webvpn context webvpn
    ssl authenticate verify all
    url-list "Webservers"
       heading "SimpleIT Technologies NBNS Servers"
       url-text "Google" url-value "www.google.com"
       url-text "Mainframe" url-value "10.236.5.2"
       url-text "Mainframe2" url-value "https://10.236.5.2"
    nbns-list "ContosoServer"
       nbns-server 10.236.5.10
       nbns-server 10.236.5.11
       nbns-server 10.236.5.12
    port-forward "PortForwarding"
       local-port 3389 remote-server "10.236.5.10" remote-port 3389 description "Server-DC01"
    policy group policy1
       url-list "Webservers"
       port-forward "PortForwarding"
       nbns-list "ContosoServer"
       functions file-access
       functions file-browse
       functions file-entry
       functions svc-enabled
       svc address-pool "webssl"
       svc default-domain "Contoso.Local"
       svc keep-client-installed
       svc split include 10.236.5.0 255.255.255.0
       svc split include 10.236.6.0 255.255.255.0
       svc split include 172.31.1.0 255.255.255.0
       svc split include 172.21.51.0 255.255.255.0
       svc dns-server primary 172.21.51.10
    default-group-policy policy1
    gateway gateway1
    inservice
    end
    Gateway#          

    Dear All,
    I have Cisco 1841 router running the below roles       
    1) SSL VPN Server
    2) PPTP Server
    3) Site to Site Connection with Sonicwall router
    I want the router to be configured a pptp client to internet vpn server (so that i will get a fixed public ip )
    Once i get this ip address i want to use this connection to accept in coming connection and forward ports to internal host,
    I went through below
    http://www.mreji.eu/content/cisco-router-pptp-client
    https://supportforums.cisco.com/thread/2167562
    But it does not work as i do not have the option for the below 2 commands in vpdn-group 2 section.(Please see section in blue)
    protocol pptp
      rotary-group 4
    Please Advise and Help
    Regards
    Hasan Reza
    My Current Config is as below
    =~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2013.06.09 17:55:23 =~=~=~=~=~=~=~=~=~=~=~=
    exit
    Gateway#show run |      
    Building configuration...
    Current configuration : 25109 bytes
    ! Last configuration change at 13:33:57 UTC Sun Jun 9 2013 by admin
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname Gateway
    boot-start-marker
    boot system flash c1841-advsecurityk9-mz.151-2.T1.bin
    boot-end-marker
    logging buffered 4096
    no logging console
    enable secret 5 $1$SciF$TlX1tR5qaG9ZE7pdZHcRJ/
    no aaa new-model
    dot11 syslog
    ip source-route
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.236.5.1 10.236.5.20
    ip dhcp excluded-address 10.236.5.21 10.236.5.50
    ip dhcp excluded-address 172.21.51.2 172.21.51.50
    ip dhcp pool ContosoPool
       network 10.236.5.0 255.255.255.0
       default-router 10.236.5.254
       dns-server 213.42.20.20 195.229.241.222
    ip dhcp pool DMZ
       network 172.21.51.0 255.255.255.0
       dns-server 172.21.51.10
       default-router 172.21.51.1
       domain-name contoso.local
    ip cef
    ip domain name contoso.local
    ip name-server 213.42.20.20
    ip name-server 195.229.241.22
    ip name-server 195.229.241.222
    ip ddns update method dyndns
    HTTP
      add http://xxxxxx:[email protected]/nic/update?system=dyndns&hostname=<h>&myip=<a>
      remove http://xxxxxx:yyyyy@@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>
    interval maximum 0 1 0 0
    multilink bundle-name authenticated
    vpdn enable
    vpdn-group 2
    request-dialin
      protocol l2tp
    initiate-to ip 173.195.0.42
    vpdn-group RAS-VPN
    ! Default PPTP VPDN group
    accept-dialin
      protocol pptp
      virtual-template 1
    l2tp tunnel timeout no-session 15
    crypto pki token default removal timeout 0
    crypto pki trustpoint TP.StartSSL.CA
    enrollment terminal pem
    revocation-check none
    crypto pki trustpoint TP.StartSSL-vpn
    enrollment terminal pem
    usage ssl-server
    serial-number none
    fqdn ssl.spktelecom.com
    ip-address none
    revocation-check crl
    rsakeypair RSA.StartSSL-vpn
    crypto pki trustpoint TP-self-signed-1981248591
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1981248591
    revocation-check none
    rsakeypair TP-self-signed-1981248591
    crypto pki trustpoint VMWare
    enrollment terminal
    revocation-check crl
    crypto pki trustpoint OWA
    enrollment terminal pem
    revocation-check crl
    crypto pki certificate chain TP.StartSSL.CA
    certificate ca 01
      (removed the certificate info for clarity)
       quit
    crypto pki certificate chain TP.StartSSL-vpn
    certificate 0936E1
        (removed the certificate info for clarity)9
       quit
    certificate ca 18
      (removed the certificate info for clarity)
       quit
    crypto pki certificate chain TP-self-signed-1981248591
    certificate self-signed 01
        (removed the certificate info for clarity)
       quit
    crypto pki certificate chain VMWare
    certificate ca 008EDCE6DBCE6B
        (removed the certificate info for clarity)
       quit
    crypto pki certificate chain OWA
       (removed the certificate info for clarity)
    license udi pid CISCO1841 sn FCZ122191TW
    archive
    log config
      hidekeys
    username admin privilege 15 password 7 1304131F02023B7B7977
    username ali password 7 06070328
    redundancy
    crypto isakmp policy 10
    encr 3des
    authentication pre-share
    group 2
    lifetime 84000
    crypto isakmp key admin_123 address 0.0.0.0 0.0.0.0
    crypto isakmp keepalive 10
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec transform-set vpnset esp-3des esp-sha-hmac
    crypto ipsec transform-set strongsha esp-3des esp-sha-hmac
    crypto dynamic-map mydyn 10
    set transform-set strongsha
    crypto map Dxb-Auh 1000 ipsec-isakmp dynamic XXXXXXXXXX
    interface FastEthernet0/0
    description Internal Network (Protected Interface)
    ip address 10.236.5.254 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    duplex auto
    speed auto
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    pppoe enable group global
    pppoe-client dial-pool-number 1
    interface ATM0/0/0
    no ip address
    shutdown
    no atm ilmi-keepalive
    interface BRI0/1/0
    no ip address
    encapsulation hdlc
    shutdown
    interface Virtual-Template1
    ip unnumbered Dialer1
    peer default ip address dhcp-pool ContosoPool
    ppp encrypt mppe auto required
    ppp authentication ms-chap ms-chap-v2 eap
    interface Dialer1
    ip ddns update hostname XXXXXXX.dyndns.org
    ip ddns update dyndns
    ip address negotiated
    ip nat outside
    ip virtual-reassembly in
    encapsulation ppp
    ip tcp adjust-mss 1450
    dialer pool 1
    ppp pap sent-username vermam password 7 13044E155E0913323B
    crypto map Dxb-Auh
    interface Dialer2
    mtu 1460
    ip address negotiated
    ip nat outside
    ip virtual-reassembly in
    encapsulation ppp
    dialer in-band
    dialer idle-timeout 0
    dialer string 123
    dialer vpdn
    dialer-group 2
    ppp pfc local request
    ppp pfc remote apply
    ppp encrypt mppe auto
    ppp authentication ms-chap ms-chap-v2 callin
    ppp eap refuse
    ppp chap hostname hasanreza
    ppp chap password 7 070E2541470726544541
    interface Dialer995
    no ip address
    ip local pool webssl 10.236.6.10 10.236.6.30
    ip forward-protocol nd
    ip http server
    ip http secure-server
    ip nat inside source list nat interface Dialer1 overload
    ip nat inside source static tcp 10.236.5.12 25 interface Dialer1 25
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 172.21.51.0 255.255.255.0 10.236.5.253
    ip access-list extended internal
    permit ip any 10.236.5.0 0.0.0.255
    ip access-list extended nat
    deny   ip 10.236.5.0 0.0.0.255 172.31.1.0 0.0.0.255
    deny   ip 10.236.5.0 0.0.0.255 172.19.19.0 0.0.0.255
    permit ip 10.236.5.0 0.0.0.255 any
    ip access-list extended nonat
    permit ip 10.236.5.0 0.0.0.255 172.19.19.0 0.0.0.255
    permit ip 10.236.5.0 0.0.0.255 172.31.1.0 0.0.0.255
    ip access-list extended sslacl
    ip access-list extended webvpn
    permit tcp any any eq 443
    logging esm config
    access-list 101 permit ip 10.236.5.0 0.0.0.255 172.31.1.0 0.0.0.255
    control-plane
    line con 0
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    login local
    transport preferred ssh
    transport input telnet ssh
    line vty 5 15
    exec-timeout 0 0
    login local
    transport preferred ssh
    transport input telnet ssh
    scheduler allocate 20000 1000
    webvpn gateway gateway1
    ip interface Dialer1 port 443
    ssl encryption rc4-md5
    ssl trustpoint TP.StartSSL-vpn
    inservice
    webvpn install svc flash:/webvpn/anyconnect-win-3.1.00495-k9.pkg sequence 1
    webvpn install csd flash:/webvpn/sdesktop.pkg
    webvpn context webvpn
    ssl authenticate verify all
    url-list "Webservers"
       heading "SimpleIT Technologies NBNS Servers"
       url-text "Google" url-value "www.google.com"
       url-text "Mainframe" url-value "10.236.5.2"
       url-text "Mainframe2" url-value "https://10.236.5.2"
    nbns-list "ContosoServer"
       nbns-server 10.236.5.10
       nbns-server 10.236.5.11
       nbns-server 10.236.5.12
    port-forward "PortForwarding"
       local-port 3389 remote-server "10.236.5.10" remote-port 3389 description "Server-DC01"
    policy group policy1
       url-list "Webservers"
       port-forward "PortForwarding"
       nbns-list "ContosoServer"
       functions file-access
       functions file-browse
       functions file-entry
       functions svc-enabled
       svc address-pool "webssl"
       svc default-domain "Contoso.Local"
       svc keep-client-installed
       svc split include 10.236.5.0 255.255.255.0
       svc split include 10.236.6.0 255.255.255.0
       svc split include 172.31.1.0 255.255.255.0
       svc split include 172.21.51.0 255.255.255.0
       svc dns-server primary 172.21.51.10
    default-group-policy policy1
    gateway gateway1
    inservice
    end
    Gateway#          

  • Sorting does not work  with ROW_NUMBER () OVER (ORDER BY

    CREATE OR REPLACE PROCEDURE SP_SALES (
    p_sales_id IN VARCHAR2,
    p_rownnum_from IN NUMBER,
    p_rownnum_to IN NUMBER,
    p_sort_by IN VARCHAR2,
    p_query OUT SYS_REFCURSOR,
    AS
    v_query VARCHAR2 (32000);
    v_sort_list VARCHAR2(32000) ;
    BEGIN
    IF p_spv_sort_by IS NULL THEN
    v_sort_list := 'given_name ASC ' ;
    ELSE
    v_sort_list :=p_spv_sort_by;
    END IF ;
    DBMS_OUTPUT.PUT_LINE ('v_sort_list '||v_sort_list);
    OPEN p_query FOR
    SELECT sales_id,
    item_id,
    order_num,
    employee_name
    ,given_name
    dept_id,
    manager_name,
    ROW_NUM
    FROM
    (SELECT x.*,
    ROW_NUMBER () OVER (ORDER BY v_sort_list ) ROW_NUM
    FROM (sales_id,
    item_id,
    order_num,
    employee_name
    ,given_name
    dept_id,
    manager_name,
    FROM order rvw,
    sales pol,
    emp ca,
    WHERE pol.id = rvw.pr_order_id
    AND ca.empid =pol.employee_id
    AND status = 'SUP') x )
    WHERE ROW_NUM BETWEEN p_rownnum_from AND p_rownnum_to;
    -- ORDER by v_sort_list ;
    DBMS_OUTPUT.PUT_LINE ('v_sort_list '||v_sort_list);
    EXCEPTION
    WHEN OTHERS THEN
    DBMS_OUTPUT.PUT_LINE ('EX ');
    END;
    END;
    SHOW ERRORS
    Sorting does not work. Am I doing something wrong here?
    executing procedure using below
    declare
    x SYS_REFCURSOR;
    y number;
    BEGIN
    SP_SALES('70159_502',1,5, 'GIVEN_NAME'||' ASC' ,:x);
    --dbms_output.put_line (:x);
    END;

    Hello
    Depending on how many different columns you can sort on and the data types of them, it may be feasible for you to include the conditional logic in the existing statement without the need for dynamic sql...
    DTYLER_APP@pssdev2> var p_spv_sort_by varchar2(100)
    DTYLER_APP@pssdev2>
    DTYLER_APP@pssdev2> exec :p_spv_sort_by:='some other column'
    PL/SQL procedure successfully completed.
    P_SPV_SORT_BY
    some other column
    DTYLER_APP@pssdev2>
    DTYLER_APP@pssdev2> WITH source AS
      2  (   SELECT 'a' given_name, 'z' other_column from dual UNION ALL
      3      SELECT 'b' given_name, 'y' other_column from dual UNION ALL
      4      SELECT 'c' given_name, 'x' other_column from dual
      5  )
      6  SELECT
      7      given_name,
      8      other_column,
      9      ROW_NUMBER ()
    10     OVER (
    11        ORDER BY
    12           CASE
    13              WHEN :p_spv_sort_by IS NULL THEN given_name
    14              WHEN :p_spv_sort_by = 'some other column' THEN other_column
    15           END)
    16        ROW_NUM
    17  FROM
    18      source
    19  /
    G O    ROW_NUM
    c x          1
    b y          2
    a z          3
    3 rows selected.
    DTYLER_APP@pssdev2> exec :p_spv_sort_by:=NULL;
    PL/SQL procedure successfully completed.
    P_SPV_SORT_BY
    DTYLER_APP@pssdev2> WITH source AS
      2  (   SELECT 'a' given_name, 'z' other_column from dual UNION ALL
      3      SELECT 'b' given_name, 'y' other_column from dual UNION ALL
      4      SELECT 'c' given_name, 'x' other_column from dual
      5  )
      6  SELECT
      7      given_name,
      8      other_column,
      9      ROW_NUMBER ()
    10     OVER (
    11        ORDER BY
    12           CASE
    13              WHEN :p_spv_sort_by IS NULL THEN given_name
    14              WHEN :p_spv_sort_by = 'some other column' THEN other_column
    15           END)
    16        ROW_NUM
    17  FROM
    18      source
    19  /
    G O    ROW_NUM
    a z          1
    b y          2
    c x          3
    3 rows selected.
    DTYLER_APP@pssdev2>But that would depend on the columns you're sorting on being of the same data type or at least having the ability to convert them to the same data type without loosing the sort order.
    DTYLER_APP@pssdev2> WITH source AS
      2  (   SELECT 'a' given_name, sysdate - 2 other_column from dual UNION ALL
      3      SELECT 'b' given_name, sysdate - 1 other_column from dual UNION ALL
      4      SELECT 'c' given_name, sysdate  other_column from dual
      5  )
      6  SELECT
      7      given_name,
      8      other_column,
      9      ROW_NUMBER ()
    10     OVER (
    11        ORDER BY
    12           CASE
    13              WHEN :p_spv_sort_by IS NULL THEN given_name
    14              WHEN :p_spv_sort_by = 'some other column' THEN other_column
    15           END)
    16        ROW_NUM
    17  FROM
    18      source
    19  /
                WHEN :p_spv_sort_by = 'some other column' THEN other_column
    ERROR at line 14:
    ORA-00932: inconsistent datatypes: expected CHAR got DATE
    DTYLER_APP@pssdev2> WITH source AS
      2  (   SELECT 'a' given_name, sysdate - 2 other_column from dual UNION ALL
      3      SELECT 'b' given_name, sysdate - 1 other_column from dual UNION ALL
      4      SELECT 'c' given_name, sysdate  other_column from dual
      5  )
      6  SELECT
      7      given_name,
      8      other_column,
      9      ROW_NUMBER ()
    10     OVER (
    11        ORDER BY
    12           CASE
    13              WHEN :p_spv_sort_by IS NULL THEN given_name
    14              WHEN :p_spv_sort_by = 'some other column' THEN TO_CHAR(other_column,'YYYYMMDDHH24MISS')
    15           END)
    16        ROW_NUM
    17  FROM
    18      source
    19  /
    G OTHER_COLUMN            ROW_NUM
    a 12-SEP-2011 15:04:19          1
    b 13-SEP-2011 15:04:19          2
    c 14-SEP-2011 15:04:19          3
    3 rows selected.HTH
    David

  • Java 7 U25 work around does not work for windows 8

    I'm working on a java application which uses the statistical software R. This line Process p = Runtime.getRuntime().exec(C:\Program Files\R\R-2.15.1 + "/bin/" + "R CMD BATCH " + "./data/rJava.R");  in the application started throwing an error after the java 7 u25 update, but it was fixed by using the work around setting jdk.lang.Process.allowAmbigousCommands to true. This fix however does not work in windows 8, although the command does not error out with "cannot create process = 2" it just executes the line, but does nothing. But if I typed the command (R CMD BATCH " + "./data/rJava.R) directly into the commandline, it works perfectly. I've tried disabling the work around, and actually using suggested solutions in the release notes (see below), all worked in windows 7, but no success with windows 8. Any suggestions would be great
    Process p = new ProcessBuilder("c:\\Program File\\foo.exe").start();
    Process p = Runtime.getRuntime().exec(new String[] { "c:\\Program File\\foo.exe" });
    Process p = Runtime.getRuntime().exec("\"c:\\Program File\\foo.exe\"");

    avancentcisco - Win7 works fine with SSL VPN. But since we all were migrating to Win8, this was of no use to us. So we ditched SSL VPN all together.
    IPSec VPN with Cisco VPN Client (version 5.0.07) works absolutely fine on Windows 8. Once you get the set up right, everything works fine (we are using full tunnel) including internet access.
    If you struggle to get it working then let me know and I can help you out. There's not much info out there on the internet. I had to do it the hard way.

Maybe you are looking for

  • Mac for Office: de-install and install

    I'm getting a new macbook pro and have office for mac on my existing powerbook. Only have one license and assuming I can't load on both so....can I de-install from the powerbook and then install on the new pro? If so, how do I de-install? Powerbook G

  • Game Streaming said that I don't have enough bandwidth to play. I have DSL connection

    All I get in response is the error code 5001-9 telling me my bandwidth isn't fast enough suggests DSL or Cable. I already have DSL By Verizon and it's just been upgrading to the latest version. Please give me answers to this problem. Thank You

  • Corrupted iTunes Store Video Download?

    I've tried downloading an episode of Scrubs five times now that I bought off of the iTunes music store. But, every time, after it starts processing, it stops downloading and a message pops up saying, "There was a problem downloading "My Intern's Eyes

  • Solenoid Control with LabVIEW

    Hey everyone, Im brand new to LabView and I am in need of some assitance. Ive attached a picture of my block diagram setup. I need help with making the LabView code in order to help run this setup. I want to use LabView to activate my photoelectric s

  • Unable to connect target /

    Hi, I have Oracle 10gR2 10.2.0.3 db on Solaris. I use EM to backup the db to the disk. I was able to connect to the db but today I am getting an error. $ . oraenv ORACLE_SID = [prod_db] rman Recovery Manager: Release 10.2.0.3.0 - Production on Mon Ma