Break out of Gateway branches

I have a process that requires 10 people to review and approve a form before it can move on.  It does not need to be sequential and time is of the essence, so I have used a gateway and created 10 different branches.  The issue is that if any one of the 10 people deny the request, all the others should receive an email notification and the process should end.  I could put 3 routes out of each review step with the names "approve", "deny" and "cancel".  Then, if one denies, an email notification would go out to the rest of the approvers informing them that it has been denied and they can just hit "cancel" to complete the process.  What is the best practice approach to accomplish this?  Should I invoke a subprocess that will go through and automatically complete the tasks at the other review tasks?  Is there a good sample to do this?
Thanks!

I hope event will help you on this requirement.
You could drop a throw event on each deny route and can complete the other tasks by writing a receive event.
Nith

Similar Messages

  • Dmvpn + local break out to the internet

    Hi, 
    I have a dmvpn network, with multiple spokes.
    One of them, needs to have a local break out to the internet.
    Wasn't able to find a configuration example, so maybe if someone could show how to config it.
    Basically what I need is a split tunnel configuration, to redirect the internet traffic outside of the vpn-tunnel.
    here's the config of my router,
    hostname testrouter
    boot-start-marker
    boot-end-marker
    aaa new-model
    aaa group server radius testradius
     server name PRO007
    no ip domain lookup
    ip domain name test-domain
    ip inspect WAAS flush-timeout 10
    ip cef
    no ipv6 cef
    track 1 list threshold percentage
     object 101
     object 102
     delay down 180 up 5
    track 101 ip sla 1 reachability
    track 102 ip sla 2 reachability
    crypto isakmp policy 10
     encr aes 256
     group 5
    crypto isakmp profile ISAKMP-DMVPN-CA
       self-identity fqdn
       ca trust-point sec-ca
       match identity host domain alert.local
       keepalive 60 retry 10
    crypto ipsec transform-set ESP-AES256-SHA-TRANSP esp-aes 256 esp-sha-hmac 
     mode transport
    crypto ipsec profile ESP-AES256-SHA-CA
     set transform-set ESP-AES256-SHA-TRANSP 
     set isakmp-profile ISAKMP-DMVPN-CA
    interface Loopback0
     ip address 10.168.244.134 255.255.255.255
    interface Tunnel0
     bandwidth 5000
     ip address 10.168.246.134 255.255.254.0
     no ip redirects
     no ip proxy-arp
     ip mtu 1400
     ip nhrp authentication DMVPN_05
     ip nhrp map 10.168.246.1 xxx.xxx.xxx.xxx
     ip nhrp map 10.168.246.2 xxx.xxx.xxx.xxy
     ip nhrp map multicast xxx.xxx.xxx.xxx
     ip nhrp map multicast xxx.xxx.xxx.xxy
     ip nhrp network-id 121
     ip nhrp holdtime 600
     ip nhrp nhs 10.168.246.1
     ip nhrp nhs 10.168.246.2
     ip nhrp registration no-unique
     tunnel source FastEthernet4
     tunnel mode gre multipoint
     tunnel key 121
     tunnel path-mtu-discovery
     tunnel protection ipsec profile ESP-AES256-SHA-CA shared
    interface FastEthernet0
     no ip address
     spanning-tree portfast
    interface FastEthernet1
     no ip address
     spanning-tree portfast
    interface FastEthernet2
     no ip address
     spanning-tree portfast
    interface FastEthernet3
     no ip address
     spanning-tree portfast
    interface FastEthernet4
     ip address dhcp client-id FastEthernet4
     ip access-group INET-INBOUND in
     no ip proxy-arp
     duplex auto
     speed auto
    interface Vlan1
     ip address 10.169.6.177 255.255.255.248
     no ip proxy-arp
    router eigrp 1
     distribute-list EIGRP-PERMIT-OUT out Tunnel0
     network 10.0.0.0
     passive-interface default
     no passive-interface Tunnel0
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip route xxx.xxx.xxx.xxy 255.255.255.255 FastEthernet4 dhcp
    ip route xxx.xxx.xxx.xxx 255.255.255.255 FastEthernet4 dhcp
    ip route xxx.xxx.xxx.xxw 255.255.255.255 FastEthernet4 dhcp
    ip access-list standard EIGRP-PERMIT-OUT
     permit 10.169.0.0 0.0.31.255
     permit 10.168.244.0 0.0.1.255
    ip access-list extended INET-INBOUND
     permit udp any any eq bootpc
     permit esp host xxx.xxx.xxx.xxy4 any
     permit gre host xxx.xxx.xxx.xxy4 any
     permit udp host xxx.xxx.xxx.xxy4 eq 2000 any
     permit udp host xxx.xxx.xxx.xxy4 any eq isakmp
     permit udp host xxx.xxx.xxx.xxy4 any eq non500-isakmp
     permit esp host xxx.xxx.xxx.xxy5 any
     permit gre host xxx.xxx.xxx.xxy5 any
     permit udp host xxx.xxx.xxx.xxy5 eq 2000 any
     permit udp host xxx.xxx.xxx.xxy5 any eq isakmp
     permit udp host xxx.xxx.xxx.xxy5 any eq non500-isakmp
     permit tcp host 193.164.88.196 eq www any
     permit udp host 193.164.88.196 eq 123 any
     permit icmp any any unreachable
     permit icmp any any echo-reply
     permit icmp any any time-exceeded
     deny   ip 10.0.0.0 0.0.0.255 any
     deny   ip 172.16.0.0 0.0.16.255 any
     deny   ip 192.168.0.0 0.0.255.255 any
     deny   ip 127.0.0.0 0.255.255.255 any
     deny   ip host 255.255.255.255 any
     deny   ip any any
    ip radius source-interface Tunnel0
    ip sla 1
     udp-echo 10.168.246.1 2000 control disable
     threshold 3000
     timeout 3500
     frequency 4
    ip sla schedule 1 life forever start-time now
    ip sla 2
     udp-echo 10.168.246.1 2000 control disable
     threshold 3000
     timeout 3500
     frequency 4
    ip sla schedule 2 life forever start-time now
    snmp-server community rvssnmp RO
    snmp-server location BX
    snmp-server contact Securitas RVS team
    radius server SECEUAD001
     address ipv4 193.164.88.2 auth-port 1645 acct-port 1646
     key 0 V8gUp9avUruprec
    line con 0
     exec-timeout 60 0
     privilege level 15
    line aux 0
    line vty 0 4
     exec-timeout 60 0
     transport input telnet ssh
     transport output telnet ssh
    ntp server 10.168.246.1
    ntp server 10.168.246.2
    ntp server 193.164.88.196
    ntp update-calendar
    end

    That's how it would work by default. 
    Only tunnel IPs and those defined by EIGRP will go through the Tunnel interface. 
    Please provide output of show ip route to see your gateway of last resort.. 

  • Breaking out of a for-in-a-for-in-a-for

    I have a question about how the break statement works. Take this:
    for (int i = 0; i < 10; i++) {
         for (int j = 0; j < 10; j++) {
              for (int k = 0; k < 10; k++) {
                   if (something) {
                        break;
    }Am I right in saying this will only break out of the very inner for loop? What I want is a way to break out the very inner and second inner for loops, but NOT the outer. Is there a way to do this? Thanks!

    Darryl.Burke wrote:
    I would prefer to factor that out into its own method.private void method() {
    for (int i = 0; i < 10; i++) {
    for (int j = 0; j < 10; j++) {
    for (int k = 0; k < 10; k++) {
    if (something) {
    return;
    }db(Being not bright enough to think in three dimensions concurrently, let alone four) I hate deep-nested-loops.
    class Cube ....
      private boolean contains(T target) {
        for (int y=0; y<NUM_ROWS; y++) {
          if (rowContains(target, y)) return true;
      private boolean rowContains(T target, int y) {
        for (int x=0; x<NUM_COLS; x++) {
          if (colContains(target, y, x)) return true;
        return false;
      private boolean colContains(T target, int y, int x) {
        for (int z=0; z<CELL_SIZE; z++) {
          if (cube[y][x][z].equals(target)) return true;
        return false;
      }... and hows about a CellVisitor to encapsulate all that nasty repeated for-x-for-y-for-z code.... a tad slower but (unless you're algoracing) who really gives a flying toss.
    Just another alternative.
    ;-) Keith.

  • How can I use Pinnacle break-out box to capture in CS5

    A colleague uses Pinnacle's break-out box to capture analog video directly through CS4, bypassing Studio.
    I have CS5, and bought Pinnacle Studio 14.
    But when I open CAPTURE in CS5, I get a "capture device offline" statement. Anyone got any ideas?
    CL

    Or...
    Old forum message, message now gone, but here's the summary - I have not used, only made note of the product "Matt with Grass Valley
    Canopus in their tech support department stated that the 110 will suffice for most hobbyist. If a person has a lot of tapes that were
    played often the tape stretches and the magnetic coding diminishes. If your goal is to encode tapes in good shape buy the 110, if you
    will be encoding old tapes of poor quality buy the 300"
    http://www.grassvalley.com/products/advc55 One Way Only to Computer
    http://www.grassvalley.com/products/advc110 for good tapes, or
    http://www.grassvalley.com/products/advc300 better with OLD tapes
    Or ADS Pyro http://www.adstechnologies.com
    ADS Pyro $120 http://www.bhphotovideo.com/c/product/462759-REG/ADS_Technologies_API_557_EFS_PYRO_A_V_Lin k_with.html
    Pyro has low rating @Newegg and low at BHPV
    Below said... I have the ADS Pyro AV Link and it works flawlessly and it bypasses MacroVision
    http://forum.videohelp.com/threads/275966-Is-Canopus-50-55-100-110-REALLY-god-s-gift-to-th e-VHS-capture-universe
    ADVC55 $159 http://www.bhphotovideo.com/c/product/312315-REG/Grass_Valley_602005_ADVC_55_Analog_to_Dig ital.html
    ADVC55 has higher ratings at BHPV with very few low ratings and also high rating @Newegg
    Next Article said Liked the ADVC55's picture quality the best
    http://www.macworld.com/reviews/product/406056/review/advc55.html

  • How do I stop iTunes from breaking out all the songs in one album into multiple albums?

    How do I stop iTunes from breaking out all the songs in one album into multiple albums when the artist has many collaborators on the different songs, for example Timbaland?  I want to just listen to the full album with all the songs, instead of having to play every song separately.

    For your solution, see Steve MacGuire's helpful article:  http://samsoft.org.uk/iTunes/grouping.asp

  • My wife has iCloud on our computer and I want to break out and create my own account. Once I build the account how do I copy the address book from her account into mine?

    my wife has icloud on our computer and I want to break out and create my own icloud account. I've built the account but can't figure out how to COPY our joint address book onto my account so I can then weed out my own addresses. Please help!

    Welcome to the Apple Community.
    When you log out of the joint account, you should be asked if you want to keep the contacts, you do. When you log into your new account you should be asked if you want to merge contacts, you do.
    If you have already signed into your new account and not taken these options, the simplest thing to do might be to add your wife's account back as a secondary account in system preferences > mail, contacts & calendars. In groups in address book you can drag contacts from your wife's contacts onto your contact group to copy them.

  • Loop with WMI Query taking too long, need to break out if time exceeds 5 min

    I've written a script that will loop through a list of computers and run a WMI query using the Win32_Product class. I am pinging the host first to ensure its online which eliminates wasting time but the issue I'm facing is that some of the machines
    are online but the WMI Query takes too long and holds up the script. I wanted to add a timeout to the WMI query so if a particular host will not respond to the query or gets stuck the loop will break out an go to the next computer object. I've added my code
    below:
    $Computers = @()
    $computers += "BES10-BH"
    $computers += "AUTSUP-VSUS"
    $computers += "AppClus06-BH"
    $computers += "Aut01-BH"
    $computers += "AutLH-VSUS"
    $computers += "AW-MGMT01-VSUS"
    $computers += "BAMBOOAGT-VSUS"
    ## Loop through all computer objects found in $Computes Array
    $JavaInfo = @()
    FOREACH($Client in $Computers)
    ## Gather WMI installed Software info from each client queried
    Clear-Host
    Write-Host "Querying: $Client" -foregroundcolor "yellow"
    $HostCount++
    $Online = (test-connection -ComputerName ADRAP-VSUS -Count 1 -Quiet)
    IF($Online -eq "True")
    $ColItem = Get-WmiObject -Class Win32_Product -ComputerName $Client -ErrorAction SilentlyContinue | `
    Where {(($_.name -match "Java") -and (!($_.name -match "Auto|Visual")))} | `
    Select-Object Name,Version
    FOREACH($Item in $ColItem)
    ## Write Host Name as variable
    $HostNm = ($Client).ToUpper()
    ## Query Named Version of Java, if Java is not installed fill variable as "No Java Installed
    $JavaVerName = $Item.name
    IF([string]::IsNullOrEmpty($JavaVerName))
    {$JavaVerName = "No Installed"}
    ## Query Version of Java, if Java is not installed fill variable as "No Java Installed
    $JavaVer = $Item.Version
    IF([string]::IsNullOrEmpty($JavaVer))
    {$JavaVer = "Not Installed"}
    ## Create new object to organize Host,JavaName & Version
    $JavaProp = New-Object -TypeName PSObject -Property @{
    "HostName" = $HostNm
    "JavaVerName" = $JavaVerName
    "JavaVer" = $JavaVer
    ## Add new object data "JavaProp" from loop into array "JavaInfo"
    $JavaInfo += $JavaProp
    Else
    {Write-Host "$Client didn't respond, Skipping..." -foregroundcolor "Red"}

    Let me give you a bigger picture of the script. I've included the emailed table the script produces and the actual script. While running the script certain hosts get hung up when running the WMI query which causes the script to never complete. From one of
    the posts I was able to use the Get-WmiCustom function to add a timeout 0f 15 seconds and then the script will continue if it is stuck. The problem is when a host is skipped I am not aware of it because my script is not reporting the server that timed out.
    If you look at ZLBH02-VSUS highlighted in the report you can see that its reporting not installed when it should say something to the effect query hung.
    How can I add a variable in the function that will be available outside the function that I can key off of to differentiate between a host that does not have the software installed and one that failed to query?
    Script Output:
    Script:
    ## Name: JavaReportWMI.ps1 ##
    ## Requires: Power Shell 2.0 ##
    ## Created: January 06, 2015 ##
    <##> $Version = "Script Version: 1.0" <##>
    <##> $LastUpdate = "Updated: January 06, 2015" <##>
    ## Configure Compliant Java Versions Below ##
    <##> $java6 = "6.0.430" <##>
    <##> $javaSEDEVKit6 = "1.6.0.430" <##>
    <##> $java7 = "7.0.710" <##>
    <##> $javaSEDEVKit7 = "1.7.0.710" <##>
    <##> $java8 = "8.0.250" <##>
    <##> $javaSEDDEVKit8 = "1.8.0.250" <##>
    ## Import Active Directory Module
    Import-Module ActiveDirectory
    $Timeout = "False"
    Function Get-WmiCustom([string]$computername,[string]$namespace,[string]$class,[int]$timeout=15)
    $ConnectionOptions = new-object System.Management.ConnectionOptions
    $EnumerationOptions = new-object System.Management.EnumerationOptions
    $timeoutseconds = new-timespan -seconds $timeout
    $EnumerationOptions.set_timeout($timeoutseconds)
    $assembledpath = "\\" + $computername + "\" + $namespace
    #write-host $assembledpath -foregroundcolor yellow
    $Scope = new-object System.Management.ManagementScope $assembledpath, $ConnectionOptions
    $Scope.Connect()
    $querystring = "SELECT * FROM " + $class
    #write-host $querystring
    $query = new-object System.Management.ObjectQuery $querystring
    $searcher = new-object System.Management.ManagementObjectSearcher
    $searcher.set_options($EnumerationOptions)
    $searcher.Query = $querystring
    $searcher.Scope = $Scope
    trap { $_ } $result = $searcher.get()
    return $result
    ## Log time for duration clock
    $Start = Get-Date
    $StartTime = "StartTime: " + $Start.ToShortTimeString()
    ## Environmental Variables
    $QueryMode = $Args #parameter for either "Desktops" / "Servers"
    $CsvPath = "C:\Scripts\JavaReport\JavaReport" + "$QueryMode" + ".csv"
    $Date = Get-Date
    $Domain = $env:UserDomain
    $HostName = ($env:ComputerName).ToLower()
    ## Regional Settings
    ## Used for testing
    IF ($Domain -eq "abc") {$Region = "US"; $SMTPDomain = "abc.com"; `
    $ToAddress = "[email protected]"; `
    $ReplyDomain = "abc.com"; $smtpServer = "relay.abc.com"}
    ## Control Variables
    $FromAddress = "JavaReport@$Hostname.na.$SMTPDomain"
    $EmailSubject = "Java Report - $Region"
    $computers = @()
    $computers += "ZLBH02-VSUS"
    $computers += "AUTSUP-VSUS"
    $computers += "AppClus06-BH"
    $computers += "Aut01-BH"
    $computers += "AutLH-VSUS"
    $computers += "AW-MGMT01-VSUS"
    $computers += "BAMBOOAGT-VSUS"
    #>
    ## Loop through all computer objects found in $Computes Array
    $JavaInfo = @()
    FOREACH($Client in $Computers)
    ## Gather WMI installed Software info from each client queried
    Clear-Host
    Write-Host "Querying: $Client" -foregroundcolor "yellow"
    $HostCount++
    $Online = (test-connection -ComputerName ADRAP-VSUS -Count 1 -Quiet)
    IF($Online -eq "True")
    $ColItem = Get-WmiCustom -Class Win32_Product -Namespace "root\cimv2" -ComputerName $Client -ErrorAction SilentlyContinue | `
    Where {(($_.name -match "Java") -and (!($_.name -match "Auto|Visual")))} | `
    Select-Object Name,Version
    FOREACH($Item in $ColItem)
    ## Write Host Name as variable
    $HostNm = ($Client).ToUpper()
    ## Query Named Version of Java, if Java is not installed fill variable as "No Java Installed
    $JavaVerName = $Item.name
    IF([string]::IsNullOrEmpty($JavaVerName))
    {$JavaVerName = "No Installed"}
    ## Query Version of Java, if Java is not installed fill variable as "No Java Installed
    $JavaVer = $Item.Version
    IF([string]::IsNullOrEmpty($JavaVer))
    {$JavaVer = "Not Installed"}
    ## Create new object to organize Host,JavaName & Version
    $JavaProp = New-Object -TypeName PSObject -Property @{
    "HostName" = $HostNm
    "JavaVerName" = $JavaVerName
    "JavaVer" = $JavaVer
    ## Add new object data "JavaProp" from loop into array "JavaInfo"
    $JavaInfo += $JavaProp
    Else
    {Write-Host "$Client didn't respond, Skipping..." -foregroundcolor "Red"}
    #Write-Host "Host Query Count: $LoopCount" -foregroundcolor "yellow"
    ## Sort Array
    Write-Host "Starting Array" -foregroundcolor "yellow"
    $JavaInfoSorted = $JavaInfo | Sort-object HostName
    Write-Host "Starting Export CSV" -foregroundcolor "yellow"
    ## Export CSV file
    $JavaInfoSorted | export-csv -NoType $CsvPath -Force
    $Att = new-object Net.Mail.Attachment($CsvPath)
    Write-Host "Building Table Header" -foregroundcolor "yellow"
    ## Table Header
    $list = "<table border=1><font size=1.5 face=verdana color=black>"
    $list += "<tr><th><b>Host Name</b></th><th><b>Java Ver Name</b></th><th><b>Ver Number</b></th></tr>"
    Write-Host "Building HTML Table" -foregroundcolor "yellow"
    FOREACH($Item in $JavaInfoSorted)
    Write-Host "$UniqueHost" -foregroundcolor "Yellow"
    ## Alternate Table Shading between Green and White
    IF($LoopCount++ % 2 -eq 0)
    {$BK = "bgcolor='E5F5D7'"}
    ELSE
    {$BK = "bgcolor='FFFFFF'"}
    ## Set Variables
    $JVer = $Item.JavaVer
    $Jname = $Item.JavaVerName
    ## Change Non-Compliant Java Versions to red in table
    IF((($jVer -like "6.0*") -and (!($jVer -match $java6))) -or `
    (($jName -like "*Java(TM) SE Development Kit 6*") -and (!($jName -match $javaSEDEVKit6))) -or `
    (($jVer -like "7.0*") -and (!($jVer -match $java7))) -or `
    (($jName -like "*Java SE Development Kit 7*") -and (!($jName -match $javaSEDEVKit7))))
    $list += "<tr $BK style='color: #ff0000'>"
    ## Compliant Java version are displayed in black
    ELSE
    $list += "<tr $BK style='color: #000000'>"
    ## Populate table with host name variable
    $list += "<td>" + $Item."HostName" + "</td>"
    ## Populate table with Java Version Name variable
    $list += "<td>" + $Item."JavaVerName" + "</td>"
    ## Populate table with Java Versionvariable
    $list += "<td>" + $Item."JavaVer" + "</td>"
    $list += "</tr>"
    $list += "</table></font>"
    $End = Get-Date
    $EndTime = "EndTime: " + $End.ToShortTimeString()
    #$TimeDiff = New-TimeSpan -Start $StartTime -End $EndTime
    $StartTime
    $EndTime
    $TimeDiff
    Write-Host "Total Hosts:$HostCount"
    ## Email Function
    Function SendEmail
    $msg = new-object Net.Mail.MailMessage
    $smtp = new-object Net.Mail.SmtpClient($smtpServer)
    $msg.From = ($FromAddress)
    $msg.ReplyTo =($ToAddress)
    $msg.To.Add($ToAddress)
    #$msg.BCC.Add($BCCAddress)
    $msg.Attachments.Add($Att)
    $msg.Subject = ($EmailSubject)
    $msg.Body = $Body
    $msg.IsBodyHTML = $true
    $smtp.Send($msg)
    $msg.Dispose()
    ## Email Body
    $Body = $Body + @"
    <html><body><font face="verdana" size="2.5" color="black">
    <p><b>Java Report - $Region</b></p>
    <p>$list</p>
    </html></body></font>
    <html><body><font face="verdana" size="1.0" color="red">
    <p><b> Note: Items in red do not have the latest version of Java installed. Please open a ticket to have an engineer address the issue.</b></p>
    </html></body></font>
    <html><body><font face="verdana" size="2.5" color="black">
    <p>
    $StartTime<br>
    $EndTime<br>
    $TimeDiff<br>
    $HostCount<br>
    </p>
    <p>
    Run date: $Date<br>
    $Version<br>
    $LastUpdate<br>
    </p>
    </html></body></font>
    ## Send Email
    SendEmail

  • Break out box question

    Is there a break out box that works with Premier CS6 and has a fire wire input? I have a Panasonic psgv320 mini dv camera and need material from the tape imported into Adobe. It uses a dv to fire wire cable.

    If your camera is digital tape, you connect the camera to a Firewire port and it should be recognized by P-Pro
    http://helpx.adobe.com/premiere-pro/kb/cant-capture-dv-hdv-video.html
    -and more about Windows http://forums.adobe.com/message/4708997
    If you have an ANALOG camera or tape player, you need a converter between your device and Firewire port
    Such as http://www.grassvalley.com/products/converters

  • Not breaking out of loop

    I've written this piece of code to search through a file until it finds:
              BufferedReader in = new BufferedReader (new FileReader(outputFile));
              String name = null;
              String data = in.readLine();
              while (name == null)
                   System.out.print("Please enter your name: ");
                   name = kybd.nextLine();
                   kybd.nextLine();
                   while (data != null)
                        if (name.equalsIgnoreCase(data))
                             name = data;
                        else
                             name = null;
                        data = in.readLine();
                   System.out.println("Sorry, name not found.");
                   System.out.println();
              }I have some problems with the logic of it and it doesn't break out of the loops, can someone give me some advice as to where it's going wrong and how to correct this, thanks.
    I've now discovered that the "kybd.nextLine();" was causing it not to enter the first loop, however now I get a NullPointerException and I know what that is, but I do not know why it is happening here.
    Edited by: jnaish on Jul 2, 2008 6:40 AM

    jnaish wrote:
    Changed it to look like this:
              while (name == null || name == "no match")
    Don't do this. You're comparing object identity instead of comparing their values. Compare strings with .equals().
                   System.out.print("Please enter your name: ");
                   name = kybd.nextLine();
                   //kybd.nextLine();
                   while (data != null)You never set data (you did in your first example), so data will be null and your loop will not execute.
                        if (name.equalsIgnoreCase(data))
                             name = data;
                             System.out.println("Found.");
                        else
                             name = "no match";
                        data = in.readLine();
                   System.out.println("Sorry, name not found.");
                   System.out.println();
              }No exception anymore but, name doesn't become equal data either.Restructure your loop. What you're doing is just awkward.
    Pseudocode:
    function {
      get line of user input
      loop over lines in file {
        if user input is equal to line from file {
          print "found"
    }Edited by: nclow on Jul 2, 2008 2:11 PM

  • To break out of a non-global zone and become root user in the global zone

    Hi folks
    "to break out of a non-global zone and become root user in the global zone through a kernel bug exploit"
    Is this possible and has SUN allready a fix/workaround/patch for that?
    Cheers

    Is it possible there's a bug in the kernel? Sure.
    Someone would need to find and identify such a bug before it could be fixed. I've not heard of the discovery of a bug like this. You could check the bug database at www.opensolaris.org.
    Darren

  • 3.5mm break out to optical and analog

    I got a new iMac with the mini jack combo output (so you can plug in headphones / speakers or use it as an optical output).
    I'd like to hook up a set of optical speakers and a set of analog speakers. I was wondering since the headphone jack on the back of the iMac has BOTH but combined into one, is there a break out box or adapter that will allow you to use both digital and analog?
    I've searched around online for a while but cannot find anything, does anyone know of this type of adapter?
    Thanks
    -Steve

    Hi Steve,
    the audio-port on the iMac (and the other Macs as well) has a small micro-switch in it which is used to determine whether an analog or a digital connecter is inserted.
    So in essence you cannot get both analog and digital out of the combined port.
    Sorry
    Stefan

  • "Break out" black and pms for prepress?

    Help please?
    I am working in Illustrator CS4, and finished a 2-sided mailer/postcard for a client in cmyk. After emailing the final PDF to the client, the client responded back to me with their print provider's request for— "native file, with black and PMS broken out". 
    First—the file was set up as CMYK, so I am asuming it was partly a lazy reponse/request? (not realizing it was set up as CMYK).
    Second—I typically I send files to commercial print providers as a PDF (Press Quality or PDF/X:1a)—is this not sufficient for them—and why?
    I appreciate any insight on this for my own edification, and I'd like to know if they asked for this beacuse they don't have certain "break out" capabilities on their end? ...OR if it's because PDF's do not provide them with editability (which I thought they did)?
    Lastly, I would specifically like to know what steps I should take to prepare CMYK colors "broken out".  (Step by step please?)
    Thank you VERY much in advance.
    Chemol

    Jet,
    Thanks for your feedback.
    Given that this "separations request" came from the print sales rep—versus the prepress department, I am inclined to think it was "partly a lazy reponse/request (not realizing it was set up as CMYK)."  ....as I stated in my initial posting. Hence, this whole discussion could be moot.
    That said, I do have the Adobe Print Publishing Guide, but not much insight on file separations/what to actually look for. Also, the book does not suggest "separations" for print vendor file prep procedure—just save as PDF/X-1 or PDF/x-3.
    I have tried to research this topic and I am not finding much on "real world" reasoning or situational application—ie: why some print vendors ask for it, while others do not. When is it expected, what is good practice? Are separations for PMS only? Situationally speaking—would a designer actually send a file to a printer broken down/separated by colour—translating a 2 spot colour, 2 sided card (2 pages) into 4 pages—one page per colour? Is that done in the native program ie: illustrator, or is there a SAVE feature that breaks it out for you? questions, questions......
    Yes I have Acrobat Pro and have viewed it already via that method, though I am not sure what I am supposed to gain by it, it or look for specifically?
    Yes, I also have a colour laser printer—I printed the separations (Host Based) instead of Composite—all 4 sheets came out in various degrees of black (similar to viewing an image via individual Channels in Photoshop). Again, not sure what I need to look for here, beyond the cool effect of an infrared appearance. ??
    Yes, I stated in my original message that I was using Ilustrator CS4.
    2-sided postcard:
    I know not to use a "multicolour black" for text, and as I mentioned in my first response to you colour question:
    1 background black (C50, M40, Y40, K100)
    black text ink (K100)
    There are no spot colours, and the commerical printer is a highly reputable large printing company.
    Good suggestion about uploading it for evaluation, and perhaps I will look for a site like that.
    Thx.

  • Break out the messenger pigeons

    WOW iCloud email down for over 2 days....time to break out the pigeons.......Never thought this would be what it felt like to be one of the 1%....;-)

    Hi...
    >
    scott
    tiger-- i want to change this tiger password as peacock>
    Connect as sysdba
    alter user scott identified by peacock;
    in general :-- ALTER USER <USERNAME> IDENTIFIED BY <PASSWORD>.
    As,you know scott's password you can login with the tiger password and change the password to peacock using the same command.The next time you login as scott the new password is to provided.
    SQL*Plus: Release 9.2.0.8.0 - Production on Tue Sep 23 01:12:29 2008
    Copyright (c) 1982, 2002, Oracle Corporation.  All rights reserved.
    Enter user-name: scott
    Enter password:
    Connected to:
    Oracle9i Enterprise Edition Release 9.2.0.8.0 - Production
    With the Partitioning, OLAP and Oracle Data Mining options
    JServer Release 9.2.0.8.0 - Production
    SQL> alter user scott identified by scott123;
    User altered.
    SQL> exitAnand

  • Break out iPad iworks apps?

    Is it possible for the hosts to break out the iPad iworks programs like the desktop iWork is? Many of us are experts in one area, not so much in others and I cannot seem to get a link to just the one area I typically help in. I have to manually refine the group down each and every time I visit the pages. I forgot recently and was answering a question that was worded in a ay it could have been for any of the three apps.
    I would have gone back and edited my response, but was forced to post another response to my own post due to the fact that I am on an iPad. Go figure iPad supporters working from iPads.but we can't edit posts.. Go figure. I know beating a dead horse. :)
    Jason

    How often do people use the tags though? I don't because I don't know what the available tas are. Do you just make them up? The few times I posted, there was no selection drop down or check boxes.
    Tags are a nice way of filtering subjects. They will eventually become a great, and also a primary, way of searching for subjects and related subjects.
    Yes, you do just make them up (if, when you're posting, you don't see a related tag, or you want to add further context to your post after selecting available tags). If you are going to creat a tag with multiple words, use an underscore between the words to keep them grouped together, i.e., tags_question.
    When you start a topic, choose from available tags at the bottom of the text field, just above the Post Message button:
    You can edit, change or add tags during the fifteen minute editing period following your original post.

  • Break out to Mono question

    Hey all..
    I've got a wierd one here...
    When i break out a clip to mono, there's two extra .wav files that get created.
    When i put these two wave files on the timeline, they are abutted one against the other, rather than dropped down on separate mono tracks.
    I stumbled, by accident, that if i drop the original .AVI, which had the mono option applied, then everything's fine..Audio gets placed on two separate mono tracks.
    Alright. Everything works backwards. I can live with that.
    I get two extra .wav files in the source bin, and the original .AVI can now have 2 mono clips.
    But what i don't understand, is why do both mono files on the timeline each play in stereo??
    Shouldn't a mono file only play out through one speaker?
    Just to give you a head's up, i'm using a Matrox RT.x2 card, and it saves a separate .wav file upon capture...
    Thanks...

    I videotaped on two separate channels on my XHA1...Channel 1 and 2. Ambient and soundboard direct. You can see by the waveform, after "breakout to mono".
    So, again, yes, when i mute any of the audios, they come through as stereo on my speakers. I just find it odd.
    And what's even more wierd...
    All my .AVI's are now breaking out to mono?
    I've created a monster
    What i don't understand then, is what purpose does this serve, if i can do it all within the stereo track??

Maybe you are looking for

  • Movie Playing on HD TV via HDMI plays to fast

    Hi everyone, I have a Mid 2011 Mac Mini with 8G of RAM and it is connected to a Sony Bravia 55' Full HD TV via HDMI. When I play a movie from the mac mini , there is a clear " fast going " effect , the video plays faster than natural but the sound is

  • Firefox is taking 20+ minutes to load a page, why?

    This morning, when launching Firefox, I was asked to update to the latest version of Firefox. I accepted, and everything appeared to be fine. Then it tried to update my extensions, when I noticed it got "stuck" at about halfway through. I left it for

  • Use of  RRKMULTIPROVHINT in multiprovider

    Hi All, Could you explain me what is the use of the above table? I was reading a document named "How to create efficient multiprovider queries". It says In the RRKMULTIPROVHINT table, you can specify the MultiProvider and a characteristic for partiti

  • Can I use logic loops in a commercial production?

    I am using the audio, drumbeats, drum kits,..the works in Logic to create a commercial track. Are there any restrictions on the use of these loops?

  • ORA-27102: out of memory,  when I try to increase the SGA in 10gR2 linux 64

    Hi, I´m trying to increase sga_max_size parameter, but when I startup the DB the following error is appears: ORA-27102: out of memory...The maximun value is 3.6 Gb Approximately, if I increase this value, the DB not start and is appears this error. M