Callback problem

hi!
can any onr help me with a callback problem. Pc dialing into router via ISDN doesnt work with callback but works without it.

modem country mica south-africa
aaa new-model
aaa authentication ppp default group radius local
aaa authorization exec default local group radius
aaa authorization network default local group radius
aaa accounting network default start-stop group radius
aaa session-id common
ip subnet-zero
ip cef
no ftp-server write-enable
async-bootp dns-server 192.168.101.2 192.168.101.3
async-bootp nbns-server 192.168.101.2 192.168.101.3
isdn switch-type basic-net3
chat-script callback ABORT ERROR ABORT BUSY "" "ATDT\T" TIMEOUT 30 "CONNECT" \c
chat-script offhook "" "ATH1" OK
modemcap entry 3com_usr:MSC=&F1S0=1
interface FastEthernet0/0
ip address 192.168.254.250 255.255.255.0
no ip redirects
no ip unreachables
duplex auto
speed auto
interface FastEthernet0/1
ip address 192.168.100.28 255.255.255.0
no ip redirects
no ip unreachables
duplex auto
speed auto
interface BRI2/0
no ip address
encapsulation ppp
dialer rotary-group 0
dialer-group 1
isdn switch-type basic-net3
isdn incoming-voice modem
isdn skipsend-idverify
no keepalive
ppp authentication pap chap ms-chap
interface BRI2/1
no ip address
encapsulation ppp
dialer rotary-group 0
dialer-group 1
isdn switch-type basic-net3
isdn incoming-voice modem
no keepalive
ppp authentication pap chap ms-chap
interface BRI2/2
no ip address
encapsulation ppp
dialer rotary-group 0
dialer-group 1
isdn switch-type basic-net3
isdn incoming-voice modem
no keepalive
ppp authentication pap chap ms-chap
interface BRI2/3
no ip address
encapsulation ppp
dialer rotary-group 0
dialer-group 1
isdn switch-type basic-net3
isdn incoming-voice modem
no keepalive
ppp authentication pap chap ms-chap
interface BRI2/4
no ip address
encapsulation ppp
dialer rotary-group 0
dialer-group 1
isdn switch-type basic-net3
isdn incoming-voice modem
no keepalive
ppp authentication pap chap ms-chap
interface BRI2/5
no ip address
encapsulation ppp
dialer rotary-group 0
dialer-group 1
isdn switch-type basic-net3
isdn incoming-voice modem
no keepalive
ppp authentication pap chap ms-chap
interface BRI2/6
no ip address
isdn switch-type basic-net3
interface BRI2/7
no ip address
isdn switch-type basic-net3
interface Group-Async1
ip unnumbered FastEthernet0/1
encapsulation ppp
no ip route-cache cef
no ip route-cache
no ip mroute-cache
dialer in-band
dialer idle-timeout 900
dialer-group 1
async dynamic routing
async mode interactive
peer default ip address pool RAS
ppp max-bad-auth 3
ppp callback accept
ppp authentication ms-chap-v2
group-range 33 50
hold-queue 10 in
hold-queue 20 out
interface Dialer0
ip unnumbered FastEthernet0/0
encapsulation ppp
no ip route-cache cef
no ip route-cache
no ip mroute-cache
dialer in-band
dialer idle-timeout 900
dialer-group 1
peer default ip address pool RAS
ppp authentication ms-chap-v2
ppp multilink
ppp callback accept
hold-queue 10 in
hold-queue 20 out
ip local pool RAS 192.168.103.230 192.168.103.254
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.254.1
ip http server
dialer-list 1 protocol ip permit
radius-server host 192.168.101.61 auth-port 1645 acct-port 1646
radius-server key xxx
radius-server vsa send authentication
line con 0
password xxx
line 33 50
session-timeout 10
script modem-off-hook offhook
script callback callback
modem InOut
modem autoconfigure discovery
autoselect during-login
autoselect ppp
line 51 62
line aux 0
line vty 0 4
password xxx
end

Similar Messages

  • Event Callback Problems during compilation

    Hi
    I try to register a callback vi with the "Register Event Callback"-node. I
    pass a reference of an array as user parameter into to the "Register Event
    Callback"-node. Everything works well in the development environment. But
    when I try to build an executable I get the Error "1003 . The vi is not
    executable".
    What is wrong?
    Mareike

    Hello Mareike,
    you can surch in the http://www.ni.com/support/ for "error" and "1003". There you will find a lot of links where this error is discussed. With a little luck, there will be an answer.
    Regards ThomasD 

  • Problems creating callback VI

    Hi,
    I stumbled over some strange behavior....
    I tried to register a TestStand ActiveX callbacks, but I'm facing multiple problems:
    My first attempt for assigning the callback VI was the right-click "Create Callback VI" which brings then up a template VI which in my case reports the following errors:
    Albeit, both typedefs are considered ok (at least) for all the rest of this application....
    So I manually deleted the "broken" controls and replaced them with the typedef'ed one and wired them up to the connector block.
    The problem comes up at runtime: the Register for callback node returns Error 97: LabVIEW:  A null or previously deleted refnum was passed in as an input.
    What am I doing wrong?
    Cheers
    Oli
    Programming languages don't create bad code, programmers create bad code....
    Solved!
    Go to Solution.

    Hi Norbert,
    thanks for the quick reply. Please find attached some scrrenshots:
    Typedef for UserEvent
    Typedef for UserEvent data
    Frontpanel of automatically created callback VI
    Frontpanel of modified callback VI (Error97)
    The typedefs reside within the same lvlib as the caller. The callback VIs are reentrant. They are also marked private within the library, changing the access scope to public did not change the behaviour.
    Do you think http://forums.ni.com/t5/LabVIEW/Register-Event-Callback-problem-with-Linkam-ActiveX-controls/td-p/15... could be related?
    BTW using LV2012SP1 ans TS 2012SP1
    Cheers
    Oli
    Programming languages don't create bad code, programmers create bad code....

  • Need help: Using JMS to callback a client.

    Hi everyone,
    I'm having a very frustrating problem. I'm just started to use JMS to overcome callback
    problem with EJBs. I simply want my EJB to send something (pub/sub) to my client so it
    can update some display. I first instantiate my Client and TopicConnection etc. etc. then
    create the EJB, invoke it and the EJB sends some TextMessage back. However, the TextMessage
    never seems to arrive at my Client. The TextListener never seems to deliver.
    Here's the snippet:
    EJB:
    private void createPublisher() {
    try {
    Context ctx = new InitialContext();
    System.out.println("Server looking up JMS Service");
    TopicConnectionFactory conFtry = (TopicConnectionFactory) ctx.lookup("java:com
    p/env/jms/MobiDTopicConnectionFactory");
    topic = (Topic) ctx.lookup("java:comp/env/jms/TopicName");
    con = conFtry.createTopicConnection();
    session = con.createTopicSession(false, Session.AUTO_ACKNOWLEDGE);
    publisher = session.createPublisher(topic);
    TextMessage mesg = session.createTextMessage();
    System.out.println("Server is sending message, see anything?");
    mesg.setText("This is from publisher");
    publisher.publish(mesg);
    // Exception catching stuff snipped.
    public void ejbCreate() { createPublisher(); }
    Client:
    public void createSubscriber() {
    try {
    Context ctx = new InitialContext();
    TopicConnectionFactory conFtry = (TopicConnectionFactory) ctx.lookup("java:com
    p/env/jms/MobiDTopicConnectionFactory");
    Topic topic = (Topic) ctx.lookup("java:comp/env/jms/TopicName");
    con = conFtry.createTopicConnection();
    session = con.createTopicSession(false, Session.AUTO_ACKNOWLEDGE);
    subscriber = session.createSubscriber(topic);
    subscriber.setMessageListener(new TextListener());
    con.start();
    System.out.println("Connection started");
    // Exception stuff snipped.
    public static void main(String args[]) {
    try {
    ConverterClient cc = new ConverterClient();
    cc.createSubscriber();
    System.out.println("Subscriber is ready");
    Context initial = new InitialContext();
    System.out.println("Looking up the bean...");
    Object ref = initial.lookup("java:comp/env/ejb/SimpleConverter");
    System.out.println("Getting the home interface");
    ConverterHome home = (ConverterHome) PortableRemoteObject.narrow(ref,
    ConverterHome.class);
    Converter conv = home.create();
    double amount = conv.dollarToYen(100.00);
    InputStreamReader inputStreamReader = new InputStreamReader(System.in);
    char answer = '\0';
    while (!((answer == 'q') || (answer == 'Q'))) {
    try {
    answer = (char) inputStreamReader.read();
    } catch (IOException e) {
    System.out.println("I/O exception: "
    + e.toString());
    Can anyone spot what's wrong with the code? I've been trying to get this to work for the
    past two days but to no avail. Please help...
    Thank you in advance.
    -vincent

    Hi, thanks for all your reply.
    The TextListener is the one downloaded from this website in the
    tutorial but I used it in different program. Here's the TextListener:
    public void onMessage(Message message) {
    System.out.println("Receiving message in onMessage()");
    TextMessage msg = null;
    try {
    if (message instanceof TextMessage) {
    msg = (TextMessage) message;
    System.out.println("Reading message: " +
    msg.getText());
    } else {
    System.out.println("Message of wrong type: " +
    message.getClass().getName());
    } catch (JMSException e) {
    System.out.println("JMSException in onMessage(): " +
    e.toString());
    } catch (Throwable t) {
    System.out.println("Exception in onMessage():" +
    t.getMessage());
    Strangely, this does not work as it never print the message. Can't see what's
    wrong from a glance though and I'm not getting any error message whatsoever.
    However, I tried my own listener:
    static class MyListener implements MessageListener {
    public MyListener() { }
    public void onMessage(Message msg) {
    try {
    System.out.println("Message received: " + ((TextMessage) msg).getText())
    catch(JMSException ex) { ex.printStackTrace(); }
    And this works...I just don't get it. MyListener is a static because I used it in my main().
    Anyone can give any comment?
    thanks,
    -vincent

  • Connection reset by peer when I specify port for Callback

    I have a successful rmi callback when it uses annoymous port by using UnicastRemoteObject.exportObject(this) from client. But I get the following messages when I tried to specify port by using UnicastRemoteObject.exportObject(this, port) by client. My understanding is this tells the server to callback using the port specify and the connection should be made. Where it fails is when the server tries to call client.notify() where the callback is taking place I get the errors.
    Am I missing something? I thought that was all I needed to do to specify a port.
    Remote Exception:java.rmi.ServerException: RemoteException occurred in server thread; nested exception is:
    java.rmi.MarshalException: Error marshaling transport header; nested exception is:
    java.net.SocketException: Connection reset by peer: Connection reset by peer
    java.rmi.ServerException: RemoteException occurred in server thread; nested exception is:
    java.rmi.MarshalException: Error marshaling transport header; nested exception is:
    java.net.SocketException: Connection reset by peer: Connection reset by peer
    at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(StreamRemoteCall.java:247)
    Thanks for the help.

    Hi Esmond, My name is Lee and I work with Joon (hellscream) and this RMI callback problem still persists. We appreciate your help and we know about your expertise in this area. (Great products on your web site by the way).
    The problem environment currently consists of a Unix Solaris server on the backend and windows XP laptops acting as clients. The callback is from the unix server back to the client.
    By looking at the output of netstat -na on the unix server during a normal anonymous port run, we can clearly see that there seem to be 3 sequentially numbered ports involved whenever the anonymous port construct of UnicastRemoteObject is used. This happens with super() or super(0); in our client code. All works very well that way.
    The problem arises when we make changes to the client impl file and specify a port with super(65000) for example.
    There is no firwall involved right now and UnicastRemoteObject doesn't seem to behave as advertised in the sense that
    We can clearly see what's going on with the network using Thread.sleep(10000) within the client app meanwhile executing netstat -na on the unix server and grepping for the client IP address
    We can see that the unix server STILL wants to talk to the client on an arbitrary port while the laptop client is listening on the desired port that we chose (65000) in this case.
    If we attempt to instantiate a port in the server Impl java file, the results are the same with the exception of the choice of the source port on the unix server. We seem to be able to choose and set that at will. Unfortunately, and from the perspective of a future firewall, the source port is irrelevant and the rules normally apply to destination ports in an outgoing connection.
    Anyway, with ports instantiated and everything compiling, the client prints the following stacktrace
    Thanks very much in advance for your help
    Remote Exception:java.rmi.ServerException: RemoteException occurred in server th
    read; nested exception is:
    java.rmi.ConnectIOException: error during JRMP connection establishment;
    nested exception is:
    java.net.SocketException: Connection reset
    java.rmi.ServerException: RemoteException occurred in server thread; nested exce
    ption is:
    java.rmi.ConnectIOException: error during JRMP connection establishment;
    nested exception is:
    java.net.SocketException: Connection reset
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:292)
    at sun.rmi.transport.Transport$1.run(Transport.java:148)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.Transport.serviceCall(Transport.java:144)
    at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:4
    60)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport
    .java:701)
    at java.lang.Thread.run(Thread.java:534)
    at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(Stream
    RemoteCall.java:247)
    at sun.rmi.transport.StreamRemoteCall.executeCall(StreamRemoteCall.java:
    223)
    at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:133)
    at ids.rmi.ServerJobImpl_Stub.execute(Unknown Source)
    at ids.jobExec.JobThread.run(JobRunner.java:551)
    Caused by: java.rmi.ConnectIOException: error during JRMP connection establishme
    nt; nested exception is:
    java.net.SocketException: Connection reset
    at sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:274
    at sun.rmi.transport.tcp.TCPChannel.newConnection(TCPChannel.java:171)
    at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:101)
    at ids.rmi.JobClientImpl_Stub.message(Unknown Source)
    at ids.rmi.ServerJobImpl.execute(ServerJobImpl.java:60)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
    java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
    sorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:324)
    at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:261)
    at sun.rmi.transport.Transport$1.run(Transport.java:148)
    at java.security.AccessController.doPrivileged(Native Method)
    at sun.rmi.transport.Transport.serviceCall(Transport.java:144)
    at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:4
    60)
    at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport
    .java:701)
    at java.lang.Thread.run(Thread.java:534)
    Caused by: java.net.SocketException: Connection reset
    at java.net.SocketInputStream.read(SocketInputStream.java:168)
    at java.io.BufferedInputStream.fill(BufferedInputStream.java:183)
    at java.io.BufferedInputStream.read(BufferedInputStream.java:201)
    at java.io.DataInputStream.readByte(DataInputStream.java:331)
    at sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:215
    ... 15 more
    Job finished. Exit status: -1

  • Emergency Responder/PSAP callback question

    Upon an IP phone making a 911 call, does anyone know how long CER "holds" the extension to ELIN mapping for? I remember in older versions there was a configurable time limit that could be extended. I see the calls in the call history, but when I call the ELIN, I'm getting a busy. I'm running 1.2(3) SR1 and can't seem to find this parameter. I'm trying to track down what appears to be a callback problem, however my translations and route points check out...plus this was all working at one point.Should I be able to call these numbers still?

    it holds it for 3 hours it can be changed in the Cisco ER Group Settings

  • Problem with register event callback in use of instrument control

    now, i use the register event callback to register a value change of a boolean control on the front panel, and wire the cluster's ref of the instrument control parameters to the user parameter input, then create the callback vi. In the callback vi, i select the pump-control subvi, and pass the user parameter to the subvi. The problem is that,  when i press the boolean control, the instrument (here is pump) can act, but immediately, the code crashes.
    I use labview 8.6
    Attachments:
    callback vi.png ‏8 KB
    register event callback.png ‏8 KB

    You would wire the event registration wire that comes out of the Register for Events node into an event structure.  You will need to right click on the event structure and check off "Show Dynamic Event Terminals" and it into that.  Then you can create a new Event Case that uses the dynamic event.  You can place your subVI in that event in whatever way you want.  (Just drop the subVI in or do a Call by Reference there, or whatever.)  Look in the Example Finder for "Dynamically Register for Events.vi".

  • Problem registering Callback applet in weblogic 8.1 SP3

    Hi,
    I am having a applet which is signed and loaded from the web application. When i am accessing the remote functions from RMI server, it works fine.
    But, while exporting the callback applet to RMI (using UnicastRemoteObject.exportObject(this)), i am getting StubNotFoundException.
    As per weblogic RMI, it wont create the Stub's and Skeletons, How do I solve this problem?
    Can anyone help me with sample code and steps to implement a call back applet in weblogic RMI.
    Thanks and Regards,
    Jamal

    Jamal,
    Have you found a solution to this problem?
    Thank you.

  • Problem with CVI blocking UART Callback

    Hi,
    I have been using LabWindows CVI 9.0 since a few years now and I have seen a problem that didn't blocked me until now.
    My LabWindows Software freezes, the code is no longer executed, when I hold a click on the interface, on a string for example.
    The problem is that I use a device that emits data continuously on a COM port. When I decide to drag the software window or simply hold a left click on the interace the software stop acquiring data from the COM callback and my software misses data.
    Do you have a solution for this problem ?
    Thank you

    HI Penou,
    In fact it is a good idea using multiple Threads to  avoid this kind of behavior.
    Maybe you are using ProcessSystemEvents to handle events,  on the same main thread. 
    If it is the case, when ProcessSystemEvents handles an event that starts a tracking loop, such as the user pulling down a menu, ProcessSystemEvents does not return until the tracking loop completes. In the case of pulling down a menu, the tracking loop does not complete until the user dismisses the menu. 
    You have several inforrmations about ProcessSystemEvents here.
    Regards,
    Rémi D.
    National Instruments France
    #adMrkt{text-align: center;font-size:11px; font-weight: bold;} #adMrkt a {text-decoration: none;} #adMrkt a:hover{font-size: 9px;} #adMrkt a span{display: none;} #adMrkt a:hover span{display: block;}
    >> Les rencontres techniques de NI - Mesures et acquisition de données : de la théorie à la mise en ...

  • Problems with ActiveX Callbacks in LabVIEW 7

    Have encountered an interesting problem with ActiveX "Reg Event Callback" in LV7 (WinXP):
    In a nutshell, when a lot of events fire in rapid succession, the user-interface locks up.
    The events still fire, and the front panel controls update, but the front panel will not respond to clicks. Interestingly, if the block diagram is open, you can stop it and turn on execution highlighting, etc...
    - I've discovered that the problem we're encountering is related to multiple events firing before the (reentrant) callback VI has finished executing from the 1st event.
    - by watching the Performance data in task manager, and tracking the # of handles used by LabVIEW, I find that when this happens, the # of handles increases, b
    ut never decreases until you stop the VI
    - I would expect several (nearly) instantaneous events to launch multiple copies of that callback VI, and I can believe that would increase the # handles, but I would expect that LabVIEW would catchup shortly thereafter and the # handles would return to its starting count.
    As an aside, using the old ActiveX event and callback method with the exact same version of the activeX control does not have this problem, events just queue up and then fire appropriately.
    Anyone seen anything like this?
    Anyone (NI guys) have any ideas?
    Follow up question (NI guys): when will the support for the old ActiveX event stuff dry up?
    Thanks in advance,
    Ben
    Ben Zimmer
    [email protected]
    Software Developer
    Meikle Automation

    Hi Ben,
    The error message warns about the use of three ActiveX Event VIs that will no longer be supported in future versions of Labview. Following version 6 of Labview, the use of ActiveX Event VIs is shifting to the use of Register Event Callback VI instead. In looking at your screenshots, I did not see any use of the older ActiveX Event VIs. If possible, try attaching the actual VI to the post and I will take a look at that.
    At least in terms of support, phone support currently exists for Labview 6 and 7. With the release of Labview 8, support for Labview 6 will slowly be phased out. In this case, phone support for the ActiveX Event VIs will no longer continue as they are no longer included in the versions of Labview for
    which phone support is provided. However, Discussion Forums and web-based resources would be your best venue of support for those features.
    I would strongly recommend that you migrate to replacing ActiveX Event VIs to using the Register Event Callback VI. The following is a KnowledgeBase article describing the transition of ActiveX in Labview:
    Migrating from the ActiveX Event VIs to Using the Register Event Callback Node
    Also, are you using the Automation Open/Close VIs? These two VIs will allow acquire/release informatio nof the ActiveX object. I have attached a couple example programs that are included in Labview to help demonstrate this concept.
    Hope this helps!
    Kileen Cheng
    Applications Engineer
    National Instruments
    Attachments:
    ActiveX_Event_Callback_for_Excel.llb ‏944 KB
    ActiveX_Event_Callback_for_IE.llb ‏972 KB

  • UCCX Callback implementation timeout problem

    I am working on an implementation of the "Callback" function for queued callers based on the Cisco sample scripts
    BaseLineAdvQueuing and BaseLineMesageCallback.   The function works correctly.  If my agents are all in Not Ready state and callers select to leave a callback number and message then their "callback" calls are queued successfully.  When an agent is made "Ready" the callback calls are delivered in the correct order and the callbacks are processed successfully.  My problem is that the "Callback" calls time out and disappear from the queue after about 30 minuted.  If an agent becomes ready after 40 minutes there are no calls delivered to them.  I have tracked this via the Real Time Reports which show active sessions for the queued Callback calls.  These disappear from the Real Time Report after 30 mins.   Is there a way to extend this timeout?.
    Regards,
    David

    Have you checked your MIVR logs for the WFMaxExecutedStepsExceededException error?
    The logic in the Advanced Queuing script is such that it loops the Get Digit String step once ever 6 seconds.  Even if I didn't consider all the steps that your callers go through before getting there, this small section will execute 1,000 steps in 50 minutes.  Subtract off your steps above and this could easily be 20 or 30 minutes.
    The Callback script is less likely the culprit as it executes 3 steps every 30 seconds, which is 166 minutes or 2.7 hours.
    My guess is that both of you are hitting the max steps on your main script.  Check your MIVR logs to know for sure.  Post your script and I'll review it.
    Also, what is your UCCX System Parameter for Max Steps set to?
    Anthony Holloway
    Please use the star ratings to help drive great content to the top of searches.

  • Problems with async callback with the BPEL Java API (Urgent- pls help)

    Hi,
    I have an async BPEL process and I invoke it form a JSP page using BPEL java API.
    I have followed the tutorials and docs at:
    $SOA_HOME/bpel\samples\tutorials\102.InvokingProcesses\rmi\com\otn\samples\async
    I can inititiate successfully the process, but when I try to get the result using getResult() or getField(String fieldName) methods I get the error:
    Oct 2, 2007 2:35:16 PM oracle.j2ee.rmi.RMIMessages EXCEPTION_ORIGINATES_FROM_THE_REMOTE_SERVER
    WARNING: Exception returned by remote server: {0}
    java.lang.ExceptionInInitializerError
         at java.lang.Class.forName0(Native Method)
         at java.lang.Class.forName(Class.java:242)
         at com.evermind.io.ClassLoaderObjectInputStream.resolveClass(ClassLoaderObjectInputStream.java:33)
         at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1538)
         at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1460)
         at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1693)
         at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1299)
         at java.io.ObjectInputStream.readObject(ObjectInputStream.java:339)
         at com.evermind.server.rmi.RMIClientConnection.handleMethodInvocationResponse(RMIClientConnection.java:856)
         at com.evermind.server.rmi.RMIClientConnection.handleOrmiCommandResponse(RMIClientConnection.java:287)
         at com.evermind.server.rmi.RMIClientConnection.dispatchResponse(RMIClientConnection.java:242)
         at com.evermind.server.rmi.RMIClientConnection.processReceivedCommand(RMIClientConnection.java:224)
         at com.evermind.server.rmi.RMIConnection.handleCommand(RMIConnection.java:152)
         at com.evermind.server.rmi.RMIConnection.listenForOrmiCommands(RMIConnection.java:127)
         at com.evermind.server.rmi.RMIConnection.run(RMIConnection.java:107)
         at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:298)
         at java.lang.Thread.run(Thread.java:595)
    Caused by: java.util.MissingResourceException: Can't find bundle for base name com.collaxa.cube.i18n.exception_cube, locale en_US
         at java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:836)
         at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:805)
         at java.util.ResourceBundle.getBundle(ResourceBundle.java:699)
         at com.collaxa.cube.CubeException.getResourceBundle(CubeException.java:142)
         at com.collaxa.cube.CubeException.<clinit>(CubeException.java:82)
         ... 17 more
    07/10/02 14:35:16 java.lang.ClassCastException: java.util.MissingResourceException
    07/10/02 14:35:16      at com.oracle.bpel.client.delivery.ext.async.thread.AsyncInstanceWatchdog.run(AsyncInstanceWatchdog.java:152)
    I check for the result only after I have checked that the instance is closed (completed or faulted) by using IInstanceHandle:getState() and InstanceHandle.STATE_CLOSED_COMPLETED, or IInstanceHandle.STATE_CLOSED_FAULTED
    I would like to add that so far I had no problems with invocation and geting result of sync BPEL processes. I do not what is missing for async processes.
    Any kind of help is appreciable.
    Thanks and best regards,
    Evanela

    Hi again,
    i managed to solve the problem:) Totally stupid.. the process variable name was not specified correctly..., but more stupid sounds the error message:))))
    Best Regards,
    Evanela

  • OSB callback response problem

    Hi.
    I have OSB service to route asynchronous (request-callback) service.
    When I test OSB service I see that inbound message is transformed well and service is invoked.
    Also I see fault
    <con:fault      xmlns:con="http://www.bea.com/wli/sb/context">
         <con:errorCode>BEA-382510</con:errorCode>
         <con:reason>
         OSB Assign action failed updating variable "transformedResponse": com.bea.wli.common.xquery.XQueryException: Error parsing XML: {err}FORG0005: expected exactly one item, got 0 items
         </con:reason>
         <con:location>
         <con:node>DefaultRouteNode</con:node>
         <con:path>response-pipeline</con:path>
         </con:location>
    </con:fault>
    I can't understand what response can cause this fault because invoked service still running and callback is not inoked.
    Why I get immediate response from asynchronous service?
    What cause start of Response Action pipe?
    Thanks for response.

    I changed response pipe ... add Assign $body to $body1 and Report it at the start of response pipe, add Assign $body to $body2 and Report it at the end of response pipe.
    Route to [ TerminalService ] invoking [ process ]
    Request Actions:
    Assign [ XQuery Resource... ]
    XQuery Resource: Project/Processes/TerminalService/TerminalServiceRequest Variable Names And Bindings: source - $body/ter:process
    to [ transformedRequest ]
    Replace [ node contents ] of [ . ]
    in [ body ] with [ $transformedReq... ]
    $transformedRequest
    Response Actions:
    Assign [ $body ]
    $body
    to [ body1 ]
    Report [ $body1 ]
    $body1
    Assign [ XQuery Resource... ]
    XQuery Resource: Project/Processes/TerminalService/TerminalServiceResponse Variable Names And Bindings: sourceProcessResponse - $body/ter:processResponse
    to [ transformedResponse ]
    Replace [ node contents ] of [ . ]
    in [ body ] with [ $transformedRes... ]
    $transformedResponse
    Assign [ $body ]
    $body
    to [ body2 ]
    Report [ $body2 ]
    $body2
    In invocation trace is only $body1 with value (reported value is the same)
    <soapenv:Body      xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
         <ter:process>
         <ter:serviceId>1</ter:serviceId>
         </ter:process>
    </soapenv:Body>
    It looks like request message not response. (Routing properties "Use inbound operation for outbound" is unchecked.)
    Edited by: Peter551059 on Jun 13, 2011 3:48 PM

  • RMI Callback Connection Refused Problem

    we are running Red Hat Linux 9, we previously had a problem connecting a server and client running in 2 different PC's. we had the following error
    Exception in mainjava.rmi.ConnectException: Connection refused to host: 127.0.0.1; nested exception is:
    java.net.ConnectException: Connection refused
    we used the -Djava.rmi.server.hostname= <hostname> option to make it run. Now, were trying to make use of call backs this time we ran into another problem having the error:
    Exception in mainjava.rmi.ConnectException: Connection refused to host: 172.16.100.24; nested exception is:
    java.net.ConnectException: Connection refused
    what are we doing wrong?

    We already included a security manager. but the error is still there.

  • Facing problem with asyn callback

    Hi.
    I created an async bpel process (Async process ). Created another async bpel process that invokes the first asyn bpel process (Async Client process). Everything works perfectly fine. 2 instances are created ie., 1. Async Client process 2. async process. If i click the async proc instance and click on audit it has the following info in addition to the rest..
    callbackClient
    [2007/07/10 10:17:40] Invoked 1-way operation "onResult" on partner "client"
    callback information on Async Client process has the following info:
    [2007/07/10 10:17:40] Skipped callback "onResult" on partner "client".
    Why has it skipped the callback? Dont really understand....
    I have created an external web service that invokes the Async process and expect the callback to the web service. The callback information is specified in the header of the soap msg. But the callback doesn't seem to come back. But the instance is completed successfully. But if i create a bpel process to invoke the async proc, callback is fine. Can anybody help me resolve this issue.

    the repos may have even been down at that time.
    just try again later.
    it should work fine.

Maybe you are looking for