Can I have 2 diferent Constructor names in a single class?

class Test{
double x;
double y;
Test( double a, double b)
x=a;
y=b;
//Can i hv another constructor name with is not test but other name? //Example
exam(double c, double d)
x=c;
y=d;
}

If you want different behavior for essentially the "same" constructor signature, use an additional variable to differentiate the signatures. For example:
Test(double a, double b) { this(a, b, false); }
Test(double a, double b, boolean exam) {
    if (exam) {
        // exam behavior
    } else {
        // normal Test behavior
}

Similar Messages

  • Can we have a group name in oracle database???

    Hello,
    what i want to know is that can we have a group name, a set of all usernames for a database,
    the whole purpose is to simplify the grant statement, rather then doing this
    grant select to <user1>
         grant select to <user2>
         grant select to <user3>
         it would be simple to do
         grant select to <group1>
         where group1 consists of user1,user2 and user3...
         cheere

    all_users
    describe all_users
    Name                                      Null?    Type
    USERNAME                                  NOT NULL VARCHAR2(30)
    USER_ID                                   NOT NULL NUMBER
    CREATED                                   NOT NULL DATE

  • Instead of using image in a link column can we have button with name?

    Hi,
    In Apex , in report region instead of using image in a link column can we have button with name?
    Thanks,
    Anoo..

    From your wording, it sounds like you used the built-in column link within APEX. You will need to edit your column and remove that so that the column is only containing the definition that is coming from the query (you can also just change the alias used for the column and then the old column with the link will be removed and the new alias will be added against your new button column).
    -- Sharon

  • Can you have multiple contact forms in a single Muse site?

    I have a site created in Muse that needs to use multiple contact forms of a sort.  One is a simple contact form.  Two others are sign up forms. In two of the three forms I have to separate the First and Last names.  Also in those there are multiple Custom fields and Message fields.
    The original simple contact form is working fine and has been.  However, I modified one of the pages by adding a second form, the first of the two sign-up forms.  It looked great in Muse, but when uploaded to the site, all of the fields were gone, leaving only the Labels in a single paragraph.
    Does this mean I can't have multiple contact forms in a single site?  If I actually, can, then what might have caused the problem?  And what could you suggest for me to try to fix it?
    Thank you,
    Laura

    Thank you for the information, but I cannot find anywhere in help where to find the field names (if that is my problem).  I changed all the labels and the corresponding text inside the field (remember, Muse does not give access to code as far as I can tell).  When I preview the page in a browser (using FireFox as default, but also tried with IE), everything looks good.  When I export to html and open the index.html on my computer, everything still looks great.  But when I FTP the page to the website, this is what I get:
    First Name:RequiredRescuer Email:RequiredOrganization (if any):RequiredSubmitting Form...The server encountered an error.Form received.Geographic Areas Covered:RequiredRescuer Cell Phone:RequiredRescuer Home Phone:RequiredRescuer Home Address:
    RequiredRescuer City:RequiredRescuer State:RequiredRescuer Zip code:RequiredRescuer Country:RequiredVeterinarian Name:RequiredVet Address:RequiredVet City & State:RequiredVet Phone:RequiredRequiredServices Offered:RequiredAdditional Info About You:Required Rescuer (available to general public) RequiredVolunteer (available only to Rescuers)RequiredPhoneRequiredEmailRequiredOtherRequiredLast Name:RequiredImage Verification:Required
    How would you prefer to be listed?
    How would you prefer to be contacted?
    However, this is how it looks on the preview:
    So, what is my problem?  And how can I fix it?
    Thank you,
    Laura

  • Can you have multiple itunes accounts on a single computer?  want to open a separate one for our daughter (but we will manage it).

    just got our daughter a new iTouch, but want to try and keep hers separate from our iPhone stuff.  can you have multiple iTunes accounts on a single computer?

    This is all i know but all you can do is just creat a new one for them both and send all the stuff to the one think u can do that i hope it helps

  • Can We have multiple SLEDs maintained in a single Batch

    Hi all
    Can we have multiple SLEDs maintained within a single batch. This SLED would be maintained at Quant level. One batch will have multiple quants and would be maintained in separate bins. However in LX27 i should see both the SLED for the same batch.
    Please Help
    Thanks & Regards
    Jajati

    My sources tell me that batch management is not a part of Retail but of logistics and unfortunately I am not able to move your post to a better thread. However, I suggest you please do a search of all forums using "batch management" as your search criteria.You'll see loads of hits. You might find your answer there or a better place to post your question.

  • Can I have multiple TFS instances use a single SSRS installation

    Can I have multiple TFS instances use a single SSRS installation?
    Thanks

    Hi Kim,
    According to your description, you have multiple TFS instances using one Reporting Services instance. Right?
    For installing TFS, to use a named instance with Team Foundation Server, you must install SQL Server by using a named instance, or move or restore Team Foundation Server data to a named instance, or create a team project collection on a named instance. Please
    refer to the link below:
    Work with SQL Server Named Instances
    Reference:
    Understanding SQL Server and SQL Server Reporting Services
    If you have any question, please feel free to ask.
    Best Regards,
    Simon Hou

  • Can I have multiple different vlans in one Single Mode Transparent Firewall

    Hi,
    I am about configuring Data Center FW (ver 9.2) to protect multi tier Servers Farm; Web, Applications & Data Base. There is a requirement to set the FW in Transparent Mode, while the license is the base 2-contexts, only.
    I wonder if One Single Transparent Context, with different bridge-groups, one for each vlan is a workable solution. I have pasted the configuration of the FW, it may help in understanding the setup.
    ======
    firewall transparent
    names
    interface TenGigabitEthernet0/8
     description To Nx7K-1 Port-8
     channel-group 9 mode passive
     no shutdown
     no nameif
     no security-level
    interface TenGigabitEthernet0/9
     description Nx7K-1 Port-9
     channel-group 9 mode passive
     no shutdown
     no nameif
     no security-level
    interface TenGigabitEthernet1/8
     description Nx7K-2 Port-8
     channel-group 9 mode passive
     no shutdown
     no nameif
     no security-level
    interface TenGigabitEthernet1/9
     description Nx7K-2 Port-9
     channel-group 9 mode passive
     no shutdown
     no nameif
     no security-level
    interface BVI1
     desc Services Zone
     ip address x.x.41.250 255.255.255.0
    interface BVI2
     description WEB-APPS Zone
     ip address x.x.42.250 255.255.255.0
    interface BVI3
     desc Oracle management
    ip address x.x.43.250 255.255.255.0
    interface BVI4
     descr Oracle DB
     ip address x.x.44.250 255.255.255.0
    interface Port-channel9
     description ECLB Trunk to NX7Ks
     duplex full
     port-channel load-balance src-dst-ip-port
     no nameif
     no security-level
    switchport mode trunk
    switchport trunk allowed vlan 41-44,141-144
    interface Port-channel9.41
     vlan 41
     nameif Services-Outside
     bridge-group 1
     security-level 0
    interface Port-channel9.141
     description Services-Inside
     vlan 141
     nameif Services-Inside
     bridge-group 1
     security-level 100
    interface Port-channel9.42
    description WEB_APPS-Outside
     vlan 42
    nameif WEB_APPS-Outside
     bridge-group 2
     security-level 0
    interface Port-channel9.142
     description WEB_APPS-Inside
     vlan 142
     nameif WEB_APPS-Inside
     bridge-group 2
     security-level 100
    interface Port-channel9.43
    desc Oracle management
     vlan 43
     nameif Oracle_Mgmt-Outside
     bridge-group 3
     security-level 0
    interface Port-channel9.143
     description Oracle management Inside
     vlan 143
     nameif Oracle_Mgmt_Inside
     bridge-group 3
     security-level 100
    interface Port-channel9.44
    desc Oracle DB
     vlan 44
     nameif Oracle_DB_Outside
     bridge-group 3
     security-level 0
    interface Port-channel9.144
     description Oracle DB Inside
     vlan 144
     nameif Oracle_DB_Inside
     bridge-group 4
     security-level 100

    it is possible but it is not scaleable.  If I remember correctly you can only have a maximum of 8 BVI interfaces...so this means you can only have 8 subnets going across the ASA.  You would also need seperate VLANs for the inside interface and the outside interface since you can not configure two interfaces to be in the same VLAN, and then assign these interfaces to the appropriate BVI group.
    Please remember to select a correct answer and rate helpful posts

  • I have a personal itunes account with an iPhone5s and an iPad 4 mini. I have unlokced my old iPhone 4 to use for work on a diffeent SIM and new number, can i have all devices associated to me single appleID and use both numbers ?

    I have a personal itunes account with an iPhone5s (perosnal mobile numer) and an iPad 4 mini (no SIMM). I have unlocked my old iPhone 4 to use for work on a different SIM and new number,
    Do you know if I can have all devices associated to my single apple ID and still use both numbers without messing up my profile. It has just changed my number over.

    I would not be able to give you idiot proof guide, since different games are different. Some of them have icloud integrated already, but those already taken care of. Some of them use specific logins and once you log - you get your info. General recommendation is to contact support sites of those games for enabling icloud instructions or enabling of transfer. There are other purely apple ways - like sync your phone in itunes and then sync apps with ipad, but those are only one time transfer. There is another way that is not typically recommended - restoring ipad from iphone backup. It may transfer your game content, but once again sync in the future has to be done by game.
    So if I were you, I would address that individually with every game provider.

  • HT3819 Can I have two apple accounts on a single device?

    Can I have two apple accounts on the same device?

    Don't know what that means.
    You can authorize your computer fro two accounts, then sync the content to the device.

  • HT2534 Can you have multiple ITunes accounts under a single e-mail address (i.e. separate accounts for my children and myself?)?

    Can you have multiple ITunes accounts assigned to a single e-mail address?  i.e. different Apple ID's for my kids and myself, but all assigned to my e-mail address.

    No. Each account must have uniquie email address.

  • Can we have 2 data sources for a Single infospoke?

    Hi,
    As per the above, can we have 2 data sources (i.e Infocube and Masterdata attribute) for a single Infospoke.
    In the current scenario, Material is my infoobject of a cube and also need material attribute -  gross weight to be made available in a table.
    Please let me know if it is possible?
    If yes, explain me how?
    Thanks,
    Ram

    Hi Ram,
    try these:
    - create a multi provider and include the cube and master data attribute concerned.
    - create a infospoke againt the multi provider.
    - do same steps as usual.
    Hope it helps.
    Regards,
    Lilly

  • Can we have our custom name in the place of Progress Indicator ?

    Hello all..
    I am using Captivate 4. I would like to use a custom name "Prasna"(means the word "question' in a local language) instead of the word "Question". How can I change it as per my requirement. In the progress indicator window, there are only 2 options where I couldn't find what I need.
    Thanks & regards,
    Pullela.

    Hello Pullela,
    For once you are lucky to use Captivate 4, because this feature was lost in CP5. It is a bit cumbersome but possible: choose File Export Captions to Word (do not remember the exact phrasing, sorry). In the Word document you will see the progess indicators, and you'll be able to change the word Question. Then re-import without changing the filename in the Captivate file.
    For CP5-users I posted an alternative workaround on my blog recently; it uses the master slide, but you could also tweak this for CP4, you'll have to copy/paste to all slides:
    Customize the progress indicator
    Lilybiri

  • When I hit mission control can I have the document names put under each document?

    This is what my mission control currently looks like
    I want to have the names of the each peice of work. Because it would just make it a bit clearer to work out what I have got open.

    Go to System Preferences > Mission Control and turn on Group windows by application. Also, if you have a trackpad, you can make a gesture to show the application windows and the most recent used documents. To do it, open System Preferences > More Gestures and look Exposé; then, take the cursor to the program you want to check the files and make the gesture

  • How can I have a topic name different than the filename of a linked Word document?

    I've encountered multiple issues with linking to Word files ...here's another one: If a Word document is entitled Feature_ABC, then upon generating the HTM after linking it, the HTM's filename and topic name are both Feature_ABC. As underscores are ugly in topic names and features can be renamed, I would hope that I could rename the topic to be different than the filename.
    The Help documentation suggests this is possible by editing the Topic Name Pattern in the Word Conversion Settings dialog of Project Settings. However, reagardless of the Pattern entered, every time I generate or update from the context menu of a linked Word document the topic name remains the same as the filename.
    Because the topic name is shown in the Search panel and browser tabs, it will be a little ugly and may even be confusing. It is possible to edit the HTML directly, but then the HTML is overwritten each time the Word documents are update and the great advantage of using linked documents is lost.
    Is there a way to solve this problem?
    Thanks in advance for any help you might be able to provide.

    Thank you for your quick reply - just checked Multifox out.
    It seems it still forces me to open a new window, while preventing the need for a new profile.
    Why isn't it in the addons.mozilla.org ? Looks dangerous ...

Maybe you are looking for

  • How to use documents MS-Word-Excel and Pdf on iPhone 4S

    Before I bought the iPhone I was using Sony Ericson X1 Xperia. On this phone I could easily read & write  on documents MS-word/excel and transferred them from and to my PC with Windows 7. Till now I cannot find an easy way to transfer these documents

  • Document Attachment at GR

    Hi Is it possible to attach the Dly challan *** invoice document at the time of GR? If so where will it be stored? The document should be stored in a separate server. Thanks Rahul

  • How to identify and delete objects after failure of registering XML schema

    Hi, I have tried to register a XML schema with many global elements but failed. I have checked the view DBA_XML_SCHEMA and found that there is an entry for this failed XML schema and the disk spaces would not be freed after the failure of registratio

  • Serialize ---- Proxy to Idoc scenario

    Hi Folks,             I m using Proxy to Idoc scenario and am trigerring proxy messages one after other from my function module on the outbound side. However sometimes idoc2 gets posted before idoc1. My requirement is that idoc2 to be processed only

  • Html5 video doesn't play

    I was on the People magazine site and where there was supposed to be a video it said this player cannot play HTML video. I thought iOS can't play Flash video but that HTML 5 is what apple supports. Am I wrong?