Can not connect to ther admin server with t3s in the WLST

Hi,
Our server face a strange problem.
We want to add SSL to our server, and I have set the SSL linsten port enabled, an we can access the admin console with https protocol and SSL listen port.
Then I want to manage the server with
##start WLST with DemoTrust enable
java -Dweblogic.security.SSL.ignoreHostnameVerification=true -Dweblogic.security.TrustKeyStore=DemoTrust weblogic.WLST
##connect
If I use
connect('system','testAdmin','t3://xxxx:10001')
##this can connect successful.
If I use
connect('system','testAdmin','t3s://xxxx:10002')
It will cause an error
WLSTException: Error occured while performing connect : Error getting the initial context. There is no server running at t3s://xxxx:10002 Use dumpStack() to view the full stacktrace
I both enabled plain and SSL listen port and I can access the admin console with http and https without problem. But why I just can not use t3s to connect the server in the WLST? Is there any setting related this? Please advise, thanks.
Here is the dumpStack()
javax.naming.CommunicationException [Root exception is java.net.ConnectException: t3s://xxxx:10002: Destination unreachable; nested exception is:
        java.io.IOException: Stream closed.; No available router to destination]
at weblogic.jndi.internal.ExceptionTranslator.toNamingException(ExceptionTranslator.java:40)
at weblogic.jndi.WLInitialContextFactoryDelegate.toNamingException(WLInitialContextFactoryDelegate.java:783)
at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialContextFactoryDelegate.java:365)
at weblogic.jndi.Environment.getContext(Environment.java:315)
at weblogic.jndi.Environment.getContext(Environment.java:285)
at weblogic.jndi.WLInitialContextFactory.getInitialContext(WLInitialContextFactory.java:117)
at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:667)
at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:288)
at javax.naming.InitialContext.init(InitialContext.java:223)
at javax.naming.InitialContext.<init>(InitialContext.java:197)
at weblogic.management.scripting.WLSTHelper.populateInitialContext(WLSTHelper.java:512)
at weblogic.management.scripting.WLSTHelper.initDeprecatedConnection(WLSTHelper.java:565)
at weblogic.management.scripting.WLSTHelper.initConnections(WLSTHelper.java:305)
at weblogic.management.scripting.WLSTHelper.connect(WLSTHelper.java:203)
at weblogic.management.scripting.WLScriptContext.connect(WLScriptContext.java:60)
at weblogic.management.scripting.utils.WLSTUtil.initializeOnlineWLST(WLSTUtil.java:125)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.python.core.PyReflectedFunction.__call__(PyReflectedFunction.java:160)
at org.python.core.PyMethod.__call__(PyMethod.java:96)
at org.python.core.PyObject.__call__(PyObject.java:248)
at org.python.core.PyObject.invoke(PyObject.java:2016)
at org.python.pycode._pyx4.connect$1(<iostream>:16)
at org.python.pycode._pyx4.call_function(<iostream>)
at org.python.core.PyTableCode.call(PyTableCode.java:208)
at org.python.core.PyTableCode.call(PyTableCode.java:404)
at org.python.core.PyTableCode.call(PyTableCode.java:287)
at org.python.core.PyFunction.__call__(PyFunction.java:179)
at org.python.pycode._pyx15.f$0(<console>:1)
at org.python.pycode._pyx15.call_function(<console>)
at org.python.core.PyTableCode.call(PyTableCode.java:208)
at org.python.core.PyCode.call(PyCode.java:14)
at org.python.core.Py.runCode(Py.java:1135)
at org.python.core.Py.exec(Py.java:1157)
at org.python.util.PythonInterpreter.exec(PythonInterpreter.java:148)
at org.python.util.InteractiveInterpreter.runcode(InteractiveInterpreter.java:89)
at org.python.util.InteractiveInterpreter.runsource(InteractiveInterpreter.java:70)
at org.python.util.InteractiveInterpreter.runsource(InteractiveInterpreter.java:44)
at weblogic.management.scripting.WLST.main(WLST.java:178)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at weblogic.WLST.main(WLST.java:29)
Caused by: java.net.ConnectException: t3s://xxxx:10002: Destination unreachable; nested exception is:
java.io.IOException: Stream closed.; No available router to destination
at weblogic.rjvm.RJVMFinder.findOrCreate(RJVMFinder.java:203)
at weblogic.rjvm.ServerURL.findOrCreateRJVM(ServerURL.java:153)
at weblogic.jndi.WLInitialContextFactoryDelegate$1.run(WLInitialContextFactoryDelegate.java:344)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:363)
at weblogic.security.service.SecurityManager.runAs(Unknown Source)
at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialContextFactoryDelegate.java:339)
... 43 more
Caused by: java.rmi.ConnectException: Destination unreachable; nested exception is:
java.io.IOException: Stream closed.; No available router to destination
at weblogic.rjvm.ConnectionManager.bootstrap(ConnectionManager.java:464)
at weblogic.rjvm.ConnectionManager.bootstrap(ConnectionManager.java:315)
at weblogic.rjvm.RJVMManager.findOrCreateRemoteInternal(RJVMManager.java:251)
at weblogic.rjvm.RJVMManager.findOrCreate(RJVMManager.java:194)
at weblogic.rjvm.RJVMFinder.findOrCreateRemoteServer(RJVMFinder.java:225)
at weblogic.rjvm.RJVMFinder.findOrCreate(RJVMFinder.java:188)
... 48 more
Edited by: Kaos on Feb 25, 2010 12:06 AM

Jai/Faisal,
One strange thing i observe, i tried connecting to admin server through WLST, it works for first time and again it gave me the error next (Connecting alternatively).
the error message which i am getting:
This Exception occurred at Thu Jun 10 08:19:39 CDT 2010.
javax.naming.CommunicationException [Root exception is java.net.ConnectException: t3s://mo8xdwls0018.bankofamerica.com:8933: Destination unreachable; nested exception is:
        java.io.IOException: Stream closed.; No available router to destination]
at weblogic.jndi.internal.ExceptionTranslator.toNamingException(ExceptionTranslator.java:40)
at weblogic.jndi.WLInitialContextFactoryDelegate.toNamingException(WLInitialContextFactoryDelegate.java:783)
at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialContextFactoryDelegate.java:365)
at weblogic.jndi.Environment.getContext(Environment.java:315)
at weblogic.jndi.Environment.getContext(Environment.java:285)
at weblogic.jndi.WLInitialContextFactory.getInitialContext(WLInitialContextFactory.java:117)
at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:667)
at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:288)
at javax.naming.InitialContext.init(InitialContext.java:223)
at javax.naming.InitialContext.<init>(InitialContext.java:197)
at weblogic.management.scripting.WLSTHelper.populateInitialContext(WLSTHelper.java:512)
at weblogic.management.scripting.WLSTHelper.initDeprecatedConnection(WLSTHelper.java:565)
at weblogic.management.scripting.WLSTHelper.initConnections(WLSTHelper.java:305)
at weblogic.management.scripting.WLSTHelper.connect(WLSTHelper.java:203)
at weblogic.management.scripting.WLScriptContext.connect(WLScriptContext.java:60)
at weblogic.management.scripting.utils.WLSTUtil.initializeOnlineWLST(WLSTUtil.java:125)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.python.core.PyReflectedFunction.__call__(PyReflectedFunction.java:160)
at org.python.core.PyMethod.__call__(PyMethod.java:96)
we are connecting to t3s://mo8xdwls0018.bankofamerica.com:8933.
Any help would be appreciated.
-Vishal Iyer

Similar Messages

  • Can not connect to Cerberus FTP Server with PASV

    I setup a FTP Server and i can connect from the inside fine but from the outside i can not connect in passive mode. I can in regular ftp or ssh.
    Here is the log from filezilla
    Status:          Resolving address of domain.com
    Status:          Connecting to ExternalIP:990...
    Status:          Connection established, initializing TLS...
    Status:          Verifying certificate...
    Status:          TLS/SSL connection established, waiting for welcome message...
    Response:          220-220-Welcome to Cerberus FTP Server
    Response:          220 220 Created by Cerberus, LLC
    Command:          USER test
    Response:          331 User test, password please
    Command:          PASS ***********
    Response:          230 Password Ok, User logged in
    Command:          CLNT FileZilla
    Response:          200 Command okay
    Command:          OPTS UTF8 ON
    Response:          220 UTF8 support on
    Command:          PBSZ 0
    Response:          200 PBSZ=0
    Command:          PROT P
    Response:          200 PROT P OK, data channel will be secured
    Status:          Connected
    Status:          Retrieving directory listing...
    Command:          PWD
    Response:          257 "/" is the current directory
    Command:          TYPE I
    Response:          200 Type Binary
    Command:          PASV
    Response:          227 Entering Passive Mode (external IP,195,83)
    Command:          MLSD
    Error:          Connection timed out
    Error:          Failed to retrieve directory listing
    Result of the command: "show running-config"
    : Saved
    ASA Version 8.0(4)
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.10.10 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    pppoe client vpdn group att
    ip address pppoe setroute
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    clock timezone CST -6
    clock summer-time CDT recurring
    object-group service RDP tcp
    description RDP
    port-object eq 3389
    object-group service FTP_PASV_Ports tcp
    description Passive Ports
    port-object range 35000 35999
    object-group service FTPS tcp
    description FTPS
    port-object eq 990
    access-list outside_access_in extended permit tcp any any object-group RDP
    access-list outside_access_in extended permit icmp any any
    access-list outside_access_in extended permit tcp any any eq ftp
    access-list outside_access_in extended permit tcp any any eq telnet
    access-list outside_access_in extended permit tcp any any eq smtp
    access-list outside_access_in extended permit tcp any any eq www
    access-list outside_access_in extended permit tcp any any eq pop3
    access-list outside_access_in extended permit tcp any any eq https
    access-list outside_access_in remark passive FTP port range
    access-list outside_access_in extended permit tcp any host server object-group FTP_PASV_Ports
    access-list outside_access_in extended permit tcp any any eq ssh
    access-list outside_access_in extended permit tcp any any object-group FTPS
    access-list outside_access_in extended permit tcp any any eq ftp-data
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1492
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-621.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp interface www server www netmask 255.255.255.255
    static (inside,outside) tcp interface https server https netmask 255.255.255.255
    static (inside,outside) tcp interface smtp server smtp netmask 255.255.255.255
    static (inside,outside) tcp interface 3389 server 3389 netmask 255.255.255.255
    static (inside,outside) tcp interface pop3 server pop3 netmask 255.255.255.255
    static (inside,outside) tcp interface ftp server ftp netmask 255.255.255.255
    static (inside,outside) tcp interface ssh server ssh netmask 255.255.255.255
    static (inside,outside) tcp interface 990 server 990 netmask 255.255.255.255
    static (inside,outside) tcp interface ftp-data server ftp-data netmask 255.255.255.255
    access-group outside_access_in in interface outside
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.10.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    telnet 0.0.0.0 0.0.0.0 inside
    telnet timeout 5
    ssh 192.168.10.0 255.255.255.0 inside
    ssh timeout 5
    console timeout 0
    vpdn group att request dialout pppoe
    vpdn group att localname @static.sbcglobal.net
    vpdn group att ppp authentication pap
    vpdn username @static.sbcglobal.net password *********
    dhcpd auto_config outside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    username admin password rcuFiQnIXLd encrypted privilege 15
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:ecb5356a2f5e680b
    : end
    I am programing the router with ASDM so if you could tell me what i need to do from the GUI to fix this.

    Dan,
    Looking at the output,
    Status:          Resolving address of domain.com
    Status:          Connecting to ExternalIP:990...
    Status:          Connection established, initializing TLS...
    Status:          Verifying certificate...
    Status:          TLS/SSL connection established, waiting for welcome message...
    This looks like FTPS which is not supported on the ASA. You can workaround it by trying to connect using Active mode from the outside instead of PSV.
    You can find more info here:
    https://supportforums.cisco.com/docs/DOC-23206
    Mike

  • I cannot connect to my game center account October 31, 2013. It's said that "Could not connect to game center server"... is the Server down? could it be fixed quickly

    I cannot connect to my game center account October 31, 2013. It's said that "Could not connect to game center server"... is the Server down? could it be fixed quickly I play Clash of Clan and I really upset when this problem happen @@!

    This happened to me as well. **Warning: The following steps will remove all network passwords from your phone and you will have to re-input them.  Unfortunately, this is unavoidable**
    To resolve, I went to Settings > General > Reset > Reset Network Settings and accept the Reset Network Settings option.
    Afterwards, I was able to log into the Game Center without a problem.
    Cheers.

  • Can not connect outside of Lan to with rtsp PVC2300

    I have the following cameras set up at my office
    1 - PVC2300
    2 - WVC54GC
    3 - AXIS 225FD
    I have a BEFSR81 Router
    I have a computer on Windows XP running the surv software to record.  Everything with that is good.
    I also have 2 desktops.
    I have been playing around with the rtsp feed with the pvc2300, but have run into a few problems.
    1(a).  I can not connect outside of the LAN with RTSP with either the VLC player or quicktime.  It connects and asks for a password and then just hangs.
    The PVC 2300 local address is 192.168.1.102 with ports 554, 5000-5010, and 6970-6999 forwarded on the router.  What am I missing?
    1(b) I can successfully connect with my blackberry bold, although when I try to change the default port (554) to something else (I would like to RTSP my the AXIS camera as well,  so I will need a different port) it connects on my bold, but then says server is unresponsive. What am I missing here?
    2.  The voice with the PVC 2300  using http outside of the LAN (internet) lags quite baddly and is choppy.  This happens without fail when I have all 4 cameras running, which I understand is upload bandwidth problem.  But it also happens when I connect to just the PVC2300.  I do have a connection to all 4 cameras inside the LAN to the XP running the surv software, but that is it. Is the my router acting buggy?  I have unplugged the router for 5 sec, and it fixed it for a while, but it always comes back.  I have donwloaded the latest firmware for the router and PVC 2300 and that didnt seem ot fix it either.  Suggestions?
    3.  This is more of a question.  I know the mobile streaming of the PVC 2300 does not include voice.  Is there an app or way that I can just get it to my Blackberry.  Even if I didnt get the video, voice is sometimes more important to me.
    I hope Ive been clear enough in my description, Im very self taught (google is amazing), but I am in no way a techy.
    Thank you in advace for your help.
    Colin

    Glad to hear you are successfully using the SWVMS16. That program is really cool and useful. I just cant tell you how that model of Linksys Router can work for you here (that is not a model we support on this community as its not small business)
    Regarding RTSP access, are you also including the mobile.sdp in the URL?
    RTSP:///mobile.sdp   I noticed in the camera GUI with the newer firmware, you can specify an access code under mobile settings after checking the enable mobile streaming box.  That word may be what you have to include, so check that too...
    Try this locally first and then remotely is the easiest way to see if you got it right, then it just becomes a routing or firewall issue to figure out.
    But your forwarded ports look right and should be opened.
    Under advanced settings, you can define an alternate HTTP, HTTPS or RTSP port

  • HT4314 could not connect to game center server .      What is the solution

    This massage
    could not connect to game center server !

    Its part of the iCloud service failure today. Just wait, it should be beck to normal soon. Mine did (although it took almost 2 hours)

  • Mountain lion 10.8.2 can not connect to windows NAS server Dell Sentinel

    I recently upgraded to 10.8 OS My office is connected to a NAS server Dell Sentinel WD4000. Everything was working fine until the upgrade from 10.7 to 10.8 Now when I "connect to server" Not one of my accounts can connect. All I get is wrong password. The server connects to every computer on the network except the 10.8 The server shows up as an icon on Shared Devices.
    Someone please help me. Apple has been useless.

    I hope this helps.  But, Apple has confirmed a significant bug in 10.7.4 that breaks SMB.  Their support says they are working on it, but they do not know when the fix will be released.  It has broken SMB at all sites I support including my own location where Lion server has the updated version as well.  Only AFP works but not consistently.  The suggestion is to restore 10.7.3 from a backup or wait until the fix is released.  SMB does work - but only when admin authentication is used on Mac servers - don't know about Windows Servers.  I do know the client side of Mac's also are affected with SMB issues.  Good luck!

  • JDeveloper 10.1.3 BPEL plugin - can NOT connect to BPEL PM server

    I can use the JDeveloper BPEL Designer 10.1.2.1.0 to create a simpel BPEL Process that I deploy to the BPELM PM with the following WSDL:
    http://kmandrup-dk:9700/orabpel/default/BPELProcess1/1.0/BPELProcess1?wsdl
    I can then use JDeveloper 10.1.3 to hook up to this WSDL
    I would however prefer to use the BPEL plugin from within JDev 10.1.3 to create the BPEL process and deploy it directly. However I can't figure out how to establish a connection to the BPEL PM. Should I instead install a UDDI registry in my application server and then register the web service there? Seems like a "twisted" workaround!
    In JDev 10.1.2 connections view, there is a node called BPEL Process Manager Server where one can create connections to BPELM PMSs
    In Jdev 10.1.3 there is an App Server node and an Integration Server node, but the Integration Server node seems only able to refer to the App Server connections.
    How does one achieve a direct BPEL PM Server connection in 10.1.3 similar to the effect of 10.1.2.
    When I create a new BPEL Process Project I get an error, That the WSDL for the service created is not valid, due to being unable to acces a BPEL PMS :( What to do?
    It also complains that it is unable to create the test suites :(
    Is something missing in my BPEL plugin install perhaps???
    Thanx in advance for any help!

    Does the 10.1.3 J-Developer have the BPEL plugin in it? I didn't think this was avail. Unless you are on a beta version, I would bet you don't have the full deal like you think.

  • Ipod touch does not turn on the screen shows USB cable and ask to connect to the itune, itune message pops up can not connect because it is locked with pass code how can i turn on this device?

    My son's ipod touch 3 screen shows a USB cable image and ask to connect to the itune. Itune does not connect with the message shows: this device is locked and can not be connected to the itune before you unlock it" I have no idea how to turn on this device and how to connect this to the itune, any help is highly appreciated.

    Try to get it to recognize it by using DFU Mode. Then restore.
    Basic troubleshooting steps  
    17" 2.2GHz i7 Quad-Core MacBook Pro  8G RAM  750G HD + OCZ Vertex 3 SSD Boot HD 
    Got problems with your Apple iDevice-like iPhone, iPad or iPod touch? Try Troubleshooting 101

  • Can  not connect datasource in weblogic server

    I have written a test class. I create datasource in weblogic server 11g(datasource name =fdbusionline jndi name = 'jdbc/fdbusionline' ) and start weblogic server. but always report the following error:
    javax.naming.NameNotFoundException: Unable to resolve 'fdbusionline'. Resolved '' [Root exception is javax.naming.NameNotFoundException: Unable to resolve 'fdbusionline'. Resolved '']; remaining name 'fdbusionline'
    at weblogic.rjvm.ResponseImpl.unmarshalReturn(ResponseImpl.java:234)
    at weblogic.rmi.cluster.ClusterableRemoteRef.invoke(ClusterableRemoteRef.java:348)
    at weblogic.rmi.cluster.ClusterableRemoteRef.invoke(ClusterableRemoteRef.java:259)
    at weblogic.jndi.internal.ServerNamingNode_1035_WLStub.lookup(Unknown Source)
    at weblogic.jndi.internal.WLContextImpl.lookup(WLContextImpl.java:423)
    at weblogic.jndi.internal.WLContextImpl.lookup(WLContextImpl.java:411)
    at com.fd.busionline.test.appinterface.impl.DataSourceTest.testConnectDataSource(DataSourceTest.java:54)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:44)
    at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:15)
    at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:41)
    at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:20)
    at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:28)
    at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:31)
    at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:73)
    at org.junit.runners.BlockJUnit4ClassRunner.runChild(BlockJUnit4ClassRunner.java:46)
    at org.junit.runners.ParentRunner.runChildren(ParentRunner.java:180)
    at org.junit.runners.ParentRunner.access$000(ParentRunner.java:41)
    at org.junit.runners.ParentRunner$1.evaluate(ParentRunner.java:173)
    at org.junit.internal.runners.statements.RunBefores.evaluate(RunBefores.java:28)
    at org.junit.internal.runners.statements.RunAfters.evaluate(RunAfters.java:31)
    at org.junit.runners.ParentRunner.run(ParentRunner.java:220)
    at oracle.jdevimpl.junit.runner.junit4.JUnit4Testable.run(JUnit4Testable.java:24)
    at oracle.jdevimpl.junit.runner.TestExecution.run(TestExecution.java:27)
    at oracle.jdevimpl.junit.runner.JUnitTestRunner.main(JUnitTestRunner.java:88)
    Caused by: javax.naming.NameNotFoundException: Unable to resolve 'fdbusionline'. Resolved ''
    at weblogic.jndi.internal.BasicNamingNode.newNameNotFoundException(BasicNamingNode.java:1139)
    at weblogic.jndi.internal.BasicNamingNode.lookupHere(BasicNamingNode.java:252)
    at weblogic.jndi.internal.ServerNamingNode.lookupHere(ServerNamingNode.java:182)
    at weblogic.jndi.internal.BasicNamingNode.lookup(BasicNamingNode.java:206)
    at weblogic.jndi.internal.RootNamingNode_WLSkel.invoke(Unknown Source)
    at weblogic.rmi.internal.BasicServerRef.invoke(BasicServerRef.java:667)
    at weblogic.rmi.cluster.ClusterableServerRef.invoke(ClusterableServerRef.java:230)
    at weblogic.rmi.internal.BasicServerRef$1.run(BasicServerRef.java:522)
    at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:363)
    at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:146)
    at weblogic.rmi.internal.BasicServerRef.handleRequest(BasicServerRef.java:518)
    at weblogic.rmi.internal.wls.WLSExecuteRequest.run(WLSExecuteRequest.java:118)
    at weblogic.work.ExecuteThread.execute(ExecuteThread.java:209)
    at weblogic.work.ExecuteThread.run(ExecuteThread.java:178)
    @test
    public void testConnectDataSource(){
    Connection conn = null;
    Context ctx = null;
    try{
    // Hashtable env = new Hashtable();
    // env.put(Context.INITIAL_CONTEXT_FACTORY, "weblogic.jndi.WLInitialContextFactory");
    // env.put(Context.PROVIDER_URL, "t3://localhost:7001");
    // env.put(InitialContext.SECURITY_PRINCIPAL, "weblogic");
    // env.put(InitialContext.SECURITY_CREDENTIALS, "!QAZ2wsx");
    Environment env=new Environment();
    env.setProviderUrl("t3://localhost:7001");
    env.setSecurityPrincipal("weblogic");
    env.setSecurityCredentials("!QAZ2wsx");
    ctx = new InitialContext();
    ctx=env.getInitialContext();
    Object obj = ctx.lookup("fdbusionline");// can not work
    Object obj = ctx.lookup("jdbc/fdbusionline"); // can not work
    DataSource ds = (DataSource) PortableRemoteObject.narrow(obj, DataSource.class);
    conn = ds.getConnection();
    Statement stmt = conn.createStatement();
    String sql = "select sysdate from dual";
    ResultSet rs = stmt.executeQuery(sql);
    while (rs.next()) {
    System.out.println(rs.getDate(1));
    } catch (Exception e) {
    e.printStackTrace();
    }finally{
    System.out.println("Test Datasource Connection");
    who can help me? Any help will be appreciated greatly

    Okay, but are you sure that the datasource is actually deployed? Does the server log or the management interface of weblogic actually report that the datasource was deployed succesfully under the name you specify? And did you double check if you don't have any name mismatches (such as a typo or an upper/lowercase mismatch)?
    I ask because the connection to the server appears to be working, but the lookup of the name gives no results - the only thing I can think of is that the resource really is not deployed even if you believe it is.
    A few observations:
    - you may want to put your JNDI credentials in a jndi.properties file in the root of the classpath in stead of hardcoding them (but you may hardcode for now as a quick test of course)
    - the correct lookup should be to "jdbc/fdbusionline", in other words you use the jndi-name.
    ctx = new InitialContext();
    ctx=env.getInitialContext();the env.getInitialContext() really is not necessary, I would remove it.

  • Can not login groupspace when admin server is not running

    hi Experts,
    I am using wc11.1.1.5, I found an issue like this:
    1. startup admin server
    2. startup WC_Spaces
    3. stop admin server
    4. login WC_Spaces
    At this time, I got the following issue:
    =============================
    Caused By: oracle.security.jps.service.idstore.IdentityStoreException: JPS-01520
    Cannot initialize identity store.
    at oracle.security.jps.internal.idstore.util.IdentityStoreUtil.getIdenti
    tyStoreFactory(IdentityStoreUtil.java:168)
    at oracle.security.jps.internal.idstore.AbstractIdmIdentityStore.getIdmF
    actory(AbstractIdmIdentityStore.java:174)
    at oracle.security.jps.internal.idstore.AbstractIdmIdentityStore.initSto
    re(AbstractIdmIdentityStore.java:124)
    at oracle.security.jps.internal.idstore.AbstractIdmIdentityStore.getIdmS
    tore(AbstractIdmIdentityStore.java:110)
    at oracle.webcenter.framework.service.Utility$1.run(Utility.java:1124)
    at oracle.webcenter.framework.service.Utility$1.run(Utility.java:1121)
    at java.security.AccessController.doPrivileged(Native Method)
    at oracle.webcenter.framework.service.Utility.getDefaultIdentityStore(Ut
    ility.java:1118)
    at oracle.webcenter.framework.service.Utility.getUserUniqueIdentifier(Ut
    ility.java:1046)
    at oracle.webcenter.framework.service.Utility.getUserName(Utility.java:6
    05)
    at oracle.webcenter.webcenterapp.model.security.WebCenterSecurityUtils.g
    etUserUniqueID(WebCenterSecurityUtils.java:2050)
    at oracle.webcenter.webcenterapp.internal.metadata.WebCenterUserCC.getVa
    lue(WebCenterUserCC.java:74)
    at oracle.mds.internal.cust.CustomizationUtils.appendCLs(CustomizationUt
    ils.java:456)
    at oracle.mds.internal.cust.CustomizationUtils.getCLList(CustomizationUt
    ils.java:282)
    at oracle.mds.core.MDSSession.getMetadataObject(MDSSession.java:3121)
    at oracle.mds.core.MDSSession.getMetadataObject(MDSSession.java:1228)
    at oracle.mds.core.MOResolver.getMetadataObjects(MOResolver.java:213)
    at oracle.adfinternal.controller.metadata.provider.MdsMetadataResourcePr
    ovider.getMetadataObjects(MdsMetadataResourceProvider.java:421)
    at oracle.adfinternal.controller.metadata.provider.MdsMetadataResourcePr
    ovider.loadUnmutalbeMetadataResources(MdsMetadataResourceProvider.java:372)
    at oracle.adfinternal.controller.metadata.provider.MdsMetadataResourcePr
    ovider.loadResources(MdsMetadataResourceProvider.java:346)
    at oracle.adfinternal.controller.metadata.provider.MdsMetadataResourcePr
    ovider.getBootstrapResources(MdsMetadataResourceProvider.java:238)
    at oracle.adf.controller.internal.metadata.MetadataService$Bootstrap.add
    All(MetadataService.java:905)
    at oracle.adf.controller.internal.metadata.MetadataService.initializePag
    eFlow(MetadataService.java:657)
    at oracle.adf.controller.internal.metadata.MetadataService.getPerUserCac
    he(MetadataService.java:760)
    at oracle.adf.controller.internal.metadata.MetadataService.getPerUserCac
    he(MetadataService.java:729)
    at oracle.adf.controller.internal.metadata.MetadataService.getAdfPageFlo
    w(MetadataService.java:459)
    at oracle.adf.controller.internal.metadata.MetadataService.getPageFlow(M
    etadataService.java:448)
    at oracle.adf.controller.internal.metadata.MetadataService.getActivity(M
    etadataService.java:304)
    at oracle.adfinternal.controller.state.ViewPortContextImpl.getPhysicalUR
    I(ViewPortContextImpl.java:1074)
    at oracle.adfinternal.controller.application.AdfcPageResolver.getPhysica
    lURI(AdfcPageResolver.java:75)
    at oracle.adf.controller.faces.lifecycle.Utils.getPagePathFromViewId(Uti
    ls.java:44)
    at oracle.adfinternal.controller.application.model.UpdateBindingListener
    .setBindingELVariable(UpdateBindingListener.java:108)
    at oracle.adfinternal.controller.application.model.UpdateBindingListener
    .beforePhase(UpdateBindingListener.java:61)
    ================
    after restart admin server, this issue was solved.
    My question is this normal? this could be a issue for high availability.
    Best regards

    Admin server's purpose is - to control other managed servers.For High availability you can use clustered enviroment and other stuffs as suggested by oracle.
    Without running Admin server how security->myrealms>Users will work ?Users will not be available ,that's why you are getting such errors.
    Regards,
    Hoque

  • On runInstaller I get 'can not connect to X11 windoows manager with DISPLAY variable

    set to :0.
    OK. What are the setting it does work with?
    or where can I find options for the settings of DISPLAY?

    You should set DISPLAY to "hostname:0.0". -- e.g. in bash: ------
    $ DISPLAY=dbserver:0.0
    $ export DISPLAY
    $ xhost +
    $ ./runInstaller
    if this does not work, restart your x-server and try again...
    greetings

  • Can not connect to itunes store ever since I did the update.

    I have tried everything from flushing my DNS, Reloading my itunes, checking my anti-virus software which is Symantec, Making sure my firewall enables itunes. One thing is that when i go into add or remove programs it asks if i want to repair itunes and i do but it still asks if i want to repair and still wont access itunes store.
    *here is my diagnostics:*
    Microsoft Windows Vista Home Edition Service Pack 1 (Build 6001)
    Hewlett-Packard HP Pavilion dv9700 Notebook PC
    iTunes 7.7.1.11
    QuickTime 7.5
    CD Driver 2.0.7.3
    CD Driver DLL 2.1.1.1
    Apple Mobile Device 2.0.1.5
    Bonjour 1.0.4.12 (118.4)
    iTunes Serial Number 42C580F40E6F4782
    Current user is not an administrator.
    The current local date and time is 2008-08-04 20:51:10.
    iTunes is not running in safe mode.
    Video Display Information
    NVIDIA, NVIDIA MCP67M
    ** External Plug-ins Information **
    No external plug-ins installed.
    ** Network Connectivity Tests **
    Network Adapter Information
    Adapter Name: {65F39CFC-3037-41FF-AC42-EF0504A3706D}
    Description: NVIDIA nForce Networking Controller
    IP Address: 192.168.1.47
    Subnet Mask: 255.255.255.0
    Default Gateway: 192.168.1.1
    DHCP Enabled: Yes
    DHCP Server: 192.168.1.1
    Lease Obtained: Mon Aug 04 20:14:08 2008
    Lease Expires: Tue Aug 05 20:14:08 2008
    DNS Servers: 192.168.1.1
    192.168.1.1
    Adapter Name: {32BA9F3C-BA8E-4341-93E8-0DDB37CA58EA}
    Description: Broadcom 4321AG 802.11a/b/g/draft-n Wi-Fi Adapter
    IP Address: 0.0.0.0
    Subnet Mask: 0.0.0.0
    Default Gateway: 0.0.0.0
    DHCP Enabled: Yes
    DHCP Server:
    Lease Obtained: Wed Dec 31 19:00:00 1969
    Lease Expires: Wed Dec 31 19:00:00 1969
    DNS Servers:
    Active Connection: LAN Connection
    Connected: Yes
    Online: Yes
    Using Modem: No
    Using LAN: Yes
    Using Proxy: No
    SSL 3.0 Support: Enabled
    TLS 1.0 Support: Enabled
    Firewall Information
    Windows Firewall is on.
    iTunes is enabled in Windows Firewall.
    Connection attempt to Apple web site was unsuccessful.
    The network connection timed out.
    Connection attempt to iTunes Store was unsuccessful.
    The network connection timed out.
    Secure connection attempt to iTunes Store was unsuccessful.
    The network connection timed out.
    Secure connection attempt to iPhone activation server unsuccessful.
    The network connection timed out.
    Last successful store access was 2008-08-01 20:56:32.

    Saw this on another post.
    Applecare Senior Advisor Txx Bxxx (I have his contact info in an email he just sent) just confirmed with me that the problem people are having with the App Store not loading is an apple issue with there servers, ITS NOT YOUR IPAD so don't go restoring it!   It's not happening to everyone however but they are looking into it, its really hit or miss.
    In the meantime ...........
    The Complete Guide to Using the iTunes Store
    http://www.ilounge.com/index.php/articles/comments/the-complete-guide-to-using-t he-itunes-store/
    Can't connect to the iTunes Store
    http://support.apple.com/kb/TS1368
    iTunes: Advanced iTunes Store troubleshooting
    http://support.apple.com/kb/TS3297
    Best Fixes for ‘Cannot Connect to iTunes Store’ Errors
    http://ipadinsight.com/ipad-tips-tricks/best-fixes-for-cannot-connect-to-itunes- store-errors/
    Try this first - Reset the iPad by holding down on the sleep and home buttons at the same time for about 10-15 seconds until the Apple Logo appears - ignore the red slider - let go of the buttons.
    This works for some users. Not sure why.
    Go to Settings>General>Date and Time> Set Automatically>Off. Set the date ahead by about a year.Then see if you can connect to the store.
     Cheers, Tom

  • DNSreport says it can't connect to my mail server...although the mail works

    When I run a test on my virtual domain at www.dnsreport.com I get the following FAILURE:
    ======
    ERROR: I could not complete a connection to any of your mailservers!
    mail.thermal3p.com: Timed out [Last data sent: RCPT TO: ]
    If this is a timeout problem, note that the DNS report only waits about 40 seconds for responses, so your mail may work fine in this case but you will need to use testing tools specifically designed for such situations to be certain.
    ======
    Mail is being received and sent via the virtualmailhost with only one known problem which is the reason I ran the report - one server keeps bouncing my outbound messages back with this vague error:
    <[email protected]>: host
    INBOUND.FILTER.THEPLANET.com[216.185.111.115] said: 550 Denied. S1 (in reply to RCPT TO command)
    Here is the full report on my virtual domain:
    http://www.dnsreport.com/tools/dnsreport.ch?domain=thermal3p.com
    It would help if I could just narrow down wether it is a DNS record problem or a server setup problem. To me the server seems to be fine, but I also can't figure out what I've done wrong in the DNS setup. DNS records are hosted at GoDaddy.
    THANKS,
    Keith

    Your mail server is answering, but isn't answering
    with its MX name in the DNS record:
    Can I tell if that is a DNS issue or a Server issue?
    It's your choice. Depends on what you want the mail server's name to be. One option would be to change your MX record in your DNS zone file so that the MX host name matches the name announced by your server. Another option would be to change the name announced by your server to match the MX record in your DNS zone file.
    Reverse DNS is wrong (some servers won't accept
    email from you unless reverse DNS matches the
    HELO/EHLO name):
    I believe this is why the one server is bouncing me.
    The IT told me to check that. Now the problem is
    that I don't know how to fix it.
    That's why I posted the entire response for your reverse DNS query. Here it is again:
    ; <<>> DiG 9.3.2 <<>> -x 71.154.29.157 ptr
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 5937
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0
    ;; QUESTION SECTION:
    ;157.29.154.71.in-addr.arpa. IN PTR
    ;; ANSWER SECTION:
    157.29.154.71.in-addr.arpa. 7200 IN PTR adsl-71-154-29-157.dsl.rcsntx.sbcglobal.net.
    ;; AUTHORITY SECTION:
    29.154.71.in-addr.arpa. 172800 IN NS ns1.pbi.net.
    29.154.71.in-addr.arpa. 172800 IN NS ns2.pbi.net.</div>
    The "Authority" for the 29.154.71.in-addr.arpa. subdomain are the nameservers at pbi.net. The person responsible for that nameserver needs to change the PTR record for 157.29.154.71.in-addr.arpa. from adsl-71-154-29-157.dsl.rcsntx.sbcglobal.net. to the name announced by your server (see above, first get the announced name to match your MX record).
    Do you think I should be talking to my service
    provider (sbcglobal.net) or the DNS host (godaddy) or
    Myself (the hack that is responsible for setting up
    the server)?
    If you start talking to yourself, people wonder. Your service provider (sbcglobal.net) is the one that has to handle this.
    Russ
    Xserve G5 2.0 GHz 2 GB RAM   Mac OS X (10.4.8)   Apple Hardware RAID, ATTO UL4D, Exabyte VXA-2 1x10 1u

  • IMac 10.7 can not connect to an old Mac with Os 9 classic

    Hi, hope somebody can help me with this issue
    My company bought a brand new IMac 10.7 Osx an I need to make a conection from this machine to an old G3 with Mac Os 9 classic system where all my files are stored and even my Rip software resides.
    When I try to make the conection a message appears telling me ¨the system is not supported¨ or something like that, so what can I do? Any way to make the conection?
    No, no way to take my old Mac to the trash, my rip software only works on Classic 9 system...
    Thanks in advance for any help

    Connecting via IP versus system name will not solve the problem, nor will me "finding a newer solution" - I already have a Mac OS 10.7 system and as of today, there is NOTHING newer (that will change possibly in the up-coming week).  I may look at the "work--round" again though. I checked the link but did not understand it on my first pass. It appeared to be a modification process executed on the 10.7 system to enable some "old and insecure behavior".
    The 10.5 based tower I have does not provide built-in hardware support for the IDE disks either, so I cannot just move them to it.  Booting the old system in target mode means physically relocating it into the immediate proximitiy of the 10.7 system, or vice versa AND it does not provide access to all of the hard disks installed. It only provides access to the boot disk in many cases. Not to mention, such relocation is not always convienient for the period of time necessary to move the files and then check the integrity to the relocated versions.   I may however attempt to install an NFS server if I can still find one and connect that way.
    There is something wrong with the system hardware too. It will not boot into 10.x from an external drive or from the DVD. When all memory modules are installed, the system indicates a memory test errorr, and it does NOT move when the order of modules is changed. Therefore I cannot install a more recent version of the OS and attempt to get the disks seen over the network that way.
    Message was edited by: Daniel O\'Leary to add additional information on things I have tried but yielded unsuccessful results.

  • Ever since I installed the new i0S 6.0 update on my iphone 4s it says "can not connect to itunes store" when I click on the "app store" on passbook. How do I fix this?

    How do I fix this on my phone so I can access the app store and the new passbook app?

    Did you try reinstalling the app and contacting the developer (there should be a contact link on the app's description page in the store) ? If you don't get a reply from the developer then you could try
    'report a problem' link from the purchase history on your computer's iTunes instead of on your iPad : log into your account on your computer's iTunes via Store > View My Account and you should then see a Purchase History section with a 'see all' link to the right of it ; click on that and you should see a list of your purchases ; find that song and use the 'Report a Problem' link (iTunes support should reply within, I think, 24 to 48 hours).
    Some people have had a problem with the 'report a problem' link (it's been taking people to this site on a browser instead of showing a form in iTunes) - if it does that to you then try contacting iTunes support via this page : http://www.apple.com/support/itunes/contact/- click on Contact iTunes Store Support on the right-hand side of the page.

Maybe you are looking for