Can not deploy  a remote storage node

Hello,
I have started successfully two SNA at two node, because we can ping to each other. But when I use admin console to to deploy the first remote storage node, it always shows the error "Connection refused to host: localhost". I use the command line to deploy a remote storage node. There is the same problem.
Dose some one know how to solve it? Thank you advanced.
Here is the error log:
in createPlan: Oracle NoSQL DB 11gR2.1.2.123 oracle.kv.impl.fault.OperationFaultException: Plan 16[Plan-16] finished in state ERROR. Problem during plan execution: Connection refused to host: localhost; nested exception is: java.net.ConnectException: Connection refused
caused by:
oracle.kv.impl.admin.AdminFaultException
Oracle NoSQL DB 11gR2.1.2.123 oracle.kv.impl.fault.OperationFaultException: Plan 16[Plan-16] finished in state ERROR. Problem during plan execution: Connection refused to host: localhost; nested exception is:
     java.net.ConnectException: Connection refused
Oracle NoSQL DB 11gR2.1.2.123 oracle.kv.impl.fault.OperationFaultException: Plan 16[Plan-16] finished in state ERROR. Problem during plan execution: Connection refused to host: localhost; nested exception is:
     java.net.ConnectException: Connection refused oracle.kv.impl.fault.OperationFaultException: Plan 16[Plan-16] finished in state ERROR. Problem during plan execution: Connection refused to host: localhost; nested exception is:
     java.net.ConnectException: Connection refused
     at sun.rmi.transport.tcp.TCPEndpoint.newSocket(TCPEndpoint.java:601)
     at sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:198)
     at sun.rmi.transport.tcp.TCPChannel.newConnection(TCPChannel.java:184)
     at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:110)
     at java.rmi.server.RemoteObjectInvocationHandler.invokeRemoteMethod(RemoteObjectInvocationHandler.java:178)
     at java.rmi.server.RemoteObjectInvocationHandler.invoke(RemoteObjectInvocationHandler.java:132)
     at $Proxy8.getSerialVersion(Unknown Source)
     at oracle.kv.impl.util.registry.RemoteAPI.(RemoteAPI.java:32)
     at oracle.kv.impl.sna.StorageNodeAgentAPI.(StorageNodeAgentAPI.java:51)
     at oracle.kv.impl.sna.StorageNodeAgentAPI.wrap(StorageNodeAgentAPI.java:58)
     at oracle.kv.impl.util.registry.RegistryUtils.getStorageNodeAgent(RegistryUtils.java:243)
     at oracle.kv.impl.admin.plan.task.DeploySN.call(DeploySN.java:94)
     at oracle.kv.impl.admin.plan.task.DeploySN.call(DeploySN.java:35)
     at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
     at java.util.concurrent.FutureTask.run(FutureTask.java:138)
     at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
     at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
     at java.lang.Thread.run(Thread.java:662)
Caused by: java.rmi.ConnectException: Connection refused to host: localhost; nested exception is:
     java.net.ConnectException: Connection refused
     ... 18 more
Caused by: java.net.ConnectException: Connection refused
     at java.net.PlainSocketImpl.socketConnect(Native Method)
     at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:351)
     at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:213)
     at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:200)
     at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
     at java.net.Socket.connect(Socket.java:529)
     at java.net.Socket.connect(Socket.java:478)
     at java.net.Socket.(Socket.java:375)
     at java.net.Socket.(Socket.java:189)
     at sun.rmi.transport.proxy.RMIDirectSocketFactory.createSocket(RMIDirectSocketFactory.java:22)
     at sun.rmi.transport.proxy.RMIMasterSocketFactory.createSocket(RMIMasterSocketFactory.java:128)
     at sun.rmi.transport.tcp.TCPEndpoint.newSocket(TCPEndpoint.java:595)
     ... 17 more
     at oracle.kv.impl.admin.AdminServiceFaultHandler.getThrowException(AdminServiceFaultHandler.java:84)
     at oracle.kv.impl.fault.ProcessFaultHandler.rethrow(ProcessFaultHandler.java:205)
     at oracle.kv.impl.fault.ProcessFaultHandler.execute(ProcessFaultHandler.java:144)
     at oracle.kv.impl.admin.CommandServiceImpl.executePlan(CommandServiceImpl.java:234)
     at oracle.kv.impl.admin.CommandServiceAPI.executePlan(CommandServiceAPI.java:162)
     at oracle.kv.impl.admin.webapp.server.AdminUIServiceImpl.createPlan(AdminUIServiceImpl.java:554)
     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
     at java.lang.reflect.Method.invoke(Method.java:597)
     at com.google.gwt.user.server.rpc.RPC.invokeAndEncodeResponse(RPC.java:569)
     at com.google.gwt.user.server.rpc.RemoteServiceServlet.processCall(RemoteServiceServlet.java:208)
     at com.google.gwt.user.server.rpc.RemoteServiceServlet.processPost(RemoteServiceServlet.java:248)
     at com.google.gwt.user.server.rpc.AbstractRemoteServiceServlet.doPost(AbstractRemoteServiceServlet.java:62)
     at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
     at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
     at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:538)
     at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:476)
     at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119)
     at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:517)
     at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:225)
     at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:934)
     at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:404)
     at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:183)
     at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:869)
     at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117)
     at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:114)
     at org.eclipse.jetty.server.Server.handle(Server.java:341)
     at org.eclipse.jetty.server.HttpConnection.handleRequest(HttpConnection.java:589)
     at org.eclipse.jetty.server.HttpConnection$RequestHandler.content(HttpConnection.java:1065)
     at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:823)
     at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:220)
     at org.eclipse.jetty.server.HttpConnection.handle(HttpConnection.java:411)
     at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:515)
     at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:40)
     at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:529)
     at java.lang.Thread.run(Thread.java:662)
(from Plans.PlanCallback)

920601 wrote:
Thanks, Charles. I use network host name or network host IP address instead of localhost and it well resolved my former problem. I can deploy the remote SN. But there is a new problem when I deploy the store. It looks like that these Replication Node at different SN can not communicate with each other, because of mis-match IP address format.
Note that the node "community01/10.193.128.223" is the first deployed node who holds the administration process, "mi-desktop/127.0.1.1:5011" is another node. I don't understand why the second node uses its loopback adress. Can you help me to find out the solution?
Here is the original error log.
"mi-desktop/127.0.1.1:5011 the address associated with this node, is a loopback address. It conflicts with an existing use, by a different node of the address:community01/10.193.128.223:5011 which is not a loopback address. Such mixing of addresses within a group is not allowed, since the nodes will not be able to communicate with each other."I'm not sure I have any good advice, but I would check your /etc/hosts to see if mi-desktop maps to the loopback address (127.0.0.1). If it does, then you need to use a name that does not map to the loopback.
Charles Lamb

Similar Messages

  • URGENT -1 from DCM Command  on OBE deploy  === can not deploy/

    Attempting to complete the OBE "Deploying J2EE and ADF Applications
    http://www.oracle.com/technology/obe/obe9051jdev/deployToAppServer/lesson_Deployment.htm
    in order to prove to upper management that it is "easy" to develop on JDEV 9.0.5 build 1618 and deploy to Oc4j 9.0.4
    Compiles clean
    Runs like a champ on the embedded oc4j
    When i try to deploy the J2EE Application to oracle 9.0.4 getting a -1 from Oc4jDcmServlet <#### Deployment incomplete. #### >
    < see attached >
    when i look at the 9.0.4 Instance's XML log i get:
    java.lang.Exception: can not deploy/undeploy to a disabled component: home
    <see attached >
    i have checked the home component. there is no way to enable / disable it just have start and stop and it is in the start state.
    please help.
    JDEV log
    Invoking DCM servlet client...
    C:\Java\j2sdk1.4.2_06\jre\bin\javaw.exe -Djava.protocol.handler.pkgs=HTTPClient -jar C:\Jdeveloper\jdev\lib\oc4j_remote_deploy.jar http://jstoll-xp-lt:1810/Oc4jDcmServletAPI/ ias_admin **** redeploy C:\Ora10G.9.0.4\InfraEngine C:\Jdeveloper\jdev\mywork\deploySamples\deployment_j2ee\View\deploy\application1.ear hr
    Initializing log
    Servlet interface for OC4J DCM commands
    Command timeout defined at 600 seconds
    Executing DCM command...
    Executing command redeploy C:\Ora10G.9.0.4\InfraEngine C:\Jdeveloper\jdev\mywork\deploySamples\deployment_j2ee\View\deploy\application1.ear hr UNDEFINED
    Command = REDEPLOY
    Reading application's ear file
    Ear file was successfully read
    Opening connection to Oc4jDcmServlet
    Setting userName to ias_admin
    Sending command to DCM servlet
    HTTP response code = 200, HTTP response msg = OK
    Command was successfully sent to Oc4jDcmServlet
    Receiving session id from servlet to check command status
    Session id = 0a0a0a0a712594fbb82a5544f92a4d1a95f5dc99c4e
    Please, wait for command to finish...
    Checking command status...
    Setting userName to ias_admin
    Setting Cookie to JSESSIONID=0a0a0a0a712594fbb82a5544f92a4d1a95f5dc99c4e
    Checking command status
    HTTP response code = 200, HTTP response msg = OK
    Command has not finished yet
    Checking command status...
    Setting userName to ias_admin
    Setting Cookie to JSESSIONID=0a0a0a0a712594fbb82a5544f92a4d1a95f5dc99c4e
    Checking command status
    HTTP response code = 200, HTTP response msg = OK
    Command has not finished yet
    Checking command status...
    Setting userName to ias_admin
    Setting Cookie to JSESSIONID=0a0a0a0a712594fbb82a5544f92a4d1a95f5dc99c4e
    Checking command status
    HTTP response code = 200, HTTP response msg = OK
    Command has not finished yet
    Checking command status...
    Setting userName to ias_admin
    Setting Cookie to JSESSIONID=0a0a0a0a712594fbb82a5544f92a4d1a95f5dc99c4e
    Checking command status
    HTTP response code = 200, HTTP response msg = OK
    Command has finished
    Receiving command exit value
    Receiving command output
    **** No output was received from command
    Closing connection to Oc4jDcmServlet
    #### DCM command did not complete successfully (-1)
    #### HTTP return code was -1
    Exit status of DCM servlet client: -1
    Elapsed time for deployment: 48 seconds
    #### Deployment incomplete. #### Oct 31, 2005 3:15:43 PM
    log.xml
    Log Entry: October 31, 2005 3:15:38 PM EST
    Component DCM
    Message Type Error
    Module ID oracle/defaultLogger/ExceptionLogger
    User ID SYSTEM
    Host Name jstoll-xp-lt
    Host Network Address 10.10.10.10
    Process/Thread ID null-Thread[Deamon Worker for TaskMaster of iAS instance at: C:\Ora10G.9.0.4\InfraEngine JVM Id = 763f5d.107482d4e1c.-8000,5,main]
    Message Level 1
    Execution Context ID 10.10.10.10:57042:1130789725003:0
    Message Text
    Remote Execute failed:
    Supplemental Text
    java.lang.Exception: can not deploy/undeploy to a disabled component: home
    at oracle.ias.sysmgmt.task.TaskMaster.internal_evaluate(Unknown Source)
    at oracle.ias.sysmgmt.task.RemoteEvaluate.execCommand(Unknown Source)
    at oracle.ias.sysmgmt.task.DaemonWorker.run(Unknown Source)

    DCM command did not complete successfully (-1)
    DCM command did not complete successfully (-1)

  • Why does my console NOT run as a storage node

    help!
    I created a minimal console script, for testing, to run as a storage node, with my own classes in the classpath.
    Unfortunately, it does not act as a storage node, even though I patterned it after the console script in the coherence/bin directory.
    The failure symptom is that my application, run on a non-storage-enabled jvm, fails with "storage is not configured."
    If instead of the console, I run as a storage node a jvm, with the same command line options, except with my own mainline that loops dumping the cache, the application in the other jvm works.
    The console does work as a client node, and is able to use my custom classes from the classpath. Hence it is participating in the cluster (the whole cluster runs on my PC).
    I assume there is something simple wrong here, but it escapes me.
    Thanks in advance
    Run Command
    /java/SDK_EE/jdk/bin/java
    -cp '/tmp/rvcinf-test/bin;../../../dist/rvcicache.jar;../../../lib/coherence.jar'
    -server -Xms256m -Xmx512m
    -Dtangosol.coherence.management=all -Dtangosol.coherence.management.remote=true
    -Dtangosol.coherence.distributed.localstorage=true -Dlogfile=logs/runsvrx-coherence.log
    com.tangosol.net.CacheFactory
    How the Working Java Storage Node is Run
    /java/SDK_EE/jdk/bin/java
    -cp '/tmp/rvcinf-test/bin;../../../dist/rvcicache.jar;../../../lib/coherence.jar'
    -server -Xms256m -Xmx512m
    -Dtangosol.coherence.management=all -Dtangosol.coherence.management.remote=true
    -Dtangosol.coherence.distributed.localstorage=true -Dlogfile=logs/runsvrx-coherence.log
    test.MainlineStorageNode
    Notes:
    My classes in:/tmp/rvcinf-test/bin and ../../../dist/rvcicache.jar
    Shown on multiple lines for readibility - was executed as one line (this is an output of bash after set -x)
    Coherence3.4.1/407
    Edited by: mesocyclone on Sep 18, 2009 11:10 PM

    Hi,
    The CacheFactory console does not automatically join all cache services. If you join the cache-service that your application is using from the console, e.g.:
    Map (?): cache foo
    2009-09-19 20:55:07.606/6.305 Oracle Coherence GE 3.6/480 <Info> (thread=main, member=1): Loaded cache configuration from "file:/Users/rhlee/work/coherence/env_configs/v2/coherence-cache-config.xml"
    2009-09-19 20:55:07.779/6.478 Oracle Coherence GE 3.6/480 <D5> (thread=DistributedCache, member=1): Service DistributedCache joined the cluster with senior service member 1
    ...it should work.
    thanks,
    -Rob

  • Can not deploy: NoClassDefFoundError

    Hi,
    i want to create a new folder in KM-Content of my Portal. Therefor i have write the following piece of code and import the libraries below. My problem is that i can not deploy my Application.
    I get the error message: Caused by: java.lang.NoClassDefFoundError: com/sapportals/wcm/repository/IResourceContext
    I have read that i have to add a Sharing reference to "knowledgemanagement" in the portaapp.xml file.
    But i use a Java Bean/Web Service (EJB) with a Application (EAR), so i have nothing with <b>dist/PORTAL-INF</b>.
    What can i do? How can i deploy my application and solve the problem?
    import bc.rf.framework_api.jar
    import bc.util.public_api.jar
    import com.sap.portal.usermanagement.admin_api.jar
    import com.sap.portal.usermanagementapi.jar
    import com.sap.security.api.ep5.jar
                 try {
                      com.sapportals.portal.security.usermanagement.IUser user = WPUMFactory.getServiceUserFactory().getServiceUser("cmadmin_service");
                   ResourceContext ctxt = new ResourceContext(user);
                   IResourceContext rContext = new ResourceContext(user);
                   IResourceFactory resourceFactory = ResourceFactory.getInstance();
                   RID aRid = RID.getRID("/documents/Test");
                   ICollection aCollection =
                        (ICollection) resourceFactory.getResource(aRid, rContext);
                   if (aCollection != null) {
                        IResource resource =
                             aCollection.createResource("myFolder", null, null);
              } catch (Exception ex) {
                   ex.printStackTrace();
    regards,
    Sharam

    Hi Sharam,
    Make sure that you have your sharing reference set properly in the portalapp.xml file. Open portalapp.xml and click on the Application tab. This is what I like to have mine set to:
    SharingReference=usermanagement,knowledgemanagement,landscape,htmlb,exportalJCOclient,exportal
    Save your changes and the recompile/deploy.
    Hope this helps!
    -StephenS

  • Weblogic rdms persistence 5.1.0 can not deploy

    hi this is rb
    we have the wl5.1 in nt and i am in Defcon 1 since i can not deploy
    with the deployerTool an entyty in this moment. The entity is ok,
    the fields of the data base are equals to the fields of the ejb,
    but i have this error:
    Persistence type WebLogic RDBMS Persistence 5.1.0 could not be
    initialized. Please report this problem to the vendor.
    Could not setup PersistenceType for bean 'null'.
    Error occurred while processing persistence type 'WebLogic RDBMS
    Persistence'.
    Due to the following underlying exceptions:
    sessionData
    Could anybody help me?
    thanks for advance.

    just now,I exam the OS firewall,i find it up.after I stop it via "service iptables stop"command,the console can access now!
    [root@dldzfp2 ~]# service iptables status
    Table: filter
    Chain INPUT (policy ACCEPT)
    num target prot opt source destination
    1 RH-Firewall-1-INPUT all -- 0.0.0.0/0 0.0.0.0/0
    Chain FORWARD (policy ACCEPT)
    num target prot opt source destination
    1 RH-Firewall-1-INPUT all -- 0.0.0.0/0 0.0.0.0/0
    Chain OUTPUT (policy ACCEPT)
    num target prot opt source destination
    Chain RH-Firewall-1-INPUT (2 references)
    num target prot opt source destination
    1 ACCEPT all -- 0.0.0.0/0 0.0.0.0/0
    2 ACCEPT icmp -- 0.0.0.0/0 0.0.0.0/0 icmp type 255
    3 ACCEPT esp -- 0.0.0.0/0 0.0.0.0/0
    4 ACCEPT ah -- 0.0.0.0/0 0.0.0.0/0
    5 ACCEPT udp -- 0.0.0.0/0 224.0.0.251 udp dpt:5353
    6 ACCEPT udp -- 0.0.0.0/0 0.0.0.0/0 udp dpt:631
    7 ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:631
    8 ACCEPT all -- 0.0.0.0/0 0.0.0.0/0 state RELATED,ESTABLISHED
    9 ACCEPT tcp -- 0.0.0.0/0 0.0.0.0/0 state NEW tcp dpt:22
    10 REJECT all -- 0.0.0.0/0 0.0.0.0/0 reject-with icmp-host-prohibited
    [root@dldzfp2 ~]# service iptables stop
    Flushing firewall rules: [  OK  ]
    Setting chains to policy ACCEPT: filter [  OK  ]
    Unloading iptables modules: [  OK  ]

  • I want to clean up my icloud account but I can not delete my mail storage and I don't using icould for my mails?

    I want to clean up my icloud account but I can not delete my mail storage and I don't using icould for my mails so there's nothing in the trash.

    Which email provider do you use if not iClouf?

  • Disk Utilities can not repair my disk - invalid node structure. How can I repair my disk? I have restarted with the CD.

    Hi,
    How can I repair my hard disk. Computer Starts up and then shuts down.
    I've started up with the CD and disk utilities can not fix the disk, invalid node error.
    How can I fix my disk?
    I need to get to the file on the hard disk.
    Thanks
    Peter

    With Disk Warrior can I start with a CD/DVD and get at the files on the hard disk?
    With apple disk utilites I can not see my files that are on the hard disk.
    If I could get at my files I could back them up and reformat my hard disk.

  • I can not start a remote server via Node Manager

     

    There is a workaround to this problem. The issue seems to be
    that when the node manager tries to start the managed server
    it can not find java.exe in the system path. So please go to
    Control Panel->System->...->Environment, and modify your PATH
    system environment variable to include the java bin directory
    in it.
    Then try using the node manager again to start the managed
    servers and you should have no problems.
    We are aware of the issue and working on having a fix for it.
    Savvas
    "Rakesh Chauhan" <[email protected]> wrote:
    >
    Hey Guys!
    I am using WLS6.1 on WIN2000 boxes. And I am getting the same error on
    the Admin
    console when I try to start any of the two
    managed servers.
    <Sep 25,2001 1:39:12 PM EDT> <Info> <[email protected]:7002><WindowsProcessControl:
    online successfully invoked on server 'server90', pid: 0> The interesting thing is that when I start managed server of its own,
    it is started
    successfully and you can Stop the managed
    server from the Admin Console.
    Really frusted, I hope I have configured everything correctly. Can somebody
    help
    me out ?
    Thanks Rakesh
    "Martin Matthews" <[email protected]> wrote:
    This message is simply a message from the Admin Server saying that it
    has asked
    NodeManager on the remote machine to start a certain server.
    To see the logs for server startup then you can find these either on
    the Admin
    machine at WL_HOME/config/NodeManagerClientLogs/<ManagedServerName>/*.log
    or on the remote machine at
    WL_HOME/config/NodeManagerLogs/<ManagedServerName>/*.log
    Cheers
    Martin
    "Paul Nixon" <[email protected]> wrote:
    I also would like to know the answer to the question below from Vincent.
    I am getting
    this message in the Admin console from either of my two managed servers
    whenever
    the console has successfully contacted the Node Manager in managed
    server
    host.
    The Node Manager logs themselves also report "online successful". What
    doesn't
    seem to happen is WebLogic startup and I haven't found any error log
    that explains
    why.
    I have set the Remote Startup parameters correctly [I think] for both
    managed
    servers so cannot see what further is required.
    Any input appreciated.
    Paul.
    "Vincent Ducret" <[email protected]> wrote:
    Hi everybody,
    When I try to start a remote WLS 6.1 server from my computer, I receive
    the message
    below in my WLS administration console. The Node manager is runningon
    the remote
    machine and correctly configured, I hope!
    What does this message mean ???
    Thanks for your help
    Vincent
    <21 août 01 10:19:17 CEST> <Info> <[email protected]:5555>
    <WindowsProcessControl:
    online successfully invoked on server 'testserver', pid: 0>

  • Can not deploy VSM1.3 to oc4j10g 10, can not translate EJB QL

    the OS is win2k
    oc4j version is oc4j 10g(10.0.3.0.0)
    started oc4j by java -Ddefault.cmp.pm=native_cmp -jar oc4j.jar
    when deploying vsm, the following EJB QL error:
    deploy-oc4j:
    [java] Error: Deploy error: deploy failed!: ; nested exception is:
    [java] oracle.oc4j.admin.internal.DeployerException: java.lang.Instanti
    ationException: Error initializing ejb-module, Exception: Compile error: Error t
    ranslating EJBQL: java.lang.NullPointerException
    [java] com.evermind.client.orion.AdminCommandException: Deploy error: deplo
    y failed!: ; nested exception is:
    [java] oracle.oc4j.admin.internal.DeployerException: java.lang.Instanti
    ationException: Error initializing ejb-module, Exception: Compile error: Error t
    ranslating EJBQL: java.lang.NullPointerException
    [java] at com.evermind.client.orion.DeployCommand.execute(DeployCommand
    .java:95)
    [java] at com.evermind.client.orion.Oc4jAdminConsole.executeCommand(Oc4
    jAdminConsole.java:117)
    [java] at com.evermind.client.orion.Oc4jAdminConsole.main(Oc4jAdminCons
    ole.java:26)
    [java] java.rmi.RemoteException: deploy failed!: ; nested exception is:
    [java] oracle.oc4j.admin.internal.DeployerException: java.lang.Instanti
    ationException: Error initializing ejb-module, Exception: Compile error: Error t
    ranslating EJBQL: java.lang.NullPointerException
    [java] at com.evermind.server.rmi.RMIConnection.EXCEPTION_ORIGINATES_FR
    OM_THE_REMOTE_SERVER(RMIConnection.java:908)
    [java] at com.evermind.server.rmi.RMIConnection.invokeMethod(RMIConnect
    ion.java:802)
    [java] at com.evermind.server.rmi.RemoteInvocationHandler.invoke(Remote
    InvocationHandler.java:69)
    [java] at com.evermind.server.rmi.RecoverableRemoteInvocationHandler.in
    voke(RecoverableRemoteInvocationHandler.java:22)
    [java] at __Proxy0.deploy(Unknown Source)
    [java] at com.evermind.client.orion.DeployCommand.execute(DeployCommand
    .java:92)
    [java] at com.evermind.client.orion.Oc4jAdminConsole.executeCommand(Oc4
    jAdminConsole.java:117)
    [java] at com.evermind.client.orion.Oc4jAdminConsole.main(Oc4jAdminCons
    ole.java:26)
    [java] Caused by: oracle.oc4j.admin.internal.DeployerException: java.lang.I
    nstantiationException: Error initializing ejb-module, Exception: Compile error:
    Error translating EJBQL: java.lang.NullPointerException
    [java] at oracle.oc4j.admin.internal.DeployerBase.execute(DeployerBase.
    java:75)
    [java] at com.evermind.server.administration.DefaultApplicationServerAd
    ministrator.internalDeploy(DefaultApplicationServerAdministrator.java:376)
    [java] at com.evermind.server.administration.DefaultApplicationServerAd
    ministrator.deploy(DefaultApplicationServerAdministrator.java:276)
    [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcces
    sorImpl.java:39)
    [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMet
    hodAccessorImpl.java:25)
    [java] at java.lang.reflect.Method.invoke(Method.java:324)
    [java] at com.evermind.server.rmi.RMICallHandler.run(RMICallHandler.jav
    a:86)
    [java] at com.evermind.server.rmi.RMICallHandler.run(RMICallHandler.jav
    a:56)
    [java] at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.r
    un(ReleasableResourcePooledExecutor.java:291)
    [java] at java.lang.Thread.run(Thread.java:534)
    [java] Caused by: java.lang.InstantiationException: Error initializing ejb-
    module, Exception: Compile error: Error translating EJBQL: java.lang.NullPointer
    Exception
    [java] at com.evermind.server.ejb.EJBContainer.postInit(EJBContainer.ja
    va:1076)
    [java] at com.evermind.server.Application.postInit(Application.java:688
    [java] at com.evermind.server.Application.setConfig(Application.java:20
    1)
    [java] at com.evermind.server.ApplicationServer.addApplication(Applicat
    ionServer.java:1947)
    [java] at oracle.oc4j.admin.internal.ApplicationDeployer.addApplication
    (ApplicationDeployer.java:382)
    [java] at oracle.oc4j.admin.internal.ApplicationDeployer.doDeploy(Appli
    cationDeployer.java:134)
    [java] at oracle.oc4j.admin.internal.DeployerBase.execute(DeployerBase.
    java:61)
    [java] ... 10 more
    [java] Caused by: java.lang.InstantiationException: Compile error: Error tr
    anslating EJBQL: java.lang.NullPointerException
    [java] at com.evermind.server.ejb.EJBContainer.postInit(EJBContainer.ja
    va:1021)
    [java] ... 16 more
    [java] Caused by: com.evermind.compiler.CompilationException: Error transla
    ting EJBQL: java.lang.NullPointerException
    [java] at com.evermind.server.ejb.compilation.Compilation.translateEjbq
    lQeries(Compilation.java:229)
    [java] at com.evermind.server.ejb.compilation.Compilation.compile(Compi
    lation.java:265)
    [java] at com.evermind.server.ejb.EJBContainer.postInit(EJBContainer.ja
    va:930)
    [java] ... 16 more
    [java] ---- Embedded exception
    [java] oracle.oc4j.admin.internal.DeployerException: java.lang.Instantiatio
    nException: Error initializing ejb-module, Exception: Compile error: Error trans
    lating EJBQL: java.lang.NullPointerException
    [java] at oracle.oc4j.admin.internal.DeployerBase.execute(DeployerBase.
    java:75)
    [java] at com.evermind.server.administration.DefaultApplicationServerAd
    ministrator.internalDeploy(DefaultApplicationServerAdministrator.java:376)
    [java] at com.evermind.server.administration.DefaultApplicationServerAd
    ministrator.deploy(DefaultApplicationServerAdministrator.java:276)
    [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcces
    sorImpl.java:39)
    [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMet
    hodAccessorImpl.java:25)
    [java] at java.lang.reflect.Method.invoke(Method.java:324)
    [java] at com.evermind.server.rmi.RMICallHandler.run(RMICallHandler.jav
    a:86)
    [java] at com.evermind.server.rmi.RMICallHandler.run(RMICallHandler.jav
    a:56)
    [java] at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.r
    un(ReleasableResourcePooledExecutor.java:291)
    [java] at java.lang.Thread.run(Thread.java:534)
    [java] Caused by: java.lang.InstantiationException: Error initializing ejb-
    module, Exception: Compile error: Error translating EJBQL: java.lang.NullPointer
    Exception
    [java] at com.evermind.server.ejb.EJBContainer.postInit(EJBContainer.ja
    va:1076)
    [java] at com.evermind.server.Application.postInit(Application.java:688
    [java] at com.evermind.server.Application.setConfig(Application.java:20
    1)
    [java] at com.evermind.server.ApplicationServer.addApplication(Applicat
    ionServer.java:1947)
    [java] at oracle.oc4j.admin.internal.ApplicationDeployer.addApplication
    (ApplicationDeployer.java:382)
    [java] at oracle.oc4j.admin.internal.ApplicationDeployer.doDeploy(Appli
    cationDeployer.java:134)
    [java] at oracle.oc4j.admin.internal.DeployerBase.execute(DeployerBase.
    java:61)
    [java] ... 10 more
    [java] Caused by: java.lang.InstantiationException: Compile error: Error tr
    anslating EJBQL: java.lang.NullPointerException
    [java] at com.evermind.server.ejb.EJBContainer.postInit(EJBContainer.ja
    va:1021)
    [java] ... 16 more
    [java] Caused by: com.evermind.compiler.CompilationException: Error transla
    ting EJBQL: java.lang.NullPointerException
    [java] at com.evermind.server.ejb.compilation.Compilation.translateEjbq
    lQeries(Compilation.java:229)
    [java] at com.evermind.server.ejb.compilation.Compilation.compile(Compi
    lation.java:265)
    [java] at com.evermind.server.ejb.EJBContainer.postInit(EJBContainer.ja
    va:930)
    [java] ... 16 more
    [java] Java Result: 1
    [java] Error: bindWebApp() failed!; nested exception is:
    [java] oracle.oc4j.admin.internal.DeployerException: Web module VSMWeb
    does not exist in application vsm
    [java] com.evermind.client.orion.AdminCommandException: bindWebApp() failed
    !; nested exception is:
    [java] oracle.oc4j.admin.internal.DeployerException: Web module VSMWeb
    does not exist in application vsm
    [java] at com.evermind.client.orion.BindWebAppCommand.execute(BindWebAp
    pCommand.java:31)
    [java] at com.evermind.client.orion.Oc4jAdminConsole.executeCommand(Oc4
    jAdminConsole.java:117)
    [java] at com.evermind.client.orion.Oc4jAdminConsole.main(Oc4jAdminCons
    ole.java:26)
    [java] java.rmi.RemoteException: bindWebApp() failed!; nested exception is:
    [java] oracle.oc4j.admin.internal.DeployerException: Web module VSMWeb
    does not exist in application vsm
    [java] at com.evermind.server.rmi.RMIConnection.EXCEPTION_ORIGINATES_FR
    OM_THE_REMOTE_SERVER(RMIConnection.java:908)
    [java] at com.evermind.server.rmi.RMIConnection.invokeMethod(RMIConnect
    ion.java:802)
    [java] at com.evermind.server.rmi.RemoteInvocationHandler.invoke(Remote
    InvocationHandler.java:69)
    [java] at com.evermind.server.rmi.RecoverableRemoteInvocationHandler.in
    voke(RecoverableRemoteInvocationHandler.java:22)
    [java] at __Proxy0.bindWebApp(Unknown Source)
    [java] at com.evermind.client.orion.BindWebAppCommand.execute(BindWebAp
    pCommand.java:28)
    [java] at com.evermind.client.orion.Oc4jAdminConsole.executeCommand(Oc4
    jAdminConsole.java:117)
    [java] at com.evermind.client.orion.Oc4jAdminConsole.main(Oc4jAdminCons
    ole.java:26)
    [java] Caused by: oracle.oc4j.admin.internal.DeployerException: Web module
    VSMWeb does not exist in application vsm
    [java] at oracle.oc4j.admin.internal.WebApplicationBinder.bindWebApp(We
    bApplicationBinder.java:187)
    [java] at com.evermind.server.administration.DefaultApplicationServerAd
    ministrator.bindWebApp(DefaultApplicationServerAdministrator.java:362)
    [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcces
    sorImpl.java:39)
    [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMet
    hodAccessorImpl.java:25)
    [java] at java.lang.reflect.Method.invoke(Method.java:324)
    [java] at com.evermind.server.rmi.RMICallHandler.run(RMICallHandler.jav
    a:86)
    [java] at com.evermind.server.rmi.RMICallHandler.run(RMICallHandler.jav
    a:56)
    [java] at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.r
    un(ReleasableResourcePooledExecutor.java:297)
    [java] at java.lang.Thread.run(Thread.java:534)
    [java] ---- Embedded exception
    [java] oracle.oc4j.admin.internal.DeployerException: Web module VSMWeb does
    not exist in application vsm
    [java] at oracle.oc4j.admin.internal.WebApplicationBinder.bindWebApp(We
    bApplicationBinder.java:187)
    [java] at com.evermind.server.administration.DefaultApplicationServerAd
    ministrator.bindWebApp(DefaultApplicationServerAdministrator.java:362)
    [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAcces
    sorImpl.java:39)
    [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMet
    hodAccessorImpl.java:25)
    [java] at java.lang.reflect.Method.invoke(Method.java:324)
    [java] at com.evermind.server.rmi.RMICallHandler.run(RMICallHandler.jav
    a:86)
    [java] at com.evermind.server.rmi.RMICallHandler.run(RMICallHandler.jav
    a:56)
    [java] at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.r
    un(ReleasableResourcePooledExecutor.java:297)
    [java] at java.lang.Thread.run(Thread.java:534)
    [java] Java Result: 17

    I have a 10.1.2 app that deploys and binds just fine,
    but when I try to deploy the same app on a 10.1.3
    version it seems to deploy just fine but I can not
    access the application. When I go into the web
    frontend of the 10.1.3 server I see my app is
    deployed, status is shown as green but when I click
    on the web app it says that no JSPs were found also
    it is not bound. I deploy using the auto deploy
    feature.Can you check and see that the http-web-site.xml has a valid <web-app> entry for your web module?
    Have you tried to access a specific JSP and see the same error? Or are you trying to access just the root context?
    Can you try deploying the application using the deployment function in Application Server Control (http://host:1810) and see if it works and/or reports any error messages?
    -steve-

  • I can Ping FW inside interface but can not connect to remote resources

    dear all
    i configer my asa 5520 through ASDM to enable VPN Connection , i follow the cisco steps and it works fine and the anyconnect version 3.1 in Windows 8 - one day troubleshoot for this point only - can connect and have an IP address from the range , but i have something wrong in NAT may be because all guides talking about old ASDM ( NAT Exempt) but i am confeused to apply it on the new ASDM.
    i can ping the inside interface  from my labtop which using anyconnect , but i can not access anything else inside my network
    Please anyone has a solution , please describe it using ASDM , thanks for help
    This is my configuration
    interface GigabitEthernet0/1
    description
    nameif SRV_ZONE
    security-level 50
    ip address 192.168.1.1 255.255.255.0
    interface GigabitEthernet0/2
    description
    nameif TRUST_ZONE
    security-level 100
    ip address 172.17.200.1 255.255.255.0
    interface GigabitEthernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif MGMT
    security-level 0
    ip address 10.10.10.1 255.255.255.0
    dns server-group DefaultDNS
    domain-name xxx.xxx.xxx
    object network obj-192.168.1.11
    host 192.168.1.11
    object network obj-xxx.xxx.xxx.xxx
    host xxx.xxx.xxx.xxx
    object service obj-tcp-source-eq-25
    service tcp source eq smtp
    object network obj-192.168.1.12
    host 192.168.1.12
    object network obj-xxx.xxx.xxx.xxx
    host xxx.xxx.xxx.xxx
    object network obj-192.168.1.0
    subnet 192.168.1.0 255.255.255.0
    object service obj-tcp-eq-25
    service tcp destination eq smtp
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network obj-0.0.0.0
    host 0.0.0.0
    object network obj_any-01
    subnet 0.0.0.0 0.0.0.0
    object network obj-172.17.8.8
    host 172.17.8.8
    object network obj-172.17.0.0
    subnet 172.17.0.0 255.255.0.0
    object network obj_any-02
    subnet 0.0.0.0 0.0.0.0
    object network obj_any-03
    subnet 0.0.0.0 0.0.0.0
    object network obj_any-04
    subnet 0.0.0.0 0.0.0.0
    object network obj_any-05
    subnet 0.0.0.0 0.0.0.0
    object network obj_any-06
    subnet 0.0.0.0 0.0.0.0
    object network obj.172.17.8.115
    host 172.17.8.115
    object network obj.xxx.xxx.xxx.xxx
    host xxx.xxx.xxx.xxx
    object service http
    service tcp source eq www destination eq www
    object network obj.xxx.xxx.xxx.xxx
    host xxx.xxx.xxx.xxx
    object service https
    service tcp source eq https destination eq https
    object service newservice
    service tcp source eq pop3 destination eq pop3
    object network mail
    host 172.17.8.8
    description mail     
    object network 192.168.1.11
    host 192.168.1.11
    description smtp     
    object service smtpnew
    service tcp source eq 587 destination eq 587
    object network VPN_RANGE
    description VPN ACCESS RANGE  
    object network VPN_PoOL
    subnet 172.17.16.0 255.255.255.0
    description vpn
    object-group network DM_INLINE_NETWORK_1
    network-object host 192.168.1.11
    network-object host 192.168.1.12
    object-group network Eighth_Floor
    network-object 172.17.8.0 255.255.255.0
    object-group service WEB_SERVICES
    service-object tcp destination eq www
    object-group network ENT_SERVERS
    network-object host 192.168.1.11
    network-object host 192.168.1.1
    object-group network DM_INLINE_NETWORK_2
    network-object 172.17.200.0 255.255.255.0
    network-object 172.17.8.0 255.255.255.0
    object-group service DM_INLINE_TCP_2 tcp
    port-object eq www
    port-object eq https
    port-object eq smtp
    object-group service web tcp
    port-object eq www
    port-object eq xxx
    port-object eq ftp
    port-object eq xxx
    port-object eq xxx
    object-group service xxx_Web_and_Email
    service-object object http
    service-object tcp destination eq pop3
    service-object tcp destination eq smtp
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    object-group protocol DM_INLINE_PROTOCOL_1
    protocol-object udp
    protocol-object tcp
    object-group protocol DM_INLINE_PROTOCOL_2
    protocol-object ip
    object-group protocol DM_INLINE_PROTOCOL_3
    protocol-object ip
    access-list DMZ_access_in extended permit ip 192.168.1.0 255.255.255.0 172.17.0.0 255.255.0.0
    access-list DMZ_access_in extended permit ip 192.168.1.0 255.255.255.0 any
    access-list justice_splitTunnelAcl standard permit 10.100.100.0 255.255.255.0
    access-list xxx-VPN_splitTunnelAcl remark vpn
    access-list xxx-VPN_splitTunnelAcl standard permit 172.17.16.0 255.255.255.0
    access-list xxx-VPN_splitTunnelAcl standard permit any
    access-list cap extended permit tcp any host xxx.xxx.xxx.xxx eq smtp log
    access-list cap1 extended permit tcp host 192.168.1.11 any eq smtp
    access-list SRV_ZONE_nat_outbound extended permit tcp 192.168.1.0 255.255.255.0 any eq smtp
    access-list SRV_ZONE_nat_outbound extended permit ip host 192.168.1.11 any
    access-list TRUST_ZONE_access_in extended permit ip host 172.17.88.108 any
    access-list TRUST_ZONE_access_in extended permit object-group DM_INLINE_PROTOCOL_2 10.10.3.0 255.255.255.0 any
    access-list TRUST_ZONE_access_in extended permit object-group DM_INLINE_PROTOCOL_3 10.10.50.0 255.255.255.0 any
    access-list TRUST_ZONE_access_in extended permit ip 172.17.8.0 255.255.255.0 any
    access-list TRUST_ZONE_access_in extended permit ip 172.17.200.0 255.255.255.0 any
    access-list TRUST_ZONE_access_in extended permit ip 172.17.0.0 255.255.0.0 host 192.168.1.12
    access-list TRUST_ZONE_cryptomap extended permit ip xxx.xxx.xxx.xxx 255.255.255.248 any
    access-list outside_access_in extended permit tcp any host 192.168.1.11 eq smtp
    access-list outside_access_in extended permit tcp any host 172.17.8.8 eq www
    access-list outside_access_in extended permit tcp any host 192.168.1.12 object-group web
    access-list outside_access_in extended permit tcp any host 172.17.8.8 eq pop3
    access-list outside_access_in extended permit ip 172.17.16.0 255.255.255.0 any inactive
    access-list vpn remark vpn
    access-list vpn standard permit 172.17.16.0 255.255.255.0
    pager lines 24
    logging enable
    logging trap informational
    logging asdm informational
    logging host TRUST_ZONE 172.17.8.100
    mtu INT_ZONE 1500
    mtu SRV_ZONE 1500
    mtu TRUST_ZONE 1500
    mtu MGMT 1500
    ip local pool VPN_POOL 172.17.16.100-172.17.16.254 mask 255.255.255.0
    ip verify reverse-path interface INT_ZONE
    ip verify reverse-path interface SRV_ZONE
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit any SRV_ZONE
    icmp permit any TRUST_ZONE
    asdm image disk0:/asdm-635.bin
    no asdm history enable
    arp timeout 14400
    nat (SRV_ZONE,INT_ZONE) source static obj-192.168.1.11 obj-xxx.xxx.xxx.xxx service any obj-tcp-source-eq-25
    nat (SRV_ZONE,INT_ZONE) source static obj-192.168.1.12 obj-xxx.xxx.xxx.xxx
    nat (SRV_ZONE,INT_ZONE) source dynamic obj-192.168.1.0 interface service obj-tcp-eq-25 obj-tcp-eq-25
    nat (INT_ZONE,SRV_ZONE) source static any any destination static 192.168.1.11 obj-172.17.8.8 service obj-tcp-source-eq-25 obj-tcp-source-eq-25
    nat (TRUST_ZONE,INT_ZONE) source static VPN_PoOL VPN_PoOL destination static VPN_PoOL VPN_PoOL
    object network obj_any
    nat (SRV_ZONE,INT_ZONE) dynamic obj-0.0.0.0
    object network obj_any-01
    nat (SRV_ZONE,MGMT) dynamic obj-0.0.0.0
    object network obj-172.17.8.8
    nat (TRUST_ZONE,INT_ZONE) static xxx.xxx.xxx.xxx service tcp www www
    object network obj-172.17.0.0
    nat (TRUST_ZONE,SRV_ZONE) static 172.17.0.0
    object network obj_any-02
    nat (TRUST_ZONE,INT_ZONE) dynamic interface
    object network obj_any-03
    nat (TRUST_ZONE,SRV_ZONE) dynamic interface
    object network obj_any-04
    nat (TRUST_ZONE,INT_ZONE) dynamic obj-0.0.0.0
    object network obj_any-05
    nat (TRUST_ZONE,SRV_ZONE) dynamic obj-0.0.0.0
    object network obj_any-06
    nat (TRUST_ZONE,MGMT) dynamic obj-0.0.0.0
    object network obj.172.17.8.115
    nat (TRUST_ZONE,INT_ZONE) static obj.xxx.xxx.xxx.xxx service tcp www www
    object network mail
    nat (TRUST_ZONE,INT_ZONE) static obj-xxx.xxx.xxx.xxx service tcp pop3 pop3
    nat (TRUST_ZONE,INT_ZONE) after-auto source static obj-172.17.8.8 obj-xxx.xxx.xxx.xxx service https https
    access-group outside_access_in in interface INT_ZONE
    access-group DMZ_access_in in interface SRV_ZONE
    access-group TRUST_ZONE_access_in in interface TRUST_ZONE
    route INT_ZONE 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx 1
    route TRUST_ZONE 10.10.0.0 255.255.0.0 172.17.200.254 1
    route TRUST_ZONE 10.11.0.0 255.255.0.0 172.17.200.254 1
    route TRUST_ZONE 10.12.0.0 255.255.0.0 172.17.200.254 1
    route TRUST_ZONE 10.13.0.0 255.255.0.0 172.17.200.254 1
    route TRUST_ZONE 172.17.0.0 255.255.0.0 172.17.200.254 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication enable console LOCAL
    aaa authentication http console LOCAL
    aaa authentication ssh console LOCAL
    aaa authentication serial console LOCAL
    http server enable
    http 172.17.8.0 255.255.255.0 TRUST_ZONE
    http 172.17.8.155 255.255.255.255 TRUST_ZONE
    http 172.17.8.45 255.255.255.255 TRUST_ZONE
    http 10.10.10.2 255.255.255.255 MGMT
    http 192.168.1.12 255.255.255.255 SRV_ZONE
    http 0.0.0.0 0.0.0.0 INT_ZONE
    http 172.17.200.0 255.255.255.0 TRUST_ZONE
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto dynamic-map pol 1 match address TRUST_ZONE_cryptomap
    crypto dynamic-map pol 1 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map INT_ZONE_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map TRUST_ZONE_map0 1 ipsec-isakmp dynamic pol
    crypto map TRUST_ZONE_map0 interface TRUST_ZONE
    crypto map INT_ZONE_map0 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map INT_ZONE_map0 interface INT_ZONE
    crypto ca trustpoint ASDM_TrustPoint0
    enrollment self
    fqdn SEC-xxx-FW1
    subject-name CN=SEC-xxx-FW1
    no client-types
    proxy-ldc-issuer
    crl configure
    crypto ca trustpoint ASDM_TrustPoint1
    enrollment self
    subject-name CN=SEC-xxx-FW1
    keypair sslvpnkeypair
    crl configure
    crypto ca certificate chain ASDM_TrustPoint0
    certificate 31
        57f4e52e 6b851966 77515d62 c209a0df 1c32ce94 bb90cbce 497cfd04 6745ea85
        efb75f85 2ae1ad35 344d94ab 915e01ab d3292626 ac697a52 b4ed6632 d3ed2332 ae
      quit
    crypto ca certificate chain ASDM_TrustPoint1
    certificate e6054352
        c64f3661 30f14c3d 06b5f039 9f14560d 3b154fd1 42782268 7531689e 8e547d91
        85e88415 e326f653 74733a6c a3f5c935 f7e83f56 f6
      quit
    crypto isakmp enable INT_ZONE
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto isakmp policy 65535
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 INT_ZONE
    ssh 172.17.8.0 255.255.255.0 TRUST_ZONE
    ssh 10.10.10.2 255.255.255.255 MGMT
    ssh timeout 5
    console timeout 0
    management-access TRUST_ZONE
    vpn load-balancing
    interface lbpublic INT_ZONE
    interface lbprivate INT_ZONE
    priority-queue INT_ZONE
      tx-ring-limit 256
    threat-detection basic-threat
    threat-detection scanning-threat
    threat-detection statistics host number-of-rate 3
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ssl trust-point ASDM_TrustPoint1 INT_ZONE
    webvpn
    enable INT_ZONE
    svc image disk0:/anyconnect-win-2.1.0148-k9.pkg 1
    svc enable
    tunnel-group-list enable
    group-policy xxx-VPN internal
    group-policy xxx-VPN attributes
    dns-server value xx.xx.xx.xx xx.xx.xx.xx
    vpn-tunnel-protocol IPSec
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value xxx-VPN_splitTunnelAcl
    group-policy DfltGrpPolicy attributes
    vpn-tunnel-protocol webvpn
    group-policy GPNEW internal
    group-policy GPNEW attributes
    dns-server value 172.17.8.41
    vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
    default-domain value xxx.xxx.xxx
    address-pools value VPN_POOL
    username VPNAM password xxx encrypted
    username VPNAM attributes
    service-type remote-access
    vpn-group-policy xxx-VPN
    tunnel-group xxx-VPN type remote-access
    tunnel-group xxx-VPN general-attributes
    dhcp-server 172.17.8.41
    tunnel-group xxx-VPN ipsec-attributes
    pre-shared-key *****
    tunnel-group pol type ipsec-l2l
    tunnel-group pol ipsec-attributes
    pre-shared-key *****
    trust-point ASDM_TrustPoint0
    tunnel-group SSLClientProfile type remote-access
    tunnel-group SSLClientProfile general-attributes
    address-pool VPN_POOL
    default-group-policy GPNEW
    tunnel-group SSLClientProfile webvpn-attributes
    group-alias SSLVPNClient enable
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect netbios
      inspect rsh
      inspect rtsp
      inspect skinny 
      inspect sqlnet
      inspect sunrpc
      inspect tftp
      inspect sip 
      inspect xdmcp
      inspect ip-options
      inspect pptp
    service-policy global_policy global
    prompt hostname context
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:78a941e3f509dec8f3570c60061eedaa
    : end

    thanks god
    i solve the problem
    the problem is in NAT
    i creat an object with the ip address host from VPN pool and name it vpn
    then i do the nat from inside to that host as the following picture...
    trust zone is the inside zone
    vpn is the outside vpn host...
    thanks and hope it helps anyone else...

  • Can not deploy a report using JDBC connection on CR2008 Server

    Hi Group,
    I have a report created with JDBC connection. When I tried to add it to CR2008 server, it gives an error - "An unexpected error has occurred ". Basically I want to add a report to a public folder via CMC. I am using adminstrator account.
    Then I thought I need to add JDBC driver into CR2008 server. so I put oracle jdbc jar into CR2008 server classpath and add JDBC connection info into CRConfig.xml. but I still got the same error.
    I also tried:
    - Change the report to use native Oracle driver rather than JDBC. The deployment succeeded (but this is not what I want)
    - Add a data source connection via Business View Manager, but no luck.
    I know how to use/change jdbc connection with programtic way, but I just want to know if I want to use built-in components in CR2008 server without any coding the reports can be deployed and managed.
    Thanks in advance.
    Dennis

    Hello Will,
    Crystal Reports supports connections to JDBC/JNDI out of the box, and have done so for a while, whether stand-alone or published to Enterprise.
    To specify where the server would search for the JDBC driver jar files, you'd change the classpath tag found in the CRConfig.xml file found on the machine where the Crystal Reports Page or Job Server is running. 
    For early Crystal Enterprise 10 and before, it used Java Native Interface (JNI) to start the Java process to retrieve the data from the JDBC connection.
    For later Crystal Enterprise 10 and later, it starts off a "Java Server" process, and communicates to the Crystal Reports process via CORBA TCP/IP connection.
    Commonissues that may arise:  (1) CRConfig.xml not configured properly, (2) unable to start or communicate to the "Java Server" because of permissions or firewall.
    Note that this is a separate connectivity map from using ADO or ADO.NET.
    Sincerely,
    Ted Ueda

  • Can not deploy application on websphere 6.0

    Hi all,
    I use Jdeveloper(10.1.2) and Jheadstart(10.1.2) converted a oracle form to J2EE.It can run on Oracle Application Server and Tomcat.I try to deploy it on websphere 6.0,after i added ADF runtime *.jar file into {WAS_HOME}\lib\ext manually,websphere can not work,error message as follows:
    ADMU3200I: Server launched. Waiting for initialization status.
    ADMU3011E: Server launched but failed initialization. Server log files should
    contain failure information.
    java.lang.reflect.InvocationTargetException
         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:85)
         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:58)
         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:60)
         at java.lang.reflect.Method.invoke(Method.java:391)
         at com.ibm.ws.bootstrap.WSLauncher.main(WSLauncher.java:190)
    Caused by: com.ibm.websphere.management.exception.AdminException: Failed while trying to start the Windows Service, retCode = -1
         at com.ibm.ws.management.tools.WindowsService.doWASServiceAction(WindowsService.java:247)
         at com.ibm.ws.management.tools.WsServerLauncher.execWithWinService(WsServerLauncher.java:150)
         at com.ibm.ws.management.tools.WsServerController.executeUtilityOnWindows(WsServerController.java:129)
         at com.ibm.ws.management.tools.WsServerLauncher.main(WsServerLauncher.java:114)
         ... 6 more
    when i remove all jar file from {WAS_HOME}\lib\ext, webspher works well.
    And i can not find bc4j_jclient_common.jar from %JDEV_HOME%BC4J\lib.
    so how can I deal with this problem?Thanks in advance!!
    Best regards,
    Appcat
    Message was edited by:
    Appcat

    JDeveloper 10.1.3 does not include bc4j_jclient_common.jar
    Re: BC4J Library bc4j_jclient_common.jar not provided in JDeveloper 10.1.3

  • Can not deploy after upgrading application from workshop 8.1 to 9.2

    Hi,
    We have an application developed on workshop 8.1 worked fine. when we upgrade the application to 9.2, the application can not be deployed on weblogic server. The error is
    weblogic.application.ModuleException: [HTTP:101064][WebAppModule(SynDesk:SynDesk
    Web)] Error parsing descriptor in Web appplication "C:\build\weboutput"
    "weblogic.application.ModuleException: Unmarshaller failed'
    Caused by: weblogic.descriptor.BeanAlreadyExistsException: Bean already exists:
    "weblogic.j2ee.descriptor.ParamValueBeanImpl@dccea29(/[NTLM HTTP Authentication
    Filter]/InitParams[jcifs.netbios.wins])"
    When I remove the NTLM filter part in the web.xml, the application is able to be deployed. But of course application does not work propertly due to no authentication.
    How can I fix the web.xml file with everything works as before? Thanks for your help
    Here is my web.xml file:
    <?xml version="1.0" encoding="UTF-8"?>
    <web-app version="2.4" xmlns="http://java.sun.com/xml/ns/j2ee" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd">
    <display-name>SyndeskWeb Application</display-name>
    <description/>
    <filter>
    <filter-name>NTLM HTTP Authentication Filter</filter-name>
    <filter-class>com.mycompany.BofaNtlmFilter</filter-class>
    <init-param>
    <description/>
    <param-name>jcifs.netbios.wins</param-name>
    <param-value>crpsecwin00.mycompany.com</param-value>
    </init-param>
    <init-param>
    <description/>
    <param-name>jcifs.netbios.wins</param-name>
    <param-value>crpchiwin00.mycompany.com</param-value>
    </init-param>
    <init-param>
    <description/>
    <param-name>debug</param-name>
    <param-value>true</param-value>
    </init-param>
    <init-param>
    <description/>
    <param-name>jcifs.util.log</param-name>
    <param-value>ALL</param-value>
    </init-param>
    <init-param>
    <description/>
    <param-name>bofa.retryCount</param-name>
    <param-value>1</param-value>
    </init-param>
    <init-param>
    <description/>
    <param-name>bofa.retrySleepTime</param-name>
    <param-value>60</param-value>
    </init-param>
    </filter>
    <filter-mapping>
    <filter-name>NTLM HTTP Authentication Filter</filter-name>
    <url-pattern>*.jsp</url-pattern>
    </filter-mapping>
    <filter-mapping>
    <filter-name>NTLM HTTP Authentication Filter</filter-name>
    <url-pattern>*.jpf</url-pattern>
    </filter-mapping>
    <filter-mapping>
    <filter-name>NTLM HTTP Authentication Filter</filter-name>
    <url-pattern>*.do</url-pattern>
    </filter-mapping>
    <servlet>
    <description/>
    <servlet-name>action</servlet-name>
    <servlet-class>org.apache.beehive.netui.pageflow.PageFlowActionServlet</servlet-class>
    <init-param>
    <description/>
    <param-name>config</param-name>
    <param-value>/_pageflow/struts-config.xml</param-value>
    </init-param>
    <init-param>
    <description/>
    <param-name>config/-global</param-name>
    <param-value>/_pageflow/struts-config--global.xml</param-value>
    </init-param>
    <init-param>
    <description/>
    <param-name>debug</param-name>
    <param-value>2</param-value>
    </init-param>
    <init-param>
    <description/>
    <param-name>detail</param-name>
    <param-value>2</param-value>
    </init-param>
    <load-on-startup>2</load-on-startup>
    </servlet>
    <welcome-file-list>
    <welcome-file>Controller.jpf</welcome-file>
    </welcome-file-list>
    <error-page>
    <error-code>500</error-code>
    <location>/error.jsp</location>
    </error-page>
    <error-page>
    <error-code>505</error-code>
    <location>/error.jsp</location>
    </error-page>
    <error-page>
    <error-code>404</error-code>
    <location>/Controller.jpf</location>
    </error-page>
    <jsp-config>
    <taglib>
    <taglib-uri>netui-tags-html.tld</taglib-uri>
    <taglib-location>/WEB-INF/tld/netui-tags-html.tld</taglib-location>
    </taglib>
    <taglib>
    <taglib-uri>netui-tags-databinding.tld</taglib-uri>
    <taglib-location>/WEB-INF/tld/netui-tags-databinding.tld</taglib-location>
    </taglib>
    <taglib>
    <taglib-uri>netui-tags-template.tld</taglib-uri>
    <taglib-location>/WEB-INF/tld/netui-tags-template.tld</taglib-location>
    </taglib>
    <taglib>
    <taglib-uri>c.tld</taglib-uri>
    <taglib-location>/WEB-INF/tld/c.tld</taglib-location>
    </taglib>
    <taglib>
    <taglib-uri>fmt.tld</taglib-uri>
    <taglib-location>/WEB-INF/tld/fmt.tld</taglib-location>
    </taglib>
    <taglib>
    <taglib-uri>sql.tld</taglib-uri>
    <taglib-location>/WEB-INF/tld/sql.tld</taglib-location>
    </taglib>
    <taglib>
    <taglib-uri>x.tld</taglib-uri>
    <taglib-location>/WEB-INF/tld/x.tld</taglib-location>
    </taglib>
    </jsp-config>
    <filter>
    <filter-name>PageFlowJspFilter</filter-name>
    <filter-class>org.apache.beehive.netui.pageflow.PageFlowJspFilter</filter-class>
    </filter>
    <filter>
    <filter-name>PageFlowForbiddenFilter</filter-name>
    <filter-class>org.apache.beehive.netui.pageflow.PageFlowForbiddenFilter</filter-class>
    <init-param>
    <param-name>response-code</param-name>
    <param-value>404</param-value>
    </init-param>
    </filter>
    <filter-mapping>
    <filter-name>PageFlowJspFilter</filter-name>
    <url-pattern>*.jsp</url-pattern>
    <dispatcher>FORWARD</dispatcher>
    <dispatcher>REQUEST</dispatcher>
    <dispatcher>INCLUDE</dispatcher>
    </filter-mapping>
    <filter-mapping>
    <filter-name>PageFlowJspFilter</filter-name>
    <url-pattern>*.jspx</url-pattern>
    <dispatcher>FORWARD</dispatcher>
    <dispatcher>REQUEST</dispatcher>
    <dispatcher>INCLUDE</dispatcher>
    </filter-mapping>
    <filter-mapping>
    <filter-name>PageFlowForbiddenFilter</filter-name>
    <url-pattern>*.java</url-pattern>
    <dispatcher>REQUEST</dispatcher>
    </filter-mapping>
    <filter-mapping>
    <filter-name>PageFlowForbiddenFilter</filter-name>
    <url-pattern>*.jsfb</url-pattern>
    <dispatcher>REQUEST</dispatcher>
    </filter-mapping>
    <filter-mapping>
    <filter-name>PageFlowForbiddenFilter</filter-name>
    <url-pattern>*.jpfs</url-pattern>
    <dispatcher>REQUEST</dispatcher>
    </filter-mapping>
    <filter-mapping>
    <filter-name>PageFlowForbiddenFilter</filter-name>
    <url-pattern>/_pageflow/*</url-pattern>
    <dispatcher>REQUEST</dispatcher>
    </filter-mapping>
    <listener>
    <listener-class>org.apache.beehive.netui.pageflow.PageFlowContextListener</listener-class>
    </listener>
    <listener>
    <listener-class>org.apache.beehive.netui.pageflow.HttpSessionMutexListener</listener-class>
    </listener>
    <servlet>
    <servlet-name>XmlHttpRequestServlet</servlet-name>
    <servlet-class>org.apache.beehive.netui.pageflow.xmlhttprequest.XmlHttpRequestServlet</servlet-class>
    </servlet>
    <servlet-mapping>
    <servlet-name>action</servlet-name>
    <url-pattern>*.jpf</url-pattern>
    </servlet-mapping>
    <servlet-mapping>
    <servlet-name>action</servlet-name>
    <url-pattern>*.do</url-pattern>
    </servlet-mapping>
    <servlet-mapping>
    <servlet-name>XmlHttpRequestServlet</servlet-name>
    <url-pattern>*.xhr</url-pattern>
    </servlet-mapping>
    <servlet-mapping>
    <servlet-name>XmlHttpRequestServlet</servlet-name>
    <url-pattern>*.render</url-pattern>
    </servlet-mapping>
    </web-app>
    Edited by cynthialiu at 05/28/2008 12:16 PM

    Hi. The issue is a level or two above JDBC. I suggest
    opening an official support case. It's probably a
    WLW issue.
    Joe

  • Can not use any remote desktop like VNC after installing Oracle Linux 6.3

    Hi
    I just installed OL 6.3 on a HP Proliant ML380 g7. Now I want to connect to the server using any Remote Desktop tools but I can not!
    I've activated system>pref>Remote Desktop
    But I can not access any of servers from:
    - a Mac using, Mac server sharing screen, VNC viewer or Microsoft Remote connection which is in a same subnet
    - Other Server Using KRDC, Remote Desktop Viewer, terminal server client or tiger VNC viewer
    Also I tried to connect to servers after activating krfb
    but it always says no rout to server/ server not found/ connection closed
    and remote desktop viewer can not find any host when I try to use option "find"
    Please Advise
    Thank you in advance

    Make sure to enable "require a password..." in the Remote Desktop Preference on the Linux system. Some clients won't work unless this is set. Unfortunately the Remote Desktop Preferences panel on the Linux side does not show you the port it is listening on, but you can get it by clicking on the IP or name that it shows as a link. The first user or vnc server is usually listening on port 5900, then 5901, and so on.
    Your problem is probably the firewall on your Linux system. You can disable the firewall on the Linux system:
    service iptables stop
    However, probably a better idea, simply tunnel the connection through SSH as following:
    On the Mac, open the Terminal application from the Applications/Utilities folder. Then type the following:
    <pre>
    ssh -L local_port:localhost:remote_port -N -f -l username server_address
    </pre>
    local_port = port on your Mac that does not conflict with any of your own screen-sharing or other services, e.g. 5555
    remote_port = vnc server port on your Linux system
    username = user for which you have enabled remote desktop sharing
    server_address = ip address or FQDN of your Linux system.
    For instance:
    <pre>
    ssh -L 5555:localhost:5900 -N -f -l root 10.0.1.2
    </pre>
    The trick is now to connect to a local port on your Mac, instead using the address of your Linux server. The communication will be encrypted using ssh going over tcp port 22, which is normally enabled in the firewall.
    The Mac screen sharing application is working fine. On your Mac, select "Go>Connect to Server" from the Finder menu and type:
    vnc://localhost:5555

  • BIRT can not deployed to web logic 8.1.

    When I deploy the BIRT application in exploded folder structure to web logic 8.1, it failed. I found out org.eclipse.equinox.registry.jar can not be deployed to web logic. An exception is thrown like following:
    Exception:weblogic.management.ApplicationException: prepare failed for birt_origin Module: birt_origin Error: Could not load birt_origin: java.lang.StringIndexOutOfBoundsException: String index out of range: -1
    [Deployer:149033]preparing application birt_origin on myserver [Deployer:149033]failed application birt_origin on myserver [Deployer:149034]An exception occurred for task [Deployer:149026]Deploy application birt_origin on myserver.: Exception:weblogic.management.ApplicationException: prepare failed for birt_origin Module: birt_origin Error: Could not load birt_origin: java.lang.StringIndexOutOfBoundsException: String index out of range: -1 .
    Then what's wrong? How to fix this?

    I've run into the same issue using weblogic 8.1 SP 3 with jdk 1.4.2
    Adding
         <container-descriptor>
              <prefer-web-inf-classes>true</prefer-web-inf-classes>
         </container-descriptor>
    did not help.

Maybe you are looking for

  • Flat Files - SSIS Handy Hints

    After working with flat files (especially text and CSV) for some time in my current role I have decided to come up with this little discussion which I believe may benefit peers who might not yet have come across some of the issues that I have raised

  • Ship-to address load

    Hi Gurus, How do I load the ship-to address (about 600) which is not related to any company code. Which means any employee can make use of the 600 ship-to addresses. By (Ship-to address) default, company code address is displayed in F4 search on the

  • Alternative to outlook

    My trial subscription to outlook has ended, but my iphone only seems able to sync with Outlook. Surely Apple have an alternative or can anyone suggest one? I can't bear to pay a fortune to Microsoft just for their Outlook calendar app. Or can my Mobi

  • Pause Frames in 2950-LRE

    Hello experts, I have an eight port 2950 Long Range Ethernet switch, model WS-C2950ST-8-LRE, with sw image c2950lre-i6l2q4-mz.121-22.EA5a.bin. I have CPE585 on the other end of the lre link. The distance is about 250 meters. When I issue the command,

  • Need Help regarding TNS listener

    ORA-12514: TNS: No listener . in Dev_W0 i got this error also OCI-call 'OCIServerAttach' failed: rc = 12541 Please Advice