Can not pass contactID to an other State (page)

Hi,
I am trying to pass the contactID from this grid to
contactdetail page load from contact state. It's load fine but did
not select the right record of contactdetail page. Any idea what I
am mssing here?
I do have funtion Edititem in the scripting block as below:
private function EditItem(key:Object):void
var e:SelectionEvent;
if( key == null )
e = new SelectionEvent("addItem", key);
else
e = new SelectionEvent("editItem", key);
this.dispatchEvent(e);
<mx:DataGrid doubleClickEnabled="true"
id="contactsGrid"
doubleClick="Application.application.currentState='Contact';EditItem(this.contactsGrid.se lectedItem.ContactID)"
dataProvider="{contacts}"
editable="false" width="100%" height="100%">
<mx:columns>
<mx:DataGridColumn dataField="ContactID" headerText="ID"
width="30" />
<mx:DataGridColumn dataField="FirstName"
headerText="First Name" />
<mx:DataGridColumn dataField="LastName" headerText="Last
Name" />
<mx:DataGridColumn dataField="Title" headerText="Title"
/>
<mx:DataGridColumn dataField="Type" headerText="Type"
/>
<mx:DataGridColumn dataField="Phone" headerText="Phone"
/>
<mx:DataGridColumn dataField="Ext" headerText="Ext" />
<mx:DataGridColumn dataField="MobilePhone"
headerText="Mobile Phone" />
<mx:DataGridColumn dataField="Email" headerText="Email"
/>
</mx:columns>
</mx:DataGrid>

I have tried a similar way in my application and it worked.
This error may have occured coz ContactId is not getting
populated. Are you able to see the ID column perfectly populated?
. One more debugging technique is to trace the results or put
in alerts for displaying contactID value.This will help you to
figure out wjether the value is getting populated in key or not.
Ex:
private function EditItem(key:Object):void
var e:SelectionEvent;
Alert.show(Key.toString()); //new line
if( key == null )
e = new SelectionEvent("addItem", key);
else
e = new SelectionEvent("editItem", key);
this.dispatchEvent(e);
If this doesnt show any proper output then try to make key as
the type of ContactID (i.e string or Int etc)

Similar Messages

  • HP4275A can not pass self test after running the labview program

    I am using Labview to control HP4275A LCR meter. The Labview program is just the instrument driver for the HP4275A, and it works great. Before running the program, the instrument can pass both Open and Short test perfectly. But after running the program, it can not pass self test, neither Open nor Short. I don't know why?? Is it relative to my Labview program??
    Thanks

    Thank you so much for your help. Yes, the instrument is in Local after running the instrument driver. In normal Open self test, just choose Capactiance as the Display A, and leave the four output terminals open then press the Self Test button. The Open self test will start and "OP" will be shown in the DIsplay A window, after 2 seconds, the open test will be finished. If something abnormal, the number of the abnormal step is displayed in Display A. Similar with the Short test.
    The problem I had was: before running the instrument driver, the self tests pass; but after running the instrument driver, the Open and Short test show abnormal, Open test is abnormal at step 17, and Short test is abnormal at step 24.
    And the instrument driver is only write commands into the instrument and then read back measuring values from it. Nothing else. So I am not sure if the problem is my instrument driver.
    The weird thing is the problems happened several times and then if I do the Open and Short self test again after running the instrument driver, both pass. I am not sure whether the problem will come back or not.
    Ia there any help??
    Big thanks

  • HT204406 my iTunes match can not pass the step 2, it keeps repeat again and again. Pls advise. Thank you.

    my iTunes Match can not pass the step 2, it keeps repeat again and again. Pls advise. Thank you.

    Very strange.  Two items to try:
    a.  Enable iCloud Status and iCloud Download fields in Song view, sort on status and look for any 'waiting' or 'error';
    b.  If (a) looks good, establish a new user account, create an empty library and enable iTunes Match, confirm that this provides access to all Songs and is working well.
    These are seeking to ensure both no bad Songs or local Library corruption - both are relatively quick.

  • I can not pass the language settings menu

    Hello,
    Since I have tried to get the latest build of Apple TV, my apple TV can not pass the language settings menu. I choose my language and then it loops back to language settings menu.
    I have restored twice from iTunes, plug and unplug from the tv, the electric network, and so on, but it does the same loop.
    Anybody has solved this problem ?
    Regards,
    F

    If you can't get past the lock screen when you slide to unlock, try rebooting your iPad and then try again.
    Reboot the iPad by holding down on the sleep and home buttons at the same time for about 10-15 seconds until the Apple Logo appears - ignore the red slider if it appears on the screen - let go of the buttons. Let the iPad start up.

  • I can not pass the lock screen

    I can not pass the lock screen, when I slide to unlock

    If you can't get past the lock screen when you slide to unlock, try rebooting your iPad and then try again.
    Reboot the iPad by holding down on the sleep and home buttons at the same time for about 10-15 seconds until the Apple Logo appears - ignore the red slider if it appears on the screen - let go of the buttons. Let the iPad start up.

  • GRE traffic can not pass through LRT224 IPSec Tunnel

    Hi,
    We have a trouble when using Cisco Router GRE tunnel plus LRT224 IPSec Gateway-Gateway Tunnel.
    We found after reboot, GRE packets can not pass trough LRT224 IPSec tunnel. need to restart serval time then gre will back to normal.
    Besides that, GRE keepalive packets can not pass trough LRT224 IPSec Tunnel.
    please help. I had tried to upgrade to latest firmware version.
    Firmware Version : v1.0.3.09 (Dec 26 2014 14:28:46) 
    A-END:
    interface Tunnel1
    ip address 10.216.80.105 255.255.255.252
    ip mtu 1400
    ip nat outside
    ip virtual-reassembly in
    ip tcp adjust-mss 1360
    ip ospf network point-to-point
    ip ospf hello-interval 3
    ip ospf cost 10000
    tunnel source 10.216.81.2
    tunnel destination 10.216.80.90
    end
    B-END:
    interface Tunnel11
    ip address 10.216.80.110 255.255.255.252
    ip mtu 1400
    ip tcp adjust-mss 1360
    ip ospf network point-to-point
    ip ospf cost 10000
    ip ospf hello-interval 3
    tunnel source 10.216.80.91
    tunnel destination 10.216.81.3
    end
    CISCO2911 <> LRT224 <> INTERNET <> LRT224 <> CISCO 2621
    San

    Can you post the results from the below command for the Cisco Routers?
    IOS Command: "sh version"
    Why not static route without NAT through the LRT224 IPSec VPN?
    Just curious why did you use LRT224's for the Site to Site VPN instead of the Cisco Routers?
    Please remember to Kudo those that help you.
    Linksys
    Communities Technical Support

  • Can not open JPEG files and can not create JPEG files from other software

    Can not open JPEG files and can not create JPEG files from other software (For example from Solidworks).
    When I try to right click on a JPEG, a notice window appears written: "Windows Explorer has stopped working - Windows is
    checking for a solution to the problem" and then the notice box disapears, the desktop appears and I can continue working.
    From the other side - If I try to save as JPEG a screen of Solidworks (like a view of a part) the Solidworks falls but the JPEG
    is created (I can see its name in the directory I created it).
    I can open the JPEGS with the Paint software if I want but not with the Windows Photo Viewer.
    I have the feeling that the Windows Photo Viewer disapeared from my computer - just a feeling.
    I will appreciate your assistance.
    Avi T. 2014

    Hi,
    Did Windows Photo Viewer option appear when you right click the JPEG file and select open with?
    I would like suggest you use Clean Boot to troubleshoot if there is third-party software conflict:
    How to perform a clean boot in Windows
    http://support.microsoft.com/kb/929135
    Karen Hu
    TechNet Community Support

  • I have 2nd generation apple tv, and this has always worked well with Lion, have now upgraded to Mountain Lion, and now can not connect to itunes, all other things work, can buy or rent films.

    I have 2nd generation apple tv, and this has always worked well with Lion, have now upgraded to Mountain Lion, and now can not connect to itunes, all other things work, can buy or rent films, but can not listen to my music or show photos. Can anybody help please?

    I have 2nd generation apple tv, and this has always worked well with Lion, have now upgraded to Mountain Lion, and now can not connect to itunes, all other things work, can buy or rent films, but can not listen to my music or show photos. Can anybody help please?

  • The problem is that I select as a pdf document does not open completely but leaves the mail. Also I can not open more even Ibook other documents already saved

    the problem is that I select as a pdf document does not open completely but leaves the mail. Also I can not open more even Ibook other documents already saved

    http://www.microsoft.com/mac/support
    http://answers.microsoft.com/en-us/mac/forum/macword?auth=1
    http://answers.microsoft.com/en-us/mac/forum/macoffice2011-macword/microsoft-wor d-for-mac-2011-will-not-open-error/ecc42616-6f49-40bb-b8f5-e21c711ea359

  • I lost my administrator password and can not install Mavericks (or any other software for that matter). How can I find my administrator password?

    I lost my administrator password and can not install Mavericks, or any other software for that matter. How can I retrieve an administrator password?

    Forgot Your Account Password
    For Lion/Mountain Lion
        Boot to the Recovery HD:
    Restart the computer and after the chime press and hold down the COMMAND and R keys until the menu screen appears. Alternatively, restart the computer and after the chime press and hold down the OPTION key until the boot manager screen appears. Select the Recovery HD and click on the downward pointing arrow button.
         When the menubar appears select Terminal from the Utilities menu.
         Enter resetpassword at the prompt and press RETURN. Follow
         instructions in the dialog window that will appear.
         Or see Reset a Mac OS X 10.7 Lion Password, OS X Mountain Lion- Reset a login password, and
         OS X Lion- Apple ID can be used to reset your user account password.
    For Snow Leopard and earlier with installer DVD
         Mac OS X 10.6- If you forget your administrator password
    For Snow Leopard and earlier without installer DVD
        How to reset your Mac OS X password without an installer disc | MacYourself

  • I can not open new tabe in the same page

    i can not open new tabe im the same page
    when i click on new tabe , it donsnt open at all

    Uninstall the Ask toolbar and it should work again. There is a compatibility issue with the Ask toolbar and Firefox that prevents new tabs from being opened.
    There are a couple of places to check for the Ask toolbar:
    * Check the Windows Control panel for the Ask Toolbar - http://about.ask.com/apn/toolbar/docs/default/faq/en/ff/index.html#na4
    * Also check your list of extensions, you may be able to uninstall it from there - https://support.mozilla.com/kb/Uninstalling+add-ons

  • I can't pass the icloud terms and conditions page after updating ios7

    Hi, I need urgent help!
    I can't pass the icloud terms and conditions page after updating ios7
    I've tried agree disagree and every other button i could press but it just wouldn't go pass the page
    Is there anyone who can help me with it?

    There are several solutions you can try in this discussion: https://discussions.apple.com/thread/5321627?start=0&tstart=0.

  • Can not pass data after while loop

    Hello.
    I have created a VI for my experiment and am having problem passing data outside a while loop to save on an excel file. The VI needs to first move a probe radially, take data at 1mm increment, then move axially, take data radially at 1mm increment, then move to the next axial position and repeat. It would then export these data to an excel file. The VI is a little complicated but it's the only way I know how to make it for our experiment. I have tested it and all the motion works correctly, however I can not get it to pass the data after the last while loop on the far right of the VI where I have put the arrows (Please see the attached VI ). Is it because I'm using too many sequence, case, and while loops?  If so, what other ways can I use to make it export data to the excel file?
    Any help would be appreciated. 
    Thank you,
    Max
    Attachments:
    B.Dot.Probe.Exp.vi ‏66 KB

    Ummmm .... gee, I'm not even sure where to begin with this one. Your VI is well .... ummmm... You have straight wires! That's always nice to see. As for everything else. Well... Your fundamental problem is lack of understanding of dataflow programming. What you've created is a text program. It would look fantastic in C. In LabVIEW it makes my heart break. For a direct answer to your question: Data will not show up outside a while loop until the while loop has completed. This means your most likely problem is that the conditions to stop that specific loop are not being met. As for what the problem is, I don't even want to start debugging this code. Of course, one way to pass data outside of loops is with local variables, and hey, you seem to be having so much fun with those, what's one more?
    This may sound harsh, and perhaps be somewhat insulting, but the brutal truth is that what I would personally do is to throw it out and to start using a good architecture like a state machine. This kind of framework is easy to code, easy to modify, and easy to debug. All qualities that your code seems to lack.
    Message Edited by smercurio_fc on 08-17-2009 10:00 PM

  • HT5625 can not purchase from apps store. message states - Apple ID is disabled.

    Can not purchase from Apps Store. Continue to get message stating that Apple ID is disabled after I select install. I have change my Itune account pass word and updated all information.

    After resetting your password you might then need to log out of your account on your iPod by tapping on your id in Settings > iTunes & App Store and then log back in so as to 'refresh' the account on it
    If that doesn't fix it then you might need to contact iTunes Support : http://www.apple.com/support/itunes/contact/ - click on Contact iTunes Store Support on the right-hand side of the page

  • I can not pass the activation of i cloud?

    i have mini i pad and i forget the password so i do recovery then when i open again he ask activation of i cloud and i put the apple ID and he could not pass and the i pad still i can not use it closed and he need activation what should i do please help me?

    my problem only the activation of i cloud why not open i put the ID and password and still not pass the activation

Maybe you are looking for