CFMX 8 - Scheduled tasks timing out

Hi,
I just migrate from CFMX 6.1 tyo CFMX 8 and I have a problem
with a scheduled task already existing. It's not that big of a task
and but page is always timing out. I tried to re-create it but it
still happens. I tried to put a RequestTimeOut in the link like
this (
http://www.myCFMpage.com//myTask.cfm?RequestTimeOut=50000)
but it doesn't work either.
Why does this happen ?? I thought that scheduled tasks never
timed out ??
Here's the message in my scheduler.log file :
The request has exceeded the allowable time limit Tag: cfhttp
Error while executing task The request has exceeded the
allowable time limit Tag: cfhttp
Thanks for your help
Gilles

cfgilles wrote:
> RequestTimeOut in the link like this
> (
http://www.myCFMpage.com//myTask.cfm?RequestTimeOut=50000)
but it doesn't work
> either.
This feature has been deprecated. You use the CF
Administrator or the
<cfsetting...> tag to adjust how long a template is
allowed to run.
>
> Why does this happen ?? I thought that scheduled tasks
never timed out ??
Of course they time out. All a schedule task does is make a
request
with ColdFusion's internal browser at a scheduled time. Once
this
request is made, it is process as any other request and will
time-out at
the defined time as any other request would.
It sounds like your <cfhttp...> request is not getting
returned in the
allowed time.

Similar Messages

  • Task Timed Retry Scheduler

    Hi,
    We are facing a peculiar problem in our environment.
    We have a process task, say Create User, on whose rejection a mail is triggered to a particular group. We have set the task retry limit as 5 at an interval of 1 hour. Now the problem is, the group is receiving mails at an interval of 30 mins. though the max. limit has reached. From logs, I inferred that this problem is coming due to the OOB schedule task "Task Timed Retry" which runs at an interval at an interval of 30mins, retries being 5.
    This is happening for the past 1 week, on a daily basis 48 mails are being received. Why is OIM triggering this repeatedly though the max. limit has reached. Which table in OIM stores data related to the scheduler Task Timed Retry.
    Any help is appreciated.

    Any help???

  • Issue with Bulk Load Post Process Scheduled Task

    Hello,
    I successfully loaded users in OIM using the bulk load utility.  I also have LDAP sync ON.  The documentation says to run the Bulk Load Post Process scheduled task to push the loaded users in OIM into LDAP.
    This works if we run the Bulk Load Post Process Scheduled Task right away after the run the bulk load.
    If some time had passed and we go back to run the Bulk Load Post Process Scheduled Task, some of the users loaded through the bulk load utility are not created in our LDAP system.  This created an off-sync situation between OIM and our LDAP.
    I tried to use the usr_key as a parameter to the Bulk Load Post Process Scheduled Task without success.
    Is there a way to force the re-evaluation of these users so they would get created in LDAP?
    Thanks
    Khanh

    The scheduled task carries out post-processing activities on the users imported through the bulk load utility.

  • Operation timed out (FSP network services manager)

    Received this error from five different RMAN jobs, all submitted at approx 6am, all failing within a couple of minutes. Resubmit of all five jobs worked fine. Many other jobs submitted at approx the same time worked fine. Time out does not appear to be related to waiting on tape drive resources.
    Any ideas as to cause? If this is a network thing, any way to extend the timeout or cause it to retry?
    Regards,
    Rich McClain
    ORA-19506: failed to create sequential file, name="SBT_TAPE/RMAN_SCMP.707724115.arch.1.7372.1", parms=""
    ORA-27028: skgfqcre: sbtbackup returned error
    ORA-19511: Error received from media manager layer, error text:
    sbt__rpc_cat_query: Query for piece SBT_TAPE/RMAN_SCMP.707724115.arch.1.7372.1 failed.
    (Oracle Secure Backup error: 'operation timed out (FSP network services manager)').
    Snippet from obroxyd.log
    2010/01/08.06:02:57 [2543] failed to connect to admin scheduler - operation timed out (FSP network services manager)
    2010/01/08.06:03:02 [2543] client disconnect from IPC connection 4 (closing)
    2010/01/08.06:03:03 [2543] obproxyd is terminating now
    2010/01/08.06:03:11 [9770] failed to connect to admin scheduler - operation timed out (FSP network services manager)
    2010/01/08.06:03:16 [9770] client disconnect from IPC connection 4 (closing)
    2010/01/08.06:03:16 [9770] obproxyd is terminating now

    Either reconfigure CONNECT_TIMEOUT to be 0, which means wait indefinitely, or reconfigure CONNECT_TIMEOUT to be some higher value. Or, if the timeout is unacceptably long, turn on tracing for further information.
    If you have oracle metalink, then read the following note;
    Note:119706.1 - Troubleshooting Guide TNS-12535 & ORA-12535 Errors

  • SSIS 2012 Scheduled SSIS package fail to start – Execution timed out

    Hi
    I am currently running into an issue that seem to have a live Connect issue raised for it. The following is the link to the connect issue https://connect.microsoft.com/SQLServer/feedback/details/783291/ssis-package-fails-to-start-application-lock-timeout-in-ssisdb-catalog-create-execution
    There is also a blog post that explains this issue in more detail, however the solution
    it provides does not work all the time and I am very reluctant to create custom stored procedures in the SSISDB. http://speaksql.wordpress.com/2013/06/27/ssis-2012-fail-to-start-execution-timed-out/
    Just to give some more background. When scheduling 10 or more, in my case I scheduled 14, SQL Server Agent Jobs all executing a package in the SSIS Catalog and all kicking off on exactly the same time about 10% to 20% of these jobs fail stating one of the
    following error messages:
    The operation failed because the execution timed out.  Source: .Net SqlClient Data Provider  Started:  12:20:01  Finished: 12:20:07  Elapsed:  5.797 seconds.  The package execution failed.  The step failed.
    Description: Transaction (Process ID 66) was deadlocked on lock resources with another process and has been chosen as the deadlock victim. Rerun the transaction.  Source: .Net SqlClient Data Provider  Started:  14:06:48  Finished: 14:06:53
     Elapsed:  4.719 seconds.  The package execution failed.  The step failed.
    This timeout takes place both when using TSQL to start the package in the Job or when the step in the Job is set to start the package as an Integration Services Package.
    Steps to recreate this:
    1. Create one SSIS package that simply executes for around a minute. For example you can use an Execute SQL Task and simply execute the following TSQL "WAITFOR DELAY '00:01:00'"
    2. Create 14 SQL Server Agent Jobs each executing the same package and schedule all of them to run at the same time.
    3. Watch the execution of the jobs take place and note the failures. (This does not always happen and you might get one run in which everything executes without a problem. The next run might have 6 or 7 of the jobs fail.)
    You can also create 14 different SSIS packages, one for each job, and the result is the same.
    I am running on SQL 2012 SP1 CU4. Windows Server 2012 R2 patched to the lastest patch level.
    This issue does not happen when the packages are deployed to the SSIS Package Store the way that it was done in SQL2008 and before. It only occurs when the SSIS packages are deployed to the SSIS Catalog.
    Any help or feedback on this would be greatly appreciated.
    Kind Regards,
    Christo Olivier

    Hi Tom
    Thank you for the fast response. I went and increased the value by 1024KB instead of the initial
    512KB. Unfortunately this seems to only alleviate the issue but does not stop it from occurring. It
    is happening much less often now but still occurring intermittently.
    Regards,
    Christo

  • Hi Experts , I am currently facing problems while running restricted version copy .. The log says 0 location products copied and that the process has has timed out. the error message is /SAPAPO/MVM_INT_SVC_CO_VER_LCW reported exception in task DP00014, th

    Hi Experts , I am currently facing problems while running restricted version copy in sap apo .. The log says 0 location products copied and that the process has timed out. the error message is " /SAPAPO/MVM_INT_SVC_CO_VER_LCW reported exception in task DP00014 " , then ending in time limit exceeded. could anyone explain why this happens. please note even if the log says 0 location products copied , in reality they have have been partially copied.
    Regards
    Jerel

    Hi, thank you for your replies, I found out few things about my servlet, and its portability
    and i have few questions, although i marked this topic as answered i guess its ok to post
    I am using javax.servlet.context.tempdir to store my files in that servletcontext temporary directory. But i dont know how to give hyperlink
    of the modified files to the user for them to download the modified files.
    What i am using to get the tempdir i will paste
    File baseurl = (File)this.getServletContext().getAttribute("javax.servlet.context.tempdir");
    System.out.println(baseurl);
    baseurl = new File(baseurl.getAbsolutePath()+File.separator+"temp"+File.separator+"files");
    baseurl.mkdirs();so i am storing my files in that temp/files folder and the servlet processes them and modifies them, then how to present them as
    links to the user for download ?
    and as the servlet is multithreaded by nature, if my servlet gets 2 different requests with same file names, i guess one of them will be overwritten
    And i want to create unique directory for each request made to the servlet , so file names dont clash.
    one another thing is that i want my servlet to be executed by my <form action> only, I dont want the user to simply type url and trigger the servlet
    Reply A.S.A.P. please..
    Thanks and regards,
    Mihir Pandya

  • Scheduled Task GPO "run as" greyed out

    Hi,
    When I'm creating a new schedule task through GPO the Run As option is greyed out, is there any way to enable this?
    Regards.

    > When I'm creating a new schedule task through GPO the Run As option is
    > greyed out, is there any way to enable this?
    Uninstall MS14-025...
    Martin
    Mal ein
    GUTES Buch über GPOs lesen?
    NO THEY ARE NOT EVIL, if you know what you are doing:
    Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))

  • TES 5.3.1 All Jobs Status Timed Out or Scheduled

    Reboot of SQL server caused all jobs to be in status Timed Out or Scheduled and never run.
    Have rebooted TES server multiple times, but every day since the SQL server reboot the problem returns.
    Must restart the TES server every day and then override every job to get them to run out of schedule.
    No errors in event viewer.
    No errors in logs. - attached
    Please help!

    I wasn't aware of this functionality, but I was curious so...
    If you click the "Restore" button (I think that's what it is called) it toggles between window and tab views.  To the very right of the tabs are the standard three windows buttons: "Help", "Restore" and "Exit".  Use the ones below the "Enterprise Scheduler" text.
    Tracy

  • VPN client get connect but Request Timed out when ping

    Hi, I'm using the cisco 837 router as my VPN server. I get  connected using Cisco VPN Client Version 5. But when I ping the router  ip, i get request timed out. Here is my configuration :
    Building configuration...
    Current configuration : 3704 bytes
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname michael
    boot-start-marker
    boot-end-marker
    memory-size iomem 5
    no logging console
    enable secret 5 $1$pZLW$9RZ8afI8QdGRq0ssaEJVu0
    aaa new-model
    aaa authentication login default local
    aaa authentication login sdm_vpn_xauth_ml_1 local
    aaa authorization exec default local
    aaa authorization network sdm_vpn_group_ml_1 local
    aaa session-id common
    resource policy
    ip subnet-zero
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.1.1
    ip dhcp pool michael
       network 192.168.1.0 255.255.255.0
       default-router 192.168.1.1
       dns-server 202.134.0.155
    ip dhcp pool excluded-address
       host 192.168.1.4 255.255.255.0
       hardware-address 01c8.d719.957a.b9
    ip cef
    ip name-server 202.134.0.155
    ip name-server 203.130.193.74
    vpdn enable
    username michael privilege 15 secret 5 $1$ZJQu$KDigCvYWKkzuzdYHBEY7f.
    username danny privilege 10 secret 5 $1$BDs.$Ez0u9wY7ywiBzVd1ECX0N/
    crypto isakmp policy 1
    encr 3des
    authentication pre-share
    group 2
    crypto isakmp xauth timeout 15
    crypto isakmp client configuration group michaelvpn
    key vpnpassword
    pool SDM_POOL_1
    acl 199
    netmask 255.255.255.0
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto dynamic-map SDM_DYNMAP_1 1
    set transform-set ESP-3DES-SHA
    crypto map SDM_CMAP_1 client authentication list sdm_vpn_xauth_ml_1
    crypto map SDM_CMAP_1 isakmp authorization list sdm_vpn_group_ml_1
    crypto map SDM_CMAP_1 client configuration address respond
    crypto map SDM_CMAP_1 65535 ipsec-isakmp dynamic SDM_DYNMAP_1
    interface Ethernet0
    description $FW_INSIDE$
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    hold-queue 100 out
    interface Ethernet2
    no ip address
    shutdown
    hold-queue 100 out
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    pvc 0/35
      pppoe-client dial-pool-number 1
    interface FastEthernet1
    duplex auto
    speed auto
    interface FastEthernet2
    duplex auto
    speed auto
    interface FastEthernet3
    duplex auto
    speed auto
    interface FastEthernet4
    duplex auto
    speed auto
    interface Virtual-PPP1
    no ip address
    interface Dialer1
    description $FW_OUTSIDE$
    mtu 1492
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    dialer pool 1
    ppp chap hostname ispusername
    ppp chap password 0 isppassword
    ppp pap sent-username ispusername password 0 isppassword
    crypto map SDM_CMAP_1
    ip local pool SDM_POOL_1 192.168.2.1 192.168.2.5
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip http server
    no ip http secure-server
    ip nat inside source static udp 192.168.1.0 1723 interface Dialer1 1723
    ip nat inside source static tcp 192.168.1.4 21 interface Dialer1 21
    ip nat inside source route-map SDM_RMAP_1 interface Dialer1 overload
    access-list 1 remark SDM_ACL Category=16
    access-list 1 permit 192.0.0.0 0.255.255.255
    access-list 102 remark SDM_ACL Category=2
    access-list 102 deny   ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255
    access-list 102 permit ip 192.168.1.0 0.0.0.255 any
    access-list 199 permit ip 192.168.1.0 0.0.0.255 192.168.2.0 0.0.0.255
    route-map SDM_RMAP_1 permit 1
    match ip address 102
    control-plane
    banner motd ^C
    Authorized Access Only
    UNAUTHORIZED ACCESS TO THIS DEVICE IS PROHIBITED
    You must have explicit permission to access this device.
    All activities performed on this device are logged.
    Any violations of access policy will result in disciplinary action.
    ^C
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    scheduler max-task-time 5000
    end
    Thank you, anny help will be appreciated.

    Thank you for your response, here is the debug :
    Log Buffer (4096 bytes):
      1 15:19:47.011: ISAKMP: set new node 856647599 to QM_IDLE     
    May  1 15:19:47.015: ISAKMP:(0:8:SW:1):Sending NOTIFY DPD/R_U_THERE_ACK protocol 1
         spi 2182802952, message ID = 856647599
    May  1 15:19:47.015: ISAKMP:(0:8:SW:1): seq. no 0xA3285B8A
    May  1 15:19:47.015: ISAKMP:(0:8:SW:1): sending packet to 120.168.1.24 my_port 4500 peer_port 52667 (R) QM_IDLE     
    May  1 15:19:47.019: ISAKMP:(0:8:SW:1):purging node 856647599
    May  1 15:19:47.019: ISAKMP:(0:8:SW:1):Input = IKE_MESG_FROM_PEER, IKE_MESG_KEEP_ALIVE
    May  1 15:19:47.019: ISAKMP:(0:8:SW:1):Old State = IKE_P1_COMPLETE  New State = IKE_P1_COMPLETE
    May  1 15:19:49.979: %SYS-2-BADSHARE: Bad refcount in pak_enqueue, ptr=81B4F274, count=0
    -Traceback= 0x80137488 0x801DC350 0x801DDDA8 0x801E6860 0x807103F4 0x807F99F8 0x801E698C 0x8043FB10 0x8043FDC8 0x80D23CD0 0x80D24304 0x80D24400 0x8027B3C4 0x8027E9E0
    May  1 15:19:49.983: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=81B4F274, count=0
    -Traceback= 0x80137488 0x801D8830 0x801DDFD8 0x801E6860 0x807103F4 0x807F99F8 0x801E698C 0x8043FB10 0x8043FDC8 0x80D23CD0 0x80D24304 0x80D24400 0x8027B3C4 0x8027E9E0
    May  1 15:19:55.127: %SYS-2-BADSHARE: Bad refcount in pak_enqueue, ptr=81B51C44, count=0
    -Traceback= 0x80137488 0x801DC350 0x801DDDA8 0x801E6860 0x807103F4 0x807F99F8 0x801E698C 0x8043FB10 0x8043FDC8 0x80D23CD0 0x80D24304 0x80D24400 0x8027B3C4 0x8027E9E0
    May  1 15:19:55.127: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=81B51C44, count=0
    -Traceback= 0x80137488 0x801D8830 0x801DDFD8 0x801E6860 0x807103F4 0x807F99F8 0x801E698C 0x8043FB10 0x8043FDC8 0x80D23CD0 0x80D24304 0x80D24400 0x8027B3C4 0x8027E9E0
    May  1 15:19:58.383: ISAKMP (0:134217736): received packet from 120.168.1.24 dport 4500 sport 52667 Global (R) QM_IDLE     
    May  1 15:19:58.383: ISAKMP: set new node -1340288848 to QM_IDLE     
    May  1 15:19:58.387: ISAKMP:(0:8:SW:1): processing HASH payload. message ID = -1340288848
    May  1 15:19:58.387: ISAKMP:(0:8:SW:1): processing NOTIFY DPD/R_U_THERE protocol 1
         spi 0, message ID = -1340288848, sa = 81A7DCEC
    May  1 15:19:58.387: ISAKMP:(0:8:SW:1):deleting node -1340288848 error FALSE reason "Informational (in) state 1"
    May  1 15:19:58.387: ISAKMP:(0:8:SW:1):Input = IKE_MESG_FROM_PEER, IKE_INFO_NOTIFY
    May  1 15:19:58.387: ISAKMP:(0:8:SW:1):Old State = IKE_P1_COMPLETE  New State = IKE_P1_COMPLETE
    May  1 15:19:58.391: ISAKMP:(0:8:SW:1):DPD/R_U_THERE received from peer 120.168.1.24, sequence 0xA3285B8B
    May  1 15:19:58.391: ISAKMP: set new node -752454119 to QM_IDLE     
    May  1 15:19:58.395: ISAKMP:(0:8:SW:1):Sending NOTIFY DPD/R_U_THERE_ACK protocol 1
         spi 2182802952, message ID = -752454119
    May  1 15:19:58.395: ISAKMP:(0:8:SW:1): seq. no 0xA3285B8B
    May  1 15:19:58.395: ISAKMP:(0:8:SW:1): sending packet to 120.168.1.24 my_port 4500 peer_port 52667 (R) QM_IDLE     
    May  1 15:19:58.399: ISAKMP:(0:8:SW:1):purging node -752454119
    May  1 15:19:58.399: ISAKMP:(0:8:SW:1):Input = IKE_MESG_FROM_PEER, IKE_MESG_KEEP_ALIVE
    May  1 15:19:58.399: ISAKMP:(0:8:SW:1):Old State = IKE_P1_COMPLETE  New State = IKE_P1_COMPLETE
    May  1 15:19:59.887: %SYS-2-BADSHARE: Bad refcount in pak_enqueue, ptr=81B51C44, count=0
    -Traceback= 0x80137488 0x801DC350 0x801DDDA8 0x801E6860 0x807103F4 0x807F99F8 0x801E698C 0x8043FB10 0x8043FDC8 0x80D23CD0 0x80D24304 0x80D24400 0x8027B3C4 0x8027E9E0
    May  1 15:19:59.887: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=81B51C44, count=0
    -Traceback= 0x80137488 0x801D8830 0x801DDFD8 0x801E6860 0x807103F4 0x807F99F8 0x801E698C 0x8043FB10 0x8043FDC8 0x80D23CD0 0x80D24304 0x80D24400 0x8027B3C4 0x8027E9E0
    May  1 15:20:05.667: %SYS-2-BADSHARE: Bad refcount in pak_enqueue, ptr=81F84148, count=0
    -Traceback= 0x80137488 0x801DC350 0x801DDDA8 0x801E6860 0x807103F4 0x807F99F8 0x801E698C 0x8043FB10 0x8043FDC8 0x80D23CD0 0x80D24304 0x80D24400 0x8027B3C4 0x8027E9E0
    May  1 15:20:05.667: %SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=81F84148, count=0
    -Traceback= 0x80137488 0x801D8830 0x801DDFD8 0x801E6860 0x807103F4 0x807F99F8 0x801E698C 0x8043FB10 0x8043FDC8 0x80D23CD0 0x80D24304 0x80D24400 0x8027B3C4 0x8027E9E0
    After searching thru the internet, I've found :
    CSCsb46264
    Symptoms: When a dialer interface is configured as an endpoint for a  IPSec+GRE tunnel, tracebacks with bad refcount may be generated.
    Conditions: This symptom is observed on a Cisco 837 when router-generated packets such as routing updates are being switched.
    Is that possible that the root of the problem was that ? Thank you.

  • Scheduled Tasks Time Keep Resetting / Changing

    I have 77 Macs in 3 labs (iMacs, G4s and G5s) all running OS 10.3.9 and ARD Client 2.2. I have an Admin ARD 2.2 iMac with 64 preset scheduled tasks ranging from log off, shut down, empty trash and send note running as early as 7:50am to as late as 11:00pm through out the week. Now the problem.... every now and then, some 1/3 to 1/2 of my tasks are reset to another time (i.e. this morning, 30 tasks went from whatever they were to now 7:00am). There is no outside access from campus (closed network) and I am the first one in in the mornings. I have taken a screen shot and can email it out. A major bug in ARD???????? Can anyone please assist? Thank you.
    Mike

    Hi Don Seher1 - I've been having the same problem as many other posters re ARD saved tasks losing timing prefs after quit or shutdown. I read your message and immediately updated Apple Java 2 SE 5.0R3 as indicated. However, this does not appear to have made any change to the problems I'm experiencing with ARD. Do you have any further insights that might help ?
    I'm trying to use ARD to perform a daily shutdown of ten computers on an airport extreme network in a museum in a remote part of western australia. All machines are running 10.4.3; ARD is 2.2 on all; all are brand new Macs. The control iMac is running 24/7 which is no good in the long term.
    My problem I know - but your message of beating this ridiculous shortcoming in the software was tantalising!

  • Scheduled Tasks In Database

    not sure how to do it, but pls advice.
    I have the schedule task to pass diffrent ID nto url for the same page.  If I have 3 IDs, I don't want to create 3 pages from CF admin schedule like
    task.cfm?id=1
    task.cfm?id=2
    task.cfm?id=3
    Instead of doing that, i create 2 pages below
    Thanks
    <!---run.cfm--->
    got 3 ID returned from variables.q_compInfo query(ID =1, 2 and 3).  I want to loop thru then pass id into task.cfm dynamiclly but runs it for 3 time.
    <cfset baseUrl = ("http://" &cgi.server_name &getDirectoryFromPath( cgi.script_name )) />
    <cfoutput>
    <cfloop query="variables.q_compInfo">
    <cfhttp method="get" url="#baseUrl#task.cfm" timeout="1" throwonerror="false">
    <!--- Pass the task ID through to the RUN page. --->
    <cfhttpparam type="url" name="id" value="#task.ID#"/>
    </cfhttp>
    </cfloop>
    </cfoutput>
    <!---task.cfm--->
    when run.cfm excuted, I expected it query will be run 3 time and update this table for 3 dirrent ID.
    <cfquery name="update" datasource="#variables.dsn#">
    update  tbl
    set schedule = 3
    where id = #url.id#
    </cfquery>

    More information - Issue happened last night.
    Here is what the application log says
    ++[Wed Nov 09 18:19:15 2011]Local/Finance/Bud/admin@Native Directory/3316/Info(1012668)++
    ++Calculating [ Schedule(ICRC501)] with fixed members [Measure(Cash, Irrec VAT, MA Adjustment, FAS Adjustment, Manual Accruals, Order Accruals, Prepayments, Manual Accruals Reversal, Order Accruals Reversal, Prepayments Reversal); Activity Type(]++
    ++[Wed Nov 09 18:19:15 2011]Local/Finance/Bud/admin@Native Directory/3316/Info(1012677)++
    ++Calculating in serial++
    ++[Wed Nov 09 22:15:03 2011]Local/Finance///8456/Error(1013291)++
    ++Failed to logout user [admin@Native Directory]: user has requests running++
    You can see that a calculation was running (normally takes 10mins or so) but nothying happens after 18:19.
    The below is an extract from the MAXL log:
    +OK/INFO - 1012569 - Formula on (or backward dependence from) member [ICRC501] forces calculation to execute in serial mode.+
    ERROR - 1042013 - Network error [10054]: Cannot Receive Data.
    ERROR - 1042012 - Network error [10054]: Cannot Send Data.
    MAXL> execute calculation 'Finance'.'Bud'.'PMRecB12' ;
    +ERROR - 1042006 - Network error [10061]: Unable to connect to [hypessbase-liv:1423]. The client timed out waiting to connect to Essbase Agent using TCP/IP. Check your network connections. Also make sure that server and port values are correct.+
    SESSION - 1241102 - Internal API error 1042006.
    Anyone know what is possibly going on? Could it still be due to fragmentation and the network errors are a bit of a red herring?
    Paul

  • ScheduledThreadPoolExecutor core thread pool / keepalive/timing out threads

    Hi,
    I am using a ScheduledThreadPoolExecutor - java1.6 on Windows(currently).
    I would like to minimise the number of threads in the pool running at any one time to around the number of threads required to run the number of tasks that are concurrently executing.
    However, I don't seem to be able to get the thread pool to minimise the number of threads below the max threads in the constructor.
    I want to do this mainly because I have a large delay queue and the performance of the pool seems to be better when the number of threads in the pool is minimised to roughly the number of threads required to service the concurrently executing tasks.
    Any ideas?
    Thanks,
    Alex
                    ThreadFactory tf = new MyThreadFactory();
              ScheduledThreadPoolExecutor scheduler = new ScheduledThreadPoolExecutor(50,tf);
              scheduler.setCorePoolSize(10);
              //scheduler.setMaximumPoolSize(50);
              scheduler.setKeepAliveTime(1, TimeUnit.NANOSECONDS);
              scheduler.allowCoreThreadTimeOut(true);
              scheduler.schedule(aTask, 10, TimeUnit.SECONDS);
    ...

    because of how a scheduledthreadpoolexecutor works, it doesn't really make sense to have a variable number of threads. since threads are only added when tasks are added to the pool (aka, when submit is called), once the core threads timed out they would never get replaced (e.g. you would eventually get down to 1 thread and never get anymore added). one way to achieve what you want would be to have a single threaded ScheduledThreadPoolExecutor, where the scheduled jobs do the real work in a separate, variable size thread pool (e.g. the scheduled tasks do not do anything but submit a task to the real work thread pool). this solution would work fine for "schedule at fixed rate" but not for "schedule with fixed delay". you would actually have to simulate the latter by scheduling a one-off task which resubmits itself to the scheduler each time it completes.

  • Scheduled task

    On a shared server that allows cfschedule, I need to run a
    page that sends
    out an email via cfmail. It needs to run each night at
    midnight. How does
    that work? I haven't dealt with cfschedule.

    Cfschedule is a tag that creates a timed event that calls a
    web page. You schedule the event to occur at a specified time and
    how often it should occur, such as nightly.
    You create the cfml template that performs the process, such
    as cfmail, etc...
    You then use the CFSCHEDULE tag to create a scheduled event.
    You only need to call this once unless somebody deletes a repeating
    event. What you do is create a setup.cfm (doesn't have to be
    setup.cfm, pick anything you like for the name) file that uses
    cfschedule to call the target mailing page and then call the setup
    page through a browser.
    Since it is a shared environment, you should probably name
    your task appropriate to your site so that you don't overwrite
    somebody elses scheduled task.
    <cfschedule action="update"
    task="myMailer"
    operation="httprequest""
    startdate="#Now()#"
    starttime="11:50 PM"
    interval="Daily"
    url="
    http://www.yoursite.com/mailer.cfm">

  • Deployed KM Scheduler Task Does Not Appear in Global Services / Scheduler T

    Hi All,
    I've deployed a portal service and a KM scheduler task in the same DC but cannot see the scheduler task listed under System Admin -> System Config -> Knowledge Management -> Content Management -> Global Services -> Scheduler Tasks.
    The service works correctly and performs its periodic processing once on initialisation of the service, and I can see the resulting log statements to make sure it has worked.
    Both the service and the scheduler task are packed inside the same DC, which builds and deploys without any errors.
    There are no errors in the log regarding the deployment of the DC, or the scheduler task.
    There is a log statement about registering the classloader for the DC, which I assume is the statement in the IRFServiceWrapper init() that goes:
    CrtClassLoaderRegistry.addClassLoader(this.getKey(), this.getClass().getClassLoader());
    But I still dont see the task listed in Global Services -> Scheduler Tasks.
    Does anyone know what might be causing this or how to diagnose the problem further?
    Cheers,
    Steve

    Hi Srini,
    No it doesn't it just has the run method which is generated automatically.
    I have created a local Portal Application project, which is not in a DC, and this also does not have a default constructor ether but appears in the Scheduler Tasks list as soon as it is deployed.
    I also tried to create a Portal Applicaiton DC and Portal Applicaiton (Packaged as SDA) DC and despite the scheduler task being the same, both the DC tasks do not appear in the Scheduler Tasks.
    The only one I can get to work is the local Portal Application project. This is no use as we cant store this in DTR (unless someone can explain how to do this???).
    The Portal Application project packages up the RF Framework JARS inside its PAR file, but the DC and SDA projects dont, so I tried including them via an Assembly Public Part to an External Library DC, which does include the JARs in the deployment files but they still dont appear in the Scheduler Tasks.
    Has anyone out there got a working Scheduler Task in a Portal Application DC?
    Cheers,
    Steve

  • Opening Excel Workbook Fails when run from Scheduled Task on Windows Server 2008 Rw

    Hi,
    I have a little vbs script that instantiates the Excel.Application object and then opens a work book to perform some tasks on it. The script runs fine when run from the command line. When I attempt to run it as a scheduled task (it is supposed to update
    data that is pulled from a SQL Server at regular intervals), it fails with the following error:
    Microsoft Office Excel cannot access the file 'c:\test\SampleWorkbook.xlsm'. There are several possible reasons: .....
    The file does exist. The path reported in the error is correct. The account under which the task is running is the same account I use to run it from the command line. User Account Control is not enabled, and the task is set up to run with highest privileges.
    When I run the same script through the Task Scheduler from a Windows Server 2003 machine, it works without issue.
    I was just wondering if somebody on this forum has run into a similar issue in connection with Windows Server 2008 R2 and figured out what the magic trick is to make it work. I'm sure it is rights related, but I haven't quite figured out what which rights
    are missing.
    Thanks in advance for any advice you may have.

    This is truly killing me ... trying to get it working on Windows Server 2012 without success.
    I desperately need to automate running Excel macros in a "headless" environment, that is non-interactive, non-GUI, etc.
    I can get it to work using Excel.Application COM, either via VBScript or Powershell, successfully on many other Windows systems  in our environment - Windows Server 2008 R2, Windows 7 (32-bit), etc.,  -BUT-
    The two servers we built out for running our automation process are Windows Server 2012 (SE) - and it just refuses to run on the 2012 servers - it gives the messages below from VBScript and PowerShell, respectively- 
    I have tried uninstalling and re-installing several different versions of Microsoft Excel (2007 Standard, 2010 Standard, 2010 Professional Plus, 32-bit vs. 64-bit, etc.), but it makes no difference.
    Would be extremely grateful if any one out there has had any success in running Excel automation on Server 2012 in a non-interactive environment that they could share.
    ( I have tried adding the "%windir%\syswow64\config\systemprofile\desktop"
    folder, which did fix the issue for me when testing on Windows Server 2008 R2, but sadly did not resolve it on Windows Server 2012 )
    [VBScript error msg]
    Z:\TestExcelMacro.vbs(35, 1) Microsoft Office Excel: Microsoft Office Excel cannot
    access the file 'Z:\TestExcelMacro.xlsm'. There are several possible reasons:
    • The file name or path does not exist.
    • The file is being used by another program.
    • The workbook you are trying to save has the same name as a currently open work
    [Powershell error msg]
    Exception calling "Add" with "0" argument(s): "Microsoft Office Excel cannot open or save any more documents because th
    ere is not enough available memory or disk space.
     To make more memory available, close workbooks or programs you no longer need.
     To free disk space, delete files you no longer need from the disk you are saving to."
        + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException
        + FullyQualifiedErrorId : ComMethodTargetInvocation
    You cannot call a method on a null-valued expression.
        + CategoryInfo          : InvalidOperation: (:) [], RuntimeException
        + FullyQualifiedErrorId : InvokeMethodOnNull

Maybe you are looking for

  • Logitech MX550 Revolution Keyboard and mouse combo

    I've been searching forever to find a solution, a driver for the keyboard and mouse. I've found pay for solutions such as, steermouse but only for the mouse. I would really like to find some software that would enable me to use my Keyboard and mouse

  • No HDMI or Front Panel Audio

    I have a Satellite X205 running VISTA and Realtek 6.0.1.5605. The internal speakers work, but there is no audio using HDMI, wired headphones, or external speakers. Only the bluetooth headphone connection works. The Control Panel shows all the correct

  • Using Arabic Langauge in Flash

    Hello every one, I have been using Flash5 and recently decided to make some arabic buttons in Flash. I have installed Arabic scrips on my laptop. when I open Flash and type any English word its alright but as soon as I change the language to Arabic i

  • Can I setup process priority on WebLogic?

    Hi, I try to find out if WebLogic provides any process priority features ? Using JMS message property field is one way. Are there any other alternatives? Chris

  • Advice on buying new Mac Pro

    How big of a difference is there between the 8-core 2.8 and the 3.0. Is it really worth the extra buck. Also, does anyone see any sign of blueray players coming standard in the mac pro? I know that cheap sony laptops are comming standard with BD play