Client can't compile

Hi
I am trying to develop client for the web component that I have deployed using the j2ee1.4 deploytool but Iam getting the compile time error .
http://localhost:8080/math-service/math?WSDL identifies the location of the WSDL file for MyFirstService that I have deployed.
My client directory structure is like as follows :
c:\sun\appserver\apps\static-stub\MathClient.java
package sstub;
import javax.xml.rpc.Stub;
public class MathClient {
private String endpointAddress;
public static void main(String argv[]) {
try {
// Invoke createProxy() to create a stub object
Stub stub = createProxy();
// Set the endpoint address the stub uses to access the service
stub._setProperty(javax.xml.rpc.Stub.ENDPOINT_ADDRESS_PROPERTY,
"http://localhost:8080/math-service/math");
// Cast the stub to the service endpoint interface (MathFace)
MathFace math = (MathFace) stub;
// Invoke the add method
System.out.println(math.add(12, 24));
} catch (Exception ex) {
ex.printStackTrace();
private static Stub createProxy() {
// Create a stub object
// Note that MyFirstService_Impl, generated by wscompile, is implementation-specific
return (Stub) (new MyFirstService_Impl().getMathFacePort());
and the configuration file config-wsdl.xml is in the same dir wher the MathClient.java is placed i.e. c:\sun\appserver\apps\static-stub\
config-wsdl.xml for client is as follows :
<?xml version="1.0" encoding="UTF-8"?>
<configuration xmlns="http://java.sun.com/xml/ns/jax-rpc/ri/config">
<wsdl location="http://localhost:8080/math-service/math?WSDL"
packageName="sstub"/>
</configuration>
I have generate client stubs, using the following command :
c:\sun\appserver\apps\static-stub>wscompile -gen:client -d build -classpath build config-wsdl.xml
This create the sstub package in the sstub dir in static-stub\build\
and I am copileing the client using :
C:\sun\APPSER~1\apps\static-stub> javac -classpath build -d build MathClient.java
but I am geeting the arror as
as follows:
MathClient.java:4: package javax.xml.rpc does not exist
import javax.xml.rpc.Stub;
^
MathClient.java:29: cannot resolve symbol
symbol : class Stub
location: class sstub.MathClient
private static Stub createProxy() {
^
MathClient.java:13: cannot resolve symbol
symbol : class Stub
location: class sstub.MathClient
Stub stub = createProxy();
^
MathClient.java:16: package javax.xml.rpc does not exist
stub._setProperty(javax.xml.rpc.Stub.ENDPOINT_ADDRESS_PROPERTY,
^
MathClient.java:20: cannot access sstub.MathFace
bad class file: build\sstub\MathFace.class
class file has wrong version 49.0, should be 48.0
Please remove or make sure it appears in the correct subdirectory of the classpath.
MathFace math = (MathFace) stub;
^
5 errors
Can u help me out ?

You need to make sure the jax-rpc jar files are in your classpath when you invoke javac.

Similar Messages

  • Service client can't compile

    Hi
    I am trying to develop client for the web component that I have deployed using the j2ee1.4 deploytool but Iam getting the compile time error .
    http://localhost:8080/math-service/math?WSDL identifies the location of the WSDL file for MyFirstService that I have deployed.
    My client directory structure is like as follows :
    c:\sun\appserver\apps\static-stub\MathClient.java
    package sstub;
    import javax.xml.rpc.Stub;
    public class MathClient {
    private String endpointAddress;
    public static void main(String argv[]) {
    try {
    // Invoke createProxy() to create a stub object
    Stub stub = createProxy();
    // Set the endpoint address the stub uses to access the service
    stub._setProperty(javax.xml.rpc.Stub.ENDPOINT_ADDRESS_PROPERTY,
              "http://localhost:8080/math-service/math");
    // Cast the stub to the service endpoint interface (MathFace)
    MathFace math = (MathFace) stub;
    // Invoke the add method
    System.out.println(math.add(12, 24));
    } catch (Exception ex) {
    ex.printStackTrace();
    private static Stub createProxy() {
    // Create a stub object
    // Note that MyFirstService_Impl, generated by wscompile, is implementation-specific
    return (Stub) (new MyFirstService_Impl().getMathFacePort());
    and the configuration file config-wsdl.xml is in the same dir wher the MathClient.java is placed i.e. c:\sun\appserver\apps\static-stub\
    config-wsdl.xml for client is as follows :
    <?xml version="1.0" encoding="UTF-8"?>
    <configuration xmlns="http://java.sun.com/xml/ns/jax-rpc/ri/config">
    <wsdl location="http://localhost:8080/math-service/math?WSDL"
    packageName="sstub"/>
    </configuration>
    I have generate client stubs, using the following command :
    c:\sun\appserver\apps\static-stub>wscompile -gen:client -d build -classpath build config-wsdl.xml
    This create the sstub package in the sstub dir in static-stub\build\
    and I am copileing the client using :
    C:\sun\APPSER~1\apps\static-stub> javac -classpath build -d build MathClient.java
    but I am geeting the arror as
    as follows:
    MathClient.java:4: package javax.xml.rpc does not exist
    import javax.xml.rpc.Stub;
    ^
    MathClient.java:29: cannot resolve symbol
    symbol : class Stub
    location: class sstub.MathClient
    private static Stub createProxy() {
    ^
    MathClient.java:13: cannot resolve symbol
    symbol : class Stub
    location: class sstub.MathClient
    Stub stub = createProxy();
    ^
    MathClient.java:16: package javax.xml.rpc does not exist
    stub._setProperty(javax.xml.rpc.Stub.ENDPOINT_ADDRESS_PROPERTY,
    ^
    MathClient.java:20: cannot access sstub.MathFace
    bad class file: build\sstub\MathFace.class
    class file has wrong version 49.0, should be 48.0
    Please remove or make sure it appears in the correct subdirectory of the classpath.
    MathFace math = (MathFace) stub;
    ^
    5 errors
    Can u help me out ?

    You need to make sure the jax-rpc jar files are in your classpath when you invoke javac.

  • Can't compile client with client.jar

    I am unable to compile a static client using the standard client.jar produced by
    Weblogic. I am trying to do this in a minimal DOS environment as shown below:
    set PATH=d:\jdk1.3.1\bin
    set classpath=.;client.jar
    javac OssNodeWeblogicClient.java
    The compiler gives me the following error:
    client.jar(com/nyiso/oss/ossnode/OssNode.java):2:
    class OssNode is public, should be declared in a file named ossNode.java
    (source unavailable)
    1 error
    I was surprised to find two java files in client.jar (OssNode.java and OssNodeFactory.java).
    These files seem to confuse javac. If I remove these files from client.jar, the
    compilation completes without errors and the client runs without any problems.
    Has anyone seen this problem?

    Naresh,
    Just a quick follow-up. I used the -verbose option with
    javac and saw that when my compile failed, and I saw the same
    error message that you saw, javac was pulling the .java file
    from the jar file and trying to compile it. In the example I
    did that worked, the javac compiler was pulling the .class file
    from the jar file instead.
    Basically the javac compiler will fail trying to compile
    the .java file located in a jar file, probably because it can't
    write the .class file to the same (compressed) location. The
    reason that the javac compiler is trying to recompile the .java
    file, even though the .class file is also in the jar file, is
    that it has determined that the .java file is more up to date.
    So two questions for WebLogic:
    1) Why does WebLogic include the .java files in the jar
    file?
    2) Why doesn't the .java file match with the .class file?
    I'll let you know if/when I hear more. Rob
    "Naresh Bhatia" <[email protected]> wrote:
    >
    I am unable to compile a static client using the standard client.jar
    produced by
    Weblogic. I am trying to do this in a minimal DOS environment as shown
    below:
    set PATH=d:\jdk1.3.1\bin
    set classpath=.;client.jar
    javac OssNodeWeblogicClient.java
    The compiler gives me the following error:
    client.jar(com/nyiso/oss/ossnode/OssNode.java):2:
    class OssNode is public, should be declared in a file named ossNode.java
    (source unavailable)
    1 error
    I was surprised to find two java files in client.jar (OssNode.java and
    OssNodeFactory.java).
    These files seem to confuse javac. If I remove these files from client.jar,
    the
    compilation completes without errors and the client runs without any
    problems.
    Has anyone seen this problem?

  • Is there a working soulseek client for snow leopard ?  doesn't crash, pretty functional ?  can't compile nicotine, wont get a dock icon.

    is there a working soulseek client for snow leopard ?  doesn't crash, pretty functional ?  can't compile nicotine, wont get a dock icon.

    Try
    https://discussions.apple.com/community/mac_os/mac_os_x_technologies#/?tagSet=10 48

  • Migrating MS SQL 2005 to Oracle 9i  (sqlserver_utilities can't compile)

    The package sqlserver_utilities can’t compile. (SQLSERVER_UTILITIES Body Compiled (with errors) )
    I am migrating a MS SQL 2005 database to an Oracle 9i database. I have the following installed:
    •     Oracle 9i Enterprise Edition Release 9.2.0.1.0 –Production with the partitioning, Spatial, Olap, and Oracle data mining options.
    •     Internal to Oracle SQL Developer (client-only) 1.5.0.53.04
    •     JTDS JDBC Driver 11.4.4.53.01 oracle.sqldeveloper.thirdparty.drivers.sqlserver
    •     Java(TM) Platform 1.5.0_06
    The MS SQL 2005 Database consists out of multiple tables, views, stored procedures, functions and triggers. I tried quick migrate only to find that the migration failed.
    For a simple migration test I created a test database in MSQL 2005. This database has a simple table with an identity field and a store procedure that does an insert into the table. I followed all the steps to migrate a sql database and everything seemed to work. In Oracle I can now find the migrated table and stored procedure. I also see that the migration tool has created a sequence to deal with the identity field (in combination with a trigger) . when I try to execute the insert stored procedure in Oracle it fails. When I started looking at the log messages I see:
    INSERT INTO "DBO_STOREDPROCEDURETEST"."SOMEOTHERTABEL" (SOMEOTHERTABELTEXT, SOMEOTHERTABELCODE, VERYBASICTABLEID) VALUES ('sdfgsdfg', 'sdgfsdfg', '1')
    One error saving changes to table "DBO_STOREDPROCEDURETEST"."SOMEOTHERTABEL":
    Row 3: ORA-04068: existing state of packages has been discarded
    ORA-04063: has errors
    ORA-04063: package body "DBO_STOREDPROCEDURETEST.SQLSERVER_UTILITIES" has errors
    ORA-06508: PL/SQL: could not find program unit being called
    ORA-06512: at "DBO_STOREDPROCEDURETEST.SOMEOTHERTABEL_SOMEOTHERTABE_1", line 19
    ORA-04088: error during execution of trigger 'DBO_STOREDPROCEDURETEST.SOMEOTHERTABEL_SOMEOTHERTABE_1'
    ORA-06512: at line 1
    INSERT INTO "DBO_STOREDPROCEDURETEST"."SOMEOTHERTABEL" (SOMEOTHERTABELTEXT, SOMEOTHERTABELCODE, VERYBASICTABLEID) VALUES ('sadf', 'asfd', '1')
    One error saving changes to table "DBO_STOREDPROCEDURETEST"."SOMEOTHERTABEL":
    Row 3: ORA-04068: existing state of packages has been discarded
    ORA-04063: has errors
    ORA-04063: package body "DBO_STOREDPROCEDURETEST.SQLSERVER_UTILITIES" has errors
    ORA-06508: PL/SQL: could not find program unit being called
    ORA-06512: at "DBO_STOREDPROCEDURETEST.SOMEOTHERTABEL_SOMEOTHERTABE_1", line 19
    ORA-04088: error during execution of trigger 'DBO_STOREDPROCEDURETEST.SOMEOTHERTABEL_SOMEOTHERTABE_1'
    ORA-06512: at line 1
    I then noticed the sqlserver_utilities package compiled with errors. It seems that DBMS_DB_VERSION.VER_LE_9_2 and REGEXP_INSTR doesn’t exists. (see code beneath)
    -- only for 10g
    IF NOT DBMS_DB_VERSION.VER_LE_9_2 THEN
    IF REGEXP_INSTR(temp_exp,
    '^\{d[[:space:]]*''([[:digit:]]{4})-([[:digit:]]{2})-([[:digit:]]{2})''\}$') = 1 THEN -- ISO861 format
    -- e.g. {d '2004-05-23' }
    temp_exp := REGEXP_REPLACE(temp_exp,
    '^\{d[[:space:]]*''([[:digit:]]{4})-([[:digit:]]{2})-([[:digit:]]{2})''\}$',
    '\1-\2-\3');
    format_str := 'YYYY-MM-DD';
    Question 1: How do I solve this problem? (the oracle database must be Oracle 9i)
    Question 2: How can I migrate an MS SQL 2005 DB to oracle 9i ? (with views, triggers, stored procedures )
    Message was edited by:
    user640306

    Hi user640306,
    FUNCTION str_to_date(p_date_expr IN VARCHAR2)
    RETURN DATE
    has the 10g regexp code
    IF format_str IS NOT NULL THEN
    RETURN TO_DATE(temp_exp, format_str);
    ELSE
    RETURN TO_DATE(temp_exp, 'DD-MON-YYYY HH24:MI:SS');
    END IF;
    It defaults to 'DD-MON-YYY HH24:MI:SS' I suggest altering the code to suite how you want string to date to work in your locale.
    FUNCTION str_to_date(p_date_expr IN VARCHAR2)
    RETURN DATE
    IS
    temp_val NUMBER;
    temp_exp VARCHAR2(50);
    format_str VARCHAR2(50) := NULL;
    BEGIN
    IF p_date_expr IS NULL THEN
    RETURN NULL;
    END IF;
    temp_exp := TRIM(p_date_expr);
    -- only for 10g code removed this was trying
    -- to work out the date mask using regular expressions.
    IF format_str IS NOT NULL THEN
    RETURN TO_DATE(temp_exp, format_str);
    ELSE
    --If you use this code insert an appropriate data mask,
    --default is  'DD-MON-YYYY HH24:MI:SS'
    RETURN TO_DATE(temp_exp, 'DD-MON-YYYY HH24:MI:SS');
    END IF;
    EXCEPTION
    WHEN OTHERS THEN
    RETURN NULL;
    END str_to_date;
    -Turloch

  • How do I put text into an Edge File that clients can edit easily afterwards

    Hi
    Can anyone explain how I can put text into an edge file (styled with google fonts) and make it so that clients can access the text and update the text as they require?
    Previous suggestion was dynamically loading a .txt file - any instructions would be most appreciated.
    Thanks.

    Hi Resdesign!
    Your code is very useful to learn how to use Json in Adobe Edge Animate!
    But I have a question: why you use ( i ) as argument of the function UpdateInfo and when you recall it you use ( index )?
    $.getJSON('slides.json', function(data){
              //for(var i=0; i<data.length; i++){
    function updateInfo(i){
                        sym.$("photo").css({"background-image": "url('"+data[i].image+"')"});
                        sym.$("pillar").html(data[i].pillar);
                        sym.$("what").html(data[i].what);
                        // position
              index = -1;
              sym.$("btn").click(function(){
              index++;
                        if (index>=5){
                                  index = 0;
              updateInfo(index);
    Many thanks for your attention!
    Davide

  • Server 2003 VPN clients can't verify username and password

    Hi,
    Hoping someone can help or point me in the right direction. I have a Windows Server 2003 R2 standard SP2 running RRAS. It has Dual NIC's and is configured for PPTP VPN. I am using a BT Business Hub 5 for internet access and using the BT Static IP service.
    The BT Hub assigns the static IP address chosen to the Server using DHCP. The firewall is configured to port forward PPTP traffic to the 2003 server. This all works correctly.
    The 2003 server is on a domain where the DC is a 2008 R2 server. The DC also acts as the DNS and DHCP for the network.
    The default gateway for the domain is pointed towards our WinGate proxy server which also acts as a DNS server.
    The 2003 server LAN NIC is configured manually, usually I would not configure a deafult gateway on the LAN NIC as the WAN NIC needs the default gateway for the BT Hub.
    The problem I am having is if a default gateway is configured on the LAN NIC, I can connect to the VPN and it will logon to the network. Once connected everything works ok. If the connection drops, when trying to reconnect the client can no longer verify
    the user name and password against the domain and the connection is refused.
    If I do not have a default gateway configured in the LAN NIC the VPN clients can not verify the username and password for the domain at all and I get RPC failure errors in the event viewer with the source dnsapi.
    Once this error occurs the only way I can get the clients to reconnect is to disable the WAN NIC, restart the RRAS service and enable the WAN NIC again.
    Any insight will be much appreciated.

    Hello,
    for Networking configuration questions better ask in
    http://social.technet.microsoft.com/Forums/windowsserver/en-US/home#forum=winserverNIS&filter=alltypes&sort=lastpostdesc&content=Search
    Best regards
    Meinolf Weber
    MVP, MCP, MCTS
    Microsoft MVP - Directory Services
    My Blog: http://blogs.msmvps.com/MWeber
    Disclaimer: This posting is provided AS IS with no warranties or guarantees and confers no rights.
    Twitter:  

  • VPN Clients can't access internal LAN

    Hello - I have seen a few other threads on this issue, but can't seem to fix mine. I have a PIX 506e. My VPN clients can connect, they get a DHCP address from our internal server no problem. But the clients can not ping me or anything else on the LAN. The clients are connecting ipsec. I know I must be missing something simple here. Here is my config. Any help would be great

    Change the VPN Pool address to something else for example 192.168.10.0/24 etc. Then try and let me know. There could be ip overlap here.

  • VPN clients can't see network resources unless Firewall is disabled.

    If the firewall is turned off, connected VPN clients can access other PCs over the VPN. But I would like to enable a rule that allows them to access computers even with the firewall turned on. I just don't know what the rule should be.

    Hi,
    Any update? If you could update us at your convenience that would be wonderful.
    Regards
    Yolanda Zhu
    TechNet Community Support

  • 10.5: VPN clients can't connect to each other

    Hey all,
    I've got a bit of an odd problem. Got my VPN server setup and working fine on 10.5.4. Clients can connect in, mount file shares, etc. However, if we have multiple clients connected in via VPN, they can't connect to each other. They can't ping each other or anything. I've checked firewalls, etc, on the client machines, and everything looks fine.
    Machines within the network can ping and connect to them both, it's just when they're trying to connect to one another that the problem occurs. Any ideas why this might be, and any possible solutions?
    Thanks in advance,
    Paul

    OS X Server / VPN /The L2TP-VPN server did not respond

  • Intermittent Internet Connection and VPN clients can't ping internal LAN but connected after installating cisco ASA5512x

    Hi!
    I wish someone can help me on this, I'm a new guy on cisco firewalls and I'm currently implementing cisco asa 5512x, here are the details:
    ISP ->  Firewall -> Core switch -> Internal LAN
    after installing the cisco asa and terminating the appropriate lan for the outside and inside interfaces, internet seems intermittent and cisco vpn client can connect with internet connection but can't ping internal LAN.
    here's my configuration from my firewall.
    ASA Version 8.6(1)2
    hostname ciscofirewall
    enable password 2KFQnbNIdI.2KYOU encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface GigabitEthernet0/0
    nameif outside
    security-level 0
    ip address 203.x.x.x 255.255.255.0
    interface GigabitEthernet0/1
    nameif inside
    security-level 100
    ip address 10.152.11.15 255.255.255.0
    interface GigabitEthernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface GigabitEthernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface GigabitEthernet0/4
    shutdown
    no nameif
    no security-level
    no ip address
    interface GigabitEthernet0/5
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    management-only
    ftp mode passive
    dns domain-lookup outside
    dns domain-lookup inside
    dns server-group DefaultDNS
    name-server 4.2.2.2 -------> public DNS
    name-server 8.8.8.8 -------> public
    name-server 203.x.x.x   ----> Clients DNS
    name-server 203.x.x.x  -----> Clients DNS
    same-security-traffic permit intra-interface
    object network net_access
    subnet 10.0.0.0 255.0.0.0
    object network citrix_server
    host 10.152.11.21
    object network NETWORK_OBJ_10.10.10.0_28
    subnet 10.10.10.0 255.255.255.240
    object network NETWORK_OBJ_10.0.0.0_8
    subnet 10.0.0.0 255.0.0.0
    object network InterconHotel
    subnet 10.152.11.0 255.255.255.0
    access-list net_surf extended permit ip any any
    access-list net_surf extended permit ip object NETWORK_OBJ_10.10.10.0_28 object InterconHotel
    access-list outside_access extended permit tcp any object citrix_server eq www
    access-list outside_access extended permit ip object NETWORK_OBJ_10.10.10.0_28 any
    access-list outsidevpn_splitTunnelAcl standard permit 10.152.11.0 255.255.255.0
    access-list LAN_Users remark LAN_clients
    access-list LAN_Users standard permit any
    access-list vpnpool extended permit ip 10.10.10.0 255.255.255.248 any
    pager lines 24
    logging enable
    logging asdm informational
    mtu management 1500
    mtu outside 1500
    mtu inside 1500
    ip local pool vpnpool 10.10.10.1-10.10.10.6 mask 255.255.255.248
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    nat (inside,outside) source static NETWORK_OBJ_10.10.10.0_28 NETWORK_OBJ_10.10.10.0_28 destination static NETWORK_OBJ_10.10.10.0_28 NETWORK_OBJ_10.10.10.0_28 no-proxy-arp route-lookup
    object network net_access
    nat (inside,outside) dynamic interface
    object network citrix_server
    nat (inside,outside) static 203.177.18.234 service tcp www www
    object network NETWORK_OBJ_10.10.10.0_28
    nat (any,outside) dynamic interface
    object network InterconHotel
    nat (inside,outside) dynamic interface dns
    access-group outside_access in interface outside
    access-group net_surf out interface outside
    route outside 0.0.0.0 0.0.0.0 203.x.x.x 1
    route outside 10.10.10.0 255.255.255.248 10.152.11.15 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    aaa authentication telnet console LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 management
    http 10.0.0.100 255.255.255.255 inside
    http 10.10.10.0 255.255.255.240 outside
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto map inside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map inside_map interface inside
    crypto ikev1 enable outside
    crypto ikev1 enable inside
    crypto ikev1 policy 10
    authentication crack
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 20
    authentication rsa-sig
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 30
    authentication pre-share
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 40
    authentication crack
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 50
    authentication rsa-sig
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 60
    authentication pre-share
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 70
    authentication crack
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 80
    authentication rsa-sig
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 90
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 100
    authentication crack
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 110
    authentication rsa-sig
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 120
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 130
    authentication crack
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 140
    authentication rsa-sig
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 150
    authentication pre-share
    encryption des
    hash sha
    group 2
    lifetime 86400
    client-update enable
    telnet 10.152.11.0 255.255.255.0 inside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd address 192.168.1.2-192.168.1.254 management
    dhcpd enable management
    threat-detection basic-threat
    threat-detection statistics
    threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
    webvpn
    enable outside
    anyconnect-essentials
    group-policy outsidevpn internal
    group-policy outsidevpn attributes
    dns-server value 203.x.x.x 203.x.x.x
    vpn-tunnel-protocol ikev1 l2tp-ipsec ssl-client
    split-tunnel-policy tunnelall
    split-tunnel-network-list value outsidevpn_splitTunnelAcl
    default-domain value interconti.com
    address-pools value vpnpool
    username test1 password i1lji/GiOWB67bAs encrypted privilege 5
    username test1 attributes
    vpn-group-policy outsidevpn
    username mnlha password WlzjmENGEEZmT9LA encrypted
    username mnlha attributes
    vpn-group-policy outsidevpn
    username cisco password 3USUcOPFUiMCO4Jk encrypted privilege 15
    tunnel-group outsidevpn type remote-access
    tunnel-group outsidevpn general-attributes
    address-pool (inside) vpnpool
    address-pool vpnpool
    authentication-server-group (outside) LOCAL
    default-group-policy outsidevpn
    tunnel-group outsidevpn ipsec-attributes
    ikev1 pre-shared-key *****
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
      inspect icmp
      inspect http
      inspect ipsec-pass-thru
    class class-default
      user-statistics accounting
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    hpm topN enable
    Cryptochecksum:edc30dda08e5800fc35b72dd6e1d88d7
    : end
    thanks. please help.

    I think you should change your nat-exemption rule to smth more general, like
    nat (inside,outside) source static any any destination static NETWORK_OBJ_10.10.10.0_28  NETWORK_OBJ_10.10.10.0_28 no-proxy-arp route-lookup
    'cause your inside networks are not the same as your vpn-pool subnet.
    Plus, if you're trying to reach inside subnets, different from 10.152.11.0 255.255.255.0 (ip from wich subnet is assignet to your inside interface, and for wich above nat exception should be enough), you should check if routing is configured from that subnets to your vpn-pool-subnet through the ASA.

  • Vpn client can access internet but cannot access internal network

    I am using PIX 501 to setup a VPN. At first the VPN client cannot access the internet once they logged in via the Cisco system vpn client, so i enable split tunneling. Now the VPN client can access the internet but they can't access the internal network.Due to the limited characters can be posted here, only necessary IOS coding is posted on the next message. Who knows how to solve this problem? Pls Help.....

    enable password ********** encrypted
    passwd ********** encrypted
    hostname Firewall
    domain-name aqswdefrgt.com.sg
    access-list 100 permit ip 192.168.1.0 255.255.255.0 192.168.50.0 255.255.255.0
    access-list nat permit tcp any host 65.165.123.142 eq smtp
    access-list nat permit tcp any host 65.165.123.142 eq pop3
    access-list nat permit tcp any host 65.165.123.143 eq smtp
    access-list nat permit tcp any host 65.165.123.143 eq pop3
    access-list nat permit tcp any host 65.165.123.143 eq www
    access-list nat permit tcp any host 65.165.123.152 eq smtp
    access-list nat permit tcp any host 65.165.123.152 eq pop3
    access-list nat permit tcp any host 65.165.123.152 eq www
    access-list nat permit tcp any host 65.165.123.143 eq https
    access-list nat permit icmp any any
    ip address outside 65.165.123.4 255.255.255.240
    ip address inside 192.168.1.2 255.255.255.0
    ip verify reverse-path interface outside
    ip local pool clientpool 192.168.50.1-192.168.50.50
    global (outside) 1 interface
    nat (inside) 0 access-list 100
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) tcp 65.165.123.142 smtp 192.168.1.56 smtp netmask 255.255.2
    55.255 0 0
    static (inside,outside) tcp 65.165.123.142 pop3 192.168.1.56 pop3 netmask 255.255.2
    55.255 0 0
    static (inside,outside) tcp 65.165.123.143 smtp 192.168.1.55 smtp netmask 255.255.2
    55.255 0 0
    static (inside,outside) tcp 65.165.123.143 pop3 192.168.1.55 pop3 netmask 255.255.2
    55.255 0 0
    static (inside,outside) tcp 65.165.123.143 www 192.168.1.55 www netmask 255.255.255
    .255 0 0
    static (inside,outside) tcp 65.165.123.152 smtp 192.168.1.76 smtp netmask 255.255.
    255.255 0 0
    static (inside,outside) tcp 65.165.123.152 pop3 192.168.1.76 pop3 netmask 255.255.
    255.255 0 0
    static (inside,outside) tcp 65.165.123.152 www 192.168.1.76 www netmask 255.255.25
    5.255 0 0
    static (inside,outside) tcp 65.165.123.143 https 192.168.1.55 https netmask 255.255
    .255.255 0 0
    access-group nat in interface outside
    route outside 0.0.0.0 0.0.0.0 65.165.123.1 1
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    aaa-server plexus protocol radius
    aaa-server plexus (inside) host 192.168.1.55 ******** timeout 5
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set myset esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto dynamic-map cisco 1 set transform-set myset
    crypto map dyn-map 20 ipsec-isakmp dynamic cisco
    crypto map dyn-map client authentication plexus
    crypto map dyn-map interface outside
    isakmp enable outside
    isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    isakmp policy 40 authentication pre-share
    isakmp policy 40 encryption 3des
    isakmp policy 40 hash md5
    isakmp policy 40 group 2
    isakmp policy 40 lifetime 86400
    vpngroup vpn3000 address-pool clientpool
    vpngroup vpn3000 dns-server 192.168.1.55
    vpngroup vpn3000 wins-server 192.168.1.55
    vpngroup vpn3000 default-domain aqswdefrgt.com.sg
    vpngroup vpn3000 idle-time 1800
    vpngroup vpn3000 password ********
    telnet 192.168.1.0 255.255.255.0 inside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    terminal width 80

  • How do I make it so my client can edit Links in business catalyst when they create new pages?

    Okay so essentially I have built a site in Muse uploaded to business catalyst and I've setup a site template so that the client can create new pages as each new course arrives, but how do I get the link from the homepage to link to the new page? basically I need the link to be editable.
    What would be ideal is a kind of portfolio layout where there is a thumbnail and a new page but for my client to be able to add a new project adn it would create a thumbnail on the homepage and a new page that he can edit. Does anyone know of something like that possible in Business catalyst?

    Hi
    Editing with Business Catalyst only works with image or text editing , we cannot add new page or page items using in browser editing.
    However, you can manage the site from BC end when your client and login to admin and add pages, modify etc, but if you re-publish the site from Muse then then changes will be overwritten.
    Thanks,
    Sanjit

  • How do I create an interactive pdf form my clients can actually use?

    In the new CS6 Indesign (which is very easy to use to make forms) I've gone through all the steps to make a beautiful form whose buttons, text fields, and hyperlinks all work (great!) but now I've stumbled across one VITAL problem: the submit form button does not work!
    I’ve set it up as I’ve seen it done on videos, as a “submit form” type, with the address “mailto: emailaddress.”
    Once I exported the file to a pdf interactive form, my "Print form" button works well, and I though I'd fixed the problem when I downloaded adobe reader to read my form, however, no matter what type of computer I use with it, when I hit the "submit form" button, a message saying something to the effect of “you must open in your browser” pops up.
    When dragged the pdf document into my browser like the message suggested, not only did the “submit form” button still not work, but now I cannot interact with any of the buttons or fields!
    My goal here is simple: make an interactive form my clients can access online (whether as a downloadable pdf or directly on my website) that they can fill out and submit to us directly to our email.  As many of our clients are older, I’d like to make it as easy as possible for them to use our system, and be able to just hit the “submit form” button instead of having to go through the trouble of attaching the finished pdf they filled out to an email and submitting to us.
    All the videos I’ve come across so far talk about how to MAKE these forms, but not how to set them up to be used realistically for a business.  Any help I can have would be appreciated, I don’t mind so much how this gets done, as long as it is easy for my clients to access the form and fill it out easily and quickly. 
    Thank you in advance,
    ~Kara
    Swentowsky Photography

    Yes, this is the page that the pdf is on.  It's the link that says "Online Ordering Form."
    http://swentowskyphotography.com/Site/reunion-order.html

  • As a Verizon FIOS client, can we just use Ethernet cable to connect to time capsule, or do we need their router to connect to the time capsule?

    As a Verizon FIOS client, can we just use Ethernet cable to connect to time capsule or do we need the Verizon router to connect to time capsule?

    The Time Capsule is indeed a wireless router with simultaneous dual band capability...and a hard drive for backup purposes. You can use that to your advantage if you configure the Time Capsule as I suggested in Bridge Mode.
    The Time Capsule will provide a 802.11n 5 GHz band and a 802.11n/g/b compatible 2.4 GHz band to allow virtually any device to connect to the network.
    I suppose that you could also use the "g" wireless network provided by the Verizon router as a "guest" network or something similar if you really do need another wireless network.
    It might be possible to configure the Time Capsule as the main router on the network....that's a question for Verizon. But even if you might be able to do this, I'm sure it is not supported by Verizon, so you would be on your own in the event of any Internet connection difficulties on your service.
    And, since the Time Capsule does not have a built in modem....you would still need to add a separate modem to the installation anyway.
    That's why my suggestion is to use the Verizon device as the "modem" and let the Time Capsule provide the dual band wireless network and of course, handle the Time Machine backups.

Maybe you are looking for