Client Side Converter Event Configuration

Hi
well I set my converter faces-config.xml file format in good think my java file and also my javascript file. My algorithm should give the format conversion ##,###. 00 and when you click on the inputText commas should be removed and leave only the number but the editing function that is in the JavaScript file does not work because not how to implement the structure and getAsObject getAsString converter. In another project and simply added a ClientListener FOCUS will set the event and it worked but with the ClientConverter not know how to do the same feature.
Thanks
Edmar

Thanks Frank
I saw the example I implement it but not like I can add an event FOCUS within the structure of the converter.
Thanks

Similar Messages

  • Client side event for h:outputText... and other JSF component

    Hello friends...
    I need client side (to use Java script ) event for change in <h:outputText /> or <h:inputText...>.
    I want to open a popup window when there is a change in there. I donot want to use onblur() for this. Is there any thing for achiev it.
    Thanks.
    Regard
    Roshan Lal ( I don't know why there is "DOG" display in LIST )
    :-)

    Hi Jacek,
    Unfortunately I think you may be stuck extending Renderer. Another possibility is creating your component via a template, which will be available in JSF 2.0. However, as JSF 2.0 won't be out for a while... you can use JSFTemplating in the meantime:
    http://java.sun.com/developer/technicalArticles/J2EE/jsf_templating/
    http://www.theserverside.com/tt/articles/article.tss?l=JSFTemplateComponent
    Good luck!
    Ken Paulsen
    https://jsftemplating.dev.java.net

  • Client side eventing with HTMLB in a jsp file

    Hi All,
    Can u give me the solution to work with client side eventing with HTMLB with a jsp page but not with a dynpage.
    Regards,
    sireesha.

    Hi sireesha,
      Check this.
    <%@ taglib uri="tagLib" prefix="hbj" %>
    <%@ page import="com.sapportals.htmlb.enum.EventTrigger,com.sapportals.htmlb.event.Event" %>
    <hbj:content id="myContext" >
    <hbj:page title="PageTitle">
    <script language="Javascript">
    function checkinput(){
         var funcName = htmlb_formid+"_getHtmlbElementId";
         func = window[funcName];
         var inputfield1 = eval(func("inf1"));
         var input1 = inputfield1.getValue();
         if (input1==""){
              alert("Enter mandatory fields");
    </script>
    <hbj:form>
    <hbj:textView id="tv1" text="Name"/>
    <hbj:inputField id="inf1"
    type="String"
    required="true"
    jsObjectNeeded="true">
    <% inf1.setClientEvent(EventTrigger.ON_BLUR, "checkinput()"); %>
    </hbj:inputField>
    <br>
    <hbj:textView id="tv2" text="City"/>
    <hbj:inputField id="inf2" type="String"/>
    <hbj:button id="b1" text ="submit" onClick="onSubmitclicked"/>
    </hbj:form>
    </hbj:page>
    </hbj:content>
    Regards,
    Harini S

  • Client Side Eventing

    Hi,
    I have 2 seperate iviews, iView1 and iView2. I would like to make a call to the backend database using JCO and pass the ResultSet to iView2. In iView2 format the data and display in a tableview.
    Is it possible to pass a Resultset using Clientside Eventing from iView1 to iView2.
    To achieve this would it be best to use Client Side Eventing or Session Beans.
    Any advice would be appreciated.
    Thank you
    NAC

    Hi NAC,
    I already answered your question in two iviews calling each other on a single page?
    If it isn't clear, please ask precise what you didn't understand...
    Best regards
    Detlev

  • Client side configuration

    Hi Everybody,
    Thanks to all of the oracle experts.
    We installed oracle 10.2 RAc database on the server side using 2 nodes on solaris 10.
    Raw devices are used for clusterware installation.
    ASM is configured for database shared files.
    Now i want to configure on the client side as they should be able to connect to this database.
    would anybody kindly provide me how to do this.
    i am in very need of it.
    thanks and regards
    suresh

    You need to install Oracle Software Client and configure tnsnames.ora with something like
    ORCLTEST =
    (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = oraclerac1vip)(PORT = 1521))
    (ADDRESS = (PROTOCOL = TCP)(HOST = oraclerac2vip)(PORT = 1521))
    (LOAD_BALANCE = yes)
    (CONNECT_DATA =
    (SERVER = DEDICATED)
    (SERVICE_NAME = orcl)
    (FAILOVER_MODE =
    (TYPE = SELECT)
    (METHOD = BASIC)
    (RETRIES = 180)
    (DELAY = 5)
    You must view oraclerac1vip and oraclerac2vip using DNS or you add this host to host table.
    Regards.
    Angel

  • Tab Strip Selection - Client Side Eventing

    Hello All,
    I have one tab strip with 5 tab strip item. Inside 1st tab strip I have one htmlb button and I want to trigger 2nd tab strip item while I am clicking the 1st tab strip buttonu2019s client side event.
    Is it Possible?
    I need Sample Code!
    Note: JspDynPage Client Side Event of Htmlb Button.

    Hi,
    Mainly tab strip utilized for random selection.
    So i Closed this Thread.
    Thank You,
    Devasarathy Pandi.

  • EPCF Client Side Eventing

    Hello,
    I have been working on some EPCF client side eventing examples. I found the example by Dr. Ron Hendrickx at the following URL.
    https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/com.sapportals.km.docs/documents/a1-8-4/iview client side eventing with the epcf toolbox service
    So, I imported the .par to Eclipse, I then changed the code so that the sender is a tree holding URL's and the receiver displays them in an IsolatedHtmlContainer and got it working fine.
    My problem is this, when I start a new project in Eclipse and copy/paste the code, properties files, the .classpath and .project files (everything) the IClientEventReceiver isReceived() event is never triggered. The doProcessBeforeOutput() method in the receiver is called but the event is not triggered. Seriously, we have copy/pasted everything exactly, the .par file created is identical in structure to Dr. Hendrick's and yet if I create a new project and make all the files it doesn't work. Only when I work with the .par imported from Dr. Hendrickx's work will the example work. We're thinking maybe some environment variable somewhere is causing this but we've copied the .classpath file, everything is exactly the same but the event will not be received in a project we create ourselves.
    Really, any help with this will be well appreciated.
    David.

    Pumped isolation method is sort of a combination of embedded and URL isolated.  The portal server is used to fetch the content from the website/application.  When the data is ready, it is "pumped" into the browser using an IFRAME tag and an XML based data stream.  This give you the ability to cache the data on the portal server, but get the flexibility of isolated iViews.
    However, we will plan to drop this functionality in the future and "pumped" iviews will automatically be treated as "URL isolated" iviews.

  • Client Side Event

    How can we achieve client side evemting in webdynpro applications?
    Regards
    DS.

    Refer to the thread below:
    http://help.sap.com/saphelp_nw2004s/helpdata/en/5d/08f43cf1da7646a2b210a16321c669/frameset.htm
    https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/d48eaa90-0201-0010-58a8-887fc8632c3c
    How to use EPCF eventing in Webdynpro
    Should be helpful.

  • How can I convert client-side Shared Object in server-side Shared Object?

    Hello world....
    I have a problem...
    I have a program that uses client-side shared Object, like the Example "Ball" il the FMS 3.5 guide: I can move a ball around the stage...
    I need to convert this program so I can use server side shared object. This is because I can load the .swf to another .swf and I must to be able to reset, or delete, the properties of my shared object. With client-side sahred object I can't delete or reset the shared object after I loaded my external .swf....
    My script is:
    private var pointer1_so:SharedObject;
    nc=new NetConnection  ;
    nc.connect (rtmpNow);
    nc.addEventListener (NetStatusEvent.NET_STATUS,doSO);
    Cerchio=new cerchio ;
    addChild (Cerchio);
    Cerchio.x=220;
    Cerchio.y=280;
    Cerchio.addEventListener (MouseEvent.MOUSE_DOWN,beginDrag1);
    Cerchio.addEventListener (MouseEvent.MOUSE_UP,endDrag1);
    private function doSO (e:NetStatusEvent):void
                 good=e.info.code == "NetConnection.Connect.Success";
                 if (good)
                       //Shared object
                       pointer1_so=SharedObject.getRemote("point1",nc.uri,false);
                       pointer1_so.connect (nc);
                       pointer1_so.addEventListener (SyncEvent.SYNC,doUpdate1);
    private function doUpdate1 (se:SyncEvent):void
                 for (var cl1:uint; cl1 < se.changeList.length; cl1++)
                       trace(se.changeList[cl1].code);
                       if (se.changeList[cl1].code == "change")
                            switch (se.changeList[cl1].name)
                                 case "xpos" :
                                       Cerchio.x=pointer1_so.data.xpos;
                                       break;
                                 case "ypos" :
                                       Cerchio.y=pointer1_so.data.ypos;
                                       break;
    private function beginDrag1 (e:MouseEvent)
                     Cerchio.addEventListener (MouseEvent.MOUSE_MOVE,moveMc1);
                     Cerchio.startDrag (false,Rect1);
    private function endDrag1 (e:MouseEvent)
                     Cerchio.stopDrag ();
    private function moveMc1 (e:MouseEvent)
                e.updateAfterEvent ();
                   pointer1_so.setProperty ("xpos",Cerchio.x);
                   pointer1_so.setProperty ("ypos",Cerchio.y);
    Can someone helps me?
    I know I need of a server side script but...
    Please...
    Emiliano.

    ResultSet is not serializable. It is an active connection. If you wish to serialize the info, then read it into an ArrayList in your serializable class and pass the Data that way.

  • Configure client side security polise for RMI

    Hi all!
    How to configure client side security if I want to use applet and RMI on the single
    computer.
    I was editing . java.policy file:
    grant {
    // added to allow RMI/JMS
    permission java.io.SerializablePermission "enableSubstitution";
    permission java.lang.RuntimePermission "setContextClassLoader";
    But I have MarshalException if I want to make a call from one
    Java VM to another.
    Regards,
    Pavel.

    Which version WLS are you using? In the latest versions of WLS 6.0 you need
    not give these extra permissions for the applets.This is taken care in the
    server itself. You can contact support for the patch.
    ..maruthi
    "Pavel" <[email protected]> wrote in message
    news:3bc7d744$[email protected]..
    >
    Hi all!
    How to configure client side security if I want to use applet and RMI onthe single
    computer.
    I was editing . java.policy file:
    grant {
    // added to allow RMI/JMS
    permission java.io.SerializablePermission "enableSubstitution";
    permission java.lang.RuntimePermission "setContextClassLoader";
    But I have MarshalException if I want to make a call from one
    Java VM to another.
    Regards,
    Pavel.

  • Do I need to configure UBBCONFIG if I'm Developing Client side only

    Hello Tuxedo Experts,
    I have successfully run the simplest of Tuxedo sampes (simpapp) after a lot of effort and issues.
    I have to develop Tuxedo Client Only for a Tuxedo Server running in client environment. I have already written client code in C.
    I want to know, what things do I need to get/know to be able to successfully run the client application. If I am making just the client on my side, Do I still create the UBBCONFIG file? Wouldn't the server already have UBBCONFIG file created on server side?
    If I have to create the UBBCONFIG, what parameters are server related information that I should ask for, from client.
    Any other things (environment variables, other bits) that I need to take from tuxedo server side team (client).
    Thanks & Regards,
    Ahsan

    Hello Todd/Venkat/Tuxedo Experts,
    I wanted to clarify the part that says: "You will also need to add the WSL to the UBBCONFIG file and recompile UBBCONFIG."
    I am guessing this means adding a WSL entry in UBBCONFIG file of Tuxedo Server since (I have been told in Venkat's post that) UBBCONFIG/tuxconfig file is not required on client side of tuxedo. Am I right in saying that client will have no UBBCONFIG and tuxconfig, while server UBBCONFIG has to have appropriate WSL entry?
    Btw, if I look at the ubbconfig of simpapp, it has no WSL entry. It does have the following server details though:
    ==============================
    DOMAINID simpapp
    MASTER DevnonAOMapp
    DevnonAOMapp LMID=DevnonAOMapp
    *GROUPS
    GROUP1
    LMID=DevnonAOMapp GRPNO=1 OPENINFO=NONE
    *SERVERS
    DEFAULT:
    CLOPT="-A"
    simpserv SRVGRP=GROUP1 SRVID=1
    *SERVICES
    TOUPPER
    ==============================
    Where will the WSL entry fit and what would it look like?
    Thanks & Regards,
    Ahsan

  • Printing multiple PDF with single event at client side

    Hello,
    I have a requirement where I must print multiple different pre-populated Adobe forms (e.g. populated with a name/address) from ABAP WD. These need to be printed at a client side printer, and they don't want to see them first (that would be easy). Just print multiple forms from a single button click.
    Has anyone had this requirement? My main question is not how to pre-populate the pdfSource, but how to have the user prompted for a printer 1x and then have the forms sent straight to the local printer without displaying.
    Thanks!

    Sorry to 'hijack' this thread but i was trying to do the same thing but failed EVERYTIME!!!
    When i tried to merge just 2 multiple-paged(abt 20+ pages each) pdfs into one, it simply crashed Preview at the end of the process! Tried 'Save', 'Save all' & 'Print as PDF' but all doesn't work!
    I tried Combine PDF.app & Automator.app and the same thing happened. The combining process CRASHED the app i used...
    Help needed!

  • The Group Policy client-side extension Scripts failed ...

    This is an error I've been seeing forever and it was always the impression that upgrading would resolve it, but it never has even in 10.3. 100% of our users get these errors in the Event Viewer:
    Event Type: Error
    Event Source: Userenv
    Event Category: None
    Event ID: 1085
    Date: 10/21/2010
    Time: 8:04:52 AM
    User: NT AUTHORITY\SYSTEM
    Computer: XXXXXX
    Description:
    The Group Policy client-side extension Scripts failed to execute. Please look for any errors reported earlier by that extension.
    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    We also seem to have flakey policy issues where once in awhile a user will not be able to logon to Windows with Workstation Only while getting the " not allowed to logon interactively" message, other times the users report not being able to access the Windows Date and Time Properties and further sometimes they are unable to make system changes.
    We have troubleshooted this and the only resolutions we've found are to run zac cc, zac ref, zac pl and sometimes it seems like deleting c:\windows\system32\grouppolicy will help.
    In regards to the Event Viewer entry I posted, on any given machine I can issue the command gpupdate and it will put another entry into the Event Viewer (sometimes multiple ones). I've learned through research that if I "clean up" c:\windows\system32\grouppolicy\gpt.ini the errors go away, but once the policy is refreshed they come right back.
    This is the version ZenWorks gives the users:
    [General]
    gPCFunctionalityVersion=2
    gPCFunctionalityVersion=2
    gPCMachineExtensionNames=[{35378EAC-683F-11D2-A89A-00C04FBBCFA2}{0F6B957D-509E-11D1-A7CC-0000F87571E3}][{3610EDA5-77EF-11D2-8DC5-00C04FA31A66}{0F6B957D-509E-11D1-A7CC-0000F87571E3}][{42B5FAAE-6536-11D2-AE5A-0000F87571E3}{40B6664F-4972-11D1-A7CA-0000F87571E3}][{4CFB60C1-FAA6-47F1-89AA-0B18730C9FD3}{0F6B957D-509E-11D1-A7CC-0000F87571E3}][{827D319E-6EAC-11D2-A4EA-00C04F79F83A}{803E14A0-B4FB-11D0-A0D0-00A0C90F574B}]
    Version=6488106
    gPCUserExtensionNames=[{35378EAC-683F-11D2-A89A-00C04FBBCFA2}{0F6B957E-509E-11D1-A7CC-0000F87571E3}][{42B5FAAE-6536-11D2-AE5A-0000F87571E3}{40B66650-4972-11D1-A7CA-0000F87571E3}][{4CFB60C1-FAA6-47F1-89AA-0B18730C9FD3}{0F6B957E-509E-11D1-A7CC-0000F87571E3}][{A2E30F80-D7DE-11D2-BBDE-00C04F86AE3B}{FC715823-C5FB-11D1-9EEF-00A0C90347FF}]
    This is the version I cleaned up:
    [General]
    gPCFunctionalityVersion=2
    gPCUserExtensionNames=[{35378EAC-683F-11D2-A89A-00C04FBBCFA2}{0F6B957E-509E-11D1-A7CC-0000F87571E3}][{4CFB60C1-FAA6-47F1-89AA-0B18730C9FD3}{0F6B957E-509E-11D1-A7CC-0000F87571E3}][{A2E30F80-D7DE-11D2-BBDE-00C04F86AE3B}{FC715823-C5FB-11D1-9EEF-00A0C90347FF}]
    gPCUserExtensionNames=[{35378EAC-683F-11D2-A89A-00C04FBBCFA2}{0F6B957E-509E-11D1-A7CC-0000F87571E3}][{A2E30F80-D7DE-11D2-BBDE-00C04F86AE3B}{FC715823-C5FB-11D1-9EEF-00A0C90347FF}]
    I'm not sure how to get Zenworks to use the cleaned up version nor and I too sure what those extra extensions are and how they got in there. I may need to contact Novell in regards to this, but since I'm already working on an SR with them I figured I'd go ahead and post here first.
    Any help or advice would be greatly appreciated.

    Here are the groups I'm using. NOTE: These have been in affect throughout the issues experienced. Users will work perfectly fine then suddenly the problem will start happening without any policy change on our side.
    -Member of-
    Network Configuration Operators+
    Remote Desktop Users+
    Users+
    -Assigned Rights under a group I called "Other Rights"-
    Access this computer from network
    Change the system time
    Log on locally
    Shut down the system
    The only condition I have is that these issues happen when logging in Workstation Only and I'm not able to recreate the problem on demand with tests.
    Originally Posted by craig_wilson
    The "Interactive Logon" is a Windows Security Permission.
    It is generally assigned to certain local groups such as "User".
    Which groups are assigned this right can be changed manually and
    controlled by local security policies.
    When user's get this error, it generally means their account is not in a
    local group that has been assigned that right.
    If using "DLU", make sure the user accounts are a member of "Users".
    And If anyone was messing with security policies, make sure they did not
    take away "Interactive Logons" from anyone.
    On 10/29/2010 7:06 AM, jcsmith1 wrote:
    >
    > Thanks for replying craig.
    >
    > My policy woes have only grown since my first post. We are currently
    > testing the removal of administrative rights and now we're having
    > teleworkers (who login Workstation Only) getting the message "policy
    > does not allow interactive login". What -seems- to fix it is a zac cc,
    > zac ref and zac pl, however we just started getting call backs from
    > users.
    >
    > I seem to have no further leads and Novell's ZenWorks tech supports
    > seems to be going through some kind of painful-to-the-customer
    > transition as one of my thoughts on resolving the issue is to go to 10.3
    > or 10.3.1, but my Satellites appear to be upgrading but in reality do
    > not upgrade (but the primary servers upgraded) (See SR 10655976331).
    >
    > Does anyone knows how to troubleshoot policy issues when the users
    > aren't loggin into ZCM?
    >
    > craig_wilson;2036646 Wrote:
    >> See: 'Group Policy Error: The Group Policy client-side extension Script
    >> failed to execute.'
    >> (Group Policy Error: The Group Policy client-side extension Script failed to execute.)
    >>
    >> This would never be fixed in any patch, since it would be the job of
    >> GPEDIT to properly maintain the GPT.INI.
    >>
    >> Most of the Time these errors are cosmetic and caused by stray script
    >> extensions.
    >>
    >> You may want to create an Enhancement Request to allow the creation of
    >> "Filters" so certain errors are discarded and not sent to the DB/ZCC.
    >> This way an Admin could choose to filter out various error messages
    >> that
    >> they deem are not actually of concern.
    >>
    >> On 10/21/2010 9:36 AM, jcsmith1 wrote:
    >>>
    >>> This is an error I've been seeing forever and it was always the
    >>> impression that upgrading would resolve it, but it never has even in
    >>> 10.3. 100% of our users get these errors in the Event Viewer:
    >>>
    >>> -Event Type: Error
    >>> Event Source: Userenv
    >>> Event Category: None
    >>> Event ID: 1085
    >>> Date: 10/21/2010
    >>> Time: 8:04:52 AM
    >>> User: NT AUTHORITY\SYSTEM
    >>> Computer: XXXXXX
    >>> Description:
    >>> The Group Policy client-side extension Scripts failed to execute.
    >>> Please look for any errors reported earlier by that extension.
    >>>
    >>> For more information, see Help and Support Center at
    >>> http://go.microsoft.com/fwlink/events.asp.
    >>> -
    >>> We also seem to have flakey policy issues where once in awhile a
    >> user
    >>> will not be able to logon to Windows with Workstation Only while
    >> getting
    >>> the " not allowed to logon interactively" message, other times the
    >> users
    >>> report not being able to access the Windows Date and Time Properties
    >> and
    >>> further sometimes they are unable to make system changes.
    >>>
    >>> We have troubleshooted this and the only resolutions we've found are
    >> to
    >>> run zac cc, zac ref, zac pl and sometimes it seems like deleting
    >>> c:\windows\system32\grouppolicy will help.
    >>>
    >>> In regards to the Event Viewer entry I posted, on any given machine
    >> I
    >>> can issue the command gpupdate and it will put another entry into
    >> the
    >>> Event Viewer (sometimes multiple ones). I've learned through
    >> research
    >>> that if I "clean up" c:\windows\system32\grouppolicy\gpt.ini the
    >> errors
    >>> go away, but once the policy is refreshed they come right back.
    >>>
    >>> This is the version ZenWorks gives the users:
    >>>> [General]
    >>>> gPCFunctionalityVersion=2
    >>>> gPCFunctionalityVersion=2
    >>>>
    >> gPCMachineExtensionNames=[{35378EAC-683F-11D2-A89A-00C04FBBCFA2}{0F6B957D-509E-11D1-A7CC-0000F87571E3}][{3610EDA5-77EF-11D2-8DC5-00C04FA31A66}{0F6B957D-509E-11D1-A7CC-0000F87571E3}][{42B5FAAE-6536-11D2-AE5A-0000F87571E3}{40B6664F-4972-11D1-A7CA-0000F87571E3}][{4CFB60C1-FAA6-47F1-89AA-0B18730C9FD3}{0F6B957D-509E-11D1-A7CC-0000F87571E3}][{827D319E-6EAC-11D2-A4EA-00C04F79F83A}{803E14A0-B4FB-11D0-A0D0-00A0C90F574B}]
    >>>> Version=6488106
    >>>>
    >> gPCUserExtensionNames=[{35378EAC-683F-11D2-A89A-00C04FBBCFA2}{0F6B957E-509E-11D1-A7CC-0000F87571E3}][{42B5FAAE-6536-11D2-AE5A-0000F87571E3}{40B66650-4972-11D1-A7CA-0000F87571E3}][{4CFB60C1-FAA6-47F1-89AA-0B18730C9FD3}{0F6B957E-509E-11D1-A7CC-0000F87571E3}][{A2E30F80-D7DE-11D2-BBDE-00C04F86AE3B}{FC715823-C5FB-11D1-9EEF-00A0C90347FF}]
    >>>>
    >>>>
    >>>
    >>> This is the version I cleaned up:
    >>>> [General]
    >>>> gPCFunctionalityVersion=2
    >>>>
    >> gPCUserExtensionNames=[{35378EAC-683F-11D2-A89A-00C04FBBCFA2}{0F6B957E-509E-11D1-A7CC-0000F87571E3}][{4CFB60C1-FAA6-47F1-89AA-0B18730C9FD3}{0F6B957E-509E-11D1-A7CC-0000F87571E3}][{A2E30F80-D7DE-11D2-BBDE-00C04F86AE3B}{FC715823-C5FB-11D1-9EEF-00A0C90347FF}]
    >>>>
    >> gPCUserExtensionNames=[{35378EAC-683F-11D2-A89A-00C04FBBCFA2}{0F6B957E-509E-11D1-A7CC-0000F87571E3}][{A2E30F80-D7DE-11D2-BBDE-00C04F86AE3B}{FC715823-C5FB-11D1-9EEF-00A0C90347FF}]
    >>>>
    >>>>
    >>>
    >>> I'm not sure how to get Zenworks to use the cleaned up version nor
    >> and
    >>> I too sure what those extra extensions are and how they got in there.
    >> I
    >>> may need to contact Novell in regards to this, but since I'm already
    >>> working on an SR with them I figured I'd go ahead and post here
    >> first.
    >>>
    >>> Any help or advice would be greatly appreciated.
    >>>
    >>>
    >>
    >>
    >> --
    >> Craig Wilson - MCNE, MCSE, CCNA
    >> Novell Knowledge Partner
    >>
    >> Novell does not officially monitor these forums.
    >>
    >> Suggestions/Opinions/Statements made by me are solely my own.
    >> These thoughts may not be shared by either Novell or any rational
    >> human.
    >
    >
    Craig Wilson - MCNE, MCSE, CCNA
    Novell Knowledge Partner
    Novell does not officially monitor these forums.
    Suggestions/Opinions/Statements made by me are solely my own.
    These thoughts may not be shared by either Novell or any rational human.

  • XSL Fragment into HTML via Client-Side Transform

    I am designing a site for a school. I searched and found the
    post here from July 25, and I have also read the Dreamweaver
    help file till I'm blue in the face. They talk all around the
    answer but never definitively say if it's possible to do this.
    Dreamweaver help mentions:
    -- Workflow for performting client-side xsl transformations
    Do one of the following:
    In your Dreamweaver site, create an entire XSLT page. See
    Creating entire XSLT pages.
    Convert an existing HTML page to an entire XSLT page. See
    Converting HTML pages to XSLT pages.
    All the online tutorials show server-side transforms but I'm
    not skilled in that...nor do I know if the hosting entity will
    provide that level of access to their .NET server.
    ---- ok. that's the background of the situation. Now to my
    problem. ---
    We plan to have two mutually exclusive areas on the home
    page, such as news & events, that will be updated by a single
    school employee. The plan is to create two XML text files that one
    teacher can update.
    The XMLfiles will be manually uploaded to the web site and
    the home page will read that data into properly formatted
    information on the home page. I would greatly prefer to keep the
    entire process as a client-side procedure.
    I have created and linked XSL fragments to the XML data.
    If I try to copy and paste code from the XSL fragment into
    the index HTML page, I get nothing.
    Success comes only after converting the home page into an
    XSLT 1.0 file using Dreamweaver and copying and pasting the code
    fromt he XSL file into the newly created XSLT file.
    Hence my questions:
    1 Can I bring these XSL fragments into an HTML home page or
    do I have to convert it to XSLT?
    2. If I must convert the HTML file to an XSLT file, can
    people still type the website address in as www dot site dot com
    and the XSLT file will open without anyone knowing the difference?
    3. Can I even do this with a client-side transform?
    4. Is it possible for one page to reference two separate XSL
    fragments pointing to the two separate respective XML files?
    Thank you very much for your help.

    Hi Eric,
    these are the cache control headers of the request that serves the XSLT:
    GET http://www.carsten-leue.de/test/iframe_xslt/xslt.php HTTP/1.1
    Accept: */*
    Referer: http://www.carsten-leue.de/test/iframe_xslt/xslt.php
    Accept-Encoding: gzip, deflate
    User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko
    Host: www.carsten-leue.de
    DNT: 1
    Connection: Keep-Alive
    There does not seem to be a header involved that prevents caching.
    You mention the "legacy ActiveX" control. In which sense is this control involved in the usecase? In my scenario I am pointing the browser to the XML document that has an associated stylesheet and the browser automatically executes the transform.
    I am not explicitly triggering the transform via some script in the page.
    Does the ActiveX control still play a role in this scenario?
    Carsten

  • Second Client Side VLAN - CSM

    Our current environment has grown to the size that a single Class C subnet on the client side of the CSM is full. We have a need to add an additional Class C subnet for the client side, but our TCOM group gave us a range which is not contiguous to the existing range and therefore cannot be added by simply changing the subnet mask (from 24 to 23).
    The default route for all traffic from the CSM is an IP address on the subnet described above.
    How should the new subnet be configured? I understand that there can only be one gateway on the CSM...so if traffic comes in on the second subnet, does this mean that it will go back out on the first subnet?
    Does this look right
    vlan 111 client
    ip address 192.168.111.5 255.255.255.0
    gateway 192.168.111.1
    vlan 222 client
    ip address 192.168.222.5 255.255.255.0
    On the Switch, when I run
    "sho ip route 192.168.111.5"
    it replys with "directly connected, via VLan111"
    When I run
    "sho ip route 192.168.222.5"
    it also replies back with the same:
    "directly connected, via VLan111"
    Please note: That I only manage the CSM and SSL-M. The switch and MSFC are managed by our TCOM group. Thanks for any information on this request!

    First, I want to thank you for the quick replies.
    I understand what you are explaining here and believe that our current configuration is as you have explained, but need to further clarify what we have in place.
    The single vlan on the client side previously had only a single class C subnet. It now has two separate Class C subnets. Traffic can reach the CSM, but never returns back to the client. When I added the configuration for the second VLAN client side and addressed it as part of the second class C address, content would now be returned to the client from the server side. But, I could not get the content to be forwarded to the SSL module which resides on a separate VLAN. I then removed client VLAN and traffic continued to flow properly (except to SSL module). I then cleared connections to the vservers (to emulate a reboot), this caused all traffic to no longer return to the client.
    Below is configuration (IP addresses changed to protect the innocent).
    ssl-proxy module 2 allowed-vlan 4,219
    ip subnet-zero
    vlan 200 server
    ip address 172.54.200.2 255.255.254.0
    alias 172.54.200.1 255.255.254.0
    vlan 4 server
    ip address 192.168.219.5 255.255.255.0
    vlan 219 client
    ip address 192.168.219.5 255.255.255.0
    gateway 192.168.219.1
    natpool SERVERSIDE1 172.54.200.241 172.54.200.254 netmask 255.255.254.0
    interface Vlan64
    description Network 64
    ip address 172.32.64.219 255.255.255.0
    ip accounting output-packets
    ip route-cache flow
    logging event link-status
    shutdown
    interface Vlan65
    description Network 65
    ip address 172.32.65.219 255.255.255.0
    ip accounting output-packets
    ip route-cache flow
    logging event link-status
    interface Vlan219
    description WebTeam URL Network
    ip address 192.168.222.2 255.255.255.0 secondary
    ip address 192.168.219.2 255.255.255.0
    no ip redirects
    no ip unreachables
    ip pim dense-mode
    ip route-cache flow
    no ip mroute-cache
    standby 10 ip 192.168.219.1
    standby 10 timers 3 9
    standby 10 priority 110
    standby 10 preempt
    standby 11 ip 192.168.222.1
    standby 11 timers 3 9
    standby 11 priority 110
    standby 11 preempt
    ip classless
    ip route 172.54.200.0 255.255.254.0 192.168.219.5
    NOTES: SSL-MODULE IP address 192.168.219.6 on VLAN 4.
    I will go ahead and open TAC Case and post results later.

Maybe you are looking for

  • Install data from external hard drive?

    Hi, we have our old macbook data saved on external hard drive (old laptop had water damage but able to retrieve data). I now have new macbook, how do I install data from external hard drive to new macbook? Is it super easy? I didn't want to set up ne

  • I can't open bookmarks from the menu in new tab on firefox 6.0 using the mouse middle button or right click. Is this normal?

    I can't open my bookmarks from the menu in a new tab. I'm wondering if this is simply not a feature and requires an add-on. I'd rather not need to use an add-on. can anybody help?

  • Service 'MSExchangeTransport' failed to start

    Good morning all, I am trying to install exchange 2010 on a Windows 2008 R2 sp1 server.  We have an existing exchange 2003 instance on our old server, a windows 2003 sp2 SBS server.  We had an awful lot of DNS problems and active directory troubles w

  • MBP massive performance slowdown

    Hello, So I picked myself up a new MacBook Pro, standard 15 inch dual 2.8ghz model, about three weeks ago. I updated it to 10.6.2. For the first two weeks, it was fantastic in every way. About a week ago, there started to be occasional little 'glitch

  • "air" Object undefined, using JavaScript.

    Hello, I'm using Adobe Air to extend the functionality of an existing web client (allowing access to file-system, etc). The web client is programmed in JavaScript. Because the source code of the web client is pretty big, I would like to avoid code br