Coherence native Windows client sometimes crashes in CacheFactory::configure. ws2_32.dll cuprit?

Hi,
We have a big project which uses Coherence (3.7.1.4 x86 Release) client.  It works mostly fine but in certain setups we get a crash when configuring coherence.dll. We use identical XML config loaded from some central repository which prints fine in our log.  I read this https://community.oracle.com/message/9808292 and I tried using win32vc8-3.7.1.9 coherence.dll and it crashed in the same place. Note that Coherence log is created but empty and we load ws2_32.dll for other purposes before calling into Coherence.
Help!
Michal
The call sequence is
stringstream cacheConfig;
stringstream coherenceConfig;
coherenceConfig << cohConfig;
XmlView coherenceConfigElement (CacheFactory::loadXml (coherenceConfig
// print coherence config XML string to our log
CacheFactory::configure (cacheConfigElement, coherenceConfigElement); // <- crashs!
Call stack at crash:
My version of C:\WINNT\system32\ws2_32.dll is 5.1.2600.5512
On my collegue's Windows 7 we managed to capture gflags sls log; below is an extract just after we printed the coherence configuration XML to our log (so in call to CacheFactory::configure), and before the crash. Maybe these "Invalid parameter passed to C runtime function" are the problem?
0dec:2128 @ 1014363429 - LdrLoadDll - ENTER: DLL name: C:\Windows\system32\ws2_32 DLL path:
0dec:2128 @ 1014363429 - LdrpLoadDll - ENTER: DLL name: C:\Windows\system32\ws2_32 DLL path:
0dec:2128 @ 1014363429 - LdrpLoadDll - INFO: Loading DLL C:\Windows\system32\ws2_32.DLL from path
0dec:2128 @ 1014363429 - LdrpFindOrMapDll - ENTER: DLL name: C:\Windows\system32\ws2_32.DLL DLL path:
0dec:2128 @ 1014363429 - LdrpSearchPath - ENTER: DLL name: C:\Windows\system32\ws2_32.DLL DLL path:
0dec:2128 @ 1014363429 - LdrpResolveFileName - ENTER: DLL name: C:\Windows\system32\ws2_32.DLL
0dec:2128 @ 1014363429 - LdrpResolveFileName - RETURN: Status: 0x00000000
0dec:2128 @ 1014363429 - LdrpResolveDllName - ENTER: DLL name: C:\Windows\system32\ws2_32.DLL
0dec:2128 @ 1014363429 - LdrpResolveDllName - RETURN: Status: 0x00000000
0dec:2128 @ 1014363429 - LdrpSearchPath - RETURN: Status: 0x00000000
0dec:2128 @ 1014363429 - LdrpMapViewOfSection - ENTER: DLL name: C:\Windows\system32\ws2_32.DLL
'QATestSuite.EXE' (Win32): Loaded 'C:\Windows\SysWOW64\ws2_32.dll'. Cannot find or open the PDB file.
0dec:2128 @ 1014363429 - LdrpMapViewOfSection - RETURN: Status: 0x40000003
'QATestSuite.EXE' (Win32): Unloaded 'C:\Windows\SysWOW64\ws2_32.dll'
0dec:2128 @ 1014363429 - LdrpFindOrMapDll - RETURN: Status: 0x00000000
0dec:2128 @ 1014363429 - LdrpLoadDll - RETURN: Status: 0x00000000
0dec:2128 @ 1014363429 - LdrLoadDll - RETURN: Status: 0x00000000
0dec:2128 @ 1014363429 - LdrGetProcedureAddressEx - INFO: Locating procedure "getaddrinfo" by name
0dec:2128 @ 1014363429 - LdrGetProcedureAddressEx - INFO: Locating procedure "getaddrinfo" by name
0dec:2128 @ 1014363429 - LdrGetProcedureAddressEx - INFO: Locating procedure "getnameinfo" by name
0dec:2128 @ 1014363429 - LdrGetProcedureAddressEx - INFO: Locating procedure "freeaddrinfo" by name
0dec:2128 @ 1014363429 - LdrLoadDll - ENTER: DLL name: kernel32.dll DLL path:
0dec:2128 @ 1014363429 - LdrpLoadDll - ENTER: DLL name: kernel32.dll DLL path:
0dec:2128 @ 1014363429 - LdrpLoadDll - INFO: Loading DLL kernel32.dll from path
0dec:2128 @ 1014363429 - LdrpFindOrMapDll - ENTER: DLL name: kernel32.dll DLL path:
0dec:2128 @ 1014363429 - LdrpFindOrMapDll - RETURN: Status: 0x00000000
0dec:2128 @ 1014363429 - LdrpLoadDll - RETURN: Status: 0x00000000
0dec:2128 @ 1014363429 - LdrLoadDll - RETURN: Status: 0x00000000
0dec:2128 @ 1014363429 - LdrGetProcedureAddressEx - INFO: Locating procedure "RtlCaptureContext" by name
0dec:2128 @ 1014363444 - LdrGetDllHandleEx - ENTER: DLL name: dbghelp.dll DLL path: NULL
0dec:2128 @ 1014363444 - LdrGetDllHandleEx - INFO: Locating DLL dbghelp.dll in path
0dec:2128 @ 1014363444 - LdrpFindLoadedDll - ENTER: DLL name: dbghelp.dll DLL path:
0dec:2128 @ 1014363444 - LdrpFindLoadedDll - RETURN: Status: 0x00000000
0dec:2128 @ 1014363444 - LdrGetDllHandleEx - RETURN: Status: 0x00000000
0dec:2128 @ 1014363444 - LdrGetProcedureAddressEx - INFO: Locating procedure "SymGetOptions" by name
0dec:2128 @ 1014363444 - LdrGetProcedureAddressEx - INFO: Locating procedure "SymSetOptions" by name
0dec:2128 @ 1014363444 - LdrGetProcedureAddressEx - INFO: Locating procedure "SymInitialize" by name
0dec:2128 @ 1014363460 - LdrGetDllHandleEx - ENTER: DLL name: ntdll.dll DLL path: NULL
0dec:2128 @ 1014363460 - LdrGetDllHandleEx - INFO: Locating DLL ntdll.dll in path
0dec:2128 @ 1014363460 - LdrpFindLoadedDll - ENTER: DLL name: ntdll.dll DLL path:
0dec:2128 @ 1014363460 - LdrpFindLoadedDll - RETURN: Status: 0x00000000
0dec:2128 @ 1014363460 - LdrGetDllHandleEx - RETURN: Status: 0x00000000
0dec:2128 @ 1014363460 - LdrGetProcedureAddressEx - INFO: Locating procedure "RtlQueryProcessDebugInformation" by name
0dec:2128 @ 1014363460 - LdrGetProcedureAddressEx - INFO: Locating procedure "RtlCreateQueryDebugBuffer" by name
0dec:2128 @ 1014363460 - LdrGetProcedureAddressEx - INFO: Locating procedure "RtlDestroyQueryDebugBuffer" by name
0dec:2128 @ 1014363460 - LdrLoadDll - ENTER: DLL name:
0dec:2128 @ 1014363460 - LdrpLoadDll - ENTER: DLL name:
0dec:2128 @ 1014363460 - LdrpLoadDll - INFO: Loading DLL
0dec:2128 @ 1014363460 - LdrpFindOrMapDll - ENTER: DLL name:
0dec:2128 @ 1014363460 - LdrpSearchPath - ENTER: DLL name:
0dec:2128 @ 1014363460 - LdrpResolveFileName - ENTER: DLL name:
0dec:2128 @ 1014363460 - LdrpResolveFileName - RETURN: Status: 0xc0000135
0dec:2128 @ 1014363460 - LdrpSearchPath - RETURN: Status: 0xc0000135
0dec:2128 @ 1014363460 - LdrpFindOrMapDll - RETURN: Status: 0xc0000135
0dec:2128 @ 1014363460 - LdrpLoadDll - RETURN: Status: 0xc0000135
0dec:2128 @ 1014363460 - LdrLoadDll - RETURN: Status: 0xc0000135
Invalid parameter passed to C runtime function.
Invalid parameter passed to C runtime function.
Invalid parameter passed to C runtime function.
path is C:\Windows\system32;C:\Windows\system;C:\Windows;.;[our stuff]
On a working Windows 7 machine gflags shows following log (path removed):
3eb0:39a0 @ 999903727 - LdrLoadDll - ENTER: DLL name: C:\Windows\system32\ws2_32 DLL path:
3eb0:39a0 @ 999903727 - LdrpLoadDll - ENTER: DLL name: C:\Windows\system32\ws2_32 DLL path:
3eb0:39a0 @ 999903727 - LdrpLoadDll - INFO: Loading DLL C:\Windows\system32\ws2_32.DLL from path
3eb0:39a0 @ 999903727 - LdrpFindOrMapDll - ENTER: DLL name: C:\Windows\system32\ws2_32.DLL DLL path:
3eb0:39a0 @ 999903727 - LdrpSearchPath - ENTER: DLL name: C:\Windows\system32\ws2_32.DLL DLL path:
3eb0:39a0 @ 999903727 - LdrpResolveFileName - ENTER: DLL name: C:\Windows\system32\ws2_32.DLL
3eb0:39a0 @ 999903727 - LdrpResolveFileName - RETURN: Status: 0x00000000
3eb0:39a0 @ 999903727 - LdrpResolveDllName - ENTER: DLL name: C:\Windows\system32\ws2_32.DLL
3eb0:39a0 @ 999903727 - LdrpResolveDllName - RETURN: Status: 0x00000000
3eb0:39a0 @ 999903727 - LdrpSearchPath - RETURN: Status: 0x00000000
3eb0:39a0 @ 999903727 - LdrpMapViewOfSection - ENTER: DLL name: C:\Windows\system32\ws2_32.DLL
'TRSFactorGenerator.exe': Loaded 'C:\Windows\SysWOW64\ws2_32.dll', No symbols loaded.
3eb0:39a0 @ 999903727 - LdrpMapViewOfSection - RETURN: Status: 0x40000003
'TRSFactorGenerator.exe': Unloaded 'C:\Windows\SysWOW64\ws2_32.dll'
3eb0:39a0 @ 999903727 - LdrpFindOrMapDll - RETURN: Status: 0x00000000
3eb0:39a0 @ 999903727 - LdrpUpdateLoadCount2 - INFO: Referencing loaded DLL "C:\Windows\syswow64\NSI.dll" (new reference count: 0x6d)
3eb0:39a0 @ 999903727 - LdrpUpdateLoadCount2 - INFO: Referencing loaded DLL "C:\Windows\syswow64\RPCRT4.dll" (new reference count: 0x273)
3eb0:39a0 @ 999903727 - LdrpUpdateLoadCount2 - INFO: Referencing loaded DLL "C:\Windows\syswow64\SspiCli.dll" (new reference count: 0xab)
3eb0:39a0 @ 999903727 - LdrpUpdateLoadCount2 - INFO: Referencing loaded DLL "C:\Windows\SysWOW64\sechost.dll" (new reference count: 0x273)
3eb0:39a0 @ 999903727 - LdrpUpdateLoadCount2 - INFO: Referencing loaded DLL "C:\Windows\syswow64\RPCRT4.dll" (new reference count: 0x274)
3eb0:39a0 @ 999903727 - LdrpUpdateLoadCount2 - INFO: Referencing loaded DLL "C:\Windows\syswow64\msvcrt.dll" (new reference count: 0x447)
3eb0:39a0 @ 999903727 - LdrpUpdateLoadCount2 - INFO: Referencing loaded DLL "C:\Windows\syswow64\CRYPTBASE.dll" (new reference count: 0xa2)
3eb0:39a0 @ 999903727 - LdrpUpdateLoadCount2 - INFO: Referencing loaded DLL "C:\Windows\syswow64\RPCRT4.dll" (new reference count: 0x275)
3eb0:39a0 @ 999903727 - LdrpUpdateLoadCount2 - INFO: Referencing loaded DLL "C:\Windows\syswow64\msvcrt.dll" (new reference count: 0x448)
3eb0:39a0 @ 999903727 - LdrpUpdateLoadCount2 - INFO: Referencing loaded DLL "C:\Windows\syswow64\msvcrt.dll" (new reference count: 0x449)
3eb0:39a0 @ 999903727 - LdrpLoadDll - RETURN: Status: 0x00000000
3eb0:39a0 @ 999903727 - LdrLoadDll - RETURN: Status: 0x00000000
3eb0:39a0 @ 999903727 - LdrGetProcedureAddressEx - INFO: Locating procedure "getaddrinfo" by name
3eb0:39a0 @ 999903727 - LdrGetProcedureAddressEx - INFO: Locating procedure "getaddrinfo" by name
3eb0:39a0 @ 999903727 - LdrGetProcedureAddressEx - INFO: Locating procedure "getnameinfo" by name
3eb0:39a0 @ 999903727 - LdrGetProcedureAddressEx - INFO: Locating procedure "freeaddrinfo" by name
3eb0:39a0 @ 999903743 - LdrLoadDll - ENTER: DLL name: kernel32.dll DLL path:
3eb0:39a0 @ 999903743 - LdrpLoadDll - ENTER: DLL name: kernel32.dll DLL path:
3eb0:39a0 @ 999903743 - LdrpLoadDll - INFO: Loading DLL kernel32.dll from path
3eb0:39a0 @ 999903743 - LdrpFindOrMapDll - ENTER: DLL name: kernel32.dll DLL path:
3eb0:39a0 @ 999903743 - LdrpFindOrMapDll - RETURN: Status: 0x00000000
3eb0:39a0 @ 999903743 - LdrpLoadDll - RETURN: Status: 0x00000000
3eb0:39a0 @ 999903743 - LdrLoadDll - RETURN: Status: 0x00000000
3eb0:39a0 @ 999903743 - LdrGetProcedureAddressEx - INFO: Locating procedure "RtlCaptureContext" by name
3eb0:39a0 @ 999903758 - LdrGetDllHandleEx - ENTER: DLL name: dbghelp.dll DLL path: NULL
3eb0:39a0 @ 999903758 - LdrGetDllHandleEx - INFO: Locating DLL dbghelp.dll in path
3eb0:39a0 @ 999903758 - LdrpFindLoadedDll - ENTER: DLL name: dbghelp.dll DLL path:
3eb0:39a0 @ 999903758 - LdrpFindLoadedDll - RETURN: Status: 0x00000000
3eb0:39a0 @ 999903758 - LdrGetDllHandleEx - RETURN: Status: 0x00000000
3eb0:39a0 @ 999903758 - LdrGetProcedureAddressEx - INFO: Locating procedure "SymGetOptions" by name
3eb0:39a0 @ 999903758 - LdrGetProcedureAddressEx - INFO: Locating procedure "SymSetOptions" by name
3eb0:39a0 @ 999903774 - LdrGetProcedureAddressEx - INFO: Locating procedure "SymInitialize" by name
3eb0:39a0 @ 999903774 - LdrGetDllHandleEx - ENTER: DLL name: ntdll.dll DLL path: NULL
3eb0:39a0 @ 999903774 - LdrGetDllHandleEx - INFO: Locating DLL ntdll.dll in path
3eb0:39a0 @ 999903774 - LdrpFindLoadedDll - ENTER: DLL name: ntdll.dll DLL path:
3eb0:39a0 @ 999903774 - LdrpFindLoadedDll - RETURN: Status: 0x00000000
3eb0:39a0 @ 999903774 - LdrGetDllHandleEx - RETURN: Status: 0x00000000
3eb0:39a0 @ 999903774 - LdrLoadDll - ENTER: DLL name: kernel32.dll DLL path:
3eb0:39a0 @ 999903774 - LdrpLoadDll - ENTER: DLL name: kernel32.dll DLL path:
3eb0:39a0 @ 999903774 - LdrpLoadDll - INFO: Loading DLL kernel32.dll from path
3eb0:39a0 @ 999903774 - LdrpFindOrMapDll - ENTER: DLL name: kernel32.dll DLL path:
3eb0:39a0 @ 999903774 - LdrpFindOrMapDll - RETURN: Status: 0x00000000
3eb0:39a0 @ 999903774 - LdrpLoadDll - RETURN: Status: 0x00000000
3eb0:39a0 @ 999903774 - LdrLoadDll - RETURN: Status: 0x00000000
3eb0:39a0 @ 999903774 - LdrGetDllHandleEx - ENTER: DLL name: ntdll.dll DLL path: NULL
3eb0:39a0 @ 999903774 - LdrGetDllHandleEx - INFO: Locating DLL ntdll.dll in path
3eb0:39a0 @ 999903774 - LdrpFindLoadedDll - ENTER: DLL name: ntdll.dll DLL path:
3eb0:39a0 @ 999903774 - LdrpFindLoadedDll - RETURN: Status: 0x00000000
3eb0:39a0 @ 999903774 - LdrGetDllHandleEx - RETURN: Status: 0x00000000
3eb0:39a0 @ 999903774 - LdrGetProcedureAddressEx - INFO: Locating procedure "RtlQueryProcessDebugInformation" by name
3eb0:39a0 @ 999903774 - LdrGetProcedureAddressEx - INFO: Locating procedure "RtlCreateQueryDebugBuffer" by name
3eb0:39a0 @ 999903774 - LdrGetProcedureAddressEx - INFO: Locating procedure "RtlDestroyQueryDebugBuffer" by name

It seems a semicolon at the end of PATH environment variable caused this behavior.

Similar Messages

  • Windows Clients freeze on file opening and sometimes dont log on,SMB errors

    On a mac pro , Leopard 10.5.2 server unlimited, OD master, PDC, SMB shares, im getting ready to shoot the mac, it logs on most of the time, but theres so many problems with network freezing and machines freezing at logon. the smb log shows tonnes of these :
    The process has forked and you cannot use this CoreFoundation functionality safely. You MUST exec().
    Break on _THE_PROCESS_HAS_FORKED_AND_YOU_CANNOT_USE_THIS_COREFOUNDATION_FUNCTIONALITY___Y OU_MUST_EXEC_() to debug.
    and the occasional this :
    he/samba/samba-187/samba/source/lib/utilsock.c:get_peeraddr(1232)
    getpeername failed. Error was Invalid argument
    [2008/06/10 15:52:49, 0, pid=81160] /SourceCache/samba/samba-187/samba/source/lib/utilsock.c:writedata(562)
    write_data: write failure in writing to client 192.168.2.14. Error Broken pipe
    [2008/06/10 15:52:49, 0, pid=81160] /SourceCache/samba/samba-187/samba/source/lib/utilsock.c:sendsmb(769)
    Error writing 4 bytes to client. -1. (Broken pipe)

    Hi
    If you browse the forum there are a number of posts similar to yours. See here:
    http://www.apple.com/support/downloads/macosxserver1053comboupdate.html
    I would make sure you have a fallback position first before applying the update as well as going for a manual download rather than using Software Update. By fallback I mean a bootable clone of the Server prior to the update. Try not to clone a 'live' Server.
    http://support.apple.com/kb/HT1142
    Explains what the update 'fixes'. Of particular interest is:
    File Services
    Addresses an issue that could cause the AppleFileServer process to stop accepting connections while
    consuming most of the available CPU time on the server.
    The smb.conf file is updated to include the line "acl check permissions = no" in order to provide
    expected permissions behavior for Windows clients connecting to the SMB service.
    It's not something I would do but you could forego the update and amend the smb.conf instead.
    Tony

  • Trying to understand text encodings between windows clients and oracle DB

    I am focusing on a "maybe bad configured" oracle windows xp client connecting into a well configured oracle db server (10g for example). Instead of just keep the correct client settings to make it work I would prefer to understand what is really doing the oracle client with all the posible bad configurations regarding encodings.
    When the client executes something like "SELECT 'Col1', N'Col2' from dual" before sending the sql sentence into the server the sentence itself should be encoded.
    But the way the sentence is encoded or the fact that some magic encoding transform occurs depends on the technology used (Java Thin, OCI, Oledb, etc..) and sometimes it depends on the windows setting "Languages for Non-unicode programs" and sometimes it depends on the client NLS_LANG setting on the registry. Or maybe thigs are simpler and I simply got confused... Here we could add that maybe some third party tool could do some other "helpfull" hidden magic encoding transformation to make it work and things become interesting
    A second time when all this encoding stuff should be considered is when the results of the sentences are retrieved on the client.
    At this point the client receives an byte stream from the server (that could be a VARCHAR column or a NVARCHAR column). Again depending on the technology used the client could be specting a utext, text (OCI) or a CHAR, NCHAR (in JAVA) or a SQL_C_WCHAR, SQL_C_CHAR (in OleDb), etc...
    Well, I'm not sure at all about the first point. Is all the sentence encoded in the same way before sending it to the server (ie is sended as plain text) or before the client parses the sentence and it understand that is sending a SELECT statement that returns two cols (one varchar and the other nvarchar)? For example the N, the ' and the Col2 are sent using the same encoding?

    Todd:
    Ref:
    http://docs.oracle.com/cd/E35855_01/tuxedo/docs12c/ads/adecid.html#wp1075436
    Section: Generating ECID by Native/WS/Jolt clients and Domain Gateway
    We are using Jolt Clients, via JSL for executing Tuxedo Services. The problem, we always face while debugging is cross relation. It would be extremely useful for us if we could get the ECID printed in webserver and tuxedo server process. Can we get ECID using any programming API in jolt client and in Tuxedo server process ? It would help us to correlate web, Tux and server logs
    Thanks,
    Biju

  • 10.2.0.3 Windows 64bits (AMD) CRash

    Hi,I found a issue on 10.2.0.3 64 windows. Sometimes if one client 8.0.5 or 8.0.6 try to connect Database , the instance crash.
    I try to find a solution with Oracle but until now no solution.
    I have some clients with forms 6i instaled and a 10g client, and sometimes the conection to database crash the instance.
    After try some diferent client configurations I found if anyone who knows the tns and try to connect to database with query builder 6i without know any username or password, crash the instance.
    Anyone have this problem?
    tks

    Sorry to bump into this thread but i'm in the same boat...at least, i'm planning to use Forms/Reports 6i with a 10g R2 db...Checking the certification matrix tells me it's desupported because Forms/Reports 6i is desupported.
    It sounds from your thread here that you are running Forms/Reports 6i against a 10.2.0.3 db...are you having any problems? or is all ok? Also, i have a designer 6i repository that i plan to port to 10.2.0.3 although it's desupported also.
    Anyway, given that i will be in the same situation, i thought i would ask if you are having problems...the fact that the client could crash the database is indeed a severe issue...something i don't want to see.
    Thanks.
    My test database also crashes intermittently after
    applying the 10.2.0.3 patchset on 64 bit (32 bit is
    stable). No error messages in the alert log and no
    trace files on the server but the Windows service
    dies.
    Forms & reports 6i is in use but I haven't been able
    to reproduce the problem at will yet.

  • Windows client other than Sunbird / Lightning? (because they don't work)

    After testing Sunbird + Lightning for a day, it has become clear, that neither software is ready for productive use. There are two major show-stoppers:
    - Calendars set to read-only become read-write again after restart of the calendar client (*)
    - Constant nagging about a username + password for "http://servername:8008" "/Search". This happens all the time, sometimes 15 times in a row while using Sunbird or Lightning and upon quitting Thunderbird (eventually leading to Thunderbird crashing)
    So my question: are there any other Windows Clients that support CalDav? We need something that doesn't have an integrated e-mail client because it's company policy to use Thunderbird.
    Peter
    * We tried the sandboxed add-on that's supposed to fix this - to no avail.

    +I'm afraid the developers haven't realized yet that this bug is a major show-stopper for any kind of business use.+
    +Perhaps it'd be good if others, too, would contact the Sunbird developers team and point out that fact to them.+
    If this is a major show stopper for your business, consider contracting for a fix. Pay somebody to find and fix the bug, and to then contribute the fix. If you don't want to do the work and contribute the fix (skills, local corporate policies, lack of access into the source pool, etc), then dangle some money publicly. Post a reward or a bounty for the fix. You could post part of the savings over a commercial purchase of a similar mail client, for instance, and see if you can move Sunbird and Lightning forward here.
    This bounty works akin to tipping the bellman and the porter and other folks that provide you services. It changes your whole experience. Positively. In the world of open source -- just like in the commercial world -- money is how you prioritize the bugs.

  • Asa 5505 vpn from internet native vpn client, tcp discarted 1723

    Hello to all,
    I'm configuring this asa for to connect home users to my network using the native microsoft vpn clients with windows xp over internet.
    This asa have on the outside interface one public intenet ip and in the inside inferface have configured in the the network 192.168.0.x and i want to acces to this network from internet users using native vpn clients.
    I tested with one pc connected directly to the outside interface and works well, but when i connect this interface to internet and tried to connect on user to the vpn i can see in the logs this, and can't connect with error 800.
    TCP request discarded from "public_ip_client/61648" to outside:publicip_outside_interface/1723"
    Can help me please?, Very thanks in advance !
    (running configuration)
    : Saved
    ASA Version 8.4(3)
    hostname ciscoasa
    enable password *** encrypted
    passwd *** encrypted
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.0.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address publicinternetaddress 255.255.255.0
    ftp mode passive
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network gatewayono
    host gatewayofinternetprovideraccess
    description salida gateway ono
    object service remotointerno
    service tcp destination eq 3389
    description remoto
    object network pb_clienteing_2
    host 192.168.0.15
    description Pebble cliente ingesta 2
    object service remotoexternopebble
    service tcp destination eq 5353
    description remotoexterno
    object network actusmon
    host 192.168.0.174
    description Actus monitor web
    object service Web
    service tcp destination eq www
    description 80
    object network irdeto
    host 192.168.0.31
    description Irdeto
    object network nmx_mc_p
    host 192.168.0.60
    description NMX Multicanal Principal
    object network nmx_mc_r
    host 192.168.0.61
    description NMX multicanal reserva
    object network tarsys
    host 192.168.0.10
    description Tarsys
    object network nmx_teuve
    host 192.168.0.30
    description nmx cabecera teuve
    object network tektronix
    host 192.168.0.20
    description tektronix vnc
    object service vnc
    service tcp destination eq 5900
    description Acceso vnc
    object service exvncnmxmcr
    service tcp destination eq 5757
    description Acceso vnc externo nmx mc ppal
    object service exvncirdeto
    service tcp destination eq 6531
    description Acceso vnc externo irdeto
    object service exvncnmxmcp
    service tcp destination eq 5656
    object service exvnctektronix
    service tcp destination eq 6565
    object service exvncnmxteuve
    service tcp destination eq 6530
    object service ssh
    service tcp destination eq ssh
    object service sshtedialexterno
    service tcp destination eq 5454
    object-group service puertosabiertos tcp
    description remotedesktop
    port-object eq 3389
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    object-group network DM_INLINE_NETWORK_1
    network-object object irdeto
    network-object object nmx_mc_p
    network-object object nmx_mc_r
    network-object object nmx_teuve
    network-object object tektronix
    object-group service vpn udp
    port-object eq 1723
    object-group service DM_INLINE_TCP_1 tcp
    port-object eq https
    port-object eq pptp
    object-group network DM_INLINE_NETWORK_2
    network-object object actusmon
    network-object object tarsys
    access-list inside_access_in extended permit object remotointerno any any
    access-list inside_access_in extended permit object ssh any any
    access-list inside_access_in extended permit object-group TCPUDP any any eq www
    access-list inside_access_in extended permit icmp any any
    access-list inside_access_in extended permit object vnc any any
    access-list inside_access_in extended permit ip any any
    access-list outside_access_in extended permit object remotointerno any object pb_clienteing_2
    access-list outside_access_in extended permit object-group TCPUDP any object actusmon eq www
    access-list outside_access_in remark Acceso tedial ssh
    access-list outside_access_in extended permit tcp any object tarsys eq ssh
    access-list outside_access_in extended permit object vnc any object-group DM_INLINE_NETWORK_1
    access-list outside_access_in extended permit tcp any any object-group DM_INLINE_TCP_1
    access-list outside_access_in extended deny icmp any any
    access-list corporativa standard permit 192.168.0.0 255.255.255.0
    access-list Split-Tunnel-ACL standard permit 192.168.0.0 255.255.255.0
    pager lines 24
    logging enable
    logging monitor debugging
    logging asdm debugging
    logging debug-trace
    mtu inside 1500
    mtu outside 1500
    ip local pool clientesvpn 192.168.0.100-192.168.0.110 mask 255.255.255.0
    ip local pool clientesvpn2 192.168.1.120-192.168.1.130 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit any inside
    icmp permit any outside
    no asdm history enable
    arp timeout 14400
    nat (outside,inside) source static any interface destination static interface actusmon service Web Web unidirectional
    nat (outside,inside) source static any interface destination static interface tarsys service sshtedialexterno ssh unidirectional
    nat (outside,inside) source static any interface destination static interface pb_clienteing_2 service remotoexternopebble remotointerno unidirectional
    nat (outside,inside) source static any interface destination static interface irdeto service exvncirdeto vnc unidirectional
    nat (outside,inside) source static any interface destination static interface nmx_mc_p service exvncnmxmcp vnc unidirectional
    nat (outside,inside) source static any interface destination static interface nmx_mc_r service exvncnmxmcr vnc unidirectional
    nat (outside,inside) source static any interface destination static interface nmx_teuve service exvncnmxteuve vnc unidirectional
    nat (outside,inside) source static any interface destination static interface tektronix service exvnctektronix vnc unidirectional
    nat (any,outside) source dynamic DM_INLINE_NETWORK_2 interface
    access-group inside_access_in in interface inside
    access-group outside_access_in in interface outside per-user-override
    route outside 0.0.0.0 0.0.0.0 gatewayinternetprovideracces 1
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    eou allow none
    aaa local authentication attempts max-fail 10
    http server enable
    http 192.168.0.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    no sysopt connection permit-vpn
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec ikev1 transform-set clientewindowsxp esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set clientewindowsxp mode transport
    crypto ipsec ikev1 transform-set L2TP-IKE1-Transform-Set esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set L2TP-IKE1-Transform-Set mode transport
    crypto ipsec ikev2 ipsec-proposal DES
    protocol esp encryption des
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal 3DES
    protocol esp encryption 3des
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES
    protocol esp encryption aes
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES192
    protocol esp encryption aes-192
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES256
    protocol esp encryption aes-256
    protocol esp integrity sha-1 md5
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 1 set ikev1 transform-set clientewindowsxp
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 1 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
    crypto dynamic-map L2TP-MAP 10 set ikev1 transform-set L2TP-IKE1-Transform-Set
    crypto map inside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map inside_map interface inside
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map L2TP-VPN-MAP 20 ipsec-isakmp dynamic L2TP-MAP
    crypto map L2TP-VPN-MAP interface outside
    crypto ca trustpoint _SmartCallHome_ServerCA
    crl configure
    crypto ikev2 policy 1
    encryption aes-256
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 10
    encryption aes-192
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 20
    encryption aes
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 30
    encryption 3des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 40
    encryption des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 enable outside client-services port 443
    crypto ikev2 remote-access trustpoint Ingenieria
    crypto ikev1 enable inside
    crypto ikev1 enable outside
    crypto ikev1 policy 5
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 10
    authentication crack
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 20
    authentication rsa-sig
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 30
    authentication pre-share
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 40
    authentication crack
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 50
    authentication rsa-sig
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 60
    authentication pre-share
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 70
    authentication crack
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 80
    authentication rsa-sig
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 90
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 100
    authentication crack
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 110
    authentication rsa-sig
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 130
    authentication crack
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 140
    authentication rsa-sig
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 150
    authentication pre-share
    encryption des
    hash sha
    group 2
    lifetime 86400
    telnet 192.168.0.0 255.255.255.0 inside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd dns 8.8.8.8
    dhcpd auto_config outside
    dhcpd address 192.168.0.5-192.168.0.36 inside
    dhcpd dns 8.8.8.8 8.8.4.4 interface inside
    dhcpd auto_config outside interface inside
    dhcpd enable inside
    no threat-detection basic-threat
    no threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ssl trust-point Ingenieria outside
    webvpn
    tunnel-group-list enable
    group-policy DefaultRAGroup internal
    group-policy DefaultRAGroup attributes
    wins-server none
    dns-server value 192.168.0.1
    vpn-tunnel-protocol l2tp-ipsec
    default-domain none
    group-policy DfltGrpPolicy attributes
    dns-server value 8.8.8.8
    vpn-tunnel-protocol ikev1 ikev2 l2tp-ipsec
    group-policy ingenieria internal
    group-policy ingenieria attributes
    vpn-tunnel-protocol l2tp-ipsec
    default-domain none
    group-policy L2TP-Policy internal
    group-policy L2TP-Policy attributes
    dns-server value 8.8.8.8
    vpn-tunnel-protocol l2tp-ipsec
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value Split-Tunnel-ACL
    intercept-dhcp enable
    username ingenieria password 4fD/5xY/6BwlkjGqMZbnKw== nt-encrypted privilege 0
    username ingenieria attributes
    vpn-group-policy ingenieria
    username rjuve password SjBNOLNgSkUi5KWk/TUsTQ== nt-encrypted
    tunnel-group DefaultRAGroup general-attributes
    address-pool clientesvpn
    address-pool clientesvpn2
    authentication-server-group (outside) LOCAL
    authorization-server-group LOCAL
    default-group-policy L2TP-Policy
    authorization-required
    tunnel-group DefaultRAGroup ipsec-attributes
    ikev1 pre-shared-key *****
    tunnel-group DefaultRAGroup ppp-attributes
    no authentication chap
    authentication ms-chap-v2
    class-map inspection_default
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    prompt hostname context
    call-home reporting anonymous
    Cryptochecksum:59b54f1d10fe829aeb47bafee57ba95e
    : end
    no asdm history enable

    Yes with this command creates this
    policy-map global_policy
        class inspection_default
         inspect pptp
    But don't work. I also tried to add the pptp and gre in the outside access rules but nothing...
    I don't understand why if a connect directly to the outside interface with the same outside network works well.
    ej: the pc have 89.120.145.14 ip and the outside asa have 89.120.145.140 and if I create one vpn in this pc the outside ip 89.120.145.140 with the correct parameters the asa don't discart 1723 and connect ok but if this ip is not of this range discards 1723...

  • Having problem with svchost.exe/ntdll.dll errors causing GPSVC (Group Policy Client) to crash preventing users from logging into the server.

    Recently (within the past 2 weeks) I have noticed a few of our servers will have problems with the svchost.exe application causing the GPSVC (Group Policy Client) to crash. The only fix at that point is to reboot the server since the GPSVC service is tied
    to svchost.exe and therefore is protected from being manually restarted.
    I noticed the following errors when this occurs:
    Log Name:      Application
    Source:        Application Error
    Date:          7/23/2013 4:35:26 AM
    Event ID:      1000
    Task Category: (100)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      Server1.xxx.xxx.net
    Description:
    Faulting application name: svchost.exe, version: 6.1.7600.16385, time stamp: 0x4a5bc3c1
    Faulting module name: ntdll.dll, version: 6.1.7601.17725, time stamp: 0x4ec4aa8e
    Exception code: 0xc0000024
    Fault offset: 0x00000000000cd7d8
    Faulting process id: 0x46c
    Faulting application start time: 0x01ce877f9476ac07
    Faulting application path: C:\Windows\system32\svchost.exe
    Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
    Report Id: d252d26d-f372-11e2-8ad4-005056ac00e8
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Application Error" />
        <EventID Qualifiers="0">1000</EventID>
        <Level>2</Level>
        <Task>100</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2013-07-23T08:35:26.000000000Z" />
        <EventRecordID>158950</EventRecordID>
        <Channel>Application</Channel>
        <Computer>AAW19XM2.agency.nwie.net</Computer>
        <Security />
      </System>
      <EventData>
        <Data>svchost.exe</Data>
        <Data>6.1.7600.16385</Data>
        <Data>4a5bc3c1</Data>
        <Data>ntdll.dll</Data>
        <Data>6.1.7601.17725</Data>
        <Data>4ec4aa8e</Data>
        <Data>c0000024</Data>
        <Data>00000000000cd7d8</Data>
        <Data>46c</Data>
        <Data>01ce877f9476ac07</Data>
        <Data>C:\Windows\system32\svchost.exe</Data>
        <Data>C:\Windows\SYSTEM32\ntdll.dll</Data>
        <Data>d252d26d-f372-11e2-8ad4-005056ac00e8</Data>
      </EventData>
    </Event>
    All of our servers are running Server 2008 R2 Enterprise where we use Citrix to deliver desktop sessions to our users, but some are virtual and some are physical. This seemingly impacts our virtual machines more, and our VMs are hosted through VMWare, however,
    about 5 months ago a similar error fired on a non-virtual machine:
    Log Name:      Application
    Source:        Application Error
    Date:          2/27/2013 6:57:58 AM
    Event ID:      1000
    Task Category: (100)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      AAW29033
    Description:
    Faulting application name: svchost.exe_gpsvc, version: 6.1.7600.16385, time stamp: 0x4a5bc3c1
    Faulting module name: ntdll.dll, version: 6.1.7601.17725, time stamp: 0x4ec4aa8e
    Exception code: 0xc0000024
    Fault offset: 0x00000000000cd7d8
    Faulting process id: 0x6c0
    Faulting application start time: 0x01ce14e1af313fd9
    Faulting application path: C:\Windows\system32\svchost.exe
    Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
    Report Id: ed3d01c4-80d4-11e2-9128-b499baa9e5e8
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Application Error" />
        <EventID Qualifiers="0">1000</EventID>
        <Level>2</Level>
        <Task>100</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2013-02-27T11:57:58.000000000Z" />
        <EventRecordID>286291</EventRecordID>
        <Channel>Application</Channel>
        <Computer>AAW29033</Computer>
        <Security />
      </System>
      <EventData>
        <Data>svchost.exe_gpsvc</Data>
        <Data>6.1.7600.16385</Data>
        <Data>4a5bc3c1</Data>
        <Data>ntdll.dll</Data>
        <Data>6.1.7601.17725</Data>
        <Data>4ec4aa8e</Data>
        <Data>c0000024</Data>
        <Data>00000000000cd7d8</Data>
        <Data>6c0</Data>
        <Data>01ce14e1af313fd9</Data>
        <Data>C:\Windows\system32\svchost.exe</Data>
        <Data>C:\Windows\SYSTEM32\ntdll.dll</Data>
        <Data>ed3d01c4-80d4-11e2-9128-b499baa9e5e8</Data>
      </EventData>
    </Event>
    I've searched and cannot seem to find any information as to what may be causing this, or even really where to start. Would someone be able to help me identify what might be causing this event, specific with the Exception code: 0xc0000024, which causes
    the Group Policy Client service to stop?

    You still out there looking at things? If so I have an update. The issue hasn't stopped, even though it did seemingly die down for awhile, however, it is now back with a vengeance.
    I am able to force it to happen by killing the svchost process that is hosting GPSVC. If I run gpupdate /force, then logout/login it does get GPSVC running again. Furthermore, if I simply start svchost again via the Task Manager GPSVC starts running again.
    When I access the server remotely with KVM it acts just like it does as if I'm logging into it via Citrix/RDP which for Admin IDs gives an error saying "Failed to connect to a windows service. Windows could not connect to the Group Policy Client service...",
    however, normal user accounts just get a message when logging into the server "The Group Policy Client Service Failed the Logon. Access is denied."
    I haven't opened a case with Microsoft yet, but we about ready to because of the increase in these errors.
    If you have any further suggestions that would be great, otherwise I'll provide an update once I get word back from Microsoft.
    **EDIT -- apparently I mistook the the server's SCM's actions as my own. I was able to successfully crash the GPSVC service by killing the hosting svchost process, however, after I crashed it and let it sit crashed for awhile when I attempted
    to restart either by starting a svchost task, or running gpupdate /force it failed. Either that, or there is a timing issue where if we don't restart the svchost process, or run gpupdate /force quickly enough it won't be able to recover without a reboot.

  • OWB 10g Release 1, version 10.1.0.3, windows client download

    Hi,
    I am looking for the windows client for the OWB version 10.1.0.3. I am not able to locate the software download anywhere in the Oracle website, could not locate the archive location from where I could download older versions if any.
    Any help locating the download in oracle site or in any other means is appreciated.
    Thanks in advance,

    Thanks for your response...
    Yeah, I have a client running 10g R1 version 10.1.0.3 server and the only client installed windows machine crashed and they are using the client on the server. It would be very useful if they could have the windows client for that specific version.
    We are also doing a fresh install of OWB 10.2.0.5 on a new server and trying to create the repository and import the .mdl project backup from the prod server (OWB 10.1.0.3).

  • Server 2.2.1 - Disable "Share with Windows clients (SMB)" as default for new Share Points

    I have been experiencing issues with the native OS X 10.8.3 Server SMBx service.  I have therefore disabled it in favor of full Samba via SMBup.  With that said, when I chose to add a new share, by default OS X Server activates "Share with Windows clients (SMB)"  I would like this option disabled by default as I am managing my SMB shares through SMBup.  Is there a preference to accomplish this?
    TIA.
    Matt

    I have been experiencing issues with the native OS X 10.8.3 Server SMBx service.  I have therefore disabled it in favor of full Samba via SMBup.  With that said, when I chose to add a new share, by default OS X Server activates "Share with Windows clients (SMB)"  I would like this option disabled by default as I am managing my SMB shares through SMBup.  Is there a preference to accomplish this?
    TIA.
    Matt

  • RV110W drops PPTP connections from a Windows client (MS CHAP v2 and MPPE)

    This might be a tough problem to diagnose. I am trying to setup an RV100W for an office gateway with VPN access using PPTP. The office is located in another state, so I'm trying to do a "dry run" from home by setting up the RV110W on the local network. That is, my home network is 192.168.0.0 and I have assigned the RV110W a static IP address of 192.168.0.120 on its WAN side and a DHCP NAT internal network of 192.168.1.0. Its LAN IP is 192.168.1.2 (because of legacy limitations, the 192.168.1.1 address will be reserved for another host on the actual office network) and I set up the PPTP server on 192.168.1.3 and clients in the 192.168.1.20 to 24 range. I have enabled MPPE encryption and NetBIOS over VPN (rather important to have).
    At first, I couldn't login at all. I had an underscore (_) in the user names (of which I have setup all five) and after I changed that, I was able to connect from a Windows 7 x64 host on the home LAN (192.168.0.132). I don't know if that was the problem as I got disconnected and reconnecting was a hit-or-miss - sometimes it would work, sometimes - it wouldn't. Below is the log from the session, showing the reasons for the disconnection. When I try to connect and it gets rejected, otherwise, the reason is the same: protocol not available.
    But, first - here's the kicker. I had the exact same experience earlier with a DD-WRT router. I thought the problem lied with the amateurish firmware and that's why I decided to get the Cisco, but it seems like this might not be the problem, after all. Here is that discussion for full details: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=149951&highlight= (to see all of the attached images and logs, you'll need an account). Briefly, with the same setup, I can establish a stable VPN connection from four Windows XP clients and one Windows 7 client, but I get the problems with two other Windows 7 clients. The Win7 clients that give me trouble can connect just fine to other PPTP VPN servers (with the built-in Microsoft PPTP client) and all three Win7 machines are clones of each other (only the hardware is different). No software firewalls, anti-virus/malware, user-permission limitations (e.g., UAC), or anything that could hamper the connections, are present on either machine.
    I don't see how the fact that the RV110W is on a LAN and not exposed to the Internet on its WAN side could cause any trouble, but even then - why some clients work fine and others - not? I would appreciate any help with this issue.
    Kamen
    This is the log from the session, showing the connection of the VPN client and then, not two minutes later, the disconnection.
    2012-02-22 21:44:40 RV110W daemon.info pptpd[4582]: CTRL: Client 192.168.0.132 control connection started
    2012-02-22 21:44:40 RV110W daemon.info pptpd[4582]: CTRL: Starting call (launching pppd, opening GRE)
    2012-02-22 21:44:40 RV110W daemon.notice pppd[4583]: pppd 2.4.5 started by (unknown), uid 0
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: using channel 2
    2012-02-22 21:44:40 RV110W daemon.info pppd[4583]: Using interface ppp0
    2012-02-22 21:44:40 RV110W daemon.notice pppd[4583]: Connect: ppp0 <--> /dev/pts/0
    2012-02-22 21:44:40 RV110W daemon.warning pppd[4583]: Warning - secret file /tmp/ppp/pap-secrets has world and/or group access
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: sent [LCP ConfReq id=0x1 <auth chap MS-v2> <magic 0x4269dad6>]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: rcvd [LCP ConfReq id=0x0 <mru 1400> <magic 0x5eec49d5> <pcomp> <accomp> <callback CBCP>]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: sent [LCP ConfRej id=0x0 <pcomp> <accomp> <callback CBCP>]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: rcvd [LCP ConfAck id=0x1 <auth chap MS-v2> <magic 0x4269dad6>]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: rcvd [LCP ConfReq id=0x1 <mru 1400> <magic 0x5eec49d5>]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: sent [LCP ConfAck id=0x1 <mru 1400> <magic 0x5eec49d5>]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: sent [LCP EchoReq id=0x0 magic=0x4269dad6]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: sent [CHAP Challenge id=0xfb <454ee20916a665999fdaa66778e1c4c5>, name = \"RV110W\"]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: rcvd [LCP Ident id=0x2 magic=0x5eec49d5 \"MSRASV5.20\"]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: rcvd [LCP Ident id=0x3 magic=0x5eec49d5 \"MSRAS-0-SOFTWAREONE64\"]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: rcvd [LCP Ident id=0x4 magic=0x5eec49d5 \"H\\37777777772\\37777777612\\37777777633F\\177\\37777777752J\\37777777640[\\377777776451\\37777777610\\\\Ob\"]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: rcvd [LCP EchoRep id=0x0 magic=0x5eec49d5]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: rcvd [CHAP Response id=0xfb <2aeb8dac876cbec7c23036952cfc270c00000000000000006f4cafa17228047ac82f26e47ae69eda8fe8650d5866e44b00>, name = \"sakor001\"]
    2012-02-22 21:44:40 RV110W daemon.warning pppd[4583]: Warning - secret file /tmp/ppp/chap-secrets has world and/or group access
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: sent [CHAP Success id=0xfb \"S=ACBA0BE9B8A98DDB757B234A1C69E9508DE169DE M=Access granted\"]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: Script /tmp/ppp/auth-up started (pid 4587)
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: sent [CCP ConfReq id=0x1 <mppe +H -M +S +L -D -C>]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: Script /tmp/ppp/auth-up finished (pid 4587), status = 0x16
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: rcvd [CCP ConfReq id=0x5 <mppe +H -M +S -L -D -C>]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: sent [CCP ConfAck id=0x5 <mppe +H -M +S -L -D -C>]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: rcvd [IPCP ConfReq id=0x6 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-wins 0.0.0.0> <ms-dns2 0.0.0.0> <ms-wins 0.0.0.0>]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: sent [IPCP TermAck id=0x6]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: rcvd [CCP ConfNak id=0x1 <mppe +H -M +S -L -D -C>]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: sent [CCP ConfReq id=0x2 <mppe +H -M +S -L -D -C>]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: rcvd [CCP ConfAck id=0x2 <mppe +H -M +S -L -D -C>]
    2012-02-22 21:44:40 RV110W daemon.notice pppd[4583]: MPPE 128-bit stateless compression enabled
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: sent [IPCP ConfReq id=0x1 <addr 192.168.1.3>]
    2012-02-22 21:44:40 RV110W daemon.debug pppd[4583]: rcvd [IPCP ConfAck id=0x1 <addr 192.168.1.3>]
    2012-02-22 21:44:42 RV110W daemon.debug pppd[4583]: rcvd [IPCP ConfReq id=0x7 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-wins 0.0.0.0> <ms-dns2 0.0.0.0> <ms-wins 0.0.0.0>]
    2012-02-22 21:44:42 RV110W daemon.debug pppd[4583]: sent [IPCP ConfRej id=0x7 <ms-wins 0.0.0.0> <ms-wins 0.0.0.0>]
    2012-02-22 21:44:42 RV110W daemon.debug pppd[4583]: rcvd [IPCP ConfReq id=0x8 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
    2012-02-22 21:44:42 RV110W daemon.debug pppd[4583]: sent [IPCP ConfNak id=0x8 <addr 192.168.1.20> <ms-dns1 216.165.129.157> <ms-dns2 216.170.153.146>]
    2012-02-22 21:44:42 RV110W daemon.debug pppd[4583]: rcvd [IPCP ConfReq id=0x9 <addr 192.168.1.20> <ms-dns1 216.165.129.157> <ms-dns2 216.170.153.146>]
    2012-02-22 21:44:42 RV110W daemon.debug pppd[4583]: sent [IPCP ConfAck id=0x9 <addr 192.168.1.20> <ms-dns1 216.165.129.157> <ms-dns2 216.170.153.146>]
    2012-02-22 21:44:42 RV110W daemon.notice pppd[4583]: local  IP address 192.168.1.3
    2012-02-22 21:44:42 RV110W daemon.notice pppd[4583]: remote IP address 192.168.1.20
    2012-02-22 21:44:42 RV110W daemon.debug pppd[4583]: Script /tmp/ppp/ip-up started (pid 4661)
    2012-02-22 21:44:42 RV110W daemon.debug pppd[4583]: Script /tmp/ppp/ip-up finished (pid 4661), status = 0x0
    2012-02-22 21:44:42 RV110W user.debug syslog: Nbsrelay start (pid= 4678)
    2012-02-22 21:46:10 RV110W daemon.notice pppd[4583]: Modem hangup
    2012-02-22 21:46:10 RV110W daemon.debug pppd[4583]: Script /tmp/ppp/auth-down started (pid 4858)
    2012-02-22 21:46:10 RV110W daemon.info pppd[4583]: Connect time 1.5 minutes.
    2012-02-22 21:46:10 RV110W daemon.info pppd[4583]: Sent 10404 bytes, received 17264 bytes.
    2012-02-22 21:46:10 RV110W daemon.debug pppd[4583]: Script /tmp/ppp/ip-down started (pid 4861)
    2012-02-22 21:46:10 RV110W daemon.err pppd[4583]: MPPE disabled
    2012-02-22 21:46:10 RV110W daemon.debug pppd[4583]: sent [LCP TermReq id=0x2 \"MPPE disabled\"]
    2012-02-22 21:46:10 RV110W daemon.notice pppd[4583]: Connection terminated.
    2012-02-22 21:46:10 RV110W daemon.debug pppd[4583]: Script /tmp/ppp/auth-down finished (pid 4858), status = 0x16
    2012-02-22 21:46:10 RV110W daemon.debug pppd[4583]: Waiting for 1 child processes...
    2012-02-22 21:46:10 RV110W daemon.debug pppd[4583]:   script /tmp/ppp/ip-down, pid 4861
    2012-02-22 21:46:10 RV110W daemon.debug pppd[4583]: Script /tmp/ppp/ip-down finished (pid 4861), status = 0x0
    2012-02-22 21:46:10 RV110W daemon.info pppd[4583]: Exit.
    2012-02-22 21:46:10 RV110W daemon.err pptpd[4582]: GRE: read(fd=11,buffer=449be4,len=8260) from network failed: status = -1 error = Protocol not available
    2012-02-22 21:46:10 RV110W daemon.err pptpd[4582]: CTRL: GRE read or PTY write failed (gre,pty)=(11,10)
    2012-02-22 21:46:10 RV110W daemon.debug pptpd[4582]: CTRL: Reaping child PPP[4583]
    2012-02-22 21:46:10 RV110W daemon.info pptpd[4582]: CTRL: Client 192.168.0.132 control connection finished

    Update: things are getting even weirder. In short - it seems to be working now (on the next day) without anything changing. First thing I did was just try another desperate tweak - I disabled the LCP extensions on the Windows client, which I've done before. It connected and stayed that way. Then, I reverted that setting back to exactly how it was before and connected again - no problems: it stayed connected for an hour (before I disconnected so I can connect to the real VPN), I could access a test-PC on the private network (a single machine just for the test) and do different tasks (resolve host names, browse UNC paths, copy files, Remote Desktop to it, etc.)
    I hate it when things happen, for which there is no explanation. I couldn't be confident sending this to the main office to replace the existing router (hardware) and VPN server (implemented in software on a Windows 2003 server). Any thoughts?
    Kamen
    P.S. I'm attaching the logs from the successful session in case someone wants to compare them, but they seems quite identical (some different ConfAck / ConfNak  sequences, but that doesn't seem to make much difference).
    2012-02-23 10:01:26 RV110W daemon.info pptpd[944]: CTRL: Client 192.168.0.132 control connection started
    2012-02-23 10:01:26 RV110W daemon.info pptpd[944]: CTRL: Starting call (launching pppd, opening GRE)
    2012-02-23 10:01:26 RV110W daemon.notice pppd[946]: pppd 2.4.5 started by (unknown), uid 0
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: using channel 5
    2012-02-23 10:01:26 RV110W daemon.info pppd[946]: Using interface ppp0
    2012-02-23 10:01:26 RV110W daemon.notice pppd[946]: Connect: ppp0 <--> /dev/pts/0
    2012-02-23 10:01:26 RV110W daemon.warning pppd[946]: Warning - secret file /tmp/ppp/pap-secrets has world and/or group access
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: sent [LCP ConfReq id=0x1 ]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: rcvd [LCP ConfReq id=0x0 ]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: sent [LCP ConfRej id=0x0 ]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: rcvd [LCP ConfAck id=0x1 ]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: rcvd [LCP ConfReq id=0x1 ]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: sent [LCP ConfAck id=0x1 ]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: sent [LCP EchoReq id=0x0 magic=0x11372b0b]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: sent [CHAP Challenge id=0x66 <74f93b7b6de315aaaac930f984c219e4>, name = \"RV110W\"]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: rcvd [LCP Ident id=0x2 magic=0x67c80cba \"MSRASV5.20\"]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: rcvd [LCP Ident id=0x3 magic=0x67c80cba \"MSRAS-0-SOFTWAREONE64\"]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: rcvd [LCP Ident id=0x4 magic=0x67c80cba \"
    \\37777777675\\027\\37777777665\\004\\37777777635\\37777777677@H\\37777777633~\\37777777775\\021\\tFQ(\
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: rcvd [LCP EchoRep id=0x0 magic=0x67c80cba]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: rcvd [CHAP Response id=0x66 <2f0330cb61ba1c8e29324410e0df24d3000000000000000025d1ef07d4cd82beaa93fe36ccc1e863b2652087eb02c39400>, name = \"sakor001\"]
    2012-02-23 10:01:26 RV110W daemon.warning pppd[946]: Warning - secret file /tmp/ppp/chap-secrets has world and/or group access
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: sent [CHAP Success id=0x66 \"S=9A5FB4C8B7C633FD6DEB868E150D0511BD93E0B4 M=Access granted\"]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: Script /tmp/ppp/auth-up started (pid 949)
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: sent [CCP ConfReq id=0x1 ]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: Script /tmp/ppp/auth-up finished (pid 949), status = 0x16
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: rcvd [CCP ConfReq id=0x5 ]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: sent [CCP ConfNak id=0x5 ]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: rcvd [IPCP ConfReq id=0x6 ]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: sent [IPCP TermAck id=0x6]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: rcvd [CCP ConfNak id=0x1 ]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: sent [CCP ConfReq id=0x2 ]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: rcvd [CCP ConfReq id=0x7 ]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: sent [CCP ConfAck id=0x7 ]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: rcvd [CCP ConfAck id=0x2 ]
    2012-02-23 10:01:26 RV110W daemon.notice pppd[946]: MPPE 128-bit stateless compression enabled
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: sent [IPCP ConfReq id=0x1 ]
    2012-02-23 10:01:26 RV110W daemon.debug pppd[946]: rcvd [IPCP ConfAck id=0x1 ]
    2012-02-23 10:01:28 RV110W daemon.debug pppd[946]: rcvd [IPCP ConfReq id=0x8 ]
    2012-02-23 10:01:28 RV110W daemon.debug pppd[946]: sent [IPCP ConfRej id=0x8 ]
    2012-02-23 10:01:28 RV110W daemon.debug pppd[946]: rcvd [IPCP ConfReq id=0x9 ]
    2012-02-23 10:01:28 RV110W daemon.debug pppd[946]: sent [IPCP ConfNak id=0x9 ]
    2012-02-23 10:01:28 RV110W daemon.debug pppd[946]: rcvd [IPCP ConfReq id=0xa ]
    2012-02-23 10:01:28 RV110W daemon.debug pppd[946]: sent [IPCP ConfAck id=0xa ]
    2012-02-23 10:01:28 RV110W daemon.notice pppd[946]: local  IP address 192.168.1.3
    2012-02-23 10:01:28 RV110W daemon.notice pppd[946]: remote IP address 192.168.1.20
    2012-02-23 10:01:28 RV110W daemon.debug pppd[946]: Script /tmp/ppp/ip-up started (pid 1028)
    2012-02-23 10:01:28 RV110W daemon.debug pppd[946]: Script /tmp/ppp/ip-up finished (pid 1028), status = 0x0
    2012-02-23 10:01:28 RV110W user.debug syslog: Nbsrelay start (pid= 1040)
    2012-02-23 10:17:56 RV110W daemon.err pptpd[944]: GRE: Bad checksum from pppd.
    2012-02-23 10:31:51 RV110W daemon.info udhcpd[807]: received INFORM from 00:13:46:E6:D3:FA
    2012-02-23 10:48:20 RV110W daemon.info httpd[376]: Administrator session timeout.
    2012-02-23 10:48:27 RV110W daemon.info httpd[376]: Administrator logined from 192.168.0.132
    2012-02-23 10:52:50 RV110W daemon.info udhcpd[807]: received INFORM from 00:26:F2:B7:49:42
    2012-02-23 10:58:49 RV110W daemon.debug pppd[946]: rcvd [LCP TermReq id=0xb \"g\\37777777710\\014\\37777777672\\000<
    \\37777777715t\\000\\000\\000\\000\
    2012-02-23 10:58:49 RV110W daemon.info pppd[946]: LCP terminated by peer (gM-H^LM-:^@
    2012-02-23 10:58:49 RV110W daemon.debug pppd[946]: Script /tmp/ppp/auth-down started (pid 6011)
    2012-02-23 10:58:49 RV110W daemon.info pppd[946]: Connect time 57.4 minutes.
    2012-02-23 10:58:49 RV110W daemon.info pppd[946]: Sent 272072987 bytes, received 6264878 bytes.
    2012-02-23 10:58:49 RV110W daemon.debug pppd[946]: Script /tmp/ppp/ip-down started (pid 6015)
    2012-02-23 10:58:49 RV110W daemon.debug pppd[946]: sent [LCP TermAck id=0xb]
    2012-02-23 10:58:49 RV110W daemon.debug pppd[946]: Script /tmp/ppp/auth-down finished (pid 6011), status = 0x16
    2012-02-23 10:58:49 RV110W daemon.notice pppd[946]: Modem hangup
    2012-02-23 10:58:49 RV110W daemon.notice pppd[946]: Connection terminated.
    2012-02-23 10:58:49 RV110W daemon.debug pppd[946]: Waiting for 1 child processes...
    2012-02-23 10:58:49 RV110W daemon.debug pppd[946]:   script /tmp/ppp/ip-down, pid 6015
    2012-02-23 10:58:49 RV110W daemon.debug pppd[946]: Script /tmp/ppp/ip-down finished (pid 6015), status = 0x0
    2012-02-23 10:58:49 RV110W daemon.info pppd[946]: Exit.
    2012-02-23 10:58:49 RV110W daemon.debug pptpd[944]: CTRL: Reaping child PPP[946]
    2012-02-23 10:58:49 RV110W daemon.info pptpd[944]: CTRL: Client 192.168.0.132 control connection finished

  • RE: Native Forte Clients with Express Services

    I would be very interested in hearing from anyone using Express who may
    have attempted using Native Forte Clients with Express Services, especially
    what problems/issues (if any) you encountered and whether you found it to
    be a successful way to develop complex screens where the 'look and feel'
    can't be achieved with Express alone.I wrote a general-purpose windows framework which uses Express Services for its
    database access. Had I known what I was letting myself in for, I probably
    wouldn't have attempted it! I started it when Express V1 was fairly new, and
    Express Windows did not support the types and complexity of relationships
    required by the application we were developing. I soon discovered how
    difficult it is to implement a completely general framework which handles every
    possible permutation. Obviously I ended up making compromises, but what we
    have now meets our needs very well. We are about to upgrade to Express V2, so
    the real test will be whether the framework migrates smoothly to the new
    release.
    If I were starting a new project now with Express V2, I don't know if I would
    go down the same path. If you do, be aware of the following (based on my
    experience of Express V1):
    * Your design MUST obey the fundamental rules of Express Services. Your
    BusinessQueries must be fired off by the correct BusinessClient subclass,
    your BusinessClass attributes must be logged at the right time (depending
    on which concurrency scheme you are using), and you must start and end
    Express transactions (different to Forte transactions) appropriately.
    * Your design needs to take into account the difference in the way Express
    Services handles aggregate and non-aggregate associations.
    * If you manage parent-child class relationships from your windows, you must
    make sure you set and log foreign key attributes at the right time. If
    the relationship is not aggregation, you must also manage the order in
    which the records are saved to the database (if you use referential
    integrity constraints).
    * If you call Express Services directly from the windows, it is hard to
    reconcile the asynchronous nature of a windows interface with the
    database's requirement for things to happen in a certain order. (From
    memory, there was a very good discussion in this user group last year of
    what should constitute a unit of work in the windows paradigm.) If I
    were doing it again, I would move all the Express-related objects and
    method calls from the windows to a separate layer, which would manage
    putting together the data from multiple windows, assigning foreign keys
    and firing things off in the right order.
    Fiona Symon
    Babylon Software Pty Ltd

    Hello Kevin,
    Normally, it has been corrected from the last public release 2.
    Hope this helps.
    Daniel Nguyen
    Kevin Klein wrote:
    >
    We had a similar problem. We reported the problem to Forte technical
    support and they determined that it is a bug. I don't know if this has been
    fixed in the 3.0.F release.
    The Stopwatch seems to be accurate for long (several second) intervals, but
    it can't be trusted for measuring short intervals.
    Kevin Klein
    Millennium Partners, Inc.
    -----Original Message-----
    From: [email protected] <[email protected]>
    To: [email protected] <[email protected]>
    Date: Tuesday, December 30, 1997 1:40 PM
    Subject: The Forte Stopwatch
    All,
    At our site we are using Windows NT 4.0 clients and a Windows NT
    Server with Forte 3.0.E.0.
    Periodically, we use the Forte StopWatch class to measure durations for
    access to data. We've noticed
    a strange phenomenon, and we're not sure if it's simply circumstance or if
    there's a problem. All of the
    measured durations that we receive through the Split method appear to
    contain either a 0 or a 9 in the
    tenth-of-a-second position. For example, values of 1011 and 1912. Has
    anybody noticed this?
    Thank you,
    Keith
    Name: Kevin Klein.vcf
    Part 1.2 Type: text/x-vcard
    Encoding: 7bit

  • Native Windows Authentication in Java?

    I'm maintaining a Java web app that runs on a Windows server and needs to use native Windows authentication to do a pass/fail validation of a client's user/pass/domain credentials.
    Currently, the app uses JNI to make a simple LogonUserW call, however JNI is causing a variety of headaches. I was wondering if Java can do Windows authentication with JAAS or Java SSO technology. I'm new to Java security APIs so any pointers are greatly appreciated.
    Thanks!

    I'm maintaining a Java web app that runs on a Windows server and needs to use native Windows authentication to do a pass/fail validation of a client's user/pass/domain credentials.
    Currently, the app uses JNI to make a simple LogonUserW call, however JNI is causing a variety of headaches. I was wondering if Java can do Windows authentication with JAAS or Java SSO technology. I'm new to Java security APIs so any pointers are greatly appreciated.
    Thanks!

  • DirectAccess - IPHTTPS Tunnel with native IPv6 client

    I observed that in a DirectAccess KerbProxy scenario, a Windows 8.1 DirectAccess client with native IPv6 Internet connectivity is still using the IP-HTTPS transition technology for connecting to a Windows 2012R2 DirectAccess server also with native IPv6
    Internet connectivity.
    Is this normal behavior, even when native IPv6 Internet connectivity is available?
    Note 1: the use of the IP-HTTPS transition technology is confirmed with a Wireshark/NetMon trace.
    Note 2: see also the related thread
    http://social.technet.microsoft.com/Forums/en-US/e4bbb30e-161a-4847-918d-ba34934b4877/directaccess-double-dns-registration-issue-with-native-ipv6-client?forum=winserverNIS
    Regards,
    Stefaan

    After some more research I found the Technet article
    http://technet.microsoft.com/en-us/library/ee844198(v=WS.10).aspx. If that's still valid then no IPHTTPS should be used at all as both the DA client and the DA server have a public IPv6 address and can reach each other.
    DA Client:
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
       Physical Address. . . . . . . . . : 9C-B6-54-EF-D9-37
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2a02:a010:1:12::10(Preferred)
       Link-local IPv6 Address . . . . . : fe80::75df:2d9e:9fa6:a730%3(Preferred)
       IPv4 Address. . . . . . . . . . . : 172.29.0.16(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.240.0
       Default Gateway . . . . . . . . . : 2a02:a010:1:12::1
                                           172.29.0.1
       DHCPv6 IAID . . . . . . . . . . . : 60601940
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1B-74-91-FD-9C-B6-54-EF-D9-37
       DNS Servers . . . . . . . . . . . : 195.238.2.21
                                           195.238.2.22
       NetBIOS over Tcpip. . . . . . . . : Enabled
    DA Server:
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : vmxnet3 Ethernet Adapter #2
       Physical Address. . . . . . . . . : 00-50-56-87-24-4C
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2a02:a010:1:20::203(Preferred)
       Link-local IPv6 Address . . . . . : fe80::7960:e687:d4f3:4bf6%18(Preferred)
       IPv4 Address. . . . . . . . . . . : 193.75.143.203(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 2a02:a010:1:20::21
                                           193.75.143.21
       DHCPv6 IAID . . . . . . . . . . . : 520114262
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1B-39-9F-8F-00-50-56-87-31-60
       DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                           fec0:0:0:ffff::2%1
                                           fec0:0:0:ffff::3%1
       NetBIOS over Tcpip. . . . . . . . : Disabled
    Also, why do we see in the "DirectAccess Policy-DaServerToCorpSimplified" as "Local Tunnel Endpoint" on the DA Server and as "Remote Tunnel Endpoint" on the DA Client the IPv6 address 2002:c14b:8fcb::c14b:8fcb ? That's the "Tunnel adapter 6TO4 Adapter"
    of the DA Server. Shouldn't that be the IPv6 address 2a02:a010:1:20::203 in our case?
    Regards,
    Stefaan

  • Windows Client Logons Stop - Auth still works.

    I've got this new XServe Intel in at the moment.
    It's got Open Directory installed and as a Master, Runs DNS and DHCP, as well as Windows services.
    Also runs Emails, IMAP and POP3.
    The problem I'm having is that the Windows clients that have been joined to the domain decide to stop working, and says the password is wrong until the you go into ServerAdmin and stop Windows Services and then Start it again.
    The thing is, if you try to connect to the machine using SMB from a laptop, it asks for the user and password and you can log in fine and it all works, it's just stopping the actual Logon with the Windows Clients
    Emails and things still authenticate fine.
    Any ideas, it's driving me nuts, I've checked out the logs with with Password Service, Open Directory, the Samba logs too. Nothing reveals anything to why it would be stopping. I changed all the logging levels to high too.
    I've occasionally had PasswordService crash, but it didn't crash this time around when it stopped working.

    I can think of 2 reasons why you might have this problem.
    1) WINS service is either not running or misconfigured
    2) The Master Browser elections are failing (this is also tied to WINS)
    I would make certain that WINS is correctly configured and running, then try to find out if another computer on your network is claiming Master Browser status.
    I had a similar problem in a network of all NT machines, and it turned out that one of the users was a little too smart for his own good. He had purchased his own copy of NT Server (don't ask me why....) and had installed it as a Standalone Server with a Workgroup name that matched the Domain name of the PDC. Master Browser elections were happening every 15 minutes or so, and people could use the network for about 10 minutes out of every hour.
    Good luck chasing down this problem.
    -Gregg

  • IFolder windows client works first but fails on 2nd connect

    Hello,
    this is a strange phenomenon. I installed iFolder server 3.8 on Ubuntu 10.04 as described in
    http://www.x2b4.com/howto/how-to-install-ifolder-on-ubuntu-server (install from RPM).
    Web access works fine from Linux and Windows. The windows client works totally fine initially, it connects, creates folders, synchronizes. But if I hit disconnect in the iFolder window and then try to connect again, the application crashes. On starting it again connection takes forever, asks for a password, and then crashes before the iFolder window appears. Next time I start, the iFolder window appears but at the next (automatic) synchronization connecting fails again.
    What went wrong in between the initial configuration of the client and the next connection to the server????
    Thanks for any ideas
    Jan

    hello
    ia have the same problem.
    have you solved it ?
    regards
    lukasz
    Originally Posted by resap
    Hello,
    this is a strange phenomenon. I installed iFolder server 3.8 on Ubuntu 10.04 as described in
    How to install iFolder on Ubuntu server (install from RPM).
    Web access works fine from Linux and Windows. The windows client works totally fine initially, it connects, creates folders, synchronizes. But if I hit disconnect in the iFolder window and then try to connect again, the application crashes. On starting it again connection takes forever, asks for a password, and then crashes before the iFolder window appears. Next time I start, the iFolder window appears but at the next (automatic) synchronization connecting fails again.
    What went wrong in between the initial configuration of the client and the next connection to the server????
    Thanks for any ideas
    Jan

Maybe you are looking for

  • Word Processing App

    I recently bought an iPad, and I need to get an app for word processing.  My MacBook has Microsoft office and my concern is that if I buy Pages for the iPad I will have compatability issues.  The same can be said with PowerPoint and Keynotes too.  Is

  • Splitting multi-page ,PDF's

    I'm using Acrobat XI and trying to split a multi-sheet .PDF.  I've found information that says there should be a "split pdf" command under the "Tools" menu.  Mine doesn't, why?

  • Checking input before sending request

    Hello JSP-fellows, I have an jsp-page with a number of input fields which I would like verify before I send the request. Is there any possibility that after pressing the submit button I go to a java script input check and if the check is not OK I do

  • Cisco call manager pub & sub definitions

    I'm just beginning to learn Cisco VOIP. Can someone explain to me in a simple way what SUB & PUB mean in relation to Cisco Unity & call manager mean, and how it's used in the real world. My supervisor wants me to do a unity & UCM backup, and I'm not

  • MAKE TWO VERSIONS OF AI

    Just like Photoshop, with or without 3D, How about splitting Illustrator into Print and Web. Print would be the good old fashion one file one document, no RGB colors and you can expand the printing options and tools. Web can keep the multiple documen