Communication Bottleneck

At my company, there is a major communication bottleneck between our different facilities. We have warehouses located in three states with our main corporate offices located in Michigan. The largest issue we have seem to be the way for instant communication. Phones can easily get tied up and when multiple people need to input, the main communication channel is email.
My question is does anyone know of a solution, such as an intranet software, or has anyone faced these issues and how did you tackle them?
This topic first appeared in the Spiceworks Community

The CPU informs the DMA hardware of the memory location where data that is associated with a particular process resides and the memory location the data is to be moved to. Once the DMA instructions are sent, the CPU can process other threads while the DMA hardware moves the data.Refer URL
http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3560/12225see/scg/swsnmp.htm

Similar Messages

  • RE: Polymorphism - retrieving type information from thedatabase or how

    Don,
    Ok but if I was to model a real restaurant, I would then have a head chef
    that can then delegate to other chefs. This head chef would have the
    additional task of coordinating the completion of subservient chefs. This
    does not and would not mean that the head chef is stuck (or partitioned) in
    one part of the kitchen. Further a head chef would most likely also be a
    chef so that he would be running around the kitchen using and interacting
    with different objects to get his part of the recipe completed. Then once
    all chefs have completed their part of the recipe the head chef could return
    the meal.
    I would also point out that it does not make sense to me to be talking about
    the chef and its ability to scale. I would look that the resource limited
    devices that must be used to prepare meals to see scalability. In this case
    the grill, the stove and the microwave. Scalability of the restaurant is a
    function of the amount of resource limited devices versus the number of
    process (i.e. chefs) that need to use those devices concurrently and the
    amount of time they require access to those devices. By talking about chefs
    as if they are the scalability limiting factor seems to bring us back to the
    notion that the chef is a manager object that is shared. And again I come
    back to the question, why?
    You may now think that in a real restaurant, there are only so many chefs so
    why not make it a shared service? Well in a real restaurant there are only
    so many of any object, but this is not a consideration in our restaurant
    model. In our "virtual" restaurant hiring a chef is as easy as:
    Chef = new;
    And of course chefs are of zero mass so there can be a whole lot in the
    kitchen. Now assuming the Grill, Stove and Microwave map to physical
    objects in our computing environment, then that is the limiting factor and
    are therefore partitioned. Whenever communication has to go through a
    single source, then scalability breaks down. I fear that too many people
    make shared objects and create communication bottlenecks where they simply
    don't exist. The only place your scalability bottlenecks should exist is in
    the actual resource limited objects of your computing environment. Simply
    said, if something isn't a resource limited object, then why is it shared?
    If anyone is not clear how to architect an application independently of the
    business model, then I would suggest looking at various framework products
    and reading some technical architecture white papers to get a different, and
    possibly enlightening, point of view.
    Mark Perreira
    Sage IT Partners.
    -----Original Message-----
    From: Don Nelson [mailto:[email protected]]
    Sent: Wednesday, June 17, 1998 9:04 AM
    To: Mark Perreira
    Cc: [email protected]
    Subject: RE: Polymorphism - retrieving type information from the
    database
    Mark,
    First, I completely agree about the naming. I purposely used rather
    euphamistic names for these "managers", since I see many convoluted names
    for common things in various applications. But that is a topic for another
    thread...
    Simply because there is a "manager" of some type, does not imply that it is
    chained to a particular duty. However, let's look at a real life case. In
    a large restaurant, you would rarely see a chef chopping carrots or serving
    dishes to customers. Those are the responsibilities of the sous-chef and
    the waiter. So, we see that the chef does not really follow the food
    around. Why not? Because it simply doesn't scale. When scalability isn't
    a problem, (the restaurant isn't that popular, for example) the chef has
    some lattitude to accept more responsibility, and might even get involved
    with purchasing, etc.
    In the real world, the more scalable something has to be, the narrower the
    responsibilities are for each of the participating members.
    Don
    At 12:59 AM 6/17/98 -0700, Mark Perreira wrote:
    Don,
    One thing that always baffles me is when should an Object get the moniker
    "Manager." This practice seems to tell me a couple of things about these
    objects. In general when someone makes reference to a "Manager" objectthat
    it is probably a service object and probably contains no or very little
    attribution. The question is why? If I am developing an object model why
    am I thinking about such implementation issues.
    Surely if you are trying to model cooking an egg I would not see
    "SustenancePreparationManager" in your model. Using a more common term I
    would still be alarmed to see "CookManager" in your model. What does the
    CookManager manage? Does it manage other cooks or eggs. Maybe it shouldbe
    called an EggManager, but that doesn't make sense. How about just Cook.
    There that seems like the real world. And this brings me to a problem in
    the analogy. Conjuring up managers in a model can sometimes make you missa
    container. For example, I would say that if we wanted to model the real
    world, then eggs is a specialization of ingredient that is contained by
    recipe that can be given to a cook to be prepared.
    I may have many cooks (objects) that can prepare recipes and my application
    architecture not the object model needs to deal with how to best let those
    cooks utilize the grill, stove and microwave that sits on different
    partitions on my server. My cooks can move around and when they do they
    take their ability to know how to cook with them. In the real world Iwould
    expect a cook to use the right appliance to prepare the recipe based on its
    contents. I would not chain every cook to its appliance and them make me
    responsible for giving the right cook the right recipe. This is what
    managers can cause. They cause the consumer of cooks to know which cookcan
    prepare what recipes based on where they are chained. This then makes me
    know something about cooking. And if I don't know anything about cooking I
    can only image what my egg would look like if I accidentally gave therecipe
    to the cook stationed at the microwave.
    Ok Ok, I have seen many architectures use facades to hide the fact that I
    like to chain my cooks to their appliance. But what is that. I have gone
    to restaurants and I don't know what a cook facade is. If I ask themanager
    to present the cook facade manager employee I would probably be met by the
    bouncer employee.
    So what is the answer? Well for a start keep the application architecture
    out of the model. The model should stand alone in describing the
    interactions required to satisfy use cases. Second find an architecture
    that describes a more responsibility driven design and how that design and
    can map your business object behavior to a physical implementation with
    appliances and cooking rules. And lastly, don't be so quick to chain your
    cooks to their appliances. Give them some control over where they cook
    their recipes, after all that is what they do.
    Mark Perreira
    Sage IT Partners.
    -----Original Message-----
    From: [email protected]
    [<a href="mailto:[email protected]">mailto:[email protected]]On</a> Behalf Of Don Nelson
    Sent: Tuesday, June 16, 1998 2:07 PM
    To: Nick Willson
    Cc: [email protected]
    Subject: Re: Polymorphism - retrieving type information from the
    database
    This thread is switching context a bit, but I would add one thought tothe
    idea of encapsulating behavior. One of the advantages to OO is that it
    helps us model real world behavior. In the real world, I would not askan
    invoice to stuff itself into an envelope and mail itself to its
    customer; I
    would not ask my vehicle to fuel itself or change its own oil; I wouldnot
    tell an egg carton to ask one of its eggs to fry itself. Even if these
    things were physically feasible, I could list a number of reasons why I
    still wouldn't want to do them. That is why we haveVehicleRepairManagers
    and SustenancePreparationManagers (aka, "Mechanics" and "Cooks").
    Don
    At 11:28 PM 6/15/98 -0700, Nick Willson wrote:
    Tim,
    You've had lots of good suggestions so I hope you won't mind an attempt
    at another one. The consensus seems to be for your option (1) for the
    Vehicle table, and Steve's example of a GenericConstraint (taking the
    place of your Vehicle) is probably how most people would go about
    answering your question. I don't have much to add to that, just wanted
    to offer something about where the persistence mechanism lives and how
    things look to clients that depend on it.
    Suppose for a moment you think about the Vehicle classes' persistence as
    being just one aspect of their behavior. In addition to persistence,
    you might have to implement security, or locking for concurrent access,
    or caching of vehicle objects to improve performance, and of course you
    want to calculate the vehicle tax and probably do other things with
    Vehicles too.
    You can put the persistence aspect of Vehicles into a
    PersistenceObjectManager, but then the others need somewhere too. If
    you use a bunch of Managers (one for security, one for locking...) then
    each class's behavior is scattered across these various Manager classes,
    each of which has to know about many classes. Or if you use one Manager
    class, it's going to know still more, plus you are forced to implement
    all the behavior in (or at least via) that manager's partition.
    An alternative would be to keep all the Vehicle classes' behavior
    encapsulated together, so a client always makes requests to a Vehicle,
    and the Vehicle delegates the implementation of requests to a chain of
    handler objects that hang off the vehicle object (a handler for
    security, another for persistence, and so on).
    One of the nice things about this is, the handlers can be responsible
    for going to another partition (if necessary), e.g. to perform
    persistence operations, or for more business-specific operations like
    tax calculations. And because the handlers are smart, you don't have to
    put a lot of code into service objects, the SOs can stay pretty simple.
    This isn't an approach you'll see in Express, so I hope of it's of some
    interest.
    General wrote:
    Part 1.1 Type: Plain Text (text/plain)
    Encoding: quoted-printable--
    Nick Willson
    SCAFFOLDS Consultant,
    Sage IT Partners, Inc.
    (415) 392 7243 x 373
    [email protected]
    The Leaders in Internet Enabled Enterprise Computing
    To unsubscribe, email '[email protected]' with
    'unsubscribe forte-users' as the body of the message.
    Searchable thread archive <URL:<a href=
    "http://pinehurst.sageit.com/listarchive/">http://pinehurst.sageit.com/listarchive/</a>>
    >>>
    >>>
    >>
    >>
    ============================================
    Don Nelson
    Regional Consulting Manager - Rocky Mountain Region
    Forte Software, Inc.
    Denver, CO
    Phone: 303-265-7709
    Corporate voice mail: 510-986-3810
    aka: [email protected]
    ============================================
    "When you deal with higher numbers, you need higher math." - Hobbes
    To unsubscribe, email '[email protected]' with
    'unsubscribe forte-users' as the body of the message.
    Searchable thread archive <URL:<a href=
    "http://pinehurst.sageit.com/listarchive/">http://pinehurst.sageit.com/listarchive/</a>>
    >>
    >
    To unsubscribe, email '[email protected]' with
    'unsubscribe forte-users' as the body of the message.
    Searchable thread archive <URL:<a href=
    "http://pinehurst.sageit.com/listarchive/">http://pinehurst.sageit.com/listarchive/</a>>
    >
    >
    ============================================
    Don Nelson
    Regional Consulting Manager - Rocky Mountain Region
    Forte Software, Inc.
    Denver, CO
    Phone: 303-265-7709
    Corporate voice mail: 510-986-3810
    aka: [email protected]
    ============================================
    "When you deal with higher numbers, you need higher math." - Hobbes
    To unsubscribe, email '[email protected]' with
    'unsubscribe forte-users' as the body of the message.
    Searchable thread archive <URL:<a href=
    "http://pinehurst.sageit.com/listarchive/">http://pinehurst.sageit.com/listarchive/</a>>

    Don,
    You are absolutely correct. But this is where I honestly think you are
    missing the point. While the mail program sends the mail, my mail message
    has an interface (i.e. send button) which can delegate that to the mail
    program. This makes it nice and simple for me the consumer of the mail
    program. It also means I can think of mailing by focusing on the interface
    (i.e. the button). It would suck if every time I wanted to mail something I
    had to identify the correct pop server to send it to (i.e the MailManager).
    Mailing something is the collaboration of the setup information of the mail
    program and my mail message. If I were to model this my mail object would
    indeed have a send method that could delegate to the correct mail servers.
    This is just simplicity of interface and it is a good practice in UI
    development just as it is in business model development. A simpler
    interface, I think we can all agree, provides for a better and quicker
    understanding.
    Mark Perreira
    Sage IT Partners.
    -----Original Message-----
    From: [email protected]
    [<a href="mailto:[email protected]">mailto:[email protected]]On</a> Behalf Of Don Nelson
    Sent: Thursday, June 18, 1998 9:22 AM
    To: Nick Willson
    Cc: [email protected]
    Subject: Re: Polymorphism - retrieving type information from the
    database
    Nick,
    It turns out that your message does not, indeed send itself. Your mailing
    program does that.
    Don
    At 11:54 PM 6/17/98 -0700, Nick Willson wrote:
    Hey Don,
    In the real world, no, you can't tell an invoice to put itself into anenvelope
    and mail itself. You have to know about stamps and post boxes and wherethey
    are located. But isn't it nice that in software you don't have to followthe
    real world very closely if you don't want to?
    Above the top left hand corner of this message I'm typing right now, thereis a
    send button which lets me tell the message to 'stuff itself into anenvelope
    and mail itself'. Why wouldn't you want to do that?
    Don Nelson wrote:
    This thread is switching context a bit, but I would add one thought to
    the
    idea of encapsulating behavior. One of the advantages to OO is that it
    helps us model real world behavior. In the real world, I would not askan
    invoice to stuff itself into an envelope and mail itself to its customer;I
    would not ask my vehicle to fuel itself or change its own oil; I wouldnot
    tell an egg carton to ask one of its eggs to fry itself. Even if these
    things were physically feasible, I could list a number of reasons why I
    still wouldn't want to do them. That is why we haveVehicleRepairManagers
    and SustenancePreparationManagers (aka, "Mechanics" and "Cooks").
    Don
    At 11:28 PM 6/15/98 -0700, Nick Willson wrote:
    Tim,
    You've had lots of good suggestions so I hope you won't mind an attempt
    at another one. The consensus seems to be for your option (1) for the
    Vehicle table, and Steve's example of a GenericConstraint (taking the
    place of your Vehicle) is probably how most people would go about
    answering your question. I don't have much to add to that, just wanted
    to offer something about where the persistence mechanism lives and how
    things look to clients that depend on it.
    Suppose for a moment you think about the Vehicle classes' persistence as
    being just one aspect of their behavior. In addition to persistence,
    you might have to implement security, or locking for concurrent access,
    or caching of vehicle objects to improve performance, and of course you
    want to calculate the vehicle tax and probably do other things with
    Vehicles too.
    You can put the persistence aspect of Vehicles into a
    PersistenceObjectManager, but then the others need somewhere too. If
    you use a bunch of Managers (one for security, one for locking...) then
    each class's behavior is scattered across these various Manager classes,
    each of which has to know about many classes. Or if you use one Manager
    class, it's going to know still more, plus you are forced to implement
    all the behavior in (or at least via) that manager's partition.
    An alternative would be to keep all the Vehicle classes' behavior
    encapsulated together, so a client always makes requests to a Vehicle,
    and the Vehicle delegates the implementation of requests to a chain of
    handler objects that hang off the vehicle object (a handler for
    security, another for persistence, and so on).
    One of the nice things about this is, the handlers can be responsible
    for going to another partition (if necessary), e.g. to perform
    persistence operations, or for more business-specific operations like
    tax calculations. And because the handlers are smart, you don't have to
    put a lot of code into service objects, the SOs can stay pretty simple.
    This isn't an approach you'll see in Express, so I hope of it's of some
    interest.
    General wrote:
    Part 1.1 Type: Plain Text (text/plain)
    Encoding: quoted-printable--
    Nick Willson
    SCAFFOLDS Consultant,
    Sage IT Partners, Inc.
    (415) 392 7243 x 373
    [email protected]
    The Leaders in Internet Enabled Enterprise Computing
    To unsubscribe, email '[email protected]' with
    'unsubscribe forte-users' as the body of the message.
    Searchable thread archive <URL:<a href=
    "http://pinehurst.sageit.com/listarchive/">http://pinehurst.sageit.com/listarchive/</a>>
    >>>
    >>>
    >>
    ============================================
    Don Nelson
    Regional Consulting Manager - Rocky Mountain Region
    Forte Software, Inc.
    Denver, CO
    Phone: 303-265-7709
    Corporate voice mail: 510-986-3810
    aka: [email protected]
    ============================================
    "When you deal with higher numbers, you need higher math." - Hobbes--
    Nick
    To unsubscribe, email '[email protected]' with
    'unsubscribe forte-users' as the body of the message.
    Searchable thread archive <URL:<a href="http://pinehurst.sageit.com/listarchive/">http://pinehurst.sageit.com/listarchive/</a>>
    >
    >
    ============================================
    Don Nelson
    Regional Consulting Manager - Rocky Mountain Region
    Forte Software, Inc.
    Denver, CO
    Phone: 303-265-7709
    Corporate voice mail: 510-986-3810
    aka: [email protected]
    ============================================
    "When you deal with higher numbers, you need higher math." - Hobbes
    To unsubscribe, email '[email protected]' with
    'unsubscribe forte-users' as the body of the message.
    Searchable thread archive <URL:<a href=
    "http://pinehurst.sageit.com/listarchive/">http://pinehurst.sageit.com/listarchive/</a>>
    To unsubscribe, email '[email protected]' with
    'unsubscribe forte-users' as the body of the message.
    Searchable thread archive <URL:<a href=
    "http://pinehurst.sageit.com/listarchive/">http://pinehurst.sageit.com/listarchive/</a>>

  • New session rejected due to memory bottleneck in testing proxy2proxy

    Hi all!
    i am testing abap proxy2proxy on the client 105 in help varient 5 of simple use cases docu.
    even though i got sending successful from SXIPATT1 on the client 105, i got the following error.
    my server has RAM 2GB and have four client(100,105,106,107), and only i use for testing, NOT another person, so i do not think memory bottleneck issue.
    checked list.
    1. SXMB_MONI,  i could see inbound message(SENDER) <b>only.</b>
       from 105 to XI, no problem I thought, but very strange there, becasue there is only inbound message(sender).
    2. status flag on sxmb_moni
       Message Recorded (Commit follows) (TO BE DELIVERED)
    does anyone experience such issue?
    do i have to up physical memory?
    Error when processing your request
    What has happened?
    The URL http://sapxi.hh.net:8000/sap/bc/gui/sap/its/webgui/! was not called due to an error.
    Note
    The following error text was processed in the system XID : <b>New session rejected due to memory bottleneck</b>
    The error occurred on the application server SAPXI_XID_00 and in the work process 0 .
    The termination type was: ABORT_MESSAGE_STATE
    The ABAP call stack was:
    Function: ICF_ATTACH_ITS_PLUGIN of program SAPLHTTP_RUNTIME
    Form: EXECUTE_REQUEST of program CL_HTTP_SERVER================CP
    Function: HTTP_DISPATCH_REQUEST of program SAPLHTTP_RUNTIME
    Module: %_HTTP_START of program SAPMHTTP
    What can I do?
    If the termination type was RABAX_STATE, then you can find more information on the cause of the termination in the system XID in transaction ST22.
    If the termination type was ABORT_MESSAGE_STATE, then you can find more information on the cause of the termination on the application server SAPXI_XID_00 in transaction SM21.
    If the termination type was ERROR_MESSAGE_STATE, then you can search for more information in the trace file for the work process 0 in transaction ST11 on the application server SAPXI_XID_00 . In some situations, you may also need to analyze the trace files of other work processes.
    If you do not yet have a user ID, contact your system administrator.
    Error code: ICF-IE-http-c:105-u:XISUPER -l:E-s:XID-i:SAPXI_XID_00 -w:0-d:20060410-t:195211-v: ABORT_MESSAGE_STATE-e:
    HTTP 500 - Internal Server Error
    Your SAP Internet Communication Framework Team

    did you have  this entries in SXMB_ADM of XI server
    catgory:RUNTIME     parameter:ENGINE_TYPE     value:     HUB
    catgory:RUNTIME     parameter:IS_URL     value:http://server:port/sap/xi/engine?type=entry

  • New session was refused due to memory bottleneck

    Has anyone had experience with this error and know how to go about fixing it from occuring again?
    Error when processing your request
    What has happened?
    The URL https://____________/zpro was not called due to an error.
    Note
    The following error text was processed in the system DEV : New session was refused due to memory bottleneck
    The error occurred on the application server onebase_DEV_00 and in the work process 0 .
    The termination type was: ABORT_MESSAGE_STATE
    The ABAP call stack was:
    Function: ICF_ATTACH_ITS_PLUGIN of program SAPLHTTP_RUNTIME
    Method: EXECUTE_REQUEST_FROM_MEMORY of program CL_HTTP_SERVER================CP
    Function: HTTP_DISPATCH_REQUEST of program SAPLHTTP_RUNTIME
    Module: %_HTTP_START of program SAPMHTTP
    What can I do?
    If the termination type was RABAX_STATE, then you can find more information on the cause of the termination in the system DEV in transaction ST22.
    If the termination type was ABORT_MESSAGE_STATE, then you can find more information on the cause of the termination on the application server onebase_DEV_00 in transaction SM21.
    If the termination type was ERROR_MESSAGE_STATE, then you can search for more information in the trace file for the work process 0 in transaction ST11 on the application server onebase_DEV_00 . In some situations, you may also need to analyze the trace files of other work processes.
    If you do not yet have a user ID, contact your system administrator.
    Error code: ICF-IE-https -c: 160 -u: ****** -l: E -s: DEV -i: onebase_DEV_00 -w: 0 -d: 20080822 -t: 094930 -v: ABORT_MESSAGE_STATE -e: New session was refused due to memory bottleneck
    HTTP 500 - Internal Server Error
    Your SAP Internet Communication Framework Team

    Hi ,
    I am having an issue related to the query in this thread. Can you please let me know if you any solution for this.
         The following error text was processed in the system : Error occurred while sending data through the HTTP protocol.
         The error occurred on the application server bwdbi_DIB_41 and in the work process 0 .
         The termination type was: RABAX_STATE
         The ABAP call stack was:
    Method: SEND_RESPONSE of program CL_HTTP_SERVER_NET============CP
    Function: HTTP_DISPATCH_REQUEST of program SAPLHTTP_RUNTIME
    Module: %_HTTP_START of program SAPMHTTP
    tHE ABOVE IS THE error message. This occurs when we are trying to call the a URL from web report using RRI, where in this url is used for RRI.
    Regards
    Sudha

  • Unique look and feel based on community...

    and not the users experience folder ??? Thoughts?

    Much of this depends on how much maintenence you're willing to foist off on the Portal Administrator, how many communities there are, and how often things change.
    Back in the day, Plumtree's Content Server gave that ability, though with the other hands it took away scalability, bottlenecking every page request in publishedcontent.jsp.
    Depending on your circumstances (which I do not know) you could add a community preference to control some UI stuff and override the stylesheet that's coming to your page via the Experience Definition. This is one way in which I've helped customers retire Content Server.

  • Performance in Sun Java Communication Suite 5 between Solaris 9 and 10

    Somebody knows which is the best Operation System to deploy the Sun Java Communication Suite? in performance terms?
    I have and old Sun Fire 280R with two 750 Mhz Processors, 3 GB Ram, and an A1000 Storage.
    Thanks a lot,
    Andres.

    AYacopino wrote:
    Somebody knows which is the best Operation System to deploy the Sun Java Communication Suite? in performance terms?Solaris 10 by far for several reasons:
    -> improved overall performance (kernel/networking level)
    -> ZFS for storage
    -> dtrace for debugging
    -> zones for the various components of the communication suite (http://www.sun.com/blueprints/0806/819-7663.html)
    I have and old Sun Fire 280R with two 750 Mhz Processors, 3 GB Ram, and an A1000 Storage.I'm not sure how many users you are planning to provide access to but your RAM is going to be the bottleneck.
    Regards,
    Shane.

  • GetConnection() and close() bottlenecks

    Hi all
    When loadtesting our Weblogic 6.1 app with a SQL Server 2000 db I have found
    that the primary bottleneck are calls to Connection.getConnection() and
    Connection.close(). Often calls to these methods (15%) take about one second
    and about 1% of the time they can take more than 20 seconds. The cpu % of
    the appserver and dbserver never seems to go above about 30% as calls to
    getConnection() and close() seem to be just blocking a lot of the time.
    Also, the number of connections in use never seems to increas to more than
    half the max allowed so its not running out of available db connections.
    I am using a standard connection pool and TX datasource and have a cached
    reference to my initial context and datasource so its not JNDI that is
    causing the delays.
    I'm wondering why the obtaining and closing of connections is taking so long
    under load. Is anyone else experiencing these problems?
    My config.xml looks like
    <JDBCTxDataSource JNDIName="datasource-trading" Name="datasource-trading"
    PoolName="trading" Targets="tradingserver"/>
    <JDBCConnectionPool DriverName="weblogic.jdbc.mssqlserver4.Driver"
    InitialCapacity="10" MaxCapacity="20" Name="trading"
    Properties="user=trading;password=thepassword" Targets="tradingserver"
    TestConnectionsOnRelease="true" TestConnectionsOnReserve="true"
    TestTableName="application"
    URL="jdbc:weblogic:mssqlserver4:localhost:1433"/>
    The application test table contains 2 rows.
    My singleton class that handles getting/closing connections looks something
    like
    public class ConnectionPoolManager {
    private static InitialContext _context = null;
    private static DataSource _datasource = null;
    private static final String J2EE_DATASOURCE = "datasource-trading";
    private static Context getContext() throws NamingException {
    if (_context == null) _context = new InitialContext();
    return _context;
    public static DataSource getDataSource() throws NamingException {
    if (_datasource == null) _datasource = (DataSource)
    getContext().lookup.J2EE_DATASOURCE);
    return _datasource;
    public static Connection getConnection() throws SQLException {
    Connection c = null;
    try {
    c = getDataSource().getConnection();
    catch (NamingException ex) {
    throw new SQLException("Unable to locate DataSource " +
    J2EE_DATASOURCE);
    c.setAutoCommit(false);
    return c;
    public static void releaseConnection(Connection con) {
    if( con != null ) {
    try {
    con.rollback();
    con.close();
    } catch (SQLException e) {
    throw new RuntimeException("Unable to release database
    connection to the pool. " + e.getMessage());
    Can anyone see any obvious reasons why the getting and returning connections
    to the pool is taking so long? This is driving me crazy and delyaing my
    project from being deployed live.
    Thanks
    Matt

    Thanks Joe. I'll make the recommended changes and see how it goes.
    "Joe Weinstein" <[email protected]> wrote in message
    news:[email protected]...
    >
    >
    Matt Krevs wrote:
    Thanks Joe
    - I've tried turning off test-connections-on-release and it does
    decrease
    times a little (generally a few milliseconds). I'll make sure its turnedoff
    from now on.
    - The application table is never updated
    - All code runs in the same jvm
    - I have used SQL Profiler during loadtesting and the longest durationof
    any queries is about 2 seconds. I'm really stuck on why there is 1% ofthe
    time an additional 18+ seconds
    In your opinion, what would typically cause a close() or getConnection()to
    take 20 seconds+? I've also found that rollback() can also take thislong
    >
    If rollback is included, then it's the DBMS taking it's own sweet time torespond.
    GetConnection() should be instantaneous from a pool that has connectionsavailable,
    except for the time it takes to do the test query, so the DBMS is againimplicated.
    Close() calls rollback() if the connection is autoCommit(false). Close()also closes
    any result sets or statements you have left...
    If you turn of test-on-reserve, (even just for a test), it will removeall
    the extra client-dbms communication, and will implicate the DBMScompletely if the
    problem is still there, and you have enough connections in the pool.Lastly,
    you might try this code for obtaining pool connections: (it may be faster)
    // You can make one and re-use indefinitely
    Driver d = new weblogic.jdbc.pool.Driver();
    Connection c = d.connect("jdbc:weblogic:pool:YOURPOOLNAME", null );
    Joe
    Matt
    "Joe Weinstein" <[email protected]> wrote in message
    news:[email protected]...
    Matt Krevs wrote:
    Hi all
    When loadtesting our Weblogic 6.1 app with a SQL Server 2000 db I have
    found
    that the primary bottleneck are calls to Connection.getConnection() and
    Connection.close(). Often calls to these methods (15%) take about onesecond
    and about 1% of the time they can take more than 20 seconds. The cpu %of
    the appserver and dbserver never seems to go above about 30% as calls
    to
    getConnection() and close() seem to be just blocking a lot of the time.
    Also, the number of connections in use never seems to increas to morethan
    half the max allowed so its not running out of available db
    connections.
    >>>>
    I am using a standard connection pool and TX datasource and have acached
    reference to my initial context and datasource so its not JNDI that is
    causing the delays.
    I'm wondering why the obtaining and closing of connections is taking solong
    under load. Is anyone else experiencing these problems?
    My config.xml looks like
    <JDBCTxDataSource JNDIName="datasource-trading"Name="datasource-trading"
    PoolName="trading" Targets="tradingserver"/>
    <JDBCConnectionPool DriverName="weblogic.jdbc.mssqlserver4.Driver"
    InitialCapacity="10" MaxCapacity="20" Name="trading"
    Properties="user=trading;password=thepassword" Targets="tradingserver"
    TestConnectionsOnRelease="true" TestConnectionsOnReserve="true"
    TestTableName="application"
    URL="jdbc:weblogic:mssqlserver4:localhost:1433"/>
    The application test table contains 2 rows.
    My singleton class that handles getting/closing connections lookssomething
    like
    public class ConnectionPoolManager {
    private static InitialContext _context = null;
    private static DataSource _datasource = null;
    private static final String J2EE_DATASOURCE = "datasource-trading";
    private static Context getContext() throws NamingException {
    if (_context == null) _context = new InitialContext();
    return _context;
    public static DataSource getDataSource() throws NamingException {
    if (_datasource == null) _datasource = (DataSource)
    getContext().lookup.J2EE_DATASOURCE);
    return _datasource;
    public static Connection getConnection() throws SQLException {
    Connection c = null;
    try {
    c = getDataSource().getConnection();
    catch (NamingException ex) {
    throw new SQLException("Unable to locate DataSource " +
    J2EE_DATASOURCE);
    c.setAutoCommit(false);
    return c;
    public static void releaseConnection(Connection con) {
    if( con != null ) {
    try {
    con.rollback();
    con.close();
    } catch (SQLException e) {
    throw new RuntimeException("Unable to release database
    connection to the pool. " + e.getMessage());
    Can anyone see any obvious reasons why the getting and returningconnections
    to the pool is taking so long? This is driving me crazy and delyaing my
    project from being deployed live.
    Thanks
    MattHi. You should turn off test-connections-on-release. That can waste
    time.
    Does your application ever update the application table? Does this code
    and it's clients run in the server?
    Joe
    >

  • How to improve spreadsheet speed when single-threaded VBA is the bottleneck.

    My brother works with massive Excel spreadsheets and needs to speed them up. Gigabytes in size and often with a million rows and many sheets within the workbook. He's already refined the sheets to take advantage of Excel's multi-thread recalculation and
    seen significant improvements, but he's hit a stumbling block. He uses extensive VBA code to aid clarity, but the VB engine is single-threaded, and these relatively simple functions can be called millions of times. Some functions are trivial (e.g. conversion
    functions) and just for clarity and easily unwound (at the expense of clarity), some could be unwound but that would make the spreadsheets much more complex, and others could not be unwound. 
    He's aware of http://www.analystcave.com/excel-vba-multithreading-tool/ and similar tools but they don't help as the granularity is insufficiently fine. 
    So what can he do? A search shows requests for multi-threaded VBA going back over a decade.
    qts

    Hi,
    >> The VB engine is single-threaded, and these relatively simple functions can be called millions of times.
    The Office Object Model is
    Single-Threaded Apartments, if the performance bottleneck is the Excel Object Model operation, the multiple-thread will not improve the performance significantly.
    >> How to improve spreadsheet speed when single-threaded VBA is the bottleneck.
    The performance optimization should be based on the business. Since I’m not familiar with your business, so I can only give you some general suggestions from the technical perspective. According to your description, the size of the spreadsheet had reached
    Gigabytes and data volume is about 1 million rows. If so, I will suggest you storing the data to SQL Server and then use the analysis tools (e.g. Power Pivot).
    Create a memory-efficient Data Model using Excel 2013
    and the Power Pivot add-in
    As
    ryguy72 suggested, you can also leverage some other third party data processing tool
    according to your business requirement.
    Regards,
    Jeffrey
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click
    HERE to participate the survey.

  • Will RAC's performance bottleneck be the shared disk storage ?

    Hi All
    I'm studying RAC and I'm concerned about RAC's I/O performance bottleneck.
    If I have 10 nodes and they use the same storage disk to hold database, then
    they will do I/Os to the disk simultaneously.
    Maybe we got more latency ...
    Will that be a performance problem?
    How does RAC solve this kind of problem?
    Thanks.

    J.Laurence wrote:
    I see FC can solve the problem with bandwidth(throughput),There are a couple of layers in the I/O subsystem for RAC.
    There is CacheFusion as already mentioned. Why read a data block from disk when another node has it in is buffer cache and can provide that instead (over the Interconnect communication layer).
    Then there is the actual pipes between the server nodes and the storage system. Fibre is slow and not what the latest RAC architecture (such as Exadata) uses.
    Traditionally, you pop a HBA card into the server that provides you with 2 fibre channel pipes to the storage switch. These usually run at 2Gb/s and the I/O driver can load balance and fail over. So it in theory can scale to 4Gb/s and provide redundancy should one one fail.
    Exadata and more "+modern+" RAC systems use HCA cards running Infiniband (IB). This provides scalability of up to 40Gb/s. Also dual port, which means that you have 2 cables running into the storage switch.
    IB supports a protocol called RDMA (Remote Direct Memory Access). This essentially allow memory to be "+shared+" across the IB fabric layer - and is used to read data blocks from the storage array's buffer cache into the local Oracle RAC instance's buffer cache.
    Port to port latency for a properly configured IB layer running QDR (4 speed) can be lower than 70ns.
    And this does not stop there. You can of course add a huge memory cache in the storage array (which is essentially a server with a bunch of disks). Current x86-64 motherboard technology supports up to 512GB RAM.
    Exadata takes it even further as special ASM software on the storage node reconstructs data blocks on the fly to supply the RAC instance with only relevant data. This reduces the data volume to push from the storage node to the database node.
    So fibre channels in this sense is a bit dated. As is GigE.
    But what about the hard drive's reading & writing I/O? Not a problem as the storage array deals with that. A RAC instance that writes a data block, writes it into storage buffer cache.. where the storage array s/w manages that cache and will do the physical write to disk.
    Of course, it will stripe heavily and will have 24+ disk controllers available to write that data block.. so do not think of I/O latency ito of the actual speed of a single disk.

  • Macbook Pro with retina display : GPU bottleneck?

    The new exciting MPB with retina doesn't offer any upgrade for the most powerful Nvidia Geforce GTX 680M. Do you think the actual 650M would be a bottleneck?
    Just checked some benchmarks at http://community.futuremark.com/hardware/gpu/NVIDIA+GeForce+GT+650M/games
    Doesn't seem to be able to run most of the games there at recommended settings. Deceiving for such an expensive computer...

    Try a SMC reset: Intel-based Macs: Resetting the System Management Controller (SMC)

  • Will RAM upgrade on Macbook Air result in a bottleneck?

    Ask a Question
    86 character(s) left
    170 character(s) left
    Make sure your question follows the community guidelines.
    Cancel
    Continue
    Edit Question
    Preview Your Question
    Will RAM upgrade on Macbook Air result in a bottleneck?
    Hi I am planning to buy a Macbook Air with the base configuration, but was giving the RAM some thought. I was thinking of upgrading it from 4 GB 1600 MHz LPDDR3 SDRAM to 8 GB. With the student discount the upgrade will cost me an additional $90. I will be going to uni for life sci and will be be using it for work assignments, music, and maybe some small-time gaming. I currently don't really game much but maybe sometime in the future I may decide to play games such as LoL or Warcraft maybe?  What I was wondering was that is it actually necessary to upgrade the RAM to be able to play these types of games without lag? I am fine with a little bit of low fps, as long as it isn't to noticable and stil fairly smooth. Maybe with like safari with music and a word processor and the game open, would the MBA be able to handle it effectively? Also, would the RAM upgrade be ineffective because of a "bottleneck" where the other specs limit the effectiveness of the increase in RAM?  The rest of the specs are: 1.4 GHz dual-core Intel i5, Turbo Boost upto 2.7 GHz Intel HD Graphics 5000 128 GB PCle-based flash storage  So overall, is it worth it? Will it make gaming significantly better, and more importantly, will 4 GB just be enough too?  Thank you very much for reading that very long question! All answers will be appreciated!

    Did you get a reply on that site?
    Are you comparing 11-inch/13-inch MacBook/Air to 13"-15" MB/Pro?
    A better idea would be to get the MacBook/Pro, since it has a better
    processor and a higher RAM spec capacity, when or if upgraded.
    More RAM will not be a bottleneck; a slow CPU processor & too much
    demand could. Including video demand, and gaming is unlikely, too.
    Check the specs at the Apple Store to compare MB/Pro w/ MB/Air;
    even the basic MacBook Pro 13-inch without Retina has a fair CPU
    and OK specs for most things; and you may be able to still upgrade
    the RAM in that basic model (also has optical drive built-in) yourself.
    See everymac.com and mactracker.ca for sources of specifications.
    Good luck & happy computing!

  • ANNOUNCEMENT: Advisor Webcast: WebCenter Content: Finding the Bottleneck

    Gain a better understanding of your WebCenter Content Server’s performance capability or performance issues by attending this 1 hour Advisor Webcast!
    Topic: WebCenter Content: Finding the Bottleneck
    When: June 7, 2012 at 16:00 UK / 17:00 CET / 08:00 am Pacific / 9:00 am Mountain / 11:00 am Eastern
    This one-hour session is recommended for technical and functional users who use WebCenter Content. This session will focus on gathering and analyzing information related to general system performance. Performance issues are very complex with many factors involved and the first steps are crucial in narrowing down the issue and identifying a root cause.
    TOPICS WILL INCLUDE:
    Identify high level topics to aid in narrowing the issue
    Gathering content server logs including system audit tracing.
    Analyzing requestaudit tracing to pinpoint possible bottlenecks
    Gathering JVM thread information to help identify any "stuck" or "locked" processes
    Identifying potential memory issues using system tools such as Jrockit Mission Control and/or VisualVM
    Provide various configuration flags and settings to help identify and alleviate performance issues
    Make sure to register and mark this date on your calendar! - Click http://bitly.com/K7cmhQ for details.

    You need to keep in mind that these OTN forums are user community forums and are publicly viewable to anyone with a web browser on the Internet.
    If you are to present a link into a forum post it needs to be a freely available link, else you need to qualify your post if it is not.
    If CSI/MOS login credentials are required (which seems to be the case here) then you need to be aware of that and state that fact. If your link is to be restricted to company-internal or for partner-only access, you need to state that.
    (... and company-internal or partner-only postings have no place in these user community forums)

  • Bottleneck on reqID generation, row insert

    Running under CF7.02 and SQL Server 2000, we're getting
    bottlenecks on attempting database inserts into our by far most
    active requests table. Within the database transaction, we check to
    see if the request is a duplicate. Then we do an exclusive type
    cflock with timeout of 90, set key column as 1 plus current max
    key, insert the new row and clear the lock. We then do CFLDAPs to
    check for dups and then modify an ldap group to reflect the
    request. Then the transaction ends.
    We're getting a lot of timeouts while attempting to do the
    cflock. Under high user load (3-4 times normal number of site
    visitors), the ColdFusion server becomes nonresponsive.
    Is there anything we can do on the database or ColdFusion app
    server side to reduce the timeouts and keep our site up? Any
    suggestions appreciated.

    Farfel wrote:
    > Running under CF7.02 and SQL Server 2000, we're getting
    bottlenecks on
    > attempting database inserts into our by far most active
    requests table. Within
    > the database transaction, we check to see if the request
    is a duplicate. Then
    > we do an exclusive type cflock with timeout of 90, set
    key column as 1 plus
    > current max key, insert the new row and clear the lock.
    We then do CFLDAPs to
    > check for dups and then modify an ldap group to reflect
    the request. Then the
    > transaction ends.
    MS SQL Server does predicate locking so every row you read in
    a
    transaction is locked until the end of your transaction.
    Since you are
    doing a MAX style query you are reading the entire table and
    the entire
    table is locked until the commit. Since that includes the
    LDAP call that
    can take a long time. (Try it, open 2 query analyzer windows,
    in the
    first one run "begin transaction; select max(X) from Y;
    insert into X
    (y) values (z);" and then do the same in the second screen
    and you will
    see it waits for a commit on the first screen.)
    To solve this either use some other way to generate the next
    ID or
    upgrade to MS SQL Server 2005 and switch to snapshot
    isolation.
    Jochem
    Jochem van Dieten
    Adobe Community Expert for ColdFusion

  • Ejb client to ejb communication- slow performance ?

    I think BEA has a very nasty implementation of ejb client to ejb server communication.
    When a client looks up a an ejb component it gets a t3client eastablishing a socket connection to the ejb server (WL server).
    For one client VM there is one such client and all ejb client to server packets go through this one socket. To me it seems to be a major bottleneck for performance.
    Any body has any info ideas on how to get around this.

    What makes you think it's a bottleneck? It nearly always greatly improves performance.
    -- Rob
    Vyask wrote:
    I think BEA has a very nasty implementation of ejb client to ejb server communication.
    When a client looks up a an ejb component it gets a t3client eastablishing a socket connection to the ejb server (WL server).
    For one client VM there is one such client and all ejb client to server packets go through this one socket. To me it seems to be a major bottleneck for performance.
    Any body has any info ideas on how to get around this.

  • Sqlnet Communication problem

    Hi Community,
    I have a challenge getting 2 Oracle servers with each located in "internal" and "DMZ" network segments.
    The oracle server on the internal network can communicate with the one on the DMZ but the one on the DMZ can NOT talk to the one on the internal network.
    The customer wants the architecture to enable realtime data updates on the Oracle in DMZ.
    My config is as follows: I need help.
    ciscoasa# wr t
    : Saved
    ASA Version 8.4(3)
    hostname ciscoasa
    domain-name default.domain.invalid
    enable password 8Ry2YjIyt7RRXU24 encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    name 10.1.184.131 Proxy_Server
    name 192.168.10.1 Internet_Router
    name 10.1.184.122 Mail_Server
    name 10.1.184.116 Mail_Server_2
    name 10.1.184.121 Mail_Server_3
    dns-guard
    interface GigabitEthernet0/0
    nameif Inside
    security-level 100
    ip address 10.1.184.1 255.255.248.0 standby 10.1.184.254
    interface GigabitEthernet0/1
    description LAN/STATE Failover Interface
    interface GigabitEthernet0/2
    nameif DMZ
    security-level 50
    ip address 192.168.30.1 255.255.255.0 standby 192.168.30.2
    interface GigabitEthernet0/3
    nameif Outside
    security-level 0
    ip address 192.168.10.2 255.255.255.0 standby 192.168.10.20
    interface Management0/0
    nameif management
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    management-only
    boot system disk0:/asa843-k8.bin
    ftp mode passive
    clock timezone GMT 1
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    object network Proxy_Server
    host 10.1.184.131
    object network Mail_Server
    host 10.1.184.122
    object network Internet_Router
    host 192.168.10.1
    description Created during name migration
    object network Mail_Server_2
    host 10.1.184.116
    description Created during name migration
    object network Mail_Server_3
    host 10.1.184.121
    description Created during name migration
    object network WebServer1
    host 192.168.30.3
    object network InternalNetwork
    subnet 10.1.184.0 255.55.248.0
    object network DMZ-IdentityPool
    range 192.168.30.30 192.168.30.254
    object network WebServer2
    host 192.168.30.4
    object network obj-remote
    subnet 192.168.0.0 255.255.255.0
    object network obj-DMZ
    subnet 192.16.30.0 255.255.255.0
    object network DatabaseServer
    host 10.1.184.134
    object network AppServer
    host 10.1.184.126
    object network MailServer
    host 10.1.184.116
    access-list Inside_access_in extended permit ip object Proxy_Server any
    access-list Inside_access_in extended permit ip host 10.1.184.190 any
    access-list Inside_access_in extended permit ip host 10.1.184.83 any
    access-list Inside_access_in extended permit icmp host 10.1.184.190 any
    access-list Inside_access_in extended permit ip host 10.1.184.67 any inactive
    access-list Inside_access_in extended permit ip host 10.1.184.83 object Internet_Router
    access-list Inside_access_in extended permit ip host 10.1.184.190 object Internet_Router
    access-list Inside_access_in extended permit udp any any
    access-list Inside_access_in extended permit icmp any any
    access-list Inside_access_in extended permit ip object Mail_Server any
    access-list Inside_access_in extended permit tcp object Mail_Server any eq smtp
    access-list Inside_access_in extended permit ip object Mail_Server_2 any
    access-list Inside_access_in extended permit tcp object Mail_Server_2 any eq smtp
    access-list Inside_access_in extended deny tcp any any eq smtp
    access-list Inside_access_in extended permit icmp host 10.1.184.43 any
    access-list Inside_access_in extended permit ip object Mail_Server_3 any
    access-list Inside_access_in extended permit tcp object Mail_Server_3 any eq smtp
    access-list Inside_access_in extended permit ip host 10.1.184.190 host 192.168.30.3
    access-list Inside_access_in extended permit tcp object InternalNetwork host 192.168.30.3 eq www
    access-list Inside_access_in extended permit ip host 10.1.184.137 host 10.1.184.133
    access-list Inside_access_in extended permit ip host 10.1.184.62 host 10.1.184.133
    access-list Inside_access_in extended permit ip host 10.1.184.117 any
    access-list Inside_access_in extended permit ip host 10.1.184.117 object Internet_Router
    access-list Inside_access_in extended permit ip host 10.1.184.129 any
    access-list Inside_access_in extended permit ip host 10.1.184.129 object Internet_Router
    access-list Inside_access_in extended permit ip host 10.1.184.150 host 10.1.184.133
    access-list Inside_access_in extended permit ip host 10.1.184.150 any
    access-list Inside_access_in extended permit ip host 10.1.184.190 host 192.168.30.4
    access-list Inside_access_in extended permit tcp object InternalNetwork host 192.168.30.4 eq www
    access-list Inside_access_in extended permit tcp host 10.1.184.134 host 192.168.30.4 eq sqlnet
    access-list Outside_access_in extended permit udp any eq domain object Proxy_Server
    access-list Outside_access_in extended permit icmp object Internet_Router any
    access-list Outside_access_in extended permit icmp any host 10.1.184.190
    access-list Outside_access_in extended permit icmp any host 10.1.184.83 inactive
    access-list Outside_access_in extended permit tcp any object Proxy_Server eq https
    access-list Outside_access_in extended permit tcp any object Proxy_Server eq www
    access-list Outside_access_in extended permit tcp any object Mail_Server eq smtp inactive
    access-list Outside_access_in extended permit tcp any object Mail_Server_2 eq pop3
    access-list Outside_access_in extended permit udp any eq domain object Mail_Server_2
    access-list Outside_access_in extended permit tcp any object Mail_Server eq imap4 inactive
    access-list Outside_access_in extended permit icmp any object Mail_Server inactive
    access-list Outside_access_in extended permit tcp any object Mail_Server_2 eq smtp
    access-list Outside_access_in extended permit tcp any object Mail_Server_2 eq imap4
    access-list Outside_access_in extended permit icmp any object Mail_Server_2
    access-list Outside_access_in extended permit icmp any host 10.1.184.43
    access-list Outside_access_in extended permit tcp any host 192.168.30.3 eq www
    access-list Outside_access_in extended permit tcp any host 192.168.30.3 eq https
    access-list Outside_access_in extended permit icmp any host 192.168.30.3
    access-list Outside_access_in extended permit icmp any any echo-reply
    access-list Outside_access_in extended permit icmp any host 192.168.30.3 echo
    access-list Outside_access_in extended permit tcp any host 192.168.30.4 eq www
    access-list Outside_access_in extended permit tcp any host 192.168.30.4 eq https
    access-list Outside_access_in extended permit icmp any host 192.168.30.4 echo
    access-list Outside_access_in extended permit icmp any host 192.168.30.4
    access-list branchgroup-SplitACL standard permit 10.0.0.0 255.0.0.0
    access-list branchgroup-SplitACL standard permit 192.168.30.0 255.255.255.0
    access-list DMZ_access_in extended permit tcp host 192.168.30.4 host 192.168.30.116 eq smtp
    access-list DMZ_access_in extended permit icmp host 192.168.30.4 any
    access-list DMZ_access_in extended permit ip host 192.168.30.4 host 192.168.30.134
    access-list DMZ_access_in extended permit tcp host 192.168.30.4 host 192.168.30.134 eq sqlnet
    pager lines 24
    logging enable
    logging timestamp
    logging standby
    logging emblem
    logging list InformationalLog level informational
    logging list InformationalLog message 101001
    logging buffer-size 16384
    logging console notifications
    logging monitor errors
    logging buffered critical
    logging trap errors
    logging asdm critical
    logging mail informational
    logging host Inside 10.1.184.132
    logging host Inside 10.1.184.190 6/1470
    logging debug-trace
    logging ftp-server 10.1.184.190 \\marinasec\akanoa akanoa *****
    logging permit-hostdown
    logging class auth buffered emergencies trap emergencies
    logging class bridge buffered emergencies trap emergencies
    logging class config buffered alerts trap emergencies
    logging class ip buffered emergencies trap alerts
    logging class sys trap alerts
    logging class ca trap emergencies
    logging class email buffered emergencies trap errors
    mtu Inside 1500
    mtu DMZ 1500
    mtu Outside 1500
    mtu management 1500
    ip local pool remoteusers 192.168.0.1-192.168.0.254
    failover
    failover lan unit secondary
    failover lan interface stateful_failover GigabitEthernet0/1
    failover replication http
    failover link stateful_failover GigabitEthernet0/1
    failover interface ip stateful_failover 192.168.20.1 255.255.255.252 standby 192.168.20.2
    no monitor-interface management
    icmp unreachable rate-limit 1 burst-size 1
    icmp permit any Inside
    asdm image disk0:/asdm-647.bin
    no asdm history enable
    arp timeout 14400
    nat (DMZ,Outside) source static obj-DMZ obj-DMZ destination static obj-remote obj-remote
    nat (Inside,Outside) source static InternalNetwork InternalNetwork destination static obj-remote obj-remote
    object network Mail_Server
    nat (Inside,Outside) static Mail_Server no-proxy-arp route-lookup
    object network WebServer1
    nat (DMZ,Outside) static 192.168.30.3 dns
    object network WebServer2
    nat (DMZ,Outside) static 192.168.30.4 dns
    object network DatabaseServer
    nat (Inside,DMZ) static 192.168.30.134
    object network AppServer
    nat (Inside,DMZ) static 192.168.30.126
    object network MailServer
    nat (Inside,DMZ) static 192.168.30.116
    access-group Inside_access_in in interface Inside
    access-group DMZ_access_in in interface DMZ
    access-group Outside_access_in in interface Outside
    route Outside 0.0.0.0 0.0.0.0 Internet_Router 1
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server vpn protocol radius
    aaa-server vpn (Inside) host 10.1.184.119
    key *****
    aaa-server vpn (Inside) host 10.1.184.120
    key *****
    user-identity default-domain LOCAL
    http server enable
    http 10.1.184.190 255.255.255.255 Inside
    http 10.1.184.2 255.255.255.255 Inside
    http 10.1.184.83 255.255.255.255 Inside
    http 192.168.1.0 255.255.255.0 management
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec ikev1 transform-set rmtset esp-3des esp-md5-hmac
    crypto dynamic-map dyn1 1 set ikev1 transform-set rmtset
    crypto dynamic-map dyn1 1 set reverse-route
    crypto map mymap 1 ipsec-isakmp dynamic dyn1
    crypto map mymap interface Outside
    crypto ikev1 enable Outside
    crypto ikev1 policy 1
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 43200
    telnet 10.1.184.83 255.255.255.255 Inside
    telnet 10.1.184.190 255.255.255.255 Inside
    telnet 10.1.184.167 255.255.255.255 Inside
    telnet timeout 5
    ssh 10.1.184.83 255.255.255.255 Inside
    ssh 10.1.184.190 255.255.255.255 Inside
    ssh 10.1.184.43 255.255.255.255 Inside
    ssh timeout 5
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics
    threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
    webvpn
    group-policy branchgroup internal
    group-policy branchgroup attributes
    dns-server value 10.1.184.120
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value branchgroup-SplitACL
    default-domain value marinasecuritieslimited.com
    username sannib password 3gB/xWLMBVp/AjjW encrypted
    username adebimpel password O./lZ/3rlYD/87u2 encrypted
    username ojoawob password w1h9Aq2Welzv1fuW encrypted
    username agbajer password NuDaZPLHC0BcF7iI encrypted
    username oyenihib password eoxptVEUfczen6VR encrypted
    username odewolef password yB12L9t1gcr.Wgx/ encrypted
    username mainuser password 8KBTvbq5FOuoFce2 encrypted privilege 15
    username maakano password c1Cb3uSluyfsyWUb encrypted
    tunnel-group branchgroup type remote-access
    tunnel-group branchgroup general-attributes
    address-pool remoteusers
    default-group-policy branchgroup
    tunnel-group branchgroup ipsec-attributes
    ikev1 pre-shared-key *****
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns migrated_dns_map_1
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns migrated_dns_map_1
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
    class class-default
      user-statistics accounting
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    hpm topN enable
    Cryptochecksum:bbe838eb9af33fc84083989823bc0c22
    : end
    [OK]
    ciscoasa#

    Hi,
    Seems to me that you have configured Static NAT from "inside" to "dmz" so that the "inside" servers are visible to the "dmz" with the IP address belonging to the "dmz"
    Is this something that you absolutely need? Is there something preventing you from using the IP address ranges on both "inside" and "dmz" and not doing NAT for them at all between those interfaces?
    IF you want to keep the current setup intact regarding NAT, change the DMZ ACL to use the actual 10.1.184.x IP addresses as the destination IP address in the ACL.
    In other words, always use the Real IP address of the host in the ACL configuration, NOT the NAT IP address. After doing that change I suppose it should also work for "dmz" to "inside". (NAT IP was used in the ACL in the ASA versions 8.2 and below, the Real IP address is used in software 8.3 and above)
    Change
    access-list DMZ_access_in extended permit tcp host 192.168.30.4 host 192.168.30.116 eq smtp
    access-list DMZ_access_in extended permit icmp host 192.168.30.4 any
    access-list DMZ_access_in extended permit ip host 192.168.30.4 host 192.168.30.134
    access-list DMZ_access_in extended permit tcp host 192.168.30.4 host 192.168.30.134 eq sqlnet
    To
    access-list DMZ_access_in extended permit tcp host 192.168.30.4 host 10.1.184.116 eq smtp
    access-list DMZ_access_in extended permit icmp host 192.168.30.4 any
    access-list DMZ_access_in extended permit ip host 192.168.30.4 host 10.1.184.134
    access-list DMZ_access_in extended permit tcp host 192.168.30.4 host 10.1.184.134 eq sqlnet
    You can also use the "object" names in the ACL.
    Which would be
    access-list DMZ_access_in extended permit tcp host 192.168.30.4 object MailServer eq smtp
    access-list DMZ_access_in extended permit icmp host 192.168.30.4 any
    access-list DMZ_access_in extended permit ip host 192.168.30.4 object DatabaseServer
    access-list DMZ_access_in extended permit tcp host 192.168.30.4 object DatabaseServer eq sqlnet
    Hope the above helps Please ask more if needed.
    - Jouni

Maybe you are looking for