Configuration Binding issues

Hi All,
I am creating a service, and supplying some default values for the configuration via properties. but when i am deploying the code - the configuration itself indicates unbound, until i save it and any changes i create a lost when i redeploy the bundle.
@Component(name = MyService.PROCESS_PID, description = "Custom Service", label = "Custom Service", metatype = true, configurationFactory = false, immediate = true)
@Service
@Properties({
                    @Property(name = "service.pid", value = MyService.PROCESS_PID),
                    @Property(name = "service.description", value = "Custom Service"),
                    @Property(name = MyService.PATHS, description = "Please add paths", label = "paths", value = "/content,/etc", cardinality = 10),
                    @Property(name = "service.vendor", value = "Adobe") })
public void activate(ComponentContext componentContext) {
                    log.info("Entering activate method.");
                    @SuppressWarnings("rawtypes")
                    Dictionary properties = componentContext.getProperties();
                    this.paths = MyUtil.convertToStringArray(properties
                                        .get(MyService.PATHS));
                    log.info("Exiting activate method.");
I also see the activate method getting called, but i still see this issue
What am i missing here, Thanks in Advance

I saw you have missed your service interface class association through which it will bind with sling script helper. I hope you have created the service interface let say "MyService" and above class which is an implementor will refer to interface like below
@Service(value=MyService.class)

Similar Messages

  • Attachment binding issue in workflow

    Hi All,
    I have used FM 'SAP_WAPI_ATTACHMENT_ADD ' in method of my workflow. Here after executing this FM i m getting id of the attachment for this workitem. But now i need to assign this to  '_Attach_Objects' of workflow container. so please help me for this binding issue. which i need to bind from method to> task to> workflow. so from next step onwards in workflow i will get that attachment.
    Smit Shah

    Hi,
    1) In the T.code SWO1, you have to create a custom method for the BO, there execute that method and check whether it working fine
    2) Then goto  T.code PFTC and Create a Task (Task no. will generate automatically), then call this method and generate the binding
    3) Goto  T.code SWDD and call that Task by assigning that Task no. and assign the binding
    Then test your workflow.
    For the Binding see this [link|http://help.sap.com/saphelp_nw04/helpdata/en/c8/bfc39b0fc57a49a0291378f8be0cd6/frameset.htm].
    Regards,
    Surjith

  • Configuration of Issue Management tables

    Hello -
    I am looking to configure the tables in Issue Management  but I cannot seem to find them via the SPRO transaction.
    Is there a guide on how to do the configuration for Issue Management?
    Please let me know
    Thanks!
    Nadine

    Please look at Note 1019583. In TA SOLMAN_ISSUE_MGMT there are also the usual Wed Dynpro ALV customizing possibilities (independent of Issue Management).

  • A data-binding issue with a combo box.

    Hi,
    Iu2019m having a data-binding issue with a combo box.  The field it is bound to is an integer.  The valid values in the combo box are 1, 2, and 3.  If I add a record when it is set to 1 or 2, the value gets stored correctly.  If I add a record when it is set to 3, it is stored as 1.  However, I can bring up the record just added on the form, change it to 3, and click u201CUpdateu201D and it is saved correctly as 3.  If I change it so that the valid values are 4, 5, and 6, it saves a 1 regardless of what is selected in the combo box.  It looks like the combo box is correctly bound for updates but not for adds.  The table is a master type UDO.  Any ideas?  Iu2019m somewhat committed to the field being an integer.  I'm using 2007A PL47.
    Thanks,
    Mike
    Edited by: Mike Angelastro on Jul 1, 2009 2:43 PM

    I tried a few things on my own.  The result is that I decided that it was not a good idea to use a combo box bound to an integer (numeric) field.  I donu2019t think the SDK can handle it.  The reason it was an integer field in the first place is that before I changed it to a combo box it was a group of two option buttons.  Option buttons use an integer (numeric) field.  This worked just fine until I added a third option; the SDK didnu2019t handle the third option correctly when adding records.  I thought that using a combo box instead would fix that.  I was wrong; the problem remained.  So I decided to use a character (alphanumeric) field instead.  This works just fine.
    So here is my advice:  Never use option buttons if they need to be bound to the database; a combo box will actually work better when bound to the database.  But use a character (alphanumeric) field.
    Edited by: Mike Angelastro on Jul 5, 2009 9:15 PM

  • [svn:cairngorm3:] 17187: Fixed binding issue on the source property of the contact's picture

    Revision: 17187
    Revision: 17187
    Author:   [email protected]
    Date:     2010-08-04 13:44:35 -0700 (Wed, 04 Aug 2010)
    Log Message:
    Fixed binding issue on the source property of the contact's picture
    Modified Paths:
        cairngorm3/trunk/samples/insync/insync-modularExtended-contacts/src/insync/contacts/prese ntation/ContactForm.mxml

    Revision: 17187
    Revision: 17187
    Author:   [email protected]
    Date:     2010-08-04 13:44:35 -0700 (Wed, 04 Aug 2010)
    Log Message:
    Fixed binding issue on the source property of the contact's picture
    Modified Paths:
        cairngorm3/trunk/samples/insync/insync-modularExtended-contacts/src/insync/contacts/prese ntation/ContactForm.mxml

  • [svn:cairngorm3:] 17186: Fixed binding issue on the source property of the contact's picture

    Revision: 17186
    Revision: 17186
    Author:   [email protected]
    Date:     2010-08-04 13:43:41 -0700 (Wed, 04 Aug 2010)
    Log Message:
    Fixed binding issue on the source property of the contact's picture
    Modified Paths:
        cairngorm3/trunk/samples/insync/insync-basic/src/insync/presentation/ContactForm.mxml

    Revision: 17186
    Revision: 17186
    Author:   [email protected]
    Date:     2010-08-04 13:43:41 -0700 (Wed, 04 Aug 2010)
    Log Message:
    Fixed binding issue on the source property of the contact's picture
    Modified Paths:
        cairngorm3/trunk/samples/insync/insync-basic/src/insync/presentation/ContactForm.mxml

  • AD Binding Issues 10.7.X

    1.) When binding to a domain controller where a legacy controller also exists (example.com and exampleNT), Directory Utility binds itself to both domains. Leopard and Snow Leopard handle this correctly without binding to the legacy.
    2.) When binding to a domain controller where a legacy controllers also exists, the Search Policy is incorrectly populated. For example, you'll attempt to bind to example.com, and Directory Utility will bind to Example.com and ExampleNT. Then the search policy will only be populated with "ExampleNT/All Domains". If you click "+" to add other resources, it will show "ExampleNT" and "Example.com". Add both of those, exit Directory Utility and go back to Search Policy. Click "+" and now "Example.com/All Domains" will appear. It should have been in the list originally. Now you have to reorder the policy to be: Example.com; Example.com/All Domains; ExampleNT; ExampleNT/All Domains. Until you've put the Search Policy in this order it is not possible to login with network accounts. And no matter how we arrange / edit / set the binding policies, that irritating login light will never be green. Only yellow: some networks accounts are unavailable. So not only is Directory Utility binding incorrectly, it is incorrectly setting the Search Policies.
    3.) In Directory Utility, if you do not check "Require Confirmation before creating a mobile account" and then bind, the box will magically become checked. However, if you check and then uncheck it, the setting will not magically become checked.
    4.) Let's say we're using a machine naming scheme in the format of AA-XXXXXX, where AA is a department abbreviation and XXXXXX is an asset tag. Prior to binding in System Preferences, we set the machine's name to AA-222222. When you open Directory Utility, it will autopopulate the ComputerID with the ID of another machine that is already bound. So instead of going with AA-222222, it will pick AA-111111. Not only that, but some characters are converted to others. AA-XXXXXX will be automatically converted to AA_XXXXXX.
    5.) When you click on bind, Directory Utility often immediately states your credentials to bind to AD are not correct. However, this is a false positive. Our setup locks AD admin accounts with any invalid attempt (ie - one failed login = locked out). But when this authentication failure occurs in Directory Utility, no lock out occurs. We've watched traffic and Directory Utility isn't actually attempting to authenticate. There is no authentication request. When this happens, all settings you've customized are reverted. So once again you have to check and uncheck the Require Confirmation selection, enter the correct machine name, etc. Now hit the bind button, and Directory Utility properly attempts and succeeds in authenticating. Binding completes.
    6.) When you unbind, often Directory Utility will simply pretend it is done, but the unbind button is still a possibility. Clikc Unbind, enter your credentials again, and this time it will actually unbind.
    I've put in several bug reports regarding these matters (along with videos of the issues, full logs, etc). All issues were confirmed as existing. Then they closed the tickets saying 10.7.3 would address the issues, but all of the issues still exist for us. Apple opened a service request with us, but acknowledged the issues exist, and then closed it out.
    Has anyone else experienced similiar issues with a legacy controller on the network? Seeing as Leopard and Snow Leopard worked perfectly and the server configuration hasn't changed, since 10.5.X and 10.6.X gave no issues, the rewrite of directory services for 10.7.X seems to be filled with bugs.

    3) I noticed that once you add your AD domain, don't manually go in and configure the Directory Utility.  Use the terminal;- http://support.apple.com/kb/TS4176
    ...not that my AD is working very well :-/

  • AD - Binding Issues!

    We are in the process of migrating all our Macs to the AD structure.  Previously, they have all been running standalone, with credentials being applied when mapped drives are setup.  Due to a new requirement, we now need to bind everyone to Active Directory (Windows 2003 R2).
    We can bind the machines to the network ok, and cache the user profile, set them as an admin etc.  The users can log into the system without an issue.  However we have a number of problems: -
    1. If the user has and office 2004 upgrade license installed on their machine, when you attempt to run any office application as the new AD user, it asks for verification media for the upgrade.  Once this has been supplied and it has verified successfully, when you click finish the application just closes, and does not start the office app.  This happens every time you try to use any of the office suite.  The only solution I have found for this so far is to completely remove the office install from the machine, deleting all traces of it, then reinstalling after the machine has been joined to the AD.  It then works without any problem.  Obviously with over 50 users we cannot possibly do this!  i suspect a permissions issue?
    2. A more serious problem is that on 2 machines now, the user has been set up with a fresh install, bound to AD, set up with a mobile profile on the machine and tested all ok.  The machine has been disconnected from wired and wireless networks, and all are still fine and can log int owithout problems.  Then, completely randomly, the user profile disappears from the login screen and the user cannot log on to the mac (unless by a local admin account, which has not got access to their usual data).  The moment the machine is connected to the network again, the problem goes; after that it's fine for a while, before going again.  The problem being that these people regularly go to client sites, and cannot have the issue of being unable to log onto their machine!
    Any help would be appreciated!

    3) I noticed that once you add your AD domain, don't manually go in and configure the Directory Utility.  Use the terminal;- http://support.apple.com/kb/TS4176
    ...not that my AD is working very well :-/

  • H323 Bind issues

    (config-subif)#h323-gateway voip bind srcaddr xxx.xxx.xxx.xxx
    Bind IP Address configured. Please remove before reconfiguring
    I am getting this message despite no bind address configured. anyone seen this issues before?
    RTR#sh run   | include bind
    RTR#
    Any advise will be much appreciated.

    version 15.0
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime localtime show-timezone
    service password-encryption
    service compress-config
    hostname RTR
    boot-start-marker
    boot system flash:c2900-universalk9-mz.SPA.150-1.M4.bin
    boot-end-marker
    card type e1 0 1
    logging buffered 4096
    aaa new-model
    aaa session-id common
    network-clock-participate wic 1
    no ipv6 cef
    no ip source-route
    ip cef
    ip vrf 3RD_PARTY
     rd
     route-target export
     route-target import
    ip vrf DATA
     rd
     route-target export
     route-target import
    ip vrf forwarding
    no ip dhcp use vrf connected
    no ip dhcp conflict logging
    ip dhcp excluded-address 172.27.165.1 172.27.165.25
    ip dhcp excluded-address 172.27.165.129
    ip dhcp pool VLAN1
       network 172.27.165.0 255.255.255.192
       dns-server xxx.xxx.xxx.xxx
       default-router 172.27.165.1
       option 150 ip XXX.XXX.XXX
       lease 3
    ip dhcp pool VLAN133
       network 172.27.165.128 255.255.255.192
       default-router 172.27.165.129
       lease 0 3
    no ip domain lookup
    multilink bundle-name authenticated
    isdn switch-type primary-net5
    crypto pki token default removal timeout 0
    voice-card 0
    voice rtp send-recv
    voice service voip
     fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none
     modem passthrough nse codec g711ulaw
    voice class codec 1
     codec preference 1 g729r8
     codec preference 2 g711ulaw
    voice class h323 1
      h225 timeout tcp establish 3
      call start fast
    voice translation-rule 100
     rule 1 /^.*/ /xxxxxxxxx/
    voice translation-profile MAPOUTSIDE
     translate calling 100
    hw-module pvdm 0/0
    redundancy
    controller E1 0/1/0
     line-termination 75-ohm
     pri-group timeslots 1-31
     description ### PABX ###
    controller E1 0/1/1
    interface GigabitEthernet0/0
     description ### Trunk  ###
     no ip address
     duplex auto
     speed auto
    interface GigabitEthernet0/0.1
     description ### Managment, Server and Voice network ###
     encapsulation dot1Q 1 native
     ip address 192.168.1.1 255.255.255.0 secondary
     ip address 172.27.165.1 255.255.255.192
     no ip redirects
    interface GigabitEthernet0/0.2
     description ### Lan ###
     encapsulation dot1Q 800
     ip vrf forwarding DATA
     no ip redirects
     ip tcp adjust-mss 1400
     bridge-group 2
     bridge-group 2 input-address-list 702
    interface GigabitEthernet0/0.5
     description ### Riverbed AUX Port ###
     encapsulation dot1Q 5
     no ip redirects
     ip nat outside
     ip virtual-reassembly
    interface GigabitEthernet0/0.133
     description ### Internet Wifi ###
     encapsulation dot1Q 133
     ip vrf forwarding 3RD_PARTY
     no ip redirects
     ip accounting output-packets
     bridge-group 33
     bridge-group 33 input-address-list 733
     bridge-group 33 output-address-list 733
    interface GigabitEthernet0/1
     no ip address
     duplex auto
     speed auto
    interface GigabitEthernet0/2
     no ip address
     duplex auto
     speed auto
    interface GigabitEthernet0/2.950
      bandwidth 1024
     encapsulation dot1Q 950
     ip address 172.27.165.254 255.255.255.252
     ip flow ingress
     ip flow egress
    interface GigabitEthernet0/2.951
      bandwidth 768
     encapsulation dot1Q 951
     ip vrf forwarding DATA
     ip address 172.27.165.250 255.255.255.252
     ip flow ingress
     ip flow egress
     rate-limit output 768000 8000 8000 conform-action transmit exceed-action drop
    interface GigabitEthernet0/2.952
     bandwidth 256
     encapsulation dot1Q 952
     ip vrf forwarding 3RD_PARTY
     ip address 172.27.165.246 255.255.255.252
     ip flow ingress
     ip flow egress
     rate-limit output 256000 8000 8000 conform-action transmit exceed-action drop
    interface GigabitEthernet0/2.959
     encapsulation dot1Q 959 native
     ip address 172.27.165.242 255.255.255.252
     ip flow ingress
     ip flow egress
    interface Serial0/0/0
     bandwidth 1024
     no ip address
     encapsulation frame-relay
     load-interval 30
     no keepalive
     priority-group 1
     ignore dcd
     no clock rate 2000000
    interface Serial0/0/1
     no ip address
     shutdown
     clock rate 2000000
    interface Serial0/1/0:15
     no ip address
     encapsulation hdlc
     isdn switch-type primary-net5
     isdn timer T310 120000
     isdn protocol-emulate network
     isdn incoming-voice voice
     no cdp enable
    interface BVI2
     ip vrf forwarding DATA
     ip address 192.168.1.1 255.255.255.0 secondary
     ip address 172.16.199.1 255.255.255.0
     no ip redirects
     ip accounting output-packets
     ip nbar protocol-discovery
     ip tcp adjust-mss 1400
    interface BVI33
     ip vrf forwarding 3RD_PARTY
     ip address 172.27.165.129 255.255.255.192
     ip accounting output-packets
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip flow-top-talkers
     top 20
     sort-by bytes
     cache-timeout 30000
    ip nat inside source list 150 interface GigabitEthernet0/0.5 overload
    ip route 0.0.0.0 0.0.0.0 172.27.165.253 name default
    ip route vrf 3RD_PARTY 0.0.0.0 0.0.0.0 172.27.165.245 name Default
    ip route vrf DATA 0.0.0.0 0.0.0.0 172.27.165.249 name Default
    control-plane
    bridge 2 protocol ieee
    bridge 2 route ip
    bridge 33 protocol ieee
    bridge 33 route ip
    no call rsvp-sync
    voice-port 0/1/0:15
    voice-port 0/2/0
    voice-port 0/2/1
    voice-port 0/2/2
    voice-port 0/2/3
    dial-peer voice 100 pots
     description ### PABX ###
     destination-pattern XXXXXXXX
     port 0/1/0:15
     forward-digits all
    dial-peer voice 2000 voip
     preference 2
     destination-pattern .T
     progress_ind setup enable 3
     session target ipv4:xxx.xxx.xxx.xxx
     voice-class codec 1
     voice-class h323 1
     dtmf-relay h245-alphanumeric
     playout-delay nominal 130
     playout-delay mode fixed
     fax-relay ecm disable
     fax rate 9600
     fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none
     clid network-number XXXXXXXX
     no vad
    dial-peer voice 2001 voip
     preference 1
     destination-pattern .T
     progress_ind setup enable 3
     session target ipv4:xxx.xxx.xxx.xxx
     voice-class codec 1
     voice-class h323 1
     dtmf-relay h245-alphanumeric
     playout-delay nominal 130
     playout-delay mode fixed
     fax-relay ecm disable
     fax rate 9600
     fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none
     clid network-number XXXXXXXX
     no vad

  • SOAP Binding Issue

    Hi All,
    My Requirement was to publish a RFC as a webserice in PI7.1.
    I did the entire configuration and publish display the sender agreement as webservice and took the WSDL from there.
    when I test this using SOAP UI tool then this WSDL works fine where the URL is standard
    http://host:port/XISOAPAdapter/MessageServlet?channel=:CommunicationComponent:ComminicationChannel
    But when I an tring to Use this wsdl in EP I am getting following error.
    Cannot Chosse this operation:There is no associated SOAP Binding.
    Am I doing Something wrong??
    Please help.
    Regards,

    Hi Suraj,
    Sorry for late Response.
    Please find the below
    - <wsdl:portType name="Z_QMNC_SAVE_CORRECTIONS.PortType">
    - <wsdl:operation name="Z_QMNC_SAVE_CORRECTIONS">
      <wsdl:input message="rfc:Z_QMNC_SAVE_CORRECTIONS.Input" xmlns:rfc="urn:sap-com:document:sap:rfc:functions" />
      <wsdl:output message="rfc:Z_QMNC_SAVE_CORRECTIONS.Output" xmlns:rfc="urn:sap-com:document:sap:rfc:functions" />
      </wsdl:operation>
      </wsdl:portType>
    - <wsdl:binding name="Z_QMNC_SAVE_CORRECTIONS.PortTypeBinding" type="rfc:Z_QMNC_SAVE_CORRECTIONS.PortType" xmlns:rfc="urn:sap-com:document:sap:rfc:functions">
      <soap:binding style="document" transport="http://schemas.xmlsoap.org/soap/http" xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" />
    - <wsdl:operation name="Z_QMNC_SAVE_CORRECTIONS">
      <soap:operation soapAction="http://sap.com/xi/WebService/soap1.1" xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" />
    - <wsdl:input>
      <soap:body use="literal" xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" />
      </wsdl:input>
    - <wsdl:output>
      <soap:body use="literal" xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" />
      </wsdl:output>
      </wsdl:operation>
      </wsdl:binding>

  • Dynamic Configuration Tool Issues

    Hi,
    Has anyone run into issues with the cisco dynamic configuration tool? I recently noticed I cannot customize the hardware I am trying to configure. This was not like this in the past.

    Hi Laurence,
    According to your description, you are creating a SQL Server Reporting Services report using SSAS cube as the data source, there are 40 parameters in the MDX query, so the performance is poor, right?
    In your scenario, you said that 10 of the parameters using existing function, so you suspect that the issue can be caused by the existing function. Based on my research, it seems that the existing function is not a problem. Only issue is that use existing
    function together with nonempty function, please refer to the link below to see the detail information about it.
    http://cwebbbi.wordpress.com/2009/03/31/existing-and-nonempty/
    In additional, I'd suggest you enable SQL profiler to monitor the queries fired by the query, once you find some queries took a very long time to run, consider creating the smaller cube partition or optimizing the query by adding index or partition
    to improve the query performance. Here are some links about performance tuning.
    http://www.bidn.com/blogs/DustinRyan/bidn-blog/2636/top-3-simplest-ways-to-improve-your-mdx-query
    http://blogs.msdn.com/b/azazr/archive/2008/05/01/ways-of-improving-mdx-performance-and-improvements-with-mdx-in-katmai-sql-2008.aspx
    http://www.packtpub.com/article/query-performance-tuning-microsoft-analysis-services-part1
    Hope this helps.
    Regards,
    Charlie Liao
    If you have any feedback on our support, please click
    here.
    Charlie Liao
    TechNet Community Support

  • JUComboBox LOV Binding Issue

    Hi,
    I am getting a problem in JUComboBoxLovBinding.
    Problem Description --
    I have created a JComboBox with used LovBinding (using two view objects -- resortVO and testVO ). The _resortVO is the LOV VO instance.
    There is one button which rollbacks the transaction and create a new row for the non-lov view object instance.
    I followed the following steps -->
    1. Run the application
    2. Press the Button.
    3. Select an item (say 'ResortA') from the combo box
    This sets the ResortId for the _testVO's current row.
    4. Again press the Button
    5. Then select the same item again i.e. ResortA.
    This does not set the ResortId for teh _testVO's current row.
    Question -- Why the ResortId is not get selected in Step 5?
    The sample code is here --
    package testapp;
    import java.awt.BorderLayout;
    import java.awt.Component;
    import java.awt.Dimension;
    import java.awt.Rectangle;
    import java.awt.event.ActionEvent;
    import java.awt.event.ActionListener;
    import java.awt.event.WindowAdapter;
    import java.awt.event.WindowEvent;
    import java.util.Hashtable;
    import javax.swing.DefaultListCellRenderer;
    import javax.swing.JButton;
    import javax.swing.JComboBox;
    import javax.swing.JFrame;
    import javax.swing.JList;
    import javax.swing.JPanel;
    import oracle.jbo.ApplicationModule;
    import oracle.jbo.AttributeDef;
    import oracle.jbo.Row;
    import oracle.jbo.ViewObject;
    import oracle.jbo.client.Configuration;
    import oracle.jbo.uicli.binding.JUApplication;
    import oracle.jbo.uicli.jui.JUComboBoxBinding;
    import oracle.jbo.uicli.jui.JUPanelBinding;
    public class TestJUComboLovBinding extends JFrame
        private BorderLayout _mainLayout = new BorderLayout();
        private JPanel _panelCenter = new JPanel();
        private JUPanelBinding _panelBinding;
        /**  ADD CUSTOM MEMBER VARIABLES HERE  **/
        private JComboBox _resortComboBox = new JComboBox();
        private ViewObject _resortVO,_testVO;
        private JButton _createButton = new JButton("Create");
        private int count = 0;
        /** CUSTOM MEMBER VARIABLES ENDS HERE  **/
        public TestJUComboLovBinding()
            try
                jbInit();
            } catch (Exception e)
                e.printStackTrace();
        private void jbInit() throws Exception
            this.setSize(350, 210);
            this.setBounds( new Rectangle(100, 80, 400, 250));
            this.setTitle( "Frame Title" );
            ApplicationModule appModule =
                Configuration.createRootApplicationModule(
                "testapp.TestAppModuleImpl", "TestAppModuleLocal");
            JUApplication app = new JUApplication(appModule);
            _panelBinding = new JUPanelBinding(app.getName(), null);
            _panelBinding.setApplication(app);
            _panelCenter.setLayout(_mainLayout);
            customJbInit();
            this.getContentPane().add("Center",_panelCenter);
            _panelBinding.executeIfNeeded();
        private void customJbInit()
            _resortVO = _panelBinding.getApplicationModule().findViewObject("VResort");
            _testVO = _panelBinding.getApplicationModule().findViewObject("VTest");
            AttributeDef[] attrDefs = _resortVO.getAttributeDefs();
            String[] allAttrNames = new String[attrDefs.length];
            for (int i = 0; i < attrDefs.length; i++)
                allAttrNames[i] = attrDefs.getName();
    _resortComboBox.setModel(
    JUComboBoxBinding.createLovBinding
    _panelBinding,
    _resortComboBox,
    _testVO.getName(),
    null,
    testVO.getName().replace('.','') + "IterBinding",
    new String[] {"ResortId"},
    _resortVO.getName(),
    new String[] {"ResortId"},
    allAttrNames,
    null,
    null
    _resortComboBox.addActionListener(
    new ActionListener() {
    public void actionPerformed(ActionEvent e ){
    if(_testVO != null && _testVO.getCurrentRow() != null)
    System.out.println("Resort ID -- > " + count++ + ":" + _testVO.getCurrentRow().getAttribute("ResortId"));
    _createButton.addActionListener(
    new ActionListener() {
    public void actionPerformed(ActionEvent e) {
    _panelBinding.getApplicationModule().getTransaction().rollback();
    _testVO.executeQuery();
    Row row = _testVO.createRow();
    _testVO.insertRow(row);
    panelCenter.add(resortComboBox,BorderLayout.NORTH);
    panelCenter.add(createButton,BorderLayout.SOUTH);
    public static void main(String[] args)
    TestJUComboLovBinding frame = new TestJUComboLovBinding();
    frame.addWindowListener(
    new WindowAdapter()
    public void windowClosing(WindowEvent evnt)
    System.exit(0);
    frame.setSize(new Dimension(400, 280));
    frame.pack();
    frame.setVisible(true);
    Thanks.

    Okay. So it's not the rollback.
    Reading your posting one more time, I see that in point 5 you write:
    "Then select the same item again".
    The problem does not occur when a different item is selected? If that's the case, then it's probably some kind of optimization in the binding that only sets the value when it actually changes.
    You could try to do something like that:
            _createButton.addActionListener(
                new ActionListener() {
                    public void actionPerformed(ActionEvent e) {
                        _panelBinding.getApplicationModule().getTransaction().rollback();
                        _testVO.executeQuery();
                        Row row = _testVO.createRow();
                        _testVO.insertRow(row);
                       // New line to insert:
                        _resortVO.reset();
            );This should ensure that a navigation happens.
    You can get the binding from the JUPanelBinding if your main application has access to that. See the getControlBinding() and findControlBinding() methods in JUFormBinding (a super class of JUPanelBinding).
    Sascha

  • SQL query / binding issues on my web page

    This may or maynot be the place to ask, but maybe someone can
    tell me what
    to look at...
    I created a page some time back.. and its displays a few
    fields of data
    based on the id passed to it..
    This works fine, but now that we are trying to improve the
    site a little,
    they want some additonal information displayed
    on the page.. so those changes were made about 2 weeks ago...
    now that some
    of the newer records contain the data
    they want displayed, some data is not displaying.. or it will
    display and
    other fields ( that were displaying before ) are now
    missing.. the web page hasnt been touched in 2 weeks.. if we
    execute the
    store procedure within SQL and within our web program
    it always returns the correct data.. but the fields that i
    have binded to
    the page are taking on a life of there own...
    Not sure if anyone has had this problem, but its getting
    annoying.. when i
    execute this within SQL it returns all the values requested.
    If i execute it
    within dreamweaver to show me what results i will get back it
    works there..
    but after i bind the fields to my page and view it only some
    or all my
    fields do not display any data... but if i play around with
    the order of my
    select statement below i can get some fields to display and
    other
    disappear... and i dont ever touch my webpage again...
    Can anyone shed some light on this issue? Or is there a
    better way to
    display my results so that what i get back with my query will
    always
    display....
    here is my stored procedure that im calling
    SET NOCOUNT ON;
    SELECT
    c.cfname,c.clname,c.cid,h.termcode,h.hiredate,h.lastdate,h.cdateh,
    h.cdatet,h.startdate,h.managername,h.termby,
    availsun1,availsun2,availmon1,availmon2,availtue1,availtue2,
    availwed1,availwed2,availthur1,availthur2,availfri1,availfri2,
    availsat1,availsat2,h.comby,ssn_dash = dbo.SSN_dash(cssn),
    Home = dbo.PhoneNumber_complete_format(chphone),
    Mobile = dbo.PhoneNumber_complete_format(cmphone),
    Other = dbo.PhoneNumber_complete_format(cophone),
    Jobtitle =
    case
    when c.st = '90' then
    (select top 1 j.jobtitle from has.dbo.JobCodes j where j.hjob
    = h.jobid and
    j.hlocation = 'DC')
    else
    (select top 1 j.jobtitle from has.dbo.JobCodes j where j.hjob
    = h.jobid and
    j.hlocation <> 'DC')
    end,
    (Select T.term_reason
    From has.dbo.termcodes T, has_arc.dbo.EmpTermHistory H
    where T.term_val = H.termcode and h.cid = @cid) as
    TermReason,
    Days = @day,
    Months = @month,
    Years = @year
    FROM has_arc.dbo.EmpCandidate C, has_arc.dbo.EmpTermHistory H
    WHERE C.cid = @cid AND C.cid = H.cid
    END
    ASP, SQL2005, DW8 VBScript

    And when it says read the columns left to right... i would
    imagine that
    means my select statement should select the columns in the
    order of which
    they are in the tables?
    so in my case.. if HomePhone is last column in my table it
    should be the
    last in the select statement?
    ASP, SQL2005, DW8 VBScript
    "Daniel" <[email protected]> wrote in message
    news:[email protected]...
    > Now when you say TEXT type.. your refering to the data
    types i have setup
    > in the database? correct
    >
    > Within the database the fields that im querying are
    pretty much all
    > varchar a few are date and one int
    >
    >
    >
    >
    > --
    > ASP, SQL2005, DW8 VBScript
    > "Joris van Lier" <[email protected]> wrote in
    message
    > news:[email protected]...
    >>
    >>
    >> "Daniel" <[email protected]> wrote in message
    >> news:[email protected]...
    >>> This may or maynot be the place to ask, but
    maybe someone can tell me
    >>> what
    >>> to look at...
    >>>
    >>> I created a page some time back.. and its
    displays a few fields of data
    >>> based on the id passed to it..
    >>> This works fine, but now that we are trying to
    improve the site a
    >>> little,
    >>> they want some additonal information displayed
    >>> on the page.. so those changes were made about 2
    weeks ago... now that
    >>> some
    >>> of the newer records contain the data
    >>> they want displayed, some data is not
    displaying.. or it will display
    >>> and
    >>> other fields ( that were displaying before ) are
    now
    >>> missing.. the web page hasnt been touched in 2
    weeks.. if we execute the
    >>> store procedure within SQL and within our web
    program
    >>> it always returns the correct data.. but the
    fields that i have binded
    >>> to
    >>> the page are taking on a life of there own...
    >>>
    >>> Not sure if anyone has had this problem, but its
    getting annoying.. when
    >>> i
    >>> execute this within SQL it returns all the
    values requested. If i
    >>> execute it
    >>> within dreamweaver to show me what results i
    will get back it works
    >>> there..
    >>> but after i bind the fields to my page and view
    it only some or all my
    >>> fields do not display any data... but if i play
    around with the order of
    >>> my
    >>> select statement below i can get some fields to
    display and other
    >>> disappear... and i dont ever touch my webpage
    again...
    >>>
    >>> Can anyone shed some light on this issue? Or is
    there a better way to
    >>> display my results so that what i get back with
    my query will always
    >>> display....
    >>>
    >>> here is my stored procedure that im calling
    >>> SET NOCOUNT ON;
    >>> SELECT
    >>>
    c.cfname,c.clname,c.cid,h.termcode,h.hiredate,h.lastdate,h.cdateh,
    >>> h.cdatet,h.startdate,h.managername,h.termby,
    >>>
    availsun1,availsun2,availmon1,availmon2,availtue1,availtue2,
    >>>
    availwed1,availwed2,availthur1,availthur2,availfri1,availfri2,
    >>> availsat1,availsat2,h.comby,ssn_dash =
    dbo.SSN_dash(cssn),
    >>> Home = dbo.PhoneNumber_complete_format(chphone),
    >>> Mobile =
    dbo.PhoneNumber_complete_format(cmphone),
    >>> Other =
    dbo.PhoneNumber_complete_format(cophone),
    >>> Jobtitle =
    >>> case
    >>> when c.st = '90' then
    >>> (select top 1 j.jobtitle from has.dbo.JobCodes j
    where j.hjob = h.jobid
    >>> and
    >>> j.hlocation = 'DC')
    >>> else
    >>> (select top 1 j.jobtitle from has.dbo.JobCodes j
    where j.hjob = h.jobid
    >>> and
    >>> j.hlocation <> 'DC')
    >>> end,
    >>> (Select T.term_reason
    >>> From has.dbo.termcodes T,
    has_arc.dbo.EmpTermHistory H
    >>> where T.term_val = H.termcode and h.cid = @cid)
    as TermReason,
    >>> Days = @day,
    >>> Months = @month,
    >>> Years = @year
    >>>
    >>> FROM has_arc.dbo.EmpCandidate C,
    has_arc.dbo.EmpTermHistory H
    >>> WHERE C.cid = @cid AND C.cid = H.cid
    >>> END
    >>>
    >>>
    >>> --
    >>> ASP, SQL2005, DW8 VBScript
    >>
    >>
    >> Are any of these fields by chance of TEXT type (or
    other Binary Large
    >> OBject type)?
    >> In this case there are certain limitations the text
    fields must be the
    >> last in your SQL statement and may only
    >> be retrieved ONCE reliably.
    >>
    >> <%
    >> Dim myTextVar
    >> myTextVar = Recordset.Fields.Item("TEXTFIELD").value
    >> %>
    >> <% If NOT IsNull(myTextVar) Then%>
    >> <%=(Replace(myTextVar, chr(13),
    "<BR>"))%>
    >> <% End If ' NOT IsNull(myTextVar) %>
    >>
    >> Here's an excerpt from the Microsoft Site
    >>
    >> When dealing with BLOB fields from Microsoft SQL
    Server, you must put
    >> them
    >> to the right of non-BLOB columns in the resultset.
    To be safe, you should
    >> also read the columns in left-to-right order, so if
    you have two BLOB
    >> columns as the last two columns in your resultset,
    read the first one and
    >> then the second. Do not read them in the reverse
    order.
    >> MS:
    http://support.microsoft.com/support/kb/articles/q175/2/39.asp
    >>
    >> Joris van Lier
    >
    >

  • SQL query / binding issues within dreamweaver

    Not sure if anyone has had this problem, but its getting
    annoying.. when i
    execute this within SQL it returns all the values requested.
    If i execute it
    within dreamweaver to show me what results i will get back it
    works there..
    but after i bind the fields to my page and view it only some
    or all my
    fields do not display any data... but if i play around with
    the order of my
    select statement below i can get some fields to display and
    other
    disappear... and i dont ever touch my webpage again...
    Can anyone shed some light on this issue? Or is there a
    better way to
    display my results so that what i get back with my query will
    always
    display....
    here is my stored procedure that im calling
    SET NOCOUNT ON;
    SELECT
    c.cfname,c.clname,c.cid,h.termcode,h.hiredate,h.lastdate,h.cdateh,
    h.cdatet,h.startdate,h.managername,h.termby,
    availsun1,availsun2,availmon1,availmon2,availtue1,availtue2,
    availwed1,availwed2,availthur1,availthur2,availfri1,availfri2,
    availsat1,availsat2,h.comby,ssn_dash = dbo.SSN_dash(cssn),
    Home = dbo.PhoneNumber_complete_format(chphone),
    Mobile = dbo.PhoneNumber_complete_format(cmphone),
    Other = dbo.PhoneNumber_complete_format(cophone),
    Jobtitle =
    case
    when c.st = '90' then
    (select top 1 j.jobtitle from has.dbo.JobCodes j where j.hjob
    = h.jobid and
    j.hlocation = 'DC')
    else
    (select top 1 j.jobtitle from has.dbo.JobCodes j where j.hjob
    = h.jobid and
    j.hlocation <> 'DC')
    end,
    (Select T.term_reason
    From has.dbo.termcodes T, has_arc.dbo.EmpTermHistory H
    where T.term_val = H.termcode and h.cid = @cid) as
    TermReason,
    Days = @day,
    Months = @month,
    Years = @year
    FROM has_arc.dbo.EmpCandidate C, has_arc.dbo.EmpTermHistory H
    WHERE C.cid = @cid AND C.cid = H.cid
    END
    ASP, SQL2005, DW8 VBScript

    Can anyone help shed some light on this?
    ASP, SQL2005, DW8 VBScript
    "Daniel" <[email protected]> wrote in message
    news:ff3ud8$10k$[email protected]..
    > Not sure if anyone has had this problem, but its getting
    annoying.. when i
    > execute this within SQL it returns all the values
    requested. If i execute
    > it within dreamweaver to show me what results i will get
    back it works
    > there.. but after i bind the fields to my page and view
    it only some or
    > all my fields do not display any data... but if i play
    around with the
    > order of my select statement below i can get some fields
    to display and
    > other disappear... and i dont ever touch my webpage
    again...
    >
    > Can anyone shed some light on this issue? Or is there a
    better way to
    > display my results so that what i get back with my query
    will always
    > display....
    >
    > here is my stored procedure that im calling
    > SET NOCOUNT ON;
    > SELECT
    >
    c.cfname,c.clname,c.cid,h.termcode,h.hiredate,h.lastdate,h.cdateh,
    > h.cdatet,h.startdate,h.managername,h.termby,
    >
    availsun1,availsun2,availmon1,availmon2,availtue1,availtue2,
    >
    availwed1,availwed2,availthur1,availthur2,availfri1,availfri2,
    > availsat1,availsat2,h.comby,ssn_dash =
    dbo.SSN_dash(cssn),
    > Home = dbo.PhoneNumber_complete_format(chphone),
    > Mobile = dbo.PhoneNumber_complete_format(cmphone),
    > Other = dbo.PhoneNumber_complete_format(cophone),
    > Jobtitle =
    > case
    > when c.st = '90' then
    > (select top 1 j.jobtitle from has.dbo.JobCodes j where
    j.hjob = h.jobid
    > and j.hlocation = 'DC')
    > else
    > (select top 1 j.jobtitle from has.dbo.JobCodes j where
    j.hjob = h.jobid
    > and j.hlocation <> 'DC')
    > end,
    > (Select T.term_reason
    > From has.dbo.termcodes T, has_arc.dbo.EmpTermHistory H
    > where T.term_val = H.termcode and h.cid = @cid) as
    TermReason,
    > Days = @day,
    > Months = @month,
    > Years = @year
    >
    > FROM has_arc.dbo.EmpCandidate C,
    has_arc.dbo.EmpTermHistory H
    > WHERE C.cid = @cid AND C.cid = H.cid
    > END
    >
    >
    > --
    > ASP, SQL2005, DW8 VBScript
    >

  • XML JAXB Binding issue

    Hi All
    Im using Webservices in which i need to Bind my XML to Java objects and reverse. Im trying to use JAXB (1.0) Ref Imp from SUN as binding framework. The problem which im facing is that for elements like:
    <xs:element name="inputRequests">
    <xs:complexType>
    <xs:sequence>
    <xs:element maxOccurs="unbounded" name="inputData" type="data" />
    </xs:sequence>
    </xs:complexType>
    </xs:element>
    JAXB genetrates:
    1. InputRequest - Interface
    2. InputRequestImpl - Class
    3. InputRequestType - Interface
    4. InputRequestTypeImpl - Class
    in InputRequestType it has generated a getter method
    public java.util.List getInputData();
    but no setter method for 'inputData'.
    Can any one help on that how we can set a sequence element in JAXB classes. I even used JAXB 2.0, but faced same issue...
    No Setter for a LIST :-(((

    That method, getInputData() is returning a reference to a List Object that is already instantiated. Once you retrieve the reference, you can invoke all the methods in the List interface, but if there is a way to reassign the reference to refer to a different list, I'm not aware of one.
    I believe that limitation is necessary my the nature of JAXB. A JAXB Object, in your case a List, is guaranteed to be marshaled and unmarshaled to XML, if you redefine the reference to some arbitrary List, how could JAXB guarantee its functionality?
    I may be way off base here, I'm no JAXB expert by any means.
    Rather than redefining the reference to a different List, you have to manipulate the List
    ...getInputData().clear();
    ...getInputData().addAll(myRequestList);Right?

Maybe you are looking for

  • What is the best ipad to get? ipad 1 with 64 gb or a i pad 2 with 16 gb

    What is the best ipad to get? Ipad 1 with 64gb or a ipad2 with 16gb?  Does a ipad2 *** with a 64gb?

  • AEpress Completely Stuck Due to Firmware Rollback

    Right off the bat, the symptoms I am having is an Airport Express (wireless-N) that is completely stuck in one state. I can't change any settings on it. When I try to access the Airport Express from the Airport Utility, I get error -6722 ("An error o

  • Multiple Invoice Check while doing GR using MIGO

    Hi all, I have made the Check Double Inv check in Vendor master and also maintained the config for set check for duplicate invoice. In set check for duplicate invoice i selected all the 3 options. Still i am able to make GR on the same Invoice more t

  • Urgent alert from skype???

    I was interrupted while I was watching a video by an alarm that said - in a voice - that i needed to reactivate my computer protection and that i was to go to [invalid URL]  and it came from a unknown user aklofenz21.  That is was an urgent system al

  • Illustrator CC 2014 is slow.

    It works fine until I have to work with a very detailed design. Then it is impossible to work with. The system will lag and hold and lag and hold and I can't click and drag with precision. Very frustrating, I've been reading others complain about thi