Creating Node data on Author server from outside source?

I was wondering if it is possible to create node data on the author server from an outside source such as the publish server, without using reverse replication?
IE,
User accessing form page on publish server, enters data, submits the form. Which somehow would create node data directly on the author server without storing any data on the publish server.
Is this even possible?
Thanks

Thank you for all the responses.
Yes I do agree that not using reverse replication as the system is designed is not exactly a wise design choice. The problem I am facing is that the end user generated content is security sensitive and cannot be store on the publish instance. (Even temporarily)
I have managed to write a servlet on the Author server to accept the post data and create node data on the Author repository.
However to do this, I have had to disable login/security on the Author server for the servlet path (IE /bin/posthandlerservlet ) so that the author servlet can be accessed from the outside. Firewall has also been adjusted to let traffic through as well.
Now my remaining question would be, is opening up this path to the Author server much more dangerous and less secure that creating the node data on the Publish server in a place that protected access? We are really worried that the node created data on the publish server could somehow be accessed by end users in the event of a security problem.

Similar Messages

  • Create a new file on server from an applet

    Hello!
    I 'm trying to create a text file on server from an applet, i have permissions to write on server and i'm running in apache, my code is
    public void write () {
    try{
    URL url = new URL("http://localhost/bnm/hello.txt");
    URLConnection urlcon = url.openConnection();
    urlcon.setDoOutput(true);
    urlcon.setUseCaches(true);
    PrintWriter pt = new PrintWriter
    (new OutputStreamWriter (urlcon.getOutputStream()));
    String str = new String(URLEncoder.encode("this is output applet ")) ;
    pt.print(str);
    pt.flush();
    catch(Exception e)
    e.printStackTrace();
    The result is nothing, the file isn�t created, but the code don't throw exceptions.
    Ah! in other example, i can read a file of server fro m the applet, the problem is to write
    Anybody, knows the matter??
    Excuse my poor english :P
    Thanks for all.

    I had the same needs and didn't know whether this was possible, due to applets security restriction. So I searched the Web and found some contradictory information. I will explain what I think is the situation, to give you an answer, but also so that other people can tell me whether I understood correctly.
    1) Unless you sign it, an applet cannot write files directly, either client-side or server-side. All what it can do to access a file server-side (except .jar files ?) is opening a http connection, which allows only to retrieve data. When I try to run code such as yours, I get this exception :
    java.net.UnknownServiceException: protocol doesn't support output
         at java.net.URLConnection.getOutputStream(URLConnection.java:679)
    2) As Ares_Man points out, what it can do is opening a http connection not directly with the file you want, but with a server-side script (JSP, PHP, CGI,...) which will be allowed to write files on the server. You can use POST or GET parameters to pass to the script what you are going to write.
    This simple code worked for me (it executed the script toto.php):
              try{
                   URL toto=new URL(getCodeBase(),"toto.php");
                   InputStream f=toto.openStream();
                   f.close();
              catch(Exception e){
                   e.printStackTrace();
    Probably it's a good idea to do a URLConnection.setCache(false) though, to be sure that the script toto.php will be executed.
    3) I don't know how you can pass serialized objects as parameters. So if more than text informations are to be written, I would tend to make the script store them into a database instead of files. That way, you could pass any SQL query as parameter, maybe along with a password parameter for security. I don't know whether this is secure enough.

  • HOW TO INSERT DATA INTO SQL SERVER FROM MS ACCESS TABLE??

    NEED TO INSERT DATA INTO SQL SERVER FROM MS ACCESS TABLE.

    this is another method
    http://www.mssqltips.com/sqlservertip/2484/import-data-from-microsoft-access-to-sql-server/
    Please Mark This As Answer if it helps to solve the issue Visakh ---------------------------- http://visakhm.blogspot.com/ https://www.facebook.com/VmBlogs

  • Can't access server from Outside

    Hi all,
    I couldn't access my server from Outside. Seem the setting is OK as i see it but please see if I missed out anything.
    From Outside, I need to access http://60.x.x.50:8080. but failed to access. Please help. Thanks.
    Below I attached part of the config.
    : Saved
    ASA Version 8.0(4)
    name 172.47.1.10 NarayaServer description Naraya Server
    name 62.x.x.172 NarayaTelco1
    name 62.x.x.178 NarayaTelco2
    interface Ethernet0/0
    nameif outside
    security-level 0
    ip address 60.x.x.50 255.255.255.252
    interface Ethernet0/1
    nameif inside
    security-level 100
    ip address 172.27.17.100 255.255.0.0
    access-list inside_access_in extended deny ip any Japan02 255.255.255.0
    access-list inside_access_in extended deny tcp object-group PermitInternet any object-group torrent1
    access-list inside_access_in extended permit ip object-group PermitInternet any
    access-list inside_access_in extended permit ip host NAVNew any
    access-list inside_access_in extended permit ip host NarayaServer any
    access-list inside_access_in extended permit ip host IPVSSvr any
    access-list inside_access_in extended permit ip host 172.17.100.30 any
    access-list outside_access_in extended permit object-group NECareService object-group NECare any
    access-list outside_access_in extended permit ip object-group DM_INLINE_NETWORK_1 host NarayaServer
    access-list outside_1_cryptomap extended permit ip host NarayaServer object-group Nry_Png
    access-list outsidein extended permit tcp any host 60.x.x.50 eq https
    access-list outsidein extended permit tcp any host 60.x.x.50 eq 8080
    access-list outsidein extended permit ip object-group DM_INLINE_NETWORK_3 host IPVSSvr
    access-list outsidein extended permit object-group rdp any host 60.x.x.50
    access-list inside_mpc extended permit object-group TCPUDP any any eq www
    access-list inside_mpc extended permit tcp any any eq www
    access-list inside_nat0_outbound extended permit ip host NarayaServer any
    ip local pool lot10ippool 172.27.17.240-172.27.17.245 mask 255.255.255.0
    ip verify reverse-path interface outside
    global (outside) 10 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 10 0.0.0.0 0.0.0.0
    static (inside,outside) tcp interface 8080 NarayaServer 8080 netmask 255.255.255.255
    static (inside,outside) tcp interface 3389 NAVNew 3389 netmask 255.255.255.255
    access-group outsidein in interface outside
    access-group inside_access_in in interface inside
    route outside 0.0.0.0 0.0.0.0 60.54.140.49 1
    route inside 0.0.0.0 255.255.255.255 60.54.140.49 1
    route inside 172.17.100.20 255.255.255.255 172.27.17.100 1
    route inside NAVNew 255.255.255.255 172.27.17.100 1
    route inside 172.17.100.30 255.255.255.255 172.27.17.100 1
    route inside NarayaServer 255.255.255.255 172.27.17.100 1
    http server enable
    http 172.17.100.30 255.255.255.255 inside
    http NAVNew 255.255.255.255 inside
    http 192.168.1.0 255.255.255.0 management
    http 0.0.0.0 0.0.0.0 outside

    Hello Mohd,
    Here are the facts:
    I honestly think you need to change that route statement as it basically says if you want to contact the NARAYASERVER send the packet via the INSIDE interface to the IP address 172.27.17.100
    route inside NarayaServer 255.255.255.255 172.27.17.100
    interface Ethernet0/1
    nameif inside
    security-level 100
    ip address 172.27.17.100 255.255.0.0
    So basically send the packet to yourself (Does not make any sense.. Try to read it so you can understand what I mean.
    The NAT 0 is breaking the translation.
    access-list inside_nat0_outbound extended permit ip host NarayaServer any
    nat (inside) 0 access-list inside_nat0_outbound
    Do the following :
    access-list inside_nat0_outbound permit ip host NarayaServer OTHER_site_VPN_subnet
    no  access-list inside_nat0_outbound extended permit ip host NarayaServer any
    Then u should be able to connect,
    Let me know if you will follow my instructions, otherwise I think I am not helping here
    Note: As you already mark the question as answered you could provide kudos (stars) on my next answers
    Cheers,
    Julio Carvajal Segura

  • Connect to MS Sql Server from Java Source

    Hi,
    Is there any way I could connect to ms sql server from Java source? I know I can call java source from function thats easy but what I really want is capability to connect to non-oracle(MS SQL server) from my java source and then call it from function.
    I don't know if JDBC driver for SQL server is even installed/available. Is there a way I could find it out form my IDE? I know sqlJ does compile but I have never used sqlj. help!!!
    Sinha

    You'll probably have better luck in a Java forum or a Microsoft forum.

  • With Mountain Lion Server, can users access the Messages Server from outside your network?

    I would like to setup a new messaging service between my employees because we have issues with most online services. I'm thinking of getting a Mac Mini Server, so I can run Messages Server, but I have an employee outside my network. Can they login to the server remotely to use the Messages Server?
    Thanks

    If you're talking about setting up and using the Jabber messaging service provided by OS X server then yes, it's really easy to set up and use in and out of the office. The only trick it is, and also most other services, is a correct DNS setup so you're able to connect and use the server from the "outside".
    I use this myself (via Lion server rather than Moutain Lion server) from behind a dynamic IP addressed ADSL line and have no problems whatsoever.

  • Insert data into oracle based on sql server data(here sql server acting as source to oracle and destination to oracle)

    Source is Oralce. Destination is SQL Server.
    Requirement - I have to fetch sql server server data (empid's) based emp table  and send this as input data to oracle to fetch and empid's are common.
    I cannot use merge or loopkup or for each as oracle have too many records.
    For example - In MS SQL - i have empid=1,2..Only these records, I have to fetch from oracle source into sql server destination. For this, I have adopted the below approaches...The major problem I face, when i build a empid's as a string, it is taking only
    4000 chars. My string lenght is 10000. How do I breakup this string lengh and send to data flow task till all broken strings length passed to DFT.
    Approach-1
    created two variables - oraquery string, empid string
    step1 - ms sql database - created sql task - declare @empid varchar(max)
    SELECT @empid=
    Stuff((SELECT ',' + empid
            FROM  
            (SELECT  DISTINCT  convert(varchar(10),empid ) empid FROM emp
             ) x
            For XML PATH ('')),1,1,'')
    select @empid =    '(' +  @empid + ')'
    select @empid
    resultset=singlerow
    resultset=resultname=0; variablename=User::empid (empid is declared as string)
    step2 - oracle database - created data flow task
    created oledb source
    I put  this statemnt in oraquery expression - "select * from dept where dept in  "
    +  @[User::empid] + "
    expression=true
    [OLE DB Source [1]] Error: SSIS Error Code DTS_E_OLEDBERROR.  An OLE DB error has occurred. Error code: 0x80040E14.
    An OLE DB record is available.  Source: "Microsoft OLE DB Provider for Oracle"  Hresult: 0x80040E14  Description: "ORA-00936: missing expression".
    Approach-2
    created three variables - oraquery string, empid  int, loop object--when I put int then it is automatically setting to 0
    step1 - ms sql database - created sql task - SELECT  DISTINCT  convert(varchar(10),empid ) empid FROM emp
    resultset=fullresult
    resultset=resultname=0; variablename=User::loop
    step2 - created a for each loop container
    for loop editor - for each ado ennumerator
    enumerator configuration - loop
    variablemapping - variable=empid;index=0
    step3 - oracle database - created data flow task (outside for each loop. If I put inside it is taking long time)
    created oledb source
    I put  this statemnt in oraquery expression - "select * from dept where dept in  "
    +  @[User::empid] + "
    expression=true
    Data inserting in a destination table but  empid=0.

    Sorry didnt understand if your step3 is outside loop how
    @[User::empid] will get values for the empids from User::loop. The iteration happens inside loop so you
    need to have a logic to form the delimited list inside using a script task or something and concatenating everything and storing to variable @[User::empid]
    . Then only it will have full value used to be used in step3 query
    Please Mark This As Answer if it helps to solve the issue Visakh ---------------------------- http://visakhm.blogspot.com/ https://www.facebook.com/VmBlogs

  • Receving packets from outside source over PIX

    Hi.I have a rather strange problem. We have a PIX515E in our company and for the last couple of days we have been receiving packets with an invalid domain name on our DNS server from addresses outside of our network. What is really strange is that from the outside traffic can enter only our DMZ(not the inside network) via specific ports (mostly tcp port 80) for specific services and the problem is happening on the inside.
    Is there any way to monitor for such packets when they arrive on a PIX or better yet block them(they arrived from 4 different IP adresses from 4 different ranges)? Is it perhaps possible that a PC on the inside is allowing access to such packets?
    Any help is most welcome.

    Refer to the following document for more detail
    ASA 7.x/PIX 6.x and Above: Open/Block the Ports Configuration Example
    http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a0080862017.shtml

  • I can't create Entity Data Model Class directly from database

    I have just installed odac beta (ODAC1120250Beta_EntityFramework) and Orace XE 11g for test.
    I have Visual Studio 2010 on Windows 7 32bit.
    The problem is that after updating odac I can't create ADO.NET Entity Data Model class. If I try, VS2010 wizard makes me choose if I want to generate from db or create an empty model. If I choose to generate from database, the next window disappers making me return to VS2010.
    The workaround is to create an empty model and then update model from database. In this way it works.
    Anybody has experimented the same?...
    Best regards
    Francesco

    A couple of things you could try:
    1. Install SP1 for Visual Studio 2010.
    2. Do you already have an Oracle connection created in server explorer? If not, try creating one and then create the model.

  • Access to file server from outside the domain

    We have users from another domain who connect over VPN to our SAP.
    These users must drop a file on a certain server in our domain to create labels.
    The problem is that they are not users on the domain, so they don't have access rights. I tried with GUI_DOWNLOAD, but this function uses Windows Access Rights. What I need is that SAP (or some system user) just puts the file there whitout checking the access rights or that this putting is done under another user.
    Has somebody an idea or knows what function I can call to do this ?
    Thanks

    Hi Thomas,
    I’m writing to follow up with you on this post. Was the link above help you solve your issue?
    If you are satisfied the solution, I’d like to mark this issue as "Answered". Please also feel free to unmark the issue, with any new findings or concerns you may have.   
    Regards,
    Charlie Liao
    TechNet Community Support

  • Data services job failes while insert data into SQL server from Linux

    SAP data services (data quality) server is running on LInux server and Windows. Data services jobs which uses the ODBC driver to connect to SQL server is failing after selecting few thousand records with following reason as per data services log on Linux server. We can run the same data services job from Windows server, the only difference here is it is using SQL server drivers provided by microsoft. So the possible errors provided below, out of which #1 and #4 may not be the reason of job failure. DBA checked on other errors and confirmed that transaction log size is unlimited and system has space.
    Why the same job runs from Windows server and fails from Linux ? It is because the ODBC drivers from windows and Linux works in different way? OR there is conflict in the data services job with ODBC driver.
    ===== Error Log ===================
    8/25/2009 11:51:51 AM Execution of <Regular Load Operations> for target <DQ_PARSE_INFO> failed. Possible causes: (1) Error in the SQL syntax;
    (2)6902 3954215840 RUN-051005 8/25/2009 11:51:51 AM Database connection is broken; (3) Database related errors such as transaction log is full, etc.; (4) The user defined in the
    6902 3954215840 RUN-051005 8/25/2009 11:51:51 AM datastore has insufficient privileges to execute the SQL. If the error is for preload or postload operation, or if it is for
    ===== Error Log ===================

    this is another method
    http://www.mssqltips.com/sqlservertip/2484/import-data-from-microsoft-access-to-sql-server/
    Please Mark This As Answer if it helps to solve the issue Visakh ---------------------------- http://visakhm.blogspot.com/ https://www.facebook.com/VmBlogs

  • Access to a web server from outside(ASA 5505)

    Heelo, need kindly advice
    i`ve configured NAT rules as following:
    object network HWebServer
    host 10.43.1.11
    description OutsideWebserver
    object network HWebServer
    nat (inside,outside) static interface service tcp 80 8087
    then set access rules to allow 8087 port on outside interface.
    but still, cannot open 10.43.1.11:8087 from internet side
    what can be done to solve?
    thanks in advance
    Komil

    Hi,
    The NAT configurations is fine but the problem is with the ACL you have configured.
    Since Cisco introduced the new NAT configuration format in the ASA Software versin 8.3 (and above) you have to allow traffic always to the real IP address and to the real port also.
    Your problem seems to be that you have allowed traffic to the mapped port TCP/8087 and not the real port TCP/80.
    So make a rule that allows port TCP/80 from the external network and then try again.
    The reason why you need to allow connections to the real IP address and real port is because the ASA first does the UN-NAT for the destination address and port and after that it checks the interface ACL and since the UN-NAT has been done the destination in that case is the Real IP and the destination port the Real Port.
    Hope this helps :)
    - Jouni

  • Remote access VPN to server from outside and server reach internet on the same time

    Dear,
    I have problem in my ASA 5515-X , when i make Remote access VPN to servers in inside zone the internet connection disconnected in the servers, or when i have internet in servers, the remote access cant reach servers.
    the configuration for server as static NAT for each server, and the connection of VPN is to another public IP but in the same subnet of NAT ip.
    server1 : 10.10.10.2 nat to 5.6.7.8
    server2: 10.10.10.3 nat to 5.6.7.9
    server3: 10.10.10.4 nat to 5.6.7.10
    VPN connection to 5.6.7.12
    is there any solution for this senario, remote vpn to servers and the same time the servers have internet readability for download updates .. etc

    Hi,
    So it seems that the problem is with lacking a NAT0 configuration
    You could modify the below configuration to match your networks/IP addresses used. In the below configuration I presume that you have interfaces "inside" and "outside".
    object network SERVER-NETWORK
     subnet <server network address> <network mask>
    object network VPN-POOL
     subnet <vpn pool network address> <network mask>
    nat (inside,outside) 1 source static SERVER-NETWORK SERVER-NETWORK destination static VPN-POOL VPN-POOL
    Just insert the correct address related information and change the "object" and interface names if required.
    This configuration will tell the ASA that no NAT will be performed for traffic between the VPN-POOL and SERVER-NETWORK. The NAT configuration is bidirectional. With this configuration the Static NAT configurations will continue to work for the servers Internet traffic and this NAT0 configuration will be applied only to the VPN Client traffic.
    Hope this helps :)
    - Jouni

  • Cannot remote into server from outside the network

    I have two laptops that all I want is to have them able to VPN to my server.  When the laptops are on my network, they are able to network in and see the server.   But when I go to Starbucks or McD's, I can connect to their network but I cannot VPN into my server.  I am getting a message that LT2?? - VPN, of course I cannot remember exactly what the message said but, it does not work.  I have changed the ports on the time capsule to 80, 1723 and something that is 4500.  As you can tell I am NO expert but would like to understand what I am doing wrong.
    I have CenturyLink and a time capsule that I have to pass through just to get to the server.  What else am I missing?

    Good advice from ebrind
    I'll add to it:
    - what IP address does your time capsule have?
         If your CenturyLink provides NAT and your Time Capsule is also setup for NAT, you will need to reconfigure either the TC or the CenturyLink to bridge mode and set the port forwarding in the device providing NAT.
    - do you see any activity in the VPN Log?
    - Your VPN server address which you set in your laptop should be the public address of your network, not the LAN address
    - If you do make a successful VPN connection, don't expect to see the server like you do when you are on the LAN. If the LAN address of your server is 10.1.10.2, you'll need to connect to:   afp://10.1.10.2  (after a successful VPN connection)
    - Lastly, do you need VPN? If you just need access to your files from the server, you can do this without VPN. Depending on your security requirements, you can simply map port 548 and access with:  afp://[public-ip]   or use webdav with SSL.

  • How do I initialize a trust database (Security Create Database) in Iplanet6 web server from the Solaris command line?

     

    Hi,
    There is no option to create trust database from command line. You have to do it from GUI only.
    Thanks,
    Daks.

Maybe you are looking for

  • Help trying to create a 2 page indesign doc with 1 landscape & 1 portrait page?

    I'm creating a double sided A5 flyer, how do I create a 2 page indesign document with one page portrait & the other landscape? Thank you in advance for anyone who can help with this ;-)

  • Remembered Networks and Internet Sharing

    How can you view the list of remembered wireless networks to remove one of them? I don't want to connect to this one network when i'm in a certain area, and airport instantly connects when I turn it on. Also, whenever I turn on airport, my powerbook

  • HT4168 Pages export to ePub - unwanted question marks

    When I export a Pages doc to ePub, a question mark appears at the end of every line. How can I avoid that? If I take the Export to ePub doc from Apple and export it, no problem. If I add some lines of my own at the end and then re-export, question ma

  • Remove element from xml using dom.

    i want to remove an element from an xml file using dom. i remove the element but the whole content of the file is also deleted. how can i rewrite the file.

  • V basic newbie question

    hi i had decided this weekend to start looking at the JAVA stuff I should be a real help to me at work. However i am having a problem setting things up. i have looked at the FAQ's but they don't seem to answer my question which is HOW do I set my com