CSS11501 load-balancing SMTP and LDAP servers

Can anybody provide me with samples of configuration to load-balance SMTP & LDAP servers with CSS ? I feer having the same problem as with FTP when the session is initiated from the server side and that we have to make some special adds-on to the config ?

Load balancing should work fine on the CSS. I am sure that there is some confiugaration issue. Can you post the configuration so that we can check where the problem is?

Similar Messages

  • How do I load balance TFTP between two servers and a client on the same subnet?

    Hi,
    I have trawled through several documents and tried umpteen different configs, all to no avail. I have a PXE boot client trying to access a boot file via TFTP from a couple of TFTP servers on the same VLAN/subnet. For HA purposes I want to load balance the two TFTP servers.
    Config is currently;
    =====
    probe icmp ICMP_PROBE
      description icmp probe for default gateway tracking
      interval 5
      passdetect interval 15
    rserver host server1
      description Server1
      ip address 10.0.0.1
      inservice
    rserver host server2
      description Server 2
      ip address 10.0.0.2
      inservice
    serverfarm host serverfarm_01
      description servers used
      probe ICMP_PROBE
      rserver server1
        inservice
      rserver server2
        inservice
    class-map match-all L4_VIP_TFTP
      10 match virtual-address 10.0.0.10 udp eq 69
    policy-map type loadbalance first-match L7_TFTP
      class class-default
        serverfarm serverfarm_01
    policy-map multi-match L4_LB_VIP_POLICY
      class L4_VIP_TFTP
        loadbalance vip inservice
        loadbalance policy L7_TFTP
        loadbalance vip icmp-reply active
    nat dynamic 1 vlan 200
    interface vlan 200
      ip address 10.0.0.250 255.255.255.0
      nat-pool 1 10.0.0.241 10.0.0.243 netmask 255.255.255.255 pat
      service-policy input L4_LB_VIP_POLICY
      no shutdown
    ip route 0.0.0.0 0.0.0.0 10.0.0.254
    =====
    I have read the doco by Ivan Kovacevic amongst many others but as my clients and servers are on the same subnet, the config doesnt work.
    Can anybody point me in the right direction please. The devices are ACE 4710 running A3(2.3).
    Thanks

    Try using the following configuration:
    Note: Please make sure to configure also a udp probe to probe udp port 69, in case the application is down.
    You need to configure a management policy on the interface when using a UDP probe.
    That is because, when port 69 on the server will be unreachable, the server will send an ICMP unreachable.
    ACE will consider a udp probe as "failed" only when it sees ICMP unreachable.
    Without a management policy-map, the ICMP unreachable message will be dropped.
    Also, add an ICMP probe to the rserver because udp probe will not be enough when the physical interface will be down.
    That is because UDP is a connection-less protocol. To consider a UDP probe successfull, ACE need to see NO answer from the server in respose to the probe.
    The ACE will not see any answer from the server when the interface is down and thus, will consider the probe as "sucessful".
    With ICMP probe attached to the rserver, you also test the reachability of the server and not only the UDP port.
    Here is the configuration (of course, you can chage the names of the of the objects to the name you are using if you want) :
    access-list ALL line 10 extended permit ip any any
    probe udp TFTP
      port 69
      interval 5
      passdetect interval 15
    probe icmp ICMP_PROBE
      interval 5
      passdetect interval 15
    rserver host TFTP_1
      ip address 10.0.0.1
      probe TFTP
      probe ICMP_PROBE
      inservice
    rserver host TFTP_2
      ip address 10.0.0.2
      probe TFTP
      probe ICMP_PROBE
      inservice
    serverfarm host TFTP-SFARM
      rserver TFTP_1
        inservice
      rserver TFTP_2
        inservice
    sticky ip-netmask 255.255.255.255 address source TFTP-STICKY
      timeout 10
      replicate sticky
      serverfarm TFTP-SFARM
    class-map type management match-any MANAGE
      2 match protocol icmp any
    class-map match-all NAT
      2 match virtual-address 0.0.0.0 0.0.0.0 udp any
    class-map match-all TFTP
      2 match virtual-address 10.0.0.10 udp eq 69
    policy-map type management first-match MANAGE
      class MANAGE
        permit
    policy-map type loadbalance first-match ROUTE
      class class-default
        forward
    policy-map type loadbalance first-match TFTP-POL
      class class-default
        sticky-serverfarm TFTP-STICKY
    policy-map multi-match TFTP-MULTI
      class TFTP
        loadbalance vip inservice
        loadbalance policy TFTP-POL
        nat dynamic 1 vlan 212
      class NAT
        loadbalance vip inservice
        loadbalance policy ROUTE
        nat dynamic 2 vlan 212
    interface vlan 212
      ip address 10.0.0.250 255.255.255.0
      no normalization
      access-group input ALL
      nat-pool 1 10.0.0.241 10.0.0.243 netmask 255.255.255.0 pat
      nat-pool 2 10.0.0.10 10.0.0.10 netmask 255.255.255.0 pat
      service-policy input TFTP-MULTI
      service-policy input MANAGE
      no shutdown
    Let me know how it goes.
    Good luck!

  • LOAD BALANCE (CSS) and Portal Port Number based on Instance Number

    Hi,
    My doubt is about LOAD BALANCE (CSS) and Portal Port Number based on Instance Number.
    I have to install 3 servers machines and 2 servers databases cluster. There will be a HIGH AVAILABILITY environment. There will be a MIGRATION and UPGRADE.
    Today there are 2 servers machines in Windows NLB. Today my production Portal is 6 6.20.
    Once, I did something for LABORATORY TEST. Migration (6 6.40) and Upgrade (7.0)in two other machines. But they were with Windows NLB. When I did the installation, for each server machine and during the instalation I had to give one Instance Number for each and in result there was a different Port Number for each.
    But I accessed both machines throught a virtual url(dns) with a specific port number. And it works!
    NOW, with a HARDWARE LOAD BALANCE _ CSS I don't know how to do.
    A guy who works with it  tell us that couldn't redirect one Port Number for different port numbers. He couldn't configure the CSS like this.
    My question is: Is he write? And if he is, there is a  way to give the same instance number for my 3 new Portal servers machines? Example: 5(02)00.
    Could you understand?
    I need help.
    Regards,
    cheers,
    Nivia

    Nivia,
    I have used F5 for load balancing, I am sure you can do the same with CSS. Yes, you can configure a virtual IP on the load balancer with standard ports (80 or 443) and load balancing the traffic to multiple servers with different ports. You can have different ports for each instance.
    -Regards
    RK

  • Trying to load Balance several Cisco ISE servers.

    Trying to load Balance several Cisco ISE servers.  For persistence, Cisco recommends using Calling-Station-ID and Framed-IP-address...Session-ID is recommended if load balancer is capable of it.  I have documentation for the Cisco ACE, but using F5 LTM's.  Assuming this has to be done with an I-Rule as none of these are available as a default.  Not sue where to begin.  I tried attaching the Cisco PDF, but not able for whatever reason.

    Please also keep in mind that When using a Load-Balancer (anyone's) you must ensure a few things.
    Each PSN must be reachable by the      PAN /  MNT directly, without having to go through NAT (Routed mode LB,       not NAT). No Source-NAT. This includes the Accounting      messages, not  just the Authentication ones.
    This means the       Load-Balancer must be in the direct path between the clients and the ISE PSNs.
    Some       organizations have used Policy  Based Routing (PBR) to accomplish the       path, without physically  locating the Load-Balancer between the clients       and the PSNs.
    Endpoints (clients) must be able      to  reach each Policy Services Node Directly (not going through the VIP) for       redirections/Centralized Web Authentication/Posture  Assessments/Native      Supplicant Provisioning, and more.
    You may want to "hack"      the certs to include the VIP FQDN in the SAN field (my next blog post      should cover this trick).
    Perform sticky (aka: persistence)      based on Calling-Station-ID and Framed-IP-address.
    VIP gets listed as the RADIUS      server of each NAD for all 802.1X related AAA.
    Dynamic-Authorization (CoA):
    If you use       Server NAT to replace the  PSN IP address with the VIP Address for Change       of Authorization,  then you would use the VIP address as the       Dynamic-Authorization  (CoA) client.
    Otherwise, use       the real IP Address of the PSN, not the VIP.
    The LoadBalancers get listed as      NADs in ISE so their test authentications may be answered, to keep the      probes alive.
    ISE uses the Layer-3 Address      to  identify the NAD, not the NAS-IP-Address in the RADIUS packet. This       is a big reason to avoid SNAT.
    Failure Scenarios:
    The VIP is the RADIUS Server, so      if the  entire VIP is down, then the NAD should fail over to the Secondary       DataCenter VIP (listed as the secondary RADIUS server on the NAD).
    Use probes on the Load-Balancers      to ensure that RADIUS is responding, as well as HTTPS (at minimum).
    LB Probes       should send test RADIUS  messages to each PSE periodically, to ensure that       RADIUS is  responding, not just look for open UDP ports.
    LB Probe should       also examine the response for HTTPS, not just look for the open port(s).
    Use node-groups with the L2-adjacent      PSN's behind the VIP.
    If the       session was in process and one  of the PSN's in a node-group fails,       then another member of the  node-group will issue a CoA-reauth; forcing       the session to begin  again. 
    At this point,       the LB should have  failed the dead PSN due to the probes configured       in the LB; and so  this new authentication request will reach the LB &       be  directed to a different PSN…

  • Load balancing, failover and fallback in Non-Clustered WebLogic environment

    hi,
    Has anyone implemented WebLogic 10.3.3 (or 10.3.4) in a Non-Clustered environment, but also got load balancing, failover and fallback work?
    We were successful in getting failover working using t3://server1:7001,server2:7002 provider URL, but not load balancing or fallback.
    The fallback is working when it was connecting to server2 and if we kill server2, then it switches to server1, but not when server2 is still running while server1 comes back.
    All we need to find a way to enforce fallback to primary site, even if secondary which the client connected is still up and running and primary site comes back.
    Any help appreciated.
    Thanks.
    Best regards,
    Bala

    hi,
    Has anyone implemented WebLogic 10.3.3 (or 10.3.4) in a Non-Clustered environment, but also got load balancing, failover and fallback work?
    We were successful in getting failover working using t3://server1:7001,server2:7002 provider URL, but not load balancing or fallback.
    The fallback is working when it was connecting to server2 and if we kill server2, then it switches to server1, but not when server2 is still running while server1 comes back.
    All we need to find a way to enforce fallback to primary site, even if secondary which the client connected is still up and running and primary site comes back.
    Any help appreciated.
    Thanks.
    Best regards,
    Bala

  • Site not found using Sharepoint Designer 2013, Load balance URL and the Front end servers.

    Dears,
    My SharePoint farm is with the below configuration in our office :
    Batch processing server the with Central Administration
    Web Front End Sever 1 (http://wfe01)
    Web Front End Sever 2 (http://wfe02)
    I do have the load balance URL as http://finance.mycompany.com and as per the system administrator it seems configured properly.
    In AAM i have mapped the URLs as below for the web application in Central Administration portal:
    http://finance.mycompany.com - Default Zone
    http://wfe01 - Intranet Zone
    http://wfe02 - Internet Zone
    I was able to browse the site via the load balance URL : http://finance.mycompany.com, but couldn't open the site using the Share Point Designer 2013. It always says the site not found.
    please advise,
    thanks,
    Ammar

    What do the wfe01 and wfe02 aams do?
    Are you browsing to the SharePoint site and using SPD on the same computer, is it part of the farm or a seperate client computer?
    thanks Alex a lot for your response and appreciate the same.
    WFE01, WFE01 is connected to the one central admin on Batch Processing Server (central admin URL is http://SharepointCA:5555 and the SharePoint Web Application is hosted under port 80 on the same server). So the AAM configured on the batch processing server
    central admin.
    I can connect to the site using the SPD inside the Batch Processing server if i mention the site urs as http://localhost. But not from other client computers by putting the load balance URL - http://finance.mycompany.com.
    I can browse the sites directly putting http://wfe01, http://wfe02 and as well as the load balance URL (http://finance.mycompany.com). The custom webparts are getting crashed when i put the web application URL as http://finance.mycompany.com.
    thanks,
    Ammar

  • CSS11501 load-balancing IPv6 services

    Hi,
    I'm new to content networking and load-balancing.
    I am setting up a new nameserver network site and have the following equipment:
    - Cisco 2811
    - Cicso CSS11501
    - Cisco Catalyst 2960
    This site will have 2 nameservers which I want to load-balance behind the CSS11501. The network will be setup like this:
    Internet
    |
    Cisco 2811
    |
    CSS11501
    |
    Cisco 2960
    |
    Nameservers 1 & 2
    The CSS11501 will be in routed mode and will have a publicly addressed VIP (eg, 203.x.x.x) for the DNS service and the name servers will be privately addressed (eg, 10.x.x.10 & 10.x.x.11). I'm hoping this will work fine and serve the requested IPv4 DNS requests.
    I would like the nameservers to also operate on IPv6 and serve out IPv6 DNS requests but am not sure the CSS11501 can perform IPv6 service load-balancing.
    My question is, does the CSS11501 support IPv6, load-balancing IPv6 service requests?
    Thanks in advance.
    Richard.

    Gilles,
    Thanks for the reply.
    On another site I was looking at rolling out a Catalyst 6500 CSM module to do the exact same thing as the site I have the CSS11501's at, but it too does not support IPv6 from all I could find. Does the ACE provide all the functionality of the CSM plus IPv6?
    Thanks.
    Richard.

  • Load balancing across multiple application servers not working with JCo RFC

    We have a problem where inbound messages to the Mapping Runtime engine (ABAP -> J2EE) are not load balanced over application servers. However, load balancing does take place across server nodes within one application server.
    Our system comprises of the following:
    Central Instance (2 X server nodes)
    Database Instance
    2 X Dialog Instances (with 2 X server nodes each)
    The 1st application server that starts is usually the one that is used for inbound messaging.
    We have looked at the sap gateway configuration and have tried various options without much luck:
    i.e.: local gateways vs. one central gateway, load balancing type by changing parameter gw/reg_lb_level, see: http://help.sap.com/saphelp_nw70/helpdata/EN/bb/9f12f24b9b11d189750000e8322d00/frameset.htm
    Here are our release levels:
    SAP_ABA     700     0012     SAPKA70012
    SAP_BASIS     700     0012     SAPKB70012
    PI_BASIS     2005_1_700     0012     SAPKIPYJ7C
    ST-PI     2005_1_700     0005     SAPKITLQI5
    SAP_BW     700     0013     SAPKW70013
    ST-A/PI     01J_BCO700     0000          -
    Any help would be greatly appreciated.
    Many thanks

    Tim
    Did you follow the guide here:
    How to Scale Up SAP Exchange Infrastructure 3.0  
    Learn what the most likely scaled system architecture looks like, and read about a step by step procedure to install additional dialog instances. The guide also walks you through additional configuration steps and the application of Support Package Stacks.
    https://www.sdn.sap.com/irj/sdn/go/portal/prtroot/docs/library/uuid/c3d9d710-0d01-0010-7486-9a51ab92b927
    We followed this guide for XI3.0 and PI7.0 and works successfully!

  • ACE Load Balance setup and testing - vip

    Got a new ACE 4710 and am I new to the appliance. I am testing out a senario with load balancing between two servers. In testing when I ping the VIP ip address the replies I see are from the real server ip addresses. I am just wondering if this is the correct normal behavior or should I see the ping replies coming from the VIP ip address?
    Thanks

    Do you use the
        loadbalance vip icmp-reply active
    command?
    policy-map multi-match POL45
      class VStest
        loadbalance vip inservice
        loadbalance policy L7SLBPOLtest
        loadbalance vip icmp-reply active

  • Load balancing across 4 web servers in same datacentre - advice please

    Hi All
    Im looking for some advice please
    The apps team have asked me about load balancing across some servers but im not that well up on it for applications
    Basically we have 4 apache web servers with about 2000 clients connecting to them, they would like to load balance connections to all these servers, they all need the same DNS name etc.
    what load balancing methods would I need for this, I believe they run on Linux
    Would I need some sort of device, or can the servers run some software that can do this, how would it work? and how would load balancing be achieved here?
    cheers

    Carl,
    What you have mentioned sounds very straightforward then everything should go well.
    The ACE is a load balancer which takes a load balancing decisions based on different matching methods like matching virtual address, url, source address, etc then once the load balance decision has been taken then the ACE will load balance the traffic based on the load balance method which you have configured (if you do not configure anything then it will use the default which is "round robin"), then it will send the traffic to the servers which it has available and finally the client should get the content.
    If you want to get some details about the load balancing methods here you have them:
    http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA3_1_0/configuration/slb/guide/overview.html#wp1000976
    For ACE deployments the most common designs are the following.
    Bridge Mode
    One Arm Mode
    Routed Mode
    Here you have a link for Bridge Mode and a sample for that:
    http://docwiki.cisco.com/wiki/Basic_Load_Balancing_Using_Bridged_Mode_on_the_Cisco_Application_Control_Engine_Configuration_Example
    Here you have a link for One Arm Mode and a sample for that:
    http://docwiki.cisco.com/wiki/Basic_Load_Balancing_Using_One_Arm_Mode_with_Source_NAT_on_the_Cisco_Application_Control_Engine_Configuration_Example
    Here you have a link for Routed Mode and a sample for that:
    http://docwiki.cisco.com/wiki/Basic_Load_Balancing_Using_Routed_Mode_on_the_Cisco_Application_Control_Engine_Configuration_Example
    Then as you could see in all those links you may end up having a configuration like this:
    interface vlan 40
      description "Default gateway of real servers"
      ip address 192.168.1.1 255.255.255.0
      service-policy input remote-access
      no shutdown
    ip route 0.0.0.0 0.0.0.0 172.16.1.1
    class-map match-all slb-vip
      2 match virtual-address 172.16.1.100 any
    policy-map multi-match client-vips
      class slb-vip
        loadbalance vip inservice
        loadbalance policy slb
    policy-map type loadbalance http first-match slb
      class class-default
        serverfarm web
    serverfarm host web
      rserver lnx1
        inservice
      rserver lnx2
        inservice
      rserver lnx3
        inservice
    rserver host lnx1
      ip address 192.168.1.11
      inservice
    rserver host lnx2
      ip address 192.168.1.12
      inservice
    rserver host lnx3
      ip address 192.168.1.13
      inservice
    Please mark it if it answered you question then other users can use it as reference in the future.
    Hope this helps!
    Jorge

  • Load Balancing, Tomcat, and SharePoint

    I'm a new BusinessObjects customer and am working on getting all of the hardware in place for a new install.  The initial plan is to have two BOE servers, and two tomcat virtual servers, with a hardware based load balancer (F5 BIG-IP Switch: Local Traffic Manager 1600 4GB, possibly) in front of the tomcat servers to handle the load balancing.
    But, I'm starting to think that it would be a good idea for us to integrate directly in to our SharePoint portal using the SAP SharePoint Integration option.
    So, here's my question.  If we do that, then our users will get to their BusinessObjects information via SharePoint.  So, SharePoint and IIS will be the web server.  Will we still have a need for the Tomcat servers?  Will SharePoint point to the load balancer, then to Tomcat, and finally to the BOE server, or will it go right to the BOE server, thus negating the need for the tomcat servers altogether, and also even negating the need for the load balancer?  If so, can the BOE app servers themselves still be load balanced?
    Hopefully this all makes sense - like I said, we're a new customer, so I don't fully understand all of what the servers are doing.  I've spent several days searching the forums & the web & reading documentation and haven't come up with an answer yet, so I'm reaching out to you all & hoping somebody can clear it up for me.  Thanks!!

    Thank you for your input, Denis, this does help explain things.  Also, thanks for pointing me to that Windows Patterns document.  I hadn't seen that one - since we're starting out on 4.0, I've only been looking at documents under the 4.0 folders...
    It sounds like we may want to utilize this same load balancer to balance the SharePoint traffic as well, while we're at it.  Right now our SharePoint server is clustered using Microsoft Clustering, but not load balanced in any way.  Or maybe we just post a link from within SharePoint to the regular old BI LaunchPad and call it a day!
    So, if I understand correctly, if we utilize SharePoint, any traffic/processing that the Tomcat server would have handled would now be handled by the SharePoint server, which could potentially be significant.  The actual processing of the reports, though, will still get handled by the BOE Cluster, which takes care of its own load balancing, so we'll be fine.  Really the only thing the hardware load balancer does is allow the presentation layer to be load balanced - the layers beyond that get load balanced automatically via CMS.  Is that all somewhat valid?  In the patterns doc, there's Application Servers separate from the BOE Servers.  We were just going to have two BOE servers and two Web servers.  Where do the application servers fall in, and are they load balanced using the hardware piece?
    If we were just concerned about High Availability, it seems like maybe we could more easily use Windows Clustering on those Tomcat servers, and avoid the hardware component altogether.  Do the Web servers really get hammered that hard that we need them load balanced?  It seems like the BOE servers are the ones doing the heavy resource intensive tasks and we get them load balanced without the hardware anyway, so maybe load balancing the web servers is overkill.....  I'm sure a lot of this is tough to answer, I'm just trying to get a feel for it.  I want us to have our best performance & be somewhat future-proofed, but don't want to buy things that I don't need to!  We're probably looking at a small, 10-20 concurrent user setup for starters, and out to say 200 concurrent max once it's fully rolled out...
    Thanks again!!

  • CSS 11503 load-balancing with MS Print Servers

    We are trying to load-balance print server connections between 2 MS print servers. When we try to connect to the print servers name, (\\PS01) or even the VIP address, we get a Path not found error. However, if we direct the path to the actual name or ip address of the print servers (not the VIP), we can view all the queues and connect/print to them. Is this possible to do on the CSS 11503? Thanks.

    Pete- Here is our config. See any problems?
    configure
    !*************************** GLOBAL ***************************
    ip route 0.0.0.0 0.0.0.0 1.100.100.100 1
    !************************* INTERFACE *************************
    interface 1/2
    bridge vlan 2
    !************************** CIRCUIT **************************
    circuit VLAN1
    ip address 1.100.101.110 255.0.0.0
    circuit VLAN2
    ip address 10.100.249.1 255.255.255.0
    !************************** SERVICE **************************
    service ps01
    ip address 10.100.249.5
    active
    service ps02
    ip address 10.100.249.6
    active
    !*************************** OWNER ***************************
    owner printserver
    content L3_Basic
    add service ps01
    add service ps02
    vip address 1.100.100.35

  • 2950 load balancing two Windows 2003 servers

    We just purchased two Windows 2003 servers that connect directly to a 2950. They have setup network load balancing on the servers. With this setup both of the servers have the same MAC address cloned to their NICS. This is obviously causing a problem with the ARP table on the 2950. I opened a TAC case, and they said it was a Microsoft problem. The vendor that installed the servers says it the switch. Has anybody ever done this?
    Thanks

    Hello,
    I think you would speak about "MAC address table" and not "ARP table" for your 2950 switch. It's typically a trouble known by Microsoft and describe here :
    http://support.microsoft.com/default.aspx?scid=kb;en-us;193602
    Regards
    Yves

  • Load balancing 3 2013 FE servers through a HW load balancer

    I want to set up our 3 FE servers so the go through our HW load balancer. From what I have read so far, the recommended solution is to LB the SIP traffic using DNS but LB the web services through the HW LB. In order to do this, I need to override the web
    services URL but the problem with that is I don't have a name in my certificate available. Right now, the pool name and the web services name are the same. Lyncpool.domain.com.
    If I override the web services URL, the name I choose has to be in the certificate Lync created. If I wanted to go this route, what should I do?
    Or, I can just pass everything through the HW LB. Both SIP and web services traffic. Not sure what ports I would need to allow but shouldn't be too hard to figure out. Any advice would be appreciated.

    Internal web services are: Meet - you need this for meetings Dialin - you need this for pin mgmt for users, changing their meet URL and information about dtmf. I wouldn't skip it if I was you Lyncdiscoverinternal - used for location of the services for
    mobile and slates Internal web service URL - used for access to address book and certificate services, download of meet content and more. This IS a must Admin, can be skipped, yes All of the above should be in a single certificate + the three servers in your
    deployment. (I recommend this approach, as the HLB MUST have this in its certificate. You can accomplish this by enrolling on one server and adding the other server names in the additional host names dialog box. After adding the internal override URL, and
    publishing the topology, you should: -make sure replication status is true - Run bootstrapper on all servers - create a new cert (make sure all your host names are present), make sure it is exportable - install the new cert on the server - Restart IIS - Export
    this certificate with private key - import this certificate on the other two servers (restart iis after import and assignment) - Import this certificate on the HLB and use it on the http VIP Hope this helps :)
    Lasse Wedø,
    Blog:Tech@work, Twitter: @lawedo
    Please take a second to hit the green arrow on the left if the post was helpful, or mark it as an answer if it resolved your issue.

  • Load Balancing, Server and / or Client ?

    Hi
    I am experiencing a problem with the connection pooling in odp.net. I have a simple test app that creates a connection, executes a query, populates an object then closes the connection. I have found that when I have client side load balancing on via the odp.net connection string property many connections are made unnecessary (sometime the actual number created reaches the max pool size but the numbers differ randomly). It appears that rather than a free connection in the pool being used more connections are being created which defeats the point of having a connection pool. I do have server side load balancing configured correctly also. Due to this finding can someone possibly answer the following questions.
    a) Do I need both server side and client side load balancing set?
    b) If I do why is the above behaviour being seen? If not could you give me a short explanation as to why not?
    Current set up is 11g (patched to 6, awaiting 7 to be applied) RAC, 2 nodes.
    Below is the C# code used while testing this. The table queried is a simple person table containing 16000 rows if data.
    OcConnection = "User Id=XXX; Password=XXX; Connection Lifetime = 60; Data Source=(DESCRIPTION=(ADDRESS_LIST=(FAILOVER=on)(LOAD_BALANCE=off)(ADDRESS=(PROTOCOL=tcp)(HOST=XXX)(PORT=1521))(ADDRESS=(PROTOCOL=tcp)(HOST=XXX)(PORT=1521)))(CONNECT_DATA=(SERVICE_NAME=MyFirstTest))); Pooling=true; HA Events = true; Load Balancing = true";
    Code:-
    Oracle.DataAccess.Client.OracleConnection con;
    con = new Oracle.DataAccess.Client.OracleConnection();
    con.ConnectionString =OcConnection;
    con.Open();
    // the command object to use for this test
    OracleCommand cmd = con.CreateCommand();
    cmd.CommandText = "select * from PERSON";
    OracleDataReader rdr = cmd.ExecuteReader();
    List<test> listTest = new List<test>();
    while (rdr.Read())
    test dc = new test();
    if (!rdr.IsDBNull(0))
    dc.id = Convert.ToInt32(rdr.GetValue(0));
    if (!rdr.IsDBNull(1))
    dc.forename = rdr.GetString(1);
    if (!rdr.IsDBNull(2))
    dc.surname = rdr.GetString(2);
    if (!rdr.IsDBNull(3))
    dc.street = rdr.GetString(3);
    if (!rdr.IsDBNull(4))
    dc.city = rdr.GetString(4);
    if (!rdr.IsDBNull(5))
    dc.postcode = rdr.GetString(5);
    if (!rdr.IsDBNull(6))
    dc.country = rdr.GetString(6);
    if (!rdr.IsDBNull(7))
    dc.email = rdr.GetString(7);
    if (!rdr.IsDBNull(8))
    dc.dateadded = rdr.GetDateTime(8);
    if (!rdr.IsDBNull(9))
    dc.randWords = rdr.GetString(9);
    if (!rdr.IsDBNull(10))
    dc.uniqueNumber = Convert.ToInt32(rdr.GetValue(10));
    listTest.Add(dc);
    rdr.Close();
    con.Close();
    rdr.Dispose();
    cmd.Dispose();
    con.Dispose();
    Thanks for your time
    Victoria

    Here are the HTTP Headers as monitored on the client side. Notice the good.txt file includes a GET as it's initial request. All works fine in this case. However, the initial request in the bad.txt is a POST. This is odd since the URL was opened using the same shortcut in both incidents and the browser was closed between each trace that was taken. I've also reviewed the shortcut with notepad to verify it does not include unwanted data such as the JSESSIONID info....etc.
    Once you have reviewed the HTTP headers, I have these questions.
    1. IIS is sending the 100 Continue messages as you mention, but why is the CSS injecting the cookie in a 100 response that is not typically processed by the client? The bad.txt file shows the client receiving two ARPT cookies because the first cookie in the 100 continue response was ignored.
    2. I know Cisco is not really in the business of troubleshooting browser behaviour. But do you know why the browser would behave differently....GET in one request and a POST in the next? We do not wish to get into modifying the browser, so I'm hoping we can provide a solution on the server side that will allow the browser to function this way if it chooses to do so. Do you think it would make sence to push the state management up a level to the cookie handed out by JRUN? This way, the cookie would not be handed back in a 100 response from IIS, and we could tell the CSS to monitor the JRUN cookie. Of course this would require we determine how to manage this cookie either by modifying to cookie to have static data for each server, or by using the right method of hashing...etc.
    Chris

Maybe you are looking for

  • From which Table we can find info about implemented applications of SCM

    Hi All, is there any table which is storing the information about the implemented apllications in SCM, Please help me to finding out this table. Thanks in Advance Mahesh

  • Measure Formulae for Uploadable and Data collection report

    Hi, I have query related to application of measure Formula for Uploadable and Data collection report. Consider a scenario where i use a MDX query to create a data collection report and I map these columns from these reports to an rowsource using a lo

  • Whys does Messages app freeze in Mountain Lion?

    Whenvever I click the app it take really long to respond and whenever I write a message and press Return the rainbow wheel shows up and it take a good minute or so to respond again. It also shows the rainbow wheel after recieveing messages. This is v

  • Error! check Activation.  What to do?

    I have downloaded Adobe Digital Edition 4.0 and Help->Authorization Information says my computer is Authorized. When when I try to download a book and open it the system gives me this Window:Error! Check Activation. What shall I do in order to make t

  • Pre-Deploy JAR files to JRE Cache in Windows

    We are looking to build an SMS installer to pre-deploy all controls for our application to our end-users desktops. The application is Siebel. Several of the controls are in JAR files and we want to pre-deploy these into the Java Cache via the SMS ins