DAQ and motor control in the same VI

Hello,
I am a beginner in labview and I am trying to control a maxon motor and run a NIDAQ at the same time. Basically, I need to measure the pressures and the angles at the same time and record these.
The problem that I am facing is that when I execute the VI, the motor runs first and this is followed by the measurement. I have twiddled around with it a lot getting a lot of help from this community but I can't figure it out. No matter what I do the motor starts running first and after the motor has completed its movement then the DAQ takes the measurements.
Is there any way to run the motor and the sensors together? I can run the motor seperately and I can run the sensors separately in their own VIs but can't seem to run them sequentially.
Any help would be appreciated.
Aman
Attachments:
VI.jpg ‏64 KB

In LabVIEW, your wires between VIs (and structures like While Loops) determine the order in which things happen.
There are several approaches that you can take to de-couple the motor and DAQ processes.  The most obvious would be to put the motor control in one while loop, and the DAQ in another.  Yes, you can do this in LabVIEW.  Just don't get too carried away.  Each loop usually will go to a separate core to run.
If there is data that has to be shared between the loops, you can use local variables, or the Value property nodes of the controls and indicators of your VI.
Machine Vision, Robotics, Embedded Systems, Surveillance
www.movimed.com - Custom Imaging Solutions

Similar Messages

  • How can I have a canvas and external controls at the same time?

    Typically all the space of an applet is used for 2D or 3D; that is, the applet provides the canvas. I am trying to develop an applet where I only want to use part of the applet space for 3D, and then, outside that space (but still within the applet) I would like to add some controls (e.g. buttons or text fields) to provide some interaction. In other words, I want to have an applet that contains something like a frame for 3D, and some controls outside the frame.
    It may be quite easy, but I am very new to applets. Can anyone kindly give me some suggestions? Any help is highly appreciated!
    Regards,
    Hua

    I got it figured out. Thanks anyway!

  • I would like to do a program that have one string control and one string indicator, any character that I type in the string control in the same time it will be appear in another string (indicator). How can help me?

    I would like to do a program that have one string control and one string indicator, any character that I type in the string control in the same time it will be appear in another string (indicator). How can help me?

    Why not use an event
    Add a While Loop, inside the loop add the Event Sructure.
    Now in the event structure selecd the String Controls.value change event to
    react
    and the new value inside the event that you get,( connect to the String
    indicator box.
    On Sun, 10 Aug 2003 15:58:47 -0500 (CDT), WiltonFilho wrote:
    > I would like to do a program that have one string control and one
    > string indicator, any character that I type in the string control in
    > the same time it will be appear in another string (indicator). How can
    > help me?
    >
    > I would like to do a program that have one string control and one
    > string indicator, any character that I type in the string control in
    > the same time it will be appear in another string (indicator). How can
    > help me?
    >
    Using M2, Opera's revolutionary e-mail client: http://www.opera.com/m2/

  • HT4623 I would like to have both my lock symbol and mute symbol to be off at the same time can they both be in the control at the same time

    looking for a way to have. both mute in lock symbol in the control panel. don't like that I can only have one working at a time

    I have posted this many, many times here. See if this helps you understand how this process works with regard to system sounds and screen rotation lock.
    System sounds can be muted and controlled two different ways. The screen lock rotation can be controlled in the same manner as well.
    Settings>General>Use Side Switch to: Mute System sounds. If this option is selected, the switch on the side of the iPad above the volume rocker will mute system sounds.
    If you choose Lock Screen Rotation, then the switch locks the screen. If the screen is locked, you will see a lock icon in the upper right corner next to the battery indicator gauge.
    If you have the side switch set to lock screen rotation then the system sound control is in the control center if you are running iOS 7. Swipe up from the bottom of the screen to get to control center . Tap on the bell icon and system sounds will return.
    If you are running iOS 5 or iOS 6, the system sound control is in the task bar at the bottom. Double tap the home button and swipe all the way to the right in the task bar to get to the speaker icon on the left side. Tap on that and the sounds will return.
    If you have the side switch set to mute system sounds, then the screen lock can be accessed in the same manner as described above.
    This support article from Apple explains how the side switch works.
    http://support.apple.com/kb/HT4085

  • Is there a way to cycle a while loop on its own and only controlled by the number of cycles?

    Hello everyone, 
    Newcomer here, recenlty just took core 1 and 2 the past couple of months
    is there a way to cycle my while loop so that the daq assist receives the same outputs from the list box table? So pretty much I need the VI to be able to read the voltages and time values from the list box and then execute them, I've manage to do this, but then I need it to stop for a given time and then execute again the same voltages. This would be controlled by a control for "number of cycles" input. 
    Can someone tell me why my "Emergency Stop" button doesn't stop the VI?
    Why is my data logging only outputing one result if I have it to read ever min?
    My wave form graph isnt plotting the temperature results, does it have somthing to do with the while loop?
    I know this is a lot of questions, I'm just trying to solve this and learn from it.
    Attachments:
    TEST RIG 11 10-28-13.vi ‏298 KB

    You took core 1 and 2!!!  Please tell me NI didn't teach it.  I'm not trying to harp on you too bad because I think the instructor is more to blame.  You have many wires going the wrong direction, multple loops doing nothing, and one loop that will never stop so even if all the others did there would be no way to stop your program, a Stop button that is read only once at the start of the application and then is never read again (so stop will never work).  You have the inner loop running forever, but even if it did stop it would run the outer loop forever, your enums should be typedefed, uninitialized shift registers when not needed, dynamic data types, far too many express VIs...ouch.
    To answer your question.  If you have a while loop that needs to run 5 times, why not use a for loop? Then wire a 5 to the N terminal.  If you do have to use a while loop for what ever reason, use the i terminal as a condition to stop.  It will start at 0 and count up so a value of 4 means it will be executing the 5 time.  If the value equals 5 then stop.  Get the Array size of the Listbox and set your for loop to run for each item.
    Unofficial Forum Rules and Guidelines - Hooovahh - LabVIEW Overlord
    If 10 out of 10 experts in any field say something is bad, you should probably take their opinion seriously.

  • When I connect my ipod to my computer it opens my documents and won't show up in my itunes and I have unistalled then reinstalled itunes and reset my ipod twice and it stills does the same thing how can I make it so that it shows up in my itunes?

    When I connect my ipod to my computer it opens my documents and won't show up in my itunes and I have unistalled then reinstalled itunes and reset my ipod twice and it stills does the same thing how can I make it so that it shows up in my itunes?

    Try
    iOS: Device not recognized in iTunes for Windows
    I would start with              
    Removing and Reinstalling iTunes, QuickTime, and other software components for Windows XP
    or              
    Removing and reinstalling iTunes and other software components for Windows Vista, Windows 7, or Windows 8
    Before you reinstall the Apple software, also remove iCloud vi Control Panel Remove programs. The reinstall the Apple programs
    New cable and different USB port?
    Runs this and see if the results help with determine the cause
    iTunes for Windows: Device Sync Tests
    Try on another computer to help determine if computer or iPod problem

  • How can i distinguish two controls with the same name?

    I'm recording automated tests with VS 2012 Coded Ui Test for testing a web application.
    In that web application it is possible to enter data in something looking like a list.
    There is - per example - an Edit control sitting on a ColumnHeader with the name/text "Description".
    Below that header is another Edit control for data input - containing the text "Description" too and which lies on a Cell control.
    When i playback my recording, Coded UI Test looks for a control with the name "Description" and gets the one, it finds at first.
    In that case the Edit on the ColumnHeader, which causes an exception, when the Text will be setted with the data input from the recording.
    Unfortunately the controls have no ID.
    Is there a way to distinguish controls with the same name?
    Thanks in advance!

    Hi Patrick Pirzer,
    >>Is there a way to distinguish controls with the same name?
    Based on the blog "How does “Coded UI test” finds a control ??", we know that to really find a control, it would be related to the unique properties as the search properties,
    so if two controls have the same property, please use other unique property as the search property would be better.
    Best Regards,
    Jack
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click
    HERE to participate the survey.

  • Does OS installed through boot camp or in virtual machine has access and full control of the peripherals like native OS X Lion?

    I am planning to buy new PC for my faculty needs and this time I am thinking to buy Apple laptop like Mac book Pro 13" or so ( I owe already IPhone and Ipad 2)
    To make final decision I need few information . These are:
    1. May I use Boot Camp or similar utility software to install Windows 7 OS next to OS X Lion, or use some kind of virtual box software to create virtual machines with diverse guest OS in them like Windows , Linux etc.?
    2. Does OS installed through Boot camp or in virtual machine has access and full control of the peripherals like native OS X Lion?
    3. May I use the same disk partitions to access to the files regardless if I am using Windows 7 or OS X Lion operating system?
    4. Is there full compatibility between Microsoft Office under OS X Lion and Windows 7 M. Office?
    5. What is general user experience with OS X Lion operating system comparing to Windows 7?
    Thanks for  sharing your experience with me.
    Adnan S

    adnans wrote:
    I am planning to buy new PC for my faculty needs and this time I am thinking to buy Apple laptop like Mac book Pro 13" or so ( I owe already IPhone and Ipad 2)
    To make final decision I need few information . These are:
    1. May I use Boot Camp or similar utility software to install Windows 7 OS next to OS X Lion, or use some kind of virtual box software to create virtual machines with diverse guest OS in them like Windows , Linux etc.?
    2. Does OS installed through Boot camp or in virtual machine has access and full control of the peripherals like native OS X Lion?
    3. May I use the same disk partitions to access to the files regardless if I am using Windows 7 or OS X Lion operating system?
    4. Is there full compatibility between Microsoft Office under OS X Lion and Windows 7 M. Office?
    5. What is general user experience with OS X Lion operating system comparing to Windows 7?
    Thanks for  sharing your experience with me.
    Adnan S
    1. Yes. You can install Windows 7 natively using Boot Camp Assistant or you can install Windows 7 in a virtual machine using Parallels, Fusion, or VirtualBox
    2. If installed using Boot Camp Assistant Windows 7 uses all your computer's resources just as OSx does. If installed using a VM Windows 7 will share the computer's resources with OSx.
    3. A Boot Camp partition is separate from the OSx partition. The VMs allow sharing of files across partitions since both OS are running at the same time.
    4. No, not 100%.
    5. Too broad a question. Be specific about what feature you are asking about or search the Internet for comparisons. I use both and find they both work well.

  • I purchased OS X Lion on my laptop and if I use the same username on my desktop it should just download not make me pay again, yet it is still saying "BUY APP" not "INSTALL." What do I do?

    I purchased OS X Lion on my laptop and if I use the same username on my desktop it should just download not make me pay again, yet it is still saying "BUY APP" not "INSTALL." What do I do?

    Hi...
    How to re download apps from the Mac App Store:
    Open the App Store. From the menu bar click Store > Sign In
    Click Purchases from the top of the App Store window.
    Select which apps you want to re download. Then right or control click where you see Installed  then click Install.
    Make sure and use the same Apple ID used for the original purchase.
    Mac App Store: Backing up your app purchases

  • Running RoboHelp 10 and RoboHelp 11 on the same system

    Background
    Windows 7, 64-bit operating system.
    Upgraded RoboHelp 10 to RoboHelp 11 this week. Upgraded my RH10 WebHelp Proj project (released with our 2.0 application) to start editing for release with 3.0 application next June .
    The upgrade did not uninstall RoboHelp 10.
    I work from within Visual Studio 2010 Professional. (I know that this is not a Source Control thread, but my issues are intertwined here.)
    I create WebHelp Pro (even though we are not yet publishing to RH Server, although we're working on it!).
    I check the output into Release folders in Souce Control, and the build picks up the files for installation with our application.
    Questions
    If I need to update the 2.0 application Help, does anyone know whether I can still use RH10 to update that project? (I've posed the question to an Adobe consultant, but have not yet heard back.)
    If I can't use RH10 to update the 2.0 application Help (and have to open the 2.0 project in RH11 and, therefore, upgrade it), are there new things in RH11 that could affect the WebHelp Pro output and, therefore, affect the use of the WebHelp Pro HTM files by the application? (Our release engineer believes that, for version control purposes, I must make changes to the 2.0  project in the same RH Client used to develop it.)
    Thanks for any help.
    Carol Levine
    AIR Worldwide

    Hi,Carol
    First, (and to reiterate what Rick said) if you are not publishing to RoboHelp Server right now. Do NOT use WebHelp Pro. The Pro flavor is strictly for hosting on a RoboHelp Server installation.
    The good news is that when and if you do decide to use RoboHelp Server, you simply take the Rh project (whether from Rh 10 or 11) and publish it with the WebHelp Pro SSL. It sounds like there is a some confusion between RoboHelp Server and Source Control. It is a common option to use RoboHelp Server and Source Control. But they are mutually exclusive. (While both may be used, they have nothing to do with one another.)
    If you think about it, RoboHelp Server is output (by definition not "source")
    So, you can continue using Rh 10 and 11 clients on the same computer, but as you note, you cannot open an Rh 10 project in Rh 11 because it is a one-way forward conversion (as Peter said).
    As for publishing, be aware that when you move to RoboHelp Server, the publishing workflow is different. The web admin can't simply copy/paste WebHelp Pro output (from source control as you describe) to the Rh Server (or, as you said, "pick up files"). The project must be published from the RoboHelp 10/11 client directly to the Rh Server. This is because Rh Server is a database application and in order for the database to be "aware" of the new content, it must come from the RoboHelp client app (10 or 11). Also, in terms of Application Help and context sensitivity, there is a CSH API and a syntax that is used to call the Rh Server help topics from the application. This is covered in the online help. See the sub head "Access context-sensitive Help" in the Adobe RoboHelp Server 9 * RoboHelp Server Web Administrator tasks as well as Adobe RoboHelp 11 * Program Help for web pages
    Thanks
    John
    John Daigle
    Adobe Certified RoboHelp and Captivate Instructor
    Evergreen, Colorado
    www.showmethedemo.com

  • Guys, my browser is going crazy and every website that I am on changes in about 10 seconds to 2 minutes to another webpage. I even downloaded a newer 5.0 version of firefox and I am having the same problem.

    Guys, my browser is going crazy and every website that I am on changes in about 10 seconds to 2 minutes to another webpage. I even downloaded a newer 5.0 version of firefox and I am having the same problem.

    Your System Details are showing Fun Web Products. Suggest you look in Add-ons - Extensions and Plug-ins, and Control Panel>Add/Remove programs or >(newer version) Programs and Features. You could also do a search of your computer.
    Fun Web Products(associated with MyWebSearch) always seems to cause problems, Alexa does, too, but less often - there may be conflicts.
    I'm not an expert on these two products. I'm afraid I can only alert you to the problems. Google will show you plenty of evidence of problems. You might also try the Search Firefox Help box above - a gold mine but it usually requires a lot of digging.
    You can start Firefox in Safe Mode - Hold Shift Key down as you double click on the Firefox icon>ignore the page that opens>Continue. If that improves things you could do a little troubleshooting(Safe Mode, Problematic extensions etc), use default theme, -
    https://support.mozilla.com/en-US/kb/Troubleshooting%20extensions%20and%20themes
    http://support.mozilla.com/en-US/kb/Troubleshooting%20plugins

  • Source and Target Table in the Same schema........will that work in ODI

    Hi ,
    Is it possible to have my source and target tables in the Same achema.......will it have any performance issues or some other issues in our ODI.......
    I would like to know whether it works well or not .........
    ( To my understanding it wont have any issues ......But I am not 100 % sure on my judgement)
    Thanks
    AK

    Yes, you're correct.
    Just be sure about you load strategy, it means, if you need only to insert use the KM Control Append, but if need update too, try the IKM Oracle Incremental Update... I believe that will work better for millions of lines.
    Anyway be sure that your database has the necessary tablespaces to manage huge data volume.

  • Cisco 877w -Configuration of subinterfaces and main interface within the same bridge group is not permitted

    Hi,
    I have another problem - after upgrade ios wirelles connection not work.
    After reload i have :
    Configuration of subinterfaces and main interface
    within the same bridge group is not permitted
    STP: Unable to get the port parameters.
    Please configure the bridge group on this interface first.
    Please configure the bridge group on this interface first.
    Please configure the bridge group on this interface first.
    SETUP: new interface NVI0 placed in "shutdown" state
    my old configuration work propertly in the old software, but after update i have notificatio.
    Old thread:
    https://supportforums.cisco.com/discussion/12379491/cisco-877w-no-wireless-connection
    my current sh run:
    version 12.4 
    no service pad 
    service tcp-keepalives-in 
    service tcp-keepalives-out 
    service timestamps debug datetime msec localtime 
    service timestamps log datetime msec localtime 
    service password-encryption 
    hostname cisco 
    boot-start-marker 
    boot system flash:c870-advipservicesk9-mz.124-24.T6.bin 
    boot-end-marker 
    logging message-counter syslog 
    logging buffered 4096 informational 
    enable secret 5 $1$eCNp$rWuBfZ/cexnwnkm7L447s. 
    aaa new-model 
    aaa session-id common 
    dot11 syslog 
    dot11 ssid ciscowifi 
     vlan 1 
     authentication open 
     authentication key-management wpa 
     guest-mode 
     wpa-psk ascii 7 050D031D26595D0617 
    dot11 wpa handshake timeout 500 
    ip source-route 
    no ip dhcp use vrf connected 
    ip dhcp excluded-address 192.168.56.1 
    ip dhcp pool CLIENT 
       import all 
       network 192.168.56.0 255.255.255.0 
       default-router 192.168.56.1 
       dns-server 8.8.8.8 194.204.159.1 194.204.152.34 
       lease 0 2 
    ip cef 
    no ip domain lookup 
    no ipv6 cef 
    multilink bundle-name authenticated 
    username marek password 7 00121A0908500A 
    archive 
     log config 
      hidekeys 
    ip tcp path-mtu-discovery 
    bridge irb 
    interface ATM0 
     description Polaczenie ADSL do ISP$ES_WAN$ 
     no ip address 
     no atm ilmi-keepalive 
     pvc 0/35 
      encapsulation aal5mux ppp dialer 
      dialer pool-member 1 
     hold-queue 224 in 
    interface FastEthernet0 
     description Edzia 
    interface FastEthernet1 
     description dom 
    interface FastEthernet2 
     description Dziadek 
    interface FastEthernet3 
    interface Dot11Radio0 
     no ip address 
     no ip redirects 
     ip local-proxy-arp 
     ip nat inside 
     ip virtual-reassembly 
     no dot11 extension aironet 
     encryption vlan 1 mode ciphers tkip 
     encryption mode ciphers aes-ccm tkip 
     broadcast-key change 3600 
     ssid ciscowifi 
     speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0 
     station-role root 
     world-mode dot11d country AU indoor 
     no cdp enable 
     bridge-group 1 
     bridge-group 1 subscriber-loop-control 
     bridge-group 1 spanning-disabled 
     bridge-group 1 block-unknown-source 
     no bridge-group 1 source-learning 
     no bridge-group 1 unicast-flooding 
    interface Dot11Radio0.1 
     description ciscowifi 
     encapsulation dot1Q 1 native 
     no cdp enable 
    interface Vlan1 
     no ip address 
     bridge-group 1 
    interface Dialer0 
     description Interfejs dzwoniacy 
     ip address negotiated 
     ip nat outside 
     ip virtual-reassembly 
     encapsulation ppp 
     dialer pool 1 
     dialer-group 1 
     ppp chap hostname [email protected] 
     ppp chap password 7 xxxxxxxxxxxxxxxxxxxxxx 
    interface BVI1 
     description Polaczenie dla sieci LAN 
     ip address 192.168.56.1 255.255.255.0 
     ip nat inside 
     ip virtual-reassembly 
    no ip forward-protocol nd 
    ip route 0.0.0.0 0.0.0.0 Dialer0 
    no ip http server 
    no ip http secure-server 
    ip nat inside source list 100 interface Dialer0 overload 
    ip nat inside source static tcp 192.168.56.10 80 interface Dialer0 80 
    ip nat inside source static tcp 192.168.56.10 22 interface Dialer0 22 
    logging trap debugging 
    logging 192.168.56.10 
    access-list 100 permit ip 192.168.56.0 0.0.0.255 any 
    access-list 100 deny   ip any any 
    no cdp run 
    snmp-server community ciskacz RO 
    snmp-server chassis-id ciskacz 
    control-plane 
    bridge 1 protocol ieee 
    bridge 1 route ip 
    line con 0 
     no modem enable 
    line aux 0 
    line vty 0 4 
     exec-timeout 0 0 
     transport preferred ssh 
     transport input ssh 
    scheduler max-task-time 5000 
    end 
    please help - thanks!

    Hello Marek,
    I suppose you are not planning to do any kinds of advanced config using several VLANs and multiple SSIDs so let's just make your configuration simple and working.
    In short, you need to remove all references to VLAN 1 and to any subinterfaces possibly related to the VLAN 1. This means in particular (follow these steps in sequence):
    Remove the Dot11Radio0.1 subinterface entirely
    In the Dot11Radio0 section, remove the encryption vlan 1 mode ciphers tkip command
    In the dot11 ssid ciscowifi section, remove the vlan 1 command
    After performing these steps, make sure that the ssid ciscowifi and encryption mode commands are still present in the Dot11Radio0 configuration, and if not, reenter them.
    Best regards,
    Peter

  • Can Motion 5 replace a green screen and blue screen in the same shot?

    Can Motion 5 replace a green screen and blue screen in the same shot? I would like to replace a green screen with one image, and a blue screen with another.

    Fox gives a good example for keying green & blue (or any other color)  from the same shot. I'd suggest doing a few things to get better accuracy.
    First, the motion keyer always removes the color it detects the most of by default (blue/green). You can override this by setting the Strength parameter to zero, then use the Color sample tool to select the color you want. The advantage is motion will do a good job of targeting only the hue (color) that you want to remove and set an appropriate starting softness.  It also will remove spill based on this color.  Looking at Fox's example movie and the shot, I'd approach the same shot this way:
    Remove the Blue
    1. Apply the keyer and set the strength to zero.
    2. Use the Sample Color tool and select the blue (or other color) to be removed.
    3. Decrease the spill level (if needed). In Fox's example the spill from the blue glasses is going to be minimal, especially compared to the green screen, your shot may need different adjustments. Only de-spilling what you need to will give you more accurate color right away and minimize additional color correction that might be needed later.
    4. Use the Color selection tools (Chroma wheel/Luma bar) to fine tune.  Ideally you want a minimal tolerance, the inner selection, with a nice fall off, the outer selection. Try with the Scrub boxes setting first, then switch to manual if you need more control. Again see Fox's example.
    Remove Green
    It's the same as the blue, you could apply the keyed to the same clip or a parent group, at this point it's many user preference.
    With these techniques you can remove any color from a shot or create a mask based on a color. BTW, as you are learning to use the keyer I'd highly recommend  having the Color Selection open so you can see the graphs.  These give you real time feedback as you make selections and changes with the Strength, Refine and Color selection tools.  Watch what happens as you make selection or changes, sometimes the problem area is actually in the brightness not the color, or the softness may change  more than the tolerance selection.  Observing what is happening in these graphs will help you figure out wha to change and speed things up.

  • Can anybody tell how to compare two documents with two pointers controlled with the same mouse

    can anybody tell how to compare two documents with two pointers controlled with the same mouse ??

    I saw what I need but in a game to find the differences between two photos (two screens, two pointers controlled by one mouse), and I need a program to make the same thing   (compare a chosen files)

Maybe you are looking for

  • IMessage trouble with two iPhones and one Apple ID

    Hi, I'm having trouble with iMessage after updating both of my iPhones to iOS 6 and not being able to use iMessage with one of the phones. Some background: -I have two iPhones, one on AT&T in the U.S., and one on NTT DoCoMo in Japan, both with separa

  • Panasonic AVC Intra codec and FCP 2

    Does anyone know if the latest version of FCP supports the new AVC Intra codec found on the higher-end Panasonic P2 HD cameras? We're a production house, and are considering investing in the Panasonic AJ-HPX3000 P2 HD camera, which is starting to shi

  • Join ResultSet fra Oracle and MS SQL?

    I currently looking for documentation on how to JOIN ResultSet fra two different databases? Currently, we use a Oracle DB for some information, and MS SQL for some other type of information which is related to each other. Don't ask why, this is a pro

  • IMac will not run OS X

    This is so weird. I have an iMac DV Special Edition model that cannot boot into OS X 10.4. It has 512MB of ram and a 10GB HD. It will show the Apple logo but before the spinning wheel appears, a black box appears over the apple and it shuts off. I ca

  • PDF - Internet Explorer cannot display the webpage. Size?

    My application generates dynamic reports in PDF format.  The reports can vary from 50K and up to over 300K. I get the message above ONLY when the PDF output is greater than 221K in IE (7,8 & 9). Anything less than 221K displays fine. Anything above i