Deploy PPTP VPN Settings for remote workers

Hi All,
I need to use applescript, so that we can email / copy the script to our remote users and they can execute it to setup PPTP VPN to our work vpn server.
I have never used applescript and google led me to a apple forum post with the following, the problem I am facing is, that I can’t seem to name the VPN connection, neither i can give it a pptp vpn server address, dns, default gateway and any custom routes.
How can I add those fields / enteries in ?
http://discussions.apple.com/thread.jspa?messageID=10368307
tell application “System Preferences”
reveal pane “Network”
activate
tell application “System Events”
tell process “System Preferences”
tell window 1
click button “Add Service”
tell sheet 1
click pop up button 1
click menu item “VPN” of menu 1 of pop up button 1
delay 1
click pop up button 2
click menu item “PPTP” of menu 1 of pop up button 2
click button “Create”
end tell
click button “Apply”
end tell
end tell
delay 1 — optional (just for visual feedback)
keystroke “w” using {command down}
end tell
end tell
will be grateful for your help on this
Thanks

I came across the same problem, I posted a solution here in case anyone else comes across it: http://blog.affirmix.com/2011/01/12/how-to-configure-a-vpn-in-mac-os-x-usingappl escript/

Similar Messages

  • Server settings for remote Server in Flash Builder 4.5 Premium

    Has anyone figured this out? Seems like everyone is talking about FlashBuilder that comes with PHP and that doesn't help me. So I'm still having trouble moving my mobile app to a remote server and I have FlashBuilder 4.5 Premium without PHP.
    I have created a PHP project outside of Flash Builder and then I have connected to it using the Data/Service tab, but then it ask for the server information and that is where I'm having the issues.
    It works create with the setting like this.
    MAC:
    Server Options
    Web Root: /Applications/MAMP/htdocs
    Root URL: http://localhost/
    But when you try to export a release build or just like to test it, and insert your server settings.
    Server Options
    Web Root: /home/username/domain_name/
    Root URL: http://mydomain.com
    It doesn't Validate which in turn won't let the project work. Also it would be nice to put the remote server in there for testing instead of just for release builds. Any one have an answer. Every tutorial or explanation shows localhost.
    thanks

    Hello guys,
    I have found a solution: In ZendFramework/library/Zend/Amf/Response/Http.php  linenumber 59:
    $ssl = $_SERVER['HTTPS']; is given an error.
    I did this:
    $_SERVER['HTTPS'] = 'off';
    $ssl = $_SERVER['HTTPS'];
    So add this line....
    And it works...
    Hope it works for you too.
    Ooh, and don't forget to follow the instruction of TweenOut.
    Erik.
    Van: tweenOut [email protected]
    Verzonden: dinsdag 20 december 2011 18:42
    Aan: EGJ Steens
    Onderwerp: Server settings for remote Server in Flash Builder 4.5 Premium
    Re: Server settings for remote Server in Flash Builder 4.5 Premium
    created by tweenOut <http://forums.adobe.com/people/tweenOut>  in Using Flash Builder - View the full discussion <http://forums.adobe.com/message/4095833#4095833

  • CF Flash Remoting Settings For Remote Server

    I am trying to setup Flex Builder 2 for evaluation, with Flex
    Builder on a Windows XP machine and ColdFusion (7.0.2) on a remote
    server. When attempting to start the Flex Project Wizard using
    Flash Remoting, I am having trouble understanding what the settings
    should be for root folder and root URL. Nothing I've tried,
    including hints based on other posts, has helped.
    It would be helpful to have an example in the help docs for
    this type of situation. It can't be uncommon and I see a few others
    have had similar trouble. Thanks.

    On your machine, these are the settings (I use CF with IIS,
    not the standalone CF server):
    On Project Properties>
    Flex Server: ‘C:\CFusionMX7\wwwroot’
    Root URL: ‘
    http://localhost/’
    When you upload to your remote server, upload the entire
    Output Folder (usually ‘bin’). You can leave out the
    xx-debug.html and xx-debug.swf files, but upload all the others.

  • VPN settings for Apple TV - Shared Secret?

    We are setting up and on network tab on the mac > connect up > the L2TP / VPN server did not respond - verify settings (auto), asks for a shared secret...anyone know what to do....thanks, Louise

    does this have anything to do with AppleTV ?

  • SQL 2008 settings for remote connections

    Hi
    I am unable to connect to my SAP B1 instance from a client PC.  I am using SQL Server 2008 for the first time.  The error message on the client PC implies that remote access has not been enabled on the SQL Server 2008.  I am not sure how to do this and have so far found nothing from SAP.
    Hope someone can help since I need this working for tomorrow!
    Ian

    SQL 2008 needs new SQL Native Client.  Have you install that client on the PC successfully?
    Thanks,
    Gordon

  • Flash Builder 4.6 - Server settings for remote server

    Hi,
    im building a mobile application with PHP Application Server Type in Flash Builder 4.6.
    Everything works good from localhost, so when im debuggin on Desktop.
    Now i want export the release build, and i don't know how should change the setting:
    Web root
    Root URL
    Output folder
    in Flex Server Panel.
    Thanks

    This post explain and works!
    http://forums.adobe.com/message/4095833#4095833#4095833

  • Remote Control settings for Markers

    The user manual for Studio Pro 4 states that Remote Control settings for Markers will override all other settings while that part of the track or story plays.
    This however, is not the case- In my project the track & story settings for Remote Control>Menu are actually overriding marker Remote Control>Menu settings, & I really need the marker functions to take precedence over other functions.
    Any idea how I can make this happen?
    Thanks!!
    eric

    As Jake said - I am not seeing this behaviour either.
    If you clear all end jumps from chapter markers and place the markers into stories then you set the menu call for the story. This can be different to the track and depending on which you are playing the menu call for that item will take precedence.
    Of course, if you really want to make it bullet proof then you could point the menu call to a script. Assuming that no matter which story you are in, or how you got to the marker in the track, the following script will always return you to a specific button on a menu for the marker that you have just played
    mov GPRM0, SPRM7
    Jump Menuname, [GPRM0]
    SPRM7 is a system parameter that checks which marker has just played. The first line of the script loads the value of this into a memory slot called GPRM0. The second line operates a jump to your menu - I assume there is only one menu here - and using a conditional GPRM based button jump, the value of GPRM0 fills in the value of the button to go to. This saves writing out lines of code for each possible button.
    If you have lots of menus then this script can be adapted very easily to cope with that, or you can set up other scripts to identify which menu you have come from so as you know which to go back to.
    However, before any of this I would want to know why you are not getting the expected behaviour on our project - my guess is that there is going to be a menu call set into a chapter marker which is over-riding the track or story menu call. If you have end jumps on markers, or menu calls on markers, remove them.

  • Deploying Settings for Creative Suite Products - network environment with redirected folders

    Hi there.  We have some deployment questions regarding settings for the Adobe Master Collection.  Because we have redirected folders for my docs, etc., they are located on our file server for all of our users (school environment).  The problem is all Adobe programs default their save and caching locations to the my docs folder, which is on the server and causes slow downs and network traffic issues.  Is there a way to set these with a file or a deployment option, or what options do we have?

    This stuff is stored in the prefs of the programs and unless you go in and change each of the prefs files there is no way to change this.
    Mylenium

  • Pptp VPN route : Leopard does not set correct netmask

    Hello
    Today I switched from a MacOSX 10.4.11 (Tiger) PowerBook to a MacOS 10.5.5 (Leopard) MacBook Pro. I configured my pptp VPN settings with the "Internet Connection Tool" and Network-Settings-panel on Leopard identically as on my Tiger PowerBook (option route all traffic over VPN on both systems disabled).
    As far I could connect on the Leopard system to the destination VPN server without any problem, but could only establish a traffic-connection to the VPN server it self. As on my Tiger system the VPN connection worked seamless over several years now I supposed some routing problem.
    In fact on the Tiger system the routing table showed me, that the destination network has a 255.255.0.0 network mask and was correctly received and set on the Tiger routing table, but that the Leopard systems assumes a 255.255.255.0 network mask and set this assumption to the its routing table: (destination LAN has address space 10.50.0.0 - 10.50.255.255 / netmask 255.255.0.0)
    Tiger 10.4.11 :
    10.50/16 ppp0 USc 0 0 ppp0
    Leopard 10.5.5 :
    10.50/24 ppp0 USc 0 0 ppp0
    In the Leopard vpn setting panel, there is also the possibility to set manually the destination ip-address and netmask, but I found it has no effect on the real setting on Leopard. The only way to set the correct route with the correct netmask is under Leopard to do it by the command shell - first deleting the route set by Leopard and setting a new route with a the correct netmask :
    route delete -net 10.50. -interface ppp0
    route add -net 10.50. -interface ppp0 -netmask 255.255.0.0
    I do not understand, why under Tiger (and also on MacOSX 10.3.X) the pptp VPN worked always correct and set the correct netmask, and now Leopard (MacOSX 10.5.X) does some kind of assumption and is not able to set the correct netmask.
    Any Ideas ?

    How did you determine that partial traffic is sent through the VPN?
    Basic principles of VPN is to avoid using a common subnet for your client ip pool. Having an uncommon subnet will solve your #2 issue below. Simply change the 3rd octet on your home network from .1 to something else, .11
    I have a working pptp server configuration on ubuntu 10 with iphone 3g iOS 4.1 connected, invested hours of research, but only a short time configuring the server and iphone vpn client. passing internet traffic through local gateway/router from work wi-fi and accessing local desktop using windows remote desktop lite app.

  • Server settings for using other pop3/imap applications?

    trying to set up mac mail on my motorola q, and can't quie get the mail to work. What should the setting be:
    For incoming and outgoing server names
    For account name (should it include @and after)
    SSL?
    Thanks

    Hello guys,
    I have found a solution: In ZendFramework/library/Zend/Amf/Response/Http.php  linenumber 59:
    $ssl = $_SERVER['HTTPS']; is given an error.
    I did this:
    $_SERVER['HTTPS'] = 'off';
    $ssl = $_SERVER['HTTPS'];
    So add this line....
    And it works...
    Hope it works for you too.
    Ooh, and don't forget to follow the instruction of TweenOut.
    Erik.
    Van: tweenOut [email protected]
    Verzonden: dinsdag 20 december 2011 18:42
    Aan: EGJ Steens
    Onderwerp: Server settings for remote Server in Flash Builder 4.5 Premium
    Re: Server settings for remote Server in Flash Builder 4.5 Premium
    created by tweenOut <http://forums.adobe.com/people/tweenOut>  in Using Flash Builder - View the full discussion <http://forums.adobe.com/message/4095833#4095833

  • Connetion String for Remote Server

    Hey All, I'm new to Oracle so please bear with me if i ask somethings that should be fairly obvious. I'm attempting to connect to a remote server using OCCI and i have no idea how to set up my connection string to accomplish this. I've read through the OCCI programming guide particularly section 3.1 (Connecting to a database) but the examples leave the connection string variable empty. Could someone please furnish me with an example connection string that could be used to connect to a remote server? That would be greatly appreciated. If there's any information you need from me to help answer this question let me know. Thanks, Mike

    Hello guys,
    I have found a solution: In ZendFramework/library/Zend/Amf/Response/Http.php  linenumber 59:
    $ssl = $_SERVER['HTTPS']; is given an error.
    I did this:
    $_SERVER['HTTPS'] = 'off';
    $ssl = $_SERVER['HTTPS'];
    So add this line....
    And it works...
    Hope it works for you too.
    Ooh, and don't forget to follow the instruction of TweenOut.
    Erik.
    Van: tweenOut [email protected]
    Verzonden: dinsdag 20 december 2011 18:42
    Aan: EGJ Steens
    Onderwerp: Server settings for remote Server in Flash Builder 4.5 Premium
    Re: Server settings for remote Server in Flash Builder 4.5 Premium
    created by tweenOut <http://forums.adobe.com/people/tweenOut>  in Using Flash Builder - View the full discussion <http://forums.adobe.com/message/4095833#4095833

  • Help in setting up VPN for Remote Desktop

    Hi,
    We recently purchased a Cisco RV220W VPN Router and want to set up VPN connections for about 10 users(employess) to connect to their work PCs (mostly win 7 & win 8) from their home computers (windows & mac) using Remote Desktop. The documentation is quite poor. Can anyone point me to a tutorial and/or help me out with steps and settings? From the Admin Guide, it looks like I should be configuring Remote Access with an IPsec Client, but it's not clear how to handle/route multiple machines?

    Hi Ray,
    You can use the QuickVPN client to connect up to Windows 7 PCs. Windows 8 is not supported as of yet.
    For Windows 8 and Mac you can create PPTP users or try a third party VPN client like Shrewsoft (Windows) or IPSecuritas (Mac). You also have the SSL VPN option in the RV220W. Please note that the third party clients are not officially supported by Cisco.
    There are some good instructions for setting up Shrewsoft with the SA500 which is similar to the RV220W here:
    https://supportforums.cisco.com/docs/DOC-9378#comment-7216
    IPSecuritas for Mac:
    http://www.cisco.com/en/US/docs/security/multi_function_security/multi_function_security_appliance/sa_500/technote/note/SA500_mac_appnote.pdf
    Please reply if you have any questions.
    - Marty

  • New to server, need VPN for remote desktop and file share...

    I've set up server and have the VPN working, I think, I need to have several outside systems join the servers VPN permanently to allow for file sharing and remote desktop. I don't want the "normal" internet browsing to go through the VPN (huge slow down) I have read that a "split DNS" or "split tunnel" is what I need, then to disable "send all traffic over VPN connection" option on each remote system. I was a little confused after reading on how to do this on Leopard server (the only instructions I found) but have absolutely no idea on how to do this on Snow Leopard server (the server I set up is 10.6) any assistance would be great, thanks in advance.

    Server Admin, VPN, Settings, Client Information, Network Routing Definition.
    Here add a private network record type that matches your LAN/VPN ip.
    For example
    IP Address: 192.168.0.0
    Mask: 255.255.255.0
    Type: Private
    You can find more informations about this feature in Snow Leopard Server documentation:
    http://images.apple.com/server/macosx/docs/NetworkServices_Adminv10.6.pdf
    search for "Configuring VPN Network Routing Definitions"

  • Help needed to connect to remote PPTP VPN via PIX 515e

    Hello,
    A user in our office needs to connect to a client's remote PPTP VPN but can't connect.  The user is running Windows 7.  We have a Cisco PIX 515e firewall that is running PIX Version 6.3(3) - this is what our user is having to go through to try and make the connection to the client's remote VPN.
    The client's network guys have come back and said the issue is at our side.  They say that they can see some of our traffic but not all of it. The standard error is shown below, and they say it's symptomatic of the client-side firewall not allowing PPTP traffic:
    "A connection between the VPN server and the VPN client XXX.XXX.XXX.XXX has been established, but the VPN connection cannot be completed. The most common cause for this is that a firewall or router between the VPN server and the VPN client is not configured to allow Generic Routing Encapsulation (GRE) packets (protocol 47). Verify that the firewalls and routers between your VPN server and the Internet allow GRE packets. Make sure the firewalls and routers on the user's network are also configured to allow GRE packets. If the problem persists, have the user contact the Internet service provider (ISP) to determine whether the ISP might be blocking GRE packets."
    I have very little firewall experience and absolutely no Cisco experience I'm afraid.  From looking at the PIX config I can see the following line:
    fixup protocol pptp 1723.
    Does this mean that the PPTP protcol is enabled on our firewall?  Is this for both incoming and outgoing traffic?
    I can see no reference to GRE 47 in the PIX config.  Can anyone advise me what I should look for to see if this has been enabled or not?
    I apologise again for my lack of knowledge.  Any help or advice would be very gratefully received.
    Ros

    Hi Eugene,
    Thank you for taking the time to reply to me.  Please see our full PIX config below.  I've XX'd out names and IP addresses as I'm never comfortable posting those type of details in a public forum.  I hope that the information below is still sufficient for you.
    Thanks again for your help,
    Ros
    PIX(config)# en
    Not enough arguments.
    Usage:  enable password [] [level ] [encrypted]
            no enable password level
            show enable
    PIX(config)# show config
    : Saved
    : Written by enable_15 at 10:30:31.976 GMT/BDT Mon Apr 4 2011
    PIX Version 6.3(3)
    interface ethernet0 auto
    interface ethernet1 auto
    interface ethernet2 auto
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    nameif ethernet2 DMZ security10
    enable password XXX encrypted
    passwd XXX encrypted
    hostname PIX
    domain-name XXX.com
    clock timezone GMT/BST 0
    clock summer-time GMT/BDT recurring last Sun Mar 1:00 last Sun Oct 2:00
    fixup protocol dns maximum-length 512
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol pptp 1723
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    name XX.XX.XX.XX Secondary
    access-list outside_access_in permit tcp XX.XX.XX.XX 255.255.255.240 host XX.XX.XX.XX eq smtp
    access-list outside_access_in permit tcp any host XX.XX.XX.XX. eq https
    access-list outside_access_in permit tcp any host XX.XX.XX.XX. eq 993
    access-list outside_access_in permit tcp any host XX.XX.XX.XX. eq 587
    access-list outside_access_in permit tcp any host XX.XX.XX.XX. eq 82
    access-list outside_access_in permit tcp any host XX.XX.XX.XX. eq www
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq www
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq www
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq https
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 993
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 587
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 82
    access-list outside_access_in permit tcp host XX.XX.XX.XX host XX.XX.XX.XX eq 82
    access-list outside_access_in permit tcp host XX.XX.XX.XX host XX.XX.XX.XX eq 82
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq smtp
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 8082
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq www
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq https
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 993
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 587
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq 82
    access-list outside_access_in permit tcp any host XX.XX.XX.XX eq smtp
    access-list outside_access_in permit tcp any host XX.XX.XX.XX. eq www
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.0.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl deny udp any any eq 135
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_40 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_60 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list USER1 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_10 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_20 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_30 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_50 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list outside_cryptomap_70 permit ip any XX.XX.XX.XX 255.255.0.0
    access-list USER2 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list USER3 permit ip any XX.XX.XX.XX 255.255.255.0
    access-list USER4 permit ip any XX.XX.XX.XX 255.255.0.0
    pager lines 24
    logging on
    logging host inside XX.XX.XX.XX
    icmp permit any outside
    icmp permit any inside
    mtu outside 1500
    mtu inside 1500
    mtu DMZ 1500
    ip address outside XX.XX.XX.XX 255.255.255.248
    ip address inside XX.XX.XX.XX 255.255.255.0
    no ip address DMZ
    ip audit info action alarm
    ip audit attack action alarm
    pdm location XX.XX.XX.XX 255.255.255.255 inside
    pdm location XX.XX.XX.XX 255.255.0.0 outside
    pdm location XX.XX.XX.XX 255.255.255.0 outside
    pdm logging debugging 100
    pdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    static (inside,outside) XX.XX.XX.XX XX.XX.XX.XX netmask 255.255.255.255 0 0
    static (inside,outside) XX.XX.XX.XX. XX.XX.XX.XX netmask 255.255.255.255 0 0
    static (inside,outside) XX.XX.XX.XX. XX.XX.XX.XX netmask 255.255.255.255 0 0
    static (inside,outside) XX.XX.XX.XX XX.XX.XX.XX netmask 255.255.255.255 0 0
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 XX.XX.XX.XX 1
    route inside XX.XX.XX.XX 255.255.0.0 XX.XX.XX.XX 1
    timeout xlate 3:00:00
    timeout conn 2:00:00 half-closed 0:30:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    ntp authenticate
    ntp server XX.XX.XX.XX source outside prefer
    http server enable
    http XX.XX.XX.XX 255.255.0.0 outside
    http XX.XX.XX.XX 255.255.255.0 outside
    http XX.XX.XX.XX 255.255.255.255 inside
    snmp-server host inside XX.XX.XX.XX
    no snmp-server location
    no snmp-server contact
    snmp-server community XXX
    snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto dynamic-map cola 20 set transform-set ESP-3DES-MD5
    crypto dynamic-map dod 10 set transform-set ESP-3DES-MD5
    crypto map outside_map 10 ipsec-isakmp dynamic cola
    crypto map outside_map 20 ipsec-isakmp
    crypto map outside_map 20 match address outside_cryptomap_20
    crypto map outside_map 20 set peer XX.XX.XX.XX
    crypto map outside_map 20 set transform-set ESP-3DES-MD5
    crypto map outside_map 25 ipsec-isakmp
    crypto map outside_map 25 match address USER1
    crypto map outside_map 25 set peer XX.XX.XX.XX
    crypto map outside_map 25 set transform-set ESP-3DES-MD5
    crypto map outside_map 30 ipsec-isakmp
    crypto map outside_map 30 match address outside_cryptomap_30
    crypto map outside_map 30 set peer XX.XX.XX.XX
    crypto map outside_map 30 set transform-set ESP-3DES-MD5
    crypto map outside_map 40 ipsec-isakmp
    crypto map outside_map 40 match address outside_cryptomap_40
    crypto map outside_map 40 set peer XX.XX.XX.XX
    crypto map outside_map 40 set transform-set ESP-3DES-MD5
    crypto map outside_map 50 ipsec-isakmp
    crypto map outside_map 50 match address outside_cryptomap_50
    crypto map outside_map 50 set peer XX.XX.XX.XX
    crypto map outside_map 50 set transform-set ESP-3DES-MD5
    crypto map outside_map 60 ipsec-isakmp
    crypto map outside_map 60 match address outside_cryptomap_60
    crypto map outside_map 60 set peer XX.XX.XX.XX
    crypto map outside_map 60 set transform-set ESP-3DES-MD5
    crypto map outside_map 70 ipsec-isakmp
    crypto map outside_map 70 match address outside_cryptomap_70
    crypto map outside_map 70 set peer XX.XX.XX.XX
    crypto map outside_map 70 set transform-set ESP-3DES-MD5
    crypto map outside_map 75 ipsec-isakmp
    crypto map outside_map 75 match address USER4
    crypto map outside_map 75 set peer XX.XX.XX.XX
    crypto map outside_map 75 set transform-set ESP-3DES-MD5
    crypto map outside_map 80 ipsec-isakmp
    crypto map outside_map 80 match address USER2
    crypto map outside_map 80 set peer XX.XX.XX.XX
    crypto map outside_map 80 set transform-set ESP-3DES-MD5
    crypto map outside_map 90 ipsec-isakmp
    crypto map outside_map 90 match address USER3
    crypto map outside_map 90 set peer XX.XX.XX.XX
    crypto map outside_map 90 set transform-set ESP-3DES-MD5
    crypto map outside_map interface outside
    isakmp enable outside
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp key ******** address XX.XX.XX.XX netmask 255.255.255.255 no-xauth no-config-mode
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption 3des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    telnet XX.XX.XX.XX 255.255.0.0 outside
    telnet XX.XX.XX.XX 255.255.255.255 inside
    telnet XX.XX.XX.XX 255.255.255.255 inside
    telnet XX.XX.XX.XX 255.255.255.255 inside
    telnet timeout 30
    ssh XX.XX.XX.XX 255.255.255.248 outside
    ssh XX.XX.XX.XX 255.255.255.248 outside
    ssh timeout 30
    management-access inside
    console timeout 0
    terminal width 80
    Cryptochecksum:XXX
    PIX(config)#

  • Remote Desktop/Access shared files over PPTP VPN

    Hello,
    I just bought the RV180W so I can connect to my office computer from anywhere as a VPN client. The two things I need to do while I am connected as a VPN client is to be able to access my files on my office desktop and be able to remote desktop to it as well. I have Win7 on all of my computers. Ideally, I would like to do that over PPTP VPN connection but if that is not possible I can try Cisco QuickVPN software.
    I enabled PPTP on my router and created a user account. I was also able to successfully establish the connection remotely. While I was connected as a PPTP VPN client, I was able to access the Internet and my router setup page which is telling me that the connection is good. However, I was not able to either discover my office PC under my network tab in Win7 nor I was able to remote desktop. I keep my office PC on all the time and it never go to sleep. I did not create any connection policy but maybe this is the problem. Please let me know if you know of a solution.
    Thanks!

    Hi David,
    Thank you for the response.
    I was able to access the router configuration using the local IP address (in my case 192.168.1.1). I don't think I would have been able to access it using the public IP address since I have the router remote management feature disabled.
    Now after reading your email, I was finally able to remote desktop and access shared files through a PPTP VPN connection. Here is what I did:
    1- I separted the PPTP VPN IP address range from my DHCP range (in my case, PPTP VPN range is 192.168.1.200 to 210 and my DHCP range is from 192.168.1.100 to 199)
    2- I assigned my office desktop PC that I am trying to remote desktop to a fixed IP address (192.168.1.20)
    3- For remote desktop, I had to type the IP address (192.168.1.20). Typing the PC name (officepc) or searching for was not working.
    4- For shared files, I had to map a network drive as //192.168.1.20/My Pictures for example. I couldn't find my PC when searched for it under Network.
    After doing all that, I was able to do kinda what I wanted. Ideally, I would have liked to avoid using fixed IP addresses and be able to access computers by their name and see them under the Network tab. Is their a way to do this? I noticed that RV220W offers SSL VPN, would that help me?
    I would appreciate it if you could answer my last two questions.
    Thanks!
    Mustafa

Maybe you are looking for

  • How can I get my ipod to list the "album artist" instead of "artist" in the music menu, but still show the artist with the featured artist when a song plays?

    For example, I am putting Kanye West's album "808's & Heartbreak" on my ipod. The track "Amazing" features Young Jeezy. So in iTunes, I list the track name as "Amazing", the artist as "Kanye West ft. Young Jeezy",  the album artist as "Kanye West", a

  • What does Firewall do?

    Hello everyone! I have been receiving BBM boradcasts from friends asking to Enable Firewall saying that it will prevent the network provider from accessing our phone and viewing our photos. Could someone pls explain the function of the firewall and i

  • Layout of report

    Dear All: I want to create a report which will have a layout of Transaction ME5A, which is not an ALV layout, i guess. I am not understanding which functional module to use or how to generate that layout. Does anyone have any sample code which can he

  • Is there an update for the Nikon D600 for CS5.5 Bridge?

    Just wondering if the Nikon D600 has been added to the list of cameras supported by Adobe Bridge in CS5.5?? I can't seem to find anything.

  • Weblogic installation

    Hi      I need a clarification regarding installation can i install two different versions of weblogic (6.0 and 6.1) on the same server sun(sparc) and run both of them at the same time. Thanx Ranga Rao