DHCP fails to get IP address

I'm using dhcpcd to try to get a lease for an IP address, but each attempt is met with a "timed out" message. The DHCP server works for other Arch Linux installs on this network, and it works for the same laptop when using Windows. This install also fails when trying on other DHCP servers, not just on my home network. I'm not sure what it is now. I usually run iptables, but I stopped it thinking it might be the problem. I've also stopped networkmanager. I have a completely updated system, I ran pacman -Syu just now and rebooted.
I can manually set the IP address and it works fine, and I've tried dhclient instead of dhcpcd.
root@thinkpad ~# dhcpcd --release
dhcpcd[7377]: dhcpcd not running
root@thinkpad ~# dhcpcd -d eth0
dhcpcd[7378]: version 5.2.12 starting
dhcpcd[7378]: eth0: using hwaddr ....
dhcpcd[7378]: eth0: executing `/usr/lib/dhcpcd/dhcpcd-run-hooks', reason PREINIT
dhcpcd[7378]: eth0: executing `/usr/lib/dhcpcd/dhcpcd-run-hooks', reason CARRIER
dhcpcd[7378]: eth0: broadcasting for a lease
dhcpcd[7378]: eth0: sending DISCOVER (xid 0x485d8657), next in 4.24 seconds
dhcpcd[7378]: eth0: sending DISCOVER (xid 0x485d8657), next in 7.21 seconds
dhcpcd[7378]: eth0: sending DISCOVER (xid 0x485d8657), next in 15.01 seconds
dhcpcd[7378]: eth0: sending DISCOVER (xid 0x485d8657), next in 31.15 seconds
dhcpcd[7378]: timed out
# lspci -v | grep -A10 Ethernet
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
Subsystem: Lenovo Device 21ce
Flags: bus master, fast devsel, latency 0, IRQ 50
Memory at d5300000 (32-bit, non-prefetchable) [size=128K]
Memory at d532b000 (32-bit, non-prefetchable) [size=4K]
I/O ports at 6040 [size=32]
Capabilities: [c8] Power Management version 2
Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [e0] PCI Advanced Features
Kernel driver in use: e1000e
Kernel modules: e1000e
and
# dmesg | grep e1000e
shows the link is up:
e1000e: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
This is my rc.conf with the comments removed:
LOCALE="en_US.UTF-8"
DAEMON_LOCALE="no"
HARDWARECLOCK="localtime"
TIMEZONE="America/Indiana/Indianapolis"
KEYMAP="us"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"
MODULES=(fuse nvidia thinkpad_acpi)
UDEV_TIMEOUT=30
USEDMRAID="no"
USEBTRFS="no"
USELVM="no"
HOSTNAME="thinkpad"
interface=eth0
address=
netmask=
broadcast=
gateway=
NETWORK_PERSIST="no"
DAEMONS=(!hwclock syslog-ng udev @slim network iptables dbus @bluetooth networkmanager @acpid !smbnetfs crond @alsa @cpufreq)
Last edited by fester (2011-12-09 22:48:47)

Mavrick, that did not fix it.
NgoHuy... dhcpcd -C eth0 did not solve the problem either.
I think dhcpcd is broken for wlan0 too...
root@thinkpad ~# dhcpcd -C eth0
dhcpcd[8439]: version 5.2.12 starting
dhcpcd[8439]: eth0: broadcasting for a lease
dhcpcd[8439]: wlan0: broadcasting for a lease
dhcpcd[8439]: timed out
dhcpcd[8439]: forked to background, child pid 8453
I also tried
dhcpcd eth0 -C /usr/lib/dhcpcd/dhcpcd-run-hooks
and that didn't work.
I removed dhcpcd:
root@thinkpad ~# pacman -Runs dhcpcd
and reinstalled it
root@thinkpad ~# pacman -S dhcpcd
and i still get the same problem
root@thinkpad ~# dhcpcd -d eth0
dhcpcd[8590]: version 5.2.12 starting
dhcpcd[8590]: eth0: using hwaddr .....
dhcpcd[8590]: eth0: executing `/usr/lib/dhcpcd/dhcpcd-run-hooks', reason PREINIT
dhcpcd[8590]: eth0: executing `/usr/lib/dhcpcd/dhcpcd-run-hooks', reason CARRIER
dhcpcd[8590]: eth0: broadcasting for a lease
dhcpcd[8590]: eth0: sending DISCOVER (xid 0x4b4b814b), next in 3.91 seconds
dhcpcd[8590]: eth0: sending DISCOVER (xid 0x4b4b814b), next in 8.73 seconds
dhcpcd[8590]: eth0: sending DISCOVER (xid 0x4b4b814b), next in 15.68 seconds
dhcpcd[8590]: eth0: sending DISCOVER (xid 0x4b4b814b), next in 32.46 seconds
dhcpcd[8590]: timed out
Last edited by fester (2011-12-08 13:03:41)

Similar Messages

  • Failed to get IP address for Local Host (2) , OPMNCTL: opmn start failed

    HI,
    Hi, I have installed on Oracle 10g on Redhat Enterprise Linux V.2.1 . I was able to start OEM without any issues. Recently I had changed the static IP address and I couldn't able to start OPMNCTL and getting the following error while starting opmnctl start. error message is as follows.
    Failed to get IP address for local host(2).....
    Failed to get IP address for local host(2).....
    Failed to get IP address for local host(2).....
    my current configuration in /etc/hosts file is as follows.
    127.0.0.1 localhost.localdomain servername
    After going through some of threads available in Oracle, I have added the static IP address in the /etc/hosts but still I am getting the same error.
    my new hosts file is as follows.
    127.0.0.1 localhost.localdomain servername
    10.21.253.102 localhost.localdomain servername
    I don't know why this is looking for localhost (2). I did not set up any local host (2) and I could not see anything in my network confiuration also.
    could you please help me in this issue? I appreciate your help in this regard.
    Thanks
    venkat

    Hi, i think that the application server part is looking for a /etc/hosts entry
    in this format:
    127.0.0.1 localhost
    As i noticed, this is used for internal communication.
    Try this entry as is, without a domain...

  • Failed to get proc address for GetLogicalProcessor...

    hi everyone whenever i try to open the skype after instalation it show me this error"Failed to get proc address for GetLogicalProcessorInformation (KERNEL32.dll."please help me to solve this problem.i will be very thankfull to you for this favour.thank you.

    Hi, i think that the application server part is looking for a /etc/hosts entry
    in this format:
    127.0.0.1 localhost
    As i noticed, this is used for internal communication.
    Try this entry as is, without a domain...

  • "failed to get MAC address for machine"

    here is the jist of things.
    installed leopard and have it pimped out to my personal specs. I like where everything is and how things are working. No issues. just so you know, i only use WIFI for internet, i share with the guys upstairs. In order to get wifi on my machine, i use a USB dongle. works great no issues with it ever, well until i physically broke it. No big deal. So i replaced it with another one, different drivers/chipset worked.. And since i installed leopard i only backed it up once with TM, i dont care for daily/hrly backups, weekly is fine for me. Now after 2 weeks and a new usb network card. TM gives me an error. i click on the little red i and it says "the backup volume could not be found" so googled and searched the forums not much help, so i tried and formated my ext drive repaired and click on TM again, same error. In the error log in console, right after i turn on TM i get this error, "failed to get MAC address for machine" then 180 secs later, TM fails. again, and again.
    Can anyone tell me where i can find what MAC address its looking for??? ethernet has never been plugged in to my machine ever. its only been online via USB wifi. Im really lost here, i dont know what i can do.. im sure if i try another drive ill get the same error. please help if you can.. much appriciated.
    Jamie

    yeah i get a 'failed to get mac address' message too. what's weird is that it seems that leopard 'broke' my ethernet (there was no mac address, couldn't connect to the internet through ethernet after a clean install), and then 10.5.2 'fixed' it. for some reason, i have an 'ethernet 2' heading in system preferences that works correctly and has a mac address and everything, while the regular 'ethernet' tab doesn't work at all. however, i still get this time machine error. i don't understand why time machine is so incredibly fickle. sorry, i'm really of no help to anyone, other than adding another voice to the frustration.

  • IOS device failed to get ip address on multiple wlan on the same anchor controller

    Dear Experts:
    in my implementation, we need 2 WLANs be served on the same anchor controller.
    WLAN1: wep/40bit, integration with NAC/OOB on anchor controller for guest wlan service.
    and guest account controlled by NACguest server.
    WLAN2: wep/40bit, no layer3 secuirty for temporary using.
    foreign controller: WiSM on v6.0.196.4 (also testing on 6.0.182.0)
    anchor controller: WLC4402 on v6.0.196.4
    on WLAN1:
    Windows7 client get ip address correctly.
    iOS (iPhone4 on 4.3.1/4.3.2, iPad2 on 4.3.1/4.3.2) can get ip address correctly on WLAN1.
    WLAN2, iOS device cannot get ip address.
    compare with debug message "debug clien mac" + "debug dhcp message enable"
    on both foreign and anchor controller.
    on foreign controller:
    PM state has changed from: DHCP_REQD (7) Change state to RUN (20) last state RUN (20)
    on anchor controller:
    PM state always stay on: DHCP_REQD (7) Change state to DHCP_REQD (7) last state DHCP_REQD (7)
    Enable/Disable DHCP Address Assignment Required is not work.
    Enable/Disable DHCP proxy is not work.
    Any hit this issue when get ip address failed in multiple WLANs on the same anchor controller?
    In attachment log file,
    DMZ.log: anchor controller on DMZ.
    S3p1.log: WiSM on v6.0.182.0
    S3p2.log: WiSM on v6.0.196.4
    client mac: 00:1f:3b:05:33:c1, Windows7 Client
    client mac: 58:55:ca:cf:d2:07, iPhone4 with 4.3.1,
    WLAN1 subnet: 10.61.246.0/23
    WLAN2 subnet: 10.61.248.0/23

    Hi, Nicolas:
    just checking the attachment for the run-config on foreign/anchor controller.
    DMZ_run.config  - anchor controller
    s3p1_run.config - WiSM on v6.0.182.0
    s3p2_run.config - WiSM on v6.0.196.4
    at this moment, we have disable the wlan 10 on foreign controller, and wlan 2 on foreign controller.
    Wilson...

  • RRAS 2012 With DHCP Works, Cannot Get Static Address Pool To Connect Completely

    Hello Forums Users:
    I have set up RRAS/DA 2012 successfully incorporating my AD DHCP server.   Every connection works and I see all networks that I have VPN tunnels set up with, which is totally cool.    However, I want to assign remote VPN users IP's from a
    static address pool - and while the setup completes without issue and the client connects, I can see absolutely nothing.    No good pings, no connect to Lync client, Outlook, etc. etc.
    I am OBVIOUSLY missing something but have no idea what that is.   Do I need to add something (and I really have no idea what that "something" is) to RRAS config so the static address pool (192.168.40.0 in this case) has the same access as
    the AD DHCP pool does?
    Thanks again for taking the time to check this out and comment.

    Bill:
    Thanks for the reply....  yes, the idea is to free up a pool of IP's large enough to accomodate all 170 staff.   Our current 192.168.2.x DHCP hands out 150, but I need to plan for DR/BCP when other locations (about 110 users) remote in when their
    location goes dark.
    I already have VPN tunnels between the main locations and a VPN user can see ALL of them when it gets an IP from DHCP.   Are you saying that I have to add routes to all the routers/firewalls to accomplish this?
    Or would I use IPv4 Static Routes?   A network I'd like access to is 192.168.14.0 /24.   Would the route look like any of these?   Sorry it's not clear what I would use as the gateway (192.168.2.1 is the RRAS server network gateway, 192.168.2.6
    is RRAS IP)
    Destination         Net Mask               Gateway                Interface
    192.168.14.0      255.255.255.0        192.168.2.1            LAN
    192.168.14.0    255.255.255.0
      192.168.14.254      LAN             (
    (.254 is the remote gateway)

  • Lumia 2520 WiFi connection problems - dhcp fails

    I have problems connecting to my work wifi network, the tablet connects to the network but fails to get IP address with DHCP. It actually fails to find DHCP server. If I enter the IP settings manually - everything starts working.
    Moreover, I have the same problems with my lumia 920 here, it fails to connect at all.
    All other devices in our office including android, iphone, ipad and windows notebooks are connecting just fine.

    fezzer79 wrote:
    I am currently experiencing a serious wifi issue with my new Lumia 920. As i whole i think the phone is amazing, but this is taking the sheen off the experience.
    From a fresh boot, my phone detects all wifi networks correctly, and i can use wifi without an issue. If i leave the phone unattended for a while, or move to a different wifi location, the phone then refuses to connect to the wifi , and even if i manually ask it to connect it tells me it can't. The only way i can fix this it to reboot the phone and it connects again no problem. I was hoping the new firmware update will fix this, but it looks like that wont appear until February
    Any advice?
    I have the same problem, and while I have no solution I have found that if you put it into Airplane Mode, turn the Wifi on then take it off Airplane mode you dont have to reboot.  It seems to happen only with my router at home when I am a fair way away from it (it goes through walls too).  My wife has a 920 and it doesnt happen to her at all!  Seems a obscure issue from my reading - do you have a first release 920 like I do?

  • AEX fails to get DHCP address, but works on DLink

    Sorry for the long post -- I'm hoping the details will help you diagnose the problem faster in the long run.
    My DLink router gets a DHCP IP address from the (Comcast) cable modem, but when I switch to the AirPort Extreme (5th gen, refurbished), it doesn't. It shows an autoconfiguration IP address of the 169.254 variety, suggesting that DHCP isn't working for the AEX. (Just fyi, my girlfriend's macbook can connect to the AEX and get 10.0.1.x IP addresses; I can ping the AEX over wifi.)
    Airport Utiltiy shows a red number 2 with a single error indicating Internet failure to get IP address or something. The suggested solution is power-cycling the modem; failing that, contact the ISP. Contacting Comcast was amusing but useless...they gave me instructions for setting up AEX with a DSL modem -- twice -- without understanding my objection!
    The AEX is configured for DHCP (not Static or PPPoE), and uses all stock settings (I did both a soft reset and used the Airport Utility to restore default settings...not sure if those two are the same).
    I've tried power-cycling the router and cable modem numerous times, including leaving them off for 15+ minutes and leaving the AEX connected for 6+ hours. I tried using the DLink to release the DHCP reservation and then quickly switching the cable over to the AEX.
    I read somewhere that resetting the "CMTS (cable modem termination system)" might help. I mentioned it to the Comcast tech support, but they didn't respond.
    At this point, I'm not sure what else to try. It could be the refurbished unit is broken, but 95% of the time these sorts of things are configuration issues. (I know a fair amount about networking, but I'm new to Apple products so I could be doing something stupid.) I may try connecting the AEX to the LAN side of the DLink to see if it can get a DHCP address from that...but I'm clearly grasping at straws.
    <whimpers>...Help?

    Update: The AEX does get a DHCP address when connected to the LAN side of the DLink gateway. (But the AEX doesn't get one when connected directly to the cable modem. Yet the DLink gets a DHCP address when connected to the cable modem.) So...??!?!!!

  • DHCP client fails to get an valid IP address from DHCP server. windows 8.1

    I have a win 8.1 Pro  64 bit pc in my office .I'm trying to connect it to my wireless cisco router with either wireless or hardwired connection but I get an error in the event viewer with discription DHCP error 1007. and Ip address showing
    169.254.93.17 but our dhcp range is 192.168.1.x
    Log Name:      Microsoft-Windows-Dhcp-
    Source:        Microsoft-Windows-Dhcp-Client
    Date:          23/Jun/2014 12:03:21 PM
    Event ID:      1001
    Task Category: Address Configuration State Event
    Level:         Error
    Keywords:      (1)
    User:          LOCAL SERVICE
    Computer:      sanddeplap.vts.com
    Description:
    Your computer was not assigned an address from the network (by the DHCP Server) for the Network Card with network address 0xF4B7E22D8721.  The following error occurred: 0x79. Your computer will continue to try and obtain an address on its
    own from the network address (DHCP) server.
    Event Xml:
    <Event xmlns="http://schemas.">
      <System>
        <Provider Name="Microsoft-Windows-Dhcp-
        <EventID>1001</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>3</Task>
        <Opcode>75</Opcode>
        <Keywords>0x4000000000000001</
        <TimeCreated SystemTime="2014-06-23T08:03:
        <EventRecordID>363</
        <Correlation />
        <Execution ProcessID="988" ThreadID="7932" />
        <Channel>Microsoft-Windows-
        <Computer>sanddeplap.vts.com</
        <Security UserID="S-1-5-19" />
      </System>
      <EventData>
        <Data Name="HWLength">6</Data>
        <Data Name="HWAddress">F4B7E22D8721<
        <Data Name="StatusCode">121</Data>
      </EventData>
    </Event>
    I tried to track issue with microsoft network monitor I'm attaching the capture file also please help me to sort out this issue
    capture report https://onedrive.live.com/redir?resid=AFE3D0245A92F6F8%21183

    The issue is that your machine is not being assigned an IP address / was unable to reach the DHCP server to receive one. The 169.254.x.x IP your machine is showing isn't assigned from DHCP, it's assigned by the local machine and is referred to as an APIPA
    address.
    So something is preventing your machine from reaching your DHCP server, which could one of a number of things. In the first instance I'd suggest having a look at
    http://epan36.blogspot.co.uk/2012/09/eventid-1001-dhcp-your-computer-was-not.html which lists several of things that could cause this error and things you can try in order to resolve it.
    If none of those work, can you confirm whether you have any other machines connecting via the same method on the network, which might indicate whether this is an issue at the machine end or somewhere between the machine and DHCP server?

  • Failed to get DHCP response on interface "Marking interface dirty"

    Dears
    i have WLC 5508 showing the below Logs , which prevent the users from connecting to the SSIDs , also its disconnecting the associted users
    DHCP Socket Task: Jul 11 09:54:08.992: %SIM-3-DHCP_SERVER_NO_REPLY: sim_interface.c:1039 Failed to get DHCP response on interface 'interface-02'. Marking interface dirty.
    *mmListen: Jul 11 09:54:08.638: %MM-3-INVALID_PKT_RECVD: mm_listen.c:7671 Received an invalid packet from 10.21.1.25. Source member:0.0.0.0. source member unknown.
    it shows 3 to 4 times durring 1 hour ,        
    any idea about the problem , and what exactly Dirty interface means ??

    looks like you could be using interface group.
    (WLC) >show interface group detailed
    Interface marked with * indicates DHCP dirty interface.
    whenever the existing interface goes dirty does the client tries the next available interface for dhcp.
    The idea of Interface Groups is that you can have a WLAN utilize multiple interfaces/VLANs/Subnets/DHCP Pools, either for load balancing. At its heart it is purely round robin or based on hash generated using mac address(it depends on the wlc code), but should a client connect in on a certain interface and not be able to complete the DHCP process we mark it as dirty for 30 minutes.  During those 30 minutes we basically remove that Interface from the Interface Group as it won't be selected for use.

  • Please help: Get IP address of a remote device (wifi kit) from DHCP router

    Hi ppl,
    I am about to get the IP address for the wifi kit which is connected to the same router with my PC.
    I need to control my wifi kit through TCP client communication, but DHCP tends to assign new IP address to my wifi kit when connected to router.
    Hence, i wish to write a java function to trace the IP address before starts the communication.
    I am thinking to get the wifi kit's IP address based on the Hostname (name of the wifi shield):
    As below:
    InetAddress thatIp = InetAddress.getByName("Wiznet");
    System.out.println("IP E:"+thatIp.getHostAddress());
    But i don't think this is secure..
    I attempt to research for getting IP address with MAC..
    But have ambiguity on the result i found.
    It stating i have to get the ARP table from router but it is not a good approach.
    I have no luck for next finding on how retrieving the table with Java.
    Hereby hope to have your advise how can i get the ip address of my wifi kit in a more dynamic and secure method..
    is it using Hostname or MAC address or else...
    many thanks.

    hi... wish to have your advise again.
    I tried to retrieve the arp table in java and attempt to extract the IP address based on MAC address for particular devise.
    But i stuck with the substring... my code is as below:
    Process result = Runtime.getRuntime().exec("arp -a");
         BufferedReader output = new BufferedReader
                   (new InputStreamReader(result.getInputStream()));
         String line = output.readLine();
         while(line != null){
              if ( line.startsWith("default") == true ){
                   System.out.println("is default");
                   break;
         line = output.readLine();
         String ipAdd = line.substring(0, 18);
         String MACAdd = line.substring(24, 42);
         System.out.println(line.length() + " " + line + " " + ipAdd + " " + MACAdd );
    i m trying to sub the IP and MAC accordingly.. but i got error saying
    Exception in thread "main" java.lang.StringIndexOutOfBoundsException: String index out of range: 42
         at java.lang.String.substring(Unknown Source)
         at ExecTest.main(ExecTest.java:22)
    i dun understand this! as since the length of LINE is 56 , why STRING INDEX OUT OF RANGE happen?!
    please advise!!!

  • DHCP: Some clients not getting IP address

    Recently setup a new DHCP server on Mac OS X Server 10.5.8 running on an Xserve.  We migrated from a Linux server.
    The Xserve was originally just a file server.  So the only services currently running are: AFP, DHCP, NFS, and SMB.  No additional software is running.
    The DHCP server ran just fine for the first couple weeks.  But then we found some computers just stopped getting IP addresses from the DHCP server.  Some were new computers introduced to the network.  Some were laptops that had left and come back.  However, the DHCP server is definitely still giving out IP addresses and renewing them for most new and existing computers.  There have been five computers that have not gotten IP addresses so far, and that had been the case both on the wireless and on a wired connection.  Two were PC's, one running Windows 7 and one running Windows XP with Lenovo's ThinkVantage software.  The other three were different models of MacBook Pros.
    For those five computers, we managed to get them working in two ways.  One, we can select to use DHCP with a manual address.  When we do that, it manages to pick up all the other information from the DHCP server like DNS and gateway.  The second thing we can do is configure the DHCP server to supply a static IP address by providing it with the MAC address of these machines.  When we do that, the computers receive the IP address from the DHCP server.
    So I guess you could say the problem I'm experiencing is for a few computers the DHCP server seems to only be able to provide static addresses, but not dynamic ones with a lease time.
    I have logging set to the highest for the DHCP server.  Below is the first thing I noticed that keeps showing up.  Sometimes it shows a different MAC address than the one below.  None of the afflicted computers have that MAC address, though.  I have not seen any other errors in the logs for the DHCP server.
    Jan 24 12:09:47 fileserver bootpd[73839]: DHCP DISCOVER [en1]: 1,0:23:32:c1:31:c3
    Jan 24 12:09:47 fileserver bootpd[73839]: service time 0.000304 seconds
    Jan 24 12:09:50 fileserver bootpd[73839]: DHCP DISCOVER [en1]: 1,0:23:32:c1:31:c3
    Jan 24 12:09:50 fileserver bootpd[73839]: service time 0.000280 seconds
    Jan 24 12:09:54 fileserver bootpd[73839]: DHCP DISCOVER [en1]: 1,0:23:32:c1:31:c3
    Jan 24 12:09:54 fileserver bootpd[73839]: service time 0.000264 seconds
    Jan 24 12:10:03 fileserver bootpd[73839]: DHCP DISCOVER [en1]: 1,0:23:32:c1:31:c3
    Jan 24 12:10:03 fileserver bootpd[73839]: service time 0.000265 seconds
    Jan 24 12:10:11 fileserver bootpd[73839]: DHCP DISCOVER [en1]: 1,0:23:32:c1:31:c3
    Jan 24 12:10:11 fileserver bootpd[73839]: service time 0.000283 seconds
    Jan 24 12:10:19 fileserver bootpd[73839]: DHCP DISCOVER [en1]: 1,0:23:32:c1:31:c3
    Jan 24 12:10:19 fileserver bootpd[73839]: service time 0.000291 seconds
    Jan 24 12:10:28 fileserver bootpd[73839]: DHCP DISCOVER [en1]: 1,0:23:32:c1:31:c3
    Jan 24 12:10:28 fileserver bootpd[73839]: service time 0.000324 seconds

    Recently setup a new DHCP server on Mac OS X Server 10.5.8 running on an Xserve.  We migrated from a Linux server.
    The Xserve was originally just a file server.  So the only services currently running are: AFP, DHCP, NFS, and SMB.  No additional software is running.
    The DHCP server ran just fine for the first couple weeks.  But then we found some computers just stopped getting IP addresses from the DHCP server.  Some were new computers introduced to the network.  Some were laptops that had left and come back.  However, the DHCP server is definitely still giving out IP addresses and renewing them for most new and existing computers.  There have been five computers that have not gotten IP addresses so far, and that had been the case both on the wireless and on a wired connection.  Two were PC's, one running Windows 7 and one running Windows XP with Lenovo's ThinkVantage software.  The other three were different models of MacBook Pros.
    For those five computers, we managed to get them working in two ways.  One, we can select to use DHCP with a manual address.  When we do that, it manages to pick up all the other information from the DHCP server like DNS and gateway.  The second thing we can do is configure the DHCP server to supply a static IP address by providing it with the MAC address of these machines.  When we do that, the computers receive the IP address from the DHCP server.
    So I guess you could say the problem I'm experiencing is for a few computers the DHCP server seems to only be able to provide static addresses, but not dynamic ones with a lease time.
    I have logging set to the highest for the DHCP server.  Below is the first thing I noticed that keeps showing up.  Sometimes it shows a different MAC address than the one below.  None of the afflicted computers have that MAC address, though.  I have not seen any other errors in the logs for the DHCP server.
    Jan 24 12:09:47 fileserver bootpd[73839]: DHCP DISCOVER [en1]: 1,0:23:32:c1:31:c3
    Jan 24 12:09:47 fileserver bootpd[73839]: service time 0.000304 seconds
    Jan 24 12:09:50 fileserver bootpd[73839]: DHCP DISCOVER [en1]: 1,0:23:32:c1:31:c3
    Jan 24 12:09:50 fileserver bootpd[73839]: service time 0.000280 seconds
    Jan 24 12:09:54 fileserver bootpd[73839]: DHCP DISCOVER [en1]: 1,0:23:32:c1:31:c3
    Jan 24 12:09:54 fileserver bootpd[73839]: service time 0.000264 seconds
    Jan 24 12:10:03 fileserver bootpd[73839]: DHCP DISCOVER [en1]: 1,0:23:32:c1:31:c3
    Jan 24 12:10:03 fileserver bootpd[73839]: service time 0.000265 seconds
    Jan 24 12:10:11 fileserver bootpd[73839]: DHCP DISCOVER [en1]: 1,0:23:32:c1:31:c3
    Jan 24 12:10:11 fileserver bootpd[73839]: service time 0.000283 seconds
    Jan 24 12:10:19 fileserver bootpd[73839]: DHCP DISCOVER [en1]: 1,0:23:32:c1:31:c3
    Jan 24 12:10:19 fileserver bootpd[73839]: service time 0.000291 seconds
    Jan 24 12:10:28 fileserver bootpd[73839]: DHCP DISCOVER [en1]: 1,0:23:32:c1:31:c3
    Jan 24 12:10:28 fileserver bootpd[73839]: service time 0.000324 seconds

  • Wireless Router 877W users cannot get ip address from DHCP

    Users can connect to wireless but they cant get ip address what can be the problem ?
    Thanks
    no aaa new-model
    resource policy
    ip subnet-zero
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.10.10.1
    ip dhcp excluded-address 192.168.239.1 192.168.239.50
    ip dhcp pool users
       network 192.168.239.0 255.255.255.0
       default-router 192.168.239.1
       dns-server 4.2.2.2
    bridge irb
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode auto
    interface ATM0.1 point-to-point
    no snmp trap link-status
    pvc 8/35
      pppoe-client dial-pool-number 1
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    interface FastEthernet3
    interface Dot11Radio0
    no ip address
    encryption vlan 1 key 1 size 40bit 0 1234567890 transmit-key
    encryption vlan 1 mode wep mandatory
    ssid wirele
        vlan 1
        authentication open
        guest-mode
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    channel 2437
    station-role root
    interface Dot11Radio0.1
    encapsulation dot1Q 1 native
    no snmp trap link-status
    no cdp enable
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
    ip address 192.168.239.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    bridge-group 1
    bridge-group 1 spanning-disabled
    interface Dialer1
    ip address negotiated
    ip nat outside
    ip virtual-reassembly
    encapsulation ppp
    ip tcp adjust-mss 1452
    dialer pool 1
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username xxxx password xxx
    crypto map MerkezVPN
    interface Dialer0
    no ip address
    interface BVI1
    no ip address
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1

    go into config t and add "bridge 1 route ip" and see what you get....

  • Unable to get IP address from DHCP

    hi all,
    I have a AP1131 which cannot get IP from DHCP server. I have tried to configure static IP address and controller IP by lwapp command and the AP can successfully joined the controller. However, after I changed it to DHCP in WLC, it cannot get IP address and all lwapp config is gone. It cannot join the controller anymore only after I reset it and configure a static IP for it. The following error message appears after I changed it to DHCP in the WLC:
    *Mar 7 08:44:36.511: RESETTING THE STATIC IP ADDRESS: LWAPP goes back to discovery
    %WIDS-6-DISABLED: IDS Signature is removed and disabled.
    %LWAPP-5-CHANGED: LWAPP changed state to DISCOVERY
    %LWAPP-5-CHANGED: LWAPP changed state to DISCOVERY
    %LINK-3-UPDOWN: Interface Dot11Radio0, changed state to up
    %LINK-3-UPDOWN: Interface Dot11Radio1, changed state to up
    %LWAPP-3-CLIENTERRORLOG: Config Command: error verifying sequence number
    %LINK-5-CHANGED: Interface Dot11Radio1, changed state to reset
    %LINK-5-CHANGED: Interface Dot11Radio0, changed state to reset
    %LWAPP-3-CLIENTERRORLOG: Config Command: error verifying sequence number
    %LWAPP-3-CLIENTERRORLOG: Config Command: error verifying sequence number
    %LWAPP-3-CLIENTERRORLOG: Config Command: error verifying sequence number
    %LWAPP-3-CLIENTERRORLOG: Config Command: error verifying sequence number
    %LWAPP-3-CLIENTERRORLOG: Config Command: error verifying sequence number
    Any expert has some idea on it?
    Thanks.

    Is that AP on the same subnet as the other AP's? The thing is, when you configure the AP with static information, you say the AP is able to join the WLC. This means that there is no issue with the AP. Now when you set the AP to use DHCP and not static, the AP does not obtain a DHCP address? Is that correct? If you have more than one AP on the same switch and on the same vlan, and only one has an issue, then maybe reset that AP to default and see if that fixes it. I'm also assuming that the vlan is being forwarded and you have enough dhcp address in the scope.

  • WLC 5760 with internal DHCP server, clients no get IP address

    Hi all,
    I have  2  Cisco 5760 WLC (active-standby)  IOS-Xe 03.03.03SE  with  one WLAN.
     sh wlan summary 
    Number of WLANs: 1
    WLAN Profile Name                     SSID                           VLAN Status 
    1    Invitados_ADSL                   Guest                          905  UP
    sh vlan         
    VLAN Name                             Status    Ports
    1    default                          active    Te1/0/3, Te1/0/4, Te1/0/5, Te1/0/6, Te2/0/3
                                                    Te2/0/4, Te2/0/5, Te2/0/6
    100  VLAN0100                         active    Te1/0/1, Te2/0/1
    101  Planta_1                         active    
    905  Internet                         active    Te1/0/2, Te2/0/2
    The DHCP server is internal.
    Sometimes the clients no get IP address and the DHCP pool has IP addresses available.
    The workaround done by me to solve the issue is “clear  ip dhcp  binding *”.
    Some days later the problem appears again.
    I see this bug with a similar problem:
    NGWC blocks DHCP traffic if wireless broadcast disabled
    CSCun88928
    Description
    Symptom:
    Some clients set the BROADCAST flag on the DHCP Discover packet. This requires the DHCP server to reply with a broadcast.
    In that case and if you are not using DHCP snooping on the 5760/3850, then the controller will block the return traffic unless you enable "wireless broadcast" which enables broadcast globally (and is thus not always desirable)
    Conditions:
    Seen on 3.3.2 IOS-XE
    Workaround:
    Use DHCP snooping with the "ip dhcp snooping wireless bootp-broadcast command"
    OR
    Enable "wireless broadcast" globally
    My DHCP configuration is:
    ip dhcp relay information trust-all
    ip dhcp snooping vlan 905
    ip dhcp snooping
    ip dhcp excluded-address 172.16.0.1 172.16.0.19
    ip dhcp excluded-address 172.16.1.250 172.16.1.254
    ip dhcp pool Invitados
     network 172.16.0.0 255.255.254.0
     default-router 172.16.0.1 
     dns-server 212.66.160.2 212.49.128.65 
     lease 0 8
    I see in Cisco documentation (http://www.cisco.com/en/US/docs/wireless/technology/5760_deploy/CT5760_Centralized_Configuration_eg.html) this configuration:
    DHCP Snooping and Trust Configuration on CT5760
    ip dhcp snooping vlan 100, 200
    ip dhcp snooping wireless bootp-broadcast enable
    ip dhcp snooping
    interface TenGigabitEthernet1/0/1
    description Connection to Core Switch
    switchport trunk allowed vlan 100, 200
    switchport mode trunk
    ip dhcp relay information trusted ip dhcp snooping trust
    interface Vlan100
    description Client Vlan
    ip dhcp relay information trusted
    My question is,Do I have to add the command "ip dhcp snooping wireless bootp-broadcast enable" to solve the issue?
    Thanks in advance.
    Regards.
    D

    Yes, test it with the command you mentioned
    ip dhcp snooping wireless bootp-broadcast enable
    HTH
    Rasika
    **** Pls rate all useful responses *****

Maybe you are looking for

  • Xsd to string conversion

    Hi Sapall. i have got a tricky situation on an IDOC to webservice Interface where the requirement is after getting the data from IDOC to Webservice xsd  structure ,PI need to convert the same xsd into a single element containing a XML string .so that

  • What happened to the 3-D visualization of tasks in Project 2013?

    I just got Project Pro 2013 loaded on my machine.  I was surprised to see all of my tasks on my Gantt with constant colors as opposed to 3-D.  I can't seem to find the switch setting "Show bars and shapes in Gantt Views in 3-D" that used to be under

  • Cache Management System

    Bridge definitely needs a cache management system whereby a user can, via whatever means, clean out old cache data. I process hundreds of thousands of images per year, constantly deleting files, archiving them to CD, etc. Remnants of those activities

  • No option to export sound with quicktime

    When i'm trying to export a video clip of various formats, all i'll get is the video, no audio. Upon investigation there is no option to export sound (the half of the settings is unclickable). I do have a sound card with correct drivers installed, an

  • Report RSWUWFML to send mails to Outlook about the work item Arrival

    Hello, Report RSWUWFML to send mails to Outlook about the work item Arrival - Can we make settigns so that only work items pertaining to Leave Requests are sent to the Outlook. Please help. Regards, Poornima